4D95 CM2150C/CM2150D, ISB - CM850, ISBe2/3 - CM850, ISBe4 (4 and 6 cylinder), ISC / Transit Bus ISL8.3 - CM850, ISL8.9 - CM850, ISLe4 (6 cylinder), QSB4.5/5.9/6.7 - CM850/CM2850, QSC8.3 - CM850/CM2850, QSL9 - CM850/CM2850, QSL9 - CM850/CM2850 - Power Gen

Last Modified: 12 February 2020

Copyright © 2020
Cummins Inc.
All rights reserved


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Exhaust Gas Pressure Sensor Number 1 Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 0001

Exhaust Gas Pressure Sensor Number 1 Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 0001 PID: SPN: None FMI: LAMP: SRT: | Exhaust Gas Pressure Sensor Number 1 Circuit - Voltage Above Normal, or Shorted to High Source. High signal voltage detected at the Exhaust Gas Pressure Sensor circuit. | None on performance.
Exhaust Gas Pressure Sensor Number 1 Circuit

Circuit Description

The exhaust gas pressure sensor provides the exhaust gas pressure to the exhaust gas treatment monitor unit through the exhaust gas treatment monitor harness.

Component Location

The exhaust gas pressure sensor will be located near the inlet to the exhaust catalyst. The location will vary depending on application.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.

This fault code will only be present in the exhaust gas treatment monitor unit and will not be present in the engine electronic control module (ECM). The exhaust gas treatment fault code and maintenance lamps will both flash one time in sequence to alert the operator that this condition exists. The engine diagnostic lamps will not illuminate.

Refer to Troubleshooting Fault Code t05-0001

Last Modified: 08-Jul-2010
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Exhaust Gas Pressure Sensor Number 1 Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 0002

Exhaust Gas Pressure Sensor Number 1 Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 0002 PID: SPN: None FMI: LAMP: SRT: | Exhaust Gas Pressure Sensor Number 1 Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage or open circuit detected at the Exhaust Gas Pressure Sensor circuit. | None on performance.
Exhaust Gas Pressure Sensor Number 1 Circuit

Circuit Description

The exhaust gas pressure sensor provides the exhaust gas pressure to the exhaust gas treatment monitor unit through the exhaust gas treatment monitor harness.

Component Location

The exhaust gas pressure sensor will be located near the inlet to the exhaust catalyst. The location will vary depending on application.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the exhaust gas treatment monitor harness or exhaust gas pressure sensor.
  • Supply line open or shorted to ground.

This fault code will only be present in the exhaust gas treatment monitor unit and will not be present in the engine electronic control module (ECM). The exhaust gas treatment fault code and maintenance lamps will both flash two times in sequence to alert the operator that this condition exists. The engine diagnostic lamps will not illuminate.

Refer to Troubleshooting Fault Code t05-0002

Last Modified: 08-Jul-2010


Exhaust Gas Pressure Sensor Number 1 Circuit - Data Erratic, Intermittent, or Incorrect.

FAULT CODE 0003

Exhaust Gas Pressure Sensor Number 1 Circuit - Data Erratic, Intermittent, or Incorrect.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 0003 PID: SPN: None FMI: LAMP: SRT: | Exhaust Gas Pressure Sensor Number 1 Circuit - Data Erratic, Intermittent, or Incorrect. The exhaust gas treatment monitor unit has detected that the exhaust gas pressure sensor number 1 is not changing. | None on performance.
Exhaust Gas Pressure Sensor Number 1 Circuit

Circuit Description

The exhaust gas pressure sensor provides the exhaust gas pressure to the exhaust gas treatment monitor unit through the exhaust gas treatment monitor harness.

Component Location

The exhaust gas pressure sensor will be located near the inlet to the exhaust catalyst. The location will vary depending on application.

Shop Talk

This fault code is activated when the exhaust gas treatment monitor unit detects that the exhaust gas pressure signal value is not changing (ie, stuck in range). In order for this fault code to activate, the exhaust gas treatment monitor unit must detect that the exhaust gas pressure signal does not change during 30 minutes of engine operation where the exhaust gas temperature is above 250°C [482°F].

Possible causes of this fault code include:

  • Faulty exhaust gas pressure sensor.

This fault code will only be present in the exhaust gas treatment monitor unit, and will not be present in the engine electronic control module (ECM). The exhaust gas treatment fault code and maintenance lamps will both flash three times in sequence to alert the operator that this condition exists. The engine diagnostic lamps will not illuminate.

Refer to Troubleshooting Fault Code t05-0003

Last Modified: 08-Jul-2010


Exhaust Gas Temperature Sensor Number 1 Circuit - Data Erratic, Intermittent, or Incorrect.

FAULT CODE 0004

Exhaust Gas Temperature Sensor Number 1 Circuit - Data Erratic, Intermittent, or Incorrect.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 0004 PID: SPN: None FMI: LAMP: SRT: | Exhaust Gas Temperature Sensor Number 1 Circuit - Data Erratic, Intermittent, or Incorrect. The exhaust gas treatment monitor unit has detected that the exhaust gas temperature sensor number 1 is not changing. | None on performance.
Exhaust Gas Temperature Sensor Number 1 Circuit

Circuit Description

The exhaust gas temperature sensor provides the exhaust gas temperature to the exhaust gas treatment monitor unit through the exhaust gas treatment monitor harness.

Component Location

The exhaust gas temperature sensor will be located near the inlet to the exhaust catalyst. The location will vary depending on application.

Shop Talk

This fault code is activated when the exhaust gas treatment monitor unit detects that the exhaust gas temperature signal value is not changing (ie, stuck in range). In order for this fault code to activate, the exhaust gas treatment monitor unit must detect that the exhaust gas temperature is below 100°C [212°F] during one hour of continuous engine operation.

Possible causes of this fault code include:

  • Faulty exhaust gas temperature sensor.

This fault code will only be present in the exhaust gas treatment monitor unit, and will not be present in the engine electronic control module (ECM). The exhaust gas treatment fault code and maintenance lamps will both flash four times in sequence to alert the operator that this condition exists. The engine diagnostic lamps will not illuminate.

Refer to Troubleshooting Fault Code t05-0004

Last Modified: 08-Jul-2010


Exhaust Gas Temperature Sensor Number 1 Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 0005

Exhaust Gas Temperature Sensor Number 1 Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 0005 PID: SPN: None FMI: LAMP: SRT: | Exhaust Gas Temperature Sensor Number 1 Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage or open circuit detected at the Exhaust Gas Temperature Sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Number 1 Circuit

Circuit Description

The exhaust gas temperature sensor provides the exhaust gas temperature to the exhaust gas treatment monitor unit through the exhaust gas treatment monitor harness.

Component Location

The exhaust gas temperature sensor will be located near the inlet to the exhaust catalyst. The location will vary depending on application.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground
  • Signal shorted to return or ground in the sensor
  • Open circuit on the signal wire
  • Open return circuit in the harness, connector, or sensor.

This fault code will only be present in the exhaust gas treatment monitor unit and will not be present in the engine electronic control module (ECM). The exhaust gas treatment fault code and maintenance lamps will both flash five times in sequence to alert the operator that this condition exists. The engine diagnostic lamps will not illuminate.

Refer to Troubleshooting Fault Code t05-0005

Last Modified: 08-Jul-2010


Exhaust Gas Temperature Sensor Number 1 Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 0006

Exhaust Gas Temperature Sensor Number 1 Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 0006 PID: SPN: None FMI: LAMP: SRT: | Exhaust Gas Temperature Sensor Number 1 Circuit - Voltage Above Normal, or Shorted to High Source. High signal voltage or open circuit detected at the Exhaust Gas Temperature Sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Number 1 Circuit

Circuit Description

The exhaust gas temperature sensor provides the exhaust gas temperature to the exhaust gas treatment monitor unit through the exhaust gas treatment monitor harness.

Component Location

The exhaust gas temperature sensor will be located near the inlet to the exhaust catalyst. The location will vary depending on application.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit shorted to a voltage source or a shorted sensor.

This fault code will only be present in the exhaust gas treatment monitor unit and will not be present in the engine electronic control module (ECM). The exhaust gas treatment fault code and maintenance lamps will both flash six times in sequence to alert the operator that this condition exists. The engine diagnostic lamps will not illuminate.

Refer to Troubleshooting Fault Code t05-0006

Last Modified: 08-Jul-2010


Engine Control Module - Critical Internal Failure

FAULT CODE 111

Engine Control Module - Critical Internal Failure

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 629 FMI: 12/12 LAMP: Red SRT: | Engine Control Module - critical internal failure. Error internal to the ECM related to memory hardware failures or internal ECM voltage supply circuits. | Engine may not start.
ECM Microprocessor

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is located on the fuel system side of the engine. It is attached at the cylinder head between cylinders 2 and 3. Refer to Procedure 100&ndash;002 in Section E for a detailed component location view.

Shop Talk

This fault code can only be caused by an internal ECM problem. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code t05-111

Last Modified: 08-Jul-2010


Fault Code Path Selection

FAULT CODE 1117
Fault Code Path Selection

Do you have an Automotive Application? | Go to 06-fc1117auto
Do you have a Marine Application? | Go to 06-fc1117mar

Last Modified: 15-Jan-2004


Power Lost Without Ignition Off - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1117 Automotive Application

Power Lost Without Ignition Off - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1117 PID: S251 SPN: 627 FMI: 2/2 LAMP: None SRT: | Power Lost Without Ignition Off - Data Erratic, Intermittent, or Incorrect. Supply voltage to the ECM fell below 6.2-VDC momentarily, or the ECM was not allowed to power down correctly (retain battery voltage for 30 seconds after key OFF). | Possible no noticeable performance effects or engine dying or hard starting. Fault information, trip information, and maintenance monitor data can be inaccurate.
Unswitched Battery Supply

Circuit Description

The ECM receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM power harness through the ECM battery supply stub. This provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM service manual.

Shop Talk

This fault is set active if the ECM battery supply voltage drops below + 6.2-VDC while the keyswitch is in the ON position.

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter. If unswitched power is coming from the starter, it is possible for the battery voltage to drop low enough during cranking to set this fault active.

Where the fault code is inactive, familiarize yourself with the vehicle shut down practices used by the operator. For example, if there are controls inside the cab that can interrupt the (ECM) power supply (before the end of the 30 second power down process after key OFF), these should be considered as a potential cause when the fault code is being addressed. This should be explained to the operator.

This fault can also be caused by resistance in the ECM battery supply (+) or (-) circuits. Resistance in these circuits can cause the voltage level at the ECM input to drop low enough to set Fault Code 1117 active.

This fault can also be caused by a short to ground in the injector wiring harness. Check to be sure the injector wires are oriented so that they will not interfere with a rocker lever or other components in the overhead system. Keep in mind that certain operating conditions can cause the rocker levers to operate outside their normal range of motion.

This fault code can also be caused by noise transmitted over the J1587 or J1939 data links. The transmitted noise can cause a momentary interruption in the ECM power, which causes Fault Code 1117 to log. During troubleshooting, isolate the engine from the chassis to determine if any of the data links are conducting noise to the engine.

Refer to Troubleshooting Fault Code t05-1117

Last Modified: 08-Jul-2010


Power Lost without Ignition Off - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1117 (Marine Application)

Power Lost without Ignition Off - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1117 PID: S251 SPN: 627 FMI: 2/2 LAMP: None SRT: | Power Lost without Ignition Off - Data Erratic, Intermittent, or Incorrect. Supply voltage to the ECM fell below +6.2-VDC momentarily, or the ECM was not allowed to power down correctly (retain battery voltage for 30 seconds after key OFF). | Possible no noticeable performance effects or engine dying or hard starting. Fault information, trip information, and maintenance monitor data can be inaccurate.
Unswitched Battery Supply

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the original equipment manufacturer (OEM) power harness through the ECM battery supply stub. This provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM service manual.

Shop Talk

This fault is set active if the ECM battery supply voltage drops below +6.2-VDC while the keyswitch is in the ON position.

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter. If unswitched power is coming from the starter, it is possible for the battery voltage to drop low enough during cranking to set this fault active.

Where the fault code is inactive, familiarize yourself with the vehicle shutdown practices used by the operator. For example, if there are controls inside the cab that can interrupt the (ECM) power supply (before the end of the 30 second power down process after key OFF), these should be considered as a potential cause when the fault code is being addressed. This should be explained to the operator.

This fault can also be caused by resistance in the ECM battery supply (+) or (-) circuits. Resistance in these circuits can cause the voltage level at the ECM input to drop low enough to set Fault Code 1117 active.

This fault can also be caused by a short to ground in the injector wiring harness. Check to be sure the injector wires are oriented so that they will not interfere with a rocker lever or other components in the overhead system. Keep in mind that certain operating conditions could cause the rocker levers to operate outside their normal range of motion.

This fault code can also be caused by noise transmitted over the J1587 or J1939 data links. The transmitted noise can cause a momentary interruption in the ECM power, which causes Fault Code 1117 to log. During troubleshooting, isolate the engine from the vessel to determine if any of the data links are conducting noise to the engine.

Refer to Troubleshooting Fault Code t05-1117

Last Modified: 08-Jul-2010


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1119

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1119 PID: P110 SPN: 110 FMI: 0/16 LAMP: Amber SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. Engine coolant temperature signal indicates engine coolant temperature is above engine protection warning limit. | Progressive power derate increasing in severity from time of alert.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The engine coolant temperature sensor is used by the engine control module (ECM) to monitor the engine coolant temperature. The ECM monitors the voltage on the SIGNAL pin and converts this to a temperature value. The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The engine coolant temperature sensor is located on the exhaust side of the engine near the thermostat housing. Refer to Procedure 100-002 in Section E for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant temperature is greater than a calibratible limit set in the ECM.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the fault code immediately after the coolant temperature decreases below the engine protection limit.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature. Refer to Engine Coolant Temperature Above Normal troubleshooting symptom tree.

Refer to Troubleshooting Fault Code t05-1119

Last Modified: 07-May-2014


Injector Solenoid Driver Cylinder 1 - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 1139

Injector Solenoid Driver Cylinder 1 - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1139 PID: S001 SPN: 651 FMI: 7 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 1 - Mechanical System Not Responding Properly or Out of Adjustment. Unintended fueling detected in cylinder number 1. | Engine will shut down.
Fuel Injector Circuit

Circuit Description

The electronic control module (ECM) can detect when unintended fuel injection occurs by monitoring fuel rail pressure and engine speed. This fault code is logged when the ECM determines that unintended fuel injection has occurred.

Component Location

The fuel injector is located in the cylinder head. 100-002 for a detailed component location view.

Shop Talk

This fault code can be caused by a failed or damaged injector causing continuous injection into the cylinder. Progressive cylinder damage may occur if the engine is operated for an extended period of time with this condition. If a failed injector is found to be the cause of this fault code, the cylinder liner and piston must be inspected for progressive damage.

If an injector nozzle is fractured or stuck, continuous fueling will ocur in that cylinder. If this condition occurs, the engine will typically die and not start. There will be exhaust smoke during cranking and no fuel rail pressure will be developed during cranking. Fault Code 2215 will be active during cranking if this condition exists.

Refer to Troubleshooting Fault Code t05-1139

Last Modified: 08-Jul-2010


Injector Solenoid Driver Cylinder 2 - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 1141

Injector Solenoid Driver Cylinder 2 - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1141 PID: S002 SPN: 652 FMI: 7 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 2 - Mechanical System Not Responding Properly or Out of Adjustment. Unintended fueling detected in cylinder number 2. | Engine will shut down.
Fuel Injector Circuit

Circuit Description

The electronic control module (ECM) can detect when unintended fuel injection occurs by monitoring fuel rail pressure and engine speed. This fault code is logged when the ECM determines that unintended fuel injection has occurred.

Component Location

The fuel injector is located in the cylinder head. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault code can be caused by a failed or damaged injector causing continuous injection into the cylinder. Progressive cylinder damage may occur if the engine is operated for an extended period of time with this condition. If a failed injector is found to be the cause of this fault code, the cylinder liner and piston must be inspected for progressive damage.

If an injector nozzle is fractured or stuck, continuous fueling will occur in that cylinder. If this condition occurs, the engine will typically die and not start. There will be exhaust smoke during cranking and no fuel rail pressure will be developed during cranking. Fault Code 2215 will be active during cranking if this condition exists.

Refer to Troubleshooting Fault Code t05-1141

Last Modified: 08-Jul-2010


Injector Solenoid Driver Cylinder 3 - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 1142

Injector Solenoid Driver Cylinder 3 - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1142 PID: S003 SPN: 653 FMI: 7 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 3 - Mechanical System Not Responding Properly or Out of Adjustment. Unintended fueling detected in cylinder number 3. | Engine will shut down.
Fuel Injector Circuit

Circuit Description

The electronic control module (ECM) can detect when unintended fuel injection occurs by monitoring fuel rail pressure and engine speed. This fault code is logged when the ECM determines that unintended fuel injection has occurred.

Component Location

The fuel injector is located in the cylinder head. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault code can be caused by a failed or damaged injector causing continuous injection into the cylinder. Progressive cylinder damage may occur if the engine is operated for an extended period of time with this condition. If a failed injector is found to be the cause of this fault code, the cylinder liner and piston must be inspected for progressive damage.

If an injector nozzle is fractured or stuck, continuous fueling will occur in that cylinder. If this condition occurs, the engine will typically die and not start. There will be exhaust smoke during cranking and no fuel rail pressure will be developed during cranking. Fault Code 2215 will be active during cranking if this condition exists.

Refer to Troubleshooting Fault Code t05-1142

Last Modified: 08-Jul-2010


Injector Solenoid Driver Cylinder 4 - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 1143

Injector Solenoid Driver Cylinder 4 - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1143 PID: S004 SPN: 654 FMI: 7 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 4 - Mechanical System Not Responding Properly or Out of Adjustment. Unintended fueling detected in cylinder number 4. | Engine will shut down.
Fuel Injector Circuit

Circuit Description

The electronic control module (ECM) can detect when unintended fuel injection occurs by monitoring fuel rail pressure and engine speed. This fault code is logged when the ECM determines that unintended fuel injection has occurred.

Component Location

The fuel injector is located in the cylinder head. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault code can be caused by a failed or damaged injector causing continuous injection into the cylinder. Progressive cylinder damage may occur if the engine is operated for an extended period of time with this condition. If a failed injector is found to be the cause of this fault code, the cylinder liner and piston must be inspected for progressive damage.

If an injector nozzle is fractured or stuck, continuous fueling will occur in that cylinder. If this condition occurs, the engine will typically die and not start. There will be exhaust smoke during cranking and no fuel rail pressure will be developed during cranking. Fault Code 2215 will be active during cranking if this condition exists.

Refer to Troubleshooting Fault Code t05-1143

Last Modified: 08-Jul-2010


Injector Solenoid Driver Cylinder 5 - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 1144

Injector Solenoid Driver Cylinder 5 - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1144 PID: S005 SPN: 655 FMI: 7 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 5 - Mechanical System Not Responding Properly or Out of Adjustment. Unintended fueling detected in cylinder Number 5. | Engine will shut down.
Fuel Injector Circuit

Circuit Description

The electronic control module (ECM) can detect when unintended fuel injection occurs by monitoring fuel rail pressure and engine speed. This fault code is logged when the ECM determines that unintended fuel injection has occurred.

Component Location

The fuel injector is located in the cylinder head. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault code can be caused by a failed or damaged injector causing continuous injection. If an injector nozzle is fractured or stuck open, continuous fueling will occur in that cylinder. If this condition occurs, an audible engine knock will be present, and the engine may stall and not start. In addition, low fuel rail pressure and excessive exhaust smoke will be present during cranking conditions. If a failed injector is found to be the cause of this fault code, progressive damage to the combustion chamber may have occurred.

Refer to Troubleshooting Fault Code t05-1144

Last Modified: 08-Jul-2010


Injector Solenoid Driver Cylinder 6 - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 1145

Injector Solenoid Driver Cylinder 6 - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1145 PID: S006 SPN: 656 FMI: 7 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 6 - Mechanical System Not Responding Properly or Out of Adjustment. Unintended fueling detected in cylinder Number 6. | Engine will shut down.
Fuel Injector Circuit

Circuit Description

The electronic control module (ECM) can detect when unintended fuel injection occurs by monitoring fuel rail pressure and engine speed. This fault code is logged when the ECM determines that unintended fuel injection has occurred.

Component Location

The fuel injector is located in the cylinder head. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault code can be caused by a failed or damaged injector causing continuous injection. If an injector nozzle is fractured or stuck open, continuous fueling will occur in that cylinder. If this condition occurs, an audible engine knock will be present, and the engine may stall and not start. In addition, low fuel rail pressure and excessive exhaust smoke will be present during cranking conditions. If a failed injector is found to be the cause of this fault code, progressive damage to the combustion chamber may have occurred.

Refer to Troubleshooting Fault Code t05-1145

Last Modified: 08-Jul-2010


Engine Magnetic Crankshaft Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

FAULT CODE 115

Engine Magnetic Crankshaft Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115 PID: P190 SPN: 612 FMI: 2 LAMP: Red SRT: | Engine Magnetic Crankshaft Speed/Position Lost Both of Two Signal - Data Erratic, Intermittent, or Incorrect. The ECM has detected that the primary engine speed sensor and the backup engine speed sensor signals are reversed. | Fueling to the injectors is disabled, and the engine can not be started.
Original Wiring Harness - Engine Speed Sensor and Camshaft Position Sensor Circuit
Revised Wiring Harness - Engine Speed Sensor and Camshaft Position Sensor Circuit

Circuit Description

The main engine speed sensor (crankshaft position sensor) and the backup engine speed sensor (camshaft position sensor) are connected to the engine wiring harness.

Component Location

The main engine speed sensor (crankshaft position sensor) reads a tone wheel that is mounted to the front of the engine crankshaft. The backup engine speed sensor (camshaft position sensor) reads a tone wheel that is inside the front cover.

Shop Talk

The main engine speed sensor (crankshaft position sensor) and the backup engine speed sensor (camshaft position sensor) are located in close proximity to one another. The same sensor is used in both locations. (Connector key is the same.) A P-clip on the engine wiring harness prohibits the harness connectors from being connected to the incorrect sensors. However, if the P-clip is omitted, it is possible to plug the wiring harness connectors into the incorrect sensors. If this occurs, the ECM will detect the problem and the engine will not start. Once the connector problem is corrected, the engine can be started and the fault code will become inactive.

The sensor return configuration for Euro 4 ISB engines has been changed for automotive wiring harnesses manufactured from February 2012 onward. The new style wiring harnesses can be be identified using the method below:

  • Disconnect the ECM connector
  • Disconnect the camshaft position sensor
  • Disconnect the intake manifold pressure/temperature sensor
  • Check for continuity between the intake manifold pressure/temperature sensor RETURN pin, and the camshaft position sensor RETURN pin
  • Check for continuity between ECM pin 47 and the camshaft position sensor RETURN pin.
  • Use the table below to determine which harness is fitted to the engine.

Engine Harnesses
From | To | New Harness | Old Harness
Intake manifold pressure/temperature sensor RETURN pin | Camshaft position sensor RETURN pin | Open circuit | Short circut
ECM pin 47 | Camshaft position sensor RETURN pin | Open circuit | Short circuit

NOTE: QSB engines, all C series engines, and all L series engines are not affected by this change.

Refer to Troubleshooting Fault Code t05-115.

Last Modified: 02-Feb-2012


Intake Manifold Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 122

Intake Manifold Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: P102 SPN: 102 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the intake manifold pressure circuit. | Automotive: Derate in power output of the engine. Marine: No engine protection for circuit or sensor failure.
Original Wiring Harness - Intake Manifold Pressure Sensor Circuit
Revised Wiring Harness - Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor monitors intake manifold pressure and passes information to the electronic control module (ECM) through the engine harness. If the intake manifold pressure becomes too high, it will cause a derate condition on automotive applications.

For marine applications, no derate condition occurs. There is no engine protection for a circuit or sensor failure.

Component Location

The intake manifold pressure sensor is located in the air intake horn. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The intake manifold pressure sensor shares SUPPLY and RETURN wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 122, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • SIGNAL wire shorted to sensor supply or battery voltage.

The sensor return configuration for Euro 4 ISB engines has been changed for automotive wiring harnesses manufactured from February 2012 onwards. The new style wiring harnesses can be be identified using the method below:

  • Disconnect the ECM connector
  • Disconnect the camshaft position sensor
  • Disconnect the intake manifold pressure/temperature sensor
  • Check for continuity between the intake manifold pressure/temperature sensor RETURN pin and the camshaft position sensor RETURN pin
  • Check for continuity between ECM pin 47 and the camshaft position sensor RETURN pin
  • Use the table below to determine which harness is fitted to the engine.

Engine Harnesses
From | To | New Harness | Old Harness
Intake manifold pressure/temperature sensor RETURN pin | Camshaft position sensor RETURN pin | Open circuit | Short circut
ECM pin 47 | Camshaft position sensor RETURN pin | Open circuit | Short circuit

NOTE: QSB engines, all C series engines, and all L series engines are not affected by this change.

Refer to Troubleshooting Fault Code t05-122.

Last Modified: 02-Feb-2012


EGR Valve Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1228

EGR Valve Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

EGR Valve Position - Data Erratic, Intermittent, or Incorrect

CODE | REASON | EFFECT
Fault Code: 1228 PID: P27 SPN: 27 FMI: 2/2 LAMP: Amber SRT: | EGR Valve Position - Data erratic, intermittent, or incorrect. Intermittent EGR position information is being received by the electronic control module (ECM). | Possible low power. EGR valve will be closed.
EGR Valve Position Sensor Circuit

Circuit Description

The EGR valve position sensor outputs a voltage signal to the electronic control module (ECM). The ECM converts this signal into a percentage value, 0 to 100 percent, indicating EGR valve position. A fully open valve is equivalent to 100 percent.

Component Location

The EGR valve position sensor is located on the EGR valve assembly. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault code is caused by an internal failure of the EGR valve position sensor. This failure causes erratic readings of EGR valve position.

Refer to Troubleshooting Fault Code t05-1228

Last Modified: 08-Jul-2010


VGT Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1229

VGT Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1229 PID: S27 SPN: 2795 FMI: 2/2 LAMP: Amber SRT: | VGT Position Sensor - Data erratic, intermittent, or incorrect. Intermittent variable geometry turbocharger (VGT) position information is being received by the electronic control module (ECM). | Possible low power. Power to the turbocharger actuator will be limited.
Turbocharger Position Sensor Circuit

Circuit Description

The turbocharger position sensor outputs a voltage signal to the ECM. The ECM converts this signal into a percentage value, 0 to 100 percent, indicating turbocharger position. A fully closed turbocharger actuataor is equivalent to 100 percent.

Component Location

The turbocharger position sensor is located on the variable geometry turbocharger (VGT) actuator assembly. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault code is caused by an internal failure of the variable geometry turbocharger (VGT) position sensor. This failure causes erratic readings of variable geometry turbocharger (VGT) position.

Refer to Troubleshooting Fault Code t05-1229

Last Modified: 08-Jul-2010


Intake Manifold Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 123

Intake Manifold Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: P102 SPN: 102 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the intake manifold pressure circuit. | Automotive: Derate in power output of the engine. Marine: None - No engine protection for circuit sensor failure.
Original Wiring Harness - Intake Manifold Pressure Sensor Circuit
Revised Wiring Harness - Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor monitors intake manifold pressure and passes information to the electronic control module (ECM) through the engine harness. On automotive applications, if the intake manifold pressure becomes too low, it will cause a derate condition.

For marine applications, no derate condition occurs. There is no engine protection for a circuit or sensor failure.

Component Location

The intake manifold pressure sensor is located in the air intake horn. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The intake manifold pressure sensor shares SUPPLY and RETURN wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 123, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • SUPPLY line open or shorted to ground.

The sensor return configuration for Euro 4 ISB engines has been changed for automotive wiring harnesses manufactured from February 2012 onward. The new style wiring harnesses can be be identified using the method below:

  • Disconnect the ECM connector
  • Disconnect the camshaft position sensor
  • Disconnect the intake manifold pressure/temperature sensor
  • Check for continuity between the intake manifold pressure/temperature sensor RETURN pin, and the camshaft position sensor RETURN pin
  • Check for continuity between ECM pin 47 and the camshaft position sensor RETURN pin
  • Use the table below to determine which harness is fitted to the engine.

Engine Harnesses
From | To | New Harness | Old Harness
Intake manifold pressure/temperature sensor RETURN pin | Camshaft position sensor RETURN pin | Open circuit | Short circut
ECM pin 47 | Camshaft position sensor RETURN pin | Open circuit | Short circuit

NOTE: QSB engines, all C series engines, and all L series engines are not affected by this change.

Refer to Troubleshooting Fault Code t05-123.

Last Modified: 02-Feb-2012


Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1239

Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1239 PID: SPN: 2623 FMI: 3/3 LAMP: Amber SRT: | Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at accelerator pedal position number 2 signal circuit. | Severe derate in power output of the engine. Limp home power only.
Accelerator Pedal Sensor

Circuit Description

The accelerator position sensor is a hall-effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the electronic control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

When the ECM senses a signal voltage lower than the normal operating range of the sensor, this fault code is set.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed.

If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 2 signal voltage can be monitored with the INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection.

Possible causes of this fault include:

  • Accelerator pedal position 2 signal circuit shorted to battery or 5 volt supply.
  • Open accelerator pedal return circuit in the harness or connections.
  • Accelerator supply shorted to battery.
  • Failed accelerator pedal position sensor.

Note: The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-1239

Last Modified: 08-Jul-2010


Intake Manifold 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 124

Intake Manifold 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 124 PID: P102 FMI: 0/16 LAMP: Amber SRT: | Intake Manifold 1 Pressure Sensor Circuit - Data Valid But Above Normal Operating Range - Moderately Severe Level. Intake manifold pressure has exceeded the maximum limit for the given engine rating. | Engine power derate.
Original Wiring Harness - Intake Manifold Pressure/Temperature Circuit
Revised Wiring Harness - Intake Manifold Pressure/Temperature Circuit

Circuit Description

The intake manifold pressure sensor is used by the ECM to monitor the engine intake manifold pressure.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code become active when the intake manifold pressure exceeds the maximum pressure limit for a given engine rating.

Possible causes:

  • Malfunctioning turbocharger wastegate
  • Wastegate tampering
  • Wrong turbocharger part
  • Possible tampering of the fuel system or turbocharger system.

The sensor return configuration for Euro 4 ISB engines has been changed for automotive wiring harnesses manufactured from February 2012 onward. The new style wiring harnesses can be be identified using the method below:

  • Disconnect the ECM connector
  • Disconnect the camshaft position sensor
  • Disconnect the intake manifold pressure/temperature sensor
  • Check for continuity between the intake manifold pressure/temperature sensor RETURN pin and the camshaft position sensor RETURN pin
  • Check for continuity between ECM pin 47 and the camshaft position sensor RETURN pin
  • Use the table below to determine which harness is fitted to the engine.

Engine Harnesses
From | To | New Harness | Old Harness
Intake manifold pressure/temperature sensor RETURN pin | Camshaft position sensor RETURN pin | Open circuit | Short circut
ECM pin 47 | Camshaft position sensor RETURN pin | Open circuit | Short circuit

NOTE: QSB engines, all C series engines, and all L series engines are not affected by this change.

Refer to Troubleshooting Fault Code t05-124.

Last Modified: 10-Feb-2012


Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1241

Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1241 PID: None SPN: 2623 FMI: 4/4 LAMP: Amber SRT: | Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at accelerator pedal position number 2 signal circuit. | Severe derate in power output of the engine. Limp home power only.
Accelerator Pedal Sensor

Circuit Description

The accelerator position sensor is a hall-effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the electronic control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from accelerator position 2. When the ECM senses a signal voltage lower than the normal operating range of the sensor, this fault code is set.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal. Refer to the OEM troubleshooting and repair manual.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed.

If troubleshooting an intermittent accelerator problem, the accelerator pedal position sensor 2 signal voltage can be monitored with the INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection.

Possible causes of this fault include:

  • Accelerator pedal position signal shorted to engine ground or return wires in the OEM harness or sensor
  • Malfunctioning accelerator pedal position sensor
  • Open circuit in the accelerator signal, supply, or return wire in the harness or connectors.

Note: The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-1241

Last Modified: 08-Jul-2010


Accelerator Pedal or Lever Position Sensor Number 1 and Number 2 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1242

Accelerator Pedal or Lever Position Sensor Number 1 and Number 2 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1242 PID: SPN: 091 FMI: 2/2 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor Number 1 and Number 2 - Data Erratic, Intermittent, or Incorrect. Accelerator position sensors numbers 1 and 2 are reading different values. | The engine will only idle.
Accelerator Pedal Sensor

Circuit Description

The accelerator position sensor is a hall-effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the electronic control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position number 1 is twice as much as the signal voltage from accelerator position number 2.

Component Location

The accelerator pedal position sensor is located on the accelerator pedal. Refer to the original equipment manufacturer (OEM) troubleshooting and repair manual.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors should be installed.

This fault code becomes active when the accelerator position sensor number 1 and accelerator position sensor number 2 are not reading the same value.

Possible causes of the fault include:

  • Failed accelerator pedal position sensor 1 or failed accelerator pedal position sensor number 2.
  • Accelerator pedal position sensor number 1 and accelerator pedal position sensor number 2 signal wires are shorted.
Refer to Troubleshooting Fault Code t05-1242

Last Modified: 08-Jul-2010


Accelerator Pedal or Lever Position Sensor Circuit - Shorted High

FAULT CODE 131

Accelerator Pedal or Lever Position Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 131 PID: P091 SPN: 91 FMI: 3/3 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor Circuit - Shorted High. High voltage detected at accelerator pedal or lever position circuit. | Automotive: Severe derate in power output of the engine. Limp home capability only. Marine: Severe derate in engine speed. Limp home capability only.
Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The accelerator pedal or lever position sensor is attached to the accelerator pedal or lever. The accelerator pedal or lever position sensor sends a signal to the electronic control module (ECM) when the accelerator pedal or lever is depressed and released. The accelerator pedal or lever position circuit contains three wires: Accelerator Pedal or Lever Position +5 VDC Supply, Accelerator Pedal or Lever Position Return, and Accelerator Pedal or Lever Position Signal.

Component Location

The accelerator pedal or lever position sensor is located on the accelerator pedal or lever. Refer to the OEM manual.

Shop Talk

If troubleshooting an intermittent accelerator problem:

The accelerator pedal or lever position sensor signal voltage can be monitored with the INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection.

Possible causes of this fault include:

  • Accelerator pedal or lever position signal circuit shorted to battery or +5 VDC supply
  • Open accelerator pedal or lever return circuit in the harness or connections
  • Accelerator supply shorted to battery
  • Failed accelerator pedal or lever position sensor.

NOTE: The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-131

Last Modified: 08-Jul-2010


Accelerator Pedal or Lever Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 132

Accelerator Pedal or Lever Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 132 PID: P091 SPN: 91 FMI: 4/4 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at accelerator pedal or lever position signal circuit. | Automotive: Severe derate in power output of the engine. Limp home capability only. Marine: Severe derate in engine speed. Limp home capability only.
Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The accelerator pedal or lever position sensor is attached to the accelerator pedal or lever. The accelerator pedal or lever position sensor sends a signal to the electronic control module (ECM) when the accelerator pedal or lever is depressed and released. The accelerator pedal or lever position circuit contains three wires: Accelerator Pedal or Lever Position Supply, Accelerator Pedal or Lever Position Return, and Accelerator Pedal or Lever Position Signal.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal or lever assembly. Refer to the OEM manual.

Shop Talk

If troubleshooting an intermittent accelerator problem:

The accelerator pedal or lever position sensor signal voltage can be monitored with the INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by INSITE™ electronic service tool.

Possible causes of this fault include:

  • Accelerator pedal or lever position signal shorted to engine ground or return wires in the OEM harness or sensor.
  • Failed accelerator pedal or lever position sensor.
  • Open circuit in the accelerator signal, supply, or return wire in the harness or connectors.

NOTE: The three wires in the accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-132

Last Modified: 08-Jul-2010


Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal, or shorted to High Source

FAULT CODE 133

Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal, or shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 133 PID: P029 SPN: 974 FMI: 3/3 LAMP: None SRT: | Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal, or shorted to High Source. High voltage detected at remote accelerator pedal position circuit. | Remote accelerator will not operate. Remote accelerator position will be set to zero percent.
Remote Accelerator Pedal Position Sensor Circuit

Circuit Description

The remote accelerator pedal or lever provides the operators accelerator command to the electronic control module (ECM) through the OEM harness. The ECM uses this signal to determine the fueling command.

Component Location

The remote accelerator pedal or lever location varies with each OEM. Refer to the OEM troubleshooting and repair manual.

Shop Talk

If troubleshooting an intermittent accelerator problem:

The remote accelerator pedal or lever position sensor signal voltage can be monitored with the INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection.

Possible causes of this fault include:

  • Remote accelerator pedal or lever position signal circuit shorted to battery or +5 volt supply
  • Open remote accelerator pedal or lever return circuit in the harness or connections
  • Remote accelerator supply shorted to battery
  • Failed remote accelerator pedal or lever position sensor.

Note: The three wires in the remote accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-133

Last Modified: 08-Jul-2010


Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 134

Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 134 PID: P029 SPN: 974 FMI: 4/4 LAMP: Red SRT: | Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal, or Shorted to Low Source. Low voltage detected at remote accelerator pedal position signal. | Remote accelerator will not operate. Remote accelerator position will be set to zero percent.
Remote Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The remote accelerator pedal or lever provides the opertors accelerator command to the electronic control module (ECM) through the OEM harness. The ECM uses this signal to determine the fueling command.

Component Location

The remote accelerator pedal or lever location varies with each OEM. Refer to the OEM service manual.

Shop Talk

If troubleshooting an intermittent accelerator problem:

The remote accelerator pedal or lever position sensor signal voltage can be monitored with the INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by INSITE™.

Possible causes of this fault include:

  • Remote accelerator pedal or lever position signal shorted to engine ground or return wires in the OEM harness or sensor.
  • Failed remote accelerator pedal or lever position sensor.
  • Open circuit in the remote accelerator signal, supply, or return wire in the harness or connectors.

NOTE: The three wires in the remote accelerator position sensor circuit must be twisted together.

Refer to Troubleshooting Fault Code t05-134

Last Modified: 08-Jul-2010


Fault Code Path Selection

FAULT CODE 06-fc135
Fault Code Path Selection

Do you have an Automotive Application? | Go to 06-fc135auto
Do you have a Marine Application? | Go to 06-fc135mar

Last Modified: 22-Jan-2004


Oil Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 135 (Automotive Application)

Oil Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3 LAMP: Amber SRT: | Oil Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source. High signal voltage detected at the engine oil pressure circuit. | None on performance. No engine protection for oil pressure.
Oil Pressure Sensor Circuit

Circuit Description

The engine oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value.

Component Location

The engine oil pressure sensor is located on the left side of the engine block. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

The oil pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 135, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-135

Last Modified: 08-Jul-2010


Oil Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 135 (Marine Applications)

Oil Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3 LAMP: Amber SRT: | Oil Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source. High signal voltage detected at the engine oil pressure circuit. | None. No engine protection for circuit or sensor failure.
Oil Pressure Sensor Circuit

Circuit Description

The engine oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value.

Component Location

The engine oil pressure sensor is located on the left side of the engine block. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-135

Last Modified: 08-Jul-2010


Fault Code Path Selection

FAULT CODE 06-fc141
Fault Code Path Selection

Do you have an Automotive Application? | Go to 06-fc141auto
Do you have a Marine Application? | Go to 06-fc141mar

Last Modified: 15-Sep-2005


Oil Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 141 (Automotive Application)

Oil Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4/4 LAMP: Amber SRT: | Oil Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the engine oil pressure circuit. | None on performance. No engine protection for oil pressure.
Oil Pressure Sensor Circuit

Circuit Description

The engine oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value.

Component Location

The engine oil pressure sensor is located on the left side of the engine block. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

The oil pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 141, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply line open or shorted to ground.
Refer to Troubleshooting Fault Code t05-141

Last Modified: 08-Jul-2010


Oil Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 141 (Marine Applications)

Oil Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4/4 LAMP: Amber SRT: | Oil Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the engine oil pressure circuit. | None. No engine protection for circuit or sensor failure.
Oil Pressure Sensor Circuit

Circuit Description

The engine oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value.

Component Location

The engine oil pressure sensor is located on the left side of the engine block. Refer to Procedure 100-002 in Section E.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply line open or shorted to ground.
Refer to Troubleshooting Fault Code t05-141

Last Modified: 08-Jul-2010


Fault Code Path Selection

FAULT CODE 06-fc143
Fault Code Path Selection

Is the engine an ISB/QSB Automotive or Industrial application, or a ISC/QSC/ISL/QSL Automotive, Industrial, or Marine application? | Go to 06-fc143b
Is the engine a QSB Marine application? | Go to 06-fc143bm

Last Modified: 15-Sep-2005


Engine Oil Rifle Pressure - Data Valid but Below Normal Operational Range - Moderately Severe Level

FAULT CODE 143 (ISB/QSB Automotive and Industrial, ISC/QSC/ISL/QSL Automotive, Industrial, and Marine)

Engine Oil Rifle Pressure - Data Valid but Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 1/18 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Valid but Below Normal Operational Range - Moderately Severe Level. Engine oil pressure signal indicates engine oil pressure is below the engine protection warning limit. | Automotive: None on performance. Marine: calibration dependent.
Engine Oil Pressure

Circuit Description

The engine oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value.

Component Location

The engine oil pressure sensor is located on the left side of the engine block. Refer to Procedure 100-002 for a detailed component location view.

Refer to Troubleshooting Fault Code t05-143

Last Modified: 08-Jul-2010


Engine Oil Rifle Pressure - Data Valid but Below Normal Operational Range - Moderately Severe Level

FAULT CODE 143 (QSB Marine Application)

Engine Oil Rifle Pressure - Data Valid but Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 1/18 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Valid but Below Normal Operational Range - Moderately Severe Level. Engine oil pressure signal indicates engine oil pressure is below the engine protection warning limit. | Marine: calibration dependent.
Engine Oil Pressure

Circuit Description

The engine oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. The ECM monitors the voltage on the signal pin and converts this to a pressure value.

Component Location

The engine oil pressure sensor is located on the left side of the engine block. Refer to Procedure 100-002 for a detailed component location view.

Refer to Troubleshooting Fault Code t05-143

Last Modified: 08-Jul-2010


Fault Code Path Selection

FAULT CODE 06-fc144
Fault Code Path Selection

Is the engine an ISB/QSB Automotive or Industrial application, or a ISC/QSC/ISL/QSL Automotive, Industrial or Marine application? | Go to 06-fc144b
Is the engine a QSB Marine application? | Go to 06-fc144bm

Last Modified: 07-Apr-2005


Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144 (ISB/QSB Automotive and Industrial, ISC/QSC/ISL/QSL Automotive, Industrial, and Marine)

Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3/3 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at engine coolant temperature circuit. | Automotive: Possible white smoke. Fan will stay ON if controlled by ECM. No engine protection for engine coolant temperature. Marine: None, no engine protection for circuit or sensor failure.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The engine coolant temperature sensor is used by the electronic control module (ECM) to monitor the engine coolant temperature. The ECM monitors the voltage on the signal pin and converts this to a temperature value. The engine coolant temperature value is used by the ECM for the engine protection system, and engine emissions control.

Component Location

The engine coolant temperature sensor is located on the thermostat housing. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

Before troubleshooting Fault Code 144, check for multiple faults.

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.

Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 30k to 37k
25 | 77 | 9.3k to 10.7k
50 | 122 | 3.2k to 3.8k
80 | 176 | 1.0k to 1.3k
95 | 203 | 700 to 800

On-Board Diagnostics (OBD) Information (Euro 4 Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.

On-Board Diagnostics (OBD) Information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 1 ignition cycle that the diagnostic runs and does not fail. The MIL lamp cannot be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.
Refer to Troubleshooting Fault Code t05-144

Last Modified: 08-Jul-2010


Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144 (QSB Marine Application)

Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3/3 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at engine coolant temperature circuit. | Marine: None, no engine protection for circuit or sensor failure.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The engine coolant temperature sensor is used by the electronic control module (ECM) to monitor the engine coolant temperature. The ECM monitors the voltage on the signal pin and converts this to a temperature value. The engine coolant temperature value is used by the ECM for the engine protection system, and engine emissions control.

Component Location

The engine coolant temperature sensor is located on the thermostat housing. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

Before troubleshooting Fault Code 144, check for multiple faults.

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.

Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 30k to 37k
25 | 77 | 9.3k to 10.7k
50 | 122 | 3.2k to 3.8k
80 | 176 | 1.0k to 1.3k
95 | 203 | 700 to 800
Refer to Troubleshooting Fault Code t05-144

Last Modified: 08-Jul-2010


Fault Code Path Selection

FAULT CODE 06-fc145
Fault Code Path Selection

Is the engine an ISB/QSB Automotive or Industrial application, or ISC/QSC/ISL/QSL Automotive, Industrial, or Marine application? | Go to 06-fc145b
Is the engine a QSB Marine application? | Go to 06-fc145bm

Last Modified: 07-Apr-2005


Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145 (ISB/QSB Automotive and Industrial, ISC/QSC/ISL/QSL Automotive, Industrial, and Marine)

Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4/4 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine coolant temperature circuit. | Automotive: Possible white smoke. Fan will stay ON if controlled by ECM. No engine protection for engine coolant temperature. Marine: calibration dependent.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The engine coolant temperature sensor is used by the electronic control module (ECM) to monitor the engine coolant temperature. The ECM monitors the voltage on the signal pin and converts this to a temperature value. The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The engine coolant temperature sensor is located on the thermostat housing. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 145, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness.
  • Signal shorted to return or ground in the sensor.

Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 30k to 37k
25 | 77 | 9.3k to 10.7k
50 | 122 | 3.2k to 3.8k
80 | 176 | 1.0k to 1.3k
95 | 203 | 700 to 800

On-Board Diagnostics (OBD) Information (Euro 4 Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.

On-Board Diagnostics (OBD) Information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 1 ignition cycle that the diagnostic runs and does not fail. The MIL lamp cannot be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.
Refer to Troubleshooting Fault Code t05-145

Last Modified: 08-Jul-2010


Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145 (QSB Marine Application)

Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4/4 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine coolant temperature circuit. | Marine: calibration dependent.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The engine coolant temperature sensor is used by the electronic control module (ECM) to monitor the engine coolant temperature. The ECM monitors the voltage on the signal pin and converts this to a temperature value. The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The engine coolant temperature sensor is located on the thermostat housing. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 145, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness.
  • Signal shorted to return or ground in the sensor.

Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 30k to 37k
25 | 77 | 9.3k to 10.7k
50 | 122 | 3.2k to 3.8k
80 | 176 | 1.0k to 1.3k
95 | 203 | 700 to 800
Refer to Troubleshooting Fault Code t05-145

Last Modified: 08-Jul-2010


Fault Code Path Selection

FAULT CODE 06-fc146
Fault Code Path Selection

Is the engine an ISB/QSB Automotive or Industrial application, or ISC/QSC/ISL/QSL Automotive, Industrial, or Marine application? | Go to 06-fc146b
Is the engine a QSB Marine application? | Go to 06-fc146bm

Last Modified: 07-Apr-2005


Engine Coolant Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 146 (ISB/QSB Automotive and Industrial, ISC/QSC/ISL/QSL Automotive, Industrial, and Marine)

Engine Coolant Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: P110 SPN: 110 FMI: 0/16 LAMP: Amber SRT: | Engine Coolant Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level. Engine coolant temperature signal indicates engine coolant temperature is above engine protection warning limit. | Automotive: Progressive power derate increasing in severity from time of alert. Marine: calibration dependent.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The engine coolant temperature sensor is used by the Electronic Control Module (ECM) to monitor the engine coolant temperature. The ECM monitors the voltage on the signal pin and converts this to a temperature value. The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The engine coolant temperature sensor is located on the exhaust side of the engine near the thermostat housing. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature. Refer to Engine Coolant Temperature Above Normal symptom troubleshooting tree.

Refer to Troubleshooting Fault Code t05-146

Last Modified: 08-Jul-2010


Engine Coolant Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 146 (QSB Marine Application)

Engine Coolant Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: P110 SPN: 110 FMI: 0/16 LAMP: Amber SRT: | Engine Coolant Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level. Engine coolant temperature signal indicates engine coolant temperature is above engine protection warning limit. | Marine: calibration dependent.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The engine coolant temperature sensor is used by the Electronic Control Module (ECM) to monitor the engine coolant temperature. The ECM monitors the voltage on the signal pin and converts this to a temperature value. The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The engine coolant temperature sensor is located on the exhaust side of the engine near the thermostat housing. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature. Refer to Engine Coolant Temperature Above Normal symptom troubleshooting tree.

Refer to Troubleshooting Fault Code t05-146

Last Modified: 08-Jul-2010


Accelerator Pedal or Lever Position 1 Sensor Circuit Frequency - Data Valid but Below Normal Operational Range - Most Severe Level

FAULT CODE 147

Accelerator Pedal or Lever Position 1 Sensor Circuit Frequency - Data Valid but Below Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 147 PID: P091 FMI: 1 LAMP: Red SRT: | Accelerator Pedal or Lever Position 1 Sensor Circuit Frequency - Data Valid but Below Normal Operational Range - Most Severe Level. A frequency of less than 100 HZ has been detected at the frequency throttle input to the ECM. | Severe detate in power output of the engine. Limp home power only.
Frequency Throttle Circuit

Circuit Description

This type of throttle interface is designed to accept a variable frequency signal as the throttle signal. An electronic component generates a square wave logic-level signal in which the frequency of the signal corresponds to a throttle command. The frequency values are established by the calibration in the electronic control module (ECM).

Component Location

Throttle location varies with each OEM. Refer to the OEM troubleshooting and repair manual.

Shop Talk

The frequency throttle can be used in conjunction with a voltage throttle or by itself.

Possible causes:

  • Open circuit in the frequency throttle signal wire.
  • Shorted to ground frequency throttle signal wire.
  • Failed frequency throttle.
  • Incorrect frequency throttle reference (input) voltage.
Refer to Troubleshooting Fault Code t05-147

Last Modified: 08-Jul-2010


Accelerator Pedal or Lever Position Sensor 1 - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 148

Accelerator Pedal or Lever Position Sensor 1 - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 148 PID: P091 FMI: 0 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor 1 - Data Valid but Above Normal Operational Range - Most Severe Level. A frequency of more than 1500 Hz has been detected at the frequency throttle input to the ECM. | Severe derate in power output of the engine. Limp home power only.
Frequency Throttle Circuit

Circuit Description

This type of throttle interface is designed to accept a variable frequency signal as the throttle signal. An electronic component generates a square wave logic-level signal in which the frequency of the signal corresponds to a throttle command. The frequency values are established by the calibration in the ECM.

Component Location

Throttle location varies with each OEM. Refer to the OEM troubleshooting and repair manual.

Shop Talk

The frequency throttle can be used in conjunction with a voltage throttle or by itself.

Possible causes:

  • Malfunctioning OEM Frequency Throttle
  • Shorted signal wire to voltage source.
Refer to Troubleshooting Fault Code t05-148

Last Modified: 08-Jul-2010


Fault Code Path Selection

FAULT CODE 06-fc151
Fault Code Path Selection

Is the engine an ISB/QSB Automotive or Industrial application, or ISC/QSC/ISL/QSL Automotive, Industrial, or Marine application? | Go to 06-fc151b
Is the engine a QSB Marine application? | Go to 06-fc151bm

Last Modified: 07-Apr-2005


Engine Coolant Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 151 (ISB/QSB Automotive and Industrial, ISC/QSC/ISL/QSL Automotive, Industrial, and Marine)

Engine Coolant Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0/0 LAMP: Red SRT: | Engine Coolant Temperature - Data Valid but Above Normal Operational Range - Most Severe Level. Engine coolant temperature signal indicates engine coolant temperature above engine protection critical limit. | Automotive: Progressive power derate increasing in severity from time of alert. If Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after red Stop lamp starts flashing. Marine: calibration dependent.
Coolant Temperature Sensor Circuit

Circuit Description

The engine coolant temperature sensor is used by the electronic control module (ECM) to monitor the engine coolant temperature. The ECM monitors the voltage on the signal pin and converts this to a temperature value. The engine coolant temperature value is used by the ECM for the engine protection system and engine emission control.

Component Location

The engine coolant temperature sensor is located on the thermostat housing. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature. Refer to the Engine Coolant Temperature Above Normal symptom troubleshooting tree in Troubleshooting and Repair Manual, ISC, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418 or ISBe and ISB (Common Rail Fuel System) Series Engines, Bulletin 4021271.

Refer to Troubleshooting Fault Code t05-151

Last Modified: 08-Jul-2010


Engine Coolant Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 151 (QSB Marine Only)

Engine Coolant Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0/0 LAMP: Red SRT: | Engine Coolant Temperature - Data Valid but Above Normal Operational Range - Most Severe Level. Engine coolant temperature signal indicates engine coolant temperature above engine protection critical limit. | Marine: calibration dependent.
Coolant Temperature Sensor Circuit

Circuit Description

The engine coolant temperature sensor is used by the electronic control module (ECM) to monitor the engine coolant temperature. The ECM monitors the voltage on the signal pin and converts this to a temperature value. The engine coolant temperature value is used by the ECM for the engine protection system and engine emission control.

Component Location

The engine coolant temperature sensor is located on the thermostat housing. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature. Refer to the Engine Coolant Temperature Above Normal symptom troubleshooting tree in Troubleshooting and Repair Manual, ISBe and ISB (Common Rail Fuel System) Series Engine, Bulletin 4021272.

Refer to Troubleshooting Fault Code t05-151

Last Modified: 08-Jul-2010


Intake Manifold Air Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Intake Manifold Air Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at intake manifold air temperature circuit. | Possible reduced engine performance.
Original Wiring Harness - Intake Manifold Air Pressure/Temperature Sensor Circuit
Revised Wiring Harness - Intake Manifold Air Pressure/Temperature Sensor Circuit

Circuit Description

The intake manifold air temperature sensor monitors intake manifold air temperature and passes information to the engine control module (ECM) through the engine harness. If the intake manifold air temperature becomes too high, it will cause a derate condition.

Component Location

The intake manifold air temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature sensor signal voltage is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.·Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged intake manifold pressure/temperature sensor.
  • Malfunctioning or damaged engine wiring harness.
Refer to Troubleshooting Fault Code t05-153.

Last Modified: 18-Apr-2022


Intake Manifold Air Pressure/Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 154

Intake Manifold Air Pressure/Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at intake manifold air temperature circuit. | Possible reduced engine performance.
Original Wiring Harness - Intake Manifold Air Temperature Sensor Circuit
Revised Wiring Harness - Intake Manifold Air Temperature Sensor Circuit

Circuit Description

The intake manifold air temperature sensor monitors intake manifold air temperature and passes information to the engine control module (ECM) through the engine harness.

Component Location

The intake manifold air temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature sensor signal voltage is out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled. Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged intake manifold pressure/temperature sensor.
  • Malfunctioning or damaged engine wiring harness.
Refer to Troubleshooting Fault Code t05-154.

Last Modified: 18-Apr-2022


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 155 (ISB/QSB Automotive and Industrial, ISC/QSC/ISL/QSL Automotive, Industrial, and Marine)

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0/0 LAMP: Red SRT: | Intake manifold air temperature signal indicates intake manifold air temperature above engine protection critical limit. | Engine shutdown.
Original Wiring Harness - Intake Manifold Air Temperature Sensor Circuit
Revised Wiring Harness - Circuit: Intake Manifold 1 Temperature

Circuit Description

The intake manifold air temperature sensor monitors intake manifold air temperature and passes information to the electronic control module (ECM) through the engine harness. If the intake manifold air temperature becomes too high, it will cause a derate condition. If engine protection is enabled, the engine will shut down 30 seconds after the red lamp starts flashing. No derate condition occurs for marine engines.

Component Location

The intake manifold air temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold air temperature was greater than 132°C [270°F] for 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.
  • The torque output of the engine will be reduced.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Restricted air flow through the charge air cooler.
  • An undersized charge air cooler.
  • High turbocharger compressor outlet temperature.
  • Plugged charge-air cooler fins.
  • Malfunctioning or damaged intake manifold temperature sensor.
  • Malfunctioning or damaged EGR valve.
  • Malfunctioning or damaged engine coolant thermostat.
  • Malfunctioning or damaged turbocharger.
Refer to Troubleshooting Fault Code t05-155.

Last Modified: 20-Apr-2022


Komnet Datalink Cannot Transmit - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1633

Komnet Datalink Cannot Transmit - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1633 PID: None SPN: 625 FMI: 2 LAMP: Amber SRT: | Komnet Datalink Cannot Transmit - Data Erratic, Intermittent, or Incorrect. Communications within the OEM datalink network is intermittent. | None on performance.
OEM Datalink Network Using J1939

Circuit Description

The Cummins electronic control module (ECM) communicates to the OEM data link network using the J1939 data link protocol.

Component Location

Refer to OEM troubleshooting for the location of the OEM installed primary and secondary ECM's.

Shop Talk

This fault code is logged when J1939 data link communications between the OEM installed ECM's and the Cummins engine ECM is intermittent. This fault is not triggered by the Cummins installed ECM and is only stored as an information fault code. Do not recalibrate or change the Cummins ECM for this fault code.

Refer to Troubleshooting Fault Code t05-1633

Last Modified: 08-Jul-2010


Auxiliary Equipment Sensor Input Number 3 (OEM Switch) - Root Cause Not Known

FAULT CODE 1639

Auxiliary Equipment Sensor Input Number 3 (OEM Switch) - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1639 PID: S051 SPN: 703 FMI: 11 LAMP: None SRT: | Auxiliary Equipment Sensor Input Number 3 (OEM Switch) - Root Cause Not Known. | Possible engine power derate.
OEM Temperature/Pressure Sensor Circuit

Circuit Description

The OEM has the option of wiring a temperature sensor input to the Cummins ECM. A specific calibration is then created to recognize this temperature sensor input. This fault code is activated when the temperature input from the OEM sensor exceeds the engine protection limit defined by the OEM. Depending on OEM requirements, an Engine Protection derate may be associated with this fault code.

Component Location

The OEM pressure or temperature sensor input will vary depending on application. Refer to the OEM troubleshooting manual for sensor location.

Shop Talk

This fault code is activated when the maximum inlet temperature or inlet pressure of a third party after-treatment system has exceeded the maximum allowable limits. A power derate may or may not be associated with this fault code.

Refer to Troubleshooting Fault Code t05-1639

Last Modified: 08-Jul-2010


Engine Misfire Cylinder 1 - Condition Exists.

FAULT CODE 1654

Engine Misfire Cylinder 1 - Condition Exists.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1654 PID: SPN: 1323 FMI: 11/31 LAMP: Amber SRT: | Engine Misfire Cylinder 1- Condition Exists. Engine misfire has been detected in cylinder number 1. | Possible low power, rough idle, or misfire.
Circuit

Circuit Description

An algorithm in the ECM calibration monitors engine speed as each injector fires while the engine is at idle. If a cylinder has high or low contribution to engine speed, this fault will become active. The intention of this fault is to assist in troubleshooting performance complaints such as engine misfire and low power.

Component Location

The ECM is located on the intake side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Shop Talk

If Fault Code 1654 is inactive in the ECM memory and there is no complaint such as “low power” or “engine misfire”, it is possible that an intermittent event such as air entering the fuel system following a filter change caused the fault. Inactive counts of Fault Code 1654 should be disregarded unless other performance symptoms are present. The engine coolant temperature must be greater than 71°C [160°F] before this diagnostic will run.

Causes of cylinder misfire can include:

  • Valve lash out of specification (compare actual valve lash to reset limits)
  • Cylinder failure (check for high blowby when the engine is loaded)
  • Valve failure or valve held open (listen for intake valve “chirping” noise in the intake)
  • Cylinder head or gasket failure (look for signs of oil, coolant, or casting flash in the intake or exhaust passages)
  • Extreme camshaft wear (inspect the camshaft lobes for wear)
  • Extra, missing, or damaged sealing washer under an injector
  • Injector failures (“swap” injectors to see if the problem “follows” the indicated injector).
  • Check air compressor timing (if engine has had fault since new or has had a recent air compressor replacement.)
  • For 6 cylinder ISBe4 automatic transmission applications: Check “On-Board Diagnostic (OBD) misfire alternate gains” setting in the features and parameters screen in INSITE™ electronic service tool. If the vehicle is fitted with a Voith transmission, this should be set to 2. All others are set to 1.

On-Board Diagnostic Information:

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails
  • The ECM turns OFF the MIL after 3 consecutive ignition cycles, with the engine running for at least 10 seconds, that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared, use the INSITE™ electronic service tool
  • The fault code will be cleared from the memory after 40 consecutive drive cycles when the diagnostic runs and passes.
Refer to Troubleshooting Fault Code t05-1654

Last Modified: 08-Jul-2010


Engine Misfire Cylinder 2 - Condition Exists.

FAULT CODE 1655

Engine Misfire Cylinder 2 - Condition Exists.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1655 PID: SPN: 1324 FMI: 11/31 LAMP: Amber SRT: | Engine Misfire Cylinder 2 - Condition Exists. Engine misfire has been detected in cylinder number 2. | Possible low power, rough idle, or misfire.
Circuit

Circuit Description

An algorithm in the ECM calibration monitors engine speed as each injector fires while the engine is at idle. If a cylinder has high or low contribution to engine speed, this fault will become active. The intention of this fault is to assist in troubleshooting performance complaints such as engine misfire and low power.

Component Location

The ECM is located on the intake side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Shop Talk

If Fault Code 1655 is inactive in the ECM memory and there is no complaint such as “low power” or “engine misfire”, it is possible that an intermittent event such as air entering the fuel system following a filter change caused the fault. Inactive counts of Fault Code 1655 should be disregarded unless other performance symptoms are present. The engine coolant temperature must be greater than 71°C [160°F] before this diagnostic will run.

Causes of cylinder misfire can include:

  • Valve lash out of specification (compare actual valve lash to reset limits)
  • Cylinder failure (check for high blowby when the engine is loaded)
  • Valve failure or valve held open (listen for intake valve “chirping” noise in the intake)
  • Cylinder head or gasket failure (look for signs of oil, coolant, or casting flash in the intake or exhaust passages)
  • Extreme camshaft wear (inspect the camshaft lobes for wear)
  • Extra, missing, or damaged sealing washer under an injector
  • Injector failures (“swap” injectors to see if the problem “follows” the indicated injector).
  • Check air compressor timing (if engine has had fault since new or has had a recent air compressor replacement.)
  • For 6 cylinder ISBe4 automatic transmission applications: Check “On-Board Diagnostic (OBD) misfire alternate gains” setting in the features and parameters screen in INSITE™ electronic service tool. If the vehicle is fitted with a Voith transmission, this should be set to 2. All others are set to 1.

On-Board Diagnostic Information:

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails
  • The ECM turns OFF the MIL after 3 consecutive ignition cycles, with the engine running for at least 10 seconds, that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared, use the INSITE™ electronic service tool
  • The fault code will be cleared from the memory after 40 consecutive drive cycles when the diagnostic runs and passes.
Refer to Troubleshooting Fault Code t05-1655

Last Modified: 08-Jul-2010


Engine Misfire Cylinder 3 - Condition Exists.

FAULT CODE 1656

Engine Misfire Cylinder 3 - Condition Exists.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1656 PID: SPN: 1325 FMI: 11/31 LAMP: Amber SRT: | Engine Misfire Cylinder 3 - Condition Exists. Engine misfire has been detected in cylinder number 3. | Possible low power, rough idle, or misfire.
Circuit

Circuit Description

An algorithm in the ECM calibration monitors engine speed as each injector fires while the engine is at idle. If a cylinder has high or low contribution to engine speed, this fault will become active. The intention of this fault is to assist in troubleshooting performance complaints such as engine misfire and low power.

Component Location

The ECM is located on the intake side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Shop Talk

If Fault Code 1656 is inactive in the ECM memory and there is no complaint such as “low power” or “engine misfire”, it is possible that an intermittent event such as air entering the fuel system following a filter change caused the fault. Inactive counts of Fault Code 1656 should be disregarded unless other performance symptoms are present. The engine coolant temperature must be greater than 71°C [160°F] before this diagnostic will run.

Causes of cylinder misfire can include:

  • Valve lash out of specification (compare actual valve lash to reset limits)
  • Cylinder failure (check for high blowby when the engine is loaded)
  • Valve failure or valve held open (listen for intake valve “chirping” noise in the intake)
  • Cylinder head or gasket failure (look for signs of oil, coolant, or casting flash in the intake or exhaust passages)
  • Extreme camshaft wear (inspect the camshaft lobes for wear)
  • Extra, missing, or damaged sealing washer under an injector
  • Injector failures (“swap” injectors to see if the problem “follows” the indicated injector).
  • Check air compressor timing (if engine has had fault since new or has had a recent air compressor replacement.)
  • For 6 cylinder ISBe4 automatic transmission applications: Check “On-Board Diagnostic (OBD) misfire alternate gains” setting in the features and parameters screen in INSITE™ electronic service tool. If the vehicle is fitted with a Voith transmission, this should be set to 2. All others are set to 1.

On-Board Diagnostic Information:

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails
  • The ECM turns OFF the MIL after 3 consecutive ignition cycles, with the engine running for at least 10 seconds, that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared, use the INSITE™ electronic service tool
  • The fault code will be cleared from the memory after 40 consecutive drive cycles when the diagnostic runs and passes.
Refer to Troubleshooting Fault Code t05-1656

Last Modified: 08-Jul-2010


Engine Misfire Cylinder 4 - Condition Exists.

FAULT CODE 1657

Engine Misfire Cylinder 4 - Condition Exists.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1657 PID: SPN: 1326 FMI: 11/31 LAMP: Amber SRT: | Engine Misfire Cylinder 4 - Condition Exists. Engine misfire has been detected in cylinder number 4. | Possible low power, rough idle, or misfire.
Circuit

Circuit Description

An algorithm in the ECM calibration monitors engine speed as each injector fires while the engine is at idle. If a cylinder has high or low contribution to engine speed, this fault will become active. The intention of this fault is to assist in troubleshooting performance complaints such as engine misfire and low power.

Component Location

The ECM is located on the intake side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Shop Talk

If Fault Code 1657 is inactive in the ECM memory and there is no complaint such as “low power” or “engine misfire”, it is possible that an intermittent event such as air entering the fuel system following a filter change caused the fault. Inactive counts of Fault Code 1657 should be disregarded unless other performance symptoms are present. The engine coolant temperature must be greater than 71°C [160°F] before this diagnostic will run.

Causes of cylinder misfire can include:

  • Valve lash out of specification (compare actual valve lash to reset limits)
  • Cylinder failure (check for high blowby when the engine is loaded)
  • Valve failure or valve held open (listen for intake valve “chirping” noise in the intake)
  • Cylinder head or gasket failure (look for signs of oil, coolant, or casting flash in the intake or exhaust passages)
  • Extreme camshaft wear (inspect the camshaft lobes for wear)
  • Extra, missing, or damaged sealing washer under an injector
  • Injector failures (“swap” injectors to see if the problem “follows” the indicated injector).
  • Check air compressor timing (if engine has had fault since new or has had a recent air compressor replacement.)
  • For 6 cylinder ISBe4 automatic transmission applications: Check “On-Board Diagnostic (OBD) misfire alternate gains” setting in the features and parameters screen in INSITE™ electronic service tool. If the vehicle is fitted with a Voith transmission, this should be set to 2. All others are set to 1.

On-Board Diagnostic Information:

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails
  • The ECM turns OFF the MIL after 3 consecutive ignition cycles, with the engine running for at least 10 seconds, that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared, use the INSITE™ service tool
  • The fault code will be cleared from the memory after 40 consecutive drive cycles when the diagnostic runs and passes.
Refer to Troubleshooting Fault Code t05-1657

Last Modified: 08-Jul-2010


Engine Misfire Cylinder 5 - Condition Exists.

FAULT CODE 1658

Engine Misfire Cylinder 5 - Condition Exists.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1658 PID: SPN: 1327 FMI: 11/31 LAMP: Amber SRT: | Engine Misfire Cylinder 5 - Condition Exists. Engine misfire has been detected in cylinder number 5. | Possible low power, rough idle, or misfire.
Circuit

Circuit Description

An algorithm in the ECM calibration monitors engine speed as each injector fires while the engine is at idle. If a cylinder has high or low contribution to engine speed, this fault will become active. The intention of this fault is to assist in troubleshooting performance complaints such as engine misfire and low power.

Component Location

The ECM is located on the intake side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Shop Talk

If Fault Code 1658 is inactive in the ECM memory and there is no complaint such as “low power” or “engine misfire”, it is possible that an intermittent event such as air entering the fuel system following a filter change caused the fault. Inactive counts of Fault Code 1658 should be disregarded unless other performance symptoms are present. The engine coolant temperature must be greater than 71°C [160°F] before this diagnostic will run.

Causes of cylinder misfire can include:

  • Valve lash out of specification (compare actual valve lash to reset limits)
  • Cylinder failure (check for high blowby when the engine is loaded)
  • Valve failure or valve held open (listen for intake valve “chirping” noise in the intake)
  • Cylinder head or gasket failure (look for signs of oil, coolant, or casting flash in the intake or exhaust passages)
  • Extreme camshaft wear (inspect the camshaft lobes for wear)
  • Extra, missing, or damaged sealing washer under an injector
  • Injector failures (“swap” injectors to see if the problem “follows” the indicated injector).
  • Check air compressor timing (if engine has had fault since new or has had a recent air compressor replacement.)
  • For 6 cylinder ISBe4 automatic transmission applications: Check “On-Board Diagnostic (OBD) misfire alternate gains” setting in the features and parameters screen in INSITE™ electronic service tool. If the vehicle is fitted with a Voith transmission, this should be set to 2. All others are set to 1.

On-Board Diagnostic Information:

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails
  • The ECM turns OFF the MIL after 3 consecutive ignition cycles, with the engine running for at least 10 seconds, that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared, use the INSITE™ electronic service tool
  • The fault code will be cleared from the memory after 40 consecutive drive cycles when the diagnostic runs and passes.
Refer to Troubleshooting Fault Code t05-1658

Last Modified: 08-Jul-2010


Engine Misfire Cylinder 6 - Condition Exists.

FAULT CODE 1659

Engine Misfire Cylinder 6 - Condition Exists.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1659 PID: SPN: 1328 FMI: 11/31 LAMP: Amber SRT: | Engine Misfire Cylinder 6 - Condition Exists. Engine misfire has been detected in cylinder number 6. | Possible low power, rough idle, or misfire.
Circuit

Circuit Description

An algorithm in the ECM calibration monitors engine speed as each injector fires while the engine is at idle. If a cylinder has high or low contribution to engine speed, this fault will become active. The intention of this fault is to assist in troubleshooting performance complaints such as engine misfire and low power.

Component Location

The ECM is located on the intake side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Shop Talk

If Fault Code 1659 is inactive in the ECM memory and there is no complaint such as “low power” or “engine misfire”, it is possible that an intermittent event such as air entering the fuel system following a filter change caused the fault. Inactive counts of Fault Code 1659 should be disregarded unless other performance symptoms are present. The engine coolant temperature must be greater than 71°C [160°F] before this diagnostic will run.

Causes of cylinder misfire can include:

  • Valve lash out of specification (compare actual valve lash to reset limits)
  • Cylinder failure (check for high blowby when the engine is loaded)
  • Valve failure or valve held open (listen for intake valve “chirping” noise in the intake)
  • Cylinder head or gasket failure (look for signs of oil, coolant, or casting flash in the intake or exhaust passages)
  • Extreme camshaft wear (inspect the camshaft lobes for wear)
  • Extra, missing, or damaged sealing washer under an injector
  • Injector failures (“swap” injectors to see if the problem “follows” the indicated injector).
  • Check air compressor timing (if engine has had fault since new or has had a recent air compressor replacement.)
  • For 6 cylinder ISBe4 automatic transmission applications: Check “On-Board Diagnostic (OBD) Misfire alternate gains” setting in the features and parameters screen in INSITE™ electronic service tool. If the vehicle is fitted with a Voith transmission, this should be set to 2. All others are set to 1.

On-Board Diagnostic Information:

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails
  • The ECM turns OFF the MIL after 3 consecutive ignition cycles, with the engine running for at least 10 seconds, that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared, use the INSITE™ service tool
  • The fault code will be cleared from the memory after 40 consecutive drive cycles when the diagnostic runs and passes.
Refer to Troubleshooting Fault Code t05-1659

Last Modified: 08-Jul-2010


Catalyst Inlet Temperature Sensor Swapped with Outlet - Condition Exists.

FAULT CODE 1663

Catalyst Inlet Temperature Sensor Swapped with Outlet - Condition Exists.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1663 PID: SPN: 3241 FMI: 11/31 LAMP: Amber SRT: | Catalyst Inlet Temperature Sensor Swapped with Outlet — Condition Exists. The inlet and outlet catalyst temperature sensor connections are swapped. | Catalyst solution injection into the aftertreatment system is disabled.
Circuit

Circuit Description

The catalyst temperature sensors are used to monitor the temperatures of the exhaust gas entering and exiting the catalyst.

Component Location

The inlet and exhaust temperature sensors are located in the aftertreatment system. The inlet temperature sensor is located before the catalyst and the exhaust temperature sensor is located at the outlet of the exhaust.

Shop Talk

Both inlet and outlet exhaust gas temperature sensors have the same part number, so it is possible to get the sensors connected backwards to the engine harness. This fault code is activated when the ECM determines that the temperature reading from the inlet and outlet sensors are reading backwards. The most likely cause of this fault code is that the inlet and exhaust temperature sensor connectors are swapped at the engine harness. Disconnect the inlet and outlet temperature sensors from the engine harness and swap the connectors. The catalyst temperature sensors must be reading ambient temperature and the engine must be off for a period of eight hours before this diagnostic will run.

On-Board Diagnostic (OBD) Information:

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ service tool
  • The fault code will be cleared from the memory after 40 consecutive drive cycles when the diagnostic runs and passes.
Refer to Troubleshooting Fault Code t05-1663

Last Modified: 08-Jul-2010


Catalyst Missing - Condition Exists.

FAULT CODE 1664

Catalyst Missing - Condition Exists.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1664 PID: SPN: 3050 FMI: 11/31 LAMP: Amber SRT: | Catalyst Missing — Condition Exists. The aftertreatment catalyst in the exhaust system is not present. | Catalyst solution injection into the aftertreatment system is disabled.
Circuit: Aftertreatment Control System

Circuit Description

The catalyst is monitored by inlet and outlet temperature sensors that are located in the aftertreatment system. The inlet temperature sensor is located before the catalyst and the outlet temperature sensor is located at the outlet of the catalyst system.

Component Location

The catalyst is located in the exhaust system. The location of the catalyst may vary depending on the OEM.

Shop Talk

This fault code becomes active when the inlet and outlet temperature sensors do not detect the presence of a catalyst in the aftertreatment system. This can be caused by tampering with the catalyst system, the catalyst has been removed from the vehicle, or a failed catalyst. The catalyst temperature sensors must be reading ambient temperature and the engine must be off for a period of eight hours before this diagnostic will run. If the catalyst temperature is above 100°F [38°C], or the catalyst temperature sensors have a difference of more than 10°F or 5.5°C the diagnostics will not run.

Possible causes of this fault include:

  • Incorrect calibration revision on INCAL CD
  • Tampering with catalyst system, removal of catalyst from vehicle, or failed catalyst.

On-Board Diagnostic (OBD) Information:

  • The ECM illuminates the malfunction indicator lamp (MIL) on the second consecutive ignition cycle that the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ service tool
  • The fault code will be cleared from the memory after 40 consecutive drive cycles when the diagnostic runs and passes.
Refer to Troubleshooting Fault Code t05-1664

Last Modified: 08-Jul-2010


Exhaust Gas Temperature 1 Circuit — Voltage Below Normal, or Shorted to Low Source.

FAULT CODE 1665

Exhaust Gas Temperature 1 Circuit — Voltage Below Normal, or Shorted to Low Source.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1665 PID: SPN: 3241 FMI: 4 LAMP: Amber SRT: | Exhaust Gas Temperature 1 Circuit — Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the catalyst inlet temperature sensor circuit. | Default temperature used for catalyst inlet temperature.
Circuit: Exhaust Gas Temperature 1

Circuit Description

The catalyst inlet temperature sensor is used by the electronic control module (ECM) to monitor the engine exhaust temperature entering the catalyst unit. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The catalyst inlet temperature sensor is located in the aftertreatment system. It is located between the turbocharger outlet and the catalyst unit inlet in the exhaust system.

Shop Talk

The catalyst inlet temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor

On-Board Diagnostics (OBD) Information (Euro 4 Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.

On-Board Diagnostics (OBD) Information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 1 ignition cycle that the diagnostic runs and does not fail. The MIL lamp cannot be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.
Refer to Troubleshooting Fault Code t05-1665

Last Modified: 08-Jul-2010


Exhaust Gas Temperature 1 Circuit — Voltage Above Normal, or Shorted to Low Source

FAULT CODE 1666

Exhaust Gas Temperature 1 Circuit — Voltage Above Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1666 PID: SPN: 3241 FMI: 3 LAMP: Amber SRT: | Exhaust Gas Temperature 1 Circuit — Voltage Above Normal, or Shorted to Low Source. High signal voltage detected at the catalyst inlet temperature sensor circuit | Default temperature used for catalyst inlet temperature.
Circuit: Exhaust Gas Temperature 1

Circuit Description

The catalyst inlet temperature sensor is used by the electronic control module (ECM) to monitor the engine exhaust temperature entering the catalyst unit. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The catalyst inlet temperature sensor is located in the aftertreatment system. It is located between the turbocharger outlet and the catalyst unit inlet in the exhaust system.

Shop Talk

Catalyst inlet temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.

On-Board Diagnostics (OBD) Information (Euro 4 Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.

On-Board Diagnostics (OBD) Information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 1 ignition cycle that the diagnostic runs and does not fail. The MIL lamp cannot be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.
Refer to Troubleshooting Fault Code t05-1666

Last Modified: 08-Jul-2010


Exhaust Gas Temperature 1 — Data Erratic, Intermittent, or Incorrect

FAULT CODE 1667

Exhaust Gas Temperature 1 — Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1667 PID: SPN: 3241 FMI: 2 LAMP: Amber SRT: | Exhaust Gas Temperature 1 — Data Erratic, Intermittent, or Incorrect. The exhaust gas temperature #1 sensor is not changing with engine operating conditions. | Default temperature value used for exhaust gas temperature #1.
Circuit: Exhaust Gas Temperature 1

Circuit Description

The exhaust gas temperature #1 sensor is used by the electronic control module (ECM) to monitor the engine exhaust temperature entering the catalyst unit. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The exhaust gas temperature #1 sensor is located in the aftertreatment system. It is located between the turbocharger outlet and the catalyst unit inlet in the exhaust system.

Shop Talk

This diagnostic runs when the exhaust gas temperature sensors are compared to other engine temperatures during engine operation. The engine coolant temperature must be above 140°F before the diagnostic will run. If the value of the exhaust gas temperature #1 does not match the engine operating conditions, this fault code is logged.

Possible causes of this fault code include:

  • Stuck in-range exhaust gas temperature #1 sensor
  • High resistance in the exhaust gas temperature #1 sensor signal or return lines.

On-Board Diagnostics (OBD) Information:

  • The ECM illuminates the malfunction indicator lamp (MIL) on the second consecutive ignition cycle that the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.
Refer to Troubleshooting Fault Code t05-1667

Last Modified: 08-Jul-2010


Catalyst Tank Level Sensor Circuit — Voltage Below Normal, or Shorted to Low Source

FAULT CODE 1668

Catalyst Tank Level Sensor Circuit — Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1668 PID: SPN: 1761 FMI: 4/4 LAMP: Amber SRT: | Catalyst Tank Level Sensor Circuit — Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the catalyst tank level sensor circuit. | Catalyst solution injection into the aftertreatment system is disabled.
Circuit: Catalyst Tank Level Sensor.

Circuit Description

The catalyst tank level sensor is used to monitor the catalyst solution level inside the catalyst tank. The catalyst tanks level sensor is a combination sensor with the catalyst solution temperature sensor. The level and temperature sensors share a common return circuit.

Component Location

The catalyst tank level sensor is located in the catalyst solution tank. Location of the tank and level sensor is OEM dependent.

Shop Talk

The catalyst tank level sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active.

Before troubleshooting Fault Code 1668, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply line open or shorted to ground.

On-Board Diagnostics (OBD) Information (Euro 4 Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.

On-Board Diagnostics (OBD) Information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 1 ignition cycle that the diagnostic runs and does not fail. The MIL lamp cannot be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.
Refer to Troubleshooting Fault Code t05-1668

Last Modified: 08-Jul-2010


Catalyst Tank Level Sensor Circuit — Voltage Above Normal, or Shorted to High Source

FAULT CODE 1669

Catalyst Tank Level Sensor Circuit — Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1669 PID: SPN: 1761 FMI: 3 LAMP: Amber SRT: | Catalyst Tank Level Sensor Circuit — Voltage Above Normal, or Shorted to High Source. High signal voltage detected at the catalyst tank level sensor circuit. | Catalyst solution injection into the aftertreatment system is disabled.
Circuit: Catalyst Tank Level Sensor.

Circuit Description

The catalyst tank level sensor is used to monitor the catalyst solution level inside the catalyst tank. The catalyst tanks level sensor is a combination sensor with the catalyst solution temperature sensor. The level and temperature sensors share a common return circuit.

Component Location

The catalyst tank level sensor is located in the catalyst tank. Location of the tank and level sensor is OEM dependent.

Shop Talk

The catalyst tank level sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active.

Before troubleshooting Fault Code 1669, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.

On-Board Diagnostics (OBD) Information (Euro 4 Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.

On-Board Diagnostics (OBD) Information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 1 ignition cycle that the diagnostic runs and does not fail. The MIL lamp cannot be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.
Refer to Troubleshooting Fault Code t05-1669

Last Modified: 08-Jul-2010


Catalyst Tank Level — Data Valid but Below Normal Operational Range — Moderately Severe Level.

FAULT CODE 1671

Catalyst Tank Level — Data Valid but Below Normal Operational Range — Moderately Severe Level.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1671 PID: SPN: 1761 FMI: 1/18 LAMP: Maintenance SRT: | Catalyst Tank Level — Data Valid but Below Normal Operational Range — Moderately Severe Level. Low catalyst solution level has been detected in the catalyst solution tank. | None on performance.
Circuit: Aftertreatment Control System

Circuit Description

The catalyst solution level sensor is used to monitor the catalyst solution level inside the catalyst tank.

Component Location

The catalyst solution level sensor is located in the catalyst solution tank. Location of the tank and level sensor is OEM dependent.

Shop Talk

Fault code 1671 is triggered when low catalyst solution level has been detected in the catalyst solution tank. Add catalyst solution to the tank. This fault code is only a warning for low catalyst tank solution level.

On-Board Diagnostic (OBD) Information:

  • The ECM illuminates the appropriate amber or red fault lamp when the diagnostic runs and fails.
  • The ECM turns off the appropriate fault lamp when the diagnostic runs and passes.
Refer to Troubleshooting Fault Code t05-1671

Last Modified: 08-Jul-2010


Catalyst Tank Level - Data Erratic, Intermittent, or Incorrect.

FAULT CODE 1673

Catalyst Tank Level - Data Erratic, Intermittent, or Incorrect.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1673 PID: SPN: 1761 FMI: 1 LAMP: Amber SRT: | Catalyst Tank Level — Data Valid but Below Normal Operational Range — Most Severe Level. No catalyst solution has been detected in the catalyst solution tank. | Catalyst solution injection into the aftertreatment system is disabled.
Circuit: Aftertreatment Control System

Circuit Description

The catalyst solution level sensor is used to monitor the catalyst solution level inside the catalyst tank.

Component Location

The catalyst solution level sensor is located in the catalyst solution tank. Location of the tank and level sensor is OEM dependent.

Shop Talk

Fault code 1673 is triggered when the catalyst solution level sensor has detected that the catalyst tank is empty. Catalyst solution may still be visible inside the tank when this fault code is active. Add catalyst solution to the tank.

On-Board Diagnostics (OBD) Information (Euro 4 Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.

On-Board Diagnostics (OBD) Information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 1 ignition cycle that the diagnostic runs and does not fail. The MIL lamp cannot be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.
Refer to Troubleshooting Fault Code t05-1673

Last Modified: 08-Jul-2010


Exhaust Gas Temperature 2 Circuit — Voltage Below Normal, or Shorted to Low Source

FAULT CODE 1674

Exhaust Gas Temperature 2 Circuit — Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1674 PID: SPN: 3249 FMI: 4 LAMP: Amber SRT: | Exhaust Gas Temperature 2 Circuit — Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the catalyst exhaust temperature sensor circuit. | Default temperature used for catalyst exhaust temperature.
Circuit: Exhaust Gas Temperature 2

Circuit Description

The catalyst outlet temperature sensor is used by the electronic control module (ECM) to monitor the engine exhaust temperature exiting the catalyst unit. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The catalyst outlet temperature sensor is located in the aftertreatment system. It is located in the outlet of the aftertreatment catalyst unit.

Shop Talk

The catalyst outlet temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.

On-Board Diagnostics (OBD) Information (Euro 4 Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.

On-Board Diagnostics (OBD) Information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 1 ignition cycle that the diagnostic runs and does not fail. The MIL lamp cannot be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.
Refer to Troubleshooting Fault Code t05-1674

Last Modified: 08-Jul-2010


Exhaust Gas Temperature 2 Circuit — Voltage Above Normal, or Shorted to Low Source

FAULT CODE 1675

Exhaust Gas Temperature 2 Circuit — Voltage Above Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1675 PID: SPN: 3249 FMI: 3 LAMP: Amber SRT: | Exhaust Gas Temperature 2 Circuit — Voltage Above Normal, or Shorted to Low Source. High signal voltage detected at the catalyst outlet temperature sensor circuit. | Default temperature used for catalyst outlet temperature.
Circuit: Exhaust Gas Temperature 2

Circuit Description

The catalyst outlet temperature sensor is used by the electronic control module (ECM) to monitor the engine exhaust temperature entering the catalyst unit. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The catalyst outlet temperature sensor is located in the aftertreatment system. It is located in the outlet of the aftertreatment catalyst unit.

Shop Talk

Catalyst outlet temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.

On-Board Diagnostics (OBD) Information (Euro 4 Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.

On-Board Diagnostics (OBD) Information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 1 ignition cycle that the diagnostic runs and does not fail. The MIL lamp cannot be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.
Refer to Troubleshooting Fault Code t05-1675

Last Modified: 08-Jul-2010


Exhaust Gas Temperature 2— Data Erratic, Intermittent, or Incorrect

FAULT CODE 1676

Exhaust Gas Temperature 2— Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1676 PID: SPN: 3249 FMI: 2 LAMP: Amber SRT: | Exhaust Gas Temperature 2 — Data Erratic, Intermittent, or Incorrect. The exhaust gas temperature #2 sensor is not changing with engine operating conditions. | Default temperature value used for exhaust gas temperature #2.
Circuit: Exhaust Gas Temperature 2

Circuit Description

The exhaust gas temperature #2 sensor is used by the electronic control module (ECM) to monitor the engine exhaust temperature entering the catalyst unit. The ECM monitors the voltage on the signal pin and converts this to a temperature value. This sensor is also called the catalyst outlet temperature sensor.

Component Location

The exhaust gas temperature #2 sensor is located in the aftertreatment system. It is located between the turbocharger outlet and the catalyst unit outlet in the exhaust system.

Shop Talk

This diagnostic runs when the exhaust gas temperature sensors are compared to other engine temperatures during engine operation. The engine coolant temperature must be above 140°F before the diagnostic will run. If the value of the exhaust gas temperature #2 does not match the engine operating conditions, this fault code is logged.

Possible causes of this fault code include:

  • Stuck in-range exhaust gas temperature #2 sensor
  • High resistance in the exhaust gas temperature #2 sensor signal or return lines.

On-Board Diagnostics (OBD) Information:

  • The ECM illuminates the malfunction indicator lamp (MIL) on the second consecutive ignition cycle that the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.
Refer to Troubleshooting Fault Code t05-1676

Last Modified: 08-Jul-2010


Catalyst Tank Temperature — Voltage Below Normal, or Shorted to Low Source

FAULT CODE 1677

Catalyst Tank Temperature — Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1677 PID: SPN: 3031 FMI: 4 LAMP: Amber SRT: | Catalyst Tank Temperature — Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the catalyst solution temperature sensor circuit. | Default temperature used for catalyst solution temperature.
Circuit: Catalyst Solution Temperature Sensor

Circuit Description

The catalyst solution temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the catalyst solution inside the catalyst tank. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The catalyst solution temperature sensor is located in the catalyst tank. The tank is mounted by the OEM. For more information, contact the OEM service manual.

Shop Talk

The catalyst solution temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 1677, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.

On-Board Diagnostics (OBD) Information (Euro 4 Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.

On-Board Diagnostics (OBD) Information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 1 ignition cycle that the diagnostic runs and does not fail. The MIL lamp cannot be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.
Refer to Troubleshooting Fault Code t05-1677

Last Modified: 08-Jul-2010


Catalyst Tank Temperature — Voltage Above Normal, or Shorted to High Source

FAULT CODE 1678

Catalyst Tank Temperature — Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1678 PID: SPN: 3031 FMI: 3 LAMP: Amber SRT: | Catalyst Tank Temperature — Voltage Above Normal, or Shorted to High Source. High signal voltage or open circuit detected at the catalyst tank temperature sensor circuit | Default temperature value used for catalyst tank temperature.
Circuit: Catalyst Tank Temperature Sensor

Circuit Description

The catalyst solution temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the catalyst solution inside the catalyst tank. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The catalyst solution temperature sensor is located in the catalyst tank. The tank is mounted by the OEM. For more information, contact the OEM service manual.

Shop Talk

The catalyst solution temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • Open signal circuit or shorted to a voltage source.

On-Board Diagnostics (OBD) Information (Euro 4 Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.

On-Board Diagnostics (OBD) Information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 1 ignition cycle that the diagnostic runs and does not fail. The MIL lamp cannot be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.
Refer to Troubleshooting Fault Code t05-1678

Last Modified: 08-Jul-2010


Catalyst Tank Temperature — Data Erratic, Intermittent, or Incorrect

FAULT CODE 1679

Catalyst Tank Temperature — Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1679 PID: SPN: 3031 FMI: 2 LAMP: Amber SRT: | Catalyst Tank Temperature — Data Erratic, Intermittent, or Incorrect. The catalyst solution temperature sensor is not changing with engine operating conditions. | Default temperature value used for catalyst solution temperature.
Circuit: Catalyst Solution Temperature Sensor

Circuit Description

The catalyst solution temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the catalyst solution in the catalyst tank. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The catalyst solution temperature sensor is located in the catalyst tank. The tank is OEM mounted. For more information, contact the OEM service manual.

Shop Talk

This diagnostic runs when the engine has not been running for at least eight hours. The catalyst solution temperature sensor is compared to engine coolant temperature and intake manifold temperature when the key is turned on after the extended eight hour shutdown. This fault code is logged if the reading from the catalyst solution temperature sensor does not match the readings from engine coolant temperature and intake manifold temperature.

Possible causes of this fault code include:

  • Stuck in-range catalyst solution temperature sensor
  • High resistance in the catalyst solution temperature sensor signal or return lines.

On-Board Diagnostics (OBD) Information (Euro 4 and Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) on the second consecutive ignition cycle that the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.
Refer to Troubleshooting Fault Code t05-1679

Last Modified: 08-Jul-2010


Dosing Control Unit — Bad Intelligent Device or Component.

FAULT CODE 1681

Dosing Control Unit — Bad Intelligent Device or Component.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1681 PID: SPN: 3361 FMI: 12 LAMP: Amber SRT: | Catalyst Dosing Control Unit — Bad Intelligent Device or Component. An internal error has been detected in the catalyst dosing control unit. | Catalyst solution injection into the aftertreatment system is disabled.
Circuit: Aftertreatment Control System

Circuit Description

The Dosing Control Unit communicates to the primary engine Electronic Control Module (ECM) through the J1939 datalink network. The dosing control unit precisely measures the amount of catalyst solution to be injected into the aftertreatment system. The dosing control unit has three primary cycles. A priming cycle at initial key on makes sure that catalyst solution is available at the dosing control unit. During the dosing cycle, catalyst solution is being delivered to the aftertreatment nozzle. A purge cycle occurs when the engine is turned off. The purge cycle makes sure that all the catalyst solution is removed from the aftertreatment line and nozzle.

Component Location

The Dosing Control Unit location is OEM dependent.

Shop Talk

Fault code 1681 is triggered when the Dosing Control Unit has detected an internal error. The only troubleshooting that can be done is to recalibrate the engine ECM. If fault code 1681 is still active after the engine ECM has been recalibrated, the Dosing Control Unit will need to be replaced.

On-Board Diagnostics (OBD) Information (Euro 4 Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.

On-Board Diagnostics (OBD) Information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 1 ignition cycle that the diagnostic runs and does not fail. The MIL lamp cannot be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.
Refer to Troubleshooting Fault Code t05-1681

Last Modified: 08-Jul-2010


Aftertreatment Diesel Exhaust Fluid Dosing Control Unit Input Lines - Condition Exists

FAULT CODE 1682

Aftertreatment Diesel Exhaust Fluid Dosing Control Unit Input Lines - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1682 PID: SPN: 3362 FMI: 11/31 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists. An error has been detected by the catalyst dosing control unit. | Diesel exhaust fluid injection into the selective catalyst reduction (SCR) aftertreatment system is disabled.
Aftertreatment Control System Circuit

Circuit Description

For an air-assisted SCR aftertreatment system, the aftertreatment diesel exhaust fluid (Urea) dosing unit requires air pressure from the original equipment manufacturer (OEM) air tanks. The diesel exhaust fluid dosing unit precisely measures the amount of diesel exhaust fluid to be injected into the aftertreatment system. The diesel exhaust fluid dosing unit has three primary cycles. A priming cycle at initial engine start makes sure that diesel exhaust fluid is available at the diesel exhaust fluid dosing unit. During the dosing cycle, the diesel exhaust fluid is being delivered to the aftertreatment nozzle. A purge cycle occurs when the engine is turned off. The purge cycle makes sure that all the diesel exhaust fluid is removed from the diesel exhaust fluid line and aftertreatment nozzle.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is OEM dependent. See equipment manufacturer service information for more information.

Conditions for Running the Diagnostics

This diagnostic consists of multiple parts, which run on engine “Run”. This can take up to 12 minutes. If the Doser Override Test passed after the repair, the repair is considered to be complete.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid dosing unit is not able to provide the correct dosing rate to the aftertreatment nozzle.

Action Taken When the Fault Code is Active

  • The engine control module (ECM) illuminates the amber CHECK ENGINE light and/or the MIL (malfunction indicator lamp) immediately when the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active, if the engine has a nitrogen oxides (NOx) sensor fitted.
  • Diesel exhaust fluid injection into the SCR aftertreatment system is disabled. The dosing unit status in INSITE™ electronic service tool will be OFF.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool while it is active.
  • To validate the repair, it is necessary to use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser Pump Override Test. Refer to Procedure 019-440 in Section 19.
  • Make sure the diesel exhaust fluid dosing unit is able to successfully cycle through all phases (priming, dosing, and purging) and that diesel exhaust fluid flows evenly from the aftertreatment nozzle.
  • The ECM will turn off the amber CHECK ENGINE light and/or MIL immediately after the diagnostic runs and passes (engines with NOx sensors only).
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.
  • The inactive fault code will be cleared from memory automatically after the completion of 9600 hours of operation without a reoccurrence.

Shop Talk

The diesel exhaust fluid dosing unit process consists of three phases, which occur in the following sequence: priming, dosing, and purging.

Priming:

  • The diesel exhaust fluid dosing unit will attempt to prime every 30 seconds for 20 attempts. The attempts can be counted by listening for the air solenoid to click every 30 seconds.
  • The diesel exhaust fluid dosing unit can take up to 12 minutes to complete the priming cycle before a fault code will become active.
  • During priming, the diesel exhaust fluid dosing unit will pump diesel exhaust fluid through the supply and return lines, and back to the tank.
  • Under most conditions, the system will prime within three or four attempts.
  • If priming is not successful, the diesel exhaust fluid dosing unit will be disabled and Fault Code 1682 will be activated.

Dosing:

  • Immediately after successful priming, the system will go into the dosing mode, the solenoid will stop clicking, and a constant flow of air will flow through the aftertreatment nozzle, which helps transport the diesel fluid and keeps the aftertreatment nozzle clear.
  • The air flow will remain constant until the system reaches all dosing conditions before diesel exhaust fluid is delivered to the aftertreatment system (catalyst temperature greater than 200°C [392°F], engine speed and load conditions met, etc.).

Purging:

  • After the engine is stopped and the keyswitch is turned off, the dosing unit enters the purging cycle, which clears any diesel exhaust fluid left in the line and the aftertreatment nozzle after operation.
  • Purging consists of flowing compressed air through the aftertreatment nozzle and diesel exhaust fluid line for 30 seconds.
  • If the full purge time is not completed, it is possible to leave diesel exhaust fluid in the line, leading to a buildup of hard urea crystals, resulting in a blocked diesel exhaust fluid line or aftertreatment nozzle.
  • If the vehicle is equipped with a battery isolation switch, it should have a built-in delay device to prevent power down of the dosing unit until the purge sequence is completed.
  • Incomplete purge events are recorded by the ECM and by increments at the next keyswitch ON event.
  • Incomplete purge counts can be viewed using the Data Monitor/Logger menu in the aftertreatment section of INSITE™ electronic service tool.

Fault Code 1682 is triggered by the following external failure modes:

  • Low aftertreatment diesel exhaust fluid level in the diesel exhaust fluid tank
  • Low air pressure is detected at the dosing control unit
  • Air pressure is cycling below the minimum limit required by the dosing control unit
  • Blocked or restricted aftertreatment nozzle
  • Blocked or restricted/frozen diesel exhaust fluid lines
  • Plugged or restricted inline air filter
  • Plugged or restricted DEF inline filter, if fitted
  • By the operation of the SCR aftertreatment system in environments where the ambient temperature falls below -11 degrees C, without suitable line and tank heating protection.

This can lead to the freezing of the dosing control unit (DCU), and can cause permanent internal damage to the DCU.

Fault Code 1682 is triggered by the following internal diesel exhaust fluid dosing unit failure modes:

  • Diesel exhaust fluid dosing unit does not initialize on keyswitch ON (fault code will be active immediately after keyswitch ON)
  • Buildup of urea crystals in the dosing unit restricts air flow to the aftertreatment nozzle, and possibly leads to buildups and restrictions in the aftertreatment nozzle itself. This results in low/no air flow to the nozzle
  • Internal pressure sensor malfunction - pump does not prime and diesel exhaust fluid is injected as the air solenoid operates during priming. Fault Code 1682 will become active after 12 minutes of consecutive priming attempts
  • Internal poppet valve malfunction, causing priming to not occur. This will cause diesel exhaust fluid to flow continuously during priming (fault code will be active after 12 minutes of unsuccessful priming attempts)
  • Contamination in the dosing unit inlet check valve from an external source, such as the diesel exhaust fluid line or tank
  • Diesel exhaust fluid dosing unit drawing in air through loose or damaged lines or connectors.
Refer to Troubleshooting Fault Code t05-1682

Last Modified: 19-Mar-2018


Catalyst Tank Heater Circuit — Voltage Above Normal, or Shorted to High Source

FAULT CODE 1683

Catalyst Tank Heater Circuit — Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1683 PID: SPN: 3449 FMI: 3 LAMP: Amber SRT: | Catalyst Tank Heater Circuit — Voltage Above Normal, or Shorted to High Source. High signal voltage detected at the catalyst tank heater relay sensor circuit. | Catalyst tank heater will be disabled.
Circuit: Catalyst Tank Heater Relay

Circuit Description

The catalyst tank heater keeps the catalyst solution from freezing in the catalyst tank. The catalyst heater element is powered by the catalyst tank heater relay.

Component Location

The catalyst tank heater is located in the catalyst tank. The location of the catalyst tank heater relays will vary by OEM.

Shop Talk

This fault code cannot detect any circuit failures on the heater side of the relay. Only circuit errors between the ECM and the relay can be detected by this fault code.

Possible causes of this fault code include:

  • Catalyst tank heater relay signal wire not connected to the relay
  • Catalyst tank heater relay return wire not connected to the relay
  • Faulty catalyst tank heater relay
  • Open circuit in the catalyst tank heater relay signal wire
  • Open circuit in the catalyst tank heater relay return wire
  • Catalyst tank heater signal wire shorted to a voltage source.

On-Board Diagnostics (OBD) Information:

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.
Refer to Troubleshooting Fault Code t05-1683

Last Modified: 08-Jul-2010


Catalyst Tank Heater Circuit — Voltage Below Normal, or Shorted to Low Source

FAULT CODE 1684

Catalyst Tank Heater Circuit — Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1684 PID: SPN: 3363 FMI: 4 LAMP: Amber SRT: | Catalyst Tank Heater Circuit — Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the catalyst tank heater relay sensor circuit. | Catalyst tank heater will be disabled.
Circuit: Catalyst Tank Heater Relay

Circuit Description

The catalyst tank heater keeps the catalyst solution from freezing in the catalyst tank. The catalyst tank heater is also used to thaw a frozen catalyst solution tank. The catalyst heater element is powered by the catalyst tank heater relay.

Component Location

The catalyst tank heater is located in the catalyst tank. The location of the catalyst tank heater relays will vary by OEM.

Shop Talk

This fault code cannot detect any circuit failures on the heater side of the relay. Only circuit errors between the ECM and the relay can be detected by this fault code.

Possible causes of this fault code include:

  • A shorted catalyst tank heater relay
  • Catalyst tank heater signal wire shorted to ground.

On-Board Diagnostics (OBD) Information (Euro 4 Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.

On-Board Diagnostics (OBD) Information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 1 ignition cycle that the diagnostic runs and does not fail. The MIL lamp cannot be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.
Refer to Troubleshooting Fault Code t05-1684

Last Modified: 08-Jul-2010


Catalyst Over Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 1687

Catalyst Over Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1687 PID: SPN: 3050 FMI: 0 LAMP: Amber SRT: | Catalyst Over Temperature - Data Valid but Above Normal Operational Range - Most Severe Level. Very high temperatures have been detected in the aftertreatment system. | Catalyst solution injection into the aftertreatment system is disabled.
Circuit: Aftertreatment Control System

Circuit Description

The Exhaust Gas Temperature Number 2 sensor is used by the ECM to monitor the engine exhaust gas temperature exiting the catalyst unit. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The catalyst exhaust gas temperature sensor is located in the aftertreatment system. It is located at the outlet of the catalyst exhaust system.

Shop Talk

This fault is triggered when the temperature at the catalyst exhaust outlet exceeds the maximum allowable temperature for a given engine rating.

On-Board Diagnostic (OBD) Information:

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared with INSITE™ electronic service tool.
  • The fault code will be cleared from the memory after 40 consecutive drive cycles when the diagnostic runs and passes.
Refer to Troubleshooting Fault Code t05-1687

Last Modified: 08-Jul-2010


Real-Time Clock Power Interrupt - Data Erratic, Intermittent or Incorrect

FAULT CODE 1689

Real-Time Clock Power Interrupt - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1689 PID: P251 SPN: 251 FMI: 12/2 LAMP: Amber SRT: | Real-Time Clock Power Interrupt - Data Erratic, Intermittent or Incorrect. The Real-Time clock power has been interrupted. | None on performance. Data in the ECM will not have accurate time and date information.
Real-Time Clock Power Circuit

Circuit Description

Under ordinary operating conditions, the real-time clock in the electronic control module (ECM) is powered by the vehicle's batteries. If battery power to the ECM is lost, then the real-time clock will be powered by a battery in the engine harness (if equipped).

Component Location

The real-time clock battery is secured to the engine harness near the ECM. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Shop Talk

This fault indicates that the real-time clock in the ECM lost power. Possible causes for this fault are weak or failed real-time clock battery, failed wiring or connectors between the battery and ECM, or the engine is not equipped with a real-time clock battery and the vehicle battery power to the ECM is lost.

NOTE:If the Real Time Clock is supplied by the OEM via a CAN BUS and a battery backup is not used, then refer to the OEM wiring diagram. If this is the case, then` check INSITE™ electronic service tool, “Advanced ECM Data - Real Time Clock Settings.” If the OEM supplies a Real Time Clock signal, then the address must be set according to the OEM wiring or the fault code will become active.

On-Board Diagnostics (OBD) Information (Euro 4 Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The malfunction indicator lamp and fault code can also be cleared using the INSITE™ electronic service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.

On-Board Diagnostics (OBD) Information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 1 ignition cycle that the diagnostic runs and does not fail. The malfunction indicator lamp and fault code can also be cleared using the INSITE™ electronic service tool.
  • The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.
Refer to Troubleshooting Fault Code t05-1689

Last Modified: 08-Jul-2010


Aftertreatment Outlet NOx Sensor - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 1692

Aftertreatment Outlet NOx Sensor - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1692 PID: SPN: 3234 FMI: 4 LAMP: Amber SRT: | Aftertreatment NOx Sensor - Voltage Below Normal, or Shorted to Low Source. Out-of-range battery voltage has been detected by the aftertreatment outlet NOx sensor. | Aftertreatment outlet NOx sensor operation will be disabled. Engine will derate after running 50 hours with the fault active.
Circuit: Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet nitrogen oxides (NOx) sensor is a smart device and receives commands from the engine electronic control module (ECM) via the J1939 datalink. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 datalink. The NOx sensor is permanently attached to the NOx control module. They are serviced as single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the outlet NOx emissions from the engine.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the aftertreatment catalyst.

Shop Talk

The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually.

Possible causes of this fault code include:

  • The voltage supplied to the aftertreatment outlet NOx sensor is below + 18-VDC
  • The voltage supplied to the aftertreatment outlet NOx sensor is above + 32-VDC
  • The aftertreatment outlet NOx sensor has malfunctioned or is damaged
  • The aftertreatment outlet NOx sensor internal heater has malfunctioned
  • The NOx sensor part number is incorrect.

On-Board Diagnostics (OBD) information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 1 ignition cycle that the diagnostic runs and does not fail. The MIL lamp cannot be cleared using INSITE™ electronic service tool.
  • The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.
Refer to Troubleshooting Fault Code t05-1692

Last Modified: 08-Jul-2010


Aftertreatment Outlet NOx Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1694

Aftertreatment Outlet NOx Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1694 PID: SPN: 3234 FMI: 2 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor - Data Erratic, Intermittent, or Incorrect. An incorrect NOx sensor reading has been detected by the aftertreatment outlet NOx sensor. | Aftertreatment outlet NOx sensor operation will be disabled. Engine will derate after running 50 hours with the fault code active.
Circuit: Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet nitrogen oxides (NOx) sensor is a smart device and receives commands from the engine electronic control module (ECM) via the J1939 datalink. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 datalink. The NOx sensor is permanently attached to the NOx control module. They are serviced as single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the outlet NOx emissions from the engine.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the aftertreatment catalyst.

Shop Talk

On-Board Diagnostics (OBD) information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) on the second consecutive ignition cycle that the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 1 ignition cycle that the diagnostic runs and does not fail. The MIL lamp cannot be cleared using the INSITE™ electronic service tool.
  • The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.

The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually.

Possible causes of this fault code include:

  • The ECM has detected that the NOx reading is higher or lower than is possible from the engine output.
  • Exhaust system leaks.
  • An incorrectly installed aftertreatment outlet NOx sensor.
  • An aftertreatment outlet NOx sensor that has carbon buildup on the tip of the sensor.
  • Excessive oil consumption.
  • Possible engine misfire
  • The NOx sensor part number is incorrect.
Refer to Troubleshooting Fault Code t05-1694

Last Modified: 08-Jul-2010


Aftertreatment #1 Air Enable Actuator — Voltage Above Normal, or Shorted to High Source.

FAULT CODE 1697

Aftertreatment #1 Air Enable Actuator — Voltage Above Normal, or Shorted to High Source.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1697 PID: SPN: 3489 FMI: 3 LAMP: Amber SRT: | Aftertreatment #1 Air Enable Actuator — Voltage Above Normal, or Shorted to High Source. High signal voltage has been detected at the catalyst air solenoid circuit. | Catalyst solution injection into the aftertreatment system is disabled.
Circuit: Aftertreatment #1 Air Enable Actuator

Circuit Description

The aftertreatment #1 air solenoid is used to enable and disable the truck air supply to the dosing control unit. The air is used to transport the catalyst solution to the catalyst nozzle.

Component Location

The aftertreatment #1 air solenoid is mounted to the back of the dosing control unit. The dosing control unit is OEM mounted.

Shop Talk

This fault code is logged when the supply voltage to the air solenoid is greater than +12 volts.

Possible causes of this fault code include:

  • Air solenoid signal wire shorted to a voltage supply
  • Failed dosing control unit.

On-Board Diagnostics (OBD) Information (Euro 4 Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.

On-Board Diagnostics (OBD) Information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 1 ignition cycle that the diagnostic runs and does not fail. The MIL lamp cannot be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.
Refer to Troubleshooting Fault Code t05-1697

Last Modified: 08-Jul-2010


Aftertreatment #1 Air Enable Actuator — Voltage Below Normal, or Shorted to Low Source.

FAULT CODE 1698

Aftertreatment #1 Air Enable Actuator — Voltage Below Normal, or Shorted to Low Source.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1698 PID: SPN: 3489 FMI: 4 LAMP: Amber SRT: | Aftertreatment #1 Air Enable Actuator — Voltage Below Normal, or Shorted to Low Source. Low signal voltage has been detected at the catalyst air solenoid circuit. | Catalyst solution injection into the aftertreatment system is disabled.
Circuit:

Circuit Description

The aftertreatment #1 air solenoid is used to enable and disable the truck air supply to the dosing control unit. The air is used to transport the catalyst solution to the catalyst nozzle.

Component Location

The aftertreatment #1 air solenoid is mounted to the back of the dosing control unit. The dosing control unit is OEM mounted.

Shop Talk

This fault code is logged when the supply voltage to the air solenoid is less than +12 volts.

Possible causes of this fault code include:

  • Open circuit in the air solenoid signal wire
  • Open circuit in the air solenoid return wire
  • Shorted to pin to pin air solenoid signal wire
  • Failed air solenoid
  • Failed dosing control unit.

On-Board Diagnostics (OBD) Information (Euro 4 Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.

On-Board Diagnostics (OBD) Information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 1 ignition cycle that the diagnostic runs and does not fail. The MIL lamp cannot be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.
Refer to Troubleshooting Fault Code t05-1698

Last Modified: 08-Jul-2010


Catalyst Tank Level Sensor — Data Erratic, Intermittent, or Incorrect.

FAULT CODE 1699

Catalyst Tank Level Sensor — Data Erratic, Intermittent, or Incorrect.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1699 PID: SPN: 1761 FMI: 2 LAMP: Amber SRT: | Catalyst Tank Level Sensor - Data Erratic, Intermittent, or Incorrect. Catalyst solution level is not changing with engine operating conditions. | Catalyst solution injection into the aftertreatment system is disabled.
Catalyst Tank Level Sensor Circuit

Circuit Description

The catalyst tank level sensor is located in the catalyst tank. Location of the tank and level sensor is OEM dependent.

Component Location

The catalyst solution tank location is OEM dependent.

Shop Talk

This fault code is triggered when the catalyst solution level reading in the catalyst tank does not change with engine operating conditions. If the catalyst dosing control unit indicates that catalyst injection has occurred, but the catalyst tank level has not changed, this fault code will be triggered. This fault will also be triggered if catalyst injection has not occurred, but a drop in the level of the catalyst solution has been detected.

Use INSITE™ electronic service tool to make sure the adjustable parameter Linear Urea Tank Volume is adjusted correctly. This fault code can trigger if this parameter is not adjusted for the correct urea tank volume.

Possible causes of this fault code include:

  • Malfunctioning catalyst tank level sensor
  • Plugged or restricted catalyst solution lines
  • Plugged or restricted aftertreatment nozzle
  • External leaks in the catalyst tank or catalyst solution lines
  • Catalyst tank level sensor tampering.

On-Board Diagnostics (OBD) Information:

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails
  • The ECM turns off the malfunction indicator lamp (MIL) when the diagnostic runs and passes. The diagnostic requires a quantity of diesel exhaust fluid (DEF) to be dosed. Depending on the application and system configuration, this may be up to 3 liters (3.17 qt). The MIL and fault code can also be cleared using INSITE™ electronic service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.
Refer to Troubleshooting Fault Code t05-1699.

Last Modified: 07-Mar-2012


Dosing Control Unit Data Link — Abnormal Update Rate

FAULT CODE 1711

Dosing Control Unit Data Link — Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1711 PID: SPN: 3361 FMI: 9 LAMP: Amber SRT: | Dosing Control Unit Data Link — Abnormal Update Rate. Data Link communications between the ECM and the Dosing Control Unit have been interrupted. | Catalyst solution injection into the aftertreatment system is disabled.
Circuit: Dosing Control Unit

Circuit Description

The catalyst dosing unit communicates to the primary engine Electronic Control Module (ECM) through the J1939 public data link network. The Dosing Control Unit also receives battery supply, keyswitch input, and ground from the OEM vehicle.

Component Location

The Dosing Control Unit location is OEM dependent. Refer to the OEM troubleshooting manual for more information.

Shop Talk

Possible causes of this fault code include:

  • Loss of battery voltage to the Dosing Control Unit
  • Loss of battery ground to the Dosing Control Unit
  • Loss of keyswitch input to the Dosing Control Unit
  • Shorted or open J1939 data link wiring between the Dosing Control Unit and the primary engine ECM
  • Failed Dosing Control Unit
  • The external OEM controlling device has failed or can no longer transmit on the data link.

On-Board Diagnostics (OBD) Information (Euro 4 Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ Electronic service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.

On-Board Diagnostics (OBD) Information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 1 ignition cycle that the diagnostic runs and does not fail. The MIL lamp cannot be cleared using the INSITE™ Electronic service tool.
  • The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.
Refer to Troubleshooting Fault Code t05-1711

Last Modified: 08-Jul-2010


Catalyst Tank Heater Circuit — Data Valid But Below Normal Operating Range — Moderately Severe Level

FAULT CODE 1712

Catalyst Tank Heater Circuit — Data Valid But Below Normal Operating Range — Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1712 PID: SPN: 3363 FMI: 1/18 LAMP: Amber SRT: | Catalyst Tank Heater Circuit — Data Valid But Below Normal Operating Range — Moderately Severe Level. The catalyst solution temperature did not increase when the catalyst tank heater was commanded on. | None on performance. Catalyst solution injection into the aftertreatment system may be disabled if the catalyst solution is frozen.
Circuit: Catalyst Tank Heater Relay

Circuit Description

The catalyst tank heater keeps the catalyst solution from freezing in the catalyst tank. The catalyst heater element is powered by the catalyst tank heater relay.

Component Location

The catalyst tank heater is located in the catalyst tank. The location of the catalyst tank heater relays will vary by OEM. Refer to Refer to Procedure Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Shop Talk

This fault code is triggered when the catalyst tank heater is commanded on by the engine ECM, but no corresponding temperature increase in the catalyst tank temperature was recorded by the catalyst temperature sensor.

Possible causes of this fault code include:

  • Failed catalyst tank heater relay
  • Faulty power supply to the catalyst tank heater
  • Faulty ground circuit to the catalyst tank heater
  • Faulty wiring between the catalyst tank heater relay and the catalyst tank heater
  • Failed catalyst tank heater.

On-Board Diagnostics (OBD) Information (Euro 4 Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.

On-Board Diagnostics (OBD) Information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 1 ignition cycle that the diagnostic runs and does not fail. The MIL lamp cannot be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.
Refer to Troubleshooting Fault Code t05-1712

Last Modified: 08-Jul-2010


Catalyst Tank Heater Circuit - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1713

Catalyst Tank Heater Circuit - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1713 PID: SPN: 3363 FMI: 0/16 LAMP: Amber SRT: | Catalyst Tank Heater Circuit - Data Valid But Above Normal Operating Range - Moderately Severe Level. The catalyst tank heater is continuously in the on position. | None on performance.
Circuit: Catalyst Tank Heater Relay

Circuit Description

The catalyst tank heater keeps the catalyst solution from freezing in the catalyst tank. The catalyst heater element is powered through the catalyst tank heater relay. The tank heater is activated once the temperature recorded by the OEM tank temperature/level sensor is below a temperature threshold.

Component Location

The catalyst tank heater is located in the catalyst tank. The location of the catalyst tank heater relays will vary by OEM.

Shop Talk

This fault code is triggered when the catalyst tank heater is determined to be in the on position when the engine ECM is commanding the heater to be in the off position. To determin if the temperature sensors are reading a sensible value, they can be compared to each other at keyswitch ON, after an 8-hour period with the engine not running. At this point, the engine TMAP sensor should display a similar temperature to the tank. For example: ambient air temperature.

Possible causes of this fault code include:

  • Damaged catalyst solution OEM tank temperature/level sensor
  • Damaged catalyst solution tank heater relay
  • Failed ECM that is commanding the heater on continuously.

On-Board Diagnostics (OBD) Information:

  • The ECM illuminates the appropriate amber or red fault code lamp when the diagnostic runs and fails
  • The ECM turns OFF the appropriate fault lamp when the diagnostic runs and passes.
Refer to Troubleshooting Fault Code t05-1713

Last Modified: 08-Jul-2010


Auxiliary Temperature Sensor Input 1 Circuit - Root Cause Not Known

FAULT CODE 1716

Auxiliary Temperature Sensor Input 1 Circuit - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1716 PID: SPN: 411 FMI: 11 LAMP: None SRT: | Auxiliary Temperature Sensor Input 1 Circuit - Root Cause Not Known. High temperature detected by the OEM temperature sensor or by the engine coolant temperature sensor. | Possible engine power derate.
OEM Temperature/Pressure Sensor Circuit

Circuit Description

The OEM has the option of wiring a temperature sensor input to the Cummins® ECM. A specific calibration is then created to recognize this temperature sensor input. This fault code is activated when the temperature input from the OEM sensor exceeds the engine protection limit defined by the OEM. Depending on OEM requirements, an Engine Protection derate may be associated with this fault code. This fault code can also be used to indicate high engine coolant temperature on certain applications.

Component Location

The OEM pressure or temperature sensor input will vary depending on application. Refer to the OEM troubleshooting manual for sensor location. The engine coolant temperature sensor is located on the thermostat housing. Refer to Refer to Procedure Procedure 100-002 (Engine Diagrams), in Section E for a detailed component location view.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature. Refer to Engine Coolant Temperature Above Normal symptom troubleshooting tree.

On-Board Diagnostics (OBD) information:

  • The ECM illuminates the appropriate amber or red fault lamp when the diagnostic runs and fails
  • The ECM turns off the appropriate fault lamp when the diagnostic runs and passes.
Refer to Troubleshooting Fault Code t05-1716

Last Modified: 08-Jul-2010


Exhaust Gas Temperature 1 — Data Valid but Above Normal Operational Range — Least Severe Level

FAULT CODE 1717

Exhaust Gas Temperature 1 — Data Valid but Above Normal Operational Range — Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1717 PID: SPN: 3241 FMI: 0/15 LAMP: None SRT: | Exhaust Gas Temperature 1 — Data Valid but Above Normal Operational Range — Least Severe Level. High catalyst inlet temperature has been detected. | Possible engine derate.
Circuit: Exhaust Gas Temperature 1

Circuit Description

The exhaust gas temperature #1 sensor is used by the electronic control module (ECM) to monitor the engine exhaust temperature entering the catalyst unit. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The exhaust gas temperature #1 sensor is located in the aftertreatment system. It is located between the turbocharger outlet and the catalyst unit inlet in the exhaust system.

Shop Talk

This fault is triggered when the temperature at the catalyst inlet exceeds the maximum allowable temperature for a given engine rating. Leaks in the charge air system or a faulty turbocharger can cause high exhaust gas temperature.

On-Board Diagnostics (OBD) Information:

  • The ECM illuminates the appropriate amber or red fault lamp when the diagnostic runs and fails.
  • The ECM turns OFF the appropriate fault lamp when the diagnostic runs and passes.
Refer to Troubleshooting Fault Code t05-1717

Last Modified: 08-Jul-2010


Engine Misfire for Multiple Cylinders — Condition Exists.

FAULT CODE 1718

Engine Misfire for Multiple Cylinders — Condition Exists.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1718 PID: SPN: 1322 FMI: 11/31 LAMP: Amber SRT: | Engine Misfire for Multiple Cylinders — Condition Exists. Engine misfire has been detected in multiple cylinder numbers. | Possible low power, rough idle, or misfire.
Circuit

Circuit Description

An algorithm in the ECM calibration monitors engine speed as each injector fires while the engine is at idle. If a cylinder has high or low contribution to engine speed, this fault will become active. The intention of this fault is to assist in troubleshooting performance complaints such as engine misfire and low power.

Component Location

The ECM is located on the intake side of the engine. 100-002 (Engine Diagrams) in section E for a detailed component location view.

Shop Talk

If Fault Code 1718 is inactive in the ECM memory and there is no complaint such as “low power” or “engine misfire”, it is possible that an intermittent event such as air entering the fuel system following a filter change caused the fault. Inactive counts of Fault Code 1718 should be disregarded unless other performance symptoms are present. The engine coolant temperature must be greater than 160°F before this diagnostic will run.

Causes of cylinder misfire can include:

  • Valve lash out of specification (compare actual valve lash to reset limits)
  • Cylinder failure (check for high blowby when the engine is loaded)
  • Valve failure or valve held open (listen for intake valve “chirping” noise in the intake)
  • Cylinder head or gasket failure (look for signs of oil, coolant, or casting flash in the intake or exhaust passages)
  • Extreme camshaft wear (inspect the camshaft lobes for wear)
  • Extra, missing, or damaged sealing washer under an injector
  • Injector failures (“swap” injectors to see if the problem “follows” the indicated injector).

On-Board Diagnostic (OBD) Information:

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ service tool
  • The fault code will be cleared from the memory after 40 consecutive drive cycles when the diagnostic runs and passes.
Refer to Troubleshooting Fault Code t05-1718

Last Modified: 08-Jul-2010


Water-in-Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source (For Generator Engines Only)

FAULT CODE 1845

Water-in-Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source (For Generator Engines Only)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1845 PID: SPN: 97 FMI: 3 LAMP: Maintenance SRT: | Water-in-Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source (For Generator Engines Only). High voltage detected at the water-in-fuel indicator circuit. | None on performance. No water-in-fuel warning available.
Water-in-Fuel Indicator Sensor Circuit - Power Generation
Water-in-Fuel Indicator Sensor Circuit - Marine

Circuit Description

The water-in-fuel indicator sensor is attached to the first stage fuel filter. The water-in-fuel indicator sensor sends a signal to the electronic control module (ECM) when a set volume of water has accumulated in the fuel filter. The water-in-fuel indicator sensor circuit contains two wires: A water-in-fuel indicator RETURN (sensor return 1) ground wire and a water-in-fuel indicator SIGNAL wire.

Component Location

The water-in-fuel indicator sensor is integrated into the bottom of the suction fuel filter. The first stage fuel filter is located on the intake side of the engine.

Shop Talk

The water-in-fuel sensor is located in the Stage 1 filter housing. It is a serviceable part.

Possible causes of this fault code include:

  • Open return or signal circuit in the harness, connectors, or sensor.
  • SIGNAL wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-1845.

Last Modified: 21-Dec-2010


Water-in-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source (For Generator Engines Only)

FAULT CODE 1846

Water-in-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source (For Generator Engines Only)

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1846 PID: SPN: 97 FMI: 4 LAMP: Maintenance SRT: | Water-in-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source (For Generator Engines Only). Low voltage detected at the water-in-fuel indicator circuit. | None on performance. No water-in-fuel warning available.
Water-in-Fuel Indicator Sensor Circuit - Power Generation
Water-in-Fuel Indicator Sensor Circuit - Marine

Circuit Description

The water-in-fuel indicator sensor is attached to the first stage fuel filter. The water-in-fuel indicator sensor sends a signal to the electronic control module (ECM) when a set volume of water has accumulated in the fuel filter. The water-in-fuel indicator sensor circuit contains two wires: A water-in-fuel indicator RETURN (sensor return 1) ground wire and a water-in-fuel indicator SIGNAL wire.

Component Location

The water-in-fuel indicator sensor is integrated into the bottom of the suction fuel filter. The first stage fuel filter is located on the intake side of the engine.

Shop Talk

The water-in-fuel sensor is located in the Stage 1 filter housing. It is a serviceable part.

Possible causes of this fault code include:

  • SIGNAL circuit shorted to ground in the harness, sensor, or connector.
Refer to Troubleshooting Fault Code t05-1846.

Last Modified: 21-Dec-2010


Intake Manifold 1 Temperature — Abnormal Rate of Change

FAULT CODE 1848

Intake Manifold 1 Temperature — Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1848 PID: P105 SPN: 105 FMI: 10 LAMP: Amber SRT: | The intake manifold temperature sensor is not responding to a change in engine operating conditions. | Possible reduced engine performance.
Circuit: Intake Manifold 1 Temperature
Intake Manifold Pressure/Temperature Sensor

Circuit Description

The engine intake manifold temperature sensor is used by the electronic control module (ECM) to monitor the engine intake manifold temperature. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

The engine intake manifold temperature value is used by the ECM for the engine protection system and engine emission control.

Component Location

The engine intake manifold temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake manifold temperature sensor reading was higher or lower than the other temperature sensors on the engine after an extended period of engine OFF time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged intake manifold temperature sensor.
  • Malfunctioning or damaged engine wiring harness.
Refer to Troubleshooting Fault Code t05-1848

Last Modified: 18-Apr-2022


Exhaust Gas Temperature 1 — Abnormal Rate of Change

FAULT CODE 1849

Exhaust Gas Temperature 1 — Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1849 PID: SPN: 3241 FMI: 10 LAMP: Amber SRT: | Exhaust Gas Temperature 1 — Abnormal Rate of Change. The catalyst inlet temperature sensor is not responding to a change in engine operating conditions. | Default temperature value used for catalyst inlet temperature.
Circuit: Exhaust Gas Temperature 1

Circuit Description

The exhaust gas temperature #1 sensor is used by the electronic control module (ECM) to monitor the engine exhaust temperature entering the catalyst unit. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The catalyst inlet temperature #1 sensor is located in the aftertreatment system. It is located between the turbocharger outlet and the catalyst unit inlet in the exhaust system.

Shop Talk

The exhaust gas temperature 1 is monitored during engine warm-up. If the exhaust gas temperature 1 reading is not changing to match the engine operating conditions, the exhaust gas temperature 1 sensor is then determined to be stuck in-range and this fault code is logged. The ECM must not see engine speed for a period of eight hours before this diagnostic will run.

Possible causes of this fault code include:

  • Stuck in-range exhaust gas temperature #1 sensor reading.
  • High resistance in the exhaust gas temperature #1 sensor signal or return lines.

On-Board Diagnostics (OBD) Information (Euro 4 and Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) on the second consecutive ignition cycle that the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.
Refer to Troubleshooting Fault Code t05-1849

Last Modified: 08-Jul-2010


Exhaust Gas Temperature 2 — Abnormal Rate of Change

FAULT CODE 1851

Exhaust Gas Temperature 2 — Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1851 PID: SPN: 3249 FMI: 10 LAMP: Amber SRT: | Exhaust Gas Temperature 2 — Abnormal Rate of Change. The catalyst outlet temperature sensor is not responding to a change in engine operating conditions. | Default temperature value used for catalyst outlet temperature.
Circuit: Exhaust Gas Temperature 2

Circuit Description

The exhaust gas temperature #2 sensor is used by the electronic control module (ECM) to monitor the engine exhaust temperature entering the catalyst unit. The ECM monitors the voltage on the signal pin and converts this to a temperature value.

Component Location

The catalyst inlet temperature #2 sensor is located in the aftertreatment system. It is located between the turbocharger exhaust and the catalyst unit exhaust in the exhaust system.

Shop Talk

The exhaust gas temperature #2 is monitored during engine warm-up. If the exhaust gas temperature 2 reading is not changing to match the engine operating conditions, the exhaust gas temperature 2 sensor is then determined to be stuck in-range and this fault code is logged. The ECM must not see engine speed for a period of eight hours before this diagnostic will run.

Possible causes of this fault code include:

  • Stuck in-range exhaust gas temperature #2 sensor reading
  • High resistance in the exhaust gas temperature #2 sensor signal or return lines.

On-Board Diagnostics (OBD) Information (Euro 4 and Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) on the second consecutive ignition cycle that the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.
Refer to Troubleshooting Fault Code t05-1851

Last Modified: 08-Jul-2010


Fault Code Path Selection

FAULT CODE 06-fc187
Fault Code Path Selection

Is the engine an ISB/QSB Automotive or Industrial application, or a ISC/QSC/ISL/QSL Automotive, Industrial, or Marine application? | Go to 06-fc187b
Is the engine a QSB Marine application? | Go to 06-fc187bm

Last Modified: 07-Apr-2005


Sensor Supply Voltage Number 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 187 (ISB/QSB Automotive and Industrial, ISC/QSC/ISL/QSL Automotive, Industrial, and Marine)

Sensor Supply Voltage Number 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 PID: S232 SPN: 1080 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply Voltage Number 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the sensor supply number 2 circuit. | Automotive: Engine power derate. Marine: None - No engine protection for circuit or sensor failure.
Original Wiring Harness - Sensor Supply Number 2 Circuit
Revised Wiring Harness - Sensor Supply Number 2 Circuit

Circuit Description

The sensor supply number 2 pin of the electronic control module (ECM) provides +5 VDC for the camshaft engine position sensor, intake manifold pressure sensor, and rail fuel pressure sensor.

Component Location

The sensor supply number 2 is located in the ECM.

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Low voltage on the +5-VDC SUPPLY line can be caused by a short circuit to ground in a SUPPLY line, a short circuit between a SUPPLY line or a RETURN line, a malfunctioning sensor, or a malfunctioning ECM power supply.

On-Board Diagnostics (OBD) Information (Euro 4 Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • The ECM turns OFF the MIL after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using INSITE™ electronic service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.

OBD Information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the MIL when the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • The ECM turns OFF the MIL after one ignition cycle that the diagnostic runs and passes. The MIL lamp cannot be cleared using INSITE™ electronic service tool.
  • The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.

OBD Information (Euro 4 Stage 1 + Certified Engines):

  • The ECM illuminates the MIL when the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • The ECM turns OFF the MIL after one ignition cycle that the diagnostic runs and passes. The MIL lamp can not be cleared using INSITE™ electronic service tool.
  • The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.

The sensor return configuration for Euro 4 ISB engines has been changed for automotive wiring harnesses manufactured from February 2012 onward. The new style wiring harnesses can be be identified using the method below:

  • Disconnect the ECM connector
  • Disconnect the camshaft position sensor
  • Disconnect the intake manifold pressure/temperature sensor
  • Check for continuity between the intake manifold pressure/temperature sensor RETURN pin and the camshaft position sensor RETURN pin
  • Check for continuity between ECM pin 47 and the camshaft position sensor RETURN pin
  • Use the table below to determine which harness is fitted to the engine.

Engine Harnesses
From | To | New Harness | Old Harness
Intake manifold pressure/temperature sensor RETURN pin | Camshaft position sensor RETURN pin | Open circuit | Short circut
ECM pin 47 | Camshaft position sensor RETURN pin | Open circuit | Short circuit

NOTE: QSB engines, all C series engines, and all L series engines are not affected by this change.

Refer to Troubleshooting Fault Code t05-187.

Last Modified: 02-Feb-2012


Sensor Supply 2 Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 187 (QSB Marine Application)

Sensor Supply 2 Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 PID: S232 SPN: 1080 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Below Normal, or Shorted to Low Source. Low voltage detected at the sensor supply number 2 circuit. | Marine: None, no engine protection for circuit or sensor failure.
Sensor Supply Number 2 Circuit

Circuit Description

The sensor supply number 2 pin of the electronic control module (ECM) provides +5 VDC for the intake manifold pressure sensor, and rail fuel pressure sensor.

Component Location

The sensor supply number 2 is located in the ECM.

Refer to Procedure 100-002 for a detailed component location view of each sensor.

Shop Talk

Low voltage on the +5-VDC supply line can be caused by a short circuit to ground in a supply line, a short circuit between a supply line or a return line, a failed sensor, or a failed ECM power supply.

Refer to Troubleshooting Fault Code t05-187

Last Modified: 08-Jul-2010


Wheel-Based Vehicle Speed — Data Valid but Below Normal Operational Range — Moderately Severe Level

FAULT CODE 1892

Wheel-Based Vehicle Speed — Data Valid but Below Normal Operational Range — Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1892 PID: P84 SPN: 84 FMI: 1/18 LAMP: Amber SRT: | Wheel-Based Vehicle Speed — Data Valid but Below Normal Operational Range — Moderately Severe Level. The ECM lost the vehicle speed signal. | Engine speed limited to Maximum Engine Speed without VSS parameter value. Cruise control, Gear-Down Protection, and Road Speed Governor will not work.
Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle's transmission. This speed signal is then transmitted to the engine electronic control module (ECM) and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle transmission. Refer to the OEM troubleshooting and repair manual.

Shop Talk

There are multiple types of vehicle speed sensors. Various types include magnetic pickup, data link, digital, and tachograph. Refer to your OEM for the specific type installed on the vehicle.

This fault is set active when the ECM loses a vehicle speed signal when other engine conditions indicate the vehicle is moving. The fault can also become active if there is a series of clutch, service brake or throttle movements with no vehicle movement. The fault is set inactive when the ECM receives a vehicle speed signal greater than zero.

Since the vehicle speed sensor is an OEM installed component, this troubleshooting procedure will not catch all failures of the circuit due to components not under Cummins Inc. control. Sensor resistance values, data link speed sensors and tachographs are not fully covered under this procedure. For more information on those components, please refer to the OEM troubleshooting and repair manual.

On-Board Diagnostics (OBD) Information:

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.
Refer to Troubleshooting Fault Code t05-1892

Last Modified: 08-Jul-2010


Injector Metering Rail Number 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 1911

Injector Metering Rail Number 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1911 PID: P157 SPN: 157 FMI: 0 LAMP: Amber SRT: | Injector Metering Rail Number 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level. Fuel pressure signal indicates that fuel pressure has exceeded the maximum limit for the given engine rating. | None, or possible engine noise associated with higher injection pressure (especially at idle or light load). Engine power is reduced.
Fuel System

Circuit Description

The electronic control module (ECM) monitors engine-operating conditions, including the reading of rail fuel pressure, and changes the flow command to either increase (OPEN the fuel pump actuator) or decrease (CLOSE the fuel pump actuator) the fuel supply to the high-pressure pump.

Component Location

The fuel pump actuator is installed on the high-pressure fuel pump.

Shop Talk

Fault Code 1911 is activated when the sensed rail fuel pressure reaches the opening pressure of the rail fuel pressure relief valve. Sensed pressure has exceeded system target range.

In normal engine operation, the ECM calibration varies the flow commanded to the fuel pump actuator to achieve the correct fuel rail pressure. System issues that result in a loss of pressure control can cause the rail pressure to exceed the normal operating pressures and open the pressure relief valve. If the ECM detects that the fuel rail pressure relief valve is open without detection of a fuel pump actuator circuit error, Fault Code 1911 will become active. On certain applications, the ECM will attempt to reset automatically causing a momentary loss of power for less than 1 second.

Conditions that can cause Fault Code 1911:

  • Purging air through the fuel system can cause a pressure overshoot, therefore causing Fault Code 1911 to log. A few bubbles exiting the line during the air in fuel test is expected. A foamy appearance is an indication of a leak that allows air to enter, a severe inlet restriction that causes cavitation, or a system that is not yet primed. If fuel inlet restriction is not excessive, the source of air entry should be isolated to one of the following: Suction fuel lines, OEM fuel lines, suction-side fuel filter assemblies, or stand-pipe(s) in the fuel tank(s).
  • Sustained periods of very low pressure under load are followed by pressure recovery overshoot. This can be caused by high restriction due to plugged filters (Fault Code 559), a tampered fuel pressure sensor that reads low, a biased pressure sensor, or a poor electrical connection.
  • If an intermittent electrical circuit problem with the fuel pump actuator circuit exists, it is possible for Fault Code 1911 to become active, then inactive during normal engine operation. ECM Fault Code 2311 is designed to detect electrical circuit issues with the actuator. Therefore, it is only necessary to inspect for bad connectors or harness issues for Fault Code 1911 if no other fault codes exist. An electric fuel control actuator with excessive leakage will result in high rail fuel pressures at idle or light load.
  • Other conditions include ECM wiring harness issues such as poor grounds, battery voltage spikes, electrical noise, low alternator output, and large disturbances of battery voltage, as when jump-starting the vehicle.
  • The fuel rail pressure sensor should also be checked. When checking the fuel rail pressure sensor accuracy, make sure the high-pressure fuel rail is not pressurized. The fuel pump, high-pressure fuel lines, and fuel rail contain very high-pressure fuel. Do not loosen any fittings while the engine is operating. Wait at least 10 minutes after shutting down the engine before loosening any fittings in the high-pressure fuel system to allow pressure to decrease to a lower level. There could be a significant amount of time waiting for the rail to depressurize to zero on some engines. In such cases, it may be necessary to manually relieve the pressure from the high-pressure fuel rail.
Refer to Troubleshooting Fault Code 1911.

Last Modified: 04-Nov-2010


Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 195 - Two Wire Sensor

Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 195 PID: P111 SPN: 111 FMI: 3/3 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at engine coolant level circuit. | Automotive: None on performance. Marine: None, no engine protection for circuit or sensor failure.
Engine Coolant Level Sensor Circuit

Circuit Description

The engine coolant level sensor monitors the engine coolant level within the coolant system and passes information to the electronic control module (ECM) through the OEM harness.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank, for marine engines, it is located in the expansion tank. Refer to the OEM troubleshooting and repair manual for location.

Shop Talk

Possible causes of this fault code include:

  • Open return or signal circuit in the harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-195

Last Modified: 08-Jul-2010


Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 195 - Three Wire Sensor

Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 195 PID: P111 SPN: 111 FMI: 3/3 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at engine coolant level circuit. | None on performance.
Engine Coolant Level Sensor 1 Circuit

Circuit Description

The electronic control module (ECM) supplies a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM troubleshooting and repair manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position, or when the engine is running.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level signal voltage is greater than 4.5-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage
  • Sensor supply circuit shorted to battery voltage.
Refer to Troubleshooting Fault Code t05-195

Last Modified: 08-Jul-2010


Fault Code Path Selection

FAULT CODE 06-fc195
Fault Code Path Selection

Is the coolant level sensor a 2-wire sensor? | Go to 06-fc195-2wire
Is the coolant level sensor a 3-wire sensor? | Go to 06-fc195-3wire

Last Modified: 19-Feb-2007


Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 196 - Two Wire Sensor

Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 196 PID: P111 SPN: 111 FMI: 4/4 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the engine coolant level circuit. | None on performance.
Engine Coolant Level Sensor Circuit

Circuit Description

The engine coolant level sensor monitors the engine coolant level within the coolant system and passes information to the electronic control module (ECM) through the OEM harness.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM troubleshooting and repair manual for location.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit shorted to ground or return in the harness, sensor or connectors.
Refer to Troubleshooting Fault Code t05-196

Last Modified: 08-Jul-2010


Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 196 - Three Wire Sensor

Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 196 PID: P111 SPN: 111 FMI: 4/4 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine coolant level circuit. | None on performance.
Coolant Level Sensor 1 Circuit

Circuit Description

The electronic control module (ECM) provides a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor SIGNAL circuit. This sensor signal voltage changes based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM troubleshooting and repair manual for location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level signal voltage is less than 0.5-VDC for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • Open SIGNAL circuit in the engine harness, connectors, or sensor
  • Signal circuit shorted to ground in the engine harness, connector, or sensor
  • Damaged sensor.
Refer to Troubleshooting Fault Code t05-196

Last Modified: 08-Jul-2010


Fault Code Path Selection

FAULT CODE 06-fc196
Fault Code Path Selection

Is the coolant level sensor a 2-wire sensor? | Go to 06-fc196-2wire
Is the coolant level sensor a 3-wire sensor? | Go to 06-fc196-3wire

Last Modified: 19-Feb-2007


Coolant Level - Data Valid but Below Normal Operational Range - Moderately Severe Level

FAULT CODE 197

Coolant Level - Data Valid but Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 197 PID: P111 SPN: 111 FMI: 1/18 LAMP: Amber SRT: | Coolant Level - Data Valid but Below Normal Operational Range - Moderately Severe Level. Low engine coolant level detected. | None on performance.
Engine Coolant Level

Circuit Description

The engine coolant level sensor monitors the engine coolant level within the coolant system and passes information to the electronic control module (ECM) through the OEM harness.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Shop Talk

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

Refer to Troubleshooting Fault Code t05-197

Last Modified: 08-Jul-2010


Engine Crankshaft Speed/Position - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 1992

Engine Crankshaft Speed/Position - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1992 PID: SPN: 190 FMI: 0/16 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid but Above Normal Operational Range - Moderately Severe Level. Engine crankshaft speed/position SIGNAL indicates engine speed above engine protection limit. | Engine shutdown.
Engine Crankshaft Speed/Position Sensor Circuit

Circuit Description

The engine crankshaft speed/position sensor and the engine camshaft speed/position sensor provide engine speed and position information to the ECM through the engine harness.

Component Location

The engine crankshaft speed/position sensor is located on the ECM side of the engine, behind the oil filters. The engine camshaft speed/position sensor is located above the fuel pump, in back of the gear housing. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Shop Talk

This fault code is only applicable to engines powering generator sets.

Possible causes of this fault code include:

  • External fuel sources drawn into the intake air passage
  • Reverse powering (motoring) of the engine
  • Tampering of the engine crankshaft speed/position and engine camshaft speed/position sensors.

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify that there are no oil leaks. Inspect the engine crankshaft speed/position and engine camshaft speed/position sensors for damage or tampering.

Refer to Troubleshooting Fault Code t05-1992

Last Modified: 08-Jul-2010


Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2183

Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2183 PID: S028 SPN: 1072 FMI: 4 LAMP: Amber SRT: | Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the engine brake solenoid number 1 signal circuit. | Engine brake on cylinders 1,2, and 3 can not be activated or exhaust brake will not operate.
Engine Brake Circuit

Circuit Description

This circuit can be used to control either an exhaust brake or an engine brake depending on the application. The ECM controls engine brakes on cylinders 1, 2, and 3 by sending a signal on the engine brake solenoid number 1 signal circuit. If an exhaust brake is installed, the exhaust brake is driven by the engine brake solenoid number 1 signal line. A 2-pin Weather Pack connector is located near the number 3 injector pass-through connector at the back of the engine. If an engine brake is installed, there will be a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing. If an exhaust brake is installed, the OEM will connect one wire to the 2-pin Weather Pack connector for the exhaust brake relay.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness from the ECM. The exhaust brake is an optional feature that is mounted in the exhaust system by the OEM.

Shop Talk

Possible causes of this fault code include a short circuit to ground in the engine harness, connector, or engine brake solenoids.

On-Board Diagnostics (OBD) Information:

  • The ECM illuminates the appropriate amber or red lamp when the diagnostic runs and fails.
  • The ECM turns OFF the appropriate fault lamp when the diagnostic runs and passes.
Refer to Troubleshooting Fault Code t05-2183

Last Modified: 08-Jul-2010


Sensor Supply Voltage 4 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2185

Sensor Supply Voltage 4 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2185 PID: S232 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply Voltage 4 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at +5 volt sensor supply circuit to the accelerator pedal position sensor. | Engine will only idle.
Accelerator Pedal or Lever Position Sensor Supply Voltage Circuit

Circuit Description

The electronic control module (ECM) supplies the accelerator pedal or lever position sensor with +5 volts.

Component Location

The accelerator pedal or lever assembly is located in the cab.

Shop Talk

This fault is logged when the ECM senses more than +5.25 volts on the accelerator pedal or lever position +5 volt supply line. This can be caused by a short circuit to a voltage source in the OEM harness or a short circuit to an actuator signal circuit that is greater than +5 volts.

Refer to Troubleshooting Fault Code t05-2185

Last Modified: 08-Jul-2010


Sensor Supply Voltage 4 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2186

Sensor Supply Voltage 4 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2186 PID: S232 SPN: 3512 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply Voltage 4 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at +5 VDC sensor supply circuit to the accelerator pedal position sensor. | Automotive: Engine will only die. Marine: Severe derate in engine speed. Limp home capability only idle. Marine: Severe derate in engine speed. Limp home capability only.
Accelerator Pedal or Lever Position Sensor Supply Voltage Circuit

Circuit Description

The electronic control module (ECM) supplies the accelerator with +5 VDC. If the supply circuit to the accelerator is damaged, the accelerator will not work correctly.

Component Location

The accelerator pedal or lever is located in the cab. For Marine application, the accelerator lever is typically located in the engine room or at the helm.

Shop Talk

For Marine application, the accelerator lever is typically located in the engine room or at the helm.

Low voltage on the +5 VDC supply line can be caused by a short circuit to ground in the supply line, a short circuit between the supply line and return circuit, a failed accelerator, or a failed ECM power supply.

Refer to Troubleshooting Fault Code t05-2186

Last Modified: 08-Sep-2016


Auxiliary Equipment Sensor Input 3 Engine Protection Critical - Special Instructions

FAULT CODE 2195

Auxiliary Equipment Sensor Input 3 Engine Protection Critical - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2195 PID: S051 SPN: 703 FMI: 14 (J1939) LAMP: Red SRT: | Auxiliary Equipment Sensor Input Engine Protection Critical - Special Instructions. OEM switch signal on the OEM harness indicates engine protection condition. | Speed derate and possible engine shutdown if engine protection shutdown feature is enabled.
OEM Switch Circuit

Circuit Description

The OEM switch is used by the electronic control module (ECM) to monitor an OEM-specific switch. The ECM monitors the signal on pin 12 for the engine/vehicle protection system.

Component Location

The OEM switch is located in different locations, depending on the OEM and equipment model. Refer to the OEM service manual.

Shop Talk

Verify the engine control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Verify with the driver the engine operating condition when the fault occurs. Depending on the engine speed and load, the OEM switch can detect a condition that falls below or exceeds the engine protection limit. Refer to the OEM service manual for more information.

Refer to Troubleshooting Fault Code t05-2195.

Last Modified: 27-Apr-2012


Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 221

Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 221 PID: P108 SPN: 108 FMI: 3/3 LAMP: Amber SRT: | Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at barometric pressure circuit. | Engine power derate.
Barometric Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor is used by the ECM to monitor the barometric pressure. This value is one of many inputs used by the ECM to determine the correct air/fuel ratio for proper engine operation.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Shop Talk

The barometric pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 221, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.

Operation below sea level:

  • Note: If you have equipment that operates below sea level (such as in a mining operation) and your equipment continues to log Fault Code 221, contact Cummins® Service Engineering for the correct calibration.

On-Board Diagnostics (OBD) Information (Euro 4 Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ electronic service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.

On-Board Diagnostics (OBD) Information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 1 ignition cycle that the diagnostic runs and does not fail. The MIL lamp cannot be cleared using the INSITE™ electronic service tool.
  • The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.
Refer to Troubleshooting Fault Code t05-221

Last Modified: 08-Jul-2010


Fault Code Path Selection

FAULT CODE 06-fc2215
Fault Code Path Selection

Is the engine an ISB or QSB? | Go to 06-fc2215b
Is the engine an ISC, QSC, ISL, or QSL? | Go to 06-fc2215cl

Last Modified: 11-Apr-2005


Fuel Pump Delivery Pressure - Data Valid But Below Normal Operational Range - Moderately Severe Level

FAULT CODE 2215 (ISB/QSB Automotive, Industrial, or Marine Application)

Fuel Pump Delivery Pressure - Data Valid But Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2215 PID: P94 SPN: 94 FMI: 1 LAMP: Amber SRT: TF-215 | Fuel Pump Delivery Pressure - Data Valid but Below Normal Operational Range - Moderately Severe Level. The ECM has detected the fuel pressure in the fuel rail is lower than the commanded performance. | Possibly hard to start; low power; possible engine smoke. Engine can possibly not start.
Fuel System

Circuit Description

The fuel pressure control loop relies on fuel pressure supplied to the high-pressure pump by the electric lift pump and low-pressure gear pump. The ECM monitors rail fuel pressure and engine operating conditions and changes the flow command to maintain the proper rail fuel pressure. Changes to the flow command result in opening (or closing) of the fuel pump actuator to supply more (or less) fuel to the high-pressure pump.

The fuel flow circuit includes, in the following order of fuel flow:

  • Fuel tank
  • OEM fuel supply line
  • OEM filter
  • ECM cooling plate
  • Electric lift pump
  • Fuel filter
  • Gear pump
  • Fuel pump actuator
  • High-pressure fuel pump
  • Rail fuel (includes fuel pressure relief valve and pressure sensor)
  • High-pressure fuel lines
  • High-pressure fuel connectors
  • Injectors
  • Return to tank.

Component Location

The fuel pump is located at the rear of the engine, on the intake side of the engine. Refer to Procedure 100-002 in Section E for a detailed component location view.

Shop Talk

General Information:

Fault Code 2215 logs when measured rail fuel pressure remains at least 10 MPa [1450 psi] less than commanded rail fuel pressure. Once detected, Fault Code 2215 will remain active until the engine is turned off or until the measured rail fuel pressure matches the commanded rail fuel pressure. When a condition exists that causes Fault Code 2215 to become active, it is typical for the fault code to become active when the engine is heavily loaded and become inactive when the engine is lightly loaded.

Fault Code 2292 sets when the ECM commands the fuel pump actuator to open more than expected to maintain rail pressure.

When Fault Code 2215 occurs, the fuel system has lost its ability to maintain rail fuel pressure. Causes of this fault can include:

  • Fuel inlet restrictions
  • Fuel filter plugging
  • Excessive air in the fuel
  • Loss of prime during cranking
  • Low fuel lift pump pressure (automotive/marine engines)
  • Stuck or restricted electronic fuel control actuator
  • System return (excessive return flow from the injectors, high-pressure pump, or rail pressure relief valve)
  • Tampering.

If the drain line is restricted completely, the high pressure fuel pump will fail, causing internal leakage. Prior to a pump malfunction, fault codes indicative of drain line restriction will occur. The fault codes are Fault Code 2216, 2293, or 449. Following the malfunction, these fault codes will go inactive and Fault Code 2215, which is indicative of leakage, will be active. If troubleshooting Fault Code 2215 results in replacement of the pump and there are inactive counts of Fault Codes 2216, 2293, or 449, the drain line must be inspected and measured for restriction to prevent repeat high pressure pump malfunctions.

Inactive Fault Code:

Troubleshooting inactive Fault Code 2215 can be very difficult. The fault code must be active for any of the outlined procedures in which the engine is operated during the test. For engines with high counts of inactive Fault Code 2215, operate the engine on a chassis dynamometer or a diagnostic road test to duplicate the fault code. The most common causes of intermittent Fault Code 2215 that are difficult to recreate are leaking high pressure connectors that only leak when the engine is hot and the fuel is hot, and intermittent fuel supply restriction, such as debris floating in the fuel tank.

If Fault Code 2215 is inactive and there are no existing performance complaints, it is possible the engine ran out of fuel or the fault became active if the engine was not primed following a fuel filter replacement. Clear the inactive fault codes.

Engine No Start:

If the engine will not start and Fault Code 2215 becomes active during cranking, but no speed sensor fault codes exist, monitor rail fuel pressure with INSITE™ electronic service tool. If the rail fuel pressure is low, check the following:

  • Fuel system prime (make sure there is fuel in the tanks and the system is primed)
  • Fuel lift pump pressure. See the ISBe and ISB Common Rail Fuel System Series Engines Service Manual, Bulletin 4021271.Refer to Procedure 005-045 in Section 5
  • Injector and pressure relief valve leakage
  • Fuel pump discharge test.

Lift Pump:

When measuring the voltage at the electric lift pump, the lift pump must be connected to the engine harness during the test. The positive and negative probes of the digital volt ohm multimeter must be connected to the circuit. This connection can be made with a 2-pin Deutsch™ breakout cable, Part Number 3163531.

24 volt applications that use a 24 volt Lift Pump Wiring Harness:

Some 24 volt applications use an additional component in the lift pump circuit. The 24 volt lift pump wiring harness consists of a relay and voltage regulator. Power supplied by the ECM engages the relay. An OEM-supplied +24-VDC power source is then delivered to the voltage regulator through the relay. The voltage regulator reduces the +24-VDC to +12-VDC, which is then supplied to the lift pump.

The regulator is load-dependant. In order for the regulator to reduce the +24-VDC to +12-VDC, the lift pump must be plugged in and running in diesel fuel. Also, the multimeter test leads must be connected to the lift pump SUPPLY and RETURN wires. This can be achieved with a breakout harness. If the voltage is measured with the lift pump disconnected, the meter will display system voltage (+24-VDC). If the multimeter ground test lead is placed on the cylinder block or anywhere else other than the lift pump RETURN wire, the display will read system voltage (+24-VDC).

With the lift pump plugged in and running in diesel fuel, the voltage measurement should not exceed +14-VDC. If the voltage is greater than +14-VDC, the regulator is damaged.

Refer to Troubleshooting Fault Code t05-2215

Last Modified: 08-Jul-2010


Fuel Pump Delivery Pressure Low - Data Valid but Below Normal Operational Range - Moderately Severe Level

FAULT CODE 2215 (ISC/QSC/ISL/QSL Automotive, Industrial, or Marine Application)

Fuel Pump Delivery Pressure Low - Data Valid but Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2215 PID: P94 SPN: 94 FMI: 0/18 LAMP: Yellow SRT: | Fuel Pump Delivery Pressure Low - Data Valid but Below Normal Operational Range - Moderately Severe Level. The ECM has detected that fuel pressure is lower than commanded pressure. | Possibly hard to start, low power, or engine smoke.
Fuel Flow Diagram

Circuit Description

The pressure control loop relies on fuel pressure supplied to the high-pressure pump by the fuel gear pump. The electronic control module (ECM) monitors rail fuel pressure and engine operating conditions and changes the flow command to maintain the proper rail fuel pressure. Changes to the flow command result in opening (or closing) of the fuel pump actuator to supply more (or less) fuel to the high-pressure pump.

The fuel flow circuit includes, in the following order:

  • OEM fuel tank
  • OEM fuel supply line
  • Water stripping fuel filter (10 micron, water stripping, suction side fuel filter)
  • Engine mounted OEM fuel connection
  • Fuel supply tube to ECM cooling plate
  • ECM cooling plate
  • Fuel supply tube to the low-pressure gear pump
  • Fuel supply tube to the pressure-side fuel filter
  • Primary fuel filter (3 micron pressure-side fuel filter)
  • Fuel supply tube to the high-pressure pump
  • High-pressure pump
  • High-pressure system (including fuel rail and fuel rail pressure relief valve), injectors, and high-pressure lines.

Component Location

The high-pressure fuel pump is mounted to the gear housing on the intake side of the engine. Refer to Procedure 100-002 in Section E.

Shop Talk

If the engine will not start and Fault Code 2215 becomes active during cranking, but no speed sensor fault codes exist, monitor the fuel rail pressure with INSITE™ electronic service tool. If the rail pressure is low, check the following:

  • Fuel system prime (make sure there is fuel in the tanks and the system is primed)
  • Fuel lift pump pressure; Use the procedure in the Troubleshooting and Repair Manual, ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Engines, Bulletin 4021418: Refer to Procedure 005-045 in Section 5.
  • Fuel gear pump pressure; Use the procedure in the Troubleshooting and Repair Manual, ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Engines, Bulletin 4021418: Refer to Procedure 005-025 in Section 5.

If the gear pump pressure is OK, test for system leakage:

  • High-pressure pump leakage; Use the procedure in the Troubleshooting and Repair Manual, ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Engines, Bulletin 4021418: Refer to Procedure 005-227 in Section 5.
  • Injector leakage; Use the procedure in the Troubleshooting and Repair Manual, ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Engines, Bulletin 4021418: Refer to Procedure 006-026 in Section 6.
  • Fuel rail pressure relief valve.

If Fault Code 2215 is inactive and there are no existing performance complaints, it is possible the vehicle was run out of fuel or the engine was not primed following fuel filter replacement. Clear the inactive fault code.

Fault Code 2215 sets when the engine is running and measured rail fuel rail pressure remains at least 10 Mpa [1450 psi] less than commanded pressure. Once detected, Fault Code 2215 will remain active until the engine is turned off or until the measured fuel rail pressure matches the commanded fuel rail pressure. When a condition exists that causes Fault Code 2215 to become active, it is typical for the fault code to become active when the engine is heavily loaded and become inactive when the engine is lightly loaded.

When Fault Code 2215 occurs, the fuel system has lost its ability to maintain fuel rail pressure. Causes of this fault include:

  • Excessive fuel inlet restriction
  • Fuel filter plugging
  • Air in the fuel system
  • Fuel gear pump output low
  • Fuel gear pump pressure regulator sticking or leaking
  • High-pressure pump capacity decay (high leakage to drain from the high-pressure pump)
  • Fuel rail pressure relief valve leaks to drain
  • Fuel rail pressure relief valve opens at too low a pressure
  • Injector fuel circuit leaks to drain
  • Pressure sensor reads more than 10 Mpa [1450 psi] lower than actual pressure.

Intermittent ECM power supply connections can cause Fault Code 2215. If the engine is running with an active Fault Code 2215 and Fault Codes 449 or 2311 are not present, check the ECM power supply for intermittent connections. Fault Code 1117 can also be active if this fault condition exists.

Inactive Fault Code:

Troubleshooting inactive Fault Code 2215 can be very difficult. The fault code must be active for any of the outlined procedures in which the engine is operated during the test. For engines with high counts of inactive Fault Code 2215, operate the engine on a chassis dynamometer or a diagnostic road test to duplicate the fault code. The most common causes of intermittent Fault Code 2215 that are difficult to create are leaking high-pressure connectors that only leak when the engine and the fuel are hot, and intermittent fuel supply restrictions, such as debris floating in the fuel tank. Check the High Pressure Connector (HPC) and connector torque and torque to specification if necessary. Operate the engine on a chassis dynamometer or conduct a diagnostic road test to duplicate the fault code.

Refer to Troubleshooting Fault Code t05-2215

Last Modified: 08-Jul-2010


Fault Code Path Selection

FAULT CODE 06-fc2216
Fault Code Path Selection

Is the engine an ISB or QSB? | Go to 06-fc2216b
Is the engine an ISC, QSC, ISL, or QSL? | Go to 06-fc2216cl

Last Modified: 11-Apr-2005


Fuel Pump Delivery Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 2216 (ISB/QSB Automotive or Industrial Application)

Fuel Pump Delivery Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2216 PID: P94 SPN: 94 FMI: 0 LAMP: Amber SRT: | Fuel pump delivery pressure - data valid but above normal operational range - moderately severe level. The ECM has detected fuel pressure in the fuel rail that is higher than the commanded pressure. | None or possible engine noise associated with higher injection pressures (especially at idle or light load). Engine power is reduced.
Fuel System

Circuit Description

The electronic control module (ECM) monitors engine operating conditions, including the reading of rail fuel pressure, and changes the flow command either to increase (OPEN the electronic fuel control actuator) or to decrease (CLOSE the electronic fuel control actuator) the fuel supply to the high-pressure pump.

Component Location

The electronic fuel control actuator is installed on the high-pressure fuel pump. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

An electronic fuel control actuator with excessive leakage will result in high rail fuel pressures at idle or light load, and Fault Code 2216 will be logged. A restriction in the fuel-drain-to-tank return line can prevent excess fuel from exiting the high-pressure fuel pump. This excess drain fuel can enter the pumping chamber and pressurize the rail. Check the fuel drain line restriction. High resistance or an open circuit in the electronic fuel control actuator can cause this fault to log. Air in the fuel can result in pressure changes that would cause this fault to log. High low-pressure pump output pressure could cause this fault to log, as could tampering with the rail fuel pressure sensor.

Fault Code 2216 is activated whenever the engine is loaded (nonzero fueling) and measured fuel pressure is higher than the commanded fuel pressure.

If the drain line is restricted completely, the high-pressure fuel pump will fail, causing internal leakage. Prior to pump failure, fault codes indicative of a drain line restriction will occur. The Fault Codes are 449, 2216, or 2293. Following the failure, these fault codes will go inactive and Fault Code 2215, which is indicative of leakage, will be active. If troubleshooting Fault Code 2215 results in replacement of the pump and there are inactive counts of Fault Codes 449, 2216, or 2293, the drain line must be inspected and measured for restriction. This is to prevent repeat high-pressure pump failures.

Refer to Troubleshooting Fault Code t05-2216

Last Modified: 08-Jul-2010


Fuel Pump Delivery Pressure High - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 2216 (ISC/QSC/ISL/QSL Automotive, Industrial or Marine Application)

Fuel Pump Delivery Pressure High - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2216 PID: P94 SPN: 94 FMI: 1 LAMP: Yellow SRT: | Fuel Pump Delivery Pressure High - Data Valid but Above Normal Operational Range - Moderately Severe Level. The ECM has detected that fuel pressure is higher than commanded pressure. | None or possible engine noise associated with higher injection pressures (especially at idle or light load).
High Pressure Pump

Circuit Description

The electronic control module (ECM) monitors engine operating conditions, including the reading of fuel rail pressure, and changes the flow command to either increase (open the fuel pump actuator) or decrease (close the fuel pump actuator) the fuel supply to the high pressure pump.

Component Location

The fuel pump actuator is installed in the adapter on the back of the high-pressure pump.

Shop Talk

A fuel pump actuator with excessive leakage or a damaged inboard o-ring will result in high fuel rail pressures at idle or light load.

If the fuel pump actuator exhibits excessive leakage, it is possible that the fuel rail pressure will reach the opening pressure of the fuel rail pressure relief valve and Fault Code 449 may also become active.

Refer to Troubleshooting Fault Code t05-2216

Last Modified: 08-Jul-2010


Engine Control Module Calibration Program Memory (RAM) Corruption - Condition Exists

FAULT CODE 2217

Engine Control Module Calibration Program Memory (RAM) Corruption - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2217 PID: S240 SPN: 630 FMI: 11/31 LAMP: Amber SRT: | Engine Control Module Calibration Program Memory (RAM) Corruption - Condition Exists. Severe loss of data from the ECM. | Possible no noticeable performance effects, engine dying or hard starting. Fault information, trip information, and maintenance monitor data can be inaccurate.
Unswitched Battery Supply Circuit

Circuit Description

The Electronic Control Module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. There is a single 30-ampere fuse in the unswitched battery wires to protect the engine harness from overheating. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned on. The battery return wires are connected directly to the negative (-) battery post. Pins 2 and 3 are optional circuits possibly not used by the OEM. Refer to the OEM wiring diagram for detailed information on the circuit.

Component Location

The ECM is located on the left side of the engine, near the front of the engine. The ECM is connected to the battery by the ECM power harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM troubleshooting and repair manual.

Shop Talk

On-Board Diagnostics (OBD) Information (Euro 4 Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.

On-Board Diagnostics (OBD) Information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 1 ignition cycle that the diagnostic runs and does not fail. The MIL lamp cannot be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.
Refer to Troubleshooting Fault Code t05-2217

Last Modified: 08-Jul-2010


Barometric Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 222

Barometric Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 222 PID: P108 SPN: 108 FMI: 4/4 LAMP: Amber SRT: | Barometric Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at barometric pressure circuit. | Engine power derate.
Barometric Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor is used by the electronic control module (ECM) to monitor the barometric pressure. This value is one of many inputs used by the ECM to determine the correct air/fuel ratio for proper engine operation.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

The barometric pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 222, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply line open or shorted to ground.

On-Board Diagnostics (OBD) Information (Euro 4 Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.

On-Board Diagnostics (OBD) Information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 1 ignition cycle that the diagnostic runs and does not fail. The MIL lamp cannot be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.
Refer to Troubleshooting Fault Code t05-222

Last Modified: 08-Jul-2010


Injector Metering Rail 1 Pressure - Data Valid but Below Normal Operational Range - Most Severe Level

FAULT CODE 2249

Injector Metering Rail 1 Pressure - Data Valid but Below Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2249 PID: P157 SPN: 157 FMI: 1 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure - Data Valid but Below Normal Operational Range - Most Severe Level. The ECM has detected that fuel pressure is lower than commanded pressure. | Possibly hard to start, low power, or engine smoke.
Rail Fuel Pressure

Circuit Description

The ECM monitors rail fuel pressure and engine operating conditions and changes the flow command to maintain the proper rail fuel pressure. Changes to the flow command result in opening (or closing) or the fuel pump actuator is supply more (or less) fuel to the high pressure pump.

Component Location

Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

Fault Code 2249 is very similar to Fault Code 559 except that the fault triggers at a different fuel pressure threshold limit. If Fault Code 2249 is active, the troubleshooting procedures for Fault Code 559 must be followed.

Refer to Troubleshooting Fault Code t05-2249

Last Modified: 08-Jul-2010


Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 2265

Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2265 PID: S126 SPN: 1075 FMI: 3 LAMP: Amber SRT: | Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal, or Shorted to High Source. High voltage or open detected at the fuel lift pump signal circuit. | Engine can be difficult to start.
Electric Fuel Lift Pump Circuit

Circuit Description

On 12 VDC Automotive and 24 VDC Industrial or Marine systems, the circuit is a pulse width modulated driver in the electronic control module (ECM) that controls the electric fuel lift pump. The lift pump is grounded in the ECM.

On 24 VDC Automotive systems, the circuit is a pulse width modulated driver in the ECM that controls the electric fuel lift pump relay. The circuit includes two additional components, a relay and voltage regulator. The ECM controls voltage to the relay. When the relay is engaged, an OEM supplied power source delivers 24 VDC to the voltage regulator. The voltage regulator reduces the 24 VDC to 12 VDC, which is then delivered to the lift pump.

Component Location

On both 12 and 24 VDC systems, the electric fuel lift pump is located behind the ECM cooling plate on the intake side of the engine. Refer to Procedure 100-002 for a detailed component location view.

On 24 VDC Automotive systems, the relay is located in the harness between the voltage regulator and the OEM power supply on the bottom edge of the ECM. The voltage regulator is located just below the ECM.

Shop Talk

On 12 VDC Automotive and 24 VDC Industrial or Marine systems, this fault code becomes active if the ECM detects an open circuit at keyswitch ON. The cause of this fault code is an open circuit in the electric fuel lift pump circuit.

If the fault code is intermittent, look for causes of an intermittent open circuit, such as loose pins and bad connections. At keyswitch ON, the lift pump duty cycle ramps to 100 percent. This fault code can detect open circuit conditions only at keyswitch ON. If an open circuit condition is indicated after the engine is started (while the lift pump is already running), Fault Code 2265 will not become active.

On 24 VDC Automotive systems, this fault code becomes active if the ECM detects an open circuit at keyswitch ON. Causes of this fault code are an open circuit in the electric fuel lift pump wiring harness, relay, or engine harness. This fault code will not become active if the voltage regulator or electric fuel lift pump has failed.

Refer to Troubleshooting Fault Code t05-2265

Last Modified: 08-Jul-2010


Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 2266

Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2266 PID: S126 SPN: 1075 FMI: 4 LAMP: Amber SRT: | Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the fuel lift pump circuit. | Engine can be difficult to start.
Electric Fuel Lift Pump Circuit

Circuit Description

On 12 VDC Automotive and 24 VDC Industrial or Marine systems, the circuit is a pulse width modulated driver in the electronic control module (ECM) that controls the electric fuel lift pump. The lift pump is grounded in the ECM.

On 24 VDC Automotive systems, the circuit is a pulse width modulated driver in the ECM that controls the electric fuel lift pump relay. The circuit includes two additional components, a relay and voltage regulator. The ECM controls voltage to the relay. When the relay is engaged, an OEM supplied power source delivers 24 VDC to the voltage regulator. The voltage regulator reduces the 24 VDC to 12 VDC, which is then delivered to the lift pump.

Component Location

On both 12 and 24 VDC systems, the electric fuel lift pump is located behind the ECM cooling plate on the intake side of the engine. Refer to Procedure 100-002 for a detailed component location view.

On 24 Automotive VDC systems, the relay is located in the harness between the voltage regulator and the OEM power supply on the bottom edge of the ECM. The voltage regulator is located just below the ECM.

Shop Talk

This fault code becomes active whenever the ECM detects a short circuit to ground or high current in the electric lift pump circuit. Causes for this fault code are short circuit to ground or low resistance.

On 12 VDC Automotive and 24 VDC Industrial or Marine systems during cold weather, gelled fuel can plug the lift pump and cause this fault code. Listen to the lift pump to be sure it is running during cold ambient temperatures (less than -29°C [-20°F]). This fault code can also become active if the lift pump rotor stalls or seizes. When the fault conditions are detected, the ECM driver to the lift pump is turned off to protect the circuit. It is necessary to cycle the keyswitch OFF and then back ON before the ECM will retest for the cause of the fault code. The ECM driver is re-enabled at keyswitch ON, and if the cause is no longer present, the fault code will become inactive and can be cleared.

On 24 VDC Automotive systems, the ECM driver to the lift pump relay is turned off when a short circuit to ground or high current in the electric fuel lift pump wiring harness relay circuit is detected. Causes of this fault code are a short circuit to ground or high current in the electric fuel lift pump wiring harness, relay or engine harness. This fault code will not become active if the voltage regulator or electric fuel lift pump has failed.

NOTE: On 12 VDC systems, this fault code will also become active if the priming pump motor stalls. Stall current for the priming pump motor is approximately 9 amperes. A good priming pump typically runs with less than 3 amperes. If the fault code is intermittent, observe the snapshot data priming pump measured current. If current was near 9 amperes when the fault condition occurred, conclude that the rotor has stalled and replace the electric priming pump.

Refer to Troubleshooting Fault Code t05-2266

Last Modified: 08-Jul-2010


Fault Code Path Selection

FAULT CODE 06-fc227
Fault Code Path Selection

Is the engine an ISB/QSB Automotive or Industrial application, or a ISC/QSC/ISL/QSL Automotive, Industrial, or Marine application? | Go to 06-fc227b
Is the engine a QSB Marine application? | Go to 06-fc227bm

Last Modified: 07-Apr-2005


EGR Valve Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2271

EGR Valve Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2271 PID: P027 SPN: 27 FMI: 3/3 LAMP: Amber SRT: | Exhaust Gas Recirculation (EGR) Valve Position Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the EGR valve position sensor circuit. | Possible low power. Power will be removed from the EGR valve motor.
EGR Valve Position Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) valve position sensor outputs a voltage signal to the electronic control module (ECM). The ECM converts this signal into a percentage value, 0 to 100, indicating valve position. A fully-open valve is equivalent to 100 percent.

Component Location

The EGR valve position sensor is located on the EGR valve assembly. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

The EGR valve position sensor shares Supply and Return wires in the engine harness with other sensors. Open circuits and short circuits in the engine harness can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return in the harness, connectors, or sensor
  • SIGNAL wire shorted to sensor supply or battery voltage
  • Failed EGR valve position sensor
  • Failed ECM.
Refer to Troubleshooting Fault Code t05-2271.

Last Modified: 06-Oct-2010


EGR Valve Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2272

EGR Valve Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2272 PID: P027 SPN: 027 FMI: 4/4 LAMP: Amber SRT: | Exhaust Gas Recirculation (EGR) valve position circuit - voltage below normal or shorted to low source. Low signal voltage detected at the EGR valve position sensor circuit. | Possible low power. Power will be removed from the EGR valve motor.
EGR Valve Position Sensor Circuit

Circuit Description

The EGR valve position sensor outputs a voltage signal to the electronic control module (ECM). The ECM converts this signal into a percentage value, 0 to 100, indicating valve position. A fully-open valve is equivalent to 100 percent.

Component Location

The EGR valve position sensor is located on the EGR valve assembly. 100-002 for a detailed component location view.

Shop Talk

The EGR valve position sensor shares SUPPLY and RETURN wires in the engine harness with other sensors. Open circuits and short circuits in the engine harness can cause multiple fault codes to be active.

Possible causes for this fault code include:

  • SIGNAL circuit open or shorted to ground
  • SUPPLY circuit open or shorted to ground
  • Sensor shorted to ground.
Refer to Troubleshooting Fault Code t05-2272

Last Modified: 08-Jul-2010


EGR Valve Differential Pressure Sensor Circuit - Shorted High

FAULT CODE 2273

EGR Valve Differential Pressure Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2273 PID: P411 SPN: 411 FMI: 3/3 LAMP: Amber SRT: | EGR valve differential pressure sensor circuit - shorted high. High voltage detected on the EGR differential pressure sensor circuit. | EGR valve will be closed.
EGR Valve Differential Pressure Sensor Circuit

Circuit Description

The exhaust gas recircultion (EGR) differential pressure sensor has two ports that sense a pressure drop across the EGR gas entrance to the intake connection. The electronic control module (ECM) uses this pressure drop to calculate the amount of EGR gas entering the intake. This calculation helps to determine the commanded position of the EGR valve (and VG turbocharger) that will control the amount of EGR gas flow into the engine.

Component Location

The EGR differential pressure sensor is mounted on the side of the intake air horn. Refer to Procedure 100-002 for a detailed component location view.

NOTE: The sensor is connected to the engine harness through a short pigtail harness. The pigtail harness is permanently affixed to the sensor. Do not try to remove the connector that is attached to the sensor body or damage to the sensor will occur.

Shop Talk

The EGR differential pressure sensor shares supply and return wires in the engine harness with other sensors. Open circuits and short circuits in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 2273, check for multiple faults. Possible causes of this fault code include:

  • Open return in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage
  • Supply circuit shorted to battery voltage.
Refer to Troubleshooting Fault Code t05-2273

Last Modified: 08-Jul-2010


EGR Valve Differential Pressure Sensor Circuit - Shorted Low

FAULT CODE 2274

EGR Valve Differential Pressure Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2274 PID: P411 SPN: 411 FMI: 4/4 LAMP: Amber SRT: | EGR valve differential pressure sensor circuit - shorted low. Low signal voltage detected on the EGR valve differential pressure sensor circuit. | EGR valve will be closed.
EGR Valve Differential Pressure Sensor Circuit

Circuit Description

The exhaust gas recirculation. (EGR) valve differential pressure sensor has two ports that sense a pressure drop across the EGR gas entrance to the intake connection. The electronic control module (ECM) uses this pressure drop to calculate the amount of EGR gas entering the intake. This calculation helps to determine the commanded position of the EGR valve (and VG turbocharger) that will control the amount of EGR gas flow into the engine.

Component Location

The EGR valve differential pressure sensor is mounted on the side of the intake connection. Refer to Procedure 100-002 for a detailed component location view.

NOTE: The sensor is connected to the engine harness through a short pigtail harness. The pigtail harness is permanently affixed to the sensor. Do not try to remove the connector that is attached to the sensor body or damage to the sensor will occur.

Shop Talk

The EGR valve differential pressure sensor shares supply and return wires in the engine harness with other sensors. Open circuits and short circuits in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 2274, check for multiple faults.

  • Open signal circuit in the engine harness, connections, or sensor
  • Supply circuit open or shorted to ground
  • Sensor shorted to ground.
Refer to Troubleshooting Fault Code t05-2274

Last Modified: 08-Jul-2010


Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 227 (ISB/QSB Automotive and Industrial, ISC/QSC/ISL/QSL Automotive, Industrial, and Marine)

Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: S232 SPN: 1080 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 2 circuit. | Automotive application: Engine power derate. Marine application: None, no engine protection for circuit or sensor failure.
Sensor Supply Voltage Number 2 Circuit

Circuit Description

The sensor supply number 2 pin of the electronic control module (ECM) provides +5 VDC for the camshaft engine position sensor, intake manifold pressure sensor, and rail fuel pressure sensor. ISB and QSB5.9 use a combined intake manifold pressure/temperature sensor.

Component Location

Sensor supply voltage number 2 is located inside the ECM. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

High voltage on the +5 VDC supply line can be caused by a signal shorted to battery voltage in the engine harness or connectors, or a failed ECM.

On-Board Diagnostics (OBD) Information (Euro 4 Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.

On-Board Diagnostics (OBD) Information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 1 ignition cycle that the diagnostic runs and does not fail. The MIL lamp cannot be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.
Refer to Troubleshooting Fault Code t05-227

Last Modified: 08-Jul-2010


Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 227 (QSB Marine Application)

Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: S232 SPN: 1080 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 2 circuit. | Marine application: None, no engine protection for circuit or sensor failure.
Sensor Supply Voltage Number 2 Circuit

Circuit Description

The sensor supply number 2 pin of the electronic control module (ECM) provides +5 VDC for the intake manifold pressure sensor, and rail fuel pressure sensor. ISB and QSB5.9 use a combined intake manifold pressure/temperature sensor.

Component Location

Sensor supply voltage number 2 is located inside the ECM. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

High voltage on the +5 VDC supply line can be caused by a signal shorted to battery voltage in the engine harness or connectors, or a failed ECM.

Refer to Troubleshooting Fault Code t05-227

Last Modified: 08-Jul-2010


Fuel Inlet Meter Device - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 2292

Fuel Inlet Meter Device - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2292 PID: SPN: FMI: 16 LAMP: Amber SRT: | Fuel Inlet Meter Device - Data Valid but Above Normal Operational Range - Moderately Severe Level. The flow demand is higher than expected. | Possibly hard to start; low power; possible engine smoke. Engine power is derated.
Fuel System

Circuit Description

The fuel pressure control loop relies on fuel pressure supplied to the high-pressure pump by the electric lift pump and low-pressure pump. The electronic control module (ECM) monitors rail fuel pressure and engine operating conditions and changes the flow command to maintain the proper rail fuel pressure. Changes to the flow command result in opening (or closing) of the electric fuel control actuator to supply more (or less) fuel to the high-pressure pump.

The fuel flow circuit includes, in the following order of fuel flow:

  • Fuel tank
  • OEM fuel supply line
  • OEM 300 micron filter
  • ECM cooling plate
  • Electric lift pump
  • Fuel filter
  • Gear pump
  • Electronic fuel control actuator
  • High-pressure fuel pump
  • Fuel rail (includes rail pressure relief valve and pressure sensor)
  • High-pressure fuel lines
  • High-pressure fuel connectors (HPCs)
  • Injectors
  • Return to tank.

Component Location

The electronic fuel control actuator is located on the fuel pump. 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Shop Talk

Causes of this fault code include the following: High inlet restriction, plugged fuel filter, low lift pump pressure, low resistance to the electronic fuel control actuator, stuck or restricted electronic fuel control actuator, system return (excessive return flow from the injectors, high-pressure pump, or rail pressure relief valve), or tampering.

Fault Code 2292 sets when the ECM commands the electronic fuel control actuator to open more than expected to maintain rail pressure. Fault Code 2215 sets when the ECM opens the electronic fuel control actuator to fully open and rail pressure is still lower than commanded.

Once the repair has been made, this fault code will require approximately 15-20 minutes of road test or dynamometer run to be set inactive.

Refer to Troubleshooting Fault Code t05-2292

Last Modified: 08-Jul-2010


Fuel Inlet Meter Device Flow Demand Lower Than Expected - Data Valid but Below Normal Operational Range - Moderately Severe Level

FAULT CODE 2293

Fuel Inlet Meter Device Flow Demand Lower Than Expected - Data Valid but Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2293 PID: SPN: FMI: 18 LAMP: Amber SRT: | Fuel inlet meter device flow demand lower than expected - data valid but below normal operational range - moderately severe level. The flow demand is lower than expected. | None or possible engine noise associated with higher injection pressures (especially at idle or light load). Engine power is derated.
Fuel System

Circuit Description

The electronic control module (ECM) monitors engine-operating conditions, including the reading of rail fuel pressure, and changes the flow command to either increase (OPEN the electronic fuel control actuator) or decrease (CLOSE the electronic fuel control actuator) the fuel supply to the high-pressure pump.

Component Location

The electronic fuel control actuator is installed on the high-pressure fuel pump. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

Fault Code 2293 is activated when the electronic fuel control actuator is closed more than expected to lower rail fuel pressure.

An electric fuel control actuator with excessive leakage can possibly result in high rail fuel pressures at idle or light load. A restriction in the fuel-drain-to-tank return line can prevent unneeded fuel from exiting the high-pressure fuel pump. This excess drain fuel can enter the pumping chamber and pressurize the rail. Check the fuel drain line restriction. High resistance or an open circuit in the electric fuel control actuator can cause this fault to log. Air in the fuel can result in pressure changes that would cause this fault to log. High lift pump delivery pressure could cause this fault to log, as could tampering with the rail fuel pressure sensor.

Once the repair has been made, this fault code will require approximately 15 to 20 minutes of road test or dynamometer run to be set inactive.

Refer to Troubleshooting Fault Code t05-2293

Last Modified: 08-Jul-2010


Fueling Actuator Number 1 Circuit Error Conditions Exists

FAULT CODE 2311

Fueling Actuator Number 1 Circuit Error Conditions Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2311 PID: S018 SPN: 633 FMI: 11/31 LAMP: Amber SRT: | Fueling Actuator Number 1 Circuit Error Conditions Exists. Fuel pump actuator circuit resistance too high or too low. | Possible low power.
Fuel Pump Actuator Circuit

Circuit Description

The circuit is a pulse width modulation driver in the electronic control module (ECM) that controls the electronic fuel control actuator. The actuator is grounded in the ECM. The ECM varies the current to this valve to provide the correct fuel flow to the high-pressure pump based on engine operating conditions. The electronic fuel control actuator valve is a normally open valve. High circuit resistance may cause fuel pressure to be higher than commanded at light loads and Fault Code 2216 may be logged.

Component Location

The fuel pump actuator valve is located on the engine-mounted fuel pump housing. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

If this fault code occurs during road test or sea trial, verify that all connectors are clean and free of corrosion before replacing components. This fault code can become active for any of the following reasons:

  • Fuel pump actuator high resistance
  • Engine harness high resistance
  • Loose, worn, or corroded connectors or pins
  • Fuel pump actuator with low internal resistance
  • Fuel pump actuator or engine harness that has shorted to ground
  • Intermittent circuit failures that cause the fuel pressure to exceed the fuel rail pressure relief valve opening pressure.

If an intermittent electrical circuit problem of the fuel pump actuator circuit exists, it is possible for the fault code to become active then inactive during normal engine operation. For example, if a poor connection causes an intermittent open or short circuit, the normally open valve will open in a fraction of a second while the circuit is faulty causing the fuel rail pressure relief valve to open. Following the event that caused the fuel rail pressure relief valve to open, the ECM will attempt to reset the fuel rail pressure relief valve, provided the fuel pump actuator circuit is not still failed.

Following any event that opens the fuel rail pressure relief valve, the fuel rail pressure relief valve will regulate the fuel pressure at approximately 90 mPa [13053 psi]. If the ECM is still capable of controlling fuel pressure, the following will occur:

  • The measured fuel pressure will reduce to 60 mPa [8702.3 psi] as the ECM prepares to re-seat the fuel rail pressure relief valve.
  • Once pressure is 60 mPa [8702.3 psi] and engine speed is greater than 1200 rpm, the ECM will momentarily close the fuel pump actuator. This action will reduce the fuel rail pressure (to less than 2 mPa [290 psi] for a fraction of a second) so that the fuel rail pressure relief valve will reset. At light engine loads, especially if the engine is sped while the driveline is not engaged, engine power interruption will be noticeable while the ECM attempts to reset the fuel rail pressure relief valve.
  • Once the ECM detects that the fuel rail pressure relief valve is reset, normal engine operation will resume and Fault Code 2311 will become inactive.
Refer to Troubleshooting Fault Code t05-2311

Last Modified: 08-Jul-2010


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2321

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2321 PID: P190 SPN: 190 FMI: 2 LAMP: None SRT: | Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect. Crankshaft engine speed sensor intermittent synchronization. | Automotive and marine applications: Engine can exhibit misfire as control switches from the primary to the backup speed sensor. Engine power is reduced while the engine operates on the backup speed sensor.
Engine Speed/Position Sensor Number 1 Circuit

Circuit Description

The crankshaft engine speed sensor provides engine speed information to the electronic control module (ECM). The sensor is powered by +5 VDC. The sensor generates the signal by sensing the movement of target teeth machined into a tone wheel that is mounted to the crankshaft.

Component Location

The engine speed sensor is located on the intake side of the engine between number 5 and number 6 cylinders at the crankshaft level. For ISB and QSB5.9 the crankshaft engine speed sensor is located on the intake side of the engine behind the vibration damper near the tone wheel. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

During engine operation, the electronic control module (ECM) monitors the primary speed sensor (crankshaft speed sensor) signal. Fault Code 689 will become active and light the yellow lamp (marine does not use lamps) if the signal from the primary speed sensor is not present or degraded for more than three continuous seconds. Meanwhile, if the primary engine speed sensor signal is not present or is degraded for a moment (less than three seconds), the ECM will interrupt injection events based on the primary engine speed sensor and resume injection events using the backup engine speed sensor. Engine power will be reduced while the injection events are based on the backup speed sensor. If the primary speed sensor signal returns, the ECM will automatically interrupt injection events based on the backup speed sensor and resume injection events based on the primary speed sensor. If over a period of time, the ECM detects several incidents of a loss of the primary speed sensor signal, this fault code will become active.

A vehicle operator can notice an intermittent “misfire” if the injection events are interrupted while the ECM switches from control based on the primary and secondary speed sensors. Also, a vehicle operator can notice intermittent “low power” if a “glitch” in the primary speed sensor signal causes the engine to intermittently use the backup speed sensor for injection control.

This fault code becomes active whenever the ECM detects a persistent loss of the primary engine speed sensor signal over a short period of time.

This fault becomes inactive at each key-on or if the ECM does not detect a loss of the primary engine speed sensor signal for at least 20 minutes.

Failures that can cause this fault:

  • Intermittent loss of primary speed sensor signal, the most likely cause is an intermittent open or short circuit can be experienced with speed sensor connector problems
  • Sensor air gap that is marginally too small or too large.

Actions to take if this fault is intermittent:

  • Look for intermittent engine harness connections in the primary engine speed sensor circuit
  • Look for loose connections at the ECM connector where the pins can not be locked into the socket
  • Look for places where the engine harness has worn into a nearby component causing an intermittent short circuit
  • Look for pin wear at the speed sensor
  • Inspect the target wheel for damage.
Refer to Troubleshooting Fault Code t05-2321

Last Modified: 08-Jul-2010


Backup Engine Speed/Position Sensor Number 2 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2322

Backup Engine Speed/Position Sensor Number 2 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2322 PID: S64 SPN: 723 FMI: 2 LAMP: None SRT: | Backup Engine Speed/Position Sensor Number 2 - Data Erratic, Intermittent, or Incorrect. Camshaft engine speed sensor intermittent synchronization. | Automotive and marine applications: Possible low power.
Original Wiring Harness - Backup Engine Speed/Position Sensor Number 2 Circuit
Revised Wiring Harness - Backup Engine Speed/Position Sensor Number 2 Circuit

Circuit Description

The camshaft engine position sensor provides engine position information to the electronic control module (ECM). The sensor is powered by (+) 5-VDC. The sensor generates the signal by sensing the movement of target teeth machined into a tone wheel that is mounted to the camshaft.

Component Location

The crankshaft speed sensor is located on the intake side of the engine near the number 6 cylinder at the crankshaft centerline. For ISB and QSB5.9, the crankshaft engine speed sensor is located on the intake side of the engine behind the vibration damper near the tone wheel. The camshaft speed sensor is located below the fuel pump in the back of the gear housing.

Shop Talk

During engine operation, the ECM monitors the secondary speed sensor (camshaft speed sensor) signal. Fault Code 778 will become active and light the yellow lamp (marine does not use lamps) if the signal from the secondary speed sensor is not present or degraded for more than three continuous seconds. If over a period of time, the ECM detects several incidents of a loss of the secondary speed sensor signal but the signal loss is short in duration, this fault code will become active. Since the secondary engine speed signal is not used for normal engine operation, a vehicle operator should not notice any symptoms related to this problem.

This fault code becomes active whenever the ECM detects a persistent loss of the secondary engine speed sensor signal over a short period of time.

This fault becomes inactive at each key ON or if the ECM does not detect a loss of the secondary engine speed sensor signal for at least 20 minutes.

Causes for this fault code:

  • Intermittent loss of primary speed sensor signal. The most likely cause is an intermittent open or short circuit as can be experienced with speed sensor connector problems
  • Sensor air gap that is marginally too small or too large, or target wheel exhibits excessive runout.

Actions to take if this fault is intermittent:

  • Look for intermittent engine harness connections in the secondary engine speed sensor circuit
  • Look for loose connections at the ECM connector where the pins can not be locked into the socket
  • Look for places where the engine harness has worn into a nearby component causing an intermittent short circuit
  • Look for pin wear at the speed sensor
  • Inspect the target wheel for damage.

The sensor return configuration for Euro 4 ISB engines has been changed for automotive wiring harnesses manufactured from February 2012 onward. The new style wiring harnesses can be be identified using the method below:

  • Disconnect the ECM connector
  • Disconnect the camshaft position sensor
  • Disconnect the intake manifold pressure/temperature sensor
  • Check for continuity between the intake manifold pressure/temperature sensor RETURN pin and the camshaft position sensor RETURN pin
  • Check for continuity between ECM pin 47 and the camshaft position sensor RETURN pin
  • Use the table below to determine which harness is fitted to the engine.

Engine Harnesses
From | To | New Harness | Old Harness
Intake manifold pressure/temperature sensor RETURN pin | Camshaft position sensor RETURN pin | Open circuit | Short circut
ECM pin 47 | Camshaft position sensor RETURN pin | Open circuit | Short circuit

NOTE: QSB engines, all C series engines, and all L series engines are not affected by this change.

Refer to Troubleshooting Fault Code t05-2322.

Last Modified: 10-Feb-2012


Fault Code Path Selection

FAULT CODE 06-fc234
Fault Code Path Selection

Is the engine an ISB/QSB Automotive or Industrial application, or a ISC/QSC/ISL/QSL Automotive, Industrial, or Marine application? | Go to 06-fc234b
Is the engine a QSB Marine application? | Go to 06-fc234bm

Last Modified: 07-Apr-2005


Fault Code Path Selection

FAULT CODE 06-fc2345
Fault Code Path Selection

Is the engine an ISB or QSB? | Go to 06-fc2345b
Is the engine an ISC, QSC, ISL, or QSL? | Go to 06-fc2345cl

Last Modified: 07-Apr-2005


Turbocharger Speed - Invalid Rate of Change Detected

FAULT CODE 2345 (ISB/QSB Automotive or Industrial Application)

Turbocharger Speed - Invalid Rate of Change Detected

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2345 PID: P103 SPN: 103 FMI: 10/10 LAMP: Amber SRT: | Turbocharger speed - invalid rate of change detected. The turbocharger speed sensor has detected an erroneous speed value. | Possible-low-power estimated turbocharger speed will be used.
Turbocharger Speed Sensor Circuit

Circuit Description

The electronic control module (ECM) provides +5 VDC to the turbocharger speed sensor signal pin. Circuitry inside the turbocharger speed sensor detects the movement of the turbocharger compressor blades and produces a speed signal. This signal is used by the ECM for engine controls.

Component Location

The turbocharger speed sensor is located in the turbocharger compressor housing. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault becomes active if the engine is running and the turbocharger speed signal rapidly changes faster than the capabilities of the turbocharger. This could be caused by a bent or missing compressor blade or a damaged compressor wheel.

Refer to Troubleshooting Fault Code t05-2345

Last Modified: 08-Jul-2010


Turbocharger Speed Invalid Rate of Change Detected - Abnormal Rate of Change

FAULT CODE 2345 (ISC/QSC/ISL/QSL Automotive, Industrial, or Marine Application)

Turbocharger Speed Invalid Rate of Change Detected - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2345 PID: P103 SPN: 103 FMI: 10/10 LAMP: Amber SRT: | Turbocharger Speed Invalid Rate of Change Detected - Abnormal Rate of Change. The turbocharger speed sensor has detected an erroneous speed value. | Engine power derate.
Turbocharger Speed Sensor Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. A signal is generated as the turbocharger shaft spins. The target on the turbocharger shaft is a ground flat in the center of the shaft.

Component Location

The turbocharger speed sensor is located in the center housing of the turbocharger. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault becomes active if the engine is running and the turbocharger speed signal rapidly changes faster than the capabilities of the turbocharger. This fault code can be caused by an intermittent turbocharger speed sensor connection, incorrect turbocharger speed sensor air gap, or a faulty turbocharger speed sensor.

Refer to Troubleshooting Fault Code t05-2345

Last Modified: 08-Jul-2010


Fault Code Path Selection

FAULT CODE 06-fc2346
Fault Code Path Selection

Is the engine an ISB or QSB? | Go to 06-fc2346b
Is the engine an ISC, QSC, ISL, or QSL? | Go to 06-fc2346cl

Last Modified: 07-Apr-2005


Exhaust Gas Temperature - Data Above Normal

FAULT CODE 2346 (ISB/QSB Automotive or Industrial Application)

Exhaust Gas Temperature - Data Above Normal

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2346 PID: SPN: 2789 FMI: 1/15 LAMP: Amber SRT: | Exhaust gas temperature - data above normal. High exhaust temperature has been calculated by the electronic control system. | Derate in power output of the engine in attempt to decrease the calculated exhaust gas temperature value.

Circuit Description

Exhaust temperature is a calculated value that the electronic control module (ECM) derives based on engine operating conditions, such as intake manifold temperature and pressure, engine speed, fuel flow, and exhaust gas recirculation (EGR) valve pressure.

Component Location

There is not a physical exhaust gas temperature sensor on the engine. The exhaust gas temperature is a calculation of the exhaust gas temperature before entering the turbocharger and is also known as the turbine inlet temperature.

Shop Talk

The most common cause of this fault code is low boost. Low boost can be caused by several factors:

  • Leaking charge air cooler
  • Damaged charge air piping or hose
  • Loose charge air cooler clamps
  • Failed intake manifold pressure sensor
  • Failed variable geometry turbocharger.

NOTE: This fault code will most likely not become active under conditions of the engine being unloaded and in the shop. The engine must be loaded to trip this fault code and to verify if the failure has been fixed.

Refer to Troubleshooting Fault Code t05-2346

Last Modified: 08-Jul-2010


Turbocharger Turbine Inlet Temperature (Calculated) - Data Valid but Above Normal Operational Range - Least Severe Level

FAULT CODE 2346 (ISC/QSC/ISL/QSL Automotive, Industrial, or Marine Application)

Turbocharger Turbine Inlet Temperature (Calculated) - Data Valid but Above Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2346 PID: SPN: 2789 FMI: 0/15 LAMP: None SRT: | Turbocharger Turbine Inlet Temperature (Calculated) - Data Valid but Above Normal Operational Range - Least Severe Level. Turbocharger turbine inlet temperature has exceeded the engine protection limit. | Engine power derate.
Turbocharger Turbine Inlet Temperature (Calculated)

Circuit Description

The exhaust gas temperature is calculated by the electronic control module (ECM). Exhaust gas temperature, or turbine inlet temperature, is derived by the electronic control module based on engine operating conditions such as intake manifold air temperature, engine speed, injection timing, intake manifold pressure, and fuel flow.

Component Location

There is not a physical exhaust gas temperature sensor in the system. The exhaust gas temperature is a calculation of exhaust gas temperature before the turbocharger and is also known as turbine inlet temperature.

NOTE: Some OEM's have pyrometer gauges mounted in their chassis. Pyrometers measure turbine outlet temperature or the exhaust gas leaving the turbocharger and will not equal the value monitored with the exhaust gas temperature parameter in INSITE™ electronic service tool.

Shop Talk

The most common cause of this fault code is low boost. Low boost can be caused by several factors: leaking charge air cooler, failed charge air cooler piping or hose, loose charge air cooler clamps, failed intake manifold pressure sensor, failed variable geometry turbocharger, or failed turbocharger control valve.

NOTE: This code will most likely not be active with no load in the shop. The engine must be loaded to trip this fault code and to determine if the failure has been found and fixed.

Refer to Troubleshooting Fault Code t05-2346

Last Modified: 08-Jul-2010


Fault Code Path Selection

FAULT CODE 06-fc2347
Fault Code Path Selection

Is the engine an ISB or QSB? | Go to 06-fc2347b
Is the engine an ISC, QSC, ISL, or QSL? | Go to 06-fc2347cl

Last Modified: 07-Apr-2005


Turbocharger Compressor Outlet Temperature - Data Above Normal

FAULT CODE 2347 (ISB/QSB Automotive or Industrial Application)

Turbocharger Compressor Outlet Temperature - Data Above Normal

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2347 PID: S151 SPN: 611 FMI: 0/15 LAMP: Amber SRT: | Turbocharger compressor outlet temperature - data above normal. High turbocharger compressor outlet temperature has been calculated by the ECM. | Fuel is limited in an attempt to decrease the calculated turbocharger compressor outlet temperature.
Turbocharger Compressor Inlet Air Temperature Sensor Circuit

Circuit Description

The turbocharger compressor outlet temperature is calculated by the electronic control module (ECM) and based on engine operating conditions such as turbocharger compressor inlet temperature, barometric pressure, turbocharger speed, engine speed, intake manifold air temperature, and intake manifold pressure.

Component Location

There is not a physical turbocharger compressor outlet temperature sensor on the engine. The turbocharger compressor outlet temperature is a calculation of the temperature of the air after it is compressed by the turbocharger but before Exhaust Gas Recircluation (EGR) is mixed into the system and before it enters the charge air cooler.

Shop Talk

Possible causes for high turbocharger compressor outlet temperature include:

  • Air intake leaks between the air filter and turbocharger, allowing warm underhood air to enter the turbocharger compressor inlet
  • Incorrect turbocharger compressor inlet temperature sensor output
  • Incorrect output of sensors used to calculate turbocharger compressor outlet temperature, such as ambient air pressure and turbocharger speed.

NOTE: This code will most likely not be active with no load in the shop. The engine must be loaded to trip this fault code and determine if the failure has been found and fixed.

Refer to Troubleshooting Fault Code t05-2347

Last Modified: 08-Jul-2010


Turbocharger Compressor Outlet Air Temperature (Calculated) - Data Valid but Above Normal Range

FAULT CODE 2347 (ISC/QSC/ISL/QSL Automotive, Industrial, or Marine Application)

Turbocharger Compressor Outlet Air Temperature (Calculated) - Data Valid but Above Normal Range

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2347 PID: SPN: 2790 FMI: 0/15 LAMP: None SRT: | Turbocharger Compressor Outlet Air Temperature (Calculated) - Data Valid but Above Normal Range - least severe level. | Engine power derate.
Turbocharger Compressor Outlet Air Temperature

Circuit Description

The turbocharger compressor outlet air temperature is calculated by the electronic control module (ECM). Turbocharger compressor outlet air temperature is calculated by the ECM based on engine operating conditions such as turbocharger compressor inlet air temperature, barometric pressure, turbocharger speed, engine speed, intake manifold air temperature, and intake manifold pressure.

Component Location

There is not a physical turbocharger compressor outlet air temperature sensor in the system. The turbocharger compressor outlet air temperature is a calculation of the temperature of the air after it is compressed by the turbocharger compressor.

Shop Talk

Possible causes of this fault code include:

  • Air intake leaks allowing hot underhood air to enter the intake system
  • Faulty intake manifold pressure readings
  • High turbocharger speed readings
  • Faulty barometric pressure readings
  • Stuck turbocharger control valve
  • Stuck variable geometry turbocharger.

NOTE: Unless the failure is a failed barometric pressure sensor or intake manifold pressure sensor, this fault code will most likely not be active with no load in the shop. The engine will most likely need to be loaded to trip this fault code, and to determine if the failure has been found and fixed.

Refer to Troubleshooting Fault Code t05-2347

Last Modified: 08-Jul-2010


EGR Valve Failed Automatic Calibration Procedure

FAULT CODE 2348

EGR Valve Failed Automatic Calibration Procedure

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2348 PID: P027 SPN: 27 FMI: 13/13 LAMP: Amber SRT: | EGR valve failed automatic calibration procedure - out of calibration. | Possible low power. Power will be removed from the EGR valve motor.
EGR Valve Circuit

Circuit Description

The electronic control module (ECM) periodically checks and adjusts the zero position of the EGR valve position sensor when the EGR valve is closed. This self-calibrating feature adjusts for wear and unit-to-unit variation of position sensors and valve assemblies. This fault is logged if the position sensor reading is outside the self-calibration limit.

Component Location

The EGR valve position sensor is located on the EGR valve assembly. The EGR valve assembly is located on the exhaust side of the engine, mounted to the exhaust manifold. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

A possible cause of this fault could be an EGR valve assembly internal failure causing the EGR valve to not close fully.

When troubleshooting inactive counts of this fault code, running the EGR Valve Test in INSITE™ electronic service tool could help identify a stuck EGR valve.

Refer to Troubleshooting Fault Code t05-2348

Last Modified: 08-Jul-2010


EGR Valve Control Circuit - Current Below Normal or Open Circuit

FAULT CODE 2349

EGR Valve Control Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2349 PID: S146 SPN: 2791 FMI: 5/5 LAMP: Amber SRT: | EGR Valve Control Circuit - Current Below Normal or Open Circuit. High voltage or open circuit detected at the EGR valve motor circuit. | Possible low power. Power removed from EGR valve motor.
EGR Valve Control Circuit - Shorted High or Open

Circuit Description

The electronic control module (ECM) controls the EGR valve, opening and closing it based on various operating conditions. The EGR valve is opened and closed by a DC motor that receives voltage from the ECM on the EGR valve motor signal (+) and EGR valve motor signal (-) circuits. To open the valve, the motor receives voltage on the EGR valve motor signal (+) circuit. To close the valve, the motor receives voltage on the EGR valve motor signal (-) circuit.

Component Location

The EGR valve motor is located on the exhaust side of the engine and is attached to the EGR valve assembly, which is mounted on the exhaust manifold. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

The ECM monitors the voltage level of this circuit and logs a fault code if the voltage level indicates an open circuit or if a short circuit to voltage source is present. This fault is always set inactive when the keyswitch is turned on. If the fault condition reoccurs while the keyswitch is in the ON position, the fault code will be set active. Since active faults are set inactive at key “ON,” this troubleshooting tree should be used to troubleshoot active and inactive faults. Possible causes of this fault include:

  • EGR valve motor output (+) or (-) leads shorted to a voltage source in the engine harness or ECM
  • An open circuit in the engine harness, connectors, motor, or ECM.

NOTE: Do not supply voltage of any kind to the EGR valve motor. This circuit uses a pulse-width-modulated signal and direct voltage can permanently damage the motor.

Refer to Troubleshooting Fault Code t05-2349

Last Modified: 08-Jul-2010


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 234 (ISB/QSB Automotive and Industrial, ISC/QSC/ISL/QSL Automotive, Industrial and Marine)

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: P190 SPN: 190 FMI: 0/0 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level. Engine speed signal indicates engine speed above engine protection limit. | Fuel injection disabled until engine speed falls below the overspeed limit.
Original Wiring Harness - Camshaft Position Sensor and Engine Speed Sensor Circuit
Revised Wiring Harness - Camshaft Position Sensor and Engine Speed Sensor Circuit

Circuit Description

The crankshaft engine speed sensor and the camshaft engine position sensor provide engine speed and position information to the electronic control module (ECM) through the engine harness.

Component Location

The crankshaft speed sensor is located on the intake side of the engine near the number 6 cylinder at the crankshaft centerline. For ISB and QSB5.9, the crankshaft engine speed sensor is located on the intake side of the engine behind the vibration damper near the tone wheel. The camshaft speed sensor is located below the fuel pump in the back of the gear housing.

Shop Talk

Possible causes of this fault code include:

  • External fuel sources drawn into the intake air passage
  • Reverse powering (motoring) of the engine
  • Tampering of the engine speed/position sensors.

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify that there are no oil leaks. Inspect the engine speed/position sensors for damage or tampering.

The sensor return configuration for Euro 4 ISB engines has been changed for automotive wiring harnesses manufactured from February 2012 onward. The new style wiring harnesses can be be identified using the method below:

  • Disconnect the ECM connector
  • Disconnect the camshaft position sensor
  • Disconnect the intake manifold pressure/temperature sensor
  • Check for continuity between the intake manifold pressure/temperature sensor RETURN pin and the camshaft position sensor RETURN pin
  • Check for continuity between ECM pin 47 and the camshaft position sensor RETURN pin
  • Use the table below to determine which harness is fitted to the engine.

Engine Harnesses
From | To | New Harness | Old Harness
Intake manifold pressure/temperature sensor RETURN pin | Camshaft position sensor RETURN pin | Open circuit | Short circut
ECM pin 47 | Camshaft position sensor RETURN pin | Open circuit | Short circuit

NOTE: QSB engines, all C series engines, and all L series engines are not affected by this change.

Refer to Troubleshooting Fault Code t05-234.

Last Modified: 02-Feb-2012


Engine Crankshaft Speed/Position - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 234 (QSB Marine Application)

Engine Crankshaft Speed/Position - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: P190 SPN: 190 FMI: 0/0 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid but Above Normal Operational Range - Most Severe Level. Engine speed signal indicates engine speed above engine protection limit. | Fuel injection disabled until engine speed falls below the overspeed limit.
Camshaft Position Sensor and Engine Speed Sensor Circuit

Circuit Description

The crankshaft engine speed sensor and the camshaft engine position sensor provide engine speed and position information to the Electronic Control Module (ECM) through the engine harness.

Component Location

For ISB and QSB5.9 the crankshaft engine speed sensor is located on the intake side of the engine behind the vibration damper near the tone wheel. The camshaft speed sensor is located below the fuel pump in the back of the gear housing.

Shop Talk

Possible causes of this fault code include:

  • External fuel sources drawn into the intake air passage
  • Reverse powering (motoring) of the engine
  • Tampering of the engine speed/position sensors.

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify that there are no oil leaks. Inspect the engine speed/position sensors for damage or tampering.

Refer to Troubleshooting Fault Code t05-234

Last Modified: 08-Jul-2010


Coolant Level - Data Valid but Below Normal Operational Range - Most Severe Level

FAULT CODE 235

Coolant Level - Data Valid but Below Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 235 PID: P111 SPN: 111 FMI: 1 LAMP: Amber SRT: | Coolant Level - Data Valid but Below Normal Operational Range - Most Severe Level. Low engine coolant level detected. | Progressive power derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after Red Stop lamp starts flashing. Marine: None. No engine protection for sensor or circuit failure.
Engine Coolant Level

Circuit Description

The engine coolant level sensor monitors the engine coolant level within the coolant system and passes information to the electronic control module (ECM) through the OEM harness.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM troubleshooting and repair manual for the location.

Shop Talk

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

Refer to Troubleshooting Fault Code t05-235

Last Modified: 08-Jul-2010


EGR Valve Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2351

EGR Valve Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2351 PID: S146 SPN: 2791 FMI: 4/4 LAMP: Amber SRT: | EGR Valve Control Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the EGR valve motor circuit. | Possible low power. Power removed from EGR valve motor.
EGR Valve Control Circuit

Circuit Description

The electronic control module (ECM) controls the EGR valve, opening and closing it based on various operating conditions. The EGR valve is opened and closed by a DC motor that receives voltage from the ECM on the EGR valve motor signal (+) and (-) circuits. To open the valve, the motor receives voltage on the EGR valve motor signal (+) circuit. To close the valve, the motor receives voltage on the EGR valve motor signal (-) circuit.

Component Location

The EGR valve motor is located on the exhaust side of the engine and is attached to the EGR valve assembly, which is mounted to the exhaust manifold. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

The ECM monitors the voltage level of the circuit and logs a fault code if the voltage level indicates a short to ground. This fault is always set inactive when the keyswitch is turned ON. If there is a failure of this circuit, the fault code will not be set active until the valve has been actuated. For these reasons, this troubleshooting tree must be used of both active and inactive fault codes. This also means that the only sufficient way for making sure that the repair is effective is to run the INSITE™ EGR Valve Test. Running the engine may not be enough to verify that the fix was effective.

A possible cause of this fault is EGR valve motor output (+ or -) leads shorted to ground in the harness, EGR valve motor, or ECM.

Refer to Troubleshooting Fault Code t05-2351

Last Modified: 08-Jul-2010


EGR Valve Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2352

EGR Valve Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2352 PID: S146 SPN: 2791 FMI: 3/3 LAMP: Amber SRT: | EGR Valve Control Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the EGR valve motor circuit. | Possible low power. Power will be removed from the EGR valve motor.
EGR Valve Control Circuit

Circuit Description

The electronic control module (ECM) controls the EGR valve, opening and closing it based on various operating conditions. The EGR valve is opened and closed by a DC-motor that receives voltage from the ECM on the EGR valve motor signal (+) and (-) circuits. To open the valve, the motor receives voltage on the EGR valve motor signal (+) circuit. To close the valve, the motor receives voltage on the EGR valve motor signal (-) circuit.

Component Location

The EGR valve motor is located on the exhaust side of the engine and is attached to the EGR valve assembly, which is mounted to the exhaust manifold. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

The ECM monitors the voltage level of the circuit and logs a fault code if the voltage level indicates a short to ground. This fault is always set inactive when the keyswitch is turned ON. If there is a failure of this circuit, the fault code will not be set active until the valve has been actuated. For these reasons this troubleshooting tree must be used for both active and inactive fault codes. This also means that the only sufficient way for making sure that the repair is effective is to run the INSITE™ electronic service tool EGR Valve Test. Running the engine may not be enough to verify that the fix was effective.

Possible causes of this fault are that the EGR motor (+ or - ) leads could be shorted to a voltage source in the harness or ECM.

Refer to Troubleshooting Fault Code t05-2352

Last Modified: 08-Jul-2010


EGR Valve Control Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 2353

EGR Valve Control Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2353 PID: S146 SPN: 2971 FMI: 6/6 LAMP: Amber SRT: | Exhaust Gas Recirculation (EGR) valve control circuit - current above normal or grounded circuit. Excess current detected at the EGR valve motor output circuit. | Possible low power. Power will be removed from the EGR valve motor.
EGR Valve Motor Output Circuit

Circuit Description

The Electronic Control Module (ECM) controls the EGR valve, opening and closing it based on various operating conditions. The EGR valve is opened and closed by a DC motor that receives voltage from the ECM on the EGR valve motor SIGNAL (+) and (-) circuits. To open the valve, the motor receives voltage on the EGR valve motor SIGNAL (+) circuit. To close the valve, the motor receives voltage on the EGR valve motor SIGNAL (-) circuit.

Component Location

The EGR valve motor is located on the exhaust side of the engine and is attached to the EGR valve assembly, which is mounted to the exhaust manifold. Refer to Procedure 100-002 for a detailed component view.

Shop Talk

The ECM monitors the current draw of this circuit. If the ECM detects excessive current for a calibrated period of time, it records this fault.

Possible causes of this fault include:

  • EGR valve motor (+) or (-) leads shorted together in the engine harness, EGR valve motor, or ECM
  • Low EGR valve motor internal resistance.
Refer to Troubleshooting Fault Code t05-2353

Last Modified: 08-Jul-2010


EGR Valve Control - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 2357

EGR Valve Control - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2357 PID: S146 SPN: 2791 FMI: 7/7 LAMP: Amber SRT: | Exhaust Gas Recirculation (EGR) Valve Control - Mechanical System Not Responding Properly or Out of Adjustment. EGR valve motor does not respond or is slow to respond. | Possible low power. Power will be removed from the EGR valve motor.
EGR Valve Control Circuit

Circuit Description

The electronic control module (ECM) controls the EGR valve, opening and closing it based on various operating conditions. The EGR valve is opened and closed by a DC motor that receives voltage from the ECM on the EGR valve motor SIGNAL (+) circuit. To open the valve, the motor receives voltage on the EGR valve motor SIGNAL (+) circuit. To close the valve, the motor receives voltage on the EGR valve motor SIGNAL (-) circuit.

Component Location

The EGR valve motor is located on the exhaust side of the engine and is attached to the EGR valve assembly, which is mounted to the exhaust manifold. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

The ECM monitors the duty cycle of the valve and logs a fault code if the duty cycle is too high. This fault is always set inactive when the keyswitch is turned ON. If there is a failure, the fault code will not be set active until the valve has been actuated. For these reasons, this troubleshooting tree must be used for both active and inactive fault codes. This also means the only sufficient way to make sure the repair is effective, is to run the INSITE™ EGR Valve Test. Running the engine may not be enough to verify the repair was effective.

Possible causes of this fault include:

  • Failed EGR valve position sensor; mechanical or electrical failure
  • EGR valve assembly failure requiring a high current to operate the valve, such as a stuck or sticking valve.
Refer to Troubleshooting Fault Code t05-2357

Last Modified: 08-Jul-2010


EGR Differential Pressure Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2359

EGR Differential Pressure Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2359 PID: P411 SPN: 411 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Recirculation (EGR) Differential Pressure Sensor - Data Valid but Above Normal Operating Range - Moderately Severe Level. EGR differential pressure sensor failed automatic calibration procedure or EGR differential pressure reading not valid for engine operating conditions. | EGR valve will be closed.
EGR Differential Pressure Sensor Circuit

Circuit Description

The Exhaust Gas Recirculation (EGR) differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

Component Location

The EGR differential pressure sensor is mounted on the intake side of the engine on the air intake connection. Refer to Procedure 100-002 in Section E.

Note: The sensor is connected to the engine harness through a short pigtail harness. The pigtail harness is permanently affixed to the sensor. Do not try to remove the connector that is attached to the sensor body, or damage to the sensor will result.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning EGR differential pressure sensor
  • A plugged or leaking low or high EGR differential pressure drilling
  • A stuck open or closed EGR valve
  • A damaged EGR connection tube hose
  • A leak in the EGR connection tube hoses or tubes
  • A damaged variable geometry turbocharger
  • A damaged variable geometry actuator.

Note: If Fault Code 2359 is active after a key-cycle and the engine is not operating, it will be set inactive only if the following conditions are met:

  • Engine coolant temperature is greater than 67°C [154°F]
  • Intake manifold air temperature is greater than 16°C [60°F]
  • Keyswitch transitions from ON to OFF
  • EGR differential pressure sensor reading is within a set calibration threshold near zero.
Refer to Troubleshooting Fault Code t05-2359

Last Modified: 08-Jul-2010


Engine Brake Actuator Circuit #1 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2362

Engine Brake Actuator Circuit #1 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2362 PID: S028 SPN: 1072 FMI: 4 LAMP: Amber SRT: | Engine Brake Actuator Circuit #1 - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the engine brake solenoid number 1 signal circuit. | Engine brake on cylinders 1,2, and 3 can not be activated or exhaust brake will not operate.
Engine Brake Circuit

Circuit Description

This circuit can be used to control either an exhaust brake or an engine brake depending on the application. The ECM controls engine brakes on cylinders 1, 2, and 3 by sending a signal on the engine brake solenoid number 1 signal circuit. If an exhaust brake is installed, the exhaust brake is driven by the engine brake solenoid number 1 signal line. A 2-pin Weather Pack connector is located near the number 3 injector pass-through connector at the back of the engine. If an engine brake is installed, there will be a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing. If an exhaust brake is installed, the OEM will connect one wire to the 2-pin Weather Pack connector for the exhaust brake relay.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness from the ECM. The exhaust brake is an optional feature that is mounted in the exhaust system by the OEM.

Shop Talk

Possible causes of this fault code include a short circuit to ground in the engine harness, connector, or engine brake solenoids.

Refer to Troubleshooting Fault Code t05-2362

Last Modified: 08-Jul-2010


Engine Brake Actuator Circuit #2 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2363

Engine Brake Actuator Circuit #2 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2363 PID: S029 SPN: 1073 FMI: 4 LAMP: Amber SRT: | Engine Brake Actuator Circuit #2 - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the engine brake solenoid number 2 signal circuit. | Engine brake on cylinders 4, 5, and 6 can not be activated.
Engine Brake Actuator Circuit #1

Circuit Description

The ECM controls engine brakes on cylinders 4, 5, and 6 by sending a signal on the engine brake solenoid number 2 signal circuit. A 2-pin Weather Pack connector is located near the number 3 injector pass-through connector at the back of the engine. There is a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness from the ECM.

Shop Talk

Possible causes of this fault code include short circuit to ground in the engine harness, connectors, or engine brake solenoids.

Refer to Troubleshooting Fault Code t05-2363

Last Modified: 08-Jul-2010


Engine Brake Actuator Circuit #1 - Voltage Above Normal or Shorted to High Source

FAULT CODE 2366

Engine Brake Actuator Circuit #1 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2366 PID: S028 SPN: 1072 FMI: 3 LAMP: Amber SRT: | Engine Brake Actuator Circuit #1 - Voltage Above Normal or Shorted to High Source. Open circuit or high voltage detected at the engine brake solenoid number 1 signal circuit. | Engine brake on cylinders 1, 2, and 3 can not be activated or exhaust brake will not operate.
Engine Brake Circuit

Circuit Description

This circuit can be used to control either an exhaust brake or an engine brake depending on the application. The ECM controls engine brakes on cylinders 1, 2, and 3 by sending a signal on the engine brake solenoid number 1 signal circuit. If an exhaust brake is installed, the exhaust brake is driven by the engine brake solenoid number 1 signal line. A 2-pin Weather Pack connector is located near the number 3 injector pass-through connector at the back of the engine. If an engine brake is installed, there will be a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing. If an exhaust brake is installed, the OEM will connect one wire to the 2-pin Weather Pack connector for the exhaust brake relay.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness from the ECM. The exhaust brake is an optional feature that is mounted in the exhaust system by the OEM.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the engine harness, brake harness, or engine brake solenoids
  • Short to voltage source in the engine harness
  • Failed ECM.
Refer to Troubleshooting Fault Code t05-2366

Last Modified: 08-Jul-2010


Engine Brake Actuator Circuit #2 - Voltage Above Normal or Shorted to High Source

FAULT CODE 2367

Engine Brake Actuator Circuit #2 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2367 PID: S029 SPN: 1073 FMI: 3 LAMP: Amber SRT: | Engine Brake Actuator Circuit #2 - Voltage Above Normal or Shorted to High Source. Open circuit or high voltage detected at the engine brake solenoid number 2 signal circuit. | Engine brake on cylinders 4, 5, and 6 can not be activated.
Engine Brake Circuit

Circuit Description

The ECM controls engine brakes on cylinders 4, 5, and 6 by sending a signal on the engine brake solenoid number 2 signal circuit. A 2-pin Weather Pack connector is located near the number 3 injector pass-through connector at the back of the engine. There is a jumper harness from this connector to the engine brake pass-through connectors on the rocker lever housing.

Component Location

The engine brake solenoids are located under the valve cover. The engine brake solenoids are controlled through the engine harness from the ECM.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the engine harness, brake harness, or engine brake solenoids
  • Short to voltage source in the engine harness
  • Failed ECM.
Refer to Troubleshooting Fault Code t05-2367

Last Modified: 08-Jul-2010


External Speed Command Input (Multiple Unit Synchronication) - Data Erratic, Intermittent, or Incorrect

FAULT CODE 237

External Speed Command Input (Multiple Unit Synchronication) - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 237 PID: S030 SPN: 644 FMI: 2 LAMP: Amber SRT: | External Speed Command Input (Multiple Unit Synchronization) - Data Erratic, Intermittent, or Incorrect. The throttle input signal to the primary or secondary engine for multiple unit synchronization is less than 3 percent or more than 97 percent. | Primary or secondary engines may be shut down.
Multi-Unit synchronization

Circuit Description

The primary engine broadcasts the engine speed control message over the J1939 datalink to all secondary engines. Jumper wires are used to configure an engine as a primary engine or as a secondary engine. Only one engine can be configured as the primary engine. Up to five engines can be configured as secondary engines on the same J1939 datalink.

Component Location

The J1939 datalink connections are part of the OEM harness. Location of the J1939 harness will vary by the OEM. Refer to the OEM manual for specific component location.

The configuration of the three pins inputs to the electronic control module (ECM) on the OEM harness determines if an engine is a primary or secondary engine. To activate a pin, the pin must be grounded. To deactivate a pin, the pin must be open circuit.

Multi-Unit Number 3 | Multi-Unit Number 2 | Multi-Unit Number 1 | Description
Inactive | Inactive | Inactive | Error Condition
Inactive | Inactive | Active | Primary
Inactive | Active | Inactive | Secondary 1
Inactive | Active | Active | Secondary 2
Active | Inactive | Inactive | Secondary 3
Active | Inactive | Active | Secondary 4
Active | Active | Inactive | Secondary 5
Active | Active | Active | Error Condition
Refer to Troubleshooting Fault Code t05-237

Last Modified: 08-Jul-2010


Exhaust Gas Pressure Sensor Circuit - Shorted High

FAULT CODE 2373

Exhaust Gas Pressure Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2373 PID: P095 SPN: 1209 FMI: 3/3 LAMP: Amber SRT: | Exhaust gas pressure sensor circuit - shorted high. High voltage detected at the exhaust gas pressure sensor circuit. | Engine will be derated.
Exhaust Gas Pressure Sensor Circuit

Circuit Description

The exhaust gas pressure sensor measures the pressure of the gas exhaust in the manifold and passes that information to the electronic control module (ECM) through the engine harness. This information is used by the ECM to control emissions and EGR valve operation. If the exhaust gas pressure becomes too high, it will cause a derate condition.

Component Location

The exhaust gas pressure sensor is located on the EGR cooler on the exhaust side of the engine. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

The exhaust gas pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to become active.

Possible causes of this fault code include:

  • Signal wire shorted to sensor supply or battery voltage
  • Open return circuit in the engine harness, connectors, or sensor.
Refer to Troubleshooting Fault Code t05-2373.

Last Modified: 06-Oct-2010


Exhaust Gas Pressure Sensor Circuit - Shorted Low

FAULT CODE 2374

Exhaust Gas Pressure Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2374 PID: P095 SPN: 1209 FMI: 4/4 LAMP: Amber SRT: | Exhaust gas pressure sensor circuit - shorted low. Low voltage detected on the exhaust gas pressure sensor exhaust circuit. | Engine power derate.
Exhaust Gas Pressure Sensor Circuit

Circuit Description

The exhaust gas pressure sensor measures the pressure of the gas in the exhaust manifold and passes that information to the electronic control module (ECM) through the engine harness. This information is used by the ECM to control emissions and for valve operation. If the exhaust gas pressure becomes too low, it will cause a derate condition.

Component Location

The exhaust gas pressure sensor is located on the EGR cooler on the exhaust side of the engine. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

The exhaust gas pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to become active.

Possible causes of this fault code include:

  • Signal wire open or shorted to ground in the harness
  • Supply line open or shorted to ground
  • Sensor shorted to ground.
Refer to Troubleshooting Fault Code t05-2374

Last Modified: 08-Jul-2010


Exhaust Gas Recirculation (EGR) Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2375

Exhaust Gas Recirculation (EGR) Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2375 PID: P412 SPN: 412 FMI: 3 LAMP: Amber SRT: | EGR Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the EGR temperature sensor circuit. | EGR valve will be closed.
EGR Temperature Sensor Circuit

Circuit Description

The EGR temperature sensor is used to measure the temperature of the exhaust gas that exits the EGR cooler. The electronic control module (ECM) uses this temperature to control emission levels of the engine.

Component Location

The EGR temperature sensor is located in the intake air horn at the front of the engine. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault code is set active if the sensor signal voltage is above the normal operating range for the sensor and the ECM has commanded the EGR valve open. This fault code will not be set active if the ECM has commanded the EGR valve closed. However, once the fault code is set, it will remain active independent of whether the EGR valve is open or closed.

The EGR temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active. Before troubleshooting Fault Code 2375, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, sensor, or ECM
  • Open signal circuit or shorted to a voltage source.

Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 256k to 423k
20 | 68 | 99k to 154k
40 | 104 | 42k to 63k
100 | 212 | 5.5k to 7.1k
140 | 284 | 1.9k to 2.3k
200 | 392 | 520 to 580
Refer to Troubleshooting Fault Code t05-2375

Last Modified: 08-Jul-2010


Recirculation Exhaust Gas Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2376

Recirculation Exhaust Gas Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2376 PID: P412 SPN: 412 FMI: 4/4 LAMP: Amber SRT: | Recirculation Exhaust Gas (EGR) Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the EGR temperature circuit. | EGR valve will be closed.
EGR Temperature Sensor Circuit

Circuit Description

The EGR temperature sensor is used to measure the temperature of the exhaust gas that exits the EGR cooler. The electronic control module (ECM) uses this temperature to control the emission levels of the engine.

Component Location

The EGR temperature sensor is located in the intake air horn at the front of the engine. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault code is set active if the sensor signal voltage is below the normal operating range for the sensor and the electronic control module (ECM) has commanded the EGR valve open. This fault code will not be set active if the ECM has commanded the EGR valve closed. However, once the fault code is set, it will remain active independent of whether the EGR valve is open or closed.

The EGR temperature sensor shares return wires in the engine harness with other sensors. An shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 2376, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness or ECM
  • Signal shorted to return or ground in the sensor.

Temperature (°C) | Temperature (°F) | Resistance (ohms)
0 | 32 | 256k to 423k
20 | 68 | 99k to 154k
40 | 104 | 42k to 63k
100 | 212 | 5.5k to 7.1k
140 | 284 | 1.9k to 2.3k
200 | 392 | 520 to 580
Refer to Troubleshooting Fault Code t05-2376

Last Modified: 08-Jul-2010


Fan Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2377

Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2377 PID: S033 SPN: 647 FMI: 3 LAMP: Amber SRT: | Fan Control Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or high voltage detected at the fan control circuit. | The fan may stay on continuously or not run at all.
Fan Control Circuit

Circuit Description

The engine control module (ECM) provides a signal to the fan control solenoid to turn the engine fan on and off. There are two types of fans supported by this signal, variable speed and ON/OFF. INSITE™ electronic service tool can be used to determine which fan type is currently set up for use. The fan control circuit varies by original equipment manufacturer (OEM). Certain OEMs may use a solenoid return that is wired to the ECM or may use a return that goes to engine block or chassis ground.

Component Location

The fan clutch solenoid location varies by OEM. Refer to the appropriate OEM service literature to determine the location.

Shop Talk

The ECM monitors the voltage level on this circuit. When the ECM commands the fan signal low, it expects the voltage level to be approximately 0 volts. If it detects a high voltage, this fault is recorded.

If Fault Code 2377 is still active after completing the following troubleshooting steps, consult the OEM service literature for procedures to check the fan clutch device for an open circuit or short circuit to ground.

Possible causes of this fault include:

  • Open circuit in the engine harness or fan control solenoid
  • Short circuit to voltage source in the OEM harness
  • Failed ECM.
Refer to Troubleshooting Fault Code t05-2377

Last Modified: 01-Nov-2016


Sensor Supply 3 Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 238

Sensor Supply 3 Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 238 PID: S232 SPN: 611 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Below Normal, or Shorted to Low Source. Low voltage detected on the +5 volt sensor supply circuit to the engine speed sensor. | Possible hard starting and rough running.
Engine Speed Sensor Circuit

Circuit Description

The engine speed voltage supply provides +5 VDC for the engine speed sensor. If the supply wire to this sensor is damaged, the sensor will not work properly.

Component Location

The engine speed sensor is located on the intake side of the engine between number 5 and number 6 cylinders at the crankshaft level. Refer to Procedure 100-002 for detailed component view location.

Shop Talk

Low voltage on the +5 VDC supply line can be caused by a short circuit to ground in a supply line, a short circuit between a supply line or a return line, a failed sensor, or a failed ECM power supply.

Refer to Troubleshooting Fault Code t05-238

Last Modified: 08-Jul-2010


Turbocharger Position Sensor Circuit - Shorted High

FAULT CODE 2381

Turbocharger Position Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2381 PID: SPN: 2795 FMI: 4/4 LAMP: Amber SRT: | Turbocharger position sensor circuit - shorted high. High signal voltage detected at the turbocharger position sensor circuit. | Possible low power. Power will be removed from the turbocharger actuator motor. Turbocharger will be open.
Turbocharger Position Sensor Circuit

Circuit Description

The turbocharger position sensor outputs a voltage signal to the electronic control module (ECM). The ECM converts this signal into a percentage value, 0 to 100 percent, indicating the position of the turbocharger actuator. A fully closed turbocharger is equivalent to 100 percent.

Component Location

The turbocharger position sensor is located on the VGT actuator assembly. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

The turbocharger position sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Possible causes of this fault include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal shorted to sensor supply or battery voltage
  • Failed ECM
  • Failed VGT position sensor.
Refer to Troubleshooting Fault Code t05-2381

Last Modified: 08-Jul-2010


Turbocharger Position Sensor Circuit - Shorted Low

FAULT CODE 2382

Turbocharger Position Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2382 PID: SPN: 2795 FMI: 4/4 LAMP: Amber SRT: | Turbocharger position sensor circuit - shorted low. Low signal voltage detected at the turbocharger position sensor circuit. | Possible low power. Power will be removed from the turbocharger actuator motor. Turbocharger will be open.
Turbocharger Position Sensor Circuit

Circuit Description

The turbocharger position sensor outputs a voltage signal to the electronic control module (ECM). The ECM converts this signal into a percentage value, 0 to 100 percent, indicating turbocharger position. A fully closed turbocharger is equivalent to 100 percent.

Component Location

The turbocharger position sensor is located on the VGT actuator assembly. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

The turbocharger position sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Possible causes of this fault include:

  • Signal circuit open or shorted to ground
  • Supply circuit open or shorted to ground
  • Sensor shorted to ground.
Refer to Troubleshooting Fault Code t05-2382

Last Modified: 08-Jul-2010


Variable Geometry Turbocharger Actuator Circuit - Current Below Normal, or Open Circuit

FAULT CODE 2383

Variable Geometry Turbocharger Actuator Circuit - Current Below Normal, or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2383 PID: S027 SPN: 641 FMI: 5/5 LAMP: Amber SRT: | Variable Geometry Turbocharger actuator circuit - current below normal, or open circuit. | Possible low power. Power removed from the turbocharger actuator motor.
Turbocharger Actuator Circuit

Circuit Description

The electronic control module (ECM) controls the turbocharger actuator, which changes the airflow of the turbocharger based on various engine operating conditions. The sliding nozzle in the turbocharger is operated by the turbocharger actuator motor. The actuator is a DC motor that receives voltage from the ECM.

Component Location

The turbocharger actuator motor is part of the turbocharger actuator assembly, which is located on the exhaust side of the engine and is mounted to the bearing housing of the turbocharger. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

The ECM monitors the voltage level of this circuit and logs a fault code if the voltage level indicates an open circuit or short to voltage source is present. This fault is always set inactive when the keyswitch is turned on. If the fault condition reoccurs while the keyswitch is in the ON position, the fault code will be set active. Since active faults are set inactive at key-on, this troubleshooting tree should be used to troubleshoot active and inactive faults. Possible causes of this fault include:

  • An open circuit in the engine harness, connectors, motor, or ECM
  • Turbocharger actuator motor signal (+ or -) leads shorted to a voltage source in the engine harness or ECM.

Do not supply voltage of any kind to the EGR valve motor. This circuit uses a pulse-width-modulated signal and direct voltage can permanently damage the motor.

Refer to Troubleshooting Fault Code t05-2383

Last Modified: 08-Jul-2010


Fault Code Path Selection

FAULT CODE 06-fc2384
Fault Code Path Selection

Is the engine an ISB or QSB? | Go to 06-fc2384b
Is the engine an ISC, QSC, ISL, or QSL? | Go to 06-fc2384cl

Last Modified: 07-Apr-2005


VGT Actuator Driver Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 2384 (ISB/QSB Automotive and Industrial Application)

VGT Actuator Driver Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2384 PID: S027 SPN: 641 FMI: 4/4 LAMP: Amber SRT: | VGT actuator driver circuit - voltage below normal, or shorted to low source. | Possible low power. Power removed from the turbocharger actuator motor.
Turbocharger Actuator Motor Circuit

Circuit Description

The electronic control module (ECM) controls the turbocharger actuator motor, which changes the airflow of the turbocharger based on various engine operating conditions. The sliding nozzle in the turbocharger is operated by the turbocharger actuator motor. The actuator is a DC motor that receives voltage from the ECM.

Component Location

The turbocharger actuator motor is part of the turbocharger actuator assembly, which is located on the exhaust side of the engine and is mounted to the bearing housing of the turbocharger. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

A possible cause of this fault is the turbocharger actuator signal (+ or -) leads can be shorted to ground in the harness, motor, or the ECM.

Do not supply voltage of any kind to the exhaust gas recirculation (EGR) valve motor. This circuit uses a pulse-width-modulated signal and direct voltage can permanently damage the motor.

Refer to Troubleshooting Fault Code t05-2384

Last Modified: 08-Jul-2010


VGT Actuator - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2384 (ISC/QSC/ISL/QSL Automotive, Industrial, or Marine Application)

VGT Actuator - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2384 PID: S027 SPN: 641 FMI: 4 LAMP: Amber SRT: | VGT Actuator - Voltage Below Normal or Shorted to Low Source. Low voltage detected at turbocharger control valve circuit. | Variable geometry turbocharger will go to the open position.
Turbocharger Control Valve Circuit

Circuit Description

The electronic control module (ECM) controls the variable geometry actuator position with the turbocharger control valve. The turbocharger control valve controls the air pressure to the variable geometry actuator when commanded by the ECM. ECM commands are sent to the control valve through the turbocharger control valve signal of the ECM engine harness.

Component Location

The turbocharger control valve is located on the fuel pump side of the engine. It is mounted between the number 5 and number 6 fuel lines on the air intake manifold. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

Turbocharger control valve command can be monitored with the INSITE™ electronic service tool. This parameter represents the ECM command to the turbocharger control valve which in turn controls the variable geometry actuator position.

Possible causes of this fault code include:

  • Signal short circuit to ground
  • Short circuit to ground in the turbocharger control valve.
Refer to Troubleshooting Fault Code t05-2384

Last Modified: 08-Jul-2010


Fault Code Path Selection

FAULT CODE 06-fc2385
Fault Code Path Selection

Is the engine an ISB or QSB? | Go to 06-fc2385b
Is the engine an ISC, QSC, ISL, or QSL? | Go to 06-fc2385cl

Last Modified: 07-Apr-2005


VGT Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2385 (ISB/QSB Automotive or Industrial Application)

VGT Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2385 PID: S027 SPN: 641 FMI: 3/3 LAMP: Amber SRT: | VGT actuator driver circuit - voltage above normal or shorted to high source. | Possible low power. Power removed from the turbocharger actuator motor.
Turbocharger Actuator Motor Circuit

Circuit Description

The ECM controls the turbocharger actuator motor, which changes the airflow of the turbocharger based on various engine operating conditions. The sliding nozzle in the turbocharger is operated by the turbocharger actuator motor. The actuator is a DC motor that receives voltage from the ECM.

Component Location

The turbocharger actuator motor is part of the turbocharger actuator assembly, which is located on the exhaust side of the engine and is mounted to the bearing housing of the turbocharger. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

A possible cause of this fault is the turbocharger actuator signal (+ or -) leads can be shorted to a voltage source in the harness or the ECM.

Do not supply voltage of any kind to the EGR valve motor. This circuit uses a pulse-width-modulated signal and direct voltage can permanently damage the motor.

Refer to Troubleshooting Fault Code t05-2385

Last Modified: 08-Jul-2010


VGT Actuator - Voltage Above Normal or Shorted to High Source

FAULT CODE 2385 (ISC/QSC/ISL/QSL Automotive, Industrial, or Marine Application)

VGT Actuator - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2385 PID: S027 SPN: 641 FMI: 3 LAMP: Amber SRT: | VGT Actuator - Voltage Above Normal or Shorted to High Source. Open circuit or high voltage detected at turbocharger control valve circuit. | Variable geometry turbocharger may be in either the open or closed position.
Turbocharger Control Valve Circuit

Circuit Description

The electronic control module (ECM) controls the variable geometry actuator position with the turbocharger control valve. The turbocharger control valve controls the air pressure to the variable geometry actuator when commanded by the ECM. ECM commands are sent to the control valve through the turbocharger control valve signal of the ECM engine harness.

Component Location

The turbocharger control valve is located on the fuel pump side of the engine. It is mounted between the number 5 and number 6 fuel lines on the air intake manifold. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

Turbocharger control valve command can be monitored with the INSITE™ electronic service tool. This parameter represents the ECM command to the turbocharger control valve, which in turn controls the variable geometry actuator position.

Possible causes of this fault code include:

  • Open circuit in the engine harness or connectors
  • Open circuit in the turbocharger control valve
  • Signal circuit short to voltage source in the engine harness.
Refer to Troubleshooting Fault Code t05-2385

Last Modified: 08-Jul-2010


Turbocharger Actuator Motor Circuit - Current Above Normal

FAULT CODE 2386

Turbocharger Actuator Motor Circuit - Current Above Normal

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2386 PID: SPN: 2975 FMI: 6/6 LAMP: Amber SRT: | Turbocharger actuator motor circuit - current is above normal. Excessive current detected at the turbocharger actuator motor circuit. | Possible low power. Power will be removed from the turbocharger actuator motor.
Turbocharger Actuator Motor Circuit

Circuit Description

The electronic control module (ECM) controls the turbocharger actuator motor, which changes the airflow of the turbocharger based on various engine operating conditions. The sliding nozzle in the turbocharger is operated by the turbocharger actuator motor. The actuator is a VDC motor that receives voltage from the ECM.

Component Location

The turbocharger actuator motor is part of the turbocharger actuator assembly, which is located on the exhaust side of the engine and is mounted to the bearing housing of the turbocharger. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

The ECM monitors the current draw of this circuit. If the ECM detects excessive current for a calibrated period of time, it records this fault. Possible causes of this fault include:

  • Turbocharger actuator motor signal (+ or -) leads shorted together in the engine harness, turbocharger actuator motor, or ECM
  • Low turbocharger actuator motor internal resistance.
Refer to Troubleshooting Fault Code t05-2386

Last Modified: 08-Jul-2010


Turbocharger Actuator Motor - Mechanical System Not Responding Properly

FAULT CODE 2387

Turbocharger Actuator Motor - Mechanical System Not Responding Properly

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2387 PID: S146 SPN: 2975 FMI: 7/7 LAMP: Amber SRT: | Turbocharger actuator motor - the mechanical system is not responding properly or is out of adjustment. Turbocharger actuator is not responding or is slow to respond. | Possible low power. Power will be removed from the turbocharger actuator motor.
Turbocharger Actuator Motor Circuit

Circuit Description

The engine control module (ECM) controls the turbocharger actuator motor, which changes the airflow of the turbocharger based on various engine operating conditions. The sliding nozzle in the turbocharger is operated by the turbocharger actuator motor. The actuator is a DC motor that receives voltage from the ECM.

Component Location

The turbocharger actuator motor is part of the turbocharger actuator assembly, which is located on the exhaust side of the engine and is mounted to the bearing housing of the turbocharger. Refer to Procedure 100-002 in Section E for a detailed component location view.

Shop Talk

Possible causes of this fault include:

  • Malfunctioned turbocharger position sensor, and mechanical or electrical malfuction.
  • Turbocharger actuator motor assembly malfunction, requiring a high current to operate the turbocharger, such as a stuck or sticking turbocharger.

Inspect the turbocharger vanes for residue, and clean the vanes, if required. Find the source of the residue and repair.

Refer to Troubleshooting Fault Code t05-2387

Last Modified: 03-Oct-2012


Variable Geometry Turbocharger Actuator Position Failed Automatic Calibration Procedure - Out of Calibration

FAULT CODE 2388

Variable Geometry Turbocharger Actuator Position Failed Automatic Calibration Procedure - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2388 PID: S269 SPN: 2795 FMI: 13/13 LAMP: Amber SRT: | Variable Geometry Turbocharger actuator position failed automatic calibration procedure - out of calibration. | Variable Geometry Turbocharger Possible low power. Variable Geometry Turbocharger actuator will remain either open or closed.
Turbocharger Actuator Motor Circuit

Circuit Description

The electronic control module (ECM) periodically checks and adjusts the zero position of the turbocharger position sensor when the turbocharger is closed. This self-calibrating feature adjusts for wear and unit-to-unit variation of position sensors and actuator assemblies. This fault is logged if the position sensor reading is outside the calibrated limits.

Component Location

The turbocharger position sensor is mounted on the turbocharger actuator assembly on the bearing housing of the turbocharger. Refer to Procedure 100-002 in Section E for a detailed component location view.

Shop Talk

A possible cause of this fault code could be a turbocharger internal failure causing the turbocharger actuator to not close fully.

When troubleshooting inactive counts of this fault code, running the Turbocharger Actuator Test in INSITE™ electronic service tool could help to identify a stuck turbocharger actuator.

Refer to Troubleshooting Fault Code t05-2388

Last Modified: 08-Jul-2010


Vehicle Speed Sensor Circuit - Data Erratic, Intermittent or Incorrect

FAULT CODE 241

Vehicle Speed Sensor Circuit - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 241 PID: P084 SPN: 84 FMI: 2/2 LAMP: Amber SRT: | Vehicle Speed Sensor Circuit - Data Erratic, Intermittent or Incorrect. The ECM lost the vehicle speed signal. | Engine speed limited to Maximum Engine Speed without VSS parameter value. Cruise control, Gear-Down Protection, and Road Speed Governor will not work.
Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle's transmission. This speed signal is then transmitted to the engine electronic control module (ECM) and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle transmission. Refer to the OEM troubleshooting and repair manual.

Shop Talk

There are multiple types of vehicle speed sensors. Various types include magnetic pickup, data link, digital, and tachograph. Refer to your OEM for the specific type installed on the vehicle.

This fault is set active when the ECM loses a vehicle speed signal when other engine conditions indicate the vehicle is moving. The fault can also become active if there is a series of clutch, service brake or throttle movements with no vehicle movement. The fault is set inactive when the ECM receives a vehicle speed signal greater than zero.

Since the vehicle speed sensor is an OEM installed component, this troubleshooting procedure will not catch all failures of the circuit due to components not under Cummins Inc. control. Sensor resistance values, data link speed sensors and tachographs are not fully covered under this procedure. For more information on those components, please refer to the OEM troubleshooting and repair manual.

Refer to Troubleshooting Fault Code t05-241

Last Modified: 08-Jul-2010


Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

FAULT CODE 242

Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 242 PID: P084 SPN: 84 FMI: 10/10 LAMP: Amber SRT: | Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change. Invalid or inappropriate vehicle speed signal. Signal indicates an intermittent connection or VSS tampering. | Engine speed limited to maximum engine speed without VSS parameter value. Cruise control, gear-down protection, and road speed governor will not work.
Vehicle Speed Sensor Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle's transmission. This speed signal is then transmitted to the engine electronic control module (ECM) and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle transmission.

Shop Talk

Verify that the feature settings for the vehicle speed sensor anti-tampering (Fault Code 242), application type and automatic transmission are set correctly. If any of these are set incorrectly for your specific vehicle and application, Fault Code 242 could occur erroneously.

Driving techniques such as driving for extended periods of time in lower gears can log Fault Code 242. Fault Code 242 can be logged if the driver attempts to defeat the road speed governor by repeatedly cycling the keyswitch.

Once the speed signal has been restored the fault code will go inactive once the keyswitch is on for 30 seconds and the ECM senses zero vehicle and engine speed.

Refer to Troubleshooting Fault Code t05-242

Last Modified: 08-Jul-2010


Coolant Level - Data Valid But Below Normal Operational Range - Least Severe Level

FAULT CODE 2448

Coolant Level - Data Valid But Below Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2448 PID: SPN: 111 FMI: 1/17 LAMP: Maintenance SRT: | Coolant Level - Data Valid But Below Normal Operational Range - Least Severe Level. Low engine coolant level detected. | None on performance.
ISB, ISC, and ISL - Electronic Control Module

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The electronic control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the coolant level is below the normal operating limits.

Action Taken When the Fault Code is Active

  • The ECM flashes the amber CHECK ENGINE light at initial key-on for 30 seconds when low engine coolant level has been detected.

Conditions for Clearing the Fault Code

The ECM will stop flashing the amber CHECK ENGINE light at key-on when coolant has been added to the engine.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

Refer to Troubleshooting Fault Code t05-2448

Last Modified: 08-Jul-2010


Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 245

Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 245 PID: S033 SPN: 647 FMI: 4/4 LAMP: Amber SRT: | Fan Control Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fan control circuit when commanded on. | The fan can possibly stay on continuously or not run at all.
Fan Control Circuit

Circuit Description

The engine control module (ECM) provides a signal to the fan control solenoid to turn the engine fan on and off. There are two types of fans supported by this signal; variable speed and ON/OFF. INSITE™ electronic service tool can be used to determine which fan type is currently set up for use. The fan control circuit varies by original equipment manufacturer (OEM). Certain OEM's may use a solenoid return that is wired to the ECM or may use a return that goes to engine block or chassis ground.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM service literature to determine the location.

Shop Talk

The fan control logic can be adjusted with INSITE™ electronic service tool. There are two choices: 12 or 24 VDC ON, or 0 VDC ON. For proper fan operation, the fan control logic setup with INSITE™ electronic service tool must match the hardware configuration on the vehicle.

This fault code is logged when the ECM commands 12 or 24 VDC to the fan control solenoid, but the voltage on the fan control signal circuit is less than 12 or 24 VDC. The low voltage on the signal circuit usually indicates a short circuit to ground in the harness or solenoid.

If Fault Code 245 is still active after completing the following troubleshooting steps, consult the OEM service literature for procedures to check the fan control circuit for a short circuit to ground.

Refer to Troubleshooting Fault Code t05-245

Last Modified: 01-Nov-2016


Engine Oil Level — Data Valid But Below Normal Operational Range — Most Severe Level

FAULT CODE 253

Engine Oil Level — Data Valid But Below Normal Operational Range — Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 253 PID: P98 SPN: 98 FMI: 1 LAMP: Red SRT: | Engine Oil Level — Data Valid But Below Normal Operational Range — Most Severe Level. Very low oil level has been detected by the oil level sensor. | The engine may derate. Possible low oil pressure, possible severe engine damage.
Circuit: Engine Oil Level Sensor.

Circuit Description

An algorithm in the ECM calibration monitors engine oil level while the ECM is keyed on and no engine speed is detected. If the engine oil level falls below a certain threshold, the ECM will activate Fault 253.

Component Location

The engine oil level sensor is located on the engine oil dipstick, on the air intake side of the engine. 100-002 (Engine Diagrams) in section E for further details on dipstick location.

Shop Talk

If inactive counts of Fault 253 are logged in the ECM, it could be possible that the engine was running or keyed on while tilted at an angle severe enough to cause this fault to be triggered.

Other causes of fault code 253 may include:

  • The engine may not have been filled to proper capacity during the most recent oil change
  • External engine oil leaks (oil leaking onto the ground)
  • Internal engine oil leaks (oil leaking into the fuel system or cooling system)
  • High engine oil consumption/power cylinder failure (check for abnormally high blowby when the engine is loaded).

On-Board Diagnostic (OBD) Information:

  • The ECM illuminates the appropriate amber or red fault lamp when the diagnostic runs and fails
  • The ECM turns off the appropriate fault lamp when the diagnostic runs and passes.
Refer to Troubleshooting Fault Code t05-253

Last Modified: 08-Jul-2010


Exhaust Pressure Sensor Circuit - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2554

Exhaust Pressure Sensor Circuit - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2554 PID: P095 SPN: 1209 FMI: 2/2 LAMP: Amber SRT: | Exhaust pressure sensor circuit - data erratic, intermittent, or incorrect. An error in the exhaust pressure sensor signal was detected by the ECM. | Engine power derate. Exhaust Gas Recirculator (EGR) valve will be closed.
Exhaust Pressure Sensor Circuit

Circuit Description

The exhaust pressure is used by the electronic control module (ECM) to monitor the engine exhaust pressure. This information is used by the ECM to control emissions and EGR valve operation.

Component Location

The exhaust pressure sensor is located above the EGR cooler, on the exhaust side of the engine. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

At key-on, before the engine is started, the readings for intake manifold pressure, barometric pressure, and exhaust pressure are compared. This fault code occurs if the exhaust pressure sensor reading is different from the other two. This check is only done once after the keyswitch is turned on. This fault will not occur while the engine is running.

Refer to Troubleshooting Fault Code t05-2554

Last Modified: 08-Jul-2010


Intake Air Heater #1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2555

Intake Air Heater #1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

Intake Air Heater #1 Circuit - Voltage Above Normal or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 2555 PID: S070 SPN: 729 FMI: 3 LAMP: Amber SRT: | Intake Air Heater #1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the intake air heater signal circuit. | The intake air heaters may be ON or OFF all the time.
Intake Air Heater #1 Circuit

Circuit Description

The intake air heater improves starting and white smoke control in cold ambient conditions. The ECM controls relays that switch power to the intake air heater. 12-volt systems will have two relays while 24-volt systems only require one relay.

Component Location

The intake air heater is located at the air inlet connection into the intake manifold. The location of the intake air heater relays will vary by OEM. Refer to Procedure 100-002 in Section E.

Shop Talk

Possible causes of this fault code include:

  • Intake air heater relay signal wire not connected to the relay
  • Intake air heater relay return wire not connected to the relay
  • Open circuit in the intake air heater relay signal wire
  • Open circuit in the intake air heater relay return wire
  • Intake air heater signal wire shorted to a voltage source.
Refer to Troubleshooting Fault Code t05-2555

Last Modified: 08-Jul-2010


Intake Air Heater #1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2556

Intake Air Heater #1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2556 PID: S070 SPN: 729 FMI: 4 LAMP: Amber SRT: | Intake Air Heater #1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the intake air heater signal circuit. | The intake air heaters may be ON or OFF all the time.
Intake Air Heater #1 Circuit

Circuit Description

The intake air heater improves starting and white smoke control in cold ambient conditions. The ECM controls relays that switch power to the intake air heater. 12-volt systems will have two relays while 24-volt systems only require one relay.

Component Location

The intake air heater is located at the air inlet connection into the intake manifold. The location of the intake air heater relays will vary by OEM. Refer to Section E for a detailed component location view.

Shop Talk

Possible causes of this fault code include:

  • A shorted intake air heater relay
  • Intake air heater relay supply wire shorted to ground.
Refer to Troubleshooting Fault Code t05-2556

Last Modified: 08-Jul-2010


Auxiliary PWM Driver #1 - Voltage Above Normal or Shorted to High Source

FAULT CODE 2557

Auxiliary PWM Driver #1 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2557 PID: S057 SPN: 697 FMI: 3 LAMP: Amber SRT: | Auxiliary PWM Driver #1 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the analog torque circuit. | Can not control transmission.
Auxiliary PWM Driver #1 Circuit

Circuit Description

The transmission shift modulator uses this signal from the ECM to determine when to shift the transmission. The return circuit is dependent on OEM wiring. It may be wired back to the ECM on some vehicles or wired to chassis or block ground on others. Consult the OEM wiring diagram for return circuit details.

Component Location

Refer to the OEM diagram for the location of the transmission shift modulator.

Shop Talk

The default setting for Transmission PWM output Type in INSITE™ electronic service tool is 80/65. The PWM output only has meaning with non-electronic Allison Transmission™ AT545. Older software and ECMs had no diagnostics on this output and having the default set at 86/50 was of no consequence. Newer software and ECMs do have a diagnostic if this output is selected but no hardware is connected. FC 2557 will be logged. Setting Transmission PWM Output Type in INSITE™ electronic service tool to NONE may clear the fault code.

This fault can be caused by the following:

  • A faulty transmission shift modulator
  • An open circuit in the output device driver return line
  • A short pin to pin in the output device driver line.
Refer to Troubleshooting Fault Code t05-2557

Last Modified: 08-Jul-2010


Auxiliary PWM Driver #1 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2558

Auxiliary PWM Driver #1 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2558 PID: S057 SPN: 697 FMI: 4 LAMP: Amber SRT: | Auxiliary PWM Driver #1 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the analog torque circuit. | Can not control transmission.
Auxiliary PWM Driver #1 Circuit

Circuit Description

The transmission shift modulator uses this signal from the ECM to determine when to shift the transmission. The return circuit is dependent on OEM wiring. It may be wired back to the ECM on some vehicles or wired to chassis or block ground on others. Consult the OEM wiring diagram for return circuit details.

Component Location

Refer to the OEM diagram for the location of the transmission shift modulator.

Shop Talk

This fault can be caused by the following:

  • A faulty transmission shift modulator
  • An short circuit to ground on the output device driver line
  • A short pin to pin in the output device driver line.
Refer to Troubleshooting Fault Code t05-2558

Last Modified: 08-Jul-2010


Transmission ECU to ECM Communication - Abnormal Update Rate

FAULT CODE 2559

Transmission ECU to ECM Communication - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2559 PID: SPN: 1845 FMI: 4 LAMP: Amber SRT: | Transmission ECU to ECM Communication Lost - Abnormal Update Rate. No communication or an invalid data transfer rate has been detected between the ECM and the transmission ECU. | None on performance.

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Component values and states from components such as sensors, accelerators, and switches can then be transmitted from the OEM VECU to the Cummins® ECM over the data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The data link wiring and the devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The ECM did not receive a message from the multiplexed device.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp after the diagnostic runs and passes.
  • The “Reset All Faults” command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

This fault can occur for the following reasons:

  • When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a malfunctioning data link connection between the OEM VECU and Cummins® ECM, a malfunctioning connection between the component and the OEM VECU, a malfunctioning OEM VECU, or a malfunctioning Cummins® ECM. It may be necessary to contact the OEM for the proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Refer to Troubleshooting Fault Code t05-2559.

Last Modified: 31-Mar-2014


Engine Coolant Temperature - Condition Exists

FAULT CODE 2659

Engine Coolant Temperature - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2659 PID: P110 SPN: 110 FMI: LAMP: None SRT: | Engine Coolant Temperature - Condition Exists. Engine coolant signal indicates coolant temperature is above the engine coolant temperature engine protection warning limit. | Progressive power derate increasing in severity from time of alert.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The engine coolant temperature sensor is used by the ECM to monitor the engine coolant temperature. The ECM monitors the voltage on the signal pin and converts this to a temperature value. The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control. This fault code will result in an Engine Protection power derate.

Component Location

The engine coolant temperature sensor is located on the exhaust side of the engine, near the thermostat housing. Refer to Procedure 100-002 (Engine Views) in Section E for a detailed component location view.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature. Refer to Engine Coolant Temperature Above Normal symptom tree.

Refer to Troubleshooting Fault Code t05-2659

Last Modified: 08-Jul-2010


Injector Metering Rail 1 Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 268

Injector Metering Rail 1 Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 268 PID: P094 SPN: 94 FMI: 2 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure - Data Erratic, Intermittent, or Incorrect. The ECM has detected that the fuel pressure signal is not changing. | The ECM will estimate fuel pressure, and power is reduced.
Fuel Pressure Sensor Circuit

Circuit Description

The fuel pressure sensor contains supply, signal, and return pins. The ECM provides +5 VDC to the fuel pressure sensor. This +5 VDC power supply is a shared supply. Other sensors on this circuit are the intake manifold pressure sensor, backup engine position sensor.

Component Location

The fuel pressure sensor is located in the rail fuel on the air intake side of the engine. See Procedure Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault code can become active any time the engine is loaded and the ECM detects that fuel pressure in the rail fuel is not changing. This fault code will become inactive whenever the ECM is powered down or if the ECM detects that the engine is loaded and the fuel pressure is changing normally. If there are many inactive counts of this fault code or if the fault is not repeatable, look for signs of tampering to the fuel pressure sensor circuit. If the fault code occurs intermittently (can not be reproduced during a road test), then inspect each of the following for poor connections or damage:

  • Intake manifold pressure sensor
  • Backup engine position sensor
  • Fuel pressure sensor.
Refer to Troubleshooting Fault Code t05-268

Last Modified: 08-Jul-2010


Antitheft Password Valid Indicator — Data Erratic, Intermittent, or Incorrect

FAULT CODE 269

Antitheft Password Valid Indicator — Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 269 PID: S217 SPN: 1195 FMI: 2 LAMP: Red SRT: | Antitheft Password Valid Indicator — Data Erratic, Intermittent, or Incorrect. Engine ignition attempt without authorization from immobilizer anti-theft device. | The engine will not start.
Circuit: Antitheft Password

Circuit Description

The immobilizer anti-theft device is connected to the primary engine Electronic Control Module (ECM) through a J1939 datalink network.

Messages sent from the immobilizer anti-theft device are received by the Cummins engine ECM and used for controlling the anti-theft features. The Cummins ECM and immobilizer anti-theft device must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The engine ECM is located on the intake side of the engine. The J1939 datalink wiring and location of OEM installed J1939 devices varies by OEM. The immobilizer anti-theft device is installed by the OEM.

Shop Talk

This fault code is active when the immobilizer anti-theft device has not been deactivated. The engine will not start until proper authorization has been activated.

On-Board Diagnostics (OBD) Information:

  • The ECM illuminates the appropriate amber or red fault lamp when the diagnostic runs and fails
  • The ECM turns off the appropriate fault lamp when the diagnostic runs and passes.
Refer to Troubleshooting Fault Code t05-269

Last Modified: 08-Jul-2010


Fault Code Path Selection

FAULT CODE 271
Fault Code Path Selection

Is the engine an ISB/QSB Automotive or Industrial application? | Go to 06-fc271b
Is the engine a ISC/QSC/ISL/QSL Automotive, Industrial, or Marine application? | Go to 06-fc271cl

Last Modified: 07-Apr-2005


High Fuel Pressure Solenoid Valve Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 271 (ISB/QSB (Automotive and Industrial Application)

High Fuel Pressure Solenoid Valve Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 271 PID: S126 SPN: 1347 FMI: 4 LAMP: Amber SRT: | High Fuel Pressure Solenoid Valve Circuit - Voltage Below Normal or Shorted to Low Source. Electronic fuel control actuator shorted low. | Engine will run poorly at idle. Engine will have low power. Fuel pressure will be higher than commanded.
Electronic Fuel Control Actuator Circuit

Circuit Description

The circuit is a pulse width modulated (PWM) driver in the Electronic Control Module (ECM) that controls the electronic fuel control actuator. The actuator is grounded in the ECM. The actuator is normally open. Pulse width modulation (PWM) duty cycle to the electronic fuel control actuator depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The electronic fuel control actuator is located on the engine-mounted fuel pump housing. The engine wiring harness and the ECM are other components in the circuit that can cause this fault code. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault becomes active when the ECM detects a short circuit in the electronic fuel control actuator circuit. Causes for this fault code are short circuit to ground or low resistance (electronic fuel control actuator coil is shorted internally) in the circuit for the electronic fuel control actuator. When excessive current or a short circuit is detected, the ECM driver to the electronic fuel control actuator is turned off to protect the circuit. It is necessary to cycle the keyswitch off and then back on before the ECM will retest for the cause of the fault code. The ECM driver is activated at key-on; and if the cause is no longer present, the fault code will become inactive and can be cleared. If the fault code is intermittent, look for causes of an intermittent short to ground in the wiring harness or connectors.

Refer to Troubleshooting Fault Code t05-271

Last Modified: 08-Jul-2010


High Fuel Pressure Solenoid Valve Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 271 (ISC/QSC/ISL/QSL Automotive, Industrial, and Marine Application)

High Fuel Pressure Solenoid Valve Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 271 PID: S126 SPN: 1347 FMI: 4 LAMP: Amber SRT: | High Fuel Pressure Solenoid Valve Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fuel pump actuator circuit. | Engine will run poorly at idle. Engine will have low power. Fuel pressure will be higher than commanded.
Electronic Fuel Control Actuator Circuit

Circuit Description

The circuit is a pulse width modulated (PWM) driver in the Electronic Control Module (ECM) that controls the electronic fuel control actuator. The actuator is grounded in the ECM. The actuator is normally open. Pulse width modulation (PWM) duty cycle to the electronic fuel control actuator depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The fuel pump actuator is located on the engine-mounted fuel pump. The engine siring harness and the ECM are other components in the circuit that can cause this fault code Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault becomes active when the ECM detects a short circuit in the electronic fuel control actuator circuit. Causes for this fault code are short circuit to ground or low resistance (fuel control actuator coil is shorted internally) in the circuit for the fuel pump actuator. When excessive current or a short circuit is detected, the ECM driver to the fuel control actuator is turned off to protect the circuit. It is necessary to cycle the keyswitch off and then back on before the ECM will retest for the cause of the fault code. The ECM driver is reenabled at key-on; and if the cause is no longer present, the fault code will become inactive and can be cleared. If the fault code is intermittent, look for causes of an intermittent short to ground in the wiring harness or connectors. Since the ISC and ISL engines utilize a 2-stage fuel rail pressure relief valve, failures to the fuel pump actuator will result in operation with the fuel rail pressure relief valve open. Extended operation with the fuel rail pressure relief valve open can damage the pressure relief valve.

Fault Code 2311 may have high counts if the fault condition is or was intermittent.

Refer to Troubleshooting Fault Code t05-271

Last Modified: 08-Jul-2010


Fault Code Path Selection

FAULT CODE 272
Fault Code Path Selection

Is the engine an ISB/QSB Automotive or Industrial application? | Go to 06-fc272b
Is the engine a ISC/QSC/ISL/QSL Automotive, Industrial, or Marine application? | Go to 06-fc272cl

Last Modified: 07-Apr-2005


High Fuel Pressure Solenoid Valve Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 272 (ISB/QSB (Automotive and Industrial Application)

High Fuel Pressure Solenoid Valve Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 272 PID: S126 SPN: 1347 FMI: 3 LAMP: Amber SRT: | High Fuel Pressure Solenoid Valve Circuit - Voltage Above Normal or Shorted to High Source. Electronic fuel control actuator shorted high. | Engine will run poorly but will be severely derated. Rail pressure will be higher than commanded.
Electronic Fuel Control Actuator Circuit

Circuit Description

The circuit is a pulse width modulated (PWM) driver in the Electronic Control Module (ECM) that controls the electronic fuel control actuator. The actuator is grounded in the ECM. The actuator is a normally open. Pulse width modulation (PWM) duty cycle to the electronic fuel control actuator depends on the difference between desired rail pressure and sensed rail pressure. Duty cycle will also decrease (electronic fuel control actuator opens) as fueling increases.

Component Location

The electronic fuel control actuator is located on engine-mounted fuel pump housing. The engine wiring harness and the ECM are other components in the circuit that can cause this fault code. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault becomes active when the ECM detects an open in the electronic fuel control actuator circuit. Causes of this fault code are a short circuit to a positive voltage or an open circuit in the electronic fuel control actuator circuit. If there is high harness resistance, Fault Code 2311 could have high inactive counts. If the fault code is intermittent, look for causes of an intermittent open circuit such as loose pins and bad connections.

Refer to Troubleshooting Fault Code t05-272

Last Modified: 08-Jul-2010


High Fuel Pressure Solenoid Valve Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 272 (ISC/QSC/ISL/QSL Automotive, Industrial, and Marine Application)

High Fuel Pressure Solenoid Valve Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 272 PID: S126 SPN: 1347 FMI: 3 LAMP: Amber SRT: | High Fuel Pressure Solenoid Valve Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at the fuel pump actuator circuit. | Engine will not run or engine will run poorly.
High Fuel Pressure Solenoid Valve Circuit

Circuit Description

The circuit is a Pulse With Modulation (PWM) driver in the Electronic Control Module (ECM) that controls the fuel pump actuator. The actuator is grounded in the ECM. The actuator is normally open. PWM duty cycle to the fuel pump actuator depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The fuel pump actuator is located on engine-mounted fuel pump housing. The engine wiring harness and the ECM are other components in the circuit that can cause this fault code. See Procedure Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault becomes active when the ECM detects an open in the fuel pump actuator circuit. Causes of this fault code are a short circuit to a positive voltage or an open circuit in the fuel pump actuator circuit. If there is high harness resistance or an intermittent open circuit, Fault Code 2311 could have high inactive counts. If the fault code is intermittent, look for causes of an intermittent open circuit such as loose pins and bad connections. If the fault code is intermittent, look closely for loose wire connections at the ECM connector. Also, if the fault code is intermittent, wiggle the harness and the electronic fuel control.

Refer to Troubleshooting Fault Code t05-272

Last Modified: 08-Jul-2010


Fuel Pumping Element Number 1 (Front) - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 275

Fuel Pumping Element Number 1 (Front) - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 275 PID: S126 SPN: 1347 FMI: 7 LAMP: Yellow SRT: | Fuel Pumping Element Number 1 (Front) - Mechanical System Not Responding Properly or Out of Adjustment. | Engine will not run or possible low power.
High Pressure Pump

Circuit Description

The fuel pump contains two barrel and plunger assemblies; each barrel and plunger assembly utilizes an inlet and outlet check valve. Fuel at gear pump pressure is metered through the fuel pump actuator and unseats one of the two inlet check valves as the fuel at gear pump pressure enters the pumping chamber. As the pumping plunger begins its upward motion, the pressure in the pumping chamber increases rapidly and the inlet check valve is closed. As pressure reaches accumulator pressure, the outlet check valve is opened. As the plunger travels upward, fuel exits past the outlet check valve and pressurizes the fuel rail.

Component Location

The fuel pump is located on the backside of the gear housing. The barrel and plunger and check valve assemblies are part of the fuel pump head sub-assembly.

Shop Talk

Fault Code 275 will most likely come active while operating at a steady state loaded condition. At this condition commanded fuel pressures are highest and the pump's pressure balance is affected the most.

If a high pressure seal has failed, pump head drain flow will be excessive. If a seal failure has progressed far enough, the engine may not start because of an inability to develop fuel rail pressure.

If the engine will not start, there are two indications that the pump head has failed:

  • The drain flow will be excessive. This can be measured while cranking the engine (refer to Troubleshooting and Repair Manual, ISC, QSC8.3, ISL, and QSL9 Series Engines, Bulletin 4021418).
  • The pumping plungers are broken or mechanically stuck. This can be checked by visual inspection (refer to Troubleshooting and Repair Manual, ISC, QSC8.3, ISL, and QSL9 Series Engines, Bulletin 4021418).

A faulty fuel pressure sensor signal due to a damaged fuel pressure sensor signal wire will cause the fuel pressure sensor to be inconsistent. This condition can cause Fault Code 275 to become active on an intermittent basis.

Refer to Troubleshooting Fault Code t05-275

Last Modified: 08-Jul-2010


Aftertreatment Outlet NOx Sensor - Abnormal Update Rate

FAULT CODE 2771

Aftertreatment Outlet NOx Sensor - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2771 PID: SPN: 3234 FMI: 9 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor - Abnormal Update Rate. No communications or valid data transfer rate detected on the J1939 datalink between the ECM and the aftertreatment outlet NOx sensor. | Aftertreatment outlet NOx sensor operation will be disabled. Engine will derate after running 50 hours with the fault active.
Circuit: Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet nitrogen oxides (NOx) sensor is a smart device and receives commands from the engine electronic control module (ECM) via the J1939 datalink. The aftertreatment outlet NOx sensor receives power and a ground directly from the battery. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM using the J1939 datalink. The aftertreatment outlet NOx sensor is permanently attached to the NOx control module. The aftertreatment outlet NOx sensor is used to measure the outlet NOx emissions from the engine.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the aftertreatment catalyst.

Shop Talk

On-Board Diagnostics (OBD) Information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 1 ignition cycle that the diagnostic runs and does not fail. The MIL lamp can not be cleared using the INSITE™ electronic service tool.
  • The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.

The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually.

Possible causes of this fault code include:

  • The aftertreatment outlet NOx sensor is not receiving power from the battery supply circuit in the OEM harness. This could be caused by an open circuit in the power supply wire, blown NOx sensor fuse, or low voltage supplied by the battery.
  • Open return circuit on the aftertreatment outlet NOx sensor circuit between the battery circuit aftertreatment outlet NOx sensor.
  • Open or short circuit on the J1939 datalink circuit between the engine ECM and aftertreatment outlet NOx sensor.
  • Intermittent communications between the aftertreatment outlet NOx sensor and the primary engine ECM on the J1939 datalink.
  • A damaged engine ECM
  • Incorrect engine calibration.
Refer to Troubleshooting Fault Code t05-2771

Last Modified: 08-Jul-2010


Aftertreatment Outlet NOx - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2772

Aftertreatment Outlet NOx - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2772 PID: SPN: 3226 FMI: 0/15 LAMP: Amber SRT: | Aftertreatment Outlet NOx - Data Valid But Above Normal Operating Range - Least Severe Level. The engine NOx output is higher than recommended levels. | Aftertreatment outlet NOx sensor operation will be disabled.
Circuit: Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet nitrogen oxides (NOx) sensor is a smart device that receives commands from the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor receives power and a ground directly from the battery. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM using the J1939 data link. The aftertreatment outlet NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the outlet NOx emissions from the engine.

Component Location

The aftertreatment outlet NOx sensor location can vary, depending on engine application. It is usually located in the exhaust system, at the outlet of the aftertreatment catalyst.

Shop Talk

On-Board Diagnostics (OBD) Information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) on the second consecutive ignition cycle that the diagnostic runs and fails.
  • The ECM turns OFF the MIL after one ignition cycle that the diagnostic runs and does not fail. The MIL lamp and fault code can not be cleared using INSITE™ electronic service tool.
  • The fault code will be cleared from the memory after 400 days or 9600 hours of engine operation.

The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually.

Possible causes of this fault code include:

  • Diesel exhaust fluid quality is not within specification
  • External leaks in the diesel exhaust fluid dosing unit and/or diesel exhaust fluid lines
  • Aftertreatment nozzle has malfunctioned
  • Aftertreatment diesel exhaust fluid dosing unit has malfunctioned or become damaged
  • Sulfur content of the diesel fuel is too high, fouling the selective catalytic reduction (SCR) catalyst and resulting in high NOx output
  • Plugged or restricted diesel exhaust fluid inline filter, if fitted
  • Aftertreatment nozzle is partially or completely plugged.
Refer to Troubleshooting Fault Code t05-2772.

Last Modified: 19-Mar-2018


Aftertreatment Outlet NOx - Data Valid but Above Normal Operating Range - Most Severe Level

FAULT CODE 2773

Aftertreatment Outlet NOx - Data Valid but Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2773 PID: SPN: 3226 FMI: 0 LAMP: Red SRT: | Aftertreatment Outlet NOx - Data Valid but Above Normal Operating Range - Most Severe Level. The engine NOx output is higher than recommended levels. | Aftertreatment outlet NOx sensor operation will be disabled. Engine will derate the next time that the vehicle sees zero vehicle speed.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet nitrogen oxides (NOx) sensor is a smart device and receives commands from the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor receives power and a ground directly from the battery. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM using the J1939 data link. The aftertreatment outlet NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the outlet NOx emissions from the engine.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the aftertreatment catalyst.

Shop Talk

On-Board Diagnostic (OBD) Information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) on the second consecutive ignition cycle that the diagnostic runs and fails.
  • An engine torque derate will be activated immediately after the fault code becomes active.
  • The ECM turns OFF the MIL after one ignition cycle that the diagnostic runs and does not malfunction. The MIL lamp and fault code cannot be cleared using INSITE™ electronic service tool.
  • The fault code will be cleared from the memory after 400 days or 9600 hours of engine operation.

The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually.

Possible causes of this fault code include:

  • Catalyst solution quality is not within specification, catalyst solution pump and lines external leaks, catalyst solution injector plugged or restricted, and catalyst solution lines plugged or restricted. Catalyst dosing unit has malfunctioned or become damaged
  • Catalyst solution injector nozzle is partially or completely plugged
  • Plugged or restricted diesel exhaust fluid filter, if fitted.
Refer to Troubleshooting Fault Code t05-2773.

Last Modified: 17-May-2018


Fuel Pump Pressurizing Assembly 1 - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 281

Fuel Pump Pressurizing Assembly 1 - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 281 PID: S126 SPN: 1347 FMI: 7 LAMP: Amber SRT: | Fuel Pump Pressurizing Assembly 1 - Mechanical System Not Responding Properly or Out of Adjustment. A pumping imbalance between the front and rear pumping plungers has been detected. | Engine will not run or possible low power.
High Pressure Pump

Circuit Description

The fuel pump contains two barrel and plunger assemblies; each barrel and plunger assembly utilizes an inlet and outlet check valve. Fuel at gear pump pressure is metered through the fuel pump actuator and unseats one of the two inlet check valves as the fuel at gear pump pressure enters the pumping chamber. As the pumping plunger begins its upward motion, the pressure in the pumping chamber increases rapidly and the inlet check valve is closed. As pressure reaches accumulator pressure, the outlet check valve is opened. As the plunger travels upward, fuel exits past the outlet check valve and pressurizes the fuel rail.

Component Location

The fuel pump is located on the backside of the gear housing. The barrel and plunger and check valve assemblies are part of the fuel pump head sub-assembly.

Shop Talk

Fault Code 281 will most likely come active while operating at a steady state loaded condition. At this condition commanded fuel pressures are highest and the pump's pressure balance is affected the most.

If a high pressure seal has failed, pump head drain flow will be excessive. If a seal failure has progressed far enough, the engine may not start because of an inability to develop fuel rail pressure.

If the engine will not start, there are two indications that the pump head has failed:

  • The drain flow will be excessive. This can be measured while cranking the engine (refer to Troubleshooting and Repair Manual, ISC, QSC8.3, ISL, and QSL9 Series Engines, Bulletin 4021418).
  • The pumping plungers are broken or mechanically stuck. This can be checked by visual inspection (refer to Troubleshooting and Repair Manual, ISC, QSC8.3, ISL, and QSL9 Series Engines, Bulletin 4021418).

A faulty fuel pressure sensor signal due to a damaged fuel pressure sensor signal wire will cause the fuel pressure sensor to be inconsistent. This condition can cause Fault Code 281 to become active on an intermittent basis.

Refer to Troubleshooting Fault Code t05-281

Last Modified: 08-Jul-2010


Engine Speed/Position Sensor (Crankshaft) Supply Voltage Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 284

Engine Speed/Position Sensor (Crankshaft) Supply Voltage Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 284 PID: S221 SPN: 1043 FMI: 4/4 LAMP: Amber SRT: | Engine Speed/Position Sensor (Crankshaft) Supply Voltage Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected on the ECM voltage supply line to engine speed sensor. | Possible hard starting and rough running.
Engine Speed Sensor Circuit

Circuit Description

The engine speed voltage supply provides +5 VDC for the engine speed sensor. If the supply wire to this sensor is damaged, the sensor will not work properly.

Component Location

The engine speed sensor is located on the intake side of the engine between number 5 and number 6 cylinders at the crankshaft level. Refer to Procedure 100-002 for detailed component view location.

Shop Talk

Low voltage on the +5 VDC supply line can be caused by a short circuit to ground in a supply line, a short circuit between a supply line or a return line, a failed sensor, or a failed ECM power supply.

Refer to Troubleshooting Fault Code t05-284

Last Modified: 08-Jul-2010


SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

FAULT CODE 285

SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 285 PID: S231 SPN: 639 FMI: 9 LAMP: Amber SRT: | SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate. The Cummins® ECM did not receive a multiplexed message from an OEM VECU or SIM within the time limit or did not receive it at all. | One or more multiplexed devices will not operate properly. One or more symptoms will occur.
SAE J1939 Multiplexing Configuration
SAE J1939 Multiplexing Configuration

Circuit Description

Note: Any reference to VECU may be considered as SIM in marine applications.

Normally, switches, accelerators and other components are connected to the engine ECM directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM Vehicle Electronic Control Unit (VECU) or Transmission ECU in the cab, or a System Integration Module (SIM) in marine applications. As a result, component values and states from components such as sensors, accelerators and switches can be transmitted from the OEM VECU or SIM to the Cummins® engine ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or Transmission ECUs, or SIMs are received by the Cummins® engine ECM and used for controlling the engine. The Cummins® ECM and OEM VECUs must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The engine ECM is located on the intake side of the engine. Refer to Procedure 100-002 in Section E. The J1939 data link wiring and VECU location varies by OEM. The SIM is located on the engine, or in the Vessel Interface Panel (VIP) in marine applications.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM does not receive a valid J1939 message from a multiplexed device for more than 1 second.

The ECM detects an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The ECM will use a default state as an input for the multiplexed device.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

When this fault code is active, some multiplexed devices may not function as desired.

This fault can occur for the following reasons:

  • When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a malfunctioning J1939 data link connection between the OEM VECU and Cummins® ECM, a malfunctioning connection between the component and the OEM VECU, malfunctioning OEM VECU or malfunctioning Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Refer to Troubleshooting Fault Code t05-285

Last Modified: 08-Jul-2010


SAE J1939 Multiplexing Configuration Error - Out of Calibration

FAULT CODE 286

SAE J1939 Multiplexing Configuration Error - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 286 PID: S231 SPN: 639 FMI: 13 LAMP: Amber SRT: | SAE J1939 Multiplexing Configuration Error - Out of Calibration. The ECM expected information from a multiplexed device but only received a portion of the necessary information. | At least one multiplexed device will not operate properly.
SAE J1939 Multiplexing Configuration
SAE J1939 Multiplexing Configuration

Circuit Description

Normally, switches, accelerators and other components are connected to the engine ECM directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM Vehicle Electronic Control Unit (VECU) or Transmission ECU in the cab, or a System Intergration Module (SIM) in marine applications. Then component values and states from components such as sensors, accelerators and switches can be transmitted from the OEM VECU or SIM to the Cummins® engine ECM over the SAE J1939 data link.

Messages sent from OEM VECUs, Transmission ECUs. or SIM are received by the Cummins® engine ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The engine ECM is located on the intake side of the engine. Refer to Procedure 100-002 in Section E.The J1939 data link wiring and VECU location varies by OEM. The SIM is located on the engine, or in the Vessel Interface Panel (VIP) in marine applications.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM expects to receive a valid J1939 message from a multiplexed device for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light immediately after the diagnostic runs and passes.

Shop Talk

Verify the electronic control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe™ Online for applicable fixes to the calibration stored in the ECM. If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

This fault can occur when the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Refer to Troubleshooting Fault Code t05-286

Last Modified: 08-Jul-2010


SAE J1939 Multiplexing Accelerator Pedal or Lever Sensor System Error - Received Network Data Error

FAULT CODE 287

SAE J1939 Multiplexing Accelerator Pedal or Lever Sensor System Error - Received Network Data Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 287 PID: P91 SPN: 91 FMI: 19 LAMP: Red SRT: | SAE J1939 Multiplexing Accelerator Pedal or Lever Sensor System Error - Received Network Data Error. The OEM vehicle electronic control unit (VECU) detected a fault with its accelerator pedal. | Engine may only idle or engine will not accelerate to full speed.
SAE J1939 Multiplexing Accelerator Pedal or Lever Sensor System

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine ECM directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM Vehicle Electronic Control Unit (VECU) or Transmission ECU in the cab. Then component values and states from components (such as sensors, accelerators, and switches) can be transmitted from the OEM VECU to the Cummins engine ECM over the SAE J1939 datalink.

Messages sent from OEM VECU's or Transmissions ECU's are received by the Cummins engine ECM and used for controlling the engine. The Cummins ECM and OEM VECU's must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The engine ECM is located on the intake side of the engine. The J1939 datalink wiring and VECU location varies by OEM.

Shop Talk

This fault can occur when the OEM VECU detects an error on the accelerator and or idle validation switch. The ECM has been set up properly (components enabled and OEM VECU source addressed correctly) to receive multiplexed information for the idle validation switch states and accelerator position over the J1939 datalink from an OEM VECU, and the OEM VECU is transmitting the message for that component.

The three types of errors that can occur for this fault are:

  • When the accelerator is depressed and the OEM VECU reads accelerator position as greater than 0%, but the idle validation switch indicates it is in the idle position. This fault status is transmitted to the Cummins ECM on the J1939 datalink, which causes this fault to occur in the Cummins ECM.
  • When the accelerator is released and the OEM VECU reads accelerator position as 0%, but the idle validation switch indicates it is not in the idle position. This fault status is transmitted to the Cummins ECM on the J1939 datalink, which causes this fault to occur in the Cummins ECM.
  • The OEM VECU determines that the accelerator signal line is shorted high or shorted low.

NOTE: It is still possible to get a Fault Code 285 or 286 if there is an incorrect setup in the OEM VECU or Cummins ECM, for other components, or the accelerator and idle validation switch, or if the datalink is damaged. OEM configurations must multiplex the accelerator and idle validation switch inputs together to allow the use of the J1939 multiplexing and limp home feature for these components. INSITE™ can be used to monitor multiplexed components.

Refer to Troubleshooting Fault Code t05-287

Last Modified: 08-Jul-2010


SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Data Error - Received Network Data Error

FAULT CODE 288

SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Data Error - Received Network Data Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 288 PID: P29 SPN: 974 FMI: 19 LAMP: Red SRT: | SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Data Error - Received Network Data Error. The OEM vehicle electronic control unit (VECU) detected a fault with the remote accelerator. | The engine will not respond to the remote throttle. Engine may only idle. The primary or cab accelerator may be able to be used.
SAE J1939 Multiplexing Remote Accelerator Pedal or Lever

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine ECM directly through individual wires. Multiplexing allows those same components to be hard wired to an OEM Vehicle Electronic Control Unit (VECU) or Transmission ECU in the cab. Then component values and states from components (such as sensors, accelerators, and switches) can be transmitted from the OEM VECU to the Cummins engine ECM over the SAE J1939 datalink.

Messages sent from OEM VECU's or Transmissions ECU's are received by the Cummins engine ECM and used for controlling the engine. The Cummins ECM and OEM VECU's must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The engine ECM is located on the intake side of the engine. The J1939 datalink wiring and VECU location varies by OEM.

Shop Talk

This fault can occur when the OEM VECU detects an error on the remote throttle and or remote throttle enable switch. The ECM has been set up properly (components enabled and OEM VECU source addressed correctly) to receive multiplexed information for the remote throttle enable switch states and remote accelerator position over the J1939 datalink from an OEM VECU, and the OEM VECU is transmitting the message for that component. Most OEM's will not have the circuitry to detect a remote throttle switch error.

The two types of errors that can occur for this fault are:

  • The OEM VECU determines that the remote throttle signal line is shorted high or shorted low. This fault status is transmitted to the Cummins ECM on the J1939 datalink, which causes this fault to occur in the Cummins ECM.
  • When the remote throttle enable switch has a shorted high or shorted low error detected by the OEM VECU. This fault status is transmitted to the ECM on the J1939 datalink, which causes this fault to occur in the ECM. Most OEM's will not incorporate fault detection on a switch.

NOTE: It is still possible to get a Fault Code 285 or 286 if there is an incorrect setup in the OEM VECU or Cummins ECM for other components, or the remote throttle and remote throttle switch, or the datalink is damaged. OEM configurations must multiplex the remote throttle and remote throttle switch inputs together to allow the use of the J1939 multiplexing feature for these components. INSITE™ can be used to monitor multiplexed components.

Refer to Troubleshooting Fault Code t05-288

Last Modified: 08-Jul-2010


Proprietary Datalink Error (OEM/Vehicle Datalink) — Abnormal Update Rate.

FAULT CODE 291

Proprietary Datalink Error (OEM/Vehicle Datalink) — Abnormal Update Rate.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 291 PID: S248 SPN: 625 FMI: 9 LAMP: Red SRT: | Proprietary Datalink Error (OEM/Vehicle Datalink) — Abnormal Update Rate. The ECM cannot communicate with the immobilizer anti-theft system. | The immobilizer anti-theft system will not operate properly. The engine may not start.
Circuit:

Circuit Description

The immobilizer anti-theft device is connected to the primary engine Electronic Control Module (ECM) through a J1939 datalink network.

Messages sent from the immobilizer anti-theft device are received by the Cummins engine ECM and used for controlling the anti-theft features. The Cummins ECM and immobilizer anti-theft device must be configured properly so that proper operation of the multiplexed components will occur.

Component Location

The engine ECM is located on the intake side of the engine. The J1939 datalink wiring and location of OEM installed J1939 devices varies by OEM.

Shop Talk

This fault can occur for the following reasons:

  • When the ECM is setup properly to receive information from an immobilizer anti-theft device, but the immobilizer anti-theft device may not actually be transmitting the message for that component. This can be caused when a multiplexed component is enabled in the Cummins ECM, but the immobilizer anti-theft device source address of the VECU transmitting the component message is incorrect in the Cummins ECM, or the immobilizer anti-theft device is not setup to transmit the multiplexed component message.
  • This fault can be caused by a bad J1939 datalink connection between the immobilizer anti-theft device and Cummins ECM , a bad connection between the component and the immobilizer anti-theft device, bad immobilizer anti-theft device or bad Cummins ECM. It may be necessary to contact the OEM for proper multiplexing configuration.

On-Board Diagnostics (OBD) Information:

  • The ECM illuminates the appropriate amber or red fault lamp when the diagnostic runs and fails.
  • The ECM turns off the appropriate fault lamp when the diagnostic runs and passes.
Refer to Troubleshooting Fault Code t05-291

Last Modified: 08-Jul-2010


Auxiliary Temperature Sensor Input 1 - Special Instructions.

FAULT CODE 292

Auxiliary Temperature Sensor Input 1 - Special Instructions.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 292 PID: P441 SPN: 441 FMI: 14 LAMP: Red SRT: | Auxiliary Temperature Sensor Input 1 - Special Instructions. | Possible engine power derate.
OEM Temperature/Pressure Sensor Circuit

Circuit Description

The OEM has the option of wiring a temperature sensor input to the Cummins ECM. A specific calibration is then created to recognize this temperature sensor input. This fault code is activated when the pressure or temperature input from the OEM sensor exceeds the engine protection limit defined by the OEM. Depending on OEM requirements, an Engine Protection derate may be associated with this fault code.

Component Location

The OEM temperature sensor input will vary depending on application. Refer to the OEM troubleshooting manual for sensor location.

Shop Talk

This fault code is activated when the temperature input from the OEM sensor exceeds the engine protection limit defined by the OEM. An engine power derate is possible depending on the OEM application.

Refer to Troubleshooting Fault Code t05-292

Last Modified: 08-Jul-2010


Auxiliary Temperature Sensor Input 1 - Voltage Above Normal, or Shorted to High Source

FAULT CODE 293

Auxiliary Temperature Sensor Input 1 - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 293 PID: P441 SPN: 441 FMI: 3 LAMP: Amber SRT: | Auxiliary Temperature Sensor Input 1 - Voltage Above Normal, or Shorted to High Source. High signal voltage or open circuit detected at the OEM auxiliary temperature circuit. | None on performance.
Auxiliary Temperature Sensor Input 1 Circuit

Circuit Description

The OEM has the option of wiring a temperature sensor input to the Cummins ECM. A specific calibration is then created to recognize this temperature sensor input.

Component Location

The OEM temperature sensor input will vary depending on application. Refer to the OEM troubleshooting manual for sensor location.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code t05-293

Last Modified: 08-Jul-2010


Auxiliary Temperature Sensor Input 1 Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 294

Auxiliary Temperature Sensor Input 1 Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 294 PID: P441 SPN: 441 FMI: 4 LAMP: Amber SRT: | Auxiliary Temperature Sensor Input 1 Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at OEM auxiliary temperature circuit. | None on performance.
Auxiliary Temperature Sensor Input One Circuit

Circuit Description

The OEM has the option of wiring a temperature sensor input to the Cummins ECM. A specific calibration is then created to recognize this temperature sensor input.

Component Location

The OEM temperature sensor input will vary depending on application. Refer to the OEM troubleshooting manual for sensor location.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-294

Last Modified: 08-Jul-2010


Barometric Pressure — Data Erratic, Intermittent, or Incorrect

FAULT CODE 295

Barometric Pressure — Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 295 PID: P108 SPN: 108 FMI: 2 LAMP: Amber SRT: | Barometric Pressure —Data Erratic, Intermittent, or Incorrect. The barometric air pressure sensor is reading an erratic value at initial key-on. | Engine power derate
Circuit:

Circuit Description

The barometric pressure sensor is used by the electronic control module (ECM) to monitor the barometric pressure. This value is one of many inputs used by the ECM to determine the correct air/fuel ratio for proper engine operation.

Component Location

The barometric pressure sensor is mounted on the main branch of the engine harness near the ECM. 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Shop Talk

The engine barometric pressure reading is compared to the other pressure sensor values at initial key-on. If the value of engine barometric pressure does not match the readings from pressure sensors within a pre-defined tolerance, this fault code is logged. To make the diagnostic run, turn the keyswitch on for 15 seconds before cranking the engine.

Possible causes of this fault code include:

  • Stuck in-range barometric pressure sensor reading
  • High resistance in the barometric pressure sensor signal or return lines
  • Stuck in-range intake manifold pressure sensor.

On-Board Diagnostics (OBD) Information (Euro 4 Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.

On-Board Diagnostics (OBD) Information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 1 ignition cycles that the diagnostic runs and does not fail. The MIL lamp cannot be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.
Refer to Troubleshooting Fault Code t05-295

Last Modified: 08-Jul-2010


Fault Code Path Selection

FAULT CODE 06-fc296
Fault Code Path Selection

View Related Topic

Is the engine an ISL Automotive, Industrial or Marine application? | Go to 06-fc296a
Is the engine an ISL Recreational Vehicle application? | Go to 06-fc296lrv

Last Modified: 11-Jul-2007


EGR Temperature - Data Valid But Above Normal Operating Range, Least Severe Level

FAULT CODE 2961

EGR Temperature - Data Valid But Above Normal Operating Range, Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2961 PID: P412 SPN: 412 FMI: 0/15 LAMP: None SRT: | Exhaust Gas Recirculation (EGR) temperature - Data Valid but Above Normal Operating Range, Least Severe Level. | Engine power derate until the EGR temperature is under the maximum limit.
EGR Temperature Sensor Circuit

Circuit Description

The EGR temperature sensor is used to measure the temperature of the exhaust gas that exits the EGR cooler. This temperature is monitored to protect the engine against extremely high temperatures associated with the EGR system.

Component Location

The EGR temperature sensor is located in the air horn, on the intake side of the engine. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Shop Talk

This fault code can be caused by:

  • A fouled EGR cooler
  • High coolant temperature
  • Low coolant level
  • Malfunctioning EGR valve
  • Malfunctioning EGR valve position sensor
  • High exhaust temperatures
  • Coolant-and-water mix
  • Stuck closed variable geometry turbocharger.

NOTE: This fault code will probably not be active with no load on the engine in the shop. The engine must be loaded to trip this fault code and determine if the malfunction has been found and fixed.

Refer to Troubleshooting Fault Code t05-2961

Last Modified: 08-Jul-2010


EGR Temperature - Data Valid But Above Normal Operating Range, Moderately Severe Level

FAULT CODE 2962

EGR Temperature - Data Valid But Above Normal Operating Range, Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2962 PID: P412 SPN: 412 FMI: 0/16 LAMP: Amber SRT: | EGR Temperature - Data Valid But Above Normal Operating Range, Moderately Severe Level. | Severe fueling derate to bring EGR temperature under the maximum limit.
EGR Temperature Sensor Circuit

Circuit Description

The EGR temperature sensor is used to measure the temperature of the exhaust gas that exits the EGR cooler. This temperature is monitored to protect the engine against extremely high temperatures associated with the EGR system.

Component Location

The EGR temperature sensor is located in the air horn, on the intake side of the engine. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code can be caused by:

  • A fouled EGR cooler
  • High coolant temperature
  • Low coolant level
  • Malfunctioning EGR valve
  • Malfunctioning EGR valve position sensor
  • High exhaust temperatures
  • Improper coolant-and-water mix
  • Variable geometry turbocharger stuck closed.

Note: This fault code will probably not be active with no load on the engine in the shop. The engine must be loaded to trip this fault code and determine if the malfunction has been found and fixed.

Refer to Troubleshooting Fault Code t05-2962

Last Modified: 08-Jul-2010


Engine Coolant Temperature High - Data Valid but Above Normal Operational Range - Least Severe Level

FAULT CODE 2963

Engine Coolant Temperature High - Data Valid but Above Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2963 PID: P110 SPN: 110 FMI: 0/15 LAMP: None SRT: | Engine Coolant Temperature High - Data Valid but Above Normal Operational Range - Least Severe Level. Engine coolant temperature signal indicates coolant temperature is above the engine coolant temperature engine protection warning limit. | Progressive power derate increasing in severity from time of alert.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The engine coolant temperature sensor is used by the ECM to monitor the engine coolant temperature. The ECM monitors the voltage on the signal pin and converts this to a temperature value. The engine coolant temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The engine coolant temperature sensor is located on the exhaust side of the engine near the thermostat housing. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature. Refer to Engine Coolant Temperature Above Normal symptom troubleshooting tree.

Refer to Troubleshooting Fault Code t05-2963

Last Modified: 08-Jul-2010


Intake Manifold Temperature High - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2964

Intake Manifold Temperature High - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2964 PID: P105 SPN: 105 FMI: 0/15 LAMP: None SRT: | Intake manifold air temperature signal indicates intake manifold air temperature above engine protection warning limit. | Reduce engine performance.
Original Wiring Harness - Intake Manifold Air Temperature
Revised Wiring Harness - Intake Manifold Air Temperature

Circuit Description

The intake manifold air temperature sensor monitors intake manifold air temperature and passes information to the electronic control module (ECM) through the engine harness. If the intake manifold air temperature becomes too high, it will cause a derate condition.

Component Location

The intake manifold air temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Plugged charge-air cooler fins.
  • Restricted airflow through the charge-air cooler.
  • Malfunctioning or damaged intake manifold temperature sensor.
  • Malfunctioning or damaged EGR valve.
  • An undersized charge-air cooler.
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code t05-2964.

Last Modified: 20-Apr-2022


Auxiliary Pressure Sensor Input 1 - Special Instructions

FAULT CODE 296a

Auxiliary Pressure Sensor Input 1 - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 296a PID: P223 SPN: 1388 FMI: 14 LAMP: Red SRT: | Auxiliary Pressure Sensor Input 1 - Special Instructions | Possible engine power derate.
OEM Temperature/Pressure Sensor Circuit

Circuit Description

The OEM has the option of wiring a pressure sensor input to the Cummins® ECM. A specific calibration is then created to recognize this pressure sensor input. This fault code is activated when the pressure or temperature input from the OEM sensor exceeds the engine protection limit defined by the OEM. Depending on OEM requirements, an Engine Protection derate may be associated with this fault code.

Component Location

The OEM pressure sensor input will vary depending on application. Refer to the OEM troubleshooting and repair manual for sensor location.

Shop Talk

This fault code is activated when the pressure input from the OEM sensor exceeds the engine protection limit defined by the OEM. An engine power derate is possible depending on the OEM application.

Refer to Troubleshooting Fault Code t05-296

Last Modified: 08-Jul-2010


Auxiliary Pressure Sensor Input 1 - Special Instructions

FAULT CODE 296lrv

Auxiliary Pressure Sensor Input 1 - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 296lrv PID: 443 SPN: 1388 FMI: 14 LAMP: Red SRT: | Auxiliary Pressure Sensor Input 1 - Special Instructions | Engine power derate.
ISL Recreational Vehicles - Crankcase Pressure Sensor Circuit

Circuit Description

The pressure inside the crankcase is measured by the crankcase pressure sensor. When the crankcase pressure sensor determines that the crankcase pressure is higher than normal, this fault code is logged.

Component Location

The crankcase pressure sensor is located on the rocker cover, near the crankcase breather.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at any rpm range.

Conditions for Setting the Fault Codes

The ECM detects that the crankcase pressure is greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red ENGINE light when the crankcase pressure limit is exceeded.

Conditions for Clearing the Fault Code

The ECM will not turn off the red ENGINE light. The red light, derate, and fault code will not clear even after KEY OFF. It will only be reset by the INSITE™ electronic service tool or calibration.

Shop Talk

Possible causes of this fault code include:

  • Coolant in the oil
  • Crankcase pressure sensor damage
  • Plugged or restricted crankcase breather oil separator
  • Plugged or restricted crankcase breather oil drain tube
  • Plugged or restricted crankcase breather draft tube
  • Scuffed piston and/or cylinder liner
  • Damaged air compressor
  • Damaged turbocharger.

It is important to check for plugged or restricted hoses, tubes, check valves, and filters in extreme cold ambient temperatures.

If Fault Code 296lrv becomes active before the maintenance interval is reached or as the result of a scuffed piston or cylinder liner, reference the Engine Noise Excessive - Connecting Rod Excessive troubleshooting symptom tree in the Troubleshooting and Repair Manual ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4, and QSL9 Engines, Bulletin 4021418.

Refer to Troubleshooting Fault Code t05-296 (ISL Recreational Vehicles).

Last Modified: 05-Jul-2012


Auxiliary Pressure Sensor Input 1 Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 297

Auxiliary Pressure Sensor Input 1 Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 297 PID: P223 SPN: 1388 FMI: 3 LAMP: Amber SRT: | Auxiliary Pressure Sensor Input 1 Circuit - Voltage Above Normal, or Shorted to High Source. High signal voltage detected at the OEM pressure circuit. | None on performance.
Auxiliary Pressure Sensor Input One Circuit

Circuit Description

The OEM has the option of wiring a pressure sensor input to the Cummins ECM. A specific calibration is then created to recognize this pressure sensor input.

Component Location

The OEM pressure sensor input will vary depending on application. Refer to the OEM troubleshooting manual for sensor location.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor.
  • signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-297

Last Modified: 08-Jul-2010


Intake Manifold Pressure Sensor Circuit - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2973

Intake Manifold Pressure Sensor Circuit - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2973 PID: P102 SPN: 102 FMI: 2/2 LAMP: MIL SRT: | Intake Manifold Pressure Sensor Circuit - Data Erratic, Intermittent, or Incorrect. The electronic control module (ECM) has detected an intake manifold pressure signal that is too high or too low for present engine operating conditions. | Malfunction indicator lamp (MIL) and/or low power complaint.
Original Wiring Harness - Intake Manifold Pressure Sensor Circuit
Revised Wiring Harness - Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor monitors intake manifold pressure and passes information to the ECM through the engine harness. If the intake manifold pressure becomes too low or too high, it will cause a fault code.

Component Location

The intake manifold pressure/temperature, 1 sensor is located in the air intake manifold.

The barometric pressure sensor can be externally mounted on the engine or can be an internal component within the ECM. Check the engine wiring diagram for circuit details.

Conditions for Running the Diagnostics

Part 1 of this diagnostic runs a sensor rationality check when the keyswitch is initially turned ON. If the fault code becomes active at key ON only, it has failed the first check.

Part 2 of this diagnostic runs a boost pressure rationality check when the engine is operating under normal conditions. The diagnostic runs a boost check when:

  • Good boost pressure is measuresd at 2000 rpm and above for 15 consecutive seconds.
  • Boost pressure is measured at 1500 rpm in a motoring condition for 15 consecutive seconds.

The diagnostic can pass or fail any of the conditions above and does not have to fail both in order to set a fault code.

Conditions for Setting the Fault Codes

This diagnostic checks the value of the intake manifold pressure sensor at key ON and while the engine is operating. If the value of the intake manifold pressure is not reading ambient pressure at key ON or is higher or lower than expected during normal engine operation, this fault code is logged.

Action Taken When the Fault Code is Active

  • The ECM illuminates the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails twice.
  • Follow the troubleshooting tree and rectify the problem.

Conditions for Clearing the Fault Code

  • Run the ECM diagnostic as described above.
  • Once the diagnostic has completed, the fault code will go inactive if it passes.
  • As soon as the diagnostic has completed and passed one trip, the MIL will remain on but the fault code will be inactive.
  • Once the fault code is inactive use "clear all faults" command using the latest version of INSITE™ electronic service tool.

NOTE: To clear the MIL without INSITE™ electronic service tool, you must perform the full diagnostic a total of three times. Make sure a full ECM 30 second power down is completed between each cycle.

Shop Talk

The intake manifold pressure sensor monitors pressure in the intake manifold. This fault is set active when the intake manifold pressure is too high or too low for the present engine operating conditions. The ECM compares the intake manifold pressure reading to turbocharger speed (estimated by the ECM in some engines) to determine if the pressure reading is valid.

Possible causes of this fault are:

  • A damaged intake manifold pressure sensor.
  • A damaged barometric pressure sensor.
  • Leaks in the air intake system between the turbocharger and intake manifold.
  • Restriction in the charge-air cooler.
  • A damaged turbocharger speed sensor.
  • A damaged turbocharger compressor intake temperature sensor.
  • A damaged engine wiring harness can cause intermittent fault codes due to intermittent resistances. Check the wiring diagram for shared supply and return circuit on sensors. It is possible that more than one sensor could be reading in range but incorrectly if a common supply/ground problem exists in the circuit. Use INSITE™ electronic service tool to log any fluctuation in sensor voltage/values when the harness is moved.

NOTE: Converting gauge pressure to absolute pressure may be required, depending on the engine.

  • Barometric pressure is approximately 29.92 in-Hg at sea level. (Absolute Pressure)
  • The intake manifold gauge pressure is approximately 0 in-Hg when the engine is not operating.
  • 29.92 in-Hg = 1 atmosphere = 1.013 bar

Example: If the barometric (absolute) pressure sensor reads (31) in-Hg and the intake manifold (gauge) pressure reads -5 in-Hg, then the difference can be calculated as follows:

1. Convert intake manifold (gauge) pressure to absolute pressure = (-5 + 29) = 24 in-Hg.

2. Subtract the new 24 in-Hg from the original barometric value 31 in-Hg. (31 - 24) = 7

3. The difference is 7 in-Hg. Since the value is greater than the specification of 3 in-Hg, it will cause the fault to become active at key ON.

4. Use the Barometric Pressure at Altitude table in the following procedure to help understand ambient pressure at different altitudes. Refer to Procedure 018-028 in Section V.

The sensor return configuration for Euro 4 ISB engines has been changed for automotive wiring harnesses manufactured from February 2012 onward. The new style wiring harnesses can be be identified using the method below:

  • Disconnect the ECM connector
  • Disconnect the camshaft position sensor
  • Disconnect the intake manifold pressure/temperature sensor
  • Check for continuity between the intake manifold pressure/temperature sensor RETURN pin and the camshaft position sensor RETURN pin
  • Check for continuity between ECM pin 47 and the camshaft position sensor RETURN pin
  • Use the table below to determine which harness is fitted to the engine.

Engine Harnesses
From | To | New Harness | Old Harness
Intake manifold pressure/temperature sensor RETURN pin | Camshaft position sensor RETURN pin | Open circuit | Short circut
ECM pin 47 | Camshaft position sensor RETURN pin | Open circuit | Short circuit

NOTE: QSB engines, all C series engines, and all L series engines are not affected by this change.

Refer to Troubleshooting Fault Code t05-2973.

Last Modified: 10-Feb-2012


Dosing Control Unit Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2976

Dosing Control Unit Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2976 PID: SPN: 3361 FMI: 2 LAMP: Amber SRT: | Dosing Control Unit Temperature - Data Erratic, Intermittent, or Incorrect. An internal error has been detected in the catalyst dosing control unit. | Catalyst solution injection into the aftertreatment system is disabled.
Circuit: Dosing Control Unit.

Circuit Description

The dosing control unit communicates to the primary engine electronic control (ECM) through the J1939 data link network.

Component Location

The dosing control unit location is OEM dependent.

Shop Talk

Fault Code 2976 is triggered when the dosing control unit internal temperature sensor is reading a different value than the other temperature sensors on the engine. This indicates a problem with the internal temperature sensor of the dosing control unit. Dosing control unit electrical supply issues that cause the dosing control unit to remain powered when the key switch is turned OFF can cause Fault Code 2976 to become active.

On-Board Diagnostics (OBD) Information (Euro 4.5 Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) on the second consecutive ignition cycle that the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • To validate the repair and turn off the MIL, the engine must be shut down with the keyswitch in the OFF position for a minimum of 8 hours. After the 8 hour cold soak, if the ambient temperature is below 2°C [36°F] or above 25°C [77°F] start the engine and allow it to idle for 1 minute or run the diagnostic. If these temperatures can not be achieved, calibrate the EMC to the latest version found in the calibration revisions listed in the ECM Calibration Revision History.
  • The ECM turns OFF the MIL after 1 ignition cycle that the diagnostic runs and does not fail. The MIL lamp can not be cleared with INSITE™ electronic service tool. The fault code will be cleared from memory after 400 days or 9,600 hours of engine operation.
Refer to Troubleshooting Fault Code t05-2976

Last Modified: 08-Jul-2010


Auxiliary Pressure Sensor Input 1 Circuit - Voltage Below Normal, or Shorted to Low Source

FAULT CODE 298

Auxiliary Pressure Sensor Input 1 Circuit - Voltage Below Normal, or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 298 PID: P223 SPN: 1388 FMI: 4 LAMP: Amber SRT: | Auxiliary Pressure Sensor Input 1 Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage or open circuit detected at the OEM pressure circuit. | None on performance.
Auxiliary Pressure Sensor Input One Circuit

Circuit Description

The OEM has the option of wiring a pressure sensor input to the Cummins ECM. A specific calibration is then created to recognize this pressure sensor input.

Component Location

The OEM pressure sensor input will vary depending on application. Refer to the OEM troubleshooting manual for sensor location.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the OEM harness or sensor.
  • Supply line open or shorted to ground.
Refer to Troubleshooting Fault Code t05-298

Last Modified: 08-Jul-2010


Real-Time Clock Power Interrupt - Data Erratic, Intermittent or Incorrect

FAULT CODE 319

Real-Time Clock Power Interrupt - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 319 PID: P251 SPN: 251 FMI: 2/2 LAMP: Amber (Maintenance Flashout) SRT: | Real-Time Clock Power Interrupt - Data Erratic, Intermittent or Incorrect. Real-time clock lost power. | None on performance. Data in the ECM will not have accurate time and date information.
Real-Time Clock Power Circuit

Circuit Description

Under ordinary operating conditions, the real-time clock in the electronic control module (ECM) is powered by the vehicle's batteries. If battery power to the ECM is lost, then the real-time clock will be powered by a battery in the engine harness (if equipped).

Component Location

The real-time clock battery is secured to the engine harness near the ECM. Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Shop Talk

This fault indicates that the real-time clock in the ECM lost power. Possible causes for this fault are weak or failed real-time clock battery, failed wiring or connectors between the battery and ECM, or the engine is not equipped with a real-time clock battery and the vehicle battery power to the ECM is lost.

NOTE:If the Real Time Clock is supplied by the OEM via a CAN BUS and a battery backup is not used, then refer to the OEM wiring diagram. If this is the case, then check INSITE™ electronic service tool, “Advanced ECM Data - Real Time Clock Settings.” If the OEM supplies a Real Time Clock signal, then the address must be set according to the OEM wiring or the fault code will become active.

Refer to Troubleshooting Fault Code t05-319

Last Modified: 08-Jul-2010


Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

FAULT CODE 322

Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 322 PID: S001 SPN: 651 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit. High resistance or no current detected at number 1 injector driver or RETURN pin. | Engine can misfire or possibly run rough.
Injector Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and six low-side switches inside the ECM. The injectors for cylinders 1, 2, and 3 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. Likewise, the injectors for cylinders 4, 5, and 6 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to three injector circuit pass-through connectors that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connectors. Each pass-through connector provides power and return to two injectors.

Shop Talk

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the faulty cylinders(s).
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or for a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.
  • If the faults occur intermittently or faults occur, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Causes of a single injector fault are:

  • An open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Damaged ECM
  • An intermittent short.

An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code. For example, a short on the harness to cylinder number 1 causes a fault code for cylinder number 2 or cylinder number 3.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Damaged ECM.

When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation. Make sure there are no shorts to a rocker lever.

NOTE: Fault Code 951 (cylinder balance) can also be present due to this fault code.

Refer to Troubleshooting Fault Code t05-322.

Last Modified: 16-May-2012


Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

FAULT CODE 323

Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 323 PID: S005 SPN: 655 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit. High resistance or no current detected at number 5 injector driver or RETURN pin. | Engine can misfire or possibly run rough.
Injector Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and six low-side switches inside the ECM. The injectors for cylinders 1, 2, and 3 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. Likewise, the injectors for cylinders 4, 5, and 6 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to three injector circuit pass-through connectors that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connectors. Each pass-through connector provides power and return to two injectors.

Shop Talk

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the faulty cylinders.
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or a short to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.
  • If the faults occur intermittently or faults occur, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Causes of a single injector fault are:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Damaged ECM
  • An intermittent short.

An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code. For example, a short on the harness to cylinder number 1 causes a fault code for cylinder number 2 or cylinder number 3.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Damaged ECM.

When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation. Make sure there are no shorts to a rocker lever.

Note: Fault Code 951 (cylinder balance) can also be present due to this fault code.

Refer to Troubleshooting Fault Code t05-323.

Last Modified: 16-May-2012


Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

FAULT CODE 324

Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 324 PID: S003 SPN: 653 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit. High resistance or no current detected at number 3 injector or RETURN pin. | Engine can misfire or possibly run rough.
Injector Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and six low-side switches inside the ECM. The injectors for cylinders 1, 2, and 3 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. Likewise, the injectors for cylinders 4, 5, and 6 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to three injector circuit pass-through connectors that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connectors. Each pass-through connector provides power and return to two injectors.

Shop Talk

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the faulty cylinders.
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.
  • If the faults occur intermittently or faults occur, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Causes of a single injector fault are:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Damaged ECM.
  • An intermittent short.

An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code. For example, a short on the harness to cylinder number 1 causes a fault code for cylinder number 2 or cylinder number 3.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Damaged ECM.

When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation. Make sure there are no shorts to a rocker lever.

Note: Fault Code 951 (cylinder balance) can also be present due to this fault code.

Refer to Troubleshooting Fault Code t05-324.

Last Modified: 16-May-2012


Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

FAULT CODE 325

Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 325 PID: S006 SPN: 656 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit. High resistance or no current detected at number 6 injector driver or RETURN pin. | Engine can misfire or possibly run rough.
Injector Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and six low-side switches inside the ECM. The injectors for cylinders 1, 2, and 3 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. Likewise, the injectors for cylinders 4, 5, and 6 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to three injector circuit pass-through connectors that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connectors. Each pass-through connector provides power and return to two injectors.

Shop Talk

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the faulty cylinders.
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.
  • If the faults occur intermittently or faults occur, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Causes of a single injector fault are:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Damaged ECM.
  • An intermittent short.

An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code. For example, a short on the harness to cylinder number 1 causes a fault code for cylinder number 2 or cylinder number 3.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Damaged ECM.

When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation. Make sure there are no shorts to a rocker lever.

Note: Fault Code 951 (cylinder balance) can also be present due to this fault code.

Refer to Troubleshooting Fault Code t05-325.

Last Modified: 16-May-2012


Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

FAULT CODE 331

Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 331 PID: S002 SPN: 652 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit. High resistance or no current detected at number 2 injector driver or RETURN pin. | Engine can misfire or possibly run rough.
Injector Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and six low-side switches inside the ECM. The injectors for cylinders 1, 2, and 3 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. Likewise, the injectors for cylinders 4, 5, and 6 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to three injector circuit pass-through connectors that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connectors. Each pass-through connector provides power and return to two injectors.

Shop Talk

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the faulty cylinders.
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuit whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.
  • If the faults occur intermittently or faults occur, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Causes of a single injector fault are:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Damaged ECM.
  • An intermittent short.

An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code. For example, a short on the harness to cylinder number 1 causes a fault code for cylinder number 2 or cylinder number 3.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Damaged ECM.

When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation. Make sure there are no shorts to a rocker lever.

Note: Fault Code 951 (cylinder balance) can also be present due to this fault code.

Refer to Troubleshooting Fault Code t05-331.

Last Modified: 16-May-2012


Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

FAULT CODE 332

Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 332 PID: S004 SPN: 654 FMI: 5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit. High resistance or no current detected at number 4 injector driver or RETURN pin. | Engine can misfire or possibly run rough.
Injector Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. There are two high-side switches and six low-side switches inside the ECM. The injectors for cylinders 1, 2, and 3 (front bank) share a single high-side switch that connects the injector circuit to the source of high voltage inside the ECM. Likewise, the injectors for cylinders 4, 5, and 6 (rear bank) also share a single high-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine harness connects the ECM to three injector circuit pass-through connectors that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connectors. Each pass-through connector provides power and return to two injectors.

Shop Talk

  • Fault activation: The ECM senses current as each injector is actuated. If the ECM detects a persistent circuit error on an injector circuit, this fault will become active. If a circuit error is determined to cause excessive current, the ECM will disable the injection event for the faulty cylinders.
  • Fault deactivation: The ECM will attempt to enable any disabled injector circuits whenever the engine is started and approximately once per minute while the engine is running. If an injector circuit fault is active and the faulty condition is repaired, the fault will become inactive once the engine is restarted or if the engine is permitted to idle for more than a minute.
  • If a fault condition is intermittent and especially if more than one injector fault code is in the ECM memory, look for a wire harness that can short to components inside the rocker housing or a short circuit to ground in the injector solenoid.
  • If more than one injector fault code is occurring and the faults occur for injector circuits in the same bank, a short circuit exists.
  • If the faults occur intermittently or fault occurs, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Causes of a single injector fault are:

  • Open circuit in the engine harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)
  • Damaged ECM.
  • An intermittent short.

An intermittent short can result if the wiring harness insulation rubs through near a rocker lever. An intermittent short can cause a single injector fault code. For example, a short on the harness to cylinder number 1 causes a fault code for cylinder number 2 or cylinder number 3.

Causes of multiple injector fault codes in the same bank of injectors are:

  • Short circuit in the engine harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the three injectors in the bank - shorts to ground
  • Damaged ECM.

When looking for short circuits in the injector harnesses, pay particular attention to the wire insulation. Make sure there are no shorts to a rocker lever.

Note: Fault Code 951 (cylinder balance) can also be present due to this fault code.

Refer to Troubleshooting Fault Code t05-332.

Last Modified: 16-May-2012


J1939 Network #2 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3329

J1939 Network #2 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3329 PID: SPN: 1231 FMI: 2/2 LAMP: None SRT: | A circuit malfunction has been detected on J1939 network 2. | Possible reduced engine performance.
SAE J1939 Data Link 2

Circuit Description

The SAE J1939 data link circuit consists of one positive and one negative wire. Two 120 ohm resistors are connected in parallel to terminate the ends of the backbone. Stubs connect the smart devices to the J1939 backbone.

The engine control modules use the J1939 data link 2 for communication between modules.

Component Location

The SAE J1939 data link 2 is located in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has detected an open on the J1939 data link backbone or a short circuit.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

For Power Generation Applications:

  • The generator set controller displays the fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

For Power Generation Applications:

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the fault code immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged datalink terminating resistors.
  • Malfunctioning or damaged fuses or relays.
  • Weak batteries.
Refer to Troubleshooting Fault Code 3329

Last Modified: 29-Oct-2021


Engine Coolant Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 334

Engine Coolant Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 334 PID: P110 SPN: 110 FMI: 2 LAMP: Amber SRT: | Engine Coolant Temperature - Data Erratic, Intermittent, or Incorrect. The engine coolant temperature reading is not changed with engine operating conditions. | The ECM will estimate engine coolant temperature.
Engine Coolant Temperature Sensor

Circuit Description

The engine coolant temperature sensor is used by the electronic control module (ECM) to monitor the engine coolant temperature. The ECM monitors the voltage on the signal pin and converts this to a temperature value. The engine coolant temperature value is use by the ECM for the engine protection system and engine emission control.

Component Location

The engine coolant temperature sensor is located on the thermostat housing. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

Two different failure modes of the engine coolant temperature sensor can trigger this fault code. The engine must be turned off for period of 8 hours before this diagnostic will run. When the keyswitch is turned ON after an 8 hour cold soak, engine coolant temperature is compared to intake manifold temperature. If coolant temperature is found to be higher than intake manifold temperature by a calibratable value, the fault code is logged. The diagnostic also checks to make sure that coolant temperature increases during the first 10 minutes of engine operation. If coolant temperature does not increase by a calibratable value, this fault code is logged.

Possible causes of this fault code include:

  • Stuck in-range engine coolant temperature sensor.
  • High resistance in the engine coolant temperature sensor signal or return lines.

On-Board Diagnostics (OBD) Information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) on the second consecutive ignition cycle that the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 1 ignition cycle that the diagnostic runs and does not fail. The MIL lamp cannot be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.
Refer to Troubleshooting Fault Code t05-334

Last Modified: 08-Jul-2010


Engine Control Module Data Lost - Data Erratic, Intermittent or Incorrect

FAULT CODE 341

Engine Control Module Data Lost - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 341 PID: S253 SPN: 630 FMI: 2/2 LAMP: Amber SRT: | Engine Control Module Data Lost - Data Erratic, Intermittent or Incorrect. Severe loss of data from the ECM. | Possible no noticeable performance effects, engine dying or hard starting. Fault information, trip information, and maintenance monitor data can be inaccurate.
Unswitched Battery Supply Circuit

Circuit Description

The Electronic Control Module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. There is a single 30-ampere fuse in the unswitched battery wires to protect the engine harness from overheating. In marine applications this is a 25 ampere fuse on 12 VDC systems and a 15 ampere fuse on 24 VDC systems. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned on. The battery return wires are connected directly to the negative (-) battery post. Pins 2 and 3 are optional circuits possibly not used by the OEM. In marine applications only circuits 1 and 3 are use for unswitched battery. Refer to the OEM circuit diagram or wiring diagram for detailed information on these circuit.

Component Location

The ECM is located on the left side of the engine, near the front of the engine. The ECM is connected to the battery by the ECM power harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM troubleshooting and repair manual.

Refer to Troubleshooting Fault Code t05-341

Last Modified: 08-Jul-2010


Electronic Calibration Code Incompatibility - Out of Calibration

FAULT CODE 342

Electronic Calibration Code Incompatibility - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 342 PID: S253 SPN: 630 FMI: 13 LAMP: Red SRT: | Electronic Calibration Code Incompatibility - Out of Calibration. An incompatable calibration between the primary and secondary OEM installed ECM's has been detected. | None on performance.
Electronic Control Module

Circuit Description

This fault code is logged when incompatibel calibrations between the primary and secondary OEM installed ECM' is detected. This fault code is specific to OEM installed ECM's and is only reported in the Cummins ECM for information purposes only.

Component Location

Refer to OEM troubleshooting for the location of the OEM installed primary and secondary ECM's.

Shop Talk

This fault code is logged when incompatible calibrations between the primary and secondary OEM installed ECM's is detected The fault is not triggered by the Cummins installed engine ECM and is only stored as an information fault code. Do not recalibrate or change the Cummins ECM for this fault code.

Refer to Troubleshooting Fault Code t05-342

Last Modified: 08-Jul-2010


Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

FAULT CODE 343

Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 343 PID: S254 SPN: 629 FMI: 12/12 LAMP: Amber SRT: | Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component. | No performance effects or possible severe power derate.
Electronic Control Module

Circuit Description

The ECM is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

The ECM is located on the fuel system side of the engine. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault code can only be caused by an internal ECM problem. Repairs are not possible for the ECM.

For Euro certified engines this fault code indicates that the Real Time Clock feature needs to re reset (if equipped).

Refer to Troubleshooting Fault Code t05-343

Last Modified: 08-Jul-2010


Injector Power Supply - Bad Intelligent Device or Component

FAULT CODE 351

Injector Power Supply - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 351 PID: S254 SPN: 627 FMI: 12 LAMP: Amber SRT: | Injector Power Supply - Bad Intelligent Device or Component. The ECM measured injector boost voltage is low. | Possible smoke, low power, engine misfire, and/or engine will not start.
Injector Circuit

Circuit Description

Between each injection event, the electronic control module (ECM) attempts to recharge the injector power supply. The injector power supply consists of a bank of capacitors; this power supply is maintained at high voltage. Recharging is accomplished by recovering energy stored in the injector solenoids. For the injector power supply to remain fully charged, there must be good ECM battery power and ground, a good engine speed sensor, and good injector circuits.

Component Location

The injector power supply is located inside the ECM.

Shop Talk

This fault code will become active when the engine is running, the primary engine speed sensor signal is present, the battery charge is above a minimum threshold, and, at the same time, the measured injector power supply voltage is lower than the commanded injector power supply voltage.

This fault code will become inactive whenever the keyswitch is turned on.

This fault code will become inactive whenever the engine is running and measured injector power supply voltage reaches the commanded injector power supply voltage. These parameters can be monitored using INSITE™ electronic service tool.

Refer to Troubleshooting Fault Code t05-351

Last Modified: 08-Jul-2010


Sensor Supply Voltage Number 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 352

Sensor Supply Voltage Number 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: S212 SPN: 1079 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply Voltage Number 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at sensor supply number 1 circuit. | Engine power derate.
ISC and ISL CM850 - Sensor Supply Voltage Number 1 Circuit OEM Wiring Harness
ISB CM850 - Sensor Supply Voltage Number 1 Circuit Engine Wiring Harness
ISBe CM850 / ISLe CM850 / QSB4.5, QSB5.9, QSB6.7 CM850 (CM2850) / QSC8.3 CM850 (CM2850) / QSL9 CM850 (CM2850) - Sensor Supply Voltage Number 1 Circuit Engine Wiring Harness

Circuit Description

The sensor supply voltage number 1 of the electronic control module (ECM) provides (+) 5 volt supply for the barometric pressure sensor. On engines with a variable geometry turbocharger, this circuit also provides voltage to the turbocharger speed sensor and the turbocharger position sensor on the engine wiring harness. This circuit also includes the return of all the sensors listed above, as well as the engine coolant temperature and recirculated exhaust gas temperature sensor. This +5 volt supply also powers three optional original equipment manufacturer (OEM) sensors. The three sensors are digital vehicle speed sensor, remote accelerator sensor, and OEM pressure sensor. If these three sensors are not present, the OEM might have wired in other devices which require a +5 volt source.

Component Location

The sensor supply number 1 is located in the ECM. The supply voltage is spliced off in the engine and OEM harness to each sensor it supports.

Shop Talk

Low voltage on the (+) 5 volt supply line can be caused by a short circuit to ground in a supply line, a short circuit between a supply line and a return line, a failed sensor, or a failed ECM power supply.

On-Board Diagnostics (OBD) Information (Euro 4 Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • The ECM turns OFF the MIL after three consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using INSITE™ electronic service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.

OBD Information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the MIL when the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • The ECM turns OFF the MIL after 1 ignition cycle that the diagnostic runs and does not fail. The MIL lamp cannot be cleared using INSITE™ electronic service tool.
  • The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.
Refer to Troubleshooting Fault Code t05-352

Last Modified: 14-Sep-2018


Sensor Supply Voltage number 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 386

Sensor Supply Voltage number 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: S212 SPN: 1079 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply Voltage number 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 1 circuit. | Engine power derate.
ISC and ISL CM850 - Sensor Supply Voltage Number 1 Circuit OEM Harness
ISB CM850 - Sensor Supply Voltage Number 1 Circuit Engine Harness
ISBe CM850 / ISLe CM850 / QSB4.5, QSB5.9, QSB6.7 CM850 (CM2850) / QSC8.3 CM850 (CM2850) / QSL9 CM850 (CM2850) - Sensor Supply Voltage Number 1 Circuit

Circuit Description

The sensor supply voltage number 1 of the engine control module (ECM) provides (+) 5 VDC supply for the barometric pressure sensor on the engine harness. This +5 VDC supply also powers three optional OEM devices. The three devices are digital vehicle speed sensor, remote accelerator position sensor, and OEM pressure sensor.

Component Location

The sensor supply number 1 is located in the ECM. The supply voltage is spliced off in the engine and OEM harness to each sensor it supports.

Shop Talk

High voltage on the sensor supply line can be caused by an individual sensor supply wire in the harness shorted to battery voltage or a failed ECM power supply.

On-Board Diagnostics (OBD) Information (Euro 4 Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.

On-Board Diagnostics (OBD) Information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 1 ignition cycle that the diagnostic runs and does not fail. The MIL lamp cannot be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.
Refer to Troubleshooting Fault Code t05-386

Last Modified: 31-Jul-2017


Accelerator Pedal or Lever Position Sensor Supply Voltage Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 387

Accelerator Pedal or Lever Position Sensor Supply Voltage Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 387 PID: S221 SPN: 1043 FMI: 3/3 LAMP: Amber SRT: | Accelerator Pedal or Lever Position Sensor Supply Voltage Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply circuit for the accelerator pedal or lever position sensor. | Automotive and marine applications: Engine will only idle.
Accelerator Pedal or Lever Position Sensor Supply Voltage Circuit

Circuit Description

The electronic control module (ECM) supplies the accelerator pedal or lever position sensor with +5 volts.

Component Location

The accelerator pedal or lever assembly is located in the cab. For marine applications, the accelerator lever assembly is typically located in the engine compartment or helm.

Shop Talk

This fault is logged when the ECM senses more than +5.25 volts on the accelerator pedal or lever position +5 volt supply line. This can be caused by a short circuit to a voltage source in the OEM harness or a short circuit to an actuator signal circuit that is greater than +5 volts.

Refer to Troubleshooting Fault Code t05-387

Last Modified: 08-Jul-2010


SAE J1587/J1922 Data Link - Can Not Transmit

FAULT CODE 412

SAE J1587/J1922 Data Link - Can Not Transmit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 412 PID: S250 SPN: 608 FMI: 2 LAMP: None SRT: | SAE J1587/J1922 data link - can not transmit. Communication between the ECM and another device on the J1587/J1922 data link has been lost. | None on performance. Devices on the J1587/J1922 data link possibly will not operate.
J1587/J1922 Data Link Circuit

Circuit Description

Devices such as automatic braking system controllers, autoshift transmissions, vehicle electronic control module (ECM), automatic slip reduction systems, electronic displays, electronic information systems, electronic service tools, and Vehicle Electronic Control Units can communicate with the ECM over the J1587/J1922 data link. Messages sent from the devices are received by the ECM and used for controlling the engine. The ECM also transmits information to these devices over the J1587/J1922 data link on the 50-pin OEM harness.

Component Location

The J1587/J1922 data link connector is located on the OEM harness. Refer to the OEM manual for the specific location.

Shop Talk

This fault occurs whenever the ECM starts communicating with any other device with the J1587/J1922 data link and then can no longer transmit on the data link. Possible causes could be the following: Unplugthe electronic service tool before keying off the ECM, the J1587/J1922 data link having an intermittent electrical problem, and the ECM (or another J1587/J1922 device) tying up communications because of an electrical problem or by sending too many messages without stopping.

Refer to Troubleshooting Fault Code t05-412

Last Modified: 08-Jul-2010


Fault Code Path Selection

FAULT CODE 415
Fault Code Path Selection

Does the engine have an Oil Pressure Sensor? | Go to 06-fc415sn
Does the engine have an Oil Pressure Switch? | Go to 06-fc415sw

Last Modified: 15-Sep-2005


Engine Oil Rifle Pressure - Data Valid but Below Normal Operational Range - Most Severe Level

FAULT CODE 415

Engine Oil Rifle Pressure - Data Valid but Below Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1/1 LAMP: Red SRT: | Engine Oil Rifle Pressure - Data Valid but Below Normal Operational Range - Most Severe Level. Oil pressure signal indicates oil pressure is below the engine protection critical limit. | Progressive power derate increasing in severity from time after alert. If the Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after the red STOP lamp starts flashing. Marine: Calibration dependent.
Engine Oil Pressure Sensor Circuit

Circuit Description

The engine oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. If the oil pressure drops below the engine protection limit, will cause Fault Code 415 to log.

Component Location

The oil pressure sensor is located on the intake side of the engine, on the block, below the fuel filter. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

Possible causes of this fault code include:

  • Low oil pressure
  • Incorrect oil level.
Refer to Troubleshooting Fault Code t05-415

Last Modified: 08-Jul-2010


Engine Oil Rifle Pressure - Data Valid but Below Normal Operational Range - Most Severe Level

FAULT CODE 415

Engine Oil Rifle Pressure - Data Valid but Below Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1/1 LAMP: Red SRT: | Engine Oil Rifle Pressure - Data Valid but Below Normal Operational Range - Most Severe Level. Oil pressure signal indicates oil pressure is below the engine protection critical limit. | Progressive power derate increasing in severity from time after alert. If the Engine Protection Shutdown feature is enabled, engine will shut down 30 seconds after the red STOP lamp starts flashing.
Engine Oil Pressure Switch Circuit

Circuit Description

The engine oil pressure sensor is used by the electronic control module (ECM) to monitor the lubricating oil pressure. If the oil pressure drops below the engine protection limit, the switch will close and cause Fault Code 415 to log. When the engine is not running, the oil pressure switch will be closed. The oil pressure switch will open when oil pressure is above 48 kPa [7 psi].

Component Location

The oil pressure sensor is located on the intake side of the engine on the engine block, below the fuel filter.Refer to Procedure 100-002 (Engine Diagrams) in Section E for a detailed component location view.

Shop Talk

Possible causes of this fault code include:

  • Low oil pressure
  • Incorrect oil level
  • Damaged oil pressure switch
  • Engine harness shorted to ground.
Refer to Troubleshooting Fault Code t05-415

Last Modified: 08-Jul-2010


Fault Code Path Selection

FAULT CODE 06-fc418
Fault Code Path Selection

Do you have an Automotive Application? | Go to 06-fc418auto
Do you have a Marine Application? | Go to 06-fc418mar

Last Modified: 21-May-2008


Water-In-Fuel Indicator - Data Valid but Above Normal Operational Range - Least Severe Level

FAULT CODE 418 (Automotive Application)

Water-In-Fuel Indicator - Data Valid but Above Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 418 PID: P097 SPN: 97 FMI: 0/15 LAMP: Amber (Maintenance flashout) SRT: | Water-In-Fuel Indicator - Data Valid but Above Normal Operational Range - Least Severe Level. Water has been detected in the fuel filter. | Possible white smoke, loss of power, or hard starting.
Water-In-Fuel Circuit

Circuit Description

The water-in-fuel sensor is attached to the fuel filter. The water-in-fuel sensor sends a signal to the ECM when a set volume of water has accumulated in the fuel filter. The water-in-fuel circuit contains two wires: A ground wire and signal wire.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter. The OEM supplied fuel filter is located on the intake side of the engine. For marine applications the water-in-fuel sensor is mounted in a filter housing which contains a serviceable element. The filter housing location will vary with each OEM.

Shop Talk

The water-in-fuel is integrated into the fuel filter. It is automatically replaced whenever the fuel filter is replaced. For marine applications the sensor is not integrated into the fuel filter and is a serviceable item.

Refer to Troubleshooting Fault Code t05-418

Last Modified: 08-Jul-2010


Water-in-Fuel Indicator Data Valid but Above Normal Operational Range - Least Severe Level

FAULT CODE 418 (Marine Application)

Water-in-Fuel Indicator Data Valid but Above Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 418 PID: P097 SPN: 97 FMI: 0/15 LAMP: Amber (Maintenance flashout) SRT: | Water-in-Fuel Indicator Data Valid but Above Normal Operational Range - Least Severe Level. Water has been detected in the fuel filter. | Possible white smoke, loss of power, or hard starting.
Water-in-Fuel Sensor Circuit

Circuit Description

The water-in-fuel sensor is attached the fuel filter housing. The ECM monitors the water-in-fuel sensor in order to flag a fault when a set volume of water has accumulated in the fuel filter. The water-in-fuel circuit contains two wires, a ground wire and a signal wire.

Component Location

In automotive, industrial, and power generation applications, the water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter. The OEM supplied fuel filter is located on the intake side of the engine. For marine applications, the water-in-fuel sensor is mounted at the base of the water/fuel separator bowl on the fuel filter housing. This fuel/water separator housing contains a serviceable element. The filter housing location will vary with each OEM. Marine applications utilize a dual WIF sensor configuration. This assembly incorporates a y-harness with either two WIF sensors (duplex filtering) or one WIF sensor and a terminating resistor.

Shop Talk

In automotive, industrial, and power generation applications, the water-in-fuel sensor is integrated into the fuel filter. It is automatically replaced whenever the fuel filter is replaced. For marine applications the sensor is not integrated into the fuel filter and is a serviceable item. Possible causes for this fault code include:

  • Water in fuel
  • Damaged sensor
  • Fuel contamination.
Refer to Troubleshooting Fault Code t05-418

Last Modified: 08-Jul-2010


SAE J1939 Data Link - Cannot Transmit

FAULT CODE 426

SAE J1939 Data Link - Cannot Transmit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 426 PID: S231 SPN: 639 FMI: 2 LAMP: None SRT: | SAE J1939 data link - cannot transmit. Communication between the ECM and another device on the SAE J1939 data link has been lost. | None on performance. J1939 devices possibly do not operate.
SAE J1939 Data Link Circuit

Circuit Description

Devices such as automatic braking system controllers, autoshift transmissions, vehicle electronic control module (ECM), automatic slip reduction systems, electronic displays, electronic information systems, electronic service tools, and vehicle electronic control unit(s) can communicate with the ECM over the J1939 data link. Messages sent from the devices are received by the ECM and used for controlling the engine. The ECM also transmits information to these devices over the J1939 data link.

Component Location

The ECM is located on the intake side of the engine, near the front. The J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Shop Talk

This fault occurs whenever the ECM starts communicating with any other device using the SAE J1939 data link and then can no longer transmit on the data link. Possible causes could be the following: Unplugging an electronic service tool before keying off the ECM, the SAE J1939 data link having an intermittent electrical problem, and the ECM (or another SAE J1939 device) tying up communications because of an electrical problem or by sending too many messages without stopping.

Refer to Troubleshooting Fault Code t05-426

Last Modified: 08-Jul-2010


SAE J1939 Datalink - Abnormal Update Rate

FAULT CODE 427

SAE J1939 Datalink - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 427 PID: S231 SPN: 639 FMI: 9 LAMP: None SRT: | J1939 Datalink - Abnormal Update Rate. Communication between the electronic control module (ECM) and another device on the SAE J1939 data link has been lost. | Engine speed will ramp down and remain at idle.
SAE J1939 Data Link Circuit

Circuit Description

Devices such as ABS controllers, autoshift transmissions, ASR systems, electronic displays, electronic information systems, electronic service tools, and VECUs can communicate with the ECM over the SAE J1939 data link. Messages sent from the devices are received by the ECM and used for controlling the engine. The ECM also transmits information to these devices over the SAE J1939 data link.

Component Location

The ECM is located on the intake side of the engine, near the front. The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Shop Talk

This fault occurs whenever the ECM has been receiving SAE J1939 datalink commands from an external OEM device and is no longer receiving the datalink commands. Possible causes of this fault include:

  • Electrical problems with the SAE J1939 data link wiring such as grounded, shorted, or open circuits
  • The ECM (or another SAE J1939 device) tying up communications by sending too many consecutive messages
  • The external OEM controlling device has failed or can no longer transmit on the datalink.
Refer to Troubleshooting Fault Code t05-427

Last Modified: 08-Jul-2010


Fault Code Path Selection

FAULT CODE 06-fc428
Fault Code Path Selection

Do you have an Automotive Application? | Go to 06-fc428auto
Do you have a Marine Application? | Go to 06-fc428mar

Last Modified: 21-May-2008


Water-in-Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 428 (Automotive Application)

Water-in-Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 428 PID: P097 SPN: 97 FMI: 3/3 LAMP: Amber SRT: | Water-in-Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the water-in-fuel circuit. | None on performance. No water-in-fuel warning available.
Water-in-Fuel Sensor Circuit

Circuit Description

The water-in-fuel sensor is attached to the fuel filter. The water-in-fuel sensor sends a signal to the ECM when a set volume of water has accumulated in the fuel filter. The water-in-fuel circuit contains two wires: A return ground and a SIGNAL wire.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter. The OEM supplied fuel filter is located on the intake side of the engine. For marine applications, the water-in-fuel sensor is mounted in a filter housing which contains a serviceable element. The filter housing location will vary with each OEM.

Shop Talk

The water-in-fuel sensor is integrated into the fuel filter. It is automatically replaced whenever the fuel filter is replaced. For marine applications, the sensor is not integrated into the fuel filter and is a serviceable item. Possible causes for this fault code include:

  • Open RETURN or SIGNAL circuit in the harness, connectors, or sensor.
  • SIGNAL wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-428

Last Modified: 08-Jul-2010


Water-in-Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 428 (Marine Application)

Water-in-Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 428 PID: P097 SPN: 97 FMI: 3/3 LAMP: Amber SRT: | Water-in-Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the water-in-fuel circuit. | None on performance. No water-in-fuel warning available.
Water-in-Fuel Sensor Circuit

Circuit Description

The water-in-fuel sensor is attached the fuel filter housing. The ECM monitors the water-in-fuel sensor in order to flag a fault when a set volume of water has accumulated in the fuel filter. The water-in-fuel circuit contains two wires, a ground wire and a signal wire.

Component Location

In automotive, industrial, and power generation applications, the water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter. The OEM supplied fuel filter is located on the intake side of the engine. For marine applications, the water-in-fuel sensor is mounted at the base of the water/fuel separator bowl on the fuel filter housing. This fuel/water separator housing contains a serviceable element. The filter housing location will vary with each OEM. Marine applications utilize a dual WIF sensor configuration. This assembly incorporates a y-harness with either two WIF sensors (duplex filtering) or one WIF sensor and a terminating resistor.

Shop Talk

In automotive, industrial, and power generation applications, the water-in-fuel sensor is integrated into the fuel filter. It is automatically replaced whenever the fuel filter is replaced. For marine applications the sensor is not integrated into the fuel filter and is a serviceable item. Possible causes for this fault code include:

  • Water in fuel
  • Damaged sensor
  • Fuel contamination.
Refer to Troubleshooting Fault Code t05-428

Last Modified: 08-Jul-2010


Fault Code Path Selection

FAULT CODE 06-fc429
Fault Code Path Selection

Do you have an Automotive Application? | Go to 06-fc429auto
Do you have a Marine Application? | Go to 06-fc429mar

Last Modified: 21-May-2008


Water-in-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 429 (Automotive Application)

Water-in-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 429 PID: P097 SPN: 97 FMI: 4/4 LAMP: Amber SRT: | Water-in-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the water-in-fuel circuit. | None on performance. No water-in-fuel warning available.
Water-in-Fuel Sensor Circuit

Circuit Description

The water-in-fuel sensor is attached to the fuel filter. The water-in-fuel sensor sends a signal to the ECM when a set volume of water has accumulated in the fuel filter. The water-in-fuel circuit contains two wires: A return ground and a signal wire.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter. The OEM supplied fuel filter is located on the intake side of the engine. For marine applications the water-in-fuel sensor is mounted in a filter housing which contains a serviceable element. The filter housing location will vary with each OEM.

Shop Talk

The water-in-fuel sensor is integrated into the fuel filter; it is automatically replaced whenever the fuel filter is replaced. For marine applications the sensor is not integrated into the fuel filter and is a serviceable item. Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness, sensor, or connector.
Refer to Troubleshooting Fault Code t05-429

Last Modified: 08-Jul-2010


Water-in-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 429 (Marine Application)

Water-in-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 429 PID: P097 SPN: 97 FMI: 4/4 LAMP: Amber SRT: | Water-in-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the water-in-fuel circuit. | None on performance. No water-in-fuel warning available.
Water-in-Fuel Sensor Circuit

Circuit Description

The water-in-fuel sensor is attached the fuel filter housing. The ECM monitors the water-in-fuel sensor in order to flag a fault when a set volume of water has accumulated in the fuel filter. The water-in-fuel circuit contains two wires, a ground wire and a signal wire.

Component Location

In automotive, industrial, and power generation applications, the water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter. The OEM supplied fuel filter is located on the intake side of the engine. For marine applications, the water-in-fuel sensor is mounted at the base of the water/fuel separator bowl on the fuel filter housing. This fuel/water separator housing contains a serviceable element. The filter housing location will vary with each OEM. Marine applications utilize a dual WIF sensor configuration. This assembly incorporates a y-harness with either two WIF sensors (duplex filtering) or one WIF sensor and a terminating resistor.

Shop Talk

In automotive, industrial, and power generation applications, the water-in-fuel sensor is integrated into the fuel filter. It is automatically replaced whenever the fuel filter is replaced. For marine applications the sensor is not integrated into the fuel filter and is a serviceable item. Possible causes for this fault code include:

  • Water in fuel
  • Damaged sensor
  • Fuel contamination.
Refer to Troubleshooting Fault Code t05-429

Last Modified: 08-Jul-2010


Fault Code Path Selection

FAULT CODE 431
Fault Code Path Selection

Do you have an ISS throttle pedal? | Go to 06-fc431iss
Do you have an NISS throttle pedal? | Go to 06-fc431niss
Do you have an SSS throttle pedal? | Go to 06-fc431sss

Last Modified: 09-Jun-2003


Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent, or Incorrect

FAULT CODE 431 (ISS)

Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 431 PID: S230 SPN: 558 FMI: 2/2 LAMP: Amber SRT: | Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent, or Incorrect. Voltage detected simultaneously on both idle validation and off-idle validation switches. | None on performance.
Accelerator Pedal or Lever Idle Validation Circuit

Circuit Description

The idle validation switch is used by the engine control module (ECM) to indicate when the accelerator pedal or lever is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal or lever position. The switch return is a shared return with other original equipment manufacturer (OEM) cab switches.

Component Location

The integrated sensor switch (ISS) is located on the accelerator pedal or lever assembly.

Shop Talk

  • This fault code is usually caused by an open circuit on either the idle validation on-idle or off-idle signal circuit, a loose connection, uncalibrated accelerator pedal or lever assembly, or miswired idle validation switch.
  • The integrated sensor switch (ISS) has a different internal resistance specification (125 ohms) than the nonintegrated sensor switch (NISS).
  • When installing a new accelerator pedal or lever assembly, it must be calibrated before operating the engine. To calibrate, turn the keyswitch to the ON position and fully depress and release the pedal three times.
Refer to Troubleshooting Fault Code t05-431

Last Modified: 07-Jan-2016


Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent, or Incorrect

FAULT CODE 431 (NISS)

Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 431 PID: S230 SPN: 558 FMI: 2/2 LAMP: Amber SRT: | Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent, or Incorrect. Voltage detected simultaneously on both idle validation and off-idle validation switches. | Automotive: Engine will only idle. Marine: Severe derate in engine speed. Limp home capability only.
Accelerator Pedal or Lever Idle Validation Circuit

Circuit Description

The idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal or lever is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal or lever position.

Component Location

The nonintegrated sensor switch (NISS) is located on the accelerator pedal or lever assembly.

Shop Talk

  • This fault code is usually caused by an open circuit on either the idle validation on-idle or off-idle signal circuits, a loose connection, uncalibrated accelerator pedal or lever assembly, or miswired idle validation switch.
  • The nonintegrated sensor switch has a different internal resistance specification (10 ohms) than the integrated sensor switch (ISS).
  • When installing a new accelerator pedal or lever assembly, it must be calibrated before operating the engine. To calibrate, turn the keyswitch to ON position and fully depress and release the pedal or lever three times.
Refer to Troubleshooting Fault Code t05-431

Last Modified: 08-Jul-2010


Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent or Incorrect

FAULT CODE 431 (SSS)

Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 431 PID: S230 SPN: 558 FMI: 2/2 LAMP: Amber SRT: | Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent or Incorrect. Voltage detected simultaneously on both idle validation and off-idle validation switches. | Automotive: Engine will only idle. Marine: Severe derate in engine speed. Limp home capability only.
Accelerator Pedal or Lever Idle Validation Circuit

Circuit Description

The idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal or lever is released (on-idle) or depressed (off-idle). The switch is adjusted at the factory to switch from on-idle to off-idle at the correct accelerator pedal or lever position.

Component Location

The solid state sensor switch (SSS) is located on the accelerator pedal or lever assembly.

Shop Talk

  • This fault code is usually caused by an open circuit on either the idle validation on-idle or off-idle signal circuits, a loose connection, uncalibrated accelerator pedal or lever assembly, or miswired idle validation switch.
  • Since the solid state sensor switch (SSS) uses an integrated circuit to output idle and off-idle signals, the internal resistance can not be checked with a multimeter as it is for the integrated sensor switch and nonintegrated sensor switch.
  • When installing a new accelerator pedal or lever assembly, it must be calibrated before operating the engine. To calibrate, turn the keyswitch to the ON position and fully depress and release the pedal three times.
Refer to Troubleshooting Fault Code t05-431

Last Modified: 08-Jul-2010


Accelerator Pedal or Lever Idle Validation Circuit - Out of Calibration

FAULT CODE 432

Accelerator Pedal or Lever Idle Validation Circuit - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 432 PID: S230 SPN: 558 FMI: 13/13 LAMP: Red SRT: | Accelerator Pedal or Lever Idle Validation Circuit - Out of Calibration. Voltage at idle validation on-idle and off-idle circuit does not match accelerator pedal position. | Automotive: Engine will only idle. Marine: Severe derate in engine speed. Limp home capability only.
Accelerator Pedal or Lever Idle Validation Circuit

Circuit Description

The accelerator pedal or lever position sensor is attached to the accelerator pedal or lever. The accelerator pedal or lever position sensor sends a signal to the electronic control module (ECM) when the accelerator pedal or lever is depressed and released. The accelerator pedal or lever position circuit contains three wires: accelerator pedal or lever position supply, accelerator pedal or lever position return, and accelerator pedal or lever position signal. The switch return circuit for the on-idle and off-idle validation circuit is a shared return with other OEM switches.

Component Location

The accelerator pedal or lever position sensor is located on the accelerator pedal or lever.

Shop Talk

This fault is logged when both the on idle and off idle validation switches disagree with the accelerator pedal or lever position signal. Turning the keyswitch ON while partially depressing the accelerator pedal or lever can cause this fault code to go active. This fault will stay active until the pedal or lever is cycled through its full travel.

Refer to Troubleshooting Fault Code t05-432

Last Modified: 08-Jul-2010


Intake Manifold Pressure Sensor Circuit - Data Incorrect

FAULT CODE 433

Intake Manifold Pressure Sensor Circuit - Data Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 433 PID: P102 SPN: 102 FMI: 2 LAMP: Amber SRT: | Intake manifold pressure sensor circuit - data incorrect. An error in the intake manifold pressure sensor signal was detected by the ECM. | Derate in power output of the engine.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor monitors intake manifold pressure and passes information to the electronic control module (ECM) through the engine harness. This value is one of the many inputs used by the ECM to determine the correct air/fuel ratio for proper engine operation.

Component Location

The intake manifold pressure sensor is located on the intake air manifold, behind the intake air horn. 100-002 for a detailed component location view.

Shop Talk

At key-on, before the engine is started, the readings for intake manifold pressure, barometric pressure, and exhaust pressure are compared. This fault code occurs if the intake manifold pressure sensor reading is different from the other three. This check is only done once after the keyswitch is turned on.

Refer to Troubleshooting Fault Code t05-433

Last Modified: 08-Jul-2010


Power Supply Lost With Ignition On - Data Erratic, Intermittent or Incorrect

FAULT CODE 434 Automotive Application

Power Supply Lost With Ignition On - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 434 PID: S251 SPN: 627 FMI: 2/2 LAMP: Amber SRT: | Power Supply Lost With Ignition On - Data Erratic, Intermittent or Incorrect. Supply voltage to the ECM fell below 6.2 VDC momentarily, or the ECM was not allowed to power down correctly (retain battery voltage for 30 seconds after key OFF). | Possible no noticeable performance effects or engine dying or hard starting. Fault information, trip information, and maintenance monitor data can be inaccurate.
ECM Power Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

This fault code will be logged if a battery disconnect switch is used in the battery circuit to stop the engine. This fault code will also log if a battery disconnect switch is opened within 10 seconds of turning the keyswitch OFF.

Component Location

The ECM is connected to the battery by the OEM power harness through the ECM battery supply stub. This provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM troubleshooting and repair manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that primary ECM power supply dropped below 6.2 VDC while the keyswitch was in the ON position. The fault code will be active when the keyswitch is turned on following the incomplete power-down event.

Action Taken When the Fault Code is Active

  • The ECM records the fault code immediately when the diagnostic runs and fails.
  • Power-down data like trip information, maintenance monitor, and fault code information will not get saved to permanent memory when the keyswitch is turned off.

Conditions for Clearing the Fault Code

The ECM must see primary ECM battery voltage above 6.2 VDC when the keyswitch is turned off before the fault code will go inactive.

Shop Talk

This fault is set active if the ECM battery supply voltage drops below 6.2 VDC while the keyswitch is in the ON position.

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter. If unswitched power is coming from the starter, it is possible for the battery voltage to drop low enough during cranking to set this fault active.

This fault can also be caused by resistance in the ECM battery supply (+) or (-) circuits. Resistance in these circuits can cause the voltage level at the ECM input to drop low enough to set Fault Code 434 active.

This fault can also be caused by a short to ground in the injector wiring harness. Check the injector wires are oriented so that they will not interfere with a rocker lever or other component in the overhead system. Remove the valve cover and check for proper alignment of the injector wiring harness.

On-Board Diagnostics (OBD) Information (Euro 4 Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.

On-Board Diagnostics (OBD) Information (Euro 4 Stage 1+ Certified Engines):

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • An engine torque derate will be activated after 50 hours of engine operation with the fault code active.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 1 ignition cycle that the diagnostic runs and does not fail. The MIL lamp cannot be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.
Refer to Troubleshooting Fault Code t05-434

Last Modified: 08-Jul-2010


Oil Pressure Switch Sensor Circuit - Data Erratic, Intermittent or Incorrect

FAULT CODE 435

Oil Pressure Switch Sensor Circuit - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 435 PID: P100 SPN: 100 FMI: 2/2 LAMP: Amber SRT: | Oil Pressure Switch Sensor Circuit - Data Erratic, Intermittent or Incorrect. An error in the engine oil pressure switch signal was detected by the ECM. | None on performance. No engine protection for oil pressure.
Engine Oil Pressure Switch Circuit

Circuit Description

The engine oil pressure switch is used by the electronic control module (ECM) to monitor the lubricating oil pressure. If the oil pressure drops below the engine protection limit, the switch will open and cause Fault Code 435 to log.

Component Location

The engine oil pressure switch is located on the intake side of the engine, on the block, below the fuel filter. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

The oil pressure switch is closed with the engine not running and open when oil pressure is present. This fault code is logged when an open circuit is detected for five consecutive key cycles when the ECM expected a closed circuit at key-on. Possible causes of this fault code include:

  • Failed engine oil pressure switch
  • Open circuit in the engine oil pressure switch signal wire
  • Failed ECM
  • Short circuit in the engine oil pressure switch signal wire to a voltage source.
Refer to Troubleshooting Fault Code t05-435

Last Modified: 13-Jan-2011


Intake Manifold 1 Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 436

Intake Manifold 1 Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 436 PID: P105 SPN: 105 FMI: 2 LAMP: Amber SRT: | The intake manifold temperature sensor is reading an erratic value at initial key ON. | Possible reduced engine performance.
Original Wiring Harness - Circuit: Intake Manifold 1 Temperature
Revised Wiring Harness - Circuit: Intake Manifold 1 Temperature

Circuit Description

The engine intake manifold temperature sensor is used by the electronic control module (ECM) to monitor the engine intake manifold temperature. The ECM monitors the voltage on the SIGNAL pin and converts this to a temperature value.

The engine intake manifold temperature value is used by the ECM for the engine protection system and engine emission control.

Component Location

The engine intake manifold temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake manifold temperature sensor reading was higher or lower than the other temperature sensors on the engine after an extended period of engine OFF time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.
  • Exhaust gas recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning engine intake manifold temperature sensor.
  • Malfunctioning or damaged engine wiring harness.
Refer to Troubleshooting Fault Code t05-436.

Last Modified: 19-Apr-2022


Battery 1 Voltage - Data Valid but Below Normal Operational Range - Moderately Severe Level

FAULT CODE 441

Battery 1 Voltage - Data Valid but Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: S168 SPN: 168 FMI: 1/18 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid but Below Normal Operational Range - Moderately Severe Level. ECM supply voltage is below the minimum system voltage level. | Engine may stop running or be difficult to start.
Unswitched Battery Supply

Circuit Description

The ECM receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. There is one 30-amp fuse in the unswitched battery wires to protect the OEM harness. In marine applications this is a 25 ampere fuse on 12V systems and a 15 ampere fuse on 24V systems. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned on. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is located on the intake side of the engine. The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. In marine applications only circuits 1 and 3 are used for unswitched battery. The location of the battery will vary with the OEM. Refer to the OEM manual for battery location.

Shop Talk

This fault code is logged when the ECM battery supply voltage drops below 6 volts.

  • Verify that the ECM unswitched power is coming from the batteries and not the starter or other device. Check for possible weak batteries.
  • If the ECM unswitched battery supply is taken from the starter, check for low voltage during cranking. Low voltage during cranking can cause the ECM power supply to drop below specifications and log Fault Code 441.
Refer to Troubleshooting Fault Code t05-441

Last Modified: 08-Jul-2010


Battery 1 Voltage - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 442

Battery 1 Voltage - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 0/16 LAMP: Amber SRT: | Battery 1 Voltage - Data Valid but Above Normal Operational Range - Moderately Severe Level. ECM supply voltage is above the maximum system voltage level. | Possible electrical damage to all electrical components.
Unswitched Battery Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. There is one 30-amp fuse in the unswitched battery wire to protect the OEM harness. In marine applications this is a 25 ampere fuse on 12V systems an a 15 ampere fuse on 24V systems. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned on. The battery return wires are connected directly to the negative (-) battery post.

Component Location

The ECM is located on the intake side of the engine. The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. In marine application only circuits 1 and 3 are use for unsiwtchd battery. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM manual for battery location.

Shop Talk

This fault code is logged when the ECM battery supply voltage exceed 36 volts. Causes of this fault code include:

  • Faulty alternator or regulator that is overcharging the system
  • Batteries connected in series instead of parallel
  • Incorrect jump-starting procedure.
Refer to Troubleshooting Fault Code t05-442

Last Modified: 08-Jul-2010


Accelerator Pedal or Lever Position Sensor Supply Voltage Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 443

Accelerator Pedal or Lever Position Sensor Supply Voltage Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 443 PID: S221 SPN: 1043 FMI: 4/4 LAMP: Amber SRT: | Accelerator Pedal or Lever Position Sensor Supply Voltage Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at sensor supply circuit to the accelerator pedal or lever position sensor. | Automotive: Engine will only die. Marine: Severe derate in engine speed. Limp home capability only.
Accelerator Pedal or Lever Position Sensor Supply Voltage Circuit

Circuit Description

The electronic control module (ECM) supplies the accelerator with +5 VDC. If the supply circuit to the accelerator is damaged, the accelerator will not work correctly.

Component Location

For Automotive applications, the accelerator pedal or lever is located in the cab.

For Marine applications, the accelerator lever is typically located in the engine compartment or the helm.

Shop Talk

Low voltage on the +5 VDC supply line can be caused by a short circuit to ground in the supply line, a short circuit between the supply line and return circuit, a failed accelerator, or a failed ECM power supply.

Refer to Troubleshooting Fault Code t05-443

Last Modified: 08-Jul-2010


Fault Code Path Selection

FAULT CODE 06-fc449
Fault Code Path Selection

Is the engine an ISB/QSB Automotive or Industrial application? | Go to 06-fc449b
Is the engine a ISC/QSC/ISL/QSL Automotive, Industrial, or Marine application? | Go to 06-fc449cl

Last Modified: 07-Apr-2005


Injector Metering Rail Number 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 449

Injector Metering Rail Number 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 449 PID: P94 SPN: 157 FMI: 0 LAMP: Amber SRT: | Injector Metering Rail Number 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level. The ECM has detected that fuel pressure in the rail fuel is higher than the commanded pressure. | None or possible engine noise associated with higher injection pressures (especially at idle or light load). Engine power is reduced.
Fuel System

Circuit Description

The electronic control module (ECM) monitors engine-operating conditions, including the reading of rail fuel pressure, and changes the flow command to either increase (OPEN the electric fuel control valve) or decrease (CLOSE the electric fuel control valve) the fuel supply to the high-pressure pump.

Component Location

The electric fuel control valve is installed on the high-pressure fuel pump.

Shop Talk

Fault Code 449 is activated when the sensed rail fuel pressure reaches the opening pressure of the rail fuel pressure relief valve. Sensed pressure has exceeded system target range.

An electric fuel control actuator with excessive leakage will result in high rail fuel pressures at idle or light load, and Fault Code 449 can possibly be logged. A restriction in the fuel-drain-to-tank return line can prevent unneeded fuel from exiting the high-pressure fuel pump. This excess drain fuel can enter the pumping chamber and pressurize the rail. Check the fuel drain line restriction. High resistance or an open circuit in the electric fuel control actuator can cause this fault to log (though Fault Codes 272 and 2311 will become active in these cases). Air in the fuel can result in pressure changes that would cause this fault to log very high. High lift pump delivery pressure could cause this fault to log, as could tampering with the rail fuel pressure sensor.

Refer to Troubleshooting Fault Code t05-449

Last Modified: 27-Sep-2018


Injector Metering Rail Number 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 449

Injector Metering Rail Number 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 449 PID: P94 SPN: 157 FMI: 0 LAMP: Amber SRT: | Injector Metering Rail Number 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level. Fuel pressure signal indicates that fuel pressure has exceeded the maximum limit for the given engine rating. | None or possible power interruption associated with dump valve reset.
Fuel System

Circuit Description

The electronic control module (ECM) monitors engine-operating conditions, including the reading of rail fuel pressure, and changes the flow command to either increase (OPEN the fuel pump actuator) or decrease (CLOSE the fuel pump actuator) the fuel supply to the high-pressure pump.

Component Location

The fuel pump actuator is installed on the high-pressure fuel pump.

Shop Talk

Fault Code 449 is activated when the sensed rail fuel pressure exceeds the opening pressure of the rail fuel pressure relief valve.

In normal engine operation the ECM calibration varies the flow command to the fuel pump actuator to achieve the correct fuel rail pressure. System failures that cause loss of pressure control can cause the fuel rail pressure relief valve to open. The fuel rail pressure relief valve acts to protect the high pressure components from over-pressurization. If the ECM detects that the fuel rail pressure relief valve is open without a detection of a fuel pump actuator circuit error, Fault Code 449 will become active.

On certain applications, the ECM will try to reset automatically causing a momentary loss of power for less than one second.

Conditions that can cause Fault Code 449:

  • Purging air through the fuel system can cause a pressure overshoot, therefore causing Fault Code 449 to log.
  • Sustained periods of very low pressure under load followed by pressure recovery overshoot. This can be caused by high restriction due to plugged filters.
  • A tampered fuel pressure sensor that reads low, a biased pressure sensor, or a poor electrical connection.
  • If an intermittent electrical circuit problem, of the fuel pump actuator circuit, exists it is possible for Fault Code 449 to become active then inactive during normal engine operation. ECM Fault Code 2311 is designed to detect electrical circuit issues with the actuator. Therefore, it is only necessary to look for bad connectors or harness issues for Fault Code 449 if no other fault codes exist.
  • Other conditions include faulty ECM wiring harness such as poor grounds, battery voltage spikes, electrical noise, low alternator output, and large disturbances of battery voltage, as when jump starting the vehicle.
Refer to Troubleshooting Fault Code t05-449

Last Modified: 27-Sep-2018


Injector Metering Rail Number 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 451

Injector Metering Rail Number 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 451 PID: P157 SPN: 157 FMI: 3 LAMP: Amber SRT: | Injector Metering Rail Number 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at rail fuel pressure sensor circuit. | Automotive: Power and/or speed derate. Marine: None.
Original Wiring Harness - Rail Fuel Pressure Sensor Circuit
Original Wiring Harness - Rail Fuel Pressure Sensor Circuit

Circuit Description

The fuel pressure sensor is used by the electronic control module (ECM) to monitor the fuel pressure in the fuel rail. The sensor gets +5-VDC from the ECM and is grounded by a RETURN pin. A third pin is the SIGNAL pin. The power and RETURN pins are shared with other devices on the engine.

Component Location

The fuel pressure sensor is installed in the fuel rail. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code will become active if there is an open circuit on any of the three pins (+5 volt SUPPLY, SIGNAL, and RETURN) that connect the sensor or the ECM to the wiring harness. This fault will also be active if the SIGNAL wire is shorted to a source of voltage. This fault code will become inactive any time the keyswitch is ON and the signal returns to a valid in-range voltage.

Causes for this fault code include:

  • Voltage (+5-VDC or higher shorted to the SIGNAL wire)
  • Open circuit on the SIGNAL wire
  • Open circuit on the +5-VDC SUPPLY wire
  • Open circuit on the RETURN wire
  • Damaged sensor
  • Malfunctioning ECM.

The sensor return configuration for Euro 4 ISB engines has been changed for automotive wiring harnesses manufactured from February 2012 onward. The new style wiring harnesses can be be identified using the method below:

  • Disconnect the ECM connector
  • Disconnect the camshaft position sensor
  • Disconnect the intake manifold pressure/temperature sensor
  • Check for continuity between the intake manifold pressure/temperature sensor RETURN pin and the camshaft position sensor RETURN pin
  • Check for continuity between ECM pin 47 and the camshaft position sensor RETURN pin
  • Use the table below to determine which harness is fitted to the engine.

Engine Harnesses
From | To | New Harness | Old Harness
Intake manifold pressure/temperature sensor RETURN pin | Camshaft position sensor RETURN pin | Open circuit | Short circut
ECM pin 47 | Camshaft position sensor RETURN pin | Open circuit | Short circuit

NOTE: QSB engines, all C series engines, and all L series engines are not affected by this change.

Refer to Troubleshooting Fault Code t05-451.

Last Modified: 10-Feb-2012


Injector Metering Rail Number 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 452

Injector Metering Rail Number 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 452 PID: P157 SPN: 157 FMI: 4 LAMP: Amber SRT: | Injector Metering Rail Number 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the rail fuel pressure sensor circuit. | Automotive: Power and/or speed derate. Marine: None.
Original Wiring Harness - Rail Fuel Pressure Sensor Circuit
Revised Wiring Harness - Rail Fuel Pressure Sensor Circuit

Circuit Description

The fuel pressure sensor is used by the electronic control module (ECM) to monitor the fuel pressure in the fuel rail. The sensor gets +5 VDC from the ECM and is grounded by a RETURN pin. A third pin is the SIGNAL pin. The power and RETURN pins are shared with other devices on the engine.

Component Location

The fuel pressure sensor is installed in the fuel rail. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code will become inactive any time the keyswitch is ON and the SIGNAL pin voltage of the ECM is too low. This can be caused by a short circuit to ground on the +5-VDC SUPPLY or SIGNAL wire. This fault will also become active if a device that is powered by the common +5-VDC power supply is shorted to ground. This fault code will become inactive any time the keyswitch is ON and the signal returns to a valid in-range voltage.

Causes for this fault code include:

  • Engine harness: the SUPPLY or SIGNAL wire is shorted to ground
  • Other components: any component connected to the common power supply is shorted to ground
  • Damaged sensor
  • Damaged ECM.

The sensor return configuration for Euro 4 ISB engines has been changed for automotive wiring harnesses manufactured from February 2012 onward. The new style wiring harnesses can be be identified using the method below:

  • Disconnect the ECM connector
  • Disconnect the camshaft position sensor
  • Disconnect the intake manifold pressure/temperature sensor
  • Check for continuity between the intake manifold pressure/temperature sensor RETURN pin and the camshaft position sensor RETURN pin
  • Check for continuity between ECM pin 47 and the camshaft position sensor RETURN pin
  • Use the table below to determine which harness is fitted to the engine.

Engine Harnesses
From | To | New Harness | Old Harness
Intake manifold pressure/temperature sensor RETURN pin | Camshaft position sensor RETURN pin | Open circuit | Short circut
ECM pin 47 | Camshaft position sensor RETURN pin | Open circuit | Short circuit

NOTE: QSB engines, all C series engines, and all L series engines are not affected by this change.

Refer to Troubleshooting Fault Code t05-452.

Last Modified: 10-Feb-2012


Engine Oil Level — Data Valid But Below Normal Operational Range — Least Severe Level

FAULT CODE 471

Engine Oil Level — Data Valid But Below Normal Operational Range — Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 471 PID: P98 SPN: 98 FMI: 1/17 LAMP: Maintenance SRT: | Engine Oil Level — Data Valid But Below Normal Operational Range — Least Severe Level. Low oil level has been detected by the oil level sensor. | The engine may derate. Possible low oil pressure, possible severe engine damage.
Circuit: Engine Oil Level Sensor.

Circuit Description

An algorithm in the ECM calibration monitors engine oil level while the ECM is keyed on and no engine speed is detected. If the engine oil level falls below a certain threshold, the ECM will activate Fault 471, as well as the maintenance lamp. The maintenance lamp will flash only during a keyon event.

Component Location

The engine oil level sensor is located on the engine oil dipstick, on the air intake side of the engine. 100-002 (Engine Diagrams) in section E for further details on dipstick location.

Shop Talk

If inactive counts of Fault 471 are logged in the ECM, it could be possible that the engine was running or keyed on while tilted at an angle severe enough to cause this fault to be triggered.

Other causes of fault code 471 may include:

  • The engine may not have been filled to proper capacity during the most recent oil change
  • External engine oil leaks (oil leaking onto the ground)
  • Internal engine oil leaks (oil leaking into the fuel system or cooling system)
  • High engine oil consumption/power cylinder failure (check for abnormally high blowby when the engine is loaded).

On-Board Diagnostic (OBD) Information:

  • The ECM illuminates the appropriate amber or red fault lamp when the diagnostic runs and fails
  • The ECM turns off the appropriate fault lamp when the diagnostic runs and passes.
Refer to Troubleshooting Fault Code t05-471

Last Modified: 08-Jul-2010


Intake Manifold 1 Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 488

Intake Manifold 1 Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 488 PID: P105 SPN: 105 FMI: 0/16 LAMP: Amber SRT: | Intake manifold air temperature signal indicates intake manifold air temperature above engine protection warning limit. | Possible reduced engine performance.
Intake Manifold Air Temperature
Revised Wiring Harness - Intake Manifold Air Temperature

Circuit Description

The intake manifold air temperature sensor monitors intake manifold air temperature and passes information to the engine control module (ECM) through the engine harness. If the intake manifold air temperature becomes too high, it will cause a derate condition.

Component Location

The intake manifold air temperature sensor is located in the air intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature was greater than a calibrated threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque may be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Plugged charge air cooler fins.
  • Restricted airflow through the charge air cooler.
  • Undersized charge air cooler.
  • High turbocharger compressor outlet temperature.
  • Malfunctioning or damaged intake manifold temperature sensor.
  • Malfunctioning or damaged engine coolant thermostat.
Refer to Troubleshooting Fault Code t05-488

Last Modified: 20-Apr-2022


Multiple Unit Synchronization Switch - Data Erratic, Intermittent, or Incorrect

FAULT CODE 497

Multiple Unit Synchronization Switch - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 497 PID: S114 SPN: 1137 FMI: 2 LAMP: Amber SRT: | Multiple Unit Synchronization Switch - Data Erratic, Intermittent, or Incorrect. Multi-Unit synchronous ON/OFF switch and Multi-Unit synchronous complimentary ON/OFF switch have different values in the ECM. | Multi-Unit synchronization feature is disabled.
Multi-Unit Synchronization

Circuit Description

The multi-unit synchronization feature uses an ON/OFF switch and a complementary switch. The complementary switch is used by the ECM to determine the type of coupling (hard or soft) to use between multiple engines when multi-unit synchronization switch is engaged.

Component Location

The multi-unit synchronization switch is mounted by the OEM. Refer to the OEM manual for specific switch location.

Shop Talk

The multi-unit synchronization feature allows two or more engines to be controlled by a single throttle signal and run at a similar speed. There is three engine configurations available with this feature: soft-coupled, hard-coupled, and soft-coupled marine.

The soft-coupled configuration has all secondary engines in parallel with each other. The primary engine outputs a throttle signal to all secondary engines. This setup allows all engines to remain running if a secondary engine stops

The hard-coupled configuration has the primary and all secondary engines in series with each other. The primary engine outputs a throttle signal, which is received by the first secondary engine. This secondary engine then outputs the throttle signal the next secondary engine in the series. This process repeats until the primary engine receives the throttle signal.

The soft-coupled mare configuration has all secondary engines in parallel with each other. The primary engine outputs a throttle signal on the J1939 datalink to all secondary engines.

Refer to Troubleshooting Fault Code t05-497

Last Modified: 08-Jul-2010


Engine Oil Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 498

Engine Oil Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 498 PID: P98 SPN: 98 FMI: 3 LAMP: Amber SRT: | Engine Oil Level Sensor Circuit - Voltage Above Normal or Shorted to High Source. The engine oil level sensor has detected an internal failure. | Oil level sensor operation will be disabled.
ISB — Oil Level Sensor Circuit
ISL and ISLe — Oil Level Sensor Circuit

Circuit Description

The oil level sensor will monitor the oil fluid level in the oil pan at key-on. The oil level sensor will not monitor the oil level after the engine is started or when the engine speed is greater than 0 rpm. During the engine key-on, if the oil level sensor detects a critical low oil level, then the amber CHECK ENGINE light will blink for 30 seconds and a fault code will be logged. If an operator observes a blinking amber CHECK ENGINE light at key-on, the operator must check the engine oil level with the manual dipstick.

The oil level sensor provides the electronic control module (ECM) with a pulse width modulated (PWM) signal. Within this signal, the oil level sensor transmits the engine oil level reading, oil temperature, and fault code information from the oil level sensor.

Component Location

The oil level sensor is located on the left side of the engine on the front oil dipstick port. Refer to Procedure 100-002 for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The oil level sensor has detected an internal short or open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The oil level sensor operation will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and enable oil level sensor operation immediately after a valid PWM signal is received from the oil level sensor.

Shop Talk

Possible causes of this fault code include:

  • Open or short circuit internally to the oil level sensor
  • A malfunctioning oil level sensor.
Refer to Troubleshooting Fault Code t05-498

Last Modified: 08-Jul-2010


Engine Oil Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 499

Engine Oil Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 499 PID: P98 SPN: 98 FMI: 4 LAMP: Amber SRT: | Engine Oil Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source. The engine oil level sensor has detected an internal failure. | Oil level sensor operation will be disabled.
ISB — Oil Level Sensor Circuit
ISL and ISLe — Oil Level Sensor Circuit

Circuit Description

The oil level sensor will monitor the oil fluid level in the oil pan at key-on. The oil level sensor will not monitor the oil level after the engine is started or when the engine speed is greater than 0 rpm. During the engine key-on, if the oil level sensor detects a critical low oil level, then the amber CHECK ENGINE light will blink for 30 seconds and a fault code will be logged. If an operator observes a blinking amber CHECK ENGINE light at key-on, the operator must check the engine oil level with the manual dipstick.

The oil level sensor provides the electronic control module (ECM) with a pulse width modulated (PWM) signal. Within this signal, the oil level sensor transmits the engine oil level reading, oil temperature, and fault code information from the oil level sensor.

Component Location

The oil level sensor is located on the left side of the engine on the front oil dipstick port. Refer to Procedure 100-002 for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The oil level sensor has detected an internal short or open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.
  • The oil level sensor operation will be disabled.

Conditions for Clearing the Fault Code

The ECM will turn off the amber CHECK ENGINE light and enable oil level sensor operation immediately after a valid PWM signal is received from the oil level sensor.

Shop Talk

Possible causes of this fault code include:

  • Open or short circuit internally to the oil level sensor
  • A failed oil level sensor
  • An open circuit in the oil level sensor circuit.
Refer to Troubleshooting Fault Code t05-499

Last Modified: 08-Jul-2010


Auxiliary Intermediate (PTO) Speed Switch Validation - Data Erratic, Intermittent, or Incorrect

FAULT CODE 523

Auxiliary Intermediate (PTO) Speed Switch Validation - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 523 PID: P089 SPN: 611 FMI: 2 LAMP: Amber SRT: | Auxiliary Intermediate (PTO) Speed Switch Validation - Data Erratic, Intermittent, or Incorrect. The position of the intermediate speed control switch 1 does not match the position of the intermediate speed control validation switch. | Intermediate speed control switch may not operate correctly.
Intermediate Speed Control Switch Configuration

Circuit Description

Up to three Intermediate Speed Control set speeds (1,2,3) can be selected, depending on OEM availability. A multi-position switch or three individual switches must be installed by the OEM to support this feature.

Component Location

The Intermediate Speed Control (PTO) switch is mounted by the OEM, usually inside the cab of the vehicle or externally as a speed control switch.

Shop Talk

When activated by switch or hand throttle, the Intermediate Speed Control feature governs engine speed to the corresponding preset speed. The three preset speeds can be adjusted with an increment or decrement switch but can not exceed the low or high idle governor engine speed limits.

If Intermediate Speed Control validation is being use, Intermediate Speed Control Switched Set Speed Three will be used as the validation input.

Refer to Troubleshooting Fault Code t05-523

Last Modified: 08-Jul-2010


Auxiliary Input/Output 2 Circuit Voltage Above Normal or Shorted to High Source

FAULT CODE 527

Auxiliary Input/Output 2 Circuit Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 527 PID: S154 SPN: 702 FMI: 3 LAMP: Amber SRT: | Auxiliary Input/Output 2 Circuit Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit has been detected at the auxiliary input and output 2 circuit. | None on performance
Dual Output Signal

Circuit Description

The electronic control module (ECM) provides a signal to the OEM output control solenoid to turn the OEM supplied accessory on and off. The OEM output control circuit varies by OEM. Certain OEM's may use a solenoid return that is wired to the ECM or may use a return that goes to engine block or chassis ground.

Component Location

The OEM out solenoid location varies by OEM. Refer to the appropriate OEM service literature to determine the location.

Shop Talk

The ECM monitors the voltage level on this circuit. When the ECM commands the OEM output signal low, it expects the voltage level to be approximately zero volts. If it detects a high voltage, this fault is recorded. If Fault Code 527 is still active after completing the following troubleshooting steps, consult the OEM service literature for procedures to check the OEM output device for an open circuit or short to ground. Possible causes of this fault include:

  • Open circuit in the engine harness or OEM output control solenoid
  • Short circuit to voltage source in the OEM harness
  • Failed ECM.
Refer to Troubleshooting Fault Code t05-527

Last Modified: 08-Jul-2010


Auxiliary Alternate Torque Validation Switch - Data Erratic, Intermittent, or Incorrect

FAULT CODE 528

Auxiliary Alternate Torque Validation Switch - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 528 PID: P093 SPN: 093 FMI: 2 LAMP: Amber SRT: | Auxiliary Alternate Torque Validation Switch - Data Erratic, Intermittent, or Incorrect. An error has been detected in the alternate torque switch circuit. | Torque curve setting defaults to default curve.
Alternate Torque Circuit

Circuit Description

The torque curve switch circuit allows the operator to select from up to three preprogrammed torque curves using a two- or three-position switch, depending on which the original equipment manufacturer (OEM) has provided.

Component Location

The location of the torque curve switch circuit varies with each OEM and equipment model. Refer to the OEM manual.

Shop Talk

The switch can be monitored for proper operation in INSITE™ electronic service tool. If the switch is changing state correctly on the service tool, then the problem does not lie in the switch circuit. The three position-switch has three states:

  • Position 1 - open
  • Position 2 - closed
  • Position 3 - 1500 ohm resistance

The two position-switch has two states:

  • Position 1 - open
  • Position 2 - closed
Refer to Troubleshooting Fault Code t05-528

Last Modified: 08-Jul-2010


Auxiliary Input/Output 3 Circuit - Voltage Above Normal, or Shorted to High Source

FAULT CODE 529

Auxiliary Input/Output 3 Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 529 PID: S051 SPN: 703 FMI: 3 LAMP: Amber SRT: | Auxiliary Input/Output 3 Circuit - Voltage Above Normal, or Shorted to High Source. High signal voltage has been detected at the auxiliary input/output 3 circuit. | None on performance.
Dual Output Signal

Circuit Description

The electronic control module (ECM) provides a signal to the OEM output control solenoid to turn the OEM supplied accessory on and off. The OEM output control circuit varies by OEM. Certain OEM's may use a solenoid return that is wired to the ECM or may use a return that goes to engine block or chassis ground.

Component Location

The OEM output solenoid location varies by OEM. Refer to appropriate OEM service literature to determine the location.

Shop Talk

The ECM monitors the voltage level on this circuit. When the ECM commands the OEM output signal low, it expects the voltage level to be approximately zero volts. If it detects a high voltage, this fault is recorded. If Fault Code 529 is still active after completing the following troubleshooting steps, consult the OEM service literature for procedures to check the OEM output device for an open circuit or short to ground. Possible causes of this fault include:

  • Open circuit in the engine harness or OEM output control solenoid
  • Short circuit to voltage source in the OEM harness
  • Failed ECM.
Refer to Troubleshooting Fault Code t05-529

Last Modified: 08-Jul-2010


Turbocharger 1 Wastegate Control — Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 545

Turbocharger 1 Wastegate Control — Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 545 PID: S032 SPN: 1188 FMI: 7 LAMP: Amber SRT: | Turbocharger 1 Wastegate Control — Mechanical System Not Responding Properly or Out of Adjustment. Intake manifold pressure has exceeded the maximum limit for the given engine rating. | Engine power derate.
Circuit: Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The intake manifold pressure sensor is used by the ECM to monitor the engine intake manifold pressure.

Component Location

100-002 (Engine Diagrams) in Section E for a detailed component location view.

Shop Talk

This fault code become active when the intake manifold pressure exceeds the maximum pressure limit for a given engine rating.

Possible causes:

  • Malfunctioning turbocharger wastegate
  • Wastegate tampering
  • Wrong turbocharger part
  • Possible tampering of the fuel system or turbocharger system.

On-Board Diagnostics (OBD) Information:

  • The ECM illuminates the malfunction indicator lamp (MIL) when the diagnostic runs and fails.
  • The ECM turns OFF the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and does not fail. The MIL lamp and fault code can also be cleared using the INSITE™ service tool.
  • The fault code will be cleared from memory after 40 consecutive drive cycles where the diagnostic runs and passes.
Refer to Troubleshooting Fault Code t05-545

Last Modified: 08-Jul-2010


Fault Code Path Selection

FAULT CODE 551
Fault Code Path Selection

Do you have an ISS throttle pedal? | Go to 06-fc551iss
Do you have an NISS throttle pedal? | Go to 06-fc551niss
Do you have an SSS throttle pedal? | Go to 06-fc551sss

Last Modified: 09-Jun-2003


Accelerator Pedal or Lever Idle Validation Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 551 (ISS)

Accelerator Pedal or Lever Idle Validation Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 551 PID: S230 SPN: 558 FMI: 4/4 LAMP: Amber SRT: | Accelerator Pedal or Lever Idle Validation Circuit - Voltage Below Normal or Shorted to Low Source. No voltage detected simultaneously on both the idle validation and off-idle and on-idle switches. | Automotive: Engine will only idle. Marine: Severe derate in engine speed. Limp home capability only.
Accelerator Pedal or Lever Idle Validation Circuit

Circuit Description

The idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal or lever is released (on-idle) or depressed (off-idle). The switch is adjusted by the accelerator pedal or lever manufacturers to switch from on-idle to off-idle at the correct accelerator pedal or lever position. The switch return is a shared return with other OEM cab switches.

Component Location

The integrated sensor switch (ISS) is located on the accelerator pedal or lever assembly.

Shop Talk

  • This fault code is usually caused by a short circuit to ground in the harness, an uncalibrated accelerator pedal or lever assembly, or a miswired idle validation switch.
  • When installing a new accelerator pedal or lever assembly, it must be calibrated before operating the engine. To calibrate, turn the keyswitch to the ON position, and fully depress and release the pedal or lever three times.
Refer to Troubleshooting Fault Code t05-551

Last Modified: 08-Jul-2010


Accelerator Pedal or Lever Idle Validation Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 551 (NISS)

Accelerator Pedal or Lever Idle Validation Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 551 PID: S230 SPN: 558 FMI: 4/4 LAMP: Amber SRT: | Accelerator Pedal or Lever Idle Validation Circuit - Voltage Below Normal or Shorted to Low Source. No voltage detected simultaneously on both the idle validation off-idle and on-idle circuits. | Automotive: Engine will only idle. Marine: Severe derate in engine speed. Limp home capability only.
Accelerator Pedal or Lever Idle Validation Circuit

Circuit Description

The idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal or lever is released (on-idle) or depressed (off-idle). The switch is adjusted by the accelerator pedal or lever manufacturers to switch from on-idle to off-idle at the correct accelerator pedal or lever position. The switch return is a shared return with other OEM cab switches.

Component Location

The nonintegrated sensor switch (NISS) is located on the accelerator pedal or lever assembly.

Shop Talk

  • This fault code is usually caused by a short circuit to ground in the harness, an uncalibrated accelerator pedal or lever assembly, or a miswired idle validation switch.
  • When installing a new accelerator pedal or lever assembly, it must be calibrated before operating the engine. To calibrate, turn the keyswitch to the ON position and fully depress and release the pedal or lever three times.
Refer to Troubleshooting Fault Code t05-551

Last Modified: 08-Jul-2010


Accelerator Pedal or Lever Idle Validation Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 551 (SSS)

Accelerator Pedal or Lever Idle Validation Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 551 PID: S230 SPN: 558 FMI: 4/4 LAMP: Amber SRT: | Accelerator Pedal or Lever Idle Validation Circuit - Voltage Below Normal or Shorted to Low Source. No voltage detected simultaneously on both the idle validation off-idle and on-idle circuits. | Automotive: Engine will only idle. Marine: Severe derate in engine speed. Limp home capability only.
Accelerator Pedal or Lever Idle Validation Circuit

Circuit Description

The idle validation switch is used by the electronic control module (ECM) to indicate when the accelerator pedal or lever is released (on-idle) or depressed (off-idle). The switch is adjusted by the accelerator pedal or lever manufacturers to switch from on-idle to off-idle at the correct accelerator pedal or lever position. The switch return is a shared return with other OEM cab switches.

Component Location

The solid state sensor switch (SSS) is located on the accelerator pedal or lever assembly.

Shop Talk

  • This fault code is usually caused by a short circuit to ground in the harness, an uncalibrated accelerator pedal or lever assembly, or a miswired idle validation switch.
  • When installing a new accelerator pedal or lever assembly, it must be calibrated before operating the engine. To calibrate, turn the keyswitch to the ON position, and fully depress and release the pedal or lever three times.
Refer to Troubleshooting Fault Code t05-551

Last Modified: 08-Jul-2010


Injector Metering Rail 1 Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 553

Injector Metering Rail 1 Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 553 PID: P157 SPN: 157 FMI: 0/16 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level. The ECM has detected that fuel pressure is higher than commanded pressure. | None or possible engine noise associated with higher injection pressures (especially at idle or light load). Engine power is reduced.
Fuel Rail Pressure Sensor

Circuit Description

The electronic control module (ECM) monitors engine operating conditions, including the reading of fuel rail pressure, and changes the flow command to either increase (open the fuel pump actuator) or decrease (close the fuel pump actuator) the fuel supply to the high pressure pump.

Component Location

The fuel pump actuator is installed in the adapter on the back of the high-pressure pump.

Shop Talk

A fuel pump actuator with excessive leakage or a damaged inboard o-ring will result in high fuel rail pressures at idle or light load.

If the fuel pump actuator exhibits excessive leakage, it is possible that the fuel rail pressure will reach the opening pressure of the fuel rail pressure relief valve and Fault Code 449 may also become active.

Refer to Troubleshooting Fault Code t05-553

Last Modified: 08-Jul-2010


Injector Metering Rail 1 Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 554

Injector Metering Rail 1 Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 554 PID: P157 SPN: 157 FMI: 2 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure - Data Erratic, Intermittent, or Incorrect. the ECM has detected that the fuel pressure signal is not changing. | The ECM will estimate fuel pressure and power is reduced.
Fuel Rail Pressure Sensor

Circuit Description

The fuel pressure sensor contains supply, signal, and return pins. The electronic control module (ECM) provides +5 VDC to the fuel pressure sensor. This +5 VDC power supply is a shared supply. Other sensors on this circuit are the intake manifold pressure sensor and backup engine position sensor.

Component Location

The fuel pressure sensor is located in the rail fuel on the air intake side of the engine. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault code can become active any time the engine is loaded and the electronic control module (ECM) detects the fuel pressure in the rail fuel is not changing. This fault code will become inactive whenever the ECM is powered down or if the ECM detects that the engine is loaded and the fuel pressure is changing normally. If there are many inactive counts of this fault code or if the fault is not repeatable, look for signs of tampering to the fuel pressure sensor circuit. If the fault code occurs intermittently (can not be reproduced during a road test), then inspect each of the following for poor connections or damage:

  • Intake manifold pressure sensor
  • Backup engine position sensor
  • Fuel pressure sensor.
Refer to Troubleshooting Fault Code t05-554

Last Modified: 08-Jul-2010


Fault Code Path Selection

FAULT CODE 06-fc559
Fault Code Path Selection

Is the engine an ISB or QSB? | Go to 06-fc559b
Is the engine an ISC, QSC, ISL, or QSL? | Go to 06-fc559cl

Last Modified: 07-Apr-2005


Fuel Pump Delivery Pressure Low - Data Valid but Below Normal Operational Range - Moderately Severe Level

FAULT CODE 559 (ISB/QSB Automotive, Marine or Industrial Application)

Fuel Pump Delivery Pressure Low - Data Valid but Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 559 PID: P157 SPN: 157 FMI: 1/18 LAMP: Amber SRT: | Fuel Pump Delivery Pressure Low - Data Valid but Below Normal Operational Range - Moderately Severe Level. The ECM has detected that fuel pressure is lower than commanded pressure. | Possibly hard to start, low power, or engine smoke. Engine can possibly not start.
Fuel Flow Diagram

Circuit Description

The fuel pressure control loop relies on fuel pressure supplied to the high-pressure pump by the electric lift pump and low-pressure pump. The ECM monitors rail fuel pressure and engine operating conditions and changes the flow command to maintain the proper rail fuel pressure. Changes to the flow command result in opening (or closing) of the electronic fuel control actuator to supply more (or less) fuel to the high-pressure pump.

The fuel flow circuit includes, in the following order of fuel flow:

  • Fuel tank
  • OEM fuel supply line
  • OEM 30-micron filter
  • ECM cooling plate
  • Electric lift pump
  • Fuel filter
  • Gear pump
  • Electronic fuel control actuator
  • High-pressure fuel pump
  • Rail fuel (includes fuel pressure relief dump valve and pressure sensor)
  • High-pressure fuel lines
  • High-pressure fuel connectors
  • Injectors
  • Return to tank.

Component Location

The fuel pump is located at the rear of the engine, on the intake side of the engine. Use the foolowing procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Causes of this fault code include the following:

  • High inlet restriction
  • Excessive air in fuel
  • Loss of fuel prime during cranking
  • Plugged fuel filter
  • Low lift pump pressure
  • Stuck or restricted electronic fuel control actuator
  • System return (excessive return flow from the injector, high-pressure pump, or rail pressure relief valve)
  • Tampering.

If the drain line is restricted completely, the high pressure fuel pump will be damaged, causing internal leakage. Prior to pump damage, fault codes indicative of a drain line restriction will occur. Following the damage, these fault codes will go inactive and Fault Code 559, which is indicative of leakage, will be active. If troubleshooting Fault Code 559 results in replacement of the pump and there are inactive counts of Fault Codes 553 or 449, the fuel drain line must be inspected and the fuel drain line restriction measured. This is to reduce the possibility of repeat high pressure pump damage.

Refer to Troubleshooting Fault Code t05-559b

Last Modified: 17-Sep-2018


Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 559 (ISC/QSC/ISL/QSL Automotive, Industrial, or Marine Application)

Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 559 PID: P94 SPN: 157 FMI: 0/18 LAMP: Yellow SRT: | Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. The engine control module (ECM) has detected fuel pressure is lower than commanded pressure. | Possibly hard to start, low power, or engine smoke.
Fuel Flow Diagram

Circuit Description

The pressure control loop relies on fuel pressure supplied to the high-pressure pump by the fuel gear pump. The ECM monitors rail fuel pressure and engine operating conditions and changes the flow command to maintain the proper rail fuel pressure. Changes to the flow command result in opening (or closing) of the fuel pump actuator to supply more (or less) fuel to the high-pressure pump.

The fuel flow circuit includes, in the following order:

  • Original equipment manufacturer (OEM) fuel tank
  • OEM fuel supply line
  • Water stripping fuel filter (10 micron, water stripping, suction side fuel filter)
  • Engine mounted OEM fuel connection
  • Fuel supply tube to ECM cooling plate
  • ECM cooling plate
  • Fuel supply tube to the low-pressure gear pump
  • Fuel supply tube to the pressure-side fuel filter
  • Primary fuel filter (3 micron pressure-side fuel filter)
  • Fuel supply tube to the high-pressure pump
  • High-pressure pump
  • High-pressure system (including fuel rail and fuel rail pressure relief valve), injectors, and high-pressure lines.

Component Location

The high-pressure fuel pump is mounted to the gear housing on the intake side of the engine. Refer to Procedure 100-002 in Section E for a detailed component location view.

Shop Talk

The troubleshooting steps for Fault Code 559 and Fault Code 2215 are the same.

For all active and non-active Fault Code 559 troubleshooting, see the Fault Code 2215 troubleshooting tree.

Refer to Troubleshooting Fault Code 559.

Last Modified: 24-May-2018


Starter Relay Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 584

Starter Relay Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 584 PID: S39 SPN: 677 FMI: 3/3 LAMP: Amber SRT: | Starter Relay Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or high voltage detected at starter lockout circuit. | Either the engine will not start or the engine will not have starter lockout protection.
Starter Relay Circuit

Circuit Description

The starter lockout relay is controlled by the ECM through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on OEM wiring. It may be wired back to the ECM on some vehicles or wired to chassis or block ground on others. Consult the OEM wiring diagram for return circuit details.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer to the OEM service manual for exact location.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a voltage when the signal is commanded off, it records this fault code.This fault can be caused by:

  • Open circuit in the starter lockout relay, OEM harness, or connectors
  • Short circuit to a voltage source in the OEM harness or relay.
Refer to Troubleshooting Fault Code t05-584

Last Modified: 08-Jul-2010


Starter Relay Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 585

Starter Relay Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 585 PID: S39 SPN: 677 FMI: 4/4 LAMP: Amber SRT: | Starter Relay Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at starter lockout circuit. | The engine will not have starter lockout protection.
Starter Relay Circuit

Circuit Description

The starter lockout relay is controlled by the electronic control module (ECM) through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on OEM wiring. It may be wired back to the ECM on some vehicles or wired to chassis or block ground on others. Consult the OEM wiring diagram for return circuit details.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer to OEM service manual for exact location.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a low voltage when the signal is commanded on, it records this fault code. This fault code can be caused by a short circuit to ground in the starter lockout relay, OEM harness, or connectors.

Refer to Troubleshooting Fault Code t05-585

Last Modified: 08-Jul-2010


Fault Code Path Selection

FAULT CODE 06-fc595
Fault Code Path Selection

Is the engine an ISB or QSB? | Go to 06-fc595b
Is the engine an ISC, QSC, ISL, or QSL? | Go to 06-fc595cl

Last Modified: 28-Feb-2006


Turbocharger Number 1 Speed High - Warning Level

FAULT CODE 595 (ISB/QSB Automotive or Industrial Application)

Turbocharger Number 1 Speed High - Warning Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 595 PID: P103 SPN: 103 FMI: 0 LAMP: Amber SRT: | Turbocharger Number 1 speed high - warning level. High turbocharger speed has been detected. | Engine power derate. The ECM uses an estimated turbocharger speed.
Turbocharger Speed Sensor Circuit

Circuit Description

The electronic control module (ECM) provides +5 VDC to the turbocharger speed sensor signal pin. Circuitry inside the turbocharger speed sensor detects the movement of the turbocharger compressor blades and produces a speed signal. This signal is used by the ECM for engine controls.

Component Location

The turbocharger speed sensor is located in the turbocharger compressor housing. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault code becomes inactive at key-on or any time the ECM detects a valid turbocharger speed signal. One cause of this fault code is high-frequency electrical noise. If the fault occurs intermittently, check the circuit and the sensor pigtail connector for opens or short circuits.

Refer to Troubleshooting Fault Code t05-595

Last Modified: 08-Jul-2010


Turbocharger Number 1 Speed High - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 595 (ISC/QSC/ISL/QSL Automotive, Industrial, or Marine Application)

Turbocharger Number 1 Speed High - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 595 PID: P103 SPN: 103 FMI: 0/16 LAMP: Amber SRT: | Turbocharger Number 1 Speed High - Data Valid but Above Normal Operational Range - Moderately Severe Level. High turbocharger speed has been detected. | Engine power derate. The ECM uses an estimated turbocharger speed.
Turbocharger Number 1 Speed High Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault can come active any time the key is on and the electronic control module (ECM) detects turbocharger speed greater than a calibration limit. This fault can be caused by failures in the following components:

  • Turbocharger speed sensor
  • Engine harness
  • ECM power supply or grounds
  • Electronic vehicle accessories which emit excessive electromagnetic interference.

This fault becomes inactive any time the ECM detects a valid turbocharger speed.

If the fault occurs intermittently:

  • Look for causes of intermittent open circuit or short circuits in the turbocharger speed sensor circuit (including the speed sensor pigtail connector).
  • Look for sources of electronic noise such as poorly installed vehicle electronic components.
  • Ensure that vehicle chassis grounds are in good condition.
  • Ensure that the ECM power supply and ground circuits are in good condition and that this power supply is not shared with other vehicle electronics.
Refer to Troubleshooting Fault Code t05-595

Last Modified: 08-Jul-2010


Electrical Charging System Voltage High - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 596

Electrical Charging System Voltage High - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 596 PID: P167 SPN: 167 FMI: 0/16 LAMP: Amber SRT: | Electrical Charging System Voltage High - Data Valid But Above Normal Operating Range - Moderately Severe Level. High battery voltage detected by the battery voltage monitor feature. | Amber warning lamp illuminated until high battery voltage condition is corrected.
Battery Voltage Monitor Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the ECM power harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM service manual for the battery location.

Shop Talk

This fault code is part of the Alternator Failure Warning feature. The ECM can increase idle speed and deactivate the idle decrement switch if idle speedup is enabled. View the Alternator Failure Warning feature settings using the INSITE™ electronic service tool. Disabling the Alternator Failure Warning feature will also disable this fault code.

Make sure the ECM battery supply (+) is coming directly from the battery and not the starter.

Possible causes of this fault code:

  • Overcharged batteries caused by a malfunctioning alternator or regulator.
Refer to Troubleshooting Fault Code t05-596

Last Modified: 09-Apr-2012


Electrical Charging System Voltage Low - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 597

Electrical Charging System Voltage Low - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 597 PID: P167 SPN: 167 FMI: 1/18 LAMP: Amber SRT: | Electrical Charging System Voltage Low - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low battery voltage detected by the battery voltage monitor feature. | Amber lamp will light until low battery voltage condition is corrected.
Voltage Monitor Supply Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the ECM power harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM service manual for the battery location.

Shop Talk

This fault code is part of the Alternator Failure Warning feature. The ECM can increase idle speed and deactivate the idle decrement switch if Idle Speedup is enabled. View the Alternator Failure Warning feature settings with INSITE™ electronic service tool. Disabling the Alternator Failure Warning feature will also disable this fault code.

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter.

Possible causes of this fault:

  • Undercharged batteries caused by a malfunctioning alternator or regulator.
  • High-current devices on the vehicle such as citizens band radio amplifiers, numerous exterior lights, or other accessories.
Refer to Troubleshooting Fault Code t05-597

Last Modified: 09-Apr-2012


Electrical Charging System Voltage Low - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 598

Electrical Charging System Voltage Low - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 598 PID: P167 SPN: 167 FMI: 1/1 LAMP: Red SRT: | Electrical Charging System Voltage Low - Data Valid But Below Normal Operating Range - Most Severe Level. Very low battery voltage detected by the battery voltage monitor feature. | Red lamp illuminated until very low battery voltage condition is corrected.
Battery Voltage Monitor Circuit

Circuit Description

The electronic control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM service manual for the battery location.

Shop Talk

This fault code is part of the Alternator Failure Warning feature. The ECM can increase idle speed and deactivate idle the decrement switch if Idle Speedup is enabled. View the Alternator Failure Warning feature settings with INSITE™ electronic service tool. Disabling the Alternator Failure Warning feature will also disable this fault code.

Make sure the ECM battery supply (+) is coming directly from the battery and not the starter.

Possible causes of this fault code:

  • Undercharged batteries caused by a malfunctioning alternator or regulator.
Refer to Troubleshooting Fault Code t05-598

Last Modified: 09-Apr-2012


Auxiliary Commanded Dual Output Shutdown - Special Instructions

FAULT CODE 599

Auxiliary Commanded Dual Output Shutdown - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 599 PID: S025 SPN: 640 FMI: 14 LAMP: Red SRT: | Auxiliary Commanded Dual Output Shutdown - Special Instructions. The engine protection limit has been exceeded for the dual outputs calibrated limits. | Engine will shut down.
Dual Outputs Circuit

Circuit Description

Dual outputs based on sensed parameters provide up to two independent switched outputs for OEM use. The state of each switched output can be determined by different inputs to the electronic control module (ECM) depending on the engine platform. The ECM can provide different outputs to OEM devices if any of the inputs are above or below calibrated thresholds. Each switched output is independent of the other with respect to control parameter input and threshold settings.

Component Location

The dual outputs features are OEM dependent. Refer to OEM troubleshooting information for component location.

Shop Talk

This fault code is activated when one of the OEM defined inputs has exceeded a calibratible limit. The triggers for shutdown are OEM dependent.

Refer to Troubleshooting Fault Code t05-599

Last Modified: 08-Jul-2010


Change Lubricating Oil and Filter - Condition Exists

FAULT CODE 649

Change Lubricating Oil and Filter - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 649 PID: S153 SPN: 1378 FMI: 11/31 LAMP: Amber (Maintenance Flashout) SRT: | Change Lubricating Oil and Filter - Condition Exists. Change engine oil and filter. | None on performance; maintenance reminder only.

Circuit Description

The ECM informs the driver of a maintenance event by using the Maintenance Monitor feature's lubrication oil drain limits.

Component Location

The oil filter is located on the exhaust side of the engine, and the oil fill port varies by application. Refer to Procedure 100-002 for a detailed component location for the oil filter and refer to the OEM manual for the location of the oil fill port.

Shop Talk

This fault code will only become active if the maintenance monitor is enabled in INSITE™. Make sure that the oil and filter are changed before clearing the fault.

Refer to Troubleshooting Fault Code t05-649

Last Modified: 08-Jul-2010


Fault Code Path Selection

FAULT CODE 06-fc687
Fault Code Path Selection

Is the engine an ISB or QSB? | Go to 06-fc687b
Is the engine an ISC, QSC, ISL, or QSL? | Go to 06-fc687cl

Last Modified: 07-Apr-2005


Turbocharger Speed Sensor - Below Normal Operating Range

FAULT CODE 687 (ISB/QSB Automotive or Industrial Application)

Turbocharger Speed Sensor - Below Normal Operating Range

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 687 PID: P103 SPN: 103 FMI: 18 LAMP: Amber SRT: | Turbocharger number 1 speed low - warning level. Low turbocharger speed detected by the ECM. | Engine power derate. The ECM uses estimated turbocharger speed.
Turbocharger Speed Sensor Circuit

Circuit Description

The electronic control module (ECM) provides +5 VDC to the turbocharger speed sensor signal pin. Circuitry inside the turbocharger speed sensor detects the movement of the turbocharger compressor blades and produces a speed signal. This signal is used by the ECM for engine controls.

Component Location

The turbocharger speed sensor is located in the turbocharger compressor housing. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault will become active if the engine is running and the ECM detects boost pressure and engine speed but no turbocharger speed signal. Possible causes of this fault:

  • Turbocharger speed sensor failure
  • Engine harness failure
  • ECM failure.

This fault becomes inactive at key-on or any time the speed signal from the turbocharger speed sensor returns. If the fault occurs intermittently, Fault Code 2345 can also be in the ECM memory. Look for causes of intermittent open circuit or short circuits in the turbocharger speed sensor circuit (including the speed sensor pigtail connector).

Refer to Troubleshooting Fault Code t05-687

Last Modified: 08-Jul-2010


Turbocharger Number 1 Speed Low - Data Valid but Below Normal Operational Range - Moderately Severe Level

FAULT CODE 687 (ISC/QSC/ISL/QSL Automotive, Industrial, or Marine Application)

Turbocharger Number 1 Speed Low - Data Valid but Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 687 PID: P103 SPN: 103 FMI: 1/18 LAMP: Amber SRT: | Turbocharger Number 1 Speed Low - Data Valid but Below Normal Operational Range - Moderately Severe Level. Low turbocharger speed detected by the ECM. | Engine power derate. The ECM uses an estimated turbocharger speed.
Turbocharger Speed Low

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. A signal is generated as the turbocharger shaft spins. The target on the turbocharger shaft is a ground flat in the center of the shaft.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger.

Shop Talk

This fault may come active if the electronic control module (ECM) senses boost pressure and engine speed while at the same time a turbocharger speed signal is not present.

Items that can fail and cause this fault code include:

  • Turbocharger speed sensor
  • Engine harness
  • Barometric pressure sensor
  • Intake manifold pressure sensor
  • ECM.

This fault becomes inactive any time the speed signal from the turbocharger speed sensor returns.

If the fault occurs intermittently, look for causes of intermittent open circuit or short circuits in the turbocharger speed sensor circuit (including the speed sensor pigtail connector).

Refer to Troubleshooting Fault Code t05-687

Last Modified: 08-Jul-2010


Engine Oil Level — Data Valid But Above Normal Operational Range — Most Severe Level

FAULT CODE 688

Engine Oil Level — Data Valid But Above Normal Operational Range — Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 688 PID: P98 SPN: 98 FMI: 0 LAMP: Red SRT: | Engine Oil Level — Data Valid But Above Normal Operational Range — Most Severe Level. High oil level has been detected by the oil level sensor. | Possible low power, excessive smoke, oil dilution, contamination, or severe engine damage. The engine may derate.
Circuit: Engine Oil Level Sensor.

Circuit Description

An algorithm in the ECM calibration monitors engine oil level while the ECM is keyed on and no engine speed is detected. If the engine oil level exceeds a certain threshold, the ECM will activate Fault 688.

Component Location

The engine oil level sensor is located on the engine oil dipstick, on the air intake side of the engine. 100-002 (Engine Diagrams) in section E for further details on dipstick location.

Shop Talk

Fault code 688 indicates that the oil level in the engine is much higher than the recommended oil level.

Other causes of fault code 688 may include:

  • The engine may have been overfilled with oil during the most recent oil change
  • The fuel system may be leaking into the lube oil system. (Check for fuel system faults or use fluorescent fuel system dye to identify leaks)
  • The cooling system may be leaking into the lube oil system. (Check for coolant in the oil).

On-Board Diagnostic (OBD) Information:

  • The ECM illuminates the appropriate amber or red fault lamp when the diagnostic runs and fails
  • The ECM turns off the appropriate fault lamp when the diagnostic runs and passes.
Refer to Troubleshooting Fault Code t05-688

Last Modified: 08-Jul-2010


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 689

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: P190 SPN: 190 FMI: 2/2 LAMP: Amber SRT: | Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect. Loss of signal from crankshaft sensor. | Engine can run rough. Possibly poor starting capability. Engine runs using backup speed sensor. Engine power is reduced.
Crankshaft Engine Speed Sensor Circuit

Circuit Description

The crankshaft engine speed sensor provides engine speed information to the electronic control module (ECM). The sensor is powered by +5 volts. The sensor generates the signal by sensing the movement of target teeth machined into a tone wheel that is mounted to the crankshaft.

Component Location

The engine speed sensor is located on the intake side of the engine between number 5 and number 6 cylinders at the crankshaft level. For ISB and QSB5.9 the crankshaft engine speed sensor is located on the intake side of the engine behind the vibration damper near the tone wheel. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault code is recorded when the electronic control module (ECM) does not receive a signal from the crankshaft engine speed sensor, or the signal it receives is degraded.

Possible causes of this fault code include:

  • Open circuit on the supply, signal, or return circuits in the sensor, engine harness, or ECM
  • Short circuits to ground or return circuits in the sensor, engine harness, or ECM
  • Short circuits to a voltage source in the sensor, engine harness, or ECM
  • Damage to the sensor target teeth or tone wheel.

INSITE™ electronic service tool monitor parameter associated with this fault code and sensor include:

  • Engine speed sensor state.

If this fault code occurs intermittently, look closely for causes of intermittent harness connections such as loose or worn pins in the engine harness connectors.

Refer to Troubleshooting Fault Code t05-689

Last Modified: 08-Jul-2010


Turbocharger #1 Compressor Inlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 691

Turbocharger #1 Compressor Inlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 691 PID: SPN: 1172 FMI: 3/3 LAMP: Amber SRT: | Turbocharger Number 1 Compressor Inlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the turbocharger compressor inlet air temperature circuit. | Engine power derate.
Turbocharger Compressor Inlet Air Temperature Sensor Circuit

Circuit Description

The turbocharger compressor inlet air temperature sensor is used by the ECM to monitor the temperature of the intake air temperature coming into the turbocharger. The ECM monitors the voltage on the signal pin and converts this to a temperature value. This temperature is one of many inputs used by the ECM to control engine operation and emissions.

Component Location

The turbocharger compressor inlet air temperature sensor is located in the compressor casing of the turbocharger. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

The turbocharger inlet air temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active. Before troubleshooting Fault Code 691, check for multiple fault codes. An extension harness between the main engine harness and the turbocharger compressor inlet temperature sensor may be used depending on the turbocharger arrangement.

Possible causes of this fault code:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or short circuit to a voltage source
  • Failed sensor.

The resistance of the sensor varies with temperature. The sensor resistance should conform to the values in the table shown below.

Temperature (°F) | Temperature (°C) | Resistance (ohms)
14 | -10 | 49k to 62k
32 | 0 | 29k to 36k
68 | 20 | 11k to 14k
104 | 40 | 4.9k to 5.8k
158 | 70 | 1.6k to 1.9k
Refer to Troubleshooting Fault Code t05-691

Last Modified: 08-Jul-2010


Turbocharger Number 1 Compressor Inlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 692

Turbocharger Number 1 Compressor Inlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 692 PID: SPN: 1172 FMI: 4/4 LAMP: Amber SRT: | Turbocharger Number 1 Compressor Inlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the turbocharger compressor inlet air temperature sensor circuit. | Engine power derate.
Turbocharger Compressor Inlet Air Temperature Sensor Circuit

Circuit Description

The turbocharger compressor inlet air temperature sensor is used by the electronic control module (ECM) to monitor the temperature of the intake air temperature coming into the turbocharger. The ECM monitors the voltage on the signal pin and converts this to a temperature value. This temperature is one of many inputs used by the ECM to control engine operation and emissions.

Component Location

The turbocharger compressor inlet air temperature sensor is located in the compressor casing of the turbocharger. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

An extension harness between the main engine harness and the turbocharger compressor inlet temperature sensor may be used depending on the turbocharger arrangement.

Possible causes of this fault code:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor
  • Failed sensor.

The resistance of the sensor varies with temperature. The sensor resistance should conform to the values in the table shown below.

Temperature (°C) | Temperature (°F) | Resistance (ohms)
-10 | 14 | 49k to 62k
0 | 32 | 29k to 36k
20 | 68 | 11k to 14k
40 | 104 | 4.9k to 5.8k
70 | 158 | 1.6k to 1.9k
Refer to Troubleshooting Fault Code t05-692

Last Modified: 08-Jul-2010


Fault Code Path Selection

FAULT CODE 06-fc731
Fault Code Path Selection

Is the engine a ISB/QSB Automotive or Industrial application, or an ISC/QSC/ISL/QSL Automotive, Industrial, or Marine application? | Go to 06-fc731b
Is the engine a QSB Marine application? | Go to 06-fc731bm

Last Modified: 07-Apr-2005


Engine Speed Sensor/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 731 (ISB/QSB Automotive and Industrial, ISC/QSC/ISL/QSL Automotive, Industrial, or Marine)

Engine Speed Sensor/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 731 PID: S064 SPN: 723 FMI: 7/7 LAMP: Amber SRT: | Engine Speed Sensor/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding Properly or Out of Adjustment. Mechanical misalignment between the crankshaft and camshaft engine speed sensors. | Engine will operate derated. Excessive smoke, hard start, and rough idle possible.
Original Wiring Harness - Engine Speed Sensor and Camshaft Position Sensor Circuit
Revised Wiring Harness - Engine Speed Sensor and Camshaft Position Sensor Circuit

Circuit Description

The engine speed sensor and camshaft position sensor provide an engine speed and position signal to the electronic control module (ECM) through the engine harness.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault will become active anytime the ECM receives a signal from both the primary EPS (crankshaft sensor) and the backup EPS (camshaft sensor), and the ECM determines that the camshaft and crankshaft signals are not in the correct phase. If this fault code is active immediately following a repair that included camshaft removal, it is likely that the camshaft gear was installed incorrectly and is not timed correctly.

The sensor return configuration for Euro 4 ISB engines has been changed for automotive wiring harnesses manufactured from February 2012 onward. The new style wiring harnesses can be be identified using the method below:

  • Disconnect the ECM connector
  • Disconnect the camshaft position sensor
  • Disconnect the intake manifold pressure/temperature sensor
  • Check for continuity between the intake manifold pressure/temperature sensor RETURN pin and the camshaft position sensor RETURN pin
  • Check for continuity between ECM pin 47 and the camshaft position sensor RETURN pin
  • Use the table below to determine which harness is fitted to the engine.

Engine Harnesses
From | To | New Harness | Old Harness
Intake manifold pressure/temperature sensor RETURN pin | Camshaft position sensor RETURN pin | Open circuit | Short circut
ECM pin 47 | Camshaft position sensor RETURN pin | Open circuit | Short circuit

NOTE: QSB engines, all C series engines, and all L series engines are not affected by this change.

Refer to Troubleshooting Fault Code t05-731.

Last Modified: 10-Feb-2012


Engine Speed Sensor/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding Properly or Out of Adjustment

FAULT CODE 731 (QSB Marine Application)

Engine Speed Sensor/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding Properly or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 731 PID: S064 SPN: 723 FMI: 7/7 LAMP: Amber SRT: | Engine Speed Sensor/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding Properly or Out of Adjustment. Mechanical misalignment between the crankshaft and camshaft engine speed sensors. | Engine will run derated. Excessive smoke, hard start, and rough idle possible.
Engine Speed Sensor and Camshaft Position Sensor Circuit

Circuit Description

The engine speed sensor and camshaft position sensor provide an engine speed and position signal to the electronic control module (ECM) through the engine harness.

Component Location

Refer to Procedure 100-002 (Engine Views) in Section E for a detailed component location view.

Shop Talk

This fault will become active anytime the ECM receives a signal from both the primary EPS (crankshaft sensor) and the backup EPS (camshaft sensor), and the ECM determines that the camshaft and crankshaft signals are not in the correct phase. If this fault code is active immediately following a repair that includes camshaft removal, it is likely that the camshaft gear was installed incorrectly and is not timed correctly.

Refer to Troubleshooting Fault Code t05-731

Last Modified: 08-Jul-2010


Electronic Control Module Data Lost - Condition Exists

FAULT CODE 757

Electronic Control Module Data Lost - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 757 PID: None SPN: 611 FMI: 11/31 LAMP: Amber SRT: | Engine Control Module Data Lost - Condition Exits. Severe loss of data from the ECM. | Possible no noticeable performance effects, engine dying or hard starting. Fault information, trip information, and maintenance monitor data can be inaccurate.
Unswitched Battery Supply Circuit

Circuit Description

The Electronic Control Module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. There is a single 30-ampere fuse in the unswitched battery wires to protect the engine harness from overheating. The ECM receives switched battery input through the vehicle keyswitch wire when the vehicle keyswitch is turned on. The battery return wires are connected directly to the negative (-) battery post. Pins 2 and 3 are optional circuits possibly not used by the OEM. Refer to the OEM wiring diagram for detailed information on these circuit.

Component Location

The ECM is located on the left side of the engine, near the front of the engine. The ECM is connected to the battery by the ECM power harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the OEM. Refer to the OEM troubleshooting and repair manual.

Refer to Troubleshooting Fault Code t05-757

Last Modified: 08-Jul-2010


Engine Speed Sensor (Camshaft) Error - Data Erratic, Intermittent, or Incorrect

FAULT CODE 778

Engine Speed Sensor (Camshaft) Error - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 778 PID: S064 SPN: 723 FMI: 2 LAMP: Amber SRT: | Engine Speed Sensor (Camshaft) Error - Data Erratic, Intermittent, or Incorrect. The ECM has detected an error in the camshaft position sensor signal. | Possible poor starting. Engine power derate.
Camshaft Engine Position Sensor Circuit

Circuit Description

The camshaft engine position sensor provides engine position information to the electronic control module (ECM). The sensor is powered by (+) 5-VDC. The sensor generates the signal by sensing the movement of target teeth machined into a tone wheel that is mounted to the camshaft.

Component Location

The camshaft position sensor is located below the fuel pump in the back of the gear housing.

Shop Talk

This fault is recorded when the ECM does not receive a signal from the camshaft position sensor or the signal the ECM receives is degraded.

Possible causes of this fault code include:

  • Open circuit on the supply, signal, or return circuits in the sensor, engine harness, or ECM
  • Short circuits to ground or return circuits in the sensor, engine harness, or ECM
  • Short circuits to voltage source in the sensor, engine harness, or ECM.

INSITE™ electronic service tool monitor parameters associated with this fault code and sensor include:

  • Camshaft engine position sensor state
  • Damage to the sensor target teeth or tone wheel.

If this fault code occurs intermittently, look closely for causes of intermittent harness connections such as loose or worn pins in the engine harness connectors.

If this fault code occurs intermittently, Fault Code 2322 will also be active or have high counts.

Refer to Troubleshooting Fault Code t05-778

Last Modified: 08-Jul-2010


Auxiliary Equipment Sensor Input #3 (OEM Switch) - Root Cause Not Known

FAULT CODE 779

Auxiliary Equipment Sensor Input #3 (OEM Switch) - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 779 PID: S051 SPN: 703 FMI: 11 LAMP: Amber SRT: | Auxiliary Equipment Sensor Input #3 (OEM Switch) - Root Cause Not Known. | Possible engine power derate.
OEM Temperature/Pressure Sensor Circuit

Circuit Description

The OEM has the option of wiring a pressure or temperature sensor input to the Cummins ECM. A specific calibration is then created to recognize this pressure or temperature sensor input. This fault code is activated when the pressure or temperature input from the OEM sensor exceeds the engine protection limit defined by the OEM. Depending on OEM requirements, an Engine Protection derate may be associated with this fault code.

Component Location

The OEM pressure or temperature sensor input will vary depending on application. Refer to the OEM troubleshooting manual for sensor location.

Shop Talk

This fault code is activated when the pressure or temperature input from the OEM sensor exceeds the engine protection limit defined by the OEM. An engine power derate is possible depending on the OEM application.

Refer to Troubleshooting Fault Code t05-779

Last Modified: 08-Jul-2010


SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate

FAULT CODE 781

SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 781 PID: S206 SPN: 1231 FMI: 9/9 LAMP: Amber SRT: | No communication or an invalid data transfer rate detected on the J1939 data link between the primary ECM and one or more secondary ECMs. | Possible reduced engine performance.
SAE J1939 Data Link 2 Circuit

Circuit Description

The ECM identified another device on the J1939 datalink network has stopped communicating on the network. The devices on the J1939 datalink network include: ECMs, and the OEM control panel. The harness for the J1939 datalink network has a shielded twisted pair of wires that connect each of the network devices.

Component Location

The Engine Control Modules (ECMs) are mounted on both banks of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

For Power Generation Applications:

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

For Power Generation Applications:

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged OEM wiring harness.
  • Malfunctioning or damaged fuses or relays.
Refer to Troubleshooting Fault Code 781.

Last Modified: 29-Oct-2021


Adaptive Cruise Control - Error

FAULT CODE 784

Adaptive Cruise Control - Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 784 PID: SPN: 1590 FMI: 2 LAMP: None SRT: | Loss of communication with adaptive cruise control. The ECM triggers this fault when the “heartbeat” signal from the data bus is not received. | Adaptive cruise control will not operate. Cruise control possibly will not operate properly.
Cruise Control Circuit

Circuit Description

The adaptive cruise control unit communicates with the electronic control module (ECM), sending and receiving vehicle speed control messages through the SAE J1939 data link.

Component Location

The adaptive cruise control is a feature in INSITE™ electronic service tool. Refer to the OEM troubleshooting and repair manual for Adaptive Cruise Control Hardware.

Shop Talk

Two conditions can cause this problem:

  • The adaptive cruise hardware is not installed on the vehicle and the adaptive cruise feature has been enabled.
  • The broadcast signal from the adaptive cruise is not being received. Refer to the OEM troubleshooting and repair manual and the Adaptive Cruise Hardware Manual.
Refer to Troubleshooting Fault Code t05-784

Last Modified: 08-Jul-2010


VGT Actuator Driver Over Temperature (Calculated) - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 9122

VGT Actuator Driver Over Temperature (Calculated) - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 9122 PID: S027 SPN: 641 FMI: 0/15 LAMP: SRT: | VGT Actuator Driver Over Temperature (Calculated) - Data Valid But Above Normal Operating Range - Least Severe Level. High internal variable geometry turbocharger (VGT) actuator temperature has been detected. | None on performance.
VGT Actuator Circuit

Circuit Description

The VGT is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine engine control module (ECM). The VGT actuator performs its own diagnostics and reports failures back to the primary engine ECM using the J1939 data link.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch is turned ON.

Conditions for Setting the Fault Codes

The fault code will log when the internal temperature of the VGT actuator exceeds 125°C [257°F] continuously for 30 minutes.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

The ECM will turn OFF the amber CHECK ENGINE light immediately after the internal actuator temperature drops below 125°C [257°F].

Shop Talk

Verify the ECM calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM. Refer to Procedure 019-032 in Section 19 in the corresponding Troubleshooting and Repair Manual for the engine being serviced.

This fault code will log when the internal temperature of the VGT actuator exceeds 125°C [257°F].

This fault code will be inactive when the vehicle is in the shop because the VGT actuator temperature has cooled down.

Troubleshoot multiple inactive counts of this fault code as an active fault code.

Also check for exhaust leaks blowing on the VGT actuator. Repair any external leaks.

Refer to Troubleshooting Fault Code t05-9122.

Last Modified: 27-Aug-2013


Cylinder Power Imbalance Detected

FAULT CODE 951

Cylinder Power Imbalance Detected

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 951 PID: P166 SPN: 166 FMI: 2 LAMP: None SRT: | Cylinder power imbalance between cylinders. A power imbalance between cylinders was detected by the ECM. | Possible low power, rough idle, or misfire.
Cylinder Circuit

Circuit Description

An algorithm in the electronic control module (ECM) calibration monitors engine speed as each injector fires while the engine is at idle. If a cylinder has high or low contribution to engine speed, this fault will become active. The intention of this fault is to assist in troubleshooting performance complaints such as engine misfire and low power. A fault lamp does not illuminate while this fault code is active.

Component Location

The ECM is located on the intake side of the engine, below the air horn. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

If Fault Code 951 is inactive in the ECM memory and there is no complaint such as “low power” or “engine misfire,” it is possible that an intermittent event such as air entering the fuel system following a filter change caused the fault. Inactive counts of Fault Code 951 should be disregarded unless other performance symptoms are present.

Causes of cylinder imbalance can include:

  • Faulty engine brakes (look for brakes out of adjustment or oil supplied to brake actuator when brakes are off)
  • Valve lash out of adjustment (compare actual valve lash to the reset limits)
  • Cylinder failure (check for high blowby when the engine is loaded)
  • Valve failure or valve held open (listen for intake valve “chirping” noise in the intake)
  • Cylinder head or gasket failure (look for signs of oil, coolant, or casting flash in the intake or exhaust passages)
  • Extreme camshaft wear (inspect the camshaft lobes for wear)
  • Extra, missing, or damaged sealing washer under an injector
  • Extremely damaged HPC/injector interface (examine the high-pressure fuel connector at the injector end); this problem will also cause excessive fuel return and Fault Code 2292/2216
  • Injector failures (“swap” injectors to see if the problem “follows” the indicated injector).
Refer to Troubleshooting Fault Code t05-951

Last Modified: 08-Jul-2010


EGR Valve Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 957

EGR Valve Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 957 PID: P27 SPN: 27 FMI: 2 LAMP: Amber SRT: | EGR Valve Position - Data erratic, intermittent, or incorrect. Intermittent EGR position information is being received by the electronic control module (ECM). | Possible low power. EGR valve will be closed.
EGR Valve Position Circuit

Circuit Description

The EGR valve position sensor outputs a voltage signal to the ECM. The ECM converts this signal into a percentage value, 0 to 100 percent, indicating EGR valve position. A fully open valve is equivalent to 100 percent.

Component Location

The EGR valve position sensor is located on the EGR valve assembly. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault code is caused by an internal failure of the EGR valve position sensor. This failure causes erratic readings of EGR valve position. The troubleshooting information for fault code 957 is the same as fault code 1228. Refer to fault code 1228 for the fault code troubleshooting information.

Refer to Troubleshooting Fault Code t05-957

Last Modified: 08-Jul-2010


VGT Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 958

VGT Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 958 PID: P27 SPN: 2795 FMI: 2 LAMP: Amber SRT: | VGT Position Sensor - Data erratic, intermittent, or incorrect. Intermittent variable geometry turbocharger (VGT) position information is being received by the electronic control module (ECM). | Possible low power. Power to the turbocharger actuator will be limited.
Variable Geometry Turbocharger (VGT) Position Sensor Circuit

Circuit Description

The turbocharger position sensor outputs a voltage signal to the ECM. The ECM converts this signal into a percentage value, 0 to 100 percent, indicating turbocharger position. A fully closed turbocharger actuator is equivalent to 100 percent.

Component Location

The turbocharger position sensor is located on the variable geometry turbocharger (VGT) actuator assembly. Refer to Procedure 100-002 for a detailed component location view.

Shop Talk

This fault code is caused by an internal failure of the variable geometry turbocharger (VGT) position sensor. This failure causes erratic readings of the variable geometry turbocharger (VGT) position. The troubleshooting information for fault code 958 is the same as fault code 1229. Refer to fault code 1229 for the fault code troubleshooting information.

Refer to Troubleshooting Fault Code t05-958

Last Modified: 08-Jul-2010


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 0001 - Exhaust Gas Pressure Sensor Number 1 Circuit - Voltage Above Normal, or Shorted to High Source

Printable Version Printable Version

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas pressure sensor and circuit. |
 | STEP 1A. Inspect the exhaust gas pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the circuit response. | Fault Code 0001 inactive and Fault Code 0002 active?
 | STEP 1C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 1D. Check the fault code and verify sensor condition. | Fault Code 0001 present?
STEP 2. | Check the exhaust gas treatment monitor unit and exhaust gas treatment monitor harness. |
 | STEP 2A. Inspect the exhaust gas treatment monitor unit and exhaust gas treatment monitor harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the exhaust gas treatment monitor harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the exhaust gas treatment monitor harness. | Greater than 100k ohms?
 | STEP 2D. Check for a pin-to-pin short circuit in the exhaust gas treatment monitor harness. | Greater than 100 ohms?
 | STEP 2E. Check for fault code presence. | Fault Code 0001 present?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 0001 present?

Guided Step 1 - Check the exhaust gas pressure sensor and circuit.

Guided Step 1A - Inspect the exhaust gas pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas pressure sensor from the exhaust gas treatment monitor harness.

Action

Inspect the exhaust gas treatment monitor harness and exhaust gas pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Use the following procedure in the Troubleshooting and Repair Manual ISC, ISCe, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 011-038 in Section 11.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas pressure sensor from the exhaust gas treatment monitor harness
  • Turn keyswitch ON
  • Connect the Emissions Monitor Interface electronic service tool.

Action

Reset the Exhaust Gas Treatment Monitor Unit using the Emissions Monitor Interface electronic service tool.

  • Start the engine and check for the appropriate circuit response after 30 seconds.
  • Use the Emissions Monitor Interface electronic service tool to read the fault codes.

Fault Code 0001 inactive and Fault Code 0002 active?
YES | NO
No Repair | No Repair

Go to 1D

Go to 2A

Guided Step 1C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas pressure sensor from the exhaust gas treatment monitor harness
  • Turn keyswitch ON.

Action

Check the SUPPLY voltage and RETURN circuit.

  • Measure the voltage between the exhaust gas pressure +5 volt SUPPLY pin and the exhaust gas pressure RETURN pin at the sensor connector of the exhaust gas treatment monitor harness.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 1D

Go to 2A

Guided Step 1D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the exhaust gas pressure sensor to the exhaust gas treatment monitor harness
  • Turn keyswitch ON
  • Connect the Emissions Monitor Interface electronic service tool.

Action

Reset the Exhaust Gas Treatment Monitor Unit using the Emissions Monitor Interface electronic service tool.

  • Start the engine and check for the appropriate circuit response after 30 seconds.
  • Use the Emissions Monitor Interface electronic service tool to read the fault codes.

Fault Code 0001 present?
YES NO

Repair

A damaged sensor has been detected.

Replace the exhaust gas pressure sensor. Use the following procedure in the Troubleshooting and Repair Manual ISC, ISCe, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 011-039 in Section 11.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 3A

Guided Step 2 - Check the exhaust gas treatment monitor unit and exhaust gas treatment monitor harness.

Guided Step 2A - Inspect the exhaust gas treatment monitor unit and exhaust gas treatment monitor harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas treatment monitor unit from the exhaust gas treatment monitor harness.

Action

Inspect the exhaust gas treatment monitor unit and exhaust gas treatment harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas treatment monitor unit connector or exhaust gas treatment monitor harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Use the following procedure in the Troubleshooting and Repair Manual ISC, ISCe, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418.

  • Refer to Procedure 011-038 in Section 11.
  • Refer to Procedure 011-035 in Section 11.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the exhaust gas treatment monitor harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas treatment monitor unit from the exhaust gas treatment monitor harness
  • Disconnect the exhaust gas pressure sensor from the exhaust gas treatment monitor harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas treatment monitor harness exhaust gas treatment monitor unit connector exhaust gas pressure RETURN pin and the exhaust gas treatment monitor harness exhaust gas pressure sensor connector RETURN pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open RETURN circuit has been detected in the exhaust gas treatment monitor harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the exhaust gas treatment monitor harness. Use the following procedure in the Troubleshooting and Repair Manual ISC, ISCe, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 011-038 in Section 11.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin to pin short circuit in the exhaust gas treatment monitor harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas treatment monitor harness from the exhaust gas treatment monitor unit connector
  • Disconnect the exhaust gas pressure sensor from the exhaust gas treatment monitor harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust gas pressure SIGNAL pin in the exhaust gas treatment monitor harness exhaust gas treatment monitor unit connector and all other pins in the exhaust gas treatment monitor harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the exhaust gas treatment monitor harness.

Troubleshoot each harness connected in series to determine which contains the pin to pin short circuit.

Repair or replace the exhaust gas treatment monitor harness. Refer to Procedure 011-038 in the Troubleshooting and Repair Manual ISC, ISCe, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit in the exhaust gas treatment monitor harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas treatment monitor harness from the exhaust gas treatment monitor unit connector
  • Disconnect the exhaust gas pressure sensor from the exhaust gas treatment monitor harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust gas pressure SUPPLY pin in the exhaust gas treatment monitor harness exhaust gas treatment monitor unit connector and all other pins in the exhaust gas treatment monitor harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SUPPLY line has been detected in the exhaust gas treatment monitor harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin short circuit.

Repair or replace the exhaust gas treatment monitor harness. Use the following procedure in the Troubleshooting and Repair Manual ISC, ISCe, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 011-038 in Section 11.

Go to 2E

Go to 3A

Guided Step 2E - Check for fault code presence.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the Emissions Monitor Interface electronic service tool.

Action

Reset the Exhaust Gas Treatment Monitor Unit using the Emissions Monitor Interface electronic service tool.

  • Start the engine and check for the appropriate circuit response after 30 seconds.
  • Use the Emissions Monitor Interface electronic service tool to read the fault codes.

Fault Code 0001 present?
YES NO

Repair

Replace the exhaust gas treatment monitor unit. Use the following procedure in the Troubleshooting and Repair Manual ISC, ISCe, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 011-035 in Section 11.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the Emissions Monitor Interface electronic service tool.

Action

Reset the fault codes using the Emissions Monitor Interface slectronic service tool.

  • Verify that the emission warning lamps flash twice to signify a reset.
  • Start the engine and let it idle for one minute.

Fault Code 0001 present?
YES | NO
No Repair | No Repair

Go to 1A

Repair complete.

Last Modified: 18-Apr-2012


FAULT CODE 0002 - Exhaust Gas Pressure Sensor Number 1 Circuit - Voltage Below Normal, or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas pressure sensor and circuit. |
 | STEP 1A. Inspect the exhaust gas pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 1C. Check the circuit response. | Fault Code 0002 inactive and Fault Code 0001 active?
 | STEP 1D. Check the fault code and verify sensor condition. | Fault Code 0002 is active?
STEP 2. | Check the exhaust gas treatment monitor unit and exhaust gas treatment monitor harness. |
 | STEP 2A. Inspect the exhaust gas treatment monitor unit and exhaust gas treatment monitor harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the exhaust gas treatment monitor harness. | Less than 10 ohms?
 | STEP 2C. Check for an open circuit in the exhaust gas treatment monitor harness. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-pin short circuit in the exhaust gas treatment monitor harness. | Greater than 100k ohms?
 | STEP 2E. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 2F. Check for fault code presence. | Fault Code 0002 present?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 0002 present?

Guided Step 1 - Check the exhaust gas pressure sensor and circuit.

Guided Step 1A - Inspect the exhaust gas pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas pressure sensor from the exhaust gas treatment monitor harness.

Action

Inspect the exhaust gas treatment monitor harness and exhaust gas pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Use the following procedure in the Troubleshooting and Repair Manual ISC, ISCe, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 011-038 in Section 11.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas pressure sensor from the exhaust gas treatment monitor harness
  • Turn keyswitch ON.

Action

Check the SUPPLY voltage and RETURN circuit.

  • Measure the voltage between the exhaust gas pressure +5 volt SUPPLY pin and the exhaust gas pressure RETURN pin at the sensor connector of the exhaust gas treatment monitor harness.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 1C

Go to 2A

Guided Step 1C - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas pressure sensor from the exhaust gas treatment monitor harness
  • Turn keyswitch ON
  • Connect the Emissions Monitor Interface electronic service tool.

Action

Reset the Exhaust Gas Treatment Monitor Unit using the Emissions Monitor Interface electronic service tool.

  • Place a jumper wire between the exhaust gas pressure SUPPLY pin and the exhaust gas pressure SIGNAL pin at the exhaust gas pressure sensor connector of the exhaust gas treatment monitor harness.
  • Start the engine and check for the appropriate circuit response after 30 seconds.
  • Use the Emissions Monitor Interface electronic service tool to read the fault codes.

Fault Code 0002 inactive and Fault Code 0001 active?
YES | NO
No Repair | No Repair

Go to 1D

Go to 2A

Guided Step 1D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the exhaust gas pressure sensor to the exhaust gas treatment monitor harness
  • Reset Emissions Gas Treatment Monitor
  • Start engine
  • Connect the Emissions Monitor Interface electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the Emissions Monitor Interface electronic service tool to read the fault codes.

Fault Code 0002 is active?
YES NO

Repair

A damaged sensor has been detected.

Replace the exhaust gas pressure sensor. Use the following procedure in the Troubleshooting and Repair Manual ISC, ISCe, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 011-039 in Section 11.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 3A

Guided Step 2 - Check the exhaust gas treatment monitor unit and exhaust gas treatment monitor harness.

Guided Step 2A - Inspect the exhaust gas treatment monitor unit and exhaust gas treatment monitor harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas treatment monitor unit from the exhaust gas treatment monitor harness.

Action

Inspect theexhaust gas treatment monitor unit and exhaust gas treatment monitor harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas treatment monitor unit connector or exhaust gas treatment monitor harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Use the following procedure(s) in the Troubleshooting and Repair Manual ISC, ISCe, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418.

  • Refer to Procedure 011-038 in Section 11.
  • Refer to Procedure 011-035 in Section 11.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the exhaust gas treatment monitor harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas treatment monitor unit from the exhaust gas treatment monitor harness
  • Disconnect the exhaust gas pressure sensor from the exhaust gas treatment monitor harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas treatment monitor harness exhaust gas treatment monitor unit connector exhaust gas pressure SUPPLY pin and the exhaust gas treatment monitor harness exhaust gas pressure sensor connector SUPPLY pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SUPPLY circuit has been detected in the exhaust gas treatment monitor harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the exhaust gas treatment monitor harness. Use the following procedure in the Troubleshooting and Repair Manual ISC, ISCe, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 011-038 in Section 11.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open circuit in the exhaust gas treatment monitor harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas treatment monitor unit from the exhaust gas treatment monitor harness
  • Disconnect the exhaust gas pressure sensor from the exhaust gas treatment monitor harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas treatment monitor harness exhaust gas treatment monitor unit connector exhaust gas pressure SIGNAL pin and the exhaust gas treatment monitor harness exhaust gas pressure sensor connector SIGNAL pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SIGNAL circuit has been detected in the exhaust gas treatment monitor harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the exhaust gas treatment monitor harness. Use the following procedure in the Troubleshooting and Repair Manual ISC, ISCe, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 011-038 in Section 11.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit in the exhaust gas treatment monitor harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas treatment monitor harness from the exhaust gas treatment monitor unit connector
  • Disconnect the exhaust gas pressure sensor from the exhaust gas treatment monitor harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust gas pressure SIGNAL pin in the exhaust gas treatment monitor harness exhaust gas treatment monitor unit connector and all other pins in the exhaust gas treatment monitor harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the exhaust gas treatment monitor harness.

Troubleshoot each harness connected in series to determine which contains the pin to pin short circuit.

Repair or replace the exhaust gas treatment monitor harness. Use the following procedure in the Troubleshooting and Repair Manual ISC, ISCe, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 011-038 in Section 11.

Go to 2E

Go to 3A

Guided Step 2E - Check for a pin short circuit to ground

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas treatment monitor harness from the exhaust gas treatment monitor unit connector
  • Disconnect the exhaust gas pressure sensor from the exhaust gas treatment monitor harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the exhaust gas pressure SIGNAL pin in the exhaust gas treatment monitor harness exhaust gas treatment monitor unit connector and ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the exhaust gas treatment monitor harness.

Troubleshoot each harness connected in series to determine which contains the pin to pin short circuit.

Repair or replace the exhaust gas treatment monitor harness. Use the following procedure in the Troubleshooting and Repair Manual ISC, ISCe, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 011-038 in Section 11.

Go to 2F

Go to 3A

Guided Step 2F - Check for fault code presence.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the Emissions Monitor Interface electronic service tool.

Action

Reset the Exhaust Gas Treatment Monitor Unit using the Emissions Monitor Interface electronic service tool.

  • Start the engine and check for the appropriate circuit response after 30 seconds.
  • Use the Emissions Monitor Interface electronic service tool to read the fault codes.

Fault Code 0002 present?
YES NO

Repair

Replace the exhaust gas treatment monitor unit. Use the following procedure in the Troubleshooting and Repair Manual ISC, ISCe, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 011-035 in Section 11.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the Emissions Monitor Interface electronic service tool.

Action

Reset the fault codes using the Emissions Monitor Interface slectronic service tool.

  • Verify that the emission warning lamps flash twice to signify a reset.
  • Start the engine and let it idle for one minute.

Fault Code 0002 present?
YES | NO
No Repair | No Repair

Go to 1A

Repair complete.

Last Modified: 18-Apr-2012


FAULT CODE 0003 - Exhaust Gas Pressure Sensor Number 1 Circuit - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor the exhaust gas pressure |
 | STEP 1A. Monitor the exhaust gas pressure. | Does the pressure reading change?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 0003 present?

Guided Step 1 - Monitor the exhaust gas pressure.

Guided Step 1A - Monitor the exhaust gas pressure.

Conditions

  • Turn keyswitch OFF
  • Connect the Emissions Monitor Interface electronic service tool
  • Start the engine.

Action

Monitor the exhaust gas pressure reading using the Emission Monitor Interface electronic service tool.

  • Operate the engine from low idle to high idle several times and verify that the pressure reading changes.

Does the pressure reading change?
YES NO
No Repair

Repair

A damaged connection has been detected in the sensor or harness connector or a damaged sensor has been detected. Use the following procedure in the Troubleshooting and Repair Manual ISC, ISCe, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 011-039 in Section 11.

No repair.

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the Emissions Monitor Interface electronic service tool.

Action

Reset the fault codes using the Emissions Monitor Interface slectronic service tool.

  • Verify that the emission warning lamps flash twice to signify a reset.

Note: The engine will need to be operated for at least thirty minutes with the exhaust gas temperature above 250°C [482°F] in order for this fault code to set. It is unlikely that this fault code will become active in the shop.

Fault Code 0003 present?
YES NO

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 18-Apr-2012


FAULT CODE 0004 - Exhaust Gas Temperature Sensor Number 1 Circuit - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor the exhaust gas temperature |
 | STEP 1A. Monitor the exhaust gas temperature. | Does the temperature reading change?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 0004 present?

Guided Step 1 - Monitor the exhaust gas temperature.

Guided Step 1A - Monitor the exhaust gas temperature.

Conditions

  • Turn keyswitch OFF
  • Connect the Emissions Monitor Interface electronic service tool
  • Start the engine.

Action

Monitor the exhaust gas temperature reading using the Emission Monitor Interface electronic service tool.

  • Operate the engine from low idle to high idle several times and verify that the temperature reading changes.

Does the temperature reading change?
YES NO
No Repair

Repair

A damaged connection has been detected in the sensor or harness connector or a damaged sensor has been detected.

Use the following procedure in the Troubleshooting and Repair Manual ISC, ISCe, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 011-037 in Section 11.

No repair.

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the Emissions Monitor Interface electronic service tool.

Action

Reset the fault codes using the Emissions Monitor Interface slectronic service tool.

  • Verify that the emission warning lamps flash twice to signify a reset.

Note: The engine will need to be operated for at least one hour in order for this fault code to set. It is unlikely that this fault code will become active in the shop.

Fault Code 0004 present?
YES NO

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Repair complete.

Last Modified: 18-Apr-2012


FAULT CODE 0005 - Exhaust Gas Temperature Sensor Number 1 Circuit - Voltage Below Normal, or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 1A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the sensor resistance. | 14k ohms to 250k ohms?
STEP 2. | Check the exhaust gas treatment monitor unit and exhaust gas treatment monitor harness. |
 | STEP 2A. Inspect the exhaust gas treatment monitor unit and exhaust gas treatment monitor harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the exhaust gas treatment monitor harness. | Less than 10 ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the exhaust gas treatment monitor harness. | Greater than 100k ohms?
 | STEP 2D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 2E. Check for fault code presence. | Fault Code 0002 present?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 0002 present?

Guided Step 1 - Check the exhaust gas temperature sensor and circuit.

Guided Step 1A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas temperature sensor from the exhaust gas treatment monitor harness.

Action

Inspect the exhaust gas treatment monitor harness and exhaust gas temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Use the following procedure in the Troubleshooting and Repair Manual ISC, ISCe, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 011-038 in Section 11.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas temperature sensor from the exhaust gas treatment monitor harness.

Action

Check the sensor resistance.

  • Measure the resistance between the SIGNAL pin and the RETURN pin at the exhaust gas temperature sensor connector.

14k ohms to 250k ohms?
YES NO
No Repair

Repair

Replace the exhaust gas temperature sensor. Use the following procedure in the Troubleshooting and Repair Manual ISC, ISCe, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 011-037 in Section 11.

Go to 2A

Go to 3A

Guided Step 2 - Check the exhaust gas treatment monitor unit and exhaust gas treatment monitor harness.

Guided Step 2A - Inspect the exhaust gas treatment monitor unit and exhaust gas treatment monitor harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas treatment monitor unit from the exhaust gas treatment monitor harness.

Action

Inspect the exhaust gas treatment monitor unit and exhaust gas treatment monitor harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas treatment monitor unit connector or exhaust gas treatment monitor harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Use the following procedure(s) in the Troubleshooting and Repair Manual ISC, ISCe, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418.

  • Refer to Procedure 011-038 in Section 11.
  • Refer to Procedure 011-035 in Section 11.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the exhaust gas treatment monitor harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas treatment unit from the exhaust gas treatment monitor harness
  • Disconnect the exhaust gas temperature sensor from the exhaust gas treatment monitor harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas treatment monitor harness exhaust gas treatment monitor unit connector exhaust gas temperature sensor SIGNAL pin and the exhaust gas treatment monitor harness exhaust gas temperature sensor connector SIGNAL pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SIGNAL circuit has been detected in the exhaust gas treatment monitor harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the exhaust gas treatment monitor harness. Use the following procedure in the Troubleshooting and Repair Manual ISC, ISCe, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 011-038 in Section 11.

Go to 2C

Go to 3A

Guided Step 2C - Check for a pin-to-pin short circuit in the exhaust gas treatment monitor harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas treatment monitor harness from the exhaust gas treatment monitor unit connector
  • Disconnect the exhaust gas temperature sensor from the exhaust gas treatment monitor harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust gas temperature SIGNAL pin in the exhaust gas treatment monitor harness exhaust gas treatment monitor unit connector and all other pins in the exhaust gas treatment monitor connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the exhaust gas treatment monitor harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin short circuit.

Repair or replace the exhaust gas treatment monitor harness. Use the following procedure in the Troubleshooting and Repair Manual ISC, ISCe, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 011-038 in Section 11.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin short circuit to ground

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas treatment monitor harness from the exhaust gas treatment monitor unit connector
  • Disconnect the exhaust gas temperature sensor from the exhaust gas treatment monitor harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the exhaust gas temperature SIGNAL pin in the exhaust gas treatment monitor harness exhaust gas treatment monitor unit connector and ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the exhaust gas treatment monitor harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-ground short circuit.

Repair or replace the exhaust gas treatment monitor harness. Use the following procedure in the Troubleshooting and Repair Manual ISC, ISCe, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 011-038 in Section 11.

Go to 2E

Go to 3A

Guided Step 2E - Check for fault code presence.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the Emissions Monitor Interface electronic service tool.

Action

Reset the Exhaust Gas Treatment Monitor Unit using the Emissions Monitor Interface electronic service tool.

  • Start the engine and check for the appropriate circuit response after the engine has idled for five minutes.
  • Use the Emissions Monitor Interface electronic service tool to read the fault codes.

Fault Code 0005 present?
YES NO

Repair

Replace the exhaust gas treatment monitor unit. Use the following procedure in the Troubleshooting and Repair Manual ISC, ISCe, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 011-035 in Section 11.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the Emissions Monitor Interface electronic service tool.

Action

Reset the fault codes using the Emissions Monitor Interface slectronic service tool.

  • Verify that the emission warning lamps flash twice to signify a reset.
  • Start the engine and let it idle for five minutes.

Fault Code 0005 present?
YES | NO
No Repair | No Repair

Go to 1A

Repair complete.

Last Modified: 18-Apr-2012


FAULT CODE 0006 - Exhaust Gas Temperature Sensor Number 1 Circuit - Voltage Above Normal, or Shorted to High Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 1A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the sensor resistance. | 14k ohms to 250k ohms?
STEP 2. | Check the exhaust gas treatment monitor unit and exhaust gas treatment monitor harness. |
 | STEP 2A. Inspect the exhaust gas treatment monitor unit and exhaust gas treatment monitor harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the exhaust gas treatment monitor harness. | Greater than 100k ohms?
 | STEP 2C. Check for fault code presence. | Fault Code 0002 present?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 0002 present?

Guided Step 1 - Check the exhaust gas temperature sensor and circuit.

Guided Step 1A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas temperature sensor from the exhaust gas treatment monitor harness.

Action

Inspect the exhaust gas treatment monitor harness and exhaust gas temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Use the following procedure in the Troubleshooting and Repair Manual ISC, ISCe, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 011-038 in Section 11.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas temperature sensor from the exhaust gas treatment monitor harness.

Action

Check the sensor resistance.

  • Measure the resistance between the SIGNAL pin and the RETURN pin at the exhaust gas temperature sensor connector.

14k ohms to 250k ohms?
YES NO
No Repair

Repair

Replace the exhaust gas temperature sensor. Use the following procedure in the Troubleshooting and Repair Manual ISC, ISCe, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 011-037 in Section 11.

Go to 2A

Go to 3A

Guided Step 2 - Check the exhaust gas treatment monitor unit and exhaust gas treatment monitor harness.

Guided Step 2A - Inspect the exhaust gas treatment monitor unit and exhaust gas treatment monitor harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas treatment monitor unit from the exhaust gas treatment monitor harness.

Action

Inspect theexhaust gas treatment monitor unit and exhaust gas treatment monitor harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas treatment monitor unit connector or exhaust gas treatment monitor harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Use the following procedure in the Troubleshooting and Repair Manual ISC, ISCe, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418.

  • Refer to Procedure 011-038 in Section 11.
  • Refer to Procedure 011-035 in Section 11.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the exhaust gas treatment monitor harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the exhaust gas treatment monitor harness from the exhaust gas treatment monitor unit connector
  • Disconnect the exhaust gas temperature sensor from the exhaust gas treatment monitor harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust gas temperature sensor SIGNAL pin in the exhaust gas treatment monitor harness exhaust gas treatment monitor unit connector and all other pins in the exhaust gas treatment monitor unit connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the exhaust gas treatment monitor harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin short circuit.

Repair or replace the exhaust gas treatment monitor harness. Use the following procedure in the Troubleshooting and Repair Manual ISC, ISCe, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 011-038 in Section 11.

Go to 2D

Go to 3A

Guided Step 2D - Check for fault code presence.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the Emissions Monitor Interface electronic service tool.

Action

Reset the Exhaust Gas Treatment Monitor Unit using the Emissions Monitor Interface electronic service tool.

  • Check for the appropriate circuit response after 30 seconds.
  • Use the Emissions Monitor Interface electronic service tool to read the fault codes.

Fault Code 0006 present?
YES NO

Repair

Replace the exhaust gas treatment monitor unit. Use the following procedure in the Troubleshooting and Repair Manual ISC, ISCe, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 011-035 in Section 11.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect the Emissions Monitor Interface electronic service tool.

Action

Reset the fault codes using the Emissions Monitor Interface slectronic service tool.

  • Verify that the emission warning lamps flash twice to signify a reset.
  • Start the engine and let it idle for one minute.

Fault Code 0006 present?
YES | NO
No Repair | No Repair

Go to 1A

Repair complete.

Last Modified: 18-Apr-2012


FAULT CODE 111 - Engine Control Module - Critical Internal Failure

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM |
 | STEP 1A. Check the ECM | Fault Code 111 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 111 | Less than 3 counts?
STEP 2. | Clear the fault codes |
 | STEP 2A. Disable the fault code | Fault Code 111 inactive?
 | STEP 2B. Clear the inactive fault codes | All fault codes cleared?

Guided Step 1 - Check the ECM

Guided Step 1A - Check the ECM

Conditions

  • Connect all components

Action

Check the ECM.

  • Turn the keyswitch OFF and wait 5 seconds.
  • Start the engine and let it idle for 1 minute.

Is Fault Code 111 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 111

Conditions

  • Turn the keyswitch ON.

Action

Check the inactive counts of Fault Code 111.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 111.

Are there less than 3 counts?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 2B

Go to 2A

Guided Step 2 - Clear the fault codes

Guided Step 2A - Disable the fault code

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 111 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 02-Mar-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Determine if Fault Code 115 becomes active during cranking. | Fault Code 115 becomes active during cranking?
 | STEP 1B. Inspect the engine harness. | Harness connectors connected to correct sensors?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 115 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Determine if Fault Code 115 becomes active during cranking.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Attempt to start the engine by engaging the starter for at least ten seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 115 becomes active during cranking?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine harness connectors for correct connections.

  • Make sure that the main engine speed sensor (crankshaft position sensor) and the backup engine speed sensor (camshaft position sensor) are connected to the engine wiring harness correctly.

Harness connectors connected to correct sensors?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 115 inactive?
YES | NO
No Repair | No Repair

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Jul-2010


FAULT CODE 122 - Intake Manifold Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 122 inactive?
STEP 2. | Check the intake manifold pressure sensor and circuit |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 123 active and Fault Code 122 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 122 active?
STEP 3. | Check the engine control module and engine harness |
 | STEP 3A. Inspect engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the engine control module response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code |
 | STEP 4A. Disable the fault code. | Fault Code 122 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 227

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ to read the fault codes.

Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor and circuit

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Wire insulation damage
  • Connector shell broken.
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the intake manifold pressure sensor.

Refer to Procedure 019-061 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module and engine harness

Guided Step 3A - Inspect engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Wire insulation damage
  • Connector shell broken.
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the engine control module response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit reaponse after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the failure.

Repair

A pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Wire insulation damage
  • Connector shell broken.
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the engine control module engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 02-Mar-2012


FAULT CODE 123 - Intake Manifold Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164596 - male Framatome test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 123 inactive?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 122 active and Fault Code 123 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 123 active?
STEP 3. | Check the engine control module and engine harness. |
 | STEP 3A. Inspect engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the engine control module response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 123 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 187

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for Inactive or Intermittent Fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the intake manifold pressure +5 volt SUPPLY pin and the intake manifold pressure SIGNAL pin at the intake manifold pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to erase the inactive fault codes.

Fault Code 123 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Repair

None. The removal and installation of the connector corrected the failure.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module and engine harness

Guided Step 3A - Inspect engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the engine control module engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit reaponse after 30 seconds.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

Fault Code 123 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A open or shorted SUPPLY circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken.
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the engine control module response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the intake manifold pressure +5 volt SUPPLY pin and the intake manifold pressure SIGNAL pin at the engine control module engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

Fault Code 123 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open circuit or a pin to pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to erase the inactive fault codes.

Fault Code 123 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 02-Mar-2012


FAULT CODE 124 - Intake Manifold 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with INSITE™ electronic service tool. | Value of Intake Manifold Pressure is less than 8 in Hg?
 | STEP 1B. Verify the sensor accuracy with a mechanical gauge. | Sensor reading is correct within 5 in Hg?
 | STEP 1C. Check the system for tampering. | Tampering detected?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 124 inactive?
 | STEP 2B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the sensor accuracy with INSITE™ electronic service tool.

  • Monitor Intake Manifold Pressure with INSITE™ electronic service tool with the keyswitch ON and the engine not running.

Value of Intake Manifold Pressure less than 8 in Hg?
YES NO
No Repair

Repair

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 1B

Repair Complete

Guided Step 1B - Verify the sensor accuracy with a mechanical gauge.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine

Action

Verify the sensor accuracy with a mechanical gauge.

  • Connect a mechanical intake manifold pressure gauge to the engine.
  • Use INSITE™ electronic service tool read the fault codes.
  • Start the engine, and compare the intake manifold pressure reading on the service tool monitor screen to the reading on the mechanical intake manifold pressure gauge.

Note: The engine may need to be loaded before the pressure readings can be compared.

Sensor reading is correct within 5 in Hg?
YES NO
No Repair

Repair

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 1C

Go to 2A

Guided Step 1C - Check the system for tampering.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger and fuel system for the following:

  • Turbocharger wastegate tampering.
  • Variable geometry turbocharger tampering.
  • Fuel system tampering.
  • Fuel system add-on electronic devices.

Tampering detected?
YES NO

Repair

Remove the tampering device.

 No Repair

Go to 2A

Engine Performance Troubleshooting Tree

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 124 inactive?
YES | NO
No Repair | No Repair

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool erase the inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 02-Mar-2012


FAULT CODE 131 - Accelerator Pedal or Lever Position Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3823996 - female Weather-Pack test leadPart Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 387 active?
 | STEP 1B. Check for an active fault code. | Fault Code 131 active?
STEP 2. | Check the accelerator pedal or lever position sensor circuit. |
 | STEP 2A. Inspect the accelerator pedal or lever position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal or lever position sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 132 active and Fault Code 131 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal or lever condition. | Fault Code 132 is active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check for an open circuit in the OEM harness. |
 | STEP 3A-2. Check for a pin-to-pin short circuit in the OEM harness. |
 | STEP 3B. Check for an inactive fault code. | Fault Code 131 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 131 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 387 active?
YES | NO
No Repair | No Repair

Fault Code 387

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an Inactive or Intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the accelerator pedal or lever position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal or lever position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the accelerator pedal or lever position sensor +5 VDC SUPPLY pin to the accelerator pedal or lever position sensor RETURN pin at the sensor connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 active and Fault Code 131 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal or lever condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal or lever to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 is active?
YES NO

Repair

A damaged accelerator pedal or lever has been detected. Contact the appropriate OEM or dealership for repair instructions.

Replace the accelerator pedal or lever. Refer to the OEM service manual.

Repair

None. The removal and installation of the connector corrected the failure.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal or lever RETURN pin and the OEM harness accelerator pedal or lever RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open RETURN circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal or lever SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 131 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked a second time.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 02-Mar-2012


FAULT CODE 132 - Accelerator Pedal or Lever Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823995 - male Weather-Pack test lead; Part Number 3823996 - female Weather-Pack test lead; Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 443 active?
 | STEP 1B. Check for an active fault code. | Fault Code 132 active?
STEP 2. | Check the accelerator pedal or lever position sensor and circuit. |
 | STEP 2A. Inspect the accelerator pedal or lever position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal or lever position sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 131 active and Fault Code 132 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal or lever condition. | Fault Code 132 is active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check for an open circuit in the OEM harness. |
 | STEP 3A-2. Check for an open circuit in the OEM harness. |
 | STEP 3A-3. Check for a pin-to-pin short circuit in the OEM harness. |
 | STEP 3A-4. Check for a pin short circuit to ground in the OEM harness. |
 | STEP 3B. Check for an inactive fault code. | Fault Code 132 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 132 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 443 active?
YES | NO
No Repair | No Repair

Fault Code 443

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the accelerator pedal or lever position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal or lever position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the accelerator pedal or lever position +5 VDC SUPPLY pin to the accelerator pedal or lever position RETURN pin at the sensor connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the accelerator pedal or lever position +5 VDC SUPPLY pin and the accelerator pedal or lever position SIGNAL pin at the sensor connector of the OEM harness.

  • Check for the appropriate ECM response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram for connector pin identification.

Fault Code 131 active and Fault Code 132 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal or lever condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal or lever to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 is active?
YES NO

Repair

A damaged accelerator pedal or lever has been detected. Contact the appropriate OEM or dealership for repair instructions.

Replace the accelerator pedal or lever.

Refer to the OEM service manual.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A defective connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal or lever SUPPLY pin and the OEM harness accelerator pedal or lever connector SUPPLY pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SUPPLY circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the accelerator pedal or lever from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal or lever SIGNAL pin and the OEM harness accelerator pedal or lever connector SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SIGNAL circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A-3

Go to 4A

Guided Step 3A-3 - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal or lever SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A-4

Go to 4A

Guided Step 3A-4 - Check for a pin short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the accelerator pedal or lever SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin to ground short circuit on the SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 inactive?
YES NO

Repair

The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 132 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked a second time.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 02-Mar-2012


FAULT CODE 133 - Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal, or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823996 - female Weather-Pack test lead and Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 387 or 2185 active?
 | STEP 1B. Check for an active fault code. | Fault Code 133 active?
STEP 2. | Check the remote accelerator pedal or lever position sensor circuit. |
 | STEP 2A. Inspect the remote accelerator pedal or lever position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the remote accelerator pedal or lever position sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 134 active and Fault Code 133 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal or lever condition. | Fault Code 134 is active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check for an open circuit in the OEM harness. |
 | STEP 3A-2. Check for a pin-to-pin short circuit in the OEM harness. |
 | STEP 3B. Check for an inactive fault code. | Fault Code 133 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 133 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 387 or 2185 active?
YES | NO
No Repair | No Repair

Fault Code 387 or 2185

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 133 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the remote accelerator pedal or lever position sensor and circuit.

Guided Step 2A - Inspect the remote accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken.
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the remote accelerator pedal or lever position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the remote accelerator pedal or lever position sensor +5 volt SUPPLY pin to the remote accelerator pedal or lever position sensor RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 active and Fault Code 133 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify remote accelerator pedal or lever condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the remote accelerator pedal or lever to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 is active?
YES NO

Repair

A damaged remote accelerator pedal or lever has been detected. Contact the appropriate OEM or dealership for repair instructions.

Replace the remote accelerator pedal or lever. Refer to the OEM service manual.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken.
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector remote accelerator pedal or lever RETURN pin and the OEM harness remote accelerator pedal or lever RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open RETURN circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the remote accelerator pedal or lever SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 133 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 133 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes .

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 02-Mar-2012


FAULT CODE 134 - Remote Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal, or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823995 - male Weather-Pack test lead; Part Number 3823996 - female Weather-Pack test lead; Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 443 or 2186 active?
 | STEP 1B. Check for an active fault code. | Fault Code 134 active?
STEP 2. | Check the remote accelerator pedal or lever position sensor and circuit. |
 | STEP 2A. Inspect the remote accelerator pedal or lever position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the remote accelerator pedal or lever position sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 133 active and Fault Code 134 inactive?
 | STEP 2D. Check the fault codes and verify remote accelerator pedal or lever condition. | Fault Code 134 is active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check for an open circuit in the OEM harness. |
 | STEP 3A-2. Check for an open circuit in the OEM harness. |
 | STEP 3A-3. Check for a pin-to-pin short circuit in the OEM harness. |
 | STEP 3A-4. Check for a pin short circuit to ground in the OEM harness. |
 | STEP 3B. Check for an inactive fault code. | Fault Code 134 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 134 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool, read the fault codes.

Fault Code 443 or 2186 active?
YES | NO
No Repair | No Repair

Fault Code 443 or 2186

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool, read the fault codes.

Fault Code 134 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent Fault Code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the remote accelerator pedal or lever position sensor and circuit.

Guided Step 2A - Inspect the remote accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken.
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the remote accelerator pedal or lever position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the accelerator pedal or lever position +5 volt SUPPLY pin to the accelerator pedal or lever position RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the accelerator pedal or lever position +5 volt SUPPLY pin and the accelerator pedal or lever position SIGNAL pin at the sensor connector of the OEM harness.

  • Check for the appropriate ECM response after 30 seconds.
  • Use INSITE™ electronic service tool , read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 133 active and Fault Code 134 inactive?

YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify remote accelerator pedal or lever condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the remote accelerator pedal or lever to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 134 is active?
YES NO

Repair

A damaged remote accelerator pedal or lever has been detected. Contact the appropriate OEM or dealership for repair instructions.

Replace the remote accelerator pedal or lever.

Refer to the OEM service manual.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken.
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector remote accelerator pedal or lever SUPPLY pin and the OEM harness remote accelerator pedal or lever connector SUPPLY pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SUPPLY circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the remote accelerator pedal or lever from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector remote accelerator pedal or lever SIGNAL pin and the OEM harness remote accelerator pedal or lever connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SIGNAL circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A-3

Go to 4A

Guided Step 3A-3 - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the remote accelerator pedal or lever SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A-4

Go to 4A

Guided Step 3A-4 - Check for a pin short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the remote accelerator pedal or lever position sensor from the OEM harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the remote accelerator pedal or lever SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin to ground short circuit on the SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 134 inactive?
YES NO

Repair

The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool, verify that the fault code is inactive.

Fault Code 134 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool, erase the inactive fault codes .

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 02-Mar-2012


FAULT CODE 135 (Automotive Application) - Oil Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome test lead and Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 135 inactive?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 141 active and Fault Code 135 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 221 active?
STEP 3. | Check the engine control module and engine harness. |
 | STEP 3A. Inspect engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the engine control module response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 135 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 386

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the oil pressure sensor. Refer to Procedure 019-066 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module and engine harness.

Guided Step 3A - Inspect engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the engine control module response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in Section 19.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module engine connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the engine control module engine connector.

Refer to the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 135 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked a second time.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Apr-2012


FAULT CODE 135 (Marine Applications) - Oil Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome test lead and Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 135 inactive?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 141 active and Fault Code 135 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 221 active?
STEP 3. | Check the engine control module and engine harness. |
 | STEP 3A. Inspect engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the engine control module response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 135 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the oil pressure sensor. Refer to Procedure 019-066 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module and engine harness.

Guided Step 3A - Inspect engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the engine control module response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module engine connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the engine control module engine connector.

Refer to the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 135 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 135 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Apr-2012


FAULT CODE 141 (Automotive Application) - Oil Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 141 inactive?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 135 active and Fault Code 141 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 141 active?
STEP 3. | Check the engine control module and engine harness. |
 | STEP 3A. Inspect engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the engine control module response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 141 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 352

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the oil pressure +5 volt SUPPY pin and the oil pressure SIGNAL pin at the oil pressure sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Start and idle the engine for 1 minute with the oil temperature higher than 49°C [120°F].

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active and Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the oil pressure sensor. Refer to Procedure 019-066 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module and engine harness.

Guided Step 3A - Inspect engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the engine control module engine connector.

Refer to the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open or shorted SUPPLY circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the engine control module response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

Place a jumper wire between the oil pressure +5 volt SUPPLY pin and the oil pressure SIGNAL pin at the engine control module engine connector.

Refer to the wiring diagram for connector pin identification.

Start and idle the engine for 1 minute with the oil temperature higher than 49°C [120°F].

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active and Fault Code 141 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open RETURN or a pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 141 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked a second time.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Apr-2012


FAULT CODE 141 (Marine Applications) - Oil Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 141 inactive?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 135 active and Fault Code 141 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 141 active?
STEP 3. | Check the engine control module and engine harness. |
 | STEP 3A. Inspect engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the engine control module response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 141 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ to read the fault codes.

Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the oil pressure +5 volt SUPPY pin and the oil pressure SIGNAL pin at the oil pressure sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Start and idle the engine for 1 minute with the oil temperature higher than 49°C [120°F].

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active and Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the oil pressure sensor. Refer to Procedure 019-066 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module and engine harness.

Guided Step 3A - Inspect engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the engine control module engine connector.

Refer to the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open or shorted SUPPLY circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the engine control module response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

Place a jumper wire between the oil pressure +5 volt SUPPLY pin and the oil pressure SIGNAL pin at the engine control module engine connector.

Refer to the wiring diagram for connector pin identification.

Start and idle the engine for 1 minute with the oil temperature higher than 49°C [120°F].

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 135 active and Fault Code 141 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the failure.

Repair

An open RETURN or a pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 141 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Apr-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 143. | Active or inactive counts of Fault Code 143?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 143.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 143?
YES NO

Repair

Refer to the Lubricating Oil Pressure Below or Above Normal troubleshooting tree in Troubleshooting and Repair Manual, ISC, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418 or ISBe and ISB (Common Rail Fuel System) Series Engines, Bulletin 4021271.

No Repair

Appropriate troubleshooting symptom tree

Repair complete

Last Modified: 08-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 143. | Active or inactive counts of Fault Code 143?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 143.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 143?
YES NO

Repair

Refer to the Lubricating Oil Pressure Below or Above Normal troubleshooting tree in Troubleshooting and Repair Manual, ISBe and ISB (Common Rail Fuel System) Series Engines, Bulletin 4021271.

No Repair

Appropriate troubleshooting symptom tree

Repair complete

Last Modified: 08-Jul-2010


FAULT CODE 144 (ISB/QSB Automotive and Industrial, ISC/QSC/ISL/QSL Automotive, Industrial, and Marine) - Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - Deutsch/AMP/Metri-Pack test lead and Part Number 3822917 - Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 144 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 145 active and Fault Code 144 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 144 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broke
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Repair

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 is active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell shroud broke
  • Damaged locking tab connector
  • Damage to wire or engine harness insulation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the coolant temperature sensor SIGNAL pin and coolant temperature sensor RETURN pin at the ECM connector.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 145 active and Fault Code 144 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature sensor RETURN pin and the engine harness engine coolant temperature sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature sensor SIGNAL pin and the engine harness engine coolant temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 144 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 12-Mar-2012


FAULT CODE 144 (QSB Marine Application) - Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - Deutsch/AMP/Metri-Pack test lead and Part Number 3822917 - Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 144 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 145 active and Fault Code 144 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 144 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broke
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Repair

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 is active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell shroud broke
  • Damaged locking tab connector
  • Damage to wire or engine harness insulation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the coolant temperature sensor SIGNAL pin and coolant temperature sensor RETURN pin at the ECM connector.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 145 active and Fault Code 144 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature sensor RETURN pin and the engine harness engine coolant temperature sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature sensor SIGNAL pin and the engine harness engine coolant temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 144 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 12-Mar-2012


FAULT CODE 145 (ISB/QSB Automotive and Industrial, ISC/QSC/ISL/QSL Automotive, Industrial, and Marine) - Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead and Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 145 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 145 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broke
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 is active?
YES NO

Repair

A damaged sensor has been detected.

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broke
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin to ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 145 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 12-Mar-2012


FAULT CODE 145 (QSB Marine Application) - Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead and Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 145 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 145 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broke
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?

YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 is active?
YES NO

Repair

A damaged sensor has been detected.

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broke
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?

YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin to ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 145 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 12-Mar-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 146. | Active or inactive counts of Fault Code 146?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 146.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 146.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 146?
YES NO

Repair

Refer to the Engine Coolant Temperature Above Normal symptom tree in Troubleshooting and Repair Manual, ISC, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418 or ISB (Common Rail Fuel System) Series Engines, Bulletin 4021271.

No Repair

Appropriate troubleshooting symptom tree

Repair complete

Last Modified: 08-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 146. | Active or inactive counts of Fault Code 146?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 146.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 146.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 146?
YES NO

Repair

Refer to the Engine Coolant Temperature Above Normal symptom tree in Troubleshooting and Repair Manual, ISBe and ISB (Common Rail Fuel System) Series Engines, Bulletin 4021271.

No Repair

Appropriate troubleshooting symptom tree

Repair complete

Last Modified: 08-Jul-2010


FAULT CODE 147 Accelerator Pedal or Lever Position 1 Sensor Circuit Frequency - Data Valid But Below Normal Operational Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Codes 147 inactive?
STEP 2. | Check the frequency throttle and circuit. |
 | STEP 2A. Inspect the frequency throttle and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short to ground in the frequency throttle. | Greater than 100K ohms?
 | STEP 2C. Check for correct frequency throttle input voltage. | Voltage greater than OEM specifications?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin short circuit to ground in the OEM harness. | Greater than 10 ohms?
 | STEP 3D. Check for a pin to pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 147 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault code 147 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Using INSITE™ electronic service tool read the fault codes.

Fault Code 147 inactive?
YES | NO
No Repair | No Repair

Intermittent fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check frequency throttle and circuit.

Guided Step 2A - Inspect the frequency throttle and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the frequency throttle and connector pins.

Action

Inspect the OEM harness and frquency throttle connector pins for the following:

  • Corroded pins
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Wire insulation damaged.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Connector shell broken.
  • Dirt or debris in or on the connector pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or has harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short to ground in the frequency throttle.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the frequency throttle from the OEM harness.

Action

Check for a frequency throttle output short to ground.

  • Measure the resistance between the frequency throttle SIGNAL pin and ground at the frequency throttle connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A shorted frequency throttle has been detected.

Repair or replace the frequency throttle. Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check for correct frequency throttle input voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the frequency throttle from the OEM harness.

Action

Check the frequency throttle reference (input) voltage.

  • Measure frequency throttle reference (input) voltage.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Voltage greater than OEM specifications?
YES NO
No Repair

Repair

An incorrect reference (input) voltage to the frequency throttle has been detected.

Repair or replace the frequency throttle reference (input) circuit. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Wire insulation damaged.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Connector shell broken.
  • Dirt or debris in or on the connector pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the frequency throttle.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector frequency throttle SIGNAL pin and the OEM harness frequency throttle connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SIGNAL circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open signal circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the frequency throttle from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector frequency throttle SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

An shorted to ground SIGNAL circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open signal circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the frequency throttle from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM pressure SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool read the fault codes.

Fault Code 147 inactive?
YES NO

Repair

None. The removal and reinstallation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let idle for one minute.
  • Use INSITE™ electronic service tool, verify that the fault code is inactive.

Fault Code 147 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool, erase the inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 12-Mar-2012


FAULT CODE 148 - Accelerator Pedal or Lever Position Sensor 1 - Data Valid But Above Normal Operational Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 148 inactive?
STEP 2. | Check the frequency throttle and circuit. |
 | STEP 2A. Inspect the frequency throttle and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 147 active and Fault Code 148 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 148 is active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins.
 | STEP 3B. Check for a pin to pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 3C. Check for an inactive fault code. | Fault Code 148 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 148 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool, read the fault codes.

Fault Code 148 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the frequency throttle and circuit.

Guided Step 2A - Inspect the frequency throttle and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the frequency throttle from the OEM harness.

Action

Inspect the OEM harness and frequency throttle connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damaged
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Dirt or debris in or on the connector pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the frequency throttle from the OEM harness.
  • Turn kesyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 147 active and Fault Code 148 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the frequency throttle to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 148 is active?
YES NO

Repair

A damaged frequency throttle has been detected.

Repair or replace the frequency throttle. Refer to OEM service manual.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damaged
  • Missing or damaged connector seals
  • Connector shell broken.
  • Dirt or debris in or on the connector pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged haness, connector or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the frequency throttle from the OEM harnress.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the frequency throttle SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE electronic service tool to read the fault codes.

Fault Code 148 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A damaged frequency throttle has been detected.

Repair or replace the frequency throttle. Refer to OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool, verify that the fault code is inactive.

Fault Code 148 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool erase the inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 12-Mar-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 151. | Active or inactive counts of Fault Code 151?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 151.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 151?
YES NO

Repair

Refer to the Engine Coolant Temperature Above Normal symptom troubleshooting tree in Troubleshooting and Repair Manual, ISB (Common Rail Fuel System) Series Engine, Bulletin 4021272 .

No Repair

Appropriate troubleshooting symptom tree

Repair complete

Last Modified: 08-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 151. | Active or inactive counts of Fault Code 151?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 151.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 151?
YES NO

Repair

Refer to the Engine Coolant Temperature Above Normal symptom troubleshooting tree in Troubleshooting and Repair Manual, ISBe and ISB (Common Rail Fuel System) Series Engine, Bulletin 4021272 .

No Repair

Appropriate troubleshooting symptom tree

Repair complete

Last Modified: 08-Jul-2010


FAULT CODE 153 Intake Manifold Air Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possiblity of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead and Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 153 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 154 active and Fault Code 153 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 153 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ to read the fault codes.

Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the intake manifold air temperature sensor.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Repair

Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 is active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and the intake manifold temperature sensor RETURN pin at the ECM connector.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit dirgram or the wiring diagram for connector pin identification.

Fault Code 154 active and Fault Code 153 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor RETURN pin and the engine harness intake manifold air temperature sensor connector RETURN pin.

Refer to the circuit dirgram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor SIGNAL pin and the engine harness intake manifold air temperature sensor connector SIGNAL pin.

Refer to the circuit dirgram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit dirgram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 12-Mar-2012


FAULT CODE 154 - Intake Manifold Air Pressure/Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possiblity of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead and Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 154 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 154 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?

YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 is active?
YES NO

Repair

A damaged sensor has been detected.

Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?

YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold air temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between intake manifold air temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 is inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 154 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 12-Mar-2012


FAULT CODE 155 - Intake Manifold 1 Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Drive Belt, Cooling Fan | Refer to Procedure 008-002 | ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System | 4021271
Coolant Thermostat | Refer to Procedure 008-013 | SB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System | 4021271
Fan Clutch, On-Off | Refer to Procedure 008-027 | ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System | 4021271
Charge-Air Cooler (CAC) | Refer to Procedure 010-027 | ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System | 4021271
Air Intake Restriction | Refer to Procedure 010-031 | ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System | 4021271
Turbocharger | Refer to Procedure 010-033 | SB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System | 4021271
EGR Valve | Refer to Procedure 011-022 | ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System | 4021271
Engine Control Module Calibration Code | Refer to Procedure 019-032 | ISB, ISBe2, ISBe3, ISBe4, QSB4.5, QSB5.9, QSB6.7, ISC, QSC8.3, ISL, ISLe3, ISLe4, and QSL9 CM850 (CM2850) | 4021416
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | ISB, ISBe2, ISBe3, ISBe4, QSB4.5, QSB5.9, QSB6.7, ISC, QSC8.3, ISL, ISLe3, ISLe4, and QSL9 CM850 (CM2850) | 4021416

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Cooling fan component inspection. |
 | STEP 1A. Cooling fan component inspection. | Damage found?
STEP 2. | High intake manifold temperature basic checks. |
 | STEP 2A. High intake manifold temperature basic checks. | Damage found?
STEP 3. | Radiator is externally obstructed. |
 | STEP 3A. Radiator is externally obstructed. | Damage found?
STEP 4. | Intake manifold temperature sensor struck in-range. |
 | STEP 4A. Intake manifold temperature sensor struck in-range. | Sensor reading within +/- 10°C [18°F]?
STEP 5. | EGR valve stuck open. |
 | STEP 5A. EGR valve stuck open. | EGR Valve Actuator Test failed?
STEP 6. | Fan clutch operates incorrectly. |
 | STEP 6A. Fan clutch operates incorrectly. | Fan engages at the correct engine temperature?
STEP 7. | Thermostat is malfunctioning. |
 | STEP 7A. Thermostat is malfunctioning. | Damage noted or thermostat does not open at the correct temperature?
 | STEP 7B. Out-of-chassis opening temperature test. | Damage noted or thermostat does not open at the correct temperature?
STEP 8. | Leaks in the intake air system. |
 | STEP 8A. Leaks in the intake air system. | Component leaking?
STEP 9. | Charge air cooler system leak. |
 | STEP 9A. Charge air cooler system leak. | Leaks found?
STEP 10. | Turbocharger is malfunctioning. |
 | STEP 10A. Turbocharger is malfunctioning. | Checks in specification?
STEP 11. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 11A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 11B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Cooling fan component inspection.

Guided Step 1A - Cooling fan component inspection.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the following components if applicable:

  • Visually inspect the cooling fan and cooling fan blades.
  • Visually inspect the cooling fan shroud.
  • Visually inspect the recirculation baffles.
  • Inspect the cooling fan belt. Refer to Procedure 008-002 in the Associated Procedures Table.
  • Visually inspect the cooling fan hub assembly.
  • Visually inspect the automatic cooling fan belt tensioner

Damage found?
YES NO

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust, repair, or replace the component preventing correct cooling fan operation. Refer to OEM Service Manual.
 No Repair

Go to 11A

Go to 2A

Guided Step 2 - High intake manifold temperature basic checks.

Guided Step 2A - High intake manifold temperature basic checks.

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the air filter to make sure it is not plugged. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Inspect the charge-air cooler for damage or debris blocking the air flow. Refer to Procedure 010-027 in the Associated Procedures Table.
  • Inspect the air conditioner condenser. Refer to OEM Service Manual.
  • Visually inspect the radiator fins for damage or debris blocking the air flow.

Damage found?
YES NO

Repair

Repair or replace the malfunctioning components.

 No Repair

Go to 11A

Go to 3A

Guided Step 3 - Radiator is externally obstructed.

Guided Step 3A - Radiator is externally obstructed.

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the radiator for damage.
  • Visually inspect the radiator for any type of external obstruction.
  • Check for closed cold weather radiator cover or winterfront.

Damage found?
YES NO

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the restricted radiator. Refer to OEM Service Manual.
  • Remove the obstruction. Refer to OEM Service Manual.
  • Repair or replace cold weather radiator cover or winterfront. Refer to OEM Service Manual.
 No Repair

Go to 11A

Go to 4A

Guided Step 4 - Intake manifold temperature sensor stuck in-range.

Guided Step 4A - Intake manifold temperature sensor stuck in-range.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the intake manifold temperature sensor reading to an infrared thermometer or a known value.

Sensor reading within +/- 10°C [18°F]?

YES NO

Repair

Repair or replace only the components that were found to be out of specification.

Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in the Associated Procedures Table.

 No Repair

Go to 11A

Go to 5A

Guided Step 5 - EGR valve stuck open.

Guided Step 5A - EGR valve stuck open.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the EGR Valve Actuator Test.

EGR Valve Actuator Test failed?

YES NO

Repair

Clean or replace the EGR valve. Refer to Procedure 011-022 in the Associated Procedures Table.

 No Repair

Go to 11A

Go to 6A

Guided Step 6 - Fan clutch operates incorrectly.

Guided Step 6A - Fan clutch operates incorrectly.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.

Ensure the following adjustable parameters are set correctly for the application:

  • Fan Control Logic.
  • Fan Control Switch.
  • Air Conditioner Pressure Switch Input.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Fan Override Test.
  • Verify that the fan operates correctly.
  • Verify the fan is engaging at the correct engine temperature. Refer to Procedure 008-027 in the Associated Procedures Table. Refer to OEM Service Manual.

Fan engages at the correct engine temperature?

YES NO
No Repair

Repair

  • Adjust, repair, or replace the component preventing correct cooling fan operation. Refer to Procedure 008-027 in the Associated Procedures Table. Refer to OEM Service Manual.

Go to 7A

Go to 11A

Guided Step 7 - Thermostat is malfunctioning.

Guided Step 7A - Thermostat is malfunctioning.

Conditions

  • Engine running.

Action

  • Allow the engine to reach operating temperature.
  • Check the thermostat opening temperature with an infrared temperature gun.
  • Check the coolant thermostat for proper operation. Refer to Procedure 008-013 in the Associated Procedures Table.
  • Check for a damaged or leaking thermostat seal. Refer to Procedure 008-013 in the Associated Procedures Table.
  • If a temperature gun is not available or if the temperature gun reading is above the correct thermostat opening temperature, then proceed to Linked Solutions section.

Damage noted or thermostat does not open at the correct temperature?

YES NO

Repair

  • Replace the engine coolant thermostat. Refer to Procedure 008-013 in the Associated Procedures Table.
 No Repair

Go to 11A

Go to 7B

Guided Step 7B - Out-of-chassis opening temperature test.

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the out-of-chassis opening temperature test. Refer to Procedure 008-013 in the Associated Procedures Table.

Damage noted or thermostat does not open at the correct temperature?

YES NO

Repair

Replace the engine coolant thermostat. Refer to Procedure 008-013 in the Associated Procedures Table.

 No Repair

Go to 11A

Go to 8A

Guided Step 8 - Leaks in the intake air system.

Guided Step 8A - Leaks in the intake air system.

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the air intake system for leaks.
  • Visually inspect the intake plumbing for possible air leaks.

Component leaking?

YES NO

Repair

  • Repair or replace the leaking components. Refer to OEM Service Manual.
 No Repair

Go to 11A

Go to 9A

Guided Step 9 - Charge air cooler system leak.

Guided Step 9A - Charge air cooler system leak.

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the charge air cooler hoses for possible air leaks.
  • Pressure test the charge air cooler to check for leaks. Refer to Procedure 010-027 in the Associated Procedures Table.

Leak found?

YES NO

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the charge air cooler. Refer to Procedure 010-027 in the Associated Procedures Table.
  • Repair or replace the charge air cooler hoses. Refer to OEM Service Manual.
 No Repair

Go to 11A

Go to 10A

Guided Step 10 - Turbocharger is malfunctioning.

Guided Step 10A - Turbocharger is malfunctioning.

Conditions

  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

  • Inspect the exhaust and intake plumbing for signs of lubricating oil contamination. Refer to Procedure 010-033 in the Associated Procedures Table.
  • Inspect the compressor wheel retaining nut for signs of dust ingestion. Refer to Procedure 010-033 in the Associated Procedures Table.
  • Inspect the turbocharger compressor and turbine blades for damage or wear. Refer to Procedure 010-033 in the Associated Procedures Table.

Checks in specification?
YES NO
No Repair

Repair

  • Replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

Go to 11A

Go to 11A

Guided Step 11 - Check ECM calibration and clear fault codes.

Guided Step 11A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Cummins electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use Cummins electronic service tool or equivalent to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 11B

Go to 11B

Guided Step 11B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Cummins electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?

YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 26-Apr-2022


FAULT CODE 187 (ISB/QSB Automotive and Industrial, ISC/QSC/ISL/QSL Automotive, Industrial, and Marine) Sensor Supply Voltage Number 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead; Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead; Part Number 3164596 - male Framatome test lead and Part Number 3164597 - female Framatome test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 187 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply number 2 and return. |
 | STEP 2A. Inspect the camshaft engine position sensor and circuit connected to the sensor supply number 2 and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the intake manifold pressure sensor and circuit connected to the sensor supply number 2 and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Check orientation of sensor connection | Is the sensor correctly installed?
 | STEP 2C-1. Inspect the rail fuel pressure sensor and circuit connected to the sensor supply number 2 and return. |
 | STEP 2C-2. Check the circuit response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 187 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 187 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply number 2 and return.

Guided Step 2A - Inspect the camshaft engine position sensor and circuit connected to the sensor supply number 2 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft engine position sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection had been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3822510.

Install the appropriate connector seal if it is damaged or missing.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the camshaft engine position sensor. Refer to Procedure 019-364 in Section 19.
No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft engine position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Repair

Replace the camshaft engine position sensor. Refer to Procedure 019-063 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the intake manifold pressure sensor and circuit connected to the sensor supply number 2 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection had been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3822510.

Install the appropriate connector seal if it is damaged or missing.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.
No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Repair

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check orientation of connector.

Conditions

  • Turn keyswitch OFF.

Action

Check for the appropriate orientation of rail fuel pressure sensor connector.

  • Note: The connector can be installed incorrectly rotated 180 degrees.

Is the sensor correctly installed?
YES NO
No Repair

Repair

Reorient connector.

Go to 2C-1

Go to 4A

Guided Step 2C-1 - Inspect the rail fuel pressure sensor and circuit connected to the sensor supply number 2 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection had been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3822510.

Install the appropriate connector seal if it is damaged or missing.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in Section 19.
No Repair

Go to 4A

Go to 2C-2

Guided Step 2C-2 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Repair

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram fro connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection had been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, or replace the sensor, whichever has the damaged pins.

Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3822510.

Install the appropriate connector seal if it is damaged or missing.

  • Repair the harness. Refer to Procedure 019-203 in Section 19.
  • Replace the harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 187 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


FAULT CODE 187 (QSB Marine Application) Sensor Supply 2 Circuit - Voltage Below Normal, or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3164596 - male Framatome™ test lead, and Part Number 3164597 - female Framatome™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 187 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply number 2 and return. |
 | STEP 2A. Inspect the rail fuel pressure sensor and circuit connected to the sensor supply number 2 and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 187 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 187 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply number 2 and return.

Guided Step 2A - Inspect the intake manifold pressure sensor and circuit connected to the sensor supply number 2 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Repair

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the rail fuel pressure sensor and circuit connected to the sensor supply number 2 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Repair

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 187 inactive?
YES NO
No Repair

Repair

Return to the ttroubleshooting steps or contact a local Cummins® Authorized Repair Location of all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


FAULT CODE 195 - Two Wire Sensor - Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 195 active?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and connector and pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Greater than 800k ohms?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin to pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 195 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and engine coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine coolant level SIGNAL pin and the engine coolant level RETURN pin at the engine coolant level sensor connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 800k ohms?
YES NO

Repair

Replace the engine coolant level sensor. Refer to Procedure 019-017 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor RETURN pin and the OEM harness engine coolant level sensor connector RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open RETURN circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SIGNAL pin and the engine coolant level sensor connector SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SIGNAL circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness form the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant level SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 195 inactive?
YES NO
No Repair

Repair

Return to the appropriate steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


FAULT CODE 195 - Three Wire Sensor - Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response | Fault Code 195 active and Fault Code 195 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 195 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 195 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 386

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and engine coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active and Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor RETURN pin at the engine coolant level sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the engine coolant level sensor. Refer to Procedure 019-017 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor RETURN pin and the OEM harness engine coolant level sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open RETURN circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness form the ECM connector.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SUPPLY pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SUPPLY line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 195 inactive?
YES NO
No Repair

Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


FAULT CODE 196 - Two Wire Sensor - Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 196 active?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 195 active and Fault Code 196 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 196 is active?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 196 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an appropriate ECM response after 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active and Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant level sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 is active?
YES NO

Repair

A damaged engine coolant level sensor has been detected.

Replace the engine coolant level sensor. Refer to Procedure 019-017 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance and check for a short circuit between the engine coolant level SIGNAL pin at the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit between pins has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin short to ground.

  • Measure the resistance and check for a short circuit between the engine coolant level sensor SIGNAL pin at the OEM harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after one minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool, verify that the fault code is inactive.

Fault Code 196 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 13-Mar-2012


FAULT CODE 196 - Three Wire Sensor - Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead and Part Number 3164133 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response | Fault Code 195 active and Fault Code 196 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 196 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit. | Greater than 100k ohms.
 | STEP 3F. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 196 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 352

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and engine coolant level sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine coolant level SUPPLY pin and the engine coolant level RETURN pin at the engine coolant level sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor SIGNAL pin at the engine coolant level sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 195 active and Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the engine coolant level sensor. Refer to Procedure 019-017 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SUPPLY pin and the OEM harness engine coolant level sensor connector SUPPLY pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SUPPLY circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SIGNAL pin and the OEM harness engine coolant level sensor connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

Repair

An open SIGNAL circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted SIGNAL circuit to ground.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 196 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 13-Mar-2012


FAULT CODE 197 - Coolant Level - Data Valid but Below Normal Operational Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 197. | Active or inactive counts of Fault Code 197?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 197.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ the electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ the electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 197?
YES NO

Repair

Add coolant to the engine.

  • Use the following procedure in the ISC, QSC8.3, ISL, and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418 or the ISBe and ISB (Common Rail Fuel System) Series Engines, Bulletin 4021271. Refer to Procedure 008-018 in Section 8.

If Fault Code 197 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. Refer to the OEM service manual before replacing the coolant level sensor.

No Repair

Repair complete.

Repair complete

Last Modified: 13-Mar-2012


FAULT CODE 221 - Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 221 inactive?
STEP 2. | Check the barometric pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 222 active and Fault Code 221 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 221 active?
STEP 3. | Check the engine control module and engine harness. |
 | STEP 3A. Inspect engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the engine control module response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 221 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 386

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the barometric pressure sensor and circuit.

Guided Step 2A - Inspect the barometric pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the barometric pressure sensor from the engine harness.

Action

Inspect the engine harness and barometric pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the barometric pressure sensor from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the barometric pressure sensor from the engine harness
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure +5 volt SUPPLY pin to the barometric pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the barometric pressure sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the barometric air pressure sensor. Refer to Procedure 019-004 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module and engine harness.

Guided Step 3A - Inspect engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

  • Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the engine control module response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

  • Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the engine control module engine connector
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure +5 volt SUPPLY pin to the barometric pressure RETURN pin at the engine control module engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 221 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


FAULT CODE 222 - Barometric Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 222 inactive?
STEP 2. | Check the barometric pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 221 active and Fault Code 222 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 222 active?
STEP 3. | Check the engine control module and engine harness. |
 | STEP 3A. Inspect engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the engine control module response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 222 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 352

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the barometric pressure sensor and circuit.

Guided Step 2A - Inspect the barometric pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.

Action

Inspect the engine harness and barometric pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure +5 volt SUPPLY pin to the barometric pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the barometric pressure +5 volt SUPPLY pin and the barometric pressure SIGNAL pin at the barometric pressure sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active and Fault Code 222 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the barometric pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the barometric pressure sensor. Refer to Procedure 019-004 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module and engine harness.

Guided Step 3A - Inspect engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure +5 volt SUPPLY pin to the barometric pressure RETURN pin at the engine control module engine connector.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open or shorted SUPPLY circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the engine control module response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the barometric pressure +5 volt SUPPLY pin and the barometric pressure SIGNAL pin at the engine control module engine connector.

Refer to the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active and Fault Code 222 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open RETURN or a pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 222 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


FAULT CODE 227 (ISB/QSB Automotive and Industrial, ISC/QSC/ISL/QSL Automotive, Industrial, and Marine) - Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 227 active?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 227 active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 227 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broke
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 227 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 14-Mar-2012


FAULT CODE 227 (QSB Marine Application) - Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 227 active?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 227 active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 227 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broke
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 227 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 14-Mar-2012


FAULT CODE 234 (ISB/QSB Automotive and Industrial, ISC/QSC/ISL/QSL Automotive, Industrial and Marine) - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

WARNING

DO NOT OPERATE A DIESEL ENGINE WHERE THERE ARE OR CAN BE COMBUSTIBLE VAPORS. These vapors can be sucked through the air intake system and cause engine acceleration and overspeeding that can result in a fire, an explosion, and extensive property damage. Numerous safety devices are available, such as air intake shutoff devices, to minimize the risk of overspeeding where an engine, due to its application, might operate in a combustible environment, such as due to a fuel spill or gas leak. Remember, Cummins has no way of knowing the use you have for your engine. THE EQUIPMENT OWNER AND OPERATOR ARE RESPONSIBLE FOR SAFE OPERATION IN A HOSTILE ENVIRONMENT. CONSULT YOUR CUMMINS AUTHORIZED REPAIR LOCATION FOR FURTHER INFORMATION.
CAUTION

If the engine speed stays above 3500 rpm, the engine must be shut off immediately or engine damage can occur.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for an alternate fuel source. | Alternate fuel source?
 | STEP 1B. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 1C. Inspect the OEM harness and vehicle speed sensor connector pins. | Dirty or damaged pins?
 | STEP 1D. Check for an active fault at low engine rpm. | Inactive fault code at low rpm?
 | STEP 1E. Test the vehicle. | Fault Code 234 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 234 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if the driver reported a fuel-controlled event where the engine rapidly accelerated to or past 3400 rpm, followed by moderate deceleration to 3400 rpm.

Alternate fuel source?
YES NO

Repair

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Engine is running.

Action

Check the engine rpm with INSITE™ electronic service tool.

NOTE: Compare the engine speed reading on INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.

Correct rpm reading?
YES NO
No Repair

Repair

Inspect the crankshaft engine speed sensor and camshaft engine position sensor as outlined in Fault Code 689 and 778.

Go to 1C

Fault Code 689 and 778

Guided Step 1C - Inspect the OEM harness and vehicle speed sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 2A

Go to 1D

Guided Step 1D - Check for an active fault at low engine rpm.

Conditions

  • Turn keyswitch ON.

Action

Check for active Fault Code 234 when the engine is not running above 3200 rpm.

Inactive fault code at low rpm?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1E

Go to 2A

Guided Step 1E - Test the vehicle.

Conditions

  • Turn keyswitch ON.

Action

Test the vehicle in a road test or sea trail to check if the overspeed condition is still present.

–

Fault Code 234 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Using INSITE™ electronic service tool, verify that the fault code is inactive.

Fault Code 234 inactive?
YES | NO
No Repair | No Repair

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 14-Mar-2012


FAULT CODE 234 (QSB Marine Application) - Engine Crankshaft Speed/Position - Data Valid but Above Normal Operational Range - Most Severe Level

Associated Procedures

Cautions and Warnings

WARNING

DO NOT OPERATE A DIESEL ENGINE WHERE THERE ARE OR CAN BE COMBUSTIBLE VAPORS. These vapors can be sucked through the air intake system and cause engine acceleration and overspeeding that can result in a fire, an explosion, and extensive property damage. Numerous safety devices are available, such as air intake shutoff devices, to minimize the risk of overspeeding where an engine, due to its application, might operate in a combustible environment, such as due to a fuel spill or gas leak. Remember, Cummins has no way of knowing the use you have for your engine. THE EQUIPMENT OWNER AND OPERATOR ARE RESPONSIBLE FOR SAFE OPERATION IN A HOSTILE ENVIRONMENT. CONSULT YOUR CUMMINS AUTHORIZED REPAIR LOCATION FOR FURTHER INFORMATION.
CAUTION

If the engine speed stays above 3500 rpm, the engine must be shut off immediately or engine damage can occur.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for proper operating conditions. | Engine motoring downhill?
 | STEP 1B. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 1C. Inspect the OEM harness and vehicle speed sensor connector pins. | Dirty or damaged pins?
 | STEP 1D. Check for an active fault at low engine rpm. | Inactive fault code at low rpm?
 | STEP 1E. Test the vehicle. | Fault Code 234 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 234 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if the driver reported a fuel-controlled event where the engine rapidly accelerated to or past 3400 rpm, followed by moderate deceleration to 3400 rpm.

Alternate fuel source?
YES NO

Repair

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Engine is running.

Action

Check the engine rpm with INSITE™ electronic service tool.

NOTE: Compare the engine speed reading on INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.

Correct rpm reading?
YES NO
No Repair

Repair

Inspect the crankshaft engine speed sensor and camshaft engine position sensor as outlined in Fault Codes 689 and 778.

Go to 1C

Fault Codes 689 and 778

Guided Step 1C - Inspect the OEM harness and vehicle speed sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 2A

Go to 1D

Guided Step 1D - Check for an active fault at low engine rpm.

Conditions

  • Turn keyswitch ON.

Action

Check for active Fault Code 234 when the engine is not running above 3200 rpm.

Inactive fault code at low rpm?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1E

Go to 2A

Guided Step 1E - Test the vehicle.

Conditions

  • Turn keyswitch ON.

Action

Test the vehicle in a sea trail to check if the overspeed condition is still present.

–

Fault Code 234 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Using INSITE™ electronic service tool, verify that the fault code is inactive.

Fault Code 234 inactive?
YES | NO
No Repair | No Repair

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 14-Mar-2012


Coolant Level Low - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 235. | Active or inactive counts of Fault Code 235?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 235.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool, to read the fault codes.

Active or inactive counts of Fault Code 235?
YES NO

Repair

Add coolant to the engine.

Use the following procedure in Troubleshooting and Repair Manual, ISC, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 008-018 in Section 8.

Use the following procedure for Troubleshooting and Repair Manual, ISBe and ISB (Common Rail Fuel System) Series Engines, Bulletin 4021271. Refer to Procedure 008-018 in Section 8.

If Fault Code 235 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. Refer to the OEM service manual before replacing the coolant level sensor.

No Repair

Repair complete

Repair complete

Last Modified: 17-Oct-2011


FAULT CODE 237 - External Speed Command Input (Multiple Unit Synchronication) - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Determine the engine configuration. |
 | STEP 1A. Check the engine configuration. | All engines configured correctly as either primary or secondary?
STEP 2. | Check the J1939 datalink harness. |
 | STEP 2A. Inspect the J1939 datalink harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open or short circuit in the J1939 datalink harness. | Resistance between 50 and 70 ohms?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin to pin short circuit in the OEM harness. | Greater then 100K ohms?
 | STEP 3C. Check for a short circuit to ground in the OEM harness. | Greater than 100K ohms for inactive pins and less than 10 ohms for active pins?
 | STEP 3D. Check for an open or short circuit in the ECM J1939 datalink harness. | Resistance between 50 to 70 ohms?
 | STEP 3E. Check for a short circuit in the ECM J1939 datalink harness. | Greater than 100K ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 237 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code | Fault Code 237 inactive?
 | STEP 4B. Clear the inactive fault code | All faults cleared?

Guided Step 1 - Determine the engine configuration.

Guided Step 1A - Check the engine configuration.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool, to determine if all engines are configured correctly as either primary or secondary engines.

  • Use INSITE™ electronic service tool to monitor parameters for Multi-Unit Synchronization to determine the engine configuration.

All engine configured correctly as either primary or secondary?
YES NO
No Repair

Repair

Check the Mult-Unit Synchronization switch configuration for correct setup.

Go to 2A

Go to 4A

Guided Step 2 - Check the J1939 datalink harness.

Guided Step 2A - Inspect the J1939 datalink harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the J1939 datalink interconnect between the primary and secondary ECM's.

Action

Inspect the J1939 data link connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damaged
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Dirt or debris in or on the connector pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the J1939 data link harness..

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open or short circuit in the J1939 datalink harness

Conditions

  • Turn keyswitch OFF.
  • Disconnect the J1939 interconnect between the primary and secondary ECM's

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 Datalink (+) wire and the SAE J1939 Datalink (-) wire on the service datalink connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 50 to 70 ohms?
YES NO
No Repair

Repair

An open or short has been detected on the service datalink connector or harness connection to the J1939 datalink backbone.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary engine OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damaged
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Dirt or debris in or on the connector pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary engine OEM harness from the ECM.

Action

Check for a pin to pin short.

  • Measure the resistance between the Multi-Unit Synchronization ID Pin 1 in the OEM ECM connector and all other pins in the OEM connector.
  • Measure the resistance between the Multi-Unit Synchronization ID Pin 2 in the OEM ECM connector and all other pins in the OEM connector.
  • Measure the resistance between the Multi-Unit Synchronization ID Pin 3 in the OEM ECM connector and all other pins in the OEM connector.
  • Measure the resistance between the Multi-Unit Synchronization ON/OFF pin in the OEM ECM connector and all other pins in the OEM connector. NOTE: The Multi-Unit Synchronization switch must be in the OFF position for this check.
  • Measure the resistance between the Multi-Unit Synchronization ON/OFF Complimentary pin in the OEM ECM connector and all other pins in the OEM connector. Note: The Multi-Unit Synchronization switch must be in the ON position for this check.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary engine OEM harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the Multi-Unit Synchronization ID Pin 1 in the OEM ECM connector and ground.
  • Measure the resistance between the Multi-Unit Synchronization ID Pin 2 in the OEM ECM connector and ground.
  • Measure the resistance between the Multi-Unit Synchronization ID Pin 3 in the OEM ECM connector and ground.
  • Measure the resistance between the Multi-Unit Synchronization ON/OFF Complimentary pin in the OEM ECM connector and ground.

NOTE: Determine the location of Multi-Unit Synchronization switch before performing these steps. Pins in this check will either be shorted or open depending on the configuration of the Multi-Unit Synchronization switch.

Refer to circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms for inactive pins and less than 10 ohms for active pins?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open or short circuit in the ECM J1939 datalink harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the primary and secondary ECM's.

Action

Check for an open or short curcuit.

  • Measure the resistance between the SAE J1939 Data Link (+) wire and the SAE J1939 Data Link (-) wire on the appropriate Cummins ECM OEM connection to the J1939 datalink harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 50 and 70 ohms?
YES NO
No Repair

Repair

An open or short has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit in the ECM J1939 datalink harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the primary and secondary ECM's.

Action

Check for a short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 Data Link (+) wire and the SAE J1939 Data Link (-) wire on the appropriate Cummins ECM OEM connection to the J1939 datalink harness connector.

NOTE: Disregard any resistance between 50 and 70 ohms between the SAE J1939 Data Link (-) pins.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A short has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool, to check the fault codes.

Fault Code 237 inactive?
YES NO

Repair

None. The removal and reinstallation of the connector corrected the fault.

Repair

A communication issue between the primary and secondary ECM's had been detected or a damaged ECM or calibration is causing the fault code.

Go to 4A

Refer to the appropriate ECM No Communication symptom tree.

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool, to verify that the fault code is inactive.

Fault Code 237 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool, erase the inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 14-Mar-2012


FAULT CODE 238 - Sensor Supply 3 Circuit - Voltage Below Normal, or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 238 active?
STEP 2. | Check the engine speed sensor and circuit. |
 | STEP 2A. Inspect the engine speed sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 238 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 238 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 238 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine speed sensor and circuit.

Guided Step 2A - Inspect the engine speed sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO
No Repair

Repair

The engine speed sensor is internally shorted.

Replace the engine speed sensor. Refer to Procedure 019-365 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

The engine speed sensor SUPPLY line has shorted to ground or a return wire.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 238 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


FAULT CODE 241 - Vehicle Speed Sensor Circuit - Data Erratic, Intermittent or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possiblity of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead and Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the vehicle speed sensor setting in INSITE™ electronic service tool. |
 | STEP 1A. Verify that the vehicle speed sensor and the setting in INSITE™ electronic service tool match. | The setting in INSITE™ electronic service tool matches the speed sensor type on the vehicle?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness pins and the sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the OEM harness connector pins at the ECM. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit to ground in the OEM harness. | More than 100k ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the OEM harness. | More than 100k ohms?
STEP 3. | Check for additional OEM devices. |
 | STEP 3A. Check the vehicle speed sensor circuit for additional devices. | Extra devices?
 | STEP 3B. Check for the gear slipping on the shaft. | Gear or tone wheel damaged or slips?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 241 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the vehicle speed sensor setting in INSITE™.

Guided Step 1A - Verify that the vehicle speed sensor and the setting in INSITE™ match.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool, go to the Vehicle Speed Source feature under Adjustments, Features and Parameters.

  • Verify that the vehicle speed sensor type parameter in INSITE™ electronic service tool matches the physical sensor type on the vehicle.

The setting in INSITE™ electronic service tool matches the speed sensor type on the vehicle?
YES NO
No Repair

Repair

Change the setting in the ECM with INSITE™ electronic service tool to match the vehicle speed sensor type.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness pins and the sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the OEM harness connector pins at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Use a multimeter, check for an open circuit in the OEM harness.

  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (+) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.
  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (-) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for a short circuit to ground on the magnetic vehicle speed sensor SIGNAL (+) and magnetic vehicle speed sensor SIGNAL (-) circuit in the OEM harness.

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) at the ECM connector to engine block ground.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) at the ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Use a multimeter, check for a pin-to-pin short circuit in the OEM harness.

  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (+) pin at the OEM harness ECM connector and all other pins in the connector.
  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (-) pin at the OEM harness ECM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check for additional OEM devices.

Guided Step 3A - Check the vehicle speed sensor circuit for additional devices.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the vehicle speed sensor circuit for any additional or extra devices that can interfere with the speed signal.

–

Extra devices?
YES NO

Repair

Remove the device or contact an OEM representative.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for the gear slipping on the shaft.

Conditions

  • Turn keyswitch OFF.
  • Remove the vehicle speed sensor from the transmission.

Action

Inspect the gear or tone wheel on the rear of the transmission where the speed sensor picks up the speed signal. Make sure the gear or tone wheel is not damaged or slipping on the shaft.

–

Gear or tone wheel damaged or slips?
YES NO

Repair

Refer to the OEM service manual to repair or replace the gear or tone wheel.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and move the vehicle so that the ECM can read a vehicle speed.
  • Use INSITE™ electronic service tool to verify that Fault Code 241 is inactive.

Fault Code 241 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location or OEM dealer if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 14-Mar-2012


FAULT CODE 242 - Vehicle Speed Sensor Circuit Tampering Has Been Detected - Abnormal Rate of Change

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead and Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify that the feature settings are correct. |
 | STEP 1A. Verify that the customer wants Vehicle Speed Anti-Tampering (Fault Code 242) enabled. | Customer wants Vehicle Speed Sensor Anti-Tampering enabled?
 | STEP 1B. Verify that the vehicle speed sensor and the setting in INSITE™ electronic service tool match. | The setting in INSITE™ electronic service tool matches the speed sensor type on the vehicle?
 | STEP 1C. Verify that the Anti-Tampering Sensitivity Level is set correctly for the application. | Sensitivity Level is set correctly?
STEP 2. | Look for signs or evidence of tampering. |
 | STEP 2A. Inspect the vehicle speed sensor. | Tampering, installed incorrectly or external device present?
 | STEP 2B. Check for open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 2C. Check for short circuit to ground in the OEM harness. | More than 100k ohms?
 | STEP 2D. Check for a pin-to-pin short circuit in the OEM harness. | More than 100k ohms?
STEP 3. | Check the vehicle speed reporting. |
 | STEP 3A. Use INSITE™ electronic service tool to monitor the vehicle speed signal. | INSITE™ electronic service tool readout and the vehicle speedometer match?
 | STEP 3B. Verify the vehicle speed. | Vehicle speed is accurate?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault codes. | Fault Code 242 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Verify that the feature settings are correct.

Guided Step 1A - Verify that the customer wants Vehicle Speed Anti-Tampering (Fault Code 242) enabled.

Action

Verify that the customer wants Vehicle Speed Sensor Anti-Tampering feature enabled.

–

Customer wants Vehicle Speed Sensor Anti-Tampering enabled?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool, disable the Vehicle Speed Sensor Anti-Tampering feature.

Go to 1B

Go to 4A

Guided Step 1B - Verify that the vehicle speed sensor and the setting in INSITE™ electronic service tool match.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool, go to the Vehicle Speed Source feature under Adjustments, Features and Parameters.

  • Verify that the Vehicle Speed Sensor Type parameter setting in INSITE™ electronic service tool matches the physical sensor type on the vehicle.

The setting in INSITE™ electronic service tool matches the speed sensor type on the vehicle?
YES NO
No Repair

Repair

Change the setting in the ECM with INSITE™ electronic service tool to match the vehicle speed sensor type.

Go to 1C

Go to 4A

Guided Step 1C - Verify that the Anti-Tampering Sensitivity Level is set correctly for the application.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify that the Vehicle Speed Signal Tampering Sensitivity Level is set correctly for the application.

  • Use INSITE™ electronic service tool go to the Vehicle Speed Source feature under Adjustments, Features and Parameters.
  • Check the ECM setting for Vehicle Speed Signal Tampering Sensitivity Level.

Sensitivity Level is set correctly?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool to set the Vehicle Speed Signal Tampering Sensitivity Level to the correct value for the vehicle.

Go to 2A

Go to 4A

Guided Step 2 - Look for signs or evidence of tampering.

Guided Step 2A - Inspect the vehicle speed sensor.

Action

Inspect the vehicle speed sensor for the following:

  • Improper mounting of the vehicle speed sensor
  • Vehicle speed sensor improperly connected to the OEM harness
  • Other external device connected in place of the vehicle speed sensor
  • Any evidence that tampering with the vehicle speed sensor has taken place.

Tampering, installed incorrectly, or external device present?
YES NO

Repair

Remove the tampering device.

Install the sensor correctly or remove the external device.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Using a multimeter, check for an open circuit in the OEM harness.

  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (+) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.
  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (-) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for a short circuit to ground on the magnetic vehicle speed sensor SIGNAL (+) and magnetic vehicle speed sensor SIGNAL (-) circuit in the OEM harness.

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) pin at the ECM connector to engine block ground.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) pin at the ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Using a multimeter, check for a pin-to-pin short circuit in the OEM harness.

  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (+) pin at the OEM harness ECM connector and all other pins in the connector.
  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (-) pin at the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the vehicle speed reporting.

Guided Step 3A - Use INSITE™ electronic service tool to monitor the vehicle speed signal.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to check the vehicle speed.

  • Verify that the vehicle speed is 0 when the vehicle is stationary and the engine is running.
  • Drive the vehicle or run on a chassis dynamometer. Compare the vehicle speed read by INSITE™ electronic service tool to the speedometer on the dash.

INSITE™ electronic service tool readout and the vehicle speedometer match?
YES NO
No Repair

Repair

Verify that the Tire Size, Rear Axle Ratio, and Tailshaft Gear Teeth parameters are set correct in the ECM.

Go to 3B

Go to 4A

Guided Step 3B - Verify the vehicle speed.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Vehicle moving.

Action

Use INSITE™ electronic service tool to verify that the speed reported is accurate or reasonable for the current gear.

  • (For example: 64 km/h [40 mph] in top gear is probably inaccurate data)

Vehicle speed is accurate?
YES NO
No Repair

Repair

Verify that the Tire Size, Rear Axle Ratio, and Tailshaft Gear Teeth parameters are set correct in the ECM.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Engine not running.
  • Vehicle not moving.

Action

Disable the fault code.

  • With the keyswitch ON and the vehicle stationary, wait 1 minute.
  • Use INSITE™ electronic service tool, verify that Fault Code 242 is inactive.

Fault Code 242 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location or OEM dealer if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 14-Mar-2012


FAULT CODE 245 - Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 245 active?
STEP 2. | Check the fan control solenoid and circuit. |
 | STEP 2A. Inspect the fan control solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an internal short in the fan control solenoid. | Within the OEM resistance specification?
 | STEP 2B-1. Check for a pin-to-ground short circuit in the fan control solenoid. |
 | STEP 2C. Check the fan control solenoid diagnostic supply voltage and supply line. | Greater than +5-VDC?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 245 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 245 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 245 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fan control solenoid and circuit.

Guided Step 2A - Inspect the fan control solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the solenoid or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an internal short in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for low internal resistance of the fan control solenoid.

  • Use a multimeter, measure the resistance between the SIGNAL and RETURN pin of the fan control solenoid connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to the OEM service manual for resistance specifications.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Within the OEM resistance specification?
YES NO
No Repair

Repair

Replace the fan control solenoid. Refer to the OEM service manual.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a pin-to-ground short circuit in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Short circuit on one connector pin-to-ground check:

Measure the resistance and check for a short circuit between the following fan control solenoid connector pin and ground:

  • Fan control SIGNAL connector pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the fan control solenoid. Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the fan control solenoid diagnostic supply voltage and supply line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.
  • Turn keyswitch ON.

Action

Measure the voltage between the fan control SIGNAL pin and the fan control RETURN pin at the OEM harness actuator connector.

Refer to the wiring diagram for connector pin identification.

Greater than +5-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire or insulation damage
  • Connector shell broken.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the solenoid or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Short circuit on one connector - pin-to-ground check:

  • Measure the resistance and check for a short circuit between the fan control SIGNAL pin of the OEM harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a short circuit on one connector pin-to-pin check:

  • Measure the resistance and check for a short circuit between the fan control SIGNAL pin of the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 245 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Start the engine and let it idle for 1 minute.
  • Turn the keyswitch OFF, shutdown the engine.
  • Connect the engine coolant temperature sensor to the engine harness.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 245 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to the appropriate troubleshooting steps

Last Modified: 14-May-2012


Engine Oil Level - Data Valid but Below Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes | Fault Code 253 active?
STEP 2. | Check the engine lubricating oil level. |
 | STEP 2A. Verify the engine lubricating oil level. | Engine lubricating oil level correct?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault codes. | Fault Code 253 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Verify engine oil temperature is near ambient temperature.
  • Make sure the vehicle is parked on level ground.

Action

Read the fault codes.

  • Use INSITE™ electronic service too to read the fault codes.

Fault Code 253 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the engine lubricating oil level.

Guided Step 2A - Verify the engine lubricating oil level.

Conditions

  • Turn keyswitch OFF.

Action

Verify the engine lubricating oil level using the oil dipstick.

Engine lubricating oil level correct?
YES NO

Repair

Replace the lubricating oil level sensor. Refer to Procedure 019-056 in Section 19.

Repair

Low engine lubricating oil level has been detected.

Add engine lubricating oil to the engine.

  • For ISB and QSB engines, use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 007-037 in Section 7.
  • For ISC, QSC, ISL, and QSL engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 007-037 in Section 7.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes

Guided Step 3A - Disable the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds, and then turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Determine if fault 253 is inactive.

Use INSITE™ electronic service tool to determine if Fault Code 253 is inactive.

Fault Code 253 inactive?
YES NO
No Repair

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 01-May-2012


FAULT CODE 268 - Injector Metering Rail 1 Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes. | Fault Code 451 or 452 active?
STEP 2. | Check the rail fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the rail fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 451 active?
 | STEP 2C. Check the circuit response. | Fault Code 452 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Clear the circuit response. | Fault Code 451 active?
 | STEP 3C. Clear the circuit response. | Fault Code 452 active?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 268 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the sensor circuit fault codes.

Guided Step 1A - Check for active Fault Codes 154 and 155.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool, to read the fault codes.

Fault Codes 451 or 452 is active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor circuit.

Guided Step 2A - Inspect the rail fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.

Action

Inspect the rail fuel pressure sensor and connector pins.

  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Wire insulation damaged.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Connector shell broken.
  • Dirt of debris in or on the connector pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use the INSITE™ electronic service tool, to read the fault codes.

Fault Code 451 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the rail fuel pressure signal pin and the rail fuel pressure return pin to the rail fuel pressure connector of the engine harness.

See the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 active?
YES NO

Repair

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Wire insulation damaged.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Connector shell broken.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropirate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Place a jumper wire between the rail fuel pressure SIGNAL pin and rail fuel pressure RETURN pin at the engine control module engine connector.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 active?
YES NO

Repair

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Diable the fault code.

  • Start the engine.
  • Operate the engine under light load for two minutes.
  • Use INSITE™ electronic service tool, to verify that the fault code is inactive.

Fault Code 268 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault code.

  • Use INSITE™ electronic service tool, to erase the inactive fault code.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 01-May-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 269 is active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault codes. | Fault code 269 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the immobilizer anti-theft device fault codes.

  • Using INSITE™ electronic service tool read the fault codes.

Fault Codes 269 active?
YES NO

Repair

The immobilizer anti-theft device has not been deactivated. The engine will not start until proper authorization has been activated.

Refer to OEM troubleshooting for immobilizer anti-theft device operation.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault codes

Conditions

  • Turn keyswitch OFF.
  • Wait 30 seconds, and then turn the keyswitch on.
  • Connect INSITE™ electronic service tool.

Action

Dertermine if fault code 269 is inactive.

  • Use INSITE™ electronic service tool to determine if fault code 269 is inactive?

Is fault code 269 inactive?
YES NO
No Repair

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Using INSITE™ electronic service tool, erase all inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Jul-2010


FAULT CODE 271 (ISB/QSB (Automotive and Industrial Application) - High Fuel Pressure Solenoid Valve Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - male Bosch® test lead; Part Number 3164111 - female Bosch® test lead; Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead and Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 271 active?
STEP 2. | Check the electronic fuel control actuator and circuit. |
 | STEP 2A. Inspect the electronic fuel control actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-ground short circuit in the electronic fuel control actuator. | Greater than 100k ohms?
 | STEP 2B-1. Check the ECM response. |
 | STEP 2B-2. Check the ECM response. |
 | STEP 2C. Check the electronic fuel control actuator diagnostic supply voltage and supply line. | Greater than 3.0 VDC?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM electronic fuel control actuator diagnostic supply voltage. | Greater than 3.0 VDC?
 | STEP 3C. Check for a pin short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 271 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 active?
YES | NO
No Repair | No Repair

Go to 2A

Inactive or Intermittent Fault Code, Refer to Procedure 019-362.

Guided Step 2 - Check the electronic fuel control actuator and circuit.

Guided Step 2A - Inspect the electronic fuel control actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic fuel control actuator from the engine harness.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broke
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a pin-to-ground short circuit in the electronic fuel control actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic fuel control actuator from the engine harness.

Action

Short circuit on one connector - pin-to-ground check:

  • Measure the resistance and check for a short circuit between the electronic fuel control actuator connector pin and ground:

Electronic fuel control actuator SIGNAL connector pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the high-pressure fuel pump. Use the following procedure in the ISBe and ISB (Common Rail Fuel System) Series Engines Troubleshooting and Repair Manual, Bulletin 4021271. Refer to Procedure 005-016 in Section 5.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic fuel control actuator from the engine harness.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check the ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 inactive and Fault Code 272 active?
YES | NO
No Repair | No Repair

Go to 2B-2

Go to 2C

Guided Step 2B-2 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Reconnect the electronic fuel control actuator to the engine harness.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check the ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.

If Fault Code 271 is active whenever the electronic fuel control actuator is connected, the electronic fuel control actuator has a short circuit.

Fault Code 271 active and Fault Code 272 inactive?
YES | NO
No Repair | No Repair

Go to 4A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2C - Check the electronic fuel control actuator diagnostic supply voltage and supply line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic fuel control actuator from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and supply line.

  • Measure the voltage between the electronic fuel control actuator SIGNAL pin and the Electronic fuel control actuator RETURN pin at the engine harness actuator connector.

Greater than 3.0 VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broke
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM electronic fuel control actuator diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the voltage between the electronic fuel control actuator SIGNAL pin at the engine harness connector ECM port and ground.

Greater than 3.0 VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the electronic fuel control actuator from the engine harness.

Action

Short circuit on one connector - pin-to-ground check:

  • Measure the resistance and check for a short circuit between the following engine harness ECM connector pin and ground:

Electronic fuel control actuator SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the electronic fuel control actuator from the engine harness.

Action

Short circuit on one connector - pin-to-pin check:

  • Measure the resistance and check for a short circuit between the following engine harness ECM connector pin and all other pins in the engine harness ECM connector:

electronic fuel control actuator SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to Resistance Measurements Using a Multimeter and Wiring Diagram, Refer to Procedure 019-360 .

Greater than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 inactive?
YES NO
No Repair

Repair

Refer to the troubleshooting steps or contact a local Cummins® Authorized Repair location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes .

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 14-Mar-2012


FAULT CODE 271 (ISC/QSC/ISL/QSL Automotive, Industrial, and Marine Application) High Fuel Pressure Solenoid Valve Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead and Part Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 271 active?
STEP 2. | Check the fuel pump actuator and circuit. |
 | STEP 2A. Inspect the fuel pump actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 272 is active and Fault Code 271 is inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 271 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 272 active and Fault Code 271 inactive
 | STEP 3C. Check for a pin short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 271 is inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 271 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel pump actuator and circuit.

Guided Step 2A - Inspect the fuel pump actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broke
  • Wire insulation damage
  • Damaged locking tab connector.

NOTE: Inspect the pigtail wire harness as well as the engine harness for wire insulation damage that can cause a short circuit.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 is active and Fault Code 271 is inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pump actuator to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 active?
YES NO

Repair

A damaged fuel pump actuator has been detected.

Replace the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broke
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool, to read the fault codes.

Fault Code 272 active and Fault Code 271 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the fuel pump actuator SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the fuel pump actuator SIGNAL pin in the engine harness ECM connector and ground.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool , to read the fault code.

Fault Code 271 is inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 inactive?
YES NO
No Repair

Repair

1A

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes .

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 14-Mar-2012


FAULT CODE 272 (ISB/QSB (Automotive and Industrial)) - High Fuel Pressure Solenoid Valve Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164110 - male Bosch® test lead, Part Number 3164111 - female Bosch® test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 272 active?
STEP 2. | Check the electronic fuel control actuator and circuit. |
 | STEP 2A. Inspect the electronic fuel control actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the electronic fuel control actuator. | Between 0.1 and 5 ohms?
 | STEP 2C. Check the electronic fuel control actuator diagnostic supply voltage and return circuit. | Greater than 3.0-VDC?
 | STEP 2D. Check for an open circuit in the electronic fuel control actuator return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM electronic fuel control actuator diagnostic supply voltage. | Greater than 3.0-VDC?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 272 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the electronic fuel control actuator and circuit.

Guided Step 2A - Inspect the electronic fuel control actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic fuel control actuator from the engine harness.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broke
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the electronic fuel control actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic fuel control actuator from the engine harness.

Action

Check the actuator continuity for a pin-to-pin open circuit:

  • Measure the resistance and check for an open circuit between the electronic fuel control actuator SIGNAL pin and the electronic fuel control actuator RETURN pin.

Reference the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 0.1 and 5 ohms?
YES NO
No Repair

Repair

Replace the high-pressure fuel pump.

Use the following procedure in the ISBe and ISB (Common Rail Fuel System) Series Engines Troubleshooting and Repair Manual, Bulletin 4021271. Refer to Procedure 005-016 in Section 5.

Go to 2C

Go to 4A

Guided Step 2C - Check the electronic fuel control actuator diagnostic supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic fuel control actuator from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the electronic fuel control actuator SIGNAL pin and the electronic fuel control actuator RETURN pin at the engine harness actuator connector.

Reference the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 3.0-VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 2D

Guided Step 2D - Check for an open circuit in the electronic fuel control actuator return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic fuel control actuator from the engine harness.

Action

Harness connector pin-to-ground continuity check:

  • Measure the resistance between the engine harness electronic fuel control actuator RETURN pin and ground.

Reference the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Clean the connector and pins.

Repair or replace the engine harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broke
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM electronic fuel control actuator diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the voltage between the electronic fuel control actuator SIGNAL pin at the engine harness connector ECM port and ground.

Reference the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 3.0-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the electronic fuel control actuator from the engine harness.

Action

Check the harness connector continuity for a pin-to-pin open circuit:

  • Measure the resistance between the electronic fuel control actuator SIGNAL pin at the ECM connector of the engine harness and the electronic fuel control actuator SIGNAL pin at the electronic fuel control actuator connector of the engine harness.

Reference the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the electronic fuel control actuator from the engine harness.

Action

Check for a pin-to-pin short circuit.

Measure the resistance and check for a short circuit between the following engine harness ECM connector pin and all other pins in the engine harness ECM connector:

  • Electronic fuel control actuator SIGNAL pin.

Reference the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes .

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 14-Mar-2012


FAULT CODE 272 (ISC/QSC/ISL/QSL Automotive, Industrial, and Marine) - High Fuel Pressure Solenoid Valve Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 272 active?
STEP 2. | Check the fuel pump actuator and circuit. |
 | STEP 2A. Inspect the fuel pump actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the fuel pump actuator. | Between 0.1 and 5 ohms?
 | STEP 2C. Check the fuel pump actuator diagnostic signal voltage and return circuit. | Greater than 3.0-VDC?
 | STEP 2D. Check for an open circuit in the fuel pump actuator return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM fuel pump actuator diagnostic signal voltage. | Greater than 3.0-VDC?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 272 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 272 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel pump actuator and circuit.

Guided Step 2A - Inspect the fuel pump actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the fuel pump actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Actuator continuity - pin-to-pin continuity check:

  • Measure the resistance and check for an open circuit between the fuel pump actuator SIGNAL pin and the fuel pump actuator RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedures for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 0.1 and 5 ohms?
YES NO
No Repair

Repair

Replace the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel pump actuator diagnostic signal voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.
  • Turn keyswitch ON.

Action

Check the signal voltage and return circuit.

  • Measure the voltage between the fuel pump actuator SIGNAL pin and the fuel pump actuator RETURN pin at the engine harness actuator connector.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedures for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 3.0-VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 2D

Guided Step 2D - Check for an open circuit in the fuel pump actuator return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness fuel pump actuator RETURN pin and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open pin-to-ground circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM fuel pump actuator diagnostic signal voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the signal voltage.

  • Measure the voltage from the fuel pump actuator SIGNAL pin to the fuel pump actuator RETURN pin at the ECM connector.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 3.0-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the fuel pump actuator SIGNAL pin at the ECM connector of the engine harness and the fuel pump actuator SIGNAL pin at the fuel pump actuator connector of the engine harness.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check the engine harness continuity for a pin-to-pin short circuit:

  • Measure the resistance between the fuel pump actuator SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 inactive?
YES NO

Repair

NOTE: The removal and installation of the connector corrected the failure.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 272 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 14-Mar-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 275 has reoccurred at least 1 time during engine operation?
STEP 2. | Check for air in fuel. |
 | STEP 2A. Check for air in fuel. | Air in fuel?
STEP 3. | Check the fuel pressure sensor connector. |
 | STEP 3A. Inspect the fuel pressure sensor connector and wiring connections. | Dirty or damaged pins?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 275 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ the electronic service tool.
  • Clear all inactive fault codes.
  • Operate the engine at the steady state loaded condition.

Action

Check for fault codes.

  • Use INSITE™ the electronic service tool to read the fault codes.

Fault Code 275 has reoccurred at least 1 time during engine operation?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check for air in fuel.

Guided Step 2A - Check for air in fuel.

Conditions

  • Install a Compuchek® fitting at the outlet of the pressure side fuel filter.
  • Start the engine and allow it to idle.
  • Connect a test hose at the fuel filter head and run into a bucket.

Action

Check for air in fuel as the engine idles.

Perform the air in fuel test. 006-003 in Troubleshooting and Repair Manual, ISC, QSC8.3, ISL, and QSL9 Series Engines, Bulletin 4021418.

Air in fuel?
YES NO

Repair

The suction side fuel lines, suction filter, or tank pick-up is allowing air to enter fuel supply.

Repair or replace the fuel lines, suction filter, or tank pick-up.

 No Repair

Go to 1A

Go to 3A

Guided Step 3 - Check the fuel pressure sensor connector.

Guided Step 3A - Inspect the fuel pressure sensor connector and wiring connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel pressure sensor connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

For general inspection techniques, refer to Component Connector and Pin Inspection, Refer to Procedure 019-361.

Refer to the wiring diagram for connector pin identification.

NOTE: A bad connection on the fuel pressure sensor or intermittent wiring connections can cause the signal reading to fluctuate and cause this fault code to become active on an intermittent basis.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Repair

Replace the fuel pump head. Refer to Procedure 005-227 in Troubleshooting and Repair Manual, ISC, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ the electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Operate the engine at a steady-state loaded condition.
  • Use INSITE™ the electronic service tool to verify the fault code is inactive.

Fault Code 275 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ the electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ the electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 281 has reoccurred at least one time during engine operation?
STEP 2. | Check for air in fuel. |
 | STEP 2A. Check for air in fuel. | Air in fuel?
STEP 3. | Check the fuel pressure sensor connector. |
 | STEP 3A. Inspect the fuel pressure sensor connector and wiring connections. | Dirty or damaged pins?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 281 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ the electronic service tool.
  • Clear all inactive fault codes.
  • Operate the engine at the steady state loaded condition.

Action

Check for fault codes.

  • Use INSITE™ the electronic service tool to read the fault codes.

Fault Code 281 has reoccurred at least one time during engine operation?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check for air in fuel.

Guided Step 2A - Check for air in fuel.

Conditions

  • Install a Compuchek® fitting at the outlet of the pressure side fuel filter.
  • Start the engine and allow it to idle.
  • Connect a test hose at the fuel filter head and run into a bucket.

Action

Check for air in fuel as the engine idles.

Perform the air in fuel test. 006-003 in Troubleshooting and Repair Manual, ISC, QSC8.3, ISL, and QSL9 Series Engines, Bulletin 4021418.

Air in fuel?
YES NO

Repair

The suction side fuel lines, suction filter, or tank pick-up is allowing air to enter fuel supply.

Repair or replace the fuel lines, suction filter, or tank pick-up.

 No Repair

Go to 1A

Go to 3A

Guided Step 3 - Check the fuel pressure sensor connector.

Guided Step 3A - Inspect the fuel pressure sensor connector and wiring connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel pressure sensor connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged locking tab connector.

For general inspection techniques, refer to Component Connector and Pin Inspection, Refer to Procedure 019-361.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Note: A bad connection on the fuel pressure sensor or intermittent wiring connections can cause the signal reading to fluctuate and cause this fault code to become active on an intermittent basis.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Repair

Replace the fuel pump head. Refer to Procedure 005-227 in Troubleshooting and Repair Manual, ISC, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ the electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Operate the engine at a steady-state loaded condition.
  • Use INSITE™ the electronic service tool to verify the fault code is inactive.

Fault Code 281 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins Authorized Repair Location if all steps have been completed and rechecked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ the electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ the electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Jul-2010


FAULT CODE 284 - Engine Speed/Position Sensor (Crankshaft) Supply Voltage Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 284 active?
STEP 2. | Check the engine speed sensor and circuit. |
 | STEP 2A. Inspect the engine speed sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 284 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 284 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 284 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 284 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine speed sensor and circuit.

Guided Step 2A - Inspect the engine speed sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine speed sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 284 active?
YES NO
No Repair

Repair

The engine speed sensor is internally shorted.

Replace the engine speed sensor. Refer to Procedure 019-365 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 284 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

The engine speed sensor SUPPLY line has shorted to ground or a return wire.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 284 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


FAULT CODE 285 - SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Communication between the INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 285 active or inactive with more than one count in the last 25 engine hours?
STEP 3. | Check the original equipment manufacturer (OEM) vehicle electronic control unit and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | 50 ohms to 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | 50 ohms to 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 285 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 285 active or inactive with more than one count in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 3A

Repair complete.

Guided Step 3 - Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool Society of Automotive Engineers (SAE) J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault.

If the status column indicates “Active” for a multiplexed component, check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

See Multiplexing Troubleshooting, Bulletin 4021378, for specific multiplexing configuration information for several OEMs. If the OEM is not listed in the bulletin, it will be necessary to contact the OEM for specific multiplexing information.

ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
YES NO
No Repair

Repair

An incorrect setup has been detected in the Cummins® engine ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM vehicle electronic control unit source addresses for each component are correct.

Go to 4A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Follow the general inspection techniques as described in the following procedure.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Follow the general resistance measurement techniques described in the following procedure and the wiring diagram. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken.
  • Wire insulation damage
  • Damaged connector locking tab.

Follow the general inspection techniques as described in the following procedure.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Follow the general resistance measurement techniques described in the following procedure and the wiring diagram. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

Repair

An open or short has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the Cummins® ECM OEM connection to all other pins in the OEM connector.

Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Use the circuit diagram or wiring diagram for connector pin identification.

Follow the general resistance measurement techniques described in the following procedure and the wiring diagram. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool.

Fault Code 285 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A communication issue between the ECM and the data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

See the appropriate ECM No Communication symptom tree.

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 11-Dec-2017


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for ECM communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Is communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 286 is active?
STEP 3. | Check the OEM VECU and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | 50 ohms to 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | 50 ohms to 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 286 inactive?
STEP 6. | Clear the fault code. |
 | STEP 6A. Disable the fault code. | Fault Code 286inactive?
 | STEP 6B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic serivce tool communication with the ECM.

Is communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286 is active?
YES | NO
No Repair | No Repair

Go to 3A

Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault.

If the status column indicates “Active” for a multiplexed component, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Note: Refer to Multiplexing Troubleshooting, Bulletin 4021378, for specific multiplexing configuration information for several OEMs. If the OEM is not listed in the bulletin, it will be necessary to contact the OEM for specific multiplexing information.

Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

Repair

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

Repair

An incorrect setup has been detected in the Cummins® engine ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken.
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

Follow the general inspection techniques as described in the following procedure.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the service data link cable or connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Follow the general resistance measurement techniques described in the following procedure and the wiring diagram. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the data link harness.

Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness.

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken.
  • Wire insulation damage
  • Damaged locking tab.

Refer to circuit diagram or wiring diagram for component pin inspection.

Follow the general inspection techniques as described in the following procedure.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Follow the general resistance measurement techniques described in the following procedure and the wiring diagram. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

Repair

An open or short has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for a pin to pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the Cummins® ECM OEM connection to all other pins in the OEM connector.

NOTE: Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Follow the general resistance measurement techniques described in the following procedure and the wiring diagram. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A communication issue between the ECM and the data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

Refer to the appropriate ECM No Communication symptom tree

Guided Step 6 - Clear the fault code.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Using the INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 286 inactive?
YES | NO
No Repair | No Repair

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use the INSITE™ electronic service tool to clear the inactive fault codes .

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 287 is active?
STEP 2. | Check the OEM VECU and engine ECM for proper multiplexing configuration. |
 | STEP 2A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 datalink to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 3. | Monitor the accelerator parameters with INSITE™ electronic service tool. |
 | STEP 3A. Determine if the idle validation switch and or accelerator parameters are being received properly by the engine ECM. | Throttle Status/Idle Validation parameter displays released and Percent Throttle parameter displays a value of zero?
 | STEP 3B. Determine if the idle validation switch and or accelerator are being received properly by the engine ECM. | Throttle Status/Idle Validation parameter displays depressed and Percent Throttle parameter displays a value greater than zero?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 287 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Using INSITE™, read the fault codes.

Fault Code 287 is active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Inactive or Intermittent Fault Code, Refer to Procedure 019-362.

Guided Step 2 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 2A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 datalink to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO
No Repair

Repair

An incorrect setup has been detected in the Cummins ECM.

Enable the proper components for multiplexing on the applicable OEM application and ensure the OEM VECU source addresses for each component are correct.

Go to 3A

Go to 4A

Guided Step 3 - Monitor the accelerator parameters with INSITE™ electronic service tool.

Guided Step 3A - Determine if the idle validation switch and or accelerator parameters are being received properly by the engine ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Determine whether the idle validation switch and accelerator position sensor are multiplexed from the appropriate OEM.
  • Ensure the accelerator is in the released position.

Action

Monitor the following parameters in INSITE™ Monitor Mode:

  • Percent Throttle
  • Throttle Status/Idle Validation

NOTE: Monitor parameters can possibly not appear in the electronic service tool exactly as listed above.

When the throttle is released, the Throttle Status/Idle Validation parameter must display “released” and Percent Throttle parameter must display a value of zero.

Throttle Status/Idle Validation parameter displays released and Percent Throttle parameter displays a value of zero?
YES NO
No Repair

Repair

There is an OEM issue with the accelerator or idle validation switch or OEM VECU.

  • Refer to the appropriate OEM for further instructions.
  • Refer to Procedure 019-054.
  • Refer to Procedure 019-085.
  • Refer to Procedure 019-086.

Go to 3B

Go to 4A

Guided Step 3B - Determine if the idle validation switch and or accelerator are being received properly by the engine ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Determine whether the idle validation switch is multiplexed with the accelerator position sensor from the appropriate OEM.
  • Ensure the accelerator is in the depressed position.

Action

Monitor the following parameters in INSITE™ Monitor Mode:

  • Percent Throttle
  • Throttle Status/Idle Validation

When the throttle is depressed, the Throttle Status/Idle Validation parameter must display “depressed” and Percent Throttle parameter must display a value greater than zero.

Throttle Status/Idle Validation parameter displays depressed and Percent Throttle parameter displays a value greater than zero?

YES NO
No Repair

Repair

There is an OEM issue with the idle validation switch or the accelerator or with the OEM VECU.

  • Refer to the appropriate OEM for further instructions.
  • Refer to Procedure 019-054.
  • Refer to Procedure 019-085.
  • Refer to Procedure 019-086.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Using the INSITE™, verify that the fault code is inactive.

Fault Code 287 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using the INSITE™.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 288 is active?
STEP 2. | Check the OEM VECU and engine ECM for proper multiplexing configuration. |
 | STEP 2A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 datalink to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 3. | Monitor the remote accelerator parameters with INSITE™ electronic service tool. |
 | STEP 3A. Determine if the remote throttle switch and or remote accelerator parameters are being received properly by the engine ECM. | Remote Throttle Switch parameter displays ON and Percent Throttle parameter displays a value of zero?
 | STEP 3B. Determine if the remote throttle switch and or remote throttle parameters are being received properly by the engine ECM. | Remote Throttle Switch parameter displays ON and Percent Throttle parameter displays a value greater than zero?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 288 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Using INSITE™, read the fault codes.

Fault Code 288 is active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Inactive or Intermittent Fault Code, Refer to Procedure 019-362.

Guided Step 2 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 2A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the SAE J1939 datalink to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO
No Repair

Repair

An incorrect setup has been detected in the Cummins ECM.

Enable the proper components for multiplexing on the applicable OEM application and ensure the OEM VECU source addresses for each component are correct.

Go to 3A

Go to 4A

Guided Step 3 - Monitor the remote accelerator parameters with INSITE™ electronic service tool.

Guided Step 3A - Determine if the remote throttle switch and or remote accelerator parameters are being received properly by the engine ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Ensure the remote throttle switch is ON and the remote accelerator is in the released position.

Action

Monitor the following parameters in INSITE™ Monitor Mode:

  • Percent Throttle
  • Remote Throttle Status/Idle Validation

NOTE: Monitor parameters can possibly not appear in the electronic service tool exactly as listed above.

When the remote throttle is released, the Remote Throttle Switch parameter must display ON and the Percent Throttle parameter must display a value of zero.

Remote Throttle Switch parameter displays ON and Percent Throttle parameter displays a value of zero?
YES NO
No Repair

Repair

There is an OEM issue with the remote throttle switch, the remote throttle, or with the OEM VECU.

Refer to the appropriate OEM for further instructions.

Go to 3B

Go to 4A

Guided Step 3B - Determine if the remote throttle switch and or remote throttle parameters are being received properly by the engine ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Ensure the remote throttle switch is ON and the remote accelerator is in the depressed position.

Action

Monitor the following parameters in INSITE™ Monitor Mode:

  • Percent Throttle
  • Remote Throttle Switch Status

NOTE: Monitor parameters can possibly not appear in the electronic service tool exactly as shown above.

When the remote throttle is depressed, the Remote Throttle Switch parameter must display ON and the Percent Throttle parameter must display a value greater than zero.

Remote Throttle Switch parameter displays ON and Percent Throttle parameter displays a value greater than zero?
YES NO
No Repair

Repair

There is an OEM issue with the remote throttle switch, or the remote throttle, or with the OEM VECU.

Refer to the appropriate OEM for further instructions.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Using the INSITE™, verify that the fault code is inactive.

Fault Code 288 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 291 is active?
STEP 2. | Check the immobilizer anti-theft device for proper configuration. |
 | STEP 2A. Determine if the immobilizer anti-theft device configured correctly. | The immobilizer anti-theft device is configured correctly.
STEP 3. | Check the service datalink harness |
 | STEP 3A. Inspect the immobilizer anti-theft device and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open or short circuit in the J1939 harness | Resistance between 50 and 70 ohms?
STEP 4. | Check the OEM harness |
 | STEP 4A. Check the ECM and OEM harness connector pins | Damaged or dirty pins?
 | STEP 4B. Check for an open or short circuit in the ECM J1939 datalink harness | Resistance between 50 and 70 ohms?
 | STEP 4C. Check for a short circuit in the ECM J1939 datalink harness | Greater than 100k ohms?
STEP 5. | Clear the fault code. |
 | STEP 5A. Disable the fault code. | Fault Code 291 inactive?
 | STEP 5B. Clear the inactive fault code. | All faults cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ to read the fault codes.

Fault Code 291 is active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Inactive or Intermittent Fault Code 019-362.

Guided Step 2 - Check the immobilizer anti-theft device for proper configuration.

Guided Step 2A - Determine if the immobilizer anti-theft device is configured correctly.

Conditions

  • Turn keyswitch ON.

Action

Check the immobilzer anti-theft device for the following:

  • Correct power supply and ground connections
  • Proper connections to the J1939 datalink
  • Correct electronic configuration of the immobilizer anti-theft device.

The immobilizer anti-theft device is configured correctly?
YES NO
No Repair

Repair

Refer to the immobilizer anti-theft installation instructions provided by the OEM.

Go to 3A

Refer to OEM installation instructions.

Guided Step 3 - Check the service datalink harness

Guided Step 3A - Inspect the immobilizer anti-theft device and connector pins

Conditions

  • Turn keyswitch OFF.
  • Disconnect the immobilizer anti-theft device from the J1939 datalink

Action

Inspect the service data link connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins

Dirty or damaged pins?
YES NO

Repair

A defective connection has been detected in the service datalink cable.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open or short circuit in the J1939 datalink harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the immobilizer anti-theft device from the J1939 datalink.

Action

Check for an open or short circuit:

  • Measure the resistance between the SAE J1939 Data Link (+) wire and the SAE J1939 Data Link (-) wire on the service data link connector.

Refer to the wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to the Resistance Measurements Using a Multimeter and Wiring Diagram, Procedure Refer to Procedure 019-360.

Resistance between 50 and 70 ohms?
YES NO
No Repair

Repair

An open or short has been detected on the service datalink connector or harness connection to the J1939 datalink backbone.

Repair/replace the OEM harness

019-071.

Go to 4A

Go to 5A

Guided Step 4 - Check the OEM harness

Guided Step 4A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM.

Action

Inspect the ECM data link harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins

Dirty or damaged pins?
YES NO

Repair

A defective connection to the Cummins ECM has been detected in the J1939 datalink connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the ECM J1939 datalink harness

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM.

Action

Check for an open or short circuit:

  • Measure the resistance between the SAE J1939 Data Link (+) wire and the SAE J1939 (-) wire on the appropriate Cummins ECM OEM connection to the J1939 datalink harness connector.

Refer to the wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to the Resistance Measurements Using a Multimeter and Wiring Diagram, Procedure Refer to Procedure 019-360.

Resistance between 50 and 70 ohms?
YES NO
No Repair

Repair

An open or short has been detected in the OEM harness.

Repair or replace the OEM harness.

019-071.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit in the ECM J1939 datalink harness

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit:

  • Measure the resistance and check for a short circuit between the SAE J1939 Data Link (+) wire and the SAE J1939 (-) wire on the appropriate Cummins ECM OEM connection to the J1939 datalink harness connector.

Note: Disregard any resistance between 50 and 70 ohms between the SAE J1939 Data Link (+) and the SAE J1939 Data Link (-) pins.

Refer to the wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to the Resistance Measurements Using a Multimeter and Wiring Diagram, Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short has been detected in the OEM harness.

Repair or replace the OEM harness.

019-071.

Refer to the No Communication Symptom Tree.

Go to 5A

Guided Step 5 - Clear the fault code

Guided Step 1A - Disable the fault code

Conditions

  • Connect all components
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute
  • Using INSITE™, verify that the fault code is inactive.

Fault Code 291 is inactive?
YES | NO
No Repair | No Repair

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault code

Conditions

  • Connect all components
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using the INSITE™ electronic service tool.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 08-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 292. | Active or inactive counts of Fault Code 292?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 292.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Using INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 292?
YES NO

Repair

The engine protection limit has been exceeded for the OEM supplied pressure or temperature input. Refer to the OEM troubleshooting manual.

No Repair

OEM troubleshooting manual

Repair complete

Last Modified: 08-Jul-2010


FAULT CODE 293 - Auxiliary Temperature Sensor Input 1 - Voltage Above Normal, or Shorted to High Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 293 is inactive?
STEP 2. | Check the OEM temperature sensor and circuit. |
 | STEP 2A. Inspect the OEM temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160K ohms?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check from an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness |
 | STEP 3C. Check for a pin to pin short circuit in the OEM harness | Greater than 100K ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 293 inactive?
STEP 4. | Clear the fault code |
 | STEP 4A. Disable the fault code. | Fault Code 293 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool, to read the fault codes.

Fault Code 293 is inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the OEM temperature sensor and circuit.

Guided Step 2A - Inspect the OEM temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM temperature sensor and connector pins.

Action

Inspect the OEM harness and OEM temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM temperature sensor from the OEM harness.

Action

Check the sensor resistance.

  • Measure the resistance between the SIGNAL pin and RETURN pin at the OEM temperature sensor connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160K ohms?

Refer to OEM service manual for additional specifications.
YES NO
No Repair

Repair

Replace the OEM temperature sensor. Refer to OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector OEM temperature sensor RETURN pin and OEM harness OEM temperature sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open RETURN circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector OEM temperature sensor SIGNAL pin and the OEM harness OEM temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SIGNAL circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 293 inactive?
YES NO

Repair

None. The removal and reinstallation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service too, to verify that the fault code is inactive.

Fault Code 293 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps.

Last Modified: 01-May-2012


FAULT CODE 294 - Auxiliary Temperature Sensor Input 1 Circuit - Voltage Below Normal, or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an inactive fault code. | Fault Code 294 is inactive?
STEP 2. | Check the OEM temperature sensor and circuit. |
 | STEP 2A. Inspect the OEM temperature sensor and connector pins. | Dirty or damage pins?
 | STEP 2B. Check the circuit response. | Fault Code 293 active and Fault Code 294 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 294 is active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 3C. Check for a pin short circuit to ground. | Greater then 100K ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 294 is inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 294 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 294 is inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the OEM temperature sensor and circuit.

Guided Step 2A - Inspect the OEM temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM temperature sensor from the OEM harness.

Action

Inspect the OEM harness and OEM temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE electronic service tool, to read the fault codes.

Fault Code 293 active and Fault Code 294 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Use INSITE™ electronic service tool to read the fault codes.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use electronic service tool to read the fault codes.

Fault Code 294 is active?
YES NO

Repair

A damaged sensor has been detected.

Replace the OEM temperature sensor. Refer to OEM service manual.

Repair

None. The removal and reinstallation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM OEM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM temperature SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from ECM.
  • Disconnect the OEM temperature sensor from the OEM harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the OEM temperature SIGNAL pin in the OEM harness ECM connector and ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 294 is inactive?
YES NO

Repair

None. The removal and reinstallation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 294 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE electronic service tool to erase the inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 01-May-2012


FAULT CODE 295 - Barometric Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 221 or 222 active?
STEP 2. | Check the barometric pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric pressure sensor and connector pins. | Dirty or damaged pins?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 222 active?
 | STEP 3C. Check the circuit response. | Fault Code 221 active?
 | STEP 3D. Check the harness resistance. | Harness resistance less than 3 ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the repair. | INSITE™ electronic service tool reading within 102 mm Hg [4 in Hg] of local barometric pressure?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 221 and 222.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 221 or 222 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the barometric pressure sensor and circuit.

Guided Step 2A - Inspect the barometric pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.

Action

Inspect the engine harness and barometric pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 222 active?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the barometric pressure +5 volt SUPPLY pin and the barometric pressure SIGNAL pin at the engine control module engine connector.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 221 active?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check the harness resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the sensor from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check the resistance of the engine harness signal and return wires.

  • Measure the resistance between the barometric pressure sensor SIGNAL pin at the barometric pressure sensor engine harness connector and the barometric pressure sensor SIGNAL pin at the ECM engine harness connector.
  • Measure the resistance between the barometric pressure sensor RETURN pin at the barometric pressure sensor engine harness connector and the barometric pressure sensor RETURN pin at the ECM engine harness connector.

Refer to the circuit diagram of the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Harness resistance less than 3 ohms?
YES NO

Repair

An in-range failure of the barometric pressure sensor has been detected.

Replace the barometric pressure sensor. Refer to Procedure 019-004 in Section 19.

Repair

High resistance has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the INSITE™ electronic service tool Data Monitor/Logger.

  • Compare the INSITE™ electronic service tool reading for Barometric Air Pressure to the local barometric pressure. Use the following procedure for barometric pressure values at altitude. Refer to Procedure 018-028 in Section V.

INSITE™ electronic service tool reading within 102 mm Hg [4 in Hg] of local barometric pressure?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear all active and inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 01-May-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 296a. | Active or inactive counts of Fault Code 296a?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 296a.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 296a?
YES NO

Repair

The engine protection limit has been exceeded for the OEM supplied pressure input. Refer to the OEM troubleshooting and repair manual.

No Repair

OEM troubleshooting manual

Repair complete

Last Modified: 08-Jul-2010


Fault Code 296 (ISL Recreational Vehicles) - Auxiliary Pressure Sensor Input 1 - Special Instructions

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 296lrv active?
STEP 2. | Inspect the crankcase ventilation system. |
 | STEP 2A. Verify pressure sensor accuracy. | Pressure reading 0 ± 0.28 kPa - G [0 ± 1.18 in H2O]?
 | STEP 2B. Inspect the crankcase ventilation oil drain tubes, check valves, breather tubes. | Oil drain tubes, check valves, or breather tubes plugged?
 | STEP 2C. Coolant in the oil. | Coolant in the oil?
STEP 3. | Check for piston and cylinder liner scuffing. |
 | STEP 3A. Inspect the cylinder liners and piston skirts for scuffing. | Scratches or scuffs?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 296lrv inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate engine.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 296lrv active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Inspect the crankcase ventilation system.

Guided Step 2A - Verify pressure sensor accuracy.

Conditions

  • Turn Keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Connect INSITE™ electronic service tool Monitor.
  • Do not operate engine.

Action

Verify pressure sensor accuracy.

  • Make sure the correct sensor part number is installed.
  • When checking the pressure sensor accuracy, make sure the engine is not running.
  • Monitor the crankcase pressure.
  • Use INSITE™ electronic service tool to measure crankcase pressure.

Is the pressure reading 0 ± 0.28 kPa - G [0 ± 1.13 in H2O]?

YES NO
No Repair

Repair

Replace the crankcase pressure sensor.

Refer to Procedure 019-445 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the crankcase ventilation oil drain tubes, check valves, breather tubes.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the oil drain tubes, check valves, and breather tubes for plugging.

Use the following procedures in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 003-001 in Section 3. Refer to Procedure 003-018 in Section 3.

Are the oil drain tubes, check valves, or breather tubes plugged?
YES NO

Repair

Clean or replace the crankcase ventilation oil drain tubes, check valves, and breather tubes. Use the following procedures in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 003-001 in Section 3. Refer to Procedure 003-018 in Section 3.

No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check for coolant in the oil.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Check for coolant in the oil.

Use the following procedures in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 007-083 in Section 7.

Is coolant in the oil?
YES NO

Repair

If coolant is found in the oil, reference the Coolant in the Lubricating Oil troubleshooting symptom tree in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check for piston and cylinder liner scuffing.

Guided Step 3A - Inspect the cylinder liners and piston skirts for scuffing.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the cylinder liners and piston skirts for scuffing.

  • Inspect the cylinder liners, and piston skirts for scuffing.
  • Check for progressive damage. Use the following procedures in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 001-028 in Section 1. Refer to Procedure 002-004 in Section 2.

Are there scratches or scuffs?
YES NO

Repair

Replace the damaged power cylinder(s) and check for progressive damage. Replace all connecting rods, connecting rod bearings, and piston pins.

Inspect the piston pin bores on any non damaged pistons.

Use the following procedures in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418.

  • Replace any piston not within specifications. If pistons are reusable, reuse the piston rings. Refer to Procedure 001-043 in Section 1.
  • Install all new connecting rods. Refer to Procedure 001-054 in Section 1.
  • Install all new connecting rod bearings. Refer to Procedure 001-005 in Section 1.
  • Install all new piston pins. Refer to Procedure 001-054 in Section 1.

Repair

Reference the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate engine.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 296lrv inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 2A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-Jul-2012


FAULT CODE 297 - Auxiliary Pressure Sensor Input 1 Circuit - Voltage Above Normal, or Shorted to High Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply or multiple fault codes. | Sensor Supply Fault Code 386 active?
STEP 2. | Check the OEM pressure sensor and circuit. |
 | STEP 2A. Inspect the OEM pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Codes 298 active and Fault Code 297 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 297 is active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin to pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 3D. Check for a pin to pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 297 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 297 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply or multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool, to read the fault codes.

Sensor supply Fault Code 386 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 386 fault code troubleshooting.

Go to 2A

Guided Step 2 - Check the OEM pressure sensor and circuit.

Guided Step 2A - Inspect the OEM pressure sensor and connector pins.

Conditions

  • Turn keyswitch ON.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Inspect the OEM harness and OEM pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 298 active and Fault Code 297 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM pressure sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the OEM Pressure +5 volt SUPPLY pin and the OEM pressure RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM pressure sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 297 is active?
YES NO

Repair

A damaged sensor has been detected.

Replace the OEM pressure sensor. Refer to OEM service manual.

Repair

None. The removal and reinstallation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM hanress and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector OEM pressure RETURN pin and the OEM harness OEM pressure sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open RETURN circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM pressure SUPPLY pin in the OEM harness ECM connector and all other pins in the ECM OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SUPPLY line has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted supply circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM pressure SUPPLY pin in the OEM harness ECM connector and all other pins in the ECM OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SUPPLY line has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 297 inactive?
YES NO

Repair

None. The removal and reinstallation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 297 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair Complete.

Appropriate troubleshooting steps.

Last Modified: 01-May-2012


FAULT CODE 298 - Auxiliary Pressure Sensor Input 1 Circuit - Voltage Below Normal, or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code Sensor Supply Fault Code 352 active?
STEP 2. | Check the OEM pressure sensor and circuit. |
 | STEP 2A. Inspect the OEM pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 297 active and Fault Code 298 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 298 is active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 3E. Check for a pin short circuit to ground. | Greater than 100K ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 298 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 298 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service to tool read the fault codes.

Fault Code Sensor Supply Fault Code 352 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 352.

Go to 2A

Guided Step 2 - Check the OEM pressure sensor and circuit.

Guided Step 2A - Inspect the OEM pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Inspect the OEM harness and OEM pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM pressure sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and retrun circuit.

  • Measure the voltage between the OEM Pressure +5 volt SUPPLY pin and the OEM pressure RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the OEM pressure SUPPLY pin and the OEM pressure SIGNAL pin at the OEM pressure sensor connector of the OEM harness.

Check for the appropriate circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 297 active and Fault Code 298 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM pressure sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 298 is active?
YES NO

Repair

A damaged sensor has been detected.

Replace the OEM pressure sensor. Refer to OEM service manual.

Repair

None. The removal and reinstallation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the connector pins for the following:Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector OEM pressure RETURN pin and the OEM harness OEM pressure sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open RETURN circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector OEM pressure SIGNAL pin and the OEM harness OEM pressure sensor connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms
YES NO
No Repair

Repair

An open SIGNAL circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open signal circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM pressure SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Grater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the pin to pin shorted signal circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM pressure sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the OEM pressure SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 298 inactive?
YES NO

Repair

None. The removal and reinstallation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • connect INSITE™ electronic service tool.

Action

Disabel the fault code.

  • Start the engine let it idle for one minute.
  • Use INSITE™ electronic service tool, to verify that the fault code is inactive.

Fault Code 298 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 01-May-2012


FAULT CODE 319 - Real-Time Clock Power Interrupt - Data Erratic, Intermittent or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part No. 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part No. 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the real-time clock battery and connections. |
 | STEP 1A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the real-time clock battery voltage at the ECM harness connector. | Between 3.3 and 3.6-VDC?
 | STEP 1B-1. Inspect the real-time clock battery and engine wire harness connector pins. |
 | STEP 1B-2. Check the real-time clock battery voltage at the battery module connector. |
STEP 2. | Check the battery module harness. |
 | STEP 2A. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2B. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 319 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the real-time clock battery and connections.

Guided Step 1A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tabs.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the real-time clock battery voltage at the ECM harness connector.

Conditions

  • Engine equipped with optional real-time clock battery
  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.

Action

Measure the voltage between the real-time clock battery SUPPLY pin and the real-time clock battery RETURN (-) pin at the ECM connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Between 3.3 and 3.6-VDC?
YES | NO
No Repair | No Repair

Go to 3A

Go to 1B-1

Guided Step 1B-1 - Inspect the real-time clock battery and engine wire harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the real-time clock battery from the engine harness.

Action

Inspect the real-time clock battery and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tabs.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the real-time clock battery or engine harness.

  • Refer to Procedure 019-311 in Section 19
  • Refer to Procedure Procedure 019-043 in Section 19.
No Repair

Go to 3A

Go to 1B-2

Guided Step 1B-2 - Check the real-time clock battery voltage at the battery module connector.

Conditions

  • Engine equipped with optional real-time clock battery
  • Turn keyswitch OFF
  • Disconnect the real-time clock battery from the engine harness.

Action

Measure the voltage between the real-time clock battery SUPPLY pin and the real-time clock battery RETURN (-) pin at the real-time clock battery connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Between 3.3 and 3.6-VDC?
YES NO
No Repair

Repair

Replace the real-time clock battery. Refer to Procedure 019-311 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the battery module harness.

Guided Step 2A - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.

Action

Measure the following resistance:

  • The resistance between the real-time clock battery SUPPLY pin at the battery connector of the engine harness to the real-time clock battery SUPPLY pin at the ECM harness connector
  • The resistance between the real-time clock battery RETURN (-) pin at the battery connector of the engine harness to the real-time clock battery RETURN (-) pin at the ECM harness connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the real-time clock battery from the engine harness.

Action

Use a multimeter, measure the resistance from the real-time clock battery SUPPLY pin at the ECM connector of the engine harness to all other pins in the connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the real-time clock battery from the engine harness.

Action

Use a multimeter, measure the resistance from the real-time clock battery SUPPLY pin at the ECM connector of the engine harness to engine block ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to set the real-time clock to the correct date and time.
  • Verify that Fault Code 319 is inactive.

Fault Code 319 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes

Repair complete.

Appropriate troubleshooting steps

Last Modified: 15-Mar-2012


FAULT CODE 322 - Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead, Part Number 3164132 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 322 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Codes for other injectors on the same bank active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connector properly connected?
 | STEP 2B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 2 ohms?
 | STEP 2C-1. Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 2D. Check for high resistance or an open circuit in the injector solenoid. | Fault code follow the injector?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector harness circuits for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Check the injector solenoids for short circuits to ground. | Greater than 100k ohms?
STEP 4. | Isolate the ECM or injector malfunction. |
 | STEP 4A. Check for active fault codes. | Same or multiple (same bank) injector fault codes active?
 | STEP 4A-1. Injector isolation. |
 | STEP 4A-2. Injector isolation. |
 | STEP 4A-3. Check for active fault codes. |
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Same or multiple (same bank) injector fault codes active?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Operate engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Note: Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to the ECM
  • Engine harness connected to the injector pass-through connectors at the rocker housing.

Connectors properly connected?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 1 DRIVER pin and the cylinder number 1 RETURN pin on the harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 1 DRIVER pin and the cylinder number 1 RETURN pin on the injector solenoid.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Less than 2 ohms?
YES NO

Repair

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit.

Repair or replace the damaged component.

Repair

Replace the injector. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6.

Go to 5A

Go to 5A

Guided Step 2D - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Remove the injector and swap it with an injector in another bank. Refer to Procedure 006-026 in Section 6.
  • Turn keyswitch ON.
  • Operate engine and let it idle.
  • Use INSITE™ electronic service tool to read the fault codes.

Note: Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Did the fault code follow the injector?
YES NO

Repair

Replace the injector. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the injector harness circuits for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder number 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder number 2 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder number 3 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin idenfication.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 2 SIGNAL pin and engine block ground
  • Measure the resistance between the cylinder 3 SIGNAL pin and engine block ground.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for a short circuit.

  • Repair or replace the damaged component.

Repair

Replace the injector. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.

Go to 5A

Go to 5A

Guided Step 4 - Isolate the ECM or injector malfunction.

Guided Step 4A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place the rocker cover on the cylinder head and install the capscrews loosely so that the engine may run at idle.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Operate the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Bank fault codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, and 331.
  • Bank 2 - Rear Bank: Fault Codes 323, 325, and 332.

Same or multiple (same bank) injector fault codes active?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 5A

Guided Step 4A-1 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 003-011 in Section 3.
  • Disconnect the injector wiring harness from injector number 1. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

Note: It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Operate the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Repair

Replace injector number 1. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.

Go to 4A-2

Go to 5A

Guided Step 4A-2 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 003-011 in Section 3.
  • Connect the injector wiring harness to injector 1.
  • Disconnect the injector wiring harness from injector number 2. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

Note: It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Operate engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Repair

Replace injector number 2. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.

Go to 4A-3

Go to 5A

Guided Step 4A-3 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Remove the valve cover. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 003-011 in Section 3.
  • Connect the injector wiring harness to injector 2.
  • Disconnect the injector wiring harness from injector number 3. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

Note: It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Operate engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Replace injector number 3. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same or multiple (same bank) injector fault codes active?
YES NO

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Jun-2012


FAULT CODE 323 - Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead, Part Number 3164132 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 323 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Codes for other injectors on the same bank active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connector properly connected?
 | STEP 2B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 2 ohms?
 | STEP 2C-1. Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 2D. Check for high resistance or an open circuit in the injector solenoid. | Fault code follow the injector?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector harness circuits for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Check the injector solenoids for short circuits to ground. | Greater than 100k ohms?
STEP 4. | Isolate the ECM or injector malfunction. |
 | STEP 4A. Check for active fault codes. | Same or multiple (same bank) injector fault codes active?
 | STEP 4A-1. Injector isolation. |
 | STEP 4A-2. Injector isolation. |
 | STEP 4A-3. Check for active fault codes. |
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Same or multiple (same bank) injector fault codes active?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Operate engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 323 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Note: Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to the ECM
  • Engine harness connected to the injector pass-through connectors at the rocker housing.

Connectors properly connected?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 5 DRIVER pin and the cylinder number 5 RETURN pin on the harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 5 DRIVER pin and the cylinder number 5 RETURN pin on the injector solenoid.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Less than 2 ohms?
YES NO

Repair

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit.

Repair or replace the damaged component.

Repair

Replace the injector. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6.

Go to 5A

Go to 5A

Guided Step 2D - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Remove the injector and swap it with an injector in another bank. Refer to Procedure 006-026 in Section 6.
  • Turn keyswitch ON.
  • Operate engine and let it idle.
  • Use INSITE™ electronic service tool to read the fault codes.

Note: Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Did the fault code follow the injector?
YES NO

Repair

Replace the injector. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the injector harness circuits for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder number 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder number 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder number 6 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin idenfication.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 5 SIGNAL pin and engine block ground
  • Measure the resistance between the cylinder 6 SIGNAL pin and engine block ground.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for a short circuit.

  • Repair or replace the damaged component.

Repair

Replace the injector. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.

Go to 5A

Go to 5A

Guided Step 4 - Isolate the ECM or injector malfunction.

Guided Step 4A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place the rocker cover on the cylinder head and install the capscrews loosely so that the engine may run at idle.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Operate the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Bank fault codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, and 331.
  • Bank 2 - Rear Bank: Fault Codes 323, 325, and 332.

Same or multiple (same bank) injector fault codes active?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 5A

Guided Step 4A-1 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 003-011 in Section 3.
  • Disconnect the injector wiring harness from injector number 4. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

Note: It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Operate the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Repair

Replace injector number 4. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.

Go to 4A-2

Go to 5A

Guided Step 4A-2 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 003-011 in Section 3.
  • Connect the injector wiring harness to injector 4.
  • Disconnect the injector wiring harness from injector number 5. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

Note: It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Operate engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Repair

Replace injector number 5. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.

Go to 4A-3

Go to 5A

Guided Step 4A-3 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Remove the valve cover. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 003-011 in Section 3.
  • Connect the injector wiring harness to injector 5.
  • Disconnect the injector wiring harness from injector number 6. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

Note: It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Operate engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Replace injector number 6. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same or multiple (same bank) injector fault codes active?
YES NO

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Jun-2012


FAULT CODE 324 - Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead, Part Number 3164132 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 324 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Codes for other injectors on the same bank active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connector properly connected?
 | STEP 2B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 2 ohms?
 | STEP 2C-1. Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 2D. Check for high resistance or an open circuit in the injector solenoid. | Fault code follow the injector?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector harness circuits for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Check the injector solenoids for short circuits to ground. | Greater than 100k ohms?
STEP 4. | Isolate the ECM or injector malfunction. |
 | STEP 4A. Check for active fault codes. | Same or multiple (same bank) injector fault codes active?
 | STEP 4A-1. Injector isolation. |
 | STEP 4A-2. Injector isolation. |
 | STEP 4A-3. Check for active fault codes. |
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Same or multiple (same bank) injector fault codes active?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Operate engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 324 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Note: Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to the ECM
  • Engine harness connected to the injector pass-through connectors at the rocker housing.

Connectors properly connected?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 3 DRIVER pin and the cylinder number 3 RETURN pin on the harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 3 DRIVER pin and the cylinder number 3 RETURN pin on the injector solenoid.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Less than 2 ohms?
YES NO

Repair

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit.

Repair or replace the damaged component.

Repair

Replace the injector. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6.

Go to 5A

Go to 5A

Guided Step 2D - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Remove the injector and swap it with an injector in another bank. Refer to Procedure 006-026 in Section 6.
  • Turn keyswitch ON.
  • Operate engine and let it idle.
  • Use INSITE™ electronic service tool to read the fault codes.

Note: Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Did the fault code follow the injector?
YES NO

Repair

Replace the injector. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the injector harness circuits for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder number 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder number 2 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder number 3 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin idenfication.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 2 SIGNAL pin and engine block ground
  • Measure the resistance between the cylinder 3 SIGNAL pin and engine block ground.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for a short circuit.

  • Repair or replace the damaged component.

Repair

Replace the injector. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.

Go to 5A

Go to 5A

Guided Step 4 - Isolate the ECM or injector malfunction.

Guided Step 4A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place the rocker cover on the cylinder head and install the capscrews loosely so that the engine may run at idle.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Operate the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Bank fault codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, and 331.
  • Bank 2 - Rear Bank: Fault Codes 323, 325, and 332.

Same or multiple (same bank) injector fault codes active?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 5A

Guided Step 4A-1 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 003-011 in Section 3.
  • Disconnect the injector wiring harness from injector number 1. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

Note: It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Operate the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Repair

Replace injector number 1. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.

Go to 4A-2

Go to 5A

Guided Step 4A-2 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 003-011 in Section 3.
  • Connect the injector wiring harness to injector 1.
  • Disconnect the injector wiring harness from injector number 2. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

Note: It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Operate engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Repair

Replace injector number 2. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.

Go to 4A-3

Go to 5A

Guided Step 4A-3 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Remove the valve cover. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 003-011 in Section 3.
  • Connect the injector wiring harness to injector 2.
  • Disconnect the injector wiring harness from injector number 3. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

Note: It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Operate engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Replace injector number 3. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same or multiple (same bank) injector fault codes active?
YES NO

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Jun-2012


FAULT CODE 325 - Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead, Part Number 3164132 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 325 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Codes for other injectors on the same bank active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connector properly connected?
 | STEP 2B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 2 ohms?
 | STEP 2C-1. Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 2D. Check for high resistance or an open circuit in the injector solenoid. | Fault code follow the injector?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector harness circuits for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Check the injector solenoids for short circuits to ground. | Greater than 100k ohms?
STEP 4. | Isolate the ECM or injector malfunction. |
 | STEP 4A. Check for active fault codes. | Same or multiple (same bank) injector fault codes active?
 | STEP 4A-1. Injector isolation. |
 | STEP 4A-2. Injector isolation. |
 | STEP 4A-3. Check for active fault codes. |
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Same or multiple (same bank) injector fault codes active?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Operate engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 325 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Note: Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to the ECM
  • Engine harness connected to the injector pass-through connectors at the rocker housing.

Connectors properly connected?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 6 DRIVER pin and the cylinder number 6 RETURN pin on the harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 6 DRIVER pin and the cylinder number 6 RETURN pin on the injector solenoid.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Less than 2 ohms?
YES NO

Repair

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit.

Repair or replace the damaged component.

Repair

Replace the injector. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6.

Go to 5A

Go to 5A

Guided Step 2D - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Remove the injector and swap it with an injector in another bank. Refer to Procedure 006-026 in Section 6.
  • Turn keyswitch ON.
  • Operate engine and let it idle.
  • Use INSITE™ electronic service tool to read the fault codes.

Note: Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Did the fault code follow the injector?
YES NO

Repair

Replace the injector. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the injector harness circuits for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder number 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder number 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder number 6 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin idenfication.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 5 SIGNAL pin and engine block ground
  • Measure the resistance between the cylinder 6 SIGNAL pin and engine block ground.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for a short circuit.

  • Repair or replace the damaged component.

Repair

Replace the injector. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.

Go to 5A

Go to 5A

Guided Step 4 - Isolate the ECM or injector malfunction.

Guided Step 4A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place the rocker cover on the cylinder head and install the capscrews loosely so that the engine may run at idle.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Operate the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Bank fault codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, and 331.
  • Bank 2 - Rear Bank: Fault Codes 323, 325, and 332.

Same or multiple (same bank) injector fault codes active?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 5A

Guided Step 4A-1 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 003-011 in Section 3.
  • Disconnect the injector wiring harness from injector number 4. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

Note: It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Operate the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Repair

Replace injector number 4. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.

Go to 4A-2

Go to 5A

Guided Step 4A-2 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 003-011 in Section 3.
  • Connect the injector wiring harness to injector 4.
  • Disconnect the injector wiring harness from injector number 5. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

Note: It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Operate engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Repair

Replace injector number 5. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.

Go to 4A-3

Go to 5A

Guided Step 4A-3 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Remove the valve cover. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 003-011 in Section 3.
  • Connect the injector wiring harness to injector 5.
  • Disconnect the injector wiring harness from injector number 6. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

Note: It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Operate engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Replace injector number 6. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same or multiple (same bank) injector fault codes active?
YES NO

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Jun-2012


FAULT CODE 331 - Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead, Part Number 3164132 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 331 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Codes for other injectors on the same bank active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connector properly connected?
 | STEP 2B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 2 ohms?
 | STEP 2C-1. Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 2D. Check for high resistance or an open circuit in the injector solenoid. | Fault code follow the injector?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector harness circuits for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Check the injector solenoids for short circuits to ground. | Greater than 100k ohms?
STEP 4. | Isolate the ECM or injector malfunction. |
 | STEP 4A. Check for active fault codes. | Same or multiple (same bank) injector fault codes active?
 | STEP 4A-1. Injector isolation. |
 | STEP 4A-2. Injector isolation. |
 | STEP 4A-3. Check for active fault codes. |
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Same or multiple (same bank) injector fault codes active?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Operate engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 331 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Note: Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to the ECM
  • Engine harness connected to the injector pass-through connectors at the rocker housing.

Connectors properly connected?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 2 DRIVER pin and the cylinder number 2 RETURN pin on the harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 2 DRIVER pin and the cylinder number 2 RETURN pin on the injector solenoid.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Less than 2 ohms?
YES NO

Repair

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit.

Repair or replace the damaged component.

Repair

Replace the injector. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6.

Go to 5A

Go to 5A

Guided Step 2D - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Remove the injector and swap it with an injector in another bank. Refer to Procedure 006-026 in Section 6.
  • Turn keyswitch ON.
  • Operate engine and let it idle.
  • Use INSITE™ electronic service tool to read the fault codes.

Note: Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Did the fault code follow the injector?
YES NO

Repair

Replace the injector. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the injector harness circuits for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder number 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder number 2 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder number 3 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin idenfication.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 2 SIGNAL pin and engine block ground
  • Measure the resistance between the cylinder 3 SIGNAL pin and engine block ground.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for a short circuit.

  • Repair or replace the damaged component.

Repair

Replace the injector. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.

Go to 5A

Go to 5A

Guided Step 4 - Isolate the ECM or injector malfunction.

Guided Step 4A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place the rocker cover on the cylinder head and install the capscrews loosely so that the engine may run at idle.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Operate the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Bank fault codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, and 331.
  • Bank 2 - Rear Bank: Fault Codes 323, 325, and 332.

Same or multiple (same bank) injector fault codes active?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 5A

Guided Step 4A-1 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 003-011 in Section 3.
  • Disconnect the injector wiring harness from injector number 1. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

Note: It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Operate the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Repair

Replace injector number 1. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.

Go to 4A-2

Go to 5A

Guided Step 4A-2 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 003-011 in Section 3.
  • Connect the injector wiring harness to injector 1.
  • Disconnect the injector wiring harness from injector number 2. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

Note: It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Operate engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Repair

Replace injector number 2. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.

Go to 4A-3

Go to 5A

Guided Step 4A-3 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Remove the valve cover. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 003-011 in Section 3.
  • Connect the injector wiring harness to injector 2.
  • Disconnect the injector wiring harness from injector number 3. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

Note: It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Operate engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Replace injector number 3. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same or multiple (same bank) injector fault codes active?
YES NO

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Jun-2012


FAULT CODE 332 - Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead, Part Number 3164132 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 332 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Codes for other injectors on the same bank active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connector properly connected?
 | STEP 2B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 2 ohms?
 | STEP 2C-1. Check for high resistance or an open circuit in the injector solenoid and circuit. |
 | STEP 2D. Check for high resistance or an open circuit in the injector solenoid. | Fault code follow the injector?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector pass-through connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector harness circuits for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Check the injector solenoids for short circuits to ground. | Greater than 100k ohms?
STEP 4. | Isolate the ECM or injector malfunction. |
 | STEP 4A. Check for active fault codes. | Same or multiple (same bank) injector fault codes active?
 | STEP 4A-1. Injector isolation. |
 | STEP 4A-2. Injector isolation. |
 | STEP 4A-3. Check for active fault codes. |
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Same or multiple (same bank) injector fault codes active?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Operate engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 332 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Note: Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Fault codes for other injectors on the same bank active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to the ECM
  • Engine harness connected to the injector pass-through connectors at the rocker housing.

Connectors properly connected?
YES NO
No Repair

Repair

Install the engine harness connectors properly.

Go to 2B

Go to 5A

Guided Step 2B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 4 DRIVER pin and the cylinder number 4 RETURN pin on the harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2 ohms?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C-1

Guided Step 2C-1 - Check for high resistance or an open circuit in the injector solenoid and circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the cylinder number 4 DRIVER pin and the cylinder number 4 RETURN pin on the injector solenoid.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Less than 2 ohms?
YES NO

Repair

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for an open circuit.

Repair or replace the damaged component.

Repair

Replace the injector. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6.

Go to 5A

Go to 5A

Guided Step 2D - Check for high resistance or an open circuit in the injector solenoid.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injector solenoid.

Action

Check for an open circuit.

  • Remove the injector and swap it with an injector in another bank. Refer to Procedure 006-026 in Section 6.
  • Turn keyswitch ON.
  • Operate engine and let it idle.
  • Use INSITE™ electronic service tool to read the fault codes.

Note: Cylinders 1, 2, and 3 (Cylinders 1 and 2 for 4-cylinder engines) are on the same injector bank. Cylinders 4, 5, and 6 (Cylinders 3 and 4 for 4-cylinder engines) are on the same injector bank.

Did the fault code follow the injector?
YES NO

Repair

Replace the injector. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

5A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector pass-through connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the injector harness circuits for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder number 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder number 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder number 6 SIGNAL pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin idenfication.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker cover.
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the cylinder 5 SIGNAL pin and engine block ground
  • Measure the resistance between the cylinder 6 SIGNAL pin and engine block ground.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Troubleshoot the engine wiring harness, injector harness, and pass-through connector for a short circuit.

  • Repair or replace the damaged component.

Repair

Replace the injector. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.

Go to 5A

Go to 5A

Guided Step 4 - Isolate the ECM or injector malfunction.

Guided Step 4A - Check for active fault codes.

Conditions

  • Connect all components.
  • Place the rocker cover on the cylinder head and install the capscrews loosely so that the engine may run at idle.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Operate the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Bank fault codes:

  • Bank 1 - Front Bank: Fault Codes 322, 324, and 331.
  • Bank 2 - Rear Bank: Fault Codes 323, 325, and 332.

Same or multiple (same bank) injector fault codes active?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 5A

Guided Step 4A-1 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 003-011 in Section 3.
  • Disconnect the injector wiring harness from injector number 4. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

Note: It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Operate the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Repair

Replace injector number 4. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.

Go to 4A-2

Go to 5A

Guided Step 4A-2 - Injector isolation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Complete injector isolation.

  • Remove the valve cover. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 003-011 in Section 3.
  • Connect the injector wiring harness to injector 4.
  • Disconnect the injector wiring harness from injector number 5. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

Note: It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Operate engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO
No Repair

Repair

Replace injector number 5. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.

Go to 4A-3

Go to 5A

Guided Step 4A-3 - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Remove the valve cover. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 003-011 in Section 3.
  • Connect the injector wiring harness to injector 5.
  • Disconnect the injector wiring harness from injector number 6. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.
  • Place tape on the ends of the injector wiring harness to make sure the harness ends do not come in contact with each other or the engine block.
  • Place the valve cover on the engine.

Note: It is not necessary to bolt the valve cover in place.

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Operate engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Multiple (same bank) injector fault codes active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Replace injector number 6. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin Number 4021271. Refer to Procedure 006-026 in Section 6.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Same or multiple (same bank) injector fault codes active?
YES NO

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Jun-2012


FAULT CODE 334 - Engine Coolant Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Code 144 and 145. | Fault Code 144 and 145 is active?
STEP 2. | Check the thermostat. |
 | STEP 2A. Check the thermostat. | Thermostat operate correctly?
STEP 3. | Check the engine coolant temperature sensor and circuit. |
 | STEP 3A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 144 active?
 | STEP 3C. Check the circuit response. | Fault Code 145 active?
STEP 4. | Check the engine control module (ECM) and engine harness. |
 | STEP 4A. Inspect ECM and engine harness connector pins. | Dirty or damage pins?
 | STEP 4B. Check the circuit response. | Fault Code 144 active?
 | STEP 4C. Check the circuit response. | Fault Code 145 active?
STEP 5. | Clear the fault code. |
 | STEP 5A. Disable the fault code. | Fault Code 334 inactive?
 | STEP 5B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 144 and 145.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 144 or 145 is active?
YES | NO
No Repair | No Repair

Fault Code 144 or 145 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the thermostat.

Guided Step 2A - Check the thermostat

Conditions

  • Turn keyswitch OFF.

Action

Check the thermostat for correct operation.

  • For ISBe, ISB, and QSB5.9 (Common Rail Fuel System). Refer to Procedure 008-013 in Section 8.
  • For ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4, and QSL9 Engines. Refer to Procedure 008-013 in Section 8.

Thermostat operate correctly?
YES NO
No Repair

Repair

Replace the thermostat.

  • For ISBe, ISB, and QSB5.9 (Common Rail Fuel System). Refer to Procedure 008-013 in Section 8.
  • For ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4, and QSL9 Engines. Refer to Procedure 008-013 in Section 8.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine coolant temperature sensor and circuit.

Guided Step 3A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor and connector pins.

Action

Inspect the engine harness and engine coolant temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine coolant temperature SIGNAL pin and the engine coolant temperature RETURN pin at the engine coolant temperature connector of the engine harness.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO

Repair

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine coolant temperature SIGNAL pin and engine coolant temperature RETURN pin at the ECM engine connector.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO

Repair

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Make sure coolant temperature is equal to ambient air temperature.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

To allow this diagnostic to run, the keyswitch must be turned OFF for a minimum of 8 hours. This will allow the coolant temperature to stabilize down to ambient temperature. The engine must be started and warmed up to operating temperature before the fault code will be disabled.

  • Start the engine with coolant temperature near ambient air temperature.
  • Operate the engine until coolant temperature reaches thermostat opening temperature.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Note: The coolant temperature must be equal to ambient air temperature before starting the engine.

Fault Code 334 inactive?
YES | NO
No Repair | No Repair

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 17-Jan-2013


Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test lead when taking a measurement:Part No. 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Are other fault codes active?
STEP 2. | Check the batteries and the power harness connector. |
 | STEP 2A. Check the resistance of the battery supply circuit. | Less than 10 ohms?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least (+) 12 VDC? (During cranking: At least (+) 6.2 VDC)?
 | STEP 2C. Check the battery connections. | Connections are tight and corrosion-free?
STEP 3. | Check the OEM fuses. |
 | STEP 3A. Verify that the OEM fuses are installed correctly. | Fuses installed correctly?
 | STEP 3B. Verify that the OEM fuses are not blown. | Fuses not blown?
STEP 4. | Check the power connector. |
 | STEP 4A. Check the add-on or the accessory wiring at the positive (+) terminal of the battery. | No damaged wires?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 341 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool to read the fault codes.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Are other fault codes active?
YES NO

Repair

Troubleshoot the active fault codes.

 No Repair

Go to appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the batteries and the power connector.

Guided Step 2A - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness connector from the ECM.

Action

Check the resistance of the battery supply circuit.

  • Use a multimeter to measure the resistance between the ECM battery SUPPLY (+) pin of the power harness ECM connector and the positive (+) battery terminal.
  • Use a multimeter to measure the resistance between the ECM battery SUPPLY (-) pin of the power harness ECM connector and the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to the Resistance Measurements Using a Multimeter and Wiring Diagram, Refer to Procedure 019-360.

Less than 10 ohms?
YES | NO
No Repair | No Repair

Go to 2B

Go to 3A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal. Touch the negative (-) probe of the multimeter to the negative battery terminal while trying to start the engine.

Normal conditions: At least (+) 12 VDC? (During cranking: At least (+) 6.2 VDC)?
YES NO
No Repair

Repair

Charge or replace the battery.

Refer to the OEM troubleshooting and repair manual.

Go to 2C

Go to 5A

Guided Step 2C - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Inspect the battery terminal connections.

Are connections tight and corrosion-free?
YES NO
No Repair

Repair

Tighten the loose connections and clean the terminals.

Refer to the OEM troubleshooting and repair manual.

Go to 4A

Go to 5A

Guided Step 3 - Check the OEM fuses.

Guided Step 3A - Verify that the OEM fuses are installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the OEM fuses for correct installation.

Are fuses installed correctly?
YES NO
No Repair

Repair

Install the fuses correctly.

Refer to Procedure 019-198.

Go to 3B

Go to 5A

Guided Step 3B - Verify that the OEM fuses are not blown.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the OEM fuses are not blown.

Are any fuses blown?
YES NO

Repair

Replace the fuses.

Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071.

Go to 5A

Go to 5A

Guided Step 4 - Check the power connector.

Guided Step 4A - Check the add-on or the accessory wiring at positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Are any wires damaged?
YES NO

Repair

Repair or replace the damaged wiring.

Repair

Verify the OEM power supply wiring to the Electronic Control Module (ECM) is correct. Refer to the Original Equipment Manufacturer (OEM) wiring diagram.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn keyswitch OFF and wait 30 seconds.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to verify Fault Code 341 is inactive.

Fault Code 341 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 342 is active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE electronic service tool.

Action

Check for active fault codes.

  • Use INSITE electronic service tool to read the fault codes.

Fault Code 342 is active?
YES NO

Repair

Incompatible calibrations have been detected in the OEM installed primary and secondary ECM's.

Refer to the OEM troubleshooting manual.

 No Repair

OEM troubleshooting manual.

Repair complete.

Last Modified: 08-Jul-2010


FAULT CODE 343 - Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Associated Procedures

Cautions and Warnings

CAUTION

To reduce damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Reset the real time clock feature (Euro certified engines only). | Has real time clock feature been set correctly (if equipped)?
 | STEP 1B. Check the ECM. | Fault Code 343 active?
 | STEP 1C. Check the inactive counts of Fault Code 343. | Less than 3 counts?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 343 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM.

Guided Step 1A - Reset the real time clock feature (Euro certified engines only).

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to check Real Time Clock feature under Advanced ECM data.

  • If the feature is available, verify that the time is set correctly.

Has the Real Time Clock feature been set correctly (if equipped)?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool to set the correct date and time for the Real Time Clock feature.

Go to 1B

Repair Complete.

Guided Step 1B - Check the ECM.

Conditions

  • Connect all components.

Action

Check the ECM.

  • Turn keyswitch OFF and wait five seconds.
  • Start the engine and let it idle for one minute.

Is Fault Code 343 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 1C

Go to 2A

Guided Step 1C - Check the inactive counts of Fault Code 343.

Conditions

  • Turn keyswitch ON.

Action

Check the inactive counts of Fault Code 343.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 343.

Are there less than three counts?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2B

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 343 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes .

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 16-Mar-2012


FAULT CODE 351 - Injector Power Supply - Bad Intelligent Device or Component

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3164133 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 322, 323, 324, 325, 331, and 332 active during engine operation?
STEP 2. | Check the ECM power supply. |
 | STEP 2A. Inspect the ECM power supply connectors and fuses. | Damage observed?
 | STEP 2B. Check for an open circuit. | Less than 0.5 ohms?
 | STEP 2C. Check for an open circuit in the ECM power supply circuit. | Less than 10 ohms?
STEP 3. | Validate the occurrence of this fault code. |
 | STEP 3A. Operate the engine and determine if fault code condition exists. | Fault Code 351 reoccurs during engine operation, while injector Fault Code 322, 323, 324, 325, 331, and 332 do not occur?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 351 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322, 323, 324, 325, 331, and 332 active during engine operation?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the ECM power supply.

Guided Step 2A - Inspect the ECM power supply connectors and fuses.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply harness from the ECM.

Action

Inspect the ECM power supply and fuses connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damage observed?
YES NO

Repair

Clean the connector and pins. Repair or replace the damaged harness, pins, fuses, or connectors. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pins at the power connector of the ECM power supply harness and the battery positive (+) pins at the battery positive (+) connection.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 0.5 ohms?
YES NO
No Repair

Repair

Repair or replace the ECM power supply harness, fuses, or fuse holders, or clean the battery terminal connections.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the ECM power supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM power supply harness from the ECM.
  • Disconnect the ECM power supply harness from the battery terminals.

Action

Check for an open circuit in the ECM power supply circuit.

  • Measure the resistance between the battery negative (-) pins at the ECM power supply connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ECM power supply harness, fuses, or fuse holders, or clean the battery terminal connections.

Go to 3A

Go to 4A

Guided Step 3 - Validate the occurrence of this fault code.

Guided Step 3A - Operate the engine and determine if fault code condition exists.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and determine whether the fault code condition still exists.

  • Operate the engine at high idle, no load.
  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: The INSITE™ electronic service tool can also be used to monitor ECM power supply and injector power supply voltages.

Fault Code 351 reoccurs during engine operation, while injector Fault Code 322, 323, 324, 325, 331, and 332 do not occur?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

A marginal battery voltage condition is possible. Make sure that the batteries are fully charged.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 351 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 16-Mar-2012


FAULT CODE 352 - Sensor Supply Voltage Number 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and wiring harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 352 active?
STEP 2. | Check the sensors and circuits connected to the sensor number 1 supply and return. |
 | STEP 2A. Inspect the barometric pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. For engines equipped with engine coolant temperature sensors, inspect the engine coolant temperature sensor and circuit connected to the sensor number 1 return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. For engines equipped with oil pressure sensor, inspect the oil pressure sensor and circuit connected to the sensor number 1 return. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2D. For engines equipped with recirculated exhaust gas, inspect the recirculated exhaust gas temperature sensor and circuit connected to the sensor number 1 return. | Dirty or damaged pins?
 | STEP 2D-1. Check the circuit response. |
 | STEP 2E. For engines equipped with variable geometry turbocharger (VGT), inspect the turbocharger position sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2E-1. Check the circuit response. |
 | STEP 2F. For engines equipped with VGT, inspect the turbocharger position sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2F-1. Check the circuit response. |
 | STEP 2G. For engines equipped with original equipment manufacturer (OEM) pressure sensor, inspect the OEM pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2G-1. Check the circuit response. |
 | STEP 2H. For engines equipped with digital vehicle speed sensor, inspect the digital vehicle speed sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2H-1. Check the circuit response. |
 | STEP 2I. For engines equipped with remote accelerator position sensor, inspect the remote accelerator position sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine wiring harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 352 active?
 | STEP 3C. Inspect the vehicle for optional OEM devices. | OEM devices installed?
 | STEP 3D. Inspect the ECM and OEM wiring harness connector pins. | Dirty or damaged pins?
 | STEP 3E. Check the OEM wiring harness for short circuit to ground. | Greater than 100k ohms?
 | STEP 3F. Check the OEM wiring harness for short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 3G. Check for a short circuit in the OEM wiring harness ECM battery (-) circuit. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 352 inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor number 1 supply and return.

Guided Step 2A - Inspect the barometric pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine wiring harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A malfunctioning connection has been detected in the connector or engine wiring harness connector(s).

Repair or replace the damaged pins. Repair or replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

A malfunctiong barometric pressure sensor has been detected.

  • Replace the barometric pressure sensor. Refer to Procedure 019-004 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - For engines equipped with engine coolant temperature sensor, inspect the engine coolant temperature sensor and circuit connected to the sensor number 1 return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine wiring harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A malfunctioning connection has been detected in the connector or engine wiring harness connector(s).

  • Repair or replace the damaged pins. Repair or replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

A malfunctioning engine coolant temperature sensor has been detected.

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - For engines equipped with oil pressure sensor, inspect the oil pressure sensor and circuit connected to the sensor number 1 return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine wiring harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A malfunctioning connection has been detected in the connector or engine wiring harness connector(s).

  • Repair or replace the damaged pins. Repair or replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

A malfunctioning oil pressure sensor has been detected.

  • Replace the oil pressure sensor. Refer to Procedure 019-019 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - For engines equipped with recirculated exhaust gas, inspect the recirculated exhaust gas temperature sensor and circuit connected to the sensor number 1 return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the recirculated exhaust gas temperature sensor from the engine wiring harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A malfunctioning connection has been detected in the connector or engine wiring harness connector(s).

  • Repair or replace the damaged pins. Repair or replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 2D-1

Guided Step 2D-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas recirculation (EGR) temperature sensor from the engine wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

A malfunctioning EGR temperature sensor has been detected.

  • Replace the EGR temperature sensor. Refer to Procedure 019-378 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - For engines equipped with variable geometry turbochargers, inspect the turbocharger speed sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine wiring harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A malfunctioning connection has been detected in the connector or engine wiring harness connector(s).

Repair or replace the damaged pins. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2E-1

Guided Step 2E-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the OEM wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

A malfunctioning turbocharger speed sensor has been detected.

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in Section 19.

Go to 2F

Go to 4A

Guided Step 2F - For engines equipped with variable geometry turbochargers, inspect the turbocharger position sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger position sensor from the engine wiring harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A malfunctioning connection has been detected in the connector or engine wiring harness connector(s).

Repair or replace the damaged pins. Repair or replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2F-1

Guided Step 2F-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger position sensor from the engine wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

A malfunctioning turbocharger position sensor has been detected.

  • Replace the turbocharger position sensor. Refer to Procedure 019-405 in Section 19.

Go to 2G

Go to 4A

Guided Step 2G - For engines equipped with OEM pressure sensor, inspect the OEM pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM pressure sensor from the OEM wiring harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A malfunctioning connection has been detected in the OEM wiring harness connector(s).

  • Repair or replace the OEM wiring harness. See equipment manufacturer service information.
 No Repair

Go to 4A

Go to 2G-1

Guided Step 2G-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM pressure sensor from the OEM wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

A malfunctioning OEM pressure sensor has been detected.

  • Replace the OEM pressure sensor. Refer to Procedure 019-400 in Section 19.

Go to 2G

Go to 4A

Guided Step 2H - For engines equipped with digital vehicle speed sensor, inspect the digital vehicle speed sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the digital vehicle speed sensor from the OEM wiring harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connectons
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A malfunctioning connection has been detected in the OEM wiring harness connector(s).

  • Repair or replace the OEM wiring harness. See equipment manufacturer service information.
 No Repair

Go to 4A

Go to 2H-1

Guided Step 2H-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the digital vehicle speed sensor from the OEM wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

A malfunctioning digital vehicle speed sensor has been detected.

Replace the digital vehicle speed sensor. See equipment manufacturer service information.

Go to 2I

Go to 4A

Guided Step 2I - For engines equipped with remote accelerator position sensor, inspect the remote accelerator position sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator position sensor from the OEM wiring harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A malfunctioning connection has been detected in the ECM connector or OEM wiring harness connector(s).

  • Repair or replace the OEM wiring harness. See equipment manufacturer service information.
 No Repair

Go to 4A

Go to 2I-1

Guided Step 2I-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the remote accelerator position sensor from the OEM wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

A malfunctioning remote accelerator position sensor has been detected.

Replace the remote accelerator position sensor. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A malfunctioning connection has been detected in the ECM connector or engine wiring harness connector(s).

  • Repair or replace the damaged pins. Repair or replace the engine wiring harness. Refer to Procedure 019-071 in Section 19.
  • Replace the OEM harness. See equipment manufacturer service information.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

A short circuit has been detected in the engine wiring harness.

  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the vehicle for optional OEM devices.

Conditions

  • Turn keyswitch OFF.

Action

OEM devices, digital vehicle speed sensor, remote accelerator position sensor, and OEM pressure sensor share a +5 volt supply with sensors on the engine harness.

  • Check the vehicle for a digital vehicle speed sensor, remote accelerator position sensor, or OEM pressure sensor.

Any listed OEM sensors installed?
YES NO
No Repair

Repair

A malfunctioning ECM has been detected.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3D

Repair complete.

Guided Step 3D - Inspect the ECM and OEM wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness from the ECM.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A malfunctioning connection has been detected in the ECM connector or engine wiring harness connector(s).

  • Repair or replace the damaged pins. Repair or replace the engine wiring harness. Refer to Procedure 019-071 in Section 19.
  • Replace the OEM harness. See equipment manufacturer service information.
  • Repair or replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3E

Guided Step 3E - Check the OEM wiring harness for short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness from the ECM.
  • Disconnect the digital vehicle speed sensor from the OEM wiring harness, if equipped.
  • Disconnect the remote accelerator position sensor from the OEM wiring harness, if equipped.
  • Disconnect the OEM pressure sensor from the OEM wiring harness, if equipped.

Action

Check the OEM harness for a short circuit to ground.

  • Measure the resistance between the OEM +5 volt SUPPLY pin at the OEM wiring harness ECM connector and engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short to ground in the OEM wiring harness has been detected.

  • Repair or replace the damaged pins. Repair or replace the engine wiring harness with the damaged pins.

Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check the OEM wiring harness for short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness from the ECM.
  • Disconnect the digital vehicle speed sensor from the OEM wiring harness, if equipped.
  • Disconnect the remote accelerator position sensor from the OEM wiring harness, if equipped.
  • Disconnect the OEM pressure sensor from the OEM wiring harness, if equipped.

Action

Check the OEM harness for a short circuit pin-to-pin.

  • Measure the resistance between the OEM +5 volt SUPPLY pin at the OEM wiring harness ECM connector to all other pins in the connector.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected in the OEM wiring harness.

  • Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

Go to 3G

Go to 4A

Guided Step 3G - Check for a short circuit in the OEM wiring harness ECM battery (-) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM wiring harness from the ECM.
  • Disconnect the engine wiring harness battery supply connector from the ECM.
  • Disconnect the digital vehicle speed sensor from the OEM wiring harness, if equipped.
  • Disconnect the remote accelerator position sensor from the OEM wiring harness, if equipped.
  • Disconnect the OEM pressure sensor from the OEM wiring harness, if equipped.

Action

Measure the resistance between the OEM +5 volt SUPPLY pin in the OEM wiring harness ECM connector and the ECM battery (-) pins in the ECM power connector.

  • Measure the resistance between the OEM +5 volt SUPPLY pin in the OEM wiring harness ECM connector and the ECM battery (-) pins in the ECM power connector.

Greater than 100k ohms?
YES NO

Repair

A malfunctioning ECM has been detected.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

A short circuit has been detected in the wiring harness.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

Repair complete.

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code 352 inactive?
YES NO
No Repair

Repair

  • Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 14-Sep-2018


FAULT CODE 386 - Sensor Supply Voltage number 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 386 active?
STEP 2. | Check the ECM and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 386 active?
STEP 3. | Check the OEM +5-VDC supply. |
 | STEP 3A. Inspect the vehicle for optional OEM devices. | Digital vehicle speed sensor or remote accelerator sensor installed?
 | STEP 3B. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the OEM harness for a short circuit pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check the OEM harness for a short circuit to ECM battery (+). | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 386 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES NO
No Repair

Repair

There is a short in the engine harness causing the sensor +5-VDC supply line to have too high a voltage.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM +5 VDC supply.

Guided Step 3A - Inspect the vehicle for optional OEM devices.

Conditions

  • Turn keyswitch OFF.

Action

OEM devices, digital vehicle speed sensor, and remote accelerator position sensor share a +5-VDC supply with sensors on the engine harness.

  • Check the vehicle for a digital vehicle speed sensor or remote accelerator position sensor.

Digital vehicle speed sensor or remote accelerator sensor installed?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Repair complete

Guided Step 3B - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the OEM harness for short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the digital vehicle speed sensor from the OEM harness (if equipped).
  • Disconnect the remote accelerator position sensor from the OEM harness (if equipped).
  • Disconnect the OEM pressure sensor from the OEM harness (if equipped).

Action

Check the OEM harness for a short circuit pin-to-pin.

  • Measure the resistance between the OEM +5-VDC SUPPLY pin at the OEM harness ECM connector to all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check the OEM harness for short circuit to ECM battery (+).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine harness battery supply connector from the ECM.
  • Disconnect the digital vehicle speed sensor from the OEM harness (if equipped).
  • Disconnect the remote accelerator position sensor from the OEM harness (if equipped).
  • Disconnect the OEM pressure sensor from the OEM harness (if equipped).

Action

Check for a short circuit to ECM battery (+) in the OEM harness.

  • Measure the resistance between the OEM +5-VDC SUPPLY pin at the OEM harness ECM connector to the ECM battery (+) pins at the ECM power connector on the engine harness battery supply.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 386 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


FAULT CODE 387 - Accelerator Pedal or Lever Position Sensor Supply Voltage Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 387 active?
STEP 2. | Check the ECM and OEM harness. |
 | STEP 2A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2B-1. Check for an unswitched battery supply OEM connector. |
 | STEP 2B-2. Check for a pin-to-pin short circuit in the unswitched battery supply OEM harness. |
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 387 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 387 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM and OEM harness.

Guided Step 2A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Short circuit on one connector - pin-to-pin check:

Measure the resistance and check for a short circuit between the +5-VDC SUPPLY pin in the OEM harness ECM connector and all other pins in the connector:

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2B-1

Go to 3A

Guided Step 2B-1 - Check for an unswitched battery supply OEM connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the ECM for a dedicated unswitched battery supply OEM connector.

  • This dedicated connector provides unswitched battery voltage to the ECM and will be in addition to the primary OEM connector.

Dedicated unswitched battery supply OEM connector?
YES | NO
No Repair | No Repair

Go to 2B-2

Go to 3A

Guided Step 2B-2 - Check for a pin-to-pin short circuit in the unswitched battery supply OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.
  • Disconnect the OEM power harness from the ECM.

Action

Short circuit on two connectors - pin-to-pin check:

Measure the resistance and check for a short circuit between the accelerator pedal or lever position +5-VDC SUPPLY pin in the ECM OEM harness connector and the +5-VDC SUPPLY pin in the ECM power harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 387 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3163151 - ECM bench calibration harnessPart Number 3164185 - ECM bench calibration adapter cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check SAE J1587/J1922 communication. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | INSITE™ electronic service tool communicates with ECM?
 | STEP 1B. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1C. Check ECM communication with the ECM bench calibration harness. | INSITE™ electronic service tool communicates with ECM?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 412 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check SAE J1587/J1922 communication.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INLINE™ II data link adapter to the vehicle SAE J1587/J1922 data link diagnostic connector.
  • Connect INSITE™ electronic service tool.

Action

Attempt to communicate with the ECM using INSITE™ electronic service tool.

  • Start INSITE™ electronic service tool and connect to the ECM with an INLINE™ II (J1587/J1922) ECM connection.

INSITE™ electronic service tool communicates with ECM?
YES NO

Repair

The ECM SAE J1587/J1922 data link circuit is functioning properly.

Refer to the OEM troubleshooting and repair manual for information on troubleshooting and vehicle SAE J1587/J1922 network.

 No Repair

Refer to the OEM troubleshooting and repair manual

Go to 1B

Guided Step 1B - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

For general inspection techniques, refer to Component Connector and Pin Inspection, Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connectors, or pins if possible.

Refer to Resistance Measurements Using a Multimeter and Wiring Diagram, Refer to Procedure 019-360.

No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check ECM communication with the ECM bench calibration harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Connect the ECM bench calibration harness to the ECM.
  • Connect INLINE™ II data link adapter.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Attempt to communicate with the ECM using INSITE™ electronic service tool.

  • Start INSITE™ electronic service tool and connect to the ECM with an INLINE™ II (J1587/J1922) ECM connection.

INSITE™ electronic service tool communicates with ECM?
YES NO

Repair

INSITE™ electronic service tool is able to communicate with the ECM. This indicates that the ECM data link circuit is functioning properly.

Refer to the OEM troubleshooting and repair manual for troubleshooting the vehicle SAE J1587/J1922 circuit and devices.

 No Repair

Refer to the OEM troubleshooting and repair manual

Refer to the Communication Error - Electronic Service Tool or Control Device troubleshooting symptom tree.

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool, verify that the fault code is inactive.

Fault Code 412 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool erase the inactive fault codes .

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check fault codes. | Active or inactive counts of Fault Code 415?
STEP 2. | Check engine oil pressure. |
 | STEP 2A. Check engine oil pressure with a mechanical gauge. | Is oil pressure greater than the minimum oil pressure limits?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine running at idle speed.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 415?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete

Guided Step 2 - Check engine oil pressure.

Guided Step 2A - Check engine oil pressure with a mechanical gauge.

Conditions

  • Turn keyswitch OFF.
  • Connect mechanical oil pressure gauge.
  • Turn keyswitch ON.
  • Engine running at idle speed.

Action

Check the engine oil pressure at the following engine speeds:

Engine Speed (rpm) Minimum Oil Pressure (psi)

600 8

1000 20

1600 30

2000 35

2200 32

  • Refer to Procedure 007-052 in the Troubleshooting and Repair Manual, ISC, QSC8.3, ISL, and QSL9 Series Engines, Bulletin 4021418 or Troubleshooting and Repair Manual, ISB Series Engines, Bulletin 3666477.

Is oil pressure greater than the minimum oil pressure limits?
YES | NO
No Repair | No Repair

Repair Complete

Refer to the Lubricating Oil Pressure Low troubleshooting symptom tree

Last Modified: 08-Jul-2010


FAULT CODE 415 - Engine Oil Rifle Pressure - Data Valid but Below Normal Operational Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead, Part Number 3822758 - male Deutsch™/Amp™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch/™Amp™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check fault codes. | Active or inactive counts of Fault Code 415?
STEP 2. | Check engine oil pressure. |
 | STEP 2A. Check engine oil pressure with a mechanical gauge. | Is oil pressure greater than 48 kPa [7 psi]?
STEP 3. | Check the engine harness and ECM. |
 | STEP 3A. Check the supply voltage at the oil pressure connector. | 4.75 to 5.25 VDC?
 | STEP 3B. Check the supply voltage at the ECM. | 4.75 to 5.25 VDC?
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault code. | Fault Code 415 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine running at idle speed.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 415?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete

Guided Step 2 - Check engine oil pressure.

Guided Step 2A - Check engine oil pressure with a mechanical gauge.

Conditions

  • Turn keyswitch OFF.
  • Connect mechanical oil pressure gauge.
  • Turn keyswitch ON.
  • Engine running at idle speed.

Action

Check the engine oil pressure.

  • Refer to OEM service manual.

Is oil pressure greater than 48 kPa [7 psi]?
YES | NO
No Repair | No Repair

Go to 3A

Refer to the Lubricating Oil Pressure Low troubleshooting symptom tree

Guided Step 3 - Check the engine harness and ECM.

Guided Step 3A - Check the supply voltage at the oil pressure connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine oil pressure switch.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the voltage between the engine oil pressure SIGNAL pin at the switch connector of the engine harness and engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75 to 5.25 VDC?
YES NO

Repair

Replace the oil pressure switch. Refer to Procedure 019-142 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the supply voltage at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage at the ECM.

  • Measure the voltage between the engine oil pressure SIGNAL pin at the engine harness ECM connector port and engine block ground.

Refer to the circuit diagram or wiring diagram form connector pin identification.

4.75 to 5.25 VDC?
YES NO

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 415 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps.

Last Modified: 26-Mar-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 418. | Active or inactive counts of Fault Code 418?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 418.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 418.

  • Use INSITE™ electronic service tool, read the fault codes.

Active or inactive counts of Fault Code 418?
YES NO

Repair

Drain the water from the fuel filter.

 No Repair

Repair complete

Repair complete

Last Modified: 08-Jul-2010


FAULT CODE 418 (Marine Application) - Water-in-Fuel Indicator Data Valid but Above Normal Operational Range - Least Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 418 active?
 | STEP 1B. Check for water in fuel/water separator bowl. | Fault Code 418 still active?
STEP 2. | Check the water-in-fuel sensor and circuit. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Within range of 210k - 230k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 418 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 429 active and Fault Code 418 inactive?
 | STEP 3C. Check for an inactive fault code. | Fault Code 418 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 418 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 418 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for water in fuel/water separator bowl.

Conditions

  • Turn keyswitch OFF.

Action

Check for water in fuel/water separator bowl.

  • Drain the water from the fuel filter housing.

Fault Code 418 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the water-in-fuel sensor and circuit.

Guided Step 2A - Inspect the water-in-fuel sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the water-in-fuel sensor.

Action

Inspect the engine harness, and water-in-fuel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken.
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the water-in-fuel sensor from the WIF sensor harness. (Check both in dual WIF configuration.)

Action

Check the sensor resistance.

  • Measure the resistance between the water-in-fuel SIGNAL pin and the water-in-fuel RETURN pin at the water-in-fuel sensor connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Within 210k - 230k ohms?
YES NO

Repair

Any corrosion, damage, or buildup on the probe tips is a sign of contaminated fuel. If there is fuel contamination present, refer to Service Bulletin 3379001 (Fuels for Cummins® Engines) for information on treating this condition. The primary and secondary fuel filters as well as all other water-in-fuel sensors on board must be replaced as well.

Replace the water-in-fuel sensor. Refer to Procedure 019-127 in Section 19.

No Repair

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the water-in-fuel sensor and WIF harness to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4218 is active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 active and Fault Code 418 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 418 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 418 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following service tools when taking a measurement:Part Number 3163151 - ECM Bench Top Calibration Harness Part Number 3164185 - ECM Bench Calibration Adapter Cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the SAE J1939 communication. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Does INSITE™ electronic service tool communicate with the ECM?
 | STEP 1B. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1C. Check ECM communication with the ECM bench calibration harness. | Does INSITE™ electronic service tool communicate with the ECM?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 426 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the SAE J1939 communication.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Connect the INLINE™ II data link adapter to the vehicle SAE J1939 data link diagnostic connector.
  • Connect the INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Attempt to communicate with the ECM use INSITE™ electronic service tool.

  • Start INSITE™ electronic service tool and connect to the ECM use an INLINE™ II (J1939) ECM connection.

Does INSITE™ electronic service tool communicate with the ECM?

YES NO

Repair

The ECM SAE J1939 data link circuit is functioning properly.

Refer to the OEM troubleshooting and repair manual for information on troubleshooting the vehicle SAE J1939 network.

 No Repair

Refer to the OEM troubleshooting and repair manual for information on troubleshooting and vehicle SAE J1939 network

Go to 1B

Guided Step 1B - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connectors for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

For general inspection techniques, refer to Component Connector and Pin Inspection, Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

Repair

Clean the connectors and pins.

Repair the damaged harness, connectors, or pins if possible.

Refer to the Resistance Measurements Using a Multimeter and Wiring Diagram, Refer to Procedure 019-360.

No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check ECM communication with the ECM bench calibration harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Connect the ECM bench calibration harness to the ECM.
  • Connect the INLINE™ II data link adapter.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Attempt to communicate with the ECM using INSITE™ electronic service tool.

  • Start INSITE™ electronic service tool and connect to the ECM with an INLINE™ II (J1939) ECM connection.

Does INSITE™ electronic service tool communicate with the ECM?
YES NO

Repair

INSITE™ electronic service tool is able to communicate with the ECM. This indicates that the ECM data link circuit is functioning properly.

Refer to the OEM troubleshooting and repair manual for information on troubleshooting the vehicle SAE J1939 network.

 No Repair

Refer to the OEM troubleshooting and repair manual

Refer to the Communication Error - Electronic Service Tool or Control Device troubleshooting symptom tree

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify that Fault Code 426 is inactive.

Fault Code 426 inactive?
YES | NO
No Repair | No Repair

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool, erase the inactive fault codes .

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3163151 - ECM bench calibration harnessPart Number 3164185 - ECM bench calibration adapter cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check SAE J1939 communication |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool | Does INSITE™ electronic service tool communicate with the ECM?
 | STEP 1B. Inspect the OEM harness and ECM connector pins | Dirty or damaged pins?
 | STEP 1C. Check ECM communications with the ECM bench calibration harness. | INSITE™ electronic service tool communicates with ECM?
STEP 2. | Clear the fault codes |
 | STEP 2A. Disable the fault code | Fault Code 427 inactive?
 | STEP 2B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Check SAE J1939 communication.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INLINE™ II data link adapter to the vehicle SAE J1939 data link diagnostic connector.
  • Connect INSITE™ electronic service tool.

Action

Attempt to communicate with the ECM using INSITE™.

  • Start INSITE™ electronic service tool and connect to the ECM using an INLINE™ II (J1939) ECM connection.

Does INSITE™ electronic service tool communicate with the ECM?
YES NO

Repair

The ECM SAE J1939 data link circuit is functioning properly.

Refer to the OEM troubleshooting and repair manual for information on troubleshooting the vehicle SAE J1939 network.

 No Repair

Refer to the OEM troubleshooting and repair manual.

Go to 1B

Guided Step 1B - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

For general inspection techniques, refer to Component Connector and Pin Inspection, Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071.

No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check ECM communications with the ECM bench calibration harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Connect the ECM bench calibration harness to the ECM.
  • Connect INLINE™ II data link adapter.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Attempt to communicate with the ECM using INSITE™.

  • Start INSITE™ electronic service tool and connect to the ECM using an INLINE™ II (J1939) ECM connection.

INSITE™ electronic service tool communicates with ECM?
YES NO

Repair

INSITE™ electronic service tool is able to communicate with the ECM. This indicates that the ECM data link circuit is functioning properly.

Refer to the OEM troubleshooting and repair manual for troubleshooting the vehicle SAE J1939 circuit and devices.

 No Repair

Refer to OEM troubleshooting and repair manual.

See the Symptom troubleshooting tree Communication Error - Electronic Service Tool or Control Device.

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Is Fault Code 427 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all the components.
  • Keyswitch "ON".
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Jul-2010


FAULT CODE 428 (Automotive Application) - Water-in-Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 428 active?
STEP 2. | Check the water-in-fuel sensor and circuit. |
 | STEP 2A. Inspect the water-in-fuel sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Greater than 100k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 428 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 429 active and Fault Code 428 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 428 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 428 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the water-in-fuel sensor and circuit.

Guided Step 2A - Inspect the water-in-fuel sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the water-in-fuel sensor.

Action

Inspect the engine harness, and water-in-fuel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken.
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the water-in-fuel SIGNAL pin and the water-in-fuel RETURN pin at the water-in-fuel sensor connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the water-in-fuel sensor. Refer to Procedure 019-127 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the water-in-fuel sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 is active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Place a jumper wire between pin 14 (water-in-fuel sensor SIGNAL pin) and pin 47 (water-in-fuel sensor RETURN pin) at the ECM connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 active and Fault Code 428 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector water-in-fuel sensor RETURN pin and the engine harness water-in-fuel sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the damaged engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector water-in-fuel sensor SIGNAL pin and the engine water-in-fuel sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair or replace the damaged engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the water-in-fuel SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the damaged engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 428 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


FAULT CODE 428 (Marine Application) - Water-in-Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 428 active?
STEP 2. | Check the water-in-fuel sensor and circuit. |
 | STEP 2A. Inspect the water-in-fuel sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Within range of 210k - 230k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 428 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 429 active and Fault Code 428 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 428 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 428 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the water-in-fuel sensor and circuit.

Guided Step 2A - Inspect the water-in-fuel sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the water-in-fuel sensor.

Action

Inspect the engine harness, and water-in-fuel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken.
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the water-in-fuel SIGNAL pin and the water-in-fuel RETURN pin at the water-in-fuel sensor connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Within 210k - 230k ohms?
YES NO
No Repair

Repair

Replace the water-in-fuel sensor. Refer to Procedure 019-127 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the water-in-fuel sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 is active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 active and Fault Code 428 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector water-in-fuel sensor RETURN pin and the engine harness water-in-fuel sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the damaged engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector water-in-fuel sensor SIGNAL pin and the engine water-in-fuel sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair or replace the damaged engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the water-in-fuel SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the damaged engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 428 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 31-May-2013


FAULT CODE 429 (Automotive Application) - Water-in-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 429 active?
STEP 2. | Check the water-in-fuel sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 428 active and Fault Code 429 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 429 is active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness, sensor, and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 428 active and Fault Code 429 inactive?
 | STEP 3C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 429 is inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 429 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the water-in-fuel sensor.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the water-in-fuel sensor.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken.
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the water-in-fuel sensor
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active and Fault Code 429 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the water-in-fuel sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 is active?
YES NO

Repair

A damaged sensor has been detected.

Replace the water-in-fuel sensor. Refer to Procedure 019-127 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness, sensor, and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the engine harness from the water-in-fuel sensor.

Action

Inspect the engine harness, sensor, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active and Fault Code 429 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the water-in-fuel sensor
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the water-in-fuel SIGNAL pin at the ECM connector of the engine harness and all other pins in the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the engine harness.

Repair or replace the damaged engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the water-in-fuel sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the damaged engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 is inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the failure.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 429 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


FAULT CODE 429 (Marine Application) - Water-in-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 429 active?
STEP 2. | Check the water-in-fuel sensor and circuit. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 428 active and Fault Code 429 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 429 is active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness, sensor, and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 428 active and Fault Code 429 inactive?
 | STEP 3C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 429 is inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 429 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the water-in-fuel sensor.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the water-in-fuel sensor.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken.
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the water-in-fuel sensor
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active and Fault Code 429 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF
  • Connect the water-in-fuel sensor to the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 is active?
YES NO

Repair

A damaged sensor has been detected.

Replace the water-in-fuel sensor. Refer to Procedure 019-127 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness, sensor, and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the engine harness from the water-in-fuel sensor.

Action

Inspect the engine harness, sensor, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active and Fault Code 429 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the water-in-fuel sensor
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the water-in-fuel SIGNAL pin at the ECM connector of the engine harness and all other pins in the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the engine harness.

Repair or replace the damaged engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the water-in-fuel sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the damaged engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 is inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 429 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


FAULT CODE 431 (ISS) - Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

WARNING

On Automotive applications, set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ISS. |
 | STEP 1A. Verify the ISS is connected to the OEM harness. | ISS is connected to the OEM harness?
 | STEP 1B. Inspect the ISS and connector pins. | Dirty or damaged pins?
 | STEP 1C. Check the ISS for an open circuit. | Less than 125 ohms?
 | STEP 1D. Check the ISS for a short circuit from pin to pin. | More than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Check the OEM harness for an open circuit. | Greater than 4.0-VDC?
 | STEP 2B. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the OEM harness for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check the OEM harness switch return circuit. | Less than 10 ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2F. Check for a short circuit in the OEM harness ECM battery (+) circuit. | Greater than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 431 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ISS.

Guided Step 1A - Verify the ISS is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the ISS is connected to the harness.

Verify the ISS is connected to the OEM harness.

ISS is connected to the OEM harness?
YES NO
No Repair

Repair

Connect the ISS to the OEM harness. Refer to the OEM service manual.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the ISS connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ISS from the OEM harness.

Action

Inspect the OEM harness and ISS connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 1C

Guided Step 1C - Check the ISS for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ISS from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the idle validation on-idle SIGNAL pin and switch RETURN pin of the ISS connector with the pedal or lever released.
  • Measure the resistance between the idle validation off-idle SIGNAL pin and switch RETURN pin of the ISS connector with the pedal or lever depressed.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 125 ohms?
YES NO
No Repair

Repair

Replace the ISS. Refer to the OEM service manual.

Go to 1D

Go to 3A

Guided Step 1D - Check the ISS for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ISS from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the idle validation on-idle SIGNAL pin and idle validation off-idle SIGNAL pin of the ISS connector with the pedal or lever released and depressed.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the ISS. Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Check the OEM harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ISS from the OEM harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the idle validation on-idle SIGNAL pin in the ISS connector of the OEM harness to the switch RETURN pin in the ISS connector of the OEM harness.
  • Measure the voltage from the idle validation off-idle SIGNAL pin in the ISS connector of the OEM harness to the switch RETURN pin in the ISS connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Greater than 4.0-VDC?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2B

Guided Step 2B - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the OEM harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the ISS from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance of the idle validation on-idle SIGNAL wire in the OEM harness between the ECM connector and the ISS connector.
  • Measure the resistance of the idle validation off-idle SIGNAL wire in the OEM harness between the ECM connector and the ISS connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the OEM harness switch return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the ISS from the OEM harness.

Action

Check for an open switch return circuit.

  • Measure the resistance of the switch RETURN wire in the OEM harness between the ECM connector and the ISS connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the ISS from the OEM harness.

Action

Check for an open switch return circuit.

Measure the resistance and check for a short circuit between the following OEM harness ECM connector pins and all other pins in the connector:

  • Idle validation on-idle SIGNAL pin
  • Idle validation off-idle SIGNAL pin

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check for a short circuit in the OEM harness ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the ISS from the OEM harness.
  • Disconnect the OEM power harness connector from the ECM.

Action

Short circuit on two connectors - pin-to-pin check.

  • Measure the resistance between the idle validation on-idle SIGNAL pin in the OEM harness ECM connector and the ECM battery (+) pins in the ECM power connector.
  • Measure the resistance between the idle validation off-idle SIGNAL pin in the OEM harness ECM connector and the ECM battery (+) pins in the ECM power connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair complete

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch ON and completely depress and release the accelerator pedal or lever three times.
  • Use INSITE™ electronic service tool to verify that Fault Code 431 is inactive.

Fault Code 431 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Service Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair Complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


FAULT CODE 431 (NISS) - Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

WARNING

On Automotive applications, set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the NISS. |
 | STEP 1A. Verify the NISS is connected to the OEM harness. | NISS is connected to the OEM harness?
 | STEP 1B. Inspect the NISS and connector pins. | Dirty or damaged pins?
 | STEP 1C. Check the NISS for an open circuit. | Less than 10 ohms?
 | STEP 1D. Check the NISS for a short circuit from pin to pin. | More than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Check the OEM harness for an open circuit. | Greater than 4.0-VDC?
 | STEP 2B. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the OEM harness for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check the OEM harness switch return circuit. | Less than 10 ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2F. Check for a short circuit in the OEM harness ECM battery (+) circuit. | Greater than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 431 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the NISS.

Guided Step 1A - Verify the NISS is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the NISS is connected to the OEM harness.

–

NISS is connected to the OEM harness?
YES NO
No Repair

Repair

Connect the NISS to the OEM harness. Refer to the OEM service manual.

Go to 1B

Go to 3A

Guided Step 1B - Inspect the NISS and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the NISS from the OEM harness.

Action

Inspect the connector pins for the following:Inspect the OEM harness and NISS connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 1C

Guided Step 1C - Check the NISS for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the NISS from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the idle validation on-idle SIGNAL pin and switch RETURN pin of the NISS connector with the pedal or lever released.
  • Measure the resistance between the idle validation off-idle SIGNAL pin and switch RETURN pin of the NISS connector with the pedal or lever depressed.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Replace the NISS. Refer to the OEM service manual.

Go to 1D

Repair Complete

Guided Step 1D - Check the NISS for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the NISS from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the idle validation on-idle SIGNAL pin and idle validation off-idle SIGNAL pin of the NISS connector with the pedal or lever released and depressed.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the NISS. Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Check the OEM harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the NISS from the OEM harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the idle validation on-idle SIGNAL pin in the NISS connector of the OEM harness to the switch RETURN pin in the NISS connector of the OEM harness.
  • Measure the voltage from the idle validation off-idle SIGNAL pin in the NISS connector of the OEM harness to the switch RETURN pin in the NISS connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Greater than 4.0-VDC?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2B

Guided Step 2B - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the OEM harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the NISS from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance of the idle validation on-idle SIGNAL wire in the OEM harness between the ECM connector and the NISS connector.
  • Measure the resistance of the idle validation off-idle SIGNAL wire in the OEM harness between the ECM connector and the NISS connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the OEM harness switch return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the NISS from the OEM harness.

Action

Check for an open switch return circuit.

  • Measure the resistance of the OEM harness switch RETURN wire in the OEM harness between the ECM connector and the NISS connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the NISS from the OEM harness.

Action

Short circuit on one connector - pin to pin check:

Measure the resistance and check for a short circuit between the following OEM harness ECM connector pins and all other pins in the connector:

  • Idle validation on-idle SIGNAL pin
  • Idle validation off-idle SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check for a short circuit in the OEM harness ECM battery (+) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the NISS from the OEM harness.
  • Disconnect the OEM power harness connector from the ECM.

Action

Short circuit on two connectors - pin-to-pin check:

  • Measure the resistance between the idle validation on-idle SIGNAL pin in the OEM harness ECM connector and the ECM battery (+) pins in the ECM power connector.
  • Measure the resistance between the idle validation off-idle SIGNAL pin in the OEM harness ECM connector and the ECM battery (+) pins in the ECM power connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair complete

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch ON and completely depress and release the accelerator pedal or lever three times.
  • Use INSITE™ electronic service tool to verify that Fault Code 431 is inactive.

Fault Code 431 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair Complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


FAULT CODE 431 (SSS) - Accelerator Pedal or Lever Idle Validation Circuit - Data Erratic, Intermittent or Incorrect

Associated Procedures

Cautions and Warnings

WARNING

On Automotive applications, set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the SSS. |
 | STEP 1A. Verify the SSS is connected to the OEM harness. | SSS is connected to the OEM harness?
 | STEP 1B. Inspect the SSS connector pins. | Dirty or damaged pins?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Check the OEM harness for an open circuit. | Greater than 4.0 VDC?
 | STEP 2B. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the OEM harness for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check the OEM harness switch return circuit. | Less than 10 ohms?
 | STEP 2E. Check for a pin to pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2F. Check for a short circuit in the OEM harness ECM battery (+) circuit. | Greater than 100k ohms?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 431 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the SSS.

Guided Step 1A - Verify the SSS is connected to the OEM harness.

Conditions

  • Turn keyswitch OFF.

Action

Verify the SSS is connected to the harness.

Verify the SSS is connected to the OEM harness.

SSS is connected to the OEM harness?
YES NO
No Repair

Repair

Connect the SSS to the OEM harness. Refer to the OEM troubleshooting and repair manual

Go to 1B

Go to 3A

Guided Step 1B - Inspect the SSS connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SSS from the OEM harness.

Action

Inspect the OEM harness and the SSS connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Check the OEM harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SSS from the OEM harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the idle validation on-idle SIGNAL pin in the SSS connector of the OEM harness to the switch RETURN pin in the SSS connector of the OEM harness.
  • Measure the voltage from the idle validation off-idle SIGNAL pin in the SSS connector of the OEM harness to the switch RETURN pin in the SSS connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Greater than 4.0 VDC?
YES | NO
No Repair | No Repair

Go to 2E

Go to 2B

Guided Step 2B - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19..

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the OEM harness for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SSS from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance of the idle validation on-idle SIGNAL wire in the OEM harness between the ECM connector and the SSS connector.
  • Measure the resistance of the idle validation off-idle SIGNAL wire in the OEM harness between the ECM connector and the SSS connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the OEM harness return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SSS from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance of the switch RETURN wire in the OEM harness between the ECM connector and the SSS connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SSS from the OEM harness.

Action

Short circuit on one connector pin to pin check:

Measure the resistance and check for a short circuit between the following OEM harness ECM connector pins and all other pins in the connector:

  • Idle validation on-idle SIGNAL pin
  • Idle validation off-idle SIGNAL pin

Refer to the wiring diagram for connector pin identifications.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check for a short circuit in the OEM harness ECM battery (+) circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SSS from the OEM harness.
  • Disconnect the OEM power harness connector from the ECM.

Action

Short circuit on two connectors pin to pin check:

  • Measure the resistance between the idle validation on-idle SIGNAL pin in the OEM ECM connector and the ECM battery (+) pins in the ECM power connector.
  • Measure the resistance between the idle validation off-idle SIGNAL pin in the OEM ECM connector and the ECM battery (+) pins in the ECM power connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the SSS. Refer to the OEM service manual.

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch ON and completely depress and release the accelerator pedal or lever three times.
  • Turn the keyswitch OFF for 30 seconds.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 431 is inactive.

Fault Code 431 inactive?
YES NO
No Repair

Repair

Return to the troublleshooting steps or contact a local Cummins® Authorized Reapir Location if all steps have been completed and checked a second time.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair Complete

Appropriate troubleshooting steps

Last Modified: 26-Mar-2012


FAULT CODE 432 - Accelerator Pedal or Lever Idle Validation Circuit - Out of Calibration

Associated Procedures

Cautions and Warnings

WARNING

For Automotive applications, set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 432 active?
STEP 2. | Check the fault codes. |
 | STEP 2A. Perform the fault code disable procedure. | Fault Code 432 active?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the accelerator pedal or lever position sensor resistance. | 1500 to 3000 Ohms (released) 250 to 1500 Ohms (depressed)?
 | STEP 3B-1. Check the resistance of the accelerator pedal or lever position sensor. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 432 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 432 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fault codes.

Guided Step 2A - Perform the fault code disable procedure.

Conditions

  • Turn keyswitch ON.
  • All components connected.

Action

Perform the fault code disable procedure.

  • Slowly depress the accelerator pedal or lever to the full throttle position and release it completely three times.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 432 active?
YES NO
No Repair

Repair

Replace the accelerator pedal or lever assembly. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the accelerator pedal or lever position sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Measure the resistance between the accelerator pedal or lever position SIGNAL pin and accelerator pedal or lever position +5 volt SUPPLY pin at the ECM connector of the OEM harness.

Refer to the wiring diagram for connector pin for identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

1500 to 3000 Ohms (released) [250 to 1500 Ohms (depressed)]?

Released value must be at least 1000 ohms greater than depressed value.

YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Check the resistance of the accelerator pedal or lever position sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Measure the resistance between the accelerator pedal or lever position SIGNAL pin and accelerator pedal or lever position +5 volt SUPPLY pin at the accelerator pedal or lever position sensor connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

1500 to 3000 Ohms (released) [250 to 1500 Ohms (depressed)]?

Released value must be at least 1000 ohms greater than depressed value.

YES NO

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair

Replace the accelerator pedal or lever assembly. Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Short circuit on one connector pin-to-pin check:

Measure the resistance and check for a short circuit between the following OEM harness ECM connector pins and all other pins in the OEM harness ECM connector:

  • Accelerator pedal or lever position +5 VDC SUPPLY pin
  • Accelerator pedal or lever position SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch ON and completely depress and release the accelerator pedal or lever three times.
  • Turn the keyswitch OFF for 30 seconds.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 432 is inactive.

Fault Code 432 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked a second time.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 26-Mar-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine speed and position fault codes. |
 | STEP 1A. Check for Fault Codes 689 and 778. | Fault Codes 689 and 778 active?
STEP 2. | Check for a valid fault code. |
 | STEP 2A. Check for an active Fault Code 433. | Fault Code 433 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 433 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for engine speed and position fault codes.

Guided Step 1A - Check for Fault Codes 689 and 778.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™, electronic service tool read the fault codes.

Fault Codes 689 and 778 active?
YES NO

Repair

Follow the troubleshooting trees of the appropriate fault code.

 No Repair

Fault Code 689 and/or 778

Go to 2A

Guided Step 2 - Check for a valid fault code.

Guided Step 2A - Check for an active Fault Code 433.

Conditions

  • Turn keyswitch OFF.

Action

Check for a valid fault code.

  • Wait 30 seconds.
  • Turn keyswitch ON; wait 15 seconds.

Fault Code 433 inactive?
YES NO
No Repair

Repair

Replace the intake manifold pressure sensor.

Refer to Procedure 019-061.

Go to 3B

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify Fault Code 433 is inactive.

Fault Code 433 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault code.

  • Use INSITE™ electronic service tool erase the inactive fault codes .

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Jul-2010


FAULT CODE 434 Automotive Application - Power Supply Lost With Ignition On - Data Erratic, Intermittent or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 434 active?
STEP 2. | Check the batteries and the power connector. |
 | STEP 2A. Check the batteries and the power connector. | Connections tight and corrosion-free?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least (+) 12-VDC [(+) 24-VDC with 24 volt system]; During Cranking: At least (+) 6.2-VDC?
 | STEP 2C. Inspect the injector wiring harness. | Injector wiring harness pigtail wiring routed correctly and aligned properly so that rocker levers do not touch wiring?
STEP 3. | Check the OEM power harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the battery power circuit. | At least (+) 10-VDC [(+) 20-VDC for a 24 volt system]?
 | STEP 3B-1. Verify that the OEM fuse is installed correctly. |
 | STEP 3B-2. Check if the OEM fuse is blown. |
 | STEP 3B-3. Check the add-on or accessory wiring at the (+) terminal of the battery. |
 | STEP 3C. Check the resistance of the battery supply circuit. | Less than 1.0 ohms?
 | STEP 3D. Check the keyswitch input-to-ECM wire. | Keyswitch input wire interrupted?
 | STEP 3E. Check the keyswitch input circuit. | Less than 5 ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 434 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 434 active?
YES NO
No Repair

Repair

If high inactive counts of Fault Code 434 are found in the ECM, check the battery disconnect devices in the vehicle. If the keyswitch and ECM power are disconnected at the same time, Fault Code 434 will be logged.

Go to 2A

Go to 4A

Guided Step 2 - Check the batteries and the power connector.

Guided Step 2A - Check the batteries and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Repair

Tighten the connections.

Tighten the loose connections, and clean the terminals. Refer to the OEM service manual.

Go to 2B

Go to 4A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal and touch the negative (-) probe to the negative battery terminal while trying to start the engine.

Normal conditions: At least (+) 12-VDC [(+) 24-VDC with 24 volt system]; During Cranking: At least (+) 6.2-VDC?
YES NO
No Repair

Repair

Charge or replace the battery. Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the injector wiring harness.

Conditions

  • Remove the rocker lever housing.

Action

This fault code can be caused by the injector pigtail wiring rubbing against the rocker levers under the rocker lever cover.

–

Is the injector wiring pigtail wiring correctly routed and aligned properly so that the rocker levers do not touch the wiring?

YES NO
No Repair

Repair

Align and route the injector wiring harness so it does not touch the rocker levers.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM power harness.

Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM power harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM battery supply stub from the ECM.

Action

Check for an open circuit in the battery power circuits.

  • Use a multimeter to measure the voltage from the ECM battery SUPPLY (+) pin of the engine harness ECM battery supply stub connector and engine block ground.

Refer to the wiring diagram for connector pin identification.

At least (+) 10-VDC [(+) 20-VDC for a 24 volt system]?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Verify that the OEM fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the OEM fuse for correct installation.

–

Is fuse installed correctly?
YES NO
No Repair

Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check if the OEM fuse is blown.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the OEM fuse is not blown.

–

Is fuse blown?
YES NO

Repair

Locate the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Replace the blown fuse(s). Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3B-3

Guided Step 3B-3 - Check the add-on or the accessory wiring at the (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the (+) terminal of the battery.

  • Starting at the (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Any damaged wires?
YES NO

Repair

Repair or replace the damaged wiring.

Repair

Repair or replace the OEM power harness from the OEM power connector to the batteries.

Go to 4A

Go to 4A

Guided Step 3C - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM battery supply stub from the ECM.
  • Disconnect the positive terminal from the battery.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the engine harness ECM battery supply stub connector and the positive battery connector.
  • Measure the resistance between the ECM battery SUPPLY (-) pin of the engine harness ECM battery supply stub connector and the negative battery connector.

Refer to the wiring diagram for connector pin identification.

Note: Since the battery supply circuit resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the circuit resistance.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1.0 ohms?
YES NO
No Repair

Repair

Repair or replace the ECM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check the keyswitch input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the keyswitch input wire from the keyswitch ignition post in the keyswitch assembly to the ECM to make sure there are no interruptions in the wire, that is, no solenoids or relays.

–

Keyswitch input wire interrupted?
YES NO

Repair

Correct the wiring so the wire is uninterrupted.

 No Repair

Go to 4A

Go to 3E

Guided Step 3E - Check the keyswitch input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM

Action

Check the keyswitch input circuit.

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine, and let it idle for 1 minute.
  • Turn the keyswitch to the OFF position for 30 seconds.
  • Turn the keyswitch ON.
  • Use INSITE™ electronic service tool to verify Fault Code 434 is inactive.

Note: For Fault Code 434 to become inactive, the ECM must go through one complete shutdown.

Fault Code 434 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 18-Apr-2012


FAULT CODE 435 - Oil Pressure Switch Sensor Circuit - Data Erratic, Intermittent or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 382278 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 435 active?
STEP 2. | Check the engine oil pressure switch and circuit. |
 | STEP 2A. Inspect the switch and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the engine oil pressure switch. | Less than 10 ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 435 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 435 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1 - Check for an active fault code.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool, read the fault codes.

Fault Code 435 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine oil pressure switch and circuit.

Guided Step 2A - Inspect the switch and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine oil pressure switch.

Action

Inspect the switch and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the engine oil pressure switch.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine oil pressure switch.

Action

Check the resistance of the switch.

  • Measure the resistance between the engine oil pressure SIGNAL pin of the engine oil pressure switch and ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine oil pressure switch. Refer to Procedure 019-066 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine oil pressure switch.

Action

Check for an open circuit.

  • Measure the resistance between the engine oil pressure SIGNAL pin at the switch connector of the engine harness and the engine oil pressure SIGNAL pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the engine oil pressure switch.

Action

Check for a pin-to-pin short circuit in the engine harness.

  • Measure the resistance and check for a short circuit between the engine oil pressure SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector:

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool, read the fault codes.

Fault Code 435 is inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the problem.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Turn the keyswitch to the ON position for one minute.
  • Use INSITE™ electronic service tool , verify that the fault code is inactive.

Fault Code 435 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes..

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


FAULT CODE 436 - Intake Manifold 1 Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 436 is active?
 | STEP 1B. Check for fault codes 153 and 154. | Fault Codes 153 or 154 is active?
STEP 2. | Check the engine intake manifold temperature sensor and circuit. |
 | STEP 2A. Inspect the engine intake manifold temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active?
 | STEP 2C. Check the circuit response. | Fault Code 154 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 153 active?
 | STEP 3C. Check the circuit response. | Fault Code 154 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the repair | Intake manifold temperature and catalyst inlet temperature reading within 5.6°C or 10°F of each other?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault codes.

  • Use INSITE™ to read the fault codes.

Fault Code 436 is active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for fault codes 153 and 154.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault codes.

  • Use INSITE™ to read the fault codes.

Fault Code 153 or 154 is active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the engine intake manifold temperature sensor and circuit.

Guided Step 2A - Inspect the engine intake manifold temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold temperature sensor from the engine harness.

Action

Inspect the engine harness and engine intake manifold temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Note: Fault code 123 will also be active when the intake manifold temperature sensor is disconnected.

Fault Code 153 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold temperature RETURN pin and the intake manifold temperature SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 154 is active?
YES NO

Repair

An in-range failure of the intake manifold temperature sensor has been detected.

Replace the engine intake manifold temperature sensor. Refer to Procedure Procedure 019-059 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 153 is active?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold temperature RETURN pin and the intake manifold temperature SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 154 is active?
YES NO

Repair

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the INSITE Data Monitor/Logger .

  • Compare the INSITE™ reading for Intake Manifold Temperature and Catalyst Inlet Temperature.

Intake Manifold Temperature and Catalyst Inlet Temperature reading within 5.6°C or 10°F of each other?
YES | NO
No Repair | No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete.

Go to
Repair complete.
Go to

Last Modified: 05-Dec-2016


FAULT CODE 441 - Battery 1 Voltage - Data Valid but Below Normal Operational Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the battery. |
 | STEP 1A. Check the battery connections. | Connections tight and corrosion-free?
 | STEP 1B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
STEP 2. | Check the fuse. |
 | STEP 2A. Verify that the fuse is installed correctly. | Fuse installed correctly?
 | STEP 2B. Check for a blown fuse. | Fuse blown?
STEP 3. | Check the OEM power harness. |
 | STEP 3A. Inspect the OEM power harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the power harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3F. Check the add-on or the accessory wiring at the positive (+) terminal of the battery. | Damaged wires?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 441 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the battery.

Guided Step 1A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.

Connections tight and corrosion-free?
YES NO
No Repair

Repair

Tighten the loose connections, and clean the terminals.

Refer to the OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start engine.

Normal conditions:

  • At least 12-VDC (12-VDC systems)
  • At least 24-VDC (24-VDC systems).

Cranking conditions:

  • At least 6.2-VDC (12-VDC systems)
  • At least 12-VDC (24-VDC systems).

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Repair

Charge or replace the battery.

Refer to the OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the fuse.

Guided Step 2A - Verify that the fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the 30-amp fuse is installed correctly.

  • Inspect the 30-amp fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a blown fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check for a blown fuse.

  • Inspect the 30-amp fuse to see if it is blown.

Fuse blown?
YES NO

Repair

Replace the fuse. Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM power harness.

Guided Step 3A - Inspect the OEM power harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM.

Action

Inspect the power harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connectors, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance from the positive (+) battery terminal post to all ECM battery SUPPLY (+) pins, one at a time, in the OEM power harness ECM connector.
  • Measure the resistance from the negative (-) battery terminal post to all ECM battery SUPPLY (-) pins, one at a time, in the OEM power harness ECM connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the power harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM.
  • Disconnect the battery.

Action

Check for a short circuit in the power harness.

  • Measure the resistance from the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to the ECM battery SUPPLY (-) pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance from the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the battery.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from one of the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to all pins in the OEM harness ECM connector.
  • Measure the resistance from the second ECM battery SUPPLY (+) pin in the OEM power harness ECM connector to all pins in the OEM harness ECM connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring, and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Damaged wires?
YES NO

Repair

Repair or replace the damaged wires.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 441 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 18-Apr-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 442 inactive
STEP 2. | Check the equipment battery system. |
 | STEP 2A. Check the battery voltage. | Less than 20 VDC for 12-VDC system. Less than 32 VDC for 24-VDC system
 | STEP 2B. Check the alternator. | Alternator charging within OEM specifications?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 442 inactive
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect the INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 442 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3B

Guided Step 2 - Check the equipment battery system.

Guided Step 2A - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all aftermarket devices from the battery supply circuit.
  • Disconnect the OEM power harness connector from the ECM.

Action

Check the battery voltage.

  • Measure the battery voltage from one of the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to engine block ground.
  • Repeat above step for the second ECM battery SUPPLY (+) pin in the OEM power harness ECM connector.

Less than 20 VDC for 12-VDC system and less than 32 VDC for 24-VDC system?
YES NO
No Repair

Repair

Install the battery system correctly. Refer to the equipment manufacturer's troubleshooting and repair manual.

Go to 2B

Go to 3A

Guided Step 2B - Check the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use an OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the alternator.

  • Start the engine and check the alternator charging rate (amps).

NOTE: Place a load on the batteries, if necessary, to measure the alternator output properly.

Alternator charging within OEM specifications?
YES NO
No Repair

Repair

Repair or replace the alternator, regulator, and/or the OEM wiring to the alternator.

Refer to the OEM troubleshooting and repair manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • UseINSITE™ electronic service tool to verify Fault Code 442 is inactive.

Fault Code 442 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool erase the inactive fault code.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 08-Jul-2010


FAULT CODE 443 - Accelerator Pedal or Lever Position Sensor Supply Voltage Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 443 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the accelerator pedal or lever position sensor and circuit connected to the sensor supply and return | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 443 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3B-1. Check for a pin short circuit to ground in the OEM harness. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 443 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 443 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the accelerator pedal or lever position sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 443 active?
YES NO
No Repair

Repair

Replace the accelerator pedal or lever position sensor. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit on one connector.

Measure the resistance and check for a short circuit between the following OEM harness ECM connector pin and all other pins in the connector:

  • Accelerator pedal or lever position +5-VDC SUPPLY pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for a pin short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Short circuit on one connector - pin to ground check:

Measure the resistance and check for a short circuit between the following OEM harness ECM connector pin and ground:

  • Accelerator pedal or lever position +5-VDC SUPPLY pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 443 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes .

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 26-Apr-2012


FAULT CODE 449 - Injector Metering Rail Number 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 271, 272, or 2311 inactive?
STEP 2. | Check the rail fuel pressure sensor. |
 | STEP 2A. Verify that the rail fuel pressure sensor reads inrange. | Pressure = 0 ±40 bar?
STEP 3. | Check the operation of the low-pressure fuel system. |
 | STEP 3A. Check for air in fuel. | Air present?
 | STEP 3B. Check for excessive lift pump fuel pressure. | Less than 20 psi?
STEP 4. | Check for fuel return drain line restriction. |
 | STEP 4A. Check the fuel return drain line for excessive restriction. | Less than 2.7 psi?
STEP 5. | Check for damage to the fuel rail pressure relief valve. |
 | STEP 5A. Check for leakage from the fuel rail pressure relief valve. | Fuel return within specification?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault codes inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the electronic fuel control actuator shorted low or high.

Fault Code 271, 272, or 2311 inactive?
YES NO
No Repair

Repair

Troubleshoot applicable fault codes for electronic fuel control actuator.

Go to 2A

Applicable Fault Code 271, 272, or 2311

Guided Step 2 - Check the rail fuel pressure sensor.

Guided Step 2A - Verify that the rail fuel pressure sensor reads inrange.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to read the rail fuel pressure.

Pressure = 0 ±40 bar?
YES NO
No Repair

Repair

Replace the sensor or repair the engine harness.

  • Refer to Procedure 019-115 in Section 19.
  • Refer to Procedure 019-360 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check the operation of the low-pressure fuel system.

Guided Step 3A - Check for air in fuel.

Conditions

  • Connect a test hose at the fuel filter head inlet and run hose into a bucket.
  • Turn keyswitch ON.

Action

Check for air in fuel as lift pump runs.

  • Perform the air-in-fuel test. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-003 in Section 6.

Air present?
YES NO

Repair

Repair the cause of the air in the fuel.

Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-003 in Section 6.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for excessive lift pump fuel pressure.

Conditions

  • Connect a test hose at the fuel filter head inlet and run hose into a bucket.
  • Turn keyswitch ON.

Action

Check for excessive lift pump fuel pressure.

  • Install a pressure gauge at the outlet port of the fuel filter head using an MI0 Compuchek™ fitting, Part Number 3824842.
  • Start the engine and let it idle.
  • Measure the pressure at the fuel filter head outlet.

Less than 20 psi?
YES NO
No Repair

Repair

The internal pressure regulator has failed.

Replace the electric fuel lift pump.

Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 005-045 in Section 5.

Go to 5A

Go to 6A

Guided Step 4 - Check for fuel return drain line restriction.

Guided Step 4A - Check the fuel return drain line for excessive restriction.

Conditions

  • Install a pressure gauge in the fuel return line banjo bolt at the high-pressure fuel pump drain manifold.
  • Turn keyswitch ON.

Action

Check the fuel return drain line for excessive restriction.

  • Operate the engine at high idle speed.
  • Measure the fuel return drain line restriction.
  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-012 in Section 6.

Less than 2.7 psi?
YES NO

Repair

Replace the electronic fuel control valve. Refer to Procedure 019-102 in Section 19.

Repair

Repair or replace the fuel return drain line.

Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-013 in Section 6.

Go to 5A

Go to 5A

Guided Step 5 - Check for damage to the fuel rail pressure relief valve.

Guided Step 5A - Check for leakage from the fuel pressure relief valve.

Conditions

  • Turn keyswitch OFF.
  • Install test fittings to measure the fuel return from the fuel rail pressure relief valve.

Action

Check for leakage from the fuel rail pressure relief valve.

NOTE: Excessive fuel rail pressure can possibly cause damage to the fuel rail pressure relief valve.

  • Install test fittings to measure the fuel return.
  • Follow the test outlined in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-061 in Section 6.

Fuel return within specification?
YES NO

Repair

Replace the high-pressure fuel pump.

Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 005-016 in Section 5.

Repair

Replace the fuel rail pressure relief valve.

Use the following procedure in the ISBe, ISB, and QSB (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-061 in Section 6.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify that fault codes are inactive.

Fault codes inactive?
YES | NO
No Repair | No Repair

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool, to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-Sep-2018


FAULT CODE 449 - Injector Metering Rail Number 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Are Fault Code(s) 271, 272, 2311, or 1117 active or high inactive counts?
STEP 2. | Check for air in the fuel. |
 | STEP 2A. Check for air in fuel. | Air in the fuel?
STEP 3. | Check the low pressure fuel system. |
 | STEP 3A. Measure the gear pump pressure at the outlet of the pressure side fuel filter. | Is gear pump pressure low?
 | STEP 3B. Measure the pressure at the inlet to the pressure side fuel filter. | Is filter restriction high?
 | STEP 3C. Measure the inlet restriction at the gear pump inlet. | Is the gear pump inlet restriction to high?
 | STEP 3D. Measure the inlet restriction at the OEM connection point. | Is OEM inlet restriction to high?
 | STEP 3E. Check for a restriction at the OEM connection point. | Debris or damage?
STEP 4. | Check the rail fuel pressure sensor. |
 | STEP 4A. Verify the rail fuel pressure sensor reads in-range. | Is the pressure 0 ± 40 bar [0 ± 580 psi]?
 | STEP 4B. Inspect the fuel pressure sensor signal wire and connector pins. | Dirty or damaged pins?
STEP 5. | Check customer complaints. |
 | STEP 5A. Check customer complaints. | Does the engine start and stall or surge at idle?
STEP 6. | Check the fuel pump actuator. |
 | STEP 6A. Check the fuel pump actuator and harness connector pins. | Dirty or damaged pins?
 | STEP 6B. Inspect the fuel pump actuator for damage. | Are the o-rings on the fuel pump actuator damaged?
 | STEP 6C. Monitor the fuel rail pressure at idle. | Does measured fuel rail pressure deviate more than 200 bar [2901 psi] and surge at idle?
STEP 7. | Check the ECM to ground strap. |
 | STEP 7A. Inspect the ECM to ground strap. | Is the ECM to ground strap missing or have the connections degraded?
STEP 8. | Clear the fault codes. |
 | STEP 8A. Disable the fault code. | Fault codes inactive?
 | STEP 8B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the fuel pump actuator shorted low or high.

Are Fault Code(s) 271, 272, 2311, or 1117 active or high inactive counts?
YES | NO
No Repair | No Repair

Appropriate Troubleshooting Tree

Go to 2A

Guided Step 2 - Check for air in the fuel.

Guided Step 2A - Check for air in the fuel.

Conditions

  • Turn keyswitch ON.

Action

Check for air in the fuel.

Air in the fuel?
YES NO

Repair

Air detected

Correct the source of the air leak. Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe4, and QSL9 Engines Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-003 in Section 6.

No Repair

Appropriate Troubleshooting Tree

Go to 3A

Guided Step 3 - Check the low pressure fuel system.

Guided Step 3A - Measure the gear pump pressure at the outlet of the pressure side fuel filter.

Conditions

  • Turn keyswitch OFF.
  • Connect the diagnostic fittings.
  • Turn keyswitch ON.

Action

Measure the pressure at the outlet of the pressure side fuel filter.

  • Install a T-fitting at the outlet of the pressure side fuel filter.
  • Install a diagnostic fuel line at the T-fitting with an orifice of 0.109 cm [0.043 in].
  • Install a 0 to 1379 kPa [0 to 200 psi] pressure gauge at the T-fitting.
  • Start the engine.
  • Measure gear pump pressure at high idle.

Minimum gear pump pressure at high idle engine speed 483 kPa [70 psi].

Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4, and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 005-025 in Setion 5.

Is gear pump pressure low?
YES | NO
No Repair | No Repair

Go to 3B

Go to 4A

Guided Step 3B - Measure the pressure at the inlet to the pressure side fuel filter.

Conditions

  • Turn keyswitch OFF.
  • Connect the diagnostic fittings.
  • Turn keyswitch ON.

Action

Measure the pressure at the inlet to the pressure side fuel filter.

  • Install a T-fitting at the outlet of the pressure side fuel filter.
  • Install a diagnostic fuel line at the T-fitting with an orifice of 0.109 cm [0.043 in]. Run the output of this fuel line into a collection device or the vehicle's fuel tank.
  • Install a 0 to 1379 kPa [0 to 200 psi] pressure gauge at the T-fitting.
  • Install a 0 to 1379 kPa [0 to 200 psi] pressure gauge at the inlet of the pressure side fuel filter.
  • Start the engine.
  • Measure gear pump pressure at high idle.

Maximum fuel filter pressure drop 138 kPa [20 psi].

Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4, and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 005-025 in Section 5.

Is filter restriction high?
YES NO

Repair

The fuel filter is plugged.

Replace the pressure side fuel filter.

Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe4, and QSL9 Engines Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-015 in Section 6.

No Repair

Go to 8A

Go to 3C

Guided Step 3C - Measure the inlet restriction at the gear pump inlet.

Conditions

  • Turn keyswitch OFF.
  • Connect the diagnostic fittings.
  • Turn keyswitch ON.

Action

Measure the inlet resriction.

  • Install a diagnostic fitting at the inlet to the fuel gear pump.
  • Install a 0 to 762 mm-Hg [0 to 30 in-Hg] vacuum gauge at the inlet to the gear pump.
  • Install a M10 standard thread o-ring diagnostic fitting at the pressure side fuel filter outlet port.
  • Operate the engine at high idle no load and measure the restriction at the inlet to the gear pump.

If the engine will not start or the engine starts and stalls, be sure the fuel is primed to the gear pump. This test is only valid if the engine is running.

Maximum gear pump inlet restriction 254 mm-Hg [10 in-Hg].

Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe4, and QSL9 Engines Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-020 in Section 6.

Is the gear pump inlet restriction too high?
YES NO
No Repair

Repair

Replace the gear pump.

Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe4, and QSL9 Engines Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 005-025 in Section 5.

Go to 3D

Go to 8A

Guided Step 3D - Measure the inlet restriction at the OEM connection point.

Conditions

  • Turn keyswitch OFF.
  • Connect the diagnostic fittings.
  • Turn keyswitch ON.

Action

Measure the inlet restriction.

  • Install a 0 to 762 mm-Hg [0 to 30 in-Hg] vacuum gauge at the OEM connection point.
  • Install a M10 standard thread o-ring diagnostic fitting at the pressure side fuel filter outlet port.
  • Install a diagnostic fitting at the pressure side outlet port with an orifice of 0.109 cm [0.043 in].
  • Operate the engine at high idle no load and measure the restriction at the inlet to the gear pump.

If the engine will not start or the engine starts and stalls, be sure the fuel is primed to the gear pump. This test is only valid if the engine is running.

Maximum OEM inlet restriction 203 mm-Hg [8 in-Hg].

Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe4, and QSL9 Engines Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-020 in Section 6.

Is OEM inlet restriction too high?
YES NO

Repair

A fuel restriction exists upstream of the OEM connection point.

Refer to the OEM service manual.

 No Repair

Appropriate Troubleshooting Manual

Go to 3E

Guided Step 3E - Check for a restriction at the OEM connection point.

Action

Inspect the ECM cooling plate and check valve.

Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe4, and QSL9 Engines Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-006 in Section 6.

Debris or damage?
YES NO

Repair

Clean or replace the ECM cooling plate.

Clean or replace the check valve.

 No Repair

Go to 8A

Go to 4A

Guided Step 4 - Check the rail fuel pressure sensor.

Guided Step 4A - Verify the rail fuel pressure sensor reads in-range.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Verify the sensor reads in-range.

Is the pressure 0 ± 40 bar [ 0 ± 580 psi]?
YES NO
No Repair

Repair

The fuel pressure sensor is incorrectly reading a fuel pressure.

Replace the rail fuel pressure sensor.

Refer to Procedure 019-115 in Section 19.

Go to 4B

Go to 8A

Guided Step 4B - Inspect the fuel pressure sensor signal wire and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect ECM from engine harness

Action

Inspect the fuel pressure sensor signal wire and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 8A

Go to 5A

Guided Step 5 - Check customer complaints.

Guided Step 5A - Check customer complaints.

Action

Interview the customer or driver.

–

Does the engine start and stall or surge at idle?
YES | NO
No Repair | No Repair

Go to 6A

Go to 7A

Guided Step 6 - Check the fuel pump actuator.

Guided Step 6A - Check the fuel pump actuator and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the fuel pump actuator, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the connector and pins. Repair the damaged harness, connectors, or pins. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 8A

Go to 6B

Guided Step 6B - Inspect the fuel pump actuator for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the fuel pump actuator.

Action

Inspect the fuel pump actuator o-rings for damage.

Are the o-rings on the fuel pump actuator damaged?
YES NO

Repair

Replace the fuel pump actuator o-rings. Refer to Procedure 019-117 in Section 19.

No Repair

Go to 8A

Go to 6C

Guided Step 6C - Monitor the fuel rail pressure at idle.

Conditions

  • Connect INSITE™ electronic service tool.
  • Start the engine.

Action

Run the engine at idle for at least one minute to purge air induced from previous steps.

  • Use INSITE™ electronic service tool, to monitor commanded fuel rail pressure and measured fuel rail pressure.

Does measured fuel rail pressure deviate more than 200 bar [2901 psi] and surge at idle?

YES NO

Repair

Replace the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

No Repair

Go to 8A

Go to 7A

Guided Step 7 - Check the ECM to ground strap.

Guided Step 7A - Inspect the ECM to ground strap.

Conditions

  • Turn keyswitch OFF.

Action

Run the engine at idle for at least one minute to purge air induced from previous steps.

  • Check the ground from the ECM to the block. Refer to Procedure 019-008 in Section 19.
  • Check ground connections from block to battery (-) negative.

Is the ECM to ground strap missing or have the connections degraded?
YES NO

Repair

Repair missing or degraded ground connections.

Repair

Contact a Cummins® Authorized Repair Location.

Go to 8A

Go to 8A

Guided Step 8 - Clear the fault codes.

Guided Step 8A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault codes are inactive.

Fault codes inactive?
YES | NO
No Repair | No Repair

Go to 8B

Go to 1A

Guided Step 8B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-Sep-2018


FAULT CODE 451 - Injector Metering Rail Number 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164111 - male Bosch™ test lead, Part Number 3164110 - female Bosch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 451 inactive?
STEP 2. | Check the rail fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the rail fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 452 active and Fault Code 451 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 451 active?
STEP 3. | Check the engine control module and engine harness. |
 | STEP 3A. Inspect the engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the engine control module response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 451 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor and circuit.

Guided Step 2A - Inspect the rail fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and rail fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the rail fuel pressure RETURN pin and the rail fuel pressure SIGNAL pin at the rail fuel pressure sensor connector of the engine harness.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram for connector pin identification.

Fault Code 452 active and Fault Code 451 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the rail fuel pressure +5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75_VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the rail fuel pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 is active?
YES NO

Repair

A damaged sensor has been detected.

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module and engine harness.

Guided Step 3A - Inspect the engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the engine control module response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the rail fuel pressure RETURN pin and the rail fuel pressure SIGNAL pin at the ECM engine connector.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram for connector pin identification.

Fault Code 452 active and Fault Code 451 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the rail fuel pressure +5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the ECM engine harness connector.

Refer to the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 451 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 16-Nov-2015


FAULT CODE 452 - Injector Metering Rail Number 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164111 - male Bosch™ test lead, Part Number 3164110 - female Bosch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 452 is inactive?
STEP 2. | Check the rail fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the rail fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 451 active and Fault Code 452 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 452 is active?
STEP 3. | Check the engine control module and engine harness. |
 | STEP 3A. Inspect engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the engine control module response. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 452 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic serive tool to read the fault codes.

Fault Code 452 is inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor and circuit.

Guided Step 2A - Inspect the rail fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and rail fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the rail fuel pressure +5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active and Fault Code 452 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the rail fuel pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 is active?
YES NO

Repair

A damaged sensor has been detected.

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module and engine harness.

Guided Step 3A - Inspect engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect theengine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the rail fuel pressure +5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the ECM engine connector.

Refer to the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the failure.

Repair

An open or shorted SUPPLY circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the engine control module response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active and Fault Code 452 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the failure.

Repair

An open return circuit or a pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 452 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes | Fault Code 471 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault codes. | Fault Code 471 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Engine oil temperature near ambient temperature.
  • Make sure the vehicle is parked on level ground.

Action

Read the fault codes.

  • Use INSITE™ to read the fault codes.

Fault Code 471 active?
YES NO

Repair

Low engine lubricating oil level has been detected.

Add engine lubricating oil to the engine.

007-037.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes

Guided Step 2A - Disable the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute
  • Using INSITE™, verify that the fault code is inactive.

Is fault 471 inactive?
YES | NO
No Repair | No Repair

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Clear the inactive fault codes.

  • Erase the inactive fault codes using INSITE™.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 08-Jul-2010


Intake Manifold 1 Temperature - Data Valid but Above Normal Operational Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Drive Belt, Cooling Fan | Refer to Procedure 008-002 | ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) | 4021271
Coolant Thermostat | Refer to Procedure 008-013 | ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) | 4021271
Fan Clutch, On-Off | Refer to Procedure 008-027 | ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) | 4021271
Charge-Air Cooler (CAC) | Refer to Procedure 010-027 | ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) | 4021271
Air Intake Restriction | Refer to Procedure 010-031 | ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) | 4021271
Engine Control Module Calibration Code | Refer to Procedure 019-032 | ISB, ISBe2, ISBe3, ISBe4, QSB4.5, QSB5.9, QSB6.7, ISC, QSC8.3, ISL, ISLe3, ISLe4, and QSL9 CM850 (CM2850) | 4021416
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | ISB, ISBe2, ISBe3, ISBe4, QSB4.5, QSB5.9, QSB6.7, ISC, QSC8.3, ISL, ISLe3, ISLe4, and QSL9 CM850 (CM2850) | 4021416

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Cooling fan component inspection. |
 | STEP 1A. Cooling fan component inspection. | Damage found?
STEP 2. | High intake manifold temperature basic checks. |
 | STEP 2A. High intake manifold temperature basic checks. | Damage found?
STEP 3. | Radiator is externally obstructed. |
 | STEP 3A. Radiator is externally obstructed. | Damage found?
STEP 4. | Intake manifold temperature sensor struck in-range. |
 | STEP 4A. Intake manifold temperature sensor struck in-range. | Sensor reading within +/- 10°C [18°F]?
STEP 5. | Thermostat is malfunctioning. |
 | STEP 5A. Thermostat is malfunctioning. | Damage noted or thermostat does not open at the correct temperature?
 | STEP 5B. Out-of-chassis opening temperature test. | Damage noted or thermostat does not open at the correct temperature?
STEP 6. | Fan clutch operates incorrectly. |
 | STEP 6A. Fan clutch operates incorrectly. | Fan engages at the correct engine temperature?
STEP 7. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Cooling fan component inspection.

Guided Step 1A - Cooling fan component inspection.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the following components if applicable:

  • Visually inspect the cooling fan and cooling fan blades.
  • Visually inspect the cooling fan shroud.
  • Visually inspect the recirculation baffles.
  • Inspect the cooling fan belt. Refer to Procedure 008-002 in the Associated Procedures Table.
  • Visually inspect the cooling fan hub assembly.
  • Visually inspect the automatic cooling fan belt tensioner.

Damage found?

YES NO

Repair

Repair or replace only the components that were found to be out of specification.

  • Adjust, repair, or replace the component preventing correct cooling fan operation. Refer to OEM Service Manual.
 No Repair

Go to 7A

Go to 2A

Guided Step 2 - High intake manifold temperature basic checks.

Guided Step 2A - High intake manifold temperature basic checks.

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the air filter to make sure it is not plugged. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Inspect the charge-air cooler for damage or debris blocking the air flow. Refer to Procedure 010-027 in the Associated Procedures Table.
  • Inspect the air conditioner condenser. Refer to OEM Service Manual.
  • Visually inspect the radiator fins for damage or debris blocking the air flow.

Damage found?
YES NO

Repair

  • Repair or replace the malfunctioning components.
No Repair

Go to 7A

Go to 3A

Guided Step 3 - Radiator is externally obstructed.

Guided Step 3A - Radiator is externally obstructed.

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the radiator for damage.
  • Visually inspect the radiator for any type of external obstruction.
  • Check for closed cold weather radiator cover or winterfront.

Damage found?
YES NO

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the restricted radiator. Refer to OEM Service Manual.
  • Remove the obstruction. Refer to OEM Service Manual.
  • Repair or replace cold weather radiator cover or winterfront. Refer to OEM Service Manual.
 No Repair

Go to 7A

Go to 4A

Guided Step 4 - Intake manifold temperature sensor stuck in-range.

Guided Step 4A - Intake manifold temperature sensor stuck in-range.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the intake manifold temperature sensor reading to an infrared thermometer or a known value.

Sensor reading within +/- 10°C [18°F]?

YES NO

Repair

Repair or replace only the components that were found to be out of specification.

Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Thermostat is malfunctioning.

Guided Step 5A - Thermostat is malfunctioning.

Conditions

  • Engine running.

Action

  • Allow the engine to reach operating temperature.
  • Check the thermostat opening temperature with an infrared temperature gun.
  • Check the coolant thermostat for proper operation. Refer to Procedure 008-013 in the Associated Procedures Table.
  • Check for a damaged or leaking thermostat seal. Refer to Procedure 008-013 in the Associated Procedures Table.
  • If a temperature gun is not available or if the temperature gun reading is above the correct thermostat opening temperature, then proceed to Linked Solutions section.

Damage noted or thermostat does not open at the correct temperature?

YES NO

Repair

  • Replace the engine coolant thermostat. Refer to Procedure 008-013 in the Associated Procedures Table.
 No Repair

Go to 7A

Go to 5B

Guided Step 5B - . Out-of-chassis opening temperature test.

Conditions

  • Turn keyswitch OFF.

Action

  • Perform the out-of-chassis opening temperature test. Refer to Procedure 008-013 in the Associated Procedures Table.

Damage noted or thermostat does not open at the correct temperature? Damage or thermostat seal leak found?

YES NO

Repair

  • Replace the engine coolant thermostat. Refer to Procedure 008-013 in the Associated Procedures Table.
 No Repair

Go to 7A

Go to 6A

Guided Step 6 - Fan clutch operates incorrectly.

Guided Step 6A - Fan clutch operates incorrectly.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.

Ensure the following adjustable parameters are set correctly for the application:

  • Fan Control Logic.
  • Fan Control Switch.
  • Air Conditioner Pressure Switch Input.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Fan Override Test.
  • Verify that the fan operates correctly.
  • Verify the fan is engaging at the correct engine temperature. Refer to Procedure 008-027 in the Associated Procedures Table. Refer to OEM Service Manual.

Fan engages at the correct engine temperature?

YES NO
No Repair

Repair

Adjust, repair, or replace the component preventing correct cooling fan operation. Refer to Procedure 008-027 in the Associated Procedures Table. Refer to OEM Service Manual.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the Cummins® electronic service tool or equivalent to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?

YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?

YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 20-Apr-2022


FAULT CODE 497 - Multiple Unit Synchronization Switch - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 497 is inactive?
STEP 2. | Check the OEM switch circuit. |
 | STEP 2A. Inspect the OEM switch. | Dirty or damaged pins?
 | STEP 2B. Check the OEM switch. | Is the multi-unit synchronization switch and the multi-unit synchronization complementary switch operating correctly?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100K ohms?
 | STEP 3D. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 497 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 497 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 497 is inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the OEM switch circuit.

Guided Step 2A - Inspect the OEM switch.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the multi-unit synchronization switch from the OEM harness.
  • Disconnect the multi-unit synchronization complementary switch fro the OEM harness.

Action

Inspect the multi-unit synchronization switch, multi-unit synchronization complementary switch, and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the switch or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the OEM switch.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the multi-unit synchronization switch from the OEM harness.
  • Disconnect the multi-unit synchronization complementary switch from the harness.

Action

Check the functionality of the multi-unit synchronization switch and the multi-unit synchronization complementary switch.

Use the following procedure for troubleshooting information for the multi-unit synchronization switch. Refer to Procedure 019-270 in Section 19.

Is the multi-unit synchronization switch and the multi-unit synchronization complementary switch operating correctly?
YES NO
No Repair

Repair

Replace the multi-unit synchronization switch or the multi-unit synchronization complementary switch. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the multi-unit synchronization switch from the harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the multi-unit synchronization switch pin in the OEM harness ECM connector and all other pins in the OEM connector.
  • Measure the resistance between the multi-unit synchronization complimentary switch pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-pin short has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from ECM.
  • Disconnect the multi-unit synchronization switch from the OEM harness.
  • Disconnect the multi-unit synchronization complimentary switch from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the multi-unit synchronization switch pin in the OEM harness ECM connector and ground.
  • Measure the resistance between the multi-unit synchronization complementary switch pin in the OEM harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the multi-unit synchronization complimentary switch from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the OEM harness ECM connector multi-unit synchronization switch pin and the OEM harness multi-unit synchronization switch pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detectd in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool, read the fault codes.

Fault Code 497 inactive?
YES NO

Repair

None. The removal and reinstallation of the connector corrected the fault.

Repair

Refer to OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool and verify that the fault code is inactive.

Fault Code 497 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Cleqar the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 21-Apr-2012


FAULT CODE 498 - Engine Oil Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 498 inactive?
STEP 2. | Check the oil level sensor. |
 | STEP 2A. Inspect the oil level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the oil level sensor. | Damage found to the oil level sensor body or connector?
 | STEP 2C. Check the fault codes. | Fault Code 498 active?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 498 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 498 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil level sensor.

Guided Step 2A - Inspect the oil level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil level

Action

Inspect the engine harness and oil level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the oil level sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil level sensor from the engine harness.
  • Remove the engine oil level sensor. Refer to Procedure 019-056 in Section 19.

Action

Visually inspect the lubricating oil level sensor for damage to the wiring or body.

  • Inspect the o-rings for damage.

Damage found to the oil level sensor body or connector?
YES NO

Repair

Replace the oil level sensor. Refer to Procedure 019-056 in Section 19.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 498 active?
YES NO

Repair

Replace the oil level sensor. Refer to Procedure 019-056 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 498 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 01-May-2012


FAULT CODE 499 - Engine Oil Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 499 inactive?
STEP 2. | Check the oil level sensor. |
 | STEP 2A. Inspect the oil level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the oil level sensor. | Damage found to the oil level sensor body or connector?
 | STEP 2C. Check the voltage to the engine oil level sensor. | Voltage is equal to battery voltage?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the engine oil level sensor voltage at the ECM |
 | STEP 3A-2. Check the battery supply voltage to the ECM |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check for an open in the engine harness. |
 | STEP 3B-2. Check for a short circuit in the engine harness. |
 | STEP 3B-3. Check for a short circuit to ground in the engine harness. |
 | STEP 3B-4. Check the fault codes. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 499 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 499 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil level sensor.

Guided Step 2A - Inspect the oil level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil level

Action

Inspect the engine harness and oil level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the oil level sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil level sensor from the engine harness.
  • Remove the engine oil level sensor. Refer to Procedure 019-056 in Section 19.

Action

Visually inspect the lubricating oil level sensor for damage to the wiring or body.

  • Inspect the o-rings for damage.

Damage found to the oil level sensor body or connector?
YES NO

Repair

Replace the oil level sensor. Refer to Procedure 019-056 in Section 19.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the voltage to the engine oil level sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil level sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the engine oil sensor.

  • Measure the voltage between engine oil level supply circuit and the engine oil level return circuit at the engine harness connector of the oil level sensor.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Voltage is equal to battery voltage?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the engine oil level sensor voltage at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the engine oil level sensor.

  • Measure the voltage between engine oil level sensor power supply circuit and engine oil level sensor return circuit at the ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Voltage is greater than or equal to battery voltage?
YES NO

Repair

An open circuit in the engine oil level sensor power supply or return circuit has been detected in the engine harness.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-2

Guided Step 3A-2 - Check the battery supply voltage to the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the ECM.

  • Measure the voltage between the ECM power supply circuit and the ECM return circuit at the OEM power harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Voltage is equal to battery voltage?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Low voltage has been detected at the ECM power connector.

Check the battery voltage and the OEM wiring between the battery and ECM power harness connector.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check for an open in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil level sensor from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the engine oil level sensor signal wire at the engine oil level sensor engine harness connector and the engine oil level sensor signal wire at the ECM engine harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the engine harness.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil level sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the engine oil level sensor wire at the ECM engine harness connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-3

Go to 4A

Guided Step 3B-3 - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil level sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit to ground in the engine harness.

  • Measure the resistance between the engine oil level sensor wire at the ECM engine harness connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3B-4

Go to 4A

Guided Step 3B-4 - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness to the ECM.
  • Connect the engine oil level sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool read the fault codes.

Fault code 499 is active?
YES NO

Repair

The engine oil level sensor is shorted internally.

Replace the engine oil level sensor. Refer to Procedure 019-056 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 499 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 01-May-2012


FAULT CODE 523 - Auxiliary Intermediate Power Take-Off (PTO) Speed Switch Validation - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 523 is inactive?
STEP 2. | Check the original equipment manufacturer (OEM) switch circuit. |
 | STEP 2A. Inspect the OEM switch. | Dirty or damaged pins?
 | STEP 2B. Check the intermediate speed control switch 1. | Intermediate speed control switch 1 is operating correctly?
 | STEP 2C. Check the intermediate speed control validation switch. | Intermediate speed control validation switch operating correctly?
STEP 3. | Check the engine control module (ECM) and OEM harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100K ohms?
 | STEP 3D. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 523 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 523 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use electronic service tool to read the fault codes.

Fault Code 523 is inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the OEM switch circuit.

Guided Step 2A - Inspect the OEM switch.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intermediate speed control switch 1 from the OEM harness.
  • Disconnect the intermediate speed control validation switch from the OEM harness.

Action

Inspect the intermediate speed control switch 1, intermediate speed control validation switch, and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the switch or harness connector.

Clean the connector and pins.

Repair the damage harness, connector or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the intermediate speed control switch 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intermediate speed control switch 1 for the OEM harness.

Action

Check the functionality of the intermediate speed control switch.

Use the following procedure for troubleshooting information for the intermediate speed control switch. Refer to Procedure 019-107 in Section 19.

Intermediate speed control switch 1 is operating correctly?
YES NO
No Repair

Repair

Replace the intermediate speed control switch. Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the intermediate speed control validation switch.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intermediate speed control validation switch from the OEM harness.

Action

Check the functionality of the intermediate speed control validation switch.

Use the following procedure for troubleshooting information for the intermediate speed control switch. Refer to Procedure 019-107 in Section 19.

Intermediate speed control switch 1 is operating correctly?
YES NO
No Repair

Repair

Replace the intermediate speed control switch. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the intermediate speed control switch 1 from the OEM harness.
  • Disconnect the intermediate speed control validation switch from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intermediate speed control switch 1 pin in the OEM harness ECM connector and all other pins in the OEM connector.
  • Measure the resistance between the intermediate speed control validation switch pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the intermediate speed control switch 1 from the OEM harness.
  • Disconnect the intermediate speed control validation switch from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the intermediate speed control switch 1 pin in the OEM harness ECM connector and ground.
  • Measure the resistance between the intermediated speed control validation switch pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3D - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the intermediate speed control switch 1 from the OEM harness.
  • Disconnect the intermediate speed control validation switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector intermediate speed control switch 1 pin and the OEM harness intermediate speed control switch 1 pin.
  • Measure the resistance between the OEM harness ECM connector intermediated speed control validation pin and the OEM harness intermediated speed control validation switch pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Engine specific condition/action text.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 523 inactive?
YES NO

Repair

None. The removal and reinstallation of the connector corrected the fault.

Repair

Refer to OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 523 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool .

Action

Clear the inactive fault code.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 11-Sep-2013


FAULT CODE 527 - Auxiliary Input/Output 2 Circuit Voltage Above Normal or Shorted to High Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an inactive fault code. | Fault Code 527 is inactive?
STEP 2. | Check the OEM output control solenoid and circuit. |
 | STEP 2A. Inspect the OEM output control solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the OEM output control solenoid. | Less than 100 ohms?
 | STEP 2C. Check the OEM output control solenoid diagnostic supply voltage, supply line and return circuit. | Greater the 3.75-VDC?
 | STEP 2D. Check for an open circuit in the OEM output control solenoid circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM output control signal circuit. | Less than 10 ohms?
 | STEP 3C. Check for a pin to pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 527 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 527 Inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 527 is inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the OEM output control solenoid and circuit.

Guided Step 2A - Inspect the OEM output control solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM output control solenoid from the OEM harness.

Action

Inspect the OEM output control harness and OEM output control solenoid connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the OEM output control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM output control solenoid from the OEM harness.

Action

Check OEM output control solenoid resistance.

  • Measure the resistance between the OEM output control solenoid SIGNAL pin and the OEM output control solenoid RETURN pin at the OEM output control solenoid connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Less than 100 ohms?
YES NO
No Repair

Repair

An open circuit in the OEM output control solenoid has been detected.

Replace the OEM output control solenoid Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the OEM output control solenoid diagnostic supply voltage, supply line and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM output control solenoid from the OEM harness.
  • Turn keyswitch ON.

Action

Check the OEM output control solenoid diagnostic supply voltage and retrun circuit.

  • Measure the voltage between the OEM output control solenoid SIGNAL pin and the OEM output control solenoid RETURN pin at the OEM output control solenoid connector of the OEM harness.

Greater than 3.75-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the OEM output control solenoid circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM output control solenoid from the OEM output control harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM output control solenoid RETURN pin in the engine harness and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit on the RETURN wire has been detected. Refer to the OEM circuit diagram or wiring diagram for RETURN wire configuration.

If the RETURN is wired to the ECM, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the failed connection.

Clean, repair, or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the OEM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM output control signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM output control solenoid from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM OEM output control solenoid SIGNAL pin and the OEM harness OEM output control solenoid connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohm?
YES NO
No Repair

Repair

An open OEM control output solenoid SIGNAL circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM output control solenoid from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM output control solenoid SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the OEM output control solenoid SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 527 inactive?
YES NO

Repair

None. The removal and reinstallation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 527 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 01-May-2012


FAULT CODE 528 - Auxiliary Alternate Torque Validation Switch - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 528 is inactive?
STEP 2. | Check the OEM switch circuit. |
 | STEP 2A. Inspect the OEM switch. | Dirty or damaged pins?
 | STEP 2B. Check the OEM switch. | Alternate torque switch operating correctly?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100K ohms?
 | STEP 3D. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 528 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 528 inactive?
 | STEP 3B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 528 is inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the OEM switch circuit.

Guided Step 2A - Inspect the OEM switch.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Alternate Torque Switch from the OEM harness.

Action

Inspect the Alternater Torque Switch and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the switch or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the OEM switch.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the Alternate Torque Switch from the OEM harness.

Action

Check the functionality of the Alternate Torque Switch.

Use the following procedure for troubleshooting information for the alternate torque switch. Refer to Procedure 019-136 in Section 19.

Alternate torque switch operating correctly?
YES NO
No Repair

Repair

Replace the alternate torque switch. Refer to OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF,
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damage pins?
YES NO

Repair

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness connector or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the alternate torque switch from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Measure the resistance between the alternate torque switch pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the alternate torque switch circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from ECM.
  • Disconnect the alternate torque switch from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the alternate torque switch pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the alternate torque switch from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector alternate torque switch pin and the OEM harness alternate torque switch pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 528 inactive?
YES NO

Repair

None. The removal and reinstallation of the connector corrected the fault.

Repair

Refer to OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 528 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 21-Apr-2012


FAULT CODE 529 - Auxiliary Input/Output 3 Circuit - Voltage Above Normal, or Shorted to High Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 529 inactive?
STEP 2. | Check the OEM output control solenoid and circuit. |
 | STEP 2A. Inspect the OEM output control solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the OEM output control solenoid. | Less than 100 ohms?
 | STEP 2C. Check the OEM output control solenoid diagnostic supply voltage, supply line and return circuit. | Greater than 3.75-VDC?
 | STEP 2D. Check for an open circuit in the OEM output control solenoid circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM output control signal circuit. | Less than 10 ohms?
 | STEP 3C. Check for a pin to pin short circuit in the OEM harness. | Greater than 100K ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 529 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 529 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool.

Fault Code 529 is inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the OEM output control solenoid and circuit.

Guided Step 2A - Inspect the OEM output control solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM output control solenoid from the OEM harness.

Action

Inspect the OEM output control solenoid and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the OEM output control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM output control solenoid from the OEM harness.

Action

Check OEM output control solenoid resistance.

  • Measure the resistance between the OEM output control solenoid SIGNAL pin and the OEM output control solenoid RETURN pin at the OEM output control solenoid connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 100 ohms?
YES NO
No Repair

Repair

An open circuit in the OEM output control solenoid has been detected.

Replace the OEM output control solenoid. Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the OEM output control solenoid diagnostic supply voltage, supply line and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM output control solenoid from the OEM harness.
  • Turn keyswitch ON.

Action

Check the OEM output control solenoid diagnostic supply voltage and return circuit.

  • Measure the voltage between the OEM output control solenoid SIGNAL pin and the OEM output control solenoid RETURN pin at the OEM output control solenoid connector of the OEM harness.

Greater than 3.75-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the OEM output control solenoid circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM output control solenoid from the OEM output control harness.

Action

Check the OEM output control solenoid diagnostic supply voltage and return circuit.

  • Measure the resistance between the OEM output control solenoid RETURN pin in the engine harness and ground.

Refer to the circuit diagram or the wiring diagram for the connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit on the RETURN wire has been detected. Refer to the OEM wiring diagram for RETURN wire configuration.

IF the RETURN is wired to the ECM, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the failed connection.

Clean, repair, or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM output control signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM output control solenoid from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM OEM output control solenoid SIGNAL pin and the OEM harness OEM output control solenoid connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open OEM control output solenoid SIGNAL circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM output control solenoid from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM output control solenoid SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the OEM output control solenoid SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 529 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the problem.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 529 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clar the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault cleared?
YES | NO
No Repair | No Repair

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 01-May-2012


FAULT CODE 545 - Turbocharger 1 Wastegate Control - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy with INSITE™ electronic service tool. | Value of intake manifold pressure is less than 203 mm Hg [8 in Hg]?
 | STEP 1B. Verify the sensor accuracy with a mechanical gauge. | Sensor reading is correct within 127 mm Hg [5 in Hg]?
 | STEP 1C. Check the system for tampering. | Tampering detected?
 | STEP 1D. Check the turbocharger wastegate operation. | Turbocharger wastegate operating properly?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault codes. | Fault code 545 inactive?
 | STEP 2B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify sensor accuracy with INSITE™ electronic service tool.

  • Monitor the intake manifold pressure with INSITE™ electronic service tool with the keyswitch on and the engine not running.

Value of the intake manifold pressure is less than 203 mm Hg [8 in Hg]?
YES NO
No Repair

Repair

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 1B

Repair Complete.

Guided Step 1B - Verify the sensor accuracy with a mechanical gauge.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine.

Action

Verify the sensor accuracy with a mechanical gauge.

  • Connect a mechanical intake manifold pressure gauge to the engine
  • Using INSITE™ electronic service tool read the fault codes
  • Start the engine, and compare the intake manifold pressure reading on the service tool monitor screen to the reading on the mechanical intake manifold pressure gauge.

Note: The engine may need to be loaded before the pressure readings can be compared.

Sensor reading is within 127 mm Hg [5 in Hg]?
YES NO
No Repair

Repair

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 1C

Go to 2A

Guided Step 1C - Check the system for tampering.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger and fuel system fior the following:

  • Turbocharger wastegate tampering
  • Variable geometry turbocharger tampering
  • Fuel system tampering
  • Fuel system add-on electronic devices.

Tampering detected?
YES NO

Repair

Remove the tampering device.

 No Repair

Go to 2A

Go to 1D

Guided Step 1D - Check the turbocharger wastegate operation.

Conditions

  • Turn keyswitch OFF.

Action

Check the wastegate actuator for proper operation.

  • For ISB and QSB engines, use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 010-050 in Section 10.
  • For ISC, QSC, ISL, and QSL engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 010-050 in Section 10.

Turbocharger wastegate operating properly?
YES NO
No Repair

Repair

Replace the turbocharger wastegate actuator.

  • For ISB and QSB engines, use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 010-050 in Section 10.
  • For ISC, QSC, ISL, and QSL engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 010-050 in Section 10.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault code 545 inactive?
YES | NO
No Repair | No Repair

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Apr-2012


FAULT CODE 551 (ISS) - Accelerator Pedal or Lever Idle Validation Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

WARNING

On Automotive applications, set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ISS. |
 | STEP 1A. Inspect the ISS and connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the ISS for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Check the OEM harness for a short circuit to ground. | Greater than 4.0-VDC?
 | STEP 2A-1. Inspect the OEM harness and ECM connector pins. |
 | STEP 2A-2. Check the OEM harness for a short circuit to return. |
 | STEP 2A-3. Check the OEM harness for a short circuit to ground. |
 | STEP 2A-4. Check for a pin-to-pin short circuit in the OEM harness. |
 | STEP 2A-5. Check the ECM voltage. |
 | STEP 2B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 551 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ISS.

Guided Step 1A - Inspect the ISS from the connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ISS from the OEM harness.

Action

Inspect the OEM harness and ISS connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the ISS for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ISS from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the idle validation on-idle SIGNAL pin and idle validation off-idle SIGNAL pin at the switch connector with the pedal or lever released and depressed.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the ISS switch. Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Check the OEM harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ISS from the OEM harness.
  • Turn keyswitch ON.

Action

Check for a short circuit to ground.

  • Measure the voltage from the idle validation on-idle SIGNAL pin in the ISS connector of the OEM harness to the switch RETURN pin in the ISS connector of the OEM harness.
  • Measure the voltage from the idle validation off-idle SIGNAL pin in the ISS connector of the OEM harness to the switch RETURN pin in the ISS connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Greater than 4.0-VDC?
YES | NO
No Repair | No Repair

Go to 2B

Go to 2A-1

Guided Step 2A-1 - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, of pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2A-2

Guided Step 2A-2 - Check the OEM harness for a short circuit to return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ISS from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to return.

  • Measure the resistance from the idle validation on-idle SIGNAL pin in the ISS connector of the OEM harness to the switch RETURN pin in the ISS connector of the OEM harness.
  • Measure the resistance from the idle validation off-idle SIGNAL pin in the ISS connector of the OEM harness to the switch RETURN pin in the ISS connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A-3

Go to 3A

Guided Step 2A-3 - Check the OEM harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the ISS from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance between the idle validation on-idle SIGNAL pin at the ISS connector of the OEM harness and engine block ground.
  • Measure the resistance between the idle validation off-idle SIGNAL pin at the ISS connector of the OEM harness and engine block ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A-4

Go to 3A

Guided Step 2A-4 - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the ISS from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the idle validation on-idle SIGNAL pin at the ECM connector of the OEM harness and all other pins in the connector.
  • Measure the resistance between the idle validation off-idle SIGNAL pin at the ECM connector of the OEM harness and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A-5

Go to 3A

Guided Step 2A-5 - Check the ECM voltage.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness to the ECM.
  • Disconnect the ISS from the OEM harness.
  • Turn keyswitch ON.

Action

Check the ECM voltage.

  • Measure the voltage between the idle validation on-idle SIGNAL pin in the ISS connector of the OEM harness to the switch RETURN pin in the ISS connector of the OEM harness.
  • Measure the voltage between the idle validation off-idle SIGNAL pin in the ISS connector of the OEM harness to the switch RETURN pin in the ISS connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Greater than 4.0-VDC?
YES NO

Repair

Replace the ISS. Refer to the OEM service manual.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Repair complete

Guided Step 2B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the ISS from the OEM harness.

Action

Check for a short circuit from pin to pin in the OEM harness.

  • Measure the resistance and check for a short circuit between the idle validation on-idle SIGNAL pin and all other pins in the OEM harness ECM connector.
  • Measure the resistance and check for a short circuit between the idle validation off-idle SIGNAL pin and all other pins in the OEM harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the ISS. Refer to the OEM service manual.

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch ON and completely depress and release the accelerator pedal or lever three times.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 551 code is inactive.

Fault Code 551 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service to erase the fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair Complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


FAULT CODE 551 (NISS) - Accelerator Pedal or Lever Idle Validation Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

WARNING

On Automotive applications, set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the NISS. |
 | STEP 1A. Inspect the NISS and harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the NISS for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Check the OEM harness for a short circuit to ground. | Greater than 4.0-VDC?
 | STEP 2A-1. Inspect the OEM harness and ECM connector pins. |
 | STEP 2A-2. Check the OEM harness for a short circuit to return. |
 | STEP 2A-3. Check the OEM harness for a short circuit to ground. |
 | STEP 2A-4. Check for a pin-to-pin short circuit in the OEM harness. |
 | STEP 2A-5. Check the ECM voltage. |
 | STEP 2B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 551 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the NISS.

Guided Step 1A - Inspect the NISS and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the NISS from the OEM harness.

Action

Inspect the OEM harness and NISS from the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the NISS for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the NISS from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the idle validation on-idle SIGNAL pin and the idle validation off-idle SIGNAL pin at the switch connector with the pedal or lever released and depressed.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the NISS. Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Check the OEM harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the NISS from the OEM harness.
  • Turn keyswitch ON.

Action

Check for a short circuit to ground.

  • Measure the voltage from the idle validation on-idle SIGNAL pin in the NISS connector of the OEM harness to the switch RETURN pin in the NISS connector of the OEM harness.
  • Measure the voltage from the idle validation off-idle SIGNAL pin in the NISS connector of the OEM harness to the switch RETURN pin in the NISS connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Greater than 4.0-VDC?
YES | NO
No Repair | No Repair

Go to 2B

Go to 2A-1

Guided Step 2A-1 - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2A-2

Guided Step 2A-2 - Check the OEM harness for a short circuit to return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the NISS from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to return.

  • Measure the resistance from the idle validation on-idle SIGNAL pin in the NISS connector of the OEM harness to the switch RETURN pin in the NISS connector of the OEM harness.
  • Measure the resistance from the idle validation off-idle SIGNAL pin in the NISS connector of the OEM harness to the switch RETURN pin in the NISS connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A-3

Go to 3A

Guided Step 2A-3 - Check the OEM harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the NISS from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance between the idle validation on-idle SIGNAL pin at the NISS connector of the OEM harness and engine block ground.
  • Measure the resistance between the idle validation off-idle SIGNAL pin at the NISS connector of the OEM harness and engine block ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A-4

Go to 3A

Guided Step 2A-4 - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the NISS from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the idle validation on-idle SIGNAL pin at the ECM connector of the OEM harness and all other pins in the connector.
  • Measure the resistance between the idle validation off-idle SIGNAL pin at the ECM connector of the OEM harness and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A-5

Go to 3A

Guided Step 2A-5 - Check the ECM voltage.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness to the ECM.
  • Disconnect the NISS from the OEM harness.
  • Turn keyswitch ON.

Action

Check for a short circuit to ground.

  • Measure the voltage between the idle validation on-idle SIGNAL pin in the NISS connector of the OEM harness to the switch RETURN pin in the NISS connector of the OEM harness.
  • Measure the voltage between the idle validation off-idle SIGNAL pin in the NISS connector of the OEM harness to the switch RETURN pin in the NISS connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Greater than 4.0-VDC?
YES NO

Repair

Replace the NISS. Refer to the OEM service manual.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Repair Complete

Guided Step 2B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the NISS from the OEM harness.

Action

Check for a short circuit from pin to pin in the OEM harness.

  • Measure the resistance and check for a short circuit between the idle validation on-idle SIGNAL pin and all other pins in the OEM harness ECM connector.
  • Measure the resistance and check for a short circuit between the idle validation off-idle SIGNAL pin and all other pins in the OEM harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch ON and completely depress and release the accelerator pedal or lever three times.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 551 is inactive.

Fault Code 551 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair Complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


FAULT CODE 551 (SSS) - Accelerator Pedal or Lever Idle Validation Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

WARNING

On Automotive applications, set the service brake using the trailer brake hand valve. Make sure there is enough air pressure to activate the brake pressure switch. Securely chock the wheels. Truck movement during troubleshooting can cause severe equipment damage, personal injury, or death.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the SSS. |
 | STEP 1A. Inspect the SSS and harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the SSS for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Check the OEM harness for a short circuit to ground. | Greater than 4.0-VDC?
 | STEP 2A-1. Inspect the OEM harness and ECM connector pins. |
 | STEP 2A-2. Check the OEM harness for a short circuit to return. |
 | STEP 2A-3. Check the OEM harness for a short circuit to ground. |
 | STEP 2A-4. Check for a short circuit from pin to pin in the OEM harness. |
 | STEP 2A-5. Check the ECM voltage. |
 | STEP 2B. Check for a pin-to-pin short circuit in the OEM harness. | More than 100k ohms.
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 551 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the SSS.

Guided Step 1A - Inspect the SSS and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SSS from the OEM harness.

Action

Inspect the OEM harness and SSS connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the SSS for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SSS from the OEM harness.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the idle validation on-idle SIGNAL pin and idle validation off-idle SIGNAL pin at the switch connector with the pedal or lever released and depressed.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the SSS. Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Check the OEM harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SSS from the OEM harness.
  • Turn keyswitch ON.

Action

Check for a short circuit to ground.

  • Measure the voltage from the idle validation on-idle SIGNAL pin in the SSS connector of the OEM harness to the switch RETURN pin in the SSS connector of the OEM harness.
  • Measure the voltage from the idle validation off-idle SIGNAL pin in the SSS connector of the OEM harness to the switch RETURN pin in the SSS connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Greater than 4.0-VDC?
YES | NO
No Repair | No Repair

Go to 2B

Go to 2A-1

Guided Step 2A-1 - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2A-2

Guided Step 2A-2 - Check the OEM harness for a short circuit to return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the SSS from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to return.

  • Measure the resistance from the idle validation on-idle SIGNAL pin in the SSS connector of the OEM harness to the switch RETURN pin in the SSS connector of the OEM harness.
  • Measure the resistance from the idle validation off-idle SIGNAL pin in the SSS connector of the OEM harness to the switch RETURN pin in the SSS connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A-3

Repair Complete

Guided Step 2A-3 - Check the OEM harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SSS from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance between the idle validation on-idle SIGNAL pin at the SSS connector of the OEM harness and engine block ground.
  • Measure the resistance between the idle validation off-idle SIGNAL pin at the SSS connector of the OEM harness and engine block ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A-4

Go to 3A

Guided Step 2A-4 - Check for a short circuit from pin to pin in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SSS from the OEM harness.

Action

Short circuit on one connector - pin-to-pin check:

  • Measure the resistance between the idle validation on-idle SIGNAL pin at the ECM connector of the OEM harness and all other pins in the connector.
  • Measure the resistance between the idle validation off-idle SIGNAL pin at the ECM connector of the OEM harness and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the SSS.

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2A-5

Go to 3A

Guided Step 2A-5 - Check the ECM voltage.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness to the ECM.
  • Disconnect the SSS from the OEM harness.
  • Turn keyswitch ON.

Action

Check for a short circuit to ground.

  • Measure the voltage between the idle validation on-idle SIGNAL pin in the SSS connector of the OEM harness to the switch RETURN pin in the SSS connector of the OEM harness.
  • Measure the voltage between the idle validation off-idle SIGNAL pin in the SSS connector of the OEM harness to the switch RETURN pin in the SSS connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Greater than 4.0-VDC?
YES NO

Repair

Replace the SSS. Refer to the OEM service manual.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Repair Complete

Guided Step 2B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the SSS from the OEM harness.

Action

Check for a short circuit from pin to pin in the OEM harenss.

  • Measure the resistance and check for a short circuit between the idle validation on-idle SIGNAL pin and all other pins in the OEM harness ECM connector.
  • Measure the resistance and check for a short circuit between the idle validation off-idle SIGNAL pin and all other pins in the OEM harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the SSS. Refer to the OEM service manual.

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn the keyswitch ON and completely depress and release the accelerator pedal or lever three times.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 551 is inactive.

Fault Code 551 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair Complete.

Appropriate troubleshooting steps

Last Modified: 01-May-2012


FAULT CODE 553 - Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operational Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fuel pump actuator fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 271, 272, 1117, or 2311 active or high inactive counts?
STEP 2. | Check the rail fuel pressure sensor. |
 | STEP 2A. Monitor rail pressure with INSITE™ electronic service tool. | Is the fuel rail pressure 0 ± 43 bar [0 ± 624 psi]?
STEP 3. | Check drain line restriction |
 | STEP 3A. Check drain line restriction. | Fuel drain line restriction is within the specifications outlined in Procedure 006-012?
STEP 4. | Check the low pressure fuel system. |
 | STEP 4A. Check for excessive supply pump fuel pressure. | Is pressure greater than 1207 kPa [175 psi]?
 | STEP 4B. Check the fuel pump actuator. | Is the inboard o-ring cut or shaved?
STEP 5. | Clear the fault code. |
 | STEP 5A. Disable the fault code. | Fault Code 553 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for fuel pump actuator fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271, 272, 1117, or 2311 active or high inactive counts?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor.

Guided Step 2A - Verify rail fuel pressure sensor accuracy.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool
  • Run INSITE™ electronic service tool monitor
  • Engine not running.

Action

Verify rail fuel pressure sensor accuracy.

  • Make sure the correct sensor part number is installed in the high-pressure fuel rail.

Monitor the fuel rail pressure.

  • Use INSITE™ electronic service tool to measure fuel rail pressure.

Is the fuel pressure 0 ± 43 bar [0 ± 624 psi]?
YES NO
No Repair

Repair

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check drain line restriction.

Guided Step 3A - Check drain line restriction.

Conditions

  • Turn keyswitch ON
  • Engine running.

Action

Check for excessive fuel drain line restriction.

  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-012 in Section 6.
  • Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-012 in Section 6.

Fuel drain line restriction is within the specifications outlined in Procedure 006-012?
YES NO
No Repair

Repair

Repair the source of the high fuel drain line restriction.

  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-012 in Section 6.
  • Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-012 in Section 6.

Go to 4A

Go to 5A

Guided Step 4 - Check the low pressure fuel system.

Guided Step 4A - Check for excessive supply pump fuel pressure.

Conditions

  • Engine running.

Action

Install an M10 standard thread o-ring diagnostic fitting, Part Number 3824842, at the pressure-side fuel filter outlet port.

Install a 0 to 2068 kPa [0 to 300 psi] pressure gauge at the outlet of the pressure side filter.

  • Operate the engine at idle and measure the pressure at the gear pump outlet.

Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 005-025 in Section 5.

Is pressure greater than 1207 kPa [175 psi]?
YES NO

Repair

Replace the fuel gear pump assembly.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the fuel pump actuator.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel pump actuator.

Remove the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

  • Inspect the fuel pump actuator inboard o-ring. If this o-ring is cut or shaved, fuel may be permitted to bypass the fuel pump actuator and enter the high-pressure pump.

Is the inboard o-ring cut or shaved?
YES NO

Repair

Replace the damaged o-ring.

Repair

Replace the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let if idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 553 inactive?
YES | NO
No Repair | No Repair

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


FAULT CODE 554 - Injector Metering Rail 1 Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 451 and 452 | Fault Code 451 or 452 is active?
STEP 2. | Check the rail fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the rail fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 451 active?
 | STEP 2C. Check the circuit response. | Fault Code 452 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect CM and engine harness connector pins. | Dirty or damaged pin?
 | STEP 3B. Check the circuit response. | Fault Code 451 active?
 | STEP 3C. Check the circuit response. | Fault Code 452 active?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 554 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 451 and 452.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 or 452 is active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor and circuit.

Guided Step 2A - Inspect the rail fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and rail fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the rail fuel pressure signal pin and the rail fuel pressure return pin at the rail fuel pressure connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 active?
YES NO

Repair

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the rail fule parssure SIGNAL pin and rail fuel pressure RETURN pin at the engine control module engine connector.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 active?
YES NO

Repair

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine.
  • Operate the engine under light load for two minutes.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 554 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 01-May-2012


FAULT CODE 559 (ISB/QSB Automotive, Marine or Industrial Application) - Fuel Pump Delivery Pressure Low - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2266 or 1911 active or high inactive counts?
STEP 2. | Check the operation of the low-pressure fuel system. |
 | STEP 2A. Check for adequate fuel supply. | Equipment/vehicle has an adequate fuel supply?
 | STEP 2B. Check for an external fuel leak. | Fuel leaks present?
STEP 3. | Low pressure system checks. |
 | STEP 3A. Measure the inlet restriction. | Inlet restriction meets specification?
 | STEP 3B. Check for electric lift pump. | Engine has an electrical lift pump?
 | STEP 3C. Measure the lift pump fuel flow. | Lift pump meets minimum specifications?
 | STEP 3D. Check for air in the fuel. | Air in the fuel?
STEP 4. | Check the fuel filter restriction. |
 | STEP 4A. Measure the pressure drop across the fuel filter. | Drop in pressure meets specification?
 | STEP 4B. Measure the fuel filter outlet pressure. | Fuel filter outlet pressure meets specification?
STEP 5. | Check the high-pressure fuel system. |
 | STEP 5A. Check for leakage from the fuel rail pressure relief valve. | Fuel return with specification?
 | STEP 5B. Check for excessive fuel return leakage from the high-pressure fuel system, injectors, and high-pressure connectors. | Fuel leakage within specification?
 | STEP 5B-1. Check the high-pressure connector (HPC) torque. |
 | STEP 5B-2. Check for individual leaking injectors. |
 | STEP 5C. Check for excessive fuel return from the high-pressure fuel pump. | Fuel return with specification?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault codes inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2266 or 1911 active or high inactive counts?
YES | NO
No Repair | No Repair

Troubleshoot applicable fault codes

Go to 2A

Guided Step 2 - Check the operation of the low-pressure fuel system.

Guided Step 2A - Check for adequate fuel supply.

Conditions

  • Turn keyswitch ON.
  • Turn engine OFF.

Action

Check for adequate fuel supply

  • Do not rely on the vehicle's fuel gauge. Verify there is fuel in the tank.
  • Check the equipment/vehicle fuel gauge.
  • Inspect the fuel tank if there is any doubt about the accuracy of the fuel gauge.

Equipment/vehicle has an adequate fuel supply?
YES NO
No Repair

Repair

Add fuel to the fuel tank or perform repairs to the vehicle's tank or fuel gauge.

Go to 2B

Go to 6A

Guided Step 2B - Check for an external fuel leak.

Conditions

  • Turn keyswitch ON.

Action

Check for external fuel leaks.

  • Start the engine and let it idle.
  • Inspect for external fuel leaks.

Fuel leaks present?
YES NO

Repair

Locate and repair the source of the external fuel leak.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Low pressure system checks.

Guided Step 3A - Measure inlet restriction.

Conditions

  • Turn keyswitch ON.

Action

Measure the inlet restriction.

  • Reference the following procedure in the ISBe, ISB, and QSB (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-020 in Section 6.

Inlet restriction meets specification?
YES NO
No Repair

Repair

The inlet restriction may be caused by a dirty OEM fuel filter, a bent fuel line, or debris in fuel tank. Identify and repair the cause of the inlet restriction.

Go to 3B

Go to 6A

Guided Step 3B - Check for electric lift pump.

Conditions

  • Turn keyswitch OFF.
  • Engine OFF.

Action

Determine if the engine is equipped with an electrical lift pump.

Engine has an electrical lift pump?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3D

Guided Step 3C - Measure the lift pump fuel flow.

Conditions

  • Turn keyswitch ON.

Action

Measure the lift pump fuel flow.

  • Reference the following procedure in the ISBe, ISB, and QSB (Common Rail Fuel System) Service Manual, Bulletin 4021271, for measuring the lift pump flow. Refer to Procedure 005-045 in Section 5.

Lift pump meets minimum specifications?
YES NO
No Repair

Repair

Replace the electric fuel lift pump.

  • Reference the following procedure in the ISBe, ISB, and QSB (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 005-045 in Section 5.

Go to 3D

Go to 6A

Guided Step 3D - Check for air in the fuel.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

This test can not be performed if the engine will not start. If the engine will not start, proceed to the next step.

Action

Check for air in the fuel.

  • Reference the following procedure in the ISBe, ISB, and QSB (Common Rail Fuel System) Service Manual, Bulletin 4021271, for checking for air in the fuel. Refer to Procedure 006-003 in Section 6.

Air in the fuel?
YES NO

Repair

Address the source of air.

A few bubbles exiting the line during the test is expected.

A foamy appearance is an indication of a leak that allows air to enter, a severe inlet restriction that causes cavitation, or a system that is not yet primed. The source of air entry can be isolated to one of the following locations:

  • Suction fuel lines
  • OEM fuel lines
  • Suction-side fuel filter assemblies
  • Stand-pipes in the fuel tank(s).
 No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check the fuel filter restriction.

Guided Step 4A - Measure the pressure drop across the fuel filter.

Conditions

  • Turn keyswitch ON.
  • Run the engine at rated condition.

Action

Measure the pressure drop across the fuel filter.

  • Reference the following procedure in the ISBe, ISB, and QSB (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-015 in Section 6.

Drop in pressure meets specification?
YES NO
No Repair

Repair

Replace the pressure-side filter and verify the pressure side fuel lines are not restricted.

Go to 4B

Go to 6A

Guided Step 4B - Measure the fuel filter outlet pressure.

Conditions

  • Turn keyswitch ON.
  • Run the engine at rated condition.

Action

Verify the fuel filter outlet pressure measured in the previous step meets specification.

  • Reference the following procedure in the ISBe, ISB, and QSB (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-015 in Section 6.

Fuel filter outlet pressure meets specification?
YES NO
No Repair

Repair

Replace the high-pressure pump.

Go to 5A

Go to 6A

Guided Step 5 - Check the high-pressure fuel system.

Guided Step 5A - Check for leakage from the fuel rail pressure relief valve.

Conditions

  • Turn keyswitch OFF.
  • Install test fittings to measure the fuel return from the fuel rail pressure relief valve.

Action

Check for leakage from the fuel rail pressure relief valve.

  • Install test fittings to measure the fuel return.
  • Reference the following procedure in the ISBe, ISB, and QSB (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure Procedure 006-061 in Section 6.

Fuel return within specification?
YES NO
No Repair

Repair

Replace the rail fuel pressure relief valve.

  • Reference the following procedure in the ISBe, ISB, and QSB (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure Procedure 006-061 in Section 6.

Go to 5B

Go to 6A

Guided Step 5B - Check for excessive fuel return leakage from the high-pressure fuel system, injector, and high-pressure connectors.

Conditions

  • Turn keyswitch OFF.
  • Install test fittings to measure the fuel return from the injectors and high-pressure connectors.

Action

Check for excessive fuel leakage from the injectors and high-pressure connectors.

  • Reference the following procedure in the ISBe, ISB, and QSB (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6.

Fuel leakage within specification?
YES | NO
No Repair | No Repair

Go to 5C

Go to 5B-1

Guided Step 5B-1 - Check the high-pressure connector (HPC) torque.

Conditions

  • Turn keyswitch OFF.

Action

Check the injector high-pressure connector torque.

  • Reference the following procedure in the ISBe, ISB, and QSB (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-052 in Section 6.

Injector high-pressure connector torque meets specifications?
YES NO
No Repair

Repair

Tighten the injector high-pressure connector.

  • Reference the following procedure in the ISBe, ISB, and QSB (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-052 in Section 6.

Check the injector return flow again.

Go to 5B-2

Go to 5B

Guided Step 5B-2 - Check for individual leaking injectors.

Conditions

  • Turn keyswitch ON.
  • Operate the engine at idle.
  • Make sure INSITE™ electronic service tool Fuel System Leakage Test is ACTIVE.

This test can be performed if the engine will not start.

If the engine will not start, perform this test while cranking the engine.

Action

Check for a fuel leak at individual injectors.

  • Cap off each injector, one at a time, with the injector leakage isolation tool. The service tool must be installed with the engine OFF.
  • Reference the following procedure in the ISBe, ISB, and QSB (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6.

One injector able to be identified to be causing the excessive return flow?
YES NO

Repair

Replace the injector for the cylinder that is causing the high injector return flow.

  • Reference the following procedure in the ISBe, ISB, and QSB (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6.

Repair

Cap off additional injectors to identify the source of high injector return flow. Replace the injector for the cylinder(s) causing the high injector return flow.

  • Reference the following procedure in the ISBe, ISB, and QSB (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6.

Go to 6A

Go to 5B

Guided Step 5C - Check for excessive fuel return from the high-pressure fuel pump.

Conditions

  • Turn keyswitch OFF.
  • Install test fittings to measure the fuel return from the high-pressure fuel pump.

Action

Check for excessive fuel return from the high-pressure fuel pump.

  • Install test fittings to measure the fuel return from the fuel pump.
  • Reference the following procedure in the ISBe, ISB, and QSB (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 005-016 in Section 5.

Fuel return within specification?
YES NO
No Repair

Repair

Replace the high-pressure fuel pump.

  • Reference the following procedure in the ISBe, ISB, and QSB (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 005-016 in Section 5.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify the fault codes are inactive.

Fault codes inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Perform a 15 to 20 minute road test or run the engine on the dynamometer.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-May-2011


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 559 active or has high inactive counts?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 559 is active or has high inactive counts?
YES | NO
No Repair | No Repair

Go to Fault Code 2215 troubleshooting tree.

Repair complete

Last Modified: 08-Jul-2010


FAULT CODE 584 - Starter Relay Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 584 active?
STEP 2. | Check the starter lockout relay circuit. |
 | STEP 2A. Inspect the starter lockout relay and connector pins. |
 | STEP 2B. Check the resistance of the starter lockout relay. | Less than 10k ohms?
 | STEP 2C. Check for an open circuit in the starter lockout relay return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 584 inactive?
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault code | Fault Code 584 inactive?
 | STEP 4B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 584 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the starter lockout relay circuit.

Guided Step 2A - Inspect the starter lockout relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter relay from the OEM harness.

Action

Inspect the OEM starter relay and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the starter lockout relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check the starter lockout relay resistance.

  • Measure the resistance between the starter lockout relay SIGNAL pin and the starter lockout relay RETURN pin.

Refer to the OEM wiring diagram for starter relay pin configuration.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

Repair

Replace the starter lockout relay. Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the starter lockout relay return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the starter lockout relay RETURN pin at the starter lockout relay connector to ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit on the RETURN wire has been detected. Refer to the OEM wiring diagram for RETURN wire configuration.

If the RETURN is wired to the ECM, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the failed connection.

Clean, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the starter lockout relay SIGNAL pin at the starter lockout relay connector and the starter lockout relay SIGNAL pin at the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit in the starter lockout relay SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the starter lockout relay SIGNAL pin in the OEM ECM connector and all other pins in the OEM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the output device driver SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 584 inactive?
YES NO

Repair

None.

The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 584 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool, to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


FAULT CODE 585 - Starter Relay Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 585 active?
STEP 2. | Check starter lockout relay and circuit. |
 | STEP 2A. Inspect starter relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the starter lockout relay resistance. | Greater than 6 ohms?
 | STEP 2B-1. Check for a pin to ground short circuit in the starter lockout relay. |
 | STEP 2C. Check the starter lockout relay diagnostic supply voltage, supply line and return circuit. | Greater than 3.75-VDC?
STEP 3. | Check the OEM harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 585 is inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 585 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 585 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check starter lockout relay and circuit.

Guided Step 2A - Inspect starter relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter relay from the OEM harness.

Action

Inspect the OEM starter relay and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the starter lockout relay resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Measure the resistance of the relay coil and check for low resistance between the starter lockout relay SIGNAL pin and the relay RETURN pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 6 ohms?
YES NO
No Repair

Repair

Replace the starter lockout relay. Refer to the OEM service manual.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a pin to ground short circuit in the starter lockout relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Measure the resistance and check for a short circuit between the starter lockout relay SIGNAL pin and ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the starter lockout relay. Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the starter lockout relay diagnostic supply voltage, supply line and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.
  • Turn keyswitch ON.

Action

Check the starter lockout relay diagnostic supply voltage and return circuit.

  • Measure the voltage between the starter lockout relay SIGNAL pin and the starter lockout relay RETURN pin at the starter lockout relay connector of the OEM harness.

Greater than 3.75-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure the resistance between the starter lockout relay SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Measure the resistance and check for a short circuit between the starter lockout relay SIGNAL pin and all other pins in the OEM harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 585 is inactive?
YES NO

Repair

None. The removal and installation of the connector correct the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 585 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


FAULT CODE 595 (ISB/QSB Automotive or Industrial Application) - Turbocharger Number 1 Speed High - Warning Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active or has inactive counts?
 | STEP 1B. Check for an active fault code. | Fault Code 595 active?
STEP 2. | Check the sensor and engine harness. |
 | STEP 2A. Inspect the engine harness and sensor harness connector pins. | Dirty or damaged pins or damaged components?
 | STEP 2B. Check for an open circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 3. | Check the circuit response. |
 | STEP 3A. Check for an active fault code. | Fault Code 595 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 595 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool, to read the fault codes.

Fault Code 352 active or has inactive counts?
YES | NO
No Repair | No Repair

Fault Code 352

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for one minute.
  • Use the accelerator pedal to accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.
  • Use INSITE™ electronic service tool, to read the fault codes.

Fault Code 595 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensor and engine harness.

Guided Step 2A - Inspect the engine harness and sensor harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the turbocharger speed sensor.
  • Disconnect the engine harness from the ECM.

Action

Inspect the sensor connector, the engine harness connector, and the sensor pigtail harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged components?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the turbocharger speed sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the Turbocharger Speed 5-VDC SUPPLY pin at the ECM connector of the engine harness and the Turbocharger Speed 5-VDC SUPPLY pin at the sensor harness connector of the engine harness.
  • Measure the resistance between the Turbocharger Speed SIGNAL pin at the ECM connector of the engine harness and the Turbocharger Speed SIGNAL pin at the sensor harness connector of the engine harness.
  • Measure the resistance between the Turbocharger Speed RETURN pin at the ECM connector of the engine harness and the Turbocharger Speed RETURN pin at the sensor harness connector of the engine harness.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the turbocharger speed sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the Turbocharger Speed 5-VDC SUPPLY pin at the ECM connector of the engine harness and engine block ground.
  • Measure the resistance between the Turbocharger Speed SIGNAL pin at the ECM connector of the engine harness and engine block ground.
  • Measure the resistance between the Turbocharger Speed RETURN pin at the ECM connector of the engine harness and engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the turbocharger speed sensor.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the Turbocharger Speed 5-VDC SUPPLY pin at the ECM connector of the engine harness and all other pins in the connector.
  • Measure the resistance between the Turbocharger Speed SIGNAL pin at the ECM connector of the engine harness and all other pins in the connector.
  • Measure the resistance between the Turbocharger Speed RETURN pin at the ECM connector of the engine harness and all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the circuit response.

Guided Step 3A - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for one minute.
  • Use the accelerator pedal to accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 595 active?
YES NO

Repair

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use the accelerator pedal to accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.

NOTE: This step applies even if maximum engine speed without vehicle speed sensor limits the engine speed.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 595 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Apr-2012


FAULT CODE 595 (ISC/QSC/ISL/QSL Automotive, Industrial, or Marine Application) - Turbocharger Number 1 Speed High - Data Valid but Above Normal Operational Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Cannon™/Metri-Pack™ test lead and Part Number 3822917 female Deutsch™/AMP™/Cannon™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for intermittent fault condition. |
 | STEP 1A. Operate the engine at idle and high idle to check for fault activation. | Does Fault Code 595 come active during engine operation?
STEP 2. | Check for a damaged turbocharger speed sensor. |
 | STEP 2A. Inspect the engine harness connector to the turbocharger speed sensor. | Is the connector or pigtail harness damaged?
 | STEP 2B. Measure the turbocharger speed sensor resistance. | Between 600 and 1600 ohms?
 | STEP 2C. Check for a short circuit to ground in the turbocharger speed sensor. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins or connector?
 | STEP 3B. Check the turbocharger speed sensor circuit continuity. | Resistance within 10 ohms of the sensor resistance?
 | STEP 3C. Check for a short to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin to pin short in the engine harness. | Greater than 100k ohms?
STEP 4. | Connect all components and determine if the fault code reoccurs. |
 | STEP 4A. Operate the engine at idle and high idle to check for fault activation. | Does Fault Code 595 come active during engine operation?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 595 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for intermittent fault condition.

Guided Step 1A - Operate the engine at idle and high idle to check for fault activation.

Conditions

  • Connect INSITE™ electronic service tool and clear inactive fault codes.
  • Start the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

Action

Using the accelerator pedal, accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.

–

Does Fault Code 595 come active during engine operation?
YES NO
No Repair

Repair

An intermittent fault condition exists. The problem may be with the turbocharger speed sensor circuit; however, the intermittent fault condition may be due to electrical noise that is caused by other devices or faulty grounds.

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check for a damged turbocharger speed sensor.

Guided Step 2A - Inspect the engine harness connector to the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the turbocharger speed sensor.

Action

Inspect the turbocharger speed sensor connector, the engine harness connector, and the turbocharger speed sensor pigtail harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Is the connector or pigtail harness damaged?
YES NO

Repair

Repair or replace the damaged connector or turbocharger speed sensor. Refer to Procedure 019-390 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Measure the turbocharger speed sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Using a multimeter, measure the resistance from the turbocharger speed SIGNAL (+) pin to the turbocharger speed RETURN (-) pin at the sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 600 and 1600 ohms?
YES NO
No Repair

Repair

The turbocharger speed sensor is damaged.

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to ground in the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Using a multimeter, measure the resistance from the turbocharger speed SIGNAL (+) pin on the sensor to the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

The turbocharger speed sensor is shorted to ground.

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or connector?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the turbocharger speed sensor circuit continuity.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM.

Action

Using a multimeter, measure the resistance from the turbocharger speed SIGNAL (+) pin at the engine harness ECM connector to the turbocharger speed RETURN (-) pin at the engine harness ECM connector.

Note: The resistance of the turbocharger speed sensor circuit must not be more than 10 ohms greater than the resistance of the turbocharger speed sensor. The turbocharger speed sensor resistance value was read in Step 2B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance within 10 ohms of sensor resistance?
YES NO
No Repair

Repair

There is high resistance or an open circuit in the engine harness or turbocharger speed sensor connector. Otherwise, there is a low resistance (short) across the sensor input pins.

Repair or replace the engine harness or connector(s). Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM.

Action

Using a multimeter, measure the resistance from the turbocharger speed SIGNAL (+) pin at the engine harness ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

There is a short to ground in the turbocharger speed sensor circuit. Inspect the engine harness for a short to ground.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a pin-to-pin short in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM.

Action

Using a multimeter, measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to all other pins in the connector except the turbocharger speed RETURN (-) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

There is a short between pins of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Connect all components and determine if the fault code reoccurs.

Guided Step 4A - Operate the engine at idle and high idle to check for fault activation.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Connect the engine harness to the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine at idle.

  • Using the accelerator pedal, accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.

Note: This step applies even if maximum engine speed without vehicle speed sensor limits the engine speed.

Does Fault Code 595 come active during engine operation?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

An intermittent fault condition exists. The problem may exist in the turbocharger speed sensor circuit or it may exist with other vehicle electronic components. The problem may have been corrected when the harness connections were re-engaged.

Be certain that the ECM and chassis grounds are in good condition.

Go to 5A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect turbocharger speed sensor to the engine harness.
  • Connect the engine harness to the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Using the accelerator pedal, accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.

Note: This step applies even if maximum engine speed without vehicle speed sensor limits the engine speed.

Fault Code 595 inactive?
YES | NO
No Repair | No Repair

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


FAULT CODE 596 - Electrical Charging System Voltage High - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable and alternator connections. | Damaged connections?
 | STEP 1B. Check the battery voltage. | Are the voltages at least (+) 12-VDC under normal conditions and at least (+) 6.2-VDC during cranking?
STEP 2. | Check the charging system. |
 | STEP 2A. Inspect the alternator. | Alternator charging within OEM specifications?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 596 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable and alternator connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable and alternator connections for the following:

  • Corrosion
  • Loose connection.

Damaged connections?
YES NO

Repair

Repair the damaged connections.Tighten the battery connections and clean the battery terminals. Refer to the OEM service manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (−) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (−) terminal while trying to start the engine.

Are the voltages at least (+) 12-VDC under normal conditions and at least (+) 6.2-VDC during cranking?
YES NO
No Repair

Repair

Charge or replace the battery. Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the charging system.

Guided Step 2A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

  • Start the engine and check the alternator's charging rate (amps).

NOTE: It will probably be necessary to place a load on the batteries to measure the alternator output properly.

Is the alternator charging within OEM specifications?
YES NO
No Repair

Repair

Repair or replace the alternator, regulator, and/or OEM wiring to the alternator. Refer to the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it run for 10 minutes.
  • Use INSITE™ electronic service tool to verify that Fault Code 596 is inactive.

Fault Code 596 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Apr-2012


FAULT CODE 597 - Electrical Charging System Voltage Low - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use these test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable and alternator connections. | Any damaged connections?
 | STEP 1B. Check the battery voltage. | Is the battery voltage at least (+) 12-VDC under normal conditions and at least (+) 6.2-VDC during cranking?
STEP 2. | Check the alternator and power harness. |
 | STEP 2A. Inspect the alternator. | Alternator charging within OEM specifications?
 | STEP 2B. Check for an open circuit in the unswitched battery supply circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit. | More than 100k ohms?
 | STEP 2D. Check the add-on or accessory wiring at the positive (+) terminal of the battery. | No damaged wires?
 | STEP 2E. Check for a pin-to-pin short circuit in the power harness. | More than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 597 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable and alternator connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable and alternator connections for the following:

  • Corrosion
  • Loose connection.

Any damaged connections?
YES NO

Repair

Repair the damaged connections.

Tighten the battery connections and clean the battery terminals. Refer to the OEM service manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal. Touch the negative (-) probe of the multimeter to the negative battery terminal while trying to start the engine.

Is the battery voltage at least (+) 12-VDC under normal conditions and at least (+) 6.2-VDC during cranking?
YES NO
No Repair

Repair

Charge or replace the battery.

Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the alternator and power harness.

Guided Step 2A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use the OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

  • Start the engine and check the alternator's charging rate (amps).

NOTE: It will probably be necessary to place a load on the batteries to measure the alternator output properly.

Is the alternator charging within OEM specifications?
YES NO
No Repair

Repair

Repair or replace the alternator and/or OEM wiring to the alternator. Refer to the OEM service manual.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit in the unswitched battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness connector from the ECM.
  • Disconnect the positive battery cable from the battery.

Action

Check for an open circuit in the unswitched battery supply circuit.

  • Using a multimeter, measure the resistance between the ECM battery SUPPLY (+) pins of the OEM power harness ECM connector and the positive (+) battery terminal.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the battery harness. Refer to the OEM service manual.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness connector from the ECM.
  • Disconnect the positive (+) battery cable from the battery.

Action

Check for a short circuit.

  • Using a multimeter, measure the resistance between the ECM battery SUPPLY (+) pins and the ECM battery SUPPLY (-) pins of the ECM power harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the OEM power harness.

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF

Action

Check the add-on or accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine the wire(s) for damaged insulation or installation error that can cause a short circuit in the supply wire to the engine block.

Any damaged wires?
YES NO

Repair

Repair the damaged wiring.

 No Repair

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit in the power harness

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM
  • Disconnect the positive (+) battery cable from the battery.

Action

Use a multimeter to measure the resistance between the ECM Battery SUPPLY (+) pins in the OEM power harness connector to all pins in the OEM harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the OEM power harness.

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it run for 10 minutes.
  • Use INSITE™ electronic service tool to verify that Fault Code 597 is inactive.

Fault Code 597 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked a second time.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Apr-2012


FAULT CODE 598 - Electrical Charging System Voltage Low - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable and alternator connections. | Damaged connections?
 | STEP 1B. Check the battery voltage. | Are the voltages at least (+) 12-VDC during normal conditions and at least (+) 6.2-VDC during cranking?
STEP 2. | Check the alternator and OEM harness. |
 | STEP 2A. Inspect the alternator. | Alternator charging within OEM specifications?
 | STEP 2B. Inspect the battery power connector. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the unswitched battery supply circuit. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-pin short circuit in the power harness. | More than 100k ohms?
 | STEP 2E. Check the add-on or accessory wiring at the positive (+) terminal of the battery. | Damaged wires?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 598 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable and alternator connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable and alternator connections for the following:

  • Corrosion
  • Loose connection.

Damaged connections?
YES NO

Repair

Repair the damaged connections.

Tighten the battery connections and clean the battery terminals.

Refer to the OEM service manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (−) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (−) terminal while trying to start the engine.

Are the voltages at least (+) 12-VDC during normal conditions and at least (+) 6.2-VDC during cranking?
YES NO
No Repair

Repair

Charge or replace the battery. Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the alternator and OEM harness.

Guided Step 2A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

  • Start the engine and check the alternator's charging rate (amps).

NOTE: It will probably be necessary to place a load on the batteries to measure the alternator output properly.

Is the alternator charging within OEM specifications?
YES NO
No Repair

Repair

Repair or replace the alternator and/or OEM wiring to the alternator. Refer to the OEM service manual.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the battery power connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness from the battery at the power connector.

Action

Inspect the battery power connector on both the battery side and the harness side for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the battery power connector. Refer to the OEM service manual for location and procedure.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for an open circuit in the unswitched battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit.

  • Measure the resistance of the ECM battery supply (+) circuit between the OEM power harness connector and the positive (+) terminal of the battery.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a pin-to-pin short circuit in the power harness

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness connector from the ECM.
  • Disconnect the positive battery cable from the battery.

Action

Measure the resistance and check for a short circuit between the ECM battery supply (+) pins and all other pins of the power harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the OEM power harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine the wire(s) for damaged insulation or installation error that can cause a short circuit at supply wire to the engine block ground.

Damaged wires?
YES NO

Repair

Repair the damaged wiring.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it run for 10 minutes.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to verify that Fault Code 598 is inactive.

Fault Code 598 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Apr-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 599. | Active or inactive counts of Fault Code 599?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 599.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 599?
YES NO

Repair

The engine protection limit has been exceeded or the OEM supplied auxiliary device. Refer to the OEM troubleshooting manual.

 No Repair

OEM troubleshooting manual.

Repair complete.

Last Modified: 08-Jul-2010


FAULT CODE 649 - Change Lubricating Oil and Filter - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 649. | Fault Code 649 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 649 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 649.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 649.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 649 active?
YES NO

Repair

Change the engine lubricating oil and filter.

Reset the maintenance monitor using the INSITE™ electronic service tool.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to reset the maintenance monitor.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

NOTE: The maintenance monitor can also be reset manually.

Fault Code 649 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Apr-2012


FAULT CODE 687 (ISB/QSB Automotive or Industrial Application) - Turbocharger Speed Sensor - Below Normal Operating Range

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active or has inactive counts?
 | STEP 1B. Check for an active fault code. | Fault Code 687 active?
STEP 2. | Check the turbocharger speed sensor and circuit. |
 | STEP 2A. Inspect the turbocharger speed sensor and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit at the harness. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor supply voltage and return circuit at the ECM. | 4.75 to 5.25 VDC?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
 | STEP 2E. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 2F. Check for a short circuit from pin to pin. | Greater than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 687 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool, read the fault codes.

Fault Code 352 active or has inactive counts?
YES | NO
No Repair | No Repair

Fault Code 352

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for one minute.
  • Use the accelerator pedal, accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.
  • Return engine speed to idle.
  • Use INSITE™ electronic service tool, read the fault codes.

NOTE: This step applies even if maximum engine speed without vehicle speed sensor limits the engine speed.

Fault Code 687 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the turbocharger speed sensor and circuit.

Guided Step 2A - Inspect the turbocharger speed sensor and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Inspect the engine harness and turbocharger speed sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broke
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

NOTE: The turbocharger speed sensor has a “pigtail” connection. Closely inspect this electrical connection for signs of damage to the wire insulation.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit at the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the turbocharger speed sensor.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage between the turbocharger speed +5 VDC SUPPLY pin and the turbocharger speed RETURN pin at the sensor connector of the engine harness.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C

Guided Step 2C - Check the sensor supply voltage and return circuit at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit at the ECM.

  • Measure the voltage between the turbocharger speed +5 VDC SUPPLY pin and the turbocharger speed RETURN pin at the ECM port.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75 to 5.25 VDC?
YES NO

Repair

Repair or replace the engine harness.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 2D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the turbocharger speed SIGNAL pin at the ECM connector of the engine harness and the turbocharger speed SIGNAL pin at the turbocharger speed sensor connector of the engine harness.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground.

  • Measure the resistance between the turbocharger speed SIGNAL pin at the ECM connector of the engine harness and engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

Go to 2F

Go to 3A

Guided Step 2F - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the turbocharger speed SIGNAL pin and all other pins at the ECM connector of the engine harness.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in Section 19.

Repair

Repair or replace the engine harness.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use the accelerator pedal, accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.
  • Return engine speed to idle.
  • Use INSITE™ electronic service tool, read the fault codes.

NOTE: This step applies even if maximum engine speed without vehicle speed sensor limits the engine speed.

Fault Code 687 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-Mar-2012


FAULT CODE 687 (ISC/QSC/ISL/QSL Automotive, Industrial, or Marine Application) - Turbocharger Number 1 Speed Low - Data Valid but Below Normal Operational Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Cannon™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Cannon™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for barometric pressure or intake manifold pressure sensor faults. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Codes 122, 123, 221, or 222 active?
STEP 2. | Check for intermittent fault condition. |
 | STEP 2A. Operate the engine and confirm that the turbocharger speed fault comes active. | Did Fault Code 687 come active during engine operation?
STEP 3. | Check for a failed turbocharger speed sensor. |
 | STEP 3A. Inspect the engine harness connector to the turbocharger speed sensor. | Is the connector or pigtail harness damaged?
 | STEP 3B. Measure the turbocharger speed sensor resistance. | Between 600 and 1600 ohms?
 | STEP 3C. Check for a short circuit to ground in the turbocharger speed sensor. | Greater than 100k ohms?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Is the engine harness connector damaged?
 | STEP 4B. Check the turbocharger speed sensor circuit continuity. | Within 10 ohms of sensor resistance?
 | STEP 4C. Check for a short to ground in the engine harness. | Greater than 100k ohms?
 | STEP 4D. Check for a pin-to-pin short in the engine harness. | Greater than 100k ohms?
STEP 5. | Check the ECM. |
 | STEP 5A. Connect all components and determine if the fault code reoccurs. | Did Fault Code 687 come active during engine operation?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 687 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for barometric pressure or intake manifold pressure sensor faults.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool.

Fault Codes 122, 123, 221, or 222 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check for intermittent fault condition.

Guided Step 2A - Operate the engine and confirm that the turbocharger speed fault comes active.

Conditions

  • Connect INSITE™ electronic service tool.
  • Clear the inactive fault codes.

Action

Start the engine.

  • Use the accelerator pedal, accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.
  • Return the engine speed to idle.
  • Use INSITE™ electronic service tool, read the fault codes.

NOTE: This step is valid even if maximum engine speed, without vehicle speed sensor, limits the engine speed.

Did Fault Code 687 come active during engine operation?
YES NO
No Repair

Repair

An intermittent fault conditions exists.

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check for a failed turbocharger speed sensor.

Guided Step 3A - Inspect the engine harness connector to the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the turbocharger speed sensor.

Action

Inspect theturbocharger speed sensor connector, the engine harness connector, and the turbocharger speed sensor pigtail harness? connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Is the connector pigtail harness damaged?
YES NO

Repair

Repair or replace the damaged connector or turbocharger speed sensor. Refer to Procedure 019-390 in Section 19.

No Repair

Go to 6A

Go to 3B

Guided Step 3B - Measure the turbocharger speed sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Using a multimeter, measure the resistance from the turbocharger speed SIGNAL (+) pin to the turbocharger speed SIGNAL (-) pin at the sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 600 and 1600 ohms?
YES NO
No Repair

Repair

The turbocharger speed sensor is damaged.

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit to ground in the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Using a multimeter, measure the resistance from the turbocharger speed SIGNAL (+) pin at the sensor to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

The turbocharger speed sensor is shorted to ground.

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness ECM connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Is the engine harness connector damaged?
YES NO

Repair

Repair or replace the engine harness connector. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the turbocharger speed sensor circuit continuity.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM.

Action

Using a multimeter, measure the resistance form the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to the turbocharger speed SIGNAL (-) pin of the engine harness ECM connector.

NOTE: The resistance of the turbocharger speed sensor circuit resistance should be no more than 10 ohms greater than the resistance of the turbocharger speed sensor. The turbocharger speed sensor resistance value was read in Step 3B.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Within 10 ohms of sensor resistance?
YES NO
No Repair

Repair

There is high resistance or an open circuit in the engine harness or turbocharger speed sensor connector.

Repair or replace the engine harness or connector(s). Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM.

Action

Using a multimeter, measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

There is a short to ground in the turbocharger speed sensor circuit. Inspect the engine harness for a short to ground.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for a pin-to-pin short in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM.

Action

Using a multimeter, measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to all other pins in the connector except turbocharger speed SIGNAL (-) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Inspect the engine harness for a short between two pins.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the ECM.

Guided Step 5A - Connect all components and determine if the fault code reoccurs.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Connect the engine harness to the ECM.
  • Turn keyswitch ON.
  • Start the engine.

Action

Operate the engine at idle.

  • Use the accelerator pedal, accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.
  • Return the engine speed to idle speed.
  • Use INSITE™ electronic service tool, read the fault codes.

NOTE: This step applies even if maximum engine speed, without vehicle speed sensor, limits the engine speed.

Did Fault Code 687 come active during engine operation?
YES NO
No Repair

Repair

The faulty condition was repaired when the components were reconnected.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Connect the engine harness to the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine.

Action

Using the accelerator pedal, accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

NOTE: This step applies even if maximum engine speed, without vehicle speed sensor, limits the engine speed.

Fault Code 687 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair location if all steps have been completed and checked a second time.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool erase the inactive fault codes .

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 28-Mar-2012


FAULT CODE 688 - Engine Oil Level — Data Valid But Above Normal Operational Range — Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes | Fault Code 688 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault codes. | Fault Code 688 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Engine oil temperature near ambient temperature.
  • Make sure the vehicle is parked on level ground.

Action

Read the fault codes.

  • Use INSITE™ to read the fault codes.

Fault Code 688 active?
YES NO

Repair

High engine lubricating oil level has been detected.

Correct the engine lubricating oil level condition. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 007-037 in Section 7.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes

Guided Step 2A - Disable the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Is fault 688 inactive?
YES | NO
No Repair | No Repair

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 23-Apr-2012


FAULT CODE 689 - Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3164596 - male Framatome™ test lead, and Part Number 3164597 - female Framatome™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 284 active?
 | STEP 1B. Check for an active fault code. | Fault Code 689 active?
STEP 2. | Check the crankshaft engine speed sensor and circuit. |
 | STEP 2A. Inspect the crankshaft engine speed sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Crankshaft engine speed sensor state equals low?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2C-2. Inspect the crankshaft engine speed sensor. |
 | STEP 2C-3. Check the circuit response. |
 | STEP 2C-4. Verify adequate crankshaft engine speed sensor air gap. |
 | STEP 2D. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2E. Check the ECM response. | Monitor crankshaft engine speed sensor state equals low?
 | STEP 2E-1. Check the ECM response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 689 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 284 active?
YES | NO
No Repair | No Repair

Fault Code 284

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • While engine idles, monitor the fault code status.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?

YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the crankshaft engine speed sensor and circuit.

Guided Step 2A - Inspect the sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft engine speed sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft engine speed sensor from the engine harness.
  • Turn keyswitch ON.

Action

Measure the voltage at the sensor connector.

Measure the voltage between the crankshaft engine speed SUPPLY pin and the crankshaft engine speed RETURN pin at the sensor connector of the engine harness.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft engine speed sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Read the crankshaft engine speed sensor state using the INSITE™ electronic service tool monitor mode.

Crankshaft engine speed sensor state equals low?
YES | NO
No Repair | No Repair

Go to 2C-1

Go to 2D

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft engine speed sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the crankshaft engine speed SUPPLY pin and the crankshaft engine speed SIGNAL pin at the sensor connector of the engine harness. Check for the appropriate ECM response.

  • Read the crankshaft engine speed sensor state using the INSITE™ electronic service tool monitor mode.

Use the circuit diagram or wiring diagram for connector pin identification.

Crankshaft engine speed sensor state equals high?
YES | NO
No Repair | No Repair

Go to 2C-2

Go to 2D

Guided Step 2C-2 - Inspect the crankshaft engine speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove the crankshaft engine speed sensor from the engine. Refer to Procedure 019-365 in Section 19.

Action

Inspect the crankshaft engine speed sensor for the following:

  • Damaged sensor tip
  • Physical signs of the sensor touching the speed or speed teeth.

Damaged sensor tip?
YES NO

Repair

Replace the crankshaft engine speed sensor. Refer to Procedure 019-365 in Section 19.

No Repair

Go to 4A

Go to 2C-3

Guided Step 2C-3 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Remove the crankshaft engine speed sensor from the engine. Refer to Procedure 019-365 in Section 19.
  • Make sure the crankshaft engine speed sensor is connected to the harness.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Use the ratchet drive side of the socket tool that was used to remove the sensor from the engine, place it flush on the sensor so that the edge of the socket is on the edge of the sensor. Slowly slide the socket in a perpendicular direction to the marked line on the sensor or in a perpendicular direction to the mounting bracket of the sensor. Inspect for the following:

Check for the appropriate response.

  • Read the crankshaft engine speed sensor state using INSITE™ electronic service tool monitor mode.

Crankshaft engine speed sensor state transitions from high to low or low to high, or the state shows triggered?
YES NO
No Repair

Repair

Replace the crankshaft engine speed sensor. Refer to Procedure 019-365 in Section 19.

Go to 2C-4

Go to 4A

Guided Step 2C-4 - Verify adequate crankshaft engine speed sensor air gap.

Conditions

  • Turn keyswitch ON.
  • Install the crankshaft engine speed sensor to the engine. Refer to Procedure 019-365 in Section 19.
  • Connect INSITE™ electronic service tool.

Action

Momentarily engage the starter but do not start the engine. Repeat this as many times as necessary. Monitor the crankshaft engine speed sensor state of the crankshaft engine speed sensor for the following:

  • Change of state from high to low or low to high, or the state shows triggered.

Crankshaft engine speed sensor transitions from high to low or low to high, or the state shows triggered?
YES NO
No Repair

Repair

Inspect the crankshaft tone wheel for damage or spinning.

Use the appropriate base engine troubleshooting and repair manual for the repair or replacement.

Go to 4A

Go to 4A

Guided Step 2D - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Read the crankshaft engine speed sensor state using the INSITE™ electronic service tool monitor mode.

Monitor crankshaft engine speed sensor state equals low?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2E-1

Go to 4A

Guided Step 2E-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the crankshaft engine speed SUPPLY pin and the crankshaft engine speed SIGNAL pin at the ECM port.

Check for the appropriate ECM response.

  • Read the crankshaft engine speed sensor state using the INSITE™ electronic service tool monitor mode.

Use the circuit diagram or wiring diagram for connector pin identification.

Monitor crankshaft engine speed sensor state equals high?
YES NO

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage between the crankshaft engine speed SUPPLY pin and the crankshaft engine speed RETURN pin at the ECM engine harness port.

Use the circuit diagram or wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES NO

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Setion 19.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 689 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 22-Oct-2014


FAULT CODE 691 - Turbocharger #1 Compressor Inlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 691 inactive?
STEP 2. | Check the turbocharger compressor inlet air temperature sensor and circuit. |
 | STEP 2A. Inspect the turbocharger compressor inlet air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 250 ohms to 380k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 691 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response | Fault Code 692 active and Fault Code 691 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 691 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 691 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool, read the fault codes.

Fault Code 691 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the turbocharger compressor inlet air temperature sensor and circuit.

Guided Step 2A - Inspect the turbocharger compressor inlet air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor? connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the turbocharger compressor inlet air temperature sensor SIGNAL pin and the turbocharger compressor inlet air temperature sensor RETURN pin at the turbocharger compressor inlet air temperature sensor.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

250 ohms to 380k ohms?
YES NO
No Repair

Repair

Replace the turbocharger compressor inlet air temperature sensor. Refer to Procedure 019-395 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger compressor inlet air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool, to read the fault codes.

Fault Code 691 is active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the turbocharger compressor inlet air temperature sensor SIGNAL pin and the turbocharger compressor inlet air temperature sensor RETURN pin at the ECM connector.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 active and Fault Code 691 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector turbocharger compressor inlet air temperature sensor RETURN pin and the engine harness turbocharger compressor inlet air temperature sensor connector RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open RETURN circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the open return.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector compressor inlet air temperature sensor SIGNAL pin and the engine harness turbocharger compressor inlet air temperature sensor connector SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SIGNAL circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the turbocharger compressor inlet air temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool , read the fault codes.

Fault Code 691 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 691 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


FAULT CODE 692 - Turbocharger Number 1 Compressor Inlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 692 inactive?
STEP 2. | Check the turbocharger compressor inlet air temperature sensor and circuit. |
 | STEP 2A. Inspect the turbocharger compressor inlet air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 691 active and Fault Code 692 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 692 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 691 active and Fault Code 692 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 692 is inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 692 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the turbocharger compressor inlet air temperature sensor and circuit.

Guided Step 2A - Inspect the turbocharger compressor inlet air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 active and Fault Code 692 inactive?

YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger compressor inlet air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 is active?
YES NO

Repair

A damaged sensor has been detected.

Replace the turbocharger compressor inlet air temperature sensor. Refer to Procedure 019-395 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 active and Fault Code 692 inactive?

YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the turbocharger compressor inlet air temperature SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the turbocharger compressor inlet air temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the turbocharger compressor inlet air temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 is inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 692 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


FAULT CODE 731b - Engine Speed Sensor/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 731 the only active fault?
STEP 2. | Inspect the tone wheels and speed/position sensors. |
 | STEP 2A. Inspect the engine speed and position sensors for damage. | Any damage?
 | STEP 2B. Inspect the tone wheels for any damage. | Any damage?
STEP 3. | Inspect the engine and vehicle grounding. |
 | STEP 3A. Inspect the engine block, starter, alternator, chassis, and battery grounds. | All grounds present, properly grounded, free of corrosion, and tight?
STEP 4. | Check for correct engine static timing. |
 | STEP 4A. Check static timing. | Camshaft and crankshaft timing marks properly aligned at top dead center?
STEP 5. | Clear the fault code. |
 | STEP 5A. Disable the fault code. | Fault Code 731 inactive?
 | STEP 5B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Is fault code 731 the only active fault?

YES NO
No Repair

Repair

Troubleshoot any other active faults before continuing with this tree.

Go to 2A

Appropriate fault code troubleshooting tree.

Guided Step 2 - Inspect the tone wheels and speed/position sensors.

Guided Step 2A - Inspect the engine speed and position sensors for damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect for damage.

  • Inspect the engine and position sensors for damage.

Any damage?
YES NO

Repair

Replace the camshaft position sensor. Refer to Procedure 019-363 in Section 19.

Replace the crankshaft position sensor. Refer to Procedure 019-365 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Inspect the tone wheels for any damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect for damage.

Inspect the crankshaft and camshaft tone wheels for damage.

Any damage?
YES NO

Repair

Replace the tone wheel.

Replace the camshaft position sensor. Refer to Procedure 019-363 in Section 19.

Replace the crankshaft position sensor. Refer to Procedure 019-365 in Section 19.

Replace the tone wheel.

  • For ISC, QSC8.3, ISL, and QSL9 engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 001-008 in Section 1.
  • For ISB and QSB engines, use the following procedure in theISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 001-008 in Section 1.
  • For ISC, QSC8.3, ISL, and QSL9 engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 001-016 in Section 1.
  • For ISB and QSB engines, use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 001-016 in Section 1.
No Repair

Go to 5A

Go to 3A

Guided Step 3 - Inspect the engine and vehicle grounding.

Guided Step 3A - Inspect the engine block, starter, alternator, chassis, and battery grounds.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine and vehicle grounding.

  • Check all engine, starter, alternator, chassis, and battery grounds.
  • Verify all grounds are present and properly grounded.
  • Verify all connections are free of corrosion and tight.

Are all grounds present, properly grounded, free of corrosion, and tight?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace, tighten, or clean the ground wires or connections.

Go to 4A

Go to 5A

Guided Step 4 - Check for correct engine static timing.

Guided Step 4A - Check static timing.

Conditions

  • Remove the gear cover.
  • Rotate the engine to TDC for the number 1 cylinder and verify that the camshaft and crankshaft gear timing marks are properly aligned.
  • For ISC, QSC, ISL, and QSL engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bullein 4021418. Refer to Procedure 001-008 in Section 1.
  • For ISB and QSB engines, use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 001-008 in Section 1.

Action

Check the timing.

Inspect the engine static timing.

Are the camshaft and crankshaft timing marks properly aligned at TDC?
YES NO
No Repair

Repair

Remove and install camshaft to properly align timing marks at TDC.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 731 is inactive.

Fault Code 731 inactive?
YES NO
No Repair

Repair

Note: Crankshaft gear slippage can be caused by excessive hydraulic loads on the gear train. Check and correct any excessive hydraulic loading condition on the vehicle.

Replace the crankshaft assembly if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair Complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


FAULT CODE 731 (QSB Marine Application) - Engine Speed Sensor/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 731 the only active fault?
STEP 2. | Inspect the tone wheels and speed/position sensors. |
 | STEP 2A. Inspect the engine speed and position sensors for damage. | Any damage?
 | STEP 2B. Inspect the tone wheels for any damage. | Any damage?
STEP 3. | Inspect the engine and vehicle grounding. |
 | STEP 3A. Inspect the engine block, starter, alternator, chassis, and battery grounds. | Are all grounds present, properly grounded, free of corrosion, and tight?
STEP 4. | Check for correct engine static timing. |
 | STEP 4A. Check static timing. | Camshaft and crankshaft timing marks properly aligned at top dead center?
STEP 5. | Clear the fault code. |
 | STEP 5A. Disable the fault code. | Fault Code 731 inactive?
 | STEP 5B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Is fault code 731 the only active fault?

YES NO
No Repair

Repair

Troubleshoot any other active faults before continuing with this tree.

Go to 2A

Appropriate fault code troubleshooting tree.

Guided Step 2 - Inspect the tone wheels and speed/position sensors.

Guided Step 2A - Inspect the engine speed and position sensors for damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect for damage.

Inspect the engine and position sensors for damage.

Any damage?
YES NO

Repair

Replace the position or speed sensor. Replace the camshaft position sensor. Refer to Procedure 019-363 in Section 19.

Replace the crankshaft position sensor. Refer to Procedure 019-365 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Inspect the tone wheels for any damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect for damage.

Inspect the crankshaft and camshaft tone wheels for damage.

Any damage?
YES NO

Repair

Replace the tone wheel.

Replace the camshaft position sensor. Refer to Procedure 019-363 in Section 19.

Replace the crankshaft position sensor. Refer to Procedure 019-365 in Section 19.

  • For ISC, QSC, ISL, and QSL9 engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 001-008 in Section 1.
  • For ISB, ISBe, and QSB engines use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 001-008 in Section 1.
  • For ISC, QSC8.3, ISL, and QSL9 engines use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 001-016 in Section 1.
  • For ISB and QSB engines, use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 001-016 Section 1.
No Repair

Go to 5A

Go to 3A

Guided Step 3 - Inspect the engine and vehicle grounding.

Guided Step 3A - Inspect the engine block, starter, alternator, chassis, and battery grounds.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine and vehicle grounding.

  • Check all engine, starter, alternator, chassis, and battery grounds.
  • Verify all grounds are present and properly grounded.
  • Verify all connections are free of corrosion and tight.

Are all grounds present, properly grounded, free of corrosion, and tight?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace, tighten, or clean the ground wires or connections.

Go to 4A

Go to 5A

Guided Step 4 - Check for correct engine static timing.

Guided Step 4A - Check static timing.

Conditions

  • Remove the gear cover.
  • Rotate the engine to TDC for the number 1 cylinder and verify that the camshaft and crankshaft gear timing marks are properly aligned. For ISC, QSC, ISL, and QSL9 engines use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 001-008 in Section 1. For ISB, ISBe, and QSB engines, use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 001-008 in Section 1.

Action

Check the timing.

Inspect the engine static timing.

Are the camshaft and crankshaft timing marks properly aligned at TDC?
YES NO
No Repair

Repair

Remove and install camshaft to properly align timing marks at TDC.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 731 is inactive.

Fault Code 731 inactive?
YES NO
No Repair

Repair

Note: Crankshaft gear slippage can be caused by excessive hydraulic loads on the gear train. Check and correct any excessive hydraulic loading condition on the vehicle.

Replace the crankshaft assembly if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair Complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part No. 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Are other fault codes active?
STEP 2. | Check the batteries and the power harness connector. |
 | STEP 2A. Check the resistance of the battery supply circuit. | Less than 10 ohms?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least (+) 12 VDC? (During cranking: At least (+) 6.2 VDC)?
 | STEP 2C. Check the battery connections. | Connections are tight and corrosion-free?
STEP 3. | Check the OEM fuses. |
 | STEP 3A. Verify that the OEM fuses are installed correctly. | Fuses installed correctly?
 | STEP 3B. Verify that the OEM fuses are not blown. | Fuses not blown?
STEP 4. | Check the power connector. |
 | STEP 4A. Check the add-on or the accessory wiring at the positive (+) terminal of the battery. | No damaged wires?
STEP 5. | Recalibrate the ECM. |
 | STEP 5A. Recalibrate the ECM. | Fault Code 757 inactive?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 757 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ the electronic service tool to read the fault codes.

Action

Check for an active fault code.

  • Use INSITE™ the electronic service tool to read the fault codes.

Are other fault codes active?
YES NO

Repair

Troubleshoot the active fault codes.

 No Repair

Go to appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the batteries and the power connector.

Guided Step 2A - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness connector from the ECM.

Action

Check the resistance of the battery supply circuit.

  • Use a multimeter to measure the resistance between the ECM battery SUPPLY (+) pin of the power harness ECM connector and the positive (+) battery terminal.
  • Use a multimeter to measure the resistance between the ECM battery SUPPLY (-) pin of the power harness ECM connector and the engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to the Resistance Measurements Using a Multimeter and Wiring Diagram, Refer to Procedure 019-360.

Less than 10 ohms?
YES | NO
No Repair | No Repair

Go to 2B

Go to 3A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal. Touch the negative (-) probe of the multimeter to the negative battery terminal while trying to start the engine.

Normal conditions: At least (+) 12 VDC? (During cranking: At least (+) 6.2 VDC)?

YES NO
No Repair

Repair

Charge or replace the battery.

Refer to the OEM troubleshooting and repair manual.

Go to 2C

Go to 5A

Guided Step 2C - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Inspect the battery terminal connections.

Are connections tight and corrosion-free?
YES NO
No Repair

Repair

Tighten the loose connections and clean the terminals.

Refer to the OEM troubleshooting and repair manual.

Go to 4A

Go to 5A

Guided Step 3 - Check the OEM fuses.

Guided Step 3A - Verify that the OEM fuses are installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the OEM fuses for correct installation.

Are fuses installed correctly?
YES NO
No Repair

Repair

Install the fuses correctly.

Refer to Procedure 019-198.

Go to 3B

Go to 5A

Guided Step 3B - Verify that the OEM fuses are not blown.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the OEM fuses are not blown.

Are any fuses blown?
YES NO

Repair

Replace the fuses.

Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071.

Go to 5A

Go to 5A

Guided Step 4 - Check the power connector.

Guided Step 4A - Check the add-on or the accessory wiring at positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Are any wires damaged?
YES NO

Repair

Repair or replace the damaged wiring.

 No Repair

Go to 6A

Go to 5A

Guided Step 5 - Recalibrate the ECM.

Guided Step 5A - Recalibrate the ECM.

Conditions

  • Connect all components.

Action

Recalibrate the ECM.

  • Use INSITE™ electronic service tool to calibrate the ECM.

Is Fault Code 757 inactive?
YES | NO
No Repair | No Repair

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ the electronic service tool.

Action

Disable the fault code.

  • Turn keyswitch OFF and wait 30 seconds.
  • Turn keyswitch ON.

Fault Code 757 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact your local Cummins Authorized Repair Location if all the steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ the electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ the electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Jul-2010


FAULT CODE 778 - Engine Speed Sensor (Camshaft) Error - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3164596 - male Framatome™ test lead, and Part Number 3164597 - female Framatome™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 or 227 active?
 | STEP 1B. Check for an active fault code. | Fault Code 778 active?
STEP 2. | Check the camshaft engine position sensor and circuit. |
 | STEP 2A. Inspect the camshaft engine position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Camshaft engine position sensor state equals low?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2C-2. Inspect the camshaft engine position sensor. |
 | STEP 2C-3. Check the circuit response. |
 | STEP 2C-4. Inspect the camshaft gear teeth, air gap, and target wheel. |
 | STEP 2D. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2E. Check the ECM response. | Monitor camshaft position sensor state equals low?
 | STEP 2E-1. Check the ECM response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 or 227 active?
YES | NO
No Repair | No Repair

Fault Code 187 or 227

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the camshaft engine position sensor and circuit.

Guided Step 2A - Inspect the sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft engine position sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft engine position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

Measure the voltage between the camshaft position +5-VDC SUPPLY pin and the camshaft position RETURN pin at the sensor connector of the engine harness.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft engine position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Read the camshaft engine position sensor state. Use INSITE™ electronic service tool monitor mode.

Camshaft engine position sensor state equals low?
YES | NO
No Repair | No Repair

Go to 2C-1

Go to 2D

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft engine position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the camshaft position +5-VDC SUPPLY pin and the camshaft engine position SIGNAL pin at the sensor connector of the engine harness.

  • Check for the appropriate ECM response.
  • Read the camshaft position sensor state. Use INSITE™ electronic service tool monitor mode.

Refer to the wiring diagram for connector pin identification.

Camshaft engine position sensor state equals high?
YES | NO
No Repair | No Repair

Go to 2C-2

Go to 2D

Guided Step 2C-2 - Inspect the camshaft engine position sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove the camshaft engine position sensor from the engine. Refer to Procedure 019-363 in Section 19.

Action

Inspect the camshaft engine position sensor for the following:

  • Damaged sensor tip
  • Physical signs of the sensor touching the speed or position teeth.

Damaged sensor tip?
YES NO

Repair

Replace the camshaft engine position sensor. Refer to Procedure 019-363 in Section 19.

No Repair

Go to 4A

Go to 2C-3

Guided Step 2C-3 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Remove the camshaft engine position sensor from the engine. Refer to Procedure 019-363 in Section 19.
  • Ensure the camshaft engine position sensor is connected to the harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

Note: Use the ratchet drive side of the socket tool that was used to remove the sensor from the engine, place it flush on the sensor so that the edge of the socket is on the edge of the sensor. Slowly slide the socket in a perpendicular direction to the marked line on the sensor or in a perpendicular direction to the mounting bracket of the sensor.

Inspect for the following:

  • Check for the appropriate ECM response
  • Read the camshaft engine position sensor state. Use INSITE™ electronic service tool monitor mode.

Camshaft engine position sensor state transitions from high to low, or low to high, or the state shows triggered?
YES NO
No Repair

Repair

Replace the camshaft engine position sensor. Refer to Procedure 019-363 in Section 19.

Go to 2C-4

Go to 4A

Guided Step 2C-4 - Inspect the camshaft gear teeth, air gap, and target wheel.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the camshaft gear teeth for damage or a loose camshaft gear condition.

For ISB engines, use the ISBe, ISB, and QSB (Common Rail Fuel System) Service Manual, Bulletin 4021271.

For ISC or ISL engines, use the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4, and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418.

Inspect the air gap.

  • Remove the secondary engine speed sensor (camshaft sensor) from the gear housing and measure the air gap at several points in the crankshaft revolution. Refer to Procedure 019-363 in Section 19.

Air gap specifications:

  • Minimum air gap: 0.96 mm [0.038 in]
  • Maximum air gap: 2.25 mm [0.089 in]
  • Maximum target runout: 0.5 mm [0.02 in]

Is the air gap within specifications?
YES NO
No Repair

Repair

Replace or shim the sensor if the air gap is out of specification.

If the target runout is excessive:

For engines with machined speed sensor targets, replace the camshaft gear.

  • For ISB and QSB engines, use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manua, Bulletin 4021271. Refer to Procedure 001-012 in Section 1.
  • For ISC, QSC, ISL, and QSL engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 001-012 in Section 1.

For engines with bolt on speed sensor targets, replace the bolt on the timing plate.

  • For ISB and QSB engines, use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manua, Bulletin 4021271. Refer to Procedure 001-013 in Section 1.
  • For ISC, QSC, ISL, and QSL engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 001-013 in Section 1.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Read the camshaft engine position sensor state. Use INSITE™ electronic service tool monitor mode.

Monitor camshaft engine position sensor state equals low?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2E-1

Go to 4A

Guided Step 2E-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the camshaft position +5-VDC SUPPLY pin and the camshaft position SIGNAL pin at the ECM port.

Check for the appropriate ECM response.

  • Read the camshaft engine position sensor state. Use INSITE™ electronic service tool monitor mode.

Refer to the wiring diagram for connector pin identification.

Monitor camshaft engine position sensor state equals high?
YES NO

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage from the camshaft position +5-VDC SUPPLY pin to the camshaft position RETURN pin at the ECM port.

Refer to the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 778 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 779. | Active or inactive counts of Fault Code 779?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 779.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Using INSITE™, read the fault codes.

Active or inactive counts of Fault Code 779?
YES NO

Repair

The engine protection limit has been exceeded for the OEM supplied pressure or temperature input. Refer to the OEM troubleshooting manual.

No Repair

OEM troubleshooting manual

Repair complete

Last Modified: 08-Jul-2010


FAULT CODE 781 - SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for related fault codes. | Fault Code 3329 active?
STEP 2. | Check the engine control module (ECM) supply voltage circuit. |
 | STEP 2A. Check for correct ECM supply voltage. | Within 1 VDC?
 | STEP 2B. Check the keyswitch signal circuit. | Less than 10 ohms?
STEP 3. | Check the SAE J1939 data link circuit. |
 | STEP 3A. Check the SAE J1939 data link resistance in the engine wiring harness. | Between 108 and 132 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the Cummins® electronic service tool or equivalent.

Action

Check for an active fault code.

  • Use the Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 3329 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the secondary ECM supply voltage circuits.

Guided Step 2A - Check for correct ECM supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Turn the keyswitch ON.

Action

Check for correct ECM supply voltage.

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in Section 19.
  • Measure the voltage between the battery voltage SUPPLY pins and the battery voltage RETURN pins in the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Within 1 VDC?
YES NO
No Repair

Repair

Repair or replace the only the components that were found to be out of specification.

  • Troubleshoot the OEM wiring harness and all interconnects.
  • Replace the fuse. Refer to OEM service manual.
  • Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check the keyswitch signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM power supply wiring harness connector from the engine wiring harness

Action

Check for an open keyswitch signal circuit.

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in Section 19.
  • Measure the resistance of the keyswitch SIGNAL wire between the OEM power supply wiring harness connector and engine wiring harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the Society of Automotive Engineers (SAE) J1939 data link circuit.

Guided Step 3A - Check the SAE J1939 data link resistance in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Check the SAE J1939 data link engine network resistance.

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in Section 19.
  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Between 108 and 132 ohms?
YES NO

Repair

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Repair

Repair or replace the engine side of SAE J1939 data link. Refer to Procedure 019-428 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the Cummins® electronic service tool or equivalent to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 20-Oct-2021


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3163151 - Electronic Control Module (ECM) Bench Calibration HarnessPart Number 3164185 - ECM Bench Calibration Adapter Cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for adaptive cruise control hardware. |
 | STEP 1A. Check for correct hardware. | Is adaptive cruise hardware installed on the vehicle?
STEP 2. | Check SAE J1939 communications. |
 | STEP 2A. Check for ECM communication with INSITE™ electronic service tool. | Does INSITE™ electronic service tool communicate with the ECM?
 | STEP 2B. Inspect the OEM harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2C. Check ECM communication with the ECM bench calibration harness. | Does INSITE™ electronic service tool communicate with the ECM?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 784 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for adaptive cruise control hardware.

Guided Step 1A - Check for correct hardware.

Conditions

  • Turn keyswitch OFF.

Action

Check the hardware.

  • Verify that the adaptive cruise hardware is installed on the vehicle.

Is adaptive cruise hardware installed on the vehicle?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool, disable the adaptive cruise feature.

Go to 2A

Go to 3A

Guided Step 2 - Check SAE J1939 communications.

Guided Step 2A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect the INLINE™ II data link adapter to the vehicle SAE J1939 data link diagnostic connector.
  • Connect INSITE™ electronic service tool.

Action

Using INSITE™, electronic service tool attempt to communicate with ECM.

  • Start INSITE™ electronic service tool.
  • Select INSITE™ electronic service tool II (J1939) ECM connection.

Does INSITE™ electronic service tool communicate with the ECM?
YES NO

Repair

The ECM SAE J1939 data link circuit is functioning properly.

 No Repair

Refer to the OEM troubleshooting and repair manual for information on troubleshooting the adaptive cruise control unit and the vehicle SAE J1939 network

Go to 2B

Guided Step 2B - Inspect the OEM harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector seals.

For general inspection techniques, refer to Component Connector and Pin Inspection, Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to the Resistance Measurements Using a Multimeter and Wiring Diagram, Refer to Procedure 019-360.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check ECM communication with the ECM bench calibration harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Connect the ECM bench calibration harness to the ECM.
  • Connect INLINE™ II data link adapter to the ECM bench calibration harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™, electronic service tool attempt to communicate with the ECM.

  • Start INSITE™ electronic service tool electronic service tool and connect to the ECM with an INLINE™ II (J1939) ECM connection.

Does INSITE™ electronic service tool communicate with the ECM?
YES NO

Repair

INSITE™ electronic service tool is able to communicate with the ECM. This indicates that the ECM SAE J1939 data link circuit is functioning properly.

No Repair

Refer to the OEM troubleshooting and repair manual for troubleshooting the vehicle SAE J1939 circuit and devices

Refer to the Communication Error - Electronic Service Tool or Control Device troubleshooting symptom tree.

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool, verify that the fault code is inactive.

Fault Code 784 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool, erase the inactive fault codes .

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fuel system fault codes. |
 | STEP 1A. Read the fault codes. | Fuel system component fault codes active or have accumulated inactive counts?
STEP 2. | Perform diagnostic tests. |
 | STEP 2A. Perform the cylinder cutout test and/or the automated cylinder balance diagnostic test. | All cylinders test okay?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 951 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fuel system fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool read the fault codes.

Fuel system component fault codes active or have accumulated inactive counts?
YES NO

Repair

Troubleshoot full system component fault codes.

 No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Perform diagnostic tests.

Guided Step 2A - Perform the cylinder cutout test and/or the automated cylinder balance diagnostic test.

Conditions

  • Turn keyswitch ON.
  • Allow the engine to run at idle speed.
  • Connect INSITE™ electronic service tool.

Action

Use the automated cylinder balance diagnostic test to determine the power contribution of each cylinder.

All cylinders test okay?
YES NO
No Repair

Repair

Failure of cylinder test can be due to faulty engine brakes, valve lash out of adjustment, cylinder failure, valve failure, cylinder head or gasket failure, extreme camshaft wear, or injector failure.

Investigate, diagnose, and correct the condition of the applicable component that is possibly out of adjustment or malfunctioning. “Swap” injectors between cylinders to see whether or not the problem follows that injector.

Go to 3A

Troubleshooting and Repair Manual, ISBe, ISB, and QSB5.9 (Common Rail Fuel System), Bulletin 4021271.

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify that the fault code is inactive.

Fault Code 951 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault code 957 is active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 957 is active?
YES | NO
No Repair | No Repair

Refer to fault code 1228.

Repair Complete

Last Modified: 08-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault code 958 is active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 958 is active?
YES | NO
No Repair | No Repair

Refer to fault code 1229.

Repair Complete

Last Modified: 08-Jul-2010


FAULT CODE 1117 Automotive Application - Power Lost Without Ignition Off - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for multiple fault codes. | Active or inactive Fault Code 2362 and/or 2363?
STEP 2. | Check the batteries and the power connector. |
 | STEP 2A. Check the batteries and the power connector. | Connections tight and corrosion-free?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least + 12-VDC [+ 24-VDC with 24 volt system]; During cranking: At least + 6.2-VDC?
STEP 3. | Check the OEM power harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the battery power circuit. | At least + 10-VDC [+ 20-VDC for a 24 volt system]?
 | STEP 3B-1. Verify that the OEM fuse is installed correctly. |
 | STEP 3B-2. Check if the OEM fuse is blown. |
 | STEP 3B-3. Check the add-on or accessory wiring at the (+) terminal of the battery. |
 | STEP 3C. Check the resistance of the battery supply circuit. | Less than 1.0 ohms?
 | STEP 3D. Check the keyswitch input-to-ECM wire. | Keyswitch input wire interrupted?
 | STEP 3E. Check the keyswitch input circuit. | Less than 5 ohms?
STEP 4. | Check the engine wiring harness, solenoid, and injector circuits. |
 | STEP 4A. Check for signal voltage. | Greater than 3.75-VDC?
 | STEP 4A-1. Check the engine harness and the ECM connector pins. |
 | STEP 4A-2. Check for a signal short to ground at the ECM. |
 | STEP 4B. Check for a short to ground. | More than 100k ohms?
 | STEP 4C. Check the engine brake solenoids for a short to ground. | 5 ohms or greater?
 | STEP 4D. Inspect the injector pass-through connector pins. | Dirty or damaged pins or damaged wire insulation?
 | STEP 4E. Check the injector harness circuits for short circuits to ground. | Greater than 1k ohms?
 | STEP 4F. Check the injector solenoids for short circuits to ground. | Greater than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 1117 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Are the following fault codes active or inactive?

  • Fault Code 2362 (Engine Brake Solenoid Signal Number 1 Circuit)?
  • Fault Code 2363 (Engine Brake Solenoid Signal Number 2 Circuit)?

Active or inactive Fault Code 2362 and/or 2363?
YES NO

Repair

Perform troubleshooting for Fault Code 2362 or 2363.

 No Repair

Fault Codes 2362 or 2363

Go to 2A

Guided Step 2 - Check the batteries and the power connector.

Guided Step 2A - Check the batteries and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Repair

Tighten the connections.

Tighten the loose connections and clean the terminals. Refer to the OEM service manual.

Go to 2B

Go to 5A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal and touch the negative (-) probe to the negative battery terminal while trying to start the engine.

Normal conditions: At least + 12-VDC [+ 24-VDC with 24 volt system]; During cranking: At least + 6.2-VDC?
YES NO
No Repair

Repair

Charge or replace the battery. Refer to the OEM service manual.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM power harness.

Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness. Refer to Procedure 019-204 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM battery supply stub from the ECM.

Action

Check for an open circuit in the battery power circuits.

  • Use a multimeter to measure the voltage from the ECM battery SUPPLY (+) pin of the engine harness ECM battery supply stub connector and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

At least + 10-VDC [+ 20-VDC for a 24 volt system]?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Verify that the OEM fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the OEM fuse for correct installation.

–

Is fuse installed correctly?
YES NO
No Repair

Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B-2

Go to 5A

Guided Step 3B-2 - Check if the OEM fuse is blown.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the OEM fuse is not blown.

–

Is fuse blown?
YES NO

Repair

Locate the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Replace the blown fuse(s). Refer to Procedure 019-198 in Section 19.

No Repair

Go to 5A

Go to 3B-3

Guided Step 3B-3 - Check the add-on or the accessory wiring at the (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the (+) terminal of the battery.

  • Starting at the (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Any damaged wires?
YES NO

Repair

Repair or replace the damaged wiring.

Repair

Repair or replace the OEM power harness from the OEM power connector to the batteries.

Go to 5A

Go to 5A

Guided Step 3C - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM battery supply stub from the ECM.
  • Disconnect the positive terminal from the battery.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the engine harness ECM battery supply stub connector and the positive battery connector.
  • Measure the resistance between the ECM battery SUPPLY (-) pin of the engine harness ECM battery supply stub connector and the negative battery connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

NOTE: Since the battery supply circuit resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the circuit resistance.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1.0 ohms?
YES NO
No Repair

Repair

Repair or replace the ECM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check the keyswitch input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the keyswitch input wire from the keyswitch ignition post in the keyswitch assembly to the ECM to make sure there are no interruptions in the wire, such as solenoids or relays.

–

Keyswitch input wire interrupted?
YES NO

Repair

Correct the wiring so the wire is uninterrupted.

 No Repair

Go to 5A

Go to 3E

Guided Step 3E - Check the keyswitch input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM

Action

Check the keyswitch input circuit.

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine wiring harness, solenoid, and injector circuits.

Guided Step 4A - Check for signal voltage.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISC, QSC8.3, ISL and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 003-011 Section 11.
  • Disconnect the engine harness from the engine brake connector.
  • Turn keyswitch ON.

Action

Check for a short circuit to ground.

  • Use a multimeter to measure the voltage from the engine brake solenoid SIGNAL Number 1 pin of the engine harness to the engine block ground.
  • Use a multimeter to measure the voltage from the engine brake solenoid SIGNAL Number 2 pin of the engine harness to the engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Greater than 3.75-VDC?
YES | NO
No Repair | No Repair

Go to 4B

Go to 4A-1

Guided Step 4A-1 - Check the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness. Refer to Procedure 019-204 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 4A-2

Guided Step 4A-2 - Check for a signal short to ground at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check for a short to ground.

  • Use a multimeter to measure the voltage from the engine brake solenoid SIGNAL 1 pin of the ECM port to engine block ground.
  • Use a multimeter to measure the voltage from the engine brake solenoid SIGNAL 2 pin of the ECM port to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 3.75-VDC?
YES NO

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 4B - Check for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the Troubleshooting and Repair Manual, ISC, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 003-011 in Section 3.
  • Disconnect the engine harness from the engine brake connector.

Action

Check for a short to ground.

  • Use a multimeter to measure the resistance from the engine brake solenoid SIGNAL Number 1 pin of the engine brake connector to engine block ground.
  • Use a multimeter to measure the resistance from the engine brake solenoid SIGNAL Number 2 pin of the engine brake connector to engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground in the engine brake circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the short circuit to ground.

Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 4C

Guided Step 4C - Check the engine brake solenoids for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine brake connector.
  • Remove the engine valve cover.
  • Disconnect the engine brake wiring harness from solenoid number 1 and 2.

Action

Check the resistance of solenoid number 1 and number 2.

  • Use a multimeter to measure the resistance of solenoid number 1 terminal of the engine brake solenoid to the engine block ground.
  • Use a multimeter to measure the resistance of solenoid number 2 terminal of the engine brake solenoid to the engine block ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

5 ohms or greater?
YES NO
No Repair

Repair

Replace the engine brake solenoid. Use the following procedure in the Troubleshooting and Repair Manual, ISC, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 020-012 in Section 20.

Go to 4D

Go to 5A

Guided Step 4D - Inspect the injector pass-through connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness from the injector pass-through connectors corresponding to the cylinders that are on the front and rear bank.

Action

Inspect the injector pass-through connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

A damaged connection has been detected in the injector circuit.

Repair or replace the injector harness or pass-through connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Replace the injector harness pass-through connector. Refer to Procedure 019-206 in Section 19.

For wire insulation damage, replace the injector harness. Refer to Procedure 019-063 in Section 19.

No Repair

Go to 5A

Go to 4E

Guided Step 4E - Check the injector harness circuits for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all injector pass-through connectors corresponding to the cylinders that are on the front and rear bank.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder number 1 DRIVER pin and engine block ground.
  • Measure the resistance between the cylinder number 2 DRIVER pin and engine block ground.
  • Measure the resistance between the cylinder number 3 DRIVER pin and engine block ground.
  • Measure the resistance between the cylinder number 4 DRIVER pin and engine block ground.
  • Measure the resistance between the cylinder number 5 DRIVER pin and engine block ground.
  • Measure the resistance between the cylinder number 6 DRIVER pin and engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 1k ohms?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4F

Guided Step 4F - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all injector pass-through connectors from the engine harness.
  • Disconnect the injector harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the cylinder number 1 DRIVER pin and engine block ground.
  • Measure the resistance between the cylinder number 2 DRIVER pin and engine block ground.
  • Measure the resistance between the cylinder number 3 DRIVER pin and engine block ground.
  • Measure the resistance between the cylinder number 4 DRIVER pin and engine block ground.
  • Measure the resistance between the cylinder number 5 DRIVER pin and engine block ground.
  • Measure the resistance between the cylinder number 6 DRIVER pin and engine block ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Repair or replace the injector harness. Refer to Procedure 019-063 in Section 19.

Repair

Replace the injector(s).

  • For ISC, QSC, and ISL engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-026 in Section 6.
  • For ISB engines, use the following procedure in the ISB, ISBe, QSB (Common Rail Fuel System) Engines, Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine, and let it idle for 1 minute.
  • Turn keyswitch to OFF position for 30 seconds.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to verify Fault Code 1117 is inactive.

NOTE: For Fault Code 1117 to become inactive, the ECM must go through one complete shutdown.

Fault Code 1117 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Apr-2012


FAULT CODE 1117 (Marine Application) - Power Lost without Ignition Off - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the batteries and the power connector. |
 | STEP 1A. Check the batteries and the power connector. | Connections tight and corrosion-free?
 | STEP 1B. Check the battery voltage. | Normal conditions: At least + 12-VDC [+ 24-VDC with 24 volt system]; During cranking: At least + 6.2-VDC?
STEP 2. | Check the OEM power harness. |
 | STEP 2A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the battery power circuit. | At least + 10-VDC [+ 20-VDC for a 24 volt system]?
 | STEP 2B-1. Verify that the OEM fuse is installed correctly. |
 | STEP 2B-2. Check if the OEM fuse is blown. |
 | STEP 2B-3. Check the add-on or accessory wiring at the (+) terminal of the battery. |
 | STEP 2C. Check the resistance of the battery supply circuit. | Less than 1.0 ohm?
 | STEP 2D. Check the keyswitch input-to-ECM wire. | Keyswitch input wire interrupted?
 | STEP 2E. Check the keyswitch input circuit. | Less than 5 ohms?
STEP 3. | Check the engine wiring harness. |
 | STEP 3A. Check the engine harness and the ECM connector pins. | Dirty or damaged pins?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1117 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the batteries and the power connector.

Guided Step 1A - Check the batteries and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Repair

Tighten the connections.

Tighten the loose connections and clean the terminals. Refer to the OEM service manual.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal and touch the negative (-) probe to the negative battery terminal while trying to start the engine.

Normal conditions: At least + 12-VDC [+ 24-VDC with 24 volt system]; During cranking: At least + 6.2-VDC?
YES NO
No Repair

Repair

Charge or replace the battery.

Refer to the OEM service manual.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM power harness.

Guided Step 2A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness. Refer to Procedure 019-204 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM battery supply stub from the ECM.

Action

Check for an open circuit in the battery power circuits.

  • Use a multimeter to measure the voltage from the ECM battery supply (+) pin of the engine harness ECM battery supply stub connector and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

At least + 10-VDC [+ 20-VDC for a 24 volt system]?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2B-1

Guided Step 2B-1 - Verify that the OEM fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the OEM fuse for correct installation.

Is fuse installed correctly?
YES NO
No Repair

Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 2B-2

Go to 4A

Guided Step 2B-2 - Check if the OEM fuse is blown.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the OEM fuse is not blown.

–

Is fuse blown?
YES NO

Repair

Locate the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Replace the blown fuse(s). Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 2B-3

Guided Step 2B-3 - Check the add-on or the accessory wiring at the (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the (+) terminal of the battery.

  • Starting at the (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Any damaged wires?
YES NO

Repair

Repair or replace the damaged wiring.

Repair

Repair or replace the OEM power harness from the OEM power connector to the batteries.

Go to 4A

Go to 4A

Guided Step 2C - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM battery supply stub from the ECM.
  • Disconnect the positive terminal from the battery.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the engine harness ECM battery supply stub connector and the positive battery connector.
  • Measure the resistance between the ECM battery SUPPLY (-) pin of the engine harness ECM battery supply stub connector and the negative battery connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

NOTE: Since the battery supply circuit resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the circuit resistance.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1.0 ohm?
YES NO
No Repair

Repair

Repair or replace the ECM power harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check the keyswitch input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the keyswitch input wire from the keyswitch ignition post in the keyswitch assembly to the ECM to make sure there are no interruptions in the wire, such as solenoids or relays.

–

Keyswitch input wire interrupted?
YES NO

Repair

Correct the wiring so the wire is uninterrupted.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check the keyswitch input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the keyswitch input circuit.

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine wiring harness.

Guided Step 3A - Check the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Check the engine harness and ECM connector pins for the following.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair the engine harness. Refer to Procedure 019-204 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine, and let it idle for 1 minute.
  • Turn the keyswitch to the OFF position for 30 seconds.
  • Turn the keyswitch ON.
  • Use INSITE™ to verify Fault Code 1117 is inactive.

NOTE: For Fault Code 1117 to become inactive, the ECM must go through one complete shutdown.

Fault Code 1117 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Apr-2012


FAULT CODE 1119 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault code. |
 | STEP 1A. Check for Fault Code 1119. | Active or inactive counts of Fault Code 1119?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for Fault Code 1119.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 1119.

Use INSITE™ electronic service tool to read the fault code.

Active or inactive counts of Fault Code 1119?
YES NO

Repair

Reference the Engine Coolant Temperature Above Normal symptom tree in Troubleshooting and Repair Manual, ISC, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418 or ISB (Common Rail Fuel System) Series Engines, Bulletin 4021271.

No Repair

Appropriate troubleshooting symptom tree.

Repair complete.

Last Modified: 07-May-2014


FAULT CODE 1139 - Injector Solenoid Driver Cylinder 1 - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1139. | Active or high inactive counts of Fault Code 1139 and loud engine knock occurs?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for a stuck open injector. | Does the engine knock go away and Fault Code 1139 is inactive?
 | STEP 2A-1. Check for progressive cylinder damage. |
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1139 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1139.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or high inactive counts of Fault Code 1139 and a loud engine knock occurs?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for a stuck open injector.

Conditions

  • Turn keyswitch OFF.

Action

Check for a stuck open injector.

Use the fuel system leak tester blocking tool, part number 3164325, to block the fuel flow going to injector number 1.

  • For ISB and QSB engines, use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6.
  • For ISC, QSC, ISL, and QSL engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-026 in Section 6.

Start the engine and idle for one minute.

Does the engine knock go away and Fault Code 1139 is inactive?
YES NO

Repair

A stuck open injector nozzle has been detected.

Replace the fuel injector.

  • For ISB and QSB engines, use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6.
  • For ISC, QSC, ISL, and QSL engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 2A-1

Refer to Engine Noise symptom tree

Guided Step 2A-1 - Check for progressive cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Measure the engine crankcase blowby. For ISB and QSB engines, use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 014-010 in Section 14. For ISC, QSC, ISL, and QSL engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 014-010 in Section 14.

Action

Progressive engine damage is possible due to the damaged injector.

  • Check for progressive damage
  • Measure engine crankcase blowby.

Crankcase blowby measurement exceeds the specified limit?
YES NO

Repair

Inspect for progressive engine damage.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1139 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Apr-2012


FAULT CODE 1141 - Injector Solenoid Driver Cylinder 2 - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1141. | Active or high inactive counts of Fault Code 1141 and loud engine knock occurs?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for a stuck open injector. | Does the engine knock go away and Fault Code 1141 is inactive?
 | STEP 2A-1. Check for progressive cylinder damage. |
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1141 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1141.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or high inactive counts of Fault Code 1141 and a loud engine knock occurs?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for a stuck open injector.

Conditions

  • Turn keyswitch OFF.

Action

Check for a stuck open injector.

Using the fuel system leak tester blocking tool, part number 3164325, block the fuel flow going to injector number 2.

  • For ISB and QSB engines, use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6.
  • For ISC, QSC, ISL, and QSL engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-026 in Section 6.
  • Start the engine and idle for one minute.

Does the engine knock go away and Fault Code 1141 is inactive?
YES NO

Repair

A stuck open injector nozzle has been detected.

Replace the fuel injector. For ISB and QSB engines, use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6. For ISC, QSC, ISL, and QSL engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 2A-1

See Engine Noise symptom tree

Guided Step 2A-1 - Check for progressive cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Measure the engine crankcase blowby. For ISB and QSB engines, use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 014-010 in Section 14. For ISC, QSC, ISL, and QSL engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 014-010 in Section 14.

Action

Progressive engine damage is possible due to the failed injector.

  • Check for progressive damage
  • Measure engine crankcase blowby.

Crankcase blowby measurement exceeds the specified limit?
YES NO

Repair

Inspect for progressive engine damage.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1141 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Apr-2012


FAULT CODE 1142 - Injector Solenoid Driver Cylinder 3 - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1142. | Active or high inactive counts of Fault Code 1142 and loud engine knock occurs?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for a stuck open injector. | Does the engine knock go away and Fault Code 1142 is inactive?
 | STEP 2A-1. Check for progressive cylinder damage. |
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1142 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1142.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or high inactive counts of Fault Code 1142 and a loud engine knock occurs?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for a stuck open injector.

Conditions

  • Turn keyswitch OFF.

Action

Check for a stuck open injector.

Using the fuel system leak tester blocking tool, part number 3164325, block the fuel flow going to injector number 3.

  • For ISB and QSB engines, use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6.
  • For ISC, QSC, ISL, and QSL engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-026 in Section 6.
  • Start the engine and idle for one minute.

Does the engine knock go away and Fault Code 1142 is inactive?
YES NO

Repair

A stuck open injector nozzle has been detected.

Replace the fuel injector.

  • For ISB and QSB engines, use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6.
  • For ISC, QSC, ISL, and QSL engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-026 in Section 6.
No Repair

Go to 2A-1

Refer to Engine Noise symptom tree

Guided Step 2A-1 - Check for progressive cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Measure the engine crankcase blowby. For ISB and QSB engines, use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 014-010 in Section 14. For ISC, QSC, ISL, and QSL engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 014-010 in Section 14.

Action

Progressive engine damage is possible due to the damaged injector.

  • Check for progressive damage
  • Measure engine crankcase blowby.

Crankcase blowby measurement exceeds the specified limit?
YES NO

Repair

Inspect for progressive engine damage.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1142 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Apr-2012


FAULT CODE 1143 - Injector Solenoid Driver Cylinder 4 - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1143. | Active or high inactive counts of Fault Code 1143 and loud engine knock occurs?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for a stuck open injector. | Does the engine knock go away and Fault Code 1143 is inactive?
 | STEP 2A-1. Check for progressive cylinder damage. |
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1143 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1143.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or high inactive counts of Fault Code 1143 and a loud engine knock occurs?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for a stuck open injector.

Conditions

  • Turn keyswitch OFF.

Action

Check for a stuck open injector.

Using the fuel system leak tester blocking tool, part number 3164325, block the fuel flow going to injector number 4.

  • For ISB and QSB engines, use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6.
  • For ISC, QSC, ISL, and QSL engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-026 in Section 6.
  • Start the engine and idle for one minute.

Does the engine knock go away and Fault Code 1143 is inactive?
YES NO

Repair

A stuck open injector nozzle has been detected.

Replace the fuel injector. For ISB and QSB engines, use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6. For ISC, QSC, ISL, and QSL engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 2A-1

Refer to Engine Noise symptom tree

Guided Step 2A-1 - Check for progressive cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Measure the engine crankcase blowby.
  • For ISB and QSB engines, use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 014-010 in Section 14.
  • For ISC, QSC, ISL, and QSL engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 014-010 in Section 14.

Action

Progressive engine damage is possible due to the damaged injector.

  • Check for progressive damage
  • Measure engine crankcase blowby.

Crankcase blowby measurement exceeds the specified limit?
YES NO

Repair

Inspect for progressive engine damage.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1143 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Apr-2012


FAULT CODE 1144 - Injector Solenoid Driver Cylinder 5 - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1144. | Active or high inactive counts of Fault Code 1144, excessive exhaust smoke, and loud engine knock occurs?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for a stuck open injector. | Does the engine knock, and excessive exhaust smoke go away and Fault Code 1144 is inactive?
 | STEP 2A-1. Check for progressive cylinder damage. Measure engine crankcase blowby. |
STEP 3. | Reset the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1144 inactive?
 | STEP 3B. Reset the inactive fault codes. | All fault codes reset?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1144.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or high inactive counts of Fault Code 1144, excessive exhaust smoke, and loud engine knock occurs?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for a stuck open injector.

Conditions

  • Turn keyswitch OFF.

Action

Check for a stuck open injector.

Using the fuel system leak tester blocking tool, Part Number 3164325, block the fuel flow going to injector Number 5.

  • For ISB and QSB engines, use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6.
  • For ISC, QSC, ISL, and QSL engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-026 in Section 6.
  • Start the engine and idle for one minute.

Does the engine knock and excessive exhaust smoke go away and Fault Code 1144 is inactive?
YES NO

Repair

A stuck open injector nozzle has been detected.

Replace the fuel injector. For ISB and QSB engines, use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6. For ISC, QSC, ISL, and QSL engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 2A-1

Refer to Engine Noise symptom tree

Guided Step 2A-1 - Check for progressive cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Measure the engine crankcase blowby. For ISB and QSB engines, use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 014-010 in Section 14. For ISC, QSC, ISL, and QSL engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 014-010 in Section 14.

Action

Progressive engine damage is possible due to the damaged injector.

  • Check for progressive damage
  • Measure engine crankcase blowby.

Crankcase blowby measurement exceeds the specified limit?
YES NO

Repair

Inspect for progressive damage.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Reset the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1144 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Reset the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Reset the inactive fault codes.

  • Use the INSITE™ electronic service tool to reset the inactive fault codes.

All fault codes reset?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Apr-2012


FAULT CODE 1145 - Injector Solenoid Driver Cylinder 6 - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1145. | Active or high inactive counts of Fault Code 1145, excessive exhaust smoke, and loud engine knock occurs?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for a stuck open injector. | Does the engine knock, and excessive exhaust smoke go away and Fault Code 1145 is inactive?
 | STEP 2A-1. Check for progressive cylinder damage. Measure engine crankcase blowby. |
STEP 3. | Reset the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1145 inactive?
 | STEP 3B. Reset the inactive fault codes. | All fault codes reset?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1145.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or high inactive counts of Fault Code 1145, excessive exhaust smoke, and loud engine knock occurs?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for a stuck open injector.

Conditions

  • Turn keyswitch OFF.

Action

Check for a stuck open injector.

Use fuel system leak tester blocking tool, Part Number 3164325, to block the fuel flow going to injector Number 6.

  • For ISB and QSB engines, use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6.
  • For ISC, QSC, ISL, and QSL engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-026 in Section 6.
  • Start the engine and idle for one minute.

Does the engine knock and excessive exhaust smoke go away and Fault Code 1145 is inactive?
YES NO

Repair

A stuck open injector nozzle has been detected.

Replace the fuel injector. For ISB and QSB engines, use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6. For ISC, QSC, ISL, and QSL engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 2A-1

Refer to Engine Noise symptom tree

Guided Step 2A-1 - Check for progressive cylinder damage.

Conditions

  • Turn keyswitch OFF.
  • Measure the engine crankcase blowby. For ISB and QSB engines, use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 014-010 in Section 14. For ISC, QSC, ISL, and QSL engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 014-010 in Section 14.

Action

Progressive engine damage is possible due to the damaged injector.

  • Check for progressive damage
  • Measure engine crankcase blowby.

Crankcase blowby measurement exceeds the specified limit?
YES NO

Repair

Inspect for progressive damage.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Reset the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1145 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Reset the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Reset the inactive fault codes.

  • Use INSITE™ electronic service tool to reset the inactive fault codes.

All fault codes reset?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Apr-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Check for fault codes. | Other active or inactive fault codes?
 | STEP 1B. Check for Fault Code 1228. | Active or inactive counts of Fault Code 1228?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault codes. | Fault Code 1228 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Other active or inactive fault codes?
YES | NO
No Repair | No Repair

Troubleshoot other fault codes

Go to 1B

Guided Step 1B - Check for Fault Code 1228.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1228?
YES NO

Repair

Replace the EGR position sensor. Refer to Procedure 019-372.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Start the engine and let it idle for one minute.

  • Use INSITE™ electronic service tool to verify Fault Code 1228 is inactive.

Fault Code 1228 inactive?
YES | NO
No Repair | No Repair

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Erase the inactive fault codes using INSITE™ electronic service tool.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Jul-2010


FAULT CODE 1229 - VGT Position Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Check for fault codes. | Other active or inactive fault codes?
 | STEP 1B. Check for Fault Code 1229. | Fault Code 1229 active?
STEP 2. | Check the turbocharger position sensor and circuit. |
 | STEP 2A. Inspect the turbocharger position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2382 active?
 | STEP 2C. Check the circuit response. | Fault Code 2381 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Clear the circuit response. | Fault Code 2382 active?
 | STEP 3C. Clear the circuit response. | Fault Code 2381 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault codes. | Fault Code 1229 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Other active or inactive fault codes?
YES | NO
No Repair | No Repair

Troubleshoot other fault codes

Go to 1B

Guided Step 1B - Check for Fault Code 1229.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1229 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the turbocharger position sensor circuit.

Guided Step 2A - Inspect the turbocharger position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger position sensor from the engine harness.

Action

Inspect the turbocharger position sensor and connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use the INSITE™ electronic service tool to read the fault codes.

Fault Code 2382 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Install a jumper wire between the turbocharger position +5-VDC SUPPLY pin and the turbocharger position SIGNAL pin at the sensor connector of the engine harness.

See the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2381 active?
YES NO

Repair

Replace the turbocharger position sensor. Refer to Procedure 019-405 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2382 active?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Install a jumper wire between the turbocharger position +5-VDC SUPPLY pin and the turbocharger position SIGNAL pin at the engine control module engine connector.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2381 active?
YES NO

Repair

High resistance or a short circuit has been detected in the engine harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Start the engine and let it idle for 1 minute.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1229 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® authorized repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 28-Mar-2012


FAULT CODE 1239 - Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1695 active?
STEP 2. | Check the accelerator pedal position sensor and circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1241 active and Fault Code 1239 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal condition. | Fault Code 1239 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1239 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1239 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 active?
YES | NO
No Repair | No Repair

Fault Code 1695

Go to 2A

Guided Step 2 - Check the accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and exhaust gas temperature 1 sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A defective connection has been detected in the sensor connector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the accelerator pedal supply voltage.

  • Measure the voltage from the accelerator pedal position sensor 5 volt SUPPLY pin to the accelerator pedal position sensor RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1241 active and Fault Code 1239 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1239 active?
YES NO

Repair

A damaged accelerator pedal has been detected. Contact the appropriate OEM or dealership for repair instructions.

Replace the accelerator pedal. Refer to the OEM service manual.

Repair

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal RETURN pin and the OEM harness accelerator pedal RETURN pin.

Refer to the circuit diagram and the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open RETURN circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1239 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the problem.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1239 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Apr-2012


FAULT CODE 1241 - Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1696 active?
STEP 2. | Check the accelerator pedal position sensor and circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1239 active and Fault Code 1241 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal condition. | Fault Code 1241 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 1241 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1241 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Fault Code 1696

Go to 2A

Guided Step 2 - Check the accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and accelerator pedal position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the accelerator pedal position sensor supply voltage.

  • Measure the voltage from the accelerator pedal position sensor 5 volt SUPPLY pin to the accelerator pedal position sensor RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the accelerator pedal position +5-VDC SUPPLY pin and the accelerator pedal position SIGNAL pin at the sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 1239 active and Fault Code 1241 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1241 active?
YES NO

Repair

A damaged accelerator pedal has been detected. Contact the appropriate OEM or dealership for repair instructions.

Replace the accelerator pedal. Refer to the OEM service manual.

Repair

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal SUPPLY pin and the OEM harness accelerator pedal connector SUPPLY pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SUPPLY circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal SIGNAL pin and the OEM harness accelerator pedal connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SIGNAL circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1241 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the problem.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1241 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Apr-2012


FAULT CODE 1242 - Accelerator Pedal or Lever Position Sensor Number 1 and Number 2 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Codes 131, 132, 1239, or 1241 active?
STEP 2. | Check the accelerator pedal position sensor readings. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Codes 132 and 1241 both active?
 | STEP 2C. Check the accelerator pedal position number 1 sensor supply and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2D. Check the accelerator pedal position number 2 sensor supply and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2E. Check the fault codes. | Fault Codes 1242 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1242 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 131, 132, 1239, or 1241 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the accelerator pedal position sensor readings.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and accelerator pedal sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes 132 and 1241 are both active?
YES NO
No Repair

Repair

If fault code 132 did not go active, follow fault code 132 troubleshooting tree.

If fault code 1241 did not go active, follow fault code 1241 troubleshooting tree.

Go to 2C

Appropriate fault code troubleshooting tree.

Guided Step 2C - Check the accelerator pedal position number 1 sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the accelerator from the pedal position number 1 sensor +5 volt SUPPLY pin to the accelerator pedal position number 1 sensor RETURN pin at the sensor connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Repair

Low sensor supply voltage has been detected.

Refer to fault code 132 troubleshooting tree.

Go to 2D

Fault code 132 troubleshooting tree.

Guided Step 2D - Check the accelerator pedal position number 2 sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Measure the voltage from the accelerator from the pedal position number 2 sensor +5 volt SUPPLY pin to the accelerator pedal position number 2 sensor RETURN pin at the sensor connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Repair

Low sensor supply voltage has been detected.

Refer to fault code 1241 troubleshooting tree.

Go to 2E

Fault code 1241 troubleshooting tree.

Guided Step 2E - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal position sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Fully depress and release the accelerator pedal 3 times.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1242 is inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the accelerator position number 1 sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the accelerator position number 2 sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

A damaged accelerator pedal has been detected. Contact the appropriate OEM or dealership for repair instructions.

Replace the accelerator pedal.

Refer to the OEM service manual.

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Fully depress and release the accelerator pedal 3 times.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1242 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 23-Apr-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1633 is active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1633 is active?
YES NO

Repair

A error has been detected in the OEM data link.

Refer to the OEM troubleshooting manual for more information.

 No Repair

Repair complete.

Repair complete.

Last Modified: 08-Jul-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1639. | Active or inactive counts of Fault Code 1639?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1639.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1639?
YES NO

Repair

The maximum inlet temperate or inlet pressure for the Exhaust Gas Filter has been exceeded.

Refer to Exhaust Gas Filter troubleshooting.

 No Repair

Exhaust Gas Filter Troubleshooting.

Repair complete

Last Modified: 08-Jul-2010


FAULT CODE 1654 - Engine Misfire Cylinder 1 - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fuel system related fault codes active or have accumulated inactive counts?
 | STEP 1B. Check for cylinder misfire. | Cylinder misfire detected?
STEP 2. | Perform diagnostic tests. |
 | STEP 2A. Perform the cylinder cutout test. | Cylinder misfire detected and isolated to injector?
STEP 3. | Clear the fault code. |
 | STEP 3A. Verify the repair | Cylinder misfire present?
 | STEP 3B. Clear the fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine and let it idle for 1 minute
  • Use INSITE™ electronic service tool to read the fault codes.

Fuel system related fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for cylinder misfire.

Conditions

  • Turn keyswitch ON.
  • Start the engine and run at low idle.

Action

Check for smoke, engine stumble, rough idle or misfire.

  • Check for black or white smoke, engine stumble, rough idle or misfire at low idle, high idle, and during snap throttle accelerations.

Cylinder misfire detected?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Perform diagnostic tests.

Guided Step 2A - Perform the cylinder cutout test

Conditions

  • Turn the keyswitch ON
  • Allow the engine to run at idle speed
  • Connect INSITE™ electronic service tool.

Action

Determine if cylinder number 1 injector is misfiring.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to determine if the cylinder number 1 injector is misfiring.

Cylinder misfire detected and isolated to the injector?
YES NO

Repair

A damaged injector has been detected.

Replace the cylinder number 1 injector.

  • For ISB and QSB engines, use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6.
  • For ISC, QSC, ISL, and QSL engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-026 in Section 6.

Repair

Check for other sources of cylinder misfire such as valve lash out of adjustment, cylinder damage, valve damage, cylinder head or gasket damage, extreme camshaft wear, or mistimed air compressor.

Go to 3A

Appropriate troubleshooting procedures.

Guided Step 3 - Clear the fault code.

Guided Step 3A - Verify the repair.

Conditions

  • Connect all components
  • Turn the keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Verify cylinder misfire is no longer present.

  • Start the engine and verify the cylinder misfire is no longer present.

Cylinder misfire is present?
YES NO

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 3B

Guided Step 3B - Clear the fault codes.

Conditions

  • Connect all components
  • Turn the keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear all active and inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps.

Last Modified: 23-Apr-2012


FAULT CODE 1655 - Engine Misfire Cylinder 2 - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fuel system related fault codes active or have accumulated inactive counts?
 | STEP 1B. Check for cylinder misfire. | Cylinder misfire detected?
STEP 2. | Perform diagnostic tests. |
 | STEP 2A. Perform the cylinder cutout test. | Cylinder misfire detected and isolated to injector?
STEP 3. | Clear the fault code. |
 | STEP 3A. Verify the repair | Cylinder misfire present?
 | STEP 3B. Clear the fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine and let it idle for 1 minute
  • Use INSITE™ electronic service tool to read the fault codes.

Fuel system related fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for cylinder misfire.

Conditions

  • Turn keyswitch ON.
  • Start the engine and run at low idle.

Action

Check for smoke, engine stumble, rough idle or misfire.

  • Check for black or white smoke, engine stumble, rough idle or misfire at low idle, high idle and during snap throttle accelerations.

Cylinder misfire detected?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Perform diagnostic tests.

Guided Step 2A - Perform the cylinder cutout test

Conditions

  • Turn the keyswitch ON
  • Allow the engine to run at idle speed
  • Connect INSITE™ electronic service tool.

Action

Determine if cylinder number 2 injector is misfiring.

  • Use the INSITE™ electronic service tool Cylinder Cutout Test to determine if the cylinder number 2 injector is misfiring.

Cylinder misfire detected and isolated to the injector?
YES NO

Repair

A damaged injector has been detected.

Replace the cylinder number 2 injector.

  • For ISB and QSB engines, use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6.
  • For ISC, QSC, ISL, and QSL engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-026 in Section 6.

Repair

Check for other sources of cylinder misfire such as: valve lash out of adjustment, cylinder damage, valve damage, cylinder head or gasket damage, extreme camshaft wear, or mis-timed air compressor.

Go to 3A

Appropriate troubleshooting procedures.

Guided Step 3 - Clear the fault code.

Guided Step 3A - Verify the repair.

Conditions

  • Connect all components
  • Turn the keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Verify cylinder misfire is no longer present.

  • Start the engine and verify the cylinder misfire is no longer present.

Cylinder misfire is present?
YES NO

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 3B

Guided Step 3B - Clear the fault codes.

Conditions

  • Connect all components
  • Turn the keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear all active and inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 23-Apr-2012


FAULT CODE 1656 - Engine Misfire Cylinder 3 - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fuel system related fault codes active or have accumulated inactive counts?
 | STEP 1B. Check for cylinder misfire. | Cylinder misfire detected?
STEP 2. | Perform diagnostic tests. |
 | STEP 2A. Perform the cylinder cutout test. | Cylinder misfire detected and isolated to injector?
STEP 3. | Clear the fault code. |
 | STEP 3A. Verify the repair | Cylinder misfire present?
 | STEP 3B. Clear the fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine and let it idle for 1 minute
  • Use INSITE™ electronic service tool to read the fault codes.

Fuel system related fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for cylinder misfire.

Conditions

  • Turn keyswitch ON.
  • Start the engine and run at low idle.

Action

Check for smoke, engine stumble, rough idle or misfire.

  • Check for black or white smoke, engine stumble, rough idle or misfire at low idle, high idle and during snap throttle accelerations.

Cylinder misfire detected?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Perform diagnostic tests.

Guided Step 2A - Perform the cylinder cutout test

Conditions

  • Turn the keyswitch ON
  • Allow the engine to run at idle speed
  • Connect INSITE™ electronic service tool.

Action

Determine if cylinder number 3 injector is misfiring.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to determine if the cylinder number 3 injector is misfiring.

Cylinder misfire detected and isolated to the injector?
YES NO

Repair

A damaged injector has been detected.

Replace the cylinder number 3 injector.

  • For ISB and QSB engines, use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6.
  • For ISC, QSC, ISL, and QSL engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-026 in Section 6.

Repair

Check for other sources of cylinder misfire such as valve lash out of adjustment, cylinder damage, valve damage, cylinder head or gasket damage, extreme camshaft wear, or mistimed air compressor.

Go to 3A

Appropriate troubleshooting procedures.

Guided Step 3 - Clear the fault code.

Guided Step 3A - Verify the repair.

Conditions

  • Connect all components
  • Turn the keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Verify cylinder misfire is no longer present.

  • Start the engine and verify the cylinder misfire is no longer present.

Cylinder misfire is present?
YES NO

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 3B

Guided Step 3B - Clear the fault codes.

Conditions

  • Connect all components
  • Turn the keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear all active and inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps.

Last Modified: 23-Apr-2012


FAULT CODE 1657 - Engine Misfire Cylinder 4 - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fuel system related fault codes active or have accumulated inactive counts?
 | STEP 1B. Check for cylinder misfire. | Cylinder misfire detected?
STEP 2. | Perform diagnostic tests. |
 | STEP 2A. Perform the cylinder cutout test. | Cylinder misfire detected and isolated to injector?
STEP 3. | Clear the fault code. |
 | STEP 3A. Verify the repair | Cylinder misfire present?
 | STEP 3B. Clear the fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine and let it idle for 1 minute
  • Use INSITE™ electronic service tool to read the fault codes.

Fuel system related fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for cylinder misfire.

Conditions

  • Turn keyswitch ON.
  • Start the engine and run at low idle.

Action

Check for smoke, engine stumble, rough idle or misfire.

  • Check for black or white smoke, engine stumble, rough idle or misfire at low idle, high idle and during snap throttle accelerations.

Cylinder misfire detected?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Perform diagnostic tests.

Guided Step 2A - Perform the cylinder cutout test

Conditions

  • Turn the keyswitch ON
  • Allow the engine to run at idle speed
  • Connect INSITE™ electronic service tool.

Action

Determine if cylinder number 4 injector is misfiring.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to determine if the cylinder number 4 injector is misfiring.

Cylinder misfire detected and isolated to the injector?
YES NO

Repair

A damaged injector has been detected

Replace the cylinder number 4 injector.

  • For ISB and QSB engines, use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6.
  • For ISC, QSC, ISL, and QSL engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-026 in Section 6.

Repair

Check for other sources of cylinder misfire such as valve lash out of adjustment, cylinder damage, valve damage, cylinder head or gasket damage, extreme camshaft wear, or mistimed air compressor.

Go to 3A

Appropriate troubleshooting procedures.

Guided Step 3 - Clear the fault code.

Guided Step 3A - Verify the repair.

Conditions

  • Connect all components
  • Turn the keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Verify cylinder misfire is no longer present.

  • Start the engine and verify the cylinder misfire is no longer present.

Cylinder misfire is present?
YES NO

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 3B

Guided Step 3B - Clear the fault codes.

Conditions

  • Connect all components
  • Turn the keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear all active and inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps.

Last Modified: 23-Apr-2012


FAULT CODE 1658 - Engine Misfire Cylinder 5 - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fuel system related fault codes active or have accumulated inactive counts?
 | STEP 1B. Check for cylinder misfire. | Cylinder misfire detected?
STEP 2. | Perform diagnostic tests. |
 | STEP 2A. Perform the cylinder cutout test. | Cylinder misfire detected and isolated to injector?
STEP 3. | Clear the fault code. |
 | STEP 3A. Verify the repair | Cylinder misfire present?
 | STEP 3B. Clear the fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine and let it idle for 1 minute
  • Use INSITE™ electronic service tool to read the fault codes.

Fuel system related fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for cylinder misfire.

Conditions

  • Turn keyswitch ON.
  • Start the engine and run at low idle.

Action

Check for smoke, engine stumble, rough idle or misfire.

  • Check for black or white smoke, engine stumble, rough idle or misfire at low idle, high idle and during snap throttle accelerations.

Cylinder misfire detected?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Perform diagnostic tests.

Guided Step 2A - Perform the cylinder cutout test

Conditions

  • Turn the keyswitch ON
  • Allow the engine to run at idle speed
  • Connect INSITE™ electronic service tool.

Action

Determine if cylinder number 5 injector is misfiring.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to determine if the cylinder number 5 injector is misfiring.

Cylinder misfire detected and isolated to the injector?
YES NO

Repair

A damaged injector has been detected

Replace the cylinder number 5 injector.

  • For ISB and QSB engines, use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6.
  • For ISC, QSC, ISL, and QSL engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-026 in Section 6.

Repair

Check for other sources of cylinder misfire such as valve lash out of adjustment, cylinder damage, valve damage, cylinder head or gasket damage, extreme camshaft wear, or mistimed air compressor.

Go to 3A

Appropriate troubleshooting procedures.

Guided Step 3 - Clear the fault code.

Guided Step 3A - Verify the repair.

Conditions

  • Connect all components
  • Turn the keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Verify cylinder misfire is no longer present.

  • Start the engine and verify the cylinder misfire is no longer present.

Cylinder misfire is present?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 1A

Go to 3B

Guided Step 3B - Clear the fault codes.

Conditions

  • Connect all components
  • Turn the keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear all active and inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete?

Appropriate troubleshooting steps.

Last Modified: 23-Apr-2012


FAULT CODE 1659 - Engine Misfire Cylinder 6 - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fuel system related fault codes active or have accumulated inactive counts?
 | STEP 1B. Check for cylinder misfire. | Cylinder misfire detected?
STEP 2. | Perform diagnostic tests. |
 | STEP 2A. Perform the cylinder cutout test. | Cylinder misfire detected and isolated to injector?
STEP 3. | Clear the fault code. |
 | STEP 3A. Verify the repair | Cylinder misfire present?
 | STEP 3B. Clear the fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine and let it idle for 1 minute
  • Use INSITE™ electronic service tool to read the fault codes.

Fuel system related fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for cylinder misfire.

Conditions

  • Turn keyswitch ON.
  • Start the engine and run at low idle.

Action

Check for smoke, engine stumble, rough idle or misfire.

  • Check for black or white smoke, engine stumble, rough idle or misfire at low idle, high idle, and during snap throttle accelerations.

Cylinder misfire detected?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Perform diagnostic tests.

Guided Step 2A - Perform the cylinder cutout test

Conditions

  • Turn the keyswitch ON
  • Allow the engine to run at idle speed
  • Connect INSITE™ electronic service tool.

Action

Determine if the cylinder number 6 injector is misfiring.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to determine if the cylinder number 6 injector is misfiring.

Cylinder misfire detected and isolated to the injector?
YES NO

Repair

A damaged injector has been detected.

Replace the cylinder number 6 injector.

  • For ISB and QSB engines, use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6.
  • For ISC, QSC, ISL, and QSL engines, use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-026 in Section 6.

Repair

Check for other sources of cylinder misfire such as valve lash out of adjustment, cylinder damage, valve damage, cylinder head or gasket damage, extreme camshaft wear, or mistimed air compressor.

Go to 3A

Appropriate troubleshooting procedures.

Guided Step 3 - Clear the fault code.

Guided Step 3A - Verify the repair.

Conditions

  • Connect all components
  • Turn the keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Verify cylinder misfire is no longer present.

  • Start the engine and verify the cylinder misfire is no longer present.

Cylinder misfire is present?
YES NO

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 3B

Guided Step 3B - Clear the fault codes.

Conditions

  • Connect all components
  • Turn the keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear all active and inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps.

Last Modified: 23-Apr-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for fault codes. | Fault code 1674, 1675, 1676, 1655, 1666, or 1667 active?
STEP 2. | Check the temperature sensor configuration. |
 | STEP 2A. Check the circuit response. | Fault code 1675 active?
 | STEP 2B. Check the circuit response. | Fault code 1676 active?
STEP 3. | Clear the fault code. |
 | STEP 3A. Clear the fault codes. | All faults cleared?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Using INSITE™ electronic service tool read the fault codes.

Fault code 1674, 1675, 1676, 1665, 1666, or 1667 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the temperature sensor configuration.

Guided Step 2A - Check the circuit response.

Conditions

  • Turn the keyswitch OFF
  • Disconnect the engine exhaust gas temperature 1 sensor (catalyst inlet) from the engine harness.
  • Turn the keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault code 1666 active?
YES NO

Repair

The catalyst inlet and catalyst exhaust temperature sensor readings are swapped.

Swap the wiring harness connections to the exhaust gas temperature 1 sensor and catalyst exhaust temperature sensor.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF
  • Disconnect the engine exhaust gas temperature 2 sensor (catalyst inlet) from the engine harness.
  • Turn the keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault code 1675 active?
YES NO

Repair

The catalyst inlet and catalyst exhaust temperature sensor readings are swapped.

Swap the wiring harness connections to the exhaust gas temperature 1 (catalyst inlet) sensor and exhaust gas temperature 2 (catalyst outlet) temperature sensor.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Clear the fault codes.

Conditions

  • Connect all components
  • Turn the keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Using INSITE™ electronic service tool, erase all active and inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 08-Jul-2010


FAULT CODE 1664 - Catalyst Missing - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for fault codes. | Fault code 1663, 1674, 1675, 1676, 1665, 1666, or 1667 active?
 | STEP 1B. Check for the presence of a catalyst. | Catalyst present in aftertreatment system?
 | STEP 1C. Inspect the aftertreatment system. | Damage or tampering found in aftertreatment system?
STEP 2. | Clear the fault code. |
 | STEP 2A. Verify the repair. | Catalyst Inlet Temperature and Catalyst Outlet Temperature reading within 10°F or 5.5°C of each other, at ambient temperature, after an 8 hour soak?
 | STEP 2B. Clear the fault code. | All faults cleared?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Using INSITE™ electronic service tool read the fault codes.

Fault code 1663, 1674, 1675, 1676, 1665, 1666, or 1667 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for presence of a catalyst.

Conditions

  • Turn keyswitch OFF.

Action

Inspect for presence of catalyst.

  • Inspect for the presence of the catalyst in the exhaust system.

Is the catalyst present in the aftertreatment system?
YES NO
No Repair

Repair

Install the proper catalyst for the application.

Refer to the OEM service manual.

Go to 1C

Go to 2A

Guided Step 1C - Inspect the aftertreatment system.

Conditions

  • Turn keyswitch OFF.
  • Remove the catalyst from the exhaust system.

Action

Inspect the catalyst.

  • Inspect the catalyst for cracks or contamination.

Damage or tampering found in the catalyst system?
YES NO

Repair

Install the proper catalyst for the application.

Refer to the OEM service manual.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Verify the repair.

Conditions

  • Connect all components
  • Turn the keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Compare INSITE™ electronic service tool reading for Catalyst Inlet Temperature and Catalyst Outlet Temperature.

  • Start the INSITE™ Data Monitor/Logger and compare the INSITE™ electronic service tool reading for Catalyst Inlet Temperature and Catalyst Outlet Temperature.

Catalyst Inlet Temperature and Catalyst Outlet Temperature within 10°F or 5.5°C of each other, at ambient temperature, after an 8 hour soak?

YES | NO
No Repair | No Repair

Go to 2B

Go to 1A

Guided Step 2B - Clear the fault codes.

Conditions

  • Connect all components
  • Turn the keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to erase all active and inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 23-Apr-2012


FAULT CODE 1665 - Exhaust Gas Temperature 1 Circuit - Voltage Below Normal, or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1665 inactive?
STEP 2. | Check the exhaust gas temperature #1 sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature #1 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1666 active and fault code 1665 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1665 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1666 active and Fault Code 1665 inactive?
 | STEP 3C. Check for a pin to pin short circuit in the engine harness. | Greater than 100K ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100K ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1665 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1665 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1665 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature #1 sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature #1 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature #1 sensor from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature #1 sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature #1 sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1666 active and fault code 1665 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature #1 sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1665 is active?
YES NO

Repair

Replace the exhaust gas temperature #1 sensor. Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1666 is active and Fault Code 1665 is inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the exhaust gas temperature #1 sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust gas temperature #1 sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the exhaust gas temperature #1 sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the exhaust gas temperature #1 sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1665 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the problem.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1665 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Apr-2012


FAULT CODE 1666 - Exhaust Gas Temperature 1 Circuit - Voltage Above Normal, or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1666 inactive?
STEP 2. | Check the exhaust gas temperature #1 sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature #1 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1665 is active and fault code 1666 is inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1666 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1665 is active and Fault Code 1666 is inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin to pin short circuit in the engine harness. | Greater than 100K ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1666 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1666 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1666 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature #1 sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature #1 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature #1 sensor from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature #1 sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature #1 sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the exhaust gas temperatue #1 SIGNAL pin and the exhaust gas temperature #1 RETURN pin at the sensor connector of the engine harness.

  • Refer to the wiring diagram for connector pin identification.

Fault Code 1665 is active and fault code 1666 is inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature #1 sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1666 is active?
YES NO

Repair

A damaged exhaust gas temperature #1 sensor has been detected.

Replace the exhaust gas temperature #1 sensor. Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the exhaust gas temperature #1 sensor SIGNAL pin and the exhaust gas temperature #1 sensor RETURN pin at the ECM connector.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram for connector pin identification.

Fault Code 1665 active and Fault Code 1666 is inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the exhaust gas temperature #1 sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector exhaust gas temperature #1 sensor RETURN pin and the engine harness exhaust gas temperature #1 sensor connector RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the exhaust gas temperature #1 sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector exhaust gas temperature #1 sensor SIGNAL pin and the engine harness exhaust gas temperature #1 sensor connector SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the exhaust gas temperature #1 sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust gas temperature #1 sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 1666 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the problem.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1666 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Using INSITE™ electronic service tool erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Apr-2012


FAULT CODE 1667 - Exhaust Gas Temperature 1 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 1665 and 1666. | Fault Code 1665 or 1666 is active?
STEP 2. | Check the exhaust gas temperature #1 sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature #1 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1666 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1666 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the repair | Catalyst Inlet Temperature and Catalyst Outlet Temperature reading within 13.9°C or 25°F of each other?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes 1665 and 1666.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1665 or 1666 is active?
YES | NO
No Repair | No Repair

Fault Code 1665 or 1666 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature #1 sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature #1 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature #1sensor from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature #1 sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature #1 sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine coolant temperature must be above 60°C [140°F].

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1666 active?
YES NO
No Repair

Repair

Replace the exhaust gas temperature #1 sensor. Refer to Procedure 019-013 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins. Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine coolant temperature must be above 60°C [140°F].

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1666 is active?
YES NO

Repair

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the INSITE™ Data Monitor/Logger.

  • Compare the INSITE™ electronic service tool reading for Catalyst Inlet Temperature and Catalyst Outlet Temperature.

Catalyst Inlet Temperature and Catalyst Outlet Temperature reading within 13.9°C or 25°F of each other?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to erase all active and inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Apr-2012


FAULT CODE 1668 - Catalyst Tank Level Sensor Circuit - Voltage Below Normal, or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1668 inactive?
STEP 2. | Check the catalyst tank level sensor and circuit. |
 | STEP 2A. Inspect the catalyst tank level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1669 active and fault code 1668 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault code 1668 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the engine control module response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1668 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?

YES | NO
No Repair | No Repair

Refer to Fault Code 187

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668 is inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the catalyst tank level sensor and circuit.

Guided Step 2A - Inspect the catalyst tank level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the catalyst tank level sensor from the engine harness.

Action

Inspect the engine harness and catalyst tank level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the catalyst tank level sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the CATALYST TANK LEVEL +5 VDC SUPPLY pin to the CATALYST TANK LEVEL RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the catalyst tank level sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the CATALYST TANK LEVEL +5 VDC SUPPLY pin and the CATALYST TANK LEVEL SIGNAL pin at the catalyst tank level sensor connector of the engine harness.
  • Using INSITE™ electronic service tool read the fault codes.

Fault Code 1669 active and Fault Code 1668 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition

Conditions

  • Turn keyswitch OFF.
  • Connect the catalyst tank level sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the approriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1668 is active?
YES NO

Repair

A damaged sensor has been detected.

Replace the catalyst tank level sensor. Refer to OEM service manual.

Repair

None. The removal and reinstallation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A defective connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Turn keyswitch ON

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the CATALYST TANK LEVEL +5 VDC SUPPLY pin to the CATALYST TANK LEVEL RETURN pin at the engine control module engine connector.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool read the fault codes.

Fault Code 1668 inactive?
YES NO

Repair

None. The removal and reinstallation of the connector corrected the problem.

Repair

An open or shorted SUPPLY circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

:Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Repair

A damaged connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the engine control module response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the CATALYST TANK LEVEL +5 VDC SUPPLY pin and the CATALYST TANK LEVEL SIGNAL pin at the engine control module engine connector.
  • Using INSITE™ electronic service tool read the fault codes.

Fault Code 1669 active and Fault Fode 1668 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668 inactive?
YES NO

Repair

None. The removal and reinstallation of the connector corrected the problem.

Repair

An open circuit or pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1668 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 28-Mar-2012


FAULT CODE 1669 - Catalyst Tank Level Sensor Circuit — Voltage Above Normal, or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1669 inactive?
STEP 2. | Check the catalyst tank level sensor and circuit. |
 | STEP 2A. Inspect the catalyst tank level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1668 active and fault code 1669 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1669 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the engine control module response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect engine control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1669 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?

YES | NO
No Repair | No Repair

Refer to Fault Code 227

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 is inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the catalyst tank level sensor and circuit.

Guided Step 2A - Inspect the catalyst tank level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the catalyst tank level sensor from the engine harness.

Action

Inspect the engine harness and catalyst tank level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the catalyst tank level sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Using INSITE™ electronic service tool read the fault codes.

Fault Code 1668 active and fault code 1669 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the catalyst tank level sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the CATALYST TANK LEVEL +5 VDC SUPPLY pin to the CATALYST TANK LEVEL RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition

Conditions

  • Turn keyswitch OFF.
  • Connect the catalyst tank level sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the approriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1669 is active?
YES NO

Repair

A damaged sensor has been detected.

Replace the catalyst tank level sensor. Refer to OEM service manual.

Repair

None. The removal and reinstallation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the engine control module response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668 active and fault code 1669 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1669 inactive?
YES NO

Repair

None. The removal and reinstallation of the connector corrected the problem.

Repair

A pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect engine control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and engine control module engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Repair

A damaged connection has been detected in the engine control module engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM engine connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the CATALYST TANK LEVEL +5 VDC SUPPLY pin and the CATALYST TANK LEVEL RETURN pin at the engine control module engine connector.

Refer to the wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 inactive?
YES NO

Repair

None. The removal and reinstallation of the connector corrected the problem.

Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1669 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 28-Mar-2012


FAULT CODE 1671 - Catalyst Tank Level - Data Valid But Below Normal Operational Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1671 active?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault Code 1671 inactive?
 | STEP 2B. Clear the inactive fault code. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1671 active?
YES NO

Repair

Low catalyst solution level has been detected.

Add catalyst solution to the catalyst solution tank.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Turn the keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1671 inactive?
YES | NO
No Repair | No Repair

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn the keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear all the inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 22-May-2012


FAULT CODE 1673 - Catalyst Tank Level - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault code 1673 active?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault code 1673 inactive?
 | STEP 2B. Clear the inactive fault code. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read fault codes.

  • Using INSITE™ electronic service tool read the fault codes.

Fault code 1673 active?
YES NO

Repair

A low aftertreatment diesel exhaust fluid (DEF) level has been detected.

Fill the DEF tank completely full.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Turn the keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault code 1673 inactive?
YES | NO
No Repair | No Repair

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn the keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase all the inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 17-Sep-2015


FAULT CODE 1674 - Exhaust Gas Temperature 2 Circuit - Voltage Below Normal, or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1674 inactive?
STEP 2. | Check the exhaust gas temperature #2 sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature #2 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1675 active and fault Code 1674 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1674 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1675 active and Fault Code 1674 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100K ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100K ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1674 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1674 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ to read the fault codes.

Fault Code 1674 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature #2 sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature #2 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature #2 sensor from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature #2 sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature #2 sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1675 active and Fault Code 1674 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature #2 sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1674 is active?
YES NO

Repair

Replace the exhaust gas temperature #2 sensor. Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1675 is active and Fault Code 1674 is inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the exhaust gas temperature #2 sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust gas temperature #2 sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the exhaust gas temperature #2 sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the exhaust gas temperature #2 sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 16674 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1674 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Apr-2012


FAULT CODE 1675 - Exhaust Gas Temperature 2 Circuit - Voltage Above Normal, or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1675 inactive?
STEP 2. | Check the exhaust gas temperature #2 sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature #2 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1674 is active and fault code 1675 is inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1675 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1674 is active and Fault Code 1675 is inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100K ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1675 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1675 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1675 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature #2 sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature #2 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature #2 sensor from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature #2 sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature #2 sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the exhaust gas temperatue #2 SIGNAL pin and the exhaust gas temperature #2 RETURN pin at the sensor connector of the engine harness.

  • Refer to the wiring diagram for connector pin identification.

Fault Code 1674 is active and Fault Code 1675 is inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature #2 sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1675 is active?
YES NO

Repair

A damaged exhaust gas temperature #2 sensor has been detected.

Replace the exhaust gas temperature #2 sensor. Refer to Procedure 019-013 in Section 19.

Repair

None. The removal and installation of the connector corrected the problem.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the exhaust gas temperature #2 sensor SIGNAL pin and the exhaust gas temperature #2 sensor RETURN pin at the ECM connector.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram for connector pin identification.

Fault Code 1674 active and Fault Code 1675 is inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the exhaust gas temperature #2 sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector exhaust gas temperature #2 sensor RETURN pin and the engine harness exhaust gas temperature #2 sensor connector RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the exhaust gas temperature #2 sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector exhaust gas temperature #2 sensor SIGNAL pin and the engine harness exhaust gas temperature #2 sensor connector SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the exhaust gas temperature #2 sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the exhaust gas temperature #2 sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1675 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1675 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Using INSITE™ electronic service tool erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Apr-2012


FAULT CODE 1676 - Exhaust Gas Temperature 2 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 1674 and 1675. | Fault Code 1674 or 1675 is active?
STEP 2. | Check the exhaust gas temperature #2 sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature #2 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1675 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1675 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the repair | Catalyst Inlet Temperature and Catalyst Outlet Temperature reading within 13.9°C or 25°F of each other?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 1674 and 1675.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1674 or 1675 is active?
YES | NO
No Repair | No Repair

Fault Code 1674 or 1675 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature #2 sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature #2 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature #2 sensor from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature #2 sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature #2 sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine coolant temperature must be above 60°C [140°F].

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1675 active?
YES NO
No Repair

Repair

Replace the exhaust gas temperature #2 sensor. Refer to Procedure 019-013 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine coolant temperature must be above 60°C [140°F].

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1675 is active?
YES NO

Repair

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the INSITE™ Data Monitor/Logger.

  • Compare the INSITE™ electronic service tool reading for Catalyst Inlet Temperature and Catalyst Outlet Temperature.

Catalyst Inlet Temperature and Catalyst Outlet Temperature reading within 13.9°C or 25°F of each other?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to erase all active and inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Apr-2012


FAULT CODE 1677 - Catalyst Tank Temperature - Voltage Below Normal, or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1677 inactive?
STEP 2. | Check the catalyst solution temperature sensor and circuit. |
 | STEP 2A. Inspect the catalyst solution temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1678 active and fault code 1677 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1677 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1678 active and Fault Code 1677 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100K ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100K ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1677 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1677 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ to read the fault codes.

Fault Code 1677 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the catalyst solution temperature sensor and circuit.

Guided Step 2A - Inspect the catalyst solution temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the catalyst solution temperature sensor from the engine harness.

Action

Inspect the engine harness and catalyst solution temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the catalyst solution temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1678 active and Fault Code 1677 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the catalyst solution temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 is active?
YES NO

Repair

Replace the catalyst solution temperature sensor. Refer to OEM service manual.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 is active and Fault Code 1677 is inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the catalyst solution temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the catalyst solution temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the catalyst solution sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the catalyst solution sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1677 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Apr-2012


FAULT CODE 1678 - Catalyst Tank Temperature - Voltage Above Normal, or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1678 inactive?
STEP 2. | Check the catalyst solution temperature sensor and circuit. |
 | STEP 2A. Inspect the catalyst solution temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1678 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1677 is active and Fault Code 1678 is inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin to pin short circuit in the engine harness. | Greater than 100K ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1678 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1678 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the catalyst solution temperature sensor and circuit.

Guided Step 2A - Inspect the catalyst solution temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the catalyst solution temperature sensor from the engine harness.

Action

Inspect the engine harness and catalyst sensor temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the catalyst solution temperature sensor from the engine harness.

Action

Measure the sensor resistance.

  • Measure the resistance between the catalyst solution temperature sensor SIGNAL pin and catalyst solution temperature sensor RETURN pin at the catalyst solution temperature sensor.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Repair

Replace the catalyst solution temperature sensor. Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the catalyst solution temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 is active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

:Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the catalyst solution temperature sensor SIGNAL pin and the catalyst solution temperature sensor RETURN pin at the ECM connector.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram for connector pin identification.

Fault Code 1677 active and Fault Code 1678 is inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the catalyst solution temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector catalyst solution temperature sensor RETURN pin and the engine harness catalyst solution temperature sensor connector RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the catalyst solution temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector catalyst solution temperature sensor SIGNAL pin and the engine harness catalyst solution temperature sensor connector SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SIGNAL circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the catalyst solution temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the catalyst solution temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1678 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Apr-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 1677 or 1678 is active?
STEP 2. | Check the catalyst solution temperature sensor and circuit. |
 | STEP 2A. Inspect the catalyst solution temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1678 active?
 | STEP 2C. Check the circuit response. | Fault Code 1677 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1678 active?
 | STEP 3C. Check the circuit response. | Fault Code 1677 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the repair | Catalyst Solution Temperature and the Thermometer are reading within 5°F of each other?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault codes.

  • Use INSITE™ to read the fault codes.

Fault Codes 1677 or 1678 is active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the catalyst solution temperature sensor and circuit.

Guided Step 2A - Inspect the catalyst solution temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the catalyst solution temperature sensor from the engine harness.

Action

Inspect the engine harness and catalyst solution temperature sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Dirt or debris in or on the connector pins

For general inspection techniques, refer to Component Connector and Pin Inspection, Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

Repair

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the catalyst solution temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault code 1678 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the catalyst solution temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the catalyst solution temperature SIGNAL pin and the catalyst solution temperature RETURN pin at the catalyst solution temperature connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 1677 is active?
YES NO

Repair

Replace the catalyst solution temperature sensor.

Refer to OEM troubleshooting procedures.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Dirt or debris in or on the connector pins

For general inspection techniques, refer to Component Connector and Pin Inspection, Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

Repair

A defective connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 1678 is active?
YES NO
No Repair

Repair

Call for pre-authorization.

Replace the ECM.

Refer to Procedure 019-031.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the catalyst solution temperature SIGNAL pin and catalyst solution temperature RETURN pin at the ECM connector.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 1677 is active?
YES NO

Repair

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Repair

Call for pre-authorization.

Replace the ECM.

Refer to Procedure 019-031.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Insert a thermometer into the catalyst solution tank.

Action

Start the INSITE Data Monitor/Logger .

  • Compare the INSITE reading for Catalyst Solution Temperature with the thermometer.

Catalyst Solution Temperature and thermometer reading within 5°F of each other?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Using INSITE™ electronic service tool, erase all active and inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Jul-2010


FAULT CODE 1681 - Dosing Control Unit - Bad Intelligent Device or Component

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault code 1681 active?
STEP 2. | Clear the fault code. |
 | STEP 2A. Disable the fault code. | Fault code 1681 inactive?
 | STEP 2B. Clear the inactive fault code. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool read the fault codes.

Fault code 1681 active?
YES NO

Repair

Replace the dosing control unit. Refer to Procedure 019-440 in Section 19.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Aug-2012


FAULT CODE 1682 - Aftertreatment Diesel Exhaust Fluid Dosing Control Unit Input Lines - Condition Exists

Associated Procedures

Cautions and Warnings

WARNING

To reduce the possibility of personal injury to the eyes, wear appropriate eye protection when removing the diesel exhaust fluid nozzle line. Air pressure may be present in the reagent nozzle line if there is a fault in the system.
WARNING

The exhaust and exhaust components can become heated during troubleshooting. To avoid the risk of fire, property damage, burns, or other serious personal injury, allow the exhaust system to cool before beginning any procedure or repair. Make sure that no combustible materials are located where they are likely to come in contact with hot exhaust or exhaust components.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 434, 1665, 1666, 1668, 1669, 1671, 1673, 1674, 1675, 1677, 1678, 1697, 1698, or 1711 active?
STEP 2. | Inspect the aftertreatment nozzle. |
 | STEP 2A. Inspect the aftertreatment nozzle. | Plugged or restricted aftertreatment nozzle detected?
STEP 3. | Verify the priming cycle of the diesel exhaust fluid (DEF) dosing unit. |
 | STEP 3A. Check the aftertreatment nozzle DEF line during priming. | Dosing unit attempts to prime for only 30 seconds (plus the 140 second prime delay if applicable)?
 | STEP 3B. Check the air solenoid operation during priming. | Air solenoid click and exhaust air down the aftertreatment nozzle line continuously after 30 seconds? (will attempt to prime up to 20 times)?
 | STEP 3C. Confirm the successful priming of the DEF dosing unit. | Air flow above 25 liters per minute [6.6 gallons per minute]?
STEP 4. | Check the DEF dosing unit air supply system. |
 | STEP 4A. Inspect the air supply lines to the DEF dosing unit. | Original equipment manufacturer (OEM) air supply correctly attached to the DEF dosing unit and supplying adequate air pressure?
 | STEP 4B. Check the DEF dosing unit air solenoid. | Flushing procedure successful?
STEP 5. | Check the DEF lines and fittings for restriction and contamination. |
 | STEP 5A. Check the DEF dosing unit fittings and lines. | DEF fittings and lines pass the inspections?
 | STEP 5B. Inspect the DEF dosing unit inline screen filter connection. | Contamination present at the screen filter?
 | STEP 5C. Check the DEF dosing lines for restrictions or leaks. | Restriction line test completed successfully?
 | STEP 5D. Inspect the DEF tank and the 35 micron tank filter. | DEF tank or DEF filter contaminated?
STEP 6. | Verify the purging cycle of the aftertreatment dosing unit. |
 | STEP 6A. Monitor the aftertreatment dosing unit purging cycle. | All the actions in this step confirmed and zero incomplete purge counts in the ECM image?
STEP 7. | Perform the DEF Doser Pump Override Test. |
 | STEP 7A. Perform the DEF Doser Pump Override Test with INSITE™ electronic service tool. | Dosing control unit operates correctly during INSITE™ electronic service tool override test? (It is recommended to complete this test three times.)
STEP 8. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 8A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 8B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 434, 1665, 1666, 1668, 1669, 1671, 1673, 1674, 1675, 1677, 1678, 1697, 1698, or 1711 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Inspect the aftertreatment nozzle.

Guided Step 2A - Inspect the aftertreatment nozzle.

Conditions

  • Make sure the nozzle has been warmed in the exhaust prior to removal. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 011-040 in Section 11.
  • Turn keyswitch OFF.
  • Remove the aftertreatment nozzle. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 011-040 in Section 11.

Action

Inspect the aftertreatment nozzle for blockage or restrictions.

  • Inspect the aftertreatment nozzle. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 011-040 in Section 11.
  • Soft crystal and ash-like buildup in the spray holes can be dissolved with 40°C [104°F] warm water.
  • Make sure that the soft buildup in the spray holes clears when the dosing unit begins dosing.

Plugged or restricted aftertreatment nozzle detected?
YES NO

Repair

Clean or replace the aftertreatment nozzle. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 011-040 in Section 11.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Verify the priming cycle of the DEF dosing unit.

Guided Step 3A - Check the aftertreatment nozzle DEF line during priming.

Conditions

  • Isolate the vehicle main power for at least 30 seconds prior to carrying out this check.
  • Disconnect the DEF line from the aftertreatment nozzle and secure it appropriately.
  • Leave the aftertreatment nozzle installed.
  • Turn keyswitch ON.
  • Start the engine and operate at low idle
  • Connect INSITE™ electronic service tool.

Action

Check the aftertreatment nozzle fluid line during priming.

  • After key ON with the engine operating, listen for the diesel exhaust fluid dosing pump to start.
  • Time the pump operation until the pump automatically switches off (the pump is attempting to prime).

While the engine is operating it may be difficult to hear the pump. If this is the case, listen for the air solenoid to click, indicating that the pump has completed 1 prime attempt.

Older calibrations did not incorporate the 140 second delay from key ON to initial prime cycle. During the 140 second delay, the dosing unit will remain on standby before receiving the command to prime. This was introduced to remove any crystallization built up on injection tip prior to the priming cycle and to avoid any blocked injection lines.

A correct prime cycle is as follows:

1. Key ON

2. 140 second pump start delay

3. Pump starts and operates for 30 seconds. (The system is now priming, this step may be attempted up to 20 times).

4. The diesel exhaust fluid injection line will now exhaust air. Priming is now complete.

If the pump detects a problem during priming, the priming attempt will be aborted after 30 seconds.

Dosing unit attempts to prime for only 30 seconds (plus the 140 second prime delay if applicable)?

YES NO

Repair

Complete line restriction testing procedure then re-prime. Use the following procedure for ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 1 or ISC, ISCe, QSC8.3, ISL, ISLe3, and QSL9 engines.

  • Refer to Procedure 011-086 in Section 11.
No Repair

Go to 3A

Go to 3B

Guided Step 3B - Check the air solenoid operation during priming.

Conditions

  • Disconnect the DEF line from the aftertreatment nozzle and secure it appropriately.
  • Leave the aftertreatment nozzle installed.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Make sure that the DEF dosing unit has successfully primed and entered the dosing state.

  • The DEF dosing unit enters the dosing state only when a successful prime is completed, and the air solenoid has clicked.
  • At this point, air will be flowing continuously down the aftertreatment nozzle line.
  • The DEF dosing unit could attempt to prime for up to 12 minutes, at which point, if a prime is successful, the pump will switch off.
  • Use INSITE™ electronic service tool Data/Monitor Logger for Aftertreatment DEF Dosing Unit State to confirm the doser status.

Air solenoid click and exhaust air down the aftertreatment nozzle line continuously after 30 seconds (will attempt to prime up to 20 times)?

YES NO
No Repair

Repair

The diesel exhaust fluid dosing unit has not primed.

Go to 3C

Go to 5A

Guided Step 3C - Confirm the successful priming of the DEF dosing unit.

Conditions

  • Turn keyswitch OFF for a minimum of 1 minute.
  • Disconnect the DEF line from the aftertreatment nozzle.
  • Attach the air flow meter to the DEF dosing line. Use the following procedure for ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 1 or ISC, ISCe, QSC8.3, ISL, ISLe3, and QSL9 engines. Refer to Procedure 011-058 in Section 11.
  • Secure the DEF dosing line and the attached air flow meter.
  • Start the engine and operate at low idle.
  • Connect INSITE™ electronic service tool.

Action

The DEF dosing unit should start the priming cycle immediately after the prime delay when the engine is started. After 30 seconds (each prime attempt will take 30 seconds, if not successful the doser will attempt to prime up to 20 times) air should continuously flow through the DEF Injection line, and the attached air flow meter.

  • Record the measured air flow from the DEF dosing line.

Air flow above 25 liters per minute [6.6 gallons per minute]?
YES | NO
No Repair | No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check the DEF dosing unit air supply system.

Guided Step 4A - Inspect the air supply lines to the DEF dosing unit.

Conditions

  • Turn keyswitch ON.
  • Start the engine.
  • Operate the engine at low idle.

Action

Inspect the OEM air supply line attached to the DEF dosing unit.

  • Check for leaks or loose connections in the air supply line.
  • Check the DEF dosing unit air filter for water or excessive oil from the vehicle's compressed air system.
  • Make sure a clean supply of air, at least 517 kPa [75 psi], pressure is present at the DEF dosing unit, downstream of the air filter.

Most vehicles are equipped with an inline air filter in the air line prior to the DEF dosing unit. A plugged or restricted inline air filter can cause low air pressure to the DEF dosing unit.

OEM air supply correctly attached to the DEF dosing unit and supplying adequate air pressure?
YES NO
No Repair

Repair

Correct the OEM air supply connection or supply. See equipment manufacturer service information.

Go to 4B

Go to 3A

Guided Step 4B - Check the DEF dosing unit air solenoid.

Conditions

  • Disconnect the DEF line from the aftertreatment nozzle and secure it appropriately.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the vehicle air tanks are full.

Action

Carry out the DEF dosing unit flushing procedure.

Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 011-082 in Section 11.

Most vehicles are equipped with an inline air filter in the air line prior to the DEF dosing unit. A plugged or restricted inline air filter can cause low air pressure to the DEF dosing unit.

Flushing procedure successful?
YES NO
No Repair

Repair

A damaged DEF dosing unit has been detected.

Replace the DEF dosing unit. Refer to Procedure 019-440 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the DEF lines and fittings for restriction and contamination.

Guided Step 5A - Check the DEF dosing unit fittings and lines.

Conditions

  • Clean the front face of the doser before removing any lines.
  • Disconnect the DEF line from the aftertreatment nozzle and secure appropriately.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Inspect the DEF dosing unit fittings and lines for the following:

Clean the front face of the aftertreatment dosing unit and lines with warm water or mild detergent before removing any line. This is to prevent any contamination due to service intervention.

  • Loose DEF inlet connectors or fitting
  • Cracked DEF lines, resulting in leaks or drawing in air
  • Restricted or damaged DEF supply or return lines.

Make sure DEF is returning to the tank during the priming cycle.

DEF fittings and lines pass the inspections?
YES NO
No Repair

Repair

Repair or replace DEF fittings, lines, and/or connector. See equipment manufacturer service information.

Go to 5B

Go to 3B

Guided Step 5B - Inspect the DEF dosing unit inline screen filter connection.

Conditions

  • Clean the front face of the doser before removing any lines.
  • Disconnect the DEF supply line from the dosing unit and secure appropriately.

Action

Inspect the DEF dosing unit inline screen filter connection.

  • Remove the diesel exhaust fluid dosing unit supply line
  • Inspect the inlet screen filter. Use the following procedure for ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 1 or ISC, ISCe, QSC8.3, ISL, ISLe3, and QSL9 engines. Refer to Procedure 011-060 in Section 11.

Clean the front face of the aftertreatment dosing unit and lines with warm water or mild detergent before removing any lines. This is to prevent any contamination due to service intervention.

Use the following procedure to identify the different connections on the DEF dosing unit. Refer to Procedure 019-440 in Section 19.

Contamination present at the screen filter?
YES NO

Repair

Replace the screen filter.

 No Repair

Go to 5C

Go to 5C

Guided Step 5C - Check the DEF dosing unit intake restriction.

Conditions

  • Turn keyswitch OFF.

Action

Complete the DEF dosing unit intake restriction.

Refer to Procedure 011-086 in Section 11.

Restriction line test completed successfully?
YES NO
No Repair

Repair

Clean or replace the DEF filter, DEF tank vent filter, and DEF suction line, as necessary.

Drain the DEF tank. Flush with distilled water. Fill the DEF tank with clean, certified DEF. See equipment manufacturer service information.

Go to 5D

Go to 6A

Guided Step 5D - Inspect the DEF tank and the 35 micron tank filter.

Conditions

  • Turn keyswitch OFF.
  • Do not operate the engine.

Action

Inspect the DEF tank and filters for fuel, oil, coolant, dirt, and debris.

For an in-tank DEF filter, use the following procedure. Refer to Procedure 011-083 in Section 11.

  • For an inline DEF filter, see equipment manufacturer service information.
  • See equipment manufacturer service information for removal/installation procedure for the DEF tank and DEF tank level sensor assembly.

In some cases the DEF tank is bonded to the vehicle chassis leaving no access to DEF tank level sensor assembly. If this is the case, contact the OEM to arrange for the tank to be removed and inspected.

Some OEMs use an inline filter instead of a DEF tank filter.

DEF tank or DEF filter contaminated?

YES NO

Repair

Locate/remove source, inform OEM. If required, replace components and connectors. Drain/refill the DEF tank. See equipment manufacturer service information.

No Repair

Go to 6A

Go to 6A

Guided Step 6 - Verify the purging cycle of the aftertreatment dosing unit.

Guided Step 6A - Monitor the aftertreatment dosing unit purging cycle.

Conditions

  • Start the engine and operate at low idle.

Action

Verify completion of the aftertreatment dosing unit purge cycle.

  • Turn the keyswitch OFF to shut down the engine.
  • Verify that the aftertreatment dosing unit remains powered for at least 30 seconds after keyswitch OFF to complete the purge cycle.
  • Confirm that air flow is present for 30 seconds after keyswitch OFF.
  • Confirm the battery isolation switch allows the purge to continue for a full 30 seconds.

The procedure above will flag incomplete purge counts in the ECM, if incorrect. See the Purging section under Shop Talk.

All the actions in this step confirmed and zero incomplete purge counts in the ECM image?
YES NO
No Repair

Repair

  • Verify the correct battery power and keyswitch wiring to the aftertreatment dosing unit.
  • Consult the engine and OEM wiring diagrams.
  • Repair any OEM wiring issue and notify the OEM.
  • If the battery isolator switch increases incomplete purge counts, the OEM must be notified. A timer relay must be in the system to allow a 30 second purge.

Go to 7A

Go to 7A

Guided Step 7 - Perform the DEF Doser Pump Override Test.

Guided Step 7A - Perform the DEF Doser Pump Override Test with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the DEF Doser Pump Override Test, under Aftertreatment Diagnostics Tests.

  • Use the following procedure for instructions and specifications. Refer to Procedure 019-440 in Section 19.
  • Check to make sure that the DEF is being injected through the aftertreatment nozzle during the dosing state.

NOTE: The aftertreatment nozzle must have been warmed in the exhaust before removing and placing it in a measuring container larger than 200 ml [6.8 oz] capacity to perform the DEF Doser Pump Override Test.

The troubleshooting tree must be followed completely before completing this test.

Dosing control unit operates correctly during INSITE™ electronic service tool override test? (It is recommended to complete this test three times.)

YES NO
No Repair

Repair

A damaged DEF dosing unit has been detected. Replace the DEF dosing unit. Refer to Procedure 019-440 in Section 19.

Go to 8A

Go to 8A

Guided Step 8 - Check the ECM calibration and clear the fault codes.

Guided Step 8A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 8B

Go to 8B

Guided Step 8B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Mar-2018


FAULT CODE 1683 - Catalyst Tank Heater Circuit -Voltage Above Normal, or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1683 inactive?
STEP 2. | Check the catalyst tank heater relay and circuit. |
 | STEP 2A. Inspect the catalyst tank heater relay and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the catalyst tank heater relay. | Less than 100 ohms?
 | STEP 2C. Check the catalyst tank heater diagnostic voltage, supply line and return circuit. | Greater than 6-VDC?
 | STEP 2D. Check for an open circuit in the catalyst tank heater return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the catalyst tank heater relay diagnostic supply voltage. | Greater than 6-VDC?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100K ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1683 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1683 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1683 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the catalyst tank heater relay and circuit.

Guided Step 2A - Inspect the catalyst tank heater relay and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the catalyst tank heater relays from the engine harness.

Action

Inspect the engine harness and catalyst tank heater relay connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the catalyst tank heater relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the catalyst tank heater relays from the engine harness.

Action

Check catalyst tank heater relay resistance.

  • Measure the resistance between the catalyst tank heater SIGNAL pin and the catalyst tank heater RETURN pin at the catalyst tank heater relay.

Refer to the wiring diagram for connector pin identification.

Less than 100 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the catalyst tank heater relay.

Replace the catalyst tank heater relay. Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the catalyst tank heater diagnostic voltage, supply line and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Connect the catalyst tank heater relay from the engine harness.
  • Turn keyswitch ON.

Action

Check the catalyst tank heater supply voltage and return circuit.

  • Measure the voltage between the catalyst tank heater relay SIGNAL line and the catalyst tank heater relay RETURN line at the catalyst tank heater relay connector of the engine harness.

Greater than 6-VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 2D

Guided Step 2D - Check for an open circuit in the catalyst tank heater return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the catalyst tank heater relay from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the catalyst tank heater relay RETURN pin in the engine harness and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open pin to ground circuit on the RETURN line has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the OPEN RETURN circuit to ground.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the catalyst tank heater relay diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the catalyst tank heater relay diagnostic supplly voltage.

  • Measure the voltage between the catalyst tank heater relay signal pin and ground at ECM connector.

Refer to the wiring diagram for connector pin identification.

Greater than 6-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the catalyst heater relay from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector. catalyst tank heater relay SUPPLY pin and the engine harness catalyst tank heater relay connector catalyst tank heater relay SUPPLY pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open catalyst tank heater SUPPLY circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the catalyst tank heater relay from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the catalyst tank heater relay SUPPLY pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the catalyst tank heater relay SUPPLY line has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the shorted supply circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1683 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the problem.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1683 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1684 inactive?
STEP 2. | Check the catalyst tank heater relay and circuit. |
 | STEP 2A. Inspect the catalyst tank heater relay and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault code 1683 active and fault code 1684 inactive?
 | STEP 2C. Check the fault codes and verify relay condition. | Fault code 1684 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault code 1683 active and fault code 1684 inactive?
 | STEP 3C. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground | Greater than 100K ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1684 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 1684 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ to read the fault codes.

Fault Code 1684 inactive?
YES | NO
No Repair | No Repair

Inactive or Intermittent Fault Code Refer to Procedure 019-362.

Go to 2A

Guided Step 2 - Check the catalyst tank heater relay and circuit.

Guided Step 2A - Inspect the catalyst tank heater relay and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the catalyst tank heater relays from the engine harness.

Action

Inspect the engine harness and catalyst tank heater relay connections for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Dirt or debris in or on the connector pins

For general inspection techniques, refer to Component Connector and Pin Inspection, Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

Repair

A defective connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the catalyst tank heater relays from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Using INSITE™, read the fault codes.

Fault code 1683 is active and fault code 1684 is inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify relay condition.

Conditions

  • Turn keyswitch OFF
  • Connect the catalyst tank heater relay from the engine harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Using INSITE™, read the fault codes

Fault code 1684 is active?
YES NO

Repair

A failed catalyst tank heater relay has been detected.

Replace the catalyst tank heater relay.

Refer to the OEM troubleshooting and repair manual.

Repair

None. The removal and installation of the connector corrected the failure.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Wire insulation damage
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Dirt or debris in or on the connector pins

For general inspection techniques, refer to Component Connector and Pin Inspection, Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

Repair

A defective connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Using INSITE™, read the fault codes.

Fault code 1683 is active and fault code 1684 is inactive?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3E

Guided Step 3C - Check for a pin to pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the catalyst heater relay from the engine harness.

Action

Check for a pin to pin short.

  • Measure the resistance between the catalyst tank heater relay SUPPLY pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to the Resistance Measurements Using a Multimeter and Wiring Diagram, Refer to Procedure 019-360.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin to pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the catalyst tank heater relay from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the catalyst tank heater relay SUPPLY pin in the engine harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

For general resistance measurement techniques, refer to the Resistance Measurements Using a Multimeter and Wiring Diagram, Refer to Procedure 019-360.

Greater than 100K ohms?
YES NO
No Repair

Repair

A pin to ground short circuit on the SUPPLY line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ to read the fault codes.

Fault Code 1684 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the failure.

Repair

Replace the ECM.

Call for authorization.

019-031.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ to verify the fault code is inactive.

Fault Code 1684 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Using INSITE™ erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Jul-2010


FAULT CODE 1687 - Catalyst Over Temperature - Data Valid but Above Normal Operational Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fuel system related fault codes. |
 | STEP 1A. Check for fuel injector related fault codes. | Fault Codes 1654, 1655, 1656, 1657, 1658, 1659, and 1718 active or high inactive counts?
STEP 2. | Check the catalyst system for correct operation. |
 | STEP 2A. Inspect the catalyst solution. | Is catalyst solution contaminated?
 | STEP 2B. Inspect the turbocharger. | Does the turbocharger turbine housing show signs of oil leaking into the exhaust system?
STEP 3. | Clear the fault code. |
 | STEP 3A. Clear the fault codes. | All faults cleared?

Guided Step 1 - Check for fuel system fault codes.

Guided Step 1A - Check for fuel injector related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1654, 1655, 1656, 1657, 1658, 1659, and 1718 active or high inactive counts?
YES NO

Repair

Troubleshoot active fault codes, followed by inactive fault codes for which there is the highest number of counts.

Refer to appropriate troubleshooting steps.

Replace the aftertreatment catalyst. Refer to OEM service manual.

 No Repair

Appropriate Troubleshooting Procedures.

Go to 2A

Guided Step 2 - Check the catalyst system for correct operation.

Guided Step 2A - Inspect the catalyst solution.

Conditions

  • Turn the keyswitch OFF

Action

Check the catalyst solution for contamination.

Take a sample of the catalyst solution from the catalyst tank.

Inspect the catalyst solution for contamination from diesel fuel, gasoline, or engine oil.

Is the catalyst solution contaminated?
YES NO

Repair

Drain the catalyst tank and flush with distilled water.

Flush all catalyst solution lines with distilled water.

Replace the aftertreatment catalyst. Refer to OEM service manual.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the turbocharger.

Conditions

  • Turn the keyswitch OFF
  • Remove the exhaust pipe from the turbocharger.

Action

Check turbocharger turbine housing.

Check the turbocharger turbine housing for signs of engine oil leaking into the exhaust system.

Does the turbocharger turbine housing show signs of oil leaking into the exhaust system?
YES NO

Repair

Remove the oil drain line and check for restrictions. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 010-045 in Section 10.

Replace the aftertreatment catalyst. Refer to OEM service manual.

Repair

Replace the aftertreatment catalyst. Refer to OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Clear the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to reset all fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 26-Apr-2012


FAULT CODE 1689 - Real-Time Clock Power Interrupt - Data Erratic, Intermittent or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part No. 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part No. 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the real-time clock battery and connections. |
 | STEP 1A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the real-time clock battery voltage at the ECM harness connector. | Between 3.3-VDC and 3.6-VDC?
 | STEP 1B-1. Inspect the real-time clock battery and engine wire harness connector pins. |
 | STEP 1B-2. Check the real-time clock battery voltage at the battery module connector. |
STEP 2. | Check the battery module harness. |
 | STEP 2A. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2B. Check for a short circuit in the engine harness. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to ground. | More than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 1689 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the real-time clock battery and connections.

Guided Step 1A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the real-time clock battery voltage at the ECM harness connector.

Conditions

  • Engine equipped with optional real-time clock battery
  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.

Action

Measure the voltage between the real-time clock battery SUPPLY pin and the real-time clock battery RETURN (-) pin at the ECM connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Between 3.3-VDC and 3.6-VDC?
YES | NO
No Repair | No Repair

Go to 3A

Go to 1B-1

Guided Step 1B-1 - Inspect the real-time clock battery and engine wire harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the real-time clock battery from the engine harness.

Action

Inspect the real-time clock battery and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the real-time clock battery or engine harness.

  • Refer to Procedure 019-311 in Section 19.
  • Refer to Procedure 019-043 in Section 19.
No Repair

Go to 3A

Go to 1B-2

Guided Step 1B-2 - Check the real-time clock battery voltage at the battery module connector.

Conditions

  • Engine equipped with optional real-time clock battery
  • Turn keyswitch OFF
  • Disconnect the real-time clock battery from the engine harness.

Action

Measure the voltage between the real-time clock battery SUPPLY pin and the real-time clock battery RETURN (-) pin at the real-time clock battery connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Between 3.3-VDC and 3.6-VDC?
YES NO
No Repair

Repair

Replace the real-time clock battery. Refer to Procedure 019-311 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the battery module harness.

Guided Step 2A - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM.

Action

Measure the following resistance:

  • The resistance between the real-time clock battery SUPPLY pin at the battery connector of the engine harness to the real-time clock battery SUPPLY pin at the ECM harness connector
  • The resistance between the real-time clock battery RETURN (-) pin at the battery connector of the engine harness to the real-time clock battery RETURN (-) pin at the ECM harness connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the real-time clock battery from the engine harness.

Action

Use a multimeter to measure the resistance from the real-time clock battery SUPPLY pin at the ECM connector of the engine harness to all other pins in the connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM
  • Disconnect the real-time clock battery from the engine harness.

Action

Use a multimeter to measure the resistance from the real-time clock battery SUPPLY pin at the ECM connector of the engine harness to engine block ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to set real-time clock to the correct date and time.
  • Verify that Fault Code 1689 is inactive.

Fault Code 1689 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes

Repair complete.

Appropriate troubleshooting steps

Last Modified: 26-Apr-2012


FAULT CODE 1692 - Aftertreatment Outlet NOx Sensor - Voltage Below Normal, or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 1692 inactive?
STEP 2. | Check the aftertreatment outlet NOx sensor circuit. |
 | STEP 2A. Inspect the NOx sensor body and condition of the NOx sensor harness. | External damage to the sensor body, head (component fitted to the EGP), or harness?
 | STEP 2B. Inspect the NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the voltage to the NOx sensor. | Voltage within the specified range for the vehicle’s electrical system voltage?
 | STEP 2D. Verify that the OEM fuse is installed correctly. | Fuse installed correctly, or has it been replaced?
 | STEP 2E. Check the batteries and the power connector. | Connections tight and corrosion free?
 | STEP 2F. Check for an open circuit in the battery power circuit. | At least +22-VDC?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault Code 1692 inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1692 inactive?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the aftertreatment outlet NOx sensor circuit.

Guided Step 2A - Inspect the NOx sensor body and condition of the NOx sensor harness.

Conditions

  • Turn keyswitch OFF.

Action

Check the NOX sensor body and the NOX sensor harness.

  • Visually inspect the NOx sensor body and NOx sensor harness for cracks or damage

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

External damage to the sensor body, head (component fitted to the EGP), or harness?
YES NO

Repair

Replace the NOXx sensor.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment outlet NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connector has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the voltage to the NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment outlet NOx sensor.

  • Measure the voltage between the aftertreatment outlet NOx sensor supply circuit and the aftertreatment outlet NOx sensor return circuit at the OEM harness connector.

Vehicle electrical system voltage specified range.

  • For a 24V electrical system the measured voltage should be between +18-VDC and +32-VDC
  • For a 12V electrical system the measured voltage should be between +8-VDC and +16-VDC

Note: Check the voltage at key ON while cranking the engine and with the engine at idle.

Refer to the wiring diagram or the circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Voltage within the specified range for the vehicle’s electrical system voltage?
YES NO

Repair

An out-of-range fault has been detected by the aftertreatment exhaust NOx sensor control module.

Replace the aftertreatment exhaust NOx sensor. Refer to Procedure 019-451 in Section 19.

No Repair

Go to 3A

Go to 2D

Guided Step 2D - Verify that the OEM fuse is installed correctly.

Conditions

  • Turn keyswitch ON.

Action

Verify the fuse is installed correctly.

Note: The aftertreatment outlet NOx sensor power supply wire contains a 20-ampere fuse. This fuse is located in the OEM harness.

  • Inspect the OEM fuse for correct installation, or for a blown fuse.
  • Inspect the fuse for corrosion or damaged pins.

Fuse installed correctly, or has it been replaced?
YES NO
No Repair

Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the batteries and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion free?
YES NO
No Repair

Repair

Clean the terminals and tighten the loose connections. Refer to the OEM service manual.

Go to 2F

Go to 3A

Guided Step 2F - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check for an open circuit in the battery power circuits.

  • Measure the voltage from the aftertreatment outlet NOx sensor SUPPLY (+) pin of the OEM harness to engine block ground.

Refer to the wiring diagram or the circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

At least +22-VDC?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

Repair

An open circuit in the OEM battery supply circuit from the aftertreatment outlet NOx sensor has been detected.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Start the engine and operate for 1 minute. Diagnostic will perform and fault code will become inactive.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

NOTE: The inactive fault code can not be cleared from memory with INSITE™ electronic service tool. The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Aug-2012


FAULT CODE 1694 - Aftertreatment Outlet NOx Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active fault codes are present?
STEP 2. | Check the aftertreatment outlet NOx sensor. |
 | STEP 2A. Inspect the NOx sensor body and condition of the NOx sensor harness. | External damage to the sensor body, head (component fitted to the exhaust gas processor) or harness?
 | STEP 2B. Inspect the NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the NOx sensor installation. | NOx sensor installed correctly and the exhaust system free of leaks?
 | STEP 2D. Check pin-to-pin continuity in the OEM harness. | Resistances less than 10 ohms?
 | STEP 2E. Check the urea doser pump for correct operation. | Urea doser pump operates correctly during INSITE™ electronic service tool override test?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault Code 1694 is inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Troubleshoot any other active fault codes first.
  • All other active fault codes must be resolved before following this troubleshooting tree.

Active fault codes are present?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment outlet NOx sensor.

Guided Step 2A - Inspect the NOx sensor body and condition of the NOx sensor harness.

Conditions

  • Turn keyswitch OFF.

Action

Check the NOx sensor body and the NOx sensor harness.

  • Visually inspect the NOx sensor body and NOx sensor harness for cracks or damage.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

External damage to the sensor body, head (component fitted to the exhaust gas processor), or harness?
YES NO

Repair

Replace the NOx sensor.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the NOx sensor and connection pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the original equipment manufacturer (OEM) harness.

Action

Inspect the OEM harness and aftertreatment outlet NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connector has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.
  • If broken pins are found within the NOx sensor, replace the NOx sensor.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the NOx sensor installation.

Conditions

  • Turn keyswitch OFF.

Action

Check the aftertreatment NOx sensor installation and check the vehicle exhaust system.

Check for active fault codes.

  • Check that the NOx sensor is securely installed in the correct position with the correct fittings and fasteners.
  • Check the exhaust system for leaks and loose connections

NOx sensor installed correctly and the exhaust system free of leaks?
YES NO
No Repair

Repair

Repair the NOx sensor installation and/or exhaust system.

Go to 2D

Go to 3A

Guided Step 2D - Check pin-to-pin continuity in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the NOx sensor.
  • Disconnect the OEM harness ECM connector.

Action

Check the continuity of the NOx sensor circuit in the OEM wiring harness.

  • Check the pin-to-pin resistance of the OEM harness between the ECM connector and the NOx sensor connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistances less than 10 ohms?
YES NO
No Repair

Repair

The OEM wiring harness resistance is excessive. Repair or replace the OEM wiring harness.

Refer to the OEM service manual.

Go to 2E

Go to 3A

Guided Step 2E - Check the urea doser pump for proper operation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the dosing control unit.

  • Use INSITE™ electronic service tool to perform the Urea Doser Pump Override Test found under Aftertreatment Diagnostics Tests.

Use the following procedure for instructions and pass/fail criteria. Refer to Procedure 019-440 in Section 19.

Note: The urea injector nozzle must be removed and placed in a measuring container in order to perform this test. Make sure the nozzle is not plugged and urea is flowing from all four holes.

DEF doser pump operates correctly during INSITE™ electronic service tool override tests?
YES NO
No Repair

Repair

Replace the catalyst dosing unit. Refer to Procedure 019-440 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

It is necessary to drive or operate the vehicle on a chassis dynamometer in order to validate the repair and for the fault code to go inactive. INSITE™ electronic service tool can not be used to clear the fault code. The diagnostic must completely perform before the fault code will go inactive and the malfunction indicator lamp (MIL) lamp will go out.

First, operate the vehicle in a condition that allows the engine to be motored (throttle released as if coming to a stop) for at least 10 seconds, followed by applying 100 percent throttle for 10 seconds, keeping the engine speed greater than 850 rpm. Repeat this procedure three times. Then, using the Data Monitor/Logger screen in INSITE™ electronic service tool, add the following parameters to the monitor screen: Catalyst Inlet Temperature, Catalyst Outlet Temperature, Catalyst Solution Injection Rate, Stable Fueling Timer, Percent Fuel, Engine Speed, NOx Monitor Pass Count, and NOx Monitor Fail Count.

Operate the engine at the following conditions; constant vehicle speed and constant engine speed in the following ranges for the applicable engine model: ISBe4 (4 cylinder) - 1450 rpm to 1750 rpm, ISBe4 (6 cylinder) - 1400 rpm to 1700 rpm, or ISLe4 - 1150 rpm to 1450 rpm.

A minimum of 60 percent engine load and 100 percent catalyst solution injection rate and the catalyst inlet and catalyst outlet temperatures over 240°C [464°F]. Drive the vehicle or operate on a chassis dynamomotor at the above condition holding a constant engine speed, engine load, and throttle position for a minimum of 35 seconds. When the diagnostic runs and passes, the MIL lamp will go out and the NOx Monitor Pass Count will increment by one. If the fault code does not go inactive, continue operating at the steady state conditions for an additional 3 minutes. It may be necessary to repeat this procedure until the fault code goes inactive.

Note: After the fault code is disabled, the inactive fault code can not be cleared from memory using INSITE™ electronic service tool. The fault code will be cleared from memory after 400 days or 9600 hours of engine operation.

Fault Code 1694 is inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Appropriate troubleshooting steps

Last Modified: 13-Jun-2013


FAULT CODE 1697 - Aftertreatment Number 1 Air Enable Actuator - Voltage Above Normal, or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1697 inactive?
STEP 2. | Check the air solenoid and circuit. |
 | STEP 2A. Inspect the air solenoid and electrical and connections. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the air solenoid. | Solenoid resistance between 8 and 20 ohms?
 | STEP 2C. Check for a short circuit to ground in the air solenoid. | Greater than 100k ohms?
STEP 3. | Check the dosing control unit and dosing control unit harness. |
 | STEP 3A. Inspect dosing control unit and dosing control unit connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the original equipment manufacturer (OEM) harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code 1697 inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1697 is inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the air solenoid and circuit.

Guided Step 2A - Inspect the air solenoid and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the air solenoid.

Action

Inspect the OEM harness and air solenoid connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the air solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the air solenoid.

Action

Check air solenoid resistance.

  • Measure the resistance between the air solenoid SIGNAL pin and the air solenoid RETURN pin at the air solenoid.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Solenoid resistance between 8 and 20 ohms?
YES NO
No Repair

Repair

An open or short circuit has been detected in the air solenoid. Replace the dosing control unit. Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground in the air solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the air solenoid.

Action

Check for an air solenoid short to ground.

  • Measure the resistance between the air solenoid SIGNAL pin and ground at the air solenoid.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the dosing control unit. Refer to OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the dosing control unit and dosing control unit harness.

Guided Step 3A - Inspect the dosing control unit and dosing control unit connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the dosing control unit.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the dosing control unit.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the dosing control unit.
  • Disconnect the OEM harness from the air solenoid.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the air solenoid SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the air solenoid signal line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Start the engine and operate it for 1 minute. The diagnostic will perform and fault code will become inactive.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1697 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 24-Aug-2012


FAULT CODE 1698 - Aftertreatment Number 1 Air Enable Actuator - Voltage Below Normal, or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1698 inactive?
STEP 2. | Check the air solenoid and circuit. |
 | STEP 2A. Inspect the air solenoid and electrical and connections. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the air solenoid. | Solenoid resistance between 8 and 20 ohms?
 | STEP 2C. Check for a short circuit to ground in the air solenoid. | Greater than 100k ohms?
STEP 3. | Check the dosing control unit and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect dosing control unit and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit in the signal circuit. | Less than 10k ohms?
 | STEP 3E. Check for an open circuit in the return circuit. | Less than 10 ohms?
 | STEP 3F. Check for an inactive fault code. | Fault code 1698 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code 1698 inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1698 is inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the air solenoid and circuit.

Guided Step 2A - Inspect the air solenoid and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the air solenoid.

Action

Inspect the dosing control unit harness and air solenoid connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the air solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the air solenoid.

Action

Check air solenoid resistance.

  • Measure the resistance between the air solenoid SIGNAL pin and the air solenoid RETURN pin at the air solenoid.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Solenoid resistance is between 8 and 20 ohms?
YES NO
No Repair

Repair

An open or short circuit has been detected in the air solenoid.

Replace the dosing control unit. Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground in the air solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the air solenoid.

Action

Check for an air solenoid short to ground.

  • Measure the resistance between the air solenoid SIGNAL pin and ground at the air solenoid.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the dosing control unit. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the dosing control unit and OEM harness.

Guided Step 3A - Inspect the dosing control unit and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the dosing control unit.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the dosing control unit.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the dosing control unit.
  • Disconnect the OEM harness from the air solenoid.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the air solenoid SIGNAL pin in the dosing control unit harness and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the air solenoid signal line has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the dosing control unit.
  • Disconnect the air solenoid from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the air solenoid SIGNAL pin in the OEM harness and all other pins in the OEM harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the air solenoid signal line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the dosing control unit.
  • Disconnect the air solenoid from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the air solenoid SIGNAL pin in the OEM harness at the dosing control unit and the air solenoid SIGNAL pin in the OEM harness at the air solenoid.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the air solenoid signal line has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3E - Check for an open circuit in the return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the dosing control unit.
  • Disconnect the air solenoid from the dosing control unit harness.

Action

Check for an open circuit.

  • Measure the resistance between the air solenoid RETURN pin in the OEM harness at the dosing control unit and the air solenoid RETURN pin in the OEM harness at the air solenoid.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the air solenoid return line has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1698 inactive?

YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the dosing control unit. Refer to Procedure 019-440 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and operate it for 1 minute. Diagnostic will perform and fault code will become inactive.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1698 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 24-Aug-2012


FAULT CODE 1699 - Catalyst Tank Level Sensor - Data Erratic, Intermittent, or Incorrect.

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes and correct sensor configuration. |
 | STEP 1A. Check for catalyst tank level sensor fault codes. | Fault Code 1669, 1671, 1681, or 1682 active?
 | STEP 1B. Check for correct adjustment of Linear Urea Tank Volume parameter. | Adjustable parameter for Linear Urea Tank Volume set correctly for the vehicle urea tank volume?
STEP 2. | Check the catalyst system. |
 | STEP 2A. Inspect the catalyst solution system for external leaks. | External leaks detected in the system?
 | STEP 2B. Inspect the catalyst solution lines. | Plugged or restricted catalyst solution lines detected?
 | STEP 2C. Inspect the aftertreatment nozzle. | Plugged or restricted aftertreatment nozzle detected?
 | STEP 2D. Inspect the catalyst tank and catalyst tank level sensor for tampering. | Tampering detected in the catalyst system?
STEP 3. | Inspect the catalyst tank level sensor. |
 | STEP 3A. Check for correct operation of the catalyst tank level sensor. | Catalyst tank solution level sensor reading correctly?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1699 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check for fault codes and correct sensor configuration.

Guided Step 1A - Check for catalyst tank level sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ to read the fault codes.

Fault Code 1669,1671, 1681, or 1682 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for correct adjustment of Linear Urea Tank Volume parameter.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to check the adjustable parameter for Linear Urea Tank Volume is adjusted correctly.

Make sure that the adjustable parameter is adjusted correctly for the size of the urea tank that is used on the vehicle.

Adjustable parameter for Linear Urea Tank Volume set correctly for the vehicle urea tank volume?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool to adjust the parameter Linear Urea Tank Volume to the correct volume for the tank that is being used on the vehicle.

Go to 2A

Repair complete.

Guided Step 2 - Check the catalyst system.

Guided Step 2A - Inspect the catalyst solution system for external leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect catalyst solution lines and catalyst solution tank for:

  • External leaks.

External leaks detected in the system?
YES NO

Repair

Repair the source of the external leak.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the catalyst solution lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect catalyst solution lines for:

  • Plugging or restrictions.

Plugged or restricted catalyst solution lines detected?
YES NO

Repair

Repair or replace the catalyst solution lines.

Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Inspect the aftertreatment nozzle.

Conditions

  • Turn keyswitch OFF.
  • Use the following procedure in the Troubleshooting and Repair Manual, ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9, Bulletin 4021418 for removing the aftertreatment nozzle. Refer to Procedure 011-040

Action

Inspect the aftertreatment nozzle for:

  • Plugging or restrictions.

Use the following procedure in the Troubleshooting and Repair Manual, ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9, Bulletin 4021418 for inspection techniques. Refer to Procedure 011-040 in Section 11.

Plugged or restricted aftertreatment nozzle detected?
YES NO

Repair

Clean or replace the aftertreatment nozzle.

Use the following procedure in the Troubleshooting and Repair Manual, ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9, Bulletin 4021418 for inspection techniques. Refer to Procedure 011-040 in Section 11.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the catalyst tank and catalyst tank level sensor for tampering.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the catalyst tank and catalyst tank level sensor for the following:

  • External catalyst solution tanks
  • Oversized catalyst solution tank
  • Tampering of the catalyst tank level sensor.

Tampering detected in the catalyst system?
YES NO

Repair

Remove any external tampering devices.

Install the correct catalyst solution tank.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Inspect the catalyst tank level sensor.

Guided Step 3A - Check the correct operation of the catalyst tank level sensor.

Conditions

  • Turn keyswitch OFF.
  • Connect the INSITE™ electronic service tool.
  • Check the level of the catalyst solution in the catalyst tank.

Action

Check the operation of the catalyst tank level sensor.

  • Monitor the position of the catalyst tank solution level with INSITE™ electronic service tool.
  • Compare the reading from INSITE™ electronic service tool to the actual level of the catalyst solution.

Catalyst tank solution level sensor reading correctly?
YES NO
No Repair

Repair

Replace the catalyst tank solution level sensor.

Refer to the OEM service manual.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Allow the diagnostic to run. The diagnostic requires a quantity of diesel exhaust fluid (DEF) to be dosed. Depending on the application and system configuration, this may be up to 3 liters [3.17 qt].
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1699 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-Mar-2012


FAULT CODE 1711 - dosing control unit Data Link - Abnormal Update Rate

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part No. 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart No. 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code | Fault code 1711 active?
STEP 2. | Check the battery supply and ground circuits. |
 | STEP 2A. Check the battery supply to the dosing unit. | Voltage greater than +24-VDC?
 | STEP 2A-1. Check ground circuit. |
 | STEP 2B. Check the keyswitch voltage to the dosing control unit. | Voltage greater than +24-VDC?
STEP 3. | Check the data link harness. |
 | STEP 3A. Check for an open or short circuit in the J1939 data link harness. | Resistance between 50 and 70 ohms?
STEP 4. | Check the OEM harness. |
 | STEP 4A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the ECM J1939 data link harness. | Resistance between 50 and 70 ohms?
 | STEP 4C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100K ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 1711 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch OFF
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1711 is active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the battery supply and ground circuits.

Guided Step 2A - Check the battery supply to the dosing control unit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the wiring harness from the dosing control unit
  • Turn keyswitch ON.

Action

Check the voltage to the dosing control unit.

  • Measure the voltage between the dosing control unit OEM battery supply and the dosing control unit OEM ground.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Voltage greater than +24-VDC?
YES | NO
No Repair | No Repair

Go to 2B

Go to 2A-1

Guided Step 2A-1 - Check ground circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the wiring harness from the dosing control unit
  • Turn keyswitch ON.

Action

Measure resistance.

  • Measure the resistance from the dosing control unit OEM ground and engine block ground.

Less than 10 ohms?
YES NO

Repair

An open circuit in the OEM battery supply circuit has been detected.

Repair or replace the OEM harness. Refer to OEM service manual.

Repair

An open circuit in the OEM ground circuit has been detected.

Repair or replace the OEM harness. Refer to OEM service manual.

Go to 5A

Go to 5A

Guided Step 2B - Check the keyswitch voltage to the dosing control unit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the wiring harness from the dosing control unit
  • Turn keyswitch ON.

Action

Check the keyswitch input voltage to the dosing control unit.

  • Measure the voltage between the dosing control unit OEM keyswitch input and ground.

Voltage greater than +24-VDC?
YES NO
No Repair

Repair

An open circuit or low keyswitch voltage input has been detected in the dosing control unit ground circuit.

Repair or replace the OEM harness. Refer to OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Check the data link harness.

Guided Step 3A - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 Data Link (+) wire and the SAE J1939 Data Link (-) wire on the service data link connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 50 and 70 ohms?
YES NO
No Repair

Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the OEM harness.

Guided Step 4A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

Clean the connector and pins.

Repair the damaged pins harness, connector, or pins, if possible.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 Data Link (+) wire and the SAE J1939 Data Link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 50 and 70 ohms?
YES NO
No Repair

Repair

An open or short has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM.

Action

Check for an open or short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 Data Link (+) wire and the SAE J1939 Data Link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

NOTE: Disregard any resistance between 50 and 70 ohms between the SAE J1939 Data Link (+) and the SAE J1939 Data Link (-) pins.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100K ohms?
YES NO

Repair

A damaged dosing control unit has been detected.

Replace the dosing control unit.

Refer to OEM troubleshooting procedures.

Repair

A short has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and idle for 1 minute
  • Use INSITE™ electronic service tool to verify that Fault Code is inactive.

Fault Code 1711 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked a second time.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes..

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting steps

Last Modified: 26-Apr-2012


FAULT CODE 1712 - Catalyst Tank Heater Circuit - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault code 1677, 1678, 1679, 1683, 1684 is active?
STEP 2. | Check the catalyst tank heater relay and circuit. |
 | STEP 2A. Inspect the catalyst tank heater relay and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for voltage to the catalyst tank heater relay. | Greater than 22-VDC?
 | STEP 2C. Check the wiring to the catalyst tank heater. | Less than 10 ohms?
 | STEP 2D. Perform the urea heater relay override test with INSITE™ electronic serivce tool. | Is the catalyst solution tank heater relay operating correctly?
STEP 3. | Check the catalyst tank heater. |
 | STEP 3A. Check the catalyst tank heater for an open circuit. | Less than 10 ohms?
STEP 4. | Clear the fault code. |
 | STEP 4A. Verify the repair. | Catalyst solution temperature and the thermometer are reading within 2.8°C or 5°F of each other?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for catalyst tank heater or catalyst temperature sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677, 1678, 1679, 1683, 1684 is active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the catalyst tank heater relay and circuit.

Guided Step 2A - Inspect the catalyst tank heater relay and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the catalyst tank heater relay from the engine harness.

Action

Inspect the engine harness and catalyst tank heater relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for voltage to the catalyst tank heater relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the catalyst tank heater relays from the engine harness.

Action

Check catalyst tank heater relay power supply.

  • Measure the voltage between the catalyst tank heater power pin and block ground.

Refer to the wiring diagram for connector pin identification.

Greater than 22-VDC?
YES NO
No Repair

Repair

The power supply to the catalyst tank heater is not correct.

Repair or replace the OEM wiring to the catalyst tank heater relay. Refer to OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the wiring to the catalyst tank heater.

Conditions

  • Turn keyswitch OFF.

Action

Check catalyst tank heater wiring between the catalyst tank heater relay and the catalyst tank heater.

  • Measure the resistance of the power supply wire between the catalyst tank heater relay and the catalyst tank heater.

Refer to the wiring diagram for connector pin identification.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit exists between the catalyst tank heater relay and the catalyst tank heater.

Repair or replace the OEM wiring between the catalyst tank heater relay and the catalyst tank heater. Refer to OEM service manual.

Go to 2D

Go to 4A

Guided Step 2D - Perform the urea heater relay override test with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch OFF
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform urea heater relay override test.

  • Enable the Urea Heater Relay Override test and listen for the catalyst solution tank heater relay operation. An audible click should be heard.

Is the catalyst solution tank heater relay operating correctly?
YES NO
No Repair

Repair

Remove the catalyst tank heater relay from the wiring harness. Check the relay pins and check the relay for proper operation.

Replace the catalyst tank heater relay. Refer to OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the catalyst tank heater.

Guided Step 3A - Check the catalyst tank heater for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the catalyst tank heater. Refer to OEM service manual.

Action

Check the catalyst tank heater for an open circuit.

  • Measure the resistance of the heater coil in the catalyst tank heater.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the catalyst tank heater.

Replace the catalyst tank heater. Refer to OEM service manual.

Go to 1A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Insert a thermometer in the catalyst solution tank.

Action

Start the INSITE™ electronic service manual Data Monitor/Logger.

  • Compare the INSITE™ electronic service tool reading for the catalyst solution temperature with the thermometer.

Catalyst solution temperature and the thermometer are reading within 2.8°C or 5°F of each other?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to erase all active and inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 26-Apr-2012


FAULT CODE 1713 - Catalyst Tank Heater Circuit - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1677, 1678, 1679, 1683, or 1684 is active?
STEP 2. | Check the catalyst solution tank heater relay and circuit. |
 | STEP 2A. Inspect the catalyst solution tank heater relay and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the catalyst solution tank heater relay. | Less than 10 ohms?
 | STEP 2C. Check the catalyst solution tank heater diagnostic voltage, supply line, and return circuit. | Greater than 11-VDC?
 | STEP 2D. Check the catalyst solution tank heater diagnostic voltage, supply line, and return circuit at the ECM. | Greater than 11-VDC?
 | STEP 2E. Perform the urea heater relay override test with INSITE™ electronic service tool. | Is the catalyst solution tank heater relay operating correctly?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault Code 1713 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for catalyst tank heater or catalyst temperature sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677, 1678, 1679, 1683, or 1684 is active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the catalyst solution tank heater relay and circuit.

Guided Step 2A - Inspect the catalyst solution tank heater relay and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the catalyst tank heater relay from the engine harness.

Action

Inspect the engine harness and catalyst tank heater relay connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the catalyst solution tank heater relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the catalyst tank heater relay from the engine harness.

Action

Check the catalyst solution tank heater relay resistance.

  • Measure the resistance between the catalyst solution tank heater relay SIGNAL pin and the catalyst solution tank heater RETURN pin at the catalyst solution tank heater relay.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

Repair

A stuck closed catalyst solution tank heater relay has been detected.

Replace the catalyst solution tank heater relay. Refer to OEM service manual.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the catalyst solution tank heater diagnostic voltage, supply line, and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the catalyst solution tank heater relay from the engine harness.
  • Turn keyswitch ON.

Action

Check for catalyst solution tank heater supply voltage and return circuit.

  • Measure the voltage between the catalyst solution tank heater relay SIGNAL pin and the catalyst solution tank heater RETURN pin at the engine harness.

Refer to the wiring diagram for connector pin identification.

Greater than 11-VDC?
YES | NO
No Repair | No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check the catalyst solution tank heater diagnostic voltage, supply line, and return circuit at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the catalyst solution tank heater relay from the engine harness.
  • Turn keyswitch ON.

Action

Check for catalyst soluction tank heater supply voltage and return circuit.

  • Measure the voltage the catalyst solution tank heater relay SIGNAL pin and the catalyst solution tank heater RETURN pin at the ECM.

Refer to the wiring diagram for connector pin identification.

Greater than 11-VDC?
YES NO

Repair

A damaged ECM has been detected.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

A short circuit to battery has been detected in the wiring harness.

Replace the wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 2E - Perform the urea heater relay override test with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the urea heater relay override test.

  • Enable the Urea Heater Relay Override test and listen for the catalyst solution tank heater relay operation. An audible click should be heard.

Is the catalyst solution tank heater relay operating correctly?
YES NO
No Repair

Repair

Remove the catalyst tank heater relay from the wiring harness. Check the relay pins and check the relay for proper operation.

Replace the catalyst tank heater relay. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault code 1713 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 26-Apr-2012


FAULT CODE 1716 - Auxiliary Temperature Sensor Input 1 Circuit - Root Cause Not Known

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1716. | Active or inactive counts of Fault Code 1716?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1716.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1716?
YES NO

Repair

The engine protection limit has been exceeded.

  • Refer to the Engine Coolant Temperature Above Normal symptom tree in ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418, or refer to the OEM service manual.
No Repair

Appropriate troubleshooting symptom tree.

Repair complete

Last Modified: 26-Apr-2012


FAULT CODE 1717 - Exhaust Gas Temperature 1 - Data Valid but Above Normal Operational Range - Least Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for fault codes 1665 and 1666. | Fault Code 1665 or 1666 is active?
STEP 2. | Check the air handling system for correct operation. |
 | STEP 2A. Check the charge air cooler, clamps, hoses, and piping. | Air leak present or clamps loose?
 | STEP 2B. Inspect turbocharger compressor and turbine blades. | Damage found on turbocharger blades?
STEP 3. | Inspect the exhaust gas temperature #1 sensor. |
 | STEP 3A. Inspect the exhaust gas temperature #1 sensor. | Damage found on exhaust gas temperature #1 sensor?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault code 1717 inactive?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes 1665 and 1666.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1665 or 1666 is active?
YES | NO
No Repair | No Repair

Fault code 1665 or 1666 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the air handling system for correct operation.

Guided Step 2A - Check the charge air cooler, clamps, hoses, and piping.

Conditions

  • Turn keyswitch OFF.

Action

Check the charge air cooler, hoses, and piping for leaks.

  • Check the clamps for adequate torque.

Air leaks present or clamps loose?
YES NO
No Repair

Repair

Repair the air leak.

Go to 2B

Go to 4A

Guided Step 2B - Inspect turbocharger compressor and turbine blades.

Conditions

  • Turn keyswitch OFF
  • Remove the inlet and exhaust connections from the turbocharger.

Action

Inspect the turbocharger compressor and turbine blades for damage.

  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 010-033 in Section 19.

Damage found on turbocharger blades?
YES NO
No Repair

Repair

Replace the turbocharger. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 010-033 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the exhaust gas temperature #1 sensor.

Guided Step 3A - Inspect the exhaust gas temperature #1 sensor.

Conditions

  • Turn keyswitch OFF
  • Remove the exhaust gas temperature #1 sensor from the exhaust system.

Action

Inspect the exhaust gas temperature #1 sensor.

  • Inspect the exhaust gas temperature #1 sensor for damage or signs of excessively high temperature.

Damage found on exhaust gas temperature #1 sensor?
YES NO
No Repair

Repair

Replace the exhaust gas temperature #1 sensor. Refer to Procedure 019-013 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault code 1717 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 26-Apr-2012


FAULT CODE 1718 - Engine Misfire for Multiple Cylinders - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fuel system related fault codes active or have accumulated inactive counts?
 | STEP 1B. Check for cylinder misfire. | Cylinder misfire detected?
STEP 2. | Perform diagnostic tests. |
 | STEP 2A. Perform the cylinder cutout test. | Cylinder misfire detected and isolated to injector?
STEP 3. | Clear the fault code. |
 | STEP 3A. Verify the repair | Cylinder misfire present?
 | STEP 3B. Clear the fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine and let it idle for 1 minute
  • Use INSITE™ electronic service tool to read the fault codes.

Fuel system related fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for cylinder misfire.

Conditions

  • Turn keyswitch ON.
  • Start the engine and run at low idle.

Action

Check for smoke, engine stumble, rough idle or misfire.

  • Check for black or white smoke, engine stumble, rough idle, or misfire at low idle, high idle and during snap throttle accelerations.

Cylinder misfire detected?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Perform diagnostic tests.

Guided Step 2A - Perform the cylinder cutout test

Conditions

  • Turn the keyswitch ON
  • Allow the engine to run at idle speed
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool cylinder cutout test to determine if multiple cylinders are misfiring.

  • Cutout individual cylinders to locate the misfiring cylinder.

Cylinder misfire detected and isolated to the injector?
YES NO

Repair

A damaged injector has been detected

Replace the injector. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6.

Repair

Check for other sources of cylinder misfire such as: valve lash out of adjustment, cylinder damage, valve damage, cylinder head or gasket damage, or extreme camshaft wear.

Go to 3A

Appropriate troubleshooting procedures.

Guided Step 3 - Clear the fault code.

Guided Step 3A - Verify the repair.

Conditions

  • Connect all components
  • Turn the keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Verify cylinder misfire is no longer present.

  • Start the engine and verify the cylinder misfire is no longer present.

Cylinder misfire is present?
YES | NO
No Repair | No Repair

Go to 1A

Go to 3B

Guided Step 3B - Clear the fault codes.

Conditions

  • Connect all components
  • Turn the keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to erase all active and inactive fault codes.

All faults cleared?
YES | NO
No Repair | No Repair

Repair complete?

Appropriate troubleshooting steps.

Last Modified: 26-Apr-2012


Fault Code 1845 - Water-in-Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source (For Generator Engines Only)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1845 active?
STEP 2. | Check the water-in-fuel sensor and circuit. |
 | STEP 2A. Inspect the engine harness and the water-in-fuel sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the water-in-fuel sensor resistance. | Greater than 200k ohms?
 | STEP 2C. Check the fault codes and verify water-in-fuel sensor condition. | Fault Code 1845 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 1846 active and Fault Code 1845 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1845 inactive?
STEP 4. | ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1845 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the water-in-fuel sensor and circuit.

Guided Step 2A - Inspect the engine harness and the water-in-fuel sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water-in-fuel sensor connector from the engine harness connector.

Action

Inspect the engine harness and water-in-fuel sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the water-in-fuel indicator sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged water-in-fuel indicator sensor.

  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Refer to Procedure 019-127 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the water-in-fuel indicator SIGNAL pin and the water-in-fuel indicator RETURN (sensor return 1) pin at the water-in-fuel sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 200k ohms?
YES NO

Repair

Replace the water-in-fuel indicator sensor. Refer to Procedure 019-127 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the water-in-fuel sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1845 active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged connector.

  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-204 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 1846 active and Fault Code 1845 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the water-in-fuel indicator sensor connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM 60-pin connector water-in-fuel indicator sensor RETURN (sensor return 1) pin and the engine harness water-in-fuel indicator sensor connector RETURN (sensor return 1) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the open circuit.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the water-in-fuel indicator sensor connector from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector water-in-fuel indicator SIGNAL pin and the water-in-fuel indicator SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the open circuit.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the water-in-fuel indicator sensor connector from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the water in fuel indicator SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.

  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1845 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. The cause of the failure should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-May-2012


Fault Code 1846 - Water-in-Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source (For Generator Engines Only)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1846 active?
STEP 2. | Check the water-in-fuel indicator sensor and circuit. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1845 active and Fault Code 1846 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1846 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 1845 active and Fault Code 1846 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 200k ohms?
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 200k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1846 inactive?
STEP 4. | ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1846 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the water-in-fuel indicator sensor and circuit.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water-in-fuel indicator sensor connector from the engine harness connector.

Action

Inspect the engine harness and water-in-fuel indicator sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the water-in-fuel indicator sensor or harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of harness or damaged water-in-fuel indicator sensor.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-205 in Section 19.
  • Refer to Procedure 019-127 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water-in-fuel indicator sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1845 active and Fault Code 1846 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify water-in-fuel indicator sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the water-in-fuel indicator sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1846 is active?
YES NO

Repair

A damaged water-in-fuel indicator sensor has been detected.

Replace the water-in-fuel indicator sensor. Refer to Procedure 019-127 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the engine harness from the water-in-fuel indicator sensor.

Action

Inspect the engine harness, water-in-fuel indicator sensor, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of harness or damaged connector.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1845 active and Fault Code 1846 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the water-in-fuel indicator sensor connector from the engine harness connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the water-in-fuel indicator SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 200k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the water-in-fuel indicator SIGNAL wire has been detected in the engine harness.

  • Troubleshoot each section of the engine harness to determine which contains the pin-to-pin short.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.
  • Disconnect the water-in-fuel indicator sensor connector from the engine harness connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the water-in-fuel indicator SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 200k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

  • Troubleshoot each section of the engine harness to determine which contains the short circuit to ground.
  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1846 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. The cause of the failure should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-May-2012


FAULT CODE 1849 - Intake Manifold 1 Temperature — Abnormal Rate of Change

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for active fault codes. | Fault code 1848 is active?
 | STEP 1B. Check for fault codes. | Fault Codes 153 or 154 is active?
STEP 2. | Check the engine intake manifold temperature sensor and circuit. |
 | STEP 2A. Inspect the engine intake manifold temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active?
 | STEP 2C. Check the circuit response. | Fault Code 154 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 153 active?
 | STEP 3C. Check the circuit response. | Fault Code 154 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the repair | Intake Manifold Temperature and Catalyst Inlet Temperature reading within 5.6°C or 10°F of each other?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1848 is active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for fault codes 153 and 154.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 or 154 is active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the engine intake manifold temperature sensor and circuit.

Guided Step 2A - Inspect the engine intake manifold temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold temperature sensor from the engine harness.

Action

Inspect the engine harness and engine intake manifold temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Note: Fault Code 123 will also be active when the intake manifold temperature sensor is disconnected.

Fault Code 153 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine intake manifold temperature SIGNAL pin and the engine intake manifold temperature RETURN pin at the engine intake manifold temperature connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 is active?
YES NO

Repair

An in-range malfunction of the intake manifold temperature sensor has been detected.

Replace the engine intake manifold temperature sensor. Refer to Procedure Procedure 019-059 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECMconnector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 is active?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine intake manifold temperature SIGNAL pin and engine intake manifold temperature RETURN pin at the ECM connector.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 is active?
YES NO

Repair

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the INSITE™ electronic service tool Data Monitor/Logger.

  • Compare the INSITE™ electronic service tool reading for Intake Manifold Temperature and Catalyst Inlet Temperature.

Intake Manifold Temperature and Catalyst Inlet Temperature reading within 5.6°C or 10°F of each other?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to erase all active and inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 13-Apr-2022


FAULT CODE 1849 - Exhaust Gas Temperature 1 - Abnormal Rate of Change

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 1665 and 1666. | Fault Code 1665 or 1666 is active?
STEP 2. | Check the exhaust gas temperature #1 sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature #1 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1666 active?
 | STEP 2C. Check the circuit response. | Fault Code 1665 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1666 active?
 | STEP 3C. Check the circuit response. | Fault Code 1665 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the repair | Catalyst Inlet Temperature and Catalyst Outlet Temperature reading within 13.9°C or 25°F of each other?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 1665 and 1666.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1665 or 1666 is active?
YES | NO
No Repair | No Repair

Fault Code 1665 or 1666 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature #1 sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature #1 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature #1 sensor from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature #1 sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature #1 sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1666 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature #1 sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the exhaust gas temperature #1 SIGNAL pin and the exhaust gas temperature #1 RETURN pin at the exhaust gas temperature #1 connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1665 is active?
YES NO

Repair

Replace the exhaust gas temperature #1 sensor. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1666 is active?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the exhaust gas temperature #1 SIGNAL pin and exhaust gas temperature #1 RETURN pin at the ECM connector.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1665 is active?
YES NO

Repair

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the INSITE™ electronic service tool Data Monitor/Logger.

  • Compare the INSITE™ electronic service tool reading for Catalyst Inlet Temperature and Catalyst Outlet Temperature.

Catalyst Inlet Temperature and Catalyst Outlet Temperature reading within 13.9°C or 25°F of each other?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to erase all active and inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


FAULT CODE 1851 - Exhaust Gas Temperature 2 - Abnormal Rate of Change

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 1674 and 1675. | Fault Code 1674 or 1675 is active?
STEP 2. | Check the exhaust gas temperature #2 sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature #2 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1675 active?
 | STEP 2C. Check the circuit response. | Fault Code 1674 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1675 active?
 | STEP 3C. Check the circuit response. | Fault Code 1674 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the repair | Catalyst Inlet Temperature and Catalyst Outlet Temperature reading within 13.9°C or 25°F of each other?
 | STEP 4B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1674 or 1675 is active?
YES | NO
No Repair | No Repair

Fault Code 1674 or 1675 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature #2 sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature #2 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature #2 sensor from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature #2 sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature #2 sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1675 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature #2 sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the exhaust gas temperature #2 SIGNAL pin and the exhaust gas temperature #2 RETURN pin at the exhaust gas temperature #2 connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1674 is active?
YES NO

Repair

Replace the exhaust gas temperature #2 sensor. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1675 is active?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the exhaust gas temperature #2 SIGNAL pin and exhaust gas temperature #2 RETURN pin at the ECM connector.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1674 is active?
YES NO

Repair

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify the repair.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the INSITE™ electronic service tool Data Monitor/Logger.

  • Compare the INSITE™ electronic service tool reading for Catalyst Inlet Temperature and Catalyst Outlet Temperature.

Catalyst Inlet Temperature and Catalyst Outlet Temperature reading within 13.9°C or 25°F of each other?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to erase all active and inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


FAULT CODE 1892 - Wheel-Based Vehicle Speed - Data Valid but Below Normal Operational Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the vehicle speed sensor setting in INSITE™ electronic service tool. |
 | STEP 1A. Verify that the vehicle speed sensor and the setting in INSITE™ electronic service tool match. | The setting in INSITE™ electronic service tool matches the speed sensor type on the vehicle?
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness pins and the sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the OEM harness connector pins at the ECM. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit to ground in the OEM harness. | More than 100k ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the OEM harness. | More than 100k ohms?
STEP 3. | Check for additional OEM devices. |
 | STEP 3A. Check the vehicle speed sensor circuit for additional devices. | Extra devices?
 | STEP 3B. Check for the gear slipping on the shaft. | Gear or tone wheel damaged or slips?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 1892 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the vehicle speed sensor setting in INSITE™ electronic service tool.

Guided Step 1A - Verify that the vehicle speed sensor and the setting in INSITE™ electronic service tool match.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool, go to the Vehicle Speed Source feature under Adjustments, Features and Parameters.

  • Verify that the vehicle speed sensor type parameter in INSITE™ electronic service tool matches the physical sensor type on the vehicle.

The setting in INSITE™ electronic service tool matches the speed sensor type on the vehicle?
YES NO
No Repair

Repair

Change the setting in the ECM with INSITE™ electronic service tool to match the vehicle speed sensor type.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness pins and the sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the OEM harness connector pins at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Use a multimeter, check for an open circuit in the OEM harness.

  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (+) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.
  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (-) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for a short circuit to ground on the magnetic vehicle speed sensor SIGNAL (+) and magnetic vehicle speed sensor SIGNAL (-) circuit in the OEM harness.

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) at the ECM connector to engine block ground.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) at the ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Use a multimeter, check for a pin-to-pin short circuit in the OEM harness.

  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (+) pin at the OEM harness ECM connector and all other pins in the connector.
  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (-) pin at the OEM harness ECM connector and all other pins in the connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check for additional OEM devices.

Guided Step 3A - Check the vehicle speed sensor circuit for additional devices.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the vehicle speed sensor circuit for any additional or extra devices that can interfere with the speed signal.

–

Extra devices?
YES NO

Repair

Remove the device or contact an OEM representative.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for the gear slipping on the shaft.

Conditions

  • Turn keyswitch OFF.
  • Remove the vehicle speed sensor from the transmission.

Action

Inspect the gear or tone wheel on the rear of the transmission where the speed sensor picks up the speed signal. Make sure the gear or tone wheel is not damaged or slipping on the shaft.

–

Gear or tone wheel damaged or slips?
YES NO

Repair

Repair or replace the gear or tone wheel. Refer to the OEM service manual.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and move the vehicle so that the ECM can read a vehicle speed.
  • Use INSITE™ electronic service tool to verify that Fault Code 1892 is inactive.

Fault Code 1892 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location or OEM dealer if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 26-Apr-2012


FAULT CODE 1911 - Injector Metering Rail Number 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 271, 272, 559, 2311, or 1117 active or high inactive counts?
STEP 2. | Check the rail fuel pressure sensor. |
 | STEP 2A. Verify the rail fuel pressure sensor reads in-range. | Pressure 0 ± 40 bar [0 ± 580 psi]?
 | STEP 2B. Inspect the fuel pressure sensor SIGNAL wire and connector pins. | Dirty or damaged pins?
STEP 3. | Perform preliminary fuel system checks. |
 | STEP 3A. Check the fuel inlet restriction. | Fuel inlet restriction within the specifications outlined in Procedure 006-020?
 | STEP 3B. Check the fuel filter pressure drop. | Fuel pressure drop within the specifications outlined in Procedure 006-015?
 | STEP 3C. Check the fuel filter pressure drop. | Fuel pressure drop within the specifications outlined in Procedure 006-015?
STEP 4. | Check drain line restriction. |
 | STEP 4A. Check the drain line restriction. | Fuel drain line restriction within the specifications outlined in Procedure 006-012?
STEP 5. | Check the fuel pump actuator. |
 | STEP 5A. Check the fuel pump actuator and harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check the fuel pump actuator resistance. | Less than 5 ohms?
 | STEP 5C. Check the fuel pump actuator for a short to ground. | Greater than 100k ohms?
 | STEP 5D. Monitor the fuel rail pressure at idle. | Does measured fuel rail pressure deviate more than 200 bar [2901 psi] and surge at idle?
 | STEP 5E. Inspect the fuel pump actuator for damage. | O-rings on the fuel pump actuator damaged?
STEP 6. | Check the engine harness. |
 | STEP 6A. Inspect the engine harness engine control module (ECM) to connector pins. | Dirty or damaged pins?
 | STEP 6B. Check the engine harness resistance. | Less than 5 ohms?
 | STEP 6C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 6D. Check for an intermittent engine harness failure. | Fault Codes 2311, 271, or 272 become active?
STEP 7. | Check ECM calibrtion and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault codes inactive?
 | STEP 7C. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the fuel pump actuator shorted low or high.

Fault Code 271, 272, 559, 2311, or 1117 active or high inactive counts?
YES | NO
No Repair | No Repair

Appropriate Troubleshooting Tree

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor.

Guided Step 2A - Verify that the rail fuel pressure sensor reads in-range.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Verify the sensor reads in-range.

Pressure 0 ± 40 bar [0 ± 580 psi]?
YES NO
No Repair

Repair

The fuel pressure sensor is incorrectly reading a fuel pressure.

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 2B

Go to 7A

Guided Step 2B - Inspect the fuel pressure sensor SIGNAL wire and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect ECM from engine harness.

Action

Inspect the fuel pressure sensor SIGNAL wire and connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris on or in the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Note: A bad connection on the fuel pressure sensor SIGNAL wire can cause the signal reading to fluctuate and cause this fault code to become active on an intermittent basis.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Perform preliminary fuel system checks.

Guided Step 3A - Check the fuel inlet restriction.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Check the fuel inlet restriction.

  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-020 in Section 6.
  • Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4, and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-020 in Section 6.

Fuel inlet restriction within the specifications outlined in Procedure 006-020 in Section 6?
YES NO
No Repair

Repair

If inlet restriction is excessive, search for the root cause:

  • Suction side fuel filters plugged
  • Fuel heater valves are restricted
  • OEM fuel lines pinched or restricted
  • Fuel tank stand pipes restricted

If the fuel inlet restriction is too high, check the OEM fuel lines from the tank for proper size. Make certain there are no kinks or bends in the fuel lines and the fuel lines are not clogged.

Check the OEM fuel supply tanks for debris (plastic , paper, etc.) that could intermittently block the fuel pickup tubes.

Check the OEM fuel lines for internal damage, such as damaged wall linings, that could intermittently block fuel flow.

Make sure there are no clogged OEM fuel strainers, filters, or malfunctioning check valves.

If no issues are found, replace the suction-side fuel filter and prime the fuel system.

  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-015 in Section 6.
  • Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4, and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-015 in Section 6.

Go to 3B

Go to 7A

Guided Step 3B - Check the fuel filter pressure drop.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Check the fuel pressure drop across the filter.

  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-015 in Section 6.
  • Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4, and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-015 in Section 6.

Fuel pressure drop within the specifications outlined in Procedure 006-015?
YES NO
No Repair

Repair

Make sure the filter pump pressure into the filter is within specification.

  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-015 in Section 6.
  • Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4, and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-015 in Section 6.

If the pump meets specifications, replace the fuel filter and prime the fuel system.

  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-015 in Section 6.
  • Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4, and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-015 in Section 6.

Go to 3C

Go to 7A

Guided Step 3C - Check for air in the fuel.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Check for air in the fuel.

  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-003 in Section 6.
  • Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4, and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-003 in Section 6.

Air in fuel?
YES NO

Repair

A few bubbles exiting the line during the test is expected.

A foamy appearance is an indication of a leak that allows air to enter, a severe inlet restriction that causes cavitation, or a system that is not yet primed.

The source of air entry should be isolated to one for the following:

  • Suction fuel lines
  • OEM fuel lines
  • Suction-side fuel filter assemblies
  • Stand pipe(s) in the fuel tank(s)
 No Repair

Go to 7A

Go to 4A

Guided Step 4 - Check drain line restriction.

Guided Step 4A - Check drain line restriction.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Check for excessive fuel drain line restriction.

  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-012 in Section 6.
  • Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4, and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-012 in Section 6.

Fuel drain line restriction is within the specifications outlined in Procedure 006-012?
YES NO
No Repair

Repair

Repair the source of the high fuel drain line restriction.

  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-012 in Section 6.
  • Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4, and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-012 in Section 6.

Go to 5A

Go to 7A

Guided Step 5 - Check the fuel pump actuator.

Guided Step 5A - Check the fuel pump actuator and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the fuel pump actuator, pigtail wires, and harness connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris on or in the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

  • Repair the connector and pins.
  • Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 7A

Go to 5B

Guided Step 5B - Check the fuel pump actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check the fuel pump actuator resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the fuel pump actuator RETURN pin at the actuator connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 0 ohms and less than 5 ohms?
YES NO
No Repair

Repair

Replace the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

Go to 5C

Go to 7A

Guided Step 5C - Check the fuel pump actuator for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check the fuel pump actuator for a short to ground.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the engine block ground.

Greater than 100 ohms?
YES NO
No Repair

Repair

Replace the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

Go to 5D

Go to 7A

Guided Step 5D - Monitor the fuel rail pressure at idle.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine.

Action

Operate the engine at idle for at least 1 minute to purge air induced from the previous steps.

  • Use INSITE™ electronic service tool to monitor commanded fuel rail pressure and measured fuel rail pressure.

Does measured fuel rail pressure deviate more than 200 bar [2901 psi] and surge at idle?
YES NO

Repair

Replace the fuel pump actuator. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 005-007 in Section 5.

No Repair

Go to 7A

Go to 5E

Guided Step 5E - Inspect the fuel pump actuator for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

Action

Inspect the fuel pump actuator o-rings for damage.

–

O-rings on the fuel pump actuator damaged?
YES NO

Repair

Replace the fuel pump actuator o-rings. Refer to Procedure 019-117 in Section 19.

No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check the engine harness.

Guided Step 6A - Inspect the engine harness ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris on or in the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the connector or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 7A

Go to 6B

Guided Step 6B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pump actuator to the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check the engine harness resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the fuel pump actuator RETURN pin at the ECM connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 6C

Go to 7A

Guided Step 6C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check the engine harness for a short to ground.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the ECM connector of the engine harness and engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 6D

Go to 7A

Guided Step 6D - Check for an intermittent engine harness malfunction.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Operate engine at low idle.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or malfunction.

  • Manipulate the engine harness, starting at the ECM engine harness connector and working to the fuel pump actuator.

If the short or open circuit is induced while the engine is operating, the fuel rail pressure relief valve will open.

Fault Codes 2311, 271, and/or 272 become active?
YES NO

Repair

An intermittent connection has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault codes are inactive.

Fault codes inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7C

Go to 1A

Guided Step 7C - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 06-May-2014


FAULT CODE 1992 - Engine Crankshaft Speed/Position - Data Valid but Above Normal Operational Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

WARNING

DO NOT OPERATE A DIESEL ENGINE WHERE THERE ARE OR CAN BE COMBUSTIBLE VAPORS. These vapors can be sucked through the air intake system and cause engine acceleration and overspeeding that can result in a fire, an explosion, and extensive property damage. Numerous safety devices are available, such as air intake shutoff devices, to minimize the risk of overspeeding where an engine, due to its application, might operate in a combustible environment, such as due to a fuel spill or gas leak. Remember, Cummins Inc. has no way of knowing the use you have for your engine. THE EQUIPMENT OWNER AND OPERATOR ARE RESPONSIBLE FOR SAFE OPERATION IN A HOSTILE ENVIRONMENT. CONSULT YOUR CUMMINS AUTHORIZED REPAIR LOCATION FOR FURTHER INFORMATION.
CAUTION

If the engine speed stays above 15 percent of rated speed, the engine must be shut off immediately or engine generator equipment damage can occur.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for an alternate fuel source. | Alternate fuel source?
 | STEP 1B. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 1C. Inspect the engine harness and engine crankshaft speed/position sensor connector pins. | Dirty or damaged pins?
 | STEP 1D. Check for an active fault at low engine rpm. | Inactive fault code at low rpm?
 | STEP 1E. Test the engine. | Fault Code 1992 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1992 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if a fuel-controlled event occurred where the engine rapidly accelerated to or past 15 percent above rated speed, followed by moderate deceleration to 15 percent above rated speed.

Alternate fuel source?
YES NO

Repair

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON
  • Engine is running.

Action

Check the engine rpm with INSITE™ electronic service tool.

NOTE: Compare the engine crankshaft speed/position sensor reading with INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.

Correct rpm reading?
YES NO
No Repair

Repair

Inspect the engine crankshaft speed/position sensor and engine camshaft speed/position sensor as outlined in Fault Codes 689 and 1376.

Go to 1C

Fault Codes 689 and 1376.

Guided Step 1C - Inspect the engine harness and engine crankshaft speed/position sensor connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness connector from the engine crankshaft speed/position sensor connector.

Action

Inspect the OEM harness and engine crankshaft speed/position sensor connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine crankshaft speed/position sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness or damaged engine crankshaft speed/position sensor.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-199 in Section 19.
  • Refer to Procedure 019-218 in Section 19.
No Repair

Go to 2A

Go to 1D

Guided Step 1D - Check for an active fault at low engine rpm.

Conditions

  • Turn keyswitch ON.

Action

Check for active Fault Code 1992 when the engine is not running above 15 percent above rated speed.

  • Check for active Fault Code 1992 when the engine is not running above 15 percent above rated speed.

Inactive fault code at low rpm?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 1E

Go to 2A

Guided Step 1E - Test the engine.

Conditions

  • Turn keyswitch ON.

Action

Test the engine to check if the overspeed condition is still present.

  • Test the engine to check if the overspeed condition is still present.

Fault Code 1992 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1992 inactive?
YES | NO
No Repair | No Repair

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 29-Mar-2012


FAULT CODE 2183 - Engine Brake Actuator Driver 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead, and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2183 is inactive?
 | STEP 1B. Determine engine brake type. | Is the engine equipped with a compression brake?
STEP 2. | Check the engine brake solenoid and circuit. |
 | STEP 2A. Check the diagnostic signal voltage at the engine brake pass-through connector. | Greater than 3.75-VDC?
 | STEP 2B. Check the engine brake wiring harness for damage. | Damaged connectors or wire insulation?
 | STEP 2C. Check the engine brake solenoid for a short to ground. | 5 ohms or greater?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine brake solenoid number 1 diagnostic supply voltage. | Greater than 3.75-VDC?
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2183 inactive?
 | STEP 3E-1. Check for exhaust brake installation. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2183 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2183 is inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 1B

Guided Step 1B - Determine engine brake type.

Conditions

  • Turn keyswitch OFF.

Action

Determine if the engine is equipped with a compression brake or exhaust brake.

–

Is the engine equipped with a compression brake?
YES NO
No Repair

Repair

The engine is equipped with an exhaust brake.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine brake solenoid and circuit.

Guided Step 2A - Check the diagnostic signal voltage at the engine brake pass-through connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake solenoid number 1 wire from the pass-through connector on the rocker lever housing.
  • Turn keyswitch ON.

Action

Check the engine brake solenoid number 1 diagnostic supply voltage.

  • Measure the voltage between the engine harness engine brake solenoid number 1 SIGNAL pin and ground.

Refer to the wiring diagram for connector pin identification.

Greater than 3.75-VDC?
YES | NO
No Repair | No Repair

Go to 2B

Go to 3A

Guided Step 2B - Check the engine brake wiring harness for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 003-011 in Section 19.
  • Remove the engine brake jumper harness between that pass-through connector and the engine brake solenoid.

Action

Inspect the internal engine brake jumper harness for the following:

  • Bent or broken pins
  • Wire insulation damaged
  • Connector shell broken.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged connectors or wire insulation?
YES NO

Repair

Repair or replace the engine brake harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the engine brake solenoid for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 003-011 in Section 3.
  • Disconnect the engine brake harness from engine brake solenoid number 1.

Action

Check the resistance of the solenoid.

  • Measure the resistance from engine brake number 1 solenoid terminal pin to ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

5 ohms or greater?
YES NO
No Repair

Repair

Replace the engine brake solenoid. Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 020-012 in Section 20.

020-012 in

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness form the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine brake solenoid number 1 diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the engine brake solenoid number 1 diagnostic supply voltage.

  • Measure the voltage between the engine brake solenoid number 1 SIGNAL pin and ground at the ECM connector.

Refer to the wiring diagram for connector pin identification.

Greater than 3.75-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • If equipped with engine brakes, disconnect the engine brake solenoid number 1 from the engine brake pass-through connector.
  • If equipped with an exhaust brake, disconnect the 2-pin Weather Pack™ connector at the back of the engine between the number 5 and 6 high pressure fuel lines.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine brake solenoid number 1 SIGNAL pin in the engine harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on engine brake actuator SIGNAL line has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the shorted supply circuit to ground.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • If equipped with engine brakes, disconnect the engine brake solenoid number 1 from the engine brake pass-through connector.
  • If equipped with an exhaust brake, disconnect the 2-pin Weather Pack™ connector at the back of the engine between the number 5 and 6 high pressure fuel lines.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine brake solenoid number 1 SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the engine brake solenoid number 1 SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2183 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

 No Repair

Go to 4A

Go to 3E-1

Guided Step 3E-1 - Check for exhaust brake installation.

Conditions

–

Action

Check if the engine is equipped with an exhaust brake.

–

Is the engine equipped with an exhaust brake?
YES NO

Repair

Refer to the OEM service manual to check the wiring and circuitry between the Cummins® wiring harness and the exhaust brake.

Repair

All the wiring has been checked and found to be OK. The ECM has malfunctioned.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

OEM service manual

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2183 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


FAULT CODE 2185 - Sensor Supply Voltage 4 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2185 active?
STEP 2. | Check the ECM and OEM harness. |
 | STEP 2A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2C. Check for a pin-to-pin short circuit in the unswitched battery supply OEM harness. | Greater then 100K ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2185 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM and OEM harness.

Guided Step 2A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

Measure the resistance between the accelerator pedal +5-VDC SUPPLY pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the accelerator pedal +5-VDC SUPPLY wire.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit in the unswitched battery supply OEM harness

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.
  • Disconnect the OEM power harness from the ECM.

Action

Check for a short circuit to battery.

Measure the resistance between the accelerator pedal SUPPLY pin in the OEM harness ECM connector and the ECM battery SUPPLY (+) pin of the power harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2185 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


FAULT CODE 2186 - Sensor Supply Voltage 4 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2186 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the accelerator pedal or lever position sensor and circuit connected to the sensor supply and return | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2186 active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3B-1. Check for a pin short circuit to ground in the OEM harness. |
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2186 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the accelerator pedal or lever position sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES NO
No Repair

Repair

Replace the accelerator pedal or lever position sensor. Refer to the OEM service manual.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

Measure the resistance between the accelerator pedal +5-VDC SUPPLY pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the accelerator pedal +5-VDC supply wire.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for a pin short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Check for a short to ground.

Measure the resistance between the accelerator pedal +5-VDC SUPPLY pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the accelerator pedal +5-VDC SUPPLY wire.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2186 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-Apr-2012


FAULT CODE 2195 - Auxiliary Equipment Sensor Input 3 Engine Protection Critical - Special Instructions

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify the sensor accuracy by inspecting the OEM device. | Refer to the OEM service manual for specification
STEP 2. | Check the OEM harness. |
 | STEP 2A. Inspect the OEM harness and 50-pin connectors. | No damaged pins
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. |
STEP 3. | Clear the inactive fault codes. |
 | STEP 3B. Clear the inactive fault codes | Fault Code 2195 inactive

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify the sensor accuracy by inspecting the OEM device.

Conditions

  • Turn keyswitch ON.

Action

Verify the sensor accuracy by inspecting the OEM device.

  • Locate the OEM input device and what vehicle condition is being monitored with the sensor.

OEM device operating correctly?
YES NO
No Repair

Repair

A damaged OEM sensor has been detected.

Replace the sensor. Refer to the OEM service manual.

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM at the 50-pin connector.

Action

Inspect the OEM harness and 50-pin connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged OEM harness connection has been detected.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair or replace the OEM harness. Refer to the OEM service manual.

 No Repair

Go to 3A

Go to 1A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code 2195 is inactive.

Fault Code 2195 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-Apr-2012


FAULT CODE 2215 (ISB/QSB Automotive, Industrial, or Marine Application) - Fuel Pump Delivery Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2215 active?
STEP 2. | Preliminary checks. |
 | STEP 2A. Check for adequate fuel supply. | The equipment/vehicle has an adequate fuel supply?
 | STEP 2B. Inspect for external fuel leaks. | Fuel leak present?
 | STEP 2C. Check the system voltage. | Voltage within the specified range?
 | STEP 2D. Check for lift pump operation at key ON. | Lift pump operates at key on?
STEP 3. | Check the fuel supply to the fuel injection pump. |
 | STEP 3A. Lift pump volume test. | Lift pump meets minimum flow specification and has no air in the fuel?
 | STEP 3A-1. Air in the fuel. |
 | STEP 3B. Check the fuel filter restriction. | Lift pump meets minimum flow specification?
 | STEP 3C. Check the fuel inlet restriction. | Lift pump inlet restriction meets specifications?
 | STEP 3D. Check lift pump voltage (determine configuration). | Is the engine a 12 volt automotive or marine configuration?
 | STEP 3E. Check lift pump voltage (determine configuration). | Is the engine a 24 volt automotive configuration?
 | STEP 3F. Check lift pump voltage (+24-VDC marine). | Is the lift pump voltage within specification?
 | STEP 3G. Check lift pump voltage (+12-VDC automotive and marine). | Is the lift pump voltage within specification?
 | STEP 3H. Check lift pump voltage (+24-VDC automotive). | Is the lift pump voltage greater than +16-VDC?
 | STEP 3I. Test the +24-VDC voltage regulator (24 volt automotive). | Is the lift pump voltage greater than +10-VDC?
 | STEP 3J. Test the +24-VDC voltage regulator (24 volt automotive). | Does the voltage regulator function?
STEP 4. | Check the fuel injectors. |
 | STEP 4A. Check the injector return flow. | Injector return flow within specifications?
 | STEP 4B. Check the high-pressure connector (HPC) torque. | Injector high-pressure connector torque meets specifications?
 | STEP 4C. Check for individual leaking injectors. | Is fuel injector return flow within specification with an injector capped off?
STEP 5. | Check the high-pressure fuel rail. |
 | STEP 5A. Verify rail fuel pressure sensor accuracy. | Is the fuel rail pressure (measured) less than 30 bar [435 psi]?
 | STEP 5B. Measure the high-pressure fuel rail return flow. | Fuel return flow meets specifications?
STEP 6. | Check the high-pressure injection pump. |
 | STEP 6A. High-pressure injection pump flow test. | Fuel pump flow meets the specification?
 | STEP 6B. Check drain line restriction. | Fuel drain line restriction within specification?
STEP 7. | Clear the fault code. |
 | STEP 7A. Disable the fault code. | Fault Code 2215 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2215 active?
YES | NO
No Repair | No Repair

Go to 2A

Fault Code 2215 must be recreated in order to properly troubleshoot. If it can not be recreated, see the Shop Talk section.

Guided Step 2 - Preliminary checks.

Guided Step 2A - Check for adequate fuel supply.

Conditions

  • Turn keyswitch ON.
  • Engine OFF.

Action

Check for adequate fuel supply.

  • Check the equipment/vehicle fuel gauge.
  • Inspect the fuel tank if there is any doubt about the accuracy of the fuel gauge.

The equipment/vehicle has an adequate fuel supply?
YES NO
No Repair

Repair

Add fuel to the fuel tank.

Go to 2B

Go to 7A

Guided Step 2B - Inspect for external fuel leaks.

Conditions

  • Turn keyswitch ON.
  • Operate engine (if it will start).

Action

Check for external fuel leaks.

  • Start the engine and allow it to idle.
  • Inspect for external fuel leaks.

Fuel leak present?
YES NO

Repair

Repair the fuel leak. See ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.

No Repair

Go to 7A

Go to 2C

Guided Step 2C - Check the system voltage.

Conditions

  • Turn keyswitch ON.
  • Operate engine (if it will start).

Action

Check the system voltage.

  • Monitor battery voltage in INSITE™ electronic service tool data monitor.
  • Connect a digital volt ohm multimeter to the batteries and monitor battery voltage.

Voltage within the specified range?

+12-VDC System: Voltage +10-15-VDC

+24-VDC System: Voltage +22-28-VDC
YES NO
No Repair

Repair

Troubleshoot the cause of low battery voltage. See the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271.

Go to 2D

Go to 7A

Guided Step 2D - Check for lift pump operation at key ON.

Conditions

  • Turn keyswitch ON.
  • Do notoperate engine.

Action

Check for lift pump operation at key ON.

  • Turn the keyswitch ON, then listen and feel for lift pump operation.
  • Note: The lift pump will operate for 60 seconds after keyswitch ON, then switch OFF.

Lift pump operates at key ON?
YES | NO
No Repair | No Repair

Go to 3A

Go to 3D

Guided Step 3 - Check the fuel supply to the fuel injection pump.

Guided Step 3A - Lift pump volume test.

Conditions

  • Turn keyswitch ON.
  • Service tool, Part Number 3824842 (Compuchek™ fitting) and Part Number 3164621 (orifice with drain hose), connected to the fuel filter OUTLET test port.

Action

Perform the lift pump volume test.

  • Install service tool, Part Number 3824842 and Part Number 3164621, to the fuel filter OUTLET test port, place the fuel line in an empty bucket, and turn the keyswitch ON. Allow the fuel lift pump to operate for the full cycle of 60 seconds. See the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, for measuring the lift pump flow. Refer to Procedure 005-045 in Section 5.
  • Check for signs of air in the fuel.

Lift pump meets minimum flow specification and has no air in the fuel?

Fuel flow rate for lift pump (do notoperate engine) - greater than 600 ml in 60 seconds or fill a 12-ounce can in 36 seconds or less.

Air in the fuel consists of large bubbles or aerated fuel after the system has been primed.
YES | NO
No Repair | No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Air in the fuel.

Conditions

  • Turn keyswitch OFF.

Action

Check for air in the fuel.

Was there air in the fuel during step 3A?

Air in the fuel consists of large bubbles or aerated fuel after the system has been primed.
YES NO

Repair

Determine the source of the air and repair. See the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271 or see the OEM manual. Refer to Procedure Refer to the Procedure 006-003 in Section 6.

No Repair

Go to 7A

Go to 3B

Guided Step 3B - Check the fuel filter restriction.

Conditions

  • Turn keyswitch ON.
  • Service tool, Part Number 3824842 (Compuchek™ fitting) and Part Number 3164621 (Orifice with drain hose), connected to the fuel filter INLET test port.

Action

Perform the lift pump volume test.

  • Remove service tool, Part Number 3824842 and Part Number 3164621, from the fuel filter outlet and connect to the fuel filter INLET test port, place the fuel line in an empty bucket, and turn the keyswitch ON. Allow the fuel lift pump to operate for the full cycle of 60 seconds. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271, to measure the lift pump flow. Refer to Procedure 005-045 in Section 5.
  • Check for signs of air in the fuel.

Lift pump meets minimum flow specification?

Fuel flow rate for lift pump (do notoperate engine) - greater than 600 ml in 60 seconds or fill a 12-ounce can in 36 seconds or less.

YES NO

Repair

Replace or repair the pressure side fuel filter/housing. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-015 in Section 6.

No Repair

Go to 7A

Go to 3C

Guided Step 3C - Check the fuel inlet restriction.

Conditions

  • Turn keyswitch ON.
  • Service tool, Part Number 3824842, connected to the fuel filter INLET test port.
  • Restriction gauge connected at the inlet of the fuel lift pump.

Action

Check fuel inlet restriction.

  • Install an M12 x 1/8 inch NPT banjo screw, Part Number 4918413, into the inlet of the fuel lift pump.
  • Install a vacuum gauge into the back of the banjo screw (gauge range of at least 0 to 67.7 kPa [0 to 20 in-Hg].
  • Connect service tool, Part Number 3824842 and Part Number 3164621, to the fuel filter housing INLET test port.
  • Turn the keyswitch ON and operate the lift pump.
  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271, for measuring the lift pump flow. Refer to Procedure 006-020 in Section 6.

Lift pump inlet restriction meets specifications?

Allowable fuel inlet restriction at full lift pump flow: Vehicle Applications MAX: 20.3 kPa [6.0 in-Hg]; Marine Applications MAX: 13.5 kPa [4.0 in-Hg]

YES NO
No Repair

Repair

Inspect the OEM fuel lines, OEM pre-filter, and fuel tank pickup tube for restrictions or damage. Refer to the OEM service manual.

Go to 3D

Go to 7A

Guided Step 3D - Check lift pump voltage (determine configuration).

Conditions

Action

Determine lift pump configuration.

  • 12 volt Automotive/Marine
  • 24 volt Automotive
  • 24 volt Marine.

Is the engine a 12 volt automotive or marine configuration?
YES | NO
No Repair | No Repair

Go to 3G

Go to 3E

Guided Step 3E - Check lift pump voltage (determine configuration).

Conditions

Action

Determine lift pump configuration.

  • 12 volt Automotive/Marine
  • 24 volt Automotive
  • 24 volt Marine.

Is the engine a 24 volt automotive configuration?
YES | NO
No Repair | No Repair

Go to 3H

Go to 3F

Guided Step 3F - Check lift pump voltage (24 volt marine).

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Lift pump override test active.

Action

Measure lift pump voltage.

  • Install the Deutsch™ 2-pin breakout cable, Part Number 3163531, and measure the lift pump voltage with the override test active.

Voltage will only be present when the lift pump is commanded ON and when the lift pump is connected to the harness. Use INSITE™ electronic service tool lift pump override test and a breakout cable between the lift pump and the engine harness to measure the lift pump voltage.

Is the lift pump voltage within specification?

Minimum: +21-VDC

Maximum: +28-VDC
YES NO

Repair

Replace the lift pump. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 005-045 in Section 5.

Repair

Check the ECM and engine harnesses. See Section 19.

Go to 7A

Go to 7A

Guided Step 3G - Check lift pump voltage (12 volt automotive and marine).

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Lift pump override test active.

Action

Measure lift pump voltage.

  • Install the Deutsch™ 2-pin breakout cable, Part Number 3163531, and measure the lift pump voltage with the override test active.

Voltage will only be present when the lift pump is commanded ON and when the lift pump is connected to the harness. To measure the lift pump voltage, use INSITE™ electronic service tool lift pump override test and a breakout cable between the lift pump and the engine harness.

Is the lift pump voltage within specification?

Minimum: +9-VDC

Maximum: +16- VDC
YES NO

Repair

Replace the lift pump. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 005-045 in Section 5.

Repair

Check the ECM and engine harnesses. See Section 19.

Go to 7A

Go to 7A

Guided Step 3H - Check lift pump voltage (24 volt automotive).

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Lift pump override test active.

Action

Measure lift pump voltage.

  • Install the Deutsch™ 2-pin breakout cable, Part Number 3163531, and measure the lift pump voltage with the override test active.

Voltage will only be present when the lift pump is commanded ON and when the lift pump is connected to the harness. To measure the lift pump voltage, use INSITE™ electronic service tool lift pump override test and a breakout cable between the lift pump and the engine harness.

Is the lift pump voltage greater than +16-VDC?
YES NO

Repair

Replace the lift pump and voltage regulator. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 005-045 in Section 5.

No Repair

Go to 7A

Go to 3I

Guided Step 3I - Test the 24 volt voltage regulator (24 volt automotive).

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Lift pump override test active.

Action

Measure lift pump voltage.

  • Install the Deutsch™ 2-pin breakout cable, Part Number 3163531, and measure the lift pump voltage with the override test active.

Voltage will only be present when the lift pump is commanded ON and when the lift pump is connected to the harness. To measure the lift pump voltage, use INSITE™ electronic service tool lift pump override test and a breakout cable between the lift pump and the engine harness.

Is the lift pump voltage greater than +10-VDC?
YES NO

Repair

Replace the lift pump. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 005-045 in Section 5.

No Repair

Go to 7A

Go to 3J

Guided Step 3J - Test the 24 volt voltage regulator (24 volt automotive).

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Lift pump override test active.

Action

Test the 24 volt voltage regulator (24 volt automotive).

  • Fuse
  • Relay
  • Supply voltage from the ECM
  • Supply voltage from the OEM.

Reference the wiring diagram, Bulletin 4021347. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271, for details about the voltage regulator. Refer to Procedure 005-045 in Section 5.

Does the voltage regulator function?
YES NO

Repair

No repair. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 005-045 in Section 5.

Repair

Replace the voltage regulator.

Go to 7A

Go to 7A

Guided Step 4 - Check the fuel injectors.

Guided Step 4A - Check the injector return flow.

Conditions

  • Turn keyswitch ON.
  • Install test fittings, Part Number 3164618 banjo adapter with drain hose, to measure the fuel return from the injectors and high-pressure connectors.
  • Operate engine at idle.
  • INSITE™ electronic service tool Fuel System Leakage Test ACTIVE, if available.

Action

Check for excessive fuel leakage from the injectors and high-pressure connectors.

  • Attach service tool, Part Number 3164618, to the injector return line. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6.

Injector return flow within specifications?

Flow Specifications:

  • INSITE™ electronic service tool fuel system leakage test active: 4-Cylinder: 200 ml/minute maximum [6.8 fl-oz per minute]; 6-Cylinder: 300 ml/minute maximum [10.1 fl-oz per minute]
  • Standard Idle Conditions: 4-Cylinder: 120 ml/minute maximum [4 fl-oz per minute]; 6-Cylinder: 180 ml/minute maximum [6 fl-oz per minute]
  • Engine Cranking: 4 and 6 - Cylinder: 90 ml/minute maximum [3.04 fl-oz per minute]

Do not overheat the starter.

YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the high-pressure connector (HPC) torque.

Conditions

  • Turn keyswitch OFF.

Action

Check the injector high pressure connector torque.

  • Check the injector high-pressure connector torque. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-052 in Section 6.

Injector high-pressure connector torque meets specifications?
YES NO
No Repair

Repair

Inspect the high pressure connector for damage and replace, if necessary. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-052 in Section 6.

Go to 4C

Go to 7A

Guided Step 4C - Check for individual leaking injectors.

Conditions

  • Turn keyswitch ON.
  • Install test fittings to measure the fuel return from the injectors and high-pressure connectors.
  • Operate engine at idle.
  • INSITE™ electronic service tool Fuel System Leakage Test ACTIVE, if available.
  • Tools: Part Number 3164618 banjo adapter with drain hose, Part Number 3164325 injector isolation.

Action

Check for fuel leak rate at individual injectors.

  • Cap off each injector one at a time with the injector leakage isolation tool, Part Number 3164325. The service tool must be installed with the engine OFF.
  • With each injector capped off, repeat the injector leakage test.

Injector isolation tool use: Isolate each injector using the tool and compare the injector return flows. The cylinder having the highest reduction effect (causes the most difference) is the source of the leak.

Any injector causing a 20 percent or greater reduction in return volume is suspect. If the engine would not start, but does with an injector isolated, operate the engine for 1 minute to determine if the code changes to inactive. If so, replace that injector and continue the isolation test. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in section 6. Refer to Procedure 006-052 in Section 6.

Is fuel injector return flow within specification with an injector capped off?

Flow Specification: Standard Idle Conditions: 4-cylinder: 120 ml/minute maximum or not more than 4 fl-oz per minute; 6-cylinder: 180 ml/minute maximum or not more than 6 fl-oz per minute

Flow Specification: Engine Cranking: 4 and 6 - cylinder: 90 ml/minute maximum [3.04 fl-oz per minute]

Do not overheat the starter.

YES NO

Repair

Replace the injector of the cylinder that is contributing to the high return flow. For ISB CM800, CM850, CM2150, CM2150 SN, CM2250 and QSB CM850 and CM2250 engines, inspect the high pressure connector for damage and only replace the high pressure connector if necessary. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6. Refer to Procedure 006-052 in Section 6.

Repair

Cap off additional injectors to identify the source of high injector return flow. For the cylinders that are causing the high injector return flow, replace the injectors. For ISB CM800, CM850, CM2150, CM2150 SN, CM2250 and QSB CM850 and CM2250 engines, inspect the high pressure connector for damage and only replace the high pressure connector if necessary. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6. Refer to Procedure 006-052 in Section 6.

Go to 7A

Go to 7A

Guided Step 5 - Check the high-pressure fuel rail.

Guided Step 5A - Verify rail fuel pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • INSITE™ Monitor.
  • Do not operate the engine.

Action

Monitor the fuel rail pressure.

  • Use INSITE™ electronic service tool to measure fuel rail pressure.

Is the fuel rail pressure (measured) less than 30 bar [435 psi]?
YES NO
No Repair

Repair

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in Section 19.

Go to 5B

Go to 7A

Guided Step 5B - Measure the high-pressure fuel rail return flow.

Conditions

  • Turn keyswitch ON.
  • Install a test fitting Part Number 3164617 (adapter with drain hose) on the high-pressure rail relief valve.
  • Operate engine at idle.
  • INSITE™ electronic service tool Fuel System Leakage Test ACTIVE, if available.

Action

Check for excessive fuel return from the high-pressure fuel rail.

  • Attach the appropriate service tool to the high-pressure rail relief valve. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-061 in Section 6.

Fuel return flow meets specifications?

Specification:

At Idle: No flow

INSITE™ electronic service tool Override: Maximum: 1 drop per second (16 ml [0.5 oz] per 60 seconds).
YES NO
No Repair

Repair

  • Replace the rail fuel pressure relief valve. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-061 in Section 6.
  • Determine the reason why the fuel rail pressure relief valve has been tripping. If not done, this could result in repeat malfunctions.

Examples:

  • Operation with the electronic fuel control valve unplugged.
  • Operation with a plugged fuel filter or excessive inlet restriction.

Go to 6A

Go to 7A

Guided Step 6 - Check the high-pressure injection pump.

Guided Step 6A - High-pressure injection pump flow test.

Conditions

  • Turn keyswitch ON.
  • Engine cranking.

Action

Check the high-pressure injection pump fuel flow.

  • Disconnect the high-pressure fuel line from to the fuel rail from the high-pressure injection pump.
  • Connect a clear hose to the outlet of the high-pressure injection pump.
  • Run the high pressure fuel line into an empty bucket.
  • Crank the engine for 30 seconds and measure the fuel pump flow.
  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 005-016 in Section 5.

Fuel pump flow meets the specification?

Minimum fuel pump flow is 75 ml [2.5 oz] in 30 seconds at 125 rpm or 90 ml [3.04 oz] in 30 seconds at 150 rpm.
YES NO

Repair

Replace the EFC actuator valve. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 005-007 in Section 5.

Repair

Replace the high pressure fuel pump. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 005-016 in Section 5.

Go to 6B

Go to 6B

Guided Step 6B - Check drain line restriction.

Conditions

  • Turn keyswitch ON.
  • Install test fittings to measure the fuel drain line restriction.
  • Operate engine at high idle no load.

Action

Check for excessive fuel drain line restriction.

  • Install test fittings to measure fuel drain line restriction.
  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-012 in Section 6.

Fuel drain line restriction within specification?

Maximum fuel drain line restriction at high idle no load is 18.6 kPa [2.7 psi]
YES NO
No Repair

Repair

  • Repair the source of the high fuel drain line restriction. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-013 in Section 6.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Fault Code 2215 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Do not operate the engine.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-May-2012


FAULT CODE 2215 (ISC/QSC/ISL/QSL Automotive, Industrial, or Marine Application) - Fuel Pump Delivery Pressure Low - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 275, 449, 1117, or 2311 active or high inactive counts?
 | STEP 1B. Inspect for external fuel leaks. | Fuel leaks present?
 | STEP 1C. Verify the rail fuel pressure sensor accuracy. | Fuel rail pressure +/- 43 bar [+/- 624 psi]?
STEP 2. | Check engine operation. |
 | STEP 2A. Attempt to start the engine. | Engine start?
 | STEP 2B. Check the fuel supply. | Adequate amount of fuel in the tank?
STEP 3. | Check the low-pressure fuel system. (Engine not operating) |
 | STEP 3A. Check the fuel lift pump pressure. | Fuel lift pump pressure within specifications?
 | STEP 3B. Measure the fuel gear pump pressure. | Fuel gear pump pressure greater than specifications?
STEP 4. | Check the low-pressure fuel system. (Engine operating) |
 | STEP 4A. Check for external fuel leak. | Any external fuel leaks?
 | STEP 4B. Check for air in the high-pressure pump fuel supply. | Air present in the fuel supply?
 | STEP 4C. Measure inlet restriction at the original equipment manufacturer (OEM) connection point. | OEM inlet restriction above specification?
 | STEP 4D. Measure inlet restriction at the gear pump inlet. | Gear pump inlet restriction above specification?
 | STEP 4E. Measure the gear pump pressure. | Gear pump pressure above specification?
 | STEP 4F. Measure the fuel filter restriction. | Fuel filter pressure drop above specification?
STEP 5. | Check the high-pressure fuel system. |
 | STEP 5A. Measure the fuel pump head flow. | Fuel pump head flow greater than 100 cc [3.4 oz] in 30 seconds of cranking?
 | STEP 5B. Check for excessive fuel return from the fuel injector drain line. | Fuel injector leakage excessive?
 | STEP 5C. Check for excessive fuel return from the high-pressure pump. | Fuel pump leakage excessive?
 | STEP 5D. Check for excessive leakage from the rail fuel pressure relief valve. | Rail fuel pressure relief valve leaking more than 30 drops per minute?
STEP 6. | Verify the repair is complete. |
 | STEP 6A. Disable the fault code. | Fault Code 2215 becomes active during loaded engine operation?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 275, 449, 1117, or 2311 active or high inactive counts?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Inspect for external fuel leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for external fuel leaks.

  • Look for fuel leaking from loose fuel fittings and damaged fuel lines, or damaged components.

Fuel leaks present?
YES NO

Repair

Repair the fuel leak.

  • Use the procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418: Refer to Procedure 006-024 in Section 6.
No Repair

Go to 6A

Go to 1C

Guided Step 1C - Verify the rail fuel pressure sensor accuracy.

Conditions

  • Turn keyswtich ON.
  • Connect INSITE™ electronic service tool.
  • Monitor INSITE™ electronic service tool.
  • Do not operate the engine.

Action

Make sure the correct sensor part number is installed in the high pressure fuel rail.

Monitor the fuel rail pressure.

  • Use INSITE™ electronic service tool to measure fuel rail pressure.

Fuel rail pressure 0 +/- 43 bar [0 +/- 624 psi]?
YES NO
No Repair

Repair

Replace the rail fuel pressure sensor.

  • Refer to Procedure 019-115 in Section 19.

Go to 2A

Go to 6A

Guided Step 2 - Check engine operation.

Guided Step 2A - Check to see if the engine will start.

Conditions

  • Turn keyswitch ON.

Action

Attempt to start the engine.

Engine start?
YES | NO
No Repair | No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fuel supply.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel tank for fuel.

Adequate amount of fuel in the tank?
YES NO
No Repair

Repair

Fill the tank with fuel.

Go to 3A

Go to 6A

Guided Step 3 - Check the low-pressure fuel system (engine not operating).

Guided Step 3A - Check the fuel lift pump pressure.

Conditions

  • Turn keyswitch ON.

Action

Measure the fuel lift pump output pressure.

Use the procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418: Refer to Procedure 005-045 in Section 5.

Fuel lift pump pressure within the specifications outlined in Procedure 005-045, in Section 5 of the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418?

YES NO
No Repair

Repair

Determine the cause of the low lift pump pressure. Use the procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418: Refer to Procedure 005-045 in Section 5.

Go to 3B

Go to 6A

Guided Step 3B - Measure fuel gear pump pressure.

Conditions

  • Turn keyswitch ON.

Action

Measure the gear pump pressure during cranking.

Use the procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418: Refer to Procedure 005-025 in Section 5.

Fuel gear pump pressure greater than the specifications outlined in Procedure 005-025, in Section 5 of the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418?

YES NO
No Repair

Repair

Replace the fuel gear pump module.

Use the procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418: Refer to Procedure 005-025 in Section 5.

Go to 5A

Go to 6A

Guided Step 4 - Check the low-pressure fuel system (engine operating).

Guided Step 4A - Check for external fuel leak.

Conditions

  • Operate engine.

Action

Check for external fuel leaks.

  • Start the engine and allow it to idle.
  • Inspect for external fuel leaks.

Any external fuel leaks?
YES NO

Repair

Repair all fuel leaks.

Reference Section 6 in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for air in the high-pressure pump fuel supply.

Conditions

  • Operate engine.

Action

Check for air in the fuel.

Use the procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418: Refer to Procedure 006-003 in Section 6.

Air present in the fuel supply?
YES NO

Repair

  • Locate and correct the cause of air ingestion in the fuel supply system.
  • Sources of air ingestion include loose fuel filters, loose fuel line fittings, loose or cracked fuel tank stand pipes, or severe restrictions in the fuel supply lines and filters.
No Repair

Go to 6A

Go to 4C

Guided Step 4C - Measure the inlet restriction at the OEM connection point.

Conditions

  • Operate engine.

Action

Measure the fuel inlet restriction.

  • Use the procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418: Refer to Procedure 006-020 in Section 6.

If the engine will not start or the engine starts and stalls, be sure fuel is primed to the gear pump. This test is only valid if the engine is operating.

OEM inlet restriction above specification outlined in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418? Refer to Procedure 006-020 in Section 6.

YES NO

Repair

A fuel restriction exists upstream of the OEM connection point. Refer to the OEM service manual.

 No Repair

Go to 6A

Go to 4D

Guided Step 4D - Measure the inlet restriction at the gear pump inlet.

Conditions

  • Turn keyswitch OFF.

Action

Measure the fuel inlet restriction.

  • Use the procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-020 in Section 6

If the engine will not start or the engine starts and stalls, be sure fuel is primed to the gear pump. This test is only valid if the engine is operating.

Gear pump inlet restriction above specification outlined in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418? Refer to Procedure 006-020 in Section 6.

YES NO

Repair

A restriction may exist between the OEM connection and the gear pump inlet.

Inspect the engine control module ( ECM) cooling plate check valve as described in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418.

Refer to Procedure 006-006 in Section 6.

No Repair

Go to 6A

Go to 4E

Guided Step 4E - Measure the gear pump pressure.

Conditions

  • Turn keyswitch OFF.

Action

Measure the gear pump pressure.

  • Use the Initial Check procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 005-025 in Section 5.

Gear pump pressure above specification outlined in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418? Refer to Procedure 005-025 in Section 5.

YES NO
No Repair

Repair

The gear pump pressure is low.The gear pump is worn.

Replace the gear pump. Use the procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 402141.

Refer to Procedure 005-025 in Section 5.

Go to 4F

Go to 6A

Guided Step 4F - Measure the fuel filter restriction.

Conditions

  • Turn keyswitch ON.

Action

Measure the pressure at the inlet to the pressure-side fuel filter.

  • Use the procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-015 in Section 6.

Measure the pressure at the outlet of the pressure-side fuel filter.

  • Use the procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418.

Refer to Procedure 006-015 in Section 6.

Fuel filter pressure drop above specification.?
YES NO

Repair

The fuel filter is plugged.

Replace the pressure-side fuel filter. Use the procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418.

Refer to Procedure 006-015 in Section 6.

No Repair

Go to 6A

Go to 5A

Guided Step 5 - Check the high-pressure fuel system

Guided Step 5A - Measure the fuel pump head flow.

Conditions

  • Disconnect the high-pressure fuel line from the rail.
  • Clamp a hose to the end of the fuel line.
  • Route a hose from the test fitting into a clean, graduated cylinder.

Action

Crank the engine fo 30 seconds.

  • Measure the fuel pump head flow.

Fuel pump head flow greater than 100 cc [3.4 oz] in 30 seconds of cranking?
YES NO
No Repair

Repair

Replace the fuel pump head.

If ceramic debris is present from plunger damage, replace the entire pump.

Use the procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 005-227 in Section 5.

Go to 5B

Go to 6A

Guided Step 5B - Check for excessive fuel return from the fuel injector drain line.

Conditions

  • Turn keyswitch OFF.
  • Use the procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418: Refer to Procedure 006-026 in Section 6.

Action

Start the engine.

  • Use INSITE™ electronic service tool high-pressure test to raise the fuel rail pressure.
  • Measure the fuel leakage from the fuel injector return line.

If the engine will not start, perform this test while cranking the engine. Use the procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-026 in Section 6.

Fuel injector leakage excessive?
YES NO

Repair

Isolate the injector high-pressure connector(s) that are the cause of the excessive leakage.

Tighten the loose high-pressure fuel connectors.

Use the procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-026 in Section 6.

No Repair

Go to 6A

Go to 5C

Guided Step 5C - Check for excessive fuel return from the high-pressure pump.

Conditions

  • Turn keyswitch OFF.
  • Install test fittings to measure the fuel drain from the fuel pump head. Use the procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418: Refer to Procedure 005-227 in Section 5.
  • Route a hose from the test fitting into a clean graduated cylinder.
  • Operate engine.
  • Connect INSITE™ electronic service tool.

Action

Start the engine.

  • Use INSITE™ electronic service tool High-Pressure Control Relief Pressure Test to raise the fuel rail pressure.
  • Measure the fuel leakage from the fuel pump head.

If the engine will not start, perform this test while cranking the engine. Use the procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 005-227 in Section 5.

Fuel pump leakage excessive?
YES NO

Repair

Replace the fuel pump head.

Use the procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 005-227 in Section 5.

No Repair

Go to 6A

Go to 5D

Guided Step 5D - Check for excessive fuel return from the rail fuel pressure relief valve.

Conditions

  • Turn keyswitch OFF.
  • Install test fittings to measure the fuel drain from the rail fuel pressure relief valve. Use the procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418: Refer to Procedure 006-061 in Section 6.

Action

Start the engine.

  • Use INSITE™ electronic service tool High-Pressure Control Relief Pressure Test to raise the fuel rail pressure.
  • Measure the fuel leakage from the fuel rail pressure relief valve.

If the engine will not start, perform this test while cranking the engine. Use the procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-061 in Section 6.

Fail fuel pressure relief valve leaking more than 30 drops per minute?
YES NO

Repair

Replace the rail fuel pressure relief valve.

Use the procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 006-061 in Section 6.

No Repair

Go to 6A

Go to 6A

Guided Step 6 - Verify the repair is complete.

Guided Step 6A - Disable the fault code.

Conditions

  • Operate engine.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to clear the fault code.

  • Road test the engine.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2215 become active during loaded engine operation?
YES NO

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 6B

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting trees

Last Modified: 06-Nov-2013


FAULT CODE 2216 (ISB/QSB Automotive or Industrial Application) - Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 271, 272, and/or 2311 inactive?
 | STEP 1B. Verify the vehicle configuration and the settings in INSITE™ electronic service tool match. | Settings in INSITE™ electronic service tool match the vehicle configuration?
STEP 2. | Check the rail fuel pressure sensor. |
 | STEP 2A. Verify the rail fuel pressure sensor reads in range. | Pressure is 0 ± 40 bar?
STEP 3. | Check for drain line restriction. |
 | STEP 3A. Check for excessive drain line restriction. | Fuel return within specification?
STEP 4. | Check the high-pressure injection pump. |
 | STEP 4A. High-pressure injection pump flow test. | Fuel pump flow meets specification?
STEP 5. | Check for damage to the fuel rail pressure relief valve. |
 | STEP 5A. Check for leakage from the fuel rail pressure relief valve. | Fuel return within specification?
STEP 6. | Clear the fault code. |
 | STEP 6A. Disable the fault code. | Fault Code 2216 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the electronic fuel control actuator shorted low or high.

Fault Code 271, 272, and/or 2311 inactive?
YES NO
No Repair

Repair

Troubleshoot applicable fault codes for ECF actuator.

Go to 1B

Applicable Fault Code 271, 272, and/or 2311

Guided Step 1B - Verify the vehicle configuration and the settings in INSITE™ electronic service tool match.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool. Go to Features and Parameters and verify the following parameters match the vehicle configuration.

  • Transmission Setup –Transmission Type

Settings in INSITE™ electronic service tool match the vehicle configuration?
YES NO
No Repair

Repair

Change the settings in the engine control module (ECM) with INSITE™ electronic service tool to match the vehicle configuration.

Go to 2A

Go to 5A

Guided Step 2 - Check the rail fuel pressure sensor.

Guided Step 2A - Verify the rail fuel pressure sensor reads in range.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to read the rail fuel pressure.

–

Pressure is 0 ± 40 bar?
YES NO
No Repair

Repair

Replace the sensor or repair the engine harness.

  • Use the following procedure to replace the sensor. Refer to Procedure 019-115 in Section 19.
  • Use the following procedure to repair the enegine harness. Refer to Procedure 019-360 in Section 19.

Go to 3A

Go to 6A

Guided Step 3 - Check for drain line restriction.

Guided Step 3A - Check for excessive drain line restriction.

Conditions

  • Turn keyswitch ON.
  • Install test fittings to measure the fuel drain line restriction.
  • Operate the engine at high idle no load.

Action

Check for excessive drain line restriction.

  • Install test fittings to measure fuel drain line restriction.

Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-012 in Section 6.

Fuel return within specification?

Maximum fuel drain line restriction at high idle no load is 18.6 kPa [2.7 psi]
YES NO
No Repair

Repair

  • Repair the source of the high fuel drain line restriction. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-013 in Section 6.

Go to 4A

Go to 5A

Guided Step 4 - Check the high-pressure injection pump.

Guided Step 4A - High-pressure injection pump flow test.

Conditions

  • Turn keyswitch ON.

Action

Check the high-pressure injection pump fuel flow.

  • Disconnect the high-pressure fuel line to the fuel rail from the high-pressure injection pump.
  • Connect a clear hose to the outlet of the high-pressure injection pump.
  • Route the high-pressure fuel line into an empty bucket.
  • Crank the engine for 30 seconds and measure the fuel pump flow.

Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 005-016 in Section 6.

Fuel pump flow meets specification?

Minimum fuel pump flow is 75 ml [2.5 oz] in 30 seconds at 125 rpm or 90 ml [3.04 oz] in 30 seconds at 150 rpm.
YES NO

Repair

The electronic fuel control actuator is damaged.

Replace the electronic fuel control actuator. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 005-007 in Section 5.

Repair

The high-pressure injection pump is damaged.

Replace the high-pressure injection pump. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 005-016 in Section 5.

Go to 5A

Go to 5A

Guided Step 5 - Check for damage to the fuel rail pressure relief valve.

Guided Step 5A - Check for leakage from the fuel rail pressure relief valve.

Conditions

  • Turn keyswitch OFF.
  • Install test fittings to measure the fuel return from the rail fuel pressure relief valve.

Action

Check for leakage from the fuel rail pressure relief valve.

  • Install test fittings to measure the fuel return.
  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-061 in Section 6.

NOTE: Excessive fuel rail pressure can possibly cause damage to the fuel rail pressure relief valve.

Specification at idle: No flow.

INSITE™ electronic service tool override: One drop per second 16 ml [0.5 oz] per minute.

NOTE: If the return flow from the rail pressure relief valve is greater than specification, restart the engine and bring to high idle. The engine will attempt to reseat the valve.

NOTE: If Fault Code 272, 449, 553, 2311, or 2216 is active, do not replace the fuel rail pressure relief valve without first determining the cause of the fault code condition. See the appropriate troubleshooting symptom tree.

If the valve does not reseat, replace valve.

Fuel return within specification?
YES NO
No Repair

Repair

Replace the fuel rail pressure relief valve. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-061 in Section 6.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault code.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 2216 is inactive.

Fault Code 2216 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting charts

Last Modified: 30-Dec-2013


FAULT CODE 2216 (ISC/QSC/ISL/QSL Automotive, Industrial, or Marine Application) - Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 271, 272, or 2311 active?
 | STEP 1B. Verify that the vehicle configuration and the settings in INSITE™ electronic service tool match. | Settings in INSITE™ electronic service tool match the vehicle configuration?
STEP 2. | Check the low-pressure fuel system. |
 | STEP 2A. Check for excessive supply pump fuel pressure. | Pressure greater than 1207 kPa [175 psi]?
 | STEP 2B. Check the fuel pump actuator. | Inboard o-ring cut or shaved?
STEP 3. | Clear the fault code. |
 | STEP 3A. Disable the fault code. | Fault codes inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271, 272, or 2311 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Verify the vehicle configuration and the settings in INSITE™ electronic service tool match.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool. Go to Features and Parameters and verify the following parameters match the vehicle configuration.

  • Transmission Setup -Transmission Type

Settings in INSITE™ electronic service tool match the vehicle configuration?
YES NO
No Repair

Repair

Change the settings in the engine control module (ECM) with INSITE™ electronic service tool to match the vehicle configuration.

Go to 2A

Go to 5A

Guided Step 2 - Check the low-pressure fuel system

Guided Step 2A - Check for excessive supply pump fuel pressure.

Conditions

  • Operate the engine.

Action

Install a M10 standard thread o-ring diagnostic fitting, Cummins® Part Number 3824842, at the pressure-side fuel filter outlet port.

Install a 0 to 2068 kPa [0 to 300 psi] pressure gauge at the outlet of the pressure-side filter.

  • Operate the engine at idle and measure the pressure at the gear pump outlet.

Refer to Procedure 005-025 in the Troubleshooting and Repair Manual, ISC, QSC8.3, ISL, and QSL9 Engines, Bulletin 4021418.

Pressure greater than 1207 kPa [175 psi]?
YES NO

Repair

Replace the fuel gear pump assembly.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the fuel pump actuator.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel pump actuator.

  • Remove the fuel pump actuator.
  • Inspect the fuel pump actuator inboard o-ring.

Refer to Procedure 019-117 in the Troubleshooting and Repair Manual, ISC, QSC8.3, ISL, and QSL9 Engines, Bulletin 4021418.

If this o-ring is cut or shaved, fuel may be permitted to bypass the fuel pump actuator and enter the high-pressure pump.

Inboard o-ring cut or shaved?
YES NO

Repair

Replace the damaged o-ring.

Repair

Replace the fuel pump actuator.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault code.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify the fault codes are inactive.

Fault codes inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 22-Feb-2013


FAULT CODE 2217 - Engine Control Module Calibration Program Memory (RAM) Corruption - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement:Part No. 3822758 - male Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Are other fault codes active?
STEP 2. | Check the batteries and the power harness connector. |
 | STEP 2A. Check the resistance of the battery supply circuit. | Less than 10 ohms?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least (+)12-VDC? (During cranking: At least (+) 6.2-VDC)?
 | STEP 2C. Check the battery connections. | Connections are tight and corrosion-free?
STEP 3. | Check the OEM fuses. |
 | STEP 3A. Verify that the OEM fuses are installed correctly. | Fuses installed correctly?
 | STEP 3B. Verify that the OEM fuses are not blown. | Fuses not blown?
STEP 4. | Check the power connector. |
 | STEP 4A. Check the add-on or the accessory wiring at the positive (+) terminal of the battery. | No damaged wires?
STEP 5. | Recalibrate the ECM. |
 | STEP 5A. Recalibrate the ECM. | Fault Code 2217 inactive?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 2217 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool to read the fault codes.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Are other fault codes active?
YES NO

Repair

Troubleshoot the active fault codes.

 No Repair

Go to appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the batteries and the power connector.

Guided Step 2A - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness connector from the ECM.

Action

Check the resistance of the battery supply circuit.

  • Using a multimeter, measure the resistance between the ECM battery SUPPLY (+) pin of the power harness ECM connector and the positive (+) battery terminal.
  • Using a multimeter, measure the resistance between the ECM battery SUPPLY (-) pin of the power harness ECM connector and the engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES | NO
No Repair | No Repair

Go to 2B

Go to 3A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal. Touch the negative (-) probe of the multimeter to the negative battery terminal while trying to start the engine.

Normal conditions: At least (+) 12-VDC? (During cranking: At least (+) 6.2-VDC)?
YES NO
No Repair

Repair

Charge or replace the battery.

Refer to the OEM service manual.

Go to 2C

Go to 5A

Guided Step 2C - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Inspect the battery terminal connections.

Are connections tight and corrosion-free?
YES NO
No Repair

Repair

Tighten the loose connections and clean the terminals.

Refer to the OEM service manual.

Go to 4A

Go to 5A

Guided Step 3 - Check the OEM fuses.

Guided Step 3A - Verify that the OEM fuses are installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the OEM fuses for correct installation.

–

Are fuses installed correctly?
YES NO
No Repair

Repair

Install the fuses correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Verify that the OEM fuses are not blown.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the OEM fuses are not blown.

–

Are any fuses blown?
YES NO

Repair

Replace the fuses.

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 5A

Guided Step 4 - Check the power connector.

Guided Step 4A - Check the add-on or the accessory wiring at positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Are any wires damaged?
YES NO

Repair

Repair or replace the damaged wiring.

Repair

Verify the OEM power supply wiring to the ECM is correct. Refer to the OEM service manual.

Go to 5A

Go to 5A

Guided Step 5 - Recalibrate the ECM.

Guided Step 5A - Recalibrate the ECM.

Conditions

  • Connect all components.

Action

Recalibrate the ECM.

  • Use INSITE™ electronic service tool to recalibrate the ECM.

Is Fault Code 2217 inactive?
YES | NO
No Repair | No Repair

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Turn keyswitch OFF and wait 30 seconds.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to verify Fault Code 2217 is inactive.

Fault Code 2217 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact your local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-Apr-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fuel system fault codes. | Fault Code 2249 is active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fuel system fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fuel system fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2249 is active?
YES NO

Repair

Follow the troubleshooting procedures for Fault Code 559.

 No Repair

Fault Code 559 troubleshooting.

Repair complete.

Last Modified: 08-Jul-2010


FAULT CODE 2265 - Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal, or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated before replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2265 inactive?
 | STEP 1B. Lift pump voltage regulator check. | Is a lift pump voltage regulator installed?
STEP 2. | Check the electric fuel lift pump relay circuit. |
 | STEP 2A. Inspect the engine harness and electric fuel lift pump relay connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the electric fuel lift pump relay. | Less than 400 ohms?
 | STEP 2C. Check the electric fuel lift pump relay diagnostic supply voltage. | Greater than 6.0 VDC? (for 12 VDC system) Greater than 18.0 VDC? (for 24 VDC system)
 | STEP 2D. Check for an open circuit in the electric fuel lift pump relay return circuit. | Less than 10 ohms?
STEP 3. | Check the electric fuel lift pump. |
 | STEP 3A. Inspect the engine harness and electric fuel lift pump connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the electric fuel lift pump. | Less than 20 ohms?
 | STEP 3C. Check the electric fuel lift pump supply voltage and return circuit. | Greater than 6.0 VDC? (for 12 VDC system) Greater than 18.0 VDC? (for 24 VDC system)
 | STEP 3D. Check for an open circuit in the electric fuel lift pump relay return circuit. | Less than 10 ohms?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the ECM electric fuel lift pump diagnostic supply voltage. | Greater than 6.0 VDC? (for 12 VDC system) Greater than 18.0 VDC? (for 24 VDC system)
 | STEP 4C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 4D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 4E. Check for an inactive fault code. | Fault Code 2265 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 2265 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2265 inactive?

YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 1B

Guided Step 1B - Lift pump voltage regulator check.

Conditions

  • Turn keyswitch OFF.

Action

Check the lift pump voltage regulator.

–

Is a lift pump voltage regulator installed?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the electric fuel lift pump relay circuit.

Guided Step 2A - Inspect the engine harness and electric fuel lift pump relay connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electric fuel lift pump relay from the electric fuel lift pump wiring harness.

Action

Inspect the engine harness, electric fuel lift pump wiring harness, and relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for an open circuit in the electric fuel lift pump relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electric fuel lift pump relay from the electric fuel lift pump wiring harness.

Action

Check the electric fuel lift pump relay resistance.

  • Measure the resistance between the electric fuel lift pump relay SUPPLY pin (85) and the electric fuel lift pump relay RETURN pin (86).

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 400 ohms?
YES NO
No Repair

Repair

A damaged electric fuel lift pump relay has been detected.

Replace the electric fuel lift pump relay. Refer to the OEM service manual.

Go to 2C

Go to 5A

Guided Step 2C - Check the electric fuel lift pump relay diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electric fuel lift pump relay from the electric fuel lift pump wiring harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the electric fuel lift pump SUPPLY pin (85) and the electric fuel lift pump RETURN pin (86) at the electric fuel lift pump relay connector.

Greater than 6.0 VDC? (for 12 VDC system)

Greater than 18.0 VDC? (for 24 VDC system)
YES | NO
No Repair | No Repair

Go to 4D

Go to 2D

Guided Step 2D - Check for an open circuit in the electric fuel lift pump relay return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electric fuel lift pump relay from the electric fuel lift pump wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the electric fuel lift pump relay RETURN pin (86) at the electric fuel lift pump relay connector to ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit in the electric fuel lift pump relay circuit has been detected.

Isolate the open circuit.

Repair or replace the electric fuel lift pump wiring harness or the engine harness.

Go to 4A

Go to 5A

Guided Step 3 - Check the electric fuel lift pump.

Guided Step 3A - Inspect the engine harness and electric fuel lift pump connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electric fuel lift pump.

Action

Inspect the engine harness and electric fuel lift pump connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the electric fuel lift pump.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electric fuel lift pump.

Action

Check for an open circuit in the electric fuel lift pump.

  • Measure the resistance between the electric fuel lift pump SUPPLY and the electric fuel lift pump RETURN pins at the electric fuel lift pump connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 20 ohms?
YES NO
No Repair

Repair

A damaged electric fuel lift pump has been detected.

Replace the electric fuel lift pump. Use the following procedure in the ISC, QSC8.3, ISL, and QSL9 Series Engines Troubleshooting and Repair Manual, Bulletin 4021418 or the ISB Troubleshooting and Repair Manual, Bulletin 3666477. Refer to Procedure 005-045 in Section 5.

Go to 3C

Go to 5A

Guided Step 3C - Check the electric fuel lift pump supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electric fuel lift pump.
  • Install the Deutsch™ 2-pin breakout tool, Part Number 3163531, in between the lift pump and the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the electric fuel lift pump SUPPLY pin and the electric fuel lift pump RETURN pin using the Deutsch™ 2-pin breakout tool.

Greater than 6.0 VDC? (for 12 VDC system)

Greater than 18.0 VDC? (for 24 VDC system)
YES | NO
No Repair | No Repair

Go to 4D

Go to 3D

Guided Step 3D - Check for an open circuit in the electric fuel lift pump return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electric fuel lift pump from the engine harness.

Action

Measure the resistance between the engine harness electric fuel lift pump RETURN pin and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness or connector pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the ECM electric fuel lift pump diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage.

  • Measure the voltage between the electric fuel lift pump SUPPLY pin (1) and the electric fuel lift pump RETURN pin (11) at the engine harness ECM connector port.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Greater than 6.0 VDC? (for 12 VDC system)

Greater than 18.0 VDC? (for 24 VDC system)
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the electric fuel lift pump from the engine harness. For 24 VDC Automotive systems with the lift pump harness, disconnect the engine harness from the electric fuel lift pump wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the electric fuel lift pump SUPPLY pin at the electric fuel lift pump connector and the electric fuel lift pump SUPPLY pin at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the electric fuel lift pump from the ECM. For 24 VDC Automotive systems with the lift pump harness, disconnect the electric fuel lift pump relay from the electric fuel lift pump wiring harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the electric fuel lift pump SUPPLY pin in the engine harness ECM connector and all other pins in the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness. If troubleshooting a 24 volt automotive system, isolate the interconnects. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2265 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the problem.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2265 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Mar-2012


FAULT CODE 2266 - Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal, or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated before replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2266 inactive?
 | STEP 1B. Lift Pump Voltage Regulator Check | Is a lift pump voltage regulator installed?
STEP 2. | Check the electric fuel lift pump relay circuit. |
 | STEP 2A. Inspect the engine harness and electric fuel lift pump relay connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2265 is active and Fault Code 2266 is inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 2266 is active?
STEP 3. | Check the electric fuel lift pump. |
 | STEP 3A. Inspect the engine harness and electric fuel lift pump connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 2265 is active and Fault Code 2266 is inactive?
 | STEP 3C. Check the fault codes and verify sensor condition. | Fault Code 2266 is active?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the ECM response. | Fault Code 2265 active and Fault Code 2266 inactive?
 | STEP 4C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 4D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 4E. Check for an inactive fault code. | Fault Code 2266 is inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 2266 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use the INSITE™ electronic service tool to read the fault codes.

Fault Code 2266 inactive?

YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 1B

Guided Step 1B - Lift Pump Voltage Regulator Check

Conditions

  • Turn keyswitch OFF.

Action

Check the lift pump voltage regulator.

Is a lift pump voltage regulator installed?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the electric fuel lift pump relay circuit.

Guided Step 2A - Inspect the engine harness and electric fuel lift pump relay connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electric fuel lift pump relay from the electric fuel lift pump wiring harness.
  • Disconnect the engine harness from the electric fuel lift pump wiring harness.

Action

Inspect the engine harness electric fuel lift pump wiring harness and relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electric fuel lift pump relay.
  • Turn keyswitch On.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the INSITE™ electronic service tool to read the fault codes.

Fault Code 2265 is active and Fault Code 2266 is inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the electric fuel lift pump relay.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the INSITE™ electronic service tool to read the fault codes.

Fault Code 2266 is active?
YES NO

Repair

A damaged electric fuel lift pump relay has been detected.

Replace the electric fuel lift pump relay. Refer to the OEM service manual.

Repair

None. Removal and installation of the connector corrected the problem.

Go to 5A

Go to 5A

Guided Step 3 - Check the electric fuel lift pump.

Guided Step 3A - Inspect the engine harness and electric fuel lift pump connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electric fuel lift pump.

Action

Inspect the engine harness and electric fuel lift pump connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electric fuel lift pump from the engine harness.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the INSITE™ electronic service tool to read the fault codes.

Fault Code 2265 is active and Fault Code 2266 is inactive?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the electric fuel lift pump to the engine harness.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the INSITE™ electronic service tool to read the fault codes.

Fault Code 2266 is active?

A damaged fuel lift pump has been detected.

Replace the electric fuel lift pump. Use the following procedure in the ISC, QSC8.3, ISL, and QSL9 Series Engines Troubleshooting and Repair Manual, Bulletin 4021418 or the ISB Troubleshooting and Repair Manual, Bulletin 3666477. Refer to Procedure 005-045 in Section 5.

YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the problem.

Go to 5A

Go to 5A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the INSITE™ electronic service tool to read the fault codes.

Fault Code 2265 is active and Fault Code 2266 is inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the electric fuel lift pump from the engine harness. For 24 VDC Automotive systems, disconnect the electric fuel lift pump relay from the electric fuel lift pump wiring harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the electric fuel lift pump SUPPLY pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SUPPLY line has been detected in the engine harness.

Repair or replace the engine harness.

For 24 VDC Automotive systems, isolate the short circuit. Repair or replace the electric fuel lift pump wiring harness or engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the electric fuel lift pump from the engine harness. For 24 VDC Automotive systems, disconnect the electric fuel lift pump relay from the electric fuel lift pump wiring harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the electric fuel lift pump SUPPLY pin in the engine harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SUPPLY line has been detected in the engine harness.

Repair or replace the engine harness.

For 24 VDC Automotive systems, isolate the short circuit. Repair or replace the electric fuel lift pump wiring harness or engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the INSITE™ electronic service tool to read the fault codes.

Fault Code 2266 is inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the problem.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 5A

Go to 1A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use the INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2266 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use the INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Mar-2012


FAULT CODE 2271 - EGR Valve Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an active fault code. | Fault Code 2271 active?
STEP 2. | Check the EGR valve position sensor and circuit. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2271 inactive and Fault Code 2272 active?
 | STEP 2C. Check the EGR valve position sensor supply and return circuit at the engine harness. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the EGR valve position sensor supply and return circuit at the engine control module. | 4.75 to 5.25-VDC?
STEP 3. | Check the engine control module. |
 | STEP 3A. Inspect the engine harness and engine control module connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine control module response. | Fault Code 2271 inactive and Fault Code 2272 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2271 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES NO

Repair

Troubleshoot Fault Code 227.

 No Repair

Fault Code 227

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2271 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the EGR valve position sensor and circuit.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve position sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connectors, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve position sensor from the engine harness.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for the appropriate engine control module response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2271 inactive and Fault Code 2272 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the EGR valve position sensor supply and return circuit at the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the EGR valve position sensor supply and return circuit at the engine harness.

  • Measure the voltage between the EGR valve position +5 VDC SUPPLY pin and the EGR valve position RETURN pin at the sensor connector of the engine harness.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75 to 5.25-VDC?
YES NO

Repair

Replace the EGR valve assembly. Refer to Procedure 019-372 in Section 19.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check the EGR valve position sensor supply and return circuit at the engine control module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module.
  • Turn keyswitch ON.

Action

Check the EGR valve position sensor supply and return circuit at the engine control module.

  • Measure the voltage between the EGR valve position +5 VDC SUPPLY pin and the EGR valve position RETURN at the engine control module port.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75 to 5.25-VDC?
YES NO

Repair

Repair or replace the engine harness.

Repair

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module.

Guided Step 3A - Inspect the engine harness and engine control module connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module.

Action

Inspect the engine harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connectors, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine control module response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for the appropriate engine control module response.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 2271 inactive and Fault Code 2272 active?
YES NO

Repair

Repair or replace the engine harness.

Repair

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 2271 is inactive.

Fault Code 2271 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-May-2012


FAULT CODE 2272 - EGR Valve Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module, all other active fault codes must be investigated prior to replacing the engine control module.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 active?
 | STEP 1B. Check for an active fault code. | Fault Code 2272 active?
STEP 2. | Check the EGR valve position sensor and circuit. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the EGR valve position sensor supply and return circuit at the harness. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 2272 inactive and Fault Code 2271 active?
 | STEP 2D. Check the engine control module response. | Fault Code 2272 inactive and Fault Code 2271 active?
STEP 3. | Check the engine control module. |
 | STEP 3A. Inspect the engine harness and engine control module connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2272 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 187 active?
YES NO

Repair

Troubleshoot Fault Code 187.

 No Repair

Refer to troubleshooting tree for Fault Code 187

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 2272 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the EGR valve position sensor and circuit.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve position sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connectors and pins.

Repair the damaged harness, connectors, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the EGR valve position sensor supply and return circuit at the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the EGR valve position sensor supply and return circuit at the engine harness.

  • Measure the voltage between the EGR valve position +5 VDC SUPPLY pin and the EGR valve position RETURN pin at the sensor connector of the engine harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use the following procedure for multimeter usage. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the EGR valve position +5 VDC SUPPLY pin and the EGR valve position SIGNAL pin at the sensor connector of the engine harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault code and check if the fault code goes inactive.

Fault Code 2272 inactive and Fault Code 2271 active?
YES NO

Repair

Replace the EGR valve assembly. Refer to Procedure 019-372 in Section 19.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check the engine control module response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the engine control module response.

  • Place a jumper wire between the EGR valve position +5-VDC SUPPLY pin and the EGR valve position SIGNAL pin at the engine control module port.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Check for the appropriate engine control module response after 30 seconds.
  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 2272 inactive and Fault Code 2271 active?
YES NO

Repair

Repair or replace the engine harness.

Repair

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module.

Guided Step 3A - Inspect the engine harness and engine control module connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module.

Action

Inspect the engine harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connectors and pins.

Repair the damaged harness, connectors, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine control module.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit at the engine control module.

  • Measure the voltage between the turbocharger position +5 VDC SUPPLY pin and the turbocharger position RETURN pin at the engine control module port.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use the following procedure for multimeter usage. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO

Repair

Repair or replace the engine harness.

Repair

Replace the engine control module. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Verify Fault Code 2272 is inactive.

Fault Code 2272 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-May-2012


FAULT CODE 2273 - EGR Valve Differential Pressure Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3164596 - male Framatome™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple fault codes. | Fault Code 227 active?
 | STEP 1B. Read the fault codes. | Fault Code 2273 active?
STEP 2. | Check the EGR differential pressure sensor and circuit. |
 | STEP 2A. Inspect the engine harness and EGR differential pressure sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2273 inactive and Fault Code 2274 active?
 | STEP 2C. Check the EGR differential pressure sensor supply and return circuit at the harness. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the EGR differential pressure sensor supply and return circuit at the ECM. | 4.75 to 5.25 VDC?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 2273 inactive and Fault Code 2274 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2273 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Connect the INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for multiple fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool, read the fault codes.

Fault Code 227 active?
YES NO

Repair

Troubleshoot Fault Code 227.

 No Repair

Fault Code 227

Go to 1B

Guided Step 1B - Read the fault codes.

Conditions

  • Connect the INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool, read the fault codes.

Fault Code 2273 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the EGR differential pressure sensor and circuit.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.

Action

Inspect the engine harness and EGR differential pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connectors, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 inactive and Fault Code 2274 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the EGR differential pressure sensor supply and return circuit at the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the EGR differential pressure sensor supply and return circuit at the harness.

  • Measure the voltage between the EGR differential pressure +5 VDC SUPPLY pin and the EGR differential pressure RETURN pin at the sensor connector of the engine harness.

4.75 to 5.25 VDC?
YES NO

Repair

Replace the EGR differential pressure sensor. Refer to Procedure 019-370 in Section 19.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check the EGR differential pressure sensor supply and return circuit at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the EGR differential pressure sensor supply and return circuit at the ECM.

  • Measure the voltage between the EGR differential pressure +5 VDC SUPPLY pin and the EGR differential pressure RETURN pin at the ECM port.

4.75 to 5.25 VDC?
YES NO

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connectors and pins.

Repair the damaged harness, connectors, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 inactive and Fault Code 2274 active?
YES NO

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify that Fault Code 2273 is inactive.

Fault Code 2273 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool, erase the inactive fault codes .

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Mar-2012


FAULT CODE 2274 - EGR Valve Differential Pressure Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3164596 - male Framatome™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple fault codes. | Fault Code 187 active?
 | STEP 1B. Read the fault codes. | Fault Code 2274 active?
STEP 2. | Check the EGR valve differential pressure sensor and circuit. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 2274 inactive and Fault Code 2273 active?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 2274 inactive and Fault Code 2273 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2274 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Connect the INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for multiple fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool, read the fault codes.

Fault Code 187 active?
YES NO

Repair

Troubleshoot Fault Code 187.

 No Repair

Fault Code 187

Go to 1B

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool, read the fault codes.

Fault Code 2274 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the EGR valve differential pressure sensor and circuit.

Guided Step 2A - Inspect the EGR valve differential pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve differential pressure sensor from the engine harness.

Action

Inspect the EGR differential pressure sensor and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connectors and pins.

Repair the damaged harness, connectors, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve differential pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage.

  • Measure the voltage between the EGR differential pressure +5 VDC SUPPLY pin and the EGR differential pressure RETURN pin at the sensor connector of the engine harness.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Disconnect the EGR valve differential pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Install a jumper wire between the EGR differential pressure +5 VDC SUPPLY pin and the EGR differential pressure SIGNAL pin at the sensor connector of the engine harness.
  • Check for the appropriate ECM response after 30 seconds.
  • Use INSITE™ electronic service tool, read the fault codes.

Fault Code 2274 inactive and Fault Code 2273 active?
YES NO

Repair

Replace the EGR valve differential pressure sensor. Refer to Procedure 019-370 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connectors and pins.

Repair the damaged harness, connectors, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response.

  • Install a jumper wire between the EGR differential pressure +5 VDC SUPPLY pin and the EGR differential pressure SIGNAL pin at the ECM port.
  • Check for the appropriate ECM response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 inactive and Fault Code 2273 active?
YES NO

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Repair complete

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Verify that Fault Code 2274 is inactive.

Fault Code 2274 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Mar-2012


FAULT CODE 2292 - Fuel Inlet Meter Device - Data Valid but Above Normal Operational Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2215 or 2266 inactive?
STEP 2. | Check the operation of the low-pressure fuel system. |
 | STEP 2A. Check for external fuel leaks. | Fuel leaks present?
STEP 3. | Check the lift pump. |
 | STEP 3A. Measure the lift pump pressure. | Lift pump meets minimum specification?
 | STEP 3B. Measure the lift pump inlet restriction. | Less than 152 mm Hg [6 in Hg]?
STEP 4. | Check the fuel filter restriction. |
 | STEP 4A. Measure the pressure drop across the fuel filter. | Drop in pressure less than 34 kPa [5 psi]?
STEP 5. | Check the high-pressure fuel system. |
 | STEP 5A. Check for leakage from the rail fuel pressure relief valve. | Fuel return within specification?
 | STEP 5B. Check for excessive fuel return leak from the high-pressure fuel system, injectors, and high-pressure connectors. | Fuel leakage within specification?
 | STEP 5C. Check for excessive fuel return from the high-pressure fuel pump. | Fuel return within specification?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault codes inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect the INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2215 or 2266 inactive?
YES NO
No Repair

Repair

Troubleshoot applicable fault codes.

Go to 2A

Applicable fault code

Guided Step 2 - Check the operation of the low-pressure fuel system.

Guided Step 2A - Check for external fuel leaks.

Conditions

  • Turn keyswitch ON.

Action

Check for external fuel leaks.

  • Start the engine and let it idle.
  • Inspect for external fuel leaks.

Fuel leaks present?
YES NO

Repair

Repair the fuel leaks.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the lift pump.

Guided Step 3A - Measure the lift pump pressure.

Conditions

  • Turn keyswitch ON.

Action

Measure the lift pump performance.

  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271, for measuring the lift pump flow. Refer to Procedure 005-045 in Section 5.

Lift pump meets minimum specification?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - Measure the lift pump inlet restriction.

Conditions

  • Turn keyswitch ON.

Action

Measure the lift pump inlet restriction.

  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-020 in Section 6.

Less than 152 mm Hg [6 in Hg]?
YES NO

Repair

Replace the electric lift pump.

Measure the fuel lift pump flow. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 005-045 in Section 5.

Repair

Replace the OEM fuel filter or repair the cause of the inlet restriction.

Go to 6A

Go to 6A

Guided Step 4 - Check the fuel filter restriction.

Guided Step 4A - Measure the pressure drop across the fuel filter.

Conditions

  • Turn keyswitch ON.
  • Run the engine at rated condition.

Action

Measure the pressure drop across the fuel filter.

  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-015 in Section 6.

Drop in pressure less than 34 kPa [5 psi]?

YES NO
No Repair

Repair

Replace the pressure-side filter and verify the pressure-side fuel lines are not restricted.

Go to 5A

Go to 6A

Guided Step 5 - Check high-pressure fuel system

Guided Step 5A - Check for leakage from the rail fuel pressure relief valve.

Conditions

  • Turn keyswitch OFF.
  • Install test fittings to measure the fuel return from the rail fuel pressure relief valve.

Action

Check for leakage from the rail fuel pressure relief valve.

  • Install test fittings to measure the fuel return.
  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-061 in Section 6.

Fuel return within specification?
YES NO
No Repair

Repair

Replace the rail fuel pressure relief valve. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-061 in Section 6.

Go to 5B

Go to 6A

Guided Step 5B - Check for excessive fuel return leak from the high-pressure fuel system, injectors, and high-pressure connectors.

Conditions

  • Turn keyswitch OFF.
  • Install test fittings to measure the fuel return from the injectors and high-pressure connectors.

Action

Check for excessive fuel leakage from the injectors and high-pressure connectors.

  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6.

Fuel leakage within specification?
YES NO
No Repair

Repair

Isolate the source of the leak and repair it.

Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-026 in Section 6.

Go to 5C

Go to 6A

Guided Step 5C - Check for excessive fuel return from the high-pressure fuel pump.

Conditions

  • Turn keyswitch OFF.
  • Install test fittings to measure the fuel return from the high-pressure fuel pump.

Action

Check for excessive fuel return from the high-pressure fuel pump.

  • Install test fittings to measure the fuel return from the fuel pump.
  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 005-016 in Section 5.

Fuel return within specification?
YES NO
No Repair

Repair

Replace the high-pressure fuel pump. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 005-016 in Section 5.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Perform a 15 to 20 minute road test or run the engine on the dynamometer.
  • Verify the fault codes are inactive.

Fault codes inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-Apr-2012


FAULT CODE 2293 - Fuel Inlet Meter Device Flow Demand Lower Than Expected - Data Valid but Below Normal Operational Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 271, 272, and/or 2311 inactive?
STEP 2. | Check the rail fuel pressure sensor. |
 | STEP 2A. Verify that the rail fuel pressure sensor reads in-range. | Pressure = 0 ±40 bar [0 ±580 psi]?
STEP 3. | Check the operation of the low-pressure fuel system. |
 | STEP 3A. Check for air in fuel. | Air present?
 | STEP 3B. Check for excessive lift pump fuel pressure. | Less than 137 kPa [20 psi]?
STEP 4. | Check for fuel return drain line restriction. |
 | STEP 4A. Check the fuel return drain line for excessive restriction. | Less than 18 kPa [2.7 psi]?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault codes inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the electronic fuel control actuator shorted low or high.

Fault Code 271, 272, and/or 2311 inactive?
YES NO
No Repair

Repair

Troubleshoot applicable fault codes for electronic fuel control actuator.

Go to 2A

Applicable Fault Code 271, 272, and/or 2311

Guided Step 2 - Check the rail fuel pressure sensor.

Guided Step 2A - Verify the rail fuel pressure sensor reads in range.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Use INSITE™ electronic service tool to electronic service tool read the rail fuel pressure.

–

Pressure = 0 ±40 bar?
YES NO
No Repair

Repair

Replace the sensor or repair the engine harness.

  • Use the following procedure to replace the sensor. Refer to Procedure 019-115 in Section 19.
  • Use the following procedure to repair the engine harness. Refer to Procedure 019-360 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the operation of the low-pressure fuel system.

Guided Step 3A - Check for air in fuel.

Conditions

  • Connect a test hose at the fuel filter head inlet and run a hose into a bucket.
  • Turn keyswitch ON. (The electric lift pump will run for approximately one minute.)

Action

Check for air in fuel as lift pump runs.

  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271, to perform the air-in-fuel test. Refer to Procedure 006-003 in Section 6.

Air present?
YES NO

Repair

Repair the cause of the air in the fuel. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-003 in Section 6.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for excessive lift pump fuel pressure.

Conditions

  • Turn keyswitch ON.

Action

Check for excessive lift pump fuel pressure.

  • Install a pressure gauge at the inlet port of the fuel filter head with a MI0 Compuchek™ fitting, Part Number 3824842.
  • Start the engine and let it idle.
  • Measure the pressure at the fuel filter head outlet.

Less than 137 kPa [20 psi]?
YES NO
No Repair

Repair

The internal pressure regulator has malfunctioned.

Replace the electric fuel lift pump. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 005-045 in Section 5.

Go to 4A

Go to 5A

Guided Step 4 - Check for fuel return drain line restriction.

Guided Step 4A - Check the fuel return drain line for excessive restriction.

Conditions

  • Install a pressure gauge in the fuel return line banjo bolt at the high-pressure fuel pump drain manifold.
  • Turn keyswitch ON.

Action

Check the fuel return drain line for excessive restriction.

  • Operate the engine at high idle speed.
  • Measure the fuel return drain line restriction.
  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-012 in Section 6.

Less than 18 kPa [2.7 psi]?
YES NO

Repair

Test the electronic fuel control actuator circuit for high resistance or an open circuit.

Replace the electronic fuel control actuator. Refer to Procedure 019-117 in Section 19.

Repair

Repair or replace the fuel return drain line. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 006-013 in Section 6.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Perform a 15 to 20 minute road test or run the engine on the dynamometer.
  • Verify fault codes are inactive.

Fault codes inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes .

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-Apr-2012


FAULT CODE 2311 - Fueling Actuator Number 1 Circuit Error Conditions Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 271 or 272 active or high inactive counts?
STEP 2. | Check the fuel pump actuator valve. |
 | STEP 2A. Inspect the fuel pump actuator and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fuel pump actuator resistance. | Less than 5 ohms?
 | STEP 2C. Check the fuel pump actuator for a short to ground. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness resistance. | Less than 5 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness failure. | Fault Codes 2311, 271, and/or 272 become active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2311 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Verify that the fuel pump actuator is connected to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 271 or 272 active or high inactive counts?
YES | NO
No Repair | No Repair

Appropriate Troubleshooting Tree

Go to 2A

Guided Step 2 - Check the fuel pump actuator.

Guided Step 2A - Inspect the fuel pump actuator and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the fuel pump actuator, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Repair

  • Repair the connector and pins.
  • Repair the damaged harness, connectors, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fuel pump actuator resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check the fuel pump actuator resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the fuel pump actuator RETURN pin at the actuator connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair

Replace the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fuel pump actuator for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check the fuel pump actuator resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the faulty electronic fuel control actuator.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the engine harness from the ECM

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Clean the connector pins.
  • Repair the damaged harness, connectors, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine harness resistance.

Conditions

  • Turn keyswitch OFF.
  • Reconnect the fuel pump actuator to the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check the engine harness resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the fuel pump actuator RETURN pin at the ECM connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check the engine harness and fuel pump actuator resistance.

  • Measure the resistance between the fuel pump actuator SIGNAL pin and the ECM connector of the engine harness and engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an intermittent engine harness failure.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Engine running at low idle.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or failure.

  • Manipulate the engine harness starting at the ECM engine harness connector and working to the fuel pump actuator.

If a short or open circuit is induced while the engine is running, the fuel rail pressure relief valve will open.

Fault Codes 2311, 271, and/or 272 become active?
YES NO

Repair

An intermittent connection has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the fuel pump actuator. Refer to Procedure 019-117 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2311 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-Apr-2012


FAULT CODE 2321 - Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 689 active or has high number of inactive counts?
STEP 2. | Check the primary speed sensor circuit (crankshaft sensor). |
 | STEP 2A. Inspect the primary speed sensor connector pins (crankshaft sensor). | Dirty or damaged pins?
 | STEP 2B. Inspect the engine harness. | Damaged wire insulation?
 | STEP 2C. Inspect the primary speed sensor (crankshaft sensor) circuit at the engine harness ECM connector. | Dirty or damaged pins?
 | STEP 2D. Inspect the engine harness. | Damaged wire insulation?
STEP 3. | Vehicle test. |
 | STEP 3A. Road test to determine if fault condition exists. | Does Fault Code 2321 become active during engine operation?
 | STEP 3B. Inspect air gap and target wheel. | Is air gap within specification?
 | STEP 3C. Manipulate the engine harness to test for an intermittent fault condition in the engine harness. | Does Fault Code 2321 status change from inactive to active while manipulating the engine harness?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2321 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

If Fault Code 689 has number of inactive counts, there is most likely an intermittent circuit problem (short or open) in the circuit for the primary speed sensor.

Fault Code 689 is active or has high number of inactive counts?
YES | NO
No Repair | No Repair

Refer to Fault Code 689 troubleshooting tree

Go to 2A

Guided Step 2 - Check the primary speed sensor circuit (crankshaft sensor).

Guided Step 2A - Inspect the primary speed sensor connector pins (crankshaft sensor).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary speed sensor from the engine harness.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

  • Clear the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary speed sensor (crankshaft sensor) from the engine harness.

Action

Closely inspect the engine harness near the primary speed sensor.

  • Look for places where the wire harness insulation is damaged allowing intermittent shorts to the block or nearby components.

Damaged wire insulation?
YES NO

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Inspect the primary speed sensor (crankshaft sensor) circuit at the engine harness ECM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the primary speed sensor (crankshaft sensor) from the engine harness.

Action

Closely inspect the engine harness near the ECM connector.

  • Look for places where the wire harness insulation is damaged allowing intermittent shorts to the engine block or nearby components.

Damaged wire insulation?
YES NO

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Vehicle test.

Guided Step 3A - Road test to determine if fault condition exists.

Conditions

  • Connect the primary speed sensor (crankshaft sensor) to the engine harness.
  • Turn keyswitch ON.

Action

Start the engine. With the engine running, accelerate the engine several times.

  • Use INSITE™ electronic service tool to observe fault codes.

Does Fault Code 2321 become active during engine operation?
YES | NO
No Repair | No Repair

Go to 3B

Go to 4A

Guided Step 3B - Inspect air gap and target wheel.

Conditions

  • Turn keyswitch OFF.

Action

Measure the air gap at several points in the crankshaft's revolution.

  • Refer to Procedure 019-365 in Section 19.

Is air gap within specifications?

  • Minimum Air Gap: 0.96 mm [0.038 in]
  • Maximum Air Gap: 2.25 mm [0.089 in]
  • Maximum Target Runout: 0.5 mm [0.02 in]
YES NO
No Repair

Repair

Replace or shim the sensor if air gap is out of specification. If the target runout is excessive, replace the target.

Go to 3C

Go to 4A

Guided Step 3C - Manipulate the engine harness to test for an intermittent fault condition in the engine harness.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to monitor Fault Code 2321 status.

  • Start the engine and allow it to idle.
  • Starting at the ECM connector, manipulate the engine harness manually. Work backwards from the ECM connector towards the engine speed sensor connector.

Does Fault Code 2321 status change from inactive to active while manipulating the engine harness?
YES NO

Repair

An intermittent connection has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2321 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting trees

Last Modified: 27-Apr-2012


FAULT CODE 2322 - Backup Engine Speed/Position Sensor Number 2 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 778 is active or has high number of inactive counts?
STEP 2. | Check the secondary speed sensor circuit (camshaft sensor). |
 | STEP 2A. Inspect the secondary speed sensor (camshaft sensor) connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the engine harness. | Damaged wire insulation?
 | STEP 2C. Inspect the secondary speed sensor (camshaft sensor) circuit at the engine harness connector. | Dirty or damaged pins?
 | STEP 2D. Inspect the engine harness. | Damaged wire insulation?
STEP 3. | Vehicle test. |
 | STEP 3A. Road test to determine if fault condition exists. | Does Fault Code 2322 become active during engine operation?
 | STEP 3B. Inspect air gap and target wheel. | Is air gap within specification?
 | STEP 3C. Manipulate the engine harness to test for an intermittent fault condition in the engine harness. | Does Fault Code 2322 status change from inactive to active while manipulating the engine harness?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2322 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

If Fault Code 778 has number of inactive counts, there is most likely an intermittent circuit problem (short or open) in the circuit for the primary speed sensor.

Fault Code 778 is active or has high number of inactive counts?
YES | NO
No Repair | No Repair

Refer to Fault Code 778 troubleshooting tree

Go to 2A

Guided Step 2 - Check the secondary speed sensor circuit (camshaft sensor).

Guided Step 2A - Inspect the secondary speed sensor (camshaft sensor) connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary speed sensor from the engine harness.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

  • Clear the connector and pins.
  • Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary speed sensor from the engine harness.

Action

Closely inspect the engine harness near the secondary speed sensor.

Look for places where the wire harness insulation is damaged allowing intermittent shorts to the block or nearby components.

Damaged wire insulation?
YES NO

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Inspect the secondary speed sensor (camshaft sensor) circuit at the engine harness ECM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the secondary speed sensor from the engine harness.

Action

Closely inspect the engine harness near the ECM connector.

Look for places where the wire harness insulation is damaged allowing intermittent shorts to the engine block or nearby components.

Damaged wire insulation?
YES NO

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Vehicle test.

Guided Step 3A - Road test to determine if fault condition exists.

Conditions

  • Connect the secondary speed sensor (camshaft sensor) to the engine harness.
  • Turn keyswitch ON.

Action

With the engine running, accelerate the engine several times.

  • Use INSITE™ electronic service tool to observe fault codes.

Does Fault Code 2322 become active during engine operation?
YES | NO
No Repair | No Repair

Go to 3B

Go to 4A

Guided Step 3B - Inspect air gap and target wheel.

Conditions

  • Turn keyswitch OFF.

Action

Remove the secondary engine speed sensor (camshaft sensor) from the gear housing and measure the air gap at several points in the crankshaft's revolution.

  • Refer to Procedure 019-363 in Section 19.

Is air gap within specifications?

  • Minimum Air Gap: 0.96 mm [0.038 in]
  • Maximum Air Gap: 2.25 mm [0.089 in]
  • Maximum Target Runout: 0.5 mm [0.02 in]
YES NO
No Repair

Repair

Replace or shim the sensor if air gap is out of specification. If the target runout is excessive, replace the target.

Go to 3C

Go to 4A

Guided Step 3C - Manipulate the engine harness to test for an intermittent fault condition in the engine harness.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to monitor Fault Code 2322 status.

  • Start the engine and allow it to idle.
  • Starting at the ECM connector, manipulate the engine harness manually. Work backwards from the ECM connector towards the engine speed sensor connector.

Does Fault Code 2322 status change from inactive to active while manipulating the engine harness?
YES NO

Repair

An intermittent connection has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disabel the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic serivce tool to verify the fault code is inactive.

Fault Code 2322 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting trees

Last Modified: 27-Apr-2012


FAULT CODE 2345 (ISB/QSB Automotive or Industrial Application) - Turbocharger Speed - Invalid Rate of Change Detected

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for additional fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Fault Code 687, 595, 2387, 2386, 2385, 2384, 2383, 2382, and/or 2381 active or inactive?
STEP 2. | Check the turbocharger. |
 | STEP 2A. Check the turbocharger compressor wheel for damage. | Bent or damaged turbocharger compressor blades?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2345 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for additional fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 687, 595, 2387, 2386, 2385, 2384, 2383, 2382, and/or 2381 active or inactive?
YES NO

Repair

Troubleshoot the fault codes starting with the fault code containing the highest number of counts.

 No Repair

Appropriate troubleshooting steps

Go to 2A

Guided Step 2 - Check the turbocharger.

Guided Step 2A - Check the turbocharger compressor wheel for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the intake piping from the turbocharger compressor.

Action

Inspect the turbocharger compressor wheel and blades.

  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 010-033 in Section 10.

Bent or damaged turbocharger compressor blades?
YES NO

Repair

Replace the turbocharger. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 010-033 in Section 10.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2345 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-Apr-2012


FAULT CODE 2345 (ISC/QSC/ISL/QSL Automotive, Industrial, or Marine Application) - Turbocharger Speed Invalid Rate of Change Detected - Abnormal Rate of Change

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for additional fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Fault Code 595 and/or 687 active or inactive?
STEP 2. | Check the turbocharger. |
 | STEP 2A. Inspect the turbocharger speed sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Inspect the turbocharge speed sensor. | Turbocharger speed sensor damage found?
 | STEP 2C. Check for an inactive fault code. | Fault Code 2345 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2345 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for additional fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 595 and/or 687 active or inactive?
YES NO

Repair

Troubleshoot fault codes starting with the fault code containing the highest number of counts.

 No Repair

Appropriate troubleshooting steps

Go to 2A

Guided Step 2 - Check the turbocharger.

Guided Step 2A - Inspect the turbocharger speed sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Inspect the engine harness and turbocharger speed sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.
  • Remove the turbocharger speed sensor from the turbocharger housing. Refer to Procedure 019-390 in Section 19.

Action

Inspect the nose of the turbocharger speed sensor for the following:

  • Cuts or scratches on the nose of the sensor
  • Cuts or scratches on the sensor body
  • A cracked sensor mounting boss.

Turbocharger speed sensor damage found?
YES NO

Repair

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in Section 19.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Engine specific condition/action text.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2345 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

 No Repair

Go to 3A

Fault Code 595

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2345 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes .

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-Apr-2012


FAULT CODE 2346 (ISB/QSB Automotive or Industrial Application) - Exhaust Gas Temperature - Data Above Normal

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active fault codes present?
 | STEP 1B. Check for inactive fault codes. | Fault Codes 153, 122, 2973, 2359, 2273, and 155 inactive?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the air intake for leaks. | Air leak present or clamps loose?
 | STEP 2B. Inspect turbocharger compressor and turbine blades. | Damaged turbocharger blades?
 | STEP 2C. Perform the INSITE™ electronic service tool turbocharger operational test. | Does the turbocharger operational test pass?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2346 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes present?
YES | NO
No Repair | No Repair

Troubleshoot the active fault codes

Go to 1B

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 153, 122, 2973, 2359, 2273, and 155 inactive?
YES | NO
No Repair | No Repair

Troubleshoot the fault codes with the highest counts

Go to 2A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the air intake for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the air intake for leaks.

  • Check the charge air cooler, hoses, and piping for leaks.
  • Check the clamps for adequate torque.

Air leak present or clamps loose?
YES NO

Repair

Repair the air leak.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect turbocharger compressor and turbine blades.

Conditions

  • Turn engine off.
  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

Inspect the turbocharger compressor and turbine blades for damage or wear.

–

Damaged turbocharger blades?
YES NO

Repair

Replace the turbocharger. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 010-033 in Section 10.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Perform the INSITE™ electronic service tool turbocharger operational test.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the INSITE™ electronic service tool turbocharger operational test.

  • Start the engine and run at low idle.
  • Select the EGR/VGT Operational Test with INSITE™ electronic service tool.

Does the turbocharger operational test pass?
YES NO
No Repair

Repair

Replace the turbocharger. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 010-033 in Section 10.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2346 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3 - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-Apr-2012


FAULT CODE 2346 (ISC/QSC/ISL/QSL Automotive, Industrial, or Marine Application) - Turbocharger Turbine Inlet Temperature (Calculated) - Data Valid but Above Normal Operational Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active fault codes present?
 | STEP 1B. Check for inactive fault codes. | Fault Codes 2973 inactive?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the charge-air cooler, clamps, hoses, and piping. | Air leak present or clamps loose?
 | STEP 2B. Inspect the turbocharger compressor and turbine blades. | Damage found on turbocharger blades?
 | STEP 2C. Check the variable geometry actuator rod for correct travel. | Does the turbocharger actuator rod extend between 8 and 9 mm [0.321 and 0.36 in]?
 | STEP 2C-1. Check for air leaks and inspect the air lines. |
 | STEP 2C-2. Check for air pressure at the turbocharger control valve. |
 | STEP 2C-3. Check for air leaks at the turbocharger control valve outlet outlet. |
 | STEP 2C-4. Check for correct turbocharger actuator travel. |
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2346 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes present?
YES | NO
No Repair | No Repair

Troubleshoot active fault codes

Go to 1B

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2973 inactive?
YES | NO
No Repair | No Repair

Fault Code 2973

Go to 2A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the charge-air cooler, clamps, hoses, and piping.

Conditions

  • Turn keyswitch OFF.

Action

Check the charge air-cooler, hoses, and piping for leaks.

Check the clamps for adequate torque.

Air leak present or clamps loose?
YES NO

Repair

Repair air leak.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the turbocharger compressor and turbine blades.

Conditions

  • Engine OFF.
  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

Inspect the turbocharger compressor and turbine blades for damage or wear.

–

Damage found on turbocharger blades?
YES NO

Repair

Replace the turbocharger. Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 010-033 in Section 10.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the variable geometry actuator rod for correct travel.

Conditions

  • Engine OFF.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Use INSITE™ electronic service tool to start the Turbocharger Actuator Test.

  • Adjust the delay timer in the Turbocharger Actuator Test so that the rod movement can be observed.
  • Select the Retract Actuator position with INSITE™ electronic service tool.
  • Mark or scribe the variable geometry actuator rod at the base of the actuator.
  • Select the Extend Actuator position with INSITE™ electronic service tool.
  • Measure the rod travel by measuring the distance from the base of the turbocharger actuator to the scribe mark.

Note: The turbocharger actuator should move quickly and crisply. If the actuator rod movement is slow, there could be a problem with the air supply or mechanical problems with the variable geometry turbocharger assembly.

Does the turbocharger actuator rod extend between 8 and 9 mm [0.32 and 0.36 in]?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2C-1

Guided Step 2C-1 - Check for air leaks and inspect air lines.

Conditions

  • Engine OFF.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Use INSITE™ electronic service tool to perform the Turbocharger Actuator Test.

Select the Extend Actuator position. Listen for air leaks at the following components:

  • Turbocharger control valve
  • Turbocharger control valve inlet connection
  • Turbocharger control valve outlet connection
  • Turbocharger actuator inlet connection
  • Turbocharger actuator
  • All air lines including OEM supply line to turbocharger control valve, and turbocharger control valve to turbocharger actuator.

Air leaks found in the system?
YES NO

Repair

Repair air leaks.

 No Repair

Go to 3A

Go to 2C-2

Guided Step 2C-2 - Check for air pressure at the turbocharger control valve outlet.

Conditions

  • Engine OFF.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Remove the air line connection at the outlet of the turbocharger control valve.

Install an M12 Compuchek™ fitting at the outlet of the turbocharger control valve.

Install an air pressure gauge that is capable of reading at least 1034 kPa [150 psi].

Perform the Turbocharger Actuator Test with the INSITE™ electronic service tool. Select the Extend Actuator position.

Is vehicle air tank pressure air pressure present at the turbocharger control valve outlet?
YES NO
No Repair

Repair

Repair the air supply from the OEM air tanks.

Go to 2C-3

Go to 3A

Guided Step 2C-3 - Check for air leaks at the turbocharger control valve outlet.

Conditions

  • Engine OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Use INSITE™ electronic service tool to perform the Turbocharger Actuator Test.

  • Select the Retract Actuator position.
  • Remove the air line connection at the outlet of the turbocharger control valve.

Can air be heard escaping from turbocharger control valve outlet?
YES NO

Repair

Replace the turbocharger control valve. Refer to Procedure 019-388 in Section 19.

No Repair

Go to 3A

Go to 2C-4

Guided Step 2C-4 - Check for correct turbocharger actuator travel.

Conditions

  • Engine OFF.
  • Remove the variable geometry actuator rod from the turbocharger.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Use INSITE™ electronic service tool to perform the Turbocharger Actuator Test.

  • Select the Extend Actuator position.

Does the turbocharger actuator rod travel at least 12 mm [0.472 in]?
YES NO

Repair

Replace the turbocharger. Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 010-033 in Section 10.

Repair

Replace the turbocharger actuator. Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 010-113 in Section 10.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Note: Unless the malfunction is a damaged barometric pressure or intake manifold pressure sensor, this code will most likely not be active with no load in the shop. The engine will most likely need to be loaded to trip this fault code, and to determine if the malfunction has been found and repaired.

Fault Code 2346 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact your local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate troubleshooting steps

Last Modified: 27-Apr-2012


FAULT CODE 2347 (ISB/QSB Automotive or Industrial Application) - Turbocharger Compressor Outlet Temperature - Data Above Normal

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active fault codes present?
 | STEP 1B. Check for inactive fault codes. | Fault Code 245, 295, 433, 488, 595, 2345, and/or 2973 inactive?
STEP 2. | Check the air intake system. |
 | STEP 2A. Check the air intake for leaks. | Air leak present?
 | STEP 2B. Use INSITE™ electronic service tool to perform the turbocharger operational test. | Does the Turbocharger Operational Test pass?
STEP 3. | Check the turbocharger compressor inlet temperature sensor. |
 | STEP 3A. Compare the sensor reading with ambient conditions. | Turbocharger compressor inlet temperature sensor reads within 10 percent of the intake manifold temperature sensor and the ambient air temperature?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2347 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes present?
YES | NO
No Repair | No Repair

Troubleshoot the active fault codes

Go to 1B

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 245, 295, 433, 488, 595, 2345, and/or 2973 inactive?
YES | NO
No Repair | No Repair

Troubleshoot the inactive fault codes

Go to 2A

Guided Step 2 - Check the air intake system.

Guided Step 2A - Check the air intake for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Air intake leaks between the air filter and turbocharger can raise the turbocharger compressor inlet temperature.

  • Check for air intake leaks between the air filter and turbocharger compressor inlet.

Air leak present?
YES NO

Repair

Repair the air leaks.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Use INSITE™ electronic service tool to perform the turbocharger operational test.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at low idle.

Action

Select the EGR/VGT Operational Test using the INSITE™ electronic service tool.

  • Run the Turbocharger Operational Test.

Does the Turbocharger Operational Test pass?
YES NO
No Repair

Repair

Replace the variable geometry turbocharger. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 010-033 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the turbocharger compressor inlet temperature sensor.

Guided Step 3A - Compare the sensor reading with ambient conditions.

Conditions

  • Make sure the engine is cold.
  • Remove the turbocharger compressor inlet temperature sensor from the engine.
  • Connect the turbocharger compressor inlet temperature sensor to the engine harness.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Compare the sensor reading with ambient conditions.

  • Use INSITE™ electronic service tool monitor/datalogger and compare the turbocharger compressor inlet temperature sensor reading to the intake manifold temperature sensor reading.
  • The turbocharger compressor inlet temperature sensor should read within 10 percent of the intake manifold temperature sensor and 10 percent of the ambient air temperature.

Turbocharger compressor inlet temperature sensor reads within 10 percent of the intake manifold temperature sensor and the ambient air temperature?

YES NO
No Repair

Repair

Replace the turbocharger compressor inlet temperature sensor. Refer to Procedure 019-395 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2347 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-Apr-2012


FAULT CODE 2347 (ISC/QSC/ISL/QSL Automotive, Industrial, or Marine Application) - Turbocharger Compressor Outlet Air Temperature (Calculated) - Data Valid but Above Normal Range

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Are active fault codes present?
 | STEP 1B. Check for inactive fault codes. | Are Fault Codes 595 or 2973 inactive?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the intake restriction to the turbocharger inlet. | Air intake restriction greater than 635 mm H²O [25 in H²O] for a used air filter or 254 mm H²O [10 in H²O] for a new filter?
 | STEP 2B. Check the underhood air intake piping. | Damage found on the turbocharger air intake piping?
 | STEP 2C. Check the charge-air cooler, clamps, hoses, and pipes. | Loose charge air cooler connection or malfunctioning charge-air cooler?
 | STEP 2D. Inspect the turbocharger compressor and turbine blades. | Damage to turbocharger turbine or compressor blades?
 | STEP 2E. Check the variable geometry actuator rod for correct travel. | Does the turbocharger actuator rod extend between 8 and 9 mm [0.32 and 0.36 in]?
 | STEP 2D-1. Check for air leaks and inspect the air lines. |
 | STEP 2D-2. Check for air leaks at the turbocharger control valve outlet. |
 | STEP 2D-3. Check for air pressure at the turbocharger control valve outlet. |
 | STEP 2D-4. Check for correct turbocharger actuator travel. |
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2347 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect the INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Are active fault codes present?
YES | NO
No Repair | No Repair

Troubleshoot active fault codes

Go to 1B

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Connect the INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Are Fault Codes 595 or 2973 inactive?
YES | NO
No Repair | No Repair

Troubleshoot inactive fault codes starting with the fault code containing the highest number of counts

Go to 2B

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the intake restriction to the turbocharger inlet.

Conditions

  • Turn keyswitch ON.
  • Operate the engine at advertised horsepower and rpm.

Action

Check the intake system restriction by installing a vacuum gauge into the air system.

–

Is air intake restriction greater than 635 mm H²O [25 in H²O] for a used air filter or 254 mm H²O [10 in H²O] for a new filter?

YES NO

Repair

Correct the cause of high intake air restriction. Check for plugged air filter or restricted air intake piping.

 No Repair

Repair complete

Go to 2B

Guided Step 2B - Check the underhood air intake piping.

Conditions

  • Engine OFF.
  • Turn keyswitch OFF.

Action

Inspect the turbocharger air inlet piping for damage or holes that would allow hot underhood air to enter the turbocharger intake.

–

Damage found on the turbocharger air intake piping?
YES NO

Repair

Repair the air intake piping.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the charge-air cooler, clamps, hoses, and piping.

Conditions

  • Engine OFF.
  • Turn keyswitch OFF.

Action

Check the charge-aircooler clamps, hoses, and pipes for signs of leaks.

Pressure check the charge air cooler.

Loose charge-air cooler connection or malfunctioning charge-air cooler?
YES NO

Repair

Repair the charge-air cooler connections or charge-air cooler.

 No Repair

Go to 3A

Go to 2D

Guided Step 2D - Inspect the turbocharger compressor and turbine blades.

Conditions

  • Engine OFF.
  • Turn keyswitch OFF.

Action

Remove the turbocharger exhaust and intake connections.

Inspect the turbocharger turbine and compressor blades for damage.

Inspect the turbocharger compressor and turbine blades for damage or wear.

Damage to the turbocharger turbine or compressor blades?
YES NO

Repair

Replace the turbocharger. Use the following procedure in ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 010-033 in Section 10.

No Repair

Go to 3A

Go to 2E

Guided Step 2E - Check the variable geometry actuator rod for correct travel.

Conditions

  • Engine OFF.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Use INSITE™ electronic service tool. to start the Turbocharger Actuator Test.

  • Adjust the delay timer in the Turbocharger Actuator Test so the rod movement can be observed.
  • Select the Retract Actuator position with INSITE™ electronic service tool.
  • Mark or scribe the Variable Geometry actuator rod at the base of the actuator.
  • Select the Extend Actuator position with INSITE™ electronic service tool.
  • Measure the rod travel by measuring the distance from the base of the turbocharger actuator to the scribe mark.

Note: The turbocharger actuator should move quickly and crisply. If the actuator rod movement is slow, there could be a problem with the air supply or mechanical problems with the variable geometry turbocharger assembly.

Does the turbocharger actuator rod extend between 8 and 9 mm [0.32 and 0.36 in]?
YES | NO
No Repair | No Repair

Go to 2F

Go to 2E-1

Guided Step 2E-1 - Check for air leaks and inspect air lines.

Conditions

  • Engine OFF.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Use INSITE™ electronic service tool. to perform the Turbocharger Actuator Test.

Select the Extend Actuator position. Listen for air leaks at the following components:

  • Turbocharger control valve
  • Turbocharger control valve inlet connection
  • Turbocharger control valve outlet connection
  • Turbocharger actuator inlet connection
  • Turbocharger actuator
  • All air lines, including the OEM supply line to turbocharger control valve, and turbocharger control valve to turbocharger actuator.

Air leaks found in the system?
YES NO

Repair

Repair air leaks.

 No Repair

Go to 3A

Go to 2E-2

Guided Step 2E-2 - Check for air pressure at the turbocharger control valve outlet.

Conditions

  • Engine OFF.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Remove the air line connection at the outlet of the turbocharger control valve.

Install an M12 Compuchek™ fitting at the outlet of the turbocharger control valve.

Install an air pressure gauge that is capable of reading at least 1034 kPa [150 psi].

Use INSITE™ electronic service tool to perform the Turbocharger Actuator Test. Select the Extend Actuator position.

Is vehicle air tank pressure air pressure present at the turbocharger control valve outlet?
YES NO
No Repair

Repair

Repair the air supply from the OEM air tanks.

Go to 2E-3

Go to 3A

Guided Step 2E-3 - Check for air leaks at the turbocharger control valve outlet.

Conditions

  • Engine OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Use INSITE™ electronic service tool to perform the Turbocharger Actuator Test.

  • Select the Retract Actuator position.
  • Remove the air line connection at the outlet of the turbocharger control valve.

Can air be heard escaping from the turbocharger control valve outlet?
YES NO

Repair

Replace the turbocharger control valve. Refer to Procedure 019-388 in Section 19.

No Repair

Go to 3A

Go to 2E-4

Guided Step 2E-4 - Check for correct turbocharger actuator travel.

Conditions

  • Engine OFF.
  • Disconnect the variable geometry actuator rod from the turbocharger cross-shaft.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.
  • Verify vehicle air tanks are fully charged.

Action

Use INSITE™ electronic service tool to perform the Turbocharger Actuator Test.

  • Select the Extend Actuator position.

Does the turbocharger actuator rod travel at least 12 mm [0.472 in]?
YES NO

Repair

Replace the turbocharger. Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 010-033 in Section 10.

Repair

Replace the turbocharger actuator. Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 010-113 in Section 10.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Note: Unless the malfunction is a damaged barometric pressure or intake manifold pressure sensor, this code will most likely not be active with no load in the shop. The engine will most likely need to be loaded to trip this fault code, and to determine if the malfunction has been found and repaired.

Fault Code 2347 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-Apr-2012


FAULT CODE 2348 - EGR Valve Failed Automatic Calibration Procedure

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the EGR valve position sensor signal for a short circuit. | Greater than 100k ohms?
STEP 2. | Check the EGR valve position sensor. |
 | STEP 2A. Inspect the EGR valve position sensor and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the EGR valve position sensor signal voltage. | Less than 0.1 VDC?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2348 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the engine harness.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the EGR valve position sensor signal for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the EGR valve position sensor from the engine harness.

Action

Check for a short circuit in the harness.

  • Measure the resistance between the EGR Valve Position Signal pin at ECM connector of the engine harness and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the EGR valve position sensor.

Guided Step 2A - Inspect the EGR valve position sensor and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve position sensor from engine harness.

Action

Inspect the EGR valve position sensor and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the EGR valve position sensor signal voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool to the SAE J1939 or SAE J1970 OEM datalink connector.

Action

Use INSITE™ electronic service tool Data Logger/Monitor to check the EGR valve position sensor signal voltage.

Less than 0.1 VDC?
YES NO

Repair

Replace the EGR valve assembly. Use the following procedure in the Troubleshooting and Repair Manual, ISBe, ISB and QSB5.9 (Common Rail Fuel System) Series, Bulletin 4021271. Refer to Procedure 011-022 in Section 11.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2348 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect the INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 02-Apr-2012


FAULT CODE 2349 - EGR Valve Control Circuit - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2349 active?
STEP 2. | Check the EGR valve motor and circuit. |
 | STEP 2A. Inspect the EGR valve motor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the EGR valve motor. | Less than 15 ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit from pin to pin in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to a voltage source in the engine harness. | Less than 1.5 VDC?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2349 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2349 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool, read the fault codes.

Fault Code 2349 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the EGR valve motor and circuit.

Guided Step 2A - Inspect the EGR valve motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the engine harness.

Action

Inspect the engine harness and EGR valve motor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the EGR valve motor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the engine harness.

Action

Check for an open circuit in the EGR valve motor.

  • Measure the resistance between the EGR valve motor SIGNAL (+) pin and the EGR valve motor SIGNAL (-) pin at the EGR valve motor connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 15 ohms?
YES NO
No Repair

Repair

Replace the EGR valve assembly. Use the following procedure in the Troubleshooting and Repair Manual, ISBe, ISB and QSB5.9 (Common Rail Fuel System) Series, Bulletin 4021271. Refer to Procedure 011-022 in Section 11.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the EGR valve motor.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the EGR valve motor SIGNAL (+) pin at the ECM connector of the engine harness and the EGR valve motor SIGNAL (+) pin at the EGR valve motor connector of the engine harness.
  • Measure the resistance between the EGR valve motor SIGNAL (-) pin at the ECM connector of the engine harness and the EGR valve motor SIGNAL (-) pin at the EGR valve motor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin to pin in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the EGR valve motor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the EGR valve motor SIGNAL (+) pin at the ECM connector of the engine harness and all other pins at the ECM connector.
  • Measure the resistance between the EGR valve motor SIGNAL (-) pin at the ECM connector of the engine harness and all other pins at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to a voltage source in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Connect the engine harness to the EGR valve motor.
  • Turn keyswitch ON.

Action

Check for a short circuit to a voltage source in the engine harness.

  • Measure the voltage between the EGR valve motor SIGNAL (+) pin at the ECM connector of the engine harness and engine block ground.
  • Measure the voltage between the EGR valve motor SIGNAL (-) pin at the ECM connector of the engine harness and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Use the following procedure for multimeter usage. Refer to Procedure 019-359 in Section 19.

Less than 1.5 VDC?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2349 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the problem.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2349 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 02-Apr-2012


FAULT CODE 2351 - EGR Valve Control Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch/™AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the EGR valve motor and circuit. |
 | STEP 1A. Inspect the EGR valve motor and connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit to ground in the EGR valve motor. | Greater than 100k ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit from pin to pin in the engine harness. | Greater than 100k ohms?
 | STEP 2D. Check for an inactive fault code. | Fault Code 2351 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2351 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the EGR valve motor and circuit.

Guided Step 1A - Inspect the EGR valve motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the engine harness.

Action

Inspect the engine harness and EGR valve motor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for a short circuit to ground in the EGR valve motor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the engine harness.

Action

Check for a short circuit to ground in the EGR valve motor.

  • Measure the resistance between the EGR valve motor SIGNAL (+) pin and engine block ground.
  • Measure the resistance between the EGR valve motor SIGNAL (-) pin and engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the EGR valve assembly. Use the following procedure in the Troubleshooting and Repair Manual, ISBe, ISB and QSB5.9 (Common Rail Fuel System) Series, Bulletin 4021271. Refer to Procedure 011-022 in Section 11.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the EGR valve motor.

Action

Check for a short circuit to ground in the engine harness.

  • Measure the resistance between the EGR valve motor SIGNAL (+) pin at the ECM connector of the engine harness and engine block ground.
  • Measure the resistance between the EGR valve motor SIGNAL (-) pin at the ECM connector of the engine harness and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin to pin in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the EGR valve motor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the EGR valve motor SIGNAL (+) pin at the ECM connector of the engine harness and all other pins at the ECM connector.
  • Measure the resistance between the EGR valve motor SIGNAL (-) pin at the ECM connector of the engine harness and all other pins at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2351 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the problem.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine coolant temperature above 82°C [180°F].
  • Engine not running.

Action

Disable the fault code.

Perform the INSITE™ electronic service tool EGR Valve Test.

NOTE: Be sure to command the valve “open” and “closed”.

NOTE: Running the engine to verify the repair was effective is not sufficient. The EGR Valve Test must be run to verify the repair was effective.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2351 inactive?
YES | NO
No Repair | No Repair

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Mar-2012


FAULT CODE 2352 - EGR Valve Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit to a voltage source. | Less than 1.5 VDC?
 | STEP 1C. Check for a short circuit from pin to pin in the engine harness. | Greater than 100k ohms?
 | STEP 1D. Check for an inactive fault code. | Fault Code 2352 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 2352 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check for a short circuit to a voltage source.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Connect the engine harness to the EGR valve motor.
  • Turn keyswitch ON.

Action

Check for a short circuit to a voltage source.

  • Measure the voltage between the EGR valve motor SIGNAL (+) pin at the ECM connector of the engine harness and engine block ground.
  • Measure the voltage between the EGR valve motor SIGNAL (-) pin at the ECM connector of the engine harness and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Use the following procedure for multimeter usage. Refer to Procedure 019-359 in Section 19.

Less than 1.5 VDC?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1C

Go to 2A

Guided Step 1C - Check for a short circuit from pin to pin in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the EGR valve motor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance between the EGR valve motor SIGNAL (+) pin at the ECM connector of the engine harness and all other pins at the ECM connector.
  • Measure the resistance between the EGR valve motor SIGNAL (-) pin at the ECM connector of the engine harness and all other pins at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2352 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the problem.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine coolant temperature above 82°C [180°F].
  • Engine not running.

Action

Disable the fault code.

Perform the INSITE™ electronic service tool EGR Valve Test.

NOTE: Be sure to command the valve “open” and “closed”.

NOTE: Running the engine to verify the repair was effective is not sufficient. The EGR Valve Test must be run to verify the repair was effective.

  • Perform the INSITE™ electronic service tool EGR Valve Test.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2352 inactive?
YES | NO
No Repair | No Repair

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to rase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Mar-2012


FAULT CODE 2353 - EGR Valve Control Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2353 active?
STEP 2. | Check the EGR valve motor and circuit. |
 | STEP 2A. Inspect the engine harness and valve motor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the EGR valve motor. | Greater than 0.5 ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Check for a short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check the EGR valve assembly. |
 | STEP 4A. Perform the INSITE™ electronic service tool EGR Valve Test. | EGR valve position 100 percent when open?
 | STEP 4B. Perform the INSITE™ electronic service tool EGR Valve Test. | Is EGR valve position less than 10 percent when closed?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 2353 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2353 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the EGR valve motor and circuit.

Guided Step 2A - Inspect the engine harness and valve motor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the engine harness.

Action

Inspect the engine harness and valve motor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the resistance of the EGR valve motor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the engine harness.
  • Make sure the multimeter is calibrated to zero before taking resistance measurements.

Action

Check the resistance of the EGR valve motor.

  • Measure the resistance between the EGR valve motor SIGNAL (+) pin and the EGR valve motor SIGNAL (-) pin at the EGR valve motor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 0.5 ohms?
YES NO
No Repair

Repair

Replace the EGR valve assembly. Used the following procedure in the ISBe and ISB (Common Rail Fuel System) Series Engines Troubleshooting and Repair Manual, Bulletin 4021271. Refer to Procedure 011-022 in Section 11.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve motor from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the EGR valve motor SIGNAL (+) pin and the EGR valve motor SIGNAL (-) pin at the EGR valve motor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the EGR valve assembly.

Guided Step 4A - Perform the INSITE™ electronic service tool EGR Valve Test.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine coolant temperature at least 82°C [180°F].

Action

Start the INSITE™ electronic service tool EGR Valve Test.

  • Open the EGR valve.

EGR valve position 100 percent when open?
YES NO
No Repair

Repair

Replace the EGR valve assembly. Use the following procedure in the Troubleshooting and Repair Manual, ISBe, ISB and QSB5.9 (Common Rail Fuel System) Series, Bulletin 4021271. Refer to Procedure 011-022 in Section 11.

Go to 4B

Go to 5A

Guided Step 4B - Perform the INSITE™ electronic service tool EGR Valve Test.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine coolant temperature at least 82°C [180°F].

Action

Start the INSITE™ electonic service tool EGR Valve Test.

  • Close the EGR valve.

Is EGR valve position less than 10 percent when closed?
YES NO
No Repair

Repair

Replace the EGR valve assembly. Use the following procedure in the Troubleshooting and Repair Manual, ISBe, ISB and QSB5.9 (Common Rail Fuel System) Series, Bulletin 4021271. Refer to Procedure 011-022 in Section 11.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify fault code is inactive.

Fault Code 2353 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Mar-2012


FAULT CODE 2357 - EGR Valve Control - Mechanical System Not Responding Properly or Out of Adjustment

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the EGR valve position sensor signal for a short circuit. | Greater than 100k ohms?
STEP 2. | Check the ECM. |
 | STEP 2A. Check the EGR valve position sensor signal voltage. | Less than 0.1 VDC?
STEP 3. | Check the EGR valve assembly. |
 | STEP 3A. Perform the INSITE™ electronic service tool EGR Valve Test. | EGR valve position 100 percent when open?
 | STEP 3B. Perform the INSITE™ electronic service tool EGR Valve Test. | EGR valve position less than 10 percent when closed?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2357 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the EGR valve position sensor signal for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the EGR valve position sensor from the engine harness.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the EGR valve position SIGNAL pin at the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the ECM.

Guided Step 2A - Check the EGR valve position sensor signal voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool to the SAE J1939 or SAE J1587 datalink connector.

Action

Use the INSITE™ electronic service tool Data Logger/Monitor, to check the EGR valve position sensor signal voltage.

Less than 0.1 VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check the EGR valve assembly.

Guided Step 3A - Perform the INSITE™ electronic service tool EGR Valve Test.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine coolant temperature above 82°C [180°F].
  • Engine not running.

Action

Start the INSITE™ electronic service tool EGR Valve Test.

  • Open the EGR valve.

EGR valve position 100 percent when open?
YES NO
No Repair

Repair

Replace the EGR valve assembly. Use the following procedure in the Troubleshooting and Repair Manual, ISBe, ISB and QSB5.9 (Common Rail Fuel System) Series, Bulletin 4021271. Refer to Procedure 011-022 in Section 11.

Go to 3B

Go to 4A

Guided Step 3B - Perform the INSITE™ electronic service tool EGR Valve Test.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Engine coolant temperature above 82°C [180°F].
  • Engine not running.

Action

Start the INSITE™ electronic service tool EGR Valve Test.

  • Close the EGR valve.

EGR valve position less than 10 percent when closed?
YES NO
No Repair

Repair

Replace the EGR valve assembly. Use the following procedure in the Troubleshooting and Repair Manual, ISBe, ISB and QSB5.9 (Common Rail Fuel System) Series, Bulletin 4021271. Refer to Procedure 011-022 in Section 11.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2357 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Trouobleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Mar-2012


FAULT CODE 2359 - EGR Differential Pressure Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for additional fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Fault Codes 1228, 1229, 2271, 2272, 2273, 2274, 2346, 2347, 2348, 2349, 2351, 2352, 2353, 2357, 2381, 2382, 2383, 2384, 2385, 2386, 2387, 2388, 9121, or 9122 active or inactive with high counts?
STEP 2. | Check the EGR differential pressure. |
 | STEP 2A. Verify the EGR differential pressure at key ON. | Fault Code 2359 active?
 | STEP 2A-1. Check the EGR differential pressure drillings for plugging. |
 | STEP 2B. Verify the EGR differential pressure at key ON. | Fault Code 2359 active?
 | STEP 2C. Verify the EGR differential pressure at key ON. | Fault Code 2359 active?
STEP 3. | Check the EGR differential pressure drillings and mounting surfaces for leaks or plugging debris. |
 | STEP 3A. Check the EGR differential pressure drillings for leaks. | Leaks detected at the EGR differential pressure sensor mounting surface?
 | STEP 3B. Check the EGR differential pressure drillings for plugging. | Debris plugging either drilling?
STEP 4. | Check the air handling system. |
 | STEP 4A. Inspect the air handling system for intake manifold, charge air cooler, or EGR leaks. | Any leaks detected?
 | STEP 4B. Perform the INSITE™ electronic service tool EGR Valve/Turbocharger Operational Test for variable geometry turbocharger. | EGR Valve/Turbocharger Operational Test passed?
 | STEP 4C. Perform the Turbocharger Leak Test for wastegate actuated turbocharger. | Turbocharger Leak Test passed?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 2359 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify the fault code does not become active under normal operation. | Fault Code 2359 becomes activated during loaded operation?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for additional fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for active or high counts of inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1228, 1229, 2271, 2272, 2273, 2274, 2346, 2347, 2348, 2349, 2351, 2352, 2353, 2357, 2381, 2382, 2383, 2384, 2385, 2386, 2387, 2388, 9121, or 9122 active or inactive with high counts?

YES NO

Repair

Troubleshoot fault codes starting with the fault code for which there is the highest number of counts.

 No Repair

Appropriate troubleshooting step

Go to 2A

Guided Step 2 - Check the EGR differential pressure.

Guided Step 2A - Verify the EGR differential pressure at key ON.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Engine not operating.
  • Exhaust fans disconnected or turned OFF.

Action

Verify the engine coolant temperature is greater than 67°C [154°F] and intake manifold air temperature is greater than 16°C [60°F].

  • Turn keyswitch OFF for 30 seconds.

NOTE: The engine must not be operating before the keyswitch is turned OFF. If the engine is operating, turn the keyswitch OFF for 30 seconds, key ON for 30 seconds then back OFF again.

  • Turn keyswitch ON and wait 30 seconds.
  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 2359 active?
YES | NO
No Repair | No Repair

Go to 2A-1

Go to 3A

Guided Step 2A-1 - Check the EGR differential pressure drillings for plugging.

Conditions

  • Turn Keyswitch OFF.

Action

Remove the EGR differential pressure sensor.

  • Inspect the EGR differential pressure drillings for plugging.

Debris plugging either drilling?
YES NO

Repair

Clear the debris. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 010-080 in Section 10.

Repair

Replace the EGR differential pressure sensor. Refer to Procedure 019-370 in Section 19.

Go to 2B

Go to 5A

Guided Step 2B - Verify the EGR differential pressure at key ON.

Conditions

  • Connect all componets
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Engine not operating.
  • Exhaust fans disconnected or turned OFF.

Action

Verify the engine coolant temperature is greater than 67°C [154°F] and intake manifold air temperature is greater than 16°C [60°F].

  • Turn keyswitch OFF for 30 seconds.

NOTE: The engine must not be operating before the keyswitch is turned OFF. If the engine is operating, turn the keyswitch OFF for 30 seconds, key ON for 30 seconds then back OFF again.

  • Turn keyswitch ON and wait 30 seconds.
  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 2359 active?
YES NO

Repair

Replace the EGR differential pressure sensor. Refer to Procedure Procedure 019-370 in Section 19.

No Repair

Go to 2C

Go to 5B

Guided Step 2C - Verify the EGR differential pressure at key ON.

Conditions

  • Connect all componets
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Engine not operating.
  • Exhaust fans disconnected or turned OFF.

Action

Verify the engine coolant temperature is greater than 67°C [154°F] and intake manifold air temperature is greater than 16°C [60°F].

  • Turn keyswitch OFF for 30 seconds.

NOTE: The engine must not be operating before the keyswitch is turned OFF. If the engine is operating, turn the keyswitch OFF for 30 seconds, key ON for 30 seconds then back OFF again.

  • Turn keyswitch ON and wait 30 seconds.
  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 2359 active?
YES NO

Repair

Replace the air intake connection.

 No Repair

Go to 5A

Go to 5B

Guided Step 3 - Check the EGR differential pressure drillings and mounting surfaces for leaks or debris plugging.

Guided Step 3A - Check the EGR differential pressure drillings for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the EGR differential pressure sensor mounting surface for leaks.

  • Leaks should be easily detected by traces of soot.

Leaks detected at the EGR differential pressure sensor mounting surface?
YES NO

Repair

Inspect the mounting surface and the EGR differential pressure sensor for the source of the leakage.

Repair or replace the suspect components.

 No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check the EGR differential pressure drillings for plugging.

Conditions

  • Turn keyswitch OFF.

Action

Remove the EGR differential pressure sensor.

  • Inspect the EGR differential pressure drillings for plugging.

Debris plugging either drilling?
YES NO

Repair

Clear the debris. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 010-080 in Section 10.

No Repair

Go to 2C

Go to 4A

Guided Step 4 - Check the air handling system.

Guided Step 4A - Inspect the air handling system for intake manifold, charge-air cooler, or EGR leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the air handling system for intake manifold, charge air cooler, or EGR leaks.

Inspect the following for leaks:

  • Charge-air cooler - Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 010-027 in Section 10.
  • Air intake and exhaust - Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 010-024 in Section 10.
  • EGR connection tubes and hoses.

Any leaks detected?
YES NO

Repair

Repair leaks.

 No Repair

Go to 6A

Variable geometry turbocharger: 4B; Wastegate actuated turbocharger: 4C

Guided Step 4B - Perform the INSITE™ electronic service tool EGR Valve/Turbocharger Operational Test for variable geometry turbocharger.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool EGR Valve/Turbocharger Operational Test.
  • Start the engine and run at low idle.

Action

Select the EGR/VGT Operational Test using the INSITE™ electronic service tool.

  • Choose All Components under Test Choices.

EGR Valve/Turbocharger Operational Test passed?
YES NO
No Repair

Repair

Repair or replace the suspect component. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 011-022 in Section 11.

Go to 6A

Go to 6A

Guided Step 4C - Perform the Turbocharger Leak Test for wastegate actuated turbocharger.

Conditions

  • Turn keyswitch OFF.

Action

Perform the Turbocharger Leak Test for wastegate actuated tubocharger.

  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 010-050 in Section 10.

Turbocharger Leak Test passed?
YES NO
No Repair

Repair

Repair or replace the suspect component. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 010-033 in Section 10.

Go to 6A

Go to 6A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Engine coolant temperature is above 67°C [154°F].
  • Intake manifold air temperature is above 16°C [60°F].
  • Engine not operating.

Action

Use INSITE™ electronic service tool to verify the engine coolant temperature is greater than 67°C [154°F] and the intake manifold air temperature is greater than 16°C [60°F].

  • Turn keyswitch OFF for 30 seconds.
  • Turn keyswitch ON.
  • Check the fault codes.

Fault Code 2359 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify the fault code does not become active under normal operation.

Conditions

  • Connect all components.

Action

Interview the driver to determine under what conditions and load the truck was being driven when this fault occurred. Try to duplicate those conditions to verify the fault does not become active.

Run the engine under the same conditions and load identified by the driver and verify Fault Code 2359 does not become activated.

Note: Certain malfunctions will cause Fault Code 2359 to be activated during normal operation and force the fault code to go inactive at key ON. This step is required to verify the correct component has been repaired or replaced.

Fault Code 2359 becomes activated during loaded operation?
YES NO

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 1A

Go to 6B

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 26-Apr-2012


FAULT CODE 2362 - Engine Brake Actuator Circuit #1 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead, and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2362 inactive?
 | STEP 1B. Determine engine brake type. | Is the engine equipped with a compression brake?
STEP 2. | Check the engine brake solenoid and circuit. |
 | STEP 2A. Check the diagnostic signal voltage at the engine brake pass-through connector. | Greater than 3.75 VDC?
 | STEP 2B. Check the engine brake wiring harness for damage. | Damaged connectors or wire insulation?
 | STEP 2C. Check the engine brake solenoid for a short to ground. | 5 ohms or greater?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine brake solenoid number 1 diagnostic supply voltage. | Greater than 3.75 VDC?
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2362 inactive?
 | STEP 3E-1. Check for exhaust brake installation. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2362 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared.

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2362 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 1B

Guided Step 1B - Determine engine brake type.

Conditions

  • Turn keyswitch OFF.

Action

Determine if the engine is equipped with a compression brake or exhaust brake.

–

Is the engine equipped with a compression brake?
YES NO
No Repair

Repair

The engine is equipped with an exhaust brake.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine brake solenoid and circuit.

Guided Step 2A - Check the diagnostic signal voltage at the engine brake pass-through connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake solenoid number 1 wire from the pass-through connector on the rocker lever housing.
  • Turn keyswitch ON.

Action

Check the engine brake solenoid number 1 diagnostic supply voltage.

  • Measure the voltage between the engine harness engine brake solenoid number 1 SIGNAL pin and ground.

Refer to the wiring diagram for connector pin identification.

Greater than 3.75 VDC?
YES | NO
No Repair | No Repair

Go to 2B

Go to 3A

Guided Step 2B - Check the engine brake wiring harness for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the Troubleshooting and Repair Manual, ISC, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 003-011 in Section 3.
  • Remove the engine brake jumper harness between the pass-through connector and the engine brake solenoid.

Action

Inspect the internal engine brake jumper harness pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged connectors or wire insulation?
YES NO

Repair

Repair or replace the engine brake harness. Refer to Procedure 019-136 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the engine brake solenoid for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the Troubleshooting and Repair Manual, ISC, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 003-011 in Section 3.
  • Disconnect the engine brake harness from engine brake solenoid number 1.

Action

Check the resistance of the solenoid.

  • Measure the resistance from engine brake number 1 solenoid terminal pin to ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

5 ohms or greater?
YES NO
No Repair

Repair

Replace the engine brake solenoid. Use the following procedure in the Troubleshooting and Repair Manual, ISC, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 020-012 in Section 20.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness form the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine brake solenoid number 1 diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the engine brake solenoid number 1 diagnostic supply voltage.

  • Measure the voltage between the engine brake solenoid number 1 SIGNAL pin and ground at the ECM connector.

Refer to the wiring diagram for connector pin identification.

Greater than 3.75 VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • If equipped with engine brakes, disconnect the engine brake solenoid number 1 from the engine brake pass-through connector.
  • If equipped with an exhaust brake, disconnect the 2-pin Weather Pack™ connector at the back of the engine between the number 5 and 6 high pressure fuel lines.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine brake solenoid number 1 SIGNAL pin in the engine harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the engine brake actuator SIGNAL wire has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the shorted supply circuit to ground.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • If equipped with engine brakes, disconnect the engine brake solenoid number 1 from the engine brake pass-through connector.
  • If equipped with an exhaust brake, disconnect the 2-pin Weather Pack™ connector at the back of the engine between the number 5 and 6 high pressure fuel lines.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine brake solenoid number 1 SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the engine brake solenoid number 1 SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2362 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the problem.

 No Repair

Go to 4A

Go to 3E-1

Guided Step 3E-1 - Check for exhaust brake installation.

Conditions

–

Action

Check if the engine is equipped with an exhaust brake.

–

Is the engine equipped with an exhaust brake?
YES NO

Repair

Refer to the OEM service manual to check the wiring and circuitry between the Cummins® engine wiring harness and the exhaust brake.

Repair

All the wiring has been checked and found to be OK. The ECM has malfunctioned.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

OEM service manual

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2362 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 16-May-2014


FAULT CODE 2363 - Engine Brake Actuator Circuit #2 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead, and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2362 is inactive?
STEP 2. | Check the engine brake solenoid and circuit. |
 | STEP 2A. Check the diagnostic signal voltage at the engine brake pass-through connector. | Greater than 3.75-VDC?
 | STEP 2B. Check the engine brake wiring harness for damage. | Damaged connectors or wire insulation?
 | STEP 2C. Check the engine brake solenoid for a short to ground. | 5 ohms or greater?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine brake solenoid number 2 diagnostic supply voltage. | Greater than 3.75-VDC?
 | STEP 3C. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3D. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2363 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2363 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Using INSITE™, read the fault codes.

Fault Code 2362 is inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine brake solenoid and circuit.

Guided Step 2A - Check the diagnostic signal voltage at the engine brake pass-through connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine brake solenoid number 2 wire from the pass-through connector on the rocker lever housing.
  • Turn keyswitch ON.

Action

Check the engine brake solenoid number 2 diagnostic supply voltage.

  • Measure the voltage between the engine harness engine brake solenoid number 2 SIGNAL pin and ground.

Refer to the wiring diagram for connector pin identification.

Greater than 3.75-VDC?
YES | NO
No Repair | No Repair

Go to 2B

Go to 3A

Guided Step 2B - Check the engine brake wiring harness for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the Troubleshooting and Repair Manual, ISC, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 003-011 in Section 3.
  • Remove the engine brake jumper harness between that pass-through connector and the engine brake solenoid.

Action

Inspect the internal engine brake jumper harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged connectors or wire insulation?
YES NO

Repair

Repair or replace the engine brake harness. Refer to Procedure 019-136 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the engine brake solenoid for a short to ground.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the Troubleshooting and Repair Manual, ISC, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 003-011 in Section 3.
  • Disconnect the engine brake harness from engine brake solenoid number 2.

Action

Check the resistance of the solenoid.

  • Measure the resistance from engine brake number 2 solenoid terminal pin to ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

5 ohms or greater?
YES NO
No Repair

Repair

Replace the engine brake solenoid. Use the following procedure in the Troubleshooting and Repair Manual, ISC, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 020-012 in Section 3.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness form the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

  • Repair the damaged harness, connector or pins if possible. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine brake solenoid number 2 diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the engine brake solenoid number 2 diagnostic supply voltage.

  • Measure the voltage between the engine brake solenoid number 2 SIGNAL pin and ground at the ECM connector.

Refer to the wiring diagram for connector pin identification.

Greater than 3.75-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine brake solenoid number 2 from the engine brake pass-through connector.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine brake solenoid number 2 SIGNAL pin in the engine harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the engine brake actuator SIGNAL wire has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the shorted supply circuit to ground.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine brake solenoid number 2 from the engine brake pass-through connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine brake solenoid number 2 SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the engine brake solenoid number 2 SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2363 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2363 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 16-May-2014


FAULT CODE 2366 - Engine Brake Actuator Circuit #1 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead, and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2366 is inactive?
 | STEP 1B. Determine engine brake type. | Is the engine equipped with a compression brake?
STEP 2. | Check the engine brake solenoid and circuit. |
 | STEP 2A. Check the engine brake solenoid for an open circuit. | Between 5 and 15 ohms?
 | STEP 2B. Check the diagnostic signal voltage at the engine brake actuator. | Greater than 3.75-VDC?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine brake solenoid number 2 diagnostic supply voltage. | Greater than 3.75-VDC?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2366 inactive?
 | STEP 3E-1. Check for exhaust brake installation. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2366 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2366 is inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 1B

Guided Step 1B - Determine engine brake type.

Conditions

  • Turn keyswitch OFF.

Action

Determine if the engine is equipped with a compression brake or exhaust brake.

–

Is the engine equipped with a compression brake?
YES NO
No Repair

Repair

The engine is equipped with an exhaust brake.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine brake solenoid and circuit.

Guided Step 2A - Check the engine brake solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. use the following procedure in the Troubleshooting and Repair Manual, ISC, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 003-011 in Section 3.
  • Disconnect the engine brake harness from engine brake solenoid number 2.

Action

Check the resistance of the solenoid.

  • Measure the resistance from the solenoid terminal pin to ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 5 and 15 ohms?
YES NO
No Repair

Repair

Replace the engine brake solenoid. Use the following procedure in the Troubleshooting and Repair Manual, ISC, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 020-012 in Section 20.

Go to 2B

Go to 4A

Guided Step 2B - Check the diagnostic signal voltage at the engine brake actuator.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the Troubleshooting and Repair Manual, ISC, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 003-011 in Section 3.
  • Disconnect the engine brake solenoid number 2 wire from the engine brake solenoid.
  • Turn keyswitch ON.

Action

Check the engine brake solenoid number 2 diagnostic supply voltage.

  • Measure the voltage between the engine harness engine brake solenoid number 2 SIGNAL pin and ground.

Refer to the wiring diagram for connector pin identification.

Greater than 3.75-VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine brake solenoid number 2 diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the engine brake solenoid number 2 diagnostic supply voltage.

  • Measure the voltage between the engine brake solenoid number 2 SIGNAL pin and ground at the ECM connector.

Refer to the wiring diagram for connector pin identification.

Greater than 3.75-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. use the following procedure in the Troubleshooting and Repair Manual, ISC, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 003-011 in Section 3.
  • If equipped with engine brakes, disconnect the engine brake solenoid number 2 wire from the engine brake solenoid.
  • If equipped with an exhaust brake, disconnect the 2-pin Weather Pack™ connector at the back of the engine between the number 5 and 6 high-pressure fuel lines.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit.

  • If equipped with engine brakes, measure the resistance between the engine brake solenoid number 2 SIGNAL wire at the engine brake solenoid to the engine brake solenoid number 2 SIGNAL wire at the ECM connector.
  • If equipped with an exhaust brake, measure the resistance between the engine brake solenoid number 2 SIGNAL wire at the 2-pin Weather Pack™ connector to the engine brake solenoid number 2 SIGNAL wire at the ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open engine brake solenoid number 2 SIGNAL circuit has been detected in the engine harness. The open circuit is in one of the following harnesses:

  • The main engine harness between the ECM and the 2-pin connector at the back of the engine
  • The engine brake jumper harness between the engine harness 2-pin connector at the back of the engine and the rocker lever housing
  • The internal engine brake harness between the rocker lever housing and the engine brake solenoid.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the engine harness. Refer to Procedure 019-043.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • If equipped with engine brakes, disconnect the engine brake solenoid number 1 wire from the engine brake pass-through connector.
  • If equipped with an exhaust brake, disconnect the 2-pin Weather Pack™ connector at the back of the engine between the number 5 and 6 high-pressure fuel lines.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine brake solenoid number 1 SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the engine brake solenoid number 1 SIGNAL line has been detected in the engine.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2366 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

 No Repair

Go to 4A

Go to 3E-1

Guided Step 3E-1 - Check for exhaust brake installation.

Conditions

–

Action

Check if the engine is equipped with an exhaust brake.

–

Is the engine equipped with an exhaust brake?
YES NO

Repair

Refer to the OEM service manual to check the wiring and circuitry between the Cummins® wiring harness and the exhaust brake.

Repair

All the wiring has been checked and found to be OK. The ECM is damaged.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

OEM service manual

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2366 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 18-Apr-2012


FAULT CODE 2367 - Engine Brake Actuator Circuit #2 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Weather-Pack™ test lead, and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2367 is inactive?
STEP 2. | Check the engine brake solenoid and circuit. |
 | STEP 2A. Check the engine brake solenoid for an open circuit. | Between 5 and 15 ohms?
 | STEP 2B. Check the diagnostic signal voltage at the engine brake actuator. | Greater than 3.75-VDC?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine brake solenoid number 2 diagnostic supply voltage. | Greater than 3.75-VDC?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin to pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2367 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2367 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2367 is inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine brake solenoid and circuit.

Guided Step 2A - Check the engine brake solenoid for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the Troubleshooting and Repair Manual, ISC, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 003-011 in Section 3.
  • Disconnect the engine brake harness from engine brake solenoid number 2.

Action

Check the resistance of the solenoid.

  • Measure the resistance from the solenoid terminal pin to ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 5 and 15 ohms?
YES NO
No Repair

Repair

Replace the engine brake solenoid. Use the following procedure in the Troubleshooting and Repair Manual, ISC, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 020-012 in Section 20.

Go to 2B

Go to 4A

Guided Step 2B - Check the diagnostic signal voltage at the engine brake actuator.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the Troubleshooting and Repair Manual, ISC, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 003-011 in Section 3.
  • Disconnect the engine brake solenoid number 2 wire from the engine brake solenoid.
  • Turn keyswitch ON.

Action

Check the engine brake solenoid number 2 diagnostic supply voltage.

  • Measure the voltage between the engine harness engine brake solenoid number 2 SIGNAL pin and ground.

Refer to the wiring diagram for connector pin identification.

Greater than 3.75-VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM? connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the engine brake solenoid number 2 diagnostic supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the engine brake solenoid number 2 diagnostic supply voltage.

  • Measure the voltage between the engine brake solenoid number 2 SIGNAL pin and ground at the ECM connector.

Refer to the wiring diagram for connector pin identification.

Greater than 3.75-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Remove the rocker lever cover. Use the following procedure in the Troubleshooting and Repair Manual, ISC, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418. Refer to Procedure 003-011 in Section 3.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine brake solenoid number 2 wire from the engine brake solenoid.

Action

Check for an open circuit.

  • Measure the resistance between the engine brake solenoid number 2 SIGNAL wire at the engine brake solenoid to the engine brake solenoid number 2 SIGNAL wire at the ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open engine brake solenoid number 2 SIGNAL circuit has been detected in the engine harness. The open circuit is in one of the following harnesses:

  • The main engine harness between the ECM and the 2-pin connector at the back of the engine
  • The engine brake jumper harness between the engine harness 2-pin connector at the back of the engine and the rocker lever housing
  • The internal engine brake harness between the rocker lever housing and the engine brake solenoid.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine brake solenoid number 2 from the engine brake pass-through connector.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine brake solenoid number 2 SIGNAL pin in the engine harness ECM connector and all other pins in the ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the engine brake solenoid number 2 SIGNAL line has been detected in the engine.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2367 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2367 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 18-Apr-2012


FAULT CODE 2373 - Exhaust Gas Pressure Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead, Part Number 3164597 - female Framatome™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 227 active?
 | STEP 1B. Check for an active fault code. | Fault Code 2373 active?
STEP 2. | Check the exhaust gas pressure sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2374 active and Fault Code 2373 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit at the engine harness. | 4.75-VDC to 5.25-VDC?
 | STEP 2D. Check the sensor supply voltage and return circuit at the ECM. | 4.75-VDC to 5.25-VDC?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 2374 active and Fault Code 2373 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2373 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Fault Code 227

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas pressure sensor and circuit.

Guided Step 2A - Inspect the exhaust gas pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 active and Fault Code 2373 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit at the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas pressure +5 volt SUPPLY pin to the exhaust gas pressure RETURN pin at the sensor connector of the engine harness.

4.75-VDC to 5.25-VDC?
YES NO

Repair

Replace the exhaust gas pressure sensor. Refer to Procedure 019-376 in Section 19.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check the sensor supply voltage and return circuit at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas pressure +5 volt SUPPLY pin to the exhaust gas pressure RETURN pin at the ECM port.

4.75-VDC to 5.25-VDC?
YES NO

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes .

Fault Code 2374 active and Fault Code 2373 inactive?
YES NO

Repair

Repair or replace the engine harness.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2373 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Apr-2012


FAULT CODE 2374 - Exhaust Gas Pressure Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3164596 - male Framatome™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 active?
 | STEP 1B. Check for an active fault code. | Fault Code 2374 active?
STEP 2. | Check the exhaust gas pressure sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 2373 active and Fault Code 2374 inactive?
 | STEP 2D. Check the ECM response. | Fault Code 2373 active and Fault Code 2374 inactive?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 2373 active and Fault Code 2374 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2374 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Fault Code 187

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 active?
YES NO
No Repair

Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas pressure sensor and circuit.

Guided Step 2A - Inspect the exhaust gas pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas pressure +5 volt SUPPLY pin to the exhaust gas pressure RETURN pin at the sensor connector of the engine harness.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the exhaust gas pressure +5 volt SUPPLY pin and the exhaust gas pressure SIGNAL pin at the sensor connector of the engine harness.
  • Check for the appropriate ECM response after 30 seconds.
  • Read the fault codes using INSITE™ electronic service tool.

Fault Code 2373 active and Fault Code 2374 inactive?
YES NO

Repair

Replace the exhaust gas pressure sensor. Refer to Procedure 019-376 in Section 19.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the exhaust gas pressure +5 volt SUPPLY pin and the exhaust gas pressure SIGNAL pin at the ECM port.
  • Check for the appropriate ECM response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 active and Fault Code 2374 inactive?
YES NO

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the exhaust gas pressure +5 volt SUPPLY pin and exhaust gas pressure SIGNAL pin at the ECM port.
  • Check for the appropriate ECM response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 active and Fault Code 2374 inactive?
YES NO

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2374 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Apr-2012


FAULT CODE 2375 - Exhaust Gas Recirculation (EGR) Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead, Part Number 3164597 - female Framatome™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2375 inactive?
STEP 2. | Check the EGR temperature sensor and circuit. |
 | STEP 2A. Inspect the EGR temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 200 ohms to 2.4M ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 2375 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 2376 active and Fault Code 2375 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2375 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2375 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the EGR temperature sensor and circuit.

Guided Step 2A - Inspect the EGR temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the EGR temperature sensor SIGNAL pin and the EGR temperature RETURN pin of the EGR temperature sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

200 ohms to 2.4M ohms?
YES NO
No Repair

Repair

Replace the EGR temperature sensor. Refer to Procedure 019-378 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the EGR temperature sensor SIGNAL pin and the EGR temperature sensor RETURN pin at the ECM connector.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Fault Code 2376 active and Fault Code 2375 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness(es).

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector EGR temperature sensor RETURN pin and the engine harness EGR temperature sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector EGR temperature sensor SIGNAL pin and the engine harness EGR temperature sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the EGR temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2375 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Apr-2012


FAULT CODE 2376 - Recirculation Exhaust Gas Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2376 inactive?
STEP 2. | Check the EGR temperature sensor and circuit. |
 | STEP 2A. Inspect the EGR temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2375 active and Fault Code 2376 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 2376 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 2375 active and Fault Code 2376 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2376 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2376 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2376 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the EGR temperature sensor and circuit.

Guided Step 2A - Inspect the EGR temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 active and Fault Code 2376 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2376 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the EGR temperature sensor. Refer to Procedure 019-378 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 active and Fault Code 2376 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the EGR temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the EGR temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the signal line has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2376 inactive?
YES NO

Repair

None. Removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2376 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Apr-2012


FAULT CODE 2377 - Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2377 is inactive?
STEP 2. | Check the fan control solenoid and circuit. |
 | STEP 2A. Inspect the fan control solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the fan control solenoid. | Less than 10k ohms?
 | STEP 2C. Check the fan control solenoid diagnostic supply voltage, supply line and return circuit. | Greater than 5.0-VDC?
 | STEP 2D. Check for an open circuit in the fan control solenoid return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in fan control signal circuit. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2377 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2377 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2377 is inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fan control solenoid and circuit.

Guided Step 2A - Inspect the fan control solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan solenoid from the OEM harness.

Action

Inspect the OEM harness and fan solenoid connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check fan control solenoid resistance.

  • Measure the resistance between the fan control solenoid SIGNAL pin and the fan control solenoid RETURN pin at the fan control solenoid connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

Repair

An open circuit in the fan control solenoid has been detected.

Replace the fan control solenoid. Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the fan control solenoid diagnostic supply voltage, supply line and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.
  • Turn keyswitch ON.

Action

Check the fan control solenoid diagnostic supply voltage and return circuit.

  • Measure the voltage between the fan control solenoid SIGNAL pin and the fan control solenoid RETURN pin at the fan control solenoid connector of the OEM harness.

Greater than 5.0-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the fan control solenoid return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the fan control solenoid RETURN pin in the engine harness and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit on the RETURN wire has been detected. Refer to the OEM wiring diagram for RETURN wire configuration.

If the RETURN is wired to the ECM, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the failed connection.

Clean, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the fan control signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM fan control solenoid SIGNAL pin and the OEM harness fan control solenoid connector fan control solenoid SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open fan control solenoid SIGNAL circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the fan control solenoid SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the fan control solenoid SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2377 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2377 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 24-Apr-2012


FAULT CODE 2381 - Turbocharger Position Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an active fault code. | Fault Code 2381 active?
STEP 2. | Check the turbocharger position sensor and circuit. |
 | STEP 2A. Inspect the turbocharger position sensor and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2381 inactive and Fault Code 2382 active?
 | STEP 2C. Check the turbocharger position sensor supply and return circuit at the harness. | 4.75-VDC to 5.25-VDC?
 | STEP 2D. Check the turbocharger position sensor supply and return circuit at the ECM. | 4.75-VDC to 5.25-VDC?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 2381 inactive and Fault Code 2382 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2381 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Fault Code 386

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2381 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the turbocharger position sensor and circuit.

Guided Step 2A - Inspect the turbocharger position sensor and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger position sensor from the engine harness.

Action

Inspect the engine harness and turbocharger position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2381 inactive and Fault Code 2382 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the turbocharger position sensor supply and return circuit at the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the turbocharger position sensor supply voltage and return circuit at the harness.

  • Measure the voltage between the Turbocharger Position +5 VOLT SUPPLY pin and the Turbocharger Position RETURN pin at the sensor connector of the engine harness.

4.75-VDC to 5.25-VDC?
YES NO

Repair

Replace the turbocharger position sensor. Refer to Procedure 019-405 in Section 19.

No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check the turbocharger position sensor supply and return circuit at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the turbocharger position sensor supply and return circuit at the ECM.

  • Measure the voltage between the Turbocharger Position +5 VOLT SUPPLY pin and the Turbocharge Position RETURN pin at the ECM port.

4.75-VDC to 5.25-VDC?
YES NO

Repair

Repair or replace the engine harness.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2381 inactive and Fault Code 2382 active?
YES NO

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Repair complete

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2381 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 12-Nov-2012


FAULT CODE 2382 - Turbocharger Position Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an active fault code. | Fault Code 2382 active?
STEP 2. | Check the turbocharger position sensor and circuit. |
 | STEP 2A. Inspect the turbocharger position sensor and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 2381 active and Fault Code 2382 inactive?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 2381 active and Fault Code 2382 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2382 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Fault Code 352

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2382 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the turbocharger position sensor and circuit.

Guided Step 2A - Inspect the turbocharger position sensor and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger position sensor from the engine harness.

Action

Inspect the engine harness and turbocharger position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage between the Turbocharger Position +5 VOLT SUPPLY pin and the Turbocharger Position RETURN pin at the sensor connector of the engine harness.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Install a jumper wire between the Turbocharger Position +5 VOLT SUPPLY pin and the Turbocharger position SIGNAL pin at the sensor connector of the engine harness:

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool and read the fault codes.

Fault Code 2381 active and Fault Code 2382 inactive?
YES NO

Repair

Replace the turbocharger position sensor. Refer to Procedure 019-405 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Install a jumper wire between the Turbocharger Position +5 VOLT SUPPLY pin and the Turbocharger Position SIGNAL pin at the ECM port:

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool and read the fault codes.

Fault Code 2381 active and Fault Code 2382 inactive?
YES NO

Repair

Repair or replace the engine harness.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2382 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 12-Nov-2012


FAULT CODE 2383 - Variable Geometry Turbocharger Actuator Circuit - Current Below Normal, or Open Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the turbocharger actuator motor and circuit. |
 | STEP 1A. Inspect the turbocharger actuator motor and harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for an open circuit in the turbocharger actuator motor. | Less than 15 ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2D. Check for a short circuit to an external voltage source. | Less than 1.5-VDC?
 | STEP 2E. Check for an inactive fault code. | Fault Code 2383 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2383 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the turbocharger actuator motor and circuit.

Guided Step 1A - Inspect the turbocharger actuator motor and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger actuator motor from the engine harness.

Action

Inspect the engine harness and the turbocharger actuator motor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector pins.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for an open circuit in the turbocharger actuator motor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger actuator motor from the engine harness.

Action

Check for an open circuit in the turbocharger actuator motor.

  • Measure the resistance between the turbocharger actuator motor SIGNAL (+) pin and the turbocharger actuator motor SIGNAL (-) pin at the turbocharger actuator connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 15 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the turbocharger actuator motor.

Replace the turbocharger. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, 4021271. Refer to Procedure 010-033 in Section 10.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector pins.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger actuator motor from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the turbocharger actuator motor SIGNAL (+) pin at the ECM connector of the engine harness and the turbocharger actuator motor SIGNAL (+) pin at the actuator motor connector of the engine harness.
  • Measure the resistance between the turbocharger actuator motor SIGNAL (-) pin at the ECM connector of the engine harness and the turbocharger actuator motor SIGNAL (-) pin at the actuator motor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger actuator motor from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the turbocharger actuator motor SIGNAL (+) pin and all other pins at the ECM connector of the engine harness.
  • Measure the resistance between the turbocharger actuator motor SIGNAL (-) pin and all other pins at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit to an external voltage source.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger actuator motor from the engine harness.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check for a short circuit to an external voltage source.

  • Measure the voltage between the turbocharger actuator motor SIGNAL (+) pin at the ECM connector of the engine harness and engine block ground.
  • Measure the voltage between the turbocharger actuator motor SIGNAL (-) pin at the ECM connector of the engine harness and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1.5-VDC?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to verify the fault code is inactive

Fault Code 2383 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2383 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Apr-2012


FAULT CODE 2384 (ISB/QSB Automotive and Industrial Application) - VGT Actuator Driver Circuit - Voltage Below Normal, or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the turbocharger actuator motor and circuit. |
 | STEP 1A. Inspect the turbocharger actuator motor and harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit to ground in the turbocharger actuator. | Greater than 100k ohms?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit from pin to pin in the engine harness. | Greater than 100k ohms?
 | STEP 2D. Check for an inactive fault code. | Fault Code 2384 inactive?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2384 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the turbocharger actuator motor and circuit.

Guided Step 1A - Inspect the turbocharger actuator motor and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger actuator motor from the engine harness.

Action

Inspect the engine harness and turbocharger actuator motor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector pins.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for a short circuit to ground in the turbocharger actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger actuator motor from the engine harness.

Action

Check for a short circuit in the turbocharger actuator motor.

  • Measure the resistance between the turbocharger actuator motor SIGNAL (+) pin at the turbocharger actuator motor connector and engine block ground.
  • Measure the resistance between the turbocharger actuator motor SIGNAL (-) pin at the turbocharger actuator motor connector and engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the turbocharger. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 010-033 in Section 10.

Go to 2A

Go to 3A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger actuator motor from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit to ground in the engine harness.

  • Measure the resistance between the turbocharger actuator motor SIGNAL (+) pin at the ECM connector of the engine harness and engine block ground.
  • Measure the resistance between the turbocharger actuator motor SIGNAL (-) pin at the ECM connector of the engine harness and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin to pin in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger actuator motor from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin to pin in the engine harness.

  • Measure the resistance between the turbocharger actuator motor SIGNAL (+) pin and all other pins at the ECM connector of the engine harness.
  • Measure the resistance between the turbocharger actuator motor SIGNAL (-) pin and all other pins at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to verify the fault code is inactive

Fault Code 2384 inactive?
YES NO

Repair

None. The removal and reinstallation of the connector corrected the fault.

Repair

The troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2384 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Apr-2012


FAULT CODE 2384 (ISC/QSC/ISL/QSL Automotive, Industrial, or Marine Application) - VGT Actuator - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2384 active?
STEP 2. | Check the turbocharger control valve circuit. |
 | STEP 2A. Inspect the turbocharger control valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2385 is active and Fault Code 2384 is inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 2384 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 2385 active and Fault Code 2384 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2384 is inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2384 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2384 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the turbocharger control valve circuit.

Guided Step 2A - Inspect the turbocharger control valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger control valve from the engine harness.

Action

Inspect the engine harness and turbocharger control valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the turbocharger control valve connector or the engine harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger control valve from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2385 is active and Fault Code 2384 is inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger control valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2384 is active?
YES NO

Repair

A damaged turbocharger control valve has been detected.

Replace the turbocharger control valve. Refer to Procedure 019-388 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and turbocharger control valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the turbocharger control valve connector or the engine harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2385 active and Fault Code 2384 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the turbocharger control valve from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the turbocharger control valve SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the turbocharger control valve from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the turbocharger control valve SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL line has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2384 is inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

The troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool, to verify that the fault code is inactive.

Fault Code 2384 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Apr-2012


FAULT CODE 2385 (ISB/QSB Automotive or Industrial Application) - VGT Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine harness. |
 | STEP 1A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit to a voltage source. | Less than 1.5 VDC?
 | STEP 1C. Check for a short circuit from pin-to-pin in the engine harness. | Greater than 100k ohms?
 | STEP 1D. Check for an inactive fault code. | Fault Code 2385 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 2385 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine harness.

Guided Step 1A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector pins.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check for a short circuit to a voltage source.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger actuator motor from the engine harness.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check for a short circuit to a voltage source.

  • Measure the voltage between the turbocharger actuator motor SIGNAL (+) pin at the ECM connector of the engine harness and engine block ground.
  • Measure the voltage between the second turbocharger actuator motor SIGNAL (-) pin at the ECM connector of the engine harness and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for Multimeter Usage. Refer to Procedure 019-359 in Section 19.

Less than 1.5-VDC?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1C

Go to 2A

Guided Step 1C - Check for a short circuit from pin-to-pin in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger actuator motor from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit from pin-to-pin in the engine harness.

  • Measure the resistance between the turbocharger actuator motor SIGNAL (+) pin and all other pins at the ECM connector of the engine harness.
  • Measure the resistance between the turbocharger actuator motor SIGNAL (-) pin and all other pins at the ECM connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 1D

Go to 2A

Guided Step 1D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2385 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

The troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2385 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and rechecked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use the INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Apr-2012


FAULT CODE 2385 (ISC/QSC/ISL/QSL Automotive, Industrial, or Marine Application) - VGT Actuator - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2385 active?
STEP 2. | Check the turbocharger control valve and circuit. |
 | STEP 2A. Check the turbocharger control valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the turbocharger control valve diagnostic signal voltage and return circuit. | Greater than 5 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 2384 active and Fault Code 2385 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 2385 is active?
STEP 3. | Check the electronic control module and engine harness. |
 | STEP 3A. Inspect the electronic control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Check the turbocharger control valve diagnostic supply voltage. | Greater than 5-VDC?
 | STEP 3B-1. Check the electronic control module response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2385 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2385 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the turbocharger control valve and circuit.

Guided Step 2A - Inspect the turbocharger control valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger control valve from the engine harness.

Action

Inspect the engine harness turbocharger control valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the turbocharger control valve diagnostic signal voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger control valve from the engine harness.
  • Turn keyswitch ON.

Action

Check the turbocharger control valve diagnostic voltage and return circuit.

  • Measure the diagnostic voltage between the turbocharger control valve SIGNAL pin and the turbocharger control valve RETURN pin at the turbocharger control valve connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 5-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger control valve from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 15 seconds.

  • Place a jumper wire between the turbocharger control valve SIGNAL pin at the turbocharger control valve connector of the engine harness and engine block ground.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2384 active and Fault Code 2385 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger control valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE ™ electronic service tool to read the fault codes.

Fault Code 2385 is active?
YES NO

Repair

A damaged turbocharger control valve has been detected.

Clean, repair or replace the engine harness.

Replace the turbocharger control valve. Refer to Procedure 019-388 in Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the electronic control module and engine harness.

Guided Step 3A - Inspect the electronic control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-2

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the turbocharger control valve diagnostic voltage.

  • Measure the voltage between the turbocharger control valve SIGNAL pin and the turbocharger control valve RETURN pin at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Greater than 5-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2385 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open SIGNAL or RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the electronic control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness, electronic control module, and engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the electronic control module, engine connector, or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the electronic control module response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the turbocharger control valve SIGNAL pin and engine block ground at the electronic control module engine connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2384 active and Fault Code 2385 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2385 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2385 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Apr-2012


FAULT CODE 2386 - Turbocharger Actuator Motor Circuit - Current Above Normal

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2386 active?
STEP 2. | Check the turbocharger actuator motor and circuit. |
 | STEP 2A. Inspect the turbocharger actuator motor and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the turbocharger actuator motor. | Greater than 0.5 ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check the turbocharger actuator motor assembly. (Connected to the turbocharger) |
 | STEP 4A. Perform the INSITE™ electronic service tool Turbocharger Actuator Test. | Actuator position 100 percent when open?
 | STEP 4B. Perform the INSITE™ electronic service tool Turbocharger Actuator Test. | Actuator position less than 10 percent when closed?
STEP 5. | Check the turbocharger actuator motor assembly. (Disconnected from the turbocharger) |
 | STEP 5A. Perform the INSITE™ electronic service tool Turbocharger Actuator Test. | Actuator position 100 percent when open?
 | STEP 5B. Perform the INSITE™ electronic service tool Turbocharger Actuator Test. | Actuator position less than 10 percent when closed?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Disable the fault code. | Fault Code 2386 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2386 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the turbocharger actuator motor and circuit.

Guided Step 2A - Inspect the turbocharger actuator motor and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger actuator motor from the engine harness.

Action

Inspect the engine harness and turbocharger actuator motor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the resistance of the turbocharger actuator motor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger actuator motor from the engine harness.

Action

Check the resistance of the turbocharger actuator motor.

  • Measure the resistance between the turbocharger actuator motor SIGNAL (+) pin and the turbocharger actuator motor SIGNAL (-) pin at the turbocharger actuator motor connector.

Greater than 0.5 ohms?
YES NO
No Repair

Repair

Replace the turbocharger actuator assembly. Refer to Procedure 019-388 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger actuator motor from the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the turbocharger actuator motor SIGNAL (+) pin and the turbocharger actuator motor SIGNAL (-) at the turbocharger actuator motor connector of the engine harness.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the turbocharger actuator motor assembly. (Connected to the turbocharger)

Guided Step 4A - Perform the INSITE™ electronic service tool Turbocharger Actuator Test.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the INSITE™ electronic service tool Turbocharger Actuator Test.

  • Select “Open Actuator”.

Actuator position 100 percent when open?
YES | NO
No Repair | No Repair

Go to 4B

Go to 5A

Guided Step 4B - Perform the INSITE™ electronic service tool Turbocharger Actuator Test.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the INSITE™ electornic service tool Turbocharger Actuator Test.

  • Select “Close Actuator”.

Actuator position less than 10 percent when closed?
YES | NO
No Repair | No Repair

Go to 6A

Go to 5B

Guided Step 5 - Check the turbocharger actuator motor assembly. (Disconnected from the turbocharger)

Guided Step 5A - Perform the INSITE™ electronic service tool Turbocharger Actuator Test.

Conditions

  • Turn keyswitch OFF.
  • Remove the turbocharger actuator motor assembly from the turbocharger.
  • Connect all electrical components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the INSITE™ electronic service tool Turbocharger Actuator Test.

  • Select “Open Actuator”.

Actuator position 100 percent when open?
YES NO

Repair

Replace the turbocharger. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 010-033 in Section 10.

Repair

Replace the turbocharger actuator motor assembly. Refer to Procedure 019-388 in Section 19.

Go to 6A

Go to 6A

Guided Step 5B - Perform the INSITE™ electronic service tool Turbocharger Actuator Test.

Conditions

  • Turn keyswitch OFF.
  • Remove the turbocharger actuator motor assembly from the turbocharger.
  • Connect all electrical components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the INSITE™ electronic service tool Turbocharger Actuator Test.

  • Select “Close Actuator”.

Actuator position less than 10 percent when closed?
YES NO

Repair

Repair or replace the turbocharger. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 010-033 in Section 10.

Repair

Replace the turbocharger actuator motor assembly. Refer to Procedure 019-388 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2386 inactive?
YES | NO
No Repair | No Repair

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Apr-2012


FAULT CODE 2387 - Turbocharger Actuator Motor - Mechanical System Not Responding Properly

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2387 active?
STEP 2. | Check the turbocharger position sensor and circuit. |
 | STEP 2A. Inspect the engine harness and turbocharger position sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the turbocharger position sensor signal for a short circuit. | Greater than 100k ohms?
STEP 3. | Check the engine control module (ECM). |
 | STEP 3A. Check the turbocharger position sensor signal voltage. | Less than 0.1-VDC?
STEP 4. | Check the turbocharger actuator motor assembly. |
 | STEP 4A. Perform INSITE™ electronic service tool Turbocharger Actuator Test. | Actuator position 100 percent when open?
 | STEP 4B. Perform the INSITE™ electronic service tool Turbocharger Actuator Test. | Actuator position less than 10 percent when closed?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 2387 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2387 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the turbocharger position sensor and circuit.

Guided Step 2A - Inspect the engine harness and turbocharger position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the turbocharger position sensor from the engine harness.

Action

Inspect the engine harness and turbocharger position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.
  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if, possible.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the turbocharger position sensor signal for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the turbocharger position sensor from the engine harness.
  • Disconnect the turbocharger speed sensor from the engine harness.
  • Disconnect the barometric pressure sensor from the engine harness.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the turbocharger position +5 volt SUPPLY pin at the ECM connector of the engine harness and all other pins in the connector.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the ECM.

Guided Step 3A - Check the turbocharger position sensor signal voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool to the Society of Automotive Engineers (SAE) J1939 or SAE J1587 data link connector.

Action

Use the INSITE™ electronic service tool Data Logger/Monitor to check the turbocharger position sensor signal voltage.

Less than 0.1-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Repair complete

Guided Step 4 - Check the turbocharger actuator motor assembly.

Guided Step 4A - Perform the INSITE™ electronic service tool Turbocharger Actuator Test.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start INSITE™ electronic service tool Turbocharger Actuator Test.

  • Open the turbocharger actuator.

Actuator position 100 percent when open?
YES NO
No Repair

Repair

Repair or replace the turbocharger. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 010-033 in Section 10.

Go to 4B

Go to 5A

Guided Step 4B - Perform the INSITE™ electronic service tool Turbocharger Actuator Test.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start INSITE™ electonic service tool Turbocharger Actuator Test.

  • Select “Close Actuator”.

Actuator position less than 10 percent when closed?
YES NO
No Repair

Repair

Repair or replace the turbocharger. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 010-033 in Section 10.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2387 inactive?
YES | NO
No Repair | No Repair

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 29-Jun-2017


FAULT CODE 2388 - Variable Geometry Turbocharger Actuator Position Failed Automatic Calibration Procedure - Out of Calibration

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the harness. |
 | STEP 1A. Inspect the electronic control module and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
STEP 2. | Check the turbocharger position sensor. |
 | STEP 2A. Inspect the turbocharger position sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the turbocharger position sensor signal voltage. | Less than 0.1-VDC?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Disable the fault code. | Fault Code 2388 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the harness.

Guided Step 1A - Inspect the electronic control module and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the electronic control module from the engine harness.

Action

Inspect the engine harness and ECM connector pins connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Flush the dirt, debris, or moisture from the connector pins with electrical contact cleaner, Part Number 3824510.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger position sensor from the engine harness.
  • Disconnect the engine harness from the electronic control module.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the turbocharger position SIGNAL pin at the electronic control module connector of the engine harness and all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the turbocharger position sensor.

Guided Step 2A - Inspect the turbocharger position sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger position sensor from the engine harness.

Action

Inspect the engine harness and turbocharger position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the turbocharger position sensor signal voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electronic control module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool to the SAEJ1939 or SAEJ1587/1708 OEM data link connector.

Action

Use the INSITE™ electronic service tool Data Logger/Monitor to check the turbocharger position sensor signal voltage.

–

Less than 0.1-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the turbocharger actuator motor assembly.

Guided Step 3A - Perform INSITE™ electronic service tool turbocharger actuator test.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Start INSITE™ electronic service tool turbocharger actuator test.

  • Open the turbocharger actuator.

Actuator position 100 percent when open?
YES NO
No Repair

Repair

Flush the dirt, debris, or moisture from the connector pins with electrical contact cleaner, Part Number 3824510.

Repair or replace the turbocharger. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 010-033 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Perform the INSITE™ electronic service tool turbocharger actuator test.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start INSITE™ electronic service tool turbocharger actuator test.

  • Select ”Close Actuator”.

Actuator position less than 10 percent when closed?
YES NO
No Repair

Repair

Repair or replace the turbocharger. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 010-033 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2388 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Reference the appropriate troubleshooting steps.

Last Modified: 25-Apr-2012


Coolant Level - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 2448. | Active or inactive counts of Fault Code 2448?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 2448.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 2448?
YES NO

Repair

Add coolant to the engine.

  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual. Refer to Procedure 008-018 in Section 8.
  • Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 Engines, Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 008-018 in Section 8.

If Fault Code 2448 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. Refer to the OEM service manual before replacing the coolant level sensor.

No Repair

Repair complete.

Repair complete

Last Modified: 17-Oct-2011


FAULT CODE 2554 - Exhaust Pressure Sensor Circuit - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for a valid fault code. |
 | STEP 1A. Check for an active Fault Code 2554. | Fault Code 2554 inactive?
 | STEP 1B. Check for condensation or foreign material. | Fault Code 2554 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 2554 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for a valid fault code.

Guided Step 1A - Check for an active Fault Code 2554.

Conditions

  • Turn keyswitch OFF for at least 30 seconds.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for an active fault code.

  • Wait 30 seconds after keyswitch is turned on.

Fault Code 2554 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check for condensation or foreign material.

Conditions

  • Turn keyswitch OFF.

Action

Check for condensation or foreign material.

  • Remove the exhaust pressure sensor, pedestal, and exhaust pressure sensor tube. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 011-027 in Section 11.
  • Check for condensation or foreign material.
  • Clean all removed components.
  • Install removed components.
  • Turn keyswitch ON.
  • Wait 30 seconds after the keyswitch is turned on.

Fault Code 2554 active?
YES NO

Repair

Replace the exhaust pressure sensor. Refer to Procedure 019-376 in Section 19.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON or Run/Stop switch to the Run position.
  • Connect the electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2554 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON or Run/Stop switch to the Run position.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use INISTE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Apr-2012


FAULT CODE 2555 - Intake Air Heater #1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2555 inactive?
STEP 2. | Check the intake air heater relay and circuit. |
 | STEP 2A. Inspect the intake air heater relay and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the intake air heater relay. | Less than 100 ohms?
 | STEP 2C. Check the intake air heater diagnostic voltage, supply line and return circuit. | Greater than 3.75-VDC?
 | STEP 2D. Check for an open circuit in the intake air heater relay return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin to pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2555 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2555 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2555 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake air heater relay and circuit.

Guided Step 2A - Inspect the intake air heater relay and electrical connections.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake air heater relays from the OEM harness.

Action

Inspect the OEM harness and intake air heater relay connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged harness, connector, or pins, if possible.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-071 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the intake air heater relay.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake air heater relays from the OEM harness.

Action

Check the intake air heater relay resistance.

  • Measure the resistance between the intake air heater SIGNAL pin and the intake air heater RETURN pin at the intake air heater relay.

NOTE: For 12-volt systems, both relays should be checked.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 100 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the intake air heater relay.

Replace the intake air heater relay.

Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the intake air heater diagnostic voltage, supply line and return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake air heater relay from the OEM harness
  • Turn keyswitch ON.

Action

Check the intake air heater supply voltage and return circuit.

  • Measure the voltage between the intake air heater relay SIGNAL line and the intake air heater relay RETURN line at the intake air heater relay connector of the OEM harness.

NOTE: For 12-volt systems, both leads should be tested.

Greater than 3.75-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the intake air heater relay return circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the intake air heater relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the intake air heater relay RETURN pin at the intake air heater relay connector to ground.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit on the RETURN wire has been detected. Use the OEM wiring diagram for RETURN wire configuration.

If the RETURN is wired to the ECM, repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

If the RETURN wire is grounded to chassis or engine block ground, repair the source of the damaged connection.

Clean, repair, or replace the OEM harness if possible.

  • Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify the connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or OEM harness connector.

Repair the damaged harness, connector, or pins, if possible.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-071 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM
  • Disconnect the intake air heater relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector intake air heater relay SIGNAL pin and the OEM harness intake air heater relay connector SIGNAL pin.

NOTE: For 12-volt systems, both leads should be tested.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open intake air heater relay SIGNAL circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM
  • Disconnect the intake air heater from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake air heater relay SIGNAL pin in the OEM harness ECM connector and all other pins in the ECM connector.

Use the wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the intake air heater relay SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2555 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2555 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Apr-2012


FAULT CODE 2556 - Intake Air Heater #1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2556 is inactive?
STEP 2. | Check the intake air heater relay and circuit. |
 | STEP 2A. Inspect the intake air heater relay and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2555 is active and Fault Code 2556 is inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 2556 is active?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2556 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2556 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2556 is inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake air heater relay and circuit.

Guided Step 2A - Inspect the intake air heater relay and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air heater relays from the OEM harness.

Action

Inspect the OEM harness and intake air heater relay connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air heater relays from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2555 is active and Fault Code 2556 is inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake air heater relay to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2556 is active?
YES NO

Repair

A damaged intake air heater relay has been detected.

Replace the damaged intake air heater relay. Refer to the OEM service manual.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the intake air heater relay from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the intake air heater relay SIGNAL pin in the OEM harness ECM connector and ground.

NOTE: For 12-volt systems, both leads should be tested.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the intake air heater relay line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the intake air heater relay from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake air heater relay SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the intake air heater SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2556 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2556 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Apr-2012


FAULT CODE 2557 - Auxiliary PWM Driver #1 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2557 inactive?
STEP 2. | Check the transmission shift modulator and circuit. |
 | STEP 2A. Inspect the transmission shift modulator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the transmission shift modulator. | Less than 2.2k ohms?
 | STEP 2C. Check the transmission shift modulator diagnostic supply voltage, supply line and return circuit. | Greater than 5-VDC?
 | STEP 2D. Check for an open circuit in the output device driver return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin to pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2557 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2557 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2557 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the transmission shift modulator and circuit.

Guided Step 2A - Inspect the transmission shift modulator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the transmission shift modulator from the OEM harness.

Action

Inspect the OEM harness and transmission shift modulator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the transmission shift modulator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the transmission shift modulator from the OEM harness.

Action

Check the transmission shift modulator resistance.

  • Measure the resistance between the output device driver SIGNAL pin and the output device driver RETURN pin at the transmission shift modulator connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2.2k ohms?
YES NO
No Repair

Repair

Replace the transmission shift modulator. Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the transmission shift modulator diagnostic supply voltage, supply line and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the transmission shift modulator from the OEM harness.
  • Turn keyswitch ON.

Action

Check the transmission shift modulator diagnostic supply voltage and return circuit.

  • Measure the voltage between the output device driver SIGNAL pin and the output device driver RETURN pin at the transmission shift modulator connector of the OEM harness.

Greater than 5-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the output device driver return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the transmission shift modulator from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the output device driver RETURN pin at the transmission shift modulator connector to ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit on the RETURN wire has been detected. Refer to the OEM wiring diagram for RETURN wire configuration.

If the RETURN is wired to the ECM, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the damaged connection.

Clean and repair, or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the transmission shift modulator from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the output device driver SIGNAL pin at the transmission shift modulator connector and the output device driver SIGNAL pin at the OEM harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit on the output device driver SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the transmission shift modulator from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the output device driver SIGNAL pin in the OEM ECM connector and all other pins in the OEM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the output device driver SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2557 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2557 inactive?
YES NO
No Repair

Repair

Return to the appropriate steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Apr-2012


FAULT CODE 2558 - Auxiliary PWM Driver #1 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2558 is inactive?
STEP 2. | Check the transmission shift modulator and circuit. |
 | STEP 2A. Inspect the transmission shift modulator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the transmission shift modulator. | Less than 2.2k ohms?
 | STEP 2B-1. Check for a short to ground in the transmission shift modulator. |
 | STEP 2C. Check the transmission shift modulator diagnostic supply voltage, supply line and return circuit. | Greater than 5-VDC?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin short circuit to ground. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2558 inactive?
STEP 4. | Clear the fault code. |
 | STEP 4A. Disable the fault code. | Fault Code 2558 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Using INSITE™, read the fault codes.

Fault Code 2558 is inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the transmission shift modulator and circuit.

Guided Step 2A - Inspect the transmission shift modulator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the transmission shift modulator from the OEM harness.

Action

Inspect the OEM harness and transmission shift modulator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the transmission shift modulator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the transmission shift modulator from the OEM harness.

Action

Check the transmission shift modulator resistance.

  • Measure the resistance between the output device driver SIGNAL pin and the output device driver RETURN pin at the transmission shift modulator connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2.2k ohms?
YES NO
No Repair

Repair

Replace the transmission shift modulator.

Refer to the OEM service manual.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a short to ground in the transmission shift modulator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the transmission shift modulator from the OEM harness.

Action

Check for a transmission shift modulator output short to ground.

  • Measure the resistance between the output device driver SIGNAL pin and ground at the transmission shift modulator connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the transmission shift modulator. Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check the transmission shift modulator diagnostic supply voltage, supply line and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the transmission shift modulator from the OEM harness.
  • Turn keyswitch ON.

Action

Check the transmission shift modulator diagnostic supply voltage and return circuit.

  • Measure the voltage between the output device driver SIGNAL pin and output device driver RETURN pin at the transmission shift modulator connector of the OEM harness.

Greater than 5-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the transmission shift modulator from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the output device driver SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the output device driver SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the transmission shift modulator from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the output device driver SIGNAL pin in the OEM ECM connector and all other pins in the OEM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the output device driver SIGNAL line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2558 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2558 inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to erase the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 25-Apr-2012


FAULT CODE 2559 - Transmission ECU to ECM Communication - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 2559 active?
STEP 3. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the data link to the engine ECM and compare to the engine ECM configuration. | ECM multiplexing configuration matches the OEM VECU multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the service data link harness. | 50 to 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM data link harness. | 50 to 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 2559 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with the INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2559 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM VECU and ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

NOTE: Refer to Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration matches the OEM VECU multiplexing configuration?
YES NO

Repair

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

Repair

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the service data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the data link (+) wire and the data link (-) wire on the service data link connector.

Use a wiring diagram for pin identification and use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

Repair

An open or short has been detected on the service data link connector or harness connection to the data link backbone.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection to the Cummins® ECM has been detected in the data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the data link (+) wire and the data link (-) wire on the appropriate Cummins® ECM OEM connection to the data link harness connector.

Use a wiring diagram for pin identification and use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

Repair

An open or short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the data link (+) wire and the data link (-) wire on the Cummins® ECM OEM connection to all other pins in the OEM connector.

NOTE: Disregard any resistance between 50 and 70 ohms between the data link (+) and the data link (-) pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2559 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A communication issue between the ECM and the data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

The appropriate ECM No Communication symptom tree

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Mar-2014


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault code 2659. | Active or inactive counts of Fault Code 2659?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault code 2659.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault code 2659.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 2659?
YES NO

Repair

Refer to the Coolant Temperature Above Normal symptom tree.

 No Repair

Appropriate symptom tree in the Service Manual, ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Series Engines, Bulletin 4021271

Repair complete

Last Modified: 08-Jul-2010


FAULT CODE 2771 - Aftertreatment Outlet NOx Sensor - Abnormal Update Rate

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes | Fault Code 2771 inactive?
STEP 2. | Check the aftertreatment outlet Mono-Nitrogen Oxides (NOx) sensor circuit. |
 | STEP 2A. Inspect the aftertreatment outlet NOx sensor body and condition of the aftertreatment outlet NOx sensor harness. | Any external damage to the sensor body, head (component installed on the exhaust gas processor) or harness?
 | STEP 2B. Inspect the aftertreatment outlet NOx sensor and connector pins. | Damaged or dirty pins?
 | STEP 2C. Check the voltage to the aftertreatment outlet NOx sensor. | Voltage within 1 - volt of direct current (VDC) of battery voltage?
 | STEP 2D. Check for correct adjustable parameter settings. | Electrical system voltage parameter correct for the engine control parts list (CPL)?
 | STEP 2E. Check for correct aftertreatment outlet NOx sensor. | Aftertreatment outlet NOx sensor the correct sensor for the engine CPL?
STEP 3. | Check the original equipment manufacturer (OEM) harness battery power circuit. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Verify that the OEM fuse is installed correctly. | Is the fuse installed correctly, or has it been replaced?
 | STEP 3C. Check for an open circuit in the battery power circuit. | Voltage is within 1-VDC of battery voltage?
STEP 4. | Check the OEM harness |
 | STEP 4A. Inspect the ECM and OEM harness connector pins. | Damaged or dirty pins?
 | STEP 4B. Check for an open circuit in the J1939 data link harness. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit in the J1939 data link harness. | Voltage is within 1-VDC of battery voltage?
 | STEP 4D. Check for a short circuit to ground in the J1939 data link harness. | Greater than 100k ohms?
 | STEP 4E. Check the J1939 terminating resistance. | 50 to 70 ohms?
 | STEP 4F. Check the fault codes. | Fault Code 2771 active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2771 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment outlet Mono-Nitrogen Oxides (NOx) sensor circuit.

Guided Step 2A - Inspect the aftertreatment outlet NOx sensor body and condition of the aftertreatment outlet NOx sensor harness.

Conditions

  • Turn keyswitch OFF.

Action

Check the aftertreatment outlet NOx sensor body, and the aftertreatment outlet NOx sensor harness.

  • Inspect the aftertreatment outlet NOx sensor body and aftertreatment outlet NOx sensor harness for cracks or damage.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Any external damage to the sensor body, head (component installed on the exhaust gas processor) or harness?
YES NO

Repair

Replace the NOx sensor. Refer to Procedure 019-451 in the Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the aftertreatment outlet NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment outlet NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the voltage to the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment outlet NOx sensor.

  • Measure the voltage between the aftertreatment outlet NOx sensor battery voltage supply circuit and the aftertreatment outlet NOx sensor return circuit at the NOx sensor wiring harness connector.

Note: Check the voltage at key-ON, while cranking the engine, and with the engine at idle.

Note: 24-VDC NOx sensors will operate between 14 and 32-VDC. 12-VDC NOx sensors will operate between 6 and 16.5-VDC.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for instructions on how to use a multimeter. Refer to Procedure 019-359 in Section 19.

Voltage within 1 - volt of direct current (VDC) of battery voltage?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check for corrrect adjustable parameter settings

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the electrical system voltage setting in INSITE™ electronic service tool is correct for the engine CPL.

Electrical system voltage parameter correct for the engine control parts list (CPL)?
YES NO
No Repair

Repair

To configure the electrical system voltage to match the engine CPL, use INSITE™ electronic service tool.

Go to 2E

Go to 4A

Guided Step 2E - Check for correct aftertreatment outlet NOx sensor

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment outlet NOx sensor.

Action

Verify aftertreatment outlet NOx sensor is the correct sensor for the engine CPL.

Note: The aftertreatment outlet NOx sensor is available in 12-VDC or 24-VDC versions.

Aftertreatment outlet NOx sensor the correct sensor for the engine CPL?
YES NO
No Repair

Repair

Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the original equipment manufacturer (OEM) harness battery power circuit.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Section 19.

Repair

Tighten the connections.

Tighten the loose connections, and clean the terminals.

Refer to the OEM service manual.

Go to 3B

Go to 4A

Guided Step 3B - Verify that the OEM fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

The aftertreatment outlet NOx sensor power supply wire contains a 20 amperes fuse. This fuse is located in the OEM harness.

  • Inspect the OEM fuse for correct installation, or for a blown fuse.

Is the fuse installed correctly, or has it been replaced?
YES NO
No Repair

Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Check for an open circuit in the battery power circuits.

  • Use a multimeter to measure the voltage from the aftertreatment outlet NOx sensor SUPPLY (+) pin of the OEM harness to engine block ground.

Refer to the wiring diagram or the circuit diagram for connector pin identification.

Note: 24-VDC NOx sensors will operate between 14 and 32-VDC. 12-VDC NOx sensors will operate between 6 and 16.5-VDC.

Voltage is within 1-VDC of battery voltage?
YES NO

Repair

An open circuit in the OEM battery return circuit from the aftertreatment outlet NOx sensor has been detected.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair

An open circuit in the OEM battery supply circuit from the aftertreatment outlet NOx sensor has been detected.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the OEM harness

Guided Step 4A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open circuit in the J1939 data link harness.

  • Measure the resistance between the Society of Automotive Engineers (SAE) J1939 data link (+) wire at the aftertreatment outlet NOx sensor OEM harness connector and the SAE J1939 data link (+) wire at the ECM OEM harness connector.
  • Measure the resistance between the SAE J1939 data link (−) wire at the aftertreatment outlet NOx sensor OEM harness connector and the SAE J1939 data link (−) wire at the ECM OEM harness connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the J1939 data link harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM OEM harness connector and all other pins in the connector.
  • Measure the resistance between the SAE J1939 data link (−) wire at the ECM OEM harness connector and all other pins in the connector.

Note: Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (−) pins.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

An short circuit has been detected in the J1939 data link harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit to ground in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a short circuit to ground in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM OEM harness connector and ground.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM OEM harness connector and ground.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

An short circuit to ground has been detected in the J1939 data link harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4E

Go to 5A

Guided Step 4E - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Measure the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire at the aftertreatment outlet NOx sensor OEM harness connector.

50 to 70 ohms?
YES NO
No Repair

Repair

Incorrect terminating resistance has been detected in the OEM harness.

Repair or replace the terminating resistor in the OEM harness. Refer to the OEM service manual.

Go to 4F

Go to 5A

Guided Step 4F - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the OEM harness to the ECM connector.
  • Connect the aftertreatment outlet NOx sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2771 active?
YES NO

Repair

Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Section 19.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Oct-2012


FAULT CODE 2772 - Aftertreatment Outlet NOx - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Perform basic troubleshooting procedures. |
 | STEP 1A. Check for active counts of Fault Code 1694. | Fault Code 1694 active?
 | STEP 1B. Check for inactive counts of Fault Code 1682, 3548, 3569, 3575, or 3738. | Recent inactive counts of Fault Code 1682, 3548, 3569, 3575, or 3738 present that have not been addressed?
STEP 2. | Check the aftertreatment catalyst system. |
 | STEP 2A. Inspect the aftertreatment catalyst system for external leaks. | External leaks detected in the system?
 | STEP 2B. Check the exhaust pressure. | Exhaust back pressure exceeds the limits provided in Procedure 011-009?
 | STEP 2C. Inspect the aftertreatment nozzle. | Plugged or restricted aftertreatment nozzle detected?
STEP 3. | Verify the priming cycle of the diesel exhaust fluid (DEF) dosing unit. |
 | STEP 3A. Check the DEF dosing unit during priming. | Dosing unit only primes for 3 seconds (plus the 140 second prime delay, if applicable)?
 | STEP 3B. Check the sir solenoid operation during priming. | Does the air solenoid click and exhaust air down the aftertreatment nozzle line continuously after 30 seconds (will attempt to prime up to 20 times)?
 | STEP 3C. Confirm the successful priming of the DEF dosing unit. | Air flow above 25 liters per minute [6.6 gallons per minute]?
STEP 4. | Check the DEF dosing unit air supply system. |
 | STEP 4A. Inspect the air supply lines to the DEF dosing unit. | Original equipment manufacturer (OEM) air supply correctly attached to the DEF dosing unit and supplying adequate air pressure?
 | STEP 4B. Check the DEF dosing unit. | Flushing procedure successful?
STEP 5. | Check the DEF lines and fittings for restriction and contamination. |
 | STEP 5A. Check the DEF dosing unit fittings and lines. | DEF fittings and lines pass the inspections?
 | STEP 5B. Check the DEF dosing unit intake restriction. | Restriction line test completed successfully?
 | STEP 5C. Inspect the DEF tank and the DEF filter. | DEF tank or DEF filter contaminated?
STEP 6. | Perform the DEF Doser Pump Override Test. |
 | STEP 6A. Perform the DEF Doser Pump Override Test with INSITE™ electronic service tool. | Dosing control unit operates correctly during INSITE™ electronic service tool override test (it is recommended to complete this test 3 times)?
 | STEP 6B. Inspect the DEF dosing unit inline screen filter connection. | Contamination present at the screen filter?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Inspect the fault codes.

Guided Step 1A - Check for active counts of Fault Code 1694.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

The following items must be checked or verified before continuing:

  • Check for active Fault Code 1694.

Fault Code 1694 active?
YES NO

Repair

Troubleshoot Fault Code 1694 before returning to this troubleshooting tree.

No Repair

Fault Code 1694 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for inactive counts of Fault Code 1682, 3548, 3569, 3575, or 3738.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to check for inactive counts of Fault Code 1682, 3548, 3569, 3575 or 3738 in the ECM.

  • Look specifically for one or more inactive counts of Fault Code 1682, 3548, 3569, 3575 or 3738 within 50 engine hours of this fault code being set.

Recent inactive counts of Fault Code 1682, 3548, 3569, 3575, or 3738 present that have not been addressed?

YES NO

Repair

Troubleshooting Fault Code 1682, 3548, 3569, 3575, or 3738 before returning to this fault code troubleshooting tree.

 No Repair

Fault Code 1682, 3548, 3569, 3575 or 3738 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment catalyst system.

Guided Step 2A - Inspect the aftertreatment catalyst system for external leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the aftertreatment catalyst system.

  • Inspect aftertreatment catalyst and all attached exhaust pipework for signs of exhaust gas leakage or damage.

External leaks detected in the system?
YES NO

Repair

Repair the source of the external leak.

 No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the exhaust back pressure.

Conditions

  • Turn keyswitch OFF.

Action

Measure the exhaust back pressure.

  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual. Refer to Procedure 011-009 in Section 11.

Exhaust back pressure exceeds the limits provided in Procedure 011-009?
YES NO

Repair

Repair source or replace the aftertreatment SCR catalyst.

  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual. Refer to Procedure 011-036 in Section 11.
No Repair

Go to 7A

Go to 2C

Guided Step 2C - Inspect the aftertreatment nozzle.

Conditions

  • Make sure the nozzle has been warmed in the exhaust prior to removal. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual. Refer to Procedure 011-040 in Section 11.
  • Turn keyswitch OFF.
  • Remove the aftertreatment nozzle. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual. Refer to Procedure 011-040 in Section 11.

Action

Inspect the aftertreatment nozzle for blockage or restrictions.

  • Inspect the aftertreatment nozzle. Inspect the aftertreatment nozzle. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual. Refer to Procedure 011-040 in Section 11.
  • Soft crystal and ash-like buildup in the spray holes can be dissolved with 40°C [104°F] warm water.
  • Make sure that the soft buildup in the spray holes clears when the dosing unit begins dosing.

Plugged or restricted aftertreatment nozzle detected?
YES NO

Repair

Clean or replace the aftertreatment nozzle.

Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual. Refer to Procedure 011-040 in Section 11.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Verify the priming cycle of the DEF dosing unit.

Guided Step 3A - Check the DEF dosing unit during priming.

Conditions

  • Disconnect the DEF line from the aftertreatment nozzle and secure it appropriately.
  • Leave the aftertreatment nozzle installed.
  • Turn keyswitch ON.
  • Start the engine and operate at low idle.
  • Connect INSITE™ electronic service tool.

Action

Check the DEF dosing unit during priming.

  • After key ON with the engine operating, listen for the DEF dosing pump to start.
  • Time the pump operation until the pump automatically switches off (the pump is attempting to prime).

While the engine is operating, it may be difficult to hear the pump. If this is the case, listen for the air solenoid to click, indicating that the pump has completed 1 prime attempt.

Older calibrations did not incorporate the 140 second delay from key ON to initial prime cycle. During the 140 second delay, the dosing unit will remain on standby before receiving the command to prime. This was introduced to remove any crystallization buildup on the injection tip prior to priming cycle and to avoid any blocked injection lines.

A correct prime cycle is as follows:

1. Key ON

2. 140 second pump start delay

3. Pump starts and operates for 30 seconds. (The system is now priming, this step may be attempted up to 20 times.)

4. The DEF injection line will now exhaust air. Priming is now complete.

Dosing unit only primes for 3 seconds (plus the 140 second prime delay, if applicable)?

YES NO

Repair

Complete line restriction testing procedure then prime again. Use the following procedure for ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 1 or ISC, ISCe, QSC8.3, ISL, ISLe3, and QSL9 engines. Refer to Procedure 011-086 in Section 11.

No Repair

Go to 3A

Go to 3B

Guided Step 3B - Check the air solenoid operation during priming.

Conditions

  • Disconnect the DEF line from the aftertreatment nozzle and secure it appropriately.
  • Leave the aftertreatment nozzle installed.
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Make sure that the DEF dosing unit has successfully primed and entered the dosing state.

  • The DEF dosing unit enters the dosing state only when a successful prime is completed, and the air solenoid has clicked.
  • At this point, air will be flowing continuously down the aftertreatment nozzle line.
  • The DEF dosing unit could attempt to prime for up to 12 minutes, at which point, if a prime is successful, the pump will switch off.
  • Use INSITE™ electronic service tool Data/Monitor Logger for Aftertreatment DEF Dosing Unit State to confirm the doser status.

Does the air solenoid click and exhaust air down the aftertreatment nozzle line continuously after 30 seconds (will attempt to prime up to 20 times)?

YES NO
No Repair

Repair

The DEF dosing unit has not primed.

Go to 3C

Go to 5A

Guided Step 3C - Confirm the successful priming of the DEF dosing unit.

Conditions

  • Turn keyswitch OFF for a minimum of 1 minute.
  • Disconnect the DEF line from the aftertreatment nozzle.
  • Attach the air flow meter to the DEF dosing line. Use the following procedure for ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 1 or ISC, ISCe, QSC8.3, ISL, ISLe3, and QSL9 engines. Refer to Procedure 011-058 in Section 11.
  • Secure the DEF dosing line and the attached air flow meter.
  • Start the engine and operate at low idle.
  • Connect INSITE™ electronic service tool.

Action

The DEF dosing unit should start the priming cycle immediately after the prime delay when the engine is started. After 30 seconds (each prime attempt will take 30 seconds, if not successful the doser will attempt to prime up to 20 times) air should continuously flow through the DEF Injection line, and the attached air flow meter.

  • Record the measured air flow from the DEF dosing line.

Air flow above 25 liters per minute [6.6 gallons per minute]?
YES NO

Repair

Clean or replace the aftertreatment nozzle.

 No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check the DEF dosing unit air supply system.

Guided Step 4A - Inspect the air supply lines to the DEF dosing unit.

Conditions

  • Turn keyswitch ON.
  • Start the engine.
  • Operate the engine at low idle.

Action

Inspect the OEM air supply line attached to the DEF dosing unit.

  • Check for leaks or loose connections in the air supply line.
  • Check the DEF dosing unit air filter for water or excessive oil from the vehicle's compressed air system.
  • Make sure a clean supply of air, at least 517 kPa [75 psi], pressure is present at the DEF dosing unit.

Most vehicles are equipped with an inline air filter in the air line prior to the DEF dosing unit. A plugged or restricted inline air filter can cause low air pressure to the DEF dosing unit.

OEM air supply correctly attached to the DEF dosing unit and supplying adequate air pressure?
YES NO
No Repair

Repair

Correct the OEM air supply connection or supply. See equipment manufacturer service information.

Go to 4B

Go to 3A

Guided Step 4B - Check the DEF dosing unit.

Conditions

  • Drain or isolate the OEM air supply circuit.
  • Remove the OEM air supply hose.

Action

Carry out the DEF dosing unit flushing procedure.

  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual. Refer to Procedure 011-082 in Section 11.
  • Most vehicles are equipped with an inline air filter in the air line prior to the DEF dosing unit. A plugged or restricted inline air filter can cause low air pressure to the DEF dosing unit.

Flushing procedure successful?
YES NO
No Repair

Repair

Replace the DEF dosing unit.

Go to 5A

Go to 7A

Guided Step 5 - Check the DEF lines and fittings for restriction and contamination.

Guided Step 5A - Check the DEF dosing unit fittings and lines.

Conditions

  • Clean the front face of the doser before removing any lines.
  • Disconnect the DEF line from the aftertreatment nozzle and secure appropriately.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Inspect the DEF dosing unit fittings and lines for the following:

Clean the front face of the aftertreatment dosing unit and lines with warm water or mild detergent before removing any line. This is to prevent any contamination due to service intervention.

  • Loose DEF inlet connectors or fittings.
  • Cracked DEF lines, resulting in leaks or drawing in air.
  • Make sure DEF is returning to the tank during the priming cycle.

DEF fittings and lines pass the inspections?
YES NO
No Repair

Repair

Repair or replace DEF lines and/or connectors. See equipment manufacturer service information.

Go to 5B

Go to 3B

Guided Step 5B - Check the DEF dosing unit intake restriction.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF dosing unit restriction.

  • Refer to Procedure 011-086 in Section 11.

Restriction line test completed successfully?
YES NO
No Repair

Repair

Clean or replace the DEF tank filter, DEF tank vent filter, and DEF suction line, as necessary.

Drain the DEF tank. Flush with distilled water. Fill the DEF tank with clean, certified DEF.

See equipment manufacturer service information.

Go to 5C

Go to 6A

Guided Step 5C - Inspect the DEF tank and the DEF filter.

Conditions

  • Turn keyswitch OFF.
  • Do not operate the engine.

Action

Inspect the DEF tank and filters for fuel, oil, coolant, dirt, and debris.

For an in-tank DEF filter, use the following procedure. Refer to Procedure 011-083 in Section 11.

For an inline DEF filter, see equipment manufacturer service information.

See equipment manufacturer service information for removal/installation procedures for the DEF tank and DEF tank level sensor assembly.

In some cases the DEF tank is bonded to the vehicle chassis leaving no access to DEF tank level sensor assembly. If this is the case then contact the OEM to arrange for the tank to be removed and inspected.

  • Some OEMs use an inline DEF filter instead of a DEF tank filter.

DEF tank or DEF filter contaminated?

YES NO

Repair

Locate and remove source. Notify the OEM. If required replace components and connectors. Drain/refill the DEF tank. See equipment manufacturer service information.

No Repair

Go to 6A

Go to 6A

Guided Step 6 - Perform the DEF Doser Pump Override Test.

Guided Step 6A - Perform the DEF Dosing Pump Override Test with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the DEF Doser Pump Override Test, under Aftertreatment Diagnostics Tests.

  • Use the following procedure for instructions and specifications. Refer to Procedure 019-440 in Section 19.
  • Check to make sure that the DEF is being injected through the aftertreatment nozzle during the dosing state.

NOTE: The aftertreatment nozzle must have been warmed in the exhaust before removing and placing it in a measuring container greater than 200 ml [6.8 oz] capacity to perform the DEF Doser Pump Override Test.

The troubleshooting tree must be followed completely before completing this test.

Dosing control unit operates correctly during INSITE™ electronic service tool override test? (It is recommended to complete this test 3 times)

YES | NO
No Repair | No Repair

Go to 7A

Go to 6B

Guided Step 6B - Inspect the DEF dosing unit inline screen filter connection.

Conditions

  • Clean the front face of the doser before removing any lines.
  • Disconnect the DEF supply line from the dosing unit and secure appropriately.

Action

Inspect the DEF dosing unit inline screen filter connection.

  • Remove the DEF dosing unit supply line.
  • Inspect the inlet screen filter. Use the following procedure for ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 1 or ISC, ISCe, QSC8.3, ISL, ISLe3, and QSL9 engines. Refer to Procedure 011-060 in Section 11.

NOTE: Clean the front face of the aftertreatment dosing unit and lines with warm water or mild detergent before removing any lines. This is to prevent any contamination due to service intervention.

Use the following procedure to identify the different connections on the DEF dosing unit. Refer to Procedure 019-440 in Section 19.

Contamination present at the screen filter?
YES NO

Repair

Replace the screen filter. Use the following procedure for ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 1 or ISC, ISCe, QSC8.3, ISL, ISLe3, and QSL9 engines. Refer to Procedure 011-060 in Section 11.

Repair

A damaged DEF dosing unit has been detected. Replace the DEF dosing unit.

  • Refer to Procedure 019-440 in Section 19.

Go to 6A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Mar-2018


FAULT CODE 2773 - Aftertreatment Outlet NOx - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Inspect the fault codes. |
 | STEP 1A. Check for active counts of Fault Code 1694. | Fault Code 1694 active?
 | STEP 1B. Check for inactive counts of Fault Code 1682, 3548, 3569, 3575, or 3738. | Recent inactive counts of Fault Code 1682, 3548, 3569, 3575, or 3738 present that have not been addressed?
 | STEP 1C. Check the remaining active/inactive fault codes. | Active fault codes or performance complaints present? (With the exception of Fault Code 2772.)
STEP 2. | Check the aftertreatment catalyst system. |
 | STEP 2A. Inspect the aftertreatment catalyst system for external leaks. | External leaks detected in the system?
 | STEP 2B. Check the exhaust back pressure. | Exhaust back pressure exceeds the limits provided in Procedure 011-009?
 | STEP 2C. Check the aftertreatment selective catalytic reduction (SCR) catalyst. | SCR catalyst present, not damaged, and not found to be broken up?
 | STEP 2D. Inspect the aftertreatment nozzle. | Plugged or restricted aftertreatment nozzle detected?
STEP 3. | Verify the priming cycle of the diesel exhaust fluid (DEF) dosing unit. |
 | STEP 3A. Check the DEF dosing unit during priming. | Dosing unit only primes for 3 seconds? (Plus the 140 second prime delay, if applicable.)
 | STEP 3B. Check the air solenoid operation during priming. | Air solenoid click and exhaust air down the aftertreatment nozzle line continuously after 30 seconds? (Will attempt to prime up to 20 times.)
 | STEP 3C. Confirm the successful priming of the DEF dosing unit. | Air flow above 25 liters per minute [6.6 gallons per minute]?
STEP 4. | Check the DEF dosing unit air supply system. |
 | STEP 4A. Inspect the air supply lines to the DEF dosing unit. | Original equipment manufacturer (OEM) air supply correctly attached to the DEF dosing unit and supplying adequate air pressure?
 | STEP 4B. Clear the DEF dosing unit air side circuit and carry out the flushing procedure. | Flushing procedure successful?
STEP 5. | Check the DEF lines and DEF filter for restriction and leaks. |
 | STEP 5A. Check the DEF dosing unit fittings and lines. | DEF fittings and lines pass the inspections?
 | STEP 5B. Inspect the DEF dosing unit inline screen filter connection. | Contamination present at the screen filter?
 | STEP 5C. Inspect the DEF tank and filter. | DEF tank or filter contaminated?
STEP 6. | Perform the DEF Doser Pump Override Test. |
 | STEP 6A. Perform the DEF Dosing Pump Override Test with INSITE™ electronic service tool. | Dosing control unit operates correctly during INSITE™ electronic service tool override test? (It is recommended to complete this test three times.)
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Inspect the fault codes.

Guided Step 1A - Check for active counts of Fault Code 1694.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

The following items must be checked or verified before continuing:

  • Check for active counts of Fault Code 1694.

Fault Code 1694 active?
YES NO

Repair

Troubleshoot Fault Code 1694 before returning to this troubleshooting tree.

No Repair

Fault Code 1694 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for inactive counts of Fault Code 1682, 3548, 3569, 3575, or 3738.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to check for inactive counts of Fault Code 1682, 3548, 3569, 3575, or 3738 in the ECM.

  • Look specifically for one or more inactive counts of Fault Code 1682, 3548, 3569, 3575, or 3738 within 50 engine hours of this fault code being set.

Recent inactive counts of Fault Code 1682, 3548, 3569, 3575, or 3738 present that have not been addressed?

YES NO

Repair

Troubleshoot Fault Code 1682, 3548, 3569, 3575, or 3738 before returning to this fault code troubleshooting tree.

 No Repair

Fault Code 1682, 3548, 3569, 3575, or 3738 troubleshooting tree.

Go to 1C

Guided Step 1C - Check the remaining active/inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Troubleshoot any other active fault codes first.
  • All other active fault codes except Fault Code 2772 must be resolved before following this troubleshooting tree.
  • Check for performance complaints
  • Troubleshoot any performance complaints related to smoke or misfire first.

Fault Code 2773 is caused by the same symptoms as Fault Code 2772, but at a more severe level. Therefore, if both fault codes are active, Fault Code 2773 should always be addressed first.

Active fault codes or performance complaints present? (With the exception of Fault Code 2772.)
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment catalyst system.

Guided Step 2A - Inspect the aftertreatment catalyst system for external leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the aftertreatment catalyst system.

  • Inspect the aftertreatment catalyst and all attached exhaust pipe work for signs of exhaust gas leakage or damage.

External leaks detected in the system?
YES NO

Repair

Repair the source of the external leak.

 No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the exhaust back pressure.

Conditions

  • Turn keyswitch OFF.

Action

Measure the exhaust back pressure.

  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 011-009 in Section 11.

Exhaust back pressure exceeds the limits provided in Procedure 011-009?
YES NO

Repair

Repair source or replace the aftertreatment SCR catalyst.

  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 011-036 in Section 11.
No Repair

Go to 7A

Go to 2C

Guided Step 2C - Check the aftertreatment SCR catalyst.

Conditions

  • Turn keyswitch OFF.

Action

Make sure that the SCR catalyst is present in the exhaust stream.

Remove the aftertreatment SCR catalyst.

  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 011-036 in Section 11.

Inspect the aftertreatment SCR catalyst. If the aftertreatment SCR catalyst has broken up, then a significant mass of broken material will move around inside the assembly when the catalyst is tilted or moved.

SCR catalyst present, not damaged, and not found to be broken up?

YES NO
No Repair

Repair

Replace the aftertreatment SCR catalyst.

  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 011-036 in Section 11.

Go to 2D

Go to 7A

Guided Step 2D - Inspect the aftertreatment nozzle.

Conditions

  • Make sure the nozzle has been warmed in the exhaust prior to removal. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 011-040 in Section 11.
  • Turn keyswitch OFF.
  • Remove the aftertreatment nozzle. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 011-040 in Section 11.

Action

Inspect the aftertreatment nozzle for blockage or restrictions.

  • Inspect the aftertreatment nozzle. Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 011-040 in Section 11.
  • Soft crystal and ash-like buildup in the spray holes can be dissolved with 40°C [104°F] warm water.
  • Make sure the soft buildup in the spray holes clears when the dosing unit begins dosing.

Plugged or restricted aftertreatment nozzle detected?
YES NO

Repair

Clean or replace the aftertreatment nozzle.

Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 011-040 in Section 11.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Verify the priming cycle of the DEF dosing unit.

Guided Step 3A - Check the diesel exhaust fluid dosing unit during priming.

Conditions

  • Disconnect the DEF line from the aftertreatment nozzle and secure it appropriately.
  • Leave the aftertreatment nozzle installed.
  • Turn keyswitch ON.
  • Start the engine and operate at low idle
  • Connect INSITE™ electronic service tool.

Action

The following items must be checked or verified before continuing:

  • After key ON with the engine operating, listen for the DEF dosing pump to start.
  • Time the pump operation until the pump automatically switches off (the pump is attempting to prime).

While the engine is operating it may be difficult to hear the pump. If this is the case, listen for the air solenoid to click, indicating that the pump has completed one prime attempt.

Older calibrations did not incorporate the 140 second delay from key on to initial prime cycle. During the 140 second delay the dosing unit will remain on standby before receiving the command to prime. This was introduced to remove any crystallization building up on the injection tip prior to priming cycle and to avoid any blocked injection lines.

A correct prime cycle is as follows:

1. Key ON

2. 140 second pump start delay

3. Pump starts and operates for 30 seconds. (The system is now priming, this step may be attempted up to 20 times).

4. The DEF injection line will now exhaust air. Priming is now complete.

Dosing unit only primes for 3 seconds? (Plus the 140 second prime delay, if applicable.)

YES NO

Repair

Complete line restriction testing procedure then prime again. Use the following procedure for ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 1 or ISC, ISCe, QSC8.3, ISL, ISLe3, and QSL9 engines. Refer to Procedure 011-086 in Section 11.

No Repair

Go to 3A

Go to 3B

Guided Step 3B - Check the air solenoid operation during priming.

Conditions

  • Disconnect the DEF line from the aftertreatment nozzle and secure it appropriately.
  • Leave the aftertreatment nozzle installed.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Make sure the DEF dosing unit has successfully primed and entered the dosing state.

  • The DEF dosing unit enters the dosing state only when a successful prime is has completed, and the air solenoid has clicked.
  • At this point, air will be flowing continuously down the aftertreatment nozzle line.
  • The DEF dosing unit could attempt to prime for up to 12 minutes, at which point, if a prime is successful, the pump will switch off.
  • Use INSITE™ electronic service tool Data/Monitor Logger for Aftertreatment Diesel Exhaust Fluid Dosing Unit State to confirm the doser status.

Air solenoid click and exhaust air down the aftertreatment nozzle line continuously after 30 seconds? (Will attempt to prime up to 20 times.)

YES NO
No Repair

Repair

The DEF dosing unit has not primed.

Go to 3C

Go to 5A

Guided Step 3C - Confirm the successful priming of the DEF dosing unit.

Conditions

  • Turn keyswitch OFF for a minimum of 1 minute.
  • Disconnect the DEF line from the aftertreatment nozzle.
  • Attach the air flow meter to the DEF dosing line. Use the following procedure for ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 1 or ISC, ISCe, QSC8.3, ISL, ISLe3, and QSL9 engines. Refer to Procedure 011-058 in Section 11.
  • Secure the DEF dosing line and the attached air flow meter.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

The DEF dosing unit should start the priming cycle immediately after the prime delay when the engine is started. After 30 seconds (each prime attempt will take 30 seconds, if not successful the doser will attempt to prime up to 20 times) air should continuously flow through the DEF injection line, and the attached air flow meter.

  • Record the measured air flow from the DEF dosing line.

Air flow above 25 liters per minute [6.6 gallons per minute]?
YES | NO
No Repair | No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check the DEF dosing unit air supply system.

Guided Step 4A - Inspect the air supply lines to the DEF dosing unit.

Conditions

  • Turn keyswitch ON.
  • Start the engine.
  • Operate the engine at low idle.

Action

Inspect the OEM air supply line attached to the DEF dosing unit.

  • Check for leaks or loose connections in the air supply line.
  • Check the DEF dosing unit air filter for water or excessive oil from the vehicle's compressed air system.
  • Make sure a clean supply of air, at least 517 kPa [75 psi], pressure is present at the DEF dosing unit.

Most vehicles are equipped with an inline air filter in the air line prior to the DEF dosing unit. A plugged or restricted inline air filter can cause low air pressure to the DEF dosing unit.

OEM air supply correctly attached to the DEF dosing unit and supplying adequate air pressure?
YES NO
No Repair

Repair

Correct the OEM air supply connection or supply. See equipment manufacturer service information.

Go to 4B

Go to 3A

Guided Step 4B - Clear the DEF dosing unit air side circuit and carry out the flushing procedure.

Conditions

  • Drain or isolate the OEM air supply circuit.
  • Remove the OEM air supply hose.

Action

Carry out the DEF dosing unit flushing procedure.

  • Use the following procedure in the ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) Service Manual, Bulletin 4021271. Refer to Procedure 011-082 in Section 11.
  • Most vehicles are equipped with an inline air filter in the air line prior to the DEF dosing unit. A plugged or restricted inline air filter can cause low air pressure to the DEF dosing unit.

Flushing procedure successful?
YES NO
No Repair

Repair

Replace the DEF dosing unit.

Go to 5A

Go to 7A

Guided Step 5 - Check the DEF lines and filter for contamination.

Guided Step 5A - Check the DEF dosing unit fittings and lines.

Conditions

  • Clean the front face of the doser before removing any lines.
  • Disconnect the DEF line from the aftertreatment nozzle and secure appropriately.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Inspect the DEF dosing unit fittings and lines for the following:

Clean the front face of the aftertreatment dosing unit and lines with warm water or mild detergent before removing any line. This is to prevent any contamination due to service intervention.

  • Loose DEF inlet connectors or fittings
  • Cracked DEF lines, resulting in leaks or drawing in air
  • Be sure DEF is returning to the tank during the priming cycle.

DEF fittings and lines pass the inspections?
YES NO
No Repair

Repair

Repair or replace DEF lines and/or connectors. See equipment manufacturer service information.

Go to 5B

Go to 3B

Guided Step 5B - Inspect the DEF dosing unit inline screen filter connection.

Conditions

  • Clean the front face of the doser before removing any lines.
  • Disconnect the DEF supply line from the dosing unit and secure appropriately.

Action

Inspect the DEF dosing unit inline screen filter connection.

  • Remove the DEF dosing unit supply line.
  • Inspect the inlet screen filter. Use the following procedure for ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 1 or ISC, ISCe, QSC8.3, ISL, ISLe3, and QSL9 engines. Refer to Procedure 011-060 in Section 11.

Clean the front face of the aftertreatment dosing unit and lines with warm water or mild detergent before removing any lines. This is to prevent any contamination due to service intervention.

Use the following procedure to identify the different connections on the DEF dosing unit. Refer to Procedure 019-440 in Section 19.

Contamination present at the screen filter?
YES NO

Repair

Replace the screen filter.

 No Repair

Go to 5C

Go to 5C

Guided Step 5C - Inspect the DEF tank and filter.

Conditions

  • Turn keyswitch OFF.
  • Do not operate the engine.

Action

Inspect the DEF tank and filters for fuel, oil, coolant, dirt, and debris.

Use the following procedure for an in-tank DEF filter. Refer to Procedure 011-083 in Section 11.

See equipment manufacturer service information for an inline DEF filter.

DEF tank or filter contaminated?

YES NO

Repair

Locate/remove source, inform OEM. If required, replace components and connectors. Drain/refill the DEF tank. See equipment manufacturer service information.

No Repair

Go to 6A

Go to 6A

Guided Step 6 - Perform the Diesel Exhaust Fluid Doser Pump Override Test.

Guided Step 6A - Perform the Diesel Exhaust Fluid Dosing Pump Override Test with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser Pump Override Test, under Aftertreatment Diagnostics Tests.

  • Use the following procedure for instructions and specifications. Refer to Procedure 019-440 in Section 19.
  • Check to make sure that the DEF is being injected through the aftertreatment nozzle during the dosing state.

The aftertreatment nozzle must have been warmed in the exhaust before removing and placing it in a measuring container larger than 200 ml [6.8 oz] capacity to perform the Diesel Exhaust Fluid Doser Pump Override Test.

The troubleshooting tree must be followed completely before completing this test.

Dosing control unit operates correctly during INSITE™ electronic service tool override test? (It is recommended to complete this test three times.)

YES NO
No Repair

Repair

A damaged diesel exhaust fluid dosing unit has been detected. Replace the diesel exhaust fluid dosing unit.

  • Refer to Procedure 019-440 in Section 19.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Turn Keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 10-Apr-2018


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active fault codes present?
 | STEP 1B. Check for inactive fault codes. | Fault Code 151, 235, 245, 595, 2277, 2346, 2348, 2357, 2359 or 2963 inactive?
STEP 2. | Check the air intake system for leaks. |
 | STEP 2A. Check the charge air cooler for leaks. | Air leak present?
 | STEP 2B. Check the intake manifold inlet and connections for leaks. | Air leak present?
STEP 3. | Check the cooling system. |
 | STEP 3A. Check the engine coolant mixture. | Engine coolant is proper mixture?
 | STEP 3B. Check the engine coolant level. | Coolant level at or above acceptable level?
STEP 4. | Check the EGR valve and cooler. |
 | STEP 4A. Perform the INSITE™ electronic service tool EGR valve actuator test. | Does the EGR valve pass the INSITE™ electronic service tool EGR valve actuator test?
 | STEP 4B. Check the EGR cooler for fouling. | Is the EGR cooler efficiency parameter greater than 50 percent after 4 minutes?
STEP 5. | Check the turbocharger. |
 | STEP 5A. Perform INSITE™ electronic service tool turbocharger operational test. | Does the Turbocharger Operational Test pass in INSITE™ electronic service tool?
STEP 6. | Check the EGR differential pressure sensor. |
 | STEP 6A. Check the EGR differential pressure sensor for proper operation. | Is the EGR differential pressure greater than 6 mm Hg [0.236 in Hg] when the EGR valve is open?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Disable the fault code. | Fault Code 2961 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes present?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 151, 235, 245, 595, 2277, 2346, 2348, 2357, 2359 or 2963 inactive?
YES | NO
No Repair | No Repair

7A; Troubleshoot inactive fault codes starting with the fault code containing the highest number of counts

Go to 2A

Guided Step 2 - Check the air intake system for leaks.

Guided Step 2A - Check the charge air cooler for leaks.

Conditions

  • Turn keyswitch ON.

Action

Check the charge air cooler for leaks.

  • Start the engine and check the charge air cooler and connections for air leaks.

Air leak present?
YES NO

Repair

Repair or replace the leaking component.

 No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the intake manifold inlet and connections for leaks.

Conditions

  • Turn keyswitch ON.

Action

Check for air leaks in connections and hoses between the turbocharger and intake manifold inlet.

Air leak present?
YES NO

Repair

Repair or replace the leaking component.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the cooling system.

Guided Step 3A - Check engine coolant mixture.

Conditions

  • Turn keyswitch OFF.

Action

Incorrect coolant mixture will cause high EGR temperatures due to inefficient cooling.

  • Check the freeze point of the engine coolant to be sure of a proper mixture.

Engine coolant is proper mixture?
YES NO
No Repair

Repair

Drain and refill the cooling system with the proper mixture.

Refer to Procedure 008-018 (Cooling System) in Section 8 in the Troubleshooting and Repair Manual, ISBe, ISB, and QSB5.9, Bulletin 4021271.

Go to 3B

Go to 7A

Guided Step 3B - Check the engine coolant level.

Conditions

  • Turn keyswitch OFF.
  • Engine coolant temperature should be below 180°F.

Action

Check the engine coolant level.

  • Low engine coolant level can cause erratic coolant flow through the engine and EGR cooler, in turn causing the EGR temperatures to rise.
  • Check for proper engine coolant level.

Coolant level at or above acceptable level?
YES NO
No Repair

Repair

Replenish the cooling system and troubleshoot for loss of coolant, if necessary.

Go to 4A

Go to 7A

Guided Step 4 -

Guided Step 4A - Perform the INSITE™ electronic service tool EGR valve actuator test.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

ECM diagnostic tests.

  • Use INSITE™ electronic service tool menu on the EGR Valve Actuator Test and follow the instructions on the screen.

Open and close the EGR valve actuator.

When opened, the actuator position will be 100 percent open.

When closed, the actuator position will be less than 10 percent closed.

Does the EGR valve pass the INSITE™ electronic service tool EGR valve actuator test?
YES NO
No Repair

Repair

Replace the EGR valve.

  • Refer to Procedure 011-022 (EGR Valve) in Section 11 of the Service Manual, ISBe, ISB, QSB (Common Rail Fuel System), Bulletin 4021271.

Go to 4B

Go to 4B

Guided Step 4B - Check the EGR cooler for fouling.

Conditions

  • Fan control switch in the OFF position.
  • Air conditioning turned OFF.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Coolant temperature above 79°C [174°F].

Action

If the effectiveness of the cooler is degraded, the cooler will not effectively cool the exhaust gas and will cause the EGR temperature to rise.

  • Start the engine and set the PTO speed to 2000 rpm.
  • Perform the EGR Valve Test in INSITE™ electronic service tool and command the EGR valve 100 percent open.
  • Start the INSITE™ electronic service tool monitor screen and monitor the EGR Cooler Efficiency.
  • Run the EGR Cooler Effectiveness Test with INSITE™ electronic service tool.
  • Operate the engine at this condition for 4 minutes.
  • After 4 minutes, record the value of the EGR Cooler Efficiency.

Is the EGR cooler efficiency parameter greater than 50 percent after 4 minutes?
YES NO
No Repair

Repair

Clean or replace the EGR cooler.

  • Refer to Procedure 011-019 (EGR Cooler) in Section 11 in the Troubleshooting and Repair Manual, ISBe, ISB, and QSB5.9 Series, Bulletin 4021271.

Go to 5A

Go to 7A

Guided Step 5 - Check the turbocharger.

Guided Step 5A - Perform the INSITE™ electronic service tool electronic service tool Turbocharger Operational Test.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at low idle.

Action

Select the EGR/Variable Geometry Turbocharger Operational Test using the INSITE™ electronic service tool.

  • Run the Turbocharger Operational Test.

Does the Turbocharger Operational Test pass in INSITE™ electronic service tool?
YES NO
No Repair

Repair

Replace the variable geometry turbocharger.

Refer to Procedure 010-033 (Turbocharger) in Section 10 in the Troubleshooting and Repair Manual, ISBe, ISB, and QSB5.9 Series, Bulletin 4021271.

Go to 6A

Go to 7A

Guided Step 6 - Check the EGR differential pressure sensor.

Guided Step 6A - Check the EGR differential pressure sensor for proper operation.

Conditions

  • Turn keyswitch ON.
  • Engine running.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine until the EGR valve opens.

  • Use INSITE™ electronic service tool to monitor the EGR valve position and EGR differential pressure.
  • When the EGR valve position is greater than 0 percent, make sure the EGR differential pressure is greater than 6 mm Hg [0.236 in Hg].

Is the EGR differential pressure greater than 6 mm Hg [0.236 in Hg] when the EGR valve is open?
YES NO
No Repair

Repair

Replace the EGR differential pressure sensor.

Refer to Procedure 019-370 (EGR Differential Pressure Sensor) in Section 19.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2961 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 08-Jul-2010


FAULT CODE 2962 - EGR Temperature - Data Valid But Above Normal Operating Range, Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active fault codes present?
 | STEP 1B. Check for inactive fault codes. | Fault Code 151, 235, 245, 595, 2277, 2346, 2348, 2357, 2359, or 2963 inactive?
STEP 2. | Check the air intake system for leaks. |
 | STEP 2A. Check the charge-air cooler for leaks. | Air leak present?
 | STEP 2B. Check the intake manifold inlet and connections for leaks. | Air leak present?
STEP 3. | Check the cooling system. |
 | STEP 3A. Check the engine coolant mixture. | Engine coolant proper mixture?
 | STEP 3B. Check the engine coolant level. | Coolant level at or above acceptable level?
STEP 4. | Check the EGR cooler. |
 | STEP 4A. Perform INSITE™ electronic service tool EGR valve actuator test. | EGR valve passes INSITE™ electronic service tool EGR valve actuator test?
 | STEP 4B. Check the EGR cooler for fouling. | Is the EGR cooler efficiency parameter greater than 50 percent after 4 minutes?
STEP 5. | Check the turbocharger. |
 | STEP 5A. Perform INSITE™ electronic service tool turbocharger operational test. | Turbocharger Operational Test passes in INSITE™ electronic service tool?
STEP 6. | Check the EGR differential pressure sensor. |
 | STEP 6A. Check the EGR differential pressure sensor for proper operation. | EGR differential pressure greater than 6 mm-Hg [0.236 in-Hg] when the EGR valve is open?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Disable the fault code. | Fault Code 2962 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes present?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for inactive fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 151, 235, 245, 595, 2277, 2346, 2348, 2357, 2359, or 2963 inactive?
YES NO

Repair

Troubleshoot inactive fault codes starting with the fault code containing the highest number of counts.

 No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the air intake system for leaks.

Guided Step 2A - Check the charge-air cooler for leaks.

Conditions

  • Turn keyswitch ON.

Action

Check the charge-air cooler for leaks.

  • Start the engine and check the charge-air cooler and connections for air leaks.

Air leak present?
YES NO

Repair

Repair or replace the leaking component.

 No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the intake manifold inlet and connections for leaks.

Conditions

  • Turn keyswitch ON.

Action

Check for air leaks in connections and hoses between the turbocharger and intake manifold inlet.

Air leak present?
YES NO

Repair

Repair or replace the leaking component.

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the cooling system.

Guided Step 3A - Check engine coolant mixture.

Conditions

  • Turn keyswitch OFF.

Action

Incorrect coolant mixture will cause high EGR temperatures due to inefficient cooling.

  • Check the freeze point of the engine coolant to be sure of a proper mixture.

Engine coolant proper mixture?
YES NO
No Repair

Repair

Drain and fill the cooling system with the proper mixture.

Use the following procedure in the Troubleshooting and Repair Manual, ISBe, ISB, and QSB5.9 (Common Rail Fuel System) Series Bulletin, 4021271. Refer to Procedure 008-018 in Section 8.

Go to 3B

Go to 7A

Guided Step 3B - Check the engine coolant level.

Conditions

  • Turn keyswitch OFF.
  • Make sure engine coolant temperature is below 82°C [180°F].

Action

Check the engine coolant level.

  • Low engine coolant level can cause erratic coolant flow through the engine and EGR cooler, causing the EGR temperatures to rise.
  • Check for proper engine coolant level.

Coolant level at or above acceptable level?
YES NO
No Repair

Repair

Replenish the cooling system and troubleshoot for loss of coolant, if necessary.

Go to 4A

Go to 7A

Guided Step 4 - Check the EGR cooler.

Guided Step 4A - Perform INSITE™ electronic service tool EGR valve actuator test.

Conditions

  • Turn keyswitch ON.
  • INSITE™ electronic service tool connected.

Action

Perform ECM diagnostic tests.

  • Use INSITE™ electronic service tool menu on the EGR valve actuator test and follow the instructions on the screen.
  • Open and close the EGR valve actuator.
  • When opened, the actuator position will be 100 percent open.
  • When closed, the actuator position will be less than 10 percent open.

Does the EGR valve pass INSITE™ electronic service tool EGR valve actuator test?
YES NO
No Repair

Repair

Replace the EGR valve.

Use the following proceudre in the Troubleshooting and Repair Manual, ISBe, ISB, and QSB5.9 (Common Rail Fuel System) Series Bulletin, 4021271. Refer to Procedure 011-022 in Section 11.

Go to 4B

Go to 4B

Guided Step 4B - Check the EGR cooler for fouling.

Conditions

  • Place fan control switch in the OFF position.
  • Turn air conditioning OFF.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Make sure coolant temperature above 79°C [174°F].

Action

If the effectiveness of the cooler is degraded, the cooler will not effectively cool the exhaust gas and will cause the EGR temperature to rise.

  • Start the engine and set the PTO speed to 2000 rpm.
  • Perform the EGR Valve Test in INSITE™ electronic service tool and command the EGR valve 100 percent open.
  • Start INSITE™ electronic service tool monitor screen and monitor the EGR cooler efficiency.
  • Perform the EGR Cooler Effectiveness Test with INSITE™ electronic service tool.
  • Operate the engine at this condition for 4 minutes.
  • After 4 minutes, record the value of the EGR cooler efficiency.

EGR cooler efficiency parameter greater than 50 percent after 4 minutes?
YES NO
No Repair

Repair

Clean or replace the EGR cooler.

Use the following procedure in the Troubleshooting and Repair Manual, ISBe, ISB, and QSB5.9 (Common Rail Fuel System) Series Bulletin, 4021271. Refer to Procedure 011-019 in Section 11.

Go to 5A

Go to 7A

Guided Step 5 - Check the turbocharger.

Guided Step 5A - Perform the INSITE™ electronic service tool turbocharger operational test.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at low idle.

Action

Select the EGR/Variable Geometry Turbocharger Operational Test using the INSITE™ electronic service tool.

  • Perform the Turbocharger Operational Test.

Turbocharger Operational Test passes in INSITE™ electronic service tool?
YES NO
No Repair

Repair

Replace the variable geometry turbocharger.

Use the following procedure in the Troubleshooting and Repair Manual, ISBe, ISB, and QSB5.9 (Common Rail Fuel System) Series, Bulletin 4021271. Refer to Procedure 010-033 in Section 10.

Go to 6A

Go to 7A

Guided Step 6 - Check the EGR differential pressure sensor.

Guided Step 6A - Check the EGR differential pressure sensor for proper operation.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate engine.

Action

Operate the engine until the EGR valve opens.

  • Use INSITE™ electronic service tool to monitor the EGR valve position and EGR differential pressure.
  • When the EGR valve position is greater than 0 percent, make sure the EGR differential pressure is greater than 6 mm-Hg [0.236 in-Hg].

EGR differential pressure greater than 6 mm-Hg [0.236 in-Hg] when the EGR valve is open?
YES NO
No Repair

Repair

Replace the EGR differential pressure sensor.

Refer to Procedure 019-370 in Section 19.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault code.

Guided Step 7A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2962 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-Sep-2011


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 2963. | Active or inactive counts of Fault Code 2963?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 2963.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 2963.

  • Using INSITE™, read the fault codes.

Active or inactive counts of Fault Code 2963?
YES NO

Repair

Refer to the Engine Coolant Temperature Above Normal symptom tree in Troubleshooting and Repair Manual, ISC, QSC8.3, ISL and QSL9 Engines, Bulletin 4021418.

No Repair

Appropriate troubleshooting symptom tree

Repair complete

Last Modified: 08-Jul-2010


Intake Manifold Temperature High - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fan Clutch, On-Off | Refer to Procedure 008-027 | ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) | 4021271
Charge-Air Cooler (CAC) | Refer to Procedure 010-027 | ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) | 4021271
Air Intake Restriction | Refer to Procedure 010-031 | ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) | 4021271
EGR Valve | Refer to Procedure 011-022 | ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 (Common Rail Fuel System) | 4021271
Engine Control Module Calibration Code | Refer to Procedure 019-032 | ISB, ISBe2, ISBe3, ISBe4, QSB4.5, QSB5.9, QSB6.7, ISC, QSC8.3, ISL, ISLe3, ISLe4, and QSL9 CM850 (CM2850) | 4021416
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | ISB, ISBe2, ISBe3, ISBe4, QSB4.5, QSB5.9, QSB6.7, ISC, QSC8.3, ISL, ISLe3, ISLe4, and QSL9 CM850 (CM2850) | 4021416

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | High intake manifold temperature basic checks. |
 | STEP 1A. High intake manifold temperature basic checks. | Damage found?
STEP 2. | Intake manifold temperature sensor struck in-range. |
 | STEP 2A. Intake manifold temperature sensor struck in-range. | Sensor reading within +/- 10°C [18°F]?
STEP 3. | EGR valve stuck open. |
 | STEP 3A. EGR valve stuck open. | EGR Valve Actuator Test failed?
STEP 4. | Fan clutch operates incorrectly. |
 | STEP 4A. Fan clutch operates incorrectly. | Fan engages at the correct engine temperature?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - High intake manifold temperature basic checks.

Guided Step 1A - High intake manifold temperature basic checks.

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the air filter to make sure it is not plugged. Refer to Procedure 010-031 in the Associated Procedures Table.
  • Inspect the charge-air cooler for damage or debris blocking the air flow. Refer to Procedure 010-027 in the Associated Procedures Table.
  • Inspect the air conditioner condenser. Refer to OEM Service Manual.
  • Visually inspect the radiator fins for damage or debris blocking the air flow.

Damage found?

YES NO

Repair

  • Repair or replace the malfunctioning components.
 No Repair

Go to 5A

Go to 2A

Guided Step 2 - Intake manifold temperature sensor stuck in-range.

Guided Step 2A - Intake manifold temperature sensor stuck in-range.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Compare the intake manifold temperature sensor reading to an infrared thermometer or a known value.

Sensor reading within +/- 10°C [18°F]?
YES NO

Repair

Repair or replace only the components that were found to be out of specification.

Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - EGR valve stuck open.

Guided Step 3A - EGR valve stuck open.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the EGR Valve Actuator Test.

EGR Valve Actuator Test failed?

YES NO

Repair

  • Clean or replace the EGR valve. Refer to Procedure 011-022 in the Associated Procedures Table.
 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Fan clutch operates incorrectly.

Guided Step 4A - Fan clutch operates incorrectly.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Check the adjustable parameters settings.

Ensure the following adjustable parameters are set correctly for the application:

  • Fan Control Logic.
  • Fan Control Switch.
  • Air Conditioner Pressure Switch Input.
  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Fan Override Test.
  • Verify that the fan operates correctly.
  • Verify the fan is engaging at the correct engine temperature. Refer to Procedure 008-027 in the Associated Procedures Table. Refer to OEM Service Manual.

Fan engages at the correct engine temperature?
YES NO
No Repair

Repair

  • Adjust, repair, or replace the component preventing correct cooling fan operation. Refer to Procedure 008-027 in the Associated Procedures. Refer to OEM Service Manual.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use Cummins® electronic service tool or equivalent to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?

YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?

YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete

Escalate or call for assistance

Last Modified: 20-Apr-2022


FAULT CODE 2973 - Intake Manifold Pressure Sensor Circuit - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or high inactive fault codes. | Active or inactive counts of Fault Codes 122, 123, 221, 222, 295, 595, 687, or 2345?
STEP 2. | Check the barometric pressure sensor. |
 | STEP 2A. Verify the sensor accuracy. | INSITE™ electronic service tool reading within 77 mm-Hg [3 in-Hg] of local barometric pressure?
STEP 3. | Check the engine intake manifold pressure/temperature sensor and circuit. |
 | STEP 3A. Inspect the engine intake manifold pressure/temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Verify the sensor accuracy. | INSITE™ electronic service tool reading for intake manifold pressure within 77 mm-Hg [3 in-Hg] of local barometric pressure?
 | STEP 3C. Check the circuit response. | Fault Code 123 active?
 | STEP 3D. Check the circuit response. | Fault Code 122 active?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 123 active?
 | STEP 4C. Check the circuit response. | Fault Code 122 active?
STEP 5. | Check the air intake system for leaks. |
 | STEP 5A. Check the charge air cooler for leaks. | Air leak present?
 | STEP 5B. Check the intake manifold inlet and connections for leaks. | Air leak present?
 | STEP 5C. Inspect the turbocharger compressor and turbine blades. | Damage or wear found on the turbocharger blades?
 | STEP 5D. Check for a restricted charge air cooler. | Within specifications?
STEP 6. | Check the turbocharger speed sensor. |
 | STEP 6A. Inspect the engine harness connector to the turbocharger speed sensor, if applicable. | Dirty or damaged pins?
 | STEP 6B. Measure the turbocharger speed sensor resistance. | Resistance between 600 and 1600 ohms?
STEP 7. | Check the exhaust system for restriction. |
 | STEP 7A. Check exhaust restriction. | Within specifications?
STEP 8. | Clear the fault codes. |
 | STEP 8A. Disable the fault code. | Fault Code 2973 inactive?
 | STEP 8B. Clear the inactive fault codes and the malfunctioning indicator lamp (MIL). | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or high inactive counts of Fault Codes 122, 123, 221, 222, 295, 595, 687, or 2345?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the barometric pressure sensor.

Guided Step 2A - Verify the sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start INSITE™ electronic service tool Data Monitor/Logger and compare the INSITE™ electronic service tool reading for barometric pressure to the local barometric pressure.

  • Refer to Procedure 018-028 in Section V.

INSITE™ electronic service tool reading is within 77 mm-Hg [3 in-Hg] of local barometric pressure?
YES NO
No Repair

Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in Section 19.

Go to 3A

Go to 8A

Guided Step 3 - Check the engine intake manifold pressure/temperature sensor and circuit.

Guided Step 3A - Inspect the engine intake manifold pressure/temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.

Action

Inspect the intake manifold pressure/temperature sensor connector and the engine harness connector for signs of the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the intake manifold pressure/temperature sensor or harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of the harness or damaged intake manifold pressure/temperature sensor. Refer to the circuit diagram or wiring diagram for all engine harness interconnections.
  • Refer to Procedure 019-043 in Section 19.
  • Refer to Procedure 019-061 in Section 19.
No Repair

Go to 8A

Go to 3B

Guided Step 3B -

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Turn engine OFF.

Action

With keyswitch ON and engine OFF, the intake manifold pressure and barometric pressure readings must agree.

Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for intake manifold pressure to the reading for barometric pressure.

INSITE™ electronic service tool reading for intake manifold pressure is within 77 mm-Hg [3 in-Hg] of local barometric pressure?
YES | NO
No Repair | No Repair

Go to 5A

Go to 3C

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.

Action

Check for the appropriate ECM response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES | NO
No Repair | No Repair

Go to 3D

Go to 4A

Guided Step 3D - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine intake manifold pressure +5 volt SUPPLY pin and the engine intake manifold pressure SIGNAL pin at the engine intake manifold pressure/temperature connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES NO

Repair

An in-range malfunction of the intake manifold pressure/temperature sensor has been detected.

Replace the engine intake manifold pressure/temperature sensor. Refer to Procedure 019-061 in Section 19.

No Repair

Go to 8A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Repair the damaged pins. Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 8A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4C

Go to 8A

Guided Step 4C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine intake manifold pressure +5 volt SUPPLY pin and engine intake manifold pressure SIGNAL pin at the engine control module engine connector.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES NO

Repair

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 8A

Go to 8A

Guided Step 5 - Check the air intake system for leaks.

Guided Step 5A - Check the charge-air cooler for leaks.

Conditions

  • Operate engine.

Action

Check the charge-air cooler and connections for air leaks.

Air leak present?
YES NO

Repair

Repair or replace the leaking component.

 No Repair

Go to 8A

Go to 5B

Guided Step 5B - Check the intake manifold inlet and connections for leaks.

Conditions

  • Operate engine.

Action

Check for air leaks in the connections and hoses between the turbocharger and intake manifold inlet.

  • Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4, and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 010-024 in Section 10.

Air leak present?
YES NO

Repair

Repair or replace the leaking component.

 No Repair

Go to 8A

Go to 5C

Guided Step 5C - Inspect the turbocharger compressor and turbine blades.

Conditions

  • Turn engine OFF.
  • Turn keyswitch ON.
  • Remove the intake and exhaust connections from the turbocharger.

Action

Inspect the turbocharger compressor and turbine blades for damage or wear.

  • Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4, and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 010-033 in Section 10.

Damage or wear found on turbocharger blades?
YES NO

Repair

Replace the turbocharger. Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4, and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 010-033 in Section 10.

No Repair

Go to 8A

Go to 5D

Guided Step 5D - Check for a restricted charge-air cooler.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Operate engine.

Action

Check the pressure differential across the charge air cooler.

  • Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4, and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 010-027 in Section 10.

Within specifications?
YES NO
No Repair

Repair

Clean or replace the charge-air cooler, if necessary.

Go to 6A

Go to 8A

Guided Step 6 - Check the turbocharger speed sensor.

Guided Step 6A - Inspect the engine harness connector to the turbocharger speed sensor, if applicable.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the turbocharger speed sensor.

Action

Only perform this step if the engine is equipped with a turbocharger speed sensor. Inspect the turbocharger or refer to the engine wiring diagram to determine if the engine has a turbocharger speed sensor. If no sensor is present, skip to Step 7.

Inspect the turbocharger speed sensor connector, the engine harness connector, and the turbocharger speed sensor pigtail harness for signs of the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness.

Repair the damaged pins. Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 8A

Go to 6B

Guided Step 6B - Measure the turbocharger speed sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Check the turbocharger speed sensor resistance.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin to the turbocharger speed SIGNAL (-) pin at the sensor.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 600 and 1600 ohms?
YES NO
No Repair

Repair

  • The turbocharger speed sensor has failed.
  • Replace the turbocharger speed sensor. Refer to Procedure 019-390 in Section 19.

Go to 7A

Go to 8A

Guided Step 7 - Check the exhaust system for restriction.

Guided Step 7A - Check exhaust restriction.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check exhaust restriction.

  • Use the following procedure in the ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4, and QSL9 Troubleshooting and Repair Manual, Bulletin 4021418. Refer to Procedure 011-009 in Section 11.

Within specifications?
YES NO
No Repair

Repair

Repair or replace the restricted component.

Go to 8A

Go to 8A

Guided Step 8 - Clear the fault codes.

Guided Step 8A - Disable the fault code.

Conditions

  • Start the engine.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine.
  • Complete the conditions for clearing a fault code per the instructions in Shoptalk.

Fault Code 2973 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 8B

Go to 1A

Guided Step 8B - Clear the inactive fault codes and MIL.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Clear the inactive fault codes and MIL.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 19-Aug-2013


FAULT CODE 2976 - Aftertreatment Diesel Exhaust Fluid Dosing Unit Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 | 4021271
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISC, ISCe, QSC8.3, ISL, ISLe3, ISLe4 and QSL9 | 4021418

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2976 inactive?
STEP 2. | Check the diesel exhaust fluid (DEF) dosing unit. |
 | STEP 2A. Inspect the dosing unit body and condition of the harness. | Damaged dosing unit or harness?
 | STEP 2B. Inspect the DEF dosing unit connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the original equipment manufacturer (OEM) harness. | Less than 10 ohms?
 | STEP 2D. Read the fault codes. | Fault Code 2976 inactive?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2976 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in section 19.

Go to 2A

Guided Step 2 - Check the diesel exhaust fluid (DEF) dosing unit.

Guided Step 2A - Inspect the dosing unit body and condition of the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the DEF dosing unit.

Action

Inspect the OEM harness and DEF dosing unit body / casing for the following:

  • Cracked or damaged DEF dosing unit casing
  • Melting or heat damage to the DEF
  • Dosing unit melted wiring harness or connectors
  • Loose or damaged wires in the OEM wiring harness
  • Damaged fasteners or wiring harness connectors.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged dosing unit or harness?
YES NO

Repair

A damaged OEM wiring harness or DEF dosing unit has been detected.

  • Repair the damaged harness, connector, or pins if possible.
  • Replace the DEF dosing unit if damage is detected. Refer to Procedure 019-071 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the DEF dosing unit connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the DEF dosing unit.

Action

Inspect the OEM harness and DEF dosing unit connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the DEF dosing unit or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.
No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Conduct a pin-to-pin continuity check in the OEM harness.

  • Measure the resistance from each pin at the DEF dosing unit connector to the corresponding pin on the ECM connector.

Refer to the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the J1939 data link harness.

Repair or replace the OEM harness.

Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2976 inactive?
YES NO

Repair

No Repair. Removal and Installation of the connectors has corrected the fault.

Repair

Replace the aftertreatment DEF dosing unit.

  • Use the following procedure for air-assisted selective catalytic reduction (SCR) dosing systems. Refer to Procedure 019-440 in Section 19.

Use the following procedure for airless SCR dosing systems. Refer to Procedure 011-058 in the Associated Procedure Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Oct-2012


FAULT CODE 3329 - J1939 Network #2 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check battery. |
 | STEP 1A. Low battery voltage. | Less than 12 VDC or 24 VDC?
 | STEP 1B. Battery load test. | Less than 11 VDC or 22 VDC?
 | STEP 1C. Fuse distribution panel check. | Damage, corrosion, or cracks?
 | STEP 1D. Ground inspection. | Damage, corrosion or incorrect routing of grounds?
STEP 2. | Check the SAE J1939 data link. |
 | STEP 2A. Check the SAE J1939 data link terminating resistance. | 54 to 66 ohms?
 | STEP 2B. Incorrect terminating resistor in the SAE J1939 data link. | 108 to 132 ohms?
 | STEP 2C. Engine wiring harness has incorrect SAE J1939 terminating resistance. | 108 to 132 ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check battery.

Guided Step 1A - Low battery voltage check.

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

For 12 volt systems

Voltage below 12 VDC?

For 24 volt systems

Voltage below 24 VDC?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Battery load test.

Conditions

  • Turn keyswitch OFF.

Action

  • Disconnect the batteries from each other.
  • Connect a load tester separately to each battery.
  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal.

For 12 volt systems

Battery voltage below 11 VDC?

For 24 volt systems

Battery voltage below 22 VDC?
YES NO

Repair

Charge or replace the batteries. Refer to OEM Service Manual.

 No Repair

Go to 3A

Go to 1C

Guided Step 1C - Fuse/distribution panel check.

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect ECM battery supply fuses for damage, corrosion or loose connections.
  • Visually inspect aftertreatment battery supply fuses for damage, corrosion or loose connections.
  • Visually inspect the battery supply fuses under a microscope or a magnifying glass for micro cracks.

Fuses can be difficult to locate. Some applications utilize a fuse distribution box within the battery box while others utilize inline fuses. There are instances where these will be located behind the battery box wrapped in a buddle of wires next to the frame rail.

Micro cracks most commonly occur near the bends on either side of the interior of the fuse.

Damage, corrosion, or cracks?

YES NO

Repair

Replace the fuse. Refer to OEM Service Manual.

 No Repair

Go to 3A

Go to 1D

Guided Step 1D - Ground inspection.

Conditions

  • Turn keyswitch OFF.

Action

  • Visually inspect the ECM ground for damage, corrosion and loose connections.
  • Visually inspect the aftertreatment interface harness ground for damage, corrosion and loose connections.
  • Visually inspect the grounds for proper routing.

Damage, corrosion or incorrect routing of grounds?
YES NO

Repair

Clean or replace connections. Refer to OEM Service Manual.

 No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the SAE J1939 data link.

Guided Step 2A - Check the SAE J1939 data link terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Wait for 90 seconds.
  • Disconnect the INLINE™ adapter from the 3-pin service datalink connector.
  • Reconnect previously disconnected components.

Action

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in Section 19.
  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire at the 3-pin service data link connector. Refer to Procedure 019-165 in the Associated Procedures Table.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

54 to 66 ohms?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2B

Guided Step 2B - Incorrect terminating resistor in the SAE J1939 data link.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the terminating resistor from the engine wiring harness.

Action

  • Measure the resistance between the pins for the engine terminating resistor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

108 to 132 ohms?
YES NO
No Repair

Repair

Replace the terminating resistor. Refer to Procedure 019-165 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Engine wiring harness has incorrect SAE J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Reconnect previously disconnected components.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.

Action

  • Measure the resistance between the SAE J1939 data link (+) pin and the SAE J1939 data link (-) pin at the 3-pin service data link connector. Refer to Procedure 019-165 in Section 19.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

108 to 132 ohms?
YES NO

Repair

Clean or replace connections. Refer to OEM Service Manual.

Repair

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the Cummins® electronic service tool or equivalent to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 19-Oct-2021


FAULT CODE 9122 - VGT Actuator Driver Over Temperature (Calculated) - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | ISB, ISBe, ISBe4, QSB4.5, QSB5.9, and QSB6.7 | 4021271

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the variable geometry turbocharger actuator cooling system. |
 | STEP 1A. Check for active fault codes. | Fault codes related to high coolant temperature active or high count or inactive coolant temperature related faults?
 | STEP 1B. Inspect variable geometry turbocharger actuator coolant lines. | Blockages found in the variable geometry turbocharger actuator cooling plate or coolant lines?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the variable geometry turbocharger actuator cooling system.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to high coolant temperature active or high count or inactive coolant temperature related faults?
YES NO

Repair

The variable geometry turbocharger actuator internal temperature has exceeded the maximum limit. No repair is necessary. This fault code is for information only.

No Repair

Troubleshoot other fault codes

Go to 1B

Guided Step 1B - Inspect variable geometry turbocharger actuator coolant lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the variable geometry turbocharger actuator coolant lines for kinks and blockages.

  • Blow shop air in reverse flow through the variable geometry turbocharger actuator cooling plate to check blockages

Blockages found in the variable geometry turbocharger actuator cooling plate or coolant lines?
YES NO

Repair

Repair or replace the blocked coolant line.

  • Refer to Procedure 010-041 in the Assoicated Procedures Table.
 No Repair

Repair complete

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 27-Aug-2013


INDEX
06-fc0001.htm

06-t05-0001.htm

06-fc0002.htm

06-t05-0002.htm

06-fc0003.htm

06-t05-0003.htm

06-fc0004.htm

06-t05-0004.htm

06-fc0005.htm

06-t05-0005.htm

06-fc0006.htm

06-t05-0006.htm

06-fc111.htm

06-t05-111.htm

06-fc115.htm

06-t05-115.htm

06-fc122.htm

06-t05-122.htm

06-fc123.htm

06-t05-123.htm

06-fc124.htm

06-t05-124.htm

06-fc131.htm

06-t05-131.htm

06-fc132.htm

06-t05-132.htm

06-fc133.htm

06-t05-133.htm

06-fc134.htm

06-t05-134.htm

06-fc135.htm

06-fc135auto.htm

06-t05-135auto.htm

06-fc135mar.htm

06-t05-135mar.htm

06-fc141.htm

06-fc141auto.htm

06-t05-141auto.htm

06-fc141mar.htm

06-t05-141mar.htm

06-fc143.htm

06-fc143b.htm

06-t05-143b.htm

06-fc143bm.htm

06-t05-143bm.htm

06-fc144.htm

06-fc144b.htm

06-t05-144b.htm

06-fc144bm.htm

06-t05-144bm.htm

06-fc145.htm

06-fc145b.htm

06-t05-145b.htm

06-fc145bm.htm

06-t05-145bm.htm

06-fc146.htm

06-fc146b.htm

06-t05-146b.htm

06-fc146bm.htm

06-t05-146bm.htm

06-fc147.htm

06-t05-147.htm

06-fc148.htm

06-t05-148.htm

06-fc151.htm

06-fc151b.htm

06-t05-151b.htm

06-fc151bm.htm

06-t05-151bm.htm

06-fc153.htm

06-t05-153.htm

06-fc154.htm

06-t05-154.htm

06-fc155.htm

06-t05-155.htm

06-fc187.htm

06-fc187b.htm

06-t05-187b.htm

06-fc187bm.htm

06-t05-187bm.htm

06-fc195.htm

06-fc195-2wire.htm

06-t05-195-2wire.htm

06-fc195-3wire.htm

06-t05-195-3wire.htm

06-fc196.htm

06-fc196-2wire.htm

06-t05-196-2wire.htm

06-fc196-3wire.htm

06-t05-196-3wire.htm

06-fc197.htm

06-t05-197.htm

06-fc221.htm

06-t05-221.htm

06-fc222.htm

06-t05-222.htm

06-fc227.htm

06-fc227b.htm

06-t05-227b.htm

06-fc227bm.htm

06-t05-227bm.htm

06-fc234.htm

06-fc234b.htm

06-t05-234b.htm

06-fc234bm.htm

06-t05-234bm.htm

06-fc235.htm

06-t05-235.htm

06-fc237.htm

06-t05-237.htm

06-fc238.htm

06-t05-238.htm

06-fc241.htm

06-t05-241.htm

06-fc242.htm

06-t05-242.htm

06-fc245.htm

06-t05-245.htm

06-fc253.htm

06-t05-253.htm

06-fc268.htm

06-t05-268.htm

06-fc269.htm

06-t05-269.htm

06-fc271.htm

06-fc271b.htm

06-t05-271b.htm

06-fc271cl.htm

06-t05-271cl.htm

06-fc272.htm

06-fc272b.htm

06-t05-272b.htm

06-fc272cl.htm

06-t05-272cl.htm

06-fc275.htm

06-t05-275.htm

06-fc281.htm

06-t05-281.htm

06-fc284.htm

06-t05-284.htm

06-fc285.htm

06-t05-285.htm

06-fc286.htm

06-t05-286.htm

06-fc287.htm

06-t05-287.htm

06-fc288.htm

06-t05-288.htm

06-fc291.htm

06-t05-291.htm

06-fc292.htm

06-t05-292.htm

06-fc293.htm

06-t05-293.htm

06-fc294.htm

06-t05-294.htm

06-fc295.htm

06-t05-295.htm

06-fc296.htm

06-fc296a.htm

06-t05-296a.htm

06-fc296lrv.htm

06-t05-296lrv.htm

06-fc297.htm

06-t05-297.htm

06-fc298.htm

06-t05-298.htm

06-fc319.htm

06-t05-319.htm

06-fc322.htm

06-t05-322.htm

06-fc323.htm

06-t05-323.htm

06-fc324.htm

06-t05-324.htm

06-fc325.htm

06-t05-325.htm

06-fc331.htm

06-t05-331.htm

06-fc332.htm

06-t05-332.htm

06-fc334.htm

06-t05-334.htm

06-fc341.htm

06-t05-341.htm

06-fc342.htm

06-t05-342.htm

06-fc343.htm

06-t05-343.htm

06-fc351.htm

06-t05-351.htm

06-fc352.htm

06-t05-352.htm

06-fc386.htm

06-t05-386.htm

06-fc387.htm

06-t05-387.htm

06-fc412.htm

06-t05-412.htm

06-fc415.htm

06-fc415sn.htm

06-t05-415sn.htm

06-fc415sw.htm

06-t05-415sw.htm

06-fc418.htm

06-fc418auto.htm

06-t05-418auto.htm

06-fc418mar.htm

06-t05-418mar.htm

06-fc426.htm

06-t05-426.htm

06-fc427.htm

06-t05-427.htm

06-fc428.htm

06-fc428auto.htm

06-t05-428auto.htm

06-fc428mar.htm

06-t05-428mar.htm

06-fc429.htm

06-fc429auto.htm

06-t05-429auto.htm

06-fc429mar.htm

06-t05-429mar.htm

06-fc431.htm

06-fc431iss.htm

06-t05-431iss.htm

06-fc431niss.htm

06-t05-431niss.htm

06-fc431sss.htm

06-t05-431sss.htm

06-fc432.htm

06-t05-432.htm

06-fc433.htm

06-t05-433.htm

06-fc434.htm

06-t05-434.htm

06-fc435.htm

06-t05-435.htm

06-fc436.htm

06-t05-436.htm

06-fc441.htm

06-t05-441.htm

06-fc442.htm

06-t05-442.htm

06-fc443.htm

06-t05-443.htm

06-fc449.htm

06-fc449b.htm

06-t05-449b.htm

06-fc449cl.htm

06-t05-449cl.htm

06-fc451.htm

06-t05-451.htm

06-fc452.htm

06-t05-452.htm

06-fc471.htm

06-t05-471.htm

06-fc488.htm

06-t05-488.htm

06-fc497.htm

06-t05-497.htm

06-fc498.htm

06-t05-498.htm

06-fc499.htm

06-t05-499.htm

06-fc523.htm

06-t05-523.htm

06-fc527.htm

06-t05-527.htm

06-fc528.htm

06-t05-528.htm

06-fc529.htm

06-t05-529.htm

06-fc545.htm

06-t05-545.htm

06-fc551.htm

06-fc551iss.htm

06-t05-551iss.htm

06-fc551niss.htm

06-t05-551niss.htm

06-fc551sss.htm

06-t05-551sss.htm

06-fc553.htm

06-t05-553.htm

06-fc554.htm

06-t05-554.htm

06-fc559.htm

06-fc559b.htm

06-t05-559b.htm

06-fc559cl.htm

06-t05-559cl.htm

06-fc584.htm

06-t05-584.htm

06-fc585.htm

06-t05-585.htm

06-fc595.htm

06-fc595b.htm

06-t05-595b.htm

06-fc595cl.htm

06-t05-595cl.htm

06-fc596.htm

06-t05-596.htm

06-fc597.htm

06-t05-597.htm

06-fc598.htm

06-t05-598.htm

06-fc599.htm

06-t05-599.htm

06-fc649.htm

06-t05-649.htm

06-fc687.htm

06-fc687b.htm

06-t05-687b.htm

06-fc687cl.htm

06-t05-687cl.htm

06-fc688.htm

06-t05-688.htm

06-fc689.htm

06-t05-689.htm

06-fc691.htm

06-t05-691.htm

06-fc692.htm

06-t05-692.htm

06-fc731.htm

06-fc731b.htm

06-t05-731b.htm

06-fc731bm.htm

06-t05-731bm.htm

06-fc757.htm

06-t05-757.htm

06-fc778.htm

06-t05-778.htm

06-fc779.htm

06-t05-779.htm

06-fc781.htm

06-t05-781.htm

06-fc784.htm

06-t05-784.htm

06-fc951.htm

06-t05-951.htm

06-fc957.htm

06-t05-957.htm

06-fc958.htm

06-t05-958.htm

06-fc1117.htm

06-fc1117auto.htm

06-t05-1117auto.htm

06-fc1117mar.htm

06-t05-1117mar.htm

06-fc1119.htm

06-t05-1119.htm

06-fc1139.htm

06-t05-1139.htm

06-fc1141.htm

06-t05-1141.htm

06-fc1142.htm

06-t05-1142.htm

06-fc1143.htm

06-t05-1143.htm

06-fc1144.htm

06-t05-1144.htm

06-fc1145.htm

06-t05-1145.htm

06-fc1228.htm

06-t05-1228.htm

06-fc1229.htm

06-t05-1229.htm

06-fc1239.htm

06-t05-1239.htm

06-fc1241.htm

06-t05-1241.htm

06-fc1242.htm

06-t05-1242.htm

06-fc1633.htm

06-t05-1633.htm

06-fc1639.htm

06-t05-1639.htm

06-fc1654.htm

06-t05-1654.htm

06-fc1655.htm

06-t05-1655.htm

06-fc1656.htm

06-t05-1656.htm

06-fc1657.htm

06-t05-1657.htm

06-fc1658.htm

06-t05-1658.htm

06-fc1659.htm

06-t05-1659.htm

06-fc1663.htm

06-t05-1663.htm

06-fc1664.htm

06-t05-1664.htm

06-fc1665.htm

06-t05-1665.htm

06-fc1666.htm

06-t05-1666.htm

06-fc1667.htm

06-t05-1667.htm

06-fc1668.htm

06-t05-1668.htm

06-fc1669.htm

06-t05-1669.htm

06-fc1671.htm

06-t05-1671.htm

06-fc1673.htm

06-t05-1673.htm

06-fc1674.htm

06-t05-1674.htm

06-fc1675.htm

06-t05-1675.htm

06-fc1676.htm

06-t05-1676.htm

06-fc1677.htm

06-t05-1677.htm

06-fc1678.htm

06-t05-1678.htm

06-fc1679.htm

06-t05-1679.htm

06-fc1681.htm

06-t05-1681.htm

06-fc1682.htm

06-t05-1682.htm

06-fc1683.htm

06-t05-1683.htm

06-fc1684.htm

06-t05-1684.htm

06-fc1687.htm

06-t05-1687.htm

06-fc1689.htm

06-t05-1689.htm

06-fc1692.htm

06-t05-1692.htm

06-fc1694.htm

06-t05-1694.htm

06-fc1697.htm

06-t05-1697.htm

06-fc1698.htm

06-t05-1698.htm

06-fc1699.htm

06-t05-1699.htm

06-fc1711.htm

06-t05-1711.htm

06-fc1712.htm

06-t05-1712.htm

06-fc1713.htm

06-t05-1713.htm

06-fc1716.htm

06-t05-1716.htm

06-fc1717.htm

06-t05-1717.htm

06-fc1718.htm

06-t05-1718.htm

06-fc1845.htm

06-t05-1845.htm

06-fc1846.htm

06-t05-1846.htm

06-fc1848.htm

06-t05-1848.htm

06-fc1849.htm

06-t05-1849.htm

06-fc1851.htm

06-t05-1851.htm

06-fc1892.htm

06-t05-1892.htm

06-fc1911.htm

06-t05-1911.htm

06-fc1992.htm

06-t05-1992.htm

06-fc2183.htm

06-t05-2183.htm

06-fc2185.htm

06-t05-2185.htm

06-fc2186.htm

06-t05-2186.htm

06-fc2195.htm

06-t05-2195.htm

06-fc2215.htm

06-fc2215b.htm

06-t05-2215b.htm

06-fc2215cl.htm

06-t05-2215cl.htm

06-fc2216.htm

06-fc2216b.htm

06-t05-2216b.htm

06-fc2216cl.htm

06-t05-2216cl.htm

06-fc2217.htm

06-t05-2217.htm

06-fc2249.htm

06-t05-2249.htm

06-fc2265.htm

06-t05-2265.htm

06-fc2266.htm

06-t05-2266.htm

06-fc2271.htm

06-t05-2271.htm

06-fc2272.htm

06-t05-2272.htm

06-fc2273.htm

06-t05-2273.htm

06-fc2274.htm

06-t05-2274.htm

06-fc2292.htm

06-t05-2292.htm

06-fc2293.htm

06-t05-2293.htm

06-fc2311.htm

06-t05-2311.htm

06-fc2321.htm

06-t05-2321.htm

06-fc2322.htm

06-t05-2322.htm

06-fc2345.htm

06-fc2345b.htm

06-t05-2345b.htm

06-fc2345cl.htm

06-t05-2345cl.htm

06-fc2346.htm

06-fc2346b.htm

06-t05-2346b.htm

06-fc2346cl.htm

06-t05-2346cl.htm

06-fc2347.htm

06-fc2347b.htm

06-t05-2347b.htm

06-fc2347cl.htm

06-t05-2347cl.htm

06-fc2348.htm

06-t05-2348.htm

06-fc2349.htm

06-t05-2349.htm

06-fc2351.htm

06-t05-2351.htm

06-fc2352.htm

06-t05-2352.htm

06-fc2353.htm

06-t05-2353.htm

06-fc2357.htm

06-t05-2357.htm

06-fc2359.htm

06-t05-2359.htm

06-fc2362.htm

06-t05-2362.htm

06-fc2363.htm

06-t05-2363.htm

06-fc2366.htm

06-t05-2366.htm

06-fc2367.htm

06-t05-2367.htm

06-fc2373.htm

06-t05-2373.htm

06-fc2374.htm

06-t05-2374.htm

06-fc2375.htm

06-t05-2375.htm

06-fc2376.htm

06-t05-2376.htm

06-fc2377.htm

06-t05-2377.htm

06-fc2381.htm

06-t05-2381.htm

06-fc2382.htm

06-t05-2382.htm

06-fc2383.htm

06-t05-2383.htm

06-fc2384.htm

06-fc2384b.htm

06-t05-2384b.htm

06-fc2384cl.htm

06-t05-2384cl.htm

06-fc2385.htm

06-fc2385b.htm

06-t05-2385b.htm

06-fc2385cl.htm

06-t05-2385cl.htm

06-fc2386.htm

06-t05-2386.htm

06-fc2387.htm

06-t05-2387.htm

06-fc2388.htm

06-t05-2388.htm

06-fc2448.htm

06-t05-2448.htm

06-fc2554.htm

06-t05-2554.htm

06-fc2555.htm

06-t05-2555.htm

06-fc2556.htm

06-t05-2556.htm

06-fc2557.htm

06-t05-2557.htm

06-fc2558.htm

06-t05-2558.htm

06-fc2559.htm

06-t05-2559.htm

06-fc2659.htm

06-t05-2659.htm

06-fc2771.htm

06-t05-2771.htm

06-fc2772.htm

06-t05-2772.htm

06-fc2773.htm

06-t05-2773.htm

06-fc2961.htm

06-t05-2961.htm

06-fc2962.htm

06-t05-2962.htm

06-fc2963.htm

06-t05-2963.htm

06-fc2964.htm

06-t05-2964.htm

06-fc2973.htm

06-t05-2973.htm

06-fc2976.htm

06-t05-2976.htm

06-fc3329.htm

06-t05-3329.htm

06-fc9122.htm

06-t05-9122.htm