Last Modified: 12 February 2020

Copyright © 2020
Cummins Inc.
All rights reserved


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Engine Speed Sensor Circuit

FAULT CODE 121

Engine Speed Sensor Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 121 PID: P190 SPN: 190 FMI: 10 LAMP: Shutdown SRT: | Engine Speed Sensor Circuit. No engine speed signal detected from the main or backup speed sensors. | Engine will shut down.
QSK60G Multiple Turbocharger with GCP1 / PCS3100 Control - Engine Speed Sensor Circuit
QSK60G Single and Multiple Turbocharger with GCPII / PCS3100 Control - Engine Speed Sensor Circuit
QSK60G Single and Multiple Turbocharger with PCC3300 Control - Engine Speed Sensor Circuit
QSK60G Multiple Turbocharger Generator Drive - Engine Speed Sensor Circuit

Circuit Description

The engine speed sensor is a dual coil circuit that provides the engine speed signal to each engine control module (ECM) through the engine harness.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

If the problem occurs only at a certain engine temperature, make sure to check the engine speed sensor circuit while the engine is at that particular temperature.

Check for the correct air gap between the engine speed sensor and the flywheel.

The QSK60G measures engine speed from the gear teeth on the flywheel. Position the flywheel so the sensor is above a tooth to set the gap.

Refer to Troubleshooting Fault Code t05-121.

Last Modified: 07-Oct-2013
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Compressor Outlet Pressure High - Critical

FAULT CODE 1213

Compressor Outlet Pressure High - Critical

Printable Version Printable Version

Overview

Compressor Outlet Pressure High - Critical

CODE | REASON | EFFECT
Fault Code: 1213 PID: P102 SPN: 102 FMI: 0 LAMP: Shutdown SRT: | Compressor Outlet Pressure High - Critical. The compressor outlet pressure has exceeded the high critical threshold. | Engine will shut down.
Compressor Outlet Pressure Sensor Circuit - Multiple Turbochargers
Compressor Outlet Pressure Sensor Circuit - Single Turbocharger

Circuit Description

The compressor outlet pressure sensor monitors the pressure of the air and fuel mixture as it exits the turbocharger compressor. This pressure is monitored by the CM558.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

The compressor outlet pressure is the pressure of the air fuel mixture after as it has exited the turbocharger compressor and prior to entering the throttle. High pressures can be a result of air-to-fuel ratios that are too high.

Refer to Troubleshooting Fault Code t05-1213

Last Modified: 30-Jun-2010


Engine Derate - Condition Exists

FAULT CODE 1243

Engine Derate - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1243 SPN: 3644 FMI: 31 LAMP: Warning SRT: | Engine Derate - Condition Exists | The engine will continue to operate but at less than 100 percent load.
Electronic Control Module

Circuit Description

Engine derate features are only active while the generator set is operating in utility parallel mode. Should an engine derate condition exist, such as Fault Code 3458, then Fault Code 1243 will also be active.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

For generator sets operating in utility parallel applications, a number of engine derate features have been introduced so that power generation can be maintained, but at a reduced output. The level of derate permitted is limited and varies between engine models and software versions.

The engine derate functions may be initiated for the following reason:

  • Engine knock related issues (Fault Code 3458).
Refer to Troubleshooting Fault Code 1243.

Last Modified: 07-Jul-2010


Engine Cylinder Number 10 Knock - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 1274

Engine Cylinder Number 10 Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1274 SPN: 1361 FMI: 0 LAMP: Shut down SRT: | Engine Cylinder Number 10 Knock - Data Valid But Above Normal Operating Range - Most Severe Level | Engine will shut down.
Knock Sensor Circuit - (Multiple and Single Turbocharger Engines)

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignition and knock occurring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of knock is not identified and rectified, engine damage can occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage may occur. Similarly, the engine should not be operated with knock sensors disconnected; this will not initiate a WARNING alarm the engine will continue to operate and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function correctly, it must be installed and tightened to the correct value.

Knock related faults are activated when the knock sensor voltage output exceeds either a warning or high critical threshold for a pre-set period of time.

When the knock high critical threshold is reached and persists for a pre-set period of time, the CM558 will register a critical alarm for the affected cylinder. The CM558 will initiate a critical shut down of the engine.

All detonation related shutdowns and persistent light knock events should be fully investigated in order to prevent engine damage.

The knock sensors can also detect mechanical noise, so mechanically related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and discounted:

  • Valve train/rocker wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever elephant foot o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust (multi-duct) gasket leakage
  • Vibration resulting from loose engine parts/components.

Generator Sets using PowerCommand® Control 3300 (PCC3300) Generator Control:

The PCC3300 Generator Control receives and displays knock levels as a percent , rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC equals 0 percent and 5-VDC equals 112.5 percent, and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from no-knock condition (0 percent) to Most Severe level (100 plus percent).

Refer to Troubleshooting Fault Code 1274.

Last Modified: 08-Jul-2010


Engine Cylinder Number 10 Knock - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1275

Engine Cylinder Number 10 Knock - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1275 SPN: 1361 FMI: 4 LAMP: Warning SRT: | Engine Cylinder Number 10 Knock - Voltage Below Normal or Shorted to Low Source. Low voltage has been detected in the engine cylinder number 10 knock sensor circuit. | No effect on engine performance.
Knock Sensor Circuit - (Multiple and Single Turbocharger Engines)

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur.

In order to provide some system diagnostics, the individual knock sensors are periodically switched outside of their normal operating window. This diagnostic window is timed to coincide with an exhaust valve closing. The knock sensor will detect the noise of the exhaust valve closing and will generate a voltage output. If the CM558 does not register a voltage above a pre-set level, this fault code will be activated.

IMPORTANT NOTE: This protection feature is not active on all engine models and/or all versions of ECM software. Therefore, the engine should not be operated with knock sensors disconnected; the warning alarm will not initiate and the engine will continue to operate. There will be no knock protection for cylinders that have had their knock sensors disconnected.

A faulty or incorrectly fitted knock sensor or knock sensor wiring harness faults, such as open circuit or high resistances, are the most likely cause of this fault.

Generator Sets Using PowerCommand® Control 3300 (PCC3300) Generator Control:

The PCC3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC equals zero percent and 5-VDC equals 112.5 percent, and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from no-knock condition (zero percent) to Most Severe Level (100 plus percent).

Refer to Troubleshooting Fault Code 1275.

Last Modified: 08-Jul-2010


Engine Cylinder Number 11 Knock - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1277

Engine Cylinder Number 11 Knock - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1277 SPN: 1362 FMI: 4 LAMP: Warning SRT: | Engine Cylinder Number 11 Knock - Voltage Below Normal or Shorted to Low Source. Low voltage has been detected in the engine cylinder number 11 knock sensor circuit. | No effect on engine performance.
Knock Sensor Circuit - (Multiple and Single Turbocharger Engines)

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur.

In order to provide some system diagnostics, the individual knock sensors are periodically switched outside of their normal operating window. This diagnostic window is timed to coincide with an exhaust valve closing. The knock sensor will detect the noise of the exhaust valve closing and will generate a voltage output. If the CM558 does not register a voltage above a pre-set level, this fault code will be activated.

IMPORTANT NOTE: This protection feature is not active on all engine models and/or all versions of ECM software. Therefore, the engine should not be operated with knock sensors disconnected; the warning alarm will not initiate and the engine will continue to operate. There will be no knock protection for cylinders that have had their knock sensors disconnected.

A faulty or incorrectly fitted knock sensor or knock sensor wiring harness faults, such as open circuit or high resistances, are the most likely cause of this fault.

Generator Sets Using PowerCommand® Control 3300 (PCC3300) Generator Control:

The PCC3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC equals zero percent and 5-VDC equals 112.5 percent, and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from no-knock condition (zero percent) to Most Severe Level (100 plus percent).

Refer to Troubleshooting Fault Code 1277.

Last Modified: 08-Jul-2010


Engine Cylinder Number 12 Knock - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 1281

Engine Cylinder Number 12 Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1281 SPN: 1363 FMI: 0 LAMP: Shutdown SRT: | Engine Cylinder Number 12 Knock - Data Valid But Above Normal Operating Range - Most Severe Level | Engine will shut down.
Knock Sensor Circuit - (Multiple and Single Turbocharger Engines)

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignition and knock occurring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of knock is not identified and corrected, engine damage can occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur. Similarly, the engine should not be operated with knock sensors disconnected; this will not initiate a WARNING alarm the engine will continue to operate and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function correctly, it must be installed and tightened to the correct value.

Knock-related faults are activated when the knock sensor voltage output exceeds either a warning or high critical threshold for a pre-set period of time.

When the knock high critical threshold is reached and persists for a pre-set period of time, the CM558 will register a critical alarm for the affected cylinder. The CM558 will initiate a critical shutdown of the engine.

All detonation related shutdowns and persistent light knock events should be fully investigated in order to prevent engine damage.

The knock sensors can also detect mechanical noise so mechanically related problems should not be discounted as a cause of detonation shut downs or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and discounted:

  • Valve train/rocker wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever elephant foot o-ring displaced, resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust (multi-duct) gasket leakage
  • Vibration resulting from loose engine parts/components.

Generator Sets using PowerCommand® Control 3300 (PCC3300) Generator Control:

The PCC3300 Generator Control receives and displays knock levels as a percent , rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC equals 0 percent and 5-VDC equals 112.5 percent, and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from no-knock condition (0 percent) to Most Severe level (100 plus percent).

Refer to Troubleshooting Fault Code 1281.

Last Modified: 19-Jul-2010


Engine Cylinder Number 12 Knock - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1282

Engine Cylinder Number 12 Knock - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1282 SPN: 1363 FMI: 4 LAMP: Warning SRT: | Engine Cylinder Number 12 Knock - Voltage Below Normal or Shorted to Low Source. Low voltage has been detected in the engine cylinder number 12 knock sensor circuit. | No effect on engine performance
Knock Sensor Circuit - (Multiple and Single Turbocharger Engines)

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur.

In order to provide some system diagnostics, the individual knock sensors are periodically switched on outside their normal operating window. This diagnostic window is timed to coincide with an exhaust valve closing. The knock sensor will detect the noise of the exhaust valve closing and will generate a voltage output. If the CM558 does not register a voltage above a pre-set level, this fault code will be activated.

IMPORTANT NOTE: This protection feature is not active on all engine models and/or all versions of ECM software. Therefore, the engine should not be operated with knock sensors disconnected; the warning alarm will not initiate and the engine will continue to operate. There will be no knock protection for cylinders that have had their knock sensors disconnected.

A faulty or incorrectly fitted knock sensor or knock sensor wiring harness faults, such as open circuit or high resistances, are the most likely cause of this fault.

Generator Sets Using PowerCommand® Control 3300 (PCC3300) Generator Control:

The PCC3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC equals zero percent and 5-VDC equals 112.5 percent, and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from no-knock condition (zero percent) to Most Severe Level (100 plus percent).

Refer to Troubleshooting Fault Code 1282.

Last Modified: 01-Aug-2010


Engine Cylinder Number 13 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1285

Engine Cylinder Number 13 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1285 PID: SPN: 1364 FMI: 16 LAMP: Shutdown SRT: | Engine Cylinder Number 13 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Cylinder number 13 has exceeded the lower knock count threshold. | The engine will shut down.
Knock Sensor Circuit - Multiple and Single Turbocharger Engines

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Knock sensors are located on each of the cylinder heads. Use the following procedure for component location. Refer to Procedure 019-346 in Section 19.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by a source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to a "pre-ignition" and knock occurring after the normal spark event is known as "detonation". The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of knock is not identified and rectified, engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function correctly, it must be installed and tightened to the correct torque.

Knock-related faults are activated when the knock sensor voltage output exceeds either a Warning or High critical threshold for a pre-set period of time.

When the knock Warning threshold is reached and persists for a pre-set period of time, the CM558 will register a Warning alarm for the affected cylinder and the engine will continue to run. The CM558 will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the CM558 will slowly advance the timing for that cylinder back to its standard timing setting. If the detonation persists, the timing retardation is repeated, up to a maximum of three timing retardations. If, following the final timing, retardation knock is still present, the CM558 will initiate a Critical shutdown of the engine.

All detonation-related shutdowns and persistent light knock events should be fully investigated in order to prevent engine damage.

The knock sensors can also detect mechanical noise, Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever "elephant foot" o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust (multi-duct) gasket leakage
  • Vibration resulting from loose engine parts/components.

Generator Sets using PowerCommand® Control 3300 (PCC3300) Generator Control:

The PCC3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code t05-1285.

Last Modified: 14-Dec-2010


Engine Cylinder Number 13 Knock - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 1286

Engine Cylinder Number 13 Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1286 SPN: 1364 FMI: 16 LAMP: shut down SRT: | Engine Cylinder Number 13 Knock - Data Valid But Above Normal Operating Range - Most Severe Level | The engine will shut down.
Knock Sensor - (Multiple and Single Turbocharger Engines)

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558 ECM.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by a source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignition and knock occurring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of knock is not identified and corrected, engine damage can occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur. Similarly, the engine should not be operated with knock sensors disconnected; this disconnects the warning alarm and the engine will continue to operate. There will be no knock protection for cylinders that have had their knock sensors disconnected. For the knock sensor to function correctly, it must be installed and tightened to the correct value. Knock related faults are activated when the knock sensor voltage output exceeds either a warning or high critical threshold for a pre-set period of time. When the knock high critical threshold is reached and persists for a pre-set period of time, the CM558 will register a critical alarm for the affected cylinder. The CM558 will initiate a critical shut down of the engine.

All detonation related shut downs and persistent light knock events should be fully investigated in order to prevent engine damage.

The knock sensors can also detect mechanical noise so mechanically related problems should not be discounted as a cause of detonation shut downs or high knock counts.

The following mechanical checks should be considered when all other causes of detonation have been investigated and discounted:

  • Valve train/rocker wear.
  • Excessive valve recession.
  • Valve rotator cracked/broken.
  • Rocker lever elephant foot o-ring displaced resulting in mechanical vibration.
  • Connecting rod bushing/bearing excessive wear.
  • Piston cooling nozzle bent or broken.
  • Piston ring damage.
  • Cylinder head gasket leakage.
  • Exhaust (multi-duct) gasket leakage.
  • Vibration resulting from loose engine parts/components.

The PCC3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standard used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC equals 0 percent and 5-VDC equals 112.5 percent, and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from no-knock condition (0 percent) to Most Severe Level (100 plus percent).

Refer to Troubleshooting Fault Code 1286.

Last Modified: 08-Jul-2010


Engine Cylinder Number 13 Knock - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1287

Engine Cylinder Number 13 Knock - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1287 SPN: 1364 FMI: 4 LAMP: Warning SRT: | Engine Cylinder Number 13 Knock - Voltage Below Normal or Shorted to Low Source. Low voltage has been detected in the engine cylinder number 13 knock sensor circuit. | No effect on engine performance
Knock Sensor Circuit - (Multiple and Single Turbocharger Engines)

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur.

In order to provide some system diagnostics, the individual knock sensors are periodically switched outside of their normal operating window. This diagnostic window is timed to coincide with an exhaust valve closing. The knock sensor will detect the noise of the exhaust valve closing and will generate a voltage output. If the CM558 does not register a voltage above a pre-set level, this fault code will be activated.

IMPORTANT NOTE: This protection feature is not active on all engine models and/or all versions of ECM software. Therefore, the engine should not be operated with knock sensors disconnected; the warning alarm will not initiate and the engine will continue to operate. There will be no knock protection for cylinders that have had their knock sensors disconnected.

A faulty or incorrectly fitted knock sensor or knock sensor wiring harness faults, such as open circuit or high resistances, are the most likely cause of this fault.

Generator Sets Using PowerCommand® Control 3300 (PCC3300) Generator Control:

The PCC3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC equals zero percent and 5-VDC equals 112.5 percent, and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from no-knock condition (0 percent) to Most Severe Level (100 plus percent).

Refer to Troubleshooting Fault Code 1287.

Last Modified: 19-Jul-2010


Engine Cylinder Number 14 Knock - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 1291

Engine Cylinder Number 14 Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1291 SPN: 1365 FMI: 0 LAMP: Shutdown SRT: | Engine Cylinder Number 14 Knock - Data Valid But Above Normal Operating Range - Most Severe Level. | The engine will shut down.
Knock Sensor Circuit

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignition and knock occurring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of knock is not identified and corrected, engine damage can occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur. Similarly, the engine should not be operated with knock sensors disconnected; the warning alarm will not alert and the engine will continue to operate. There will be no knock protection for cylinders that have had their knock sensors disconnected. For the knock sensor to function correctly, it must be installed and tightened to the correct value. Knock related faults are activated when the knock sensor voltage output exceeds either a warning or high critical threshold for a pre-set period of time. When the knock warning threshold is reached and persists for a pre-set period of time, the CM558 will register a warning alarm for the affected cylinder and the engine will continue to operate. The CM558 will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the CM558 will slowly advance the timing for that cylinder back to its standard timing setting. If the detonation persists, the timing retardation is repeated, up to a maximum of three timing retardations. If following the final timing retardation, knock is still present, the CM558 will initiate a critical shutdown of the engine. All detonation related shutdowns and persistent light knock events should be fully investigated in order to prevent engine damage. The knock sensors can also detect mechanical noise so mechanically related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and discounted:

  • Valve train/rocker wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever elephant foot o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust (multi-duct) gasket leakage
  • Vibration resulting from loose engine parts/components.

Generator Sets using PowerCommand® Control 3300 (PCC3300) Generator Control:

The PCC3300 Generator Control receives and displays knock levels as a percent , rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC and 5-VDC equals 112.5 percent, and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from no-knock condition (0 percent) to Most Severe Level (100 plus percent) .

Refer to Troubleshooting Fault Code 1291.

Last Modified: 19-Jul-2010


Engine Cylinder Number 14 Knock - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1292

Engine Cylinder Number 14 Knock - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1292 SPN: 1365 FMI: 4 LAMP: Warning SRT: | Engine Cylinder Number 14 Knock - Voltage Below Normal or Shorted to Low Source. Low voltage has been detected in the engine cylinder number 14 knock sensor circuit. | No effect on engine performance
Knock Sensor Circuit - (Multiple and Single Turbocharger Engines)

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur.

In order to provide some system diagnostics, the individual knock sensors are periodically switched outside of their normal operating window. This diagnostic window is timed to coincide with an exhaust valve closing. The knock sensor will detect the noise of the exhaust valve closing and will generate a voltage output. If the CM558 does not register a voltage above a pre-set level, this fault code will be activated.

IMPORTANT NOTE: This protection feature is not active on all engine models and/or all versions of ECM software. Therefore, the engine should not be operated with knock sensors disconnected; the warning alarm will not initiate and the engine will continue to operate. There will be no knock protection for cylinders that have had their knock sensors disconnected.

A faulty or incorrectly fitted knock sensor or knock sensor wiring harness faults, such as open circuit or high resistances, are the most likely cause of this fault.

Generator Sets Using PowerCommand® Control 3300 (PCC3300) Generator Control:

The PCC3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC equals zero percent and 5-VDC equals 112.5 percent, and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from no-knock condition (zero percent) to Most Severe Level (100 plus percent).

Refer to Troubleshooting Fault Code 1292.

Last Modified: 19-Jul-2010


Engine Cylinder Number 15 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1295

Engine Cylinder Number 15 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1295 PID: SPN: 1366 FMI: 16 LAMP: Shutdown SRT: | Engine Cylinder Number 15 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Cylinder number 15 has exceeded the lower knock count threshold. | The engine will shut down.
Knock Sensor Circuit - Multiple and Single Turbocharger Engines

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Knock sensors are located on each of the cylinder heads. Use the following procedure for component location. Refer to Procedure 019-346 in Section 19.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by a source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to a "pre-ignition" and knock occurring after the normal spark event is known as "detonation". The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of knock is not identified and rectified, engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function correctly, it must be installed and tightened to the correct torque.

Knock-related faults are activated when the knock sensor voltage output exceeds either a Warning or High critical threshold for a pre-set period of time.

When the knock Warning threshold is reached and persists for a pre-set period of time, the CM558 will register a Warning alarm for the affected cylinder and the engine will continue to run. The CM558 will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the CM558 will slowly advance the timing for that cylinder back to its standard timing setting. If the detonation persists, the timing retardation is repeated, up to a maximum of three timing retardations. If, following the final timing, retardation knock is still present, the CM558 will initiate a Critical shutdown of the engine.

All detonation-related shutdowns and persistent light knock events should be fully investigated in order to prevent engine damage.

The knock sensors can also detect mechanical noise, Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever "elephant foot" o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust (multi-duct) gasket leakage
  • Vibration resulting from loose engine parts/components.

Generator Sets using PowerCommand® Control 3300 (PCC3300) Generator Control:

The PCC3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code t05-1295.

Last Modified: 14-Dec-2010


Engine Cylinder Number 15 Knock - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 1296

Engine Cylinder Number 15 Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1296 SPN: 1366 FMI: 16 LAMP: Shutdown SRT: | Engine Cylinder Number 15 Knock - Data Valid But Above Normal Operating Range - Most Severe Level | The engine will shut down.
Knock Sensor Circuit - (Multiple and Single Turbocharger Engines)

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignition, and knock occurring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts, within the power cylinder, colliding. If the cause of knock is not identified and corrected, then engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage may occur. Similarly, the engine should not be operated with knock sensors disconnected; this will not initiate a warning alarm. The engine will continue to operate and there will be no knock protection for cylinders that have had their knock sensors disconnected. For the knock sensor to function correctly, it must be installed and tightened to the correct torque value. Knock related faults are activated when the knock sensor voltage output exceeds either a warning or high critical threshold for a pre-set period of time. When the knock warning threshold is reached and persists for a pre-set period of time, then the CM558 will register a warning alarm for the affected cylinder and the engine will continue to operate. The CM558 will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, then the CM558 will slowly advance the timing for that cylinder back to its standard timing setting. If the detonation persists, then the timing retardation is repeated, up to a maximum of three timing retardations. If, following the final timing retardation, knock is still present, the CM558 will initiate a critical shutdown of the engine. All detonation-related shutdowns and persistent light knock events should be fully investigated in order to prevent engine damage. The knock sensors can also detect mechanical noise. Mechanically-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and discounted:

  • Valve train/rocker lever wear.
  • Excessive valve recession
  • Valve rotator cracked/broken.
  • Rocker lever elephant foot o-ring displaced resulting in mechanical vibration.
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken.
  • Piston ring damage.
  • Cylinder head gasket leakage.
  • Exhaust (multi-duct) gasket leakage.
  • Vibration resulting from loose engine parts/components.

Generator Sets using PowerCommand® Control 3300 (PCC3300) Generator Control:

The PCC3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC equals zero percent and 5-VDC equals 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from no-knock (zero percent) condition to Most Severe Level (112.5 plus percent).

Refer to Troubleshooting Fault Code 1296.

Last Modified: 27-Sep-2016


Engine Cylinder Number 15 Knock - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1297

Engine Cylinder Number 15 Knock - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1297 SPN: 1366 FMI: 4 LAMP: Warning SRT: | Engine Cylinder Number 15 Knock - Voltage Below Normal or Shorted to Low Source | No effect on engine performance.
Knock Sensor Circuit - (Multiple and Single Turbocharger Engines)

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur.

In order to provide some system diagnostics, the individual knock sensors are periodically switched outside of their normal operating window. This diagnostic window is timed to coincide with an exhaust valve closing. The knock sensor will detect the noise of the exhaust valve closing and will generate a voltage output. If the CM558 does not register a voltage above a pre-set level, this fault code will be activated.

IMPORTANT NOTE: This protection feature is not active on all engine models and/or all versions of ECM software. Therefore, the engine should not be operated with knock sensors disconnected; the warning alarm will not initiate and the engine will continue to operate. There will be no knock protection for cylinders that have had their knock sensors disconnected.

A faulty or incorrectly fitted knock sensor or knock sensor wiring harness faults, such as open circuit or high resistances, are the most likely cause of this fault.

Generator Sets Using PowerCommand® Control 3300 (PCC3300) Generator Control:

The PCC3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC equals zero percent and 5-VDC equals 112.5 percent, and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from no-knock condition (zero percent) to Most Severe Level (100 plus percent).

Refer to Troubleshooting Fault Code 1297.

Last Modified: 19-Jul-2010


Engine Oil Pressure Sensor Circuit (Rifle) - Shorted High

FAULT CODE 135

Engine Oil Pressure Sensor Circuit (Rifle) - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: 100 SPN: 100 FMI: 3 LAMP: Warning SRT: | Engine Oil Pressure Sensor Circuit (Rifle) - Shorted High. High voltage detected on the Engine Oil Pressure Sensor (Rifle) SIGNAL pin of the CM700. | Fault Codes 142, 143, and 415 are disabled. No engine protection for oil pressure.
Engine Oil Pressure Sensor - Multiple Turbochargers
Engine Oil Pressure Sensor - Multiple Turbochargers Generator Drive
Engine Oil Pressure Sensor - Single Turbocharger

Circuit Description

The CM700 engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The CM700 also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the CM700 on the engine oil pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the oil rifle. The CM700 will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The CM700 will detect a high signal voltage during operating conditions when the oil temperature is low or engine speed is high.

Component Location

The engine oil pressure sensor is located on the flywheel housing.

The CM700 is located within the original equipment manufacturer (OEM) control panel. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the ECM keyswitch is in the ON position

Conditions for Setting the Fault Codes

The ECM detects that the engine oil pressure signal voltage is greater than 4.75-VDC for 3 seconds. The default persistence time is 3 seconds for this fault code, but the persistence time may have a different setting for specific CM700 software versions and engine applications.

Action Taken When the Fault Code is Active

  • The CM700 illuminates the amber ALARM WARNING lamp on the generator control panel immediately when the diagnostic runs and fails. Fault Code 135 will also show as active by INSITE™ electronic service tool and on the OEM control panel Human Machine Interface (HMI) display.
  • A default value of the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The CM700 will turn off the amber ALARM WARNING lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

Does the fault code occur only in cold weather and following an extended engine shutdown? If so, check that the engine heaters are switched on and functioning correctly. Allow the engine oil to warm up and see if the fault code goes INACTIVE.

If the oil pressure sensor shares SUPPLY and RETURN wires in the engine harness with other sensors, open and short circuits in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 135, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-135.

Last Modified: 12-Aug-2013


Engine Oil Pressure Sensor Circuit (Pre-filter) - Shorted High

FAULT CODE 136

Engine Oil Pressure Sensor Circuit (Pre-filter) - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 136 PID: SPN: 1208 FMI: 3 LAMP: Warning SRT: | Engine Oil Pressure Sensor Circuit (Pre-filter) - Shorted High. High voltage detected on the engine oil pressure sensor (pre-filter) SIGNAL pin of the main harness CM700 connector. | Fault Code 481 is disabled.
Engine Pre-Oil Filter Oil Pressure Sensor Circuit - Single and Multiple Turbochargers

Circuit Description

The CM700 engine control module (ECM) provides a 5 volt supply to the pre-filter oil pressure sensor on the sensor supply circuit. The CM700 also provides a ground on the sensor return circuit. The engine pre-filter oil pressure sensor provides a signal to the CM700 on the engine pre-filter oil pressure sensor signal circuit. This sensor signal voltage changes, based on the oil pressure before the oil filters.

Component Location

The engine pre-filter oil pressure sensor is located on the oil filter head.

The CM700 is located within the original equipment manufacturer (OEM) control panel. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the ECM keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the pre-filter oil pressure signal voltage is greater than 4.75-VDC for 3 seconds. The default persistence time is 3 seconds for this fault code, but the persistence time may have a different setting for specific CM700 software versions and engine applications.

Action Taken When the Fault Code is Active

  • The CM700 illuminates the amber ALARM WARNING lamp on the generator control panel immediately when the diagnostic runs and fails. Fault code 136 will also shown as active by INSITE™ electronic service tool and on the OEM control panel Human Machine Interface (HMI) display.
  • A default value of the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair start the engine and let it run for 1 minute at no load.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostics runs and passes.
  • The CM700 will turn off the amber ALARM WARNING lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

Does the fault occur only in cold weather and following an extended engine shutdown? If so, check the engine heaters are switched on and functioning correctly. Allow the engine oil to warm up and see if the fault code goes inactive.

If the pre-filter oil pressure sensor shares supply and return wires in the engine harness with other sensors, open and short circuits in the engine harness can cause multiple fault codes to be active.

Before troubleshooting Fault Code 136, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-136.

Last Modified: 12-Aug-2013


Engine Oil Filter Restriction High - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1362

Engine Oil Filter Restriction High - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1362 PID: 99 SPN: 99 FMI: 16 LAMP: Warning SRT: | Engine Oil Filter Restriction High - Data Valid But Above Normal Operating Range - Moderately Severe Level. The engine oil filter differential pressure, measured by the inlet and outlet oil filter pressure sensors, has exceeded the Warning threshold level. | No effect on engine performance.
QSK60 G Multiple Turbochargers with Generator Control Panel 1 (GCP1) and PowerCommand™ Supervisor 3100 - Engine Oil Filter Differential Pressure Circuit
QSK60 G Single and Multiple Turbochargers with Generator Control Panel 2 (GCP2) and PowerCommand™ Supervisor 3100 - Engine Oil Filter Differential Pressure Circuit
QSK60 G Single and Multiple Turbochargers with PowerCommand™ Control 3300 - Engine Oil Filter Differential Pressure Circuit

Circuit Description

The engine oil filter differential pressure is monitored by the CM700 module via pressure sensors fitted before and after the oil filtration. The pre-oil filter pressure sensor (inlet) monitors the oil pressure before the oil filters. The post-oil filter pressure sensor (outlet) monitors the oil pressure after the oil filters. The CM700 monitors the voltage on the SIGNAL pin and converts this to a pressure value.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Fault Code 1362 will become active when the difference between the oil pressure at the inlet and outlet of the oil filter head reaches a preset Warning threshold. Reasons for this fault code include:

  • Plugged oil filters
  • Damaged sensors or harness
  • Plugged oil filter head.
Refer to Troubleshooting Fault Code 1362.

Last Modified: 10-Feb-2011


Engine Oil Pressure Sensor Circuit (Pre-filter) - Shorted Low

FAULT CODE 137

Engine Oil Pressure Sensor Circuit (Pre-filter) - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 137 PID: SPN: 1208 FMI: 4 LAMP: Warning SRT: | Engine Oil Pressure Sensor Circuit (Pre-filter) - Shorted Low. Low voltage detected on the engine oil pressure sensor (pre-filter) SIGNAL pin of the main harness CM700 connector. | Fault Code 481 is disabled.
Engine Pre-Oil Filter Oil Pressure Sensor Circuit - Single and Multiple Turbochargers

Circuit Description

The CM700 engine control module (ECM) provides a 5 volt supply to the pre-filter oil pressure sensor on the sensor supply circuit. The CM700 also provides a ground on the sensor return circuit. The engine pre-filter oil pressure sensor provides a signal to the CM700 on the engine pre-filter oil pressure sensor signal circuit. This sensor signal voltage changes, based on the oil pressure before the oil filters.

Component Location

The engine pre-filter oil pressure sensor is located on the oil filter head.

The CM700 is located within the original equipment manufacturer (OEM) control panel. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the ECM keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the pre-filter oil pressure signal voltage is less than 0.25-VDC for 3 seconds. The default persistence time is 3 seconds for this fault code, but the persistence time may have a different setting for specific CM700 software versions and engine applications.

Action Taken When the Fault Code is Active

  • The CM700 illuminates the amber ALARM WARNING lamp on the generator control panel immediately when the diagnostic runs and fails. Fault code 137 will also show as active by INSITE™ electronic service tool and on the OEM control panel Human Machine Interface (HMI) display.
  • A default value of the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostics runs and passes.
  • The CM700 will turn off the amber ALARM WARNING lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

Does the fault occur only in cold weather and following an extended engine shutdown? If so, check the engine heaters are switched on and functioning correctly. Allow the engine oil to warm up and see if the fault code goes inactive.

If the pre-filter oil pressure sensor shares supply and return wires in the engine harness with other sensors, open and short circuits in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 137, check for multiple fault codes.

Possible causes of this fault code include:

  • Supply wire open circuit or short to ground in the harness, connectors, or sensor
  • Signal wire open circuit or short to ground.
Refer to Troubleshooting Fault Code t05-137.

Last Modified: 10-Sep-2013


Engine Oil Pressure Sensor Circuit (Rifle) - Shorted Low

FAULT CODE 141

Engine Oil Pressure Sensor Circuit (Rifle) - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: 100 SPN: 100 FMI: 4 LAMP: Warning SRT: | Engine Oil Pressure Sensor Circuit (Rifle) - Shorted Low. Low voltage detected on the oil pressure sensor (rifle) SIGNAL pin of the main harness CM700 connector. | Fault Codes 142, 143, and 415 are disabled. No engine protection for oil pressure.
Engine Oil Pressure Sensor (Rifle) - Single and Multiple Turbocharger Engine Models

Circuit Description

The CM700 engine control module (ECM) provides a 5 volt supply to the oil pressure sensor on the sensor supply circuit. The CM700 also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the CM700 on the engine oil pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the oil rifle. The CM700 will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The CM700 will detect a high signal voltage during operating conditions when the oil temperature is low or engine speed is high.

Component Location

The engine oil pressure sensor is located on the flywheel housing.

The CM700 is located within the original equipment manufacturer (OEM) control panel. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the ECM keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil pressure signal voltage is less than 0.25-VDC for 3 seconds. The default persistence time is 3 seconds for this fault code, but the persistence time may have a different setting for specific CM700 software versions and engine applications.

Action Taken When the Fault Code is Active

  • The CM700 illuminates the amber ALARM WARNING lamp on the generator control panel immediately when the diagnostic runs and fails. Fault Code 141 will also shown as active by INSITE™ electronic service tool and on the OEM control panel Human Machine Interface (HMI) display.
  • A default value of the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The CM700 will turn off the amber ALARM WARNING lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

Does the fault occur only in cold weather and following an extended engine shutdown? If so, check that the engine heaters are switched on and functioning correctly. Allow the engine oil to warm up and see if the fault code goes inactive.

If the oil pressure sensor shares SUPPLY and RETURN wires in the engine harness with other sensors, open and short circuits in the engine harness can cause multiple fault codes to be active.

Before troubleshooting Fault Code 141, check for multiple fault codes.

Possible causes of this fault code include:

  • SUPPLY wire open circuit or shorted to ground in the harness, connectors, or sensor
  • SIGNAL wire open circuit or shorted to ground.
Refer to Troubleshooting Fault Code t05-141.

Last Modified: 12-Aug-2013


Engine Oil Pressure (Rifle) High - Warning

FAULT CODE 142

Engine Oil Pressure (Rifle) High - Warning

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 142 PID: P100 SPN: 100 FMI: 16 LAMP: Warning SRT: | Engine Oil Pressure (Rifle) High - Warning. The engine oil pressure (rifle) has exceeded the high warning threshold. | No effect on engine performance.
Engine Oil Pressure Sensor Circuit - Single and Multiple Turbocharger Engine Models

Circuit Description

The CM700 engine control module (ECM) provides a 5 volt supply to the oil pressure sensor on the sensor supply circuit. The CM700 also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the CM700 on the engine oil pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the oil rifle. The CM700 will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The CM700 will detect a high signal voltage during operating conditions when the oil temperature is low or engine speed is high.

Component Location

The engine oil pressure sensor is located on the flywheel housing.

The CM700 is located within the original equipment manufacturer (OEM) control panel. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the ECM keyswitch is in the ON position and the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil pressure is greater than the engine protection limit for 3 seconds. The default persistence time is 3 seconds for this fault code, but the persistence time may have a different setting for specific CM700 software versions and engine applications.

Action Taken When the Fault Code is Active

  • The CM700 illuminates the amber ALARM WARNING lamp on the generator control panel immediately when the diagnostic runs and fails. Fault Code 142 will also show as active by INSITE™ electronic service tool and on the OEM control panel Human Machine Interface (HMI) display.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The CM700 will turn off the amber ALARM WARNING lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

Does the fault occur only in cold weather and following an extended engine shutdown? If so, check that the engine heaters are switched on and functioning correctly. Allow the engine oil to warm up, operate the engine, and see if the fault code goes inactive.

Refer to Troubleshooting Fault Code t05-142.

Last Modified: 12-Aug-2013


Engine Oil Pressure (Rifle) Low - Warning

FAULT CODE 143

Engine Oil Pressure (Rifle) Low - Warning

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 18 LAMP: Warning SRT: | Engine Oil Pressure (Rifle) Low - Warning. The engine oil pressure (rifle) has dropped below the low warning threshold. | No effect on engine performance.
Engine Oil Pressure Sensor Circuit - Single and Multiple Turbocharger Engine Models

Circuit Description

The CM700 engine control module (ECM) provides a 5 volt supply to the oil pressure sensor on the sensor supply circuit. The CM700 also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the CM700 on the engine oil pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the oil rifle. The CM700 will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The CM700 will detect a high signal voltage during operating conditions when the oil temperature is low or engine speed is high.

If the CM700 detects low signal voltage, indicating low oil pressure, the fault code is activated.

Component Location

The engine oil pressure sensor is located on the flywheel housing.

The CM700 is located within the original equipment manufacturer (OEM) control panel. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the ECM keyswitch is in the ON position and the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the engine oil pressure is less than the engine protection limit for 3 seconds. The default persistence time is 3 seconds for this fault code, but the persistence time may have a different setting for specific CM700 software versions and engine applications.

Action Taken When the Fault Code is Active

The CM700 illuminates the amber ALARM WARNING lamp on the generator control panel immediately when the diagnostic runs and fails. Fault code 143 will also show as active by INSITE™ electronic service tool and on the OEM control panel Human Machine Interface (HMI) display.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The CM700 will turn off the amber ALARM WARNING lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

This fault code goes active when the oil pressure drops below the engine protection limit. Troubleshoot the engine for low oil pressure.

Refer to Troubleshooting Fault Code t05-143.

Last Modified: 12-Aug-2013


Operator Interface Mode Transition to Emergency Stop (due to Remote E-Stop) - Condition Exists

FAULT CODE 1434

Operator Interface Mode Transition to Emergency Stop (due to Remote E-Stop) - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1434 PID: SPN: 611 FMI: 31 LAMP: Red/Shutdown SRT: | Operator Interface Mode Transition to Emergency Stop (due to Remote E-Stop) - Condition Exists. Operator interface mode transition to emergency stop (due to remote E-Stop). | Engine will shut down and will not restart until the remote emergency stop switch has been reset.

Circuit Description

The remote emergency stop switches are used by the operator to initiate an E-Stop, if an emergency condition exists.

Component Location

Use the following procedure for the location of the emergency stop switches. Refer to Procedure 100-002 in Section E.

The location of some remote emergency stop switches will be site specific. Operators and service technicians must locate these switches before commencing work or operating the generator set.

Refer to Troubleshooting Fault Code t05-1434.

Last Modified: 10-Feb-2011


Engine Coolant Temperature Sensor Circuit (High Temperature) - Shorted High

FAULT CODE 144

Engine Coolant Temperature Sensor Circuit (High Temperature) - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3 LAMP: Warning SRT: | Engine Coolant Temperature Sensor Circuit (High Temperature) - Shorted High | No engine protection for coolant temperature.
Engine Coolant Temperature Sensor Circuit - Multiple Turbochargers
Engine Coolant Temperature Sensor Circuit - Single Turbocharger

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The CM700 engine control module (ECM) supplies 5 volts to the coolant temperature circuit. The CM700 monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the engine ECMs for the engine protection system and emissions control.

Component Location

The engine coolant temperature sensor (high temperature) is located on the right bank side of the high temperature coolant thermostat housing, and is directly below the low temperature coolant thermostat housing.

The CM700 is located within the original equipment manufacturer (OEM) control panel. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the ECM keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the high temperature coolant signal is greater than 4.95-VDC for 3 seconds. The default persistence is time 3 seconds for this fault code, but the persistence time may have a different setting for specific CM700 software versions and engine applications.

Action Taken When the Fault Code is Active

  • The CM700 illuminates the amber ALARM WARNING lamp on the generator control panel immediately when the diagnostic runs and fails. Fault Code 144 will also show as active by INSITE™ electronic service tool and on the OEM control panel display.
  • A default value is used for the engine coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The CM700 will turn off the amber ALARM WARNING lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. A fault on the return circuit can cause multiple fault codes to be active.

Before troubleshooting Fault Code 144, check for multiple fault codes.

Possible causes of this fault code include:

  • Open circuit return wire in the harness, connectors, or sensor
  • Open circuit or shorted to a voltage source in the signal wire.
Refer to Troubleshooting Fault Code t05-144.

Last Modified: 22-May-2013


Engine Coolant Temperature Sensor Circuit (High Temperature) - Shorted Low

FAULT CODE 145

Engine Coolant Temperature Sensor Circuit (High Temperature) - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: 110 SPN: 110 FMI: 4 LAMP: Warning SRT: | Engine Coolant Temperature Sensor Circuit (High Temperature) - Shorted Low | No engine protection for coolant temperature.
Engine Coolant Temperature Sensor Circuit - Multiple Turbochargers
Engine Coolant Temperature Sensor Circuit - Single Turbocharger

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The CM700 engine control module (ECM) supplies 5 volts to the coolant temperature circuit. The CM700 monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the engine ECMs for the engine protection system and emissions control.

Component Location

The engine coolant temperature sensor (high temperature) is located on the right bank side of the high temperature coolant thermostat housing, and is directly below the low temperature coolant thermostat housing.

The CM700 is located within the original equipment manufacturer (OEM) control panel. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the ECM keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The ECM detects that the high temperature coolant signal is less than 0.5-VDC for 3 seconds. The default persistence time is 3 seconds for this fault code, but the persistence time may have a different setting for specific CM700 software versions and engine applications.

Action Taken When the Fault Code is Active

  • The CM700 illuminates the amber ALARM WARNING lamp on the generator control panel immediately when the diagnostic runs and fails. Fault Code 145 will also show as active by INSITE™ electronic service tool and on the OEM control panel display.
  • A default value is used for the engine coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The CM700 will turn off the amber ALARM WARNING lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. A shorted return circuit can cause multiple fault codes to be active.

Before troubleshooting Fault Code 145, check for multiple fault codes.

Possible causes of this fault code include:

  • Short to ground in the SIGNAL wire in the harness or connectors
  • Signal circuit shorted to return or ground in the sensor.

Possible causes of this fault code include:

  • Short to ground in the SIGNAL wire in the harness or connectors
  • Signal circuit shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code t05-145.

Last Modified: 22-May-2013


Generator Synchronizing to Electric Bus Failed - Condition Exists

FAULT CODE 1457

Generator Synchronizing to Electric Bus Failed - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1457 PID: SPN: 2529 FMI: 31 LAMP: Amber SRT: | Generator Synchronizing to Electric Bus Failed - Condition Exists. The generator set synchronization to the system electric bus has malfunctioned. | The generator set will continue to run, but the generator set will not close its breaker or pick-up load.

Circuit Description

The generator set picks up electrical load from the system electric bus. For the generator set to connect to the bus (other than a dead bus), it must match, within a preset threshold, the voltage, frequency, and phase rotation of the bus. The generator set can not connect to the bus while voltage and frequency are outside of the threshold, and the phase rotation between the generator set and the bus does not match; otherwise, serious damage can occur to the generator set.

The generator set control panel transmits certain generator set parameters to the engine parent control module (CM700) by way of a data link. The generator set control system will inform the operator that the generator set has not synchronized to the system electric bus by displaying a fault code on the generator set control panel. The engine CM700 module will also generate Fault Code 1457.

Component Location

For the location of the generator set circuit breakers, use the customer/facility/installation documentation.

For the generator set component locations, Refer to Procedure 100-002 in Section E.

Shop Talk

The generator set control fault code is dependant on the model of the control panel installed. The fault code generated will be as follows:

  • Cummins® PowerCommand® Supervisor (PCS) 3100: Fault Code 224.
  • Cummins® PowerCommand® Controller (PCC) 3300: Fault Code 1457.

The fault codes must be cleared on both the generator set and engine control systems before the generator set can be restarted.

The alarm condition of this fault is configurable via the generator set controller front panel, or by connecting the Cummins Power Generation™ electronic service tool - InPower™. The operator/service technician, can set this fault code to either '"WARNING", in which case the generator set will continue to run but not take load, or "SHUTDOWN", in which case the generator set will shutdown. The factory default setting for this fault code is set as "WARNING".

Generator set related problems that can activate this fault code are:

  • Incorrect adjustment of bus or generator set voltage (control panel calibration)
  • Malfunctioning power transformer module
  • Generator set controller synchronizing permissive window parameters incorrectly set
  • Generator set control panel circuit board faults
  • Generator set harness faults.

Troubleshooting of the generator set control panel is outside of the scope of this document. For guidance on generator set control panel troubleshooting, go to the applicable control panel service manual:

  • Cummins® PowerCommand® Supervisor (PCS) 3100: Service Manual, Bulletin A034T570.
  • Cummins® PowerCommand® Controller (PCC) 3300: Service Manual, Bulletin 0900-0670.

The throttle plate commanded signal and the feedback signal can be monitored with the electronic service tool. If the difference between the commanded position and the feedback position signal is greater than the fault threshold, which is pre-set to 30 percent, then Fault Code 177 will be set.

The throttle assembly can be tested using the electronic service tool. To conduct this test, the engine rpm must be at zero. The throttle plate can be commanded to any position between 0 percent and 100 percent and the feedback signal compared with the commanded signal.

The most likely causes for this fault being activated are:

  • Mechanical seizure of the throttle shaft/bearings
  • A fault with the throttle plate position feedback circuit.
Refer to Troubleshooting Fault Code t05-1457.

Last Modified: 05-Oct-2011


Engine Coolant Temperature (High Temperature) High - Warning

FAULT CODE 146

Engine Coolant Temperature (High Temperature) High - Warning

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: P110 SPN: 1100 FMI: 16 LAMP: Warning SRT: | Engine Coolant Temperature (High Temperature) High - Warning. The engine coolant temperature (high-temperature) has exceeded the high warning threshold. | No effect on engine performance.
Engine Coolant Temperature Sensor Circuit - Multiple Turbochargers
Engine Coolant Temperature Sensor Circuit - Single Turbocharger

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The CM700 engine control module (ECM) supplies 5 volts to the coolant temperature circuit. The CM700 monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the engine ECMs for the engine protection system and emissions control. This fault code indicates that the engine coolant temperature has exceeded the engine protection limit.

Component Location

The engine coolant temperature sensor (high temperature) is located on the right bank side of the high temperature coolant thermostat housing, and is directly below the low temperature coolant thermostat housing.

The CM700 is located within the original equipment manufacturer (OEM) control panel. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the ECM keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the high temperature coolant signal is greater than 93°C [200°F] for 3 seconds. The default persistence time is 3 seconds for this fault code, but the persistence time may have a different setting for specific CM700 software versions and engine applications.

Action Taken When the Fault Code is Active

  • The CM700 illuminates the amber ALARM WARNING lamp on the generator control panel immediately when the diagnostic runs and fails. Fault code 146 will also show as active by INSITE™ electronic service tool and on the OEM control panel display.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The CM700 will turn off the amber ALARM WARNING lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

This fault code indicates that the coolant temperature (high temperature coolant circuit) has exceeded the engine protection limit for high coolant temperature. Reference the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS of the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. OEM-supplied balance-of-plant equipment can also cause Fault Code 146 to be activated. This equipment must be confirmed as working correctly when troubleshooting this fault code.

OEM-supplied equipment includes (but not limited to):

  • Radiators
  • Electrically driven radiator fans
  • Off-engine electrically driven coolant circulation pumps
  • Heat exchangers
  • Coolant deaeration lines
  • Cooling system pressure vessels
  • Electrically driven coolant flow control valves.
Refer to Troubleshooting Fault Code t05-146.

Last Modified: 22-May-2013


Software Version Mismatch Between Master Controller and Extended I/O Board - Condition Exists

FAULT CODE 1474

Software Version Mismatch Between Master Controller and Extended I/O Board - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1474 PID: SPN: 520211 FMI: 31 LAMP: Red/Shutdown SRT: | Software Version Mismatch Between Master Controller and Extended I/O Board - Condition Exists. The ECM has detected a software version conflict on one or more modules. | The engine will not be allowed to start.
Electronic Service Tool

Circuit Description

The CM700 and CM558 modules require software, often referred to as calibrations, to perform control functions and provide engine protection.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The ECM function and control can change with software versions. The electronic service tool and ECM perform automatic checks to make certain the CM700 and CM558 software versions are compatible. If the ECM automatic check identifies incompatible software, Fault Code 1474 will be activated.

The fault code description "Software Version Mismatch between the Master Controller and Extended I/O Board - Condition Exists" is only generated by the CM558 modules. The "Calibration Compatibility State" in the CM700 module would show an appropriate message, such as "Engine Control Module Calibration Out-of-Date".

Refer to Troubleshooting Fault Code t05-1474.

Last Modified: 10-Feb-2011


Engine Coolant Temperature (High Temperature) High - Critical

FAULT CODE 151

Engine Coolant Temperature (High Temperature) High - Critical

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0 LAMP: Shutdown SRT: | Engine Coolant Temperature (High Temperature) High - Critical. The engine coolant temperature (high temperature) has exceeded the high critical threshold. | Engine will shut down.
Engine Coolant Temperature Sensor Circuit - Multiple Turbochargers
Engine Coolant Temperature Sensor Circuit - Single Turbocharger

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The CM700 engine control module (ECM) supplies 5 volts to the coolant temperature circuit. The CM700 monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

The engine coolant temperature value is used by the engine ECMs for the engine protection system and emissions control. This fault code indicates that the engine coolant temperature has exceeded the engine protection limit.

Component Location

The engine coolant temperature sensor (high temperature) is located on the right bank side of the high temperature coolant thermostat housing, and is directly below the low temperature coolant thermostat housing.

The CM700 is located within the original equipment manufacturer (OEM) control panel. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the ECM keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the high temperature coolant signal is greater than 104°C [220°F] for 3 seconds. The default persistence time is 3 seconds for this fault code, but the persistence time may have a different setting for specific CM700 software versions and engine applications.

Action Taken When the Fault Code is Active

  • The CM700 illuminates the amber ALARM WARNING lamp on the generator control panel immediately when the diagnostic runs and fails. Fault Code 151 will also show as active by INSITE™ electronic service tool and on the OEM control panel display.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The CM700 will turn off the amber ALARM WARNING lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

This fault code indicates that the coolant temperature (high temperature coolant circuit) has exceeded the engine protection limit for high coolant temperature. Reference the Engine Coolant Temperature Above Normal troubleshooting symptom tree in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. OEM-supplied balance-of-plant equipment can also cause Fault Code 151 to be activated. This equipment must be confirmed as working correctly when troubleshooting this fault code.

OEM-supplied equipment includes (but not limited to):

  • Radiators
  • Electrically driven radiator fans
  • Off-engine electrically driven coolant circulation pumps
  • Heat exchangers
  • Coolant deaeration lines
  • Cooling system pressure vessels
  • Electrically driven coolant flow control valves.
Refer to Troubleshooting Fault Code t05-151.

Last Modified: 22-May-2013


Fault Code Path Selection

FAULT CODE 1521
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc1521mt
Is this engine equipped with a single turbocharger? | Go to 59-fc1521st

Last Modified: 07-Oct-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1521 - Multiple Turbochargers

Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1521 PID: SPN: 1139 FMI: 3 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 3. | No effect on engine performance. No engine protection for exhaust gas temperature.
Cylinder 3 (A2) Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a 'high voltage' detected on the sensor circuit (short to a high source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature / engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 1521 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

Refer to Troubleshooting Fault Code t05-1521mt

Last Modified: 14-Jan-2011


Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1521 - Single Turbocharger

Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1521 PID: SPN: 1139 FMI: 3 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 3. | No effect on engine performance. No engine protection for exhaust gas temperature.
Cylinder 3 (A2) (Single Turbocharger) -Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules – one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0-5-VDC thermister-type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘high voltage’ detected on the sensor circuit (short to a high source), the monitoring system is unable to detect any low exhaust temperatures caused by an engine misfire. This means that the low exhaust gas temperature / engine misfire protection for the affected cylinder in ineffective.

Should Fault Code 1521 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

Refer to Troubleshooting Fault Code t05-1521st

Last Modified: 13-Dec-2010


Fault Code Path Selection

FAULT CODE 1522
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc1522mt
Is this engine equipped with a single turbocharger? | Go to 59-fc1522st

Last Modified: 07-Oct-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1522 - Multiple Turbochargers

Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1522 PID: SPN: 1141 FMI: 3 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 5. | No effect on engine performance. No engine protection for exhaust gas temperature.
Cylinder 5 (A3) Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a 'high voltage' detected on the sensor circuit (short to a high source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature / engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 1522 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

Refer to Troubleshooting Fault Code t05-1522mt

Last Modified: 14-Jan-2011


Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1522 - Single Turbocharger

Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1522 PID: SPN: 1141 FMI: 3 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 5. | No effect on engine performance. No engine protection for exhaust gas temperature.
Cylinder 5 (A3) (Single Turbocharger) -Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules – one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0-5-VDC thermister-type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘high voltage’ detected on the sensor circuit (short to a high source), the monitoring system is unable to detect any low exhaust temperatures caused by an engine misfire. This means that the low exhaust gas temperature / engine misfire protection for the affected cylinder in ineffective.

Should Fault Code 1522 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

Refer to Troubleshooting Fault Code t05-1522st

Last Modified: 13-Dec-2010


Fault Code Path Selection

FAULT CODE 1523
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc1523mt
Is this engine equipped with a single turbocharger? | Go to 59-fc1523st

Last Modified: 07-Oct-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1523 - Multiple Turbochargers

Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1523 PID: SPN: 1143 FMI: 3 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 7. | No effect on engine performance. No engine protection for exhaust gas temperature.
Cylinder 7 (A4) Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a 'high voltage' detected on the sensor circuit (short to a high source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature / engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 1523 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

Refer to Troubleshooting Fault Code t05-1523mt

Last Modified: 14-Jan-2011


Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1523 - Single Turbocharger

Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1523 PID: SPN: 1143 FMI: 3 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 7. | No effect on engine performance. No engine protection for exhaust gas temperature.
Cylinder 7 (A4) (Single Turbocharger) -Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules – one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0-5-VDC thermister-type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘high voltage’ detected on the sensor circuit (short to a high source), the monitoring system is unable to detect any low exhaust temperatures caused by an engine misfire. This means that the low exhaust gas temperature / engine misfire protection for the affected cylinder in ineffective.

Should Fault Code 1523 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

Refer to Troubleshooting Fault Code t05-1523st

Last Modified: 13-Dec-2010


Fault Code Path Selection

FAULT CODE 1524
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc1524mt
Is this engine equipped with a single turbocharger? | Go to 59-fc1524st

Last Modified: 07-Oct-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1524 - Multiple Turbochargers

Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1524 PID: SPN: 1145 FMI: 3 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 9. | No effect on engine performance. No engine protection for exhaust gas temperature.
Cylinder 9 (A5) Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a 'high voltage' detected on the sensor circuit (short to a high source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature / engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 1524 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

Refer to Troubleshooting Fault Code t05-1524mt

Last Modified: 14-Jan-2011


Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1524 - Single Turbocharger

Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1524 PID: SPN: 1145 FMI: 3 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 9. | No effect on engine performance. No engine protection for exhaust gas temperature.
Cylinder 9 (A5) (Single Turbocharger) -Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules – one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0-5-VDC thermister-type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘high voltage’ detected on the sensor circuit (short to a high source), the monitoring system is unable to detect any low exhaust temperatures caused by an engine misfire. This means that the low exhaust gas temperature / engine misfire protection for the affected cylinder in ineffective.

Should Fault Code 1524 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

Refer to Troubleshooting Fault Code t05-1524st

Last Modified: 13-Dec-2010


Fault Code Path Selection

FAULT CODE 1525
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc1525mt
Is this engine equipped with a single turbocharger? | Go to 59-fc1525st

Last Modified: 07-Oct-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1525 - Multiple Turbochargers

Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1525 PID: SPN: 1147 FMI: 3 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 11. | No effect on engine performance. No engine protection for exhaust gas temperature.
Cylinder 11 (A6) Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a 'high voltage' detected on the sensor circuit (short to a high source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature / engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 1525 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

Refer to Troubleshooting Fault Code t05-1525mt

Last Modified: 14-Jan-2011


Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1525 - Single Turbocharger

Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1525 PID: SPN: 1147 FMI: 3 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 11. | No effect on engine performance. No engine protection for exhaust gas temperature.
Cylinder 11 (A6) (Single Turbocharger) -Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules – one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0-5-VDC thermister-type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘high voltage’ detected on the sensor circuit (short to a high source), the monitoring system is unable to detect any low exhaust temperatures caused by an engine misfire. This means that the low exhaust gas temperature / engine misfire protection for the affected cylinder in ineffective.

Should Fault Code 1525 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

Refer to Troubleshooting Fault Code t05-1525st

Last Modified: 07-Jan-2013


Fault Code Path Selection

FAULT CODE 1526
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc1526mt
Is this engine equipped with a single turbocharger? | Go to 59-fc1526st

Last Modified: 07-Oct-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1526 - Multiple Turbochargers

Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1526 PID: SPN: 1149 FMI: 3 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 13. | No effect on engine performance. No engine protection for exhaust gas temperature.
Cylinder 13 (A7) Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a 'high voltage' detected on the sensor circuit (short to a high source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature / engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 1526 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

Refer to Troubleshooting Fault Code t05-1526mt

Last Modified: 14-Jan-2011


Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1526 - Single Turbocharger

Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1526 PID: SPN: 1149 FMI: 3 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 13. | No effect on engine performance. No engine protection for exhaust gas temperature.
Cylinder 13 (A7) (Single Turbocharger) -Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules – one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0-5-VDC thermister-type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘high voltage’ detected on the sensor circuit (short to a high source), the monitoring system is unable to detect any low exhaust temperatures caused by an engine misfire. This means that the low exhaust gas temperature / engine misfire protection for the affected cylinder in ineffective.

Should Fault Code 1526 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

Refer to Troubleshooting Fault Code t05-1526st

Last Modified: 13-Dec-2010


Fault Code Path Selection

FAULT CODE 1527
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc1527mt
Is this engine equipped with a single turbocharger? | Go to 59-fc1527st

Last Modified: 07-Oct-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1527 - Multiple Turbochargers

Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1527 PID: SPN: 1151 FMI: 3 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 15. | No effect on engine performance. No engine protection for exhaust gas temperature.
Cylinder 15 (A8) Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a 'high voltage' detected on the sensor circuit (short to a high source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature / engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 1527 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

Refer to Troubleshooting Fault Code t05-1527mt

Last Modified: 14-Jan-2011


Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1527 - Single Turbocharger

Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1527 PID: SPN: 1151 FMI: 3 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 15. | No effect on engine performance. No engine protection for exhaust gas temperature.
Cylinder 15 (A8) (Single Turbocharger) -Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules – one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0-5-VDC thermister-type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘high voltage’ detected on the sensor circuit (short to a high source), the monitoring system is unable to detect any low exhaust temperatures caused by an engine misfire. This means that the low exhaust gas temperature / engine misfire protection for the affected cylinder in ineffective.

Should Fault Code 1527 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

Refer to Troubleshooting Fault Code t05-1527st

Last Modified: 13-Dec-2010


Fault Code Path Selection

FAULT CODE 1529
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc1529mt
Is this engine equipped with a single turbocharger? | Go to 59-fc1529st

Last Modified: 07-Oct-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1529 - Multiple Turbochargers

Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1529 PID: SPN: 1138 FMI: 3 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 2. | No effect on engine performance. No engine protection for exhaust gas temperature.
Cylinder 2 (B1) Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a 'high voltage' detected on the sensor circuit (short to a high source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature / engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 1529 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

Refer to Troubleshooting Fault Code t05-1529mt

Last Modified: 07-Jan-2011


Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1529 - Single Turbocharger

Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1529 PID: SPN: 1138 FMI: 3 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 2. | No effect on engine performance. No engine protection for exhaust gas temperature.
Cylinder 2 (B1) (Single Turbocharger) -Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules – one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0-5-VDC thermister-type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘high voltage’ detected on the sensor circuit (short to a high source), the monitoring system is unable to detect any low exhaust temperatures caused by an engine misfire. This means that the low exhaust gas temperature / engine misfire protection for the affected cylinder in ineffective.

Should Fault Code 1529 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

Refer to Troubleshooting Fault Code t05-1529st

Last Modified: 13-Dec-2010


Intake Manifold Temperature Sensor Circuit - Shorted High

FAULT CODE 153

Intake Manifold Temperature Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3 LAMP: Warning SRT: | Intake Manifold Temperature Sensor Circuit - Shorted High. | No engine protection for the intake manifold air temperature. Possible reduced engine performance.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold 1 temperature sensor is a variable resistor sensor and is used to measure the temperature of the air/fuel mixture entering the intake manifold of the engine. The intake manifold temperature value is used by the engine control module (ECM)s for the engine protection system and engine emissions control.

The left-bank CM558 ECM supplies 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air/fuel mixture is cold, the sensor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground, therefore, the ECM senses a high signal voltage or a low temperature. When the intake air/fuel mixture is hot, the sensor resistance is low. The ECM signal voltage pulls down a large amount, therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 temperature sensor is located on the right-bank side, non-drive end of the engine and is mounted on the intake manifold.

The CM558 is located on the engine left-bank intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the ECM keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold temperature sensor signal voltage is greater than 4.95-VDC for 3 seconds. Three seconds is the default persistence time for this fault code, but the persistence time may have a different setting for specific CM558 software versions and engine applications.

Action Taken When the Fault Code is Active

The CM558 illuminates the amber ALARM WARNING lamp on the Generator Control Panel immediately when the diagnostic runs and fails. Fault Code 153 will also show as ACTIVE by INSITE™ electronic service tool and on the original equipment manufacturer (OEM) control panel display.

Conditions for Clearing the Fault Code

  • To validate the repair. start the engine and let it run for 1 minute at no load.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostics runs and passes.
  • The CM558 will turn off the amber ALARM WARNING lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

The intake manifold temperature sensor shares supply and return wires in the engine harness with other sensors. Open and short circuits in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 153, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-153.

Last Modified: 18-Nov-2013


Fault Code Path Selection

FAULT CODE 1531
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc1531mt
Is this engine equipped with a single turbocharger? | Go to 59-fc1531st

Last Modified: 07-Oct-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1531 - Multiple Turbochargers

Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1531 PID: SPN: 1142 FMI: 3 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 6. | No effect on engine performance. No engine protection for exhaust gas temperature.
Cylinder 6 (B3) Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a 'high voltage' detected on the sensor circuit (short to a high source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature / engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 1531 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

Refer to Troubleshooting Fault Code t05-1531mt

Last Modified: 07-Jan-2011


Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1531 - Single Turbocharger

Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1531 PID: SPN: 1142 FMI: 3 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 6. | No effect on engine performance. No engine protection for exhaust gas temperature.
Cylinder 6 (B3) (Single Turbocharger) -Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules – one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0-5-VDC thermister-type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘high voltage’ detected on the sensor circuit (short to a high source), the monitoring system is unable to detect any low exhaust temperatures caused by an engine misfire. This means that the low exhaust gas temperature / engine misfire protection for the affected cylinder in ineffective.

Should Fault Code 1531 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

Refer to Troubleshooting Fault Code t05-1531st

Last Modified: 13-Dec-2010


Fault Code Path Selection

FAULT CODE 1532
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc1532mt
Is this engine equipped with a single turbocharger? | Go to 59-fc1532st

Last Modified: 07-Oct-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1532 - Multiple Turbochargers

Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1532 PID: SPN: 1144 FMI: 3 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 8. | No effect on engine performance. No engine protection for exhaust gas temperature.
Cylinder 8 (B4) Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a 'high voltage' detected on the sensor circuit (short to a high source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature / engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 1532 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

Refer to Troubleshooting Fault Code t05-1532mt

Last Modified: 07-Jan-2011


Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1532 - Single Turbocharger

Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1532 PID: SPN: 1144 FMI: 3 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 8. | No effect on engine performance. No engine protection for exhaust gas temperature.
Cylinder 8 (B4) (Single Turbocharger) -Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules – one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0-5-VDC thermister-type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘high voltage’ detected on the sensor circuit (short to a high source), the monitoring system is unable to detect any low exhaust temperatures caused by an engine misfire. This means that the low exhaust gas temperature / engine misfire protection for the affected cylinder in ineffective.

Should Fault Code 1532 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

Refer to Troubleshooting Fault Code t05-1532st

Last Modified: 13-Dec-2010


Fault Code Path Selection

FAULT CODE 1533
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc1533mt
Is this engine equipped with a single turbocharger? | Go to 59-fc1533st

Last Modified: 07-Oct-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1533 - Multiple Turbochargers

Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1533 PID: SPN: 1146 FMI: 3 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 10. | No effect on engine performance. No engine protection for exhaust gas temperature.
Cylinder 10 (B5) Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a 'high voltage' detected on the sensor circuit (short to a high source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature / engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 1533 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

Refer to Troubleshooting Fault Code t05-1533mt

Last Modified: 07-Jan-2011


Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1533 - Single Turbocharger

Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1533 PID: SPN: 1146 FMI: 3 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 10. | No effect on engine performance. No engine protection for exhaust gas temperature.
Cylinder 10 (B5) (Single Turbocharger) -Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules – one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0-5-VDC thermister-type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘high voltage’ detected on the sensor circuit (short to a high source), the monitoring system is unable to detect any low exhaust temperatures caused by an engine misfire. This means that the low exhaust gas temperature / engine misfire protection for the affected cylinder in ineffective.

Should Fault Code 1533 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

Refer to Troubleshooting Fault Code t05-1533st

Last Modified: 13-Dec-2010


Fault Code Path Selection

FAULT CODE 1534
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc1534mt
Is this engine equipped with a single turbocharger? | Go to 59-fc1534st

Last Modified: 07-Oct-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1534 - Multiple Turbochargers

Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1534 PID: SPN: 1148 FMI: 3 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 12. | No effect on engine performance. No engine protection for exhaust gas temperature.
Cylinder 12 (B6) Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a 'high voltage' detected on the sensor circuit (short to a high source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature / engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 1534 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

Refer to Troubleshooting Fault Code t05-1534mt

Last Modified: 07-Jan-2011


Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1534 - Single Turbocharger

Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1534 PID: SPN: 1148 FMI: 3 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 12. | No effect on engine performance. No engine protection for exhaust gas temperature.
Cylinder 12 (B6) (Single Turbocharger) -Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules – one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0-5-VDC thermister-type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘high voltage’ detected on the sensor circuit (short to a high source), the monitoring system is unable to detect any low exhaust temperatures caused by an engine misfire. This means that the low exhaust gas temperature / engine misfire protection for the affected cylinder in ineffective.

Should Fault Code 1534 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

Refer to Troubleshooting Fault Code t05-1534st

Last Modified: 13-Dec-2010


Fault Code Path Selection

FAULT CODE 1535
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc1535mt
Is this engine equipped with a single turbocharger? | Go to 59-fc1535st

Last Modified: 07-Oct-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1535 - Multiple Turbochargers

Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1535 PID: SPN: 1150 FMI: 3 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 14. | No effect on engine performance. No engine protection for exhaust gas temperature.
Cylinder 14 (B7) Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a 'high voltage' detected on the sensor circuit (short to a high source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature / engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 1535 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

Refer to Troubleshooting Fault Code t05-1535mt

Last Modified: 07-Jan-2011


Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1535 - Single Turbocharger

Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1535 PID: SPN: 1150 FMI: 3 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 14. | No effect on engine performance. No engine protection for exhaust gas temperature.
Cylinder 14 (B7) (Single Turbocharger) -Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules – one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0-5-VDC thermister-type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘high voltage’ detected on the sensor circuit (short to a high source), the monitoring system is unable to detect any low exhaust temperatures caused by an engine misfire. This means that the low exhaust gas temperature / engine misfire protection for the affected cylinder in ineffective.

Should Fault Code 1535 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

Refer to Troubleshooting Fault Code t05-1535st

Last Modified: 13-Dec-2010


Fault Code Path Selection

FAULT CODE 1536
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc1536mt
Is this engine equipped with a single turbocharger? | Go to 59-fc1536st

Last Modified: 07-Oct-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 16 (B8) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1536 - Multiple Turbochargers

Exhaust Gas Temperature Sensor Circuit Cylinder 16 (B8) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1536 PID: SPN: 1152 FMI: 3 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 16 (B8) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 16. | No effect on engine performance. No engine protection for exhaust gas temperature.
Cylinder 16 (B8) Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a 'high voltage' detected on the sensor circuit (short to a high source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature / engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 1536 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

Refer to Troubleshooting Fault Code t05-1536mt

Last Modified: 07-Jan-2011


Exhaust Gas Temperature Sensor Circuit Cylinder 16 (B8) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1536 - Single Turbocharger

Exhaust Gas Temperature Sensor Circuit Cylinder 16 (B8) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1536 PID: SPN: 1152 FMI: 3 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 16 (B8) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 16. | No effect on engine performance. No engine protection for exhaust gas temperature.
Cylinder 16 (B8) (Single Turbocharger) -Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules – one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0-5-VDC thermister-type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘high voltage’ detected on the sensor circuit (short to a high source), the monitoring system is unable to detect any low exhaust temperatures caused by an engine misfire. This means that the low exhaust gas temperature / engine misfire protection for the affected cylinder in ineffective.

Should Fault Code 1536 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

Refer to Troubleshooting Fault Code t05-1536st

Last Modified: 13-Dec-2010


Intake Manifold Temperature Sensor Circuit - Shorted Low

FAULT CODE 154

Intake Manifold Temperature Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4 LAMP: Warning SRT: | Intake Manifold Temperature Sensor Circuit - Shorted Low. Sensor signal is shorted low. | No engine protection for the intake air manifold temperature. Possible reduced engine performance.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold 1 temperature sensor is a variable resistor sensor and is used to measure the temperature of the air/fuel mixture entering the intake manifold of the engine. The intake manifold temperature value is used by the engine control modules (ECM)s for the engine protection system and engine emissions control.

The left-bank CM558 ECM supplies 5 volts to the intake manifold temperature signal circuit and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air/fuel mixture is cold, the sensor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground, therefore, the ECM senses a high signal voltage or a low temperature. When the intake air/fuel mixture is hot, the sensor resistance is low. The ECM signal voltage pulls down a large amount, therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 temperature sensor is located on the right-bank side, non-drive end of the engine, and is mounted on the intake manifold.

The CM558 is located on the engine's left-bank intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the ECM keywitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold temperature sensor signal voltage is less than 0.142-VDC for 3 seconds. Three seconds is the default persistence time for this fault code, but the persistence time may have a different setting for specific CM558 software versions and engine applications.

Action Taken When the Fault Code is Active

  • The CM558 illuminates the amber ALARM WARNING lamp on the generator control panel immediately when the diagnostic runs and fails.
  • Fault Code 154 will also show as ACTIVE by INSITE™ electronic service tool and on the original equipment manufacturer (OEM) control panel display.

Conditions for Clearing the Fault Code

  • To validate the repair start the engine and let it run at rated speed for 1 minute at no load.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostics runs and passes.
  • The CM558 will turn off the amber ALARM WARNING lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive fault codes.

Shop Talk

The intake manifold temperature sensor shares supply and return wires in the engine harness with other sensors. Open and short circuits in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 154, check for multiple fault codes.

Possible causes of this fault code include:

  • RETURN wire open circuit or short to ground in the harness, connectors, or sensor
  • SIGNAL wire open circuit or short to ground.
Refer to Troubleshooting Fault Code t05-154.

Last Modified: 18-Nov-2013


Engine Crankshaft Speed/Position Lost - Condition Exists

FAULT CODE 1546

Engine Crankshaft Speed/Position Lost - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1546 PID: 190 SPN: 190 FMI: 11 LAMP: Warning SRT: | Engine Crankshaft Speed/Position Lost - Condition Exists. The flywheel teeth or crankshaft pattern, speed/position signal has not been detected by the ECM. | No action taken by the ECM. Engine will continue to run on the camshaft engine position sensor. Possible loss of performance.
QSK60 G Multiple Turbocharger Engines with Generator Control Panel 1 (GCP1) and PowerCommand™ Supervisor 3100 Generator Set Controller - Crankshaft Engine Speed Sensor Circuit
QSK60 G Single and Multiple Turbocharger Engines with Generator Control Panel 2 (GCP2) and PowerCommand™ Supervisor 3100 Generator Set Controller - Crankshaft Engine Speed Sensor Circuit
QSK60 G Single and Multiple Turbocharger Engines with PowerCommand™ Control 3300 Generator Set Controller - Crankshaft Engine Speed Sensor Circuit

Circuit Description

The crankshaft engine speed sensor provides engine speed and position information to the CM700 module. The sensor has a dual core circuit. On some QSK60 G models, the dual core circuit supplies a speed signal to the CM700 (engine speed) and the PowerCommand™ Supervisor 3100 generator set control panel (speed bias control). On other applications, only one of the sensor core circuits is used. The sensor generates a signal by sensing the movement of the flywheel teeth.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Check for the correct air gap between the crankshaft engine speed sensor and the gear teeth on the flywheel. Position the flywheel so that a gear tooth is directly below the sensor in order to check and set the gap.

Possible causes of this fault code include a damaged crankshaft engine speed sensor, an open or shorted circuit, or a power supply voltage failure.

If Fault Code 1546 is only activated at a certain engine temperature, make certain to check the crankshaft engine speed sensor and circuit while the engine is at that particular temperature.

Refer to Troubleshooting Fault Code 121.

Last Modified: 04-Jan-2011


Intake Manifold Temperature High - Critical

FAULT CODE 155

Intake Manifold Temperature High - Critical

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0 LAMP: Shutdown SRT: | The intake manifold temperature has exceeded the high critical threshold. | The engine will shut down.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The intake manifold 1 temperature sensor is a variable resistor sensor and is used to measure the temperature of the air/fuel mixture entering the intake manifold of the engine. The intake manifold temperature value is used by the engine control module (ECM) for the engine protection system, timing, and engine emissions control.

The left-bank CM558 ECM supplies 5-VDC to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air/fuel mixture is cold, the sensor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground, therefore, the ECM senses a high signal voltage or a low temperature. When the intake air/fuel mixture is warm, the sensor resistance is low. The ECM signal voltage pulls down a large amount, therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 temperature sensor is located on the right-bank side, non-drive end of the engine, and is mounted on the intake manifold.

The ECM, CM558, is located on the engine's left-bank intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the ECM keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold temperature has exceeded the critical temperature threshold of 71° C [160° F] for 3 seconds. Three seconds is the default persistence time for this fault code, but the persistence time may have a different setting for specific CM558 software versions and engine applications.

Action Taken When the Fault Code is Active

  • The CM558 illuminates the red ALARM SHUTDOWN lamp on the Generator Control Panel immediately, when the diagnostic runs and fails. Fault Code 155 will also be shown as ACTIVE by INSITE™ electronic service tool and on the OEM control panel display.
  • The engine will shut down (critical stop).

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run at rated speed for 1 minute at no load.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostics runs and passes.
  • The CM558 will turn off the red ALARM SHUTDOWN lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

High intake manifold temperatures affect combustion of the air/fuel in the cylinders and engine knock can occur as a result.

Possible cause of this fault code include:

  • Restricted air flow through the charge-air cooler.
  • Temperature of coolant (high temperature and low temperature cooling circuits) passing through charge-air cooler higher than normal.
  • Coolant flow (high temperature and low temperature cooling circuits) through the charge-air cooler restricted.
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code t05-155

Last Modified: 05-Dec-2013


Engine Cylinder Number 12 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1579

Engine Cylinder Number 12 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1579 PID: SPN: 1363 FMI: 16 LAMP: Shutdown SRT: | Engine Cylinder Number 12 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Cylinder number 12 has exceeded the lower knock count threshold. | The engine will shut down.
Knock Sensor Circuit - Multiple and Single Turbocharger Engines

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Knock sensors are located on each of the cylinder heads. Use the following procedure for component location. Refer to Procedure 019-346 in Section 19.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by a source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to a "pre-ignition" and knock occurring after the normal spark event is known as "detonation". The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of knock is not identified and rectified, engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function correctly, it must be installed and tightened to the correct torque.

Knock-related faults are activated when the knock sensor voltage output exceeds either a Warning or High critical threshold for a pre-set period of time.

When the knock Warning threshold is reached and persists for a pre-set period of time, the CM558 will register a Warning alarm for the affected cylinder and the engine will continue to run. The CM558 will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the CM558 will slowly advance the timing for that cylinder back to its standard timing setting. If the detonation persists, the timing retardation is repeated, up to a maximum of three timing retardations. If, following the final timing, retardation knock is still present, the CM558 will initiate a Critical shutdown of the engine.

All detonation-related shutdowns and persistent light knock events should be fully investigated in order to prevent engine damage.

The knock sensors can also detect mechanical noise, Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever "elephant foot" o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust (multi-duct) gasket leakage
  • Vibration resulting from loose engine parts/components.

Generator Sets using PowerCommand® Control 3300 (PCC3300) Generator Control:

The PCC3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code t05-1579.

Last Modified: 14-Dec-2010


Engine Cylinder Number 14 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1581

Engine Cylinder Number 14 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1581 PID: SPN: 1365 FMI: 16 LAMP: Shutdown SRT: | Engine Cylinder Number 14 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Cylinder number 14 has exceeded the lower knock count threshold. | The engine will shut down.
Knock Sensor Circuit - Multiple and Single Turbocharger Engines

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Knock sensors are located on each of the cylinder heads. Use the following procedure for component location. Refer to Procedure 019-346 in Section 19.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by a source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to a "pre-ignition" and knock occurring after the normal spark event is known as "detonation". The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of knock is not identified and rectified, engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function correctly, it must be installed and tightened to the correct torque.

Knock-related faults are activated when the knock sensor voltage output exceeds either a Warning or High critical threshold for a pre-set period of time.

When the knock Warning threshold is reached and persists for a pre-set period of time, the CM558 will register a Warning alarm for the affected cylinder and the engine will continue to run. The CM558 will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the CM558 will slowly advance the timing for that cylinder back to its standard timing setting. If the detonation persists, the timing retardation is repeated, up to a maximum of three timing retardations. If, following the final timing, retardation knock is still present, the CM558 will initiate a Critical shutdown of the engine.

All detonation-related shutdowns and persistent light knock events should be fully investigated in order to prevent engine damage.

The knock sensors can also detect mechanical noise, Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever "elephant foot" o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust (multi-duct) gasket leakage
  • Vibration resulting from loose engine parts/components.

Generator Sets using PowerCommand® Control 3300 (PCC3300) Generator Control:

The PCC3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code t05-1581.

Last Modified: 14-Dec-2010


Engine Cylinder Number 16 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1582

Engine Cylinder Number 16 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1582 PID: SPN: 1367 FMI: 16 LAMP: Shutdown SRT: | Engine Cylinder Number 16 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Cylinder number 16 has exceeded the lower knock count threshold. | The engine will shut down.
Knock Sensor Circuit - Multiple and Single Turbocharger Engines

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Knock sensors are located on each of the cylinder heads. Use the following procedure for component location. Refer to Procedure 019-346 in Section 19.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by a source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to a "pre-ignition" and knock occurring after the normal spark event is known as "detonation". The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of knock is not identified and rectified, engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function correctly, it must be installed and tightened to the correct torque.

Knock-related faults are activated when the knock sensor voltage output exceeds either a Warning or High critical threshold for a pre-set period of time.

When the knock Warning threshold is reached and persists for a pre-set period of time, the CM558 will register a Warning alarm for the affected cylinder and the engine will continue to run. The CM558 will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the CM558 will slowly advance the timing for that cylinder back to its standard timing setting. If the detonation persists, the timing retardation is repeated, up to a maximum of three timing retardations. If, following the final timing, retardation knock is still present, the CM558 will initiate a Critical shutdown of the engine.

All detonation-related shutdowns and persistent light knock events should be fully investigated in order to prevent engine damage.

The knock sensors can also detect mechanical noise, Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever "elephant foot" o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust (multi-duct) gasket leakage
  • Vibration resulting from loose engine parts/components.

Generator Sets using PowerCommand® Control 3300 (PCC3300) Generator Control:

The PCC3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code t05-1582.

Last Modified: 14-Dec-2010


Engine Cylinder Number 16 Knock - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 1583

Engine Cylinder Number 16 Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1583 PID: SPN: 1367 FMI: 0 LAMP: Shutdown SRT: | Engine Cylinder Number 16 Knock - Data Valid But Above Normal Operating Range - Most Severe Level. Cylinder number 16 knock sensor has detected a knock above critical level. | The engine will shutdown.
Knock Sensor Circuit

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Knock sensors are located on each of the cylinder heads. Use the following procedure for component location. Refer to Procedure 019-346 in Section 19.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignition and knock occurring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts within the power cylinder colliding. If the cause of knock is not identified and rectified, then engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage may occur. Similarly, the engine must not be run with knock sensors disconnected; this will not initiate a warning alarm. The engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function correctly, it must be installed and tightened to the correct torque value.

Knock related faults are activated when the knock sensor voltage output exceeds either a warning or high critical threshold for a pre-set period of time.

When the knock high critical threshold is reached and persists for a pre-set period of time, then the CM558 will register a critical alarm for the affected cylinder. The CM558 will initiate a critical shutdown of the engine.

All detonation related shutdowns and persistent light knock events should be fully investigated in order to prevent engine damage.

The knock sensors can also detect mechanical noise, and mechanical related problems must not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks must be considered when all other causes of detonation have been investigated and discounted:

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever elephant foot o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust (multi-duct) gasket leakage
  • Vibration resulting from loose engine parts/components.

Generator Sets using PowerCommand™ Control 3300 Generator Control:

The PowerCommand™ Control 3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from no-knock condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code t05-1583

Last Modified: 31-Dec-2010


Engine Cylinder Number 16 Knock - Voltage below Normal or Shorted to Low Source

FAULT CODE 1584

Engine Cylinder Number 16 Knock - Voltage below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1584 PID: SPN: 1367 FMI: 4 LAMP: Warning SRT: | Engine Cylinder Number 16 Knock - Voltage below Normal or Shorted to Low Source. Low voltage has been detected in the engine cylinder number 16 knock sensor circuit. | No effect on engine performance.
Knock Sensor Circuit

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Knock sensors are located on each of the cylinder heads. Use the following procedure for component location. Refer to Procedure 019-346 in Section 19.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage may occur.

In order to provide some system diagnostics, the individual knock sensors are periodically switched on outside of their normal operating window. This diagnostic window is timed to coincide with an exhaust valve closing. The knock sensor will detect the noise of the exhaust valve closing and will generate a voltage output. If the CM558 does not register a voltage above a pre-set level, then this fault code will be activated.

IMPORTANT NOTE: This protection feature is not active on all engine models and/or all versions of ECM software. Therefore, the engine must not be run with knock sensors disconnected; this may not initiate this warning alarm. The engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

A faulty or incorrectly fitted knock sensor or knock sensor wiring harness faults, such as open circuit or high resistances, are the most likely cause of this fault.

Generator Sets using PowerCommand™ Control 3300 (PCC3300) Generator Control:

The PowerCommand™ Control 3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from no-knock condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code t05-1584

Last Modified: 31-Dec-2010


Fault Code Path Selection

FAULT CODE 1618
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc1618mt
Is this engine equipped with a single turbocharger? | Go to 59-fc1618st

Last Modified: 07-Oct-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1618 - Multiple Turbochargers

Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1618 PID: SPN: 1137 FMI: 3 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 1. | No effect on engine performance. No engine protection for exhaust gas temperature.
Cylinder 1 (A1) Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a 'high voltage' detected on the sensor circuit (short to a high source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature / engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 1618 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

Refer to Troubleshooting Fault Code t05-1618mt

Last Modified: 14-Jan-2011


Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1618 - Single Turbocharger

Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1618 PID: SPN: 1137 FMI: 3 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 1. | No effect on engine performance. No engine protection for exhaust gas temperature.
Cylinder 1 (A1) (Single Turbocharger) -Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules – one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0-5-VDC thermister-type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘high voltage’ detected on the sensor circuit (short to a high source), the monitoring system is unable to detect any low exhaust temperatures caused by an engine misfire. This means that the low exhaust gas temperature / engine misfire protection for the affected cylinder in ineffective.

Should Fault Code 1618 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

Refer to Troubleshooting Fault Code t05-1618st

Last Modified: 13-Dec-2010


Fault Code Path Selection

FAULT CODE 1619
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc1619mt
Is this engine equipped with a single turbocharger? | Go to 59-fc1618st

Last Modified: 07-Oct-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1619 - Multiple Turbochargers

Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1619 PID: SPN: 1140 FMI: 3 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 4. | No effect on engine performance. No engine protection for exhaust gas temperature.
Cylinder 4 (B2) Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a 'high voltage' detected on the sensor circuit (short to a high source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature / engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 1619 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

Refer to Troubleshooting Fault Code t05-1619mt

Last Modified: 07-Jan-2011


Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1619 - Single Turbocharger

Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1619 PID: SPN: 1140 FMI: 3 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 4. | No effect on engine performance. No engine protection for exhaust gas temperature.
Cylinder 4 (B2) (Single Turbocharger) -Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules – one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0-5-VDC thermister-type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘high voltage’ detected on the sensor circuit (short to a high source), the monitoring system is unable to detect any low exhaust temperatures caused by an engine misfire. This means that the low exhaust gas temperature / engine misfire protection for the affected cylinder in ineffective.

Should Fault Code 1619 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

Refer to Troubleshooting Fault Code t05-1619st

Last Modified: 13-Dec-2010


Engine Throttle Control Actuator - Bad Intelligent Device or Component

FAULT CODE 1737

Engine Throttle Control Actuator - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1737 PID: SPN: 3464 FMI: 12 LAMP: Shutdown SRT: | Engine Throttle Control Actuator - Bad Intelligent Device or Component. The engine throttle control actuator is not functioning. | Engine will shut down.
Multiple Turbochargers Integrated Throttle - Throttle Actuator Circuit
Single Turbocharger Integrated Throttle - Throttle Actuator Circuit

Circuit Description

On engines equipped with integrated digital throttles, the throttle assembly is a one-piece unit consisting of an integrated throttle actuator and driver assembly. The throttle assembly receives a "commanded position signal" over the engine's proprietary data link circuit. The throttle position feedback signal is also a digital signal transmitted over the proprietary data link circuit.

This fault code is applicable for generator sets with digital integrated throttle assemblies using a proprietary communication data link network protocol, such as CAN 2.0B.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The new generation of digital integrated throttle assemblies has the ability to self-monitor the throttle actuator for the following conditions:

  • Actuator internal temperature - this fault can be activated by a damaged internal temperature sensor.
  • Actuator 12-VDC internal power supply - this fault can be activated if the 12-VDC internal supply of the actuator is out-of-range.
  • Actuator -9-VDC internal power supply - this fault can be activated if the -9-VDC internal supply of the actuator is out-of-range.
  • Actuator 5-VDC internal power supply - this fault can be activated if the 5-VDC internal supply of the actuator is out-of-range.
  • Actuator internal software - this fault can be activated if an actuator internal software error exists.
  • Actuator internal EPROM - this fault can be activated if an actuator internal EPROM error exists.
  • Actuator internal position feedback - this fault can be activated if the internal monitoring system of the actuator detects an out-of-range signal on the internal position feedback circuit.
  • General alarm - generated internally within the digital throttle actuator.

The digital throttle assembly communicates "diagnostics and event codes" upon request to the CM558. Once the diagnostics and event codes are received, the CM558 will activate Fault Code 1737 to indicate that an internal fault condition exists within the digital throttle actuator.

The digital throttle assemblies are not serviceable. Damaged digital throttle assemblies should be replaced.

Refer to Troubleshooting Fault Code 1737.

Last Modified: 10-Feb-2011


Engine Throttle Control Actuator - Root Cause Not Known

FAULT CODE 1738

Engine Throttle Control Actuator - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1738 PID: SPN: 3464 FMI: 11 LAMP: Warning SRT: | Engine Throttle Control Actuator - Root Cause Not Known. Unidentified failure mode has occurred in the engine throttle control actuator. | The engine will continue to run but performance may be impaired.
Multiple Turbochargers Integrated Throttle - Throttle Actuator Circuit
Single Turbocharger Integrated Throttle - Throttle Actuator Circuit

Circuit Description

In engines fitted with integrated digital throttles, the throttle assembly is a one-piece unit consisting of an integrated throttle actuator and driver assembly. The throttle assembly receives a “commanded position signal” over the engine's proprietary data link circuit. The throttle position feedback signal is also a digital signal transmitted over the proprietary data link circuit.

This fault code is applicable for generator sets using digital integrated throttle assemblies utilizing a proprietary communication data link network protocol, such as CAN 2.0B.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The new generation of digital integrated throttle assemblies has the ability to self-monitor the throttle actuator for the following conditions:

  • Actuator Internal Temperature - this fault may activated by a faulty internal temperature sensor.
  • Actuator 12-VDC Internal Power Supply - this fault may be activated if the actuator 12-VDC internal supply is out-of-range.
  • Actuator -9-VDC Internal Power Supply - this fault may be activated if the actuator -9-VDC internal power supply is out-of-range.
  • Actuator 5-VDC Internal Power Supply - this fault may be activated if the actuator 5-VDC internal supply is out-of-range.
  • Actuator Internal Software - this fault may be activated if an actuator internal software error exists.
  • Actuator Internal EPROM - this fault may be activated if an actuator internal EPROM error exists.
  • Actuator Internal Position Feedback - this fault may be activated if the actuator internal monitoring system detects an out-of-range signal on the internal position feedback circuit.
  • General Alarm - generated internally within the digital throttle actuator.

The digital throttle assembly communicates diagnostics and event codes upon request to the CM558. Once the diagnostics and event codes are received, the CM558 will activate Fault Code 1738 to indicate that an unidentified internal fault condition exists within the digital throttle actuator.

The digital throttle assemblies are not repairable within the field and faulty digital throttle assemblies should be replaced.

There may be other generator set fault codes activated as a result of Fault Code 1738 being triggered. To avoid the possibility of damaging a new digital throttle assembly, all other active fault codes must be investigated and rectified before replacing the digital throttle assembly.

Refer to Troubleshooting Fault Code t05-1738

Last Modified: 31-Dec-2010


Engine Throttle Control Actuator - Condition Exists

FAULT CODE 1739

Engine Throttle Control Actuator - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1739 PID: SPN: 3464 FMI: 31 LAMP: Warning SRT: | Engine Throttle Control Actuator - Condition Exists. Failure reported by smart throttle (HHP) as fault on primary throttle position request. | The engine will continue to run, but performance can be inpaired.
Multiple Turbochargers Integrated Throttle - Throttle Actuator Circuit
Single Turbocharger Integrated Throttle - Throttle Actuator Circuit

Circuit Description

On engines fitted with integrated digital throttles, the throttle assembly is a one-piece unit consisting of an integrated throttle actuator and driver assembly. The throttle assembly receives a "commanded position signal" over the engine's proprietary data link circuit. The throttle position feedback signal is also a digital signal transmitted over the proprietary data link circuit.

This fault code is applicable for generator sets with digital integrated throttle assemblies using a proprietary communication data link network protocol, such as CAN 2.0B.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The new generation of digital integrated throttle assemblies has the ability to self-monitor the throttle actuator for the following conditions:

  • Actuator internal temperature - this fault can be activated by a damaged internal temperature sensor.
  • Actuator 12-VDC internal power supply - this fault can be activated if the 12-VDC internal supply of the actuator is out-of-range.
  • Actuator -9-VDC internal power supply - this fault can be activated if the -9-VDC internal supply of the actuator is out-of-range.
  • Actuator 5-VDC internal power supply - this fault can be activated if the 5-VDC internal supply of the actuator is out-of-range.
  • Actuator internal software - this fault can be activated if an actuator internal software error exists.
  • Actuator internal EPROM - this fault can be activated if an actuator internal EPROM error exists.
  • Actuator internal position feedback - this fault can be activated if the internal monitoring system of the actuator detects an out-of-range signal on the internal position feedback circuit.
  • General alarm - generated internally within the digital throttle actuator.

The digital throttle assembly communicates "diagnostics and event codes" upon request to the CM558. Once the diagnostics and event codes are received, the CM558 will activate Fault Code 1737 to indicate that an internal fault condition exists within the digital throttle actuator.

The digital throttle assemblies are not serviceable. Damaged digital throttle assemblies should be replaced.

Refer to Troubleshooting Fault Code 1739.

Last Modified: 10-Feb-2011


Engine Throttle Control Actuator Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 1741

Engine Throttle Control Actuator Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1741 PID: SPN: 3464 FMI: 15 LAMP: Warning SRT: | Engine Throttle Control Actuator Temperature - Data Valid But Above Normal Operating Range - Least Severe Level. High internal temperature has been detected by the engine throttle control actuator. | The engine will continue to run, but performance can be inpaired.
Multiple Turbochargers Integrated Throttle - Throttle Actuator Circuit
Single Turbocharger Integrated Throttle - Throttle Actuator Circuit

Circuit Description

On engines fitted with integrated digital throttles, the throttle assembly is a one-piece unit consisting of an integrated throttle actuator and driver assembly. The throttle assembly receives a "commanded position signal" over the engine's proprietary data link circuit. The throttle position feedback signal is also a digital signal transmitted over the proprietary data link circuit.

This fault code is applicable for generator sets using digital integrated throttle assemblies with a proprietary communication data link network protocol, such as CAN 2.0B.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The new generation of digital integrated throttle assemblies has the ability to self-monitor the throttle actuator for the following conditions:

  • Actuator internal temperature - this fault can be activated by a damaged internal temperature sensor.
  • Actuator 12-VDC internal power supply - this fault can be activated if the 12-VDC internal supply of the actuator is out-of-range.
  • Actuator -9-VDC internal power supply - this fault can be activated if the -9-VDC internal supply of the actuator is out-of-range.
  • Actuator 5-VDC internal power supply - this fault can be activated if the 5-VDC internal supply of the actuator is out-of-range.
  • Actuator internal software - this fault can be activated if an actuator internal software error exists.
  • Actuator internal EPROM - this fault can be activated if an actuator internal EPROM error exists.
  • Actuator internal position feedback - this fault can be activated if the internal monitoring system of the actuator detects an out-of-range signal on the internal position feedback circuit.
  • General alarm - generated internally within the digital throttle actuator.

The digital throttle assembly communicates "diagnostics and event codes" upon request to the CM558. Once the diagnostics and event codes are received, the CM558 will activate Fault Code 1737 to indicate that an internal fault condition exists within the digital throttle actuator.

The digital throttle assemblies are not serviceable. Damaged digital throttle assemblies should be replaced.

Refer to Troubleshooting Fault Code 1741.

Last Modified: 10-Feb-2011


Engine Throttle Control Actuator Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1742

Engine Throttle Control Actuator Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1742 PID: SPN: 3464 FMI: 16 LAMP: Warning SRT: | Engine Throttle Control Actuator Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. High internal temperature has been detected by the engine throttle control actuator. | The engine will continue to run, but performance can be inpaired.
Multiple Turbochargers Integrated Throttle - Throttle Actuator Circuit
Single Turbocharger Integrated Throttle - Throttle Actuator Circuit

Circuit Description

On engines fitted with integrated digital throttles, the throttle assembly is a one-piece unit consisting of an integrated throttle actuator and driver assembly. The throttle assembly receives a "commanded position signal" over the engines proprietary data link circuit. The throttle position feedback signal is also a digital signal transmitted over the proprietary data link circuit.

This fault code is applicable for generator sets with digital integrated throttle assemblies using a proprietary communication data link network protocol, such as CAN 2.0B.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The new generation of digital integrated throttle assemblies has the ability to self-monitor the throttle actuator for the following conditions:

  • Actuator internal temperature - this fault can be activated by a damaged internal temperature sensor.
  • Actuator 12-VDC internal power supply - this fault can be activated if the 12-VDC internal supply of the actuator is out-of-range.
  • Actuator -9-VDC internal power supply - this fault can be activated if the -9-VDC internal supply of the actuator is out-of-range.
  • Actuator 5-VDC internal power supply - this fault can be activated if the 5-VDC internal supply of the actuator is out-of-range.
  • Actuator internal software - this fault can be activated if an actuator internal software error exists.
  • Actuator internal EPROM - this fault can be activated if an actuator internal EPROM error exists.
  • Actuator internal position feedback - this fault can be activated if the internal monitoring system of the actuator detects an out-of-range signal on the internal position feedback circuit.
  • General alarm - generated internally within the digital throttle actuator.

The digital throttle assembly communicates "diagnostics and event codes" upon request to the CM558. Once the diagnostics and event codes are received, the CM558 will activate Fault Code 1737 to indicate that an internal fault condition exists within the digital throttle actuator.

The digital throttle assemblies are not serviceable. Damaged digital throttle assemblies should be replaced.

Refer to Troubleshooting Fault Code 1742.

Last Modified: 10-Feb-2011


Throttle Actuator Circuit High Error

FAULT CODE 175

Throttle Actuator Circuit High Error

Printable Version Printable Version

Overview

Throttle Actuator Circuit High Error

CODE | REASON | EFFECT
Fault Code: 175 PID: 58 SPN: 698 FMI: 3 LAMP: Warning SRT: | Throttle Actuator Circuit High Error. High current detected on the throttle actuator return pin on the main harness CM558 connector. | No effect on engine performance.
Throttle Actuator Position Circuit - Multiple Turbochargers
Throttle Actuator Position Circuit - Single Turbocharger

Circuit Description

The Throttle Actuator Circuit consists of the Throttle Driver and the CM558. The Throttle Driver receives a 4-20 mA commanded position signal from the CM558.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

Always verify that the cable connections on the throttle driver tight. There are four connections: the signal to throttle actuator, the position command from the CM558, the power supply, and the feedback signal. The feedback signal is the smallest round connector.

Refer to Troubleshooting Fault Code t05-175

Last Modified: 30-Jun-2010


Throttle Actuator Circuit Low Error

FAULT CODE 176

Throttle Actuator Circuit Low Error

Printable Version Printable Version

Overview

Throttle Actuator Circuit Low Error

CODE | REASON | EFFECT
Fault Code: 176 PID: 58 SPN: 698 FMI: 4 LAMP: Warning SRT: | Throttle Actuator Circuit Low Error. Low current detected on the throttle actuator return pin on the main harness CM558 connector. | No effect on engine performance.
Throttle Actuator Position Circuit - Multiple Turbochargers
Throttle Actuator Position Circuit - Single Turbocharger

Circuit Description

The Throttle Actuator Circuit consists of the Throttle Driver and the CM558. The Throttle Driver receives a 4-20 mA commanded position signal from the CM558.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

Always verify that the cable connections on the throttle driver are tight. There are four connections: the signal to throttle actuator, the position command from the CM558, the power supply, and the feedback signal. The feedback signal is the smallest round connector.

Refer to Troubleshooting Fault Code t05-176

Last Modified: 30-Jun-2010


Engine Electronic Fuel Valve 1 Position - Data Erratic, Intermittent or Incorrect

FAULT CODE 1761

Engine Electronic Fuel Valve 1 Position - Data Erratic, Intermittent or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1761 PID: SPN: 1442 FMI: 2 LAMP: Shutdown SRT: | Engine Electronic Fuel Valve 1 Position - Data Erratic, Intermittent, or Incorrect. The fuel control valve position feedback is not responding to commands from the ECM. The valve is stuck. | The engine will shut down.
QSK60 G Multiple Turbochargers with Generator Control Panel 1 (GCP1) with PowerCommand™ Supervisor 3100 and AC and DC Generator Set Terminal Boxes - Engine Electronic Fuel Control Valve Circuit
QSK60 G Single and Multiple Turbochargers with Generator Control Panel 2 (GCP23) with PowerCommand™ Supervisor 3100 and Generator Interface Boxes (GIB) - Engine Electronic Fuel Control Valve Circuit
QSK60 G Single and Multiple Turbochargers with PowerCommand™ Control 3300 and Generator Interface Box (GIB) - Engine Electronic Fuel Control Valve Circuit

Circuit Description

The fuel control valve position circuit consists of the commanded position signal from the CM558 and the feedback signal that is received by the CM558 from the fuel control valve. The fuel control valve commanded position signal is supplied by the CM558. The position signal is a 24-VDC pulse width modulated (PWM) signal and the feedback is a 0 to 5-VDC signal.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The fuel control valve feedback data is monitored by the CM558 and it compares the feedback data to the commanded data. If the difference between the commanded position and the feedback data exceeds the fault threshold, then Fault Code 1761 is activated. The fuel control valve is most likely to fail in either the closed or fully open position.

The fuel control valve commanded signal and the feedback signal can be monitored using the electronic service tool. The electronic service tool can also be used to test the valve for free movement.

The following table, which can be used as an aid when troubleshooting the fuel control valve, provides actuator position commanded PWM percent duty cycle and VDC feedback signal specifications.

Actuator Commanded Position | Percent Duty Cycle | 0 to 5-VDC Feedback Signal
0 | 10 - 11 | 0.4 - 0.7
10 | 17 - 19 | 0.9 - 1.1
20 | 25 - 27 | 1.3 - 1.5
30 | 33 - 35 | 1.7 - 1.9
40 | 41 - 43 | 2.1 - 2.3
50 | 49 - 51 | 2.5 - 2.7
60 | 57 - 59 | 2.9 - 3.1
70 | 65 - 67 | 3.3 - 3.5
80 | 73 - 75 | 3.7 - 3.9
90 | 81 - 83 | 4.1 - 4.3
100 | 89 - 91 | 4.6 - 4.8

PWM percent duty cycle signals can only be measured with multimeters or other measuring devices that have a percent duty cycle function.

Refer to Troubleshooting Fault Code 1761.

Last Modified: 10-Feb-2011


Fault Code Path Selection

FAULT CODE 177
Fault Code Path Selection

Is this engine equipped with multiple turbocharger integrated throttle? | Go to 59-fc177mtit
Is this engine equipped with multiple turbocharger two-piece throttle? | Go to 59-fc177mttt
Is this engine equipped with a single turbocharger integrated throttle? | Go to 59-fc177stit

Last Modified: 07-Oct-2010


Multiple Turbocharger Integrated Throttle Electronic Throttle Control Actuator - Mechanical System is Not Responding or Out of Adjustment

FAULT CODE FAULT CODE 177 - Multiple Turbocharger Integrated Throttle

Multiple Turbocharger Integrated Throttle Electronic Throttle Control Actuator - Mechanical System is Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 177 SPN: 3464 FMI: 4 LAMP: Shutdown SRT: | Multiple Turbocharger Integrated Throttle Electronic Throttle Control Actuator - Mechanical System is Not Responding or Out of Adjustment. Engine throttle control actuator is stuck and/or not responding mechanically. | The engine will shut down.
Throttle Actuator Circuit - (Multiple Turbocharger Engines)

Circuit Description

For engines fitted with integrated digital throttles, the throttle assembly is a one-piece unit consisting of an integrated throttle actuator and driver assembly. The throttle assembly receives a commanded position signal over the engine's proprietary data link circuit. The throttle position feedback signal is also a digital signal transmitted over the proprietary data link circuit.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The throttle plate commanded signal and the feedback signal can be monitored with the electronic service tool. If the difference between the commanded position and the feedback position signal is greater than the fault threshold, which is pre-set to 30 percent, Fault Code 177 will be set.

The throttle assembly can be tested using INSITE™ electronic service tool. To conduct this test, the engine rpm must be at zero. The throttle plate can be commanded to any position between 0 percent and 100 percent and the feedback signal compared with the commanded signal.

The most likely causes for this fault being activated are mechanical seizure of the throttle shaft/bearings or a fault with the throttle plate position feedback circuit.

Refer to Troubleshooting Fault Code 177.

Last Modified: 08-Jul-2010


Multiple Turbocharger Two-Piece Throttle Electronic Throttle Control Actuator - Mechanical System is Not Responding or Out of Adjustment

FAULT CODE 177 Multiple Turbocharger Two-Piece Throttle

Multiple Turbocharger Two-Piece Throttle Electronic Throttle Control Actuator - Mechanical System is Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 177 SPN: 3464 FMI: 4 LAMP: Shutdown SRT: | Multiple Turbocharger Two-Piece Throttle Electronic Throttle Control Actuator - Mechanical System is Not Responding or Out of Adjustment. Engine throttle control actuator is stuck and/or not responding mechanically. | The engine will shutdown.
Throttle Actuator Circuit - (Multiple Turbocharger Engines)

Circuit Description

For engines fitted with two-piece analog throttles, the throttle assembly consists of a throttle driver and a throttle actuator. The throttle actuator receives a 4-20 milliampere commanded throttle position SIGNAL from the CM558. The throttle position feedback SIGNAL from the throttle driver is also a 4-20 milliampere SIGNAL.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The throttle plate commanded SIGNAL and the feedback SIGNAL can be monitored with the electronic service tool. If the difference between the commanded position and the feedback position SIGNAL is greater than the fault threshold, which is pre-set to 30 percent, Fault Code 177 will be set.

The throttle assembly can be tested using the electronic service tool. To conduct this test the engine rpm must be at zero. The throttle plate can be commanded to any position between 0 percent and 100 percent and the feedback SIGNAL compared with the commanded SIGNAL.

NOTE: There are a number of throttle parameter trim and gain adjustment pots mounted inside the throttle driver circuit board. These adjustment pots are pre-set by the manufacturer and must not be adjusted in the field.

The most likely causes for this fault being activated are mechanical seizure of the throttle shaft/bearings or a fault with the throttle plate position feedback circuit.

Refer to Troubleshooting Fault Code 177.

Last Modified: 08-Jul-2010


Single Turbocharger Integrated Throttle Electronic Throttle Control Actuator - Mechanical System is Not Responding or Out of Adjustment

FAULT CODE 177 Single Turbocharger Integrated Throttle

Single Turbocharger Integrated Throttle Electronic Throttle Control Actuator - Mechanical System is Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 177 SPN: 3464 FMI: 4 LAMP: Shutdown SRT: | Single Turbocharger Integrated Throttle Electronic Throttle Control Actuator - Mechanical System is Not Responding or Out of Adjustment. Engine throttle control actuator is stuck and/or not responding mechanically. | The engine will shut down.
Throttle Actuator Circuit - (Single Turbocharger Engines)

Circuit Description

For engines fitted with integrated digital throttles, the throttle assembly is a one-piece unit consisting of an integrated throttle actuator and driver assembly. The throttle assembly receives a commanded position signal over the engine's proprietary data link circuit. The throttle position feedback signal is also a digital signal transmitted over the proprietary data link circuit.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The throttle plate commanded signal and the feedback signal can be monitored with the electronic service tool. If the difference between the commanded position and the feedback position signal is greater than the fault threshold, which is pre-set to 30 percent, Fault Code 177 will be set.

The throttle assembly can be tested using the electronic service tool. To conduct this test, the engine rpm must be at zero. The throttle plate can be commanded to any position between 0 percent and 100 percent and the feedback signal compared with the commanded signal.

The most likely causes for this fault being activated are mechanical seizure of the throttle shaft/bearings or a fault with the throttle plate position feedback circuit.

Refer to Troubleshooting Fault Code 177.

Last Modified: 08-Jul-2010


Electrical Load, Engine Failure to Meet Load and/or Speed Demand - Condition Exists

FAULT CODE 1791

Electrical Load, Engine Failure to Meet Load and/or Speed Demand - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1791 PID: SPN: 1204 FMI: 31 LAMP: Shutdown SRT: | Electrical Load, Engine Failure to Meet Load and/or Speed Demand - Condition Exists. The calculated difference between the desired and actual engine speed is greater than the critical threshold for a set period of time. | The engine will shut down.
QSK60G Multiple Turbochargers Generator Set with Generator Control Panel 1 (GCP1) and PowerCommand™ Supervisor (PCS) 3100 Control Panel - Engine Speed and Speed Bias Circuit
QSK60G Single and Multiple Turbochargers Generator Set with Generator Control Panel 2 (GCP2) and PowerCommand™ Supervisor (PCS) 3100 Control Panel - Engine Speed and Speed Bias Circuit
QSK60G Single and Multiple Turbochargers Generator Set with PowerCommand™ Control (PCC) 3300 Control Panel - Engine Speed and Speed Bias Circuit

Circuit Description

This feature provides diagnostics in order to prevent the engine from losing speed and/or power, or failing to meet demand for indefinite periods of time.

When operating in Isolate Bus applications, the engine control module (ECM) monitors engine speed via the engine speed sensor mounted at the flywheel. The engine speed signal is monitored by the CM700 module.

When operating in utility/grid parallel applications, the ECM monitors the speed bias demand signal. The engine speed bias sensor is mounted at the flywheel and its signal is monitored by the generator set control panel (PowerCommand™ Supervisor 3100 or PowerCommand™ Control 3300). The generator set control panel sends a speed bias command signal to the CM700 module so that the load demand is met (up to 100 percent of generator set rated output).

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

If Fault Code 1791 is activated during load ramp up, the most probable causes are:

  • Generator set control panel: Ramp Load Time incorrect (load being applied too quickly). The Ramp Load Time has been changed to a lower value than the default value of 120 seconds.
  • Air/Fuel Ratio too lean; this may also cause multiple cylinder misfires and multiple low cylinder exhaust temperatures.
  • Intake filters restricted.
  • Any fuel system related faults, such as: fuel supply pressure too low; fuel control valve related fault; throttle driver or actuator related fault; or fuel system sensor faults (fuel inlet pressure sensor, fuel outlet pressure sensor, gas mass flow sensor, intake manifold pressure sensor, intake manifold temperature sensor, high temperature coolant temperature sensor, generator set kW signal).

If Fault Code 1791 is activated when the engine is operating at a steady state condition, the most probable causes are:

  • Air inlet temperature too high, resulting in loss of throttle margin.
  • Incorrect throttle valve adjustment.
  • Generator set control panel voltage/ampere calibration incorrect resulting in a mismatch between actual kW load and calculated kW load. This could result in the generator set running overload, but the control panel indicates 100 percent load.
  • Air/Fuel Ratio too lean; this may also result in multiple cylinder misfires and low cylinder exhaust temperatures.
  • High/Low Temperature (LT) Coolant circuit temperature.
  • Turbocharger compressor bypass valve malfunctioned in the open position or not connected (QSK60G Single Turbocharger generator set only).
  • Turbocharger wear.

If Fault Code 1791 is activated, always check for multiple active or inactive fault codes and fully investigate before replacing the turbocharger(s).

Refer to Troubleshooting Fault Code t05-1791.

Last Modified: 25-Jun-2012


Engine Low Idle / Rated Speed with Generator Breakers Closed

FAULT CODE 1792

Engine Low Idle / Rated Speed with Generator Breakers Closed

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1792 PID: SPN: 4079 FMI: 31 LAMP: Warning SRT: | Engine Low Idle / Rated Speed with Generator Breakers Closed. Engine speed is commanded to idle and the generator set mode of operation is utility parallel. | The engine speed will be maintained at rated speed until generator set mode of operation is not utility parallel.
Idle / Rated Circuit - Generator Set Control with PowerCommand® Supervisor
Utility Parallel Circuit – Generator Set Control with PowerCommand® Supervisor
J1939 Communications Circuit - Generator Set Control with PCC3300
Generator Set Circuit Breaker Position Circuit

Circuit Description

On generator sets with PowerCommand® Supervisor, idle engine speed mode of operation is the default, open state of PLC 6 - 7. When PLC 6 - 7 closes when commanded from the Human Machine Interface (HMI), it energizes K10-2 coil and closes K10’s contact circuit, enabling CM700 to enter rated engine speed mode of operation.

On generator sets with PowerCommand® Supervisor, the CM700 enables utility parallel mode of operation when the signal from CM700 C-36 is grounded. This signal is grounded when K12-3 and K15-2 are energized by the closing of the generator set output circuit breaker position and utility parallel enable switches respectively.

On generator sets with PCC3300, generator set circuit breaker position is a PCC3300 input. Idle / Rated mode of operation switch is toggled either via InPower™ electronic service tool or the generator set HMI. The PCC3300 communicates these signals to the CM700 with J1939 communications.

Component Location

Use the following procedure for component locations. Refer to Procedure 100-002 in Section E.

Shop Talk

The CM700 will prevent the engine from entering idle mode of operation, regardless of idle command input, if the generator set mode of operation is utility parallel. In order for CM700 to allow idle mode of operation, remove the generator set from utility parallel mode of operation and then attempt enabling idle mode of operation.

Refer to Troubleshooting Fault Code t05-121.

Last Modified: 12-Oct-2010


Engine Crankshaft Speed / Position Mismatch between ECMs - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 1793

Engine Crankshaft Speed / Position Mismatch between ECMs - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1793 PID: 190 SPN: 190 FMI: 7 LAMP: Warning SRT: | Engine Crankshaft Speed / Position Mismatch between ECMs - Mechanical System Not Responding or Out of Adjustment. There is an engine speed / position mismatch between the engine ECMs. | No action taken by the ECM. Engine will continue to run, but there may be a possible loss of performance.
QSK60G Multiple Turbocharger Engines with Generator Control Panel 1(GCP1) and PowerCommand® Supervisor 3100 Generator Set Controller - Crankshaft / Camshaft Engine Speed and Engine Speed/Position Sensor Circuit
QSK60G Single and Multiple Turbocharger Engines with Generator Control Panel 2 (GCP2) and PowerCommand® Supervisor 3100 Generator Set Controller - Crankshaft / Camshaft Engine Speed and Engine Speed/Position Sensor Circuit
QSK60G Single and Multiple Turbocharger Engines with PowerCommand® Control 3300 Generator Set Controller - Crankshaft / Camshaft Engine Speed and Engine Speed/Position Sensor Circuit

Circuit Description

The crankshaft engine speed sensor provides engine speed and position information to the CM700 module. The sensor has a dual core circuit, that on some QSK60G models supplies a speed signal to the CM700 (engine speed) and the PowerCommand® Supervisor 3100 generator set control panel (speed bias control). On other applications, only one of the sensor core circuits is utilized. The sensor generates a signal by sensing the movement of the flywheel teeth.

The camshaft engine speed / position sensor monitors engine speed and position with a dual core/coil sensor. One coil feeds the left-bank CM558 and one feeds the right-bank CM558.

Fault Code 1793 is activated when the speed mismatch between the ECMs exceeds the warning threshold of 100 rpm for 1.0 second.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The crankshaft engine speed sensor is a magnetic sensor that senses the movement of the flywheel teeth.

The camshaft engine speed/position sensor is a magnetic sensor that senses a ribbed camshaft drive wheel that is connected to the left bank camshaft. The ribbed wheel has a single mark to identify the beginning of the firing order/cycle.

Check for the correct air gap between the crankshaft engine speed sensor and the gear teeth on the flywheel. Position the flywheel so that a gear tooth is directly below the sensor in order to check and set the gap.

Possible causes of this fault code include:

  • Damaged or incorrectly adjusted crankshaft engine speed sensor
  • Damaged camshaft engine speed/position sensor
  • Open or shorted circuit.

If Fault Code 1793 is only activated at a certain engine temperature, be sure to check the engine speed and position sensors and their circuits while the engine is at that particular temperature.

Refer to Troubleshooting Fault Code t05-1793.

Last Modified: 21-Oct-2010


Unexpected Thermal Event - Condition Exists

FAULT CODE 1794

Unexpected Thermal Event - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1794 PID: SPN: 520335 FMI: 31 LAMP: Shutdown SRT: | Unexpected Thermal Event - Condition Exists. An unexpected thermal event has occurred. | Engine will shutdown.
Electronic Control Module (ECM)

Circuit Description

IMPORTANT NOTE: Comply with all site fire procedures, as well as national and local regulations. Evacuate the buildings and proceed to the designated fire assembly area.

If the source of the fire alarm activation was found to be local to the generator set, DO NOT enter the engine room or container until it has been confirmed as safe to do so by local health and safety executive personnel and they have authorized entry.

The generator set must not be re-started until authorized by local health and safety executive personnel. This troubleshooting procedure must be followed and any identified issues rectified before attempting to re-start the generator set.

NOTE: This document does not override or replace any local legislation or regulations.

Most engine rooms or generator set containers will be equipped with some form of fire detection equipment in order to comply with local legislation. Typically, such fire detection equipment will be interfaced with the generator set controls, so that if the fire detection equipment is activated for any reason, any running generator sets will be brought to an immediate stop with a critical shutdown.

Engine auxiliaries, such as coolant and lube oil circulation pumps, will also be isolated.

The generator set control system may also be interfaced with any site fire alarm system and may be tripped as a result of the site fire alarm being activated.

Component Location

Reference the site specific installation schematics for the component location.

Shop Talk

Maintaining a running natural gas fueled generator set during a possible fire situation is undesirable; therefore, it is common to have the generator sets linked to site fire alarm systems so that any running generator sets will be brought to an immediate stop.

Once the cause of the fire alarm has been investigated and resolved, by suitably qualified and authorized personnel, the engine room/container fire protection system will need to be reset before Fault Code 1794 can be cleared and the generator set restarted.

NOTE: The fire detection system alarm reset procedure detailed in this procedure refers to the generator plant room or container local system. Any main site system reset procedure is outside of the scope of this document and must only be undertaken by local authorized personnel.

Refer to Troubleshooting Fault Code t05-1794.

Last Modified: 12-Oct-2010


Engine Turbocharger Compressor Bypass Actuator Position Sensor - Voltage Above Normal or Shorted to a High Source

FAULT CODE 1795

Engine Turbocharger Compressor Bypass Actuator Position Sensor - Voltage Above Normal or Shorted to a High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1795 PID: SPN: 3675 FMI: 3 LAMP: Warning SRT: | Engine Turbocharger Compressor Bypass Actuator Position Sensor - Voltage Above Normal or Shorted to High Source. High voltage detected on the turbocharger compressor bypass actuator position RETURN pin. | Possible reduced engine performance.
QSK60G Single Turbocharger with Generator Control Panel 2 (GCP2) and Power Command™ Supervisor 3100 - Engine Turbocharger Compressor Bypass Actuator Circuit
QSK60G Single Turbocharger with Generator Interface Box (GIB) and Power Command™ Control 3300 - Engine Turbocharger Compressor Bypass Actuator Circuit

Circuit Description

The engine turbocharger compressor bypass actuator position feedback circuit is used to monitor the position of the turbocharger compressor bypass valve. The compressor bypass valve is supplied with 24-VDC directly from the generator set 24-VDC power supply system.

The CM558 supplies the turbocharger compressor bypass valve with position information and the CM558 monitors the position of the valve via the position feedback circuit.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E of this manual.

Shop Talk

The compressor bypass actuator position signal to the CM558 module must read from 0 to 5-VDC, based on the position of the valve

The turbocharger compressor bypass actuator position COMMAND signal from the CM558 module is a 24-VDC pulse-width modulated (PWM) signal. The PWM percent duty cycle must read from 10 to 100 percent, based on the position of the valve. The turbocharger compressor bypass actuator position FEEDBACK signal to the CM558 module must read from 0 to 5-VDC, based on the position of the valve.

The following table provides actuator position Commanded PWM percent Duty Cycle and VDC Feedback signal specifications.

Actuator Commanded Position | Percent of Duty Cycle | 0 to 5-VDC Feedback Signal
0 | 10-11 | 0.4 to 0.7
10 | 17-19 | 0.9 to 1.1
20 | 25-27 | 1.3 to 1.5
30 | 33-35 | 1.7 to 1.9
40 | 41-43 | 2.1 to 2.3
50 | 49-51 | 2.5 to 2.7
60 | 57-59 | 2.9 to 3.1
70 | 65-67 | 3.3 to 3.5
80 | 73-75 | 3.7 to 3.9
90 | 81-83 | 4.1 to 4.3
100 | 89-91 | 4.6 to 4.8

PWM percent duty cycle signals can only be measured with multimeters or other measuring devices that have a percent duty cycle function.

A short to battery voltage in the harness or turbocharger compressor bypass valve connector will cause Fault Code 1795 to be activated.

Refer to Troubleshooting Fault Code 1795.

Last Modified: 08-Nov-2010


Engine Turbocharger Compressor Bypass Actuator Position Sensor - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1796

Engine Turbocharger Compressor Bypass Actuator Position Sensor - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1796 PID: SPN: 3675 FMI: 4 LAMP: Warning SRT: | Engine Turbocharger Compressor Bypass Actuator Position Sensor - Voltage Below Normal or Shorted to Low Source. Low voltage detected on the turbocharger compressor bypass actuator position RETURN pin. | Possible reduced engine performance.
QSK60G Single Turbocharger with Generator Control Panel 2 (GCP2) and Power Command™ Supervisor 3100 - Engine Turbocharger Compressor Bypass Actuator Circuit
QSK60G Single Turbocharger with Generator Interface Box (GIB) and Power Command™ Control 3300 - Engine Turbocharger Compressor Bypass Actuator Circuit

Circuit Description

The engine turbocharger compressor bypass actuator position feedback circuit is used to monitor the position of the turbocharger compressor bypass valve. The compressor bypass valve is supplied with 24-VDC directly from the generator set 24-VDC power supply system.

The CM558 supplies the turbocharger compressor bypass valve with position information and the CM558 monitors the position of the valve via the position feedback circuit.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The turbocharger compressor bypass actuator position COMMAND signal from the CM558 module is a 24-VDC pulse width modulated (PWM) signal. The PWM percent duty cycle must read from10 to 100 percent, based on the position of the valve.

The turbocharger compressor bypass actuator position FEEDBACK signal to the CM558 module must read from 0 to 5-VDC, based on the position of the valve.

Actuator Commanded Position | Percent Duty Cycle | 0 to 5-VDC Feedback Signal
0 | 10 to 11 | 0.4 to 0.7
10 | 17 to 19 | 0.9 to 1.1
20 | 25 to 27 | 1.3 to 1.5
30 | 33 to 35 | 1.7 to 1.9
40 | 41 to 43 | 2.1 to 2.3
50 | 49 to 51 | 2.5 to 2.7
60 | 57 to 59 | 2.9 to 3.1
70 | 65 to 67 | 3.3 to 3.5
80 | 73 to 75 | 3.7 to 3.9
90 | 81 to 83 | 4.1 to 4.3
100 | 89 to 91 | 4.6 to 4.8

PWM percent duty cycle signals can only be measured with multimeters or other measuring devices that have a percent duty cycle function.

A short to ground or an open circuit in the harness or at the turbocharger compressor bypass valve connector will cause Fault Code 1796 to be activated.

Refer to Troubleshooting Fault Code 1796.

Last Modified: 09-Nov-2010


Engine Turbocharger Compressor Bypass Actuator Position Command Sensor - Voltage Above Normal or Shorted to High Source

FAULT CODE 1797

Engine Turbocharger Compressor Bypass Actuator Position Command Sensor - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1797 PID: SPN: 3670 FMI: 3 LAMP: Warning SRT: | Engine Turbocharger Compressor Bypass Actuator Position Command Sensor - Voltage Above Normal or Shorted to High Source. High voltage detected on the turbocharger compressor bypass actuator position command circuit. | Possible reduced engine performance.
QSK60G Single Turbocharger with Generator Control Panel 2 (GCP2) and Power Command™ Supervisor 3100 - Engine Turbocharger Compressor Bypass Actuator Circuit
QSK60G Single Turbocharger with Generator Interface Box (GIB) and Power Command™ Control 3300 - Engine Turbocharger Compressor Bypass Actuator Circuit

Circuit Description

The engine turbocharger compressor bypass actuator position feedback circuit is used to monitor the position of the turbocharger compressor bypass valve. The compressor bypass valve is supplied with 24-VDC directly from the generator set 24-VDC power supply system.

The commanded position signal from the CM558 to the turbocharger compressor bypass valve is a + 24-VDC pulse width modulated (PWM) signal.

Component Location

Use the following procedure for componenet location. Refer to Procedure 100-002 in Section E.

Shop Talk

The turbocharger compressor bypass actuator position signal to the CM558 module must read from 0 to 5-VDC, based on the position of the valve.

The turbocharger compressor bypass actuator position COMMAND signal from the CM558 module is a 24-VDC PWM signal. The PWM percent duty cycle must read from 10 to 100 percent, based on the position of the valve.

The turbocharger compressor bypass actuator position FEEDBACK signal to the CM558 module must read from 0 to 5-VDC, based on the position of the valve. The following table provides actuator position commanded PWM percent duty cycle and VDC Feedback signal specifications.

Actuator Commanded Position | Percent Duty Cycle | 0 to 5-VDC Feedback Signal
0 | 10 to 11 | 0.4 to 0.7
10 | 17 to 19 | 0.9 to 1.1
20 | 25 to 27 | 1.3 to 1.5
30 | 33 to 35 | 1.7 to 1.9
40 | 41 to 43 | 2.1 to 2.3
50 | 49 to 51 | 2.5 to 2.7
60 | 57 to 59 | 2.9 to 3.1
70 | 65 to 67 | 3.3 to 3.5
80 | 73 to 75 | 3.7 to 3.9
90 | 81 to 83 | 4.1 to 4.3
100 | 89 to 91 | 4.6 to 4.8

PWM percent duty cycle signals can only be measured with multimeters or other measuring devices that have a percent duty cycle function.

A short to ground or an open circuit in the harness or at the turbocharger compressor bypass valve connector will cause Fault Code 1796 to be activated.

Refer to Troubleshooting Fault Code 1797.

Last Modified: 08-Nov-2010


Engine Turbocharger Compressor Bypass Actuator Control Command Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1798

Engine Turbocharger Compressor Bypass Actuator Control Command Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1798 PID: SPN: 3470 FMI: 4 LAMP: Warning SRT: | Engine Turbocharger Compressor Bypass Actuator Control Command Circuit - Voltage Below Normal or Shorted to Low Source. A short to ground or open circuit has been detected on the engine compressor bypass actuator command pin of the main harness CM558 connector. | Possible reduced engine performance.
QSK60G Single Turbocharger with Generator Control Panel 2 (GCP2) and Power Command™ Supervisor 3100 - Engine Turbocharger Compressor Bypass Actuator Circuit
QSK60G Single Turbocharger with Generator Interface Box (GIB) and PowerCommand™ Control 3300 - Engine Turbocharger Compressor Bypass Actuator Circuit

Circuit Description

The engine turbocharger compressor bypass actuator position sensor circuit is used to monitor the position of the turbocharger compressor bypass valve. The compressor bypass valve is supplied with 24-VDC directly from the generator set 24-VDC power supply system.

The commanded position signal from the CM558 to the turbocharger compressor bypass valve is a + 24-VDC pulse width modulated (PWM) signal.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The compressor bypass actuator position signal to the CM558 module must read from 0 to 5-VDC, based on the position of the valve.

The turbocharger compressor bypass actuator position COMMAND signal from the CM558 module is a 24-VDC PWM signal. The PWM percent duty cycle must read from10 to 100 percent, based on the position of the valve.

The turbocharger compressor bypass actuator position FEEDBACK signal to the CM558 module must read from 0 to 5-VDC, based on the position of the valve.

The following table provides actuator position commanded PWM percent duty cycle and VDC Feedback signal specifications.

Actuator Commanded Position | Percent Duty Cycle | 0 to 5-VDC Feedback Signal
0 | 10 to 11 | 0.4 to 0.7
10 | 17 to 19 | 0.9 to 1.1
20 | 25 to 27 | 1.3 to 1.5
30 | 33 to 35 | 1.7 to 1.9
40 | 41 to 43 | 2.1 to 2.3
50 | 49 to 51 | 2.5 to 2.7
60 | 57 to 59 | 2.9 to 3.1
70 | 65 to 67 | 3.3 to 3.5
80 | 73 to 75 | 3.7 to 3.9
90 | 81 to 83 | 4.1 to 4.3
100 | 89 to 91 | 4.6 to 4.8

PWM percent duty cycle signals can only be measured with multimeters or other measuring devices that have a percent duty cycle function.

A short to ground or an open circuit in the harness or at the turbocharger compressor bypass valve connector will cause Fault Code 1796 to be activated.

Refer to Troubleshooting Fault Code 1798.

Last Modified: 08-Nov-2010


Engine Turbocharger Compressor Bypass Actuator Control Command - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 1799

Engine Turbocharger Compressor Bypass Actuator Control Command - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1799 PID: SPN: 3470 FMI: 7 LAMP: Warning SRT: | Engine Turbocharger Compressor Bypass Actuator Control Command - Mechanical System Not Responding or Out of Adjustment | Possible reduced engine performance.
QSK60G Single Turbocharger with Generator Control Panel 2 (GCP2) and PowerCommand™ Supervisor 3100 - Engine Turbocharger Compressor Bypass Actuator Circuit
QSK60G Single Turbocharger with Generator Interface Box (GIB) and PowerCommand™ Control 3300 - Engine Turbocharger Compressor Bypass Actuator Circuit

Circuit Description

The turbocharger compressor bypass actuator position circuit consists of the commanded position signal from the CM558 and feedback signal that is received by the CM558 from the turbocharger compressor bypass valve. The CM558 monitors the commanded position and the feedback position signals to confirm that the compressor bypass valve has responded and is in the desired position. The commanded position signal is a + 24-VDC pulse-width modulated (PWM) signal and the feedback is a 0 to 5-VDC signal.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The turbocharger compressor bypass actuator commanded signal and the feedback signal can be monitored using the electronic service tool. The turbocharger compressor bypass valve is most likely to fail in either the closed or fully open position. Monitor the position feedback signal to make sure that the valve is moving freely and is in the desired position.

The following table provides actuator position commanded PWM percent duty cycle and voltage feedback specifications.

Fuel Control Valve and Turbocharger Compressor Bypass Valve
Actuator Commanded Position | Commanded % Duty Cycle | 0 to 5-VDC Position Feedback
0 | 10 to 14 | 0.4 to 0.7-VDC
10 | 17 to 21 | 0.9 to 1.1-VDC
20 | 25 to 28 | 1.3 to 1.5-VDC
30 | 33 to 37 | 1.7 to 1.9-VDC
40 | 41 to 44 | 2.1 to 2.3-VDC
50 | 49 to 54 | 2.5 to 2.7-VDC
60 | 55 to 60 | 2.9 to 3.1-VDC
70 | 65 to 70 | 3.3 to 3.5-VDC
80 | 73 to 78 | 3.7 to 3.9-VDC
90 | 81 to 86 | 4.1 to 4.3-VDC
100 | 89 to 94 | 4.6 to 4.8-VDC

PWM percent duty cycle signals can only be measured with multimeters or other measuring devices that have a percent duty cycle function.

If the difference between the commanded position and the feedback position signals is greater than the fault threshold, Fault Code 1799 will be activated.

Possible causes of this fault code include:

  • Turbocharger compressor bypass valve mechanically seized
  • Short circuit in the commanded position or feedback signal circuits within the engine harness
  • Open circuit in the commanded position or feedback signal circuits within the engine harness.
Refer to Troubleshooting Fault Code t05-1799.

Last Modified: 10-Feb-2012


Engine Fuel Shutoff Valve Leak Test Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1811

Engine Fuel Shutoff Valve Leak Test Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1811 PID: SPN: 3601 FMI: 3 LAMP: Warning SRT: | Engine Fuel Shutoff Valve Leak Test Control Circuit - Voltage Above Normal or Shorted to High Source. A high voltage has been detected in the Engine Fuel Shutoff Valve Leak Test Control Circuit. | No effect on engine performance.
QSK60G Single and Multiple Turbochargers with Generator Control Panel 2 (GCP2) and PowerCommand® Supervisor 3100
QSK60G Single and Multiple Turbochargers with PowerCommand® Control 3300
Fuel Double Solenoid Shutoff Valve

Circuit Description

The Fuel Double-Solenoid Shutoff Valve (DSSV), above, is checked for gas tightness following every engine shutdown. The Valve Proving System (VPS) module is responsible for performing this test and is controlled by the CM700 module. The VPS module is mounted on the DSSV.

Following an engine shutdown, the CM700 commands the VPS module to pump gas into the DSSV, directly between the downstream and upstream gas valves. The CM700, via the fuel supply pressure sensor, monitors the pressure rise between the gas valves, and monitors for a pre-determined pressure rise, within a pre-set time limit threshold. When the required pressure rise is attained, the CM700 commands the VPS modules integral pump to switch off. The attained gas pressure must then be maintained for a set period of time. This test procedure checks the integrity of the upstream and downstream gas valves.

Should any of the VPS test requirements not be met, the CM700 module prevents the engine from starting (Critical Shutdown). The cause of the test failure must be identified and corrected before the engine is allowed to start.

Component Location

The Fuel Double Solenoid Shutoff Valve (DSSV) is located off-engine and is site specific. Reference to site installation drawings for location.

Shop Talk

None.

Refer to Troubleshooting Fault Code t05-1811.

Last Modified: 12-Oct-2010


Engine Fuel Shutoff Valve Leak Test Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1812

Engine Fuel Shutoff Valve Leak Test Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1812 PID: SPN: 3601 FMI: 4 LAMP: Warning SRT: | Engine Fuel Shutoff Valve Leak Test Control Circuit - Voltage Below Normal or Shorted to Low Source. A low voltage has been detected in the Engine Fuel Shutoff Valve Leak Test Control Circuit. | No effect on engine performance.
QSK60G Single and Multiple Turbochargers with Generator Control Panel 2(GCP2) and PowerCommand® Supervisor 3100 - Circuit Art
QSK60G Single and Multiple Turbochargers with PowerCommand® Control 3300 - Circuit Art
Fuel Double Solenoid Shutoff Valve

Circuit Description

The Fuel Double-Solenoid Shutoff Valve (DSSV) is checked for gas tightness following every engine shutdown. The Valve Proving System (VPS) module is responsible for performing this test and is controlled by the CM700 module. The VPS module is mounted on the DSSV.

Following an engine shutdown, the CM700 commands the VPS Module to pump gas into the DSSV, directly between the downstream and upstream gas valves. The CM700, via the fuel supply pressure sensor, monitors the pressure rise between the gas valves, and monitors for a pre-determined pressure rise within a pre-set time limit threshold. When the required pressure rise is attained, the CM700 commands the VPS modules integral pump to switch off. The attained gas pressure must then be maintained for a set period of time. This test procedure checks the integrity of the upstream and downstream gas valves.

If any of the VPS test requirements are not be met, the CM700 module prevents the engine from starting (Critical Shutdown). The cause of the unsuccessful test must be identified and corrected before the engine is allowed to start.

Component Location

The Fuel Double Solenoid Shutoff Valve (DSSV) is located off-engine and is site specific. Refer to site installation drawings for location.

Shop Talk

None.

Refer to Troubleshooting Fault Code t05-1812.

Last Modified: 21-Oct-2010


Engine Fuel Shutoff Valve Leak Test - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 1813

Engine Fuel Shutoff Valve Leak Test - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1813 PID: SPN: 3601 FMI: 18 LAMP: Warning SRT: | Engine Fuel Shutoff Valve Leak Test - Data Valid But Below Normal Operating Range - Moderately Severe Level. A low pressure has been detected in the Engine Fuel Shutoff Valve following the leak test. | No effect on engine performance.
QSK60G Single and Multiple Turbochargers with Generator Control Panel 2(GCP2) and PowerCommand® Supervisor 3100 - Circuit Art
QSK60G Single & Multiple Turbochargers with PowerCommand® Control 3300 - Circuit Art
Fuel Double Solenoid Shutoff Valve

Circuit Description

The Fuel Double-Solenoid Shutoff Valve (DSSV) is checked for gas tightness following every engine shutdown. The Valve Proving System (VPS) module is responsible for performing this test and is controlled by the CM700 module. The VPS module is mounted on the DSSV.

Following an engine shutdown, the CM700 commands the VPS Module to pump gas into the DSSV, directly between the downstream and upstream gas valves. The CM700, via the fuel supply pressure sensor, monitors the pressure rise between the gas valves, and monitors for a pre-determined pressure rise, within a pre-set time limit threshold. When the required pressure rise is attained, the CM700 commands the VPS modules integral pump to switch off. The attained gas pressure must then be maintained for a set period of time. This test procedure checks the integrity of the upstream and downstream gas valves.

Component Location

The Fuel Double Solenoid Shutoff Valve (DSSV) is located off-engine and is site specific. Refer to site installation drawings for location.

Shop Talk

Fault Code 1813 must be investigated at the earliest opportunity in order to prevent further deterioration of the Fuel Double Solenoid Shutoff Valve (DSSV) and Fault Code 1814 being activated.

Possible Causes of Fault Code 1813 are:

  • Faulty upstream gas shutoff valve
  • Faulty downstream gas shutoff valve
  • Faulty Valve Proving System (VPS) module.

IMPORTANT NOTE: In most countries, inspection and repair of natural gas supply systems and components can only be undertaken by qualified and certified personnel. In many regions, accreditation to a nationally recognized trade organization is also required. It is necessary to comply with all local and national codes and legislation when performing these maintenance procedures.

Refer to Troubleshooting Fault Code t05-1813.

Last Modified: 22-Oct-2010


Engine Fuel Shutoff Valve Leak Test - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 1814

Engine Fuel Shutoff Valve Leak Test - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1814 PID: SPN: 3601 FMI: 1 LAMP: Shutdown SRT: | Engine Fuel Shutoff Valve Leak Test - Data Valid But Below Normal Operating Range - Most Severe Level. A very low pressure has been detected in the Engine Fuel Shutoff Valve following the leak test. | Engine starting will be locked out.
QSK60G Single and Multiple Turbochargers with Generator Control Panel 2(GCP2) and PowerCommand® Supervisor 3100 - Circuit Art
QSK60G Single & Multiple Turbochargers with PowerCommand® Control 3300 - Circuit Art
Fuel Double Solenoid Shutoff Valve

Circuit Description

The Fuel Double-Solenoid Shutoff Valve (DSSV) is checked for gas tightness following every engine shutdown. The Valve Proving System (VPS) module is responsible for performing this test and is controlled by the CM700 module. The VPS module is mounted on the DSSV.

Following an engine shutdown, the CM700 commands the VPS Module to pump gas into the DSSV, directly between the downstream and upstream gas valves. The CM700, via the fuel supply pressure sensor, monitors the pressure rise between the gas valves, and monitors for a pre-determined pressure rise, within a pre-set time limit threshold. When the required pressure rise is attained, the CM700 commands the VPS modules integral pump to switch off. The attained gas pressure must then be maintained for a set period of time. This test procedure checks the integrity of the upstream and downstream gas valves.

If any of the VPS test requirements are not be met, the CM700 module prevents the engine from starting (Critical Shutdown). The cause of the unsuccessful test must be identified and corrected before the engine is allowed to start.

Component Location

The Fuel Double Solenoid Shutoff Valve (DSSV) is located off-engine and is site specific. Refer to site installation drawings for location.

Shop Talk

Fault Code 1814 must be investigated at the earliest opportunity in order to prevent further deterioration of the Fuel Double Solenoid Shutoff Valve (DSSV) and Fault Code 1814 being activated.

Possible Causes of Fault Code 1814 are:

  • Faulty upstream gas shutoff valve
  • Faulty downstream gas shutoff valve
  • Faulty Valve Proving System (VPS) module.

IMPORTANT NOTE: In most countries, inspection and repair of natural gas supply systems and components can only be undertaken by qualified and certified personnel. In many regions, accreditation to a nationally recognized trade organization is also required. It is necessary to comply with all local and national codes and legislation when performing these maintenance procedures.

Refer to Troubleshooting Fault Code t05-1814.

Last Modified: 22-Oct-2010


Engine Crankshaft Speed / Position Very Low Engine Speed Detected When Engine is Supposed to Be Running - Root Cause Not Known

FAULT CODE 1821

Engine Crankshaft Speed / Position Very Low Engine Speed Detected When Engine is Supposed to Be Running - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1821 PID: P190 SPN: 190 FMI: 11 LAMP: Shutdown SRT: | Engine Crankshaft Speed / Position Very Low Engine Speed Detected When Engine is Supposed to be Running - Root Cause Not Known. | The engine will shutdown or will fail to start.
QSK60G Multiple Turbocharger Engines with Generator Control Panel 1(GCP1) and PowerCommand® Supervisor 3100 Generator Set Controller - Crankshaft Engine Speed, Camshaft Engine Speed/Position Sensor Circuit
QSK60G Single and Multiple Turbocharger Engines with Generator Control Panel 2 (GCP2) and PowerCommand® Supervisor 3100 Generator Set Controller - Crankshaft Engine Speed, Camshaft Engine Speed/Position Sensor Circuit
QSK60G Single and Multiple Turbocharger Engines with PowerCommand® Control 3300 Generator Set Controller - Crankshaft Engine Speed, Camshaft Engine Speed/Position Sensor Circuit

Circuit Description

The crankshaft engine speed sensor provides engine speed and position information to the CM700 module. The sensor has a dual core circuit, that on some QSK60G models supplies a speed signal to the CM700 (engine speed) and the PowerCommand® Supervisor 3100 generator set control panel (speedbias control). On other applications, only one of the sensor core circuits is utilized. The sensor generates a signal by sensing the movement of the flywheel teeth.

The camshaft engine speed / position sensor monitors engine speed and position via a dual core/coil sensor. One coil feeds the left-bank CM558 and one feeds the right-bank CM558.

Fault Code 1821 is activated when no or very low speed is detected by the ECMs, when the ECMs know that the engine is supposed to be running.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The crankshaft engine speed sensor is a magnetic sensor that senses the movement of the flywheel teeth.

The camshaft engine speed/position sensor is a magnetic sensor that senses a ribbed camshaft drive wheel that is connected to the left bank camshaft. The ribbed wheel has a single mark to identify the beginning of the firing order/cycle.

Check for the correct air gap between the crankshaft engine speed sensor and the gear teeth on the flywheel. Position the flywheel so that a gear tooth is directly below the sensor in order to check and set the gap.

Possible causes of this fault code include:

  • Damaged or incorrectly adjusted crankshaft engine speed sensor
  • Damaged camshaft engine speed/position sensor
  • Open or shorted circuit.

If Fault Code 1821 is only activated at a certain engine temperature, be sure to check the engine speed and position sensors and their circuits while the engine is at that particular temperature.

Refer to Troubleshooting Fault Code t05-1821.

Last Modified: 21-Oct-2010


Engine Aftercooler Coolant Level (LT) - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 1822

Engine Aftercooler Coolant Level (LT) - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1822 PID: SPN: 3679 FMI: 11 LAMP: Shutdown SRT: | Engine Aftercooler Coolant Level (LT) - Data Valid But Below Normal Operating Range - Most Severe Level. Low engine coolant level in the engine aftercooler low temperature (LT) engine cooling circuit detected. | The engine will shutdown.
QSK60G Multiple Turbochargers with Generator Control Panel (GCP1) and PowerCommand® Supervisor 3100
QSK60G Single and Multiple Turbochargers with Generator Control Panel (GCP2) and PowerCommand® Supervisor 3100
QSK60G Single and Multiple Turbochargers with PowerCommand® Control 3300

Circuit Description

The engine coolant level sensor (LT) monitors the engine coolant level within the engine's low temperature aftercooler cooling system and passes information to the CM700 module. The wiring between the coolant level sensor and the Generator Control Panel or Generator Interface Box is customer supplied.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

None.

Refer to Troubleshooting Fault Code t05-1822.

Last Modified: 21-Oct-2010


Engine Aftercooler Coolant Level (LT) - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 1823

Engine Aftercooler Coolant Level (LT) - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1823 PID: SPN: 3676 FMI: 17 LAMP: Warning SRT: | Engine Aftercooler Coolant Level (LT) - Data Valid But Below Normal Operating Range - Least Severe Level. Low engine coolant level in the engine aftercooler low temperature (LT) engine cooling circuit detected. | No effect on engine performance.
QSK60G Multiple Turbochargers with Generator Control Panel (GCP1) and PowerCommand® Supervisor 3100
QSK60G Single and Multiple Turbochargers with Generator Control Panel (GCP2) and PowerCommand® Supervisor 3100
QSK60G Single and Multiple Turbochargers with PowerCommand® Control 3300

Circuit Description

The engine coolant level sensor (LT) monitors the engine coolant level within the engine's low temperature aftercooler cooling system and passes information to the CM700 module. The wiring between the coolant level sensor and the Generator Control Panel or Generator Interface Box is customer supplied.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

None.

Refer to Troubleshooting Fault Code t05-1823.

Last Modified: 21-Oct-2010


Engine Oil Temperature Sensor 1 Circuit, Too Cold For High Idle - Condition Exists

FAULT CODE 1824

Engine Oil Temperature Sensor 1 Circuit, Too Cold For High Idle - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1824 PID: SPN: 175 FMI: 31 LAMP: Warning SRT: | Engine Oil Temperature Sensor 1 Circuit, Too Cold For High Idle - Condition Exists. The oil has not warmed up sufficiently for the engine to increase speed. | The engine will continue to run at low idle until minimum oil temperature is achieved.
Multiple Turbocharger Engines - Oil Temperature Sensor 1 Circuit
Single Turbocharger Engines - Oil Temperature Sensor 1 Circuit

Circuit Description

The engine oil temperature sensor is used by the CM700 to monitor the temperature of the engine lubricating oil.

When Fault Code 1824 is activated, the engine will be held at low-idle (900 rpm) until the minimum oil temperature threshold has been reached. On reaching the threshold, the engine control system will allow the engine to go to rated speed and normal operation is resumed.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section.

Shop Talk

Cummins® High Horsepower Natural Gas Lean-Burn Generator Sets typically use monograde engine oils. Monograde oils increase in viscosity when cold more than a multi-grade oil. In order to protect the engine from damage as a result of increased oil viscosity, the engine's control system monitors the oil temperature and when the oil temperature is below a preset threshold, the engine is prevented from going to rated speed.

In order to reduce the time the engine operates at low-idle, the engine is fitted with coolant heaters to help maintain oil temperature and viscosity during shutdown. The coolant heaters are powered only when the engine is at 0 rpm (shutdown) and may be isolated following critical shutdowns or following Generator Set isolation during service and maintenance.

It is possible for sensors to malfunction in-range. Therefore, the sensors' respective fault codes may not be activated. Therefore, the oil temperature sensor 1 must be checked if the engine does not go to rated speed even though Fault Codes 212 and 213 are not active.

Refer to Troubleshooting Fault Code t05-1824.

Last Modified: 21-Oct-2010


Incompatible Software Version Determined in Secondary Control Module - Condition Exists

FAULT CODE 1826

Incompatible Software Version Determined in Secondary Control Module - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1826 PID: SPN: 520357 FMI: 31 LAMP: Shutdown SRT: | Incompatible Software Version Determined in Secondary Control Module - Condition Exists. The ECMs have detected a software version conflict on one or more of the CM558 modules. | The engine will not be allowed to start.
INSITE™ electronic service tool

Circuit Description

The CM700 and CM558 modules each require software, often referred to as calibrations, to perform engine control functions and provide engine protection.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The electronic control module (ECM) function and control can change with software versions. The electronic service tool and ECMs automatically check to make sure the CM700 and CM558 software versions are compatible. If the ECM automatic check identifies incompatible software in any of the CM558 modules, Fault Code 1826 will be activated.

Refer to Troubleshooting Fault Code t05-1826.

Last Modified: 22-Oct-2010


Engine Gas Control Valve Intake Pressure - Voltage Above Normal or Shorted to High Source

FAULT CODE 1827

Engine Gas Control Valve Intake Pressure - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1827 PID: SPN: 1390 FMI: 3 LAMP: Warning SRT: | Engine Gas Control Valve Intake Pressure - Voltage Above Normal or Shorted to High Source. High voltage has been detected in the engine gas control valve fuel inlet pressure circuit signal circuit. | Possible reduced engine performance.
Generator Interface Box (GIB) and PowerCommand® Supervisor 3100 Generator Controller - Fuel Inlet Pressure Circuit
Generator Interface Box and PowerCommand® Control 3300 Generator Control Panel - Fuel Inlet Pressure Circuit

Circuit Description

The A-Bank CM558 module uses the fuel inlet pressure sensor to measure the fuel pressure in the fuel supply line immediately before the gas mass flow sensor.

The signal DC voltage is directly proportional to pressure; as the pressure increases the signal DC voltage will increase.

Component Location

The fuel inlet pressure sensor is located in the fuel supply line, immediately before the gas mass flow sensor.

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The A-Bank CM558 module uses the fuel inlet pressure sensor to measure the fuel supply pressure immediately before the gas mass flow sensor. This signal is used by the A-Bank CM558 as part of the open and closed-loop fueling calculations so that the engine operates at the correct air/fuel ratio and exhaust emissions are maintained to specification through a wide range of operating conditions.

The fuel inlet pressure sensor is an absolute sensor.

Refer to Troubleshooting Fault Code t05-1827.

Last Modified: 21-Oct-2010


Engine Gas Control Valve Intake Pressure - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1828

Engine Gas Control Valve Intake Pressure - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1828 PID: SPN: 1390 FMI: 4 LAMP: Warning SRT: | Engine Gas Control Valve Intake Pressure - Voltage Below Normal or Shorted to Low Source. Low voltage has been detected in the engine gas control valve fuel inlet pressure circuit signal circuit. | Possible reduced engine performance.
Generator Interface Box (GIB) and PowerCommand® Supervisor 3100 Generator Control Panel - Fuel Inlet Pressure Circuit
Generator Interface Box and PowerCommand® Control 3300 Generator Control Panel - Fuel Inlet Pressure Circuit

Circuit Description

The A-Bank CM558 module uses the fuel inlet pressure sensor to measure the fuel pressure in the fuel supply line immediately before the gas mass flow sensor.

The signal DC voltage is directly proportional to pressure; as the pressure increases the signal DC voltage will increase.

Component Location

The fuel inlet pressure sensor is located in the fuel supply line, immediately before the gas mass flow sensor.

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The A-Bank CM558 module uses the fuel inlet pressure sensor to measure the fuel supply pressure immediately before the gas mass flow sensor. This signal is used by the A-Bank CM558 as part of the open and closed-loop fueling calculations so that the engine operates at the correct air/fuel ratio and exhaust emissions are maintained to specification through a wide range of operating conditions.

The fuel inlet pressure sensor is an absolute sensor.

Refer to Troubleshooting Fault Code 1828.

Last Modified: 21-Oct-2010


Engine Coolant Circulating Pump Control High Temperature (HT) - Breaker Tripped

FAULT CODE 1834

Engine Coolant Circulating Pump Control High Temperature (HT) - Breaker Tripped

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1834 PID: SPN: 3605 FMI: 31 LAMP: Warning SRT: | Engine Coolant Circulating Pump Control High Temperature (HT) - Breaker Tripped. Engine high temperature (HT) coolant circulating pump control is enabled and high temperature (HT) coolant circulating pump power supply circuit breaker trip circuit is active. | Engine high temperature (HT) coolant circulating pump will not operate properly.
Engine High Temperature (HT) Coolant Circulating Control Circuit - Generator Set with PowerCommand® Supervisor (50Hz)
Engine High Temperature (HT) Coolant Circulating Control Circuit - Generator Set with PowerCommand® Supervisor (60Hz)
Engine High Temperature (HT) Coolant Circulating Control Circuit - Generator Set with PCC3300 (50Hz)
Engine High Temperature (HT) Coolant Circulating Control Circuit - Generator Set with PCC3300 (60Hz)

Circuit Description

On generator sets with PowerCommand® Supervisor, CM700 receives high temperature (HT) coolant temperature sensor signal voltage and supplies HT Temperature Controller with a corresponding 24-VDC, 4-20mA signal. HT Temperature Controller compares CM700 HT coolant temperature signal to the controller's target temperature and, if necessary, engages, via 24-VDC, 0-20mA supply, either normally open (NO) contactor KM6A or KM6B to close. Upon closure, the contactor enables HT control valve with AUX VAC, as supplied through the generator interface box (GIB) AUX VAC isolator and circuit breaker MCB6’s normally closed (NC) main switch, to open (KM6A) or close (KM6B) the HT Control Valve. The CM700 supplies normally closed (NC) MCB6 trip switch with 24-VDC and senses current drop across an internal resistor to verify closure. If MCB6’s main switch opens or trips due to excessive current, the trip switch also opens, stopping DC current flow through CM700 HT Temperature Control Valve Trip circuit.

On generator sets with PCC3300, CM700 receives HT coolant temperature sensor signal voltage and supplies HT Temperature Controller with a corresponding 24-VDC, 4-20mA signal. HT Temperature Controller compares CM700 HT coolant temperature signal to the controllers target temperature and, if necessary, engages, via 24-VDC, 0-20mA supply, either normally open (NO) contactor KM9A or KM9B to close. Upon closure, the contactor enables HT Control Valve with AUX VAC, as supplied through generator interface box (GIB) AUX VAC isolator, GIB circuit breaker MCB8’s normally closed (NC) main switch, remote coolant temperature control panel AUX VAC isolator and MCB9’s normally closed (NC) switch, to open (KM9A) or close (KM9B) the HT Control Valve. The CM700 supplies normally closed (NC) generator interface box (GIB) MCB8 trip switch and remote coolant temperature control panel MCB9 trip switch with 24-VDC and senses current drop across an internal resistor to verify closure. If GIB MCB8 and remote coolant temperature control panel MCB9 main switch opens or trips due to excessive current, the trip switches also open, stopping DC current flow through CM700 HT Temperature Control Valve Trip circuit.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The HT coolant temperature control circuit consists of the CM700, one electronic temperature control, one off engine temperature control valve and two solid state relays, one to command opening the temperature control valve and one to command closure, and one circuit breaker. On-engine, wax-type thermostats are not used due to an inability to adequately control the coolant temperature.

Refer to Troubleshooting Fault Code t05-1834.

Last Modified: 21-Oct-2010


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1837

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1837 PID: SPN: 723 FMI: 2 LAMP: Shutdown SRT: | Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect. The camshaft engine speed/position measurement is irrational. | The engine will shutdown or will fail to start.
Camshaft Engine Speed/Position Sensor Circuit

Circuit Description

The camshaft engine speed/position sensor monitors the engine speed and position using a dual core/coil sensor. One coil feeds the left bank CM558 the other feeds the right bank CM558.

Fault Code 1821 is activated when no or very low speed is detected by the electronic control module(s) (ECM)s, when the engine is supposed to be running.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The camshaft engine speed/position sensor is a magnetic sensor that senses a ribbed camshaft drive wheel that is connected to the left bank camshaft. The ribbed wheel has a single mark to identify the beginning of the firing order/cycle.

Possible causes of this fault code include:

  • Malfunctioning camshaft engine speed/position sensor
  • Open circuit
  • Shorted circuit.

If Fault Code 1837 is only activated at a certain engine temperature, make sure to check the engine speed and position sensors, and their circuits, while the engine is at that particular temperature when the malfunction occurred.

Refer to Troubleshooting Fault Code t05-1837.

Last Modified: 13-Oct-2010


Generator Electrical Overload (kW) Signal (Partial Overload) - Data Valid But High - Serious

FAULT CODE 1838

Generator Electrical Overload (kW) Signal (Partial Overload) - Data Valid But High - Serious

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1838 PID: SPN: 2452 FMI: 0 LAMP: Shutdown SRT: | Generator Electrical Overload (kW) Signal (Partial Overload) - Data Valid But High - Serious. Overload protection is enabled and load is higher than partial continuous load threshold for set persistence time. | The engine will shut down.
Generator Electrical Load (kW) Signal Circuit - Generator Set with PowerCommand® Supervisor (P7 Alternator Circuit Shown)
Generator Control to PLC Communication and PLC to CM700 Modbus Communication Circuits - Generator Set with PowerCommand® Supervisor
Generator Electrical Load (kW) Signal Circuit - Generator Set with PCC3300 (P7 Alternator Circuit Shown)
J1939 Data Link Circuit - Multiple Turbochargers - Generator Set with PCC3300
J1939 Data Link Circuit - Single Turbocharger - Generator Set with PCC3300

Circuit Description

On generator sets with PowerCommand® Supervisor, the PT / CT module is connected in parallel to the main alternator lines for sensing the primary alternators voltage and current production. The PT / CT module reduces alternator line voltage to approximately 18-VAC and converts CT sensed current at 0.55A (100 percent load) to approximately 1.65-VAC for analog generator set control (PCS) input. The generator control then calculates kW electrical load and sends a signal via proprietary data link to PLC 1 channel 1. The PLC converts the generator control kW electrical load signal to modbus output to the CM700.

On generator sets with PCC3300, alternator voltage and current is sensed directly at the PCC3300 unless alternator voltage is greater than 600-VAC, then a PT is employed to reduce alternator voltage below 600-VAC during normal operation for PCC3300 sensing.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Alternator kW load is compared to three calibratable thresholds:

  • Maximum Critical Overload Threshold with smallest fault persistence time with fault resulting in emergency shutdown.
  • Medium Critical Overload Threshold (Maximum Critical Overload Threshold > Medium Critical Overload Threshold > Generator Set Rating) with longer fault persistence time than Maximum Critical Overload and fault resulting in a controlled shutdown.
  • Low Critical Overload Threshold (Medium Critical Overload Threshold > Low Critical Overload Threshold > Generator Set Rating) with fault resulting in a warning.
Refer to Troubleshooting Fault Code t05-1838.

Last Modified: 04-Jan-2011


Gas Supply (Regulated) Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1839

Gas Supply (Regulated) Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1839 PID: SPN: 159 FMI: 3 LAMP: Warning SRT: | Gas Supply (Regulated) Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High voltage has been detected in the gas supply pressure sensor circuit. | No effect on engine performance.
Fuel Supply Pressure Sensor Circuit

Circuit Description

The CM700 module uses the fuel supply pressure sensor to measure the fuel pressure in the fuel supply line after the fuel pressure regulator.

The signal DC voltage is directly proportional to pressure; as the pressure increases the signal DC voltage will increase.

Component Location

The fuel supply pressure sensor is located in the double-solenoid gas valve.

The double-solenoid gas valve is mounted remotely from the generator set.

Refer to site specific system installation drawings for location.

Shop Talk

The CM700 module uses the fuel supply pressure sensor to measure the fuel supply pressure immediately after the fuel pressure regulator. This signal is used by the CM700 module for fuel supply (regulated) high pressure and low pressure protection.

This signal is also used by the CM700 module as part of the valve proving system (VPS) test procedure; which is used to confirm the integrity (gas tightness) of the double-solenoid gas valve. The VPS test is automatically performed immediately following a generator set shutdown and is controlled by the CM700 Module.

The fuel supply pressure sensor is an absolute sensor.

Refer to Troubleshooting Fault Code t05-1839.

Last Modified: 04-Jan-2011


Gas Supply (Regulated) Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1841

Gas Supply (Regulated) Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1841 PID: SPN: 159 FMI: 4 LAMP: Warning SRT: | Gas Supply (Regulated) Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage has been detected in the gas supply pressure sensor circuit. | Possible reduced engine performance
Fuel Supply Pressure Sensor Circuit

Circuit Description

The CM700 module uses the fuel supply pressure sensor to measure the fuel pressure in the fuel supply line after the fuel pressure regulator.

The signal DC voltage is directly proportional to pressure; as the pressure increases the signal DC voltage will increase.

Component Location

The fuel supply pressure sensor is mounted on the double-solenoid gas valve.

The double-solenoid gas valve is mounted remotely from the generator set.

Refer to site specific system installation drawings for location.

Shop Talk

The CM700 module uses the fuel supply pressure sensor to measure the fuel supply pressure immediately after the fuel pressure regulator. This signal is used by the CM700 module for fuel supply (regulated) high pressure and low pressure protection.

This signal is also used by the CM700 module as part of the valve proving system (VPS) test procedure; which is used to confirm the integrity (gas tightness) of the double-solenoid gas valve. The VPS test is automatically performed immediately following a generator set shutdown and is controlled by the CM700 module.

The fuel supply pressure sensor is an absolute sensor.

Refer to Troubleshooting Fault Code t05-1841.

Last Modified: 21-Oct-2010


Crankcase Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1843

Crankcase Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1843 PID: SPN: 101 FMI: 3 LAMP: Warning SRT: | Crankcase Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the crankcase pressure sensor circuit. | Fault Code 556 is disabled. No engine protection for crankcase pressure.
Crankcase Pressure Sensor Circuit - Multiple Turbochargers
Crankcase Pressure Sensor Circuit - Single Turbocharger

Circuit Description

The crankcase pressure sensor monitors the pressure in the crankcase as a result of combustion gas leaking past the piston rings. This information is monitored by the CM700.

High voltage will cause Fault Code 1843 and can be caused by shorts in the SUPPLY, SIGNAL, or RETURN wires, an open in the RETURN wire, or a malfunctioning sensor.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Crankcase pressure is measured by sensing the pressure drop across an orifice of known diameter in series with the breather hose. Sensor malfunction will result if the orifice becomes plugged.

Refer to Troubleshooting Fault Code t05-1843.

Last Modified: 21-Oct-2010


Crankcase Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1844

Crankcase Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1844 PID: 101 SPN: 101 FMI: 4 LAMP: Warning SRT: | Crankcase Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. | None on performance.
Crankcase Pressure Sensor Circuit - Multiple Turbochargers
Crankcase Pressure Sensor Circuit - Single Turbocharger

Circuit Description

The crankcase blowby pressure sensor monitors the pressure in the crankcase as a result of combustion gas leaking past the piston rings. This information is monitored by the CM700.

Low voltage will cause Fault Code 1844 to be set and can be caused by shorts in the SUPPLY, SIGNAL, or RETURN wires, an open circuit in the RETURN wire, or a failed sensor.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Crankcase blowby pressure is measured by sensing the pressure drop across an orifice or known diameter in series with the breather hose. Sensor failure will result if the orifice becomes plugged.

Refer to Troubleshooting Fault Code t05-1844.

Last Modified: 04-Jan-2011


Sensor Supply Circuit Number 2 - Shorted Low

FAULT CODE 187

Sensor Supply Circuit Number 2 - Shorted Low

Printable Version Printable Version

Overview

Sensor Supply Circuit Number 2 - Shorted Low

CODE | REASON | EFFECT
Fault Code: 187 PID: S232 SPN: 1080 FMI: 4 LAMP: Warning SRT: | Sensor Supply Circuit Number 2 - Shorted Low. Sensor Supply Number 2 supply signal is shorted low. | Possible reduced engine performance or shutdown. Pressure sensor shorted low faults likely.
Sensor Supply Circuit Number 2 - Multiple Turbochargers
Sensor Supply Circuit Number 2 - Single Turbocharger

Circuit Description

Sensor supply circuit number 2 from the ECM supplies multiple engine pressure sensors with a positive (+) 5-VDC supply. The ECM has a common return for most of the engine pressure and temperature sensors. A fault on either of these wires can cause multiple pressure and temperature sensor fault codes as well as the power supply fault.

Component Location

Reference Section E for the component location.

Shop Talk

Refer to the engine wiring diagram to find sensors that share a common electrical supply or return. A failed pressure sensor can cause multiple fault codes. A damaged pressure sensor can cause multiple active fault codes to become inactive when the engine is started.

Refer to Troubleshooting Fault Code t05-187

Last Modified: 19-Mar-2018


Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 197

Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 197 PID: P111 SPN: 111 FMI: 18 LAMP: Warning SRT: | Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low engine coolant level detected. | No effect on engine performance.
QSK60G Multiple Turbochargers with Generator Control Panel (GCP1) and PowerCommand® Supervisor 3100
QSK60G Single and Multiple Turbochargers with Generator Control Panel (GCP2) and PowerCommand® Supervisor 3100
QSK60G Single and Multiple Turbochargers with PowerCommand® Control 3300

Circuit Description

The engine coolant level sensor (HT) monitors the engine coolant level within the high temperature cooling system and passes information to the CM700 module. The wiring between the coolant level sensor and the generator control panel or generator interface box is customer supplied.

Component Location

Reference site specific installation drawings for the location of the high temperature system coolant tank and coolant level sensor.

Refer to Troubleshooting Fault Code t05-197.

Last Modified: 06-Jul-2011


Engine Coolant Temperature Sensor Circuit Number 2 (Low Temperature) - Shorted High

FAULT CODE 2111

Engine Coolant Temperature Sensor Circuit Number 2 (Low Temperature) - Shorted High

Printable Version Printable Version

Overview

Engine Coolant Temperature Sensor Circuit Number 2 (Low Temperature) - Shorted High

CODE | REASON | EFFECT
Fault Code: 2111 PID: SPN: 52 FMI: 3 LAMP: Warning SRT: | Engine Coolant Temperature Sensor Circuit Number 2 (Low Temperature) - Shorted High. The Engine Coolant Temperature Sensor signal (Low Temperature) is shorted high. | No engine protection for the Engine Coolant Temperature (Low Temperature). Possible reduced engine performance.
Engine Coolant Temperature Sensor Circuit (Low Temperature) - Multiple Turbochargers
Engine Coolant Temperature Sensor Circuit (Low Temperature) - Single Turbocharger

Circuit Description

The engine coolant temperature sensor (low temperature) is used by the CM700 to monitor the temperature of the coolant in the low temperature coolant circuit.

If the voltage is high the CM700 will log Fault Code 2111. Voltage high can be caused by opens in the signal or return wires, voltage shorts to the signal or return wires, or a failed open sensor.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

The resistance of the sensor varies with the temperature.

Refer to Section V (Specifications) for resistance specifications.

Refer to Troubleshooting Fault Code t05-2111

Last Modified: 30-Jun-2010


Engine Coolant Temperature Sensor Circuit Number 2 (Low Temperature) - Shorted Low

FAULT CODE 2112

Engine Coolant Temperature Sensor Circuit Number 2 (Low Temperature) - Shorted Low

Printable Version Printable Version

Overview

Engine Coolant Temperature Sensor Circuit Number 2 (Low Temperature) - Shorted Low

CODE | REASON | EFFECT
Fault Code: 2112 PID: SPN: 52 FMI: 4 LAMP: Warning SRT: | The Engine Coolant Temperature Sensor signal (Low Temperature) is shorted low. | No engine protection for the Engine Coolant Temperature (Low Temperature). Possible reduced engine performance.
Engine Coolant Temperature Sensor Circuit (Low Temperature) - Multiple Turbochargers
Engine Coolant Temperature Sensor Circuit (Low Temperature) - Single Turbocharger

Circuit Description

The engine coolant temperature sensor (low temperature) is used by the CM700 to monitor the temperature of the coolant in the low temperature coolant circuit.

If the voltage is low the CM700 will log Fault Code 2112. Low voltage can be caused by shorts to ground on the supply or return wires or an internally grounded, failed sensor.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

The resistance of the sensor varies with the temperature.

Refer to Section V (Specifications) for resistance specifications.

Refer to Troubleshooting Fault Code t05-2112

Last Modified: 30-Jun-2010


Engine Coolant Temperature Number 2 (Low Temperature) High - Warning

FAULT CODE 2113

Engine Coolant Temperature Number 2 (Low Temperature) High - Warning

Printable Version Printable Version

Overview

Engine Coolant Temperature Number 2 (Low Temperature) High - Warning

CODE | REASON | EFFECT
Fault Code: 2113 PID: SPN: 52 FMI: 16 LAMP: Warning SRT: | The engine coolant temperature (low temperature) has exceeded the high warning threshold. | No effect on engine performance.
Engine Coolant Temperature Sensor Circuit (Low Temperature) - Multiple Turbochargers
Engine Coolant Temperature Sensor Circuit (Low Temperature) - Single Turbocharger

Circuit Description

The coolant temperature sensor (low temperature) is used by the CM700 to monitor the temperature of the engine coolant. Coolant temperature is used by the CM700 for the engine protection system, timing, and fueling control.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

The engine coolant temperature (low temperature) has exceeded the warning threshold.

Refer to Troubleshooting Fault Code t05-2113

Last Modified: 30-Jun-2010


Engine Coolant Temperature Number 2 (Low Temperature) High - Critical

FAULT CODE 2114

Engine Coolant Temperature Number 2 (Low Temperature) High - Critical

Printable Version Printable Version

Overview

Engine Coolant Temperature Number 2 (Low Temperature) High - Critical

CODE | REASON | EFFECT
Fault Code: 2114 PID: SPN: 52 FMI: 0 LAMP: Shutdown SRT: | The engine coolant temperature (low temperature) has exceeded the high critical threshold. | Engine will shut down.
Engine Coolant Temperature Sensor Circuit (Low Temperature) - Multiple Turbochargers
Engine Coolant Temperature Sensor Circuit (Low Temperature) - Single Turbocharger

Circuit Description

The coolant temperature sensor (low temperature) is used by the CM700 to monitor the temperature of the engine coolant. Coolant temperature is used by the CM700 for the engine protection system, timing, and fueling control.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

The engine coolant temperature (low temperature) has exceeded the critical threshold.

Refer to Troubleshooting Fault Code t05-2114

Last Modified: 30-Jun-2010


Engine Coolant Pressure Sensor Circuit Number 2 (Low Temperature) - Shorted High

FAULT CODE 2115

Engine Coolant Pressure Sensor Circuit Number 2 (Low Temperature) - Shorted High

Printable Version Printable Version

Overview

Engine Coolant Pressure Sensor Circuit Number 2 (Low Temperature) - Shorted High

CODE | REASON | EFFECT
Fault Code: 2115 PID: SPN: FMI: 3 LAMP: Warning SRT: | High voltage detected on engine coolant pressure sensor signal (low temperature) pin of the main harness A CM700 connector. | Fault Code 2429 is disabled.
Engine Coolant Pressure Sensor Circuit (Low Temperature) - Multiple Turbochargers
Engine Coolant Pressure Sensor Circuit (Low Temperature) - Single Turbocharger

Circuit Description

The engine coolant pressure sensor (low temperature) monitors the engine coolant pressure in the low temperature coolant circuit. This pressure is monitored by the CM700. High voltage will cause Fault Code 2115 and can be caused by shorts in the supply, signal or return wires, an open in the return wire or a failed sensor.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

Confirm that the low temperature circuit radiator cap is installed correctly. Check the radiator for proper operation.

Refer to Troubleshooting Fault Code t05-2115

Last Modified: 30-Jun-2010


Engine Coolant Pressure Sensor Circuit Number 2 (Low Temperature) - Shorted Low

FAULT CODE 2116

Engine Coolant Pressure Sensor Circuit Number 2 (Low Temperature) - Shorted Low

Printable Version Printable Version

Overview

Engine Coolant Pressure Sensor Circuit Number 2 (Low Temperature) - Shorted Low

CODE | REASON | EFFECT
Fault Code: 2116 PID: SPN: FMI: 4 LAMP: Warning SRT: | Low voltage detected on the engine coolant pressure sensor signal (low temperature) pin of the main harness CM700 connector. | Fault Code 2429 is disabled.
Engine Coolant Pressure Sensor Circuit (Low Temperature) - Multiple Turbochargers
Engine Coolant Pressure Sensor Circuit (Low Temperature) - Single Turbocharger

Circuit Description

The engine coolant pressure sensor (low temperature) monitors the engine coolant pressure in the low temperature coolant circuit. This pressure is monitored by the CM700. Low voltage will cause Fault Code 2116 and can be caused by shorts in the supply, signal or return wires, an open in the return wire, or a failed sensor.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

Confirm that the low temperature circuit radiator cap is installed correctly. Check the radiator for proper operation.

Refer to Troubleshooting Fault Code t05-2116

Last Modified: 30-Jun-2010


Engine Coolant Pressure (Low Temperature) Low - Warning

FAULT CODE 2117

Engine Coolant Pressure (Low Temperature) Low - Warning

Printable Version Printable Version

Overview

Engine Coolant Pressure (Low Temperature) Low - Warning

CODE | REASON | EFFECT
Fault Code: 2117 PID: SPN: FMI: 18 LAMP: Warning SRT: | Engine Coolant Pressure (Low Temperature) Low - Warning. The engine coolant pressure (low temperature) has dropped below the low warning threshold. | No effect on engine performance.
Engine Coolant Pressure Sensor Circuit (Low Temperature) - Multiple Turbochargers
Engine Coolant Pressure Sensor Circuit (Low Temperature) - Single Turbocharger

Circuit Description

The low temperature coolant pressure sensor monitors coolant pressure in the low temperature coolant loop and passes information to the CM700.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

The engine coolant pressure (low temperature) has dropped below the low warning threshold.

Refer to Troubleshooting Fault Code t05-2117

Last Modified: 30-Jun-2010


Engine Oil Temperature Sensor Circuit - Shorted High

FAULT CODE 212

Engine Oil Temperature Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

Engine Oil Temperature Sensor Circuit - Shorted High

CODE | REASON | EFFECT
Fault Code: 212 PID: P175 SPN: 175 FMI: 3 LAMP: Warning SRT: | Engine Oil Temperature Sensor Circuit - Shorted High. Engine Oil Temperature Sensor signal is shorted high. | No engine protection for the engine oil temperature. Possible reduced engine performance.
Engine Oil Temperature Sensor Circuit - Multiple Turbochargers
Engine Oil Temperature Sensor Circuit - Single Turbocharger

Circuit Description

The engine oil temperature sensor is used by the CM700 to monitor the temperature of the engine Lubricating oil.

If the voltage is high the CM700 will log Fault Code 212. Voltage high can be caused by opens in the signal or return wires, voltage shorts to the signal or return wires, or a failed open sensor.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

The resistance of the sensor varies with the temperature.

Refer to the wiring diagram for resistance specifications.

Refer to Troubleshooting Fault Code t05-212

Last Modified: 30-Jun-2010


Exhaust Temperature Cylinder Left 1 High - Warning

FAULT CODE 2121 - Multiple Turbochargers

Exhaust Temperature Cylinder Left 1 High - Warning

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Left 1 High - Warning

CODE | REASON | EFFECT
Fault Code: 2121 PID: SPN: 1137 FMI: 16 LAMP: Warning SRT: | Exhaust Temperature Cylinder Left 1 High - Warning. The exhaust temperature cylinder number left 1 has exceeded the high warning threshold. | No effect on engine performance.
Exhaust Temperature Cylinder Left 1

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CENSE™ module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2121-mt.

Last Modified: 04-Aug-2015


Exhaust Temperature Cylinder Left 1 High - Warning

FAULT CODE 2121 - Single Turbocharger

Exhaust Temperature Cylinder Left 1 High - Warning

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Left 1 High - Warning

CODE | REASON | EFFECT
Fault Code: 2121 PID: SPN: 1137 FMI: 16 LAMP: Warning SRT: | Exhaust Temperature Cylinder Left 1 High - Warning. The exhaust temperature cylinder number left 1 has exceeded the high warning threshold. | No effect on engine performance.
Exhaust Temperature Cylinder Left 1

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CM850 module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CM850 module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2121-st.

Last Modified: 04-Aug-2015


Fault Code Path Selection

FAULT CODE 2121
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2121-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2121-st

Last Modified: 05-Oct-2007


Exhaust Temperature Cylinder Left 2 High - Warning

FAULT CODE 2122 - Multiple Turbochargers

Exhaust Temperature Cylinder Left 2 High - Warning

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Left 2 High - Warning

CODE | REASON | EFFECT
Fault Code: 2122 PID: SPN: 1138 FMI: 16 LAMP: Warning SRT: | Exhaust Temperature Cylinder Left 2 High - Warning. The exhaust temperature cylinder number left 2 has exceeded the high warning threshold. | No effect on engine performance.
Exhaust Temperature Cylinder Left 2

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CENSE™ module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2122-mt.

Last Modified: 04-Aug-2015


Exhaust Temperature Cylinder Left 2 High - Warning

FAULT CODE 2122 - Single Turbocharger

Exhaust Temperature Cylinder Left 2 High - Warning

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Left 2 High - Warning

CODE | REASON | EFFECT
Fault Code: 2122 PID: SPN: 1138 FMI: 16 LAMP: Warning SRT: | Exhaust Temperature Cylinder Left 2 High - Warning. The exhaust temperature cylinder number left 2 has exceeded the high warning threshold. | No effect on engine performance.
Exhaust Temperature Cylinder Left 2

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CM850 module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CM850 module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2122-st.

Last Modified: 04-Aug-2015


Fault Code Path Selection

FAULT CODE 2122
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2122-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2122-st

Last Modified: 05-Oct-2007


Exhaust Temperature Cylinder Left 3 High - Warning

FAULT CODE 2123 - Multiple Turbochargers

Exhaust Temperature Cylinder Left 3 High - Warning

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Left 3 High - Warning

CODE | REASON | EFFECT
Fault Code: 2123 PID: SPN: 1139 FMI: 16 LAMP: Warning SRT: | Exhaust Temperature Cylinder Left 3 High - Warning. The exhaust temperature cylinder number left 3 has exceeded the high warning threshold. | No effect on engine performance.
Exhaust Temperature Cylinder Left 3

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 in Section E of this manual for the component location.

Shop Talk

The exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CENSE™ module malfunction will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2123-mt.

Last Modified: 12-Aug-2015


Exhaust Temperature Cylinder Left 3 High - Warning

FAULT CODE 2123 - Single Turbocharger

Exhaust Temperature Cylinder Left 3 High - Warning

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Left 3 High - Warning

CODE | REASON | EFFECT
Fault Code: 2123 PID: SPN: 1139 FMI: 16 LAMP: Warning SRT: | Exhaust Temperature Cylinder Left 3 High - Warning. The exhaust temperature cylinder number left 3 has exceeded the high warning threshold. | No effect on engine performance.
Exhaust Temperature Cylinder Left 3

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CM850 module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 in Section E of this manual for the component location.

Shop Talk

The exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CM850 module malfunction will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2123-st.

Last Modified: 12-Aug-2015


Fault Code Path Selection

FAULT CODE 2123
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2123-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2123-st

Last Modified: 05-Oct-2007


Exhaust Temperature Cylinder Left 4 High - Warning

FAULT CODE 2124 - Multiple Turbochargers

Exhaust Temperature Cylinder Left 4 High - Warning

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Left 4 High - Warning

CODE | REASON | EFFECT
Fault Code: 2124 PID: SPN: 1140 FMI: 16 LAMP: Warning SRT: | Exhaust Temperature Cylinder Left 4 High - Warning. The exhaust temperature cylinder number left 4 has exceeded the high warning threshold. | No effect on engine performance.
Exhaust Temperature Cylinder Left 4

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

The exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CENSE™ module malfunction will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2124-mt.

Last Modified: 12-Aug-2015


Exhaust Temperature Cylinder Left 4 High - Warning

FAULT CODE 2124 - Single Turbocharger

Exhaust Temperature Cylinder Left 4 High - Warning

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Left 4 High - Warning

CODE | REASON | EFFECT
Fault Code: 2124 PID: SPN: 1140 FMI: 16 LAMP: Warning SRT: | Exhaust Temperature Cylinder Left 4 High - Warning. The exhaust temperature cylinder number left 4 has exceeded the high warning threshold. | No effect on engine performance.
Exhaust Temperature Cylinder Left 4

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CM850 module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

The exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CM850 module malfunction will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2124-st.

Last Modified: 12-Aug-2015


Fault Code Path Selection

FAULT CODE 2124
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2124-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2124-st

Last Modified: 05-Oct-2007


Exhaust Temperature Cylinder Left 5 High - Warning

FAULT CODE 2125 - Multiple Turbochargers

Exhaust Temperature Cylinder Left 5 High - Warning

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Left 5 High - Warning

CODE | REASON | EFFECT
Fault Code: 2125 PID: SPN: 1141 FMI: 16 LAMP: Warning SRT: | Exhaust Temperature Cylinder Left 5 High - Warning. The exhaust temperature cylinder number left 5 has exceeded the high warning threshold. | No effect on engine performance.
Exhaust Temperature Cylinder Left 5

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

The exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CENSE™ module malfunction will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2125-mt.

Last Modified: 12-Aug-2015


Exhaust Temperature Cylinder Left 5 High - Warning

FAULT CODE 2125 - Single Turbocharger

Exhaust Temperature Cylinder Left 5 High - Warning

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Left 5 High - Warning

CODE | REASON | EFFECT
Fault Code: 2125 PID: SPN: 1141 FMI: 16 LAMP: Warning SRT: | Exhaust Temperature Cylinder Left 5 High - Warning. The exhaust temperature cylinder number left 5 has exceeded the high warning threshold. | No effect on engine performance.
Exhaust Temperature Cylinder Left 5

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CM850 module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

The exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CM850 module malfunction will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2125-st.

Last Modified: 12-Aug-2015


Fault Code Path Selection

FAULT CODE 2125
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2125-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2125-st

Last Modified: 05-Oct-2007


Exhaust Temperature Cylinder Left 6 High - Warning

FAULT CODE 2126 - Multiple Turbochargers

Exhaust Temperature Cylinder Left 6 High - Warning

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Left 6 High - Warning

CODE | REASON | EFFECT
Fault Code: 2126 PID: SPN: 1142 FMI: 16 LAMP: Warning SRT: | Exhaust Temperature Cylinder Left 6 High - Warning. The exhaust temperature cylinder number left 6 has exceeded the high warning threshold. | No effect on engine performance.
Exhaust Temperature Cylinder Left 6

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

The exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CENSE™ module malfunction will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2126-mt.

Last Modified: 12-Aug-2015


Exhaust Temperature Cylinder Left 6 High - Warning

FAULT CODE 2126 - Single Turbocharger

Exhaust Temperature Cylinder Left 6 High - Warning

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Left 6 High - Warning

CODE | REASON | EFFECT
Fault Code: 2126 PID: SPN: 1142 FMI: 16 LAMP: Warning SRT: | Exhaust Temperature Cylinder Left 6 High - Warning. The exhaust temperature cylinder number left 6 has exceeded the high warning threshold. | No effect on engine performance.
Exhaust Temperature Cylinder Left 6

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CM850 module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

The exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CM850 module malfunction will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2126-st.

Last Modified: 12-Aug-2015


Fault Code Path Selection

FAULT CODE 2126
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2126-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2126-st

Last Modified: 05-Oct-2007


Exhaust Temperature Cylinder Left 7 High - Warning

FAULT CODE 2127 - Multiple Turbochargers

Exhaust Temperature Cylinder Left 7 High - Warning

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Left 7 High - Warning

CODE | REASON | EFFECT
Fault Code: 2127 PID: SPN: 1143 FMI: 16 LAMP: Warning SRT: | Exhaust Temperature Cylinder Left 7 High - Warning. The exhaust temperature cylinder number left 7 has exceeded the high warning threshold. | No effect on engine performance.
Exhaust Temperature Cylinder Left 7

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

The exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CENSE™ module malfunction will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2127-mt.

Last Modified: 12-Aug-2015


Exhaust Temperature Cylinder Left 7 High - Warning

FAULT CODE 2127 - Single Turbocharger

Exhaust Temperature Cylinder Left 7 High - Warning

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Left 7 High - Warning

CODE | REASON | EFFECT
Fault Code: 2127 PID: SPN: 1143 FMI: 16 LAMP: Warning SRT: | Exhaust Temperature Cylinder Left 7 High - Warning. The exhaust temperature cylinder number left 7 has exceeded the high warning threshold. | No effect on engine performance.
Exhaust Temperature Cylinder Left 7

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

The exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CENSE™ module malfunction will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2127-st.

Last Modified: 12-Aug-2015


Fault Code Path Selection

FAULT CODE 2127
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2127-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2127-st

Last Modified: 05-Oct-2007


Exhaust Temperature Cylinder Left 8 High - Warning

FAULT CODE 2128 - Multiple Turbochargers

Exhaust Temperature Cylinder Left 8 High - Warning

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Left 8 High - Warning

CODE | REASON | EFFECT
Fault Code: 2128 PID: SPN: 1144 FMI: 16 LAMP: Warning SRT: | Exhaust Temperature Cylinder Left 8 High - Warning. The exhaust temperature cylinder number left 8 has exceeded the high warning threshold. | No effect on engine performance.
Exhaust Temperature Cylinder Left 8

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

The exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CENSE™ module malfunction will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2128-mt.

Last Modified: 12-Aug-2015


Exhaust Temperature Cylinder Left 8 High - Warning

FAULT CODE 2128 - Single Turbocharger

Exhaust Temperature Cylinder Left 8 High - Warning

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Left 8 High - Warning

CODE | REASON | EFFECT
Fault Code: 2128 PID: SPN: 1144 FMI: 16 LAMP: Warning SRT: | Exhaust Temperature Cylinder Left 8 High - Warning. The exhaust temperature cylinder number left 8 has exceeded the high warning threshold. | No effect on engine performance.
Exhaust Temperature Cylinder Left 8

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CM850 module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

The exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CM850 module malfunction will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2128-st.

Last Modified: 12-Aug-2015


Fault Code Path Selection

FAULT CODE 2128
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2128-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2128-st

Last Modified: 05-Oct-2007


Engine Oil Temperature Sensor Circuit - Shorted Low

FAULT CODE 213

Engine Oil Temperature Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

Engine Oil Temperature Sensor Circuit - Shorted Low

CODE | REASON | EFFECT
Fault Code: 213 PID: P175 SPN: 175 FMI: 4 LAMP: Warning SRT: | Engine Oil Temperature Sensor Circuit - Shorted Low. Engine Oil Temperature Sensor signal is shorted low. | No engine protection for the engine oil temperature. Possible reduced engine performance.
Engine Oil Temperature Sensor Circuit - Multiple Turbochargers
Engine Oil Temperature Sensor Circuit - Single Turbocharger

Circuit Description

The engine oil temperature sensor is used by the CM700 to monitor the temperature of the engine oil.

If the voltage is low the CM700 will log Fault Code 213. Low voltage can be caused by shorts to ground on the supply or return wires or an internally grounded, failed sensor.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

The resistance of the sensor varies with the temperature.

Refer to the wiring diagram for resistance specifications.

Refer to Troubleshooting Fault Code t05-213

Last Modified: 30-Jun-2010


Exhaust Temperature Cylinder Right 1 High - Warning

FAULT CODE 2131 - Multiple Turbochargers

Exhaust Temperature Cylinder Right 1 High - Warning

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Right 1 High - Warning

CODE | REASON | EFFECT
Fault Code: 2131 PID: SPN: 1146 FMI: 16 LAMP: Warning SRT: | Exhaust Temperature Cylinder Right 1 High - Warning. The exhaust temperature cylinder number right 1 has exceeded the high warning threshold. | No effect on engine performance.
Exhaust Temperature Cylinder Right 1

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

The exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CENSE™ module malfunction will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2131-mt.

Last Modified: 12-Aug-2015


Exhaust Temperature Cylinder Right 1 High - Warning

FAULT CODE 2131 - Single Turbocharger

Exhaust Temperature Cylinder Right 1 High - Warning

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Right 1 High - Warning

CODE | REASON | EFFECT
Fault Code: 2131 PID: SPN: 1146 FMI: 16 LAMP: Warning SRT: | Exhaust Temperature Cylinder Right 1 High - Warning. The exhaust temperature cylinder number right 1 has exceeded the high warning threshold. | No effect on engine performance.
Exhaust Temperature Cylinder Right 1

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CM850 module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

The exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CM850 module malfunction will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2131-st.

Last Modified: 12-Aug-2015


Fault Code Path Selection

FAULT CODE 2131
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2131-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2131-st

Last Modified: 05-Oct-2007


Exhaust Temperature Cylinder Right 2 High - Warning

FAULT CODE 2132 - Multiple Turbochargers

Exhaust Temperature Cylinder Right 2 High - Warning

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Right 2 High - Warning

CODE | REASON | EFFECT
Fault Code: 2132 PID: SPN: 1147 FMI: 16 LAMP: Warning SRT: | Exhaust Temperature Cylinder Right 2 High - Warning. The exhaust temperature cylinder number right 2 has exceeded the high warning threshold. | No effect on engine performance.
Exhaust Temperature Cylinder Right 2

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

The exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CENSE™ module malfunction will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2132-mt.

Last Modified: 12-Aug-2015


Exhaust Temperature Cylinder Right 2 High - Warning

FAULT CODE 2132 - Single Turbocharger

Exhaust Temperature Cylinder Right 2 High - Warning

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Right 2 High - Warning

CODE | REASON | EFFECT
Fault Code: 2132 PID: SPN: 1147 FMI: 16 LAMP: Warning SRT: | Exhaust Temperature Cylinder Right 2 High - Warning. The exhaust temperature cylinder number right 2 has exceeded the high warning threshold. | No effect on engine performance.
Exhaust Temperature Cylinder Right 2

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CM850 module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

The exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CM850 module malfunction will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2132-st.

Last Modified: 12-Aug-2015


Fault Code Path Selection

FAULT CODE 2132
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2132-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2132-st

Last Modified: 05-Oct-2007


Exhaust Temperature Cylinder Right 3 High - Warning

FAULT CODE 2133 - Multiple Turbochargers

Exhaust Temperature Cylinder Right 3 High - Warning

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Right 3 High - Warning

CODE | REASON | EFFECT
Fault Code: 2133 PID: SPN: 1148 FMI: 16 LAMP: Warning SRT: | Exhaust Temperature Cylinder Right 3 High - Warning. The exhaust temperature cylinder number right 3 has exceeded the high warning threshold. | No effect on engine performance.
Exhaust Temperature Cylinder Right 3

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

The exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CENSE™ module malfunction will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2133-mt.

Last Modified: 12-Aug-2015


Exhaust Temperature Cylinder Right 3 High - Warning

FAULT CODE 2133 - Single Turbocharger

Exhaust Temperature Cylinder Right 3 High - Warning

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Right 3 High - Warning

CODE | REASON | EFFECT
Fault Code: 2133 PID: SPN: 1148 FMI: 16 LAMP: Warning SRT: | Exhaust Temperature Cylinder Right 3 High - Warning. The exhaust temperature cylinder number right 3 has exceeded the high warning threshold. | No effect on engine performance.
Exhaust Temperature Cylinder Right 3

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CM850 module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

The exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CM850 module malfunction will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2133-st.

Last Modified: 12-Aug-2015


Fault Code Path Selection

FAULT CODE 2133
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2133-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2133-st

Last Modified: 05-Oct-2007


Exhaust Temperature Cylinder Right 4 High - Warning

FAULT CODE 2134 - Multiple Turbochargers

Exhaust Temperature Cylinder Right 4 High - Warning

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Right 4 High - Warning

CODE | REASON | EFFECT
Fault Code: 2134 PID: SPN: 1149 FMI: 16 LAMP: Warning SRT: | Exhaust Temperature Cylinder Right 4 High - Warning. The exhaust temperature cylinder number right 4 has exceeded the high warning threshold. | No effect on engine performance.
Exhaust Temperature Cylinder Right 4

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

The exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CENSE™ module malfunction will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2134-mt.

Last Modified: 12-Aug-2015


Exhaust Temperature Cylinder Right 4 High - Warning

FAULT CODE 2134 - Single Turbocharger

Exhaust Temperature Cylinder Right 4 High - Warning

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Right 4 High - Warning

CODE | REASON | EFFECT
Fault Code: 2134 PID: SPN: 1149 FMI: 16 LAMP: Warning SRT: | Exhaust Temperature Cylinder Right 4 High - Warning. The exhaust temperature cylinder number right 4 has exceeded the high warning threshold. | No effect on engine performance.
Exhaust Temperature Cylinder Right 4

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CM850 module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

The exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CM850 module malfunction will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2134-st.

Last Modified: 12-Aug-2015


Fault Code Path Selection

FAULT CODE 2134
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2134-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2134-st

Last Modified: 05-Oct-2007


Exhaust Temperature Cylinder Right 5 High - Warning

FAULT CODE 2135 - Multiple Turbochargers

Exhaust Temperature Cylinder Right 5 High - Warning

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Right 5 High - Warning

CODE | REASON | EFFECT
Fault Code: 2135 PID: SPN: 1150 FMI: 16 LAMP: Warning SRT: | Exhaust Temperature Cylinder Right 5 High - Warning. The exhaust temperature cylinder number right 5 has exceeded the high warning threshold. | No effect on engine performance.
Exhaust Temperature Cylinder Right 5

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

The exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CENSE™ module malfunction will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2135-mt

Last Modified: 12-Aug-2015


Exhaust Temperature Cylinder Right 5 High - Warning

FAULT CODE 2135 - Single Turbocharger

Exhaust Temperature Cylinder Right 5 High - Warning

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Right 5 High - Warning

CODE | REASON | EFFECT
Fault Code: 2135 PID: SPN: 1150 FMI: 16 LAMP: Warning SRT: | Exhaust Temperature Cylinder Right 5 High - Warning. The exhaust temperature cylinder number right 5 has exceeded the high warning threshold. | No effect on engine performance.
Exhaust Temperature Cylinder Right 5

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CM850 module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

The exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CM850 module malfunction will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2135-st.

Last Modified: 12-Aug-2015


Fault Code Path Selection

FAULT CODE 2135
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2135-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2135-st

Last Modified: 05-Oct-2007


Exhaust Temperature Cylinder Right 6 High - Warning

FAULT CODE 2136 - Multiple Turbochargers

Exhaust Temperature Cylinder Right 6 High - Warning

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Right 6 High - Warning

CODE | REASON | EFFECT
Fault Code: 2136 PID: SPN: 1151 FMI: 16 LAMP: Warning SRT: | Exhaust Temperature Cylinder Right 6 High - Warning. The exhaust temperature cylinder number right 6 has exceeded the high warning threshold. | No effect on engine performance.
Exhaust Temperature Cylinder Right 6

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

The exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CENSE™ module malfunction will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2136-mt.

Last Modified: 12-Aug-2015


Exhaust Temperature Cylinder Right 6 High - Warning

FAULT CODE 2136 - Single Turbocharger

Exhaust Temperature Cylinder Right 6 High - Warning

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Right 6 High - Warning

CODE | REASON | EFFECT
Fault Code: 2136 PID: SPN: 1151 FMI: 16 LAMP: Warning SRT: | Exhaust Temperature Cylinder Right 6 High - Warning. The exhaust temperature cylinder number right 6 has exceeded the high warning threshold. | No effect on engine performance.
Exhaust Temperature Cylinder Right 6

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CM850 module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

The exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CM850 module malfunction will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2136-st.

Last Modified: 12-Aug-2015


Fault Code Path Selection

FAULT CODE 2136
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2136-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2136-st

Last Modified: 05-Oct-2007


Exhaust Temperature Cylinder Right 7 High - Warning

FAULT CODE 2137 - Multiple Turbochargers

Exhaust Temperature Cylinder Right 7 High - Warning

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Right 7 High - Warning

CODE | REASON | EFFECT
Fault Code: 2137 PID: SPN: 1152 FMI: 16 LAMP: Warning SRT: | Exhaust Temperature Cylinder Right 7 High - Warning. The exhaust temperature cylinder number right 7 has exceeded the high warning threshold. | No effect on engine performance.
Exhaust Temperature Cylinder Right 7

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

The exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CENSE™ module malfunction will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2137-mt.

Last Modified: 12-Aug-2015


Exhaust Temperature Cylinder Right 7 High - Warning

FAULT CODE 2137 - Single Turbocharger

Exhaust Temperature Cylinder Right 7 High - Warning

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Right 7 High - Warning

CODE | REASON | EFFECT
Fault Code: 2137 PID: SPN: 1152 FMI: 16 LAMP: Warning SRT: | Exhaust Temperature Cylinder Right 7 High - Warning. The exhaust temperature cylinder number right 7 has exceeded the high warning threshold. | No effect on engine performance.
Exhaust Temperature Cylinder Right 7

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CM850 module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

The exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CM850 module malfunction will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2137-st.

Last Modified: 12-Aug-2015


Fault Code Path Selection

FAULT CODE 2137
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2137-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2137-st

Last Modified: 05-Oct-2007


Exhaust Temperature Cylinder Right 8 High - Warning

FAULT CODE 2138 - Multiple Turbochargers

Exhaust Temperature Cylinder Right 8 High - Warning

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Right 8 High - Warning

CODE | REASON | EFFECT
Fault Code: 2138 PID: SPN: 1153 FMI: 16 LAMP: Warning SRT: | Exhaust Temperature Cylinder Right 8 High - Warning. The exhaust temperature cylinder number right 8 has exceeded the high warning threshold. | No effect on engine performance.
Exhaust Temperature Cylinder Right 8

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

The exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CENSE™ module malfunction will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2138-mt.

Last Modified: 12-Aug-2015


Exhaust Temperature Cylinder Right 8 High - Warning

FAULT CODE 2138 - Single Turbocharger

Exhaust Temperature Cylinder Right 8 High - Warning

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Right 8 High - Warning

CODE | REASON | EFFECT
Fault Code: 2138 PID: SPN: 1153 FMI: 16 LAMP: Warning SRT: | Exhaust Temperature Cylinder Right 8 High - Warning. The exhaust temperature cylinder number right 8 has exceeded the high warning threshold. | No effect on engine performance.
Exhaust Temperature Cylinder Right 8

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CM850 module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

The exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CM850 module malfunction will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2138-st.

Last Modified: 12-Aug-2015


Fault Code Path Selection

FAULT CODE 2138
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2138-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2138-st

Last Modified: 05-Oct-2007


Engine Oil Temperature High - Critical

FAULT CODE 214

Engine Oil Temperature High - Critical

Printable Version Printable Version

Overview

Engine Oil Temperature High - Critical

CODE | REASON | EFFECT
Fault Code: 214 PID: P175 SPN: 175 FMI: 0 LAMP: Shutdown SRT: | Engine Oil Temperature High - Critical. The engine oil temperature has exceeded the high critical threshold. | The engine will shut down.
Engine Oil Temperature Sensor Circuit - Multiple Turbochargers
Engine Oil Temperature Sensor Circuit - Single Turbocharger

Circuit Description

The engine oil temperature sensor is used by the CM700 to monitor the temperature of the engine lubricating oil.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

The engine oil temperature has exceeded a high critical threshold. The resistance of the sensor varies with temperature. Refer to the wiring diagram for resistance specifications.

Refer to Troubleshooting Fault Code t05-214

Last Modified: 30-Jun-2010


Exhaust Temperature Cylinder Right 8 High - Shutdown

FAULT CODE 2144 - Multiple Turbochargers

Exhaust Temperature Cylinder Right 8 High - Shutdown

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Right 8 High - Shutdown

CODE | REASON | EFFECT
Fault Code: 2144 PID: SPN: 1153 FMI: 0 LAMP: Shutdown SRT: | Exhaust Temperature Cylinder Right 8 High - Shutdown. The exhaust temperature for cylinder number right 8 has exceeded the high critical threshold. | The engine will shut down.
Exhaust Temperature Cylinder Right 8

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CENSE™ module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2144

Last Modified: 30-Jun-2010


Exhaust Temperature Cylinder Right 8 High - Shutdown

FAULT CODE 2144 - Single Turbocharger

Exhaust Temperature Cylinder Right 8 High - Shutdown

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Right 8 High - Shutdown

CODE | REASON | EFFECT
Fault Code: 2144 PID: SPN: 1153 FMI: 0 LAMP: Shutdown SRT: | Exhaust Temperature Cylinder Right 8 High - Shutdown. The exhaust temperature for cylinder number right 8 has exceeded the high critical threshold. | The engine will shut down.
Exhaust Temperature Cylinder Right 8

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CM850 module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CM850 module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-2144

Last Modified: 30-Jun-2010


Fault Code Path Selection

FAULT CODE 2144
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2144-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2144-st

Last Modified: 05-Oct-2007


Engine Oil Pressure Sensor Circuit (Post-filter) - Shorted High

FAULT CODE 2154

Engine Oil Pressure Sensor Circuit (Post-filter) - Shorted High

Printable Version Printable Version

Overview

Engine Oil Pressure Sensor Circuit (Post-filter) - Shorted High

CODE | REASON | EFFECT
Fault Code: 2154 PID: SPN: 611 FMI: 3 LAMP: Warning SRT: | Engine Oil Pressure Sensor Circuit (Post-filter) - Shorted High. High voltage detected on Engine Oil Pressure Sensor (Post-filter) signal pin on the main harness CM700 connector. | Fault Code 2153 is disabled.
Engine Oil Pressure Sensor Circuit (Post-filter) - Multiple Turbochargers
Engine Oil Pressure Sensor Circuit (Post-filter) - Single Turbocharger

Circuit Description

The engine oil pressure sensor (post-filter) monitors engine oil pressure as it exits the filter. High voltage will cause Fault Code 2154 and can be caused by shorts in the supply, signal, or return wires, an open in the return wire, or a failed sensor.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

If the fault occurs only in cold environment, allow the oil to warm up and check to see if the fault becomes inactive.

Refer to Troubleshooting Fault Code t05-2154

Last Modified: 30-Jun-2010


Engine Oil Pressure Sensor Circuit (Post-filter) - Shorted Low

FAULT CODE 2155

Engine Oil Pressure Sensor Circuit (Post-filter) - Shorted Low

Printable Version Printable Version

Overview

Engine Oil Pressure Sensor Circuit (Post-filter) - Shorted Low

CODE | REASON | EFFECT
Fault Code: 2155 PID: SPN: 611 FMI: 4 LAMP: Warning SRT: | Engine Oil Pressure Sensor Circuit (Post-filter) - Shorted Low. Low voltage detected on Engine Oil Pressure Sensor (Post-filter) signal pin on the main harness A CENSE™ connector. | Fault Code 2153 is disabled.
Engine Oil Pressure Sensor Circuit (Post-filter) - Multiple Turbochargers
Engine Oil Pressure Sensor Circuit (Post-filter) - Single Turbocharger

Circuit Description

The engine oil pressure sensor (post-filter) monitors engine oil pressure as it exits the filter. This pressure is monitored by the CENSE™ module, which passes the data to the CM700 via the J1939 data link. Low voltage will cause Fault Code 2155 and can be caused by shorts in the supply, signal, or return wires, an open in the return wire, or a failed sensor.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

If the fault occurs only in cold environment, allow the oil to warm up and check to see if the fault becomes inactive.

If all CENSE™ data are invalid (exhaust temperatures, post-filter oil pressure, and crankcase blowby pressure) then it is likely that the J1939 data link or CENSE™ module have failed.

Refer to Troubleshooting Fault Code t05-2155

Last Modified: 30-Jun-2010


Intake Manifold Absolute Pressure Sensor Disagrees with the Compressor Outlet Pressure Sensor - Condition Exists

FAULT CODE 2191

Intake Manifold Absolute Pressure Sensor Disagrees with the Compressor Outlet Pressure Sensor - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2191 PID: 102 SPN: 102 FMI: 31 LAMP: Warning SRT: | Intake Manifold Absolute Pressure Sensor Disagrees with the Compressor Outlet Pressure Sensor - Condition Exists. The intake manifold pressure and compressor outlet pressure are mismatching. | Possible reduced engine performance.
QSK60G Generator Drive, Multiple Turbochargers

Circuit Description

The turbocharger compressor outlet pressure sensor monitors the pressure of the air and fuel mixture after the turbocharger compressor outlet. The left-bank CM558 engine control module (ECM) provides a 5 volt supply to the compressor outlet pressure sensor on the sensor supply circuit. The left-bank CM558 also provides a ground on the sensor return circuit. The compressor outlet pressure sensor provides a signal to the left-bank CM558 on the compressor outlet pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the intake manifold before the throttle valve. The left-bank CM558 will detect a low signal voltage during operating conditions when the turbocharger outlet pressure is low. The left-bank CM558 will detect a high signal voltage during operating conditions when the turbocharger compressor outlet pressure is high.

The intake manifold pressure sensor monitors the absolute pressure of the air and fuel mixture in the intake manifold, immediately after the engine throttle valve. The left-bank CM558 ECM provides a 5 volt supply to the intake manifold absolute pressure sensor on the sensor supply circuit. The left-bank CM558 also provides a ground on the sensor return circuit. The intake manifold absolute pressure sensor provides a signal to the left-bank CM558 on the intake manifold absolute pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the intake manifold after the throttle valve. The left-bank CM558 will detect a low signal voltage during operating conditions when the intake manifold pressure is low. The left-bank CM558 will detect a high signal voltage during operating conditions when the intake manifold pressure is high.

Component Location

The turbocharger compressor outlet pressure sensor is located in the free-end of the intake manifold, after the aftercooler and before the throttle valve.

The intake manifold absolute pressure sensor is mounted in the free-end of the right-bank intake manifold, after the throttle valve.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the ECM keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The pressure differential (delta P) between the turbocharger compressor outlet pressure sensor and the intake manifold pressure sensor has exceeded the pressure threshold for a period of 30 seconds and ignition timing retardation has reached the limit of adjustment.

Action Taken When the Fault Code is Active

The left-bank CM558 module illuminates the amber ALARM WARNING lamp on the Generator Control Panel immediately when the diagnostic runs and fails. Fault Code 2191 will also be shown as ACTIVE by INSITE™ electronic service tool and on the original equipment manufacturer (OEM) control panel display.

Conditions for Clearing the Fault Code

To validate the repair:

  • Start the engine and let it operate for 1 minute at no load.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The left-bank CM558 will turn off the amber ALARM WARNING lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The turbocharger compressor outlet pressure sensor is monitoring the boost pressure from the turbocharger(s) and the intake manifold pressure sensor is monitoring intake manifold pressure after the throttle plate.

The pressure differential (delta P) between the turbocharger compressor outlet pressure sensor and the intake manifold pressure sensor will vary according to the position of the throttle plate and as the throttle plate position increases, the delta P decreases. This pressure differential is monitored by the left-bank CM558 module and is referred to as Throttle Margin.

If turbocharger boost pressure is low, then the ECM will command the throttle plate to open in order to try and maintain engine speed and load. At the same time, the engine's ignition timing is retarded in order to try and recover turbocharger boost pressure. If turbocharger boost pressure remains low, the throttle plate position will again be increased and the ignition timing will be further retarded. Fault Code 2191 will be activated when the delta P threshold and limit of ignition timing retardation are reached. Due to the increased throttle plate position for a given load, throttle margin is lost and engine performance may be reduced as a result.

Throttle Margin can be calculated using the following formula:

Turbocharger Compressor Outlet Pressure minus Intake Manifold Pressure divided by Turbocharger Compressor Outlet Pressure times 100 (%).

Throttle margin data can be interpretated:
Throttle margin greater than 8% | Sufficient throttle margin for present operating conditions.
Throttle margin 6% to 8% | Approaching minimum throttle margin - schedule engine shut down to investigate.
Throttle margin less than 6% | Risk of instability and engine may be unlikely to maintain load - urgent investigation required. The engine may shut down.

Throttle plate position can also give an indication of the engine's intake system condition and can be referenced to aid troubleshooting. For most applications, the throttle plate position should not exceed 60% at full / rated load.

Throttle position data can be interpretated:
Throttle plate position less than 60% | Sufficient throttle valve margin for present operating conditions.
Throttle plate position 60% to 70% | Approaching minimum for stable governing - schedule shut down to investigate.
Throttle plate position greater than 70% | Unlikely to achieve or maintain load - urgent investigation required. The engine may shut down.

Possible causes of this fault code include:

  • Engine operation at high altitude and applicable derate not applied
  • Engine operation at high ambient temperatures
  • Low temperature coolant circuit temperature too high
  • Incorrect exhaust emissions (air/fuel ratio too lean)
  • Turbocharger wear
  • Aftercooler core blocked
  • Engine air filters blocked
  • Exhaust back pressure too high
  • Engine room or container air inlet filters blocked
  • Compressor outlet pressure sensor malfunctioned (sensor can fail in range so no fault code active)
  • Intake manifold pressure sensor malfunctioned (sensor can fail in range so no fault code active).

OEM supplied equipment can cause Fault Code 2191 to be active. OEM equipment must be installed and operating to manufacturer's specification. Refer to the OEM service manual(s).

Refer to Troubleshooting Fault Code t05-2191.

Last Modified: 30-Jul-2013


Engine Control Module Calibration Program Memory (RAM) Corruption - Condition Exists

FAULT CODE 2217

Engine Control Module Calibration Program Memory (RAM) Corruption - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2217 PID: SPN: 630 FMI: 31 LAMP: Warning SRT: | Engine Control Module Calibration Program Memory (RAM) Corruption - Condition Exists. Internal ECM error. | Possible no effect on engine performance, loss of performance, engine may run rough, or engine will possibly not start.
Electronic Control Module (ECM)

Circuit Description

The CM700 and CM558 modules are computers that perform engine control functions and provide engine protection and diagnostics (fault codes).

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Fault Code 2217 can only be activated by an internal ECM problem. Repairs to the ECM are not possible.

Refer to Troubleshooting Fault Code t05-2217.

Last Modified: 05-Apr-2011


Sensor Supply Circuit Number 2 - Shorted High

FAULT CODE 227

Sensor Supply Circuit Number 2 - Shorted High

Printable Version Printable Version

Overview

Sensor Supply Circuit Number 2 - Shorted High

CODE | REASON | EFFECT
Fault Code: 227 PID: S232 SPN: 1080 FMI: 3 LAMP: Warning SRT: | Sensor Supply Circuit Number 2 - Shorted High. Sensor supply number 2 supply signal is shorted high. | Possible reduced engine performance or shutdown. Pressure sensor shorted high faults likely.
Sensor Supply Circuit Number 2 - Multiple Turbochargers
Sensor Supply Circuit Number 2 - Single Turbocharger

Circuit Description

Sensor supply circuit number 2 from the ECM supplies multiple engine pressure sensors with a positive (+) 5-VDC supply. The ECM has a common return for most of the engine pressure and temperature sensors. A fault on either of these wires can cause multiple pressure and temperature sensor fault codes as well as the power supply fault.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

Refer to the engine wiring diagram to find sensors that share a common electrical supply or return. A damaged pressure sensor can cause multiple fault codes. A damaged pressure sensor can cause multiple active fault codes to become inactive when the engine is started.

Refer to Troubleshooting Fault Code t05-227

Last Modified: 30-Jun-2010


Engine Coolant Pressure (High Temperature) Low - Critical

FAULT CODE 228

Engine Coolant Pressure (High Temperature) Low - Critical

Printable Version Printable Version

Overview

Engine Coolant Pressure (High Temperature) Low - Critical

CODE | REASON | EFFECT
Fault Code: 228 PID: P109 SPN: 109 FMI: 1 LAMP: Shutdown SRT: | Engine Coolant Pressure (High Temperature) Low - Critical. The engine coolant pressure (high temperature) has dropped below the low critical threshold. | The engine will shut down.
Engine Coolant Pressure Sensor Circuit - Multiple Turbochargers
Engine Coolant Pressure Sensor Circuit - Single Turbocharger

Circuit Description

The high temperature coolant pressure sensor monitors coolant pressure in the high temperature coolant loop and passes information to the CM700.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

The engine coolant pressure (high temperature) has dropped below the low critical threshold.

Refer to Troubleshooting Fault Code t05-228

Last Modified: 30-Jun-2010


Engine Cylinder Number 11 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2281

Engine Cylinder Number 11 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2281 PID: SPN: 1362 FMI: 16 LAMP: Shutdown SRT: | Engine Cylinder Number 11 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Cylinder number 11 has exceeded the lower knock count threshold. | The engine will shut down.
Knock Sensor Circuit - Multiple and Single Turbocharger Engines

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Knock sensors are located on each of the cylinder heads. Use the following procedure for component location. Refer to Procedure 019-346 in Section 19.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by a source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to a "pre-ignition" and knock occurring after the normal spark event is known as "detonation". The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of knock is not identified and rectified, engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function correctly, it must be installed and tightened to the correct torque.

Knock-related faults are activated when the knock sensor voltage output exceeds either a Warning or High critical threshold for a pre-set period of time.

When the knock Warning threshold is reached and persists for a pre-set period of time, the CM558 will register a Warning alarm for the affected cylinder and the engine will continue to run. The CM558 will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the CM558 will slowly advance the timing for that cylinder back to its standard timing setting. If the detonation persists, the timing retardation is repeated, up to a maximum of three timing retardations. If, following the final timing, retardation knock is still present, the CM558 will initiate a Critical shutdown of the engine.

All detonation-related shutdowns and persistent light knock events should be fully investigated in order to prevent engine damage.

The knock sensors can also detect mechanical noise, Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever "elephant foot" o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust (multi-duct) gasket leakage
  • Vibration resulting from loose engine parts/components.

Generator Sets using PowerCommand® Control 3300 (PCC3300) Generator Control:

The PCC3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code t05-2281.

Last Modified: 09-May-2012


Engine Cylinder Number 11 Knock Sensor Circuit - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2282

Engine Cylinder Number 11 Knock Sensor Circuit - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2282 PID: SPN: 1362 FMI: 0 LAMP: Shutdown SRT: | Engine Cylinder Number 11 Knock Sensor Circuit - Data Valid But Above Normal Operating Range - Most Severe Level. Cylinder number 11 knock sensor has detected a knock above critcal level. | The engine will shut down.
Knock Sensor Circuit (Multiple and Single Turbocharger Engines)

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as 'pre-ignition' and knock occurring after the normal spark event is known as 'detonation'. The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts within the power cylinder colliding. If the cause of knock is not identified and rectified, then engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage may occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a WARNING alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function correctly, it must be installed and tightened to the correct torque.

Knock related faults are activated when the knock sensor voltage output exceeds either a WARNING or HIGH critical threshold for a pre-set period of time.

When the knock HIGH critical threshold is reached and persists for a pre-set period of time, then the CM558 will initiate a critical shutdown of the engine.

All detonation-related shutdowns and persistent light knock events should be fully investigated in order to prevent engine damage.

The knock sensors can also detect mechanical noise, and mechanical-related problems should not be dicounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and discounted:

  • Valve train/rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever 'elephant foot' o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust gasket leakage
  • Vibration resulting from loose engine parts/components.

Generator Sets using PowerCommand™ Control 3300 (PCC3300) Generator Control:

The PCC3300 generator control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from 'no-knock' condition (0 percent) to most severe level (100 percent +).

Refer to Troubleshooting Fault Code t05-2282

Last Modified: 30-Jun-2010


Engine Coolant Pressure Sensor Circuit (High Temperature) - Shorted High

FAULT CODE 231

Engine Coolant Pressure Sensor Circuit (High Temperature) - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 231 PID: P109 SPN: 109 FMI: 3 LAMP: Warning SRT: | Engine Coolant Pressure Sensor Circuit (High Temperature) - Shorted High. High voltage detected on the Engine Coolant Pressure Sensor (High Temperature) signal pin of the CM700. | No engine protection for engine coolant pressure (high temperature). No effect on performance.
Engine Coolant Pressure Sensor Circuit (High Temperature) - Multiple Turbochargers
Engine Coolant Pressure Sensor Circuit (High Temperature) - Single Turbocharger

Circuit Description

The engine coolant pressure sensor (high temperature) monitors engine coolant pressure in the high temperature engine coolant loop and passes information to the CM700. High voltage will trip Fault Code 231 and can be caused by a short in the supply, signal, or return wires, an open in the return wire, or a damaged sensor.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

Confirm that the engine cooling high temperature radiator cap is installed correctly.Check the radiator for proper operation.

Refer to Troubleshooting Fault Code t05-231

Last Modified: 30-Jun-2010


Engine Electronic Fuel Control Valve 1 Circuit – Condition Exists

FAULT CODE 2311

Engine Electronic Fuel Control Valve 1 Circuit – Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2311 PID: SPN: 633 FMI: 31 LAMP: Warning SRT: | Engine Electronic Fuel Control Valve 1 Circuit – Condition Exists. The fuel control valve circuit resistance is too high or too low, or an intermittent connection exists. | The engine will continue to run but performance may be impaired.
QSK60G Multiple Turbochargers with Generator Control Panel 1 (GCP1) with PowerCommand® Supervisor 3100 and AC and DC Generator Set Terminal Boxes
QSK60G Single and Multiple Turbochargers with Generator Control Panel 2 (GCP2) with PowerCommand® Supervisor 3100 and Generator Interface Box (GIB)
QSK60G Single and Multiple Turbochargers with PowerCommand® Control 3300 and Generator Interface Box (GIB)

Circuit Description

The fuel control valve position circuit consists of the commanded signal from the CM558 module and the feedback signal that is received by the CM558 from the fuel control valve. The fuel control valve commanded position signal is supplied by the CM558 and is a 24-VDC pulse-width modulated (PWM) signal. The feedback is a 0 to 5-VDC signal.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

If an intermittent electrical circuit problem of the electronic fuel control valve circuit exists, it is possible for Fault Code 2311 to become active and then inactive during normal generator set operation. This would indicate an intermittent open or short circuit.

Possible causes of this fault code include:

  • Electronic fuel control valve actuator high resistance
  • Engine harness or extension harness high resistance
  • Loose, worn, or corroded connectors or pins at the fuel control valve connector or ECM connector
  • Electronic fuel control valve low internal resistance
  • Electronic fuel control valve or engine harness short to ground
  • Intermittent circuit malfunctions.

Verify that all connectors are clean and free of corrosion before replacing components.

The following table, which can be used as an aid when troubleshooting the fuel control valve operation, provides fuel control valve actuator commanded position, PWM percentage Duty Cycle, and VDC Feedback signal specifications.

Actuator Commanded Position | Percentage Duty Cycle | 0 to 5-VDC Feedback Signal
0 | 10 - 11 | 0.4 - 0.7
10 | 17 - 19 | 0.9 - 1.1
20 | 25 - 27 | 1.3 - 1.5
30 | 33 - 35 | 1.7 - 1.9
40 | 41 - 43 | 2.1 - 2.3
50 | 49 - 51 | 2.9 - 3.1
60 | 57 - 59 | 2.9 - 3.1
70 | 65 - 67 | 3.3 - 3.5
80 | 73 - 75 | 3.7 - 3.9
90 | 81 - 83 | 4.1 - 4.3
100 | 89 - 91 | 4.6 - 4.8

PWM percentage duty cycle signals can only be measured with multimeters or other measuring devices that have a percentage duty cycle function.

Refer to Troubleshooting Fault Code t05-2311.

Last Modified: 05-Apr-2011


Engine Coolant Pressure Sensor Circuit (High Temperature) - Shorted Low

FAULT CODE 232

Engine Coolant Pressure Sensor Circuit (High Temperature) - Shorted Low

Printable Version Printable Version

Overview

Engine Coolant Pressure Sensor Circuit (High Temperature) - Shorted Low

CODE | REASON | EFFECT
Fault Code: 232 PID: P109 SPN: 109 FMI: 4 LAMP: Warning SRT: | Engine Coolant Pressure Sensor Circuit (High Temperature) - Shorted Low. Low voltage detected on the Engine Coolant Pressure Sensor Circuit (High Temperature) signal pin of the main harness CM700 connector. | The CM700 will shutdown the engine.
Engine Coolant Pressure Sensor Circuit (High Temperature) - Multiple Turbochargers
Engine Coolant Pressure Sensor Circuit (High Temperature) - Single Turbocharger

Circuit Description

The engine coolant pressure sensor (high temperature) monitors engine coolant pressure in the high temperature engine coolant loop and passes information to the CM700. Low voltage will trip Fault Code 232 and can be caused by a short in the supply, signal, or return wires, an open in the return wire, or a damaged sensor.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

Confirm that the engine cooling high temperature radiator cap is installed correctly.Check the radiator for proper operation.

Refer to Troubleshooting Fault Code t05-232

Last Modified: 30-Jun-2010


Engine Coolant Pressure (High Temperature) Low - Warning

FAULT CODE 233

Engine Coolant Pressure (High Temperature) Low - Warning

Printable Version Printable Version

Overview

Engine Coolant Pressure (High Temperature) Low - Warning

CODE | REASON | EFFECT
Fault Code: 233 PID: P109 SPN: 109 FMI: 18 LAMP: Warning SRT: | Engine Coolant Pressure (High Temperature) Low - Warning. The engine coolant pressure (high temperature) has dropped below the low warning threshold. | No effect on engine performance.
Engine Coolant Pressure Sensor Circuit (High Temperature) - Multiple Turbochargers
Engine Coolant Pressure Sensor Circuit (High Temperature) - Single Turbocharger

Circuit Description

The engine coolant pressure sensor (high temperature) monitors coolant pressure in the high temperature coolant loop and passes information to the CM700.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

The engine coolant pressure (high temperature) has dropped below the low warning threshold.

Refer to Troubleshooting Fault Code t05-233

Last Modified: 30-Jun-2010


Engine Overspeed

FAULT CODE 234

Engine Overspeed

Printable Version Printable Version

Overview

Engine Overspeed

CODE | REASON | EFFECT
Fault Code: 234 PID: 190 SPN: 190 FMI: 0 LAMP: Warning SRT: | Engine Overspeed. Engine speed signals indicate an engine speed greater than the shutdown threshold. | Engine will shut down. Fuel shutoff valves are de-energized (valves closed).
QSK60G Multiple Turbocharger with GCP1 / PCS3100 Control - Engine Speed Sensor Circuit
QSK60G Single and Multiple Turbocharger with GCPII / PCS3100 Control - Engine Speed Sensor Circuit
QSK60G Single and Multiple Turbocharger with PCC3300 Control - Engine Speed Sensor Circuit

Circuit Description

The engine/speed position sensor(s) monitor the engine position and the engine speed. They then pass this information to the CM700 and CM558 through the engine harness.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Possible causes of this fault code include reverse powering (motoring) of the engine, or damaged engine speed/position sensors and sudden decreases in generator load.

Inspect the engine/speed position sensors for damage and check the air gap of the installed sensors.

Refer to Troubleshooting Fault Code t05-234.

Last Modified: 06-Jul-2011


Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 235

Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 235 PID: 111 SPN: 111 FMI: 1 LAMP: Shutdown SRT: | Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level. Low engine coolant level in the high temperature (HT) engine cooling circuit detected. | The engine will shut down.
QSK60 G Multiple Turbochargers with Generator Control Panel (GCP1) and PowerCommand® Supervisor 3100
QSK60 G Single and Multiple Turbochargers with Generator Control Panel (GCP2) and PowerCommand® Supervisor 3100
QSK60 G Single and Multiple Turbochargers with PowerCommad® Control 3300

Circuit Description

The engine coolant level sensor (HT) monitors the engine coolant level within the high temperature cooling system and passes information to the CM700 module. The wiring between the coolant level sensor and the generator control panel or generator interface box is customer supplied.

Component Location

Reference site specific installation drawings for the location of the high temperature system coolant tank and coolant level sensor.

Refer to Troubleshooting Fault Code t05-235.

Last Modified: 11-Jan-2011


Sensor Supply Circuit Number 3 - Shorted Low

FAULT CODE 238

Sensor Supply Circuit Number 3 - Shorted Low

Printable Version Printable Version

Overview

Sensor Supply Circuit Number 3 - Shorted Low

CODE | REASON | EFFECT
Fault Code: 238 PID: S232 SPN: 620 FMI: 4 LAMP: Warning SRT: | Sensor Supply Circuit Number 3 - Shorted Low. Sensor supply number 3 supply signal is shorted low. | Possible reduced engine performance or shutdown. Gas Mass Flow Sensor shorted low fault likely.
Sensor Supply Voltage Number 3 Circuit - Multiple Turbochargers
Sensor Supply Voltage Number 3 Circuit - Single Turbocharger

Circuit Description

Sensor supply circuit number 3 from the CM558 module supplies the gas mass flow sensor with a positive (+) 14-VDC supply. A fault on either of these wires can cause multiple sensor fault codes as well as the power supply fault.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

Refer to the engine wiring diagram to find sensors that share a common electrical supply or return. A damaged sensor can cause multiple fault codes. A damaged sensor can cause multiple active fault codes to become inactive when the engine is started.

Refer to Troubleshooting Fault Code t05-238

Last Modified: 30-Jun-2010


Sensor Supply Circuit Number 3 - Shorted High

FAULT CODE 239

Sensor Supply Circuit Number 3 - Shorted High

Printable Version Printable Version

Overview

Sensor Supply Circuit Number 3 - Shorted High

CODE | REASON | EFFECT
Fault Code: 239 PID: S232 SPN: 620 FMI: 4 LAMP: Warning SRT: | Sensor Supply Circuit Number 3 - Shorted High. Sensor supply number 3 supply signal is shorted high. | Possible reduced engine performance or shutdown. Gas Mass Flow Sensor shorted high fault likely.
Sensor Supply Voltage Number 3 Circuit - Multiple Turbochargers
Sensor Supply Voltage Number 3 Circuit - Single Turbocharger

Circuit Description

Sensor supply circuit number 3 from the CM558 module supplies the gas mass flow sensor with a positive (+) 14-VDC supply. A fault on either of these wires may cause multiple sensor fault codes as well as the power supply fault.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

Refer to the engine wiring diagram to find sensors that share a common electrical supply or return. A damaged sensor can cause multiple fault codes. A damaged sensor can cause multiple active fault codes to become inactive when the engine is started.

Refer to Troubleshooting Fault Code t05-239

Last Modified: 30-Jun-2010


Fuel Outlet Pressure Sensor Circuit - Shorted High

FAULT CODE 2427

Fuel Outlet Pressure Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

Fuel Outlet Pressure Sensor Circuit - Shorted High

CODE | REASON | EFFECT
Fault Code: 2427 PID: SPN: FMI: 3 LAMP: Warning SRT: | Fuel Outlet Pressure Sensor Circuit - Shorted High. High voltage detected on the Fuel Outlet Pressure Sensor signal pin of the main harness CM558 connector. | Possible reduced engine performance.
Fuel Outlet Pressure Sensor Circuit - Multiple Turbochargers
Fuel Outlet Pressure Sensor Circuit - Single Turbocharger

Circuit Description

The fuel outlet pressure sensor monitors the gas pressure as it exits the fuel control assembly. The pressure is monitored by the CM558 modules. High voltage will cause Fault Code 2427 and can be caused by shorts in the supply, signal, or return wires, an open in the return wire, or a failed sensor.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

The fuel outlet pressure is the gas pressure after the gas flow has been metered by the fuel control valve. This gas is introduced into the air box to mix with the intake air.

Refer to Troubleshooting Fault Code t05-2427

Last Modified: 30-Jun-2010


Fuel Outlet Pressure Sensor Circuit - Shorted Low

FAULT CODE 2428

Fuel Outlet Pressure Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

Fuel Outlet Pressure Sensor Circuit - Shorted Low

CODE | REASON | EFFECT
Fault Code: 2428 PID: SPN: FMI: 4 LAMP: Warning SRT: | Fuel Outlet Pressure Sensor Circuit - Shorted Low. Low voltage detected on the Fuel Outlet Pressure Sensor signal pin of the main harness CM558 connector. | Possible reduced engine performance.
Fuel Outlet Pressure Sensor Circuit - Multiple Turbochargers
Fuel Outlet Pressure Sensor Circuit - Single Turbocharger

Circuit Description

The fuel outlet pressure sensor monitors the gas pressure as it exits the fuel control assembly. The pressure is monitored by the CM558 modules. Low voltage will cause Fault Code 2428 and can be caused by shorts in the supply, signal, or return wires, an open in the return wire, or a failed sensor.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

The fuel outlet pressure is the gas pressure after the gas flow has been metered by the fuel control valve. This gas is introduced into the air box to mix with the intake air.

Refer to Troubleshooting Fault Code t05-2428

Last Modified: 30-Jun-2010


Kilowatt Load High Error

FAULT CODE 2453

Kilowatt Load High Error

Printable Version Printable Version

Overview

Kilowatt Load High Error

CODE | REASON | EFFECT
Fault Code: 2453 PID: FMI: 16 LAMP: Warning SRT: | Kilowatt Load High Error. High current detected at the kilowatt load signal pin of the main harness CM700 connector. | Possible reduced engine performance.
Kilowatt Load Circuit

Circuit Description

The kilowatt load sensor receives alternating current (AC) voltage and current signals from the main alternator. The sensor output is a 4 to 20 mA signal to the CM700.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Use caution when troubleshooting the kilowatt load transducer. AC voltage is present.

The kilowatt load sensor output needs to be calibrated with an electronic service tool if the transducer is replaced.

Refer to Troubleshooting Fault Code t05-2453

Last Modified: 30-Jun-2010


Kilowatt Load Low Error

FAULT CODE 2454

Kilowatt Load Low Error

Printable Version Printable Version

Overview

Kilowatt Load Low Error

CODE | REASON | EFFECT
Fault Code: 2454 PID: FMI: 18 LAMP: Warning SRT: | Kilowatt Load Low Error. Low current detected at the kilowatt load signal pin of the main harness CM700 connector. | Possible reduced engine performance.
Kilowatt Load Circuit

Circuit Description

The kilowatt load sensor receives alternating current (AC) voltage and current signals from the main alternator. The sensor output is a 4 to 20 mA signal to the CM700.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Use caution when troubleshooting the kilowatt load transducer. AC voltage is present.

The kilowatt load sensor output needs to be calibrated with an electronic service tool if the transducer is replaced.

Refer to Troubleshooting Fault Code t05-2454

Last Modified: 30-Jun-2010


External Governor Speed or Frequency Bias - Current Below Normal or Open Circuit

FAULT CODE 2455

External Governor Speed or Frequency Bias - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2455 PID: SPN: 3938 FMI: 5 LAMP: Warning SRT: | External Governor Speed or Frequency Bias - Current Below Normal or Open Circuit. Low current has been detected in the external governor speed or frequency bias circuit. | Possible reduced engine performance or reduced generator set synchronizing performance.
Speed Bias Circuit - Multiple Turbochargers
Speed Bias Circuit - Single Turbocharger

Circuit Description

NOTE: Fault Code 2455 is only applicable for generator sets fitted with Generator Control Panel (GCP1 or II) and PowerCommand® Supervisor 3100 Controller.

The speed bias signal input to the CM700 module from the PowerCommand® Supervisor 3100 Controller is a 5-VDC pulse width modulated (PWM) signal. An open speed bias signal or short-to-ground will cause Fault Code 2455 to be activated.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The crankshaft engine speed sensor has a dual core circuit, where one circuit supplies an engine speed signal to the CM700 (engine speed) and the other supplies an engine speed signal to the PowerCommand® Supervisor 3100 Controller generator set control panel (speed bias control).

The PowerCommand® Supervisor 3100 Controller generator set control panel sends a PWM speed bias signal to the CM700 to control engine speed during generator set synchronization with the utility and/or other generator set installed in the system, as well as for throttle control when operating in parallel with utility.

NOTE: PWM signals must be measured with a high-speed multimeter, having a sample rate of at least twice the frequency to be measured; otherwise false or misleading results may be obtained.

Fault Code 2455 is activated when there is a fault present on the CM700 module speed bias input circuit from the PowerCommand® Supervisor 3100 generator set control panel.

Refer to Troubleshooting Fault Code t05-2455

Last Modified: 13-Oct-2010


External Governor Speed or Frequency Bias - Current Above Normal or Grounded Circuit

FAULT CODE 2456

External Governor Speed or Frequency Bias - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2456 PID: SPN: 3938 FMI: 5 LAMP: Warning SRT: | External Governor Speed or Frequency Bias - Current Above Normal or Grounded Circuit. High current has been detected in the external governor speed or frequency bias circuit. | Possible reduced engine performance or reduced generator set synchronizing performance.
Multiple Turbocharger with GCP1/PCS3100 Control
Single and Multiple Turbocharger with GCP II/PCS3100 Control

Circuit Description

NOTE: Fault Code 2456 is only applicable for generator sets fitted with Generator Control Panel (GCP1 or II) and PowerCommand® Supervisor 3100 Controller.

The speed bias signal input to the CM700 module from the PowerCommand® Supervisor 3100 Controller is a 5-VDC pulse width modulated (PWM) signal. A pin-to-pin or short-to-ground will cause Fault Code 2456 to be activated.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The crankshaft engine speed sensor has a dual core circuit, where one circuit supplies an engine speed signal to the CM700 (engine speed) and the other circuit supplies an engine speed signal to the PowerCommand® Supervisor 3100 generator set control panel (speed bias control).

The PowerCommand® Supervisor 3100 generator set control panel sends a PWM speed bias signal to the CM700 to control engine speed during generator set synchronization with the utility and/or other generator sets installed in the system, as well as for throttle control when operating in parallel with the utility.

The PWM signal that is sent to the CM700 from the PowerCommand® Supervisor 3100 generator set control panel should always read a frequency of 3 kHz.

NOTE: PWM signals must be measured with a high-speed multimeter, having a sample rate of at least twice the frequency to be measured; otherwise false or misleading results may be obtained.

Fault Code 2456 is activated when there is fault present on the CM700 module speed bias signal input circuit from the PowerCommand® Supervisor 3100 generator set control panel.

Refer to Troubleshooting Fault Code t05-2456.

Last Modified: 13-Oct-2010


Fault Code Path Selection

FAULT CODE 2457
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2457mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2457st

Last Modified: 07-Oct-2010


Engine Misfire for Multiple Cylinders - Condition Exists

FAULT CODE 2457 - Multiple Turbochargers

Engine Misfire for Multiple Cylinders - Condition Exists

Printable Version Printable Version

Overview

Engine Misfire for Multiple Cylinders - Condition Exists

CODE | REASON | EFFECT
Fault Code: 2457 PID: SPN: 1322 FMI: 31 LAMP: Shut down SRT: | Engine Misfire for Multiple Cylinders - Condition Exists. The engine is experiencing misfire in multiple cylinders. | The engine will shut down.
Exhaust Temperature Circuit - Multiple Turbochargers

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Refer to Procedure 100-002 in Section E.

Shop Talk

Multiple-cylinder engine misfires are most often caused by spark plug malfunction, typically as a result of extending spark plug life beyond the recommended spark plug change interval.

Multiple-cylinder engine misfires can also be caused by poor connections, either within the ignition harness or the exhaust temperature sensing harness.

Excessively lean air/fuel mixtures can also cause multiple cylinder engine misfires.

An exhaust temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature probe or harness can be faulty. If shown on all cylinders, either the J1939 data link circuit, exhaust temperature return circuit or CENSE™ can be at fault. If this condition exists, the engine will continue to run for a short period, but will then shut down and display the appropriate fault code or codes.

Refer to Troubleshooting Fault Code 2457 (Multiple Turbochargers).

Last Modified: 09-Jul-2010


Engine Misfire for Multiple Cylinders - Condition Exists

FAULT CODE 2457 - Single Turbochargers

Engine Misfire for Multiple Cylinders - Condition Exists

Printable Version Printable Version

Overview

Engine Misfire for Multiple Cylinders - Condition Exists

CODE | REASON | EFFECT
Fault Code: 2457 PID: SPN: 1322 FMI: 31 LAMP: Shut down SRT: | Engine Misfire for Multiple Cylinders - Condition Exists. The engine is experiencing misfire in multiple cylinders. | The engine will shut down.
Exhaust Temperature Circuit - Single Turbochargers (Left Bank)
Exhaust Temperature Circuit - Single Turbochargers (Right Bank)

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to two CM850 modules, one for each bank, which sends this information to the CM700 module via the Proprietary Data Link. The temperature sensor is a thermocouple device which converts its output to a 0 - 5-VDC thermister type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Refer to Procedure 100-002 in Section E.

Shop Talk

Multiple-cylinder engine misfires are most often caused by spark plug failure, typically as a result of extending spark plug life beyond the recommended spark plug change interval.

Multiple-cylinder engine misfires can also be caused by poor connections, either within the ignition harness or the exhaust temperature sensing harness.

Additionally, excessively lean air/fuel mixtures can also cause multiple cylinder engine misfires.

An exhaust temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature probe or harness may be faulty. If shown on all cylinders for one bank, either the exhaust temperature supply or return circuit or the CM850 for the specific bank may be at fault. If all cylinders are displaying this value, then the Proprietary Data Link Circuit may be at fault. If this condition exists, the engine will continue to run for a short period, but will then shut down and display the appropriate fault code or codes.

Refer to Troubleshooting Fault Code 2457 (Single Turbochargers).

Last Modified: 09-Jul-2010


Fault Code Path Selection

FAULT CODE 2458
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2458mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2458st

Last Modified: 07-Oct-2010


Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2458 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2458 PID: SPN: 1138 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor on cylinder 2 (B1) indicates temperature has reached the Low Temperature Warning threshold. | No effect on engine performance.
Cylinder 2 (B1) Exhaust Temperature Circuit - Multiple Turbocharger Engines

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. The low warning alarm can be an indication of misfiring within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shut down.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning can recover the exhaust temperature for a short period (1 -2 days) giving time for a repair action to be coordinated.

An exhaust temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature probe or harness can be faulty. If shown on all cylinders, either the J1939 data link circuit, exhaust temperature return circuit, or CENSE™ can be at fault. The engine will continue to run for a short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code 2458 (Multiple Turbochargers).

Last Modified: 09-Jul-2010


Exhaust Gas Temperature Cylinder 2 (B1) Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2458 - Single Turbocharger

Exhaust Gas Temperature Cylinder 2 (B1) Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 2 (B1) Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2458 PID: SPN: 1138 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor on cylinder 2 (B1) indicates temperature has reached the Low Temperature Warning threshold. | No effect on engine performance.
Cylinder 2 (B1) Exhaust Temperature Circuit - Single Turbocharger

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to two CM850 modules, one for each bank, which sends this information to the CM700 module via the Proprietary data link. The temperature sensor is a thermocouple device which converts its output to a 0 - 5-VDC thermister type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. The low warning alarm can be an indication of misfiring within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shut down.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning can recover the exhaust temperature for a short period (1 - 2 days) giving time for a repair action to be coordinated.

An exhaust temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature sensor or harness to that sensor may be faulty. If shown on all cylinders for one bank of the engine, either the exhaust temperature sensor 5 volt supply or return circuits or CM850 module may be at fault. If -17.78° (C or F) is shown on all engine cylinders, then the fault may be with the Proprietary Data Link which connects both CM850 modules to the CM700 module. The engine will continue to run for a short period and will then shut down and will display the appropriate fault code.

Refer to Troubleshooting Fault Code 2458 (Single Turbocharger).

Last Modified: 09-Jul-2010


Fault Code Path Selection

FAULT CODE 2459
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2459mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2459st

Last Modified: 07-Oct-2010


Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2459 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2459 PID: SPN: 1140 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor on cylinder 4 (B2) indicates temperature has reached the Low Temperature Warning threshold. | No effect on engine performance.
Cylinder 4 (B2) Exhaust Temperature Circuit - Multiple Turbocharger Engines

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. The low warning alarm can be an indication of misfiring within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shut down.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning can recover the exhaust temperature for a short period (1 -2 days) giving time for a repair action to be coordinated.

An exhaust temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature probe or harness can be faulty. If shown on all cylinders, either the J1939 data link circuit, exhaust temperature return circuit, or CENSE™ can be at fault. The engine will continue to run for a short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code 2459 (Multiple Turbochargers).

Last Modified: 09-Jul-2010


Exhaust Gas Temperature Cylinder 4 (B2) Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2459 - Single Turbocharger

Exhaust Gas Temperature Cylinder 4 (B2) Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 4 (B2) Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2459 PID: SPN: 1140 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor on cylinder 4 (B2) indicates temperature has reached the Low Temperature Warning threshold. | No effect on engine performance.
Cylinder 4 (B2) Exhaust Temperature Circuit - Single Turbocharger Engines

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to two CM850 modules, one for each bank, which sends this information to the CM700 module via the Proprietary data link. The temperature sensor is a thermocouple device which converts its output to a 0 - 5-VDC thermister type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. The low warning alarm can be an indication of misfiring within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shut down.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning can recover the exhaust temperature for a short period (1 - 2 days) giving time for a repair action to be coordinated.

An exhaust temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature sensor or harness to that sensor may be faulty. If shown on all cylinders for one bank of the engine, either the exhaust temperature sensor 5 volt supply or return circuits or CM850 module may be at fault. If -17.78° (C or F) is shown on all engine cylinders, then the fault may be with the Proprietary Data Link which connects both CM850 modules to the CM700 module. The engine will continue to run for a short period and will then shut down and will display the appropriate fault code.

Refer to Troubleshooting Fault Code 2459 (Single Turbocharger).

Last Modified: 09-Jul-2010


Fault Code Path Selection

FAULT CODE 2461
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2461mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2461st

Last Modified: 07-Oct-2010


Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2461 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2461 PID: SPN: 1142 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor on cylinder 6 (B3) indicates temperature has reached the Low Temperature Warning threshold. | No effect on engine performance.
Cylinder 6 (B3) Exhaust Temperature Circuit - Multiple Turbocharger Engines

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. The low warning alarm can be an indication of misfiring within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shut down.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning can recover the exhaust temperature for a short period (1 -2 days) giving time for a repair action to be coordinated.

An exhaust temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature probe or harness can be faulty. If shown on all cylinders, either the J1939 data link circuit, exhaust temperature return circuit, or CENSE™ can be at fault. The engine will continue to run for a short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code 2461 (Multiple Turbochargers).

Last Modified: 09-Jul-2010


Exhaust Gas Temperature Cylinder 6 (B3) Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2461 - Single Turbocharger

Exhaust Gas Temperature Cylinder 6 (B3) Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 6 (B3) Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2461 PID: SPN: 1142 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor on cylinder 6 (B3) indicates temperature has reached the Low Temperature Warning threshold. | No effect on engine performance.
Cylinder 6 (B3) Exhaust Temperature Circuit - Single Turbocharger Engines

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to two CM850 modules, one for each bank, which sends this information to the CM700 module via the Proprietary data link. The temperature sensor is a thermocouple device which converts its output to a 0 - 5-VDC thermister type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. The low warning alarm can be an indication of misfiring within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning can recover the exhaust temperature for a short period (1 - 2 days) giving time for a repair action to be coordinated.

An exhaust temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature sensor or harness to that sensor may be faulty. If shown on all cylinders for one bank of the engine, either the exhaust temperature sensor 5 volt supply or return circuits or CM850 module may be at fault. If -17.78° (C or F) is shown on all engine cylinders, then the fault may be with the Proprietary Data Link which connects both CM850 modules to the CM700 module. The engine will continue to run for a short period and will then shutdown and will display the appropriate fault code.

Refer to Troubleshooting Fault Code 2461 (Single Turbocharger).

Last Modified: 09-Jul-2010


Fault Code Path Selection

FAULT CODE 2462
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2462mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2462st

Last Modified: 07-Oct-2010


Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2462 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2462 PID: SPN: 1144 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor on cylinder 8 (B4) indicates temperature has reached the Low Temperature Warning threshold. | No effect on engine performance.
Cylinder 8 (B4) Exhaust Temperature Circuit - Multiple Turbocharger Engines

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. The low warning alarm can be an indication of misfiring within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shut down.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning can recover the exhaust temperature for a short period (1 -2 days) giving time for a repair action to be coordinated.

An exhaust temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature probe or harness can be faulty. If shown on all cylinders, either the J1939 data link circuit, exhaust temperature return circuit, or CENSE™ can be at fault. The engine will continue to run for a short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code 2462 (Multiple Turbochargers).

Last Modified: 09-Jul-2010


Exhaust Gas Temperature Cylinder 8 (B4) Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2462 - Single Turbocharger

Exhaust Gas Temperature Cylinder 8 (B4) Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 8 (B4) Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2462 PID: SPN: 1138 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor on cylinder 8 (B4) indicates temperature has reached the Low Temperature Warning threshold. | No effect on engine performance.
Cylinder 8 (B4) Exhaust Temperature Circuit - Single Turbocharger

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to two CM850 modules, one for each bank, which sends this information to the CM700 module via the Proprietary data link. The temperature sensor is a thermocouple device which converts its output to a 0 - 5 VDC thermister type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. The low warning alarm can be an indication of misfiring within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shut down.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning can recover the exhaust temperature for a short period (1 - 2 days) giving time for a repair action to be coordinated.

An exhaust temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature sensor or harness to that sensor may be faulty. If shown on all cylinders for one bank of the engine, either the exhaust temperature sensor 5 volt supply or return circuits or CM850 module may be at fault. If -17.78° (C or F) is shown on all engine cylinders, then the fault may be with the Proprietary Data Link which connects both CM850 modules to the CM700 module. The engine will continue to run for a short period and will then shut down and will display the appropriate fault code.

Refer to Troubleshooting Fault Code 2462 (Single Turbocharger).

Last Modified: 09-Jul-2010


Fault Code Path Selection

FAULT CODE 2463
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2463mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2463st

Last Modified: 07-Oct-2010


Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2463 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2463 PID: SPN: 1146 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor on cylinder 10 (B5) indicates temperature has reached the Low Temperature Warning threshold. | No effect on engine performance.
Cylinder 10 (B5) Exhaust Temperature Circuit - Multiple Turbocharger Engines

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. The low warning alarm can be an indication of misfiring within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shut down.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning can recover the exhaust temperature for a short period (1 -2 days) giving time for a repair action to be coordinated.

An exhaust temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature probe or harness can be faulty. If shown on all cylinders, either the J1939 data link circuit, exhaust temperature return circuit or CENSE™ can be at fault. The engine will continue to run for a short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code 2463 (Multiple Turbochargers).

Last Modified: 09-Jul-2010


Exhaust Gas Temperature Cylinder 10 (B5) Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2463 - Single Turbocharger

Exhaust Gas Temperature Cylinder 10 (B5) Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 10 (B5) Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2463 PID: SPN: 1138 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor on cylinder 10 (B5) indicates temperature has reached the Low Temperature Warning threshold. | No effect on engine performance.
Cylinder 10 (B5) Exhaust Temperature Circuit - Single Turbocharger

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to two CM850 modules, one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device which converts its output to a 0 - 5-VDC thermister type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. The low warning alarm can be an indication of misfiring within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shut down.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning can recover the exhaust temperature for a short period (1 - 2 days) giving time for a repair action to be coordinated.

An exhaust temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature sensor or harness to that sensor may be faulty. If shown on all cylinders for one bank of the engine, either the exhaust temperature sensor 5 volt supply or return circuits, or the CM850 module may be at fault. If -17.78° (C or F) is shown on all engine cylinders, then the fault may be with the proprietary data link which connects both CM850 modules to the CM700 module. The engine will continue to run for a short period and will then shut down and will display the appropriate fault code.

Refer to Troubleshooting Fault Code 2463 (Single Turbocharger).

Last Modified: 09-Jul-2010


Fault Code Path Selection

FAULT CODE 2464
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2464mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2464st

Last Modified: 07-Oct-2010


Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2464 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2464 PID: SPN: 1148 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor on cylinder 12 (B6) indicates temperature has reached the Low Temperature Warning threshold. | No effect on engine performance.
Cylinder 12 (B6) Exhaust Temperature Circuit - Multiple Turbocharger Engines

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. The low warning alarm can be an indication of misfiring within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shut down.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning can recover the exhaust temperature for a short period (1 -2 days) giving time for a repair action to be coordinated.

An exhaust temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature probe or harness can be faulty. If shown on all cylinders, either the J1939 data link circuit, exhaust temperature return circuit or CENSE™ can be at fault. The engine will continue to run for a short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code 2464 (Multiple Turbochargers).

Last Modified: 09-Jul-2010


Exhaust Gas Temperature Cylinder 12 (B6) Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2464 - Single Turbocharger

Exhaust Gas Temperature Cylinder 12 (B6) Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 12 (B6) Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2464 PID: SPN: 1148 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor on cylinder 12 (B6) indicates temperature has reached the Low Temperature Warning threshold. | No effect on engine performance.
Cylinder 12 (B6) Exhaust Temperature Circuit - Single Turbocharger

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to two CM850 modules, one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device which converts its output to a 0 - 5-VDC thermister type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. The low warning alarm can be an indication of misfiring within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shut down.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning can recover the exhaust temperature for a short period (1 - 2 days) giving time for a repair action to be coordinated.

An exhaust temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature sensor or harness to that sensor may be faulty. If shown on all cylinders for one bank of the engine, either the exhaust temperature sensor 5 volt supply or return circuits, or the CM850 module may be at fault. If -17.78° (C or F) is shown on all engine cylinders, then the fault may be with the proprietary data link which connects both CM850 modules to the CM700 module. The engine will continue to run for a short period and will then shut down and will display the appropriate fault code.

Refer to Troubleshooting Fault Code 2464 (Single Turbocharger).

Last Modified: 09-Jul-2010


Fault Code Path Selection

FAULT CODE 2465
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2465mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2465st

Last Modified: 08-Oct-2010


Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2465 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2465 PID: SPN: 1150 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor on cylinder 14 (B7) indicates temperature has reached the Low Temperature Warning threshold. | No effect on engine performance.
Cylinder 14 (B7) Exhaust Temperature Circuit - Multiple Turbocharger Engines

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. The low warning alarm can be an indication of misfiring within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shut down.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning can recover the exhaust temperature for a short period (1 -2 days) giving time for a repair action to be coordinated.

An exhaust temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature probe or harness can be faulty. If shown on all cylinders, either the J1939 data link circuit, exhaust temperature return circuit or CENSE™ can be at fault. The engine will continue to run for a short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code 2465 (Multiple Turbochargers).

Last Modified: 09-Jul-2010


Exhaust Gas Temperature Cylinder 14 (B7) Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2465 - Single Turbocharger

Exhaust Gas Temperature Cylinder 14 (B7) Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 14 (B7) Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2465 PID: SPN: 1150 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor on cylinder 14 (B7) indicates temperature has reached the Low Temperature Warning threshold. | No effect on engine performance.
Cylinder 14 (B7) Exhaust Temperature Circuit - Single Turbocharger Engines

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to two CM850 modules, one for each bank, which sends this information to the CM700 module via the Proprietary data link. The temperature sensor is a thermocouple device which converts its output to a 0 - 5-VDC thermister type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. The low warning alarm can be an indication of misfiring within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shut down.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning can recover the exhaust temperature for a short period (1 - 2 days) giving time for a repair action to be coordinated.

An exhaust temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature sensor or harness to that sensor may be faulty. If shown on all cylinders for one bank of the engine, either the exhaust temperature sensor 5 volt supply or return circuits, or the CM850 module may be at fault. If -17.78° (C or F) is shown on all engine cylinders, then the fault may be with the proprietary data link which connects both CM850 modules to the CM700 module. The engine will continue to run for a short period and will then shut down and will display the appropriate fault code.

Refer to Troubleshooting Fault Code 2465 (Single Turbocharger).

Last Modified: 09-Jul-2010


Fault Code Path Selection

FAULT CODE 2466
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2466mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2466st

Last Modified: 08-Oct-2010


Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2466 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2466 PID: SPN: 1152 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor on cylinder 16 (B8) indicates temperature has reached the Low Temperature Warning threshold. | No effect on engine performance.
Cylinder 16 (B8) Exhaust Temperature Circuit - Multiple Turbocharger Engines

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. The low warning alarm can be an indication of misfiring within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shut down.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning can recover the exhaust temperature for a short period (1 -2 days) giving time for a repair action to be coordinated.

An exhaust temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature probe or harness can be faulty. If shown on all cylinders, either the J1939 data link circuit, exhaust temperature return circuit or CENSE™ can be at fault. The engine will continue to run for a short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code 2466 (Multiple Turbochargers).

Last Modified: 09-Jul-2010


Exhaust Gas Temperature Cylinder 16 (B8) Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2466 - Single Turbocharger

Exhaust Gas Temperature Cylinder 16 (B8) Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Exhaust Gas Temperature Cylinder 16 (B8) Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2466 PID: SPN: 1152 FMI: 18 LAMP: Warning SRT: | The exhaust gas temperature sensor on cylinder 16 (B8) indicates temperature has reached the Low Temperature Warning threshold. | No effect on engine performance.
Cylinder 16 (B8) Exhaust Temperature Circuit - Single Turbocharger

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to two CM850 modules, one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device which converts its output to a 0 - 5-VDC thermister type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. The low warning alarm can be an indication of misfiring within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shut down.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning can recover the exhaust temperature for a short period (1 - 2 days) giving time for a repair action to be coordinated.

An exhaust temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature sensor or harness to that sensor may be faulty. If shown on all cylinders for one bank of the engine, either the exhaust temperature sensor 5 volt supply or return circuits, or the CM850 module may be at fault. If -17.78° (C or F) is shown on all engine cylinders, then the fault may be with the proprietary data link which connects both CM850 modules to the CM700 module. The engine will continue to run for a short period and will then shut down and will display the appropriate fault code.

Refer to Troubleshooting Fault Code 2466 (Single Turbocharger).

Last Modified: 09-Jul-2010


Fault Code Path Selection

FAULT CODE 2469
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2469mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2469st

Last Modified: 08-Oct-2010


Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2469 (Multiple Turbochargers)

Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2469 (Multiple Turbochargers) SPN: 1137 FMI: 18 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Below Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor on cylinder 1 (A1) indicated temperature has reached the low temperature warning threshold. | No effect on engine performance.
Cylinder 1 (A1) Exhaust Temperature Circuit (Multiple Turbocharger Engines)

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. The low warning alarm can be an indication of mis-firing with the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning can recover the exhaust temperature for a short period (1 to 2 days) giving time for a repair action to be coordinated.

An exhaust temperature -17.78°(C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature sensor or harness may be faulty. If shown on all cylinders, either the J1939 data link circuit, exhaust temperature return circuit, or CENSE™ may be at fault. The engine will continue to run for short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code t05-2469

Last Modified: 27-Sep-2016


Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2469 (Single Turbocharger)

Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2469 (Single Turbocharger) SPN: 1137 FMI: 18 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Below Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor on cylinder 1 (A1) indicated temperature has reached the low temperature warning threshold. | No effect on engine performance.
Cylinder 1 (A1) Exhaust Temperature Circuit (Single Turbocharger Engines)

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to two CM850 modules, one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device which converts its output to a 0 to 5-VDC thermistor type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. The low warning alarm can be an indication of mis-firing with the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning can recover the exhaust temperature for a short period (1 to 2 days) giving time for a repair action to be coordinated.

An exhaust temperature -17.78°(C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature sensor or harness may be faulty. If shown on all cylinders for one bank of the engine, either the exhaust temperature sensor 5 volt supply or return circuits, or CM850 module may be at fault. If -17.78°(C or F) is shown on all engine cylinders, then the fault may be with a proprietary data link which connects both CM850 modules to the CM700 module. The engine will continue to run for a short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code t05-2469

Last Modified: 27-Sep-2016


Fault Code Path Selection

FAULT CODE 2471
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2471mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2471st

Last Modified: 08-Oct-2010


Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2471 (Multiple Turbochargers)

Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2471 (Multiple Turbochargers) SPN: 1139 FMI: 18 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Below Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor on cylinder 3 (A2) indicated temperature has reached the low temperature warning threshold. | No effect on engine performance.
Cylinder 3 (A2) Exhaust Temperature Circuit (Multiple Turbocharger Engines)

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30 mVDC) that varies with the temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. The low warning alarm can be an indication of mis-firing with the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning can recover the exhaust temperature for a short period (1 to 2 days) giving time for a repair action to be coordinated.

An exhaust temperature -17.78°(C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature sensor or harness may be damaged. If shown on all cylinders, either the J1939 data link circuit, exhaust temperature return circuit, or CENSE™ may be at fault. The engine will continue to run for short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code t05-2471

Last Modified: 30-Jun-2010


Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2471 (Single Turbocharger)

Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2471 (Single Turbocharger) SPN: 1139 FMI: 18 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Below Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor on cylinder 3 (A2) indicated temperature has reached the low temperature warning threshold. | No effect on engine performance.
Cylinder 3 (A2) Exhaust Temperature Circuit (Single Turbocharger Engines)

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to two CM850 modules, one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device which converts its output to a 0 to 5-VDC thermistor type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. The low warning alarm can be an indication of mis-firing with the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning can recover the exhaust temperature for a short period (1 to 2 days) giving time for a repair action to be coordinated.

An exhaust temperature -17.78°(C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature sensor or harness may be faulty. If shown on all cylinders for one bank of the engine, either the exhaust temperature sensor 5 volt supply or return circuits, or CM850 module may be at fault. If -17.78°(C or F) is shown on all engine cylinders, then the fault may be with the proprietary data link which connects both CM850 modules to the CM700 module. The engine will continue to run for a short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code t05-2471

Last Modified: 30-Jun-2010


Fault Code Path Selection

FAULT CODE 2472
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2472mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2472st

Last Modified: 08-Oct-2010


Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2472 (Multiple Turbochargers)

Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2472 (Multiple Turbochargers) SPN: 1141 FMI: 18 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Below Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor on cylinder 5 (A3) indicated temperature has reached the low temperature warning threshold. | No effect on engine performance.
Cylinder 5 (A3) Exhaust Temperature Circuit (Multiple Turbocharger Engines)

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30 mVDC) that varies with the temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. The low warning alarm can be an indication of mis-firing with the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning can recover the exhaust temperature for a short period (1 to 2 days) giving time for a repair action to be coordinated.

An exhaust temperature -17.78°(C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature sensor or harness may be damaged. If shown on all cylinders, either the J1939 data link circuit, exhaust temperature return circuit, or CENSE™ may be at fault. The engine will continue to run for short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code t05-2472

Last Modified: 30-Jun-2010


Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2472 (Single Turbocharger)

Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2472 (Single Turbocharger) SPN: 1141 FMI: 18 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Below Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor on cylinder 5 (A3) indicated temperature has reached the low temperature warning threshold. | No effect on engine performance.
Cylinder 5 (A3) Exhaust Temperature Circuit (Single Turbocharger Engines)

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to two CM850 modules, one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device which converts its output to a 0 to 5-VDC thermistor type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. The low warning alarm can be an indication of mis-firing with the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning can recover the exhaust temperature for a short period (1 to 2 days) giving time for a repair action to be coordinated.

An exhaust temperature -17.78°(C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature sensor or harness may be faulty. If shown on all cylinders for one bank of the engine, either the exhaust temperature sensor 5 volt supply or return circuits, or CM850 module may be at fault. If -17.78°(C or F) is shown on all engine cylinders, then the fault may be with the proprietary data link which connects both CM850 modules to the CM700 module. The engine will continue to run for a short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code t05-2472

Last Modified: 30-Jun-2010


Fault Code Path Selection

FAULT CODE 2473
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2473mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2473st

Last Modified: 08-Oct-2010


Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2473 (Multiple Turbochargers)

Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2473 (Multiple Turbochargers) SPN: 1137 FMI: 18 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Below Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor on cylinder 7 (A4) indicated temperature has reached the low temperature warning threshold. | No effect on engine performance.
Cylinder 7 (A4) Exhaust Temperature Circuit (Multiple Turbocharger Engines)

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30 mVDC) that varies with the temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. The low warning alarm can be an indication of mis-firing with the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning can recover the exhaust temperature for a short period (1 to 2 days) giving time for a repair action to be coordinated.

An exhaust temperature -17.78°(C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature sensor or harness may be damaged. If shown on all cylinders, either the J1939 data link circuit, exhaust temperature return circuit, or CENSE™ may be at fault. The engine will continue to run for short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code t05-2473

Last Modified: 30-Jun-2010


Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2473 (Single Turbocharger)

Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2473 (Single Turbocharger) SPN: 1143 FMI: 18 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Below Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor on cylinder 7 (A4) indicated temperature has reached the low temperature warning threshold. | No effect on engine performance.
Cylinder 7 (A3) Exhaust Temperature Circuit (Single Turbocharger Engines)

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to two CM850 modules, one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device which converts its output to a 0 to 5-VDC thermistor type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. The low warning alarm can be an indication of mis-firing with the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning can recover the exhaust temperature for a short period (1 to 2 days) giving time for a repair action to be coordinated.

An exhaust temperature -17.78°(C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature sensor or harness may be faulty. If shown on all cylinders for one bank of the engine, either the exhaust temperature sensor 5 volt supply or return circuits, or CM850 module may be at fault. If -17.78°(C or F) is shown on all engine cylinders, then the fault may be with the proprietary data link which connects both CM850 modules to the CM700 module. The engine will continue to run for a short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code t05-2473

Last Modified: 30-Jun-2010


Fault Code Path Selection

FAULT CODE 2475
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2475mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2475st

Last Modified: 08-Oct-2010


Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2475 (Multiple Turbochargers)

Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2475 (Multiple Turbochargers) SPN: 1145 FMI: 18 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Below Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor on cylinder 9 (A5) indicated temperature has reached the low temperature warning threshold. | No effect on engine performance.
Cylinder 9 (A5) Exhaust Temperature Circuit (Multiple Turbocharger Engines)

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30-mVDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. The low warning alarm can be an indication of mis-firing with the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning can recover the exhaust temperature for a short period (1 to 2 days), giving time for a repair action to be coordinated.

An exhaust temperature -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature sensor or harness may be faulty. If shown on all cylinders, either the J1939 data link circuit, exhaust temperature return circuit, or CENSE™ may be at fault. The engine will continue to run for short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code t05-2475

Last Modified: 30-Jun-2010


Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2475 (Single Turbocharger)

Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2475 SPN: 11453 FMI: 18 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 9 (A54) - Data Valid But Below Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor on cylinder 9 (A5) indicated temperature has reached the low temperature warning threshold. | No effect on engine performance.
Cylinder 9 (A3) Exhaust Temperature Circuit (Single Turbocharger Engines)

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to two CM850 modules, one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device which converts its output to a 0 to 5-VDC thermistor type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. The low warning alarm can be an indication of misfiring with the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning can recover the exhaust temperature for a short period (1 to 2 days) giving time for a repair action to be coordinated.

An exhaust temperature -17.78°(C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature sensor or harness may be faulty. If shown on all cylinders for one bank of the engine, either the exhaust temperature sensor 5 volt supply or return circuits, or CM850 module may be at fault. If -17.78°(C or F) is shown on all engine cylinders, then the fault may be with the proprietary data link which connects both CM850 modules to the CM700 module. The engine will continue to run for a short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code t05-2475

Last Modified: 30-Jun-2010


Fault Code Path Selection

FAULT CODE 2476
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2476mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2476st

Last Modified: 08-Oct-2010


Exhaust Gas Temperature Cylinder 11(A6) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2476 (Multiple Turbochargers)

Exhaust Gas Temperature Cylinder 11(A6) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2476 (Multiple Turbochargers) SPN: 1147 FMI: 18 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 11(A6) - Data Valid But Below Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor on cylinder 11 (A6) indicated temperature has reached the low temperature warning threshold. | No effect on engine performance.
Cylinder 11(A6) Exhaust Temperature Circuit (Multiple Turbocharger Engines)

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30-mVDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. The low warning alarm can be an indication of mis-firing with the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning can recover the exhaust temperature for a short period (1 to 2 days), giving time for a repair action to be coordinated.

An exhaust temperature -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature sensor or harness may be faulty. If shown on all cylinders, either the J1939 data link circuit, exhaust temperature return circuit, or CENSE™ may be at fault. The engine will continue to run for short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code t05-2476

Last Modified: 30-Jun-2010


Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2476 (Single Turbocharger)

Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2476 SPN: 1147 FMI: 18 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Below Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor on cylinder 11 (A6) indicated temperature has reached the low temperature warning threshold. | No effect on engine performance.
Cylinder 11 (A6) Exhaust Temperature Circuit (Single Turbocharger Engines)

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to two CM850 modules, one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device which converts its output to a 0 to 5-VDC thermistor type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. The low warning alarm can be an indication of misfiring with the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning can recover the exhaust temperature for a short period (1 to 2 days) giving time for a repair action to be coordinated.

An exhaust temperature -17.78°(C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature sensor or harness may be faulty. If shown on all cylinders for one bank of the engine, either the exhaust temperature sensor 5 volt supply or return circuits, or CM850 module may be at fault. If -17.78°(C or F) is shown on all engine cylinders, then the fault may be with the proprietary data link which connects both CM850 modules to the CM700 module. The engine will continue to run for a short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code t05-2476

Last Modified: 30-Jun-2010


Fault Code Path Selection

FAULT CODE 2477
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2477mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2477st

Last Modified: 08-Oct-2010


Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2477 (Multiple Turbochargers)

Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2477 (Multiple Turbochargers) SPN: 1149 FMI: 18 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Below Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor on cylinder 13 (A7) indicated temperature has reached the low temperature warning threshold. | No effect on engine performance.
Cylinder 13 (A7) Exhaust Temperature Circuit (Multiple Turbocharger Engines)

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30-mVDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. The low warning alarm can be an indication of misfiring with the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning can recover the exhaust temperature for a short period (1 to 2 days), giving time for a repair action to be coordinated.

An exhaust temperature -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature sensor or harness may be faulty. If shown on all cylinders, either the J1939 data link circuit, exhaust temperature return circuit, or CENSE™ may be at fault. The engine will continue to run for short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code t05-2477mt

Last Modified: 10-Jun-2013


Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2477 (Single Turbocharger)

Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2477 SPN: 1149 FMI: 18 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Below Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor on cylinder 13 (A7) indicated temperature has reached the low temperature warning threshold. | No effect on engine performance.
Cylinder 13 (A6) Exhaust Temperature Circuit (Single Turbocharger Engines)

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to two CM850 modules, one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device which converts its output to a 0 to 5-VDC thermistor type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. The low warning alarm can be an indication of misfiring with the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning can recover the exhaust temperature for a short period (1 to 2 days) giving time for a repair action to be coordinated.

An exhaust temperature -17.78°(C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature sensor or harness may be faulty. If shown on all cylinders for one bank of the engine, either the exhaust temperature sensor 5 volt supply or return circuits, or CM850 module may be at fault. If -17.78°(C or F) is shown on all engine cylinders, then the fault may be with the proprietary data link which connects both CM850 modules to the CM700 module. The engine will continue to run for a short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code t05-2477st

Last Modified: 10-Jun-2013


Fault Code Path Selection

FAULT CODE 2478
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2478mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2478st

Last Modified: 08-Oct-2010


Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2478 (Multiple Turbochargers)

Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2478 SPN: 1151 FMI: 18 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Below Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor on cylinder 15 (A8) indicated temperature has reached the low temperature warning threshold. | No effect on engine performance.
Cylinder 15 (A8) Exhaust Temperature Circuit (Multiple Turbocharger Engines)

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30-mVDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. The low warning alarm can be an indication of misfiring with the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning can recover the exhaust temperature for a short period (1 to 2 days), giving time for a repair action to be coordinated.

An exhaust temperature -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature sensor or harness may be faulty. If shown on all cylinders, either the J1939 data link circuit, exhaust temperature return circuit, or CENSE™ may be at fault. The engine will continue to run for short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code t05-2478

Last Modified: 30-Jun-2010


Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2478 (Single Turbocharger)

Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2478 SPN: 1151 FMI: 18 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Below Normal Operating Range - Moderately Severe Level. The exhaust gas temperature sensor on cylinder 15 (A8) indicated temperature has reached the low temperature warning threshold. | No effect on engine performance.
Cylinder 15 (A8) Exhaust Temperature Circuit (Single Turbocharger Engines)

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to two CM850 modules, one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device which converts its output to a 0 to 5-VDC thermistor type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. The low warning alarm can be an indication of misfiring with the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning can recover the exhaust temperature for a short period (1 to 2 days) giving time for a repair action to be coordinated.

An exhaust temperature -17.78°(C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust temperature sensor or harness may be faulty. If shown on all cylinders for one bank of the engine, either the exhaust temperature sensor 5 volt supply or return circuits, or CM850 module may be at fault. If -17.78°(C or F) is shown on all engine cylinders, then the fault may be with the proprietary data link which connects both CM850 modules to the CM700 module. The engine will continue to run for a short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code t05-2478

Last Modified: 30-Jun-2010


Start Block Condition

FAULT CODE 2482

Start Block Condition

Printable Version Printable Version

Overview

Start Block Condition

CODE | REASON | EFFECT
Fault Code: 2482 PID: SPN: FMI: 11 LAMP: Shutdown SRT: | Start Block Condition. A start attempt has been made while a start block condition was active. | The engine will not start.
Start Block Condition - Multiple Turbochargers
Start Block Condition - Single Turbocharger

Circuit Description

The starter motor is commanded to run by the CM700. If an attempt is made to start the engine while a start block condition is active, the engine will not start and the start block condition fault will be set.

In the above, starter relay coil is commanded to close by the CM700. This sends + 24-VDC to the starter solenoid to engage the starter.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Common start block conditions are having the barring gear engaged or attempting to start the engine too quickly after a keyswitch reset.

Refer to Troubleshooting Fault Code t05-2482

Last Modified: 30-Jun-2010


Continuous Starter Failure

FAULT CODE 2483

Continuous Starter Failure

Printable Version Printable Version

Overview

Continuous Starter Failure

CODE | REASON | EFFECT
Fault Code: 2483 PID: SPN: FMI: 7 LAMP: Shutdown SRT: | Continuous Starter Failure. The starter motor has been commanded to run and is not running. | The engine will not start.
Continuous Starter Failure - Multiple Turbochargers
Continuous Starter Failure - Single Turbocharger

Circuit Description

The starter motor is commanded to run by the CM700. If the CM700 commands the starter to run three times and does not see engine speed during any attempt, the continuous starter failure fault is set.

The starter relay coil is energized by the CM700. This sends + 24-VDC to the starter solenoid to engage the starter.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

A relay in the DC interface panel determines which pins in the starter connection are used for the start signal. The pins depend on whether or not an air starter or an electric starter is in use. Refer to the engine wiring diagram for the appropriate circuit.

Refer to Troubleshooting Fault Code t05-2483

Last Modified: 30-Jun-2010


Exhaust Gas Temperature Cylinder 1 (A1) - Deviation Error

FAULT CODE 2484 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 1 (A1) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2484 PID: SPN: 1137 FMI: 10 LAMP: Warning SRT: | Exhaust Temperature Cylinder 1 (A1) - Deviation Error. The difference between cylinder 1 exhaust gas temperature and the average engine exhaust gas temperature has exceeded the Critical threshold. | The engine will shut down.
Cylinder 1 (A1) Exhaust Temperature Circuit - Multiple Turbocharger Engines

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30mVDC) that varies with temperature.

To provide individual cylinder exhaust temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a ‘Cylinder 1 (A1) Temperature Deviation’ error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66°C or 119°F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82°C or 148°F.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2484mt.

Last Modified: 10-Dec-2010


Exhaust Gas Temperature Cylinder 1 (A1) - Deviation Error

FAULT CODE 2484 - Single Turbocharger

Exhaust Gas Temperature Cylinder 1 (A1) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2484 PID: SPN: 1137 FMI: 10 LAMP: Shutdown SRT: | Exhaust Gas Temperature Cylinder 1 (A1) - Deviation Error. The difference between cylinder 1 (A1) exhaust gas temperature and the average left bank exhaust gas temperature has exceeded the critical threshold. | The engine will shut down.
Exhaust Gas Temperature Cylinder 1 (A1) Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules – one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device which converts its output to a 0 to 5-VDC thermister type signal which is proportional to temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a ‘Cylinder 1 (A1) Temperature Deviation’ error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66° C [119° F], and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82° C [148° F].

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Use the engine diagrams for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a failing spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2484 (Single Turbocharger).

Last Modified: 24-Mar-2011


Fault Code Path Selection

FAULT CODE 2484
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2484-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2484-st

Last Modified: 05-Oct-2007


Exhaust Gas Temperature Cylinder 3 (A2) - Deviation Error

FAULT CODE 2485 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 3 (A2) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2485 PID: SPN: 1139 FMI: 10 LAMP: Warning SRT: | Exhaust Temperature Cylinder 3 (A2) - Deviation Error. The difference between cylinder 3 exhaust gas temperature and the average engine exhaust gas temperature has exceeded the Critical threshold. | The engine will shut down.
Cylinder 3 (A2) Exhaust Temperature Circuit - Multiple Turbocharger Engines

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30mVDC) that varies with temperature.

To provide individual cylinder exhaust temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a ‘Cylinder 3 (A2) Temperature Deviation’ error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66°C or 119°F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82°C or 148°F.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2485mt.

Last Modified: 21-Dec-2010


Exhaust Gas Temperature Cylinder 3 (A2) - Deviation Error

FAULT CODE 2485 - Single Turbocharger

Exhaust Gas Temperature Cylinder 3 (A2) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2485 PID: SPN: 1139 FMI: 10 LAMP: Shutdown SRT: | Exhaust Gas Temperature Cylinder 3 (A2) - Deviation Error. The difference between Cylinder 3 (A2) exhaust gas temperature and the average left bank exhaust gas temperature has exceeded the critical threshold. | The engine will shut down.
Exhaust Gas Temperature Cylinder 3 (A2) Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules – one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device which converts its output to a 0 to 5-VDC thermister type signal which is proportional to temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a ‘Cylinder 3 (A2) Temperature Deviation’ error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66° C [119° F], and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82° C [148° F].

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a failing spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2485 (Single Turbocharger).

Last Modified: 25-Mar-2011


Fault Code Path Selection

FAULT CODE 2485
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2485-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2485-st

Last Modified: 05-Oct-2007


Exhaust Gas Temperature Cylinder 5 (A3) - Deviation Error

FAULT CODE 2486 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 5 (A3) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2486 PID: SPN: 1141 FMI: 10 LAMP: Warning SRT: | Exhaust Temperature Cylinder 5 (A3) - Deviation Error. The difference between cylinder 5 exhaust gas temperature and the average engine exhaust gas temperature has exceeded the Critical threshold. | The engine will shut down.
Cylinder 5 (A3) Exhaust Temperature Circuit - Multiple Turbocharger Engines

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30mVDC) that varies with temperature.

To provide individual cylinder exhaust temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a ‘Cylinder 5 (A3) Temperature Deviation’ error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66°C or 119°F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82°C or 148°F.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2486mt.

Last Modified: 21-Dec-2010


Exhaust Gas Temperature Cylinder 5 (A3) - Deviation Error

FAULT CODE 2486 - Single Turbocharger

Exhaust Gas Temperature Cylinder 5 (A3) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2486 PID: SPN: 1141 FMI: 10 LAMP: Shutdown SRT: | Exhaust Gas Temperature Cylinder 5 (A3) - Deviation Error. The difference between Cylinder 5 (A3) exhaust gas temperature and the average left bank exhaust gas temperature has exceeded the critical threshold. | The engine will shut down.
Exhaust Gas Temperature Cylinder 5 (A3) Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules – one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device which converts its output to a 0 to 5-VDC thermister type signal which is proportional to temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a cylinder 5 (A3) Temperature Deviation’ error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66° C [119° F], and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82° C [148° F].

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a failing spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2486 (Single Turbocharger).

Last Modified: 25-Mar-2011


Fault Code Path Selection

FAULT CODE 2486
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2486-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2486-st

Last Modified: 05-Oct-2007


Exhaust Gas Temperature Cylinder 7 (A4) - Deviation Error

FAULT CODE 2487 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 7 (A4) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2487 PID: SPN: 1143 FMI: 10 LAMP: Warning SRT: | Exhaust Temperature Cylinder 7 (A4) - Deviation Error. The difference between cylinder 7 exhaust gas temperature and the average engine exhaust gas temperature has exceeded the Critical threshold. | The engine will shut down.
Cylinder 7 (A4) Exhaust Temperature Circuit - Multiple Turbocharger Engines

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30mVDC) that varies with temperature.

To provide individual cylinder exhaust temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a ‘Cylinder 7 (A4) Temperature Deviation’ error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66°C or 119°F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82°C or 148°F.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2487mt.

Last Modified: 21-Dec-2010


Exhaust Gas Temperature Cylinder 7 (A4) - Deviation Error

FAULT CODE 2487 - Single Turbocharger

Exhaust Gas Temperature Cylinder 7 (A4) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2487 PID: SPN: 1143 FMI: 10 LAMP: Shutdown SRT: | Exhaust Gas Temperature Cylinder 7 (A4) - Deviation Error. The difference between Cylinder 7 (A4) exhaust gas temperature and the average left bank exhaust gas temperature has exceeded the critical threshold. | The engine will shut down.
Exhaust Gas Temperature Cylinder 7 (A4) Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules – one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device which converts its output to a 0 to 5-VDC thermister type signal which is proportional to temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a ‘Cylinder 7 (A4) Temperature Deviation’ error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66° C [119° F], and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82° C [148° F].

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a failing spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2487 (Single Turbocharger).

Last Modified: 25-Mar-2011


Fault Code Path Selection

FAULT CODE 2487
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2487-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2487-st

Last Modified: 05-Oct-2007


Exhaust Gas Temperature Cylinder 9 (A5) - Deviation Error

FAULT CODE 2488 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 9 (A5) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2488 PID: SPN: 1145 FMI: 10 LAMP: Warning SRT: | Exhaust Temperature Cylinder 9 (A5) - Deviation Error. The difference between cylinder 9 exhaust gas temperature and the average engine exhaust gas temperature has exceeded the Critical threshold. | The engine will shut down.
Cylinder 9 (A5) Exhaust Temperature Circuit - Multiple Turbocharger Engines

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30mVDC) that varies with temperature.

To provide individual cylinder exhaust temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a ‘Cylinder 9 (A5) Temperature Deviation’ error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66°C or 119°F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82°C or 148°F.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2488mt.

Last Modified: 21-Dec-2010


Exhaust Gas Temperature Cylinder 9 (A5) - Deviation Error

FAULT CODE 2488 - Single Turbocharger

Exhaust Gas Temperature Cylinder 9 (A5) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2488 PID: SPN: 1145 FMI: 10 LAMP: Shutdown SRT: | Exhaust Gas Temperature Cylinder 9 (A5) - Deviation Error. The difference between Cylinder 9 (A5) exhaust gas temperature and the average left bank exhaust gas temperature has exceeded the critical threshold. | The engine will shut down.
Exhaust Gas Temperature Cylinder 9 (A5) Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules – one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device which converts its output to a 0 to 5-VDC thermister type signal which is proportional to temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a ‘Cylinder 9 (A5) Temperature Deviation’ error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66° C [119° F], and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82° C [148° F].

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a failing spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2488 (Single Turbocharger).

Last Modified: 25-Mar-2011


Fault Code Path Selection

FAULT CODE 2488
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2488-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2488-st

Last Modified: 05-Oct-2007


Exhaust Gas Temperature Cylinder 11 (A6) - Deviation Error

FAULT CODE 2489 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 11 (A6) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2489 PID: SPN: 1147 FMI: 10 LAMP: Warning SRT: | Exhaust Temperature Cylinder 11 (A6) - Deviation Error. The difference between cylinder 11 exhaust gas temperature and the average engine exhaust gas temperature has exceeded the Critical threshold. | The engine will shut down.
Cylinder 11 (A6) Exhaust Temperature Circuit - Multiple Turbocharger Engines

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30mVDC) that varies with temperature.

To provide individual cylinder exhaust temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a ‘Cylinder 11 (A6) Temperature Deviation’ error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66°C or 119°F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82°C or 148°F.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2489mt.

Last Modified: 21-Dec-2010


Exhaust Gas Temperature Cylinder 11 (A6) - Deviation Error

FAULT CODE 2489- Single Turbocharger

Exhaust Gas Temperature Cylinder 11 (A6) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2484 PID: SPN: 1147 FMI: 10 LAMP: Shutdown SRT: | Exhaust Gas Temperature Cylinder 11 (A6) - Deviation Error. The difference between Cylinder 11 (A6) exhaust gas temperature and the average left bank exhaust gas temperature has exceeded the critical threshold. | The engine will shut down.
Exhaust Gas Temperature Cylinder 11 (A6) Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules – one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device which converts its output to a 0 to 5-VDC thermister type signal which is proportional to temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a ‘Cylinder 11 (A6) Temperature Deviation’ error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66° C [119° F], and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82° C [148° F].

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a failing spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2489 (Single Turbocharger).

Last Modified: 25-Mar-2011


Fault Code Path Selection

FAULT CODE 2489
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2489-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2489-st

Last Modified: 05-Oct-2007


Exhaust Gas Temperature Cylinder 13 (A7) - Deviation Error

FAULT CODE 2491 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 13 (A7) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2491 PID: SPN: 1149 FMI: 10 LAMP: Warning SRT: | Exhaust Temperature Cylinder 13 (A7) - Deviation Error. The difference between cylinder 13 exhaust gas temperature and the average engine exhaust gas temperature has exceeded the Critical threshold. | The engine will shut down.
Cylinder 13 (A7) Exhaust Temperature Circuit - Multiple Turbocharger Engines

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30mVDC) that varies with temperature.

To provide individual cylinder exhaust temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a ‘Cylinder 13 (A7) Temperature Deviation’ error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66°C or 119°F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82°C or 148°F.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2491mt.

Last Modified: 21-Dec-2010


Exhaust Gas Temperature Cylinder 13 (A7) - Deviation Error

FAULT CODE 2491 - Single Turbocharger

Exhaust Gas Temperature Cylinder 13 (A7) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2491 PID: SPN: 1149 FMI: 10 LAMP: Shutdown SRT: | Exhaust Gas Temperature Cylinder 13 (A7) - Deviation Error. The difference between Cylinder 13 (A7) exhaust gas temperature and the average left bank exhaust gas temperature has exceeded the critical threshold. | The engine will shut down.
Exhaust Gas Temperature Cylinder 13 (A7) Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules – one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device which converts its output to a 0 to 5-VDC thermister type signal which is proportional to temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a ‘Cylinder 13 (A7) Temperature Deviation’ error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66° C [119° F], and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82° C [148° F].

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a failing spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2491 (Single Turbocharger).

Last Modified: 25-Mar-2011


Fault Code Path Selection

FAULT CODE 2491
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2491-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2491-st

Last Modified: 05-Oct-2007


Exhaust Gas Temperature Cylinder 15 (A8) - Deviation Error

FAULT CODE 2492 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 15 (A8) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2492 PID: SPN: 1151 FMI: 10 LAMP: Warning SRT: | Exhaust Temperature Cylinder 15 (A8) - Deviation Error. The difference between cylinder 15 exhaust gas temperature and the average engine exhaust gas temperature has exceeded the Critical threshold. | The engine will shut down.
Cylinder 15 (A8) Exhaust Temperature Circuit - Multiple Turbocharger Engines

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30mVDC) that varies with temperature.

To provide individual cylinder exhaust temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a ‘Cylinder 15 (A8) Temperature Deviation’ error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66°C or 119°F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82°C or 148°F.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2492mt.

Last Modified: 21-Dec-2010


Exhaust Gas Temperature Cylinder 15 (A8) - Deviation Error

FAULT CODE 2492 - Single Turbocharger

Exhaust Gas Temperature Cylinder 15 (A8) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2492 PID: SPN: 1151 FMI: 10 LAMP: Shutdown SRT: | Exhaust Gas Temperature Cylinder 15 (A8) - Deviation Error. The difference between Cylinder 15 (A8) exhaust gas temperature and the average left bank exhaust gas temperature has exceeded the critical threshold. | The engine will shut down.
Exhaust Gas Temperature Cylinder 15 (A8) Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules – one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device which converts its output to a 0 to 5-VDC thermister type signal which is proportional to temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a ‘Cylinder 15 (A8) Temperature Deviation’ error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66° C [119° F], and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82° C [148° F].

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a failing spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2492 (Single Turbocharger).

Last Modified: 25-Mar-2011


Fault Code Path Selection

FAULT CODE 2492
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2492-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2492-st

Last Modified: 12-May-2009


Exhaust Gas Temperature Cylinder 2 (B1) - Deviation Error

FAULT CODE 2494 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 2 (B1) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2494 PID: SPN: 1138 FMI: 10 LAMP: Warning SRT: | Exhaust Temperature Cylinder 2 (B1) - Deviation Error. The difference between cylinder 1 exhaust gas temperature and the average engine exhaust gas temperature has exceeded the Critical threshold. | The engine will shut down.
Cylinder 2 (B1) Exhaust Temperature Circuit - Multiple Turbocharger Engines

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30mVDC) that varies with temperature.

To provide individual cylinder exhaust temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a ‘Cylinder 2 (B1) Temperature Deviation’ error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66°C or 119°F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82°C or 148°F.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2494mt.

Last Modified: 21-Dec-2010


Exhaust Gas Temperature Cylinder 2 (B1) - Deviation Error

FAULT CODE 2494 - Single Turbocharger

Exhaust Gas Temperature Cylinder 2 (B1) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2494 PID: SPN: 1138 FMI: 10 LAMP: Shutdown SRT: | Exhaust Gas Temperature Cylinder 2 (B1) - Deviation Error. The difference between Cylinder 2 (B1) exhaust gas temperature and the average left bank exhaust gas temperature has exceeded the critical threshold. | The engine will shut down.
Exhaust Gas Temperature Cylinder 2 (B1) Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules – one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device which converts its output to a 0 to 5-VDC thermister type signal which is proportional to temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a ‘Cylinder 2 (B1) Temperature Deviation’ error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66° C [119° F], and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82° C [148° F].

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a failing spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2494 (Single Turbocharger).

Last Modified: 25-Mar-2011


Fault Code Path Selection

FAULT CODE 2494
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2494-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2494-st

Last Modified: 05-Oct-2007


Exhaust Gas Temperature Cylinder 4 (B2) - Deviation Error

FAULT CODE 2495 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 4 (B2) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2495 PID: SPN: 1140 FMI: 10 LAMP: Warning SRT: | Exhaust Temperature Cylinder 4 (B2) - Deviation Error. The difference between cylinder 4 exhaust gas temperature and the average engine exhaust gas temperature has exceeded the Critical threshold. | The engine will shut down.
Cylinder 4 (B2) Exhaust Temperature Circuit - Multiple Turbocharger Engines

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30mVDC) that varies with temperature.

To provide individual cylinder exhaust temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a ‘Cylinder 4 (B2) Temperature Deviation’ error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66°C or 119°F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82°C or 148°F.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2495mt.

Last Modified: 21-Dec-2010


Exhaust Gas Temperature Cylinder 4 (B2) - Deviation Error

FAULT CODE 2495 - Single Turbocharger

Exhaust Gas Temperature Cylinder 4 (B2) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2495 PID: SPN: 1140 FMI: 10 LAMP: Shutdown SRT: | Exhaust Gas Temperature Cylinder 4 (B2) - Deviation Error. The difference between Cylinder 4 (B2) exhaust gas temperature and the average left bank exhaust gas temperature has exceeded the critical threshold. | The engine will shut down.
Exhaust Gas Temperature Cylinder 4 (B2) Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules – one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device which converts its output to a 0 to 5-VDC thermister type signal which is proportional to temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a ‘Cylinder 4 (B2) Temperature Deviation’ error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66° C [119° F], and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82° C [148° F].

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a failing spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2495 (Single Turbocharger).

Last Modified: 25-Mar-2011


Fault Code Path Selection

FAULT CODE 2495
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2495-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2495-st

Last Modified: 05-Oct-2007


Exhaust Gas Temperature Cylinder 6 (B3) - Deviation Error

FAULT CODE 2496 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 6 (B3) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2496 PID: SPN: 1142 FMI: 10 LAMP: Warning SRT: | Exhaust Temperature Cylinder 6 (B3) - Deviation Error. The difference between cylinder 6 exhaust gas temperature and the average engine exhaust gas temperature has exceeded the Critical threshold. | The engine will shut down.
Cylinder 6 (B3) Exhaust Temperature Circuit - Multiple Turbocharger Engines

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30mVDC) that varies with temperature.

To provide individual cylinder exhaust temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a ‘Cylinder 6 (B3) Temperature Deviation’ error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66°C or 119°F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82°C or 148°F.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2496mt.

Last Modified: 21-Dec-2010


Exhaust Gas Temperature Cylinder 6 (B3) - Deviation Error

FAULT CODE 2496 - Single Turbocharger

Exhaust Gas Temperature Cylinder 6 (B3) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2496 PID: SPN: 1142 FMI: 10 LAMP: Shutdown SRT: | Exhaust Gas Temperature Cylinder 6 (B3) - Deviation Error. The difference between Cylinder 6 (B3) exhaust gas temperature and the average left bank exhaust gas temperature has exceeded the critical threshold. | The engine will shut down.
Exhaust Gas Temperature Cylinder 6 (B3) Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules – one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device which converts its output to a 0 to 5-VDC thermister type signal which is proportional to temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a ‘Cylinder 6 (B3) Temperature Deviation’ error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66° C [119° F], and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82° C [148° F].

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a failing spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2496 (Single Turbocharger).

Last Modified: 25-Mar-2011


Fault Code Path Selection

FAULT CODE 2496
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2496-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2496-st

Last Modified: 05-Oct-2007


Exhaust Gas Temperature Cylinder 8 (B4) - Deviation Error

FAULT CODE 2497 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 8 (B4) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2497 PID: SPN: 1144 FMI: 10 LAMP: Warning SRT: | Exhaust Temperature Cylinder 8 (B4) - Deviation Error. The difference between cylinder 8 exhaust gas temperature and the average engine exhaust gas temperature has exceeded the Critical threshold. | The engine will shut down.
Cylinder 8 (B4) Exhaust Temperature Circuit - Multiple Turbocharger Engines

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30mVDC) that varies with temperature.

To provide individual cylinder exhaust temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a ‘Cylinder 8 (B4) Temperature Deviation’ error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66°C or 119°F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82°C or 148°F.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2497mt.

Last Modified: 21-Dec-2010


Exhaust Gas Temperature Cylinder 8 (B4) - Deviation Error

FAULT CODE 2497 - Single Turbocharger

Exhaust Gas Temperature Cylinder 8 (B4) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2497 PID: SPN: 1144 FMI: 10 LAMP: Shutdown SRT: | Exhaust Gas Temperature Cylinder 8 (B4) - Deviation Error. The difference between Cylinder 8 (B4) exhaust gas temperature and the average left bank exhaust gas temperature has exceeded the critical threshold. | The engine will shut down.
Exhaust Gas Temperature Cylinder 8 (B4) Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules – one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device which converts its output to a 0 to 5-VDC thermister type signal which is proportional to temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a ‘Cylinder 8 (B4) Temperature Deviation’ error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66° C [119° F], and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82° C [148° F].

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a failing spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2497 (Single Turbocharger).

Last Modified: 25-Mar-2011


Fault Code Path Selection

FAULT CODE 2497
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2497-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2497-st

Last Modified: 05-Oct-2007


Exhaust Gas Temperature Cylinder 10 (B5) - Deviation Error

FAULT CODE 2498 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 10 (B5) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2498 PID: SPN: 1146 FMI: 10 LAMP: Warning SRT: | Exhaust Temperature Cylinder 10 (B5) - Deviation Error. The difference between cylinder 10 exhaust gas temperature and the average engine exhaust gas temperature has exceeded the Critical threshold. | The engine will shut down.
Cylinder 10 (B5) Exhaust Temperature Circuit - Multiple Turbocharger Engines

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30mVDC) that varies with temperature.

To provide individual cylinder exhaust temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a ‘Cylinder 10 (B5) Temperature Deviation’ error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66°C or 119°F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82°C or 148°F.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2498mt.

Last Modified: 21-Dec-2010


Exhaust Gas Temperature Cylinder 10 (B5) - Deviation Error

FAULT CODE 2498 - Single Turbocharger

Exhaust Gas Temperature Cylinder 10 (B5) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2498 PID: SPN: 1146 FMI: 10 LAMP: Shutdown SRT: | Exhaust Gas Temperature Cylinder 10 (B5) - Deviation Error. The difference between Cylinder 10 (B5) exhaust gas temperature and the average left bank exhaust gas temperature has exceeded the critical threshold. | The engine will shut down.
Exhaust Gas Temperature Cylinder 10 (B5) Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules – one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device which converts its output to a 0 to 5-VDC thermister type signal which is proportional to temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a ‘Cylinder 10 (B5) Temperature Deviation’ error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66° C [119° F], and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82° C [148° F].

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a failing spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2498 (Single Turbocharger).

Last Modified: 25-Mar-2011


Fault Code Path Selection

FAULT CODE 2498
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2498-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2498-st

Last Modified: 05-Oct-2007


Exhaust Gas Temperature Cylinder 12 (B6) - Deviation Error

FAULT CODE 2499 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 12 (B6) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2499 PID: SPN: 1148 FMI: 10 LAMP: Warning SRT: | Exhaust Temperature Cylinder 12 (B6) - Deviation Error. The difference between cylinder 12 exhaust gas temperature and the average engine exhaust gas temperature has exceeded the Critical threshold. | The engine will shut down.
Cylinder 12 (B6) Exhaust Temperature Circuit - Multiple Turbocharger Engines

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30mVDC) that varies with temperature.

To provide individual cylinder exhaust temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a ‘Cylinder 12 (B6) Temperature Deviation’ error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66°C or 119°F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82°C or 148°F.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2499mt.

Last Modified: 21-Dec-2010


Exhaust Gas Temperature Cylinder 12 (B6) - Deviation Error

FAULT CODE 2499 - Single Turbocharger

Exhaust Gas Temperature Cylinder 12 (B6) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2499 PID: SPN: 1148 FMI: 10 LAMP: Shutdown SRT: | Exhaust Gas Temperature Cylinder 12 (B6) - Deviation Error. The difference between Cylinder 12 (B6) exhaust gas temperature and the average left bank exhaust gas temperature has exceeded the critical threshold. | The engine will shut down.
Exhaust Gas Temperature Cylinder 12 (B6) Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules – one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device which converts its output to a 0 to 5-VDC thermister type signal which is proportional to temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a ‘Cylinder 12 (B6) Temperature Deviation’ error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66° C [119° F], and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82° C [148° F].

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a failing spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2499 (Single Turbocharger).

Last Modified: 25-Mar-2011


Fault Code Path Selection

FAULT CODE 2499
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2499-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2499-st

Last Modified: 05-Oct-2007


Exhaust Gas Temperature Cylinder 14 (B7) - Deviation Error

FAULT CODE 2511 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 14 (B7) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2511 PID: SPN: 1150 FMI: 10 LAMP: Warning SRT: | Exhaust Temperature Cylinder 14 (B7) - Deviation Error. The difference between cylinder 14 exhaust gas temperature and the average engine exhaust gas temperature has exceeded the Critical threshold. | The engine will shut down.
Cylinder 14 (B7) Exhaust Temperature Circuit - Multiple Turbocharger Engines

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30mVDC) that varies with temperature.

To provide individual cylinder exhaust temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a ‘Cylinder 14 (B7) Temperature Deviation’ error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66°C or 119°F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82°C or 148°F.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2511mt.

Last Modified: 21-Dec-2010


Exhaust Gas Temperature Cylinder 14 (B7) - Deviation Error

FAULT CODE 2511 - Single Turbocharger

Exhaust Gas Temperature Cylinder 14 (B7) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2511 PID: SPN: 1150 FMI: 10 LAMP: Shutdown SRT: | Exhaust Gas Temperature Cylinder 14 (B7) - Deviation Error. The difference between Cylinder 14 (B7) exhaust gas temperature and the average left bank exhaust gas temperature has exceeded the critical threshold. | The engine will shut down.
Exhaust Gas Temperature Cylinder 14 (B7) Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules – one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device which converts its output to a 0 to 5-VDC thermister type signal which is proportional to temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a ‘Cylinder 14 (B7) Temperature Deviation’ error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66° C [119° F], and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82° C [148° F].

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a failing spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2511 (Single Turbocharger).

Last Modified: 25-Mar-2011


Fault Code Path Selection

FAULT CODE 2511
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2511-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2511-st

Last Modified: 05-Oct-2007


Exhaust Gas Temperature Cylinder 16 (B8) - Deviation Error

FAULT CODE 2512 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 16 (B8) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2512 PID: SPN: 1152 FMI: 10 LAMP: Warning SRT: | Exhaust Temperature Cylinder 16 (B8) - Deviation Error. The difference between cylinder 16 exhaust gas temperature and the average engine exhaust gas temperature has exceeded the Critical threshold. | The engine will shut down.
Cylinder 16 (B8) Exhaust Temperature Circuit - Multiple Turbocharger Engines

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30mVDC) that varies with temperature.

To provide individual cylinder exhaust temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a ‘Cylinder 16 (B8) Temperature Deviation’ error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66°C or 119°F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82°C or 148°F.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2512mt.

Last Modified: 21-Dec-2010


Exhaust Gas Temperature Cylinder 16 (B8) - Deviation Error

FAULT CODE 2512 - Single Turbocharger

Exhaust Gas Temperature Cylinder 16 (B8) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2512 PID: SPN: 1152 FMI: 10 LAMP: Shutdown SRT: | Exhaust Gas Temperature Cylinder 16 (B8) - Deviation Error. The difference between Cylinder 16 (B8) exhaust gas temperature and the average left bank exhaust gas temperature has exceeded the critical threshold. | The engine will shut down.
Exhaust Gas Temperature Cylinder 16 (B8) Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules – one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device which converts its output to a 0 to 5-VDC thermister type signal which is proportional to temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a ‘Cylinder 16 (B8) Temperature Deviation’ error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66° C [119° F], and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82° C [148° F].

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2512 (Single Turbocharger).

Last Modified: 25-Mar-2011


Fault Code Path Selection

FAULT CODE 2512
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2512-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2512-st

Last Modified: 05-Oct-2007


Engine Turbocharger 1 Boost Pressure Sensor - Voltage Above Normal or Shorted to High Source

FAULT CODE 2517

Engine Turbocharger 1 Boost Pressure Sensor - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2517 PID: SPN: FMI: 3 LAMP: Warning SRT: | Engine Turbocharger 1 Boost Pressure Sensor - Voltage Above Normal or Shorted to High Source. High voltage detected on compressor outlet pressure sensor SIGNAL pin of the main harness CM558 connector. | Possible reduced engine performance.
Multiple Turbocharger Engines
Single Turbocharger Engines

Circuit Description

The compressor outlet pressure sensor monitors the pressure of the air and fuel mixture as it exits the turbocharger compressor. This pressure is monitored by the CM558. High voltage will cause Fault Code 2517 and can be caused by shorts in the SUPPLY, SIGNAL, or RETURN wires, an open in the RETURN wire, or a failed sensor.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The compressor outlet pressure is the pressure of the air fuel mixture after it has exited the turbocharger compressor and prior to entering the throttle. High pressures can be a result of air-to-fuel ratios that are too high.

Refer to Troubleshooting Fault Code t05-2517.

Last Modified: 13-Oct-2010


Engine Turbocharger 1 Boost Pressure Sensor - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2518

Engine Turbocharger 1 Boost Pressure Sensor - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2518 PID: SPN: FMI: 4 LAMP: Warning SRT: | Engine Turbocharger 1 Boost Pressure Sensor - Voltage Below Normal or Shorted to Low Source. Low voltage detected on compressor outlet pressure sensor SIGNAL pin of the main harness CM558 connector. | Possible reduced engine performance.
Multiple Turbocharger Engines
Single Turbocharger Engines

Circuit Description

The compressor outlet pressure sensor monitors the pressure of the air and fuel mixture as it exits the turbocharger compressor. This pressure is monitored by the CM558. Low voltage will cause Fault Code 2518 and can be caused by shorts in the SUPPLY, SIGNAL, or RETURN wires, an open in the RETURN wire, or a failed sensor.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The compressor outlet pressure is the pressure of the air fuel mixture after it has exited the turbocharger compressor and prior to entering the throttle. Low pressures can be a result of air-to-fuel ratios that are too low.

Refer to Troubleshooting Fault Code t05-2518.

Last Modified: 21-Oct-2010


Throttle Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2519

Throttle Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2519 PID: P51 SPN: 51 FMI: 2/2 LAMP: Red SRT: | The throttle position sensor feedback is not responding to commands from the ECM. | Engine will shut down.
Throttle Actuator Position Circuit – Single Turbocharger with Integrated Throttle
Throttle Actuator Position Circuit - Multiple Turbocharger with Two-Piece Throttle
Throttle Actuator Position Circuit - Multiple Turbocharger with Integrated Throttle

Circuit Description

The engine control module (ECM) controls the engine throttle actuator, which is both an input and output device. The throttle position sensor is located inside the engine throttle actuator and they share a common supply and return. The ECM controls the position of the throttle across the engine throttle actuator.

Component Location

The throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the throttle position sensor is erratic.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Throttle actuator is malfunctioning.
  • Malfunctioning throttle position sensor.
  • Damaged or loose connectors.
Refer to Troubleshooting Fault Code t05-2519

Last Modified: 10-Mar-2021


Bank Identification Error

FAULT CODE 2521

Bank Identification Error

Printable Version Printable Version

Overview

Bank Identification Error

CODE | REASON | EFFECT
Fault Code: 2521 PID: SPN: 1225 FMI: 11 LAMP: Shutdown SRT: | Bank Identification Error. Incorrect bank identification detected by the CM558 at power up. | Engine will not start.
Left and Right CM558 Bank Identification Circuit - Multiple Turbochargers
Left and Right CM558 Bank Identification Circuit - Single Turbocharger

Circuit Description

Each CM558 reads the status of two pins to determine whether it is on the left bank or the right bank upon power up. A proper combination requires that one of these pins be shorted to CM558 Switch Return and the other left open. The short is permanently wired inside the wiring harness.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Each CM558 must have a unique identification as established by the two bank identification pins upon start up. If both pins on either CM558 are shorted to CM558 switch return or open, a fault will occur. The two CM558s must not have the same pin shorted to CM558 switch return.

Refer to Troubleshooting Fault Code t05-2521

Last Modified: 30-Jun-2010


Engine Cylinder Number 1 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2522

Engine Cylinder Number 1 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2522 PID: SPN: 1352 FMI: 16 LAMP: Shutdown SRT: | Engine Cylinder Number 1 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Cylinder number 1 has exceeded the lower knock count threshold. | The engine will shut down.
Knock Sensor Circuit - Multiple and Single Turbocharger Engines

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Knock sensors are located on each of the cylinder heads. Use the following procedure for component location. Refer to Procedure 019-346 in Section 19.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by a source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to a "pre-ignition" and knock occurring after the normal spark event is known as "detonation". The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of knock is not identified and rectified, engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function correctly, it must be installed and tightened to the correct torque.

Knock-related faults are activated when the knock sensor voltage output exceeds either a Warning or High critical threshold for a pre-set period of time.

When the knock Warning threshold is reached and persists for a pre-set period of time, the CM558 will register a Warning alarm for the affected cylinder and the engine will continue to run. The CM558 will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the CM558 will slowly advance the timing for that cylinder back to its standard timing setting. If the detonation persists, the timing retardation is repeated, up to a maximum of three timing retardations. If, following the final timing, retardation knock is still present, the CM558 will initiate a Critical shutdown of the engine.

All detonation-related shutdowns and persistent light knock events should be fully investigated in order to prevent engine damage.

The knock sensors can also detect mechanical noise, Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever "elephant foot" o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust (multi-duct) gasket leakage
  • Vibration resulting from loose engine parts/components.

Generator Sets using PowerCommand® Control 3300 (PCC3300) Generator Control:

The PCC3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code t05-2522.

Last Modified: 13-Dec-2010


Engine Cylinder Number 2 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2523

Engine Cylinder Number 2 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2523 PID: SPN: 1353 FMI: 16 LAMP: Shutdown SRT: | Engine Cylinder Number 2 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Cylinder number 2 has exceeded the lower knock count threshold. | The engine will shut down.
Knock Sensor Circuit - Multiple and Single Turbocharger Engines

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Knock sensors are located on each of the cylinder heads. Use the following procedure for component location. Refer to Procedure 019-346 in Section 19.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by a source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to a "pre-ignition" and knock occurring after the normal spark event is known as "detonation". The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of knock is not identified and rectified, engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function correctly, it must be installed and tightened to the correct torque.

Knock-related faults are activated when the knock sensor voltage output exceeds either a Warning or High critical threshold for a pre-set period of time.

When the knock Warning threshold is reached and persists for a pre-set period of time, the CM558 will register a Warning alarm for the affected cylinder and the engine will continue to run. The CM558 will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the CM558 will slowly advance the timing for that cylinder back to its standard timing setting. If the detonation persists, the timing retardation is repeated, up to a maximum of three timing retardations. If, following the final timing, retardation knock is still present, the CM558 will initiate a Critical shutdown of the engine.

All detonation-related shutdowns and persistent light knock events should be fully investigated in order to prevent engine damage.

The knock sensors can also detect mechanical noise, Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever "elephant foot" o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust (multi-duct) gasket leakage
  • Vibration resulting from loose engine parts/components.

Generator Sets using PowerCommand® Control 3300 (PCC3300) Generator Control:

The PCC3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code t05-2523.

Last Modified: 14-Dec-2010


Engine Cylinder Number 3 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2524

Engine Cylinder Number 3 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2524 PID: SPN: 1354 FMI: 16 LAMP: Shutdown SRT: | Engine Cylinder Number 3 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Cylinder number 3 has exceeded the lower knock count threshold. | The engine will shut down.
Knock Sensor Circuit - Multiple and Single Turbocharger Engines

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Knock sensors are located on each of the cylinder heads. Use the following procedure for component location. Refer to Procedure 019-346 in Section 19.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by a source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to a "pre-ignition" and knock occurring after the normal spark event is known as "detonation". The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of knock is not identified and rectified, engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function correctly, it must be installed and tightened to the correct torque.

Knock-related faults are activated when the knock sensor voltage output exceeds either a Warning or High critical threshold for a pre-set period of time.

When the knock Warning threshold is reached and persists for a pre-set period of time, the CM558 will register a Warning alarm for the affected cylinder and the engine will continue to run. The CM558 will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the CM558 will slowly advance the timing for that cylinder back to its standard timing setting. If the detonation persists, the timing retardation is repeated, up to a maximum of three timing retardations. If, following the final timing, retardation knock is still present, the CM558 will initiate a Critical shutdown of the engine.

All detonation-related shutdowns and persistent light knock events should be fully investigated in order to prevent engine damage.

The knock sensors can also detect mechanical noise, Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever "elephant foot" o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust (multi-duct) gasket leakage
  • Vibration resulting from loose engine parts/components.

Generator Sets using PowerCommand® Control 3300 (PCC3300) Generator Control:

The PCC3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code t05-2524.

Last Modified: 14-Dec-2010


Engine Cylinder Number 4 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2525

Engine Cylinder Number 4 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2525 PID: SPN: 1355 FMI: 16 LAMP: Shutdown SRT: | Engine Cylinder Number 4 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Cylinder number 4 has exceeded the lower knock count threshold. | The engine will shut down.
Knock Sensor Circuit - Multiple and Single Turbocharger Engines

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Knock sensors are located on each of the cylinder heads. Use the following procedure for component location. Refer to Procedure 019-346 in Section 19.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by a source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to a "pre-ignition" and knock occurring after the normal spark event is known as "detonation". The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of knock is not identified and rectified, engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function correctly, it must be installed and tightened to the correct torque.

Knock-related faults are activated when the knock sensor voltage output exceeds either a Warning or High critical threshold for a pre-set period of time.

When the knock Warning threshold is reached and persists for a pre-set period of time, the CM558 will register a Warning alarm for the affected cylinder and the engine will continue to run. The CM558 will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the CM558 will slowly advance the timing for that cylinder back to its standard timing setting. If the detonation persists, the timing retardation is repeated, up to a maximum of three timing retardations. If, following the final timing, retardation knock is still present, the CM558 will initiate a Critical shutdown of the engine.

All detonation-related shutdowns and persistent light knock events should be fully investigated in order to prevent engine damage.

The knock sensors can also detect mechanical noise, Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever "elephant foot" o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust (multi-duct) gasket leakage
  • Vibration resulting from loose engine parts/components.

Generator Sets using PowerCommand® Control 3300 (PCC3300) Generator Control:

The PCC3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code t05-2525.

Last Modified: 14-Dec-2010


Engine Cylinder Number 5 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2526

Engine Cylinder Number 5 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2526 PID: SPN: 1356 FMI: 16 LAMP: Shutdown SRT: | Engine Cylinder Number 5 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Cylinder number 5 has exceeded the lower knock count threshold. | The engine will shut down.
Knock Sensor Circuit - Multiple and Single Turbocharger Engines

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Knock sensors are located on each of the cylinder heads. Use the following procedure for component location. Refer to Procedure 019-346 in Section 19.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by a source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to a "pre-ignition" and knock occurring after the normal spark event is known as "detonation". The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of knock is not identified and rectified, engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function correctly, it must be installed and tightened to the correct torque.

Knock-related faults are activated when the knock sensor voltage output exceeds either a Warning or High critical threshold for a pre-set period of time.

When the knock Warning threshold is reached and persists for a pre-set period of time, the CM558 will register a Warning alarm for the affected cylinder and the engine will continue to run. The CM558 will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the CM558 will slowly advance the timing for that cylinder back to its standard timing setting. If the detonation persists, the timing retardation is repeated, up to a maximum of three timing retardations. If, following the final timing, retardation knock is still present, the CM558 will initiate a Critical shutdown of the engine.

All detonation-related shutdowns and persistent light knock events should be fully investigated in order to prevent engine damage.

The knock sensors can also detect mechanical noise, Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever "elephant foot" o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust (multi-duct) gasket leakage
  • Vibration resulting from loose engine parts/components.

Generator Sets using PowerCommand® Control 3300 (PCC3300) Generator Control:

The PCC3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code t05-2526.

Last Modified: 14-Dec-2010


Engine Cylinder Number 6 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2527

Engine Cylinder Number 6 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2527 PID: SPN: 1357 FMI: 16 LAMP: Shutdown SRT: | Engine Cylinder Number 6 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Cylinder number 6 has exceeded the lower knock count threshold. | The engine will shut down.
Knock Sensor Circuit - Multiple and Single Turbocharger Engines

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Knock sensors are located on each of the cylinder heads. Use the following procedure for component location. Refer to Procedure 019-346 in Section 19.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by a source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to a "pre-ignition" and knock occurring after the normal spark event is known as "detonation". The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of knock is not identified and rectified, engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function correctly, it must be installed and tightened to the correct torque.

Knock-related faults are activated when the knock sensor voltage output exceeds either a Warning or High critical threshold for a pre-set period of time.

When the knock Warning threshold is reached and persists for a pre-set period of time, the CM558 will register a Warning alarm for the affected cylinder and the engine will continue to run. The CM558 will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the CM558 will slowly advance the timing for that cylinder back to its standard timing setting. If the detonation persists, the timing retardation is repeated, up to a maximum of three timing retardations. If, following the final timing, retardation knock is still present, the CM558 will initiate a Critical shutdown of the engine.

All detonation-related shutdowns and persistent light knock events should be fully investigated in order to prevent engine damage.

The knock sensors can also detect mechanical noise, Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever "elephant foot" o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust (multi-duct) gasket leakage
  • Vibration resulting from loose engine parts/components.

Generator Sets using PowerCommand® Control 3300 (PCC3300) Generator Control:

The PCC3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code t05-2527.

Last Modified: 14-Dec-2010


Engine Cylinder Number 7 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2528

Engine Cylinder Number 7 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2528 PID: SPN: 1358 FMI: 16 LAMP: Shutdown SRT: | Engine Cylinder Number 7 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Cylinder number 7 has exceeded the lower knock count threshold. | The engine will shut down.
Knock Sensor Circuit - Multiple and Single Turbocharger Engines

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Knock sensors are located on each of the cylinder heads. Use the following procedure for component location. Refer to Procedure 019-346 in Section 19.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by a source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to a "pre-ignition" and knock occurring after the normal spark event is known as "detonation". The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of knock is not identified and rectified, engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function correctly, it must be installed and tightened to the correct torque.

Knock-related faults are activated when the knock sensor voltage output exceeds either a Warning or High critical threshold for a pre-set period of time.

When the knock Warning threshold is reached and persists for a pre-set period of time, the CM558 will register a Warning alarm for the affected cylinder and the engine will continue to run. The CM558 will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the CM558 will slowly advance the timing for that cylinder back to its standard timing setting. If the detonation persists, the timing retardation is repeated, up to a maximum of three timing retardations. If, following the final timing, retardation knock is still present, the CM558 will initiate a Critical shutdown of the engine.

All detonation-related shutdowns and persistent light knock events should be fully investigated in order to prevent engine damage.

The knock sensors can also detect mechanical noise, Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever "elephant foot" o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust (multi-duct) gasket leakage
  • Vibration resulting from loose engine parts/components.

Generator Sets using PowerCommand® Control 3300 (PCC3300) Generator Control:

The PCC3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code t05-2528.

Last Modified: 14-Dec-2010


Engine Cylinder Number 8 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2529

Engine Cylinder Number 8 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2529 PID: SPN: 1359 FMI: 16 LAMP: Shutdown SRT: | Engine Cylinder Number 8 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Cylinder number 8 has exceeded the lower knock count threshold. | The engine will shut down.
Knock Sensor Circuit - Multiple and Single Turbocharger Engines

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Knock sensors are located on each of the cylinder heads. Use the following procedure for component location. Refer to Procedure 019-346 in Section 19.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by a source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to a "pre-ignition" and knock occurring after the normal spark event is known as "detonation". The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of knock is not identified and rectified, engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function correctly, it must be installed and tightened to the correct torque.

Knock-related faults are activated when the knock sensor voltage output exceeds either a Warning or High critical threshold for a pre-set period of time.

When the knock Warning threshold is reached and persists for a pre-set period of time, the CM558 will register a Warning alarm for the affected cylinder and the engine will continue to run. The CM558 will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the CM558 will slowly advance the timing for that cylinder back to its standard timing setting. If the detonation persists, the timing retardation is repeated, up to a maximum of three timing retardations. If, following the final timing, retardation knock is still present, the CM558 will initiate a Critical shutdown of the engine.

All detonation-related shutdowns and persistent light knock events should be fully investigated in order to prevent engine damage.

The knock sensors can also detect mechanical noise, Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever "elephant foot" o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust (multi-duct) gasket leakage
  • Vibration resulting from loose engine parts/components.

Generator Sets using PowerCommand® Control 3300 (PCC3300) Generator Control:

The PCC3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code t05-2529.

Last Modified: 14-Dec-2010


Engine Oil Level - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 253

Engine Oil Level - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 253 PID: 98 SPN: 98 FMI: 1 LAMP: Shutdown SRT: | Engine Oil Level - Data Valid But Below Normal Operating Range - Most Severe Level. Very low engine oil level has been detected by the oil level sensor. | The engine will shut down.
QSK60 G Multiple Turbochargers with Generator Control Panel (GCP1) and PowerCommand® Supervisor 3100
QSK60 G Single and Multiple Turbochargers with Generator Control Panel (GCP2) and PowerCommand® Supervisor 3100
QSK60 G Single and Multiple Turbochargers with Generator Interface Box (GIB) and PowerCommand® Supervisor 3300
Discrete Murphy™ Oil Sump Level Switch - Terminal Connections (All Models)

Circuit Description

The discrete Murphy™ oil sump level switch monitors and maintains oil level within the engine sump. The engine oil level is monitored at all times while the 24-VDC supply is switched ON.

The oil level switch is integral to the Murphy™ level switch assembly. If the oil level within the Murphy™ level switch falls below a certain level, the control system will activate Fault Code 253.

On generator sets fitted with generator control panel 1 (GCP1) with PowerCommand® Supervisor 3100, the low oil sump level signal is monitored by the programmable logic cotnrol (PLC).

On generator sets fitted with generator control panel 2 (GCP2) with PowerCommand® Supervisor 3100 or generator interface box (GIB) with PowerCommand® Control 3300, the low oil sump level signal is monitored by the CM700 module.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

To maintain the correct engine oil level within the engine at all times, the Murphy™ oil level switch is connected to an engine lubricating oil "day tank", usually located near the generator set. The positioning of the Murphy™ oil level switch is critical to maintaining the correct oil level within the sump. This position has been pre-determined and is non-adjustable.

The oil level within the Murphy™ oil level switch can be monitored using an integral sight glass.

The Murphy™ oil level switch also incorporates an integral "test switch" which can be used to test the switch alarm outputs to the PLC or CM700 module for the corresponding fault code activation.

Possible causes of this fault code include:

  • Engine lubricating oil "day tank" low oil level
  • External engine oil leaks
  • Internal engine oil leaks (oil leaking into the cooling system)
  • High engine oil consumption/power cylinder failure.

Check for abnormally high blowby when the engine is loaded, as well as rapid filling of the engine's dirty oil tank. Appropriate dirty oil tank level alarms will be activated.

Refer to Troubleshooting Fault Code t05-253.

Last Modified: 06-Jul-2011


Engine Cylinder Number 9 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2531

Engine Cylinder Number 9 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2531 PID: SPN: 1360 FMI: 16 LAMP: Shutdown SRT: | Engine Cylinder Number 9 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Cylinder number 9 has exceeded the lower knock count threshold. | The engine will shut down.
Knock Sensor Circuit - Multiple and Single Turbocharger Engines

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Knock sensors are located on each of the cylinder heads. Use the following procedure for component location. Refer to Procedure 019-346 in Section 19.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by a source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to a "pre-ignition" and knock occurring after the normal spark event is known as "detonation". The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of knock is not identified and rectified, engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function correctly, it must be installed and tightened to the correct torque.

Knock-related faults are activated when the knock sensor voltage output exceeds either a Warning or High critical threshold for a pre-set period of time.

When the knock Warning threshold is reached and persists for a pre-set period of time, the CM558 will register a Warning alarm for the affected cylinder and the engine will continue to run. The CM558 will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the CM558 will slowly advance the timing for that cylinder back to its standard timing setting. If the detonation persists, the timing retardation is repeated, up to a maximum of three timing retardations. If, following the final timing, retardation knock is still present, the CM558 will initiate a Critical shutdown of the engine.

All detonation-related shutdowns and persistent light knock events should be fully investigated in order to prevent engine damage.

The knock sensors can also detect mechanical noise, Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever "elephant foot" o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust (multi-duct) gasket leakage
  • Vibration resulting from loose engine parts/components.

Generator Sets using PowerCommand® Control 3300 (PCC3300) Generator Control:

The PCC3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code t05-2531.

Last Modified: 14-Dec-2010


Engine Cylinder Number 10 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2532

Engine Cylinder Number 10 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2532 PID: SPN: 1361 FMI: 16 LAMP: Shutdown SRT: | Engine Cylinder Number 10 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level. Cylinder number 10 has exceeded the lower knock count threshold. | The engine will shut down.
Knock Sensor Circuit - Multiple and Single Turbocharger Engines

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Knock sensors are located on each of the cylinder heads. Use the following procedure for component location. Refer to Procedure 019-346 in Section 19.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by a source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to a "pre-ignition" and knock occurring after the normal spark event is known as "detonation". The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts colliding within the power cylinder. If the cause of knock is not identified and rectified, engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a Warning alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function correctly, it must be installed and tightened to the correct torque.

Knock-related faults are activated when the knock sensor voltage output exceeds either a Warning or High critical threshold for a pre-set period of time.

When the knock Warning threshold is reached and persists for a pre-set period of time, the CM558 will register a Warning alarm for the affected cylinder and the engine will continue to run. The CM558 will initiate a pre-set timing retardation for that cylinder. If the knock disappears following the timing retardation, the CM558 will slowly advance the timing for that cylinder back to its standard timing setting. If the detonation persists, the timing retardation is repeated, up to a maximum of three timing retardations. If, following the final timing, retardation knock is still present, the CM558 will initiate a Critical shutdown of the engine.

All detonation-related shutdowns and persistent light knock events should be fully investigated in order to prevent engine damage.

The knock sensors can also detect mechanical noise, Mechanical-related problems should not be discounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and eliminated:

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever "elephant foot" o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust (multi-duct) gasket leakage
  • Vibration resulting from loose engine parts/components.

Generator Sets using PowerCommand® Control 3300 (PCC3300) Generator Control:

The PCC3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5V = 0 percent and 5V = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from "no-knock" condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code t05-2532.

Last Modified: 14-Dec-2010


Fuel Shutoff Valve Circuit - Shorted Low

FAULT CODE 254

Fuel Shutoff Valve Circuit - Shorted Low

Printable Version Printable Version

Overview

Fuel Shutoff Valve Circuit - Shorted Low

CODE | REASON | EFFECT
Fault Code: 254 PID: 17 SPN: 701 FMI: 4 LAMP: Shutdown SRT: | Fuel Shutoff Valve Circuit - Shorted Low. Low voltage detected at the signal return pin of the fuel shutoff valve. | The engine will shut down.
Fuel Shutoff Valve Circuit - Multiple Turbochargers
Fuel Shutoff Valve Circuit - Single Turbocharger

Circuit Description

The fuel shutoff valve is commanded by both the CM700 and the left bank CM558. The module outputs operate relays that then power the respective solenoids in the fuel shutoff valve.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

The fuel shutoff valve power connections share a common ground. The main power connector on the valve has two +24-VDC supplies and one ground connection. The logic of the vent valve is the opposite of the main fuel shutoff solenoids. When power is provided to open the solenoids, the vent valve is closed (if fitted).

Refer to Troubleshooting Fault Code t05-254

Last Modified: 30-Jun-2010


ECM Internal Air Temperature High — Critical

FAULT CODE 2544

ECM Internal Air Temperature High — Critical

Printable Version Printable Version

Overview

ECM Internal Air Temperature High — Critical

CODE | REASON | EFFECT
Fault Code: 2544 PID: FMI: 0 LAMP: SRT: | The ECM internal temperature has exceeded the high shutdown threshold. | The engine will shut down.
Electronic Control Module (ECM)

Circuit Description

The CM700 and CM558 each contain an internal temperature sensor. The circuit is entirely internal to the ECM.

Component Location

The ECM internal air temperature sensor is inside the ECM.

Shop Talk

The ECM temperature is monitored to protect the generator system in the event of excessive ECM temperature.

Refer to Troubleshooting Fault Code t05-2544

Last Modified: 30-Jun-2010


Engine Oil Level – Data Valid But Below Normal Operating Range – Moderately Severe Level

FAULT CODE 2553

Engine Oil Level – Data Valid But Below Normal Operating Range – Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2553 PID: 98 SPN: 98 FMI: 18 LAMP: Warning SRT: | Engine Oil Level – Data Valid But Below Normal Operating Range – Moderately Severe Level. Low engine oil level has been detected by the oil level sensor. | No effect on engine performance.
QSK60G Multiple Turbochargers with Generator Control Panel (GCP1) and PowerCommand® Supervisor 3100
QSK60G Single and Multiple Turbochargers with Generator Control Panel (GCP2) and PowerCommand® Supervisor 3100
QSK60G Single & Multiple Turbochargers with Generator Interface Box (GIB) and PowerCommand® Control 3300
Discrete Murphy® Oil Sump Level Switch – Terminal Connections (All Models)

Circuit Description

The Discrete Murphy® Oil Sump Level Switch both monitors and maintains the oil level within the engine's sump. The engine oil level is monitored at all times while the 24-VDC supply is switched ON.

The oil level switch is integral to the Murphy® Level Switch Assembly. If the oil level within the Murphy® Level Switch falls below a certain level, the control system will activate Fault Code 2553.

On Generator Sets fitted with Generator Control Panel 1 (GCP1) with PowerCommand® Supervisor 3100, the Low Oil Sump Level signal is monitored by the Programmable Logic Control (PLC).

On Generator Sets fitted with Generator Control Panel 2 (GCP2) with PowerCommand® Supervisor 3100 or Generator Interface Box (GIB) with PowerCommand® Control 3300, the Low Oil Sump Level signal is monitored by the CM700 module.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

In order to maintain the correct engine oil level within the engine at all times, the Murphy® Oil Level Switch is connected to an engine lubricating oil ‘day tank’, usually located close to the generator set. The positioning of the Murphy® Oil Level Switch is critical to maintaining the correct oil level within the sump. This position has been pre-determined and is non-adjustable.

The oil level within the Murphy® Oil Level Switch can be monitored via an integral sight glass.

The Murphy® Oil Level Switch also incorporates an integral ‘Test Switch’, which can be used to test the switch alarm outputs to the PLC or CM700 module for the corresponding fault code activation.

Possible causes of this fault code include:

  • Engine lubricating oil 'day tank' low oil levels
  • External engine oil leaks
  • Internal engine oil leaks (oil leaking into the cooling system)
  • High engine oil consumption/power cylinder damage. Check for abnormally high blowby when the engine is loaded, as well as rapid filling of the engine dirty oil tank. Appropriate dirty oil tank level alarms will be activated.
Refer to Troubleshooting Fault Code t05-2553.

Last Modified: 05-Apr-2011


Gas Supply Pressure (Regulated) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2568

Gas Supply Pressure (Regulated) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2568 PID: SPN: 159 FMI: 0 LAMP: Shutdown SRT: | Gas Supply Pressure (Regulated) - Data Valid But Above Normal Operating Range - Most Severe Level. The gas supply pressure sensor indicates pressure above critical level. | The engine will shutdown.
Fuel Supply Pressure Sensor Circuit

Circuit Description

The CM700 module uses the fuel supply pressure sensor to measure the fuel pressure in the fuel supply line after the fuel pressure regulator. The CM700 provides a 5 volt supply to the sensor supply circuit, as well as a ground on the sensor return circuit.

The fuel supply pressure sensor provides a signal to the CM700 via the sensor signal circuit. The signal DC voltage is directly proportional to pressure; as the pressure increases the signal DC voltage will increase.

Component Location

The fuel supply pressure sensor is located in the engine fuel double-solenoid shutoff valve (DSSV).

The engine fuel double-solenoid shutoff valve is mounted remotely from the generator set. Reference the site specific system installation drawings for location.

Shop Talk

The CM700 module uses the fuel supply pressure sensor to measure the fuel supply pressure immediately after the fuel pressure regulator. This signal is used by the CM700 Module for fuel supply (regulated) ‘high pressure’ and ‘low pressure’ protection.

This signal is also used by the CM700 module as part of the valve proving system (VPS) test procedure; which is used to confirm the integrity (gas tightness) of the double-solenoid gas valve.

The fuel supply pressure sensor is an absolute sensor.

Refer to Troubleshooting Fault Code t05-2568.

Last Modified: 04-Jan-2011


Gas Supply Pressure (Regulated) - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 2569

Gas Supply Pressure (Regulated) - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2569 PID: SPN: 159 FMI: 1 LAMP: Shutdown SRT: | Gas Supply Pressure (Regulated) - Data Valid But Above Normal Operating Range - Most Severe Level. The gas supply pressure sensor indicates pressure below critical level. | The engine will shutdown.
Fuel Supply Pressure Sensor Circuit

Circuit Description

The CM700 module uses the fuel supply pressure sensor to measure the fuel pressure in the fuel supply line after the fuel pressure regulator. The CM700 provides a 5 volt supply to the sensor supply circuit, as well as a ground on the sensor return circuit.

The fuel supply pressure sensor provides a signal to the CM700 via the sensor signal circuit. The signal DC voltage is directly proportional to pressure; as the pressure increases the signal DC voltage will increase.

Component Location

The fuel supply pressure sensor is located in the engine fuel double-solenoid shutoff valve (DSSV).

The engine fuel double-solenoid shutoff valve is mounted remotely from the generator set. Reference the site specific system installation drawings for location.

Shop Talk

The CM700 module uses the fuel supply pressure sensor to measure the fuel supply pressure immediately after the fuel pressure regulator. This signal is used by the CM700 Module for fuel supply (regulated) ‘high pressure’ and ‘low pressure’ protection.

This signal is also used by the CM700 module as part of the valve proving system (VPS) test procedure; which is used to confirm the integrity (gas tightness) of the double-solenoid gas valve.

The fuel supply pressure sensor is an absolute sensor.

Refer to Troubleshooting Fault Code t05-2569.

Last Modified: 04-Jan-2011


Fuel Temperature Sensor Circuit - Shorted High

FAULT CODE 263

Fuel Temperature Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

Fuel Temperature Sensor Circuit - Shorted High

CODE | REASON | EFFECT
Fault Code: 263 PID: P174 SPN: 174 FMI: 3 LAMP: Warning SRT: | Fuel Temperature Sensor Circuit - Shorted High. Engine Fuel Temperature Sensor signal is shorted high. | Possible reduced engine performance.
Fuel Temperature Sensor Circuit - Multiple Turbochargers
Fuel Temperature Sensor Circuit - Single Turbocharger

Circuit Description

The fuel temperature sensor is used by the CM558 to monitor the temperature of the fuel entering the fuel control assembly. The fuel temperature sensor is used by the CM558 for timing and fueling control.

If the voltage is high the CM558 will log Fault Code 263. Voltage high can be caused by opens in the signal or return wires, voltage shorts to the signal or return wires, or a failed open sensor.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

The resistance of the sensor varies with the temperature.

Refer to the wiring diagram for details.

Refer to Troubleshooting Fault Code t05-263

Last Modified: 30-Jun-2010


Fuel Temperature Sensor Circuit - Shorted Low

FAULT CODE 265

Fuel Temperature Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

Fuel Temperature Sensor Circuit - Shorted Low

CODE | REASON | EFFECT
Fault Code: 265 PID: P174 SPN: 174 FMI: 4 LAMP: Warning SRT: | Fuel Temperature Sensor Circuit - Shorted Low. Engine Fuel Temperature Sensor signal is shorted low. | Possible reduced engine performance.
Fuel Temperature Sensor Circuit - Multiple Turbochargers
Fuel Temperature Sensor Circuit - Single Turbocharger

Circuit Description

The fuel temperature sensor is used by the CM558 to monitor the temperature of the fuel entering the fuel control assembly. The fuel temperature sensor is used by the CM558 for timing and fuel control.

If the voltage is low, the CM558 will log Fault Code 265. Low voltage can be caused a short to ground on the supply or return wires, or an internally grounded, damaged sensor.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

The resistance of the sensor varies with the temperature.

Refer to the wiring diagram for details.

Refer to Troubleshooting Fault Code t05-265

Last Modified: 30-Jun-2010


Fault Code Path Selection

FAULT CODE 2752
Fault Code Path Selection

Is this engine equipped with multiple turbochargers integrated throttle? | Go to 59-fc2752mtit
Is this engine equipped with multiple turbochargers two-piece throttle? | Go to 59-fc2752mttt
Is this engine equipped with a single turbocharger integreated throttle? | Go to 59-fc2752stit

Last Modified: 08-Oct-2010


FAULT CODE 2752 - Multiple Turbocharger Integrated Throttle

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2752 PID: SPN: 3464 FMI: 6 LAMP: Shutdown SRT: | Engine Throttle Control Actuator – Current above Normal or Grounded Circuit – Most Severe Level. Engine throttle control actuator is stuck and/or not responding mechanically. | The engine will shutdown.
Throttle Actuator Circuit

Circuit Description

For engines fitted with integrated digital throttles, the throttle assembly is a one-piece unit consisting of an integrated throttle actuator and driver assembly. The throttle assembly receives a ‘commanded position signal’ over the engine's proprietary data link circuit. The throttle position feedback signal is also a digital signal transmitted over the proprietary data link circuit.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Always verify that the cable connections on the throttle driver are tight. On integrated throttles, there is one connection.

Refer to Troubleshooting Fault Code t05-2752mtit.

Last Modified: 04-Jan-2011


FAULT CODE 2752 - Multiple Turbocharger Two-Piece Throttle

Overview

CODE | REASON | EFFECT
Fault Code: 2752 PID: SPN: 3464 FMI: 6 LAMP: Shutdown SRT: | Engine Throttle Control Actuator – Current Above Normal or Grounded Circuit – Most Severe Level. Engine throttle control actuator is stuck and/or not responding mechanically. | The engine will shutdown.
Throttle Actuator Circuit

Circuit Description

For engines fitted with two-piece analog throttles, the throttle assembly consists of a throttle driver and a throttle actuator. The throttle actuator receives a 4-20mA ‘commanded throttle position’ signal from the CM558. The throttle position feedback signal from the throttle driver is also a 4-20mA signal.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Always verify that the cable connections on the throttle driver are tight. On integrated throttles, there is one connection.

Refer to Troubleshooting Fault Code t05-2752mttt.

Last Modified: 04-Jan-2011


FAULT CODE 2752 - Single Turbocharger Integrated Throttle

Overview

CODE | REASON | EFFECT
Fault Code: 2752 PID: SPN: 3464 FMI: 6 LAMP: Shutdown SRT: | Engine Throttle Control Actuator – Current Above Normal or Grounded Circuit – Most Severe Level. Engine throttle control actuator is stuck and/or not responding mechanically. | The engine will shutdown.
Throttle Actuator Circuit

Circuit Description

For engines fitted with integrated digital throttles, the throttle assembly is a one-piece unit consisting of an integrated throttle actuator and driver assembly. The throttle assembly receives a ‘commanded position signal’ over the engine's proprietary data link circuit. The throttle position feedback signal is also a digital signal transmitted over the proprietary data link circuit.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Always verify that the cable connections on the throttle driver are tight. On integrated throttles, there is one connection.

Refer to Troubleshooting Fault Code t05-2752stit.

Last Modified: 04-Jan-2011


Left Bank Capacitive Coil Driver Failed

FAULT CODE 2766

Left Bank Capacitive Coil Driver Failed

Printable Version Printable Version

Overview

Left Bank Capacitive Coil Driver Failed

CODE | REASON | EFFECT
Fault Code: 2766 PID: SPN: FMI: 1 LAMP: Shutdown SRT: | Left Bank Capacitive Coil Driver Failed. The number of misfiring cylinders has exceeded the critical threshold. | The engine will shut down.
Left Bank Capacitive Coil Driver Circuit - Multiple Turbochargers
Left Bank Capacitive Coil Driver Circuit - Single Turbocharger

Circuit Description

The capacitive coil driver receives timing and reference pulses from the CM558. It then sends primary voltage signals to the individual coil on plugs.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

If more than an allowable number of exhaust temperatures drop below the misfire threshold, the capacitive coil driver failed fault is set. Be sure to verify that there is a + 24-VDC power supply to the capacitive coil driver. Check the fuses and circuit breakers in the remotely-mounted power supply. Refer to the wiring diagram for the appropriate circuit.

Refer to Troubleshooting Fault Code t05-2766

Last Modified: 30-Jun-2010


Right Bank Capacitive Coil Driver Failed

FAULT CODE 2767

Right Bank Capacitive Coil Driver Failed

Printable Version Printable Version

Overview

Right Bank Capacitive Coil Driver Failed

CODE | REASON | EFFECT
Fault Code: 2767 PID: SPN: FMI: 1 LAMP: Shutdown SRT: | Right Bank Capacitive Coil Driver Failed. The number of misfiring cylinders has exceeded the critical threshold. | The engine will shut down.
Right Bank Capacitive Coil Driver Circuit - Multiple Turbochargers
Right Bank Capacitive Coil Driver Circuit - Single Turbocharger

Circuit Description

The capacitive coil driver receives timing and reference pulses from the CM558. It then sends primary voltage signals to the individual coil on plugs.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

If more than an allowable number of exhaust temperatures drop below the misfire threshold, the capacitive coil driver failed fault is set. Be sure to verify that there is a + 24-VDC power supply to the capacitive coil driver. Check the fuses and circuit breakers in the remotely-mounted power supply. Refer to the circuit diagram or wiring diagram for the appropriate circuit.

Refer to Troubleshooting Fault Code t05-2767

Last Modified: 30-Jun-2010


Engine Network Primary/Secondary Communication - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2768

Engine Network Primary/Secondary Communication - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2768 PID: SPN: 520334 FMI: 2 LAMP: Shutdown SRT: | Engine Network Primary/Secondary Communication - Data Erratic, Intermittent, or Incorrect. The communication between the primary module and secondary modules is erratic, intermittent, or incorrect. | Engine will shut down.
Engine Network Primary/Secondary Communication Circuit (Multiple Turbocharger Engines)
Engine Network Primary/Secondary Communication Circuit (Single Turbocharger Engines)

Circuit Description

The proprietary data link is a high speed data link that carries critical engine operating data.

Component Location

Reference the site specific installation schematics for the component location.

Shop Talk

The high speed proprietary data link network is used to communicate critical engine data between the engine primary module (CM700) and secondary modules (CM558 A and B-Bank) and CM850 modules (when fitted)). If this data link is erratic, intermittent, or incorrect, control of the engine may be compromised.

There are two termination resistors locate within the proprietary data link circuit. One resistor is located within the engine harness. For multiple turbocharger engines, there is a 3-pin 120 ohm termination resistor socket. For single turbocharger engines, the 120 ohm termination resistor is built into the right-bank CM850 60-pin connector plus back shell. The second resistor is located within the Generator Interface Panel on the engine harness terminal strip. Both resistors must be in place and in good condition in order to maintain proper communication. Reference the engine wiring diagram and the Gen Set panel wiring diagrams for resistor locations.

Fault Code 2768 can be generated by either engine bank CM558 module (secondary) to indicate that the CM558 is not receiving valid data or consistent communications from the CM700 module (primary).

The most common cause for Fault Code 2768 being activated is poor or loose wiring connections.

Refer to Troubleshooting Fault Code t05-2768

Last Modified: 30-Jun-2010


Engine Network Primary Message - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2769

Engine Network Primary Message - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2769 PID: SPN: 520335 FMI: 2 LAMP: Shutdown SRT: | Engine Network Primary Message - Data Erratic, Intermittent, or Incorrect. The communication between the secondary modules and all other communication modules in the system is erratic, intermittent, or incorrect. | Engine will shut down.
Engine Network Communication Circuit (Multiple Turbocharger Engines)
Engine Network Communication Circuit (Single Turbocharger Engines)

Circuit Description

The proprietary data link is a high speed data link that carries critical engine operating data.

Component Location

Reference the site specific installation schematics for the component location.

Shop Talk

The high speed proprietary data link network is used to communicate critical engine data between the engine primary module (CM700) and secondary modules (CM558 A and B-Bank) and CM850 modules (when fitted)). If this data link is erratic, intermittent, or incorrect, control of the engine may be compromised.

There are two termination resistors locate within the proprietary data link circuit. One resistor is located within the engine harness. For multiple turbocharger engines, there is a 3-pin 120 ohm termination resistor socket. For single turbocharger engines, the 120 ohm termination resistor is built into the right-bank CM850 60-pin connector plus back shell. The second resistor is located within the Generator Interface Panel on the engine harness terminal strip. Both resistors must be in place and in good condition in order to maintain proper communication. Reference the engine wiring diagram and the Gen Set panel wiring diagrams for resistor locations.

Fault Code 2769 can be generated by either engine bank CM558 module (secondary) to indicate that the CM558 is not receiving valid data or consistent communications from the CM700 module (primary).

The most common cause for Fault Code 2769 being activated is poor or loose wiring connections.

Refer to Troubleshooting Fault Code t05-2769

Last Modified: 30-Jun-2010


Engine Electronic Fuel Control Valve 1 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 277

Engine Electronic Fuel Control Valve 1 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 277 PID: SPN: 633 FMI: 7 LAMP: Warning SRT: | Engine Electronic Fuel Control Valve 1 - Mechanical System Not Responding or Out of Adjustment. The electronic fuel control valve 1 is stuck or not responding. | Engine will continue to run but performance may be impaired.
QSK60G Multiple Turbochargers with Generator Control Panel 1 (GCP1) with PowerCommand™ Supervisor 3100 and AC and DC Generator Set Terminal Boxes - Engine Electronic Fuel Control Valve Circuit
QSK60G Single and Multiple Turbochargers with Generator Control Panel 2 (GCP2) with PowerCommand™ Supervisor 3100 and Generator Interface Box (GIB) - Engine Electronic Fuel Control Valve Circuit
QSK60G Single and Multiple Turbochargers with PowerCommand™ Control 3300 and Generator Interface Box (GIB) - Engine Electronic Fuel Control Valve Circuit

Circuit Description

The fuel control valve (FCV) position circuit consists of the commanded signal from the CM558 module and the feedback signal that is received by the CM558 from the fuel control valve. The FCV commanded position signal is supplied by the CM558 and is a 24-VDC pulse width modulated (PWM) signal and the feedback is a 0 to 5-VDC signal.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

If an intermittent electrical circuit problem of the electronic fuel control valve circuit exists, it is possible for Fault Code 277 to become active and then inactive during normal generator set operation. This would indicate an intermittent open or short circuit.

This fault code can become active for any of the following reasons:

  • Electronic FCV actuator high resistance
  • Engine harness, or extension harness high resistance
  • Loose, worn or corroded connectors or pins at the FCV connector or ECM connector
  • Electronic FCV low internal resistance
  • Electronic FCV or engine harness short to ground
  • Intermittent circuit malfunctions.

Verify that all connectors are clean and free of corrosion before replacing components.

Mechanical or electronic adjustment of the electronic fuel control valve is not necessary.

The following table, which can be used as an aid when troubleshooting the FCV operation, provides FCV actuator position commanded PWM percent duty cycle and VDC feedback signal specifications.

Actuator Commanded Position | Percent Duty Cycle | 0 to 5-VDC Feedback Signal
0 | 10 - 14 | 0.4 - 0.7
10 | 17 - 21 | 0.9 - 1.1
20 | 25 - 28 | 1.3 - 1.5
30 | 33 - 37 | 1.7 - 1.9
40 | 41 - 44 | 2.1 - 2.3
50 | 49 - 54 | 2.5 - 2.7
60 | 55 - 60 | 2.9 - 3.1
70 | 65 - 70 | 3.3 - 3.5
80 | 73 - 78 | 3.7 - 3.9
90 | 81 - 86 | 4.1 - 4.3
100 | 89 - 94 | 4.6 - 4.8

Note: PWM percent duty cycle signals can only be measured with multimeters or other measuring devices that have a percentage duty cycle function.

Refer to Troubleshooting Fault Code t05-277

Last Modified: 09-Feb-2012


Fault Code Path Selection

FAULT CODE 2789
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2789mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2789st

Last Modified: 08-Oct-2010


Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2789 - Multiple Turbochargers

Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2789 PID: SPN: 110 FMI: 18 LAMP: Warning SRT: | Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level. The engine coolant temperature (high temperature) has exceeded the low warning threshold. | No effect on engine performance.
Engine Coolant Temperature Sensor Circuit - High Temperature - Multiple Turbocharger Engines

Circuit Description

The engine coolant temperature sensor (high temperature) is used by the CM700 to monitor the temperature of the engine high temperature coolant.

Coolant temperature is used by the CM700 for the engine protection system, timing, and fuelling control.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

For multiple turbocharger engines, coolant temperature regulation is achieved by using on-engine wax element thermostats. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 008-013 in Section 8.

Refer to Troubleshooting Fault Code 2789 (Multiple Turbochargers).

Last Modified: 09-Jul-2010


Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2789 - Single Turbocharger

Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2789 PID: SPN: 110 FMI: 18 LAMP: Warning SRT: | Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level. The engine coolant temperature (high temperature) has exceeded the low warning threshold. | No effect on engine performance.
Engine Coolant Temperature Sensor Circuit High Temperature - Single Turbocharger Engines - PowerCommand™ Supervisor 3100 Control
Engine Coolant Temperature Sensor Circuit High Temperature - Single Turbocharger Engines - PowerCommand™ Supervisor 3300 Control

Circuit Description

The engine coolant temperature sensor (high temperature) is used by the CM700 to monitor the temperature of the engine high temperature coolant.

Coolant temperature is used by the CM700 for the engine protection system, timing and fuelling control.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

For single turbocharger engines fitted with PowerCommand™ Supervisor 3100 Generator Set Control, the off-engine temperature control modules and relays are located within the Generator Interface Box (GIB).

For single turbocharger engines fitted with PowerCommand™ Control 3300 Generator Set Control, the off-engine temperature control modules and relays are located within a dedicated panel the location of this panel is site specific. Use the site drawings for location. The customer is responsible for the 24-VDC supply and CM700 communication wiring between the Generator Interface Box and the Temperature Control Panel.

Shop Talk

For single turbocharger engines, coolant temperature regulation is achieved by off-engine electronic temperature control valves. The coolant temperature regulation system consists of the following:

  • High temperature (HT) coolant temperature sensor
  • Low temperature (LT) coolant temperature sensor
  • CM700 electronic control module
  • High temperature system temperature control module
  • Low temperature system temperature control module
  • Two solid-state relays for the high temperature control system (one to open the HT coolant control valve, one to close the HT coolant control valve)
  • Two solid-state relays for the low temperature control system (one to open the LT coolant control valve, one to close the LT coolant control valve)
  • Two cooling system temperature control valves one for the HT cooling system, one for the LT cooling system
  • 24 volt power supply
  • Voltage - 50/60Hz power supply
  • Interconnect harness.

The HT and LT cooling system temperature sensors sense the coolant temperature for each cooling circuit. Their signals are sent to the CM700 module. The CM700 module transmits a 4-20mA signal for each cooling circuit to its respective temperature control module. The 4-20mA signal is directly proportional to the coolant temperature. The temperature control module outputs a 24-VDC signal to either the open or close solid-state relay. The relay energized will output an AC voltage (50/60Hz) to its respective contact in the temperature control valve, and the valve will open or close accordingly (open = reduce coolant temperature, close = increase coolant temperature).

Each temperature control module is programmed with coolant temperature set points, which are dependent on the engine model, fuel rating and HT and LT coolant temperature specification for the specific application. Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395 for fuel rating / coolant operating temperature specifications. Refer to Procedure 018-002 in Section V.

Refer to Troubleshooting Fault Code 2789 (Single Turbocharger).

Last Modified: 09-Jul-2010


Fault Code Path Selection

FAULT CODE 2793
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2793mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2793st

Last Modified: 08-Oct-2010


Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 2793 - Multiple Turbochargers

Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Most Severe Level

CODE | REASON | EFFECT
Fault Code: 2793 PID: SPN: 110 FMI: 1 LAMP: Shutdown SRT: | Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Most Severe Level. The engine coolant temperature (high temperature) has exceeded the low warning threshold. | Engine will shut down.
Engine Coolant Temperature Sensor Circuit - High Temperature - Multiple Turbocharger Engines

Circuit Description

The engine coolant temperature sensor (high temperature) is used by the CM700 to monitor the temperature of the engine high temperature coolant.

Coolant temperature is used by the CM700 for the engine protection system, timing, and fuelling control.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

For multiple turbocharger engines, coolant temperature regulation is achieved by using on-engine wax element thermostats. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 008-013 in Section 8.

Refer to Troubleshooting Fault Code 2793 (Multiple Turbochargers).

Last Modified: 09-Jul-2010


Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 2793 - Single Turbocharger

Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Most Severe Level

CODE | REASON | EFFECT
Fault Code: 2793 PID: SPN: 110 FMI: 1 LAMP: Shutdown SRT: | Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Most Severe Level. The engine coolant temperature (high temperature) has exceeded the low warning threshold. | Engine will shutdown.
Engine Coolant Temperature Sensor Circuit High Temperature - Single Turbocharger Engines - PowerCommand™ Supervisor 3100 Control
Engine Coolant Temperature Sensor Circuit High Temperature - Single Turbocharger Engines - PowerCommand™ Supervisor 3300 Control

Circuit Description

The engine coolant temperature sensor (high temperature) is used by the CM700 to monitor the temperature of the engine high temperature coolant.

Coolant temperature is used by the CM700 for the engine protection system, timing and fuelling control.

Component Location

Use the following procedure for component location.Refer to Procedure 100-002 in Section E.

For single turbocharger engines fitted with PowerCommand™ Supervisor 3100 Generator Set Control, the off-engine temperature control modules and relays are located within the Generator Interface Box (GIB).

For single turbocharger engines fitted with PowerCommand™ Control 3300 Generator Set Control, the off-engine temperature control modules and relays are located within a dedicated panel the location of this panel is site specific. Use the site drawings for location. The customer is responsible for the 24-VDC supply and CM700 communication wiring between the Generator Interface Box and the Temperature Control Panel.

Shop Talk

For single turbocharger engines, coolant temperature regulation is achieved by off-engine electronic temperature control valves. The coolant temperature regulation system consists of the following:

  • High temperature (HT) coolant temperature sensor
  • Low temperature (LT) coolant temperature sensor
  • CM700 electronic control module
  • High temperature system temperature control module
  • Low temperature system temperature control module
  • Two solid-state relays for the high temperature control system (one to open the HT coolant control valve, one to close the HT coolant control valve)
  • Two solid-state relays for the low temperature control system (one to open the LT coolant control valve, one to close the LT coolant control valve)
  • Two cooling system temperature control valves one for the HT cooling system, one for the LT cooling system
  • 24 volt power supply
  • Voltage - 50/60Hz power supply
  • Interconnect harness.

The HT and LT cooling system temperature sensors sense the coolant temperature for each cooling circuit. Their signals are sent to the CM700 module. The CM700 module transmits a 4-20mA signal for each cooling circuit to its respective temperature control module. The 4-20mA signal is directly proportional to the coolant temperature. The temperature control module outputs a 24-VDC signal to either the open or close solid-state relay. The relay energized will output an AC voltage (50/60Hz) to its respective contact in the temperature control valve, and the valve will open or close accordingly (open = reduce coolant temperature, close = increase coolant temperature).

Each temperature control module is programmed with coolant temperature set points, which are dependent on the engine model, fuel rating and HT and LT coolant temperature specification for the specific application. Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395 for fuel rating / coolant operating temperature specifications. Refer to Procedure 018-002 in Section V.

Refer to Troubleshooting Fault Code 2793 (Single Turbocharger).

Last Modified: 09-Jul-2010


Generator Electrical Load Signal - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2796

Generator Electrical Load Signal - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2796 PID: SPN: 2452 FMI: 15 LAMP: Warning SRT: | Generator Electrical Load Signal - Data Valid But Above Normal Operating Range - Least Severe Level. Overload protection is enabled and load is higher than partial continuous load threshold for set persistence time. | No action is taken by the ECM.
Generator Electrical Load (kW) Signal Circuit - GenSet with PowerCommand™ Supervisor (P7 Alternator Circuit Shown)
Generator Control to PLC Communication and PLC to CM700 Modbus Communication Circuits - GenSet with PowerCommand™ Supervisor
Generator Electrical Load (kW) Signal Circuit - GenSet with PCC3300 (P7 Alternator Circuit Shown)
J1939 Data Link Circuit - Multiple Turbochargers - GenSet with PCC3300
J1939 Data Link Circuit - Single Turbocharger - GenSet with PCC3300

Circuit Description

On GenSets with PowerCommand™ Supervisor, the PT / CT module is connected in parallel to the main alternator lines for sensing the primary alternator's voltage and current production. The PT / CT module reduces alternator line voltage to approximately 18-VAC and converts CT sensed current at 0.55 amperes (100 percent load) to approximately 1.65 VAC for analog GenSet control (PCS) input.

On GenSets with PCC3300, altenator voltage and current is sensed directly at the PCC3300 unless alternator voltage is greater than 600 VAC then a PT is employed to reduce alternator voltage below 600 VAC during normal operation for PCC3300 sensing.

On both control platforms, the generator control calculates the alternator's kilowatt electrical load and sends that load signal to the CM700.

Component Location

Use the following procedure for a detailed component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Alternator kW load is compared to three calibratable thresholds:

  • Maximum Critical Overload Threshold with smallest fault persistence time with fault resulting in emergency shutdown.
  • Medium Critical Overload Threshold (Maximum Critcial Overload Threshold > Medium Critical Overload Threshold > GenSet Rating) with longer fault persistence time than Maximum Critical Overload and fault resulting in a controlled shutdown.
  • Low Critical Overload Threshold (Medium Critical Overload Threshold > Low Critical Overload Threshold > Genset Rating) with fault resulting in a warning.
Refer to Troubleshooting Fault Code 2796.

Last Modified: 21-Jul-2010


Engine Turbocharger 1 Boost Pressure - Abnormal Rate of Change

FAULT CODE 2799

Engine Turbocharger 1 Boost Pressure - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2799 PID: SPN: 1127 FMI: 10 LAMP: Stop/Shutdown SRT: | Engine Turbocharger 1 Boost Pressure - Abnormal Rate of Change. With Compressor Outlet Pressure Delta Diagnostic enabled, a large change in pressure sensor voltage with respect to the set time delta is sensed by the CM558, B-bank. | Stop/Shutdown
Multiple Turbocharger Engines
Single Turbocharger Engines

Circuit Description

The compressor pressure sensor is an absolute pressure sensor used to measure the varying pressure of the air/fuel mixture in the intake system of the engine before the throttle plate. The compressor outlet pressure value is used by the engine control modules (ECMs) for the engine protection system, timing and engine emissions control.

The left-bank CM558 ECM supplies 5-VDC to the compressor outlet pressure sensor supply circuit. The left-bank CM558 also provides a ground on the sensor return circuit. The pressure sensor provides a signal to the left-bank CM558 on the compressor outlet pressure signal circuit. This sensor signal voltage changes, based on the pressure in the intake system, after the turbocharger but before the throttle plate. The left-bank CM558 will detect a low signal voltage at operating conditions when the compressor outlet pressure will be low (low load, steady state conditions). The left-bank CM558 will detect a high signal voltage at operating conditions when the compressor outlet pressure will be high (high load or load demand conditions).

Component Location

The compressor outlet pressure sensor is located on the right-bank side, non-drive end of the engine, and is mounted on the charge-air outlet of the aftercooler.

The CM558 is located on the engine left-bank intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the ECM keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The left-bank CM558 module is constantly monitoring the compressor outlet pressure sensor signal. The ECM compares the current compressor outlet pressure reading (p-1) with the immediately preceeding compressor outlet pressure reading (p). If the difference between p-1 and p (Delta p) exceeds 16psia for more than 0.01 seconds, Fault Code 2799 is activated.

Action Taken When the Fault Code is Active

  • The CM558 illuminates the red ALARM SHUTDOWN lamp on the Generator Control Panel immediately when the diagnostic runs and fails. Fault code 2799 will also show as ACTIVE by INSITE™ electronic service tool and on the original equipment manufacturer (OEM) control panel display.
  • The engine will shutdown.

Conditions for Clearing the Fault Code

  • To validate the repair. start the engine and let it run at rated speed for 1 minute at no load.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostics runs and passes.
  • The CM558 will turn off the red ALARM shutdown lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This feature provides protection for the charge-air system, valve train, and power cylinders when a rapid rise in compressor outlet pressure occurs (an intake manifold over-pressure condition). The CM558 compares the current compressor outlet pressure reading (p-1) with the immediately preceeding compressor outlet pressure reading (p), and if the difference between p-1 and p (Delta p) exceeds 16 psia for more than 0.01 seconds, the ECM logs a fault and requests a shutdown.

The troubleshooting steps below give guidance for determining the cause of the intake manifold over-pressure event and the resulting active Fault Code 2799.

Following the activation of Fault Code 2799, an inspection must be performed on the engine to check for any consequential damage. Any issues or damage must be corrected before starting the engine.

The recommended checks are as follows:

  • Check for external coolant leaks between cylinder head and block. Signs of coolant leaks would indicate that the cylinders have lifted during the intake manifold over-pressure event.
  • Check the air filter elements and air filter housing for damage.
  • Inspect the charge-air system for leaks.
  • Inspect the charge-air system pipe work for damage.
  • Check for free movement of the throttle throughout the full range.
  • Check throttle plate alignment.
  • Check the charge-air cooler for leaks (coolant and air/fuel mixture). Check the charge-air cooler element for any damage resulting from the intake manifold over-pressure event.
  • Remove the valve covers and check valve clearances. Check for any abnormalities or misaligned rocker gear, valve stems, valve spring assemblies and collets. Check the intake valve retention cir-clip and washer for damage. Any damaged parts must be replaced prior to starting the engine.
  • Bar the engine over by hand. Any tightness when rotating must be investigated. Dropped intake/exhaust valves and coolant leakage internal to the power cylinders must be considered, which can result in further consequential damage to power cylinder components.
  • Inspect the turbocharger compressor wheel blades, on both turbocharger assemblies, for signs of damage and contect with the compressor housing. If there are any signs of damage, then the turbocharger(s) must be replaced before starting the Generator Set.
  • Following start-up of the generator set, carefully monitor individual cylinder exhaust temperatures via the Human Machine Interface (HMI). Any cold cylinders must be investigated using appropriate investigation and troubleshooting methods.
Refer to Troubleshooting Fault Code t05-2799.

Last Modified: 30-May-2019


Engine Turbocharger 1 Boost Pressure - Data Valid But Above Normal Operational Range - Most Severe Level

FAULT CODE 2811

Engine Turbocharger 1 Boost Pressure - Data Valid But Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2811 PID: SPN: 1127 FMI: 0 LAMP: Stop/Shutdown SRT: | Engine Turbocharger 1 Boost Pressure - Data Valid But Above Normal Operational Range - Most Severe Level. With compressor outlet pressure (COP) maximum diagnostic enabled and the COP maximum is greater than the COP maximum threshold for the COP maximum set duration. | The engine will stop or shutdown.
Compressor Outlet Pressure Sensor Circuit - Single Turbocharger

Circuit Description

The COP sensor measures the absolute boost pressure of the turbocharger outlet. The CM558 supplies the sensor with 5 volts and a return. The sensor produces a signal between 0.5 and 4.5-VDC that is proportional to the measured pressure.

Component Location

Use the following procedure for a detailed component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The compressor outlet pressure is the pressure of the air/fuel mixture after exiting the turbocharger compressor and prior to entering the throttle.

Refer to Troubleshooting Fault Code t05-2811

Last Modified: 30-Jun-2010


Engine Throttle Control Actuator – Data Erratic, Intermittent, or Incorrect

FAULT CODE 2812

Engine Throttle Control Actuator – Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2812 PID: SPN: 3464 FMI: 2 LAMP: Shutdown SRT: | Engine Throttle Control Actuator – Data Erratic, Intermittent, or Incorrect. The throttle is receiving erratic, intermittent, or incorrect data. | Engine will shut down.
Multiple Turbochargers Integrated Throttle
Single Turbocharger Integrated Throttle

Circuit Description

In engines fitted with integrated digital throttles, the throttle assembly is a one-piece unit consisting of an integrated throttle actuator and driver assembly. The throttle assembly receives a ‘commanded position signal’ over the engine's proprietary data link circuit. The throttle position feedback signal is also a digital signal transmitted over the proprietary data link circuit.

This fault code is applicable for generator sets using digital integrated throttle assemblies utilizing a proprietary communication data link network protocol, such as CAN 2.0B.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The new generation of digital integrated throttle assemblies has the ability to self-monitor the throttle actuator for the following conditions:

  • Actuator internal temperature – this fault may beeactivated by a faulty internal temperature sensor.
  • Actuator 12-VDC internal power supply – this fault may be activated if the actuator’s 12-VDC internal supply is out-of-range.
  • Actuator 9-VDC internal power supply – this fault may be activated if the actuator’s 9-VDC internal supply is out-of-range
  • Actuator 5-VDC internal power supply – this fault may be activated if the actuator’s 5-VDC internal supply is out-of-range.
  • Actuator internal software – this fault may be activated if an actuator internal software error exists.
  • Actuator internal EPROM (erasable programmable read only memory) – this fault may be activated if an actuator internal EPROM error exists.
  • Actuator internal position feedback – this fault may be activated if the actuator’s internal monitoring system detects an out-of-range signal on the internal position feedback circuit.
  • General alarm – generated internally within the digital throttle actuator.

The digital throttle actuator receives control command signals from the ECM over the proprietary data link. Should this signal become erratic or intermittent, Fault Code 2812 will be activated.

The digital throttle assemblies are not repairable within the field and faulty digital throttle assemblies should be replaced.

There may be other generator set fault codes activated as a result of Fault Code 2812 being triggered. To avoid the possibility of damaging a new digital throttle assembly, all other active fault codes must be investigated and rectified before replacing the digital throttle assembly.

Refer to Troubleshooting Fault Code t05-2812.

Last Modified: 21-Mar-2011


Engine Electronic Fuel Control Valve 1 Circuit - Root Cause Not Known

FAULT CODE 2814

Engine Electronic Fuel Control Valve 1 Circuit - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2814 PID: SPN: 633 FMI: 11 LAMP: Warning SRT: | Engine Electronic Fuel Control Valve 1 Circuit - Root Cause Not Known. An unidentified failure mode has occurred in the electronic fuel control valve. | The engine will continue to run but performance may be impaired.
QSK60G Multiple Turbochargers with Generator Control Panel 1 (GCP1) with PowerCommand™ Supervisor 3100 and AC and DC Generator Set Terminal Boxes - Engine Electronic Fuel Control Valve 1 Circuit
QSK60G Single and Multiple Turbochargers with Generator Control Panel 2 (GCP2) with PowerCommand™ Supervisor 3100 and Generator Interface Box (GIB) - Engine Electronic Fuel Control Valve 1 Circuit
QSK60G Single and Multiple Turbochargers with PowerCommand™ Control 3300 and Generator Interface Box (GIB) - Engine Electronic Fuel Control Valve 1 Circuit

Circuit Description

The fuel control valve (FCV) position circuit consists of the commanded signal from the CM558 module and the feedback signal that is received by the CM558 from the FCV. The FCV commanded position signal is supplied by the CM558 and is a 24-VDC pulse-width modulated signal (PMW) and the feedback is a 0 to 5-VDC signal.

Component Location

Refer to Procedure 100-002 in Section E for component location.

Shop Talk

If an intermittent electrical circuit problem of the electronic fuel control valve circuit exists, it is possible for Fault Code 2184 to become active and then inactive during normal generator set operation. This would indicate an intermittent open or short circuit.

This fault code can become active for any of the following reasons:

  • Electronic FCV actuator high resistance
  • Engine harness or extension harness high resistance
  • Loose, worn, or corroded connectors or pins at the FCV connector or ECM connector
  • Electronic FCV low internal resistance
  • Electronic FCV or engine harness short to ground
  • Intermittent circuit malfunctions.

Verify that all connectors are clean and free of corrosion before replacing components.

The following table, which can be used as an aid when troubleshooting the FCV operation, provides FCV actuator commanded position, PWM percent duty cycle, and VDC feedback signal specifications.

Actuator Commanded Position | PMW Percent Duty Cycle | 0 to 5-VDC Feedback Signal
0 | 10 - 14 | 0.4 - 0.7
10 | 17 - 21 | 0.9 - 1.1
20 | 25 - 28 | 1.3 - 1.5
30 | 33 - 37 | 1.7 - 1.9
40 | 41 - 44 | 2.1 - 2.3
50 | 49 - 54 | 2.5 - 2.7
60 | 55 - 60 | 2.9 - 3.1
70 | 65 - 70 | 3.3 - 3.5
80 | 73 - 78 | 3.7 - 3.9
90 | 81 - 86 | 4.1 - 4.3
100 | 89 - 94 | 4.6 - 4.8

Note: PWM percent duty cycle signals can only be measured with multimeters or other measuring devices that have a percent duty cycle function.

Refer to Troubleshooting Fault Code t05-2814

Last Modified: 10-Feb-2012


Fault Code Path Selection

FAULT CODE 2837
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2837mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2837st

Last Modified: 08-Oct-2010


Exhaust Gas Temperature Cylinder 1 (A1) - Deviation Error

FAULT CODE 2837 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 1 (A1) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2837 PID: SPN: 1137 FMI: 2 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 1 (A1) - Deviation Error. The difference between cylinder 1 exhaust gas temperature and the average engine exhaust gas temperature has exceeded the Warning threshold. | No effect on engine performance.
Cylinder 1 (A1) Exhaust Gas Temperature Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a "Cylinder # Temperature Deviation" error is activated.

There are two exhaust port temperature deviation protection threshold limits: WARNING, where the individual cylinder deviation against the engine average exceeds 66°C or 119°F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82°C or 148°F.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of misfiring within the cylinder, likely caused by a failing spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning may recover the exhaust temperature (if the cause of the temperature deviation is caused by a worn spark plug) for a short period (1 to 2 days), giving time for a repair action to be coordinated.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2837mt.

Last Modified: 18-Jan-2011


Exhaust Gas Temperature Cylinder 1 (A1) - Deviation Error

FAULT CODE 2837 - Single Turbocharger

Exhaust Gas Temperature Cylinder 1 (A1) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2837st PID: SPN: 1137 FMI: 2 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 1 (A1) Deviation Error. The difference between cylinder 1 exhaust gas temperature and the average engine exhaust temperature has exceeded the Warning threshold. | No effect on engine performance.
Cylinder 1 (A1) Exhaust Temperature Circuit - Single Turbocharger

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules - one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0-5-VDC thermister-type signal which is proportional to temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a "Cylinder Temperature Deviation" error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66° C or 119° F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82° C or 148° F.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning may recover the exhaust temperature (if the cause of the temperature deviation is caused by a worn spark plug) for a short period (1-2 days), giving time for a repair action to be co-ordinated.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are adjacent to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2837st.

Last Modified: 15-Dec-2010


Fault Code Path Selection

FAULT CODE 2838
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2838mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2838st

Last Modified: 08-Oct-2010


Exhaust Gas Temperature Cylinder 3 (A2) - Deviation Error

FAULT CODE 2838 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 3 (A2) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2838 PID: SPN: 1139 FMI: 2 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 3 (A2) - Deviation Error. The difference between cylinder 3 exhaust gas temperature and the average engine exhaust gas temperature has exceeded the Warning threshold. | No effect on engine performance.
Cylinder 3 (A2) Exhaust Gas Temperature Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a "Cylinder # Temperature Deviation" error is activated.

There are two exhaust port temperature deviation protection threshold limits: WARNING, where the individual cylinder deviation against the engine average exceeds 66°C or 119°F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82°C or 148°F.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of misfiring within the cylinder, likely caused by a failing spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning may recover the exhaust temperature (if the cause of the temperature deviation is caused by a worn spark plug) for a short period (1 to 2 days), giving time for a repair action to be coordinated.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2838mt.

Last Modified: 18-Jan-2011


Exhaust Gas Temperature Cylinder 3 (A2) - Deviation Error

FAULT CODE 2838 - Single Turbocharger

Exhaust Gas Temperature Cylinder 3 (A2) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2838st PID: SPN: 1139 FMI: 2 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 3 (A2) Deviation Error. The difference between cylinder 3 exhaust gas temperature and the average engine exhaust temperature has exceeded the Warning threshold. | No effect on engine performance.
Cylinder 3 (A2) Exhaust Temperature Circuit - Single Turbocharger

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules - one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0-5-VDC thermister-type signal which is proportional to temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a "Cylinder Temperature Deviation" error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66° C or 119° F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82° C or 148° F.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning may recover the exhaust temperature (if the cause of the temperature deviation is caused by a worn spark plug) for a short period (1-2 days), giving time for a repair action to be co-ordinated.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are adjacent to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2838st.

Last Modified: 15-Dec-2010


Fault Code Path Selection

FAULT CODE 2839
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2839mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2839st

Last Modified: 08-Oct-2010


Exhaust Gas Temperature Cylinder 5 (A3) - Deviation Error

FAULT CODE 2839 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 5 (A3) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2839 PID: SPN: 1141 FMI: 2 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 5 (A3) - Deviation Error. The difference between cylinder 5 exhaust gas temperature and the average engine exhaust gas temperature has exceeded the Warning threshold. | No effect on engine performance.
Cylinder 5 (A3) Exhaust Gas Temperature Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a "Cylinder # Temperature Deviation" error is activated.

There are two exhaust port temperature deviation protection threshold limits: WARNING, where the individual cylinder deviation against the engine average exceeds 66°C or 119°F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82°C or 148°F.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of misfiring within the cylinder, likely caused by a failing spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning may recover the exhaust temperature (if the cause of the temperature deviation is caused by a worn spark plug) for a short period (1 to 2 days), giving time for a repair action to be coordinated.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2839mt.

Last Modified: 18-Jan-2011


Exhaust Gas Temperature Cylinder 5 (A3) - Deviation Error

FAULT CODE 2839 - Single Turbocharger

Exhaust Gas Temperature Cylinder 5 (A3) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2839st PID: SPN: 1141 FMI: 2 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 5 (A3) Deviation Error. The difference between cylinder 5 exhaust gas temperature and the average engine exhaust temperature has exceeded the Warning threshold. | No effect on engine performance.
Cylinder 5 (A3) Exhaust Temperature Circuit - Single Turbocharger

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules - one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0-5-VDC thermister-type signal which is proportional to temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a "Cylinder Temperature Deviation" error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66° C or 119° F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82° C or 148° F.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning may recover the exhaust temperature (if the cause of the temperature deviation is caused by a worn spark plug) for a short period (1-2 days), giving time for a repair action to be co-ordinated.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are adjacent to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2839st.

Last Modified: 15-Dec-2010


Fault Code Path Selection

FAULT CODE 2841
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2841mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2841st

Last Modified: 08-Oct-2010


Exhaust Gas Temperature Cylinder 7 (A4) - Deviation Error

FAULT CODE 2841 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 7 (A4) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2841 PID: SPN: 1143 FMI: 2 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 7 (A4) - Deviation Error. The difference between cylinder 7 exhaust gas temperature and the average engine exhaust gas temperature has exceeded the Warning threshold. | No effect on engine performance.
Cylinder 7 (A4) Exhaust Gas Temperature Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a "Cylinder # Temperature Deviation" error is activated.

There are two exhaust port temperature deviation protection threshold limits: WARNING, where the individual cylinder deviation against the engine average exceeds 66°C or 119°F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82°C or 148°F.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of misfiring within the cylinder, likely caused by a failing spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning may recover the exhaust temperature (if the cause of the temperature deviation is caused by a worn spark plug) for a short period (1 to 2 days), giving time for a repair action to be coordinated.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2841mt.

Last Modified: 18-Jan-2011


Exhaust Gas Temperature Cylinder 7 (A4) - Deviation Error

FAULT CODE 2841 - Single Turbocharger

Exhaust Gas Temperature Cylinder 7 (A4) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2841st PID: SPN: 1143 FMI: 2 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 7 (A4) Deviation Error. The difference between cylinder 7 exhaust gas temperature and the average engine exhaust temperature has exceeded the Warning threshold. | No effect on engine performance.
Cylinder 7 (A4) Exhaust Temperature Circuit - Single Turbocharger

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules - one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0-5-VDC thermister-type signal which is proportional to temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a "Cylinder Temperature Deviation" error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66° C or 119° F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82° C or 148° F.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning may recover the exhaust temperature (if the cause of the temperature deviation is caused by a worn spark plug) for a short period (1-2 days), giving time for a repair action to be co-ordinated.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are adjacent to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2841st.

Last Modified: 15-Dec-2010


Fault Code Path Selection

FAULT CODE 2842
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2842mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2842st

Last Modified: 08-Oct-2010


Exhaust Gas Temperature Cylinder 9 (A5) - Deviation Error

FAULT CODE 2842 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 9 (A5) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2842 PID: SPN: 1145 FMI: 2 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 9 (A5) - Deviation Error. The difference between cylinder 9 exhaust gas temperature and the average engine exhaust gas temperature has exceeded the Warning threshold. | No effect on engine performance.
Cylinder 9 (A5) Exhaust Gas Temperature Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a "Cylinder # Temperature Deviation" error is activated.

There are two exhaust port temperature deviation protection threshold limits: WARNING, where the individual cylinder deviation against the engine average exceeds 66°C or 119°F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82°C or 148°F.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of misfiring within the cylinder, likely caused by a failing spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning may recover the exhaust temperature (if the cause of the temperature deviation is caused by a worn spark plug) for a short period (1 to 2 days), giving time for a repair action to be coordinated.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-3842mt.

Last Modified: 18-Jan-2011


Exhaust Gas Temperature Cylinder 9 (A5) - Deviation Error

FAULT CODE 2842 - Single Turbocharger

Exhaust Gas Temperature Cylinder 9 (A5) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2842st PID: SPN: 1145 FMI: 2 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 9 (A5) Deviation Error. The difference between cylinder 9 exhaust gas temperature and the average engine exhaust temperature has exceeded the Warning threshold. | No effect on engine performance.
Cylinder 9 (A5) Exhaust Temperature Circuit - Single Turbocharger

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules - one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0-5-VDC thermister-type signal which is proportional to temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a "Cylinder Temperature Deviation" error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66° C or 119° F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82° C or 148° F.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning may recover the exhaust temperature (if the cause of the temperature deviation is caused by a worn spark plug) for a short period (1-2 days), giving time for a repair action to be co-ordinated.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are adjacent to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2842st.

Last Modified: 15-Dec-2010


Fault Code Path Selection

FAULT CODE 2843
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2843mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2843st

Last Modified: 08-Oct-2010


Exhaust Gas Temperature Cylinder 11 (A6) - Deviation Error

FAULT CODE 2843 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 11 (A6) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2843 PID: SPN: 1147 FMI: 2 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 11 (A6)) - Deviation Error. The difference between cylinder 11 exhaust gas temperature and the average engine exhaust gas temperature has exceeded the Warning threshold. | No effect on engine performance.
Cylinder 11 (A6) Exhaust Gas Temperature Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a "Cylinder # Temperature Deviation" error is activated.

There are two exhaust port temperature deviation protection threshold limits: WARNING, where the individual cylinder deviation against the engine average exceeds 66°C or 119°F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82°C or 148°F.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of misfiring within the cylinder, likely caused by a failing spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning may recover the exhaust temperature (if the cause of the temperature deviation is caused by a worn spark plug) for a short period (1 to 2 days), giving time for a repair action to be coordinated.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2843mt.

Last Modified: 18-Jan-2011


Exhaust Gas Temperature Cylinder 11 (A6) - Deviation Error

FAULT CODE 2843 - Single Turbocharger

Exhaust Gas Temperature Cylinder 11 (A6) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2843st PID: SPN: 1147 FMI: 2 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 11 (A6) Deviation Error. The difference between cylinder 11 exhaust gas temperature and the average engine exhaust temperature has exceeded the Warning threshold. | No effect on engine performance.
Cylinder 11 (A6) Exhaust Temperature Circuit - Single Turbocharger

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules - one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0-5-VDC thermister-type signal which is proportional to temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a "Cylinder Temperature Deviation" error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66° C or 119° F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82° C or 148° F.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning may recover the exhaust temperature (if the cause of the temperature deviation is caused by a worn spark plug) for a short period (1-2 days), giving time for a repair action to be co-ordinated.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are adjacent to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2843st.

Last Modified: 15-Dec-2010


Fault Code Path Selection

FAULT CODE 2844
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2844mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2844st

Last Modified: 08-Oct-2010


Exhaust Gas Temperature Cylinder 13 (A7) - Deviation Error

FAULT CODE 2844 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 13 (A7) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2844 PID: SPN: 1149 FMI: 2 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 13 (A7) - Deviation Error. The difference between cylinder 13 exhaust gas temperature and the average engine exhaust gas temperature has exceeded the Warning threshold. | No effect on engine performance.
Cylinder 13 (A7) Exhaust Gas Temperature Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a "Cylinder # Temperature Deviation" error is activated.

There are two exhaust port temperature deviation protection threshold limits: WARNING, where the individual cylinder deviation against the engine average exceeds 66°C or 119°F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82°C or 148°F.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of misfiring within the cylinder, likely caused by a failing spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning may recover the exhaust temperature (if the cause of the temperature deviation is caused by a worn spark plug) for a short period (1 to 2 days), giving time for a repair action to be coordinated.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2844mt.

Last Modified: 18-Jan-2011


Exhaust Gas Temperature Cylinder 13 (A7) - Deviation Error

FAULT CODE 2844 - Single Turbocharger

Exhaust Gas Temperature Cylinder 13 (A7) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2844st PID: SPN: 1149 FMI: 2 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 13 (A7) Deviation Error. The difference between cylinder 13 exhaust gas temperature and the average engine exhaust temperature has exceeded the Warning threshold. | No effect on engine performance.
Cylinder 13 (A7) Exhaust Temperature Circuit - Single Turbocharger

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules - one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0-5-VDC thermister-type signal which is proportional to temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a "Cylinder Temperature Deviation" error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66° C or 119° F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82° C or 148° F.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning may recover the exhaust temperature (if the cause of the temperature deviation is caused by a worn spark plug) for a short period (1-2 days), giving time for a repair action to be co-ordinated.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are adjacent to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2844st.

Last Modified: 15-Dec-2010


Fault Code Path Selection

FAULT CODE 2845
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2845mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2845st

Last Modified: 08-Oct-2010


Exhaust Gas Temperature Cylinder 15 (A8) - Deviation Error

FAULT CODE 2845 - Multiple Turbochagers

Exhaust Gas Temperature Cylinder 15 (A8) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2845 PID: SPN: 1151 FMI: 2 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 15 (A8) - Deviation Error. The difference between cylinder 15 exhaust gas temperature and the average engine exhaust gas temperature has exceeded the Warning threshold. | No effect on engine performance.
Cylinder 15 (A8) Exhaust Gas Temperature Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a "Cylinder # Temperature Deviation" error is activated.

There are two exhaust port temperature deviation protection threshold limits: WARNING, where the individual cylinder deviation against the engine average exceeds 66°C or 119°F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82°C or 148°F.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of misfiring within the cylinder, likely caused by a failing spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning may recover the exhaust temperature (if the cause of the temperature deviation is caused by a worn spark plug) for a short period (1 to 2 days), giving time for a repair action to be coordinated.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2845mt.

Last Modified: 18-Jan-2011


Exhaust Gas Temperature Cylinder 15 (A8) - Deviation Error

FAULT CODE 2845 - Single Turbocharger

Exhaust Gas Temperature Cylinder 15 (A8) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2845st PID: SPN: 1151 FMI: 2 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 15 (A8) Deviation Error. The difference between cylinder 15 exhaust gas temperature and the average engine exhaust temperature has exceeded the Warning threshold. | No effect on engine performance.
Cylinder 15 (A8) Exhaust Temperature Circuit - Single Turbocharger

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules - one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0-5-VDC thermister-type signal which is proportional to temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a "Cylinder Temperature Deviation" error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66° C or 119° F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82° C or 148° F.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning may recover the exhaust temperature (if the cause of the temperature deviation is caused by a worn spark plug) for a short period (1-2 days), giving time for a repair action to be co-ordinated.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are adjacent to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2845st.

Last Modified: 15-Dec-2010


Fault Code Path Selection

FAULT CODE 2847
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2847mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2847st

Last Modified: 08-Oct-2010


Exhaust Gas Temperature Cylinder 2 (B1) - Deviation Error

FAULT CODE 2847 - Multiple Turbochagers

Exhaust Gas Temperature Cylinder 2 (B1) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2847 PID: SPN: 1138 FMI: 2 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 2 (B1) - Deviation Error. The difference between cylinder 2 exhaust gas temperature and the average engine exhaust gas temperature has exceeded the Warning threshold. | No effect on engine performance.
Cylinder 2 (B1) Exhaust Gas Temperature Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a "Cylinder # Temperature Deviation" error is activated.

There are two exhaust port temperature deviation protection threshold limits: WARNING, where the individual cylinder deviation against the engine average exceeds 66°C or 119°F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82°C or 148°F.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of misfiring within the cylinder, likely caused by a failing spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning may recover the exhaust temperature (if the cause of the temperature deviation is caused by a worn spark plug) for a short period (1 to 2 days), giving time for a repair action to be coordinated.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2847mt.

Last Modified: 18-Jan-2011


Exhaust Gas Temperature Cylinder 2 (B1) - Deviation Error

FAULT CODE 2847 - Single Turbocharger

Exhaust Gas Temperature Cylinder 2 (B1) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2847st PID: SPN: 1138 FMI: 2 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 2 (B1) Deviation Error. The difference between cylinder 2 exhaust gas temperature and the average engine exhaust temperature has exceeded the Warning threshold. | No effect on engine performance.
Cylinder 2 (B1) Exhaust Temperature Circuit - Single Turbocharger

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules - one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0-5-VDC thermister-type signal which is proportional to temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a "Cylinder Temperature Deviation" error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66° C or 119° F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82° C or 148° F.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning may recover the exhaust temperature (if the cause of the temperature deviation is caused by a worn spark plug) for a short period (1-2 days), giving time for a repair action to be co-ordinated.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are adjacent to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2847st.

Last Modified: 15-Dec-2010


Fault Code Path Selection

FAULT CODE 2848
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2848mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2848st

Last Modified: 08-Oct-2010


Exhaust Gas Temperature Cylinder 4 (B2) - Deviation Error

FAULT CODE 2848 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 4 (B2) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2848 PID: SPN: 1140 FMI: 2 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 4 (B2) - Deviation Error. The difference between cylinder 4 exhaust gas temperature and the average engine exhaust gas temperature has exceeded the Warning threshold. | No effect on engine performance.
Cylinder 4 (B2) Exhaust Gas Temperature Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a "Cylinder # Temperature Deviation" error is activated.

There are two exhaust port temperature deviation protection threshold limits: WARNING, where the individual cylinder deviation against the engine average exceeds 66°C or 119°F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82°C or 148°F.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of misfiring within the cylinder, likely caused by a failing spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning may recover the exhaust temperature (if the cause of the temperature deviation is caused by a worn spark plug) for a short period (1 to 2 days), giving time for a repair action to be coordinated.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2848mt.

Last Modified: 18-Jan-2011


Exhaust Gas Temperature Cylinder 4 (B2) - Deviation Error

FAULT CODE 2848 - Single Turbocharger

Exhaust Gas Temperature Cylinder 4 (B2) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2848st PID: SPN: 1140 FMI: 2 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 4 (B2) Deviation Error. The difference between cylinder 4 exhaust gas temperature and the average engine exhaust temperature has exceeded the Warning threshold. | No effect on engine performance.
Cylinder 4 (B2) Exhaust Temperature Circuit - Single Turbocharger

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules - one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0-5-VDC thermister-type signal which is proportional to temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a "Cylinder Temperature Deviation" error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66° C or 119° F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82° C or 148° F.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning may recover the exhaust temperature (if the cause of the temperature deviation is caused by a worn spark plug) for a short period (1-2 days), giving time for a repair action to be co-ordinated.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are adjacent to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2848st.

Last Modified: 15-Dec-2010


Fault Code Path Selection

FAULT CODE 2849
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2849mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2849st

Last Modified: 08-Oct-2010


Exhaust Gas Temperature Cylinder 6 (B3) - Deviation Error

FAULT CODE 2849 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 6 (B3) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2849 PID: SPN: 1142 FMI: 2 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 6 (B3) - Deviation Error. The difference between cylinder 6 exhaust gas temperature and the average engine exhaust gas temperature has exceeded the Warning threshold. | No effect on engine performance.
Cylinder 6 (B3) Exhaust Gas Temperature Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a "Cylinder # Temperature Deviation" error is activated.

There are two exhaust port temperature deviation protection threshold limits: WARNING, where the individual cylinder deviation against the engine average exceeds 66°C or 119°F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82°C or 148°F.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of misfiring within the cylinder, likely caused by a failing spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning may recover the exhaust temperature (if the cause of the temperature deviation is caused by a worn spark plug) for a short period (1 to 2 days), giving time for a repair action to be coordinated.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2849mt.

Last Modified: 18-Jan-2011


Exhaust Gas Temperature Cylinder 6 (B3) - Deviation Error

FAULT CODE 2849 - Single Turbocharger

Exhaust Gas Temperature Cylinder 6 (B3) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2849st PID: SPN: 1142 FMI: 2 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 6 (B3) Deviation Error. The difference between cylinder 6 exhaust gas temperature and the average engine exhaust temperature has exceeded the Warning threshold. | No effect on engine performance.
Cylinder 6 (B3) Exhaust Temperature Circuit - Single Turbocharger

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules - one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0-5-VDC thermister-type signal which is proportional to temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a "Cylinder Temperature Deviation" error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66° C or 119° F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82° C or 148° F.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning may recover the exhaust temperature (if the cause of the temperature deviation is caused by a worn spark plug) for a short period (1-2 days), giving time for a repair action to be co-ordinated.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are adjacent to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2849st.

Last Modified: 15-Dec-2010


Fault Code Path Selection

FAULT CODE 2851
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2851mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2851st

Last Modified: 08-Oct-2010


Exhaust Gas Temperature Cylinder 8 (B4) - Deviation Error

FAULT CODE 2851 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 8 (B4) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2851 PID: SPN: 1137 FMI: 2 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 8 (B4) - Deviation Error. The difference between cylinder 8 exhaust gas temperature and the average engine exhaust gas temperature has exceeded the Warning threshold. | No effect on engine performance.
Cylinder 8 (B4) Exhaust Gas Temperature Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a "Cylinder # Temperature Deviation" error is activated.

There are two exhaust port temperature deviation protection threshold limits: WARNING, where the individual cylinder deviation against the engine average exceeds 66°C or 119°F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82°C or 148°F.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of misfiring within the cylinder, likely caused by a failing spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning may recover the exhaust temperature (if the cause of the temperature deviation is caused by a worn spark plug) for a short period (1 to 2 days), giving time for a repair action to be coordinated.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2851mt.

Last Modified: 18-Jan-2011


Exhaust Gas Temperature Cylinder 8 (B4) - Deviation Error

FAULT CODE 2851 - Single Turbocharger

Exhaust Gas Temperature Cylinder 8 (B4) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2851st PID: SPN: 1144 FMI: 2 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 8 (B4) Deviation Error. The difference between cylinder 8 exhaust gas temperature and the average engine exhaust temperature has exceeded the Warning threshold. | No effect on engine performance.
Cylinder 8 (B4) Exhaust Temperature Circuit - Single Turbocharger

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules - one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0-5-VDC thermister-type signal which is proportional to temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a "Cylinder Temperature Deviation" error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66° C or 119° F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82° C or 148° F.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning may recover the exhaust temperature (if the cause of the temperature deviation is caused by a worn spark plug) for a short period (1-2 days), giving time for a repair action to be co-ordinated.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are adjacent to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2851st.

Last Modified: 15-Dec-2010


Fault Code Path Selection

FAULT CODE 2852
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2852mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2852st

Last Modified: 08-Oct-2010


Exhaust Gas Temperature Cylinder 10 (B5) - Deviation Error

FAULT CODE 2852 - Multiple Turbochagers

Exhaust Gas Temperature Cylinder 10 (B5) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2852 PID: SPN: 1146 FMI: 2 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 10 (B5) - Deviation Error. The difference between cylinder 10 exhaust gas temperature and the average engine exhaust gas temperature has exceeded the Warning threshold. | No effect on engine performance.
Cylinder 10 (B5) Exhaust Gas Temperature Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a "Cylinder # Temperature Deviation" error is activated.

There are two exhaust port temperature deviation protection threshold limits: WARNING, where the individual cylinder deviation against the engine average exceeds 66°C or 119°F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82°C or 148°F.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of misfiring within the cylinder, likely caused by a failing spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning may recover the exhaust temperature (if the cause of the temperature deviation is caused by a worn spark plug) for a short period (1 to 2 days), giving time for a repair action to be coordinated.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2852mt.

Last Modified: 18-Jan-2011


Exhaust Gas Temperature Cylinder 10 (B5) - Deviation Error

FAULT CODE 2852 - Single Turbocharger

Exhaust Gas Temperature Cylinder 10 (B5) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2852st PID: SPN: 1146 FMI: 2 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 10 (B5) Deviation Error. The difference between cylinder 10 exhaust gas temperature and the average engine exhaust temperature has exceeded the Warning threshold. | No effect on engine performance.
Cylinder 10 (B5) Exhaust Temperature Circuit - Single Turbocharger

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules - one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0-5-VDC thermister-type signal which is proportional to temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a "Cylinder Temperature Deviation" error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66° C or 119° F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82° C or 148° F.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning may recover the exhaust temperature (if the cause of the temperature deviation is caused by a worn spark plug) for a short period (1-2 days), giving time for a repair action to be co-ordinated.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are adjacent to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2852st.

Last Modified: 15-Dec-2010


Fault Code Path Selection

FAULT CODE 2853
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2853mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2853st

Last Modified: 08-Oct-2010


Exhaust Gas Temperature Cylinder 12 (B6) - Deviation Error

FAULT CODE 2853 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 12 (B6) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2853 PID: SPN: 1148 FMI: 2 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 12 (B6) - Deviation Error. The difference between cylinder 12 exhaust gas temperature and the average engine exhaust gas temperature has exceeded the Warning threshold. | No effect on engine performance.
Cylinder 12 (B6) Exhaust Gas Temperature Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a "Cylinder # Temperature Deviation" error is activated.

There are two exhaust port temperature deviation protection threshold limits: WARNING, where the individual cylinder deviation against the engine average exceeds 66°C or 119°F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82°C or 148°F.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of misfiring within the cylinder, likely caused by a failing spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning may recover the exhaust temperature (if the cause of the temperature deviation is caused by a worn spark plug) for a short period (1 to 2 days), giving time for a repair action to be coordinated.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2853mt.

Last Modified: 18-Jan-2011


Exhaust Gas Temperature Cylinder 12 (B6) - Deviation Error

FAULT CODE 2853 - Single Turbocharger

Exhaust Gas Temperature Cylinder 12 (B6) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2853st PID: SPN: 1148 FMI: 2 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 12 (B6) Deviation Error. The difference between cylinder 12 exhaust gas temperature and the average engine exhaust temperature has exceeded the Warning threshold. | No effect on engine performance.
Cylinder 12 (B6) Exhaust Temperature Circuit - Single Turbocharger

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules - one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0-5-VDC thermister-type signal which is proportional to temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a "Cylinder Temperature Deviation" error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66° C or 119° F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82° C or 148° F.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning may recover the exhaust temperature (if the cause of the temperature deviation is caused by a worn spark plug) for a short period (1-2 days), giving time for a repair action to be co-ordinated.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are adjacent to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2853st.

Last Modified: 15-Dec-2010


Fault Code Path Selection

FAULT CODE 2854
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2854mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2854st

Last Modified: 08-Oct-2010


Exhaust Gas Temperature Cylinder 14 (B7) - Deviation Error

FAULT CODE 2854 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 14 (B7) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2854 PID: SPN: 1150 FMI: 2 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 14 (B7) - Deviation Error. The difference between cylinder 14 exhaust gas temperature and the average engine exhaust gas temperature has exceeded the Warning threshold. | No effect on engine performance.
Cylinder 14 (B7) Exhaust Gas Temperature Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a "Cylinder # Temperature Deviation" error is activated.

There are two exhaust port temperature deviation protection threshold limits: WARNING, where the individual cylinder deviation against the engine average exceeds 66°C or 119°F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82°C or 148°F.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of misfiring within the cylinder, likely caused by a failing spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning may recover the exhaust temperature (if the cause of the temperature deviation is caused by a worn spark plug) for a short period (1 to 2 days), giving time for a repair action to be coordinated.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2854mt.

Last Modified: 18-Jan-2011


Exhaust Gas Temperature Cylinder 14 (B7) - Deviation Error

FAULT CODE 2854 - Single Turbocharger

Exhaust Gas Temperature Cylinder 14 (B7) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2854st PID: SPN: 1150 FMI: 2 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 14 (B7) Deviation Error. The difference between cylinder 14 exhaust gas temperature and the average engine exhaust temperature has exceeded the Warning threshold. | No effect on engine performance.
Cylinder 14 (B7) Exhaust Temperature Circuit - Single Turbocharger

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules - one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0-5-VDC thermister-type signal which is proportional to temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a "Cylinder Temperature Deviation" error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66° C or 119° F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82° C or 148° F.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning may recover the exhaust temperature (if the cause of the temperature deviation is caused by a worn spark plug) for a short period (1-2 days), giving time for a repair action to be co-ordinated.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are adjacent to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2854st.

Last Modified: 15-Dec-2010


Fault Code Path Selection

FAULT CODE 2855
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc2855mt
Is this engine equipped with a single turbocharger? | Go to 59-fc2855st

Last Modified: 08-Oct-2010


Exhaust Gas Temperature Cylinder 16 (B8) - Deviation Error

FAULT CODE 2855 - Multiple Turbochargers

Exhaust Gas Temperature Cylinder 16 (B8) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2855 PID: SPN: 1152 FMI: 2 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 16 (B8) - Deviation Error. The difference between cylinder 16 exhaust gas temperature and the average engine exhaust gas temperature has exceeded the Warning threshold. | No effect on engine performance.
Cylinder 16 (B8) Exhaust Gas Temperature Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a "Cylinder # Temperature Deviation" error is activated.

There are two exhaust port temperature deviation protection threshold limits: WARNING, where the individual cylinder deviation against the engine average exceeds 66°C or 119°F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82°C or 148°F.

Component Location

The exhaust gas temperature sensor circuit is located in the engine harness. Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of misfiring within the cylinder, likely caused by a failing spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning may recover the exhaust temperature (if the cause of the temperature deviation is caused by a worn spark plug) for a short period (1 to 2 days), giving time for a repair action to be coordinated.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are local to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2855mt.

Last Modified: 18-Jan-2011


Exhaust Gas Temperature Cylinder 16 (B8) - Deviation Error

FAULT CODE 2855 - Single Turbocharger

Exhaust Gas Temperature Cylinder 16 (B8) - Deviation Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2855st PID: SPN: 1152 FMI: 2 LAMP: Warning SRT: | Exhaust Gas Temperature Cylinder 16 (B8) Deviation Error. The difference between cylinder 16 exhaust gas temperature and the average engine exhaust temperature has exceeded the Warning threshold. | No effect on engine performance.
Cylinder 16 (B8) Exhaust Temperature Circuit - Single Turbocharger

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules - one for each bank, which sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0-5-VDC thermister-type signal which is proportional to temperature.

To provide individual cylinder exhaust gas temperature deviation protection, the CM700 monitors individual exhaust port temperatures for any deviation against the average of all exhaust port temperatures. If this deviation is too great, a "Cylinder Temperature Deviation" error is activated.

There are two exhaust port temperature deviation protection threshold limits; WARNING, where the individual cylinder deviation against the engine average exceeds 66° C or 119° F, and SHUTDOWN, where the individual cylinder deviation against the engine average exceeds 82° C or 148° F.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust port temperature is a monitor of the in-cylinder combustion process. This parameter can be particularly useful for troubleshooting by comparing to other cylinders, trending over time, verifying fault locations, etc. Individual cylinder deviation alarms can be an indication of mis-firing within the cylinder, likely caused by a malfunctioning spark plug, and is designed to give the operator sufficient time to assess the situation, plan a repair action, and avoid an unscheduled shutdown.

If operating in a multiple generator set power plant or installation, redistributing the system load to reduce power from the generator set with this warning may recover the exhaust temperature (if the cause of the temperature deviation is caused by a worn spark plug) for a short period (1-2 days), giving time for a repair action to be co-ordinated.

If more than one cylinder on the engine has an exhaust port temperature deviation, and these cylinders are adjacent to each other, the intake and/or exhaust systems should be inspected for possible blockages/obstructions.

Refer to Troubleshooting Fault Code t05-2855st.

Last Modified: 15-Dec-2010


Turbocharger Number 1 Speed High - Data Valid but Above Normal Operational Range - Most Severe Level

FAULT CODE 2857

Turbocharger Number 1 Speed High - Data Valid but Above Normal Operational Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2857 PID: P103 SPN: 103 FMI: 0 LAMP: Shutdown SRT: | Turbocharger Number 1 Speed High - Data Valid but Above Normal Operational Range - Most Severe Level. High turbocharger speed has been detected. | Generator will shutdown.
Turbocharger Number 1 Speed High Circuit - Single Turbocharger

Circuit Description

The turbocharger speed sensor is a variable reluctance sensor consisting of a wire coil wrapped around an iron core and aimed at an induction target. To measure turbocharger shaft rotational speed, a ground flat target is centrally located on the shaft. The induction pulses are sent to be processed by the CM700.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger. Refer to Procedure 100-002 (Engine Diagrams in Section E for a detailed component location view.

Shop Talk

The CM700 detected the turbocharger shaft rotation speed as greater than the critical high speed threshold for the critical dwell time. High turbocharger shaft speed can result in shortened shaft bearing life or significant turbocharger damage with aftercooler contamination or engine contaminant ingestion if turbocharger rotating components break due to the high speed rotational forces. This can be caused by:

  • Engine running in an overload condition
  • Engine running at or near rated load but the air/fuel mixture is too lean
  • Turbocharger speed sensor malfunction
  • CM700 power supply or grounds.
Refer to Troubleshooting Fault Code t05-2857

Last Modified: 30-Jun-2010


Alternator Heater Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2859

Alternator Heater Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

Alternator Heater Control Circuit - Voltage Above Normal or Shorted to High Source

CODE | REASON | EFFECT
Fault Code: 2859 PID: SPN: 520377 FMI: 3 LAMP: Warning SRT: | Alternator Heater Control Circuit - Voltage Above Normal or Shorted to High Source. Alternator heater control circuit voltage is sensed out of range (high) when the heaters are commanded on. | No alternator heating.
Alternator Heater Control Circuit - Single Turbocharger

Circuit Description

The CM700 software commands the alternator heater(s) on or off with the application of voltage to relay KM8's driver circuit.

Component Location

Refer to Procedure 100-002 in Section E Relay KM8 is located in the Generator Interface Box (GIB).

Shop Talk

The alternator heaters are used to prevent the build up of moisture due to condensation when the generator is not running. Condensation within the alternator can compromise the integrity of the winding insulation and can lead to significant damage to the alternator.

Possible causes for this fault code include:

  • Open circuit in the engine harness, connectors, or alternator heater control relay
  • Alternator heater control signal wire shorted to a voltage source in the harness.
Refer to Troubleshooting Fault Code t05-2859

Last Modified: 30-Jun-2010


Alternator Heater Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2861

Alternator Heater Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

Alternator Heater Control Circuit - Voltage Below Normal or Shorted to Low Source

CODE | REASON | EFFECT
Fault Code: 2861 PID: SPN: 520377 FMI: 3 LAMP: Warning SRT: | Alternator Heater Control Circuit - Voltage Below Normal or Shorted to Low Source. Alternator heater control circuit voltage is sensed out of range (low) when the heaters are commanded on. | Shorted to ground - Alternator heater always on. Open Circuit - no alternator heating.
Alternator Heater Control Circuit - Single Turbocharger

Circuit Description

The CM700 software commands the alternator heater(s) on or off with the application of voltage to relay KM8's driver circuit.

Component Location

Refer to Procedure 100-002 in Section E. Relay KM8 is located in the Generator Interface Box (GIB).

Shop Talk

The alternator heaters are used to prevent the build up of moisture due to condensation when the generator is not running. Condensation within the alternator can compromise the integrity of the winding insulation and can lead to significant damage to the alternator.

Possible causes for this fault code include:

  • Short circuit to ground in the engine harness, connectors, or alternator heater control relay
  • Open circuit in the alternator heater control circuit.
Refer to Troubleshooting Fault Code t05-2861

Last Modified: 30-Jun-2010


Engine ECM to Gen Set Controller Communications - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2863

Engine ECM to Gen Set Controller Communications - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE REASON EFFECT
Fault Code: 2863
PID:
SPN: 520381
FMI: 2
LAMP: Shutdown
SRT:

Engine ECM to Gen Set Controller Communications - Data Erratic, Intermittent, or Incorrect. The CM700 J1939 communication data link with generator set control message timed out error count is higher than fault threshold.

  • Generator Controller Message 1 Lost - Critical
  • Generator Controller Message 2 Lost - Critcial
  • Generator AC Switching Message Lost Lost - Critical
  • Engine to GenSet Communications Message Lost - Critical
  • GenSet Controller Message 1 Lost - Critical
  • GenSet Controller Message 2 Lost - Critical
  • Generator AC Switching Message Lost - Critical
  • Engine to GenSet Communications Message Lost - Critical

The engine will shut down.
J1939 Data Link Circuit - Muliple Turbocharger
J1939 Data Link Circuit - Single Turbocharger

Circuit Description

The J1939 data link is a public data link that broadcasts engine operating data as well as fault codes.

Component Location

Use the following procedure for a detailed component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The J1939 data link is a network data link on which each ECM is attached via a network stub connection. Make sure the electronic service tool is set up for J1939 communications (if applicable) when using this data link. Although this link provides important diagnostic and engine protection information, the engine will continue to run without it.

Refer to Troubleshooting Fault Code t05-2863

Last Modified: 30-Jun-2010


Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2864

Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2864 PID: SPN: 632 FMI: 3 LAMP: Shutdown SRT: | Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source. High voltage has been detected at the engine fuel shutoff valve driver circuit. | The engine will shut down.
QSK60G Multiple Turbochargers with Generator Control Panel 1 (GCP1) and PowerCommand™ Supervisor 3100
QSK60G Single and Multiple Turbochargers with Generator Control Panel 2 (GCP2) and PowerCommand™ Supervisor 3100
QSK60G Single and Multiple Turbochargers with PowerCommand™ Control 3300

Circuit Description

The engine fuel shutoff valve is commanded by the CM700 module. The module outputs operate relays, which then power the respective solenoids in the fuel shutoff valve.

Component Location

The fuel shutoff valve is located off the engine and is site specific. Reference the site installation drawings for location.

Shop Talk

N/A

Refer to Troubleshooting Fault Code t05-2864.

Last Modified: 22-Feb-2011


Engine Electronic Fuel Control Valve 1 Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2866

Engine Electronic Fuel Control Valve 1 Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2866 PID: SPN: 1442 FMI: 3 LAMP: Warning SRT: | Engine Electronic Fuel Control Valve 1 Position Sensor Circuit - Voltage Above Normal or Shorted to High Source. A high voltage has been detected in the fuel control valve position circuit. | The engine will continue to run but performance may be impaired.
QSK60G Multiple Turbochargers with Generator Control Panel 1 (GCP1) with PowerCommand™ Supervisor 3100 and AC and DC Generator Set Terminal Boxes
QSK60G Single and Multiple Turbochargers with Generator Control Panel 2(GCP2) with PowerCommand™ Supervisor 3100 and Generator Interface Box(GIB)
QSK60G Single and Multiple Turbochargers with PowerCommand™ Control 3300 and Generator Interface Box (GIB)

Circuit Description

The fuel control valve (FCV) position circuit consists of the commanded position signal from the CM558 module and the position feedback signal that is received by the CM558 from the fuel control valve. The fuel control valve commanded position signal is supplied by the CM558 and is a 24-VDC pulse width modulated signal and the feedback is a 0 to 5-VDC signal.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The most common causes for Fault Code 2866 to be activated are if electrical circuit problems of the electronic fuel control valve circuit exist, such as open or short circuits.

The fuel control valve is not repairable, so if the valve is determined to have malfunctioned after following the troubleshooting steps, it will be necessary to replace the fuel control valve assembly.

The following table, which can be used as an aid when checking the fuel control valve operation, provides actuator position commanded pulse width modulated percent duty cycle and VDC feedback signal specifications.

Actuator Commanded Position | Percent Duty Cycle | 0 - 5-VDC Feedback Signal
0 | 10-11 | 0.4 - 0.7
10 | 17 - 19 | 0.9 - 1.1
20 | 25 - 27 | 1.3 - 1.5
30 | 33 - 35 | 1.7 - 1.9
40 | 41 - 43 | 2.1 - 2.3
50 | 49 - 51 | 2.5 - 2.7
60 | 57 - 59 | 2.9 - 3.1
70 | 65 - 67 | 3.3 - 3.5
80 | 73 - 75 | 3.7 - 3.9
90 | 81 - 83 | 4.1 - 4.3
100 | 89 - 91 | 4.6 - 4.8

Note: Pulse width modulated (PWM) percent duty-cycle signals can only be measured with multimeters or other measuring devices that have a percent duty-cycle function.

Refer to Troubleshooting Fault Code t05-2866.

Last Modified: 09-Mar-2011


Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2867

Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2867 PID: SPN: 1442 FMI: 4 LAMP: Warning SRT: | Engine Electronic Fuel Valve 1 Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source. A low voltage has been detected on the fuel control valve position circuit. | The engine will continue to run but performance may be impaired.
QSK60G Multiple Turbochargers with Generator Control Panel 1 (GCP1) with PowerCommand™ Supervisor 3100 and AC and DC Generator Set Terminal Boxes
QSK60G Single and Multiple Turbochargers with Generator Control Panel 2 (GCP2) with PowerCommand™ Supervisor 3100 and Generator Interface Box (GIB)
QSK60G Single and Multiple Turbochargers with PowerCommand™ Control 3300 and Generator Interface Box (GIB)

Circuit Description

The fuel control valve (FCV) position circuit consists of the commanded position signal from the CM558 module and the position feedback signal that is received by the CM558 from the fuel control valve. The fuel control valve commanded position signal is supplied by the CM558 and is a 24-VDC pulse width modulated signal and the feedback is a 0 to 5-VDC signal.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The most common causes for Fault Code 2867 to be activated are if electrical circuit problems of the electronic fuel control valve circuit exist, such as open or short circuits.

The fuel control valve is not repairable, so if the valve is determined to have malfunctioned after following the troubleshooting steps, it will be necessary to replace the fuel control valve assembly.

The following table, which can be used as an aid when checking the fuel control valve operation, provides actuator position commanded pulse width modulated percent duty cycle and VDC feedback signal specifications.

Actuator Commanded Position | Percent Duty Cycle | 0 - 5-VDC Feedback Signal
0 | 10-11 | 0.4 - 0.7
10 | 17 - 19 | 0.9 - 1.1
20 | 25 - 27 | 1.3 - 1.5
30 | 33 - 35 | 1.7 - 1.9
40 | 41 - 43 | 2.1 - 2.3
50 | 49 - 51 | 2.5 - 2.7
60 | 57 - 59 | 2.9 - 3.1
70 | 65 - 67 | 3.3 - 3.5
80 | 73 - 75 | 3.7 - 3.9
90 | 81 - 83 | 4.1 - 4.3
100 | 89 - 91 | 4.6 - 4.8

Note: Pulse width modulated percent duty cycle signals can only be measured with multimeters or other measuring devices that have a percent duty cycle function.

Refer to Troubleshooting Fault Code t05-2867.

Last Modified: 28-Feb-2011


Engine Block/Coolant Pre-heater Control Circuit - Engine Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2868

Engine Block/Coolant Pre-heater Control Circuit - Engine Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

Engine Block/Coolant Pre-heater Control Circuit - Engine Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level

CODE | REASON | EFFECT
Fault Code: 2868 PID: SPN: 3604 FMI: 16 LAMP: Warning SRT: | Engine Block/Coolant Pre-heater Control Circuit - Engine Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level. With the engine heater over temperature diagnostic enabled, the engine heater over temperature input is active and the engine heater is commanded on. | Warning, loss of engine heater control.
Engine Coolant Temperature Sensing Circuit
Coolant Heater Circuit (380 - 440V 50 Hz 3 Phase 4 Wire)
Coolant Heater Circuit (480 - 60 Hz 3 Phase 3 Wire)

Circuit Description

Temperature Sensing: The engine coolant temperature sensors employ an internal resistor that varies inversely with the sensed temperature; as temperature increases, the resistance decreases. The CM700 supplies 5 VDC and, via an internal resistor with fixed resistance in series with the engine coolant temperature sensor's variable resistor, determines the voltage drop across the engine coolant temperature sensor and corresponding temperature. The CM700 uses this input for engine protection.

Coolant Heating: If coolant heating is desired, the CM700 supplies 24 VDC, through the coolant heater thermostat which is closed when temperatures are below the thermostat's open threshold, MCB1 to contactor KM1 to close the normally open contactor. Closing KM1 enables the VAC supply, as supplied through the MCB, to be employed within the coolant heater's resistors.

Component Location

Use the following procedure to identify the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Coolant heaters are employed to ease engine start-up by maintaining engine block temperature and assisting engine oil heater operation to near normal operating temperatures.

Refer to Troubleshooting Fault Code t05-2868

Last Modified: 30-Jun-2010


High Temperature Cooling Circuit Current Driver - Current Above Normal or Grounded Circuit

FAULT CODE 2869

High Temperature Cooling Circuit Current Driver - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2869 PID: SPN: 520382 FMI: 5 LAMP: Warning SRT: | High Temperature Cooling Circuit Current Driver - Current Above Normal or Grounded Circuit. With the high temperature control support enabled, the high temperature control circuit driver current is greater than the driver's OOR high limit for the duration of the persistence time. | The high temperature cooling loop will no longer be adequately controlled.
High Temperature Cooling Circuit

Circuit Description

The high temperature (HT) coolant control circuit driver is a 4-20mA signal, sent from the CM700 to the high temperature controller. The high temperature (HT) controller uses this signal to determine the desired position of the temperature control valve.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The high temperature (HT) cooling circuit is controlled by an off engine temperature control valve. On-engine wax type thermostats are not used, as they do not provide the required level of temperature control. The high temperature (HT) control circuit consists of the CM700, temperature controller, 2 solid state relays (one to open the valve and one to close the valve), and the off engine mounted temperature control valve.

Refer to Troubleshooting Fault Code t05-2869

Last Modified: 30-Jun-2010


High Temperature Cooling Circuit Current Driver - Current Below Normal or Open Circuit

FAULT CODE 2871

High Temperature Cooling Circuit Current Driver - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

High Temperature Cooling Circuit Current Driver - Current Below Normal or Open Circuit

CODE | REASON | EFFECT
Fault Code: 2871 PID: SPN: 520382 FMI: 5 LAMP: Warning SRT: | High Temperature Cooling Circuit Current Driver - Current Below Normal or Open Circuit. With High Temperature (HT) coolant temperature control support enabled, the HT temperature control circuit driver current is below the driver's OOR low limit for the duration of the persistence time. | The HT cooling loop will no longer be adequately controlled.
HT Coolant Temperature Controller Supply Circuit

Circuit Description

The CM700 supplies the HT temperature controller with a 24-VDC, 4-20mA signal, which the HT temperature controller uses to determine the desired position of the HT temperature control valve.

Component Location

Refer to Procedure 100-002 in Section E.

Shop Talk

The HT coolant temperature control circuit consists of the CM700, one electronic temperature control, one off-engine temperature control valve and two solid state relays. One to command opening the temperature control valve and one to command closure. On-engine, wax-type thermostats are not used due to an inability to adequately control the coolant temperature.

Refer to Troubleshooting Fault Code t05-2871

Last Modified: 30-Jun-2010


High Temperature (HT) Cooling Circuit Current Driver Breaker Tripped - Condition Exists

FAULT CODE 2872

High Temperature (HT) Cooling Circuit Current Driver Breaker Tripped - Condition Exists

Printable Version Printable Version

Overview

High Temperature (HT) Cooling Circuit Current Driver Breaker Tripped - Condition Exists

CODE | REASON | EFFECT
Fault Code: 2872 PID: SPN: 520382 FMI: 31 LAMP: Warning SRT: | High Temperature (HT) Cooling Circuit Current Driver Breaker Tripped - Condition Exists. With High Temperature (HT) coolant temperature control support enabled, the HT Control Valve Trip signal is active. | The high temperature cooling loop will no longer be adequately controlled.
HT Coolant Controller Valve Protection Circuit

Circuit Description

The CM700 receives the sensed HT coolant temperature and supplies the HT Temperature Controller with a corresponding 24-VDC, 4-20mA signal. The HT Temperature Controller compares the CM700's supply to its target temperature and, if necessary, engages, via 24-VDC 0-20mA supply, the normally open (NO) contactor in KM6A or KM6B to close. Upon closure, the contactor enables the HT Control Valve with AUX VAC, as supplied through circuit breaker MCB6's normally closed (NC) main switch, to open (KM6A) or close (KM6B) the HT Control Valve. The CM700 supplies the NC MCB6 trip switch with 24-VDC and senses current drop across an internal resistor to verify closure. If MCB6's main switch opens or trips due to excessive current, the trip switch also opens, stopping DC current flow from the CM700.

Component Location

Refer to Procedure 100-002 in Section E. The HT Temperature Controller, VAC Isolator, MCB6, KM6A and KM6B are located in the Generator Interface Box (GIB). The HT Control Valve is commonly located at the front of the genset, inline with the HT Coolant Circuit, but can be relocated by the customer as needed to fit plant needs.

Shop Talk

The HT coolant temperature control circuit consists of the CM700, one electronic temperature control, one off engine temperature control valve and two solid state relays, one to command opening the temperature control valve and one to command closure and one circuit breaker. On-engine, wax-type thermostats are not used due to an inability to adequately control the coolant temperature.

Refer to Troubleshooting Fault Code t05-2872

Last Modified: 30-Jun-2010


Aftercooler Cooling Circuit Current Driver - Current Above Normal or Grounded Circuit

FAULT CODE 2873

Aftercooler Cooling Circuit Current Driver - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

Aftercooler Cooling Circuit Current Driver - Current Above Normal or Grounded Circuit

CODE | REASON | EFFECT
Fault Code: 2873 PID: SPN: 520383 FMI: 6 LAMP: Warning SRT: | Aftercooler Cooling Circuit Current Driver - Current Above Normal or Grounded Circuit. With Low Temperature (LT) and High Temperature (HT) coolant temperature control support enabled, the LT temperature control circuit driver current is above the driver's OOR high limit for the duration of the persistence time. | The LT cooling loop will no longer be adequately controlled.
LT Coolant Temperature Controller Supply Circuit

Circuit Description

The CM700 supplies the LT temperature controller with a 24-VDC, 4 to 20-mA signal, which the LT temperature controller uses to determine the desired position of the LT temperature control valve.

Component Location

Refer to Procedure 100-002 in Section E. The LT coolant temperature controller is located either in the Generator Interface Box (GIB) or in the optional Coolant Control Box.

Shop Talk

The terminology "LT Cooling Circuit" refers to the same cooling circuit as the "Aftercooler Cooling Circuit". For general applications, the Aftercooler term applies and therefore is employed in the fault description; for Energy Solutions applications, LT is more commonly employed and therefore referenced in this procedure to a greater extent than Aftercooler.

The LT coolant temperature control circuit consists of the CM700, one electronic temperature control, one off-engine temperature control valve and two solid state relays, one to command opening the temperature control valve and one to command closure. On-engine, wax-type thermostats are not used due to the requirement for increased circuit temperature control about the nominal operating temperature so-as to optimize the genset's efficiency.

Refer to Troubleshooting Fault Code t05-2873

Last Modified: 30-Jun-2010


Aftercooler Cooling Circuit Current Driver - Current Below Normal or Grounded Circuit

FAULT CODE 2874

Aftercooler Cooling Circuit Current Driver - Current Below Normal or Grounded Circuit

Printable Version Printable Version

Overview

Aftercooler Cooling Circuit Current Driver - Current Below Normal or Grounded Circuit

CODE | REASON | EFFECT
Fault Code: 2874 PID: SPN: 520383 FMI: 5 LAMP: Warning SRT: | Aftercooler Cooling Circuit Current Driver - Current Below Normal or Grounded Circuit. With Low Temperature (LT) and High Temperature (HT) coolant temperature control support enabled, the LT temperature control circuit driver current is below the driver's OOR high limit for the duration of the persistence time. | The LT cooling loop will no longer be adequately controlled.
LT Coolant Temperature Controller Supply Circuit

Circuit Description

The CM700 supplies the LT temperature controller with a 24-VDC, 4 to 20-mA signal, which the LT temperature controller uses to determine the desired position of the LT temperature control valve.

Component Location

Refer to Procedure 100-002 in Section E. The LT coolant temperature controller is located either in the Generator Interface Box (GIB) or in the optional Coolant Control Box.

Shop Talk

The terminology "LT Cooling Circuit" refers to the same cooling circuit as the "Aftercooler Cooling Circuit". For general applications, the Aftercooler term applies and therefore is employed in the fault description; for Energy Solutions applications, LT is more commonly employed and therefore referenced in this procedure to a greater extent than Aftercooler.

The LT coolant temperature control circuit consists of the CM700, one electronic temperature control, one off-engine temperature control valve and two solid state relays, one to command opening the temperature control valve and one to command closure. On-engine, wax-type thermostats are not used due to the requirement for increased circuit temperature control about the nominal operating temperature so-as to optimize the genset's efficiency.

Refer to Troubleshooting Fault Code t05-2874

Last Modified: 30-Jun-2010


Aftercooler Cooling (LT) Circuit Current Driver Breaker Tripped - Condition Exists

FAULT CODE 2875

Aftercooler Cooling (LT) Circuit Current Driver Breaker Tripped - Condition Exists

Printable Version Printable Version

Overview

Aftercooler Cooling (LT) Circuit Current Driver Breaker Tripped - Condition Exists

CODE | REASON | EFFECT
Fault Code: 2875 PID: SPN: 520383 FMI: 31 LAMP: Warning SRT: | Aftercooler Cooling (LT) Circuit Current Driver Breaker Tripped - Condition Exists. With Low Temperature (LT) coolant temperature control support enabled, the LT Control Valve Trip signal is active. | The low temperature cooling loop will no longer be adequately controlled.
LT Coolant Controller Valve Protection Circuit

Circuit Description

The CM700 receives the sensed LT coolant temperature and supplies the LT Temperature Controller with a corresponding 24-VDC, 4 to 20-mA signal. The LT Temperature Controller compares the CM700's supply to its target temperature and, if necessary, engages, via 24-VDC 0 to 20-mA supply, the normally open (NO) contactor in KM7A or KM7B to close. Upon closure, the contactor enables the LT Control Valve with AUX VAC, as supplied through circuit breaker MCB7's normally closed (NC) main switch, to open (KM7A) or close (KM7B) the LT Control Valve. The CM700 supplies the NC MCB7 trip switch with 24-VDC and senses current drop across an internal resistor to verify closure. If MCB7's main switch opens or trips due to excessive current, the trip switch also opens, stopping DC current flow from the CM700.

Component Location

Refer to Procedure 100-002 in Section E. The LT Temperature Controller, VAC Isolator, MCB7, KM7A and KM7B are located in the Generator Interface Box (GIB). The LT Control Valve is commonly located at the front of the genset, inline with the LT Coolant Circuit, but can be relocated by the customer as needed to fit plant needs.

Shop Talk

The terminology "LT Cooling Circuit" refers to the same cooling circuit as the "Aftercooler Cooling Circuit". For general applications, the Aftercooler term applies and therefore is employed in the fault description; for Energy Solutions applications, LT is more commonly employed and therefore referenced in this procedure to a greater extent than Aftercooler.

The LT coolant temperature control circuit consists of the CM700, one electronic temperature control, one off engine temperature control valve and two solid state relays, one to command opening the temperature control valve and one to command closure and one circuit breaker. On-engine, wax-type thermostats are not used due to an inability to adequately control the coolant temperature.

Refer to Troubleshooting Fault Code t05-2875

Last Modified: 30-Jun-2010


Turbocharger 1 Compressor Inlet Temperature - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 2876

Turbocharger 1 Compressor Inlet Temperature - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2876 PID: SPN: 1172 FMI: 1 LAMP: Shutdown SRT: | Turbocharger 1 Compressor Inlet Temperature - Data Valid But Below Normal Operating Range - Most Severe Level. The temperature of the air entering the turbocharger compressor inlet is below the critical threshold. | Shutdown
QSK60G Single Turbocharger with Generator Control Panel 2 (GCP2) and PowerCommand® Supervisor 3100 - Turbocharger 1 Compressor Inlet Air Temperature Sensor Circuit
QSK60G Single Turbocharger with Generator Interface Box (GIB) and PowerCommand® Control 3300 - Turbocharger 1 Compressor Inlet Air Temperature Sensor Circuit

Circuit Description

The turbocharger 1 compressor inlet air temperature sensor is a variable resistance sensor and is used to measure the temperature of the air entering the compressor intake of the turbocharger. The CM700 module supplies 5-VDC to the compressor intake temperature signal circuit. The CM700 monitors the change in voltage caused by changes in the resistance of the sensor to determine compressor inlet air temperature.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Intake manifold pressure will increase as air density increases. Generally, air density increases as air temperature decreases. As air density increases, the likelihood for turbocharger compressor surge increases.

For generator sets fitted with Generator Control Panel 2 and PowerCommand® Supervisor 3100 control panel, the turbocharger compressor air inlet temperature sensor return wire is shared in the engine harness with other sensors. A shorted return wire can therefore cause multiple fault codes. Before troubleshooting this fault code, check for multiple fault codes.

Possible causes for this fault code include:

  • Incorrect engine room ventilation fan control
  • Incorrect engine room motorized louvre control
  • Turbocharger compressor air inlet temperature sensor failed in range (this will not activate Fault Code 691 or 692).

The compressor air inlet temperature sensors internal resistance varies inversely to changes in sensed air temperature as follows:

Temperature |  | Acceptable Resistance Range
°C | °F | Ohms
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-2876.

Last Modified: 13-Oct-2010


Turbocharger 1 Compressor Inlet Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2877

Turbocharger 1 Compressor Inlet Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2877 PID: SPN: 1172 FMI: 18 LAMP: Warning SRT: | Turbocharger 1 Compressor Inlet Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level. The temperature of the air entering the turbocharger compressor inlet is below the critical threshold. | Engine performance may be affected.
QSK60G Single Turbocharger with Generator Control Panel 2 (GCP2) and PowerCommand® Supervisor 3100 - Turbocharger 1 Compressor Inlet Air Temperature Sensor Circuit
QSK60G Single Turbocharger with Generator Interface Box (GIB) and PowerCommand® Control 3300 - Turbocharger 1 Compressor Inlet Air Temperature Sensor Circuit

Circuit Description

The turbocharger 1 compressor inlet air temperature sensor is a variable resistance sensor and is used to measure the temperature of the air entering the compressor intake of the turbocharger. The CM700 module supplies 5-VDC to the compressor intake temperature signal circuit. The CM700 monitors the change in voltage caused by changes in the resistance of the sensor to determine compressor inlet air temperature.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Intake manifold pressure will increase as air density increases. Generally, air density increases as air temperature decreases. As air density increases, the likelihood for turbocharger compressor surge increases.

For generator sets fitted with Generator Control Panel 2 and PowerCommand® Supervisor 3100 control panel, the turbocharger compressor air inlet temperature sensor return wire is shared in the engine harness with other sensors. A shorted return wire can therefore cause multiple fault codes. Before troubleshooting this fault code, check for multiple fault codes.

Possible causes of this fault code include:

  • Incorrect engine room ventilation fan control
  • Incorrect engine room motorized louvre control
  • Turbocharger compressor air inlet temperature sensor failed in range (this will not activate Fault Code 691 ior 692).

The compressor air inlet temperature sensor's internal resistance varies inversely to changes in sensed air temperature as shown in the table below.

Temperature |  | Acceptable Resistance Range
°C | °F | Ohms (Ω)
0 | 32 | 30k to 36k
25 | 77 | 9k to 11k
50 | 122 | 3k to 4k
75 | 167 | 1350 to 1500
100 | 212 | 600 to 675
Refer to Troubleshooting Fault Code t05-2877.

Last Modified: 13-Oct-2010


Engine Control Module Internal Failure - Special Instructions

FAULT CODE 2994

Engine Control Module Internal Failure - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2994 PID: SPN: 629 FMI: 14 LAMP: Warning SRT: | Engine Control Module Internal Failure - Special Instructions. Error internal to the CM558 or CM700. | No effect on engine performance.
CM558 or CM700 (CM700 shown)

Circuit Description

The CM558 and CM700 are ECMs that are responsible for engine control, diagnostics, and user features.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code can only be caused by an internal CM558 or CM700 problem.

Refer to Troubleshooting Fault Code t05-2994.

Last Modified: 06-Jan-2011


Engine Cylinder Number 1 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3111

Engine Cylinder Number 1 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

Engine Cylinder Number 1 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3111 PID: SPN: 1352 FMI: 14 LAMP: Shutdown SRT: | Engine Cylinder Number 1 Knock Sensor - Excessive Mechanical Vibration - Special Instructions. Cylinder number 1 knock sensor has detected mechanical vibration above the critical level. | The engine will shut down.
Knock Sensor Circuit - Multiple and Single Turbocharger Engines

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to a pre-ignition, and knock occurring after the normal spark event is known a detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts, within the power cylinder, colliding. If the cause of knock is not identified and rectified, then engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage may occur. Similarly, the engine must not be run with knock sensors disconnected; this will not initiate a warning alarm. The engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

Knock related faults are activated when the knock sensor voltage output exceeds either a warning or high critical threshold for a pre-set period of time.

Knock protection is not activated until a pre-determined minimum intake manifold pressure is reached; when operating below this intake manifold pressure threshold, it is unlikely that combustion related knock events will occur.

The knock sensors can also detect mechanical noise and mechanical related problems must not be discounted as a cause of detonation shutdowns or high knock counts. By activating the knock sensors below the minimum intake manifold pressure threshold and outside of their normal monitoring window, the knock sensors can be used to monitor for excessive mechanical vibration and help reduce the progressive damage caused by mechanical related problems.

The following mechanical checks must be considered when all other causes of detonation have been investigated and discounted:

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever elephant foot o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust gasket leakage
  • Vibration resulting from loose engine parts/components.

All knock related shutdowns and persistent light knock events must be fully investigated before restarting the engine in order to prevent engine damage.

Generator Sets using PowerCommand™ Control 3300 Generator Control:

The PowerCommand™ Control 3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 112.5 percent, and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from no-knock condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code t05-3111

Last Modified: 30-Jun-2010


Engine Cylinder Number 2 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3112

Engine Cylinder Number 2 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

Engine Cylinder Number 2 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3112 PID: SPN: 1353 FMI: 14 LAMP: Shutdown SRT: | Engine Cylinder Number 2 Knock Sensor - Excessive Mechanical Vibration - Special Instructions. Cylinder number 2 knock sensor has detected mechanical vibration above the critical level. | The engine will shut down.
Knock Sensor Circuit - Multiple and Single Turbocharger Engines

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to a pre-ignition, and knock occurring after the normal spark event is known a detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts, within the power cylinder, colliding. If the cause of knock is not identified and rectified, then engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage may occur. Similarly, the engine must not be run with knock sensors disconnected; this will not initiate a warning alarm. The engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

Knock related faults are activated when the knock sensor voltage output exceeds either a warning or high critical threshold for a pre-set period of time.

Knock protection is not activated until a pre-determined minimum intake manifold pressure is reached; when operating below this intake manifold pressure threshold, it is unlikely that combustion related knock events will occur.

The knock sensors can also detect mechanical noise and mechanical related problems must not be discounted as a cause of detonation shutdowns or high knock counts. By activating the knock sensors below the minimum intake manifold pressure threshold and outside of their normal monitoring window, the knock sensors can be used to monitor for excessive mechanical vibration and help reduce the progressive damage caused by mechanical related problems.

The following mechanical checks must be considered when all other causes of detonation have been investigated and discounted:

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever elephant foot o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust gasket leakage
  • Vibration resulting from loose engine parts/components.

All knock related shutdowns and persistent light knock events must be fully investigated before restarting the engine in order to prevent engine damage.

Generator Sets using PowerCommand™ Control 3300 Generator Control:

The PowerCommand™ Control 3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 112.5 percent, and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from no-knock condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code t05-3112

Last Modified: 30-Jun-2010


Engine Cylinder Number 3 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3113

Engine Cylinder Number 3 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

Engine Cylinder Number 3 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3113 PID: SPN: 1354 FMI: 14 LAMP: Shutdown SRT: | Engine Cylinder Number 3 Knock Sensor - Excessive Mechanical Vibration - Special Instructions. Cylinder number 3 knock sensor has detected mechanical vibration above the critical level. | The engine will shut down.
Knock Sensor Circuit - Multiple and Single Turbocharger Engines

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to a pre-ignition, and knock occurring after the normal spark event is known a detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts, within the power cylinder, colliding. If the cause of knock is not identified and rectified, then engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage may occur. Similarly, the engine must not be run with knock sensors disconnected; this will not initiate a warning alarm. The engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

Knock related faults are activated when the knock sensor voltage output exceeds either a warning or high critical threshold for a pre-set period of time.

Knock protection is not activated until a pre-determined minimum intake manifold pressure is reached; when operating below this intake manifold pressure threshold, it is unlikely that combustion related knock events will occur.

The knock sensors can also detect mechanical noise and mechanical related problems must not be discounted as a cause of detonation shutdowns or high knock counts. By activating the knock sensors below the minimum intake manifold pressure threshold and outside of their normal monitoring window, the knock sensors can be used to monitor for excessive mechanical vibration and help reduce the progressive damage caused by mechanical related problems.

The following mechanical checks must be considered when all other causes of detonation have been investigated and discounted:

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever elephant foot o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust gasket leakage
  • Vibration resulting from loose engine parts/components.

All knock related shutdowns and persistent light knock events must be fully investigated before restarting the engine in order to prevent engine damage.

Generator Sets using PowerCommand™ Control 3300 Generator Control:

The PowerCommand™ Control 3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 112.5 percent, and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from no-knock condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code t05-3113

Last Modified: 30-Jun-2010


Engine Cylinder Number 4 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3114

Engine Cylinder Number 4 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

Engine Cylinder Number 4 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3114 PID: SPN: 1355 FMI: 14 LAMP: Shutdown SRT: | Engine Cylinder Number 4 Knock Sensor - Excessive Mechanical Vibration - Special Instructions. Cylinder number 4 knock sensor has detected mechanical vibration above the critical level. | The engine will shut down.
Knock Sensor Circuit - Multiple and Single Turbocharger Engines

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to a pre-ignition, and knock occurring after the normal spark event is known a detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts, within the power cylinder, colliding. If the cause of knock is not identified and rectified, then engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage may occur. Similarly, the engine must not be run with knock sensors disconnected; this will not initiate a warning alarm. The engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

Knock related faults are activated when the knock sensor voltage output exceeds either a warning or high critical threshold for a pre-set period of time.

Knock protection is not activated until a pre-determined minimum intake manifold pressure is reached; when operating below this intake manifold pressure threshold, it is unlikely that combustion related knock events will occur.

The knock sensors can also detect mechanical noise and mechanical related problems must not be discounted as a cause of detonation shutdowns or high knock counts. By activating the knock sensors below the minimum intake manifold pressure threshold and outside of their normal monitoring window, the knock sensors can be used to monitor for excessive mechanical vibration and help reduce the progressive damage caused by mechanical related problems.

The following mechanical checks must be considered when all other causes of detonation have been investigated and discounted:

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever elephant foot o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust gasket leakage
  • Vibration resulting from loose engine parts/components.

All knock related shutdowns and persistent light knock events must be fully investigated before restarting the engine in order to prevent engine damage.

Generator Sets using PowerCommand™ Control 3300 Generator Control:

The PowerCommand™ Control 3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 112.5 percent, and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from no-knock condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code t05-3114

Last Modified: 30-Jun-2010


Engine Cylinder Number 5 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3115

Engine Cylinder Number 5 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

Engine Cylinder Number 5 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3115 PID: SPN: 1352 FMI: 14 LAMP: Shutdown SRT: | Engine Cylinder Number 5 Knock Sensor - Excessive Mechanical Vibration - Special Instructions. Cylinder number 5 knock sensor has detected mechanical vibration above the critical level. | The engine will shut down.
Knock Sensor Circuit - Multiple and Single Turbocharger Engines

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to a pre-ignition, and knock occurring after the normal spark event is known a detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts, within the power cylinder, colliding. If the cause of knock is not identified and rectified, then engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage may occur. Similarly, the engine must not be run with knock sensors disconnected; this will not initiate a warning alarm. The engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

Knock related faults are activated when the knock sensor voltage output exceeds either a warning or high critical threshold for a pre-set period of time.

Knock protection is not activated until a pre-determined minimum intake manifold pressure is reached; when operating below this intake manifold pressure threshold, it is unlikely that combustion related knock events will occur.

The knock sensors can also detect mechanical noise and mechanical related problems must not be discounted as a cause of detonation shutdowns or high knock counts. By activating the knock sensors below the minimum intake manifold pressure threshold and outside of their normal monitoring window, the knock sensors can be used to monitor for excessive mechanical vibration and help reduce the progressive damage caused by mechanical related problems.

The following mechanical checks must be considered when all other causes of detonation have been investigated and discounted:

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever elephant foot o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust gasket leakage
  • Vibration resulting from loose engine parts/components.

All knock related shutdowns and persistent light knock events must be fully investigated before restarting the engine in order to prevent engine damage.

Generator Sets using PowerCommand™ Control 3300 Generator Control:

The PowerCommand™ Control 3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 112.5 percent, and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from no-knock condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code 3115.

Last Modified: 02-Jul-2010


Engine Cylinder Number 6 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3116

Engine Cylinder Number 6 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

Engine Cylinder Number 6 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3116 PID: SPN: 1357 FMI: 14 LAMP: Shutdown SRT: | Engine Cylinder Number 6 Knock Sensor - Excessive Mechanical Vibration - Special Instructions. Cylinder number 6 knock sensor has detected mechanical vibration above the critical level. | The engine will shutdown.
Knock Sensor Circuit - Multiple and Single Turbocharger Engines

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to a pre-ignition, and knock occurring after the normal spark event is known a detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts, within the power cylinder, colliding. If the cause of knock is not identified and rectified, then engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage may occur. Similarly, the engine must not be run with knock sensors disconnected; this will not initiate a warning alarm. The engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

Knock related faults are activated when the knock sensor voltage output exceeds either a warning or high critical threshold for a pre-set period of time.

Knock protection is not activated until a pre-determined minimum intake manifold pressure is reached; when operating below this intake manifold pressure threshold, it is unlikely that combustion related knock events will occur.

The knock sensors can also detect mechanical noise and mechanical related problems must not be discounted as a cause of detonation shutdowns or high knock counts. By activating the knock sensors below the minimum intake manifold pressure threshold and outside of their normal monitoring window, the knock sensors can be used to monitor for excessive mechanical vibration and help reduce the progressive damage caused by mechanical related problems.

The following mechanical checks must be considered when all other causes of detonation have been investigated and discounted:

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever elephant foot o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust gasket leakage
  • Vibration resulting from loose engine parts/components.

All knock related shutdowns and persistent light knock events must be fully investigated before restarting the engine in order to prevent engine damage.

Generator Sets using PowerCommand™ Control 3300 Generator Control:

The PowerCommand™ Control 3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 112.5 percent, and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from no-knock condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code 3116.

Last Modified: 02-Jul-2010


Engine Cylinder Number 7 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3117

Engine Cylinder Number 7 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

Engine Cylinder Number 7 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3117 PID: SPN: 1358 FMI: 14 LAMP: Shutdown SRT: | Engine Cylinder Number 7 Knock Sensor - Excessive Mechanical Vibration - Special Instructions. Cylinder number 7 knock sensor has detected mechanical vibration above the critical level. | The engine will shut down.
Knock Sensor Circuit - Multiple and Single Turbocharger Engines

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to a pre-ignition, and knock occurring after the normal spark event is known a detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts, within the power cylinder, colliding. If the cause of knock is not identified and rectified, then engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage may occur. Similarly, the engine must not be run with knock sensors disconnected; this will not initiate a warning alarm. The engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

Knock related faults are activated when the knock sensor voltage output exceeds either a warning or high critical threshold for a pre-set period of time.

Knock protection is not activated until a pre-determined minimum intake manifold pressure is reached; when operating below this intake manifold pressure threshold, it is unlikely that combustion related knock events will occur.

The knock sensors can also detect mechanical noise and mechanical related problems must not be discounted as a cause of detonation shutdowns or high knock counts. By activating the knock sensors below the minimum intake manifold pressure threshold and outside of their normal monitoring window, the knock sensors can be used to monitor for excessive mechanical vibration and help reduce the progressive damage caused by mechanical related problems.

The following mechanical checks must be considered when all other causes of detonation have been investigated and discounted:

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever elephant foot o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust gasket leakage
  • Vibration resulting from loose engine parts/components.

All knock related shutdowns and persistent light knock events must be fully investigated before restarting the engine in order to prevent engine damage.

Generator Sets using PowerCommand™ Control 3300 Generator Control:

The PowerCommand™ Control 3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 112.5 percent, and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from no-knock condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code 3117.

Last Modified: 02-Jul-2010


Engine Cylinder Number 8 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3118

Engine Cylinder Number 8 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

Engine Cylinder Number 8 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3118 PID: SPN: 1359 FMI: 14 LAMP: Shutdown SRT: | Engine Cylinder Number 8 Knock Sensor - Excessive Mechanical Vibration - Special Instructions. Cylinder number 8 knock sensor has detected mechanical vibration above the critical level. | The engine will shut down.
Knock Sensor Circuit - Multiple and Single Turbocharger Engines

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to a pre-ignition, and knock occurring after the normal spark event is known a detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts, within the power cylinder, colliding. If the cause of knock is not identified and rectified, then engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage may occur. Similarly, the engine must not be run with knock sensors disconnected; this will not initiate a warning alarm. The engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

Knock related faults are activated when the knock sensor voltage output exceeds either a warning or high critical threshold for a pre-set period of time.

Knock protection is not activated until a pre-determined minimum intake manifold pressure is reached; when operating below this intake manifold pressure threshold, it is unlikely that combustion related knock events will occur.

The knock sensors can also detect mechanical noise and mechanical related problems must not be discounted as a cause of detonation shutdowns or high knock counts. By activating the knock sensors below the minimum intake manifold pressure threshold and outside of their normal monitoring window, the knock sensors can be used to monitor for excessive mechanical vibration and help reduce the progressive damage caused by mechanical related problems.

The following mechanical checks must be considered when all other causes of detonation have been investigated and discounted:

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever elephant foot o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust gasket leakage
  • Vibration resulting from loose engine parts/components.

All knock related shutdowns and persistent light knock events must be fully investigated before restarting the engine in order to prevent engine damage.

Generator Sets using PowerCommand™ Control 3300 Generator Control:

The PowerCommand™ Control 3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 112.5 percent, and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from no-knock condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code 3118.

Last Modified: 02-Jul-2010


Engine Cylinder Number 9 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3119

Engine Cylinder Number 9 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

Engine Cylinder Number 9 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3119 PID: SPN: 1360 FMI: 14 LAMP: Shutdown SRT: | Engine Cylinder Number 9 Knock Sensor - Excessive Mechanical Vibration - Special Instructions. Cylinder number 9 knock sensor has detected mechanical vibration above the critical level. | The engine will shut down.
Knock Sensor Circuit - Multiple and Single Turbocharger Engines

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to a pre-ignition, and knock occurring after the normal spark event is known a detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts, within the power cylinder, colliding. If the cause of knock is not identified and rectified, then engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage may occur. Similarly, the engine must not be run with knock sensors disconnected; this will not initiate a warning alarm. The engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

Knock related faults are activated when the knock sensor voltage output exceeds either a warning or high critical threshold for a pre-set period of time.

Knock protection is not activated until a pre-determined minimum intake manifold pressure is reached; when operating below this intake manifold pressure threshold, it is unlikely that combustion related knock events will occur.

The knock sensors can also detect mechanical noise and mechanical related problems must not be discounted as a cause of detonation shutdowns or high knock counts. By activating the knock sensors below the minimum intake manifold pressure threshold and outside of their normal monitoring window, the knock sensors can be used to monitor for excessive mechanical vibration and help reduce the progressive damage caused by mechanical related problems.

The following mechanical checks must be considered when all other causes of detonation have been investigated and discounted:

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever elephant foot o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust gasket leakage
  • Vibration resulting from loose engine parts/components.

All knock related shutdowns and persistent light knock events must be fully investigated before restarting the engine in order to prevent engine damage.

Generator Sets using PowerCommand™ Control 3300 Generator Control:

The PowerCommand™ Control 3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 112.5 percent, and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from no-knock condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code 3119.

Last Modified: 02-Jul-2010


Engine Cylinder Number 10 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3121

Engine Cylinder Number 10 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

Engine Cylinder Number 10 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3121 PID: SPN: 1361 FMI: 14 LAMP: Shutdown SRT: | Engine Cylinder Number 10 Knock Sensor - Excessive Mechanical Vibration - Special Instructions. Cylinder number 10 knock sensor has detected mechanical vibration above the critical level. | The engine will shut down.
Knock Sensor Circuit - Multiple and Single Turbocharger Engines

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to a pre-ignition, and knock occurring after the normal spark event is known a detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts, within the power cylinder, colliding. If the cause of knock is not identified and rectified, then engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage may occur. Similarly, the engine must not be run with knock sensors disconnected; this will not initiate a warning alarm. The engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

Knock related faults are activated when the knock sensor voltage output exceeds either a warning or high critical threshold for a pre-set period of time.

Knock protection is not activated until a pre-determined minimum intake manifold pressure is reached; when operating below this intake manifold pressure threshold, it is unlikely that combustion related knock events will occur.

The knock sensors can also detect mechanical noise and mechanical related problems must not be discounted as a cause of detonation shutdowns or high knock counts. By activating the knock sensors below the minimum intake manifold pressure threshold and outside of their normal monitoring window, the knock sensors can be used to monitor for excessive mechanical vibration and help reduce the progressive damage caused by mechanical related problems.

The following mechanical checks must be considered when all other causes of detonation have been investigated and discounted:

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever elephant foot o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust gasket leakage
  • Vibration resulting from loose engine parts/components.

All knock related shutdowns and persistent light knock events must be fully investigated before restarting the engine in order to prevent engine damage.

Generator Sets using PowerCommand™ Control 3300 Generator Control:

The PowerCommand™ Control 3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 112.5 percent, and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from no-knock condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code 3121.

Last Modified: 02-Jul-2010


Engine Cylinder Number 11 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3122

Engine Cylinder Number 11 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

Engine Cylinder Number 11 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3122 PID: SPN: 1362 FMI: 14 LAMP: Shutdown SRT: | Engine Cylinder Number 11 Knock Sensor - Excessive Mechanical Vibration - Special Instructions. Cylinder number 11 knock sensor has detected mechanical vibration above the critical level. | The engine will shut down.
Knock Sensor Circuit - Multiple and Single Turbocharger Engines

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to a pre-ignition, and knock occurring after the normal spark event is known a detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts, within the power cylinder, colliding. If the cause of knock is not identified and rectified, then engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage may occur. Similarly, the engine must not be run with knock sensors disconnected; this will not initiate a warning alarm. The engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

Knock related faults are activated when the knock sensor voltage output exceeds either a warning or high critical threshold for a pre-set period of time.

Knock protection is not activated until a pre-determined minimum intake manifold pressure is reached; when operating below this intake manifold pressure threshold, it is unlikely that combustion related knock events will occur.

The knock sensors can also detect mechanical noise and mechanical related problems must not be discounted as a cause of detonation shutdowns or high knock counts. By activating the knock sensors below the minimum intake manifold pressure threshold and outside of their normal monitoring window, the knock sensors can be used to monitor for excessive mechanical vibration and help reduce the progressive damage caused by mechanical related problems.

The following mechanical checks must be considered when all other causes of detonation have been investigated and discounted:

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever elephant foot o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust gasket leakage
  • Vibration resulting from loose engine parts/components.

All knock related shutdowns and persistent light knock events must be fully investigated before restarting the engine in order to prevent engine damage.

Generator Sets using PowerCommand™ Control 3300 Generator Control:

The PowerCommand™ Control 3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 112.5 percent, and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from no-knock condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code 3122.

Last Modified: 02-Jul-2010


Engine Cylinder Number 12 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3123

Engine Cylinder Number 12 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

Engine Cylinder Number 12 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3123 PID: SPN: 1363 FMI: 14 LAMP: Shutdown SRT: | Engine Cylinder Number 12 Knock Sensor - Excessive Mechanical Vibration - Special Instructions. Cylinder number 12 knock sensor has detected mechanical vibration above the critical level. | The engine will shut down.
Knock Sensor Circuit - Multiple and Single Turbocharger Engines

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to a pre-ignition, and knock occurring after the normal spark event is known a detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts, within the power cylinder, colliding. If the cause of knock is not identified and rectified, then engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage may occur. Similarly, the engine must not be run with knock sensors disconnected; this will not initiate a warning alarm. The engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

Knock related faults are activated when the knock sensor voltage output exceeds either a warning or high critical threshold for a pre-set period of time.

Knock protection is not activated until a pre-determined minimum intake manifold pressure is reached; when operating below this intake manifold pressure threshold, it is unlikely that combustion related knock events will occur.

The knock sensors can also detect mechanical noise and mechanical related problems must not be discounted as a cause of detonation shutdowns or high knock counts. By activating the knock sensors below the minimum intake manifold pressure threshold and outside of their normal monitoring window, the knock sensors can be used to monitor for excessive mechanical vibration and help reduce the progressive damage caused by mechanical related problems.

The following mechanical checks must be considered when all other causes of detonation have been investigated and discounted:

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever elephant foot o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust gasket leakage
  • Vibration resulting from loose engine parts/components.

All knock related shutdowns and persistent light knock events must be fully investigated before restarting the engine in order to prevent engine damage.

Generator Sets using PowerCommand™ Control 3300 Generator Control:

The PowerCommand™ Control 3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 112.5 percent, and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from no-knock condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code 3123.

Last Modified: 02-Jul-2010


Engine Cylinder Number 13 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3124

Engine Cylinder Number 13 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

Engine Cylinder Number 13 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3124 PID: SPN: 1364 FMI: 14 LAMP: Shutdown SRT: | Engine Cylinder Number 13 Knock Sensor - Excessive Mechanical Vibration - Special Instructions. Cylinder number 13 knock sensor has detected mechanical vibration above the critical level. | The engine will shut down.
Knock Sensor Circuit - Multiple and Single Turbocharger Engines

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to a pre-ignition, and knock occurring after the normal spark event is known a detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts, within the power cylinder, colliding. If the cause of knock is not identified and rectified, then engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage may occur. Similarly, the engine must not be run with knock sensors disconnected; this will not initiate a warning alarm. The engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

Knock related faults are activated when the knock sensor voltage output exceeds either a warning or high critical threshold for a pre-set period of time.

Knock protection is not activated until a pre-determined minimum intake manifold pressure is reached; when operating below this intake manifold pressure threshold, it is unlikely that combustion related knock events will occur.

The knock sensors can also detect mechanical noise and mechanical related problems must not be discounted as a cause of detonation shutdowns or high knock counts. By activating the knock sensors below the minimum intake manifold pressure threshold and outside of their normal monitoring window, the knock sensors can be used to monitor for excessive mechanical vibration and help reduce the progressive damage caused by mechanical related problems.

The following mechanical checks must be considered when all other causes of detonation have been investigated and discounted:

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever elephant foot o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust gasket leakage
  • Vibration resulting from loose engine parts/components.

All knock related shutdowns and persistent light knock events must be fully investigated before restarting the engine in order to prevent engine damage.

Generator Sets using PowerCommand™ Control 3300 Generator Control:

The PowerCommand™ Control 3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 112.5 percent, and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from no-knock condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code 3124.

Last Modified: 02-Jul-2010


Engine Cylinder Number 14 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3125

Engine Cylinder Number 14 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

Engine Cylinder Number 14 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3125 PID: SPN: 1365 FMI: 14 LAMP: Shutdown SRT: | Engine Cylinder Number 14 Knock Sensor - Excessive Mechanical Vibration - Special Instructions. Cylinder number 14 knock sensor has detected mechanical vibration above the critical level. | The engine will shut down.
Knock Sensor Circuit - Multiple and Single Turbocharger Engines

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to a pre-ignition, and knock occurring after the normal spark event is known a detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts, within the power cylinder, colliding. If the cause of knock is not identified and rectified, then engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage may occur. Similarly, the engine must not be run with knock sensors disconnected; this will not initiate a warning alarm. The engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

Knock related faults are activated when the knock sensor voltage output exceeds either a warning or high critical threshold for a pre-set period of time.

Knock protection is not activated until a pre-determined minimum intake manifold pressure is reached; when operating below this intake manifold pressure threshold, it is unlikely that combustion related knock events will occur.

The knock sensors can also detect mechanical noise and mechanical related problems must not be discounted as a cause of detonation shutdowns or high knock counts. By activating the knock sensors below the minimum intake manifold pressure threshold and outside of their normal monitoring window, the knock sensors can be used to monitor for excessive mechanical vibration and help reduce the progressive damage caused by mechanical related problems.

The following mechanical checks must be considered when all other causes of detonation have been investigated and discounted:

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever elephant foot o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust gasket leakage
  • Vibration resulting from loose engine parts/components.

All knock related shutdowns and persistent light knock events must be fully investigated before restarting the engine in order to prevent engine damage.

Generator Sets using PowerCommand™ Control 3300 Generator Control:

The PowerCommand™ Control 3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 112.5 percent, and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from no-knock condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code 3125.

Last Modified: 02-Jul-2010


Engine Cylinder Number 15 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3126

Engine Cylinder Number 15 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

Engine Cylinder Number 15 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3126 PID: SPN: 1366 FMI: 14 LAMP: Shut down SRT: | Engine Cylinder Number 15 Knock Sensor - Excessive Mechanical Vibration - Special Instructions. Cylinder number 15 knock sensor has detected mechanical vibration above the critical level. | The engine will shutdown.
Knock Sensor Circuit - Multiple and Single Turbocharger Engines

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by a source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to a pre-ignition and knock occurring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts within the power cylinder colliding. If the cause of knock is not identified and rectified, engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage may occur. Similarly, the engine must not be run with knock sensors disconnected; this will not initiate a warning alarm. The engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

Knock related faults are activated when the knock sensor voltage output exceeds either a warning or high critical threshold for a pre-set period of time.

Knock protection is not activated until a pre-determined minimum intake manifold pressure is reached; when operating below this intake manifold pressure threshold, it is unlikely that combustion related knock events will occur.

The knock sensors can also detect mechanical noise and mechanical-related problems must not be discounted as a cause of detonation shutdowns or high knock counts. By activating the knock sensors below the minimum intake manifold pressure threshold and outside of their normal monitoring window, the knock sensors can be used to monitor for excessive mechanical vibration and help reduce the progressive damage caused by mechanical-related problems.

The following mechanical checks must be considered when all other causes of detonation have been investigated and discounted:

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever elephant foot o-ring displaced, resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust (multi-duct) gasket leakage
  • Vibration resulting from loose engine parts/components.

All knock related shutdowns and persistent light knock events must be fully investigated before restarting the engine, in order to prevent engine damage.

Generator Sets using PowerCommand™ Control 3300 Generator Control:

The PowerCommand™ Control 3300 Generator Control receives and displays knock levels as a percentage, rather than as a voltage, as this is the standard used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from no-knock condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code 3126.

Last Modified: 02-Jul-2010


Engine Cylinder Number 16 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

FAULT CODE 3127

Engine Cylinder Number 16 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Printable Version Printable Version

Overview

Engine Cylinder Number 16 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3127 PID: SPN: 1367 FMI: 14 LAMP: Shutdown SRT: | Engine Cylinder Number 16 Knock Sensor - Excessive Mechanical Vibration - Special Instructions. Cylinder number 16 knock sensor has detected mechanical vibration above the critical level. | The engine will shutdown.
Knock Sensor Circuit - Multiple and Single Turbocharger Engines

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by a source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to a pre-ignition and knock occurring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts within the power cylinder colliding. If the cause of knock is not identified and rectified, engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage may occur. Similarly, the engine must not be run with knock sensors disconnected; this will not initiate a warning alarm. The engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

Knock related faults are activated when the knock sensor voltage output exceeds either a warning or high critical threshold for a pre-set period of time.

Knock protection is not activated until a pre-determined minimum intake manifold pressure is reached; when operating below this intake manifold pressure threshold, it is unlikely that combustion related knock events will occur.

The knock sensors can also detect mechanical noise and mechanical related problems must not be discounted as a cause of detonation shutdowns or high knock counts. By activating the knock sensors below the minimum intake manifold pressure threshold and outside of their normal monitoring window, the knock sensors can be used to monitor for excessive mechanical vibration and help reduce the progressive damage caused by mechanical related problems.

The following mechanical checks must be considered when all other causes of detonation have been investigated and discounted:

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever elephant foot o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust (multi-duct) gasket leakage
  • Vibration resulting from loose engine parts/components.

All knock related shutdowns and persistent light knock events must be fully investigated before restarting the engine in order to prevent engine damage.

Generator Sets using PowerCommand™ Control 3300 Generator Control:

The PowerCommand™ Control 3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from no-knock condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code 3127.

Last Modified: 02-Jul-2010


Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

FAULT CODE 343

Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 343 PID: SPN: 629 FMI: 13 LAMP: Amber SRT: | Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component. ECM internal power supply errors have been detected. | No performance effect on engine performance.
Electronic Control Module

Circuit Description

The CM700 and CM558 modules are engine-mounted computers that are responsible for engine control functions, engine protection, and diagnostics.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Fault Code 343 is activated when one of the ECMs detects a malfunction with its internal circuitry. The ECM can not be repaired in the field.

For Euro certified engines this fault code indicates that the Real Time Clock feature needs to reset again (if equipped).

Refer to Troubleshooting Fault Code t05-343.

Last Modified: 06-Jul-2011


Knock Sensor Based Engine Derate - Condition Exists

FAULT CODE 3458

Knock Sensor Based Engine Derate - Condition Exists

Printable Version Printable Version

Overview

Knock Sensor Based Engine Derate - Condition Exists

CODE | REASON | EFFECT
Fault Code: 3458 PID: SPN: 520464 FMI: 31 LAMP: Warning SRT: | Knock Sensor Based Engine Derate - Condition Exists. Engine knock counts have exceeded the lower threshold. | The engine will continue to run but at less than 100 percent load.
Knock Sensor Circuit

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as pre-ignition, while knock occurring after the normal spark event is known as detonation. The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts, within the power cylinder, colliding. If the cause of knock is not identified and rectified, engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage may occur. Similarly, the engine should not be run with knock sensors disconnected; this may initiate a Warning alarm, however the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function correctly, it must be installed and tightened to the correct torque value.

The CM558 for each bank is monitoring its bank for knock events. The CM558s are constantly communicating with each other and transmitting knock count information via the CAN2.0B proprietary data link.

The Knock Sensor Based Engine Derate knock events are counted separately within the CM558 modules from other engine knock events.

Knock Sensor Based Engine Derate will be initiated when the sensed knock counts across the engine exceeds a pre-set number of knock counts per hour. The level of engine derate is dependant upon the number of knock counts per hour registered.

The Knock Sensor Based Engine Derate knock counts also decrease over time if no further knock events are registered. If the cause of engine knock is temporary, such as a reduction in gas quality for a short period, when the registered knock counts fall below the pre-set threshold, the engine derate command will be removed and load will slowly be returned to 100 percent.

The maximum permissible derate is limited and is pre-set within the CM558 software. The derate steps and maximum permissible derate may vary between engine models and software version.

There are potentially two types of Knock Sensor Based Engine Derates that can occur. The first is in response to what is classified as heavy knock, or consecutive knocking cycles where the voltage exceeds a prescribed threshold. The heavy knock - Knock Sensor Based Engine Derate reduces the load rapidly (within several seconds) and the Generator Set should return to full load within several minutes. This Rapid Derate is only active on Single Turbocharger Generator Sets fitted with Compressor Bypass Valves.

The second of the Knock Sensor Based Engine Derates reduces load and increases load gradually in response to total knock count accumulation across the engine.

Neither Knock Sensor Based Engine Derate invalidates the pre-existing knock sensor based engine shutdown features (such as Fault Code 561 or Fault Code 2522).

IMPORTANT NOTE: Engine derate features are only active for generator sets that are operating in Utility Parallel applications.

All detonation related shutdowns and persistent light knock events should be fully investigated in order to prevent engine damage.

The knock sensors can also detect mechanical noise and mechanical related problems should not be discounted as a cause of detonation shutdowns or high knock

  • Valve train / rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever elephant foot o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust (multi-duct) gasket leakage
  • Vibration resulting from loose engine parts/components.

Generator sets using PowerCommand™ Control 3300 (PCC3300) Generator Control:

  • The PCC3300 Generator Control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from no-knock condition (0 percent) to Most Severe Level (100 percent +).
Refer to Troubleshooting Fault Code 3458.

Last Modified: 02-Jul-2010


Engine Control Module (CM700 or CM558) - Warning Software Error

FAULT CODE 346

Engine Control Module (CM700 or CM558) - Warning Software Error

Printable Version Printable Version

Overview

Engine Control Module (CM700 or CM558) - Warning Software Error

CODE | REASON | EFFECT
Fault Code: 346 PID: S253 SPN: 630 FMI: 12 LAMP: None SRT: | Error internal to the CM700 or CM558. | No effect on engine performance.
CM700 or CM558

Circuit Description

The CM700 or CM558 is a computer that is responsible for engine control, diagnostics, and user features.

Component Location

Refer to the Engine Diagrams in Section E of this manual for the component location.

Shop Talk

This fault code can only be caused by an internal CM700 or CM558 problem.

Refer to Troubleshooting Fault Code t05-346

Last Modified: 30-Jun-2010


Engine Turbocharger Compressor Bypass Actuator Control Command - Condition Exists

FAULT CODE 3489

Engine Turbocharger Compressor Bypass Actuator Control Command - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3489 PID: SPN: 3470 FMI: 31 LAMP: Warning SRT: | Engine Turbocharger Compressor Bypass Actuator Control Command - Condition Exists. The ECM has detected a difference between the actuator commanded position and the actuator feedback signal. | Possible reduced engine performance.
Engine Turbocharger Compressor Bypass Actuator Circuit - QSK60G Single Turbocharger with Generator Control Panel 2 (GCP2) and PowerCommand® Supervisor 3100
Engine Turbocharger Compressor Bypass Actuator Circuit - QSK60G Single Turbocharger with Generator Interface Box (GIB) and PowerCommand® Control 3300

Circuit Description

The turbocharger compressor bypass actuator position circuit consists of the commanded position signal from the CM558 and the feedback signal that is received by the CM558 from the turbocharger compressor bypass valve. The CM558 monitors the commanded position and the feedback position signals to confirm that the compressor bypass valve has responded and is in the desired position. The commanded position signal is a + 24-VDC pulse width modulated (PWM) signal and the feedback is a 0 to 5-VDC signal.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The turbocharger compressor bypass actuator commanded signal and the feedback signal can be monitored using an electronic service tool. The turbocharger compressor bypass valve is most likely to malfunction in either the closed or fully open position. Compare the feedback signal with the commanded position signal to make sure that the valve is moving freely and is in the desired position.

The following table provides actuator position commanded PWM percent duty cycle and VDC feedback signal specifications.

Actuator Commanded Position | Percent Duty Cycle | 0 to 5-VDC Feedback Signal
0 | 10 - 11 | 0.4 - 0.7
10 | 17 - 19 | 0.9 - 1.1
20 | 25 - 27 | 1.3 - 1.5
30 | 33 - 35 | 1.7 - 1.9
40 | 41 - 43 | 2.1 - 2.3
50 | 49 - 51 | 2.5 - 2.7
60 | 57 - 59 | 2.9 - 3.1
70 | 65 - 67 | 3.3 - 3.5
80 | 73 - 75 | 3.7 - 3.9
90 | 81 - 83 | 4.1 - 4.3
100 | 89 - 91 | 4.6 - 4.8

PWM percent duty cycle signals can only be measured with multimeters or other measuring devices that have a percent duty cycle function.

If the difference between the commanded position and the feedback position signals is greater than the fault threshold, Fault Code 3489 will be activated.

Possible causes of this fault code include:

  • Short circuit in the commanded position or feedback signal circuits within the engine harness
  • Open circuit in the commanded position or feedback signal circuits within the engine harness.
Refer to Troubleshooting Fault Code t05-3489.

Last Modified: 06-Jan-2011


Engine Oil Filter Restriction High - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 3491

Engine Oil Filter Restriction High - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3491 PID: 99 SPN: 99 FMI: 0 LAMP: Warning SRT: | Engine Oil Filter Restriction High - Data Valid But Above Normal Operating Range - Most Severe Level. The engine oil filter differential pressure, as measured by the inlet and outlet oil filter pressure sensors, has exceeded the critical threshold level. | The engine will shutdown.
Lubricating Oil Pressure Sensor Circuit - QSK60G Multiple Turbochargers with Generator Control Panel 1 (GCP1) and PowerCommand® Supervisor 3100
Lubricating Oil Pressure Sensor Circuit - QSK60G Single and Multiple Turbochargers with Generator Control Panel 2 (GCP2) and PowerCommand® Supervisor 3100
Lubricating Oil Pressure Sensor Circuit - QSK60G Single and Multiple Turbochargers with PowerCommand® Control 3300

Circuit Description

The engine oil filter differential pressure is monitored by the CM700 module via pressure sensors fitted before and after the oil filtration. The pre-oil filter pressure sensor (inlet) monitors the oil pressure before the oil filters. The post-oil filter pressure sensor (outlet) monitors the oil pressure after the oil filters. The CM700 monitors the voltage on the SIGNAL pin and coverts this to a pressure value.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Fault Code 3491 will become active when the difference between the oil pressure at the inlet and outlet of the oil filter head reaches a present shutdown threshold.

Possible causes of this fault code include:

  • Plugged oil filters
  • Damaged sensors or harness
  • Plugged oil filter head.
Refer to Troubleshooting Fault Code t05-3491.

Last Modified: 06-Jan-2011


Engine Throttle Control Actuator CAN Commanded Shutdown Special Instructions

FAULT CODE 3515

Engine Throttle Control Actuator CAN Commanded Shutdown Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3515 PID: P190 SPN: 3464 FMI: 14/14 LAMP: Red SRT: | The Throttle Control Valve has reported to the ECM that it has been commanded to shut down. | The engine will shut down or will not start.
Throttle Control Actuator Circuit
Throttle Control Valve Run Enable Relay circuit

Circuit Description

The Throttle Control Valve is a smart actuator. It is controlled by the ECM through the J1939 datalink network. The ECM can open and close the throttle control valve based on the operating conditions in order to regulate air flow to the engine. The power supply for the throttle comes from the generator set control panel.

Component Location

The throttle control valve is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active and engine is running.

Conditions for Setting the Fault Codes

The throttle control valve has reported to the Engine Control Module (ECM) that it has been commanded to shut down.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning or damaged throttle control valve.
  • Malfunctioning or damaged run enable relay.
  • Malfunctioning DC power supply module.
  • Malfunctioning or damaged generator set wiring harness.
Refer to Troubleshooting Fault Code 3515.

Last Modified: 09-Feb-2021


Sensor Supply Circuit Number 1 - Shorted Low

FAULT CODE 352

Sensor Supply Circuit Number 1 - Shorted Low

Printable Version Printable Version

Overview

Sensor Supply Circuit Number 1 - Shorted Low

CODE | REASON | EFFECT
Fault Code: 352 PID: S232 SPN: 1079 FMI: 4 LAMP: Warning SRT: | Sensor Supply Circuit Number 1 - Shorted Low. Sensor supply number 1 supply signal is shorted low. | Possible reduced engine performance or shutdown. Gas mass flow sensor shorted low fault likely.
Sensor Supply Circuit Number 1 - Multiple Turbochargers
Sensor Supply Circuit Number 1 - Single Turbocharger

Circuit Description

Sensor supply circuit number 1 from the ECM supplies multiple engine pressure sensors with a positive (+) 5-VDC supply. The ECM has a common return for most of the engine pressure and temperature sensors. A fault on either of these wires can cause multiple pressure and temperature sensor fault codes as well as the power supply fault.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

Refer to the engine wiring diagram to find sensors that share a common electrical supply or return. A damaged pressure sensor can cause multiple fault codes. A damaged pressure sensor can cause multiple active fault codes to become inactive when the engine is started.

Refer to Troubleshooting Fault Code t05-352

Last Modified: 30-Jun-2010


Intake Manifold Pressure Sensor Circuit - Shorted High

FAULT CODE 354

Intake Manifold Pressure Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 354 PID: P106 SPN: 106 FMI: 3 LAMP: Shutdown SRT: | High voltage detected on the intake manifold pressure sensor SIGNAL pin of the main harness CM558 connector. | The engine will shut down.
Intake Manifold Pressure Sensor Circuit

Circuit Description

The intake manifold pressure sensor is an absolute pressure sensor used to measure the varying pressure of the air/fuel mixture entering the intake manifold of the engine. The intake manifold pressure value is used by the engine control module (ECM) for the engine protection system, timing and engine emissions control.

The left-bank CM558 ECM supplies 5-VDC to the intake manifold pressure supply circuit. The left-bank CM558 also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the left-bank CM558 on the intake manifold pressure signal circuit. This sensor signal voltage changes, based on the pressure in the intake manifold. The left-bank CM558 will detect a low signal voltage at operating conditions when the intake manifold pressure will be low (low load, steady state conditions). The left-bank CM558 will detect a high signal voltage at operating conditions when the intake manifold pressure will be high (high load or load demand conditions).

Component Location

The intake manifold pressure sensor is located on the right-bank side, non-drive end of the engine, and is mounted on the intake manifold.

The ECM, CM558, is located on the engines left-bank intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the ECM keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold pressure sensor signal voltage has exceeded the critical voltage high threshold of 4.75-VDC for 3 seconds. A 4.75-VDC is the default voltage high threshold and 3 seconds is the default persistence time for this fault code, but the default voltage threshold and persistence time may have different settings for specific CM558 software versions and engine applications.

Action Taken When the Fault Code is Active

  • The CM558 illuminates the red ALARM SHUTDOWN lamp on the Generator Control Panel immediately when the diagnostic runs and fails. Fault Code 354 will also be shown as ACTIVE by INSITE™ electronic service tool and on the original equipment manufacturer (OEM)harge a control panel display.
  • The engine will shut down (critical stop).

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run at rated speed for 1 minute at no load.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM, CM558, will turn off the red ALARM SHUTDOWN lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The intake manifold pressure sensor shares SUPPLY and RETURN wires in the engine harness with other sensors. Open and short circuits in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 354, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connector or sensor.
  • A signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code t05-354.

Last Modified: 04-Dec-2013


Intake Manifold Pressure Sensor Circuit - Shorted Low

FAULT CODE 355

Intake Manifold Pressure Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 355 PID: P106 SPN: 106 FMI: 4 LAMP: Shutdown SRT: | Intake Manifold Pressure Sensor Circuit - Shorted Low. Low voltage detected on the Intake Manifold Pressure Sensor SIGNAL pin of the main harness CM558 connector. | The engine will shut down.

Circuit Description

The intake manifold pressure sensor is an absolute pressure sensor used to measure the varying pressure of the air/fuel mixture entering the intake manifold of the engine. The intake manifold pressure value is used by the engine control modules (ECMs) for the engine protection system, timing, and engine emissions control.

The left-bank CM558 ECM supplies 5-VDC to the intake manifold pressure supply circuit. The left-bank CM558 also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the left-bank CM558 on the intake manifold pressure signal circuit. This sensor signal voltage changes, based on the pressure in the intake manifold. The left-bank CM558 will detect a low signal voltage at operating conditions when the intake manifold pressure will be low (low load, steady state conditions). The left-bank CM558 will detect a high signal voltage at operating conditions when the intake manifold pressure will be high (high load or load demand conditions).

Component Location

The intake manifold pressure sensor is located on the right-bank side, non-drive end of the engine, and is mounted on the intake manifold.

The CM558 is located on the engine's left-bank intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the ECM keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold pressure sensor signal voltage has exceeded the critical voltage low threshold of 0.146-VDC for 3 seconds. The default voltage low threshold is 0.146-VDC and 3 seconds is the default persistence time for this fault code, but the default voltage threshold and persistence time may have different settings for specific CM558 software versions and engine applications.

Action Taken When the Fault Code is Active

  • The CM558 illuminates the red ALARM SHUTDOWN lamp on the Generator Control Panel immediately when the diagnostic runs and fails. Fault Code 355 will also be shown as ACTIVE by INSITE™ electronic service tool and on the original equipment manufacturer (OEM) control panel display.
  • The engine will shut down (critical stop).

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run at rated speed for 1 minute at no load.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostics runs and passes.
  • The CM558 will turn off the red ALARM SHUTDOWN lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

The intake manifold pressure sensor shares SUPPLY and RETURN wires in the engine harness with other sensors. Open and short circuits in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 355, check for multiple fault codes.

Possible cause of this fault code include:

  • SUPPLY wire open circuit or short to ground in the engine harness, connectors, or sensor.
  • A signal circuit wire open circuit or shorted to ground.
Refer to Troubleshooting Fault Code t05-355.

Last Modified: 01-Nov-2013


Engine Derate - Special Instructions

FAULT CODE 3584

Engine Derate - Special Instructions

Printable Version Printable Version

Overview

Engine Derate - Special Instructions

CODE | REASON | EFFECT
Fault Code: 3584 PID: SPN: FMI: LAMP: Shutdown SRT: | Engine Derate - Special Instructions. The generator set or utility paralleling circuit breaker has open while the engine is in an active state of self-derate. | The engine will shutdown.
Reference to site specific wiring diagrams for the generator set circuit breaker and the utility paralleling circuit breaker wiring.

Circuit Description

Engine derate features are only active while the generator set is operating in utility parallel mode. If any of the paralleling circuits breakers open (the utility paralleling circuit breaker or the generator set circuit breaker), while the engine is on load but in an active state of self-derate, then the control system will initiate an immediate shutdown in order to prevent severe engine over speed.

The connection after the generator set circuit breaker is site specific. Reference will need to be made to the site electrical installation drawings and protection logic. Access to this equipment and areas are usually restricted to electrically qualified and authorized personnel, such as a senior authorized person.

Make certain that you understand and comply with local regulations and legislation.

Component Location

Reference the site specific installation drawings for the location of the generator set circuit breaker and utility paralleling circuit breaker.

Shop Talk

For generator sets operating in utility parallel applications, a number of engine derate features have been introduced so that power generation can be maintained, but at a reduced output. The level of derate permitted is limited and varies between engine models and software versions.

The engines derate functions can be initiated for the following reason:

  • Engine knock related issues (Fault Code 3458).
Refer to Troubleshooting Fault Code 3584.

Last Modified: 02-Jul-2010


Engine Failed to Start

FAULT CODE 359

Engine Failed to Start

Printable Version Printable Version

Overview

Engine Failed to Start

CODE | REASON | EFFECT
Fault Code: 359 PID: SPN: FMI: 31 LAMP: SRT: | The engine has not started after a complete starting cycle. | The engine will shutdown.
Starter Circuit

Circuit Description

The starter is commanded to run by the CM700. If the engine performs a complete start cycle of cranking and purge attempts without starting, the failed start fault will be set.

In the above circuit, the starter relay is commanded to close by the CM700. This sends 24 VDC to the starter solenoid to engage the starter.

Component Location

Refer to the engine diagrams in SectionE of this manual for the component location.

Shop Talk

The failed to start fault will cause the start cycle to stop and a shutdown fault will occur. However, as soon as the engine speed reaches zero, after the final purge cycle, the fault will reset and the engine will be ready for another starting cycle.

Refer to Troubleshooting Fault Code t05-359

Last Modified: 30-Jun-2010


Engine Emissions Closed Loop fueling (Limit) - Condition Exist

FAULT CODE 3594

Engine Emissions Closed Loop fueling (Limit) - Condition Exist

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3594 PID: SPN: 520485 FMI: 31 LAMP: Warning SRT: | Engine Emissions Closed Loop fueling (Limit) - Condition Exists. The engine closed loop fueling control has reached the limit of adjustment within the calibration. | The engine will continue to run but performance may be impaired.
Multiple Turbochargers Generator Sets with Two-Piece Throttle, PowerCommand® Supervisor 3100 Control, and AC and DC Generator Interface Boxes
Single and Multiple Turbocharger Generator Sets with Integrated Throttle, PowerCommand® Supervisor 3100 Control and Generator Interface Box (GIB)
Single and Multiple Turbocharger Generator Sets with Integrated Throttle and PowerCommand® Controller 3300 Control

Circuit Description

Engine fueling control is managed by the left-bank CM558 module. The fueling map is part of the CM558 calibration and is specific to the engine rating, application and exhaust emissions specification. The range of adjustment or fueling compensation available within the fuel map is limited, but is designed to provide a wide-range of fueling compensation in response to varying inputs, including fuel quality (Lower Heating Value kg/N.m³).

The CM558 controls the fueling based on a number of engine sensor inputs.

Open and closed loop fueling:

  • Engine speed (RPM)
  • Coolant temperature (high temperature circuit)
  • Intake manifold temperature (IMT)
  • Intake manifold pressure (IMP)
  • Fuel inlet pressure (FIP)
  • Fuel outlet pressure (FOP)
  • Gas mass flow (GMF)
  • Fuel control valve position percent (FCV).

Closed loop fueling:

  • Torque-over-boost.

Torque-over-boost is a method of calculating the engines actual air/fuel ratio (measured) for a given operating condition and the key inputs are generator kilowatts (KW = torque) and intake manifold pressure (boost).

From all of these inputs, the CM558 can calculate the Desired Gas Flow (used for open-loop fueling) and the Desired Air/Fuel Ratio (used for closed-loop fueling). The CM558 then compares the Measured Gas Flow and the Measured Air/Fuel Ratio and adjusts the fuel control valve accordingly in order to make the necessary fueling adjustment required to maintain the specified exhaust emissions.

Engines will operate using open-loop fueling control at low intake manifold pressures and will switch to closed-loop fueling control when the pressure measured in the intake manifold exceeds 103.4 kPa [15 psia].

For generator sets fitted with AC and DC Generator Interface Panels use a kilowatt load transducer to supply generator set kilowatt load information to the CM700 module.

For generator sets fitted with a Generator Interface Box (GIB), the kilowatt load is taken directly from the generator set controller (PowerCommand® Supervisor 3100 Control Panel or PowerCommand® Controller 3300 Control Panel).

The CM700 module communicates any fueling related information to the left bank CM558 module over the proprietary data link circuit.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Once the engine fueling has been adjusted and set, the CM558 will work to maintain the desired fueling to achieve the required exhaust emissions, while maintaining engine stability and response.

If the sensors used for fueling control and the fuel remain within specification (fuel Lower Heating Value (LHV) ±4 percent), then the fueling and exhaust emissions will be maintained across a wide range of operating conditions. The fueling and emissions can begin to drift out of specification if one or more of the input sensors or the fuel quality begins to deviate outside of its specification. The CM558 module can, up to a limit, compensate for these deviations. However, if the sensor condition or fuel quality continues to deteriorate, the CM558 module will eventually reach the limit of adjustment within the fuel map and engine performance will be compromised. When this limit of adjustment is reached, Fault Code 3594 will be activated.

Auxiliary equipment within the overall power plant system, such as Selective Catalyst Reduction (SCR) systems, can also have an effect on engine fueling and will be need to be considered when investigating Fault Code 3594 - for example, if the catalyst medium (bricks) within the SCR becomes blocked. The causes of SCR malfunction will need to be investigated using the relevant service literature supplied with the equipment.

NOTE: Fault finding of auxiliary equipment, such as SCR systems, are outside of the scope of this document.

The most likely cause for this fault is that one of the sensors used for fuel control has malfunctioned or has a poor connection. It should be remembered that sensors can malfunction in-range, which will not activate their respective fault codes. The generator set kilowatt load signal to the CM700 may also be inaccurate and will cause incorrect fueling. Fuel quality will also need to be considered and checked.

The following table, which can be used as an aid when checking the fuel control valve operation, provides actuator position Commanded PWM percent Duty Cycle and VDC Feedback signal specifications.

Actuator Commanded Position | Percent Duty Cycle | 0 - 5-VDC Feedback Signal
0 | 10 - 11 | 0.4 - 0.7
10 | 17 - 19 | 0.9 - 1.1
20 | 25 - 27 | 1.3 - 1.5
30 | 33 - 35 | 1.7 - 1.9
40 | 41 - 43 | 2.1 - 2.3
50 | 49 - 51 | 2.5 - 2.7
60 | 57 - 59 | 2.9 - 3.1
70 | 65 - 67 | 3.3 - 3.5
80 | 73 - 75 | 3.7 - 3.9
90 | 81 - 83 | 4.1 - 4.3
100 | 89 - 91 | 4.6 - 4.8

NOTE: PWM percent duty cycle signals can only be measured with multimeters or other measuring devices that have a percent duty cycle function.

Refer to Troubleshooting Fault Code 3594.

Last Modified: 09-Jul-2010


Engine Emissions Closed Loop Fueling (Limit) - Root Cause Not Known

FAULT CODE 3595

Engine Emissions Closed Loop Fueling (Limit) - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3595 PID: SPN: 520485 FMI: 11 LAMP: Shutdown SRT: | Engine Emissions Closed Loop fueling (Limit) - Root Cause Not Known. The engine closed loop fueling control has reached the limit of adjustment within the calibration. | The engine will shutdown.
Multiple Turbocharger Generator Sets with Two-Piece Throttle, PowerCommand® Supervisor 3100 Control, and AC and DC Generator Interface Boxes
Single and Multiple Turbocharger Generator Sets with Integrated Throttle, PowerCommand® Supervisor 3100 Control and Generator Interface Box (GIB)
Single and Multiple Turbocharger Generator Sets with Integrated Throttle and PowerCommand® Controller 3300 Control

Circuit Description

Engine fueling control is managed by the left bank CM558 module. The fueling map is part of the CM558 calibration and is specific to the engine rating, application, and exhaust emissions specification. The range of adjustment or fueling compensation available within the fuel map is limited, but is designed to provide a wide-range of fueling compensation in response to varying inputs, including fuel quality (Lower Heating Value kg/N.m3).

The CM558 controls the fueling based on a number of engine sensor inputs.

Open and closed loop fueling:

  • Engine speed (rpm)
  • Coolant temperature (high temperature circuit)
  • Intake manifold temperature (IMT)
  • Intake manifold pressure (IMP)
  • Fuel inlet pressure (FIP)
  • Fuel outlet pressure (FOP)
  • Gas mass flow (GMF)
  • Fuel control valve position percent (FCV).

Closed-loop fueling:

  • Torque-over-boost.

Torque-over-boost is a method of calculating the engine's actual air/fuel ratio (measured) for a given operating condition and the key inputs are generator kilowatts (KW = torque) and intake manifold pressure (boost).

From all of these inputs, the CM558 can calculate the "Desired Gas Flow" (used for open-loop fueling) and the "Desired Air/Fuel Ratio" (used for closed-loop fueling). The CM558 then compares the "Measured Gas Flow" and the "Measured Air/Fuel Ratio" and adjusts the fuel control valve accordingly in order to make the necessary fueling adjustment required to maintain the specified exhaust emissions.

Engines will operate using "open-loop" fueling control at low intake manifold pressures and will switch to closed-loop fueling control when the pressure measured in the intake manifold exceeds 103 kPa [15 psia].

Generator sets fitted with AC and DC generator interface panels use a kilowatt load transducer to supply generator set kilowatt load information to the CM700 module.

Generator Sets fitted with a generator interface box (GIB), the kilowatt load is taken directly from the generator set controller (PowerCommand® Supervisor 3100 Control Panel or PowerCommand® Controller 3300 Control Panel).

The CM700 module communicates any fueling-related information to the left bank CM558 module over the proprietary data link circuit.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Once the engine fueling has been adjusted and set, the CM558 will work to maintain the desired fueling to achieve the required exhaust emissions, while maintaining engine stability and response.

If the sensors used for fueling control and the fuel remain within specification (fuel Lower Heating Value (LHV) ±4 percent), the fueling and exhaust emissions will be maintained across a wide range of operating conditions. The fueling and emissions can begin to drift out of specification if one or more of the input sensors or the fuel quality begins to deviate outside of its specification. The CM558 module can, up to a limit, compensate for these deviations. However, if the sensor condition or fuel quality continues to deteriorate, the CM558 module will eventually reach the limit of adjustment within the fuel map and engine performance will be compromised. When this limit of adjustment is reached, Fault Code 3595 will be activated.

Auxiliary equipment within the overall power plant system, such as Selective Catalyst Reduction (SCR) systems, can also have an effect on engine fueling and will need to be considered when investigating Fault Code 3595 - for example, if the catalyst medium (bricks) within the SCR becomes blocked. The causes of SCR malfunction will need to be investigated using the relevant service literature supplied with the equipment.

NOTE: Fault finding of auxiliary equipment, such as SCR systems, are outside of the scope of this document.

The most likely cause for this fault is that one of the sensors used for fuel control has malfunctioned or has a poor connection. It should be remembered that sensors can malfunction "in-range" which will not activate their respective fault codes. The generator set kilowatt load signal to the CM700 can also be inaccurate and will cause incorrect fueling. Fuel quality will also need to be considered and checked.

The following table, which can be used as an aid when checking the fuel control valve operation, provides actuator position commanded pulse width modulated (PWM) percent duty cycle and VDC feedback signal specifications.

Actuator Commanded Position | Percent Duty Cycle | 0 - 5-VDC Feedback Signal
0 | 10 - 11 | 0.4 - 0.7
10 | 17 - 19 | 0.9 - 1.1
20 | 25 - 27 | 1.3 - 1.5
30 | 33 - 35 | 1.7 - 1.9
40 | 41 - 43 | 2.1 - 2.3
50 | 49 - 51 | 2.5 - 2.7
60 | 57 - 59 | 2.9 - 3.1
70 | 65 - 67 | 3.3 - 3.5
80 | 73 - 75 | 3.7 - 3.9
90 | 81 - 83 | 4.1 - 4.3
100 | 89 - 91 | 4.6 - 4.8

NOTE: PWM percent duty cycle signals can only be measured with multimeters or other measuring devices that have a percent duty cycle function.

Refer to Troubleshooting Fault Code t05-3595.

Last Modified: 21-Oct-2010


Sensor Supply Circuit Number 1 - Shorted High

FAULT CODE 386

Sensor Supply Circuit Number 1 - Shorted High

Printable Version Printable Version

Overview

Sensor Supply Circuit Number 1 - Shorted High

CODE | REASON | EFFECT
Fault Code: 386 PID: S232 SPN: 1079 FMI: 3 LAMP: Warning SRT: | Sensor Supply Circuit Number 1 - Shorted High. Sensor supply number 1 supply signal is shorted high. | Possible reduced engine performance or shutdown. Gas mass flow sensor shorted high fault likely.
Sensor Supply Circuit Number 1 - Multiple Turbochargers
Sensor Supply Circuit Number 1 - Single Turbocharger

Circuit Description

Sensor Supply Circuit Number 1 from the ECM supplies multiple engine pressure sensors with a positive (+) 5-VDC supply. The ECM has a common return for most of the engine pressure and temperature sensors. A fault on either of these wires may cause multiple pressure and temperature sensor fault codes as well as the power supply fault.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

Refer to the engine wiring diagram to find sensors that share a common electrical supply or return. A damaged pressure sensor can cause multiple fault codes. A damaged pressure sensor can cause multiple active fault codes to become inactive when the engine is started.

Refer to Troubleshooting Fault Code t05-386

Last Modified: 30-Jun-2010


Low Voltage Ride Through - Bad Intelligent Device or Component

FAULT CODE 3869

Low Voltage Ride Through - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3869 PID: SPN: 520527 FMI: 12 LAMP: Warning SRT: | Low Voltage Ride Through - Bad Intelligent Device or Component. Low voltage ride through detection in the generator set controller is in error or not available. | The engine will continue to run.
QSK60G Single and Multiple Turbochargers with PowerCommand™ Control 3300 and Generator Interface Box (GIB) - Low Voltage Ride Through Circuit

Circuit Description

Low Voltage Ride Through (LVRT) detection equipment is part of the Cummins® PowerCommand™ Controller 3300 (PCC3300) generator set control system. LVRT related information is relayed from the PCC3300 to the CM700 module (engine control system) over the J1939 data link.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

LVRT relates to Grid Code Compliance and is mainly in force within Europe, but LVRT is expected to be adopted in some form by other countries. Within the European Union, LVRT compliance will be mandatory from 2014.

LVRT applies to generator set connection to the utility (grid) and requires that the generator set remains connected to the utility during certain grid fault conditions. The period of time that the generator set should remain connected to the utility is determined by the fault condition, but is generally in the region of 500ms (milliseconds), after which the generator set can be disconnected from the utility.

Note: LVRT system and related equipment faults can result in serious engine and generator set damage.

Troubleshooting of the generator set control system (PCC3300) and associated components and circuits is outside the scope of this procedure. For generator set control system troubleshooting guidance, refer to the appropriate Generator Set Controller Service Manual.

  • For Cummins® PowerCommand™ Controller (PCC) 3300: Service Manual, Bulletin Number 0900-0670.
Refer to Troubleshooting Fault Code t05-3869

Last Modified: 24-Feb-2012


Low Voltage Ride Through - Abnormal Update Rate

FAULT CODE 3871

Low Voltage Ride Through - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3871 PID: SPN: 520527 FMI: 9 LAMP: Warning SRT: | Low Voltage Ride Through - Abnormal Update Rate. Receiving low voltage ride through information over data link lost or intermittent. | The engine will continue to run.
QSK60G Single and Multiple Turbochargers with PowerCommand™ Control 3300 and Generator Interface Box (GIB) - Low Voltage Ride Through Circuit

Circuit Description

Low Voltage Ride Through (LVRT) detection equipment is part of the Cummins® PowerCommand™ Controller 3300 (PCC3300) generator set control system. LVRT related information is relayed from the PCC3300 to the CM700 module (engine control system) over the J1939 data link.

Component Location

Refer to Procedure 100-002 in Section E for the component location.

Shop Talk

LVRT relates to Grid Code Compliance and is mainly in force within Europe, but LVRT is expected to be adopted in some form by other countries. Within the European Union, LVRT compliance will be mandatory from 2014.

LVRT applies to generator set connection to the utility (grid) and requires that the generator set remains connected to the utility during certain grid fault conditions. The period of time that the generator set should remain connected to the utility is determined by the fault condition, but is generally in the region of 500ms (milliseconds), after which the generator set can be disconnected from the utility.

Note: LVRT system and related equipment faults can result in serious engine and generator set damage.

Troubleshooting of the generator set control system (PCC3300) and associated components and circuits is outside the scope of this procedure. For generator set control system troubleshooting guidance, refer to the appropriate Generator Set Controller Service Manual:

  • For Cummins® PowerCommand™ Controller (PCC) 3300: Service Manual Bulletin Number 0900-0670.
Refer to Troubleshooting Fault Code t05-3871

Last Modified: 24-Feb-2012


Low Voltage Ride Through - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3872

Low Voltage Ride Through - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3872 PID: N/A SPN: 520527 FMI: 2 LAMP: Warning SRT: N/A | Low Voltage Ride Through - Data Erratic, Intermittent, or Incorrect. Receiving low voltage ride through information over data link is erratic, intermittent or incorrect. | The engine will continue to operate.
QSK60G Single and Multiple Turbochargers with PowerCommand™ Control 3300 and Generator Interface Box - Low Voltage Ride Through Circuit

Circuit Description

Low voltage ride through (LVRT) detection equipment is part of the Cummins® PowerCommand™ Controller 3300 (PCC3300) generator set control system. LVRT related information is relayed from the PCC3300 to the CM700 module (engine control system) over the J1939 data link.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

LVRT relates to grid code compliance and is mainly inforced within Europe, but LVRT is expected to be adopted in some form by other countries within the European Union, LVRT compliance will be mandatory 2014.

LVRT applies to generator set connection to the utility (grid) and requires that the generator set remains connected to the utility during certain grid fault conditions. The period of time that the generator set should remain connected to the utility is determined by the fault condition, but is generally in the region of 500ms (milliseconds), after which the generator set can be disconnected from the utility.

NOTE: LVRT system and related equipment faults can result in serious engine and generator set damage.

Troubleshooting of the generator set control system (PCC3300) and associated components and circuits is outside of the scope of this procedure. For generator set control system troubleshooting guidance, use the appropriate Generator Set Controller Service Manual:

  • Cummins® PowerCommand™ Controller (PCC) 3300: Service Manual Bulletin Number 0900-0670
Refer to Troubleshooting Fault Code t05-3872.

Last Modified: 10-Feb-2012


Low Voltage Ride Through - Abnormal Frequency, Pulse Width, or Period

FAULT CODE 3873

Low Voltage Ride Through - Abnormal Frequency, Pulse Width, or Period

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3873 PID: N/A SPN: 520527 FMI: 8 LAMP: Shutdown SRT: N/A | Low Voltage Ride Through - Abnormal Frequency, Pulse Width, or Period. Receiving low voltage ride through information over data link at an abnormal frequency, pulse width or period. | The engine will stop.
QSK60G Single and Multiple Turbochargers with PowerCommand™ Control 3300 and Generator Interface Box - Low Voltage Ride Through Circuit

Circuit Description

Low Voltage Ride Through (LVRT) detection equipment is part of the Cummins® PowerCommand™ Controller 3300 (PCC3300) generator set control system. LVRT related information is relayed from the PCC3300 to the CM700 module (engine control system) over the J1939 data link.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

LVRT relates to Grid Code Compliance and is mainly in-force within Europe, but LVRT is expected to be adopted in some form by other Countries. Within the European Union, LVRT compliance will be mandatory from 2014.

LVRT applies to generator set connection to the utility (grid) and requires that the generator set remains connected to the utility during certain grid fault conditions. The period of time that the generator set should remain connected to the utility is determined by the fault condition, but is generally in the region of 500ms (milliseconds), after which the generator set can be disconnected from the utility.

NOTE: LVRT system and related equipment faults can result in serious engine and generator set damage. Troubleshooting of the generator set control system (PCC3300) and associated components and circuits is outside of the scope of this procedure. For generator set control system troubleshooting guidance, use the appropriate Generator Set Controller Service Manual:

  • Cummins® PowerCommand™ Controller (PCC) 3300: Service Manual Bulletin Number 0900-0670.

Activation of this fault code could indicate that a high number of grid faults have/are present, which could occur in regions which have an unstable utility grid system.

Refer to Troubleshooting Fault Code t05-3873.

Last Modified: 10-Feb-2012


Low Voltage Ride Through - Root Cause Not Known

FAULT CODE 3874

Low Voltage Ride Through - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3874 PID: N/A SPN: 520527 FMI: 11 LAMP: Warning SRT: N/A | Low Voltage Ride Through - Root Cause Not Known. An unknown fault has occurred with receiving low voltage ride through information over the data link. | The engine will continue to operate.
QSK60G Single and Multiple Turbochargers with PowerCommand™ Control 3300 and Generator Interface Box - Low Voltage Ride Through Circuit

Circuit Description

Low voltage ride through (LVRT) detection equipment is part of the Cummins® PowerCommand™ Controller 3300 (PCC3300) generator set control system. LVRT related information is relayed from the PCC3300 to the CM700 module (engine control system) over the J1939 data link.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002 in Section E.

Shop Talk

LVRT relates to grid code compliance and is mainly inforced within Europe, but LVRT is expected to be adopted in some form by other countries. Within the European Union, LVRT compliance will be mandatory from 2014. LVRT applies to generator set connection to the utility (grid) and requires that the generator set remains connected to the utility during certain grid fault conditions. The period of time that the generator set should remain connected to the utility is determined by the fault condition, but is generally in the region of 500ms (milliseconds), after which the generator set can be disconnected from the utility.

NOTE: LVRT system and related equipment faults can result in serious engine and generator set damage.

Troubleshooting of the generator set control system (PCC3300) and associated components and circuits is outside of the scope of this procedure. For generator set control system troubleshooting guidance, use the appropriate Generator Set Controller Service Manual:

  • Cummins® PowerCommand™ Controller (PCC) 3300: Service Manual Bulletin Number 0900-0670

Activation of this fault code could indicate a fault in the generator set PCC3300 controller or an intermittent short in the generator set harness.

Refer to Troubleshooting Fault Code t05-3874.

Last Modified: 10-Feb-2012


Low Voltage Ride Through - Condition Exists

FAULT CODE 3875

Low Voltage Ride Through - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3875 PID: N/A SPN: 520527 FMI: 31 LAMP: Warning SRT: N/A | Low Voltage Ride Through - Condition Exists. The low voltage ride through detection system has detected a low voltage ride through event. | The engine will continue to operate.
QSK60G Single and Multiple Turbochargers with PowerCommand™ Control 3300 and Generator Interface Box - Low Voltage Ride Through Circuit

Circuit Description

Low voltage ride through (LVRT) detection equipment is part of the Cummins® PowerCommand™ Controller 3300 (PCC3300) generator set control system. LVRT related information is relayed from the PCC3300 to the CM700 module (engine control system) over the J1939 data link.

Component Location

Use the following procedure for the component location. Refer to Procedure 100-002-in Section E.

Shop Talk

LVRT relates to Grid Code Compliance and is mainly inforced within Europe, but LVRT is expected to be adopted in some form by other countries. Within the European Union, LVRT compliance will be mandatory from 2014.

LVRT applies to generator set connection to the utility (grid) and requires that the generator set remains connected to the utility during certain grid fault conditions. The period of time that the generator set should remain connected to the utility is determined by the fault condition, but is generally in the region of 500ms (milliseconds), after which the generator set can be disconnected from the utility.

NOTE: LVRT system and related equipment faults can result in serious engine and generator set damage.

Troubleshooting of the generator set control system (PCC3300) and associated components and circuits is outside of the scope of this procedure. For generator set control system troubleshooting guidance, use the appropriate Generator Set Controller Service Manual:

  • Cummins® PowerCommand™ Controller (PCC) 3300: Service Manual Bulletin Number 0900-0670

Activation of this fault code indicates that a grid related fault has occurred, which the LVRT system has detected, and the generator set has remained connected to the grid.

Refer to Troubleshooting Fault Code t05-3875.

Last Modified: 10-Feb-2012


SAE J1587/1939 Datalink Can Not Transmit

FAULT CODE 412

SAE J1587/1939 Datalink Can Not Transmit

Printable Version Printable Version

Overview

SAE J1587/1939 Datalink Can Not Transmit

CODE | REASON | EFFECT
Fault Code: 412 PID: S250 SPN: 608 FMI: 2 LAMP: None SRT: | Erratic, intermittent, or incorrect data detected on the SAE J1587/1939 datalink | No effect on engine performance.
SAE J1587/1939 Datalink Circuit

Circuit Description

The SAE J1587/1939 datalink is a public datalink that broadcasts engine operating data as well as fault codes.

Component Location

Refer to the Engine Diagrams in Section E of this manual for the datalink location.

Shop Talk

A selector switch in installed in the generator set control panel that allows for the selection of the module data that will be available on the datalink. Be sure that the selector switch is in the appropriate position for the electronic tool configuration.

Refer to Troubleshooting Fault Code t05-412

Last Modified: 30-Jun-2010


SAE J1587/1939 Datalink - Abnormal Update Rate

FAULT CODE 414

SAE J1587/1939 Datalink - Abnormal Update Rate

Printable Version Printable Version

Overview

SAE J1587/1939 Datalink - Abnormal Update Rate

CODE | REASON | EFFECT
Fault Code: 414 PID: S250 SPN: 608 FMI: 9 LAMP: None SRT: | An abnormal update rate has been detected on the SAE J1587/1939 datalink. | No effect on engine performance.
SAE J1587/1939 Datalink Circuit

Circuit Description

The SAE J1587/1939 datalink is a public datalink that broadcasts engine operating data as well as fault codes.

Component Location

Refer to the Engine Diagrams in Section E of this manual for the datalink location.

Shop Talk

A selector switch is installed in the generator set control panel that allows for the selection of the module data that will be available on the datalink. Be sure the selector switch is in the appropriate position for the electronic tool configuration.

Refer to Troubleshooting Fault Code t05-414

Last Modified: 30-Jun-2010


Engine Oil Pressure (Rifle) Low - Critical

FAULT CODE 415

Engine Oil Pressure (Rifle) Low - Critical

Printable Version Printable Version

Overview

Engine Oil Pressure (Rifle) Low - Critical

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1 LAMP: Shutdown SRT: | Engine Oil Pressure (Rifle) Low - Critical. The engine oil pressure (rifle) has dropped below the low critical threshold. | The engine will shut down.
Engine Oil Pressure Sensor Circuit - Multiple Turbochargers
Engine Oil Pressure Sensor Circuit - Single Turbocharger

Circuit Description

The oil pressure sensor monitors oil pressure and passes information to the CM700. The CM700 monitors voltage on the oil pressure signal pin and expects to see the voltage vary between 0.46 and 4.56-VDC during normal engine operation.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

The engine oil pressure (rifle) has dropped below the low critical threshold.

Refer to Troubleshooting Fault Code t05-415

Last Modified: 30-Jun-2010


Engine Oil Temperature High - Warning

FAULT CODE 421

Engine Oil Temperature High - Warning

Printable Version Printable Version

Overview

Engine Oil Temperature High - Warning

CODE | REASON | EFFECT
Fault Code: 421 PID: P175 SPN: 175 FMI: 16 LAMP: Warning SRT: | Engine Oil Temperature High - Warning. The engine oil temperature has exceeded the high warning threshold. | No effect on engine performance.
Engine Oil Temperature Sensor Circuit - Multiple Turbochargers
Engine Oil Temperature Sensor Circuit - Single Turbocharger

Circuit Description

The oil temperature sensor is used by the CM700 to monitor the temperature of the engine lubricating oil.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

The engine oil temperature has exceeded a high warning threshold. The resistance of the sensor varies with temperature. Refer to the wiring diagram for resistance specifications.

Refer to Troubleshooting Fault Code t05-421

Last Modified: 30-Jun-2010


SAE J1939 Data Link - Can Not Transmit

FAULT CODE 426

SAE J1939 Data Link - Can Not Transmit

Printable Version Printable Version

Overview

SAE J1939 Data Link - Can Not Transmit

CODE | REASON | EFFECT
Fault Code: 426 PID: S231 SPN: 639 FMI: 2 LAMP: None SRT: | SAE J1939 Data Link - Can Not Transmit. Erratic, intermittent, or incorrect data detected on the SAE J1939 data link. | No effect on engine performance.
SAE J1939 Data Link Circuit - Multiple Turbochargers
SAE J1939 Data Link Circuit - Single Turbocharger

Circuit Description

The SAE J1939 data link is a public data link that broadcasts engine operating data as well as fault codes.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

The SAE J1939 data link is a network data link on which each ECM is attached via a network stub connection. Be sure the electronic service tool is set up for J1939 communications (if applicable) when using this data link.

Refer to Troubleshooting Fault Code t05-426

Last Modified: 30-Jun-2010


SAE J1939 Data Link - Abnormal Update Rate

FAULT CODE 427

SAE J1939 Data Link - Abnormal Update Rate

Printable Version Printable Version

Overview

SAE J1939 Data Link - Abnormal Update Rate

CODE | REASON | EFFECT
Fault Code: 427 PID: S231 SPN: 639 FMI: 9 LAMP: None SRT: | An abnormal update rate has been detected on the SAE J1939 data link. | No effect on engine performance.
SAE J1939 Data Link Circuit - Multiple Turbochargers
SAE J1939 Data Link Circuit - Single Turbocharger

Circuit Description

The SAE J1939 data link is a public data link that broadcasts engine operating data as well as fault codes.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

The SAE J1939 data link is a network data link on which each ECM is attached via a network stub connection. Be sure the electronic service tool is set up for J1939 communications (if applicable) when using this data link.

Refer to Troubleshooting Fault Code t05-427

Last Modified: 30-Jun-2010


Battery Supply Circuit - Low

FAULT CODE 441

Battery Supply Circuit - Low

Printable Version Printable Version

Overview

Battery Supply Circuit - Low

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 1/18 LAMP: Warning SRT: | Battery Supply Circuit - Low. Low voltage has been detected on the battery supply. | ECM voltage supply approaching a level at which unpredictable operation will occur.
Battery Supply Circuit - Multiple Turbochargers
Battery Supply Circuit - Single Turbocharger

Circuit Description

The +24-VDC battery circuit provides operating power to the CM700, CM558s, CENSE™ module and the fuel control valve. This supply is provided by a 20 ampere DC power supply, which is located at the customers discretion.

Component Location

The location of the DC power supply in the generator room will vary with the OEM.

Shop Talk

This fault is usually caused by loose or corroded connections, a blown fuse or a tripped circuit breaker.

Refer to Troubleshooting Fault Code t05-441

Last Modified: 30-Jun-2010


Battery Supply Circuit - High

FAULT CODE 442

Battery Supply Circuit - High

Printable Version Printable Version

Overview

Battery Supply Circuit - High

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 0/16 LAMP: Warning SRT: | Battery Supply Circuit - High. High voltage has been detected on the battery. | ECM damage will occur.
Battery Supply Circuit - Multiple Turbochargers
Battery Supply Circuit - Single Turbocharger

Circuit Description

The 24-VDC battery circuit provides operating power to the CM700, CM558s, CENSE™ module and the Fuel Control Valve. This supply is provided by a 20 ampere DC power supply, which is located at the customers discretion.

Component Location

The location of the DC power supply in the generator room will vary with the OEM.

Shop Talk

Improper wiring of the battery circuit is the most likely cause of this fault.

Refer to Troubleshooting Fault Code t05-442

Last Modified: 30-Jun-2010


Gas Mass Flow Sensor Circuit - Shorted High

FAULT CODE 453

Gas Mass Flow Sensor Circuit - Shorted High

Printable Version Printable Version

Overview

Gas Mass Flow Sensor Circuit - Shorted High

CODE | REASON | EFFECT
Fault Code: 453 PID: P183 SPN: FMI: 3 LAMP: Warning SRT: | Gas Mass Flow Sensor Circuit - Shorted High. High voltage detected at the gas mass flow sensor pin of the main harness CM558 connector. | Possible Reduced engine performance.
Gas Mass Flow Sensor Circuit - Multiple Turbochargers
Gas Mass Flow Sensor Circuit - Single Turbocharger

Circuit Description

The signal from the CM558 to the gas mass flow sensor is 14-VDC. A short to battery voltage in the harness or at the gas mass flow sensor connector will cause Fault Code 453 to be set.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

The gas mass flow sensor is supplied with 14-VDC from the CM558. The sensor is a hot wire sensor with two wire elements that protrude into the gas flow. The two wires are kept at equal temperatures and the signal, 0 to 5-VDC, indicates the gas flow to the CM558. The 0 to 5-VDC signal corresponds to the voltage necessary to maintain the temperature of the wires due to the cooling effect as the gas flows.

Refer to Troubleshooting Fault Code t05-453

Last Modified: 30-Jun-2010


Gas Mass Flow Sensor Circuit - Shorted Low

FAULT CODE 454

Gas Mass Flow Sensor Circuit - Shorted Low

Printable Version Printable Version

Overview

Gas Mass Flow Sensor Circuit - Shorted Low

CODE | REASON | EFFECT
Fault Code: 454 PID: P183 SPN: FMI: 4 LAMP: Warning SRT: | Gas Mass Flow Sensor Circuit - Shorted Low. Low voltage detected at the Gas Mass Flow Sensor pin of the main harness CM558 connector. | Possible reduced engine performance.
Gas Mass Flow Sensor Circuit - Multiple Turbochargers
Gas Mass Flow Sensor Circuit - Single Turbocharger

Circuit Description

The signal from the CM558 to the Gas Mass Flow Sensor is 14-VDC. A short to ground in the harness or at the Gas Mass Flow Sensor connector will cause Fault Code 454 to be set.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

The Gas Mass Flow Sensor is supplied with 14-VDC from the CM558. The sensor is a hot wire sensor with two wire elements that protrude into the gas flow. The two wires are kept at equal temperatures and the signal, 0 to 5-VDC, indicates the gas flow to the CM558. The 0 to 5-VDC signal corresponds to the voltage necessary to maintain the temperature of the wires, due to the cooling effect as the gas flows.

Refer to Troubleshooting Fault Code t05-454

Last Modified: 30-Jun-2010


Ignition Timing Signal Circuit - Shorted High

FAULT CODE 458

Ignition Timing Signal Circuit - Shorted High

Printable Version Printable Version

Overview

Ignition Timing Signal Circuit - Shorted High

CODE | REASON | EFFECT
Fault Code: 458 PID: S067 SPN: 726 FMI: 3 LAMP: Shutdown SRT: | Ignition Timing Signal Circuit - Shorted High. The ignition timing signal pin of the CM558 incorrectly remains at a high voltage level when it is commanded low. | The engine will shut down.
Ignition Timing and Reference Signal Circuit - Multiple Turbochargers
Ignition Timing and Reference Signal Circuit - Single Turbocharger

Circuit Description

The ignition timing signal is a 5-VDC signal. The CM558 drives the ignition timing signal to 0-VDC to create an ignition timing pulse for each cylinder.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

The CM558 generates ignition reference and ignition timing signals to control spark ignition. The ignition reference signal pulse directs the capacitive coil driver to start the firing sequence at the beginning. The ignition timing signal provides a separate pulse for each cylinder to control the exact timing of each cylinder's spark.

Refer to Troubleshooting Fault Code t05-458

Last Modified: 30-Jun-2010


Ignition Timing Signal Circuit - Shorted Low

FAULT CODE 459

Ignition Timing Signal Circuit - Shorted Low

Printable Version Printable Version

Overview

Ignition Timing Signal Circuit - Shorted Low

CODE | REASON | EFFECT
Fault Code: 459 PID: S067 SPN: 726 FMI: 4 LAMP: Shutdown SRT: | Ignition Timing Signal Circuit - Shorted Low. The ignition timing signal pin of the CM558 incorrectly remains at a low voltage level when it is commanded high. | The engine will shut down.
Ignition Timing and Reference Signal Circuit - Multiple Turbochargers
Ignition Timing and Reference Signal Circuit - Single Turbocharger

Circuit Description

The ignition timing signal is a 5-VDC signal. The CM558 drives the ignition timing signal to 0-VDC to create an ignition timing pulse for each cylinder.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

The CM558 generates ignition reference and ignition timing signals to control spark ignition. The ignition reference signal pulse directs the capacitive coil driver to start the firing sequence at the beginning. The ignition timing signal provides a separate pulse for each cylinder to control the exact timing of each cylinder's spark.

Refer to Troubleshooting Fault Code t05-459

Last Modified: 30-Jun-2010


Ignition Reference Signal Circuit - Shorted High

FAULT CODE 461

Ignition Reference Signal Circuit - Shorted High

Printable Version Printable Version

Overview

Ignition Reference Signal Circuit - Shorted High

CODE | REASON | EFFECT
Fault Code: 461 PID: S066 SPN: 725 FMI: 3 LAMP: Shutdown SRT: | Ignition Reference Signal Circuit - Shorted High. The ignition reference signal pin of the CM558 incorrectly remains at a high voltage level when it is commanded low. | Engine will shut down.
Ignition timing and Reference Signal Circuit - Multiple Turbochargers
Ignition timing and Reference Signal Circuit - Single Turbocharger

Circuit Description

The ignition reference signal is a 5-VDC signal. The CM558 drives the ignition reference signal to 0-VDC to create pulse to initiate the firing order.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

The CM558 generates ignition reference and ignition timing signals to control spark ignition. The ignition reference signal pulse directs the capacitive coil driver to start the firing sequence at the beginning. The ignition timing signal provides a separate pulse for each cylinder to control the exact timing of each cylinder's spark.

Refer to Troubleshooting Fault Code t05-461

Last Modified: 30-Jun-2010


Ignition Reference Signal Circuit - Shorted Low

FAULT CODE 462

Ignition Reference Signal Circuit - Shorted Low

Printable Version Printable Version

Overview

Ignition Reference Signal Circuit - Shorted Low

CODE | REASON | EFFECT
Fault Code: 462 PID: S066 SPN: 725 FMI: 4 LAMP: Shutdown SRT: | Ignition Reference Signal Circuit - Shorted Low. The ignition reference signal pin of the CM558 incorrectly remains at a low voltage level when it is commanded high. | Engine will shut down.
Ignition timing and Reference Signal Circuit - Multiple Turbochargers
Ignition timing and Reference Signal Circuit - Single Turbocharger

Circuit Description

The ignition reference signal is a 5-VDC signal. The CM558 drives the ignition reference signal to 0-VDC to create pulse to initiate the firing order.

Component Location

Refer to Procedure 100-002in Section E.

Shop Talk

The CM558 generates ignition reference and ignition timing signals to control spark ignition. The ignition reference signal pulse directs the capacitive coil driver to start the firing sequence at the beginning. The ignition timing signal provides a separate pulse for each cylinder to control the exact timing of each cylinder's spark.

Refer to Troubleshooting Fault Code t05-462

Last Modified: 30-Jun-2010


Engine Controlled Shutdown Request - Special Instructions

FAULT CODE 4687

Engine Controlled Shutdown Request - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4687 PID: SPN: 3606 FMI: 14/14 LAMP: Red SRT: | Engine Controlled Shutdown Request - Special Instructions. The generator set controller is not responding to a shutdown request. | Engine will be shutdown.
Engine Control Module (ECM)

Circuit Description

Some applications use the original equipment manufacturer (OEM) switch input to drive an engine protection event in the form of an emergency engine shutoff switch, engine compartment cover location switch, or similar.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM has diagnosed the generator set controller is not responding to a shutdown request.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the malfunction indicator lamp (MIL) immediately when the diagnostic runs and fails.

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine. Let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs nad passes.

Shop Talk

Other, more precise, fault codes exist (example: electrical circuit fault codes).

Refer to Troubleshooting Fault Code 4687.

Last Modified: 27-Sep-2016


Isolated Battery Supply Circuit - Low

FAULT CODE 477

Isolated Battery Supply Circuit - Low

Printable Version Printable Version

Overview

Isolated Battery Supply Circuit - Low

CODE | REASON | EFFECT
Fault Code: 477 PID: P044 SPN: 1376 FMI: 1/18 LAMP: Warning SRT: | Isolated Battery Supply Circuit - Low. Low voltage has been detected on the Isolated Battery Supply. | ECM voltage supply approaching a level at which unpredictable operation will occur.
Isolated Battery Supply Circuit - Multiple Turbochargers
Isolated Battery Supply Circuit - Single Turbocharger

Circuit Description

The +24-VDC Isolated Battery Circuit provides operating power to the capacitive coil drivers. This supply is provided by a 20 Ampere Direct Current (DC) power supply, which is located at the customers discretion.

Component Location

The location of the Direct Current (DC) power supply in the generator room will vary with the OEM.

Shop Talk

This fault is usually caused by loose or corroded connections, a blown fuse, or a tripped circuit breaker.

Refer to Troubleshooting Fault Code t05-477

Last Modified: 30-Jun-2010


Isolated Battery Supply Circuit - High

FAULT CODE 478

Isolated Battery Supply Circuit - High

Printable Version Printable Version

Overview

Isolated Battery Supply Circuit - High

CODE | REASON | EFFECT
Fault Code: 478 PID: P044 SPN: 1376 FMI: 0/16 LAMP: Warning SRT: | Isolated Battery Supply Circuit - High. High voltage has been detected on the Isolated Battery Supply. | ECM damage will occur.
Isolated Battery Supply Circuit - Multiple Turbochargers
Isolated Battery Supply Circuit - Single Turbocharger

Circuit Description

The +24-VDC Isolated Battery Circuit provides operating power to the capacitive coil drivers. This supply is provided by a 20 Ampere Direct Current (DC) power supply, which is located at the customers discretion.

Component Location

The location of the Direct Current (DC) power supply in the generator room will vary with the OEM.

Shop Talk

Improper wiring of the battery circuit is the most likely cause of this fault.

Refer to Troubleshooting Fault Code t05-478

Last Modified: 30-Jun-2010


Intake Manifold Temperature High - Warning

FAULT CODE 488

Intake Manifold Temperature High - Warning

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 488 PID: 105 SPN: 105 FMI: 16 LAMP: Warning SRT: | Intake Manifold Temperature High - Warning. The engine intake manifold temperature has exceeded the warning threshold. | Possible reduced engine performance.

Circuit Description

The intake manifold 1 temperature sensor is a variable resistor sensor and is used to measure the temperature of the air/fuel mixture entering the intake manifold of the engine. The intake manifold temperature value is used by the engine control modules (ECMs) for the engine protection system, timing and engine emissions control.

The left-bank CM558 ECM supplies 5-VDC to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air/fuel mixture is cold, the sensor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground, therefore, the ECM senses a high signal voltage or a low temperature. When the intake air/fuel mixture is warm, the sensor resistance is low. The ECM signal voltage pulls down a large amount, therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 temperature sensor is located on the left-bank side, flywheel end of the engine, and is mounted on the intake manifold.

The CM558 is located on the engine's left-bank intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the ECM keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects that the intake manifold temperature has reached the threshold temperature of 123.8°C (255°F) for 3 seconds.

Action Taken When the Fault Code is Active

  • The CM558 illuminates the amber ALARM WARNING lamp on the Generator Control Panel immediately when the diagnostic runs and fails. Fault Code 488 will also be shown as ACTIVE by INSITE™ electronic service tool and on the OEM control panel display.
  • The engine will continue to run, but engine performance may be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair. start the engine and let it run at rated speed for 1 minute at no load.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostics runs and passes.
  • The CM558 will turn off the amber ALARM WARNING lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

High intake manifold temperatures affect combustion of the air/fuel in the cylinders and engine knock can occur as a result.

Possible cause of this fault code include:

  • Restricted air flow through the charge-air cooler
  • Temperature of coolant (high temperature and low temperature cooling circuits) passing through the charge-air cooler higher than normal
  • Coolant flow (high temperature and low temperature cooling circuits) through the charge-air cooler restricted
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code t05-488.

Last Modified: 01-Nov-2013


Throttle Plate Position Circuit High Error

FAULT CODE 512

Throttle Plate Position Circuit High Error

Printable Version Printable Version

Overview

Throttle Plate Position Circuit High Error

CODE | REASON | EFFECT
Fault Code: 512 PID: 51 SPN: 51 FMI: 3 LAMP: Warning SRT: | Throttle Plate Position Circuit High Error. High current detected on the throttle plate position signal pin of the main harness CM558 connector. | No effect on engine performance.
Throttle Plate Position Circuit - Multiple Turbochargers
Throttle Plate Position Circuit - Single Turbocharger

Circuit Description

The throttle plate position circuit consists of the Throttle Driver and the CM558. The Throttle Driver has internal circuitry that provides a 4 to 20 mA throttle position reference to the CM558.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

Always verify that the cable connections on the Throttle Driver are tight. There are three connections: the signal to the throttle actuator, the position command from the CM558 and power supply, and the feedback signal. The feedback signal is the smallest round connector.

Refer to Troubleshooting Fault Code t05-512

Last Modified: 30-Jun-2010


Throttle Plate Position Circuit Low Error

FAULT CODE 513

Throttle Plate Position Circuit Low Error

Printable Version Printable Version

Overview

Throttle Plate Position Circuit Low Error

CODE | REASON | EFFECT
Fault Code: 513 PID: 51 SPN: 51 FMI: 4 LAMP: Warning SRT: | Throttle Plate Position Circuit Low Error. Low current detected on the throttle plate position signal pin of the main harness CM558 connector. | No effect on engine performance.
Throttle Plate Position Circuit - Multiple Turbochargers
Throttle Plate Position Circuit - Single Turbocharger

Circuit Description

The throttle plate position circuit consists of the Throttle Driver and the CM558. The Throttle Driver has internal circuitry that provides a 4 to 20 mA throttle position reference to the CM558.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

Always verify that the cable connections on the Throttle Driver are tight. There are three connections: the signal to the throttle actuator, the position command from the CM558 and power supply, and the feedback signal. The feedback signal is the smallest round connector.

Refer to Troubleshooting Fault Code t05-513

Last Modified: 30-Jun-2010


Blowby Pressure - High

FAULT CODE 556

Blowby Pressure - High

Printable Version Printable Version

Overview

Blowby Pressure - High

CODE | REASON | EFFECT
Fault Code: 556 PID: 30 SPN: 30 FMI: 0 LAMP: None SRT: | Blowby Pressure - High. Engine blowby has exceeded the shutdown threshold for high engine blowby. | Engine shut down.
Blowby Pressure Sensor Circuit - Multiple Turbochargers
Blowby Pressure Sensor Circuit - Single Turbocharger

Circuit Description

The Blowby Pressure Sensor is used by the CM700 to monitor the engine crankcase pressure. The CM700 monitors the voltage on the signal pin and converts this to a pressure value. The blowby pressure value is used by the CM700 for the engine protection system.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

Confirm that the crankcase breathers and breather tubes are not obstructed.

Refer to Troubleshooting Fault Code t05-556

Last Modified: 30-Jun-2010


Engine Cylinder Number 1 Knock Sensor Circuit - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 561

Engine Cylinder Number 1 Knock Sensor Circuit - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 561 PID: SPN: 1352 FMI: 0 LAMP: Shutdown SRT: | Engine Cylinder Number 1 Knock Sensor Circuit - Data Valid But Above Normal Operating Range - Most Severe Level. Cylinder number 1 knock sensor has detected a knock above critcal level. | The engine will shutdown.
Knock Sensor Circuit (Multiple and Single Turbocharger Engines)

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as 'pre-ignition' and knock occurring after the normal spark event is known as 'detonation'. The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts within the power cylinder colliding. If the cause of knock is not identified and rectified, then engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage may occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a WARNING alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function correctly, it must be installed and tightened to the correct torque.

Knock related faults are activated when the knock sensor voltage output exceeds either a WARNING or HIGH critical threshold for a pre-set period of time.

When the knock HIGH critical threshold is reached and persists for a pre-set period of time, then the CM558 will initiate a critical shutdown of the engine.

All detonation-related shutdowns and persistent light knock events should be fully investigated in order to prevent engine damage.

The knock sensors can also detect mechanical noise, and mechanical related problems should not be dicounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and discounted:

  • Valve train/rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever 'elephant foot' o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust gasket leakage
  • Vibration resulting from loose engine parts/components.

Generator Sets using PowerCommand™ Control 3300 (PCC3300) Generator Control:

The PCC3300 generator control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from 'no-knock' condition (0 percent) to most severe level (100 percent +).

Refer to Troubleshooting Fault Code t05-561

Last Modified: 30-Jun-2010


Engine Cylinder Number 2 Knock Sensor Circuit - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 562

Engine Cylinder Number 2 Knock Sensor Circuit - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 562 PID: SPN: 1353 FMI: 0 LAMP: Shutdown SRT: | Engine Cylinder Number 2 Knock Sensor Circuit - Data Valid But Above Normal Operating Range - Most Severe Level. Cylinder number 2 knock sensor has detected a knock above critcal level. | The engine will shut down.
Knock Sensor Circuit (Multiple and Single Turbocharger Engines)

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as 'pre-ignition' and knock occurring after the normal spark event is known as 'detonation'. The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts within the power cylinder colliding. If the cause of knock is not identified and rectified, then engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage may occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a WARNING alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function correctly, it must be installed and tightened to the correct torque.

Knock related faults are activated when the knock sensor voltage output exceeds either a WARNING or HIGH critical threshold for a pre-set period of time.

When the knock HIGH critical threshold is reached and persists for a pre-set period of time, then the CM558 will initiate a critical shutdown of the engine.

All detonation-related shutdowns and persistent light knock events should be fully investigated in order to prevent engine damage.

The knock sensors can also detect mechanical noise, and mechanical related problems should not be dicounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and discounted:

  • Valve train/rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever 'elephant foot' o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust gasket leakage
  • Vibration resulting from loose engine parts/components.

Generator Sets using PowerCommand™ Control 3300 (PCC3300) Generator Control:

The PCC3300 generator control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from 'no-knock' condition (0 percent) to most severe level (100 percent +).

Refer to Troubleshooting Fault Code t05-562

Last Modified: 30-Jun-2010


Engine Cylinder Number 3 Knock Sensor Circuit - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 563

Engine Cylinder Number 3 Knock Sensor Circuit - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 563 PID: SPN: 1354 FMI: 0 LAMP: Shutdown SRT: | Engine Cylinder Number 3 Knock Sensor Circuit - Data Valid But Above Normal Operating Range - Most Severe Level. Cylinder number 3 knock sensor has detected a knock above critcal level. | The engine will shut down.
Knock Sensor Circuit (Multiple and Single Turbocharger Engines)

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as 'pre-ignition' and knock occurring after the normal spark event is known as 'detonation'. The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts within the power cylinder colliding. If the cause of knock is not identified and rectified, then engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage may occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a WARNING alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function correctly, it must be installed and tightened to the correct torque.

Knock-related faults are activated when the knock sensor voltage output exceeds either a WARNING or HIGH critical threshold for a pre-set period of time.

When the knock HIGH critical threshold is reached and persists for a pre-set period of time, then the CM558 will initiate a critical shutdown of the engine.

All detonation-related shutdowns and persistent light knock events should be fully investigated in order to prevent engine damage.

The knock sensors can also detect mechanical noise, and mechanical related problems should not be dicounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and discounted:

  • Valve train/rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever 'elephant foot' o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust gasket leakage
  • Vibration resulting from loose engine parts/components.

Generator Sets using PowerCommand™ Control 3300 (PCC3300) Generator Control:

The PCC3300 generator control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from 'no-knock' condition (0 percent) to most severe level (100 percent +).

Refer to Troubleshooting Fault Code t05-563

Last Modified: 30-Jun-2010


Engine Cylinder Number 4 Knock Sensor Circuit - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 564

Engine Cylinder Number 4 Knock Sensor Circuit - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 564 PID: SPN: 1355 FMI: 0 LAMP: Shutdown SRT: | Engine Cylinder Number 4 Knock Sensor Circuit - Data Valid But Above Normal Operating Range - Most Severe Level. Cylinder number 4 knock sensor has detected a knock above critcal level. | The engine will shut down.
Knock Sensor Circuit (Multiple and Single Turbocharger Engines)

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as 'pre-ignition' and knock occurring after the normal spark event is known as 'detonation'. The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts within the power cylinder colliding. If the cause of knock is not identified and rectified, then engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage may occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a WARNING alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function correctly, it must be installed and tightened to the correct torque.

Knock-related faults are activated when the knock sensor voltage output exceeds either a WARNING or HIGH critical threshold for a pre-set period of time.

When the knock HIGH critical threshold is reached and persists for a pre-set period of time, then the CM558 will initiate a critical shutdown of the engine.

All detonation-related shutdowns and persistent light knock events should be fully investigated in order to prevent engine damage.

The knock sensors can also detect mechanical noise, and mechanical related problems should not be dicounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and discounted:

  • Valve train/rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever 'elephant foot' o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust gasket leakage
  • Vibration resulting from loose engine parts/components.

Generator Sets using PowerCommand™ Control 3300 (PCC3300) Generator Control:

The PCC3300 generator control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from 'no-knock' condition (0 percent) to most severe level (100 percent +).

Refer to Troubleshooting Fault Code t05-564

Last Modified: 30-Jun-2010


Engine Cylinder Number 5 Knock Sensor Circuit - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 565

Engine Cylinder Number 5 Knock Sensor Circuit - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 565 PID: SPN: 1356 FMI: 0 LAMP: Shutdown SRT: | Engine Cylinder Number 5 Knock Sensor Circuit - Data Valid But Above Normal Operating Range - Most Severe Level. Cylinder number 5 knock sensor has detected a knock above critcal level. | The engine will shut down.
Knock Sensor Circuit (Multiple and Single Turbocharger Engines)

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as 'pre-ignition' and knock occurring after the normal spark event is known as 'detonation'. The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts within the power cylinder colliding. If the cause of knock is not identified and rectified, then engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage may occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a WARNING alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function correctly, it must be installed and tightened to the correct torque.

Knock-related faults are activated when the knock sensor voltage output exceeds either a WARNING or HIGH critical threshold for a pre-set period of time.

When the knock HIGH critical threshold is reached and persists for a pre-set period of time, then the CM558 will initiate a critical shutdown of the engine.

All detonation-related shutdowns and persistent light knock events should be fully investigated in order to prevent engine damage.

The knock sensors can also detect mechanical noise, and mechanical related problems should not be dicounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and discounted:

  • Valve train/rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever 'elephant foot' o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust gasket leakage
  • Vibration resulting from loose engine parts/components.

Generator Sets using PowerCommand™ Control 3300 (PCC3300) Generator Control:

The PCC3300 generator control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from 'no-knock' condition (0 percent) to most severe level (100 percent +).

Refer to Troubleshooting Fault Code t05-565

Last Modified: 30-Jun-2010


Engine Cylinder Number 6 Knock Sensor Circuit - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 566

Engine Cylinder Number 6 Knock Sensor Circuit - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 566 PID: SPN: 1357 FMI: 0 LAMP: Shutdown SRT: | Engine Cylinder Number 6 Knock Sensor Circuit - Data Valid But Above Normal Operating Range - Most Severe Level. Cylinder numberr 6 knock sensor has detected a knock above critcal level. | The engine will shut down.
Knock Sensor Circuit (Multiple and Single Turbocharger Engines)

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as 'pre-ignition' and knock occurring after the normal spark event is known as 'detonation'. The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts within the power cylinder colliding. If the cause of knock is not identified and rectified, then engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage may occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a WARNING alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function correctly, it must be installed and tightened to the correct torque.

Knock-related faults are activated when the knock sensor voltage output exceeds either a WARNING or HIGH critical threshold for a pre-set period of time.

When the knock HIGH critical threshold is reached and persists for a pre-set period of time, then the CM558 will initiate a critical shutdown of the engine.

All detonation-related shutdowns and persistent light knock events should be fully investigated in order to prevent engine damage.

The knock sensors can also detect mechanical noise, and mechanical related problems should not be dicounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and discounted:

  • Valve train/rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever 'elephant foot' o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust gasket leakage
  • Vibration resulting from loose engine parts/components.

Generator Sets using PowerCommand™ Control 3300 (PCC3300) Generator Control:

The PCC3300 generator control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from 'no-knock' condition (0 percent) to most severe level (100 percent +).

Refer to Troubleshooting Fault Code t05-566

Last Modified: 30-Jun-2010


Engine Cylinder Number 7 Knock Sensor Circuit - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 567

Engine Cylinder Number 7 Knock Sensor Circuit - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 567 PID: SPN: 1358 FMI: 0 LAMP: Shutdown SRT: | Engine Cylinder Number 7 Knock Sensor Circuit - Data Valid But Above Normal Operating Range - Most Severe Level. Cylinder number 7 knock sensor has detected a knock above critcal level. | The engine will shut down.
Knock Sensor Circuit (Multiple and Single Turbocharger Engines)

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as 'pre-ignition' and knock occurring after the normal spark event is known as 'detonation'. The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts within the power cylinder colliding. If the cause of knock is not identified and rectified, then engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage may occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a WARNING alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function correctly, it must be installed and tightened to the correct torque.

Knock-related faults are activated when the knock sensor voltage output exceeds either a WARNING or HIGH critical threshold for a pre-set period of time.

When the knock HIGH critical threshold is reached and persists for a pre-set period of time, then the CM558 will initiate a critical shutdown of the engine.

All detonation-related shutdowns and persistent light knock events should be fully investigated in order to prevent engine damage.

The knock sensors can also detect mechanical noise, and mechanical related problems should not be dicounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and discounted:

  • Valve train/rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever 'elephant foot' o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust gasket leakage
  • Vibration resulting from loose engine parts/components.

Generator Sets using PowerCommand™ Control 3300 (PCC3300) Generator Control:

The PCC3300 generator control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from 'no-knock' condition (0 percent) to most severe level (100 percent +).

Refer to Troubleshooting Fault Code t05-567

Last Modified: 30-Jun-2010


Engine Cylinder Number 8 Knock Sensor Circuit - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 568

Engine Cylinder Number 8 Knock Sensor Circuit - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 568 PID: SPN: 1359 FMI: 0 LAMP: Shutdown SRT: | Engine Cylinder Number 8 Knock Sensor Circuit - Data Valid But Above Normal Operating Range - Most Severe Level. Cylinder number 8 knock sensor has detected a knock above critcal level. | The engine will shut down.
Knock Sensor Circuit (Multiple and Single Turbocharger Engines)

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as 'pre-ignition' and knock occurring after the normal spark event is known as 'detonation'. The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts within the power cylinder colliding. If the cause of knock is not identified and rectified, then engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage may occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a WARNING alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function correctly, it must be installed and tightened to the correct torque.

Knock-related faults are activated when the knock sensor voltage output exceeds either a WARNING or HIGH critical threshold for a pre-set period of time.

When the knock HIGH critical threshold is reached and persists for a pre-set period of time, then the CM558 will initiate a critical shutdown of the engine.

All detonation-related shutdowns and persistent light knock events should be fully investigated in order to prevent engine damage.

The knock sensors can also detect mechanical noise, and mechanical related problems should not be dicounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and discounted:

  • Valve train/rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever 'elephant foot' o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust gasket leakage
  • Vibration resulting from loose engine parts/components.

Generator Sets using PowerCommand™ Control 3300 (PCC3300) Generator Control:

The PCC3300 generator control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from 'no-knock' condition (0 percent) to most severe level (100 percent +).

Refer to Troubleshooting Fault Code t05-568

Last Modified: 30-Jun-2010


Engine Cylinder Number 9 Knock Sensor Circuit - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 569

Engine Cylinder Number 9 Knock Sensor Circuit - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 569 PID: SPN: 1360 FMI: 0 LAMP: Shutdown SRT: | Engine Cylinder Number 9 Knock Sensor Circuit - Data Valid But Above Normal Operating Range - Most Severe Level. Cylinder number 9 knock sensor has detected a knock above critcal level. | Engine will shutdown.
Knock Sensor Circuit (Multiple and Single Turbocharger Engines)

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

Knock can be described as uncontrolled combustion within the power cylinder, due to the fuel being ignited by another source other than the spark plug. Knock can occur either before or after the normal spark event. Knock before the normal spark event is referred to as 'pre-ignition' and knock occurring after the normal spark event is known as 'detonation'. The causes may be different, but the symptoms and effects are the same. The characteristic noise associated with knock is caused as a result of multiple flame fronts within the power cylinder colliding. If the cause of knock is not identified and rectified, then engine damage may occur.

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage may occur. Similarly, the engine should not be run with knock sensors disconnected; this will not initiate a WARNING alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

For the knock sensor to function correctly, it must be installed and tightened to the correct torqure.

Knock related faults are activated when the knock sensor voltage output exceeds either a WARNING or HIGH critical threshold for a pre-set period of time.

When the knock HIGH critical threshold is reached and persists for a pre-set period of time, then the CM558 will initiate a critical shutdown of the engine.

All detonation-related shutdowns and persistent light knock events should be fully investigated in order to prevent engine damage.

The knock sensors can also detect mechanical noise, and mechanical related problems should not be dicounted as a cause of detonation shutdowns or high knock counts. The following mechanical checks should be considered when all other causes of detonation have been investigated and discounted:

  • Valve train/rocker gear wear
  • Excessive valve recession
  • Valve rotator cracked/broken
  • Rocker lever 'elephant foot' o-ring displaced resulting in mechanical vibration
  • Connecting rod bushing/bearing excessive wear
  • Piston cooling nozzle bent or broken
  • Piston ring damage
  • Cylinder head gasket leakage
  • Exhaust gasket leakage
  • Vibration resulting from loose engine parts/components.

Generator Sets using PowerCommand™ Control 3300 (PCC3300) Generator Control:

The PCC3300 generator control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 112.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from 'no-knock' condition (0 percent) to most severe level (100 percent +).

Refer to Troubleshooting Fault Code t05-569

Last Modified: 30-Jun-2010


Engine Cylinder 1 (A1) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 571

Engine Cylinder 1 (A1) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 571 SPN: 1352 FMI: 4 LAMP: Warning SRT: | Engine Cylinder 1 (A1) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage has been detected in the engine cylinder number 1 knock sensor circuit. | No effect on engine performance.
Knock Sensor Circuit (Multiple and Single Turbocharger Engines

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for component location. Refer to Procedure Refer Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur.

In order to provide some system diagnostics, the individual knock sensors are periodically switched ON outside of their normal operating window. This diagnostic window is timed to coincide with an exhaust valve closing. The knock sensor will detect the noise of the exhaust valve closing and will generate a voltage output. If the CM558 does not register a voltage above a pre-set level, then this fault code will be activated.

NOTE: This protection feature is not active on all engine models and/or all versions of electronic control module (ECM) software. Therefore, the engine should not be run with knock sensors disconnected; this may not initiate this WARNING alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

A faulty or incorrectly fitted knock sensor or knock sensor wiring harness faults, such as open circuit or high resistances, are the most likely cause of this fault.

Generator Sets using PowerCommand™ Control 3300 (PCC3300) Generator Control:

The PCC3300 generator control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 122.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from 'no-knock' condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code t05-571

Last Modified: 30-Jun-2010


Engine Cylinder 2 (B1) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 572

Engine Cylinder 2 (B1) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 572 SPN: 1353 FMI: 4 LAMP: Warning SRT: | Engine Cylinder 2 (B1) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage has been detected in the engine cylinder number 2 knock sensor circuit. | No effect on engine performance.
Knock Sensor Circuit (Multiple and Single Turbocharger Engines)

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for component location. Refer to Procedure Refer Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur.

In order to provide some system diagnostics, the individual knock sensors are periodically switched ON outside of their normal operating window. This diagnostic window is timed to coincide with an exhaust valve closing. The knock sensor will detect the noise of the exhaust valve closing and will generate a volage output. If the CM558 does not register a voltage above a pre-set level, then this fault code will be activated.

NOTE: This protection feature is not active on all engine models and/or all versions of ECM software. Therefore, the engine should not be run with knock sensors disconnected; this may not initiate this WARNING alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

A faulty or incorrectly fitted knock sensor or knock sensor wiring harness faults, such as open circuit or high resistances, are the most likely cause of this fault.

Generator Sets using PowerCommand™ Control 3300 (PCC3300) Generator Control:

The PCC3300 generator control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 122.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from 'no-knock' condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code t05-572

Last Modified: 30-Jun-2010


Engine Cylinder 3 (A2) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 573

Engine Cylinder 3 (A2) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 573 SPN: 1354 FMI: 4 LAMP: Warning SRT: | Engine Cylinder 3 (A2) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage has been detected in the engine cylinder number 3 knock sensor circuit. | No effect on engine performance.
Knock Sensor Circuit (Multiple and Single Turbocharger Engines)

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for component location. Refer to Procedure Refer Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur.

In order to provide some system diagnostics, the individual knock sensors are periodically switched ON outside of their normal operating window. This diagnostic window is timed to coincide with an exhaust valve closing. The knock sensor will detect the noise of the exhaust valve closing and will generate a volage output. If the CM558 does not register a voltage above a pre-set level, then this fault code will be activated.

NOTE: This protection feature is not active on all engine models and/or all versions of ECM software. Therefore, the engine should not be run with knock sensors disconnected; this may not initiate this WARNING alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

A faulty or incorrectly fitted knock sensor or knock sensor wiring harness faults, such as open circuit or high resistances, are the most likely cause of this fault.

Generator Sets using PowerCommand™ Control 3300 (PCC3300) Generator Control:

The PCC3300 generator control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized unit used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 122.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from 'no-knock' condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code t05-573

Last Modified: 30-Jun-2010


Engine Cylinder 4 (B2) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 574

Engine Cylinder 4 (B2) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 574 SPN: 1355 FMI: 4 LAMP: Warning SRT: | Engine Cylinder 4 (B2) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage has been detected in the engine cylinder number 4 knock sensor circuit. | No effect on engine performance.
Knock Sensor Circuit (Multiple and Single Turbocharger Engines)

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for component location. Refer to Procedure Refer Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur.

In order to provide some system diagnostics, the individual knock sensors are periodically switched ON outside of their normal operating window. This diagnostic window is timed to coincide with an exhaust valve closing. The knock sensor will detect the noise of the exhaust valve closing and will generate a volage output. If the CM558 does not register a voltage above a pre-set level, then this fault code will be activated.

NOTE: This protection feature is not active on all engine models and/or all versions of ECM software. Therefore, the engine should not be run with knock sensors disconnected; this may not initiate this WARNING alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

A faulty or incorrectly fitted knock sensor or knock sensor wiring harness faults, such as open circuit or high resistances are the most likely cause of this fault.

Generator Sets using PowerCommand™ Control 3300 (PCC3300) Generator Control:

The PCC3300 generator control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 122.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from 'no-knock' condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code t05-574

Last Modified: 30-Jun-2010


Engine Cylinder 5 (A3) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 575

Engine Cylinder 5 (A3) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 575 SPN: 1356 FMI: 4 LAMP: Warning SRT: | Engine Cylinder 5 (A3) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage has been detected in the engine cylinder number 5 knock sensor circuit. | No effect on engine performance.
Knock Sensor Circuit (Multiple and Single Turbocharger Engines)

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for component location. Refer to Procedure Refer Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur.

In order to provide some system diagnostics, the individual knock sensors are periodically switched ON outside of their normal operating window. This diagnostic window is timed to coincide with an exhaust valve closing. The knock sensor will detect the noise of the exhaust valve closing and will generate a volage output. If the CM558 does not register a voltage above a pre-set level, then this fault code will be activated.

NOTE: This protection feature is not active on all engine models and/or all versions of ECM software. Therefore, the engine should not be RUN with knock sensors disconnected; this may not initiate this WARNING alarm - the engine will continue to RUN and there will be no knock protection for cylinders that have had their knock sensors disconnected.

A faulty or incorrectly fitted knock sensor or knock sensor wiring harness faults, such as open circuit or high resistances are the most likely cause of this fault.

Generator Sets using PowerCommand™ Control 3300 (PCC3300) Generator Control:

The PCC3300 generator control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 122.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from 'no-knock' condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code t05-575

Last Modified: 30-Jun-2010


Engine Cylinder 6 (B3) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 576

Engine Cylinder 6 (B3) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 576 SPN: 1357 FMI: 4 LAMP: Warning SRT: | Engine Cylinder 6 (B3) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage has been detected in the engine cylinder number 6 knock sensor circuit. | No effect on engine performance.
Knock Sensor Circuit (Multiple and Single Turbocharger Engines)

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for component location. Refer to Procedure Refer Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur.

In order to provide some system diagnostics, the individual knock sensors are periodically switched ON outside of their normal operating window. This diagnostic window is timed to coincide with an exhaust valve closing. The knock sensor will detect the noise of the exhaust valve closing and will generate a volage output. If the CM558 does not register a voltage above a pre-set level, then this fault code will be activated.

NOTE: This protection feature is not active on all engine models and/or all versions of ECM software. Therefore, the engine should not be run with knock sensors disconnected; this may not initiate this WARNING alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

A faulty or incorrectly fitted knock sensor or knock sensor wiring harness faults, such as open circuit or high resistances are the most likely cause of this fault.

Generator Sets using PowerCommand™ Control 3300 (PCC3300) Generator Control:

The PCC3300 generator control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 122.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from 'no-knock' condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code t05-576

Last Modified: 30-Jun-2010


Engine Cylinder 7 (A4) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 577

Engine Cylinder 7 (A4) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 577 SPN: 1358 FMI: 4 LAMP: Warning SRT: | Engine Cylinder 7 (A4) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage has been detected in the engine cylinder number 7 knock sensor circuit. | No effect on engine performance.
Knock Sensor Circuit (Multiple and Single Turbocharger Engines)

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for component location. Refer to Procedure Refer Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur.

In order to provide some system diagnostics, the individual knock sensors are periodically switched ON outside of their normal operating window. This diagnostic window is timed to coincide with an exhaust valve closing. The knock sensor will detect the noise of the exhaust valve closing and will generate a volage output. If the CM558 does not register a voltage above a pre-set level, then this fault code will be activated.

NOTE: This protection feature is not active on all engine models and/or all versions of ECM software. Therefore, the engine should not be run with knock sensors disconnected; this may not initiate this WARNING alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

A faulty or incorrectly fitted knock sensor or knock sensor wiring harness faults, such as open circuit or high resistances are the most likely cause of this fault.

Generator Sets using PowerCommand™ Control 3300 (PCC3300) Generator Control:

The PCC3300 generator control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 122.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from 'no-knock' condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code t05-577

Last Modified: 30-Jun-2010


Engine Cylinder 8 (B4) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 578

Engine Cylinder 8 (B4) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 578 SPN: 1359 FMI: 4 LAMP: Warning SRT: | Engine Cylinder 8 (B4) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage has been detected in the engine cylinder number 8 knock sensor circuit. | No effect on engine performance.
Knock Sensor Circuit (Multiple and Single Turbocharger Engines)

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for component location. Refer to Procedure Refer Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur.

In order to provide some system diagnostics, the individual knock sensors are periodically switched ON outside of their normal operating window. This diagnostic window is timed to coincide with an exhaust valve closing. The knock sensor will detect the noise of the exhaust valve closing and will generate a volage output. If the CM558 does not register a voltage above a pre-set level, then this fault code will be activated.

NOTE: This protection feature is not active on all engine models and/or all versions of ECM software. Therefore, the engine should not be run with knock sensors disconnected; this may not initiate this WARNING alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

A faulty or incorrectly fitted knock sensor or knock sensor wiring harness faults, such as open circuit or high resistances are the most likely cause of this fault.

Generator Sets using PowerCommand™ Control 3300 (PCC3300) Generator Control:

The PCC3300 generator control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 122.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from 'no-knock' condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code t05-578

Last Modified: 30-Jun-2010


Engine Cylinder 9 (A5) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 579

Engine Cylinder 9 (A5) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 579 SPN: 1360 FMI: 4 LAMP: Warning SRT: | Engine Cylinder 9 (A5) Knock Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage has been detected in the engine cylinder number 9 knock sensor circuit. | No effect on engine performance.
Knock Sensor Circuit (Multiple and Single Turbocharger Engines)

Circuit Description

The knock sensors are used to monitor each cylinder for excessive knock. The knock sensor is a piezoelectric type with internal electrical resistance decreasing as knock intensity increases, resulting in less voltage drop across the sensor and higher voltage returned to the CM558.

Component Location

Use the following procedure for component location. Refer to Procedure Refer Procedure 100-002 in Section E.

Shop Talk

Each cylinder is fitted with a knock sensor. A CM558 module on each bank monitors all the knock sensors for that bank. Each knock sensor monitors its cylinder for a fixed window within the 4-stroke cycle. For this reason, it is important that knock sensor harness connectors are not swapped between cylinder knock sensors, as engine knock protection will be compromised and engine damage can occur.

In order to provide some system diagnostics, the individual knock sensors are periodically switched ON outside of their normal operating window. This diagnostic window is timed to coincide with an exhaust valve closing. The knock sensor will detect the noise of the exhaust valve closing and will generate a volage output. If the CM558 does not register a voltage above a pre-set level, then this fault code will be activated.

NOTE: This protection feature is not active on all engine models and/or all versions of ECM software. Therefore, the engine should not be run with knock sensors disconnected; this may not initiate this WARNING alarm - the engine will continue to run and there will be no knock protection for cylinders that have had their knock sensors disconnected.

A faulty or incorrectly fitted knock sensor or knock sensor wiring harness faults, such as open circuit or high resistances are the most likely cause of this fault.

Generator Sets using PowerCommand™ Control 3300 (PCC3300) Generator Control:

The PCC3300 generator control receives and displays knock levels as a percent, rather than as a voltage, as this is the standardized units used by SAE J1939 messaging. The software is configured so that a knock sensor output of 0.5-VDC = 0 percent and 5-VDC = 122.5 percent and is linear between these voltages. The percentage value is a relative measure of knock magnitude for each cylinder, from 'no-knock' condition (0 percent) to Most Severe Level (100 percent +).

Refer to Troubleshooting Fault Code t05-579

Last Modified: 30-Jun-2010


Starter Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 584

Starter Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 584 PID: S39 SPN: 677 FMI: 3 LAMP: Amber SRT: | Starter Relay Circuit - Voltage Above Normal or Shorted to High Source. | The engine will not start.
QSK60 G Multiple Turbochargers Generator Sets with Generator Control Panel 1 using PowerCommand® Supervisor 3100 Controller
QSK60 G Single and Multiple Turbochargers Generator Sets with Generator Control Panel 2 using PowerCommand® Supervisor 3100 Controller
QSK60 G Single and Multiple Turbochargers using PowerCommand® Control 3300 Controller

Circuit Description

The starter relay is controlled by the CM700 through the starter relay signal circuit. The starter motor circuit is made up of two wiring harnesses; the on-engine wiring harness and the generator set wiring harness. The location of the starter relay is dependent on the generator set control option.

Component Location

For QSK60 G Multiple Turbochargers with Generator Control Panel 1 using PowerCommand® Supervisor 3100 Controllers the starter lockout relay is located within the genset terminal/DC panel.

For QSK60 G Single and Multiple Turbochargers with Generator Control Panel 2 using PowerCommand® Supervisor 3100 Controllers the starter lockout relay is located within the generator interface box (GIB).

For QSK60 G Single and Multiple Turbochargers using PowerCommand® Control 3300 Controllers the starter lockout relay is located within the generator interface box (GIB).

Shop Talk

The CM700 monitors the voltage level on this circuit. If it detects a voltage when the signal is commanded OFF, it records this fault code.

Possible causes of this fault code include:

  • Open circuit in the starter lockout relay, its harness, or connectors
  • Short circuit to a voltage source, either in the relay or its harness.
Refer to Troubleshooting Fault Code t05-584.

Last Modified: 06-Jul-2011


Starter Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 585

Starter Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 585 PID: S39 SPN: 677 FMI: 4 LAMP: Amber SRT: | Starter Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source. | Engine cranking performance (rpm) will be reduced and the engine may not start.
QSK60 G Multiple Turbochargers Generator Sets with Generator Control Panel 1 Using PowerCommand® Supervisor 3100 Controller - Starter Relay Circuit
QSK60 G Single and Multiple Turbochargers Generator Sets with Generator Control Panel 2 Using PowerCommand® Supervisor 3100 Controller - Starter Relay Circuit
QSK60 G Single and Multiple Turbochargers Using PowerCommand® 3300 Controller - Starter Relay Circuit

Circuit Description

The starter relay is controlled by the CM700 through the starter relay signal circuit. The starter motor circuit is made up of two wiring harnesses: the on-engine wiring harness and the generator set wiring harness. The location of the starter relay is dependent on the generator set control option.

Component Location

For QSK60 G Multiple Turbochargers with Generator Control Panel 1 Using PowerCommand® Supervisor 3100 Controllers the starter lockout relay is located within the Genset Terminal/DC panel.

For QSK60 G Single and Multiple Turbochargers with Generator Control Panel 2 Using PowerCommand® Supervisor 3100 Controllers the starter lockout relay is located within the generator interface box (GIB).

For QSK60 G Single and Multiple Turbochargers using PowerCommand® Control 3300 Controllers the starter lockout relay is located within the generator interfae box (GIB).

Shop Talk

The CM700 monitors the voltage level on this circuit. If it detects a low voltage when the signal is commanded ON, it records this fault code.

Possible causes of this fault code include:

  • Short circuit to ground in the starter lockout relay, its harness, or connectors.
Refer to Troubleshooting Fault Code t05-585.

Last Modified: 06-Jul-2011


Turbocharger Number 1 Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 595

Turbocharger Number 1 Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 595 PID: P103 SPN: 103 FMI: 0/16 LAMP: Warning SRT: | Turbocharger Number 1 Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level. High turbocharger speed has been detected. | No effect on engine performance.
Turbocharger 1 Speed Sensor Circuit - Single Turbocharger

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger is a reference such as a machined flat area on the center of the turbine shaft. As the reference passes the speed sensor, a time-varying flux passes through the iron core that induces a proportional voltage in the coil. This signal is supplied to the CM700 module for speed measurement.

Turbocharger speed is not monitored until the intake manifold pressure reaches [20 psia] or above.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Fault Code 595 can become active any time the keyswitch is ON and the CM700 detects turbocharger speed greater than a calibratible WARNING threshold.

Possible causes of this fault code include:

  • Compressor inlet temperature high
  • Low ambient pressure (possibly caused by engine room ventilation fan not operating when the generator set is in operation, etc.)
  • Generator set overload
  • Generator set being operated at high altitudes
  • Gross speed governing instability (caused by engine misfire, lean air/fuel ratio, blocked air filters, etc.)
  • Retarded ignition timing caused by either repeated engine knock events ormis-set engine mechanical timing following a rebuild, etc.

The above systems should be checked and eliminated as the cause of the fault code being active. Associated fault codes may also be activated.

Fault Code 595 can also become active if a malfunction exists in any of the following system components:

  • Turbocharger speed sensor
  • Engine harness
  • ECM CM700 power supply or grounds.

This fault becomes inactive any time the CM700 detects a valid turbocharger speed.

If the fault occurs intermittently:

  • Check for causes of intermittent open circuits or short circuits in the turbocharger speed sensor circuit (including the speed sensor connector)
  • Check that the generator set grounds are in good condition
  • Make sure that the CM700 module power supply and grounds are in good condition
Refer to Troubleshooting Fault Code t05-595.

Last Modified: 06-Jul-2011


Exhaust Temperature Cylinder Left 1 High - Shutdown

FAULT CODE 641 - Multiple Turbochargers

Exhaust Temperature Cylinder Left 1 High - Shutdown

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Left 1 High - Shutdown

CODE | REASON | EFFECT
Fault Code: 641 PID: SPN: 1137 FMI: 0 LAMP: Shutdown SRT: | Exhaust Temperature Cylinder Left 1 High - Shutdown. The exhaust temperature for cylinder number left 1 has exceeded the high critical threshold. | The engine will shut down.
Exhaust Temperature Cylinder Left 1

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CENSE™ module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-641-mt.

Last Modified: 19-Jan-2015


Exhaust Temperature Cylinder Left 1 High - Shutdown

FAULT CODE 641 - Single Turbocharger

Exhaust Temperature Cylinder Left 1 High - Shutdown

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Left 1 High - Shutdown

CODE | REASON | EFFECT
Fault Code: 641 PID: SPN: 1137 FMI: 0 LAMP: Shutdown SRT: | Exhaust Temperature Cylinder Left 1 High - Shutdown. The exhaust temperature for cylinder number left 1 has exceeded the high critical threshold. | The engine will shutdown.
Exhaust Temperature Cylinder Left 1

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CM850 module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CM850 module malfunction will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-641-st.

Last Modified: 19-Jan-2015


Fault Code Path Selection

FAULT CODE 641
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc641-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc641-st

Last Modified: 05-Oct-2007


Exhaust Temperature Cylinder Left 2 High - Shutdown

FAULT CODE 642 - Multiple Turbochargers

Exhaust Temperature Cylinder Left 2 High - Shutdown

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Left 2 High - Shutdown

CODE | REASON | EFFECT
Fault Code: 642 PID: SPN: 1138 FMI: 0 LAMP: Shutdown SRT: | Exhaust Temperature Cylinder Left 2 High - Shutdown. The exhaust temperature for cylinder number left 2 has exceeded the high critical threshold. | The engine will shut down.
Exhaust Temperature Cylinder Left 2

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CENSE™ module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-642-mt

Last Modified: 31-Jul-2015


Exhaust Temperature Cylinder Left 2 High - Shutdown

FAULT CODE 642 - Single Turbocharger

Exhaust Temperature Cylinder Left 2 High - Shutdown

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Left 2 High - Shutdown

CODE | REASON | EFFECT
Fault Code: 642 PID: SPN: 1138 FMI: 0 LAMP: Shutdown SRT: | Exhaust Temperature Cylinder Left 2 High - Shutdown. The exhaust temperature for cylinder number left 2 has exceeded the high critical threshold. | The engine will shut down.
Exhaust Temperature Cylinder Left 2

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CM850 module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CM850 module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-642-st

Last Modified: 31-Jul-2015


Fault Code Path Selection

FAULT CODE 642
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc642-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc642-st

Last Modified: 05-Oct-2007


Exhaust Temperature Cylinder Left 3 High - Shutdown

FAULT CODE 643 - Multiple Turbochargers

Exhaust Temperature Cylinder Left 3 High - Shutdown

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Left 3 High - Shutdown

CODE | REASON | EFFECT
Fault Code: 643 PID: SPN: 1139 FMI: 0 LAMP: Shutdown SRT: | Exhaust Temperature Cylinder Left 3 High - Shutdown. The exhaust temperature for cylinder number left 3 has exceeded the high critical threshold. | The engine will shut down.
Exhaust Temperature Cylinder Left 3

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CENSE™ module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-643-mt

Last Modified: 31-Jul-2015


Exhaust Temperature Cylinder Left 3 High - Shutdown

FAULT CODE 643 - Single Turbocharger

Exhaust Temperature Cylinder Left 3 High - Shutdown

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Left 3 High - Shutdown

CODE | REASON | EFFECT
Fault Code: 643 PID: SPN: 1139 FMI: 0 LAMP: Shutdown SRT: | Exhaust Temperature Cylinder Left 3 High - Shutdown. The exhaust temperature for cylinder number left 3 has exceeded the high critical threshold. | The engine will shut down.
Exhaust Temperature Cylinder Left 3

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CM850 module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CM850 module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-643-st.

Last Modified: 31-Jul-2015


Fault Code Path Selection

FAULT CODE 643
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc643-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc643-st

Last Modified: 05-Oct-2007


Exhaust Temperature Cylinder Left 4 High - Shutdown

FAULT CODE 644 - Multiple Turbochargers

Exhaust Temperature Cylinder Left 4 High - Shutdown

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Left 4 High - Shutdown

CODE | REASON | EFFECT
Fault Code: 644 PID: SPN: 1140 FMI: 0 LAMP: Shutdown SRT: | Exhaust Temperature Cylinder Left 4 High - Shutdown. The exhaust temperature for cylinder number left 4 has exceeded the high critical threshold. | The engine will shut down.
Exhaust Temperature Cylinder Left 4

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CENSE™ module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-644-mt.

Last Modified: 31-Jul-2015


Exhaust Temperature Cylinder Left 4 High - Shutdown

FAULT CODE 644 - Single Turbocharger

Exhaust Temperature Cylinder Left 4 High - Shutdown

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Left 4 High - Shutdown

CODE | REASON | EFFECT
Fault Code: 644 PID: SPN: 1140 FMI: 0 LAMP: Shutdown SRT: | Exhaust Temperature Cylinder Left 4 High - Shutdown. The exhaust temperature for cylinder number left 4 has exceeded the high critical threshold. | The engine will shut down.
Exhaust Temperature Cylinder Left 4

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CM850 module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CM850 module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-644-st.

Last Modified: 31-Jul-2015


Fault Code Path Selection

FAULT CODE 644
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc644-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc644-st

Last Modified: 05-Oct-2007


Exhaust Temperature Cylinder Left 5 High - Shutdown

FAULT CODE 645 - Multiple Turbochargers

Exhaust Temperature Cylinder Left 5 High - Shutdown

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Left 5 High - Shutdown

CODE | REASON | EFFECT
Fault Code: 645 PID: SPN: 1141 FMI: 0 LAMP: Shutdown SRT: | Exhaust Temperature Cylinder Left 5 High - Shutdown. The exhaust temperature for cylinder number left 5 has exceeded the high critical threshold. | The engine will shut down.
Exhaust Temperature Cylinder Left 5

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CENSE™ module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-645-mt.

Last Modified: 31-Jul-2015


Exhaust Temperature Cylinder Left 5 High - Shutdown

FAULT CODE 645 - Single Turbocharger

Exhaust Temperature Cylinder Left 5 High - Shutdown

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Left 5 High - Shutdown

CODE | REASON | EFFECT
Fault Code: 645 PID: SPN: 1141 FMI: 0 LAMP: Shutdown SRT: | Exhaust Temperature Cylinder Left 5 High - Shutdown. The exhaust temperature for cylinder number left 5 has exceeded the high critical threshold. | The engine will shut down.
Exhaust Temperature Cylinder Left 5

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CM850 module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CM850 module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-645-st.

Last Modified: 31-Jul-2015


Fault Code Path Selection

FAULT CODE 645
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc645-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc645-st

Last Modified: 05-Oct-2007


Exhaust Temperature Cylinder Left 6 High - Shutdown

FAULT CODE 646 - Multiple Turbochargers

Exhaust Temperature Cylinder Left 6 High - Shutdown

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Left 6 High - Shutdown

CODE | REASON | EFFECT
Fault Code: 646 PID: SPN: 1142 FMI: 0 LAMP: Shutdown SRT: | Exhaust Temperature Cylinder Left 6 High - Shutdown. The exhaust temperature for cylinder number left 6 has exceeded the high critical threshold. | The engine will shut down.
Exhaust Temperature Cylinder Left 6

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CENSE™ module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-646-mt.

Last Modified: 31-Jul-2015


Exhaust Temperature Cylinder Left 6 High - Shutdown

FAULT CODE 646 - Single Turbocharger

Exhaust Temperature Cylinder Left 6 High - Shutdown

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Left 6 High - Shutdown

CODE | REASON | EFFECT
Fault Code: 646 PID: SPN: 1142 FMI: 0 LAMP: Shutdown SRT: | Exhaust Temperature Cylinder Left 6 High - Shutdown. The exhaust temperature for cylinder number left 6 has exceeded the high critical threshold. | The engine will shut down.
Exhaust Temperature Cylinder Left 6

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CM850 module, which sends this information to the CM700 via the J1939 datalink. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 datalink, a datalink or CM850 module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-646-st.

Last Modified: 31-Jul-2015


Fault Code Path Selection

FAULT CODE 646
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc646-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc646-st

Last Modified: 05-Oct-2007


Exhaust Temperature Cylinder Left 7 High - Shutdown

FAULT CODE 647 - Multiple Turbochargers

Exhaust Temperature Cylinder Left 7 High - Shutdown

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Left 7 High - Shutdown

CODE | REASON | EFFECT
Fault Code: 647 PID: SPN: 1143 FMI: 0 LAMP: Shutdown SRT: | Exhaust Temperature Cylinder Left 7 High - Shutdown. The exhaust temperature for cylinder number left 7 has exceeded the high critical threshold. | The engine will shut down.
Exhaust Temperature Cylinder Left 7

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CENSE™ module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-647-mt.

Last Modified: 31-Jul-2015


Exhaust Temperature Cylinder Left 7 High - Shutdown

FAULT CODE 647 - Single Turbocharger

Exhaust Temperature Cylinder Left 7 High - Shutdown

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Left 7 High - Shutdown

CODE | REASON | EFFECT
Fault Code: 647 PID: SPN: 1143 FMI: 0 LAMP: Shutdown SRT: | Exhaust Temperature Cylinder Left 7 High - Shutdown. The exhaust temperature for cylinder number left 7 has exceeded the high critical threshold. | The engine will shut down.
Exhaust Temperature Cylinder Left 7

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CM850 module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CM850 module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-647-st.

Last Modified: 31-Jul-2015


Fault Code Path Selection

FAULT CODE 647
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc647-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc647-st

Last Modified: 05-Oct-2007


Exhaust Temperature Cylinder Left 8 High - Shutdown

FAULT CODE 648 - Multiple Turbochargers

Exhaust Temperature Cylinder Left 8 High - Shutdown

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Left 8 High - Shutdown

CODE | REASON | EFFECT
Fault Code: 648 PID: SPN: 1144 FMI: 0 LAMP: Shutdown SRT: | Exhaust Temperature Cylinder Left 8 High - Shutdown. The exhaust temperature for cylinder number left 8 has exceeded the high critical threshold. | The engine will shut down.
Exhaust Temperature Cylinder Left 8

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CENSE™ module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-648-mt.

Last Modified: 31-Jul-2015


Exhaust Temperature Cylinder Left 8 High - Shutdown

FAULT CODE 648 - Single Turbocharger

Exhaust Temperature Cylinder Left 8 High - Shutdown

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Left 8 High - Shutdown

CODE | REASON | EFFECT
Fault Code: 648 PID: SPN: 1144 FMI: 0 LAMP: Shutdown SRT: | Exhaust Temperature Cylinder Left 8 High - Shutdown. The exhaust temperature for cylinder number left 8 has exceeded the high critical threshold. | The engine will shut down.
Exhaust Temperature Cylinder Left 8

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CM850 module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CM850 module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-648-st.

Last Modified: 31-Jul-2015


Fault Code Path Selection

FAULT CODE 648
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc648-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc648-st

Last Modified: 05-Oct-2007


Exhaust Temperature Cylinder Right 1 High - Shutdown

FAULT CODE 652 - Multiple Turbochargers

Exhaust Temperature Cylinder Right 1 High - Shutdown

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Right 1 High - Shutdown

CODE | REASON | EFFECT
Fault Code: 652 PID: SPN: 1146 FMI: 0 LAMP: Shutdown SRT: | Exhaust Temperature Cylinder Right 1 High - Shutdown. The exhaust temperature for cylinder number right 1 has exceeded the high critical threshold. | The engine will shut down.
Exhaust Temperature Cylinder Right 1

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CENSE™ module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-652-mt.

Last Modified: 31-Jul-2015


Exhaust Temperature Cylinder Right 1 High - Shutdown

FAULT CODE 652 - Single Turbocharger

Exhaust Temperature Cylinder Right 1 High - Shutdown

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Right 1 High - Shutdown

CODE | REASON | EFFECT
Fault Code: 652 PID: SPN: 1146 FMI: 0 LAMP: Shutdown SRT: | Exhaust Temperature Cylinder Right 1 High - Shutdown. The exhaust temperature for cylinder number right 1 has exceeded the high critical threshold. | The engine will shut down.
Exhaust Temperature Cylinder Right 1

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CM850 module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CM850 module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-652-st.

Last Modified: 31-Jul-2015


Fault Code Path Selection

FAULT CODE 652
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc652-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc652-st

Last Modified: 05-Oct-2007


Exhaust Temperature Cylinder Right 2 High - Shutdown

FAULT CODE 653 - Multiple Turbochargers

Exhaust Temperature Cylinder Right 2 High - Shutdown

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Right 2 High - Shutdown

CODE | REASON | EFFECT
Fault Code: 653 PID: SPN: 1147 FMI: 0 LAMP: Shutdown SRT: | Exhaust Temperature Cylinder Right 2 High - Shutdown. The exhaust temperature for cylinder number right 2 has exceeded the high critical threshold. | The engine will shut down.
Exhaust Temperature Cylinder Right 2

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CENSE™ module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-653-mt.

Last Modified: 31-Jul-2015


Exhaust Temperature Cylinder Right 2 High - Shutdown

FAULT CODE 653 - Single Turbocharger

Exhaust Temperature Cylinder Right 2 High - Shutdown

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Right 2 High - Shutdown

CODE | REASON | EFFECT
Fault Code: 653 PID: SPN: 1147 FMI: 0 LAMP: Shutdown SRT: | Exhaust Temperature Cylinder Right 2 High - Shutdown. The exhaust temperature for cylinder number right 2 has exceeded the high critical threshold. | The engine will shut down.
Exhaust Temperature Cylinder Right 2

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CM850 module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CM850 module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-653-st.

Last Modified: 31-Jul-2015


Fault Code Path Selection

FAULT CODE 653
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc653-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc653-st

Last Modified: 05-Oct-2007


Exhaust Temperature Cylinder Right 3 High - Shutdown

FAULT CODE 654 - Multiple Turbochargers

Exhaust Temperature Cylinder Right 3 High - Shutdown

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Right 3 High - Shutdown

CODE | REASON | EFFECT
Fault Code: 654 PID: SPN: 1148 FMI: 0 LAMP: Shutdown SRT: | Exhaust Temperature Cylinder Right 3 High - Shutdown. The exhaust temperature for cylinder number right 3 has exceeded the high critical threshold. | The engine will shut down.
Exhaust Temperature Cylinder Right 3

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CENSE™ module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-654-mt.

Last Modified: 31-Jul-2015


Exhaust Temperature Cylinder Right 3 High - Shutdown

FAULT CODE 654 - Single Turbocharger

Exhaust Temperature Cylinder Right 3 High - Shutdown

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Right 3 High - Shutdown

CODE | REASON | EFFECT
Fault Code: 654 PID: SPN: 1148 FMI: 0 LAMP: Shutdown SRT: | Exhaust Temperature Cylinder Right 3 High - Shutdown. The exhaust temperature for cylinder number right 3 has exceeded the high critical threshold. | The engine will shut down.
Exhaust Temperature Cylinder Right 3

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CM850 module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CM850 module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-654-st.

Last Modified: 31-Jul-2015


Fault Code Path Selection

FAULT CODE 654
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc654-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc654-st

Last Modified: 05-Oct-2007


Exhaust Temperature Cylinder Right 4 High - Shutdown

FAULT CODE 655 - Multiple Turbochargers

Exhaust Temperature Cylinder Right 4 High - Shutdown

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Right 4 High - Shutdown

CODE | REASON | EFFECT
Fault Code: 655 PID: SPN: 1149 FMI: 0 LAMP: Shutdown SRT: | Exhaust Temperature Cylinder Right 4 High - Shutdown. The exhaust temperature for cylinder number right 4 has exceeded the high critical threshold. | The engine will shut down.
Exhaust Temperature Cylinder Right 4

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CENSE™ module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-655-mt.

Last Modified: 31-Jul-2015


Exhaust Temperature Cylinder Right 4 High - Shutdown

FAULT CODE 655 - Single Turbocharger

Exhaust Temperature Cylinder Right 4 High - Shutdown

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Right 4 High - Shutdown

CODE | REASON | EFFECT
Fault Code: 655 PID: SPN: 1149 FMI: 0 LAMP: Shutdown SRT: | Exhaust Temperature Cylinder Right 4 High - Shutdown. The exhaust temperature for cylinder number right 4 has exceeded the high critical threshold. | The engine will shut down.
Exhaust Temperature Cylinder Right 4

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CM850 module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CM850 module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-655-st.

Last Modified: 31-Jul-2015


Fault Code Path Selection

FAULT CODE 655
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc655-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc655-st

Last Modified: 05-Oct-2007


Exhaust Temperature Cylinder Right 5 High - Shutdown

FAULT CODE 656 - Multiple Turbochargers

Exhaust Temperature Cylinder Right 5 High - Shutdown

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Right 5 High - Shutdown

CODE | REASON | EFFECT
Fault Code: 656 PID: SPN: 1150 FMI: 0 LAMP: Shutdown SRT: | Exhaust Temperature Cylinder Right 5 High - Shutdown. The exhaust temperature for cylinder number right 5 has exceeded the high critical threshold. | The engine will shut down.
Exhaust Temperature Cylinder Right 5

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CENSE™ module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-656-mt.

Last Modified: 31-Jul-2015


Exhaust Temperature Cylinder Right 5 High - Shutdown

FAULT CODE 656 - Single Turbocharger

Exhaust Temperature Cylinder Right 5 High - Shutdown

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Right 5 High - Shutdown

CODE | REASON | EFFECT
Fault Code: 656 PID: SPN: 1150 FMI: 0 LAMP: Shutdown SRT: | Exhaust Temperature Cylinder Right 5 High - Shutdown. The exhaust temperature for cylinder number right 5 has exceeded the high critical threshold. | The engine will shut down.
Exhaust Temperature Cylinder Right 5

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CM850 module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CM850 module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-656-st.

Last Modified: 31-Jul-2015


Fault Code Path Selection

FAULT CODE 656
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc656-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc656-st

Last Modified: 05-Oct-2007


Exhaust Temperature Cylinder Right 6 High - Shutdown

FAULT CODE 657 - Multiple Turbochargers

Exhaust Temperature Cylinder Right 6 High - Shutdown

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Right 6 High - Shutdown

CODE | REASON | EFFECT
Fault Code: 657 PID: SPN: 1151 FMI: 0 LAMP: Shutdown SRT: | Exhaust Temperature Cylinder Right 6 High - Shutdown. The exhaust temperature for cylinder number right 6 has exceeded the high critical threshold. | The engine will shut down.
Exhaust Temperature Cylinder Right 6

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CENSE™ module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-657-mt.

Last Modified: 31-Jul-2015


Exhaust Temperature Cylinder Right 6 High - Shutdown

FAULT CODE 657 - Single Turbocharger

Exhaust Temperature Cylinder Right 6 High - Shutdown

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Right 6 High - Shutdown

CODE | REASON | EFFECT
Fault Code: 657 PID: SPN: 1151 FMI: 0 LAMP: Shutdown SRT: | Exhaust Temperature Cylinder Right 6 High - Shutdown. The exhaust temperature for cylinder number right 6 has exceeded the high critical threshold. | The engine will shut down.
Exhaust Temperature Cylinder Right 6

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CM850 module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CM850 module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-657-st.

Last Modified: 31-Jul-2015


Fault Code Path Selection

FAULT CODE 657
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc657-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc657-st

Last Modified: 05-Oct-2007


Exhaust Temperature Cylinder Right 7 High - Shutdown

FAULT CODE 658 - Multiple Turbochargers

Exhaust Temperature Cylinder Right 7 High - Shutdown

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Right 7 High - Shutdown

CODE | REASON | EFFECT
Fault Code: 658 PID: SPN: 1152 FMI: 0 LAMP: Shutdown SRT: | Exhaust Temperature Cylinder Right 7 High - Shutdown. The exhaust temperature for cylinder number right 7 has exceeded the high critical threshold. | The engine will shut down.
Exhaust Temperature Cylinder Right 7

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CENSE™ module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CENSE™ module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-658-mt.

Last Modified: 31-Jul-2015


Exhaust Temperature Cylinder Right 7 High - Shutdown

FAULT CODE 658 - Single Turbocharger

Exhaust Temperature Cylinder Right 7 High - Shutdown

Printable Version Printable Version

Overview

Exhaust Temperature Cylinder Right 7 High - Shutdown

CODE | REASON | EFFECT
Fault Code: 658 PID: SPN: 1152 FMI: 0 LAMP: Shutdown SRT: | Exhaust Temperature Cylinder Right 7 High - Shutdown. The exhaust temperature for cylinder number right 7 has exceeded the high critical threshold. | The engine will shut down.
Exhaust Temperature Cylinder Right 7

Circuit Description

The exhaust temperature sensor circuit provides the exhaust temperature signal to the CM850 module, which sends this information to the CM700 via the J1939 data link. The sensor is a thermocouple or bimetallic junction that produces a small voltage (less than 30 mVDC) that varies with temperature.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E of this manual for the component location.

Shop Talk

Since the exhaust port temperatures are sent to the CM700 via the J1939 data link, a data link or CM850 module failure will cause the CM700 to display the same default value for all cylinders.

Refer to Troubleshooting Fault Code t05-658-st.

Last Modified: 31-Jul-2015


Fault Code Path Selection

FAULT CODE 658
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc658-mt
Is this engine equipped with a single turbocharger? | Go to 59-fc658-st

Last Modified: 05-Oct-2007


Fault Code Path Selection

FAULT CODE 671
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc671mt
Is this engine equipped with a single turbocharger? | Go to 59-fc671st

Last Modified: 07-Oct-2010


Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 671

Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 671mt PID: SPN: 1137 FMI: 4/4 LAMP: Warning SRT: | Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 1. | No effect on engine performance.
Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Multiple Turbochargers

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor is located in the exhaust port outlet of the cylinder head. Use the following procedure for a detailed component location view. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘low voltage’ detected on the sensor circuit (short to a low source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature/engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 671 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

An exhaust gas temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust gas temperature sensor or harness may be malfunctioning. If shown on all cylinders, either the J1939 data link circuit, exhaust temperature return circuit or CENSE™ may be malfunctioning. The engine will continue to run for a short period and will then shut down and display the appropriate fault code.

Refer to Fault Code Troubleshooting t05-671mt.

Last Modified: 06-Jul-2011


Exhaust Gas Temperature Sensor Circuit Cylinder 1 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 671

Exhaust Gas Temperature Sensor Circuit Cylinder 1 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 671 PID: SPN: 1137 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 1 - Voltage Below Normal or Shorted to Low Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 1. | No engine protection for exhaust gas temperature.
Cylinder 1 (A1) (Single Turbocharger) - Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules - one for each bank, and sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0.5-VDC thermister-type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘low voltage’ detected on the sensor circuit (short to a low source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature/engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 671 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

An exhaust gas temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust gas temperature sensor or harness to that sensor may be malfunctioning. If shown on all cylinders for one bank of the engine, either the exhaust temperature sensor 5 volt supply or return circuits, or CM850 module may have malfunctioned. If -17.78° (C or F) is shown on all engine cylinders, then the malfunction may be with the proprietary data link which connects both CM850 modules to the CM700 module. The engine will continue to operate for a short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code t05-671st.

Last Modified: 06-Jul-2011


Fault Code Path Selection

FAULT CODE 672
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc672mt
Is this engine equipped with a single turbocharger? | Go to 59-fc672st

Last Modified: 07-Oct-2010


Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 672

Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 672mt PID: SPN: 1139 FMI: 4/4 LAMP: Warning SRT: | Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 3. | No effect on engine performance.
Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Multiple Turbochargers

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor is located in the exhaust port outlet of the cylinder head. Use the following procedure for a detailed component location view. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘low voltage’ detected on the sensor circuit (short to a low source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature/engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 672 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

An exhaust gas temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust gas temperature sensor or harness may be malfunctioning. If shown on all cylinders, either the J1939 data link circuit, exhaust temperature return circuit, or CENSE™ may be malfunctioning. The engine will continue to run for a short period and will then shut down and display the appropriate fault code.

Refer to Fault Code Troubleshooting t05-672mt.

Last Modified: 06-Jul-2011


Single Turbocharger Exhaust Gas Temperature Sensor Circuit Cylinder 3 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 672

Single Turbocharger Exhaust Gas Temperature Sensor Circuit Cylinder 3 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 672 PID: SPN: 1139 FMI: 4/4 LAMP: Maintenance SRT: | Single Turbocharger Exhaust Gas Temperature Sensor Circuit Cylinder 3 - Voltage Below Normal or Shorted to Low Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 3. | No engine protection for exhaust gas temperature.
Cylinder 3 (A2) (Single Turbocharger) - Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules - one for each bank, and sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0.5-VDC thermister-type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor located on the exhaust port outlet of the cylinder head. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘low voltage’ detected on the sensor circuit (short to a low source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature/engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 671 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

An exhaust gas temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust gas temperature sensor or harness to that sensor may be malfunctioning. If shown on all cylinders for one bank of the engine, either the exhaust temperature sensor 5 volt supply or return circuits, or CM850 module may have malfunctioned. If -17.78° (C or F) is shown on all engine cylinders, then the malfunction may be with the proprietary data link which connects both CM850 modules to the CM700 module. The engine will continue to operate for a short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code t05-672st.

Last Modified: 06-Jul-2011


Fault Code Path Selection

FAULT CODE 673
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc673mt
Is this engine equipped with a single turbocharger? | Go to 59-fc673st

Last Modified: 07-Oct-2010


Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 673

Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 671mt PID: SPN: 1141 FMI: 4/4 LAMP: Warning SRT: | Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 5. | No effect on engine performance.
Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Multiple Turbochargers

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor is located in the exhaust port outlet of the cylinder head. Use the following procedure for a detailed component location view. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘low voltage’ detected on the sensor circuit (short to a low source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature/engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 673 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

An exhaust gas temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust gas temperature sensor or harness may be malfunctioning. If shown on all cylinders, either the J1939 data link circuit, exhaust temperature return circuit or CENSE™ may be malfunctioning. The engine will continue to run for a short period and will then shut down and display the appropriate fault code.

Refer to Fault Code Troubleshooting t05-673mt.

Last Modified: 06-Jul-2011


Single Turbocharger Exhaust Gas Temperature Sensor Circuit Cylinder 5 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 673

Single Turbocharger Exhaust Gas Temperature Sensor Circuit Cylinder 5 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 673 PID: SPN: 1141 FMI: 4/4 LAMP: Maintenance SRT: | Single Turbocharger Exhaust Gas Temperature Sensor Circuit Cylinder 5 - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas temperature sensor circuit cylinder 5. | No engine protection for exhaust gas temperature.
Cylinder 5 (A3) (Single Turbocharger) - Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules - one for each bank, and sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0.5-VDC thermister-type signal which is proportional to temperature

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘low voltage’ detected on the sensor circuit (short to a low source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature/engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 671 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

An exhaust gas temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust gas temperature sensor or harness to that sensor may be malfunctioning. If shown on all cylinders for one bank of the engine, either the exhaust temperature sensor 5 volt supply or return circuits, or CM850 module may have malfunctioned. If -17.78° (C or F) is shown on all engine cylinders, then the malfunction may be with the proprietary data link which connects both CM850 modules to the CM700 module. The engine will continue to operate for a short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code t05-673st.

Last Modified: 06-Jul-2011


Fault Code Path Selection

FAULT CODE 674
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc674mt
Is this engine equipped with a single turbocharger? | Go to 59-fc674st

Last Modified: 07-Oct-2010


Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 674

Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 674mt PID: SPN: 1143 FMI: 4/4 LAMP: Warning SRT: | Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 7. | No effect on engine performance.
Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Multiple Turbochargers

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor is located in the exhaust port outlet of the cylinder head. Use the following procedure for a detailed component location view. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘low voltage’ detected on the sensor circuit (short to a low source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature/engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 674 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

An exhaust gas temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust gas temperature sensor or harness may be malfunctioning. If shown on all cylinders, either the J1939 data link circuit, exhaust temperature return circuit or CENSE™ may be malfunctioning. The engine will continue to run for a short period and will then shut down and display the appropriate fault code.

Refer to Fault Code Troubleshooting t05-674mt.

Last Modified: 06-Jul-2011


Single Turbocharger Exhaust Gas Temperature Sensor Circuit Cylinder 7 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 674

Single Turbocharger Exhaust Gas Temperature Sensor Circuit Cylinder 7 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 674 PID: SPN: 1143 FMI: 4/4 LAMP: Maintenance SRT: | Single Turbocharger Exhaust Gas Temperature Sensor Circuit Cylinder 7 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 7. | No engine protection for exhaust gas temperature.
Cylinder 7 (A4) (Single Turbocharger) - Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules - one for each bank, and sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0.5-VDC thermister-type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor circuit cylinder 7 is located in the exhaust manifold at the cylinder head 7 exhaust manifold interface. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘low voltage’ detected on the sensor circuit (short to a low source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature/engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 671 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

An exhaust gas temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust gas temperature sensor or harness to that sensor may be malfunctioning. If shown on all cylinders for one bank of the engine, either the exhaust temperature sensor 5 volt supply or return circuits, or CM850 module may have malfunctioned. If -17.78° (C or F) is shown on all engine cylinders, then the malfunction may be with the proprietary data link which connects both CM850 modules to the CM700 module. The engine will continue to operate for a short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code t05-674st.

Last Modified: 06-Jul-2011


Fault Code Path Selection

FAULT CODE 675
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc675mt
Is this engine equipped with a single turbocharger? | Go to 59-fc675st

Last Modified: 07-Oct-2010


Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 675

Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 675 PID: SPN: 1145 FMI: 4/4 LAMP: Warning SRT: | Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 9. | No effect on engine performance.
Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Multiple Turbochargers

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor is located in the exhaust port outlet of the cylinder head. Use the following procedure for a detailed component location view. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘low voltage’ detected on the sensor circuit (short to a low source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature/engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 671 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

An exhaust gas temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust gas temperature sensor or harness may be malfunctioning. If shown on all cylinders, either the J1939 data link circuit, exhaust temperature return circuit or CENSE™ may be malfunctioning. The engine will continue to run for a short period and will then shut down and display the appropriate fault code.

Refer to Fault Code Troubleshooting t05-671mt.

Last Modified: 06-Jul-2011


Exhaust Gas Temperature Sensor Circuit Cylinder 9 - Voltage Above Normal or Shorted to High Source

FAULT CODE 675 (Single Turbocharger)

Exhaust Gas Temperature Sensor Circuit Cylinder 9 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 675 PID: SPN: 1145 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 9 - Voltage Below Normal or Shorted to High Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 9. | No engine protection for exhaust gas temperature.
Cylinder 9 (A5)(Single Turbocharger) - Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules - one for each bank, and sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0.5-VDC thermister-type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘low voltage’ detected on the sensor circuit (short to a low source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature/engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 671 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

An exhaust gas temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust gas temperature sensor or harness to that sensor may be malfunctioning. If shown on all cylinders for one bank of the engine, either the exhaust temperature sensor 5 volt supply or return circuits, or CM850 module may have malfunctioned. If -17.78° (C or F) is shown on all engine cylinders, then the malfunction may be with the proprietary data link which connects both CM850 modules to the CM700 module. The engine will continue to operate for a short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code t05-675st.

Last Modified: 07-Jan-2013


Fault Code Path Selection

FAULT CODE 676
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc676mt
Is this engine equipped with a single turbocharger? | Go to 59-fc676st

Last Modified: 07-Oct-2010


Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 676

Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 676 PID: SPN: 1147 FMI: 4/4 LAMP: Warning SRT: | Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 11. | No effect on engine performance.
Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Multiple Turbochargers

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30-VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor is located in the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘low voltage’ detected on the sensor circuit (short to a low source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature/engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 676 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

An exhaust gas temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust gas temperature sensor or harness may be malfunctioning. If shown on all cylinders, either the J1939 data link circuit, exhaust temperature return circuit or CENSE™ may be malfunctioning. The engine will continue to run for a short period and will then shut down and display the appropriate fault code.

Refer to Fault Code Troubleshooting t05-676mt.

Last Modified: 15-Jul-2011


Exhaust Gas Temperature Sensor Circuit Cylinder 11 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 676

Exhaust Gas Temperature Sensor Circuit Cylinder 11 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 676 PID: SPN: 1147 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 11 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at exhaust gas temperature sensor circuit cylinder 11. | No engine protection for exhaust gas temperature.
Cylinder 11 (A6) (Single Turbocharger) - Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules - one for each bank, and sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0.5-VDC thermister-type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘low voltage’ detected on the sensor circuit (short to a low source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature/engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 671 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

An exhaust gas temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust gas temperature sensor or harness to that sensor may be malfunctioning. If shown on all cylinders for one bank of the engine, either the exhaust temperature sensor 5 volt supply or return circuits, or CM850 module may have malfunctioned. If -17.78° (C or F) is shown on all engine cylinders, then the malfunction may be with the proprietary data link which connects both CM850 modules to the CM700 module. The engine will continue to operate for a short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code t05-676st.

Last Modified: 15-Jul-2011


Fault Code Path Selection

FAULT CODE 677
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc677mt
Is this engine equipped with a single turbocharger? | Go to 59-fc677st

Last Modified: 07-Oct-2010


Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 677

Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 677 PID: SPN: 1149 FMI: 4/4 LAMP: Warning SRT: | Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 13. | No effect on engine performance.
Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Multiple Turbochargers

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor is located in the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘low voltage’ detected on the sensor circuit (short to a low source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature/engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 677 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

An exhaust gas temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust gas temperature sensor or harness may be malfunctioning. If shown on all cylinders, either the J1939 data link circuit, exhaust temperature return circuit or CENSE™ may be malfunctioning. The engine will continue to run for a short period and will then shut down and display the appropriate fault code.

Refer to Fault Code Troubleshooting t05-677mt.

Last Modified: 15-Jul-2011


Exhaust Gas Temperature Sensor Circuit Cylinder 13 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 677

Exhaust Gas Temperature Sensor Circuit Cylinder 13 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 677 PID: SPN: 1149 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 13 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at exhaust gas temperature sensor circuit cylinder 13. | No engine protection for exhaust gas temperature.
Circuit Cylinder 13 (7) (Single Turbocharger) - Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules - one for each bank, and sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0.5-VDC thermister-type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘low voltage’ detected on the sensor circuit (short to a low source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature/engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 671 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

An exhaust gas temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust gas temperature sensor or harness to that sensor may be malfunctioning. If shown on all cylinders for one bank of the engine, either the exhaust temperature sensor 5 volt supply or return circuits, or CM850 module may have malfunctioned. If -17.78° (C or F) is shown on all engine cylinders, then the malfunction may be with the proprietary data link which connects both CM850 modules to the CM700 module. The engine will continue to operate for a short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code t05-677st.

Last Modified: 15-Jul-2011


Fault Code Path Selection

FAULT CODE 678
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc678mt
Is this engine equipped with a single turbocharger? | Go to 59-fc678st

Last Modified: 07-Oct-2010


Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 678

Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 678 PID: SPN: 1151 FMI: 4/4 LAMP: Warning SRT: | Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 15. | No effect on engine performance.
Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Multiple Turbochargers

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor is located in the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘low voltage’ detected on the sensor circuit (short to a low source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature/engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 678 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

An exhaust gas temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust gas temperature sensor or harness may be malfunctioning. If shown on all cylinders, either the J1939 data link circuit, exhaust temperature return circuit or CENSE™ may be malfunctioning. The engine will continue to run for a short period and will then shut down and display the appropriate fault code.

Refer to Fault Code Troubleshooting t05-678mt.

Last Modified: 15-Jul-2011


Exhaust Gas Temperature Sensor Circuit Cylinder 15 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 678

Exhaust Gas Temperature Sensor Circuit Cylinder 15 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 678 PID: SPN: 1151 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 15 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at exhaust gas temperature sensor circuit cylinder 15. | No engine protection for exhaust gas temperature.
Cylinder 15 (A8) (Single Turbocharger) - Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules - one for each bank, and sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0.5-VDC thermister-type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘low voltage’ detected on the sensor circuit (short to a low source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature/engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 671 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

An exhaust gas temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust gas temperature sensor or harness to that sensor may be malfunctioning. If shown on all cylinders for one bank of the engine, either the exhaust temperature sensor 5 volt supply or return circuits, or CM850 module may have malfunctioned. If -17.78° (C or F) is shown on all engine cylinders, then the malfunction may be with the proprietary data link which connects both CM850 modules to the CM700 module. The engine will continue to operate for a short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code t05-678st.

Last Modified: 15-Jul-2011


Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect

FAULT CODE 686

Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 686 PID: 103 SPN: 103 FMI: 2 LAMP: Warning SRT: | Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect. An invalid turbocharger speed signal has been detected by the ECM. | No effect on engine performance.
Turbocharger 1 Speed Sensor Circuit - Single Turbocharger Engines

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger is reference such as a ground flat on the center of the turbine shaft. As the reference passes the speed sensor, a time-varying flux passes through the iron core that induces a proportional voltage in the coil. This signal is supplied to the CM700 module for speed measurement.

Turbocharger speed is not monitored until the intake manifold pressure reaches 20 psi, or above.

Component Location

Reference the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code indicates that a malfunction exists in one or more of the following system components:

  • Turbocharger speed sensor
  • Engine harness
  • ECM (CM700) power supply or grounds.

If the fault code occurs intermittently:

  • Check for causes of intermittent open circuit or short circuits in the turbocharger speed sensor circuit (including the speed sensor connector).
  • Check that the generator set grounds are in good condition.
  • Make sure that the CM700 module power supply and grounds are in good condition.
Refer to Troubleshooting Fault Code t05-696.

Last Modified: 02-Aug-2011


Turbocharger 1 Speed Low - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 687

Turbocharger 1 Speed Low - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 687 PID: 103 SPN: 103 FMI: 18 LAMP: Warning SRT: | Turbocharger 1 Speed Low - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low turbocharger speed has been detected by the ECM. | No effect on engine performance.
Turbocharger 1 Speed Low Circuit - Single Turbocharger

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger is reference such as a ground flat on the center of the turbine shaft. As the reference passes the speed sensor, a time-varying flux passes through the iron core that induces a proportional voltage in the coil. This signal is supplied to the CM700 module for speed measurement.

Turbocharger speed is not monitored until the intake manifold pressure reaches 20 psi or above.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

This fault code indicates that a malfunction exists in one or more of the following system components:

  • Turbocharger speed sensor
  • Engine harness
  • ECM (CM700) power supply or grounds.

If the fault occurs intermittently check the following:

  • Causes of intermittent open circuit or short circuits in the turbocharger speed sensor circuit (including the speed sensor connector)
  • Generator set grounds are in good condition
  • CM700 module power supply and grounds are in good condition.

This fault code can also be activated by mechanical problems with the turbocharger that could lead to reduced turbocharger speed, such as a poor lubricating oil supply to the turbocharger bearings leading to a seized turbocharger shaft. There would be other associated fault codes activated if these conditions exist.

Refer to Troubleshooting Fault Code t05-687.

Last Modified: 02-Aug-2011


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 689

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: 190 SPN: 190 FMI: 2 LAMP: Warning SRT: | Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect. An invalid crankshaft speed/position signal has been detected by the ECM. | No action taken by the ECM. Engine will continue to run on the camshaft engine position sensor. Possible loss of performance.
QSK60 G Multiple Turbocharger Engines with Generator Control Panel 1 (GCP1) and PowerCommand™ Supervisor 3100 Generator Set Controller - Crankshaft Engine Speed Sensor Circuit
QSK60 G Single and Multiple Turbocharger Engines with Generator Control Panel 2 (GCP2) and PowerCommand™ Supervisor 3100 Generator Set Controller - Crankshaft Engine Speed Sensor Circuit
QSK60 G Single and Multiple Turbocharger Engines with PowerCommand™ Supervisor 3300 Generator Set Controller - Crankshaft Engine Speed Sensor Circuit

Circuit Description

The crankshaft engine speed sensor provides engine speed and position information to the CM700 module. The sensor has a dual core circuit, that on some QSK60 G models, supplies a speed signal to the CM700 (engine speed) and PowerCommand™ Supervisor 3100 generator set control panel (speed bias control). On other applications, only one of the sensor core circuits is used. The sensor generates a signal by sensing the movement of the flywheel teeth.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Check for the correct air gap between the crankshaft engine speed sensor and the gear teeth on the flywheel. To check and set the gap, position the flywheel so that a gear tooth is directly below the sensor.

Possible causes of this fault code include:

  • Damaged crankshaft engine speed sensor
  • Open or shorted circuit
  • Power supply voltage malfunction.

If Fault Code 689 is only activated at a certain engine temperature, check the crankshaft engine speed sensor and the crankshaft engine speed sensor circuit while the engine is at that particular temperature.

Refer to Troubleshooting Fault Code t05-689.

Last Modified: 02-Aug-2011


Turbocharger 1 Compressor Inlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 691

Turbocharger 1 Compressor Inlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 691 PID: 351 SPN: 1172 FMI: 3 LAMP: Warning SRT: | Turbocharger 1 Compressor Inlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. A high signal voltage has been detected at the turbocharger compressor inlet air temperature circuit. | No effect on performance.
QSK60 G Single Turbocharger with Generator Control Panel 2 (GCP2) and PowerCommand™ Supervisor 3100 - Turbocharger 1 Compressor Inlet Air Temperature Sensor Circuit
QSK60 G Single Turbocharger with Generator Interface Box (GIB) and PowerCommand™ Control 3300 - Turbocharger 1 Compressor Inlet Air Temperature Sensor Circuit

Circuit Description

The turbocharger 1 compressor inlet air temperature sensor is a variable resistance sensor and is used to measure the temperature of the air entering the compressor intake of the turbocharger. The CM700 module supplies 5-VDC to the compressor intake temperature signal circuit. The CM700 monitors the change in voltage caused by changes in the resistance of the sensor to determine compressor inlet air temperature.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Depending on the generator set control panel type, the turbocharger 1 compressor inlet air temperature sensor can share sensor return (-) wires in the engine harness with other sensors. Therefore, an open circuit can cause multiple fault codes to become active. Before troubleshooting Fault Code 691, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return (-) circuit in the harness, connectors, or sensor
  • Open signal circuit or short circuit to a voltage source
  • Damaged sensor.
Refer to Troubleshooting Fault Code t05-691.

Last Modified: 02-Aug-2011


Turbocharger 1 Compressor Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 692

Turbocharger 1 Compressor Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 692 PID: 351 SPN: 1172 FMI: 4 LAMP: Warning SRT: | Turbocharger 1 Compressor Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. A low signal voltage has been detected at the turbocharger compressor inlet air temperature circuit. | No effect on engine performance.
QSK60 G Single Turbocharger with Generator Control Panel 2 (GCP2) and PowerCommand™ Supervisor 3100 - Turbocharger 1 Compressor Inlet Air Temperature Sensor Circuit
QSK60 G Single Turbocharger with Generator Interface Box (GIB) and PowerCommand™ Control 3300 - Turbocharger 1 Compressor Inlet Air Temperature Sensor Circuit

Circuit Description

The turbocharger 1 compressor inlet air temperature sensor is a variable resistance sensor and is used to measure the temperature of the air entering the compressor intake of the turbocharger. The CM700 module supplies 5-VDC to the compressor intake temperature signal circuit. The CM700 monitors the change in voltage cause by changes in the resistance of the sensor to determine compressor inlet air temperature.

Component Location

Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

Depending on the generator set control panel type, the turbocharger 1 compressor inlet air temperature sensor can share sensor return (-) wires in the engine harness with other sensors. Therefore, a short circuit can lead to multiple fault codes to become active. Before troubleshooting Fault Code 692, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal circuit (+) shorted to ground in the harness
  • Signal circuit (-) shorted to return or ground in the sensor
  • Damaged sensor.
Refer to Troubleshooting Fault Code t05-692.

Last Modified: 02-Aug-2011


ECM Internal Air Temperature - Shorted High

FAULT CODE 697

ECM Internal Air Temperature - Shorted High

Printable Version Printable Version

Overview

ECM Internal Air Temperature - Shorted High

CODE | REASON | EFFECT
Fault Code: 697 PID: P21 SPN: 1136 FMI: 3 LAMP: Warning SRT: | The internal signal for the ECM temperature is reading abnormally high voltage. | No effect on engine performance.
CM700

Circuit Description

The CM700 and CM558 each contain an internal temperature sensor. The circuit is entirely internal to the ECM.

Component Location

The ECM Internal Air Temperature Sensor is inside of the ECM.

Shop Talk

The ECM temperature is monitored to protect the generator system in the event of excessive ECM temperature.

Refer to Troubleshooting Fault Code t05-697

Last Modified: 30-Jun-2010


ECM Internal Air Temperature - Shorted Low

FAULT CODE 698

ECM Internal Air Temperature - Shorted Low

Printable Version Printable Version

Overview

ECM Internal Air Temperature - Shorted Low

CODE | REASON | EFFECT
Fault Code: 698 PID: P21 SPN: 1136 FMI: 4 LAMP: Warning SRT: | The internal signal for the ECM temperature is reading abnormally low voltage. | No effect on engine performance.
CM700

Circuit Description

The CM700 and CM558 each contain an internal temperature sensor. The circuit is entirely internal to the ECM.

Component Location

The ECM Internal Air Temperature Sensor is inside of the ECM.

Shop Talk

The ECM temperature is monitored to protect the generator system in the event of excessive ECM temperature.

Refer to Troubleshooting Fault Code t05-698

Last Modified: 30-Jun-2010


Fault Code Path Selection

FAULT CODE 721
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc721mt
Is this engine equipped with a single turbocharger? | Go to 59-fc721st

Last Modified: 07-Oct-2010


Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 721

Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 721mt PID: SPN: 1138 FMI: 4/4 LAMP: Warning SRT: | Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 2. | No effect on engine performance.
Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Multiple Turbochargers

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor is located in the exhaust port outlet of the cylinder head. Use the following procedure for component location. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘low voltage’ detected on the sensor circuit (short to a low source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature/engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 721 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

An exhaust gas temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust gas temperature sensor or harness may be malfunctioning. If shown on all cylinders, either the J1939 data link circuit, exhaust temperature return circuit or CENSE™ may be malfunctioning. The engine will continue to run for a short period and will then shut down and display the appropriate fault code.

Refer to Fault Code Troubleshooting t05-721mt.

Last Modified: 02-Aug-2011


Exhaust Gas Temperature Sensor Circuit Cylinder 2 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 721

Exhaust Gas Temperature Sensor Circuit Cylinder 2 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 721 PID: SPN: 1138 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 2 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at exhaust gas temperature sensor circuit cylinder 2. | No engine protection for exhaust gas temperature.
Cylinder 2 (B1) (Single Turbocharger) - Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules - one for each bank, and sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0.5-VDC thermister-type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘low voltage’ detected on the sensor circuit (short to a low source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature/engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 671 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

An exhaust gas temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust gas temperature sensor or harness to that sensor may be malfunctioning. If shown on all cylinders for one bank of the engine, either the exhaust temperature sensor 5 volt supply or return circuits, or CM850 module may have malfunctioned. If -17.78° (C or F) is shown on all engine cylinders, then the malfunction may be with the proprietary data link which connects both CM850 modules to the CM700 module. The engine will continue to operate for a short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code t05-721st.

Last Modified: 02-Aug-2011


Fault Code Path Selection

FAULT CODE 722
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc722mt
Is this engine equipped with a single turbocharger? | Go to 59-fc722st

Last Modified: 07-Oct-2010


Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 722

Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 722 PID: SPN: 1140 FMI: 4/4 LAMP: Warning SRT: | Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 4. | No effect on engine performance.
Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Multiple Turbochargers

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor is located in the exhaust port outlet of the cylinder head. Use the following procedure for a detailed component location view. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘low voltage’ detected on the sensor circuit (short to a low source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature/engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 722 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

An exhaust gas temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust gas temperature sensor or harness may be malfunctioning. If shown on all cylinders, either the J1939 data link circuit, exhaust temperature return circuit or CENSE™ may be malfunctioning. The engine will continue to run for a short period and will then shut down and display the appropriate fault code.

Refer to Fault Code Troubleshooting t05-722mt.

Last Modified: 02-Aug-2011


Exhaust Gas Temperature Sensor Circuit Cylinder 4 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 722

Exhaust Gas Temperature Sensor Circuit Cylinder 4 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 722 PID: SPN: 1140 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 4 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at exhaust gas temperature sensor circuit cylinder 4. | No engine protection for exhaust gas temperature.
Cylinder 4 (B2) (Single Turbocharger) - Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules - one for each bank, and sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0.5-VDC thermister-type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘low voltage’ detected on the sensor circuit (short to a low source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature/engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 671 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

An exhaust gas temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust gas temperature sensor or harness to that sensor may be malfunctioning. If shown on all cylinders for one bank of the engine, either the exhaust temperature sensor 5 volt supply or return circuits, or CM850 module may have malfunctioned. If -17.78° (C or F) is shown on all engine cylinders, then the malfunction may be with the proprietary data link which connects both CM850 modules to the CM700 module. The engine will continue to operate for a short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code t05-722st.

Last Modified: 02-Aug-2011


Fault Code Path Selection

FAULT CODE 723
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc723mt
Is this engine equipped with a single turbocharger? | Go to 59-fc723st

Last Modified: 07-Oct-2010


Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 723

Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 723 PID: SPN: 1142 FMI: 4/4 LAMP: Warning SRT: | Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 6. | No effect on engine performance.
Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Multiple Turbochargers

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor is located in the exhaust port outlet of the cylinder head. Use the following procedure for a detailed component location view. Refer to Procedure 019-013 in Section 19.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘low voltage’ detected on the sensor circuit (short to a low source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature/engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 723 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

An exhaust gas temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust gas temperature sensor or harness may be malfunctioning. If shown on all cylinders, either the J1939 data link circuit, exhaust temperature return circuit or CENSE™ may be malfunctioning. The engine will continue to run for a short period and will then shut down and display the appropriate fault code.

Refer to Fault Code Troubleshooting t05-723mt.

Last Modified: 02-Aug-2011


Exhaust Gas Temperature Sensor Circuit Cylinder 6 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 723

Exhaust Gas Temperature Sensor Circuit Cylinder 6 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 723 PID: SPN: 1142 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 6 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 6. | No engine protection for exhaust gas temperature.
Cylinder 6 (B3) (Single Turbocharger) - Exhaust Gas Temperature Sensor Circuit

Circuit Description

exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules - one for each bank, and sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0.5-VDC thermister-type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘low voltage’ detected on the sensor circuit (short to a low source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature/engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 671 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

An exhaust gas temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust gas temperature sensor or harness to that sensor may be malfunctioning. If shown on all cylinders for one bank of the engine, either the exhaust temperature sensor 5 volt supply or return circuits, or CM850 module may have malfunctioned. If -17.78° (C or F) is shown on all engine cylinders, then the malfunction may be with the proprietary data link which connects both CM850 modules to the CM700 module. The engine will continue to operate for a short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code t05-723st.

Last Modified: 02-Aug-2011


Fault Code Path Selection

FAULT CODE 724
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc724mt
Is this engine equipped with a single turbocharger? | Go to 59-fc724st

Last Modified: 07-Oct-2010


Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 724

Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 724mt PID: SPN: 1144 FMI: 4/4 LAMP: Warning SRT: | Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 8. | No effect on engine performance.
Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Multiple Turbochargers

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor is located in the exhaust port outlet of the cylinder head. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘low voltage’ detected on the sensor circuit (short to a low source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature/engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 724 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

An exhaust gas temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust gas temperature sensor or harness may be malfunctioning. If shown on all cylinders, either the J1939 data link circuit, exhaust temperature return circuit or CENSE™ may be malfunctioning. The engine will continue to run for a short period and will then shut down and display the appropriate fault code.

Refer to Fault Code Troubleshooting t05-724mt.

Last Modified: 02-Aug-2011


Exhaust Gas Temperature Sensor Circuit Cylinder 8 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 724

Exhaust Gas Temperature Sensor Circuit Cylinder 8 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 724 PID: SPN: 1144 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 8 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 8. | No engine protection for exhaust gas temperature.
Cylinder 8 (B4) (Single Turbocharger) - Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules - one for each bank, and sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0.5-VDC thermister-type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘low voltage’ detected on the sensor circuit (short to a low source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature/engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 671 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

An exhaust gas temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust gas temperature sensor or harness to that sensor may be malfunctioning. If shown on all cylinders for one bank of the engine, either the exhaust temperature sensor 5 volt supply or return circuits, or CM850 module may have malfunctioned. If -17.78° (C or F) is shown on all engine cylinders, then the malfunction may be with the proprietary data link which connects both CM850 modules to the CM700 module. The engine will continue to operate for a short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code t05-724st.

Last Modified: 02-Aug-2011


Fault Code Path Selection

FAULT CODE 725
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc725mt
Is this engine equipped with a single turbocharger? | Go to 59-fc725st

Last Modified: 07-Oct-2010


Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 725

Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 725 PID: SPN: 1146 FMI: 4/4 LAMP: Warning SRT: | Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 10. | No effect on engine performance.
Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Multiple Turbochargers

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor is located in the exhaust port outlet of the cylinder head. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘low voltage’ detected on the sensor circuit (short to a low source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature/engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 725 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

An exhaust gas temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust gas temperature sensor or harness may be malfunctioning. If shown on all cylinders, either the J1939 data link circuit, exhaust temperature return circuit or CENSE™ may be malfunctioning. The engine will continue to run for a short period and will then shut down and display the appropriate fault code.

Refer to Fault Code Troubleshooting t05-725mt.

Last Modified: 03-Aug-2011


Exhaust Gas Temperature Sensor Circuit Cylinder 10 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 725

Exhaust Gas Temperature Sensor Circuit Cylinder 10 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 725 PID: SPN: 1146 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 10 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 10. | No engine protection for exhaust gas temperature.
Cylinder 10 (B5) (Single Turbocharger) - Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules - one for each bank, and sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0.5-VDC thermister-type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘low voltage’ detected on the sensor circuit (short to a low source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature/engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 671 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

An exhaust gas temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust gas temperature sensor or harness to that sensor may be malfunctioning. If shown on all cylinders for one bank of the engine, either the exhaust temperature sensor 5 volt supply or return circuits, or CM850 module may have malfunctioned. If -17.78° (C or F) is shown on all engine cylinders, then the malfunction may be with the proprietary data link which connects both CM850 modules to the CM700 module. The engine will continue to operate for a short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code t05-725st.

Last Modified: 02-Aug-2011


Fault Code Path Selection

FAULT CODE 726
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc726mt
Is this engine equipped with a single turbocharger? | Go to 59-fc726st

Last Modified: 07-Oct-2010


Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 726

Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 726mt PID: SPN: 1148 FMI: 4/4 LAMP: Warning SRT: | Multiple Turbochargers Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 12. | No effect on engine performance.
Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Multiple Turbochargers

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor is located in the exhaust port outlet of the cylinder head. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘low voltage’ detected on the sensor circuit (short to a low source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature/engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 726 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

An exhaust gas temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust gas temperature sensor or harness may be malfunctioning. If shown on all cylinders, either the J1939 data link circuit, exhaust temperature return circuit or CENSE™ may be malfunctioning. The engine will continue to run for a short period and will then shut down and display the appropriate fault code.

Refer to Fault Code Troubleshooting t05-726mt.

Last Modified: 02-Aug-2011


Exhaust Gas Temperature Sensor Circuit Cylinder 12 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 726

Exhaust Gas Temperature Sensor Circuit Cylinder 12 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 726 PID: SPN: 1148 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 12 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 12. | No engine protection for exhaust gas temperature.
Cylinder 12 (B6) (Single Turbocharger) - Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules - one for each bank, and sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0.5-VDC thermister-type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘low voltage’ detected on the sensor circuit (short to a low source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature/engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 671 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

An exhaust gas temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust gas temperature sensor or harness to that sensor may be malfunctioning. If shown on all cylinders for one bank of the engine, either the exhaust temperature sensor 5 volt supply or return circuits, or CM850 module may have malfunctioned. If -17.78° (C or F) is shown on all engine cylinders, then the malfunction may be with the proprietary data link which connects both CM850 modules to the CM700 module. The engine will continue to operate for a short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code t05-726st.

Last Modified: 02-Aug-2011


Fault Code Path Selection

FAULT CODE 727
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc727mt
Is this engine equipped with a single turbocharger? | Go to 59-fc727st

Last Modified: 07-Oct-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 727

Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 727 PID: SPN: 1150 FMI: 4/4 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 14. | No effect on engine performance.
Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Multiple Turbochargers

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor is located in the exhaust port outlet of the cylinder head. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘low voltage’ detected on the sensor circuit (short to a low source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature/engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 727 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

An exhaust gas temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust gas temperature sensor or harness may be malfunctioning. If shown on all cylinders, either the J1939 data link circuit, exhaust temperature return circuit or CENSE™ may be malfunctioning. The engine will continue to run for a short period and will then shut down and display the appropriate fault code.

Refer to Fault Code Troubleshooting t05-727mt.

Last Modified: 03-Aug-2011


Exhaust Gas Temperature Sensor Circuit Cylinder 14 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 727

Exhaust Gas Temperature Sensor Circuit Cylinder 14 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 727 PID: SPN: 1150 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 14 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 14. | No engine protection for exhaust gas temperature.
Cylinder 14 (B7) (Single Turbocharger) - Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules - one for each bank, and sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0.5-VDC thermister-type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘low voltage’ detected on the sensor circuit (short to a low source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature/engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 671 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

An exhaust gas temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust gas temperature sensor or harness to that sensor may be malfunctioning. If shown on all cylinders for one bank of the engine, either the exhaust temperature sensor 5 volt supply or return circuits, or CM850 module may have malfunctioned. If -17.78° (C or F) is shown on all engine cylinders, then the malfunction may be with the proprietary data link which connects both CM850 modules to the CM700 module. The engine will continue to operate for a short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code t05-727st.

Last Modified: 03-Aug-2011


Fault Code Path Selection

FAULT CODE 728
Fault Code Path Selection

Is this engine equipped with multiple turbochargers? | Go to 59-fc728mt
Is this engine equipped with a single turbocharger? | Go to 59-fc728st

Last Modified: 07-Oct-2010


Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B8) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 728

Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B8) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 728 PID: SPN: 1152 FMI: 4/4 LAMP: Warning SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B8) - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 14. | No effect on engine performance.
Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B8) - Multiple Turbochargers

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to the CENSE™ module, which sends this information to the CM700 module via the J1939 data link. The temperature sensor is a thermocouple device that produces a small voltage (less than 30m-VDC) that varies with temperature.

Component Location

The exhaust gas temperature sensor is located in the exhaust port outlet of the cylinder head. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘low voltage’ detected on the sensor circuit (short to a low source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature/engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 728 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

An exhaust gas temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust gas temperature sensor or harness may be malfunctioning. If shown on all cylinders, either the J1939 data link circuit, exhaust temperature return circuit or CENSE™ may be malfunctioning. The engine will continue to run for a short period and will then shut down and display the appropriate fault code.

Refer to Fault Code Troubleshooting t05-728mt.

Last Modified: 03-Aug-2011


Exhaust Gas Temperature Sensor Circuit Cylinder 16 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 728

Exhaust Gas Temperature Sensor Circuit Cylinder 16 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 728 PID: SPN: 1152 FMI: 4/4 LAMP: Maintenance SRT: | Exhaust Gas Temperature Sensor Circuit Cylinder 16 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas temperature sensor circuit cylinder 16. | No engine protection for exhaust gas temperature.
Cylinder 16 (B8) (Single Turbocharger) - Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor circuit provides the exhaust gas temperature signal to two CM850 modules - one for each bank, and sends this information to the CM700 module via the proprietary data link. The temperature sensor is a thermocouple device that converts its output to a 0.5-VDC thermister-type signal which is proportional to temperature.

Component Location

The exhaust gas temperature sensor is located on the exhaust port outlet of the cylinder head. Use the following procedure for a detailed component location view. Refer to Procedure 100-002 in Section E.

Shop Talk

The exhaust gas temperature sensing circuit provides misfire protection for the engine. If there is a ‘low voltage’ detected on the sensor circuit (short to a low source), the monitoring system is unable to detect any low exhaust gas temperature caused by an engine misfire. This means that the low exhaust gas temperature/engine misfire protection for the affected cylinder is ineffective.

Should Fault Code 671 be activated, the cause must be investigated and rectified as soon as possible, so that full engine protection is re-established.

An exhaust gas temperature of -17.78° (C or F) is a default value that indicates that the CM700 is not receiving a valid signal or data. If this is shown on a single cylinder, the exhaust gas temperature sensor or harness to that sensor may be malfunctioning. If shown on all cylinders for one bank of the engine, either the exhaust temperature sensor 5 volt supply or return circuits, or CM850 module may have malfunctioned. If -17.78° (C or F) is shown on all engine cylinders, then the malfunction may be with the proprietary data link which connects both CM850 modules to the CM700 module. The engine will continue to operate for a short period and will then shut down and display the appropriate fault code.

Refer to Troubleshooting Fault Code t05-728st.

Last Modified: 03-Aug-2011


Invalid Signal Detected at Gas Mass Flow Sensor

FAULT CODE 751

Invalid Signal Detected at Gas Mass Flow Sensor

Printable Version Printable Version

Overview

Invalid Signal Detected at Gas Mass Flow Sensor

CODE | REASON | EFFECT
Fault Code: 751 PID: P183 SPN: 183 FMI: 2 LAMP: Shutdown SRT: | Invalid Signal Detected at Gas Mass Flow Sensor. A signal that is outside of the normal operating limits was detected on the gas mass flow sensor signal pin of the main harness CM558 connector. | Engine performance can be affected.
Gas Mass Flow Sensor Circuit - Multiple Turbochargers
Gas Mass Flow Sensor Circuit - Single Turbocharger

Circuit Description

The signal from the CM558 to the gas mass flow sensor is 14-VDC. The feedback signal from the sensor to the CM558 is 0 to 5-VDC. A signal outside of the normal operating limits will cause Fault Code 751 to be set.

Component Location

Refer to Procedure 100-002 (Engine Diagrams) in Section E for the component location.

Shop Talk

The gas mass flow sensor is supplied with 14-VDC from the CM558. The sensor is a hot wire sensor with two wire elements that protrude into the gas flow. The two wires are kept at equal temperatures and the signal, 0 to 5-VDC, indicates the gas flow to the CM558. The 0 to 5-VDC signal corresponds to the voltage necessary to maintain the temperature of the wires due to the cooling effect as the gas flows.

An invalid signal on the gas mass flow sensor can be caused by fuel system problems. The invalid signal is an indication that the gas mass flow sensor is either faulty, or it can not correct the fuel flow to the desired value. The gas mass flow sensor corrects the fuel flow by adjusting the position of the fuel control valve.

Refer to Troubleshooting Fault Code t05-751

Last Modified: 30-Jun-2010


SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate

FAULT CODE 781

SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 781 SPN: 1231 FMI: 9 LAMP: Warning SRT: | SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate. The engine ECMs have detected a communication problem with the SAE J1939 data link network. | Warning
SAE J1939 Data Link 2 Circuit - (Multiple Turbocharger Engines)
SAE J1939 Data Link 2 Circuit - (Single Turbocharger Engines)

Circuit Description

The J1939 data link is a public data link that broadcasts engine operating data, as well as fault codes.

Component Location

Use the following procedure for component location. Refer to Procedure 100-002 in Section E.

Shop Talk

The J1939 data link is a network data link on which each electronic control module (ECM) is attached via a network stub connection. Be sure the electronic service tool is set up for J1939 communications (if applicable) when using this data link. Although this link provides important diagnostic and ending protection information, the engine will continue to operate without it.

Refer to Troubleshooting Fault Code 781.

Last Modified: 13-Jul-2010


Intake Manifold 1 Temperature - Abnormal Rate of Change

FAULT CODE 783

Intake Manifold 1 Temperature - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 783 PID: 105 SPN: 105 FMI: 10 LAMP: Shutdown SRT: | Intake Manifold 1 Temperature - Abnormal Rate of Change. With the intake manifold over-pressure, compressor outlet pressure maximum diagnostic enabled, and the intake manifold over-pressure, intake manifold temperature filtered derivative is greater than the derivative threshold for set persistence time. | The engine will shut down.
Intake Manifold 1 Temperature Sensor Circuit

Circuit Description

The intake manifold 1 temperature sensor is a variable resistor sensor and is used to measure the temperature of the air/fuel mixture entering the intake manifold of the engine. The intake manifold temperature value is used by the engine control modules (ECMs) for the engine protection system, timing, and engine emissions control.

The left-bank CM558 ECM supplies 5 VDC to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air/fuel mixture is cold, the sensor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground, therefore, the ECM senses a high signal voltage or a low temperature. When the intake air/fuel mixture is warm, the sensor resistance is low. The ECM signal voltage pulls down a large amount, therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 temperature sensor is located on the right bank side, non-drive end of the engine, and is mounted on the intake manifold.

The CM558 is located on the engine left bank intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the ECM keyswitch is in the ON position or when the engine is operating.

Conditions for Setting the Fault Codes

The ECM detects the intake manifold temperature rate of change has exceeded the temperature-over-time threshold of 1.11° C [2.0° F] per second.

Action Taken When the Fault Code is Active

  • The CM558 illuminates the red ALARM SHUTDOWN lamp on the Generator Control Panel immediately when the diagnostic runs and fails. Fault Code 488 will also show as ACTIVE by INSITE™ electronic service tool and on the original equipment manufacturer (OEM) control panel display.
  • The engine will shutdown.

Conditions for Clearing the Fault Code

  • Make sure the recommended pre-start checks listed under Shop Talk have been performed.
  • To validate the repair, start the engine and let it run at rated speed for 1 minute at no load.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The CM558 will turn off the red ALARM SHUTDOWN lamp after the diagnostic runs and passes.
  • The "Reset All Faults" command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This feature provides protection for the charge-air system, valve train, and power cylinders when a rapid rise in intake manifold charge-air temperature occurs; for example, as a result of a backfire in the intake manifold. The CM558 monitors the change in the intake manifold 1 temperature sensor over a period of time. If the intake manifold temperature rate of change is excessive, the CM558 logs a fault and requests a shutdown.

The troubleshooting steps below give guidance for determining the cause of the intake manifold event and the resulting active Fault Code 783.

Following the activation of Fault Code 783, an inspection must be performed on the engine to check for any consequential damage. Any issues or damage must be corrected before starting the engine.

The recommended checks are as follows:

  • Check for external coolant leaks between each cylinder head and the block. Signs of coolant and/or oil leaks would indicate the cylinder heads have lifted during the intake manifold backfire event.
  • Check the air filter elements and air filter housing for damage.
  • Inspect the charge-air system for leaks.
  • Inspect the charge-air system pipe work for damage.
  • Check for free movement of the throttle throughout the full range.
  • Check throttle plate alignment.
  • Check the charge-air cooler for leaks (coolant and air/fuel mixture). Check the charge-air cooler element for any damage resulting from the intake manifold over-pressure event.
  • Remove the valve covers. Check valve clearances. Check for any abnormalities or mis-aligned rocker gear, valve stems, valve spring assemblies, and displaced valve collets. Check the intake valve retention cir-clip and washer for damage. Any damaged parts must be replaced prior to starting the engine.
  • Bar the engine over by hand. Any tightness when rotating must be investigated. Dropped intake/exhaust valves and coolant leakage internal to the power cylinders must be considered, which can result in further consequential damage to power cylinder components.
  • Inspect the turbocharger compressor wheel blades (on both turbocharger assemblies) for signs of damage and contact with the compressor housing. If there are any signs of damage, then the turbocharger(s) must be replaced before starting the generator set.
  • Following start-up of the generator set, carefully monitor individual cylinder exhaust temperatures via the Human Machine Interface. Any cold cylinders must be investigated using appropriate investigation and troubleshooting methods.

Engine/generator set overload must also be considered as a cause of Fault Code 783 being activated. Engine overload can be caused by excessively large load steps being applied on the engine on one application. Any load step that exceeds 30 percent of the generator rated load is considered as excessive, but this load figure can vary according to site conditions and quality of fuel being supplied to the engine. Contact your local Cummins® Authorized Repair Location for further advice.

Additionally, generator set breaker control must be configured to protect the engine when operating in Isolated Bus, Multiple Generator Set applications. In the event of one generator set shutting down unexpectedly (critical shutdown), the remaining sets are protected from being overloaded (the remaining circuit breakers must also open to prevent any overload condition from being applied).

If necessary, a datalogger should be installed so the engine/generator set load profile can be confirmed as being within the engine/generator set load application specification limits.

Important Note: The troubleshooting steps in Troubleshooting Fault Code Tree 59-t05-783 recommend the engine's exhaust emissions are checked to confirm the exhaust emissions meet published specifications. The following procedures must be followed if the exhaust emissions are found not to meet published specification for the engine application.

  • Confirm the engine's emissions have be previously tuned to published specifications. If this can not be confirmed, retune exhaust emissions so they meet the published specification for the engine application. Use the following procedure in the QSK60G Generator CM700 Operation and Maintenance Manual, Bulletin 4021395, or QSK60 G CM700 K103 Operation and Maintenance Manual, Bulletin 4325991. Reference Procedure 307-001 in Section H.
  • If it can be confirmed the engine's exhaust emissions have been previously tuned to published specifications, and if the average measured exhaust emissions have changed by ±90 ppm, and the closed loop fueling compensation has not changed significantly (less than ±20 lb/hr), then this indicates the emissions change is being driven by the fueling control system. Fueling control related systems and sensors must be checked to confirm they are operating correctly.
  • If it can be confirmed the engine's exhaust emissions have been previously tuned to published specifications, and if the average measured exhaust emissions have changed by ±90 ppm, and the closed loop fueling compensation has changed significantly (more than ±20 lb/hr), then this indicates the emissions change is being driven by a change in the fuel quality being supplied to the engine. The fueling compensation may have reached its limit of adjustment. Retune the exhaust emissions so they meet the published specification for the engine application. Use the following procedure in the QSK60G Generator CM700 Operation and Maintenance Manual, Bulletin 4021395, or QSK60 G CM700 K103 Operation and Maintenance Manual, Bulletin 4325991. Reference Procedure 307-001 in Section H.

The following table, which can be used as an aid when troubleshooting the fuel control valve operation, provides fuel control valve actuator position, pulse width modulation commanded position, percent duty cycle, and volts of direct current (VDC) feedback signal specifications.

Fuel Control Valve - Commanded Position Percent Duty Cycle and 0 to 5 VDC Position Feedback Signal Specification
Value Commanded Position | Commanded Percent Duty Cycle | 0 to 5 VDC Position Feedback
0 | 10 to 14 | 0.4 to 0.7
10 | 17 to 21 | 0.7 to 1.1
20 | 25 to 28 | 1.3 to 1.5
30 | 33 to 37 | 1.7 to 1.9
40 | 41 to 44 | 2.1 to 2.3
50 | 49 to 54 | 2.5 to 2.7
60 | 55 to 60 | 2.9 to 3.0
70 | 65 to 70 | 3.3 to 3.5
80 | 73 to 78 | 3.7 to 3.9
90 | 81 to 86 | 4.1 to 4.8
100 | 89 to 94 | 4.6 to 4.8
Refer to Troubleshooting Fault Code 783.

Last Modified: 30-May-2019


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Engine speed sensor fault code active?
STEP 2. | Check the engine speed sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the engine speed sensor. | Damaged engine speed sensor?
 | STEP 2C. Check for an open circuit. | Less than 2k ohms?
 | STEP 2D. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 2E. Check for a short circuit between coils. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the extension harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 2k ohms?
 | STEP 3C. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 121 inactive?
 | STEP 4B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Keyswitch circuit energized
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Engine speed sensor fault code active?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool to clear the inactive fault codes.

Go to 2A

Repair complete

Guided Step 2 - Check the engine speed sensor.

Guided Step 2A - Inspect the sensor and the engine harness connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/sto/auto switch in STOP mode
  • Disconnect the engine harness connector from the engine speed sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the engine harness or the engine speed sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical/electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-211 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the engine speed sensor.

Conditions

  • De-energize keyswitch circuit
  • Place run/sto/auto switch in STOP mode
  • Disconnect the engine harness from the engine speed sensor
  • Remove the engine speed sensor.

Action

Inspect the engine speed sensor for the following:

  • Metal debris on end of sensor
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor
  • Damage to end of sensor caused by camshaft gear or flywheel ring gear.

Damaged engine speed sensor?
YES NO

Repair

Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/sto/auto switch in STOP mode
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for an open circuit in the sensor.

  • Measure the resistance from the engine speed sensor SIGNAL pin to the engine speed sensor RETURN pin.

NOTE: While testing sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

Less than 2k ohms?
YES NO
No Repair

Repair

Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit
  • Place run/sto/auto switch in STOP mode
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance between the engine speed sensor SIGNAL pin to the engine block ground.

NOTE: While testing sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a short circuit between coils.

Conditions

  • De-energize keyswitch circuit
  • Place run/sto/auto switch in STOP mode
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit between coils.

  • Measure the resistance between the engine speed sensor SIGNAL pin of one coil and the engine speed sensor SIGNAL pin of the other coil.
  • Measure the resistance between the engine speed sensor RETURN pin to the engine speed sensor RETURN pin.

NOTE: While testing sensor, electrical leads from the sensor to the sensor connector must be gently flexed to check for damaged or partially broken wires under the insulation.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and the extension harness connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/sto/auto switch in STOP mode
  • Disconnect the engine harness from the control module.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical/electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/sto/auto switch in STOP mode
  • Disconnect the engine harness from the control module
  • Connect the engine harness to the engine speed sensor.

Action

Check for an open circuit.

  • Measure the resistance from the engine speed sensor SIGNAL pin to the speed sensor RETURN pin on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Less than 2k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit
  • Place run/sto/auto switch in STOP mode
  • Disconnect the engine harness from the control module
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the engine speed sensor SIGNAL pin on the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/sto/auto switch in STOP mode
  • Disconnect the engine harness from the control module
  • Disconnect the engine harness from the engine speed sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the engine speed sensor SIGNAL pin and all other pins of the engine harness connector.
  • Measure the resistance between the engine speed sensor RETURN pin and all other pins of the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Place run/sto/auto switch in RUN mode and running for longer than 1 minute.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 121 is inactive.

Fault Code 121 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked.

Go to 4B

Go to 2A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Place run/sto/auto switch in STOP mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 27-Oct-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164752 - pressure sensor breakout cablePart Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 227 active?
STEP 2. | Check the engine oil pressure sensor (rifle). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault Code 135 is inactive?
 | STEP 4B. Check the CM700 signal pin resistance. | Less than 100k ohm.
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that fault code is inactive. | Fault Code 135 is inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the engine oil pressure sensor (rifle).

Fault Code 227 active?
YES | NO
No Repair | No Repair

Refer to Sensor Supply Fault Code 227

Go to 2A

Guided Step 2 - Check the engine oil pressure sensor (rifle).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the engine oil pressure sensor (rifle).

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the engine oil pressure sensor (rifle), whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 (Danfoss (Circular DIN Series) Connector in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the engine oil pressure sensor (rifle). Refer to Procedure 019-066 (engine oil pressure sensor) in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect INSITE™ electronic service tool.

Action

Check the Engine Oil Pressure Sensor (Rifle) supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the engine oil pressure sensor breakout cable between the sensor and the harness connector
  • Connect INSITE™ electronic service tool.

Action

Check the Engine Oil Pressure Sensor (Rifle) signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

Repair

Replace the engine oil pressure sensor (rifle).

Refer to Procedure 019-066 (engine oil pressure sensor) in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the engine oil pressure sensor (rifle) and the CM700.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the engine oil pressure sensor (rifle)
  • Disconnect the engine harness from all sensors that have a shared supply or return with the engine oil pressure sensor (rifle).

Action

Inspect the engine harness and connector pins for the following:

  • Measure the resistance from the engine oil pressure sensor (rifle) supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine oil pressure sensor (rifle) return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine oil pressure sensor (rifle) signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the engine oil pressure sensor (rifle).

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the engine oil pressure sensor (rifle) return pin on the engine harness connector to the engine oil pressure sensor (rifle) return pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM700 response.

Guided Step 4A - Check for an appropriate CM700 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool
  • Disconnect the engine oil pressure sensor connector.

Action

Check for the appropriate CM700 response.

  • Use INSITE™ electronic service tool to verify the fault codes.

NOTE: Fault Code 141 will become active upon disconnecting the sensor.

Fault Code 135 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM700 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the 50-pin A Deutsch connector from the CM700
  • Disconnect the 50-pin B Deutsch connector from the CM700
  • Disconnect the 50-pin C Deutsch connector from the CM700.

Action

Check the CM700 signal pin resistance.

  • Measure the resistance from the engine oil pressure sensor (rifle) signal pin on the CM700 to CM700 sensor supply circuit number 2 return pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™electronic service tool to verify that Fault Code 135 is inactive.

Fault Code 135 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164752 - pressure sensor breakout cablePart Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 227 active?
STEP 2. | Check the engine oil pressure sensor (pre-filter). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault Code 136 is inactive?
 | STEP 4B. Check the CM700 signal pin resistance. | Less than 100k ohm?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 136 is inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the engine oil pressure sensor (pre-filter).

Fault Code 227 active?
YES | NO
No Repair | No Repair

Refer to Sensor Supply Fault Code 227

Go to 2A

Guided Step 2 - Check the engine oil pressure sensor (pre-filter).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the engine oil pressure sensor (pre-filter).

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the engine oil pressure sensor (pre-filter), whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 (Danfoss (Circular DIN Series) Connector in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the engine oil pressure sensor (pre-filter). Refer to Procedure 019-066 (Engine Oil Pressure Sensor) in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the engine oil pressure sensor (pre-filter)supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the engine oil pressure sensor (pre-filter) breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the engine oil pressure sensor (pre-filter) signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

Repair

Replace the engine oil pressure sensor (pre-filter).

Refer to Procedure 019-066 (Engine Oil Pressure Sensor) in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the engine oil pressure sensor (pre-filter) and the CM700.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the engine oil pressure sensor (pre-filter).
  • Disconnect the engine harness from all sensors that have a shared supply or return with the engine oil pressure sensor (pre-filter).

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the engine oil pressure sensor (pre-filter) supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine oil pressure sensor (pre-filter) return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine oil pressure sensor (pre-filter) signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the engine oil pressure sensor (pre-filter).

Action

Check for an open circuit in the harness.

  • Measure the resistance from the engine oil pressure sensor (pre-filter) return pin on the engine harness connector to the engine oil pressure sensor (pre-filter) return pin on the engine harness sensor connector.
  • Measure the resistance from the engine oil pressure sensor (pre-filter) signal pin on the engine harness connector to the engine oil pressure sensor (pre-filter) signal pin on the engine harness sensor connector.
  • Measure the resistance from the engine oil pressure sensor (pre-filter) supply pin on the engine harness connector to the engine oil pressure sensor (pre-filter) supply pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM700 response.

Guided Step 4A - Check for an appropriate CM700 response.

Conditions

  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine oil pressure sensor (pre-filter) connector.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM700 response.

  • Use INSITE™ electronic service tool to verify the fault codes.

NOTE: Fault Code 137 will become active upon disconnecting the sensor.

Fault Code 136 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM700 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the 50-pin A Deutsch™ connector from the CM700.
  • Disconnect the 50-pin B Deutsch™ connector from the CM700.
  • Disconnect the 50-pin C Deutsch™ connector from the CM700.

Action

Check the CM700 signal pin resistance.

  • Measure the resistance from the engine oil pressure sensor (pre-filter) signal pin on the CM700 to the CM700 sensor supply circuit number 2 pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 136 is inactive.

Fault Code 136 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164752 - pressure sensor breakout cablePart Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 187 active?
STEP 2. | Check the engine oil pressure sensor (pre-filter). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault Code 137 is inactive?
 | STEP 4B. Check the CM700 signal pin resistance. | Less than 100k ohm.
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 137 is inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the engine oil pressure sensor (pre-filter).

Fault Code 187 active?
YES | NO
No Repair | No Repair

Refer to Sensor Supply Fault Code 227

Go to 2A

Guided Step 2 - Check the engine oil pressure sensor (pre-filter).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the engine oil pressure sensor (pre-filter).

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the engine oil pressure sensor (pre-filter), whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 (Danfoss (Circular DIN Series) Connector in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the Engine Oil Pressure Sensor (Rifle). Refer to Procedure 019-066 (Engine Oil Pressure Sensor) in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the engine oil pressure sensor (pre-filter) supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the engine oil pressure sensor (pre-filter) breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the engine oil pressure sensor (pre-filter) signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

Repair

Replace the engine oil pressure sensor (pre-filter).

Refer to Procedure 019-066 (Engine Oil Pressure Sensor) in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the engine oil pressure sensor (pre-filter) and the CM700.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the engine oil pressure sensor (pre-filter).
  • Disconnect the engine harness from all sensors that have a shared supply or return with the engine oil pressure sensor (pre-filter).

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the engine oil pressure sensor (pre-filter) supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine oil pressure sensor (pre-filter) return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine oil pressure sensor (pre-filter) signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the engine oil pressure sensor (pre-filter).

Action

Check for an open circuit in the harness.

  • Measure the resistance from the engine oil pressure sensor (pre-filter) return pin on the engine harness connector to the engine oil pressure sensor (pre-filter) return pin on the engine harness sensor connector.
  • Measure the resistance from the engine oil pressure sensor (pre-filter) signal pin on the engine harness connector to the engine oil pressure sensor (pre-filter) signal pin on the engine harness sensor connector.
  • Measure the resistance from the engine oil pressure sensor (pre-filter) supply pin on the engine harness connector to the engine oil pressure sensor (pre-filter) supply pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM700 response.

Guided Step 4A - Check for an appropriate CM700 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine oil pressure sensor (pre-filter) connector
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM700 response.

  • Place a jumper wire between the engine oil pressure sensor (pre-filter) supply pin and the engine oil pressure sensor (pre-filter) signal pin of the sensor connector.
  • Check for the appropriate CM700 response after 30 seconds.
  • Read the fault codes using the electronic service tool.

NOTE: Fault Code 136 will become active upon installing the jumper.

Fault code 137 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM700 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the 50-pin A Deutsch™ connector from the CM700.
  • Disconnect the 50-pin B Deutsch™ connector from the CM700.
  • Disconnect the 50-pin C Deutsch™ connector from the CM700.

Action

Check the CM700 signal pin resistance.

  • Measure the resistance from the engine oil pressure sensor (pre-filter) signal pin on the CM700 to the CM700 sensor supply circuit number 2 return pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 136 is inactive.

Fault Code 137 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164752 - pressure sensor breakout cablePart Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 187 active?
STEP 2. | Check the engine oil pressure sensor (rifle). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault Code 141 is inactive?
 | STEP 4B. Check the CM700 signal pin resistance. | Less than 100k ohm.
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 141 is inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the engine oil pressure sensor (rifle).

Fault Code 227 active?
YES | NO
No Repair | No Repair

Refer to Sensor Supply Fault Code 227

Go to 2A

Guided Step 2 - Check the engine oil pressure sensor (rifle).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the engine oil pressure sensor (rifle).

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the Oil Pressure Sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 (Danfoss (Circular DIN Series) Connector in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the engine oil pressure sensor (rifle). Refer to Procedure 019-066 (Engine Oil Pressure Sensor) in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the engine oil pressure sensor (rifle)supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the engine oil pressure sensor (rifle) signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

Repair

Replace the engine oil pressure sensor (rifle).

Refer to Procedure 019-066 (Engine Oil Pressure Sensor) in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the engine oil pressure sensor (rifle) and the CM700.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the engine oil pressure sensor (rifle).
  • Disconnect the engine harness from all sensors that have a shared supply or return with the engine oil pressure sensor (rifle).

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the engine oil pressure sensor (rifle) supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine oil pressure sensor (rifle) return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine oil pressure sensor (rifle) signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the engine oil pressure sensor (rifle).

Action

Check for an open circuit in the harness.

  • Measure the resistance from the engine oil pressure sensor (rifle) return pin on the engine harness connector to the engine oil pressure sensor (rifle) return pin on the engine harness sensor connector.
  • Measure the resistance from the engine oil pressure sensor (rifle) signal pin on the engine harness connector to the engine oil pressure sensor (rifle) signal pin on the engine harness sensor connector.
  • Measure the resistance from the engine oil pressure sensor (rifle) supply pin on the engine harness connector to the engine oil pressure sensor (rifle) supply pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM700 response.

Guided Step 4A - Check for an appropriate CM700 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine oil pressure sensor (rifle) connector
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM700 response.

  • Place a jumper wire between the engine oil pressure sensor (rifle) supply pin and the engine oil pressure sensor (rifle) signal pin of the sensor connector.
  • Check for the appropriate CM700 response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Fault Code 135 will become active upon installing the jumper.

Fault code 141 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM700 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the 50-pin A Deutsch™ connector from the CM700.
  • Disconnect the 50-pin B Deutsch™ connector from the CM700.
  • Disconnect the 50-pin C Deutsch™ connector from the CM700.

Action

Check the CM700 signal pin resistance.

  • Measure the resistance from the engine oil pressure sensor (rifle) signal pin on the CM700 to the CM700 sensor supply circuit number 2 return pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 141 is inactive.

Fault Code 141 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 135 or 141 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 135 or 141 active?
YES NO
No Repair

Repair

Reference the Lubricating Oil Pressure High symptom tree in the Troubleshooting and Repair Manual QSK60G Generator CM700, Bulletin 4021396.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Jun-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 135 or 141 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 135 or 141 active?
YES NO
No Repair

Repair

Reference the Lubricating Oil Pressure Low symptom tree in the Troubleshooting and Repair Manual QSK60G Generator CM700, Bulletin 4021396.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Jun-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the engine coolant temperature sensor (high temperature). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault Code 144 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 144 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the engine coolant temperature sensor (high temperature).

Other fault codes active?
YES | NO
No Repair | No Repair

Refer to appropriate fault codes.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor (high temperature).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the engine coolant temperature sensor (high temperature).

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the engine coolant temperature sensor (high temperature), whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-202 (Metripack Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the engine coolant temperature sensor (high temperature). Refer to Procedure 019-019 (Engine Coolant Temperature Sensor) in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the engine coolant temperature sensor (high temperature).

Action

Check the resistance of the engine coolant temperature sensor (high temperature).

  • Measure the resistance between the engine coolant temperature sensor (high temperature) signal pin and the engine coolant temperature sensor (high temperature) return pin.

600 ohms to 36k ohms?
YES NO
No Repair

Repair

Replace the engine coolant temperature sensor (high temperature). Refer to Procedure 019-019 (Engine Coolant Temperature Sensor) in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the engine coolant temperature sensor (high temperature).

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the engine coolant temperature sensor (high temperature) connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the engine coolant temperature sensor (high temperature). Refer to Procedure 019-019 (Engine Coolant Temperature Sensor) in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the engine coolant temperature sensor (high temperature) and the CM700.

Action

Inspect the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the engine coolant temperature sensor (high temperature).
  • Disconnect the engine harness from the CM700.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the engine coolant temperature sensor (high temperature) return pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant temperature sensor (high temperature) signal pin in the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect engine harness from engine coolant temperature sensor (high temperature).
  • Disconnect engine harness from the CM700.

Action

Check for a short circuit to ground in the signal and return wires.

  • Measure the resistance from the engine coolant temperature sensor (high temperature) signal pin in the engine harness connector to the engine block ground.
  • Measure the resistance from the engine coolant temperature sensor (high temperature) return pin in the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the CM700
  • Disconnect the engine harness connector from the engine coolant temperature sensor (high temperature).

Action

Check for an open circuit.

  • Measure the resistance from the signal pin in the engine coolant temperature sensor (high temperature) connector to the sensor signal pin in the CM700.
  • Measure the resistance from the return pin in the engine coolant temperature sensor (high temperature) connector to the return pin in the CM700.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM700 response.

Guided Step 4A - Check for the appropriate CM700 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the engine coolant temperature sensor (high temperature).
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM700 response.

  • Place a jumper wire between the engine coolant temperature sensor (high temperature) signal pin and the engine coolant temperature sensor (high temperature) return pin of the sensor connector.
  • Check for the appropriate CM700 response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Fault Code 145 will become active upon disconnecting the sensor.

Fault Code 144 inactive?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Facility.

Go to 5A

Repair complete.

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 144 is inactive.

Fault Code 144 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Facility if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

WARNING

Do not remove the radiator pressure cap from a hot engine. Wait until the coolant temperature is below 50°C [120°F] before removing the radiator pressure cap. Heated coolant spray or steam can cause personal injury.
CAUTION

To reduce the possibility of damaging a new ECM, all other fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the engine coolant temperature sensor (high temperature). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault Code 145 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 145 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the engine coolant temperature sensor.

Other fault codes active?
YES | NO
No Repair | No Repair

Refer to appropriate fault codes.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor (high temperature).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the engine coolant temperature sensor (high temperature).

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the engine coolant temperature sensor (high temperature), whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-202 (Metripack Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the engine coolant temperature sensor (high temperature). Refer to Procedure 019-019 (Engine Coolant Temperature Sensor) in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the engine coolant temperature sensor (high temperature).

Action

Check the resistance of the engine coolant temperature sensor (high temperature).

  • Measure the resistance between the coolant temperature signal pin and the coolant temperature return pin.

600 ohms to 36k ohms?
YES NO
No Repair

Repair

Replace the engine coolant temperature sensor (high temperature). Refer to Procedure 019-019 (Engine Coolant Temperature Sensor) in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the engine coolant temperature sensor (high temperature).

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the engine coolant temperature sensor (high temperature) connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the engine coolant temperature sensor (high temperature). Refer to Procedure 019-019 (Engine Coolant Temperature Sensor) in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the engine coolant temperature sensor (high temperature) and the CM700.

Action

Inspect the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the engine coolant temperature sensor (high temperature)
  • Disconnect the engine harness from the CM700.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the engine coolant temperature sensor (high temperature) return pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant temperature sensor (high temperature) signal pin in the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect engine harness from engine coolant temperature sensor (high temperature).
  • Disconnect engine harness from the CM700.

Action

Check for a short circuit to ground in the signal and return wires.

  • Measure the resistance from the engine coolant temperature sensor (high temperature) signal pin in the engine harness connector to the engine block ground.
  • Measure the resistance from the engine coolant temperature sensor (high temperature) return pin in the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the CM700
  • Disconnect the engine harness connector from the engine coolant temperature sensor (high temperature).

Action

Check for an open circuit.

  • Measure the resistance from the signal pin in the engine coolant temperature sensor (high temperature) connector to the sensor signal pin in the CM700.
  • Measure the resistance from the return pin in the engine coolant temperature sensor (high temperature) connector to the return pin in the CM700.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM700 response.

Guided Step 4A - Check for the appropriate CM700 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the engine coolant temperature sensor (high temperature).
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM700 response.

  • Use INSITE™ electronic service tool to verify the fault codes.

NOTE: Fault Code 144 will become active upon disconnecting the sensor.

Fault Code 145 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 145 is inactive.

Fault Code 145 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 144 or 145 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 144 or 145 active?
YES NO
No Repair

Repair

Refer to the Coolant Temperature Above Normal symptom tree in this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the Intake Manifold Temperature Sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for a short circuit to the engine block ground. | More than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 153 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 153 inactive?
 | STEP 5B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Read the fault codes using the electronic service tool
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the Intake Manifold Temperature Sensor.

Other fault codes active?
YES | NO
No Repair | No Repair

Refer to appropriate fault code

Go to 2A

Guided Step 2 - Check the Intake Manifold Temperature Sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Intake Manifold Temperature Sensor.

Action

Inspect the harness and sensor connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the engine harness or the Intake Manifold Temperature Sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Intake Manifold Temperature Sensor. Refer to Procedure 019-059.

Go to 2B

5A

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Intake Manifold Temperature Sensor.

Action

Check the resistance of the Intake Manifold Temperature Sensor.

  • Measure the resistance between the intake manifold temperature signal pin and the intake manifold temperature return pin.

600 ohms to 36k ohms?
YES NO
No Repair

Repair

Replace the Intake Manifold Temperature Sensor. Refer to Procedure 019-059.

Go to 3A

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Intake Manifold Temperature Sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the Intake Manifold Temperature Sensor connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the Intake Manifold Temperature Sensor. Refer to Procedure 019-059.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Intake Manifold Temperature Sensor and the CM558.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram in Section E to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair or replace the engine harness or the extension harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the CM558
  • Disconnect the engine harness from the Intake Manifold Temperature Sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the intake manifold temperature return pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold temperature signal pin in the engine harness connector to all other pins in the engine harness connector.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Intake Manifold Temperature Sensor
  • Disconnect the engine harness from the CM558.

Action

Check for a short circuit to ground in the signal and return wires

  • Measure the resistance from the intake manifold temperature signal pin on the engine harness connector to the engine block ground.
  • Measure the resistance from the intake manifold temperature return pin on the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram in Section E to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Intake Manifold Temperature Sensor
  • Disconnect the engine harness from the CM558.

Action

Check for an open circuit.

  • Measure the resistance from the signal pin on the Intake Manifold Temperature Sensor connector to the sensor signal pin on the CM558.
  • Measure the resistance from the return pin on the Intake Manifold Temperature Sensor connector to the return signal pin on the CM558.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram in Section E to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM558 response.

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch is Stop mode
  • Disconnect the engine harness from the Intake Manifold Temperature Sensor
  • Connect the electronic service tool.

Action

Check for appropriate CM558 response.

  • Place a jumper wire between the intake manifold temperature signal pin and the intake manifold temperature return pin of the sensor connector.
  • Check for the appropriate CM558 response after 30 seconds.
  • Read the fault codes using the electronic service tool.

NOTE: Fault Code 154 will become active upon installing the jumper.

Fault Code 153 inactive?
YES NO
No Repair

Repair

Contact the nearest Cummins Authorized Repair Location.

Go to 5A

Repair complete

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify Fault Code 153 is inactive.

Fault Code 153 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes are active?
STEP 2. | Check the Intake Manifold Temperature Sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for a short circuit to the engine block ground. | More than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 154 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 154 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Read the fault codes using the electronic service tool
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the Intake Manifold Temperature Sensor.

Other fault codes are active?
YES | NO
No Repair | No Repair

Refer to appropriate fault code

Go to 2A

Guided Step 2 - Check the Intake Manifold Temperature Sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Intake Manifold Temperature Sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Corroded pins
  • Bent or broke pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the Intake Manifold Temperature Sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-202.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Intake Manifold Temperature Sensor. Refer to Procedure 019-059.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Intake Manifold Temperature Sensor.

Action

Check the resistance of the Intake Manifold Temperature Sensor.

  • Measure the resistance between the intake manifold temperature signal pin and the intake manifold temperature return pin.

600 ohms to 36k ohms?
YES NO
No Repair

Repair

Replace the Intake Manifold Temperature Sensor. Refer to Procedure 019-059.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Intake Manifold Temperature Sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the Intake Manifold Temperature Sensor connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the Intake Manifold Temperature Sensor. Refer to Procedure 019-059.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Intake Manifold Temperature Sensor and the CM558.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram in Section E to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair or replace the engine harness or the extension harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the CM558
  • Disconnect the engine harness from the Intake Manifold Temperature Sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the intake manifold temperature return pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold temperature signal pin in the engine harness connector to all other pins in the engine harness connector.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Intake Manifold Temperature Sensor
  • Disconnect the engine harness from the CM558.

Action

Check for a short circuit to ground in the signal and return wires

  • Measure the resistance from the intake manifold temperature signal pin on the engine harness connector to the engine block ground.
  • Measure the resistance from the intake manifold temperature return pin on the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram in Section E to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Intake Manifold Temperature Sensor
  • Disconnect the engine harness from the CM558.

Action

Check for an open circuit.

  • Measure the resistance from the signal pin on the Intake Manifold Temperature Sensor connector to the sensor signal pin on the CM558.
  • Measure the resistance from the return pin on the Intake Manifold Temperature Sensor connector to the return pin on the CM558.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram in Section E to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM558 response.

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Intake Manifold Temperature Sensor
  • Connect the electronic service tool.

Action

Check for the appropriate CM558 response.

  • Using the electronic service tool, verify the fault codes.

NOTE: Fault Code 153 will become active upon disconnecting the sensor.

Fault Code 154 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 154 is inactive.

Fault Code 154 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear any inactive fault codes.

  • Using the electronic service tool, clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 153 or 154 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 153 or 154 active?
YES NO
No Repair

Repair

Refer to the Intake Manifold Temperature Above Specification symptom tree in this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 441, 442, 477 or 478 active?
STEP 2. | Check the throttle driver. |
 | STEP 2A. Inspect the throttle driver and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the throttle driver supply voltage. | 24-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit for pin to pin. | More than 100k ohms?
STEP 4. | Check the throttle driver. |
 | STEP 4A. Check the throttle driver commanded position signal current. | More than 20 mA?
 | STEP 4B. Check for the appropriate CM558 response. | Fault Code 175 is inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that fault code is inactive. | Fault code 175 is inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441, 442, 477 or 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting step

Go to 2A

Guided Step 2 - Check the throttle driver.

Guided Step 2A - Inspect the throttle driver and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connectors from the throttle driver.

Action

Inspect the throttle driver and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the throttle driver, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 (Danfoss (Circular DIN Series) Connector) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the throttle driver. Refer to Procedure 019-429 (Throttle Driver) in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the throttle driver supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the throttle driver power connection
  • Connect INSITE™ electronic service tool.

Action

Check the throttle driver supply voltage.

Use a multimeter to measure the throttle supply voltage.

24-VDC?
YES NO
No Repair

Repair

Check the power supply connections and the fuses in the harness. Refer to the engine wiring diagram for the appropriate circuit.

Go to 2C

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connectors from the throttle driver and the CM558.

Action

Inspect the throttle driver and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the throttle driver, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit for pin to pin.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the throttle driver.

Action

Check for a short circuit for pin to pin.

  • Measure the resistance from the throttle driver return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the throttle driver signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Preform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the throttle driver.

Guided Step 4A - Check the throttle driver commanded position signal current.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the throttle driver commanded position connection
  • Connect INSITE™ electronic service tool.

Action

Check the throttle driver commanded position signal

  • Connect an ammeter in series with the commanded position signal wire
  • Use a jumper wire to connect the return connection.

More than 20 mA?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 5A

Guided Step 4B - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the throttle driver commanded position connector
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Use INSITE™ electronic service tool to verify the fault codes.
  • Fault Code 176 will become active upon disconnecting the throttle driver commanded position connector.

Fault Code 175 is inactive?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Run mode and running for longer than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 175 is inactive.

Fault Code 175 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 441, 442, 477 or 478 active?
STEP 2. | Check the throttle driver. |
 | STEP 2A. Inspect the throttle driver and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the throttle driver supply voltage. | 24-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit for pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the throttle driver. |
 | STEP 4A. Check the throttle driver commanded position signal current. | Less than 4 mA?
 | STEP 4B. Check for the appropriate CM558 response. | Fault Code 176 is inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that fault code is inactive. | Fault code 176 is inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441, 442, 477 or 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the throttle driver.

Guided Step 2A - Inspect the throttle driver and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connectors from the throttle driver.

Action

Inspect the throttle driver and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the throttle driver, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 (Danfoss (Circular DIN Series) Connector) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the throttle driver. Refer to Procedure 019-429 (Throttle Driver) in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the throttle driver supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the throttle driver power connection
  • Connect INSITE™ electronic service tool.

Action

Check the throttle driver supply voltage.

Use a multimeter to measure the throttle supply voltage.

24-VDC?
YES NO
No Repair

Repair

Check the power supply connections and the fuses in the harness. Refer to the engine wiring diagram for the appropriate circuit.

Go to 2C

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connectors from the throttle driver and the CM558.

Action

Inspect the throttle driver and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the throttle driver, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit for pin to pin.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the throttle driver.

Action

Check for a short circuit for pin to pin.

  • Measure the resistance from the throttle driver return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the throttle driver signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the throttle driver commanded position connector.

Action

Check for a short circuit for pin to pin.

  • Measure the resistance from the throttle driver commanded position return pin on the engine harness connector to the throttle driver commanded position return pin on the throttle driver commanded position connector.
  • Measure the resistance from the throttle driver commanded position signal pin on the engine harness connector to the throttle driver commanded position signal pin on the throttle driver commanded position connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the throttle driver.

Guided Step 4A - Check the throttle driver commanded position signal current.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the throttle driver commanded position connection
  • Connect INSITE™ electronic service tool.

Action

Check the throttle driver commanded position signal.

  • Connect an ammeter in series with the commanded position signal wire.
  • Use a jumper wire to connect the return connection.

Less than 4 mA?
YES NO

Repair

Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 4B

Go to 5A

Guided Step 4B - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Run mode and engine running at rated speed and load
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Use INSITE™ electronic service tool to verify the fault codes.

Fault Code 176 is inactive?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Run mode and running for longer than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 176 is inactive.

Fault Code 176 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 30-Jun-2010


FAULT CODE 177 - Multiple Turbocharger Integrated Throttle - Electronic Throttle Control Actuator – Mechanical System is Not Responding or Out of Adjustment

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 175, 176, 512, and 513 active?
STEP 2. | Check the throttle plate for free movement. |
 | STEP 2A. Check the throttle assembly for commanded position signal and feedback position signal for excessive deviation. | Throttle assembly commanded position signal and feedback position signal exceeds 30 percent deviation limit?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the throttle for free movement. |
 | STEP 4A. Check the throttle for free movement. | Throttle shaft moves freely?
 | STEP 4B. Inspect the throttle plate for misalignment or damage. | Throttle plate misaligned or damaged?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 177 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 175, 176, 512, and 513 active?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 5A

Guided Step 2 - Check the throttle plate for free movement.

Guided Step 2A - Check the throttle assembly for commanded position signal and feedback position signal for excessive deviation.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Connect INSITE™ electronic service tool.

Action

Check the throttle assembly for commanded signal position signal and feedback position signal for excessive deviation (greater than 30 percent deviation).

  • Use INSITE™ electronic service tool to electronically test the throttle plate for free movement.
  • Use the actuator diagnostics tests within the ECM diagnostics tests feature to perform this test.
  • Contact a Cummins® Authorized Repair Location.

Throttle assembly commanded position signal and feedback position signal exceeds 30 percent deviation limit?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the throttle assembly, CM558 left and right bank modules, and the CM700 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins. Repair or replace the engine harness or the harness connector.

Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.

Install the appropriate connector seal if it is damaged or missing.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the throttle assembly, CM558 left and right bank modules, and the CM700 module.

Action

Check for a short circuit from pin to pin:

  • Measure the resistance from the proprietary data link SIGNAL pin in the CM700 connector to all other pins in the engine harness. Refer to Procedure 019-417 in Section 19.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Repair the wiring harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the throttle assembly, CM558 left and right bank modules, and the CM700 module.

Action

Check for an open circuit.

  • Measure the resistance from the proprietary data link SIGNAL pin in the throttle assembly driver connector (C27) to the proprietary data link SIGNAL pin in the CM700 module connector.
  • Measure the resistance from the proprietary data link RETURN pin in the throttle assembly driver connector (C27) to the proprietary data link RETURN pin in the CM700 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins. Refer to Procedure 019-417 in Section 19.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the throttle for free movement.

Guided Step 4A - Check the throttle shaft for free movement.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the throttle assembly.

Action

Check the throttle shaft for free movement.

Carry out the following procedures:

  • Remove the throttle assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396.Refer to Procedure 005-052 in Section 5.
  • Rotate the shaft from the fully closed to fully open position. Check for smooth movement through the full range.
  • Check for any tight spots during the rotation of the shaft.
  • Check the throttle shaft bearings for excessive free-play.
  • Contact a Cummins® Authorized Repair Location.

Throttle shaft moves freely?

YES NO
No Repair

Repair

Replace the throttle actuator assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396.Refer to Procedure 005-052 in Section 5.

Contact your Cummins® Authorized Repair Location.

Go to 4B

Go to 5A

Guided Step 4B - Inspect the throttle plate for misalignment or damage.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the throttle assembly.

Action

Inspect the throttle plate for misalignment or damage:

  • Remove the throttle assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 005-052 in Section 5.
  • Inspect the throttle plate for misalignment. This will be indicated by loss of clearance between the throttle plate and throttle body on one edge. Misalignment may indicate a bent throttle shaft.
  • Inspect the throttle plate for damage.
  • Contact a Cummins® Authorized Repair Location.

Throttle plate misaligned or damaged?

YES NO

Repair

Replace the throttle actuator assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 005-052 in Section 5.

Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode.
  • Operate the engine for greater than 1 minute.

Action

Verify the fault code is inactive.

Use INSITE™ electronic service tool to verify Fault Code 177 is inactive.

Fault Code 177 inactive?
YES NO
No Repair

Repair

Return to the troublshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 02-Aug-2010


FAULT CODE 177 - Multiple Turbocharger Two-Piece Throttle - Electronic Throttle Control Actuator – Mechanical System is Not Responding or Out of Adjustment

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 175, 176, 512, and 513 active?
STEP 2. | Check the throttle plate for free movement. |
 | STEP 2A. Check the throttle driver for commanded position SIGNAL and feedback position SIGNAL for excessive deviation. | Throttle driver commanded position SIGNAL and feedback position SIGNAL exceeds 30 percent deviation limit?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the throttle for free movement. |
 | STEP 4A. Check the throttle shaft for free movement. | Throttle shaft moves freely?
 | STEP 4B. Inspect the throttle plate for misalignment or damage. | Throttle plate misaligned or damaged?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 177 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 175, 176, 512, and 513 active?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 5A

Go to 2A

Guided Step 2 - Check the throttle plate for free movement.

Guided Step 2A - Check the throttle driver for commanded position SIGNAL and feedback position SIGNAL for excessive deviation.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Connect INSITE™ electronic service tool.

Action

Check the throttle driver for commanded signal position signal and feedback position signal for excessive deviation (greater than 30 percent deviation).

  • Use INSITE™ electronic service tool to electronically test the throttle plate for free movement. Use the actuator diagnostics tests within the ECM diagnostics tests feature to perform this test.
  • Contact a Cummins® Authorized Repair Location.

Throttle driver commanded position SIGNAL and feedback position SIGNAL exceeds 30 percent deviation limit?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the throttle driver and throttle actuator.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins. Repair or replace the engine harness or the harness connector.

Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.

Install the appropriate connector seal if it is damaged or missing.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the throttle driver and throttle actuator.

Action

Check for a short circuit from pin to pin:

  • Measure the resistance from the throttle position feedback SUPPLY pin to all other pins in the engine harness.
  • Measure the resistance from the throttle control driver SIGNAL pin to all other pins in the engine harness.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Repair the wiring harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the throttle driver and throttle actuator.

Action

Check for an open circuit.

  • Measure the resistance from the throttle control driver SIGNAL pin in the throttle driver connector (J2) to the throttle control driver SIGNAL pin in the throttle actuator connector.
  • Measure the resistance from the throttle control driver RETURN pin in the throttle driver connector (J2) to the throttle control driver RETURN pin in the throttle actuator connector.
  • Measure the resistance from the throttle position feedback SUPPLY pin in the throttle driver connector (J2) to the throttle position feedback SUPPLY pin in the throttle actuator connector.
  • Measure the resistance from the throttle position feedback SIGNAL pin in the throttle driver connector (J2) to the throttle position feedback SIGNAL pin in the throttle actuator connector.
  • Measure the resistance from the throttle position feedback RETURN pin in the throttle driver connector (J2) to the throttle position feedback RETURN pin in the throttle actuator connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Repair the wiring harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the throttle for free movement.

Guided Step 4A - Check the throttle shaft for free movement.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the throttle driver and throttle actuator.

Action

Check the throttle shaft for free movement.

Carry out the following procedures:

  • Remove the throttle assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396.
  • Refer to Procedure 005-052 in Section 5.
  • Rotate the shaft from the fully closed to fully open position. Check for smooth movement through the full range.
  • Check for any tight spots during the rotation of the shaft.
  • Check the throttle shaft bearings for excessive free-play.
  • Contact a Cummins® Authorized Repair Location.

Throttle shaft moves freely?

YES NO
No Repair

Repair

Replace the throttle actuator assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396.Refer to Procedure 005-052 in Section 5.

Contact a Cummins®Authorized Repair Location.

Go to 4B

Go to 5A

Guided Step 4B - Inspect the throttle plate for misalignment or damage.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the throttle actuator.

Action

Inspect the throttle plate for misalignment or damage:

  • Remove the throttle assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 005-052 in Section 5.
  • Inspect the throttle plate for misalignment. This will be indicated by loss of clearance between the throttle plate and throttle body on one edge. Misalignment may indicate a bent throttle shaft. Inspect the throttle plate for damage.
  • Contact a Cummins® Authorized Repair Location.

Throttle plate misaligned or damaged?

YES NO

Repair

Replace the throttle actuator assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396.Refer to Procedure 005-052 in Section 5.

Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode.
  • Operate the engine for greater than 1 minute.

Action

Verify the fault code is inactive.

Use INSITE™ electronic service tool to verify Fault Code 177 is inactive.

Fault Code 177 is inactive?
YES NO
No Repair

Repair

Retrun to the troublshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-Aug-2010


FAULT CODE 177 - Single Turbocharger Integrated Throttle - Electronic Throttle Control Actuator - Mechanical System is Not Responding or Out of Adjustment

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 175, 176, 512 and 513 active?
STEP 2. | Check the throttle plate for free movement. |
 | STEP 2A. Check the throttle assembly for commanded position signal and feedback position signal for excessive deviation. | Throttle assembly commanded position signal and feedback position signal exceeds 30 percent deviation limit?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the throttle for free movement. |
 | STEP 4A. Check the throttle shaft for free movement. | Throttle shaft moves freely?
 | STEP 4B. Inspect the throttle plate for misalignment or damage. | Throttle plate misaligned or damaged?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Clear the inactive fault codes. | All fault codes cleared?
 | STEP 5B. Verify the fault code is inactive. | Fault Code 177 inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 175, 176, 512, and 513 active?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 5A

Go to 2A

Guided Step 2 - Check the throttle plate for free movement.

Guided Step 2A - Check the throttle assembly for commanded position signal and feedback position signal for excessive deviation.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Connect INSITE™ electronic service tool.

Action

Check the throttle assembly for commanded signal position signal and feedback position signal for excessive deviation (greater than 30 percent deviation).

  • Use INSITE™ electronic service tool to electronically test the throttle plate for free movement.
  • Use the actuator diagnostics tests within the ECM diagnostics tests feature to perform this test.
  • Contact a Cummins® Authorized Repair Location.

Throttle assembly commanded position signal and feedback position signal exceeds 30 percent deviation limit?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the throttle assembly, CM558 left and right bank modules, and the CM700 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins. Repair or replace the engine harness or the harness connector.

Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.

Install the appropriate connector seal if it is damaged or missing.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the throttle assembly, CM558 left and right bank modules, and the CM700 module.

Action

Check for a short circuit from pin to pin:

  • Measure the resistance from the proprietary data link SIGNAL pin in the CM700 connector to all other pins in the engine harness. Refer to Procedure 019-417 in Section 19.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to Procedure 019-417 in Section 19.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Repair the wiring harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the throttle assembly, CM558 left and right bank modules, and the CM700 module.

Action

Check for an open circuit.

  • Measure the resistance from the proprietary data link SIGNAL pin in the throttle assembly driver connector (C27) to the proprietary data link SIGNAL pin in the CM700 module connector.
  • Measure the resistance from the proprietary data link RETURN pin in the throttle assembly driver connector (C27) to the proprietary data link RETURN pin in the CM700 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.Refer to Procedure 019-417 in Section 19.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Repair the wiring harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the throttle for free movement.

Guided Step 4A - Check the throttle for free movement.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the throttle assembly.

Action

Check the throttle shaft for free movement.

Carry out the following procedures:

  • Remove the throttle assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396.Refer to Procedure 005-052 in Section 5.
  • Rotate the shaft from the fully closed to fully open position. Check for smooth movement through the full range.
  • Check for any tight spots during the rotation of the shaft.
  • Check the throttle shaft bearings for excessive free-play.
  • Contact a Cummins® Authorized Repair Location.

Throttle shaft moves freely?

YES NO
No Repair

Repair

Replace the throttle actuator assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 005-052 in Section 5.

Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 5A

Guided Step 4B - Inspect the throttle plate for misalignment or damage.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the throttle assembly.

Action

Inspect the throttle plate for misalignment or damage:

  • Remove the throttle assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396.Refer to Procedure 005-052 in Section 5.
  • Inspect the throttle plate for misalignment. This will be indicated by loss of clearance between the throttle plate and throttle body on one edge. Misalignment may indicate a bent throttle shaft.
  • Inspect the throttle plate for damage.
  • Contact a Cummins® Authorized Repair Location.

Throttle plate misaligned or damaged?

YES NO

Repair

Replace the throttle actuator assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 005-052 in Section 5.

Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTOswitch in the RUN mode.

Action

Verify the fault code is inactive.

Operate the engine for greater than 1 minute.

Use INSITE™ electronic service tool to verify Fault Code 177 is inactive.

Fault Code 177 is inactive?
YES NO
No Repair

Repair

Return to the troublshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTOswitch in the STOP mode.

Action

Clear the inactive fault codes.

Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 02-Aug-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 187 and other fault codes active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the wiring harness connector pins. | Damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 2D. Check the circuit response. | Fault Code 187 active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify that the fault code is inactive. | Fault Code 187 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing sensor supply circuit number 2.

Fault Code 187 and other fault codes active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 (Inactive or Intermittent Fault Code) in Section 19.

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the wiring harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from all the sensors that share sensor supply circuit number 2.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the sensor supply circuit number 2 positive (+) 5-VDC pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and Wiring Diagram) in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from all the sensors that share sensor supply circuit number 2.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the sensor supply pin on the engine harness connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and Wiring Diagram) in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the circuit response.

Conditions

  • De-energize the keyswitch circuit
  • Disconnect the engine harness from the ECM
  • Energize the keyswitch circuit
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO

Repair

Contact a Cummins® Authorized Repair Location.

 No Repair

Repair complete

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify that the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 187 is inactive.

Fault Code 187 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


FAULT CODE 197 - Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the active fault codes. |
 | STEP 1A. Check the active fault codes. | Fault Code 197 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Verify the fault code is inactive. | Fault Code 197 inactive?
 | STEP 2B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 197 active?
YES NO

Repair

Reference Section TS in the QSK60G CM700 Generator Troubleshooting and Repair Manual, Bulletin 4021396, for the Coolant Loss, External and Coolant Loss, Internal symptom troubleshooting trees.

If Fault Code 197 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. Refer to the OEM service manual before replacing the coolant level sensor.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes

Guided Step 2A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and operate engine for greater than 1 minute.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 197 is inactive.

Fault Code 197 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes

Repair complete

Appropriate troubleshooting chart.

Last Modified: 17-Oct-2011


FAULT CODE 212 - Engine Oil Temperature Sensor Circuit - Shorted High

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the engine oil temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3C. Check for a short circuit to the engine block ground. | More than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault Code 212 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 212 inactive?
 | STEP 5B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the engine specific wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the engine oil temperature sensor.

Other fault codes active?
YES | NO
No Repair | No Repair

Refer to appropriate fault code

Go to 2A

Guided Step 2 - Check the engine oil temperature sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine oil temperature sensor.

Action

Inspect the harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged pins?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the engine harness or the engine oil temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine oil temperature sensor. Refer to Procedure 019-067 in Section 19.

Go to 2B

5A

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • De-energized keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine oil temperature sensor.

Action

Check the resistance of the engine oil temperature sensor.

  • Measure the resistance between the engine oil temperature SIGNAL pin and the engine oil temperature RETURN pin.

600 ohms to 36k ohms?
YES NO
No Repair

Repair

Replace the engine oil temperature sensor. Refer to Procedure 019-067 in Section 19.

Go to 3A

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine oil temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the engine oil temperature sensor connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the engine oil temperature sensor. Refer to Procedure 019-067 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine oil temperature sensor and the CM700.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged pins?
YES NO

Repair

Repair or replace the engine harness or the extension harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700.
  • Disconnect the engine harness from the engine oil temperature sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the engine oil temperature RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine oil temperature SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine oil temperature sensor.
  • Disconnect the engine harness from the CM700.

Action

Check for a short circuit to ground in the SIGNAL and RETURN wires

  • Measure the resistance from the engine oil temperature SIGNAL pin on the engine harness connector to the engine block ground.
  • Measure the resistance from the engine oil temperature RETURN pin on the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine oil temperature sensor.
  • Disconnect the engine harness from the CM700.

Action

Check for an open circuit.

  • Measure the resistance from the SIGNAL pin on the engine oil temperature sensor connector to the sensor SIGNAL pin on the CM700.
  • Measure the resistance from the RETURN pin on the engine oil temperature sensor connector to the RETURN SIGNAL pin on the CM700.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM700 response.

Guided Step 4A - Check for the appropriate CM700 response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch is STOP mode.
  • Disconnect the engine harness from the engine oil temperature sensor.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate CM700 response.

  • Place a jumper wire between the engine oil temperature SIGNAL pin and the engine oil temperature RETURN pin of the sensor connector.
  • Check for the appropriate CM700 response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Fault Code 213 will become active upon installing the jumper.

Fault Code 212 inactive?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Repair complete

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and running for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 212 is inactive.

Fault Code 212 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 04-May-2012


FAULT CODE 213 - Engine Oil Temperature Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes are active?
STEP 2. | Check the engine oil temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3C. Check for a short circuit to the engine block ground. | More than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault Code 213 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 213 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the engine oil temperature sensor.

Other fault codes are active?
YES | NO
No Repair | No Repair

Refer to appropriate fault code

Go to 2A

Guided Step 2 - Check the engine oil temperature sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine oil temperature sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or replace the engine oil temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine oil temperature sensor. Refer to Procedure 019-067 in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine oil temperature sensor.

Action

Check the resistance of the engine oil temperature sensor.

  • Measure the resistance between the engine oil temperature SIGNAL pin and the engine oil temperature RETURN pin.

600 ohms to 36k ohms?
YES NO
No Repair

Repair

Replace the engine oil temperature sensor. Refer to Procedure 019-067 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine oil temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the engine oil temperature sensor connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the engine oil temperature sensor. Refer to Procedure 019-067 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine oil temperature sensor and the CM700.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

  • Loose connector

Damaged pins?
YES NO

Repair

Repair or replace the engine harness or the extension harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700.
  • Disconnect the engine harness from the engine oil temperature sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the engine oil temperature RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine oil temperature SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine oil temperature sensor.
  • Disconnect the engine harness from the CM700.

Action

Check for a short circuit to ground in the SIGNAL and RETURN wires

  • Measure the resistance from the engine oil temperature SIGNAL pin on the engine harness connector to the engine block ground.
  • Measure the resistance from the engine oil temperature RETURN pin on the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine oil temperature sensor.
  • Disconnect the engine harness from the CM700.

Action

Check for an open circuit.

  • Measure the resistance from the SIGNAL pin on the engine oil temperature sensor connector to the sensor SIGNAL pin on the CM700.
  • Measure the resistance from the RETURN pin on the engine oil temperature sensor connector to the RETURN pin on the CM700.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM700 response.

Guided Step 4A - Check for the appropriate CM700 response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the engine oil temperature sensor.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM700 response.

  • Use INSITE™ the electronic service tool to verify the fault codes.

NOTE: Fault Code 212 will become active upon disconnecting the sensor.

Fault Code 213 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in Run mode and running for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 213 is inactive.

Fault Code 213 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear any inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 04-May-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 212 or 213 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 212 or 213 active?
YES NO
No Repair

Repair

Refer to the Lubricating Oil Temperature Above Specification symptom tree in this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 227 and other fault codes active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the wiring harness connector pins. | Damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 2C. Check the circuit response. | Fault Code 227 is active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify that the fault code is inactive. | Fault Code 227 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing sensor supply circuit number 2.

Fault Code 227 and other fault codes active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 (Inactive or Intermittent Fault Code) in Section 19.

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the wiring harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from all the sensors that share sensor supply circuit number 2.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the sensor supply circuit number 2 positive (+) 5-VDC pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and Wiring Diagram) in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • De-energize the keyswitch circuit
  • Disconnect the engine harness from the ECM
  • Energize the keyswitch circuit
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 is active?
YES NO

Repair

Contact a Cummins® Authorized Repair Location.

 No Repair

Repair complete

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify that the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 227 is inactive.

Fault Code 227 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 231 or 232 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 231 or 232 active?
YES NO
No Repair

Repair

Refer to the Coolant Pressure Low symptom tree in this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164752 - pressure sensor breakout cablePart Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 386 active?
STEP 2. | Check the engine coolant pressure sensor circuit (high temperature). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault code 231 is inactive?
 | STEP 4B. Check the CM700 signal pin resistance. | Less than 100k ohm?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault code 231 is inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the oil sensor.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Refer to Sensor Supply Fault Code 386.

Go to 2A

Guided Step 2 - Check the Engine Coolant Pressure Sensor Circuit (High Temperature).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Engine Coolant Pressure Sensor Circuit (High Temperature).

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or replace the oil pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 (Danfoss (Circular DIN Series) Connector in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the engine coolant pressure sensor (high temperature). Refer to Procedure 019-016 (Coolant Pressure Sensor) in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect INSITE™ electronic service tool.

Action

Check the Engine Coolant Pressure Sensor Circuit (High Temperature) supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the oil pressure sensor breakout cable between the sensor and the harness connector
  • Connect INSITE™ electronic service tool.

Action

Check the Engine Coolant Pressure Sensor Circuit (High Temperature) signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

Repair

Replace the engine coolant pressure sensor (high temperature). Refer to Procedure 019-016 (Coolant Pressure Sensor) in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the engine coolant pressure sensor (high temperature)
  • Disconnect the engine harness from all sensors that have a shared supply or return with the engine coolant pressure sensor (high temperature).

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the engine coolant pressure sensor (high temperature) supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant pressure sensor (high temperature) return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant pressure sensor (high temperature) signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the engine coolant pressure sensor (high temperature).

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the engine coolant pressure sensor (high temperature) return pin on the engine harness connector to the engine coolant pressure sensor (high temperature) return pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM700 response.

Guided Step 4A - Check for an appropriate CM700 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine coolant pressure sensor (high temperature) connector
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM700 response.

  • Use INSITE™ electronic service tool to verify the fault codes.

NOTE: Fault Code 232 will become active upon disconnecting the sensor.

Fault code 231 is inactive?
YES | NO
No Repair | No Repair

Go to 4B

Go to 5A

Guided Step 4B - Check the CM700 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the 50-pin A Deutsch™ connector from the CM700.
  • Disconnect the 50-pin B Deutsch™ connector from the CM700.
  • Disconnect the 50-pin C Deutsch™ connector from the CM700.

Action

Check the CM700 signal pin resistance.

  • Measure the resistance from the engine coolant pressure sensor (high temperature) signal pin on the CM700 to the CM700 sensor supply circuit number 1 return pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 231 is inactive.

Fault code 231 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164752 - pressure sensor breakout cablePart Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 352 active?
STEP 2. | Check the engine coolant pressure sensor circuit (high temperature). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault Code 232 is inactive?
 | STEP 4B. Check the CM700 signal pin resistance. | Less than 100k ohm.
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 232 is inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the engine coolant pressure sensor circuit (high temperature).

Fault Code 352 active?
YES | NO
No Repair | No Repair

Refer to Sensor Supply Fault Code 227

Go to 2A

Guided Step 2 - Check the Engine Coolant Pressure Sensor Circuit (High Temperature).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the engine coolant pressure sensor (high temperature).

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or replace the engine coolant pressure sensor (high temperature), whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 (Danfoss (Circular DIN Series) Connector in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the engine coolant pressure sensor (high temperature). Refer to Procedure 019-016 (Coolant Pressure Sensor) in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the engine coolant pressure sensor circuit (high temperature) supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the engine coolant pressure sensor circuit (high temperature) signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

Repair

Replace the engine coolant pressure sensor (high temperature). Refer to Procedure 019-016 (Coolant Pressure Sensor) in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the engine coolant pressure sensor (high temperature) and the CM700.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the engine coolant pressure sensor (high temperature).
  • Disconnect the engine harness from all sensors that have a shared supply or return with the engine coolant pressure sensor circuit (high temperature).

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the engine coolant pressure (high temperature) supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant pressure (high temperature) return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant pressure (high temperature) signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the engine coolant pressure sensor (high temperature).

Action

Check for an open circuit in the harness.

  • Measure the resistance from the engine coolant pressure (high temperature) return pin on the engine harness connector to the engine coolant pressure (high temperature) return pin on the engine harness sensor connector.
  • Measure the resistance from the engine coolant pressure (high temperature) signal pin on the engine harness connector to the engine coolant pressure (high temperature) signal pin on the engine harness sensor connector.
  • Measure the resistance from the engine coolant pressure (high temperature) supply pin on the engine harness connector to the engine coolant pressure (high temperature) supply pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM700 response.

Guided Step 4A - Check for an appropriate CM700 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine coolant pressure sensor (high temperature) connector
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM700 response.

  • Place a jumper wire between the engine coolant pressure (high temperature) supply pin and the engine coolant pressure (high temperature) signal pin of the sensor connector.
  • Check for the appropriate CM700 response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Fault Code 231 will become active upon installing the jumper.

Fault code 232 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM700 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the 50-pin A Deutsch™ connector from the CM700.
  • Disconnect the 50-pin B Deutsch™ connector from the CM700.
  • Disconnect the 50-pin C Deutsch™ connector from the CM700.

Action

Check the CM700 signal pin resistance.

  • Measure the resistance from the engine coolant pressure (high temperature) signal pin on the CM700 to the CM700 sensor supply circuit number 2 return pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 232 is inactive.

Fault Code 232 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


FAULT CODE 234 - Engine Overspeed

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for proper operating conditions. | Load transient?
 | STEP 1B. Check the engine rpm with the monitor mode. | Correct rpm reading?
 | STEP 1C. Check for an active fault code at idle or rated speed. | Fault Code 234 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Verify that the fault code is inactive. | Fault Code 234 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Check for proper operating conditions.

  • Verify that the fault did not occur after the load transient.

Load transient?
YES NO

Repair

Check the engine for damage.

  • Electronics are functional
  • Check the base engine for damage because of overspeed condition.
 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the engine rpm with the monitor mode.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in the RUN mode and operate engine for longer than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Check the engine rpm with the monitor mode.

  • Use INSITE™ electronic service tool to monitor the engine rpm.

Correct rpm reading?
YES NO
No Repair

Repair

Check the engine position sensor as outlined for Fault Code 121.

Go to 1C

Refer to the troubleshooting chart for Fault Code 121.

Guided Step 1C - Check for an active fault at idle or rated speed.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and operate engine for longer than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes at idle or rated speed.

  • Check for active Fault Code 234 when the engine is not running above the engine overspeed shutdown threshold.

Fault Code 234 inactive?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 2A

Repair complete.

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and operate engine for longer than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Disable fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 234 is inactive.

Fault Code 234 inactive?
YES NO
No Repair

Repair

Return to the appropriate troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 06-Jan-2011


FAULT CODE 235 - Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 235 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Verify the fault code is inactive. | Fault Code 235 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 235 active?
YES NO

Repair

Reference the Coolant Loss symptom troubleshooting trees: .

  • t021-240-tr Coolant Loss, External in Section TS of the QSK60G CM700 Generator Troubleshooting and Repair Manual, Bulletin 4021396
  • t021-250-tr Coolant Loss, Internal in Section TS of the QSK60G CM700 Generator Troubleshooting and Repair Manual, Bulletin 4021396

If Fault Code 235 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. Refer to the OEM service manual before replacing the coolant level sensor.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate engine for greater than 1 minute.

Action

Verify the the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 235 is inactive.

Fault Code 235 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 17-Oct-2011


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 238 and other fault codes active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the wiring harness connector pins. | Damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 2D. Check the circuit response. | Fault Code 238 active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify that the fault code is inactive. | Fault Code 238 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing sensor supply circuit number 3.

Fault Code 238 and other fault codes active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 (Inactive or Intermittent Fault Code) in Section 19.

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the wiring harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19..
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from all the sensors that share sensor supply circuit number 3.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the sensor supply circuit number 3 positive (+) 5-VDC pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and Wiring Diagram) in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from all the sensors that share sensor supply circuit number 3.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the sensor supply pin on the engine harness connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the circuit response.

Conditions

  • De-energize the keyswitch circuit
  • Disconnect the engine harness from the ECM
  • Energize the keyswitch circuit
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO

Repair

Contact a Cummins® Authorized Repair Location.

 No Repair

Repair complete

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify that the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 238 is inactive.

Fault Code 238 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 239 and other fault codes active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the wiring harness connector pins. | Damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 2C. Check the circuit response. | Fault Code 239 active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify that the fault code is inactive. | Fault Code 239 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing sensor supply circuit number 3.

Fault Code 239 and other fault codes active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 (Inactive or Intermittent Fault Code) in Section 19.

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the wiring harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from all the sensors that share sensor supply circuit number 3.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the sensor supply circuit number 3 positive (+) 5-VDC pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and Wiring Diagram) in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • De-energize the keyswitch circuit
  • Disconnect the engine harness from the ECM
  • Energize the keyswitch circuit
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 active?
YES NO

Repair

Contact a Cummins® Authorized Repair Location.

 No Repair

Repair complete

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify that the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 239 is inactive.

Fault Code 239 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


FAULT CODE 253 - Engine Oil Level - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active Fault Code 253. | Fault Code 253 active?
 | STEP 1B. Check for multiple active/inactive fault codes. | Fault codes 137, 143, 219, 415, 481, 555, 556, 1362, 1785, 1787, 1788, 1825, 2553, and/or 3491 active/inactive?
STEP 2. | Check the engine oil day tank. |
 | STEP 2A. Check the oil level within the engine oil day tank. | Engine oil day tank oil level low?
 | STEP 2B. Check for oil flow between the engine oil day tank and the Murphy oil level switch. | Oil flow from engine oil day tank to the Murphy oil level switch?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 253 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active Fault Code 253.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electric service tool to read for active fault code 253.

Fault Code 253 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 1B

Guided Step 1B - Check for multiple active/inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read for multiple active/inactive fault codes.

Fault codes 137, 143, 219, 415, 481, 555, 556, 1362, 1785, 1787, 1788, 1825, 2553, and/or 3491 active/inactive?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active/inactive fault codes or contact a Cummins® Authorized Repair Location.

 No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the engine oil day tank.

Guided Step 2A - Check the oil level within the engine oil day tank.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the oil level within the engine oil day tank.

Engine oil day tank oil level low?
YES NO

Repair

Fill the engine oil day tank with engine oil of the correct specification.

  • Refer to Procedure 018-003 in Section V.
  • Contact a Cummins® Authorized Repair Location.
 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for oil flow between the engine oil day tank and the Murphy oil level switch.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually check for oil flow between the engine oil day tank and the Murphy oil level switch.

  • Temporarily disconnect the oil supply pipe from the engine oil day tank to the Murphy oil level switch from the connection at the Murphy oil level switch.
  • Use a suitable container to catch the oil, check that there is a good flow of oil from the engine oil day tank.
  • Contact a Cummins® Authorized Repair Location.

Oil flow from engine oil day tank to the Murphy oil level switch?
YES NO
No Repair

Repair

Poor or no oil flow has been detected between the engine oil day tank and the Murphy oil level switch. Check for the following conditions:

  • Engine oil day tank to Murphy oil level switch oil supply pipe - isolation valve fully open.
  • Engine oil day tank - check for blockages at oil outlet, such as foreign matter, etc.
  • Engine oil day tank to Murphy oil level switch oil supply pipe - no restrictions caused by routing or securing of flexible pipe work.
  • Engine oil day tank to Murphy oil level switch oil supply pipe - no restrictions caused by internal blockages.
  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 2B

Guided Step 3 - Clear the fault codes

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

Use INSITE™ electronic service tool to verify Fault Code 253 is inactive.

Is fault 253 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 04-Jan-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 441 and 442 or 477 and 478 active?
STEP 2. | Check the fuel shutoff valve. |
 | STEP 2A. Inspect the valve and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the valve supply voltage. | +24-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 and CM700 response. |
 | STEP 4A. Check for the appropriate CM558 and CM700 response. | Fault Code 254 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 254 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 and 442 or 477 and 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the fuel shutoff valve.

Guided Step 2A - Inspect the valve and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the fuel shutoff valve.

Action

Inspect the valve and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or replace the fuel shutoff valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 (Danfoss (Circular DIN Series) Connector) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the fuel shutoff valve. Refer to Procedure 005-044 (Fuel Shutoff Valve) in Section 5 in the Troubleshooting and Repair Manual QSK60G CM700, Bulletin 4021396.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the valve supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and engine cranking
  • Disconnect the main engine harness from the fuel shutoff valve
  • Connect INSITE™ electronic service tool.

Action

Check the fuel shutoff valve supply voltage.

NOTE: Make sure that the engine is not performing a purge cycle when making this measurement.

+24-VDC?
YES NO
No Repair

Repair

Check the battery connections and the fuses in the harness. Refer to the engine wiring diagram for the appropriate circuit.

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the fuel shutoff valve and the CM558 and CM700.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the fuel shutoff valve.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel shutoff valve return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel shutoff valve supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the fuel shutoff valve.

Action

Check for an open circuit in the supply and return wires.

  • Measure the resistance from the fuel shutoff valve supply pin on the engine harness connector to the fuel shutoff valve supply pin on the engine harness sensor connector.
  • Measure the resistance from the fuel shutoff valve return pin on the engine harness connector to the fuel shutoff valve return pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 and CM700 response.

Guided Step 4A - Check for the appropriate CM558 and CM700 response.

Conditions

  • Keyswitch circuit energized
  • Disconnect the fuel control valve actuator connector
  • Run/Stop/Auto switch in Run mode and engine cranking
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 and CM700 response.

  • Remove the fuel shutoff valve relays and crank the engine. Refer to the engine wiring diagram for the appropriate circuit.
  • Use INSITE™ electronic service tool to verify the fault codes.

NOTE: Fault Code 255 will become active.

Fault Code 254 inactive?
YES NO
No Repair

Repair

Contact Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 254 is inactive.

Fault Code 254 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the fuel temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for a short circuit to the engine block ground. | More than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 263 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 263 inactive?
 | STEP 5B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the fuel temperature sensor.

Other fault codes active?
YES | NO
No Repair | No Repair

Refer to appropriate fault code

Go to 2A

Guided Step 2 - Check the fuel temperature sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the fuel temperature sensor.

Action

Inspect the harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or replace the fuel temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the fuel temperature sensor. Refer to Procedure 019-119 (Engine Fuel Temperature Sensor) in Section 19.
No Repair

Go to 2B

5A

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Check the resistance of the fuel temperature sensor.

  • Measure the resistance between the fuel temperature signal pin and the fuel temperature return pin.

600 ohms to 36k ohms?
YES NO
No Repair

Repair

  • Replace the fuel temperature sensor. Refer to Procedure 019-119 (Engine Fuel Temperature Sensor) in Section 19.

Go to 3A

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the fuel temperature sensor connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair

  • Replace the fuel temperature sensor. Refer to Procedure 019-119 (Engine Fuel Temperature Sensor) in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the fuel temperature sensor and the CM558.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair or replace the engine harness or the extension harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the CM558
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel temperature return pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel temperature signal pin in the engine harness connector to all other pins in the engine harness connector.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the fuel temperature sensor
  • Disconnect the engine harness from the CM558.

Action

Check for a short circuit to ground in the signal and return wires

  • Measure the resistance from the fuel temperature signal pin on the engine harness connector to the engine block ground.
  • Measure the resistance from the fuel temperature return pin on the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the fuel temperature sensor
  • Disconnect the engine harness from the CM558.

Action

Check for an open circuit.

  • Measure the resistance from the signal pin on the fuel temperature sensor connector to the sensor signal pin on the CM558.
  • Measure the resistance from the return pin on the fuel temperature sensor connector to the return signal pin on the CM558.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM558 response.

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch is Stop mode
  • Disconnect the engine harness from the fuel temperature sensor
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate CM558 response.

  • Place a jumper wire between the fuel temperature signal pin and the fuel temperature return pin of the sensor connector.
  • Check for the appropriate CM558 response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Fault Code 265 will become active upon installing the jumper.

Fault Code 263 inactive?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Repair complete

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 263 is inactive.

Fault Code 263 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes are active?
STEP 2. | Check the fuel temperature sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for a short circuit to the engine block ground. | More than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 265 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 265 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the fuel temperature sensor.

Other fault codes are active?
YES | NO
No Repair | No Repair

Refer to appropriate fault code

Go to 2A

Guided Step 2 - Check the fuel temperature sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the fuel temperature sensor.

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or replace the fuel temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the fuel temperature sensor. Refer to Procedure 019-119 (Engine Fuel Temperature Sensor) in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Check the resistance of the fuel temperature sensor.

  • Measure the resistance between the fuel temperature signal pin and the fuel temperature return pin.

600 ohms to 36k ohms?
YES NO
No Repair

Repair

  • Replace the fuel temperature sensor. Refer to Procedure 019-119 (Engine Fuel Temperature Sensor) in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the fuel temperature sensor connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair

  • Replace the fuel temperature sensor. Refer to Procedure 019-119 (Engine Fuel Temperature Sensor) in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the fuel temperature sensor and the CM558.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair or replace the engine harness or the extension harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the CM558
  • Disconnect the engine harness from the fuel temperature sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel temperature return pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel temperature signal pin in the engine harness connector to all other pins in the engine harness connector.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the fuel temperature sensor
  • Disconnect the engine harness from the CM558.

Action

Check for a short circuit to ground in the signal and return wires

  • Measure the resistance from the fuel temperature signal pin on the engine harness connector to the engine block ground.
  • Measure the resistance from the fuel temperature return pin on the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the fuel temperature sensor
  • Disconnect the engine harness from the CM558.

Action

Check for an open circuit.

  • Measure the resistance from the signal pin on the fuel temperature sensor connector to the sensor signal pin on the CM558.
  • Measure the resistance from the return pin on the fuel temperature sensor connector to the return pin on the CM558.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM558 response.

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the fuel temperature sensor
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Use INSITE™ electronic service tool to verify the fault codes.

NOTE: Fault Code 263 will become active upon disconnecting the sensor.

Fault Code 265 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 265 is inactive.

Fault Code 265 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear any inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


FAULT CODE 277 - Engine Electronic Fuel Control Valve 1 - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 277 active or high inactive counts?
STEP 2. | Check the fuel control valve actuator. |
 | STEP 2A. Inspect the actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fuel control actuator commanded signal percent duty cycle. | Percent duty cycle 10 to 94 percent?
 | STEP 2C. Check the fuel control valve feedback signal voltage. | 0 to 5-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | More than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness malfunction. | Fault Code 277 and/or 2184, 2311, 2864, 2866 and 2867 active?
STEP 4. | Check the ECM. |
 | STEP 4A. Check the fuel control valve commanded position percent pulse width modulation duty cycle signal at the CM558 connector. | Percent duty cycle 10 – 94 percent?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 277 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 277 active or high inactive counts?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 5A

Guided Step 2 - Check the fuel control valve actuator.

Guided Step 2A - Inspect the actuator and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the fuel control valve actuator.

Action

Inspect the actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inpection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness, the harness connector, or the fuel control valve actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrial contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel control valve. Refer to Procedure 006-049 in Section 6 of the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the fuel control valve (FCV) actuator commanded signal percent duty cycle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle.

  • Use the actuator test function within INSITE™ electronic service tool to drive the FCV to a number of positions between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the FCV actuator position SIGNAL (+) and RETURN (–) pins at the FCV actuator connector. The signal percent duty cycle must be between 10 and 94 percent, based on the FCV actuator position.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Refer to the specification table provided in the Shop Talk section of this document for commanded position percent duty cycle specifications.

Percent duty cycle 10 - 94 percent?
YES NO
No Repair

Repair

Check the power supply connections and the fuses. Refer to the engine wiring diagram for the appropriate circuit.

Go to 2C

Go to 3A

Guided Step 2C - Check the FCV feedback signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve feedback signal voltage.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the signal feedback voltage by connecting the multimeter test probes between the FCV actuator position feedback and RETURN (–) pins. The feedback signal must be between 0 to 5-VDC.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Refer to the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

0 to 5-VDC?
YES NO
No Repair

Repair

Replace the FCV. Refer to Procedure 006-049 in Section 6 of the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the CM558 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Connect the engine harness to the FCV actuator.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the FCV actuator. Refer to the wiring diagram to identify shared sensors.
  • Disconnect the engine harness from the left bank CM558 module.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the FCV actuator SIGNAL pin at the FCV connector and the FCV actuator SIGNAL pin at the CM558 module connector of the engine harness.
  • Measure the resistance between the FCV actuator RETURN pin at the FCV connector and the FCV actuator RETURN pin at the CM558 module connector of the engine harness.

Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check the engine harness for a short to ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the CM558 module.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator. Refer to the wiring diagram to identify shared sensors.

Action

Check the engine harness and FCV actuator resistance.

  • Measure the resistance from the FCV actuator SIGNAL pin in the engine harness CM558 connector to the engine block ground.
  • Measure the resistance from the FCV actuator feedback pin in the engine harness CM558 connector to the engine block ground.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the appropriate wiring diagram to identify connectors and pins.

  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an intermittent engine harness malfunction.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode at rated speed, no load.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or malfunction.

  • Manipulate the engine harness, starting at the ECM engine harness connector and working to the FCV actuator connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

If a short or open circuit is induced while the engine is operating, a warning or shutdown alarm and corresponding fault code will be activated.

Fault Code 277 and/or 2184, 2311, 2864, 2866 and 2867 become active?
YES NO

Repair

An intermittent connection has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM.

Guided Step 4A - Check the fuel control valve commanded position percent PWM duty cycle signal at the CM558 connector.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle at the left bank CM558 connector B.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a number of positions between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the FCV actuator position SIGNAL (+) and RETURN (–) pins at the CM558 connector. The signal percent duty cycle must be between 10 and 94 percent, based on the FCV actuator position.

Use the appropriate wiring diagram to identify the SIGNAL and RETURN pins.

Refer to the specification table provided in the Shop Talk section of this document for commanded position percent duty cycle specifications.

Percent duty cycle 10 to 94 percent?
YES NO
No Repair

Repair

A fault code has been detected with the CM558 module.

  • Replace the left bank CM558 module. Refer to Procedure 019-031 in Section 19.
  • Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code in inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for more than 1 minute.

Action

Use INSITE™ electronic service tool to verify that Fault Code 277 is inactive.

Fault Code 277 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Using INSITE™ electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 19-Mar-2012


FAULT CODE 343 - Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Associated Procedures

Cautions and Warnings

CAUTION

To reduce damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 343 active?
STEP 2. | Clear the fault code. |
 | STEP 2A. Verify the fault code is inactive. | Fault Code 343 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes. INSITE™ electronic service tool will identify which ECM has actived the fault code.

Fault Code 343 active?
YES NO

Repair

An internal fault has been identified within the ECM that has activated the fault code.

Repalce the appropriate ECM.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Verify the fault code is inactive.

Conditions

  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 343 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 19-Mar-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 346 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 346. | Less than three counts?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check the ECM.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to verify that Fault Code 346 is inactive.

Fault Code 346 inactive?
YES NO
No Repair

Repair

Contact the nearest authorized repair location.

Go to 1B

Repair complete

Guided Step 1B - Check the inactive counts of Fault Code 346.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode.

Action

Check the inactive counts of Fault Code 346.

  • Use the electronic service tool to read the inactive counts of Fault Code 346.

Less than three counts?
YES NO
No Repair

Repair

Contact the nearest authorized repair location.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


FAULT CODE 352 - Sensor Supply Circuit Number 1 - Shorted Low

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 352 and other fault codes active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the wiring harness connector pins. | Damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 2D. Check the circuit response. | Fault Code 352 active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify that the fault code is inactive. | Fault Code 352 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in Stop mode.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing sensor supply circuit number 1.

Fault Code 352 and other fault codes active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the wiring harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in Stop mode.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged pins?
YES NO

Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in Stop mode.
  • Disconnect the engine harness from the extension harness, if present.
  • Disconnect the engine harness from all the sensors that share sensor supply circuit number 1.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the sensor supply circuit number 1 positive (+) 5-VDC pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in Stop mode.
  • Disconnect the engine harness from the extension harness, if present.
  • Disconnect the engine harness from all the sensors that share sensor supply circuit number 1.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the sensor SUPPLY pin on the engine harness connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the circuit response.

Conditions

  • De-energize the keyswitch circuit.
  • Disconnect the engine harness from all the sensors that share sensor supply circuit number 1.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Repair complete

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify that the fault code is inactive.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in Stop mode.
  • Connect INSITE™ electronic service tool.
  • Place run/stop/auto switch in Run mode and running for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 352 is inactive.

Fault Code 352 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault code.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in Stop mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 19-Mar-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164752 - pressure sensor breakout cablePart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 386 active?
STEP 2. | Check the Intake Manifold Pressure Sensor . |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 354 is inactive?
 | STEP 4B. Check the CM558 signal pin resistance. | Less than 100k ohm.
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 354 is inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Using the electronic service tool, read the fault codes
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the Intake Manifold Pressure Sensor.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Refer to Sensor Supply Fault Code 386

Go to 2A

Guided Step 2 - Check the Intake Manifold Pressure Sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Intake Manifold Pressure Sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the Intake Manifold Pressure Sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Intake Manifold Pressure Sensor. Refer to Procedure 019-061.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the Intake Manifold Pressure Sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the Intake Manifold Pressure Sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Repair

Replace the Intake Manifold Pressure Sensor.

Refer to Procedure 019-061.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Intake Manifold Pressure Sensor and the CM558.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram in Section E to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the Intake Manifold Pressure Sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the Intake Manifold Pressure Sensor.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the intake manifold pressure supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram in Section E to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the Intake Manifold Pressure Sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the intake manifold pressure return pin on the engine harness connector to the intake manifold pressure return pin on the engine harness sensor connector.
  • Measure the resistance from the intake manifold pressure signal pin on the engine harness connector to the intake manifold pressure signal pin on the engine harness sensor connector.
  • Measure the resistance from the intake manifold pressure supply pin on the engine harness connector to the intake manifold pressure supply pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram in Section E to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the Intake Manifold Pressure Sensor connector.
  • Connect the electronic service tool.

Action

Check for the appropriate CM700 response.

  • Using the electronic service tool, verify the fault codes.

NOTE: Fault Code 355 will become active upon disconnecting the sensor.

Fault Code 354 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM558 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main harness connector from the CM558.

Action

Check the CM558 signal pin resistance.

  • Measure the resistance from the intake manifold pressure signal pin on the CM558 to the CM558 sensor supply circuit number 1 return pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact the nearest Cummins Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 354 is inactive.

Fault Code 354 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164752 - pressure sensor breakout cablePart Number 3822758 - male Deutsch/AMP/Metri-Pack test leadPart Number 3822917 - female Deutsch/AMP/Metri-Pack test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 352 active?
STEP 2. | Check the Intake Manifold Pressure Sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56 VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 355 is inactive?
 | STEP 4B. Check the CM558 signal pin resistance. | Less than 100k ohm.
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 355 is inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Using the electronic service tool, read the fault codes
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the Intake Manifold Pressure Sensor.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Refer to Sensor Supply Fault Code 352

Go to 2A

Guided Step 2 - Check the Intake Manifold Pressure Sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the Intake Manifold Pressure Sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the Intake Manifold Pressure Sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Replace the Intake Manifold Pressure Sensor. Refer to Procedure 019-061.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the Intake Manifold Pressure Sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect the electronic service tool.

Action

Check the Intake Manifold Pressure Sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56 VDC?
YES NO
No Repair

Repair

Replace the Intake Manifold Pressure Sensor.

Refer to Procedure 019-061.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the Intake Manifold Pressure Sensor and the CM558.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram in Section E to identify connectors and pins.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins using electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the Intake Manifold Pressure Sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the Intake Manifold Pressure Sensor.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the intake manifold pressure supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram in Section E to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the Intake Manifold Pressure Sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the intake manifold pressure return pin on the engine harness connector to the intake manifold pressure return pin on the engine harness sensor connector.
  • Measure the resistance from the intake manifold pressure signal pin on the engine harness connector to the intake manifold pressure signal pin on the engine harness sensor connector.
  • Measure the resistance from the intake manifold pressure supply pin on the engine harness connector to the intake manifold pressure supply pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram in Section E to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 and Refer to Procedure 019-208.
  • Replace the engine harness. Refer to Procedure 019-043.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the Intake Manifold Pressure Sensor connector.
  • Connect the electronic service tool.

Action

Check for the appropriate CM558 response.

  • Place a jumper wire between the intake manifold pressure supply pin and the intake pressure signal pin of the sensor connector.
  • Check for the appropriate CM558 response after thirty seconds.
  • Read the fault codes using the electronic service tool.

NOTE: Fault Code 354 will become active upon disconnecting the sensor.

Fault Code 355 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM558 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main harness connector from the CM558.

Action

Check the CM558 signal pin resistance.

  • Measure the resistance from the intake manifold pressure signal pin on the CM558 to the CM558 sensor supply circuit number one return pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact the nearest Cummins Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Verify that the fault code is inactive.

  • Using the electronic service tool, verify that Fault Code 355 is inactive.

Fault Code 355 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact your nearest Cummins Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Other fault codes active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Other fault codes active?
YES NO
No Repair

Repair

Refer to the Engine Performance Troubleshooting Tree in Section TT of this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault code.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in the Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charts

Last Modified: 30-Jun-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 386 and other fault codes active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the wiring harness connector pins. | Damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 2C. Check the circuit response. | Fault Code 386 active?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify that the fault code is inactive. | Fault Code 386 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the engine wiring diagram to verify that no fault codes are active for any sensor sharing sensor supply circuit number 1.

Fault Code 386 and other fault codes active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 (Inactive or Intermittent Fault Code) in Section 19.

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the wiring harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from all the sensors that share sensor supply circuit number 1.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the sensor supply circuit number 1 positive (+) 5-VDC pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Refer to Procedure 019-360 (Resistance Measurements Using a Multimeter and Wiring Diagram) in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • De-energize the keyswitch circuit
  • Disconnect the engine harness from the ECM
  • Energize the keyswitch circuit
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES NO

Repair

Contact a Cummins® Authorized Repair Location.

 No Repair

Repair complete

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify that the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect the electronic service tool
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 386 is inactive.

Fault Code 386 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault code.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 477 or 478 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 477 or 478 active?
YES NO
No Repair

Repair

Refer to Procedure 019-166, SAE J1587/1939 Datalink Circuit, in this manual for troubleshooting procedures.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 135 or 141 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 135 or 141 active?
YES NO
No Repair

Repair

Reference the Lubricating Oil Pressure Low symptom tree in the Troubleshooting and Repair Manual, QSK60G Generator CM700, Bulletin 4021396.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 19-Mar-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 212 or 213 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 212 or 213 active?
YES NO
No Repair

Repair

Reference the Lubricating Oil Pressure Low symptom tree in the Troubleshooting and Repair Manual QSK60G Generator CM700, Bulletin 4021396.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Jun-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 477 or 478 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 477 or 478 active?
YES NO
No Repair

Repair

Refer to Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 for troubleshooting procedures.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3824811 - male Deutsch™ test leadPart Number 3824812 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable connections. | Damaged connections?
 | STEP 1B. Check the battery voltage. | 17.3 to 34.7-VDC (24-VDC system)?
 | STEP 1C. Verify 120-VAC supplied to DC power supply. | 120-VAC?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the battery cable connections. | No damaged connections?
 | STEP 2B. Check the battery supply fuses. | Less than 10 ohms?
 | STEP 2C. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
 | STEP 2E. Check for a short circuit from pin to pin | More than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 441 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Inspect the DC power supply cable connections for the following:

  • Corrosion
  • Loose connections.

Damaged connections?
YES NO

Repair

Repair the damaged connections.

Tighten the DC power supply connections and clean the terminals. Refer to the Power Supply Manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check the battery voltage.

  • Measure the voltage from the positive (+) terminal to the negative (-) terminal of the DC power supply.

17.3 to 34.7-VDC (24-VDC system)?
YES NO
No Repair

Repair

Repair or replace the DC power supply.

Go to 2A

Go to 1C

Guided Step 1C - Verify 120-VAC supplied to DC power supply.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Measure the 120-VAC supplied to the DC power supply.

Measure the 120-VAC input to the DC power supply.

120-VAC?
YES NO

Repair

Repair or replace the DC power supply.

Repair

Make sure input circuit breakers are turned on.

Check the input supply fuses.

Go to 3A

Go to 3A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the battery ground connections.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check the battery ground connection.

  • Measure the resistance from the negative (-) terminal on the DC power supply to the engine block ground.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair the battery ground connection. Refer to Procedure 019-197 (Ring Terminal) in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the battery supply fuses.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check each fuse in the Battery Supply Circuit to see if any fuse is blown.

  • Refer to the wiring diagram to identify all fuses in the circuit.

Less than 10 ohms?
YES NO
No Repair

Repair

Replace the fuse. Refer to Procedure 019-198 (Fuse, Harness In-Line) in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the wiring harness and connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Inspect the OEM harness and OEM interface harness connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness from the extension harness (if installed)
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for an open circuit.

  • Measure the resistance from all pins being supplied by the DC power supply on the engine harness to the positive (+) terminal connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify the connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness from the extension harness (if installed)
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for a short circuit in the battery supply circuit.

  • Measure the resistance from all DC power supply pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify the connectors and pins.

More than 100k ohms?
YES NO

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 1A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify that the fault codes are inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the run mode and engine running for longer than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 441 is inactive.

Fault Code 441 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3824811 - male Deutsch™ test leadPart Number 3824812 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable connections. | Damaged connections?
 | STEP 1B. Check the battery voltage. | 17.3 to 34.7-VDC (24-VDC system)?
 | STEP 1C. Verify 120-VAC supplied to DC power supply. | 120-VAC?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the battery cable connections. | Damaged connections?
 | STEP 2B. Check the battery supply fuses. | Less than 10 ohms?
 | STEP 2C. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
 | STEP 2E. Check for a short circuit from pin to pin | More than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 442 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Inspect the DC power supply cable connections for the following:

  • Corrosion
  • Loose connections.

Damaged connections?
YES NO

Repair

Repair the damaged connections.

Tighten the DC power supply connections and clean the terminals. Refer to the Power Supply Manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check the battery voltage.

  • Measure the voltage from the positive (+) terminal to the negative (-) terminal of the DC power supply.

17.3 to 34.7-VDC (24-VDC system)?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Verify 120-VAC supplied to DC power supply.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Measure the 120-VAC supplied to the DC power supply.

Measure the 120-VAC input to the DC power supply.

120-VAC?
YES NO

Repair

Repair or replace the DC power supply.

Repair

Make sure input circuit breakers are turned on.

Check the input supply fuses.

Go to 3A

Go to 3A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the battery ground connections.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check the battery ground connection.

  • Measure the resistance from the negative (-) terminal on the DC power supply to the engine block ground.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair the battery ground connection. Refer to Procedure 019-197 (Ring Terminal) in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the battery supply fuses.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check each fuse in the Battery Supply Circuit to see if any fuse is blown.

  • Refer to the wiring diagram to identify all fuses in the circuit.

Less than 10 ohms?
YES NO
No Repair

Repair

Replace the fuse. Refer to Procedure 019-198 (Fuse, Harness In-Line) in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the wiring harness and connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness from the extension harness (if installed).

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Inspect the OEM harness and OEM interface harness connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness from the extension harness (if installed)
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for an open circuit.

  • Measure the resistance from all pins being supplied by the DC power supply on the engine harness to the positive (+) terminal connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify the connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness from the extension harness (if installed)
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for a short circuit in the battery supply circuit.

  • Measure the resistance from all DC power supply pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify the connectors and pins.

More than 100k ohms?
YES NO

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 1A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify that the fault codes are inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the run mode and engine running for longer than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 442 is inactive.

Fault Code 442 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 239 active?
STEP 2. | Check the gas mass flow sensor. |
 | STEP 2A. Inspect the sensor and harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 8 to 15-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for an appropriate CM558 response. | Fault Code 453 is inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that fault code is inactive. | Fault Code 453 is inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 active?
YES | NO
No Repair | No Repair

Refer to Sensor Supply Fault Code 239

Go to 2A

Guided Step 2 - Check the gas mass flow sensor.

Guided Step 2A - Inspect the sensor and harness connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the gas mass flow sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the gas mass flow sensor, whichever has the damaged pins.

  • Flush the dirt or debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the connector. Refer to Procedure 019-219 Danfoss (Circular DIN Series) Connector) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the gas mass flow sensor. Refer to Procedure 019-101 (Gas Mass Flow Sensor) in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the gas mass flow sensor
  • Connect INSITE™ electronic service tool.

Action

Check the gas mass flow sensor supply voltage.

  • Measure the sensor supply voltage.

8 to 15-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the CM558
  • Connect INSITE™ electronic service tool.

Action

Check the gas mass flow sensor signal voltage.

  • Measure the signal voltage at the main harness CM558 connector with a multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

Repair

Replace the gas mass flow sensor. Refer to Procedure 019-101 (Gas Mass Flow Sensor) in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the gas mass flow sensor and the CM558.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt or debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the gas mass flow sensor
  • Disconnect the engine harness from all sensors that have a shared supply or return with the gas mass flow sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the gas mass flow sensor supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the gas mass flow sensor return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the gas mass flow sensor signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the gas mass flow sensor

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the gas mass flow sensor return pin on the engine harness connector to the gas mass flow sensor return pin on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the gas mass flow sensor
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Use INSITE™ electronic service tool to verify the fault codes.

Note: Fault Code 454 will become active upon disconnecting the sensor.

Fault Code 453 is inactive?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 453 is inactive.

Fault Code 453 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Facility if the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 238 active?
STEP 2. | Check the Gas Mass Flow Sensor. |
 | STEP 2A. Inspect the sensor and harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 8 to 15-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for an appropriate CM558 response. | Fault Code 454 is inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that fault code is inactive. | Fault Code 454 is inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES | NO
No Repair | No Repair

Refer to Sensor Supply Fault Code 238

Go to 2A

Guided Step 2 - Check the Gas Mass Flow Sensor.

Guided Step 2A - Inspect the sensor and harness connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the Gas Mass Flow Sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the Gas Mass Flow Sensor, whichever has the damaged pins.

  • Flush the dirt or debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the connector. Refer to Procedure 019-219 Danfoss (Circular DIN Series) Connector) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the Gas Mass Flow Sensor. Refer to Procedure 019-101 (Gas Mass Flow Sensor) in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the Gas Mass Flow Sensor
  • Connect INSITE™ electronic service tool.

Action

Check the Gas Mass Flow Sensor supply voltage.

  • Measure the sensor supply voltage.

8 to 15-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main engine harness from the CM558
  • Connect INSITE™ electronic service tool.

Action

Check the Gas Mass Flow Sensor signal voltage.

  • Measure the signal voltage at the main harness CM558 connector with a multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

Repair

Replace the Gas Mass Flow Sensor. Refer to Procedure 019-101 (Gas Mass Flow Sensor) in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the Gas Mass Flow Sensor and the CM558.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt or debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the Gas Mass Flow Sensor
  • Disconnect the engine harness from all sensors that have a shared supply or return with the Gas Mass Flow Sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the Gas Mass Flow Sensor supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the Gas Mass Flow Sensor return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the Gas Mass Flow Sensor signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the Gas Mass Flow Sensor

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the Gas Mass Flow Sensor return pin on the engine harness connector to the Gas Mass Flow Sensor return pin on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the Gas Mass Flow Sensor
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Place a jumper line between the Gas Mass Flow Sensor supply pin and the Gas Mass Flow Sensor signal pin on the sensor connector.
  • Check the appropriate CM558 response after thirty seconds.
  • Use INSITE™ electronic service tool to verify the fault codes.

Note: Fault Code 453 will become active upon installing the jumper.

Fault Code 454 is inactive?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 454 is inactive.

Fault Code 454 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

WARNING

EXTREMELY HIGH VOLTAGE. Do not touch any ignition wiring or component while the engine is operating unless an insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 441, 442, 477, or 478 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit on the capacitive coil driver connector. | More than 100k ohms?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check the capacitive coil driver. |
 | STEP 3A. Check the ignition timing signal. | 5-VDC?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 458 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 458 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441, 442, 477, or 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the wiring harness connector from the capacitive coil driver
  • Disconnect the main harness connectors from the CM558.

Action

Inspect the pins of the CM558 connectors and the capacitive coil driver connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt or debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a short circuit on the capacitive coil driver connector.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the wiring harness connector from the capacitive coil driver
  • Disconnect the main harness connectors from the CM558.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the ignition timing signal pin to all other pins on the capacitive coil driver wiring harness connector.
  • Measure the resistance from the 24-VDC supply pin to all other pins on the capacitive coil driver wiring harness connector.
  • Measure the resistance from the 24-VDC return pin to all other pins on the capacitive coil driver wiring harness connector.
  • Measure the resistance from the ignition timing signal pin to all other pins on the CM558 connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the wiring harness connector from the capacitive coil driver
  • Disconnect the main harness connectors from the CM558.

Action

Check for an open circuit on the signal, power supply, and power return lines.

  • Measure the resistance from the ignition timing signal pin on the capacitive coil driver wiring harness connector to the ignition timing signal pin on the CM558 connector.
  • Measure the resistance from the 24-VDC supply pin on the capacitive coil driver wiring harness connector to the 24-VDC supply terminal on the power supply relay.
  • Measure the resistance from the 24-VDC return pin on the capacitive coil driver wiring harness connector to the 24-VDC return on the power supply.
  • Measure the resistance from the 24-VDC supply pin on the CM558 wiring harness connector to the 24-VDC supply on the power supply.
  • Measure the resistance from the 24-VDC return pin on the CM558 wiring harness connector to the 24-VDC return on the power supply.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the capacitive coil driver.

Guided Step 3A - Check the ignition timing signal.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the wiring harness connectors from the right bank CM558.

Action

Check the voltage on the ignition timing signal pin of the CM558 main harness connector.

  • Install a jumper across the contacts of the capacitive coil driver power supply relay. Be sure that 24-VDC is applied to the circuit.
  • Use a multimeter to measure the ignition timing signal voltage.

5-VDC?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Use INSITE™ electronic service tool to verify the fault codes.

Fault Codes 458 inactive?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 458 is inactive.

Fault Code 458 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

WARNING

EXTREMELY HIGH VOLTAGE. Do not touch any ignition wiring or component while the engine is operating unless an insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM. To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823995 - male Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 441, 442, 477, or 478 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin to pin short circuit on the capacitive coil driver connector. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check the capacitive coil driver. |
 | STEP 3A. Check the ignition timing signal. | 5-VDC?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 459 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 459 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 441, 442, 477, or 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the wiring harness connector from the capacitive coil driver
  • Disconnect the main harness connectors from the CM558.

Action

Inspect the pins of the CM558 connectors and the capacitive coil driver connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt or debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a pin to pin short circuit on the capacitive coil driver connector.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the wiring harness connector from the capacitive coil driver
  • Disconnect the main harness connectors from the CM558.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the ignition timing signal pin to all other pins on the capacitive coil driver wiring harness connector.
  • Measure the resistance from the 24-VDC supply pin to all other pins on the capacitive coil driver wiring harness connector.
  • Measure the resistance from the 24-VDC return pin to all other pins on the capacitive coil driver wiring harness connector.
  • Measure the resistance from the ignition timing signal pin to all other pins on the CM558 connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram in Section E to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the wiring harness connector from the capacitive coil driver
  • Disconnect the main harness connectors from the CM558.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the ignition timing signal pin on the capacitive coil driver wiring harness connector to engine block ground.
  • Measure the resistance from the 24-VDC supply pin on the capacitive coil driver harness connector to engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the wiring harness connector from the capacitive coil driver
  • Disconnect the main harness connectors from the CM558.

Action

Check for an open circuit on the signal, power supply, and power return lines.

  • Measure the resistance from the ignition timing signal pin on the capacitive coil driver wiring harness connector to the ignition timing signal pin on the CM558 connector.
  • Measure the resistance from the 24-VDC supply pin on the capacitive coil driver wiring harness connector to the 24-VDC supply terminal on the power supply relay.
  • Measure the resistance from the 24-VDC return pin on the capacitive coil driver wiring harness connector to the 24-VDC return on the power supply.
  • Measure the resistance from the 24-VDC supply pin on the CM558 wiring harness connector to the 24-VDC supply on the power supply.
  • Measure the resistance from the 24-VDC return pin on the CM558 wiring harness connector to the 24-VDC return on the power supply.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the capacitive coil driver.

Guided Step 3A - Check the ignition timing signal.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the wiring harness connectors from the right bank CM558.

Action

Check the voltage on the ignition timing signal pin of the CM558 main harness connector.

Install a jumper across the contacts of the capacitive coil driver power supply relay. Be sure that 24-VDC is applied to the circuit.

  • Use a multimeter to measure the ignition timing signal voltage.

5-VDC?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Use INSITE™ electronic service tool to verify the fault codes.

Fault Codes 459 inactive?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 459 is inactive.

Fault Code 459 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

WARNING

EXTREMELY HIGH VOLTAGE. Do not touch any ignition wiring or component while the engine is operating unless an insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement.Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 441, 442, 477, or 478 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the harness and the connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin on the capacitive coil driver connector. | More than 100k ohms?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check the capacitive coil driver. |
 | STEP 3A. Check the ignition reference signal. | 5-VDC?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 459 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 459 inactive?
 | STEP 5B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 441, 442, 477, or 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting step

Go to 2A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the harness and connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the wiring harness connector for the capacitive coil driver
  • Disconnect the main harness connectors from the CM558.

Action

Inspect the engine harnes and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Clean the connector and pins.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 5A

Go to 2B

Guided Step 2B - Check for a pin to pin short circuit on the capacitive coil driver connector.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the wiring harness connector for the capacitive coil driver
  • Disconnect the main harness connectors from the CM558.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the ignition reference signal pin to all others on the capacitive coil driver wiring harness connector.
  • Measure the resistance from the 24-VDC supply pin to all other pins on the capacitive coil driver wiring harness connector.
  • Measure the resistance from the 24-VDC return pin to all other pins on the capacitive coil driver wiring harness connector.
  • Measure the resistance from the ignition reference signal pin to all others on the CM558 connectors.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the wiring harness connector for the capacitive coil driver
  • Disconnect the main harness connectors from the CM558.

Action

Check for an open circuit on the signal, power supply and power return lines.

  • Measure the resistance from the ignition reference signal pin on the capacitive coil driver wiring harness connector to the ignition reference signal pin on the CM558 connector.
  • Measure the resistance from the 24-VDC supply pin on the capacitive coil driver wiring harness connector to the 24-VDC supply terminal on the power supply relay.
  • Measure the resistance from the 24-VDC return pin on the capacitive coil driver wiring harness connector to the 24-VDC return on the power supply.
  • Measure the resistance from the 24-VDC supply pin on the CM558 wiring harness connector to the 24-VDC supply on the power supply.
  • Measure the resistance from the 24-VDC return pin on the CM558 wiring harness connector to the 24-VDC return on the power supply.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the capacitive coil driver.

Guided Step 3A - Check the ignition reference signal.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main harness connectors from the right bank CM558.

Action

Check the voltage on the ignition reference signal pin on the CM558 main harness connector.

  • Install a jumper across the contacts of the capacitive coil driver power supply relay. Be sure that 24-VDC is applied to the circuit.
  • Measure the ignition reference signal voltage using a multimeter.

5-VDC?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • All components connected
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Use INSITE™ electronic service tool to verify the fault codes.

Fault Code 461 inactive?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that fault code is inactive.

Fault Code 461 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if the steps have been completed and checked again.

Go to 5A

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

WARNING

EXTREMELY HIGH VOLTAGE. Do not touch any ignition wiring or component while the engine is operating unless an insulated tool is being used to prevent electrical shock and damage to the equipment.
CAUTION

To reduce the possibility of damaging a new ECM, all other fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement.Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3823995 - male Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 441, 442, 477, or 478 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the harness and the connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin on the capacitive coil driver connector. | More than 100k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check the capacitive coil driver. |
 | STEP 3A. Check the ignition reference signal. | 5-VDC?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 462 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 462 inactive?
 | STEP 5B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 441, 442, 477, or 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting step

Go to 2A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the harness and connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the wiring harness connector for the capacitive coil driver
  • Disconnect the main harness connectors from the CM558.

Action

Inspect the engine harnes and CM558 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a pin to pin short circuit on the capacitive coil driver connector.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the wiring harness connector for the capacitive coil driver
  • Disconnect the main harness connectors from the CM558.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the ignition reference signal pin to all others on the capacitive coil driver wiring harness connector.
  • Measure the resistance from the 24-VDC supply pin to all other pins on the capacitive coil driver wiring harness connector.
  • Measure the resistance from the 24-VDC return pin to all other pins on the capacitive coil driver wiring harness connector.
  • Measure the resistance from the ignition reference signal pin to all others on the CM558 connectors.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the wiring harness connector for the capacitive coil driver
  • Disconnect the main harness connectors from the CM558.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance from the ignition reference signal pin on the capacitive coil driver wiring harness connector to engine block ground.
  • Measure the resistance from the 24-VDC supply pin the capacitive coil driver wiring harness connector to engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the wiring harness connector for the capacitive coil driver
  • Disconnect the main harness connectors from the CM558.

Action

Check for an open circuit on the signal power supply and power return lines.

  • Measure the resistance from the ignition reference signal pin on the capacitive coil driver wiring harness connector to the Ignition Reference Signal pin on the CM558 connector.
  • Measure the resistance from the 24-VDC supply pin on the capacitive coil driver wiring harness connector to the 24-VDC supply terminal on the power supply relay.
  • Measure the resistance from the 24-VDC return pin on the capacitive coil driver wiring harness connector to the 24-VDC return on the power supply.
  • Measure the resistance from the 24-VDC supply pin on the CM558 wiring harness connector to the 24-VDC supply on the power supply.
  • Measure the resistance from the 24-VDC return pin on the CM558 wiring harness connector to the 24-VDC return on the power supply.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 ) in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the capacitive coil driver.

Guided Step 3A - Check the ignition reference signal.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the main harness connectors from the right bank CM558.

Action

Check the voltage on the ignition reference signal pin on the CM558 main harness connector.

  • Install a jumper across the contacts of the capacitive coil driver power supply relay. Be sure that 24-VDC is applied to the circuit.
  • Use a multimeter to measure the ignition reference signal voltage.

5-VDC?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for a CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • All components connected
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Use INSITE™ electronic service tool to verify the fault codes.

Fault Code 462 inactive?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Verify that the fault code is inactive.

  • Use INSITE™electronic service tool to verify the fault code is inactive.

Fault Code 462 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting steps.

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3824811 - male Deutsch™ test leadPart Number 3824812 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable connections. | Damaged connections?
 | STEP 1B. Check the battery voltage. | +17.3 to 34.7-VDC (24-VDC system)?
 | STEP 1C. Verify 120-VAC supplied to DC power supply. | 120-VAC?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the battery cable connections. | No damaged connections?
 | STEP 2B. Check the battery supply fuses. | Less than 10 ohms?
 | STEP 2C. Inspect the wiring harness and connector pins. | Pins OK?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
 | STEP 2E. Check for a short circuit from pin to pin | More than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 477 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Inspect the DC power supply cable connections for the following:

  • Corrosion
  • Loose connections.

Damaged connections?
YES NO

Repair

Repair the damaged connections.

Tighten the DC power supply connections and clean the terminals. Refer to the Power Supply Manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check the battery voltage.

  • Measure the voltage from the positive (+) terminal to the negative (-) terminal of the DC power supply.

+17.3 to 34.7-VDC (24-VDC system)?
YES NO
No Repair

Repair

Repair or replace the DC power supply.

Go to 2A

Go to 1C

Guided Step 1C - Verify 120-VAC supplied to DC power supply.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Verify 120-VAC supplied to DC power supply.

Measure the 120-VAC input to the DC power supply.

120-VAC?
YES NO

Repair

Repair or replace the DC power supply.

Repair

Make sure input circuit breakers are turned on.

Check the input supply fuses.

Go to 3A

Go to 3A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the battery ground connections.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check the battery ground connection.

  • Measure the resistance from the negative (-) terminal on the DC power supply to the engine block ground.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair the battery ground connection. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the battery supply fuses.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check each fuse in the Isolated Battery Supply Circuit to see if any fuse is blown.

  • Refer to the wiring diagram to identify all fuses in the circuit.

Fuse OK?
YES NO
No Repair

Repair

Replace the fuse. Refer to Procedure 019-198 (Fuse, Harness In-Line) in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the wiring harness and connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Inspect the OEM harness and OEM interface harness connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness from the extension harness (if installed)
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for an open circuit.

  • Measure the resistance from all pins being supplied by the DC power supply on the engine harness to the positive (+) terminal connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify the connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness from the extension harness (if installed)
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for a short circuit in the battery supply circuit.

  • Measure the resistance from all DC power supply pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify the connectors and pins.

More than 100k ohms?
YES NO

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 1A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify that the fault codes are inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the run mode and engine running for greater than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 477 is inactive.

Fault Code 477 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3824811 - male Deutsch™ test leadPart Number 3824812 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable connections. | Damaged connections?
 | STEP 1B. Check the battery voltage. | +17.3 to 34.7-VDC (24-VDC system)?
 | STEP 1C. Verify 120-VAC supplied to DC power supply. | 120-VAC?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the battery cable connections. | Damaged connections?
 | STEP 2B. Check the battery supply fuses. | Less than 10 ohms?
 | STEP 2C. Inspect the wiring harness and connector pins. | Pins OK?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
 | STEP 2E. Check for a short circuit from pin to pin | More than 100k ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 478 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable connections.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Inspect the DC power supply cable connections for the following:

  • Corrosion
  • Loose connections.

Damaged connections?
YES NO

Repair

Repair the damaged connections.

Tighten the DC power supply connections and clean the terminals. Refer to the Power Supply Manual.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check the battery voltage.

  • Measure the voltage from the positive (+) terminal to the negative (-) terminal of the DC power supply.

+17.3 to 34.7-VDC (24-VDC system)?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1C

Guided Step 1C - Verify 120-VAC supplied to DC power supply.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Verify 120-VAC supplied to DC power supply.

Measure the 120-VAC input to the DC power supply.

120-VAC?
YES NO

Repair

Repair or replace the DC power supply.

Repair

Make sure input circuit breakers are turned on.

Check the input supply fuses.

Go to 3A

Go to 3A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the battery ground connections.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check the battery ground connection.

  • Measure the resistance from the negative (-) terminal on the DC power supply to the engine block ground.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair the battery ground connection. Refer to Procedure 019-197 (Ring Terminal) in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the battery supply fuses.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode.

Action

Check each fuse in the Isolated Battery Supply Circuit to see if any fuse is blown.

  • Refer to the wiring diagram to identify all fuses in the circuit.

Fuse OK?
YES NO
No Repair

Repair

Replace the fuse. Refer to Procedure 019-198 (Fuse, Harness In-Line) in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the wiring harness and connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness from the extension harness (if installed).

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Inspect the OEM harness and OEM interface harness connector pins.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness from the extension harness (if installed)
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for an open circuit.

  • Measure the resistance from all pins being supplied by the DC power supply on the engine harness to the positive (+) terminal connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify the connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto in the Stop mode
  • Disconnect the engine harness from the extension harness (if installed)
  • Disconnect the positive (+) terminal of the DC power supply.

Action

Check for a short circuit in the battery supply circuit.

  • Measure the resistance from all DC power supply pin on the engine harness connector to all other pins on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify the connectors and pins.

More than 100k ohms?
YES NO

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 1A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify that the fault codes are inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the run mode and engine running for greater than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 478 is inactive.

Fault Code 478 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 153 and 154 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop position.

Action

Check the ECM.

  • Use an electronic service tool to read the active fault codes.

Fault Codes 153 and 154 active?
YES NO
No Repair

Repair

Refer to the Intake Manifold Air Temperature Above Specification symptom tree in this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop position
  • Connect all components
  • Connect the electronics service tool.

Action

Clear the inactive fault codes.

  • Using the electronic service tool, clear the inactive fault codes.

All faults cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Codes 441, 442 or 477, 478 active?
STEP 2. | Check the throttle driver. |
 | STEP 2A. Inspect the throttle driver and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the throttle driver supply voltage. | 24-VDC?
 | STEP 2C. Check the throttle driver signal circuit. | More than 20 mA?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 4. | Check the CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 512 is inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that fault code is inactive. | Fault Code 512 is inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes 441, 442, 447, or 448 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the throttle driver.

Guided Step 2A - Inspect the throttle driver and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connectors from the throttle driver.

Action

Inspect the throttle driver and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the throttle driver, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 (Danfoss (Circular DIN Series) Connector) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the throttle driver. Refer to Procedure 019-429 (Throttle Driver) in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the throttle driver supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connectors from the throttle driver power connection
  • Connect INSITE™ electronic service tool.

Action

Check throttle driver supply voltage.

Measure the driver supply voltage with a multimeter.

24-VDC?
YES NO
No Repair

Repair

Check the power supply connections and the fuses in the harness. Refer to the engine wiring diagram for the appropriate circuit.

Go to 2C

Go to 3A

Guided Step 2C - Check the throttle driver position signal current.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connectors from the throttle driver position feedback connection
  • Connect INSITE™ electronic service tool.

Action

Check the throttle driver position signal current.

  • Connect an ammeter in series with the positive throttle driver position feedback wire.
  • Use a jumper wire to connect the negative (-) connection.

More than 20 mA?
YES NO

Repair

  • Replace the throttle driver. Refer to Procedure 019-429 (Throttle Driver) in Section 19.
No Repair

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connectors from the throttle driver and the CM558.

Action

Inspect the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the throttle driver
  • Disconnect the engine harness from all sensors that have a shared supply or return with the throttle driver.

Action

Inspect the engine harness connector pins for the following:

  • Measure the resistance from the throttle driver return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the throttle driver position signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Refer to Procedure 019-360 (Resistance Measurements Using a Multimeter) in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for 1 minute
  • Disconnect the throttle driver actuator position feedback connector
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Use INSITE™ electronic service tool to verify the fault codes.

NOTE: Fault Code 513 will become active upon disconnecting the throttle driver position feedback connector.

Fault Code 512 is inactive?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 512 is inactive.

Fault Code 512 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 441, 442, 477 or 478 active?
STEP 2. | Check the throttle driver. |
 | STEP 2A. Inspect the throttle driver and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the throttle driver supply voltage. | 24-VDC?
 | STEP 2C. Check the throttle driver position signal circuit. | Less than 4 mA?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 513 is inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that fault code is inactive. | Fault Code 513 is inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441, 442, 477 or 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the Throttle Driver.

Guided Step 2A - Inspect the throttle driver and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connectors from the throttle driver.

Action

Inspect the throttle driver and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the throttle driver, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 (Danfoss (Circular DIN Series) Connector) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the Throttle Driver. Refer to Procedure 019-429 (Throttle Driver) in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the throttle driver supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connectors from the throttle driver power connection
  • Connect INSITE™ electronic service tool.

Action

Check throttle driver supply voltage.

Measure the supply voltage with a multimeter.

24-VDC?
YES NO
No Repair

Repair

Check the power supply connections and the fuses in the harness. Refer to the engine wiring diagram for the appropriate circuit.

Go to 2C

Go to 3A

Guided Step 2C - Check the throttle driver position signal current.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connectors from the throttle driver position feedback connection
  • Connect INSITE™ electronic service tool.

Action

Check the throttle driver position signal current.

  • Connect an ammeter in series with the positive throttle position feedback wire.
  • Use a jumper wire to connect the negative (-) connection.

Less than 4 mA?
YES NO

Repair

  • Replace the throttle driver. Refer to Procedure 019-429 (Throttle Driver) in Section 19.
No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connectors from the Throttle Driver and the CM558.

Action

Inspect the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the throttle driver
  • Disconnect the engine harness from all sensors that have a shared supply or return with the throttle driver.

Action

Inspect the engine harness connector pins for the following:

  • Measure the resistance from the throttle driver return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the throttle driver position signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Refer to Procedure 019-360 (Resistance Measurements Using a Multimeter) in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the throttle driver position feedback connector.

Action

Check for an open circuit in the signal and return wire.

  • Measure the resistance from the throttle driver return pin on the engine harness connector to the throttle driver return pin on the engine harness sensor connector.
  • Measure the resistance from the throttle driver position signal pin on the engine harness connector to the throttle driver position signal pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Refer to Procedure 019-360 (Resistance Measurements Using a Multimeter) in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running at rated speed and load.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Use INSITE™ electronic service tool to verify the fault codes.

NOTE: Fault Code 513 will become active upon disconnecting the throttle driver position feedback connector.

Fault Code 513 is inactive?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 513 is inactive.

Fault Code 513 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


FAULT CODE 556 - Blowby Pressure - High

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor for accuracy. |
 | STEP 1A. Verify pressure sensor accuracy. | Pressure reading 0 ± 0.25 kPa – g (0 ± 1 in H2O)?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive??

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Do not operate the engine.

Action

  • Make sure the correct sensor part number is installed.
  • When checking the pressure sensor accuracy, make sure the engine is not operating.
  • Use INSITE™ electronic service tool to monitor "Crankcase Pressure".

Pressure reading 0 ± 0.25 kPa – g (0 ± 1 in H2O)?
YES NO
No Repair

Repair

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in Section 19.

Reference the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree in Section TS.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes..

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Read the CM700.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Mar-2017


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1213, 1274, 1281, 1286, 1291, 1296, 1583, and 2282 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specification?
STEP 3. | Check the kilowat load reference calibration. |
 | STEP 3A. Check the kilowatt load tranducer-sensed kilowatts against the generator set controller kilowatts. | Kilowatt load transducer sensed kilowatts match generator set controller kilowatts?
 | STEP 3B. Check the GenSet controller calibration. | GenSet controller voltage and ampere output calibration correct?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor supply voltages and reference resistances within specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor supply and reference voltages within specification?
STEP 6. | Check the quality of the natural gas supply to the GenSet. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply meets or exceeds minimum specification for GenSet?
STEP 7. | Inspect the number 1 cylinder head. |
 | STEP 7A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 7B. Check the spark plug gap. | Spark plug gap excessive?
 | STEP 7C. Check the cylinder head. | Leaking gaskets or loose components?
 | STEP 7D. Check the valve lash. | Valve lash correct?
 | STEP 7E. Check the valve train. | Worn or mis-set valve train components?
STEP 8. | Inspect cylinder 1 power cylinder. |
 | STEP 8A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 8B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 8C. Inspect the connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 8D. Inspect the piston cooling nozzle. | Piston cooling nozzle bent or missing?
 | STEP 8E. Check cylinder 1 and adjacent cylinder main bearings. | Main bearings damaged?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 561 inactive?
 | STEP 9B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1213, 1274, 1281, 1286, 1291, 1296, 1583, and 2282 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Reference troubleshooting symptom tree t048 (Engine Noise Excessive - Combustion Knocks) in Section TS.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Connect an exhaust gas analyzer.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode and operate at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Check the exhaust emissions.

  • Use an exhaust gas analyzer. With the sample probe inserted into the exhaust gas manifold test port, check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure for exhaust emission specfications in the Operation and Maintenance Manual, Generator Set QSK60G CM700, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specfication?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool. Reference the exhaust gas analyzer, adjust the 'open and closed-loop' fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.

  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 9A

Guided Step 3 - Check the kilowatt load reference signal.

Guided Step 3A - Check the kilowatt load transducer, reference signal - where fitted.

Conditions

NOTE: If the generator set is not fitted with a kilowatt load transducer then proceed to Guided Step 3B.

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode with load available.

Action

Check the load.

  • Check the kilowatt load transducer-sensed kilowatts against the generator set controller displayed kilowatts.
  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatts match generator set controller kilowatts?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool to calibrate the kilowatt load sensor milliamp/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the calibration of the GenSet controller.

Conditions

NOTE: This guided step should ONLY be followed for generator sets not fitted with a kilowatt load transducer.

  • Connect all components.
  • Connect a power analyzer or digital multimeter.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode with load available.

Action

Check the GenSet controller.

  • Connect a power analyzer or digital multimeter to the alternator main output terminals. Check that the GenSet controller readings for output voltage (L1-L2, L2-L3, and L-3-L1) and amperes (L1, L2, and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

GenSet controller output voltage and amperes readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter. Recalibrate the GenSet controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode. Operate at maximum possible load with no knock present.

Action

Check the intake manifold temperature.

  • Use the generator set Human Machine Interface (HMI) to check the intake manifold temperature.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold temperature within specification?
YES NO
No Repair

Repair

Check the following:

  • Check the temperature of the high temperature (HT) coolant outlet from the engine. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 018-018 in Section V.
  • Check the temperature of the low temperature (LT) coolant outlet from the engine.Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 018-018 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the intake manifold temperature sensor.

  • Check the intake manifold temperature sensor resistances.

NOTE: The intake manifold temperature sensor may have failed 'in range' and the related fault codes will not be activated. Reference Fault Code 153 (Intake Manifold Temperature Sensor Shorted High) or Fault Code 154 (Intake Manifold Temperature Sensor Shorted Low) in Section TF.

  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
  • Use the following procedure for intake manifold temperature sensor specifications. Refer to Procedure 019-059 in Section 19.

Intake manifold temperature sensor resistances to specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode., Operate at maximum possible load with no knock present.

Action

Check the intake manifold pressure.

  • Use the generator set Human Machine Interface (HMI) to check the intake manifold pressure.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396 for the air intake system. Refer to Procedure 018-019 in Section V.

Intake manifold pressure within specification?
YES NO
No Repair

Repair

Check the following:

  • If fitted, check the operation of the compressor bypass valve (single turbocharger engines only).
  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the intake manifold pressure.

  • Check the intake manifold temperature sensor.

NOTE: The intake manifold pressure sensor may have failed 'in range' and the related fault codes will not be activated. Reference Fault Code 354 (Intake Manifold Pressure Sensor Shorted High) or Fault Code 355 (Intake Manifold Pressure Sensor Shorted Low) in Section TF.

  • Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.
  • Use a wiring diagram for intake manifold pressure sensor specifications.

Intake manifold pressure sensor resistances to specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor. Refer to Procedure 019-061 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the GenSet.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the natural gas supply.

  • Check that the quality of the natural gas supplied to the generator set meets or exceeds minimum requirements for the generator set (methane number and fuel contaminants limits).
  • Use the following procedure in the Operation and Maintenance Manual, QSK60G CM700 Generator Set, Bulletin 4021395, for fuel recommendations and specifications. Refer to Procedure 018-002 in Section V.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspection of cylinder 1 cylinder head.

Guided Step 7A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tighened.
  • Spark plug 'J' connector damaged.
  • Inspect the electrode for signs of oil contamination.
  • Spark plug porcelain damaged. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder 1 spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Retighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder 1 spark plug gap excessive?
YES NO

Repair

Replace the spark plug:

  • Replace the spark plug. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396, for the electrical system. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7C

Guided Step 7C - Check the cylinder head.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the cylinder head.

Inspect the cylinder 1 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases. Use the following procedure to replace the cylinder head gasket in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder 1 cylinder head.

Cylinder 1 cylinder head gaskets leaking or loose components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head gasket. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396, to replace the cylinder head gasket. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure to replace the cylinder head gasket in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose components on or immediately around cylinde 1 cylinder head. Reference the appropriate procedures in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396.
No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check that the valve lash is correct.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the valve lash.

  • Check to see if the cylinder 1 valve lash setting is correct. Use the following procedure to set valve lash in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 1 valve lash setting correct?
YES NO
No Repair

Repair

Repair as necessary:

  • Proceed to the next troubleshooting step.

Go to 8A

Go to 7E

Guided Step 7E - Check the valve train.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the valve train.

Inspect the cylinder 1 valve train for the following:

  • Inlet or exhaust valve wear/recession or damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Cam follower wear. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder 1 camshaft lobe wear. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Cylinder 1 valve train wear?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the cam follower. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the rocker lever assembly. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

Adjust the valve lash:

  • Use the following procedure to set valve lash in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 9A

Go to 8A

Guided Step 8 - Inspection of cylinder 1 power cylinder.

Guided Step 8A - Cut open the oil filter(s) and inspect for debris.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the oil filters.

  • Remove the lubricating oil filter(s). Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396 to remove the oil filters. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter(s) and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filter(s)?
YES NO

Repair

Proceed to the next troubleshooting step

 No Repair

Go to 8B

Go to 8D

Guided Step 8B - Check the internal power cylinder.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the internal power cylinder.

NOTE: If available, these inspections can be performed using a borescope without component removal.

Inspect the internal power cylinder for the following:

  • Piston ring scuffing or breakage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 1 power cylinder damaged?
YES NO

Repair

Replace as necessary:

  • Replace the piston rings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Replace the liner. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-045 in Section 1.
  • Replace the cylinder head. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the connecting rod bearings.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the connecting rod bearings.

Inspect the cylinder 1 connecting rod bearings for excessive wear or damage. Use the following procedure to remove the connecting rod bearings in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder 1 connecting rod bearings damaged?
YES NO

Repair

Replace the connecting rod bearings:

  • Replace the connecting rod bearings. Use the following procedure to remove the connecting rod bearings in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.
No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the piston cooling nozzle.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the piston cooling nozzle.

Cylinder 1 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle.

  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.
No Repair

Go to 9A

Go to 8E

Guided Step 8E - Inspect cylinder 1 and immediately adjacent main bearings.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect main bearings.

  • Inspect cylinder 1 and immediately adjacent main bearings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-006 in Section 2.

Cylinder 1 or immediately adjacent main bearings worn or damaged?
YES NO

Repair

Replace the main bearings as required (cylinder 1 or immediately adjacent cylinders):

  • Replace the main bearings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.
No Repair

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode and operate engine for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 569 is inactive.

Fault Code 561 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1213, 1274, 1281, 1286, 1291, 1296, 1583, and 2282 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specification?
STEP 3. | Check the kilowat load reference calibration. |
 | STEP 3A. Check the kilowatt load tranducer-sensed kilowatts against the generator set controller kilowatts. | Kilowatt load transducer sensed kilowatts match generator set controller kilowatts?
 | STEP 3B. Check the GenSet controller calibration. | GenSet controller voltage and ampere output calibration correct?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor supply voltage and reference resistance within specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor supply and reference voltage within specification?
STEP 6. | Check the quality of the natural gas supply to the GenSet. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply meets or exceeds minimum specification for GenSet?
STEP 7. | Inspect the number 2 cylinder head. |
 | STEP 7A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 7B. Check the spark plug gap. | Spark plug gap excessive?
 | STEP 7C. Check the cylinder head. | Leaking gaskets or loose components?
 | STEP 7D. Check the valve lash. | Valve lash correct?
 | STEP 7E. Check the valve train. | Worn or mis-set valve train components?
STEP 8. | Inspect cylinder 2 power cylinder. |
 | STEP 8A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 8B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 8C. Inspect the connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 8D. Inspect the piston cooling nozzle. | Piston cooling nozzle bent or missing?
 | STEP 8E. Check cylinder 2 and adjacent cylinder main bearings. | Main bearings damaged?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 562 inactive?
 | STEP 9B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1213, 1274, 1281, 1286, 1291, 1296, 1583, and 2282 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Reference troubleshooting symptom tree t048 (Engine Noise Excessive - Combustion Knocks) in Section TS.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Connect an exhaust gas analyzer.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode and operate at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Check the exhaust emissions.

  • Use an exhaust gas analyzer. With the sample probe inserted into the exhaust gas manifold test port, check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure for exhaust emission specfications in the Operation and Maintenance Manual, Generator Set QSK60G CM700, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specfication?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool. Reference the exhaust gas analyzer, adjust the 'open and closed-loop' fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.

  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 9A

Guided Step 3 - Check the kilowatt load reference signal.

Guided Step 3A - Check the kilowatt load transducer, reference signal - where fitted.

Conditions

NOTE: If the generator set is not fitted with a kilowatt load transducer, then proceed to Guided Step 3B.

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode with load available.

Action

Check the load.

  • Check the kilowatt load transducer-sensed kilowatts against the generator set controller displayed kilowatts.
  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatts match generator set controller kilowatts?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool to calibrate the kilowatt load sensor milliamp/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the calibration of the GenSet controller.

Conditions

NOTE: This guided step should ONLY be followed for generator sets not fitted with a kilowatt load transducer.

  • Connect all components.
  • Connect a power analyzer or digital multimeter.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode with load available.

Action

Check the GenSet controller.

  • Connect a power analyzer or digital multimeter to the alternator main output terminals. Check that the GenSet controller readings for output voltage (L1-L2, L2-L3, and L-3-L1) and amperes (L1, L2, and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

GenSet controller output voltage and ampere readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter. Recalibrate the GenSet controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode. Operate at maximum possible load with no knock present.

Action

Check the intake manifold temperature.

  • Use the generator set Human Machine Interface (HMI) to check the intake manifold temperature.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold temperature within specification?
YES NO
No Repair

Repair

Check the following:

  • Check the temperature of the high temperature (HT) coolant outlet from the engine. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 018-018 in Section V.
  • Check the temperature of the low temperature (LT) coolant outlet from the engine.Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 018-018 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the intake manifold temperature sensor.

  • Check the intake manifold temperature sensor resistances.

NOTE: The intake manifold temperature sensor may have failed 'in range' and the related fault codes will not be activated. Reference Fault Code 153 (Intake Manifold Temperature Sensor Shorted High) or Fault Code 154 (Intake Manifold Temperature Sensor Shorted Low) in Section TF.

  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
  • Use the following procedure for intake manifold temperature sensor specifications. Refer to Procedure 019-059 in Section 19.

Intake manifold temperature sensor resistances to specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode., Operate at maximum possible load with no knock present.

Action

Check the intake manifold pressure.

  • Use the generator set Human Machine Interface (HMI) to check the intake manifold pressure.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396 for the air intake system. Refer to Procedure 018-019 in Section V.

Intake manifold pressure within specification?
YES NO
No Repair

Repair

Check the following:

  • If fitted, check the operation of the compressor bypass valve (single turbocharger engines only).
  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the intake manifold pressure.

  • Check the intake manifold temperature sensor.

NOTE: The intake manifold pressure sensor may have failed 'in range' and the related fault codes will not be activated. Reference Fault Code 354 (Intake Manifold Pressure Sensor Shorted High) or Fault Code 355 (Intake Manifold Pressure Sensor Shorted Low) in Section TF.

  • Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.
  • Use a wiring diagram for intake manifold pressure sensor specifications.

Intake manifold pressure sensor resistance to specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor. Refer to Procedure 019-061 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the GenSet.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the natural gas supply.

  • Check that the quality of the natural gas supplied to the generator set meets or exceeds minimum requirements for the generator set (methane number and fuel contaminants limits).
  • Use the following procedure in the Operation and Maintenance Manual, QSK60G CM700 Generator Set, Bulletin 4021395, for fuel recommendations and specifications. Refer to Procedure 018-002 in Section V.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspection of cylinder 2 cylinder head.

Guided Step 7A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • Spark plug 'J' connector damaged.
  • Inspect the electrode for signs of oil contamination.
  • Spark plug porcelain damaged. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder 2 spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder 2 spark plug gap excessive?
YES NO

Repair

Replace the spark plug:

  • Replace the spark plug. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396, for the electrical system. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7C

Guided Step 7C - Check the cylinder head.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the cylinder head.

Inspect the cylinder 2 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder 2 cylinder head.

Cylinder 2 cylinder head gasket leaking or loose components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head gasket. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose components on or immediately around cylinder 1 cylinder head. Reference the appropriate procedures in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396.
No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check that the valve lash is correct.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the valve lash.

  • Check to see if the cylinder 2 valve lash setting is correct. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 2 valve lash setting correct?
YES NO
No Repair

Repair

Repair as necessary:

  • Proceed to the next troubleshooting step.

Go to 8A

Go to 7E

Guided Step 7E - Check the valve train.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the valve train.

Inspect the cylinder 2 valve train for the following:

  • Inlet or exhaust valve wear/recession or damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Cam follower wear. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder 2 camshaft lobe wear. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Cylinder 2 valve train wear?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the cam follower. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the rocker lever assembly. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

Adjust the valve lash:

  • Use the following procedure to set valve lash in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 9A

Go to 8A

Guided Step 8 - Inspection of cylinder 2 power cylinder.

Guided Step 8A - Cut open the oil filter(s) and inspect for debris.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the oil filters.

  • Remove the lubricating oil filter(s). Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter(s) and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filter(s)?
YES NO

Repair

Proceed to the next troubleshooting step

 No Repair

Go to 8B

Go to 8D

Guided Step 8B - Check the internal power cylinder.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the internal power cylinder.

NOTE: If available, these inspections can be performed using a borescope without component removal.

Inspect the internal power cylinder for the following:

  • Piston ring scuffing or breakage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 2 power cylinder damaged?
YES NO

Repair

Replace as necessary:

  • Replace the piston rings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Replace the liner. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-045 in Section 1.
  • Replace the cylinder head. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the connecting rod bearings.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the connecting rod bearings.

Inspect the cylinder 2 connecting rod bearings for excessive wear or damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder 2 connecting rod bearings damaged?
YES NO

Repair

Replace the connecting rod bearings:

  • Replace the connecting rod bearings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.
No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the piston cooling nozzle.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the piston cooling nozzle.

Cylinder 2 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle.

  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.
No Repair

Go to 9A

Go to 8E

Guided Step 8E - Inspect cylinder 2 and immediately adjacent main bearings.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect main bearings.

  • Inspect cylinder 2 and immediately adjacent main bearings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-006 in Section 2.

Cylinder 2 or immediately adjacent main bearings worn or damaged?
YES NO

Repair

Replace the main bearings as required (cylinder 2 or immediately adjacent cylinders):

  • Replace the main bearings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.
No Repair

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode and operate engine for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 562 is inactive.

Fault Code 562 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1213, 1274, 1281, 1286, 1291, 1296, 1583, and 2282 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specification?
STEP 3. | Check the kilowatt load reference calibration. |
 | STEP 3A. Check the kilowatt load tranducer-sensed kilowatts against the generator set controller kilowatts. | Kilowatt load transducer-sensed kilowatts match generator set controller kilowatts?
 | STEP 3B. Check the GenSet controller calibration. | GenSet controller voltage and ampere output calibration correct?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor supply voltage and reference resistance within specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor supply and reference voltage within specification?
STEP 6. | Check the quality of the natural gas supply to the GenSet. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply meets or exceeds minimum specification for GenSet?
STEP 7. | Inspect the number 3 cylinder head. |
 | STEP 7A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 7B. Check the spark plug gap. | Spark plug gap excessive?
 | STEP 7C. Check the cylinder head. | Leaking gaskets or loose components?
 | STEP 7D. Check the valve lash. | Valve lash correct?
 | STEP 7E. Check the valve train. | Worn or mis-set valve train components?
STEP 8. | Inspect cylinder 3 power cylinder. |
 | STEP 8A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 8B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 8C. Inspect the connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 8D. Inspect the piston cooling nozzle. | Piston cooling nozzle bent or missing?
 | STEP 8E. Check cylinder 3 and adjacent cylinder main bearings. | Main bearings damaged?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 563 inactive?
 | STEP 9B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1213, 1274, 1281, 1286, 1291, 1296, 1583, and 2282 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Reference troubleshooting symptom tree t048 (Engine Noise Excessive - Combustion Knocks) in Section TS.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Connect an exhaust gas analyzer.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode and operate at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Check the exhaust emissions.

  • Use an exhaust gas analyzer. With the sample probe inserted into the exhaust gas manifold test port, check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure for exhaust emission specfications in the Operation and Maintenance Manual, Generator Set QSK60G CM700, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specfication?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool. Reference the exhaust gas analyzer, adjust the 'open and closed-loop' fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.

  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 9A

Guided Step 3 - Check the kilowatt load reference signal.

Guided Step 3A - Check the kilowatt load transducer, reference signal - where fitted.

Conditions

NOTE: If the generator set is not fitted with a kilowatt load transducer, then proceed to Guided Step 3B.

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode with load available.

Action

Check the load.

  • Check the kilowatt load transducer-sensed kilowatts against the generator set controller displayed kilowatts.
  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatts match generator set controller kilowatts?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool to calibrate the kilowatt load sensor milliamp/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the calibration of the GenSet controller.

Conditions

NOTE: This guided step should ONLY be followed for generator sets not fitted with a kilowatt load transducer.

  • Connect all components.
  • Connect a power analyzer or digital multimeter.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode with load available.

Action

Check the GenSet controller.

  • Connect a power analyzer or digital multimeter to the alternator main output terminals. Check that the GenSet controller readings for output voltage (L1-L2, L2-L3, and L-3-L1) and amperes (L1, L2, and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

GenSet controller output voltage and ampere readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter. Recalibrate the GenSet controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode. Operate at maximum possible load with no knock present.

Action

Check the intake manifold temperature.

  • Use the generator set Human Machine Interface (HMI) to check the intake manifold temperature.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold temperature within specification?
YES NO
No Repair

Repair

Check the following:

  • Check the temperature of the high temperature (HT) coolant outlet from the engine. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 018-018 in Section V.
  • Check the temperature of the low temperature (LT) coolant outlet from the engine.Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 018-018 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the intake manifold temperature sensor.

  • Check the intake manifold temperature sensor resistances.

NOTE: The intake manifold temperature sensor may have failed 'in range' and the related fault codes will not be activated. Reference Fault Code 153 (Intake Manifold Temperature Sensor Shorted High) or Fault Code 154 (Intake Manifold Temperature Sensor Shorted Low) in Section TF.

  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
  • Use the following procedure for intake manifold temperature sensor specifications. Refer to Procedure 019-059 in Section 19.

Intake manifold temperature sensor resistances to specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode., Operate at maximum possible load with no knock present.

Action

Check the intake manifold pressure.

  • Use the generator set Human Machine Interface (HMI) to check the intake manifold pressure.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396 for the air intake system. Refer to Procedure 018-019 in Section V.

Intake manifold pressure within specification?
YES NO
No Repair

Repair

Check the following:

  • If fitted, check the operation of the compressor bypass valve (single turbocharger engines only).
  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the intake manifold pressure.

  • Check the intake manifold temperature sensor.

NOTE: The intake manifold pressure sensor may have failed 'in range' and the related fault codes will not be activated. Reference Fault Code 354 (Intake Manifold Pressure Sensor Shorted High) or Fault Code 355 (Intake Manifold Pressure Sensor Shorted Low) in Section TF.

  • Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.
  • Use a wiring diagram for intake manifold pressure sensor specifications.

Intake manifold pressure sensor resistance to specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor. Refer to Procedure 019-061 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the GenSet.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the natural gas supply.

  • Check that the quality of the natural gas supplied to the generator set meets or exceeds minimum requirements for the generator set (methane number and fuel contaminants limits).
  • Use the following procedure in the Operation and Maintenance Manual, QSK60G CM700 Generator Set, Bulletin 4021395, for fuel recommendations and specifications. Refer to Procedure 018-002 in Section V.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspection of cylinder 3 cylinder head.

Guided Step 7A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • Spark plug 'J' connector damaged.
  • Inspect the electrode for signs of oil contamination.
  • Spark plug porcelain damaged. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder 3 spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder 3 spark plug gap excessive?
YES NO

Repair

Replace the spark plug:

  • Replace the spark plug. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7C

Guided Step 7C - Check the cylinder head.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the cylinder head.

Inspect the cylinder 3 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases. Use the following procedure to replace the cylinder head gasket in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder 3 cylinder head.

Cylinder 3 cylinder head gaskets leaking or loose components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head gasket. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose components on or immediately around cylinder 1 cylinder head. Reference the appropriate procedures in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396.
No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check that the valve lash is correct.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the valve lash.

  • Check to see if the cylinder 3 valve lash setting is correct. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 3 valve lash setting correct?
YES NO
No Repair

Repair

Repair as necessary:

  • Proceed to the next troubleshooting step.

Go to 8A

Go to 7E

Guided Step 7E - Check the valve train.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the valve train.

Inspect the cylinder 3 valve train for the following:

  • Inlet or exhaust valve wear/recession or damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Cam follower wear. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder 3 camshaft lobe wear. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Cylinder 3 valve train wear?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the cam follower. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the rocker lever assembly. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

Adjust the valve lash:

  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 9A

Go to 8A

Guided Step 8 - Inspection of cylinder 3 power cylinder.

Guided Step 8A - Cut open the oil filter(s) and inspect for debris.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the oil filters.

  • Remove the lubricating oil filter(s). Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter(s) and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filter(s)?
YES NO

Repair

Proceed to the next troubleshooting step

 No Repair

Go to 8B

Go to 8D

Guided Step 8B - Check the internal power cylinder.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the internal power cylinder.

NOTE: If available, these inspections can be performed using a borescope without component removal.

Inspect the internal power cylinder for the following:

  • Piston ring scuffing or breakage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 3 power cylinder damaged?
YES NO

Repair

Replace as necessary:

  • Replace the piston rings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Replace the liner. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-045 in Section 1.
  • Replace the cylinder head. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the connecting rod bearings.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the connecting rod bearings.

Inspect the cylinder 3 connecting rod bearings for excessive wear or damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder 3 connecting rod bearings damaged?
YES NO

Repair

Replace the connecting rod bearings:

  • Replace the connecting rod bearings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.
No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the piston cooling nozzle.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the piston cooling nozzle.

Cylinder 3 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle.

  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.
No Repair

Go to 9A

Go to 8E

Guided Step 8E - Inspect cylinder 3 and immediately adjacent main bearings.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect main bearings.

  • Inspect cylinder 3 and immediately adjacent main bearings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-006 in Section 2.

Cylinder 3 or immediately adjacent main bearings worn or damaged?
YES NO

Repair

Replace the main bearings as required (cylinder 3 or immediately adjacent cylinders):

  • Replace the main bearings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.
No Repair

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode and operate engine for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 563 is inactive.

Fault Code 563 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1213, 1274, 1281, 1286, 1291, 1296, 1583, and 2282 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specification?
STEP 3. | Check the kilowat load reference calibration. |
 | STEP 3A. Check the kilowatt load tranducer-sensed kilowatts against the generator set controller kilowatts. | Kilowatt load transducer-sensed kilowatts match generator set controller kilowatts?
 | STEP 3B. Check the Gen Set controller calibration. | Gen Set controller voltage and ampere output calibration correct?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor supply voltage and reference resistance within specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor supply and reference voltage within specification?
STEP 6. | Check the quality of the natural gas supply to the Gen Set. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply meets or exceeds minimum specification for Gen Set?
STEP 7. | Inspect the number 4 cylinder head. |
 | STEP 7A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 7B. Check the spark plug gap. | Spark plug gap excessive?
 | STEP 7C. Check the cylinder head. | Leaking gaskets or loose components?
 | STEP 7D. Check the valve lash. | Valve lash correct?
 | STEP 7E. Check the valve train. | Worn or mis-set valve train components?
STEP 8. | Inspect cylinder 4 power cylinder. |
 | STEP 8A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 8B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 8C. Inspect the connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 8D. Inspect the piston cooling nozzle. | Piston cooling nozzle bent or missing?
 | STEP 8E. Check cylinder 4 and adjacent cylinder main bearings. | Main bearings damaged?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 564 inactive?
 | STEP 9B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1213, 1274, 1281, 1286, 1291, 1296, 1583, and 2282 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Reference troubleshooting symptom tree t048 (Engine Noise Excessive - Combustion Knocks) in Section TS.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Connect an exhaust gas analyzer.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode and operate at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Check the exhaust emissions.

  • Use an exhaust gas analyzer. With the sample probe inserted into the exhaust gas manifold test port, check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure for exhaust emission specfications in the Operation and Maintenance Manual, Generator Set QSK60G CM700, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specfication?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool. Reference the exhaust gas analyzer, adjust the 'open and closed-loop' fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.

  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 9A

Guided Step 3 - Check the kilowatt load reference signal.

Guided Step 3A - Check the kilowatt load transducer, reference signal - where fitted.

Conditions

NOTE: If the generator set is not fitted with a kilowatt load transducer, then proceed to Guided Step 3B.

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode with load available.

Action

Check the load.

  • Check the kilowatt load transducer-sensed kilowatts against the generator set controller displayed kilowatts.
  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatts match generator set controller kilowatts?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool to calibrate the kilowatt load sensor milliamp/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the calibration of the Gen Set controller.

Conditions

NOTE: This guided step should ONLY be followed for generator sets not fitted with a kilowatt load transducer.

  • Connect all components.
  • Connect a power analyzer or digital multimeter.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode with load available.

Action

Check the GenSet controller.

  • Connect a power analyzer or digital multimeter to the alternator main output terminals. Check that the Gen Set controller readings for output voltage (L1-L2, L2-L3, and L-3-L1) and amperes (L1, L2, and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Gen Set controller output voltage and ampere readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter. Recalibrate the Gen Set controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode. Operate at maximum possible load with no knock present.

Action

Check the intake manifold temperature.

  • Use the generator set Human Machine Interface (HMI) to check the intake manifold temperature.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold temperature within specification?
YES NO
No Repair

Repair

Check the following:

  • Check the temperature of the high temperature (HT) coolant outlet from the engine. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 018-018 in Section V.
  • Check the temperature of the low temperature (LT) coolant outlet from the engine.Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 018-018 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the intake manifold temperature sensor.

  • Check the intake manifold temperature sensor resistances.

NOTE: The intake manifold temperature sensor may have failed 'in range' and the related fault codes will not be activated. Reference Fault Code 153 (Intake Manifold Temperature Sensor Shorted High) or Fault Code 154 (Intake Manifold Temperature Sensor Shorted Low) in Section TF.

  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
  • Use the following procedure for intake manifold temperature sensor specifications. Refer to Procedure 019-059 in Section 19.

Intake manifold temperature sensor resistances to specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode., Operate at maximum possible load with no knock present.

Action

Check the intake manifold pressure.

  • Use the generator set Human Machine Interface (HMI) to check the intake manifold pressure.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396 for the air intake system. Refer to Procedure 018-019 in Section V.

Intake manifold pressure within specification?
YES NO
No Repair

Repair

Check the following:

  • If fitted, check the operation of the compressor bypass valve (single turbocharger engines only).
  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the intake manifold pressure.

  • Check the intake manifold temperature sensor.

NOTE: The intake manifold pressure sensor may have failed 'in range' and the related fault codes will not be activated. Reference Fault Code 354 (Intake Manifold Pressure Sensor Shorted High) or Fault Code 355 (Intake Manifold Pressure Sensor Shorted Low) in Section TF.

  • Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.
  • Use a wiring diagram for intake manifold pressure sensor specifications.

Intake manifold pressure sensor resistance to specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor. Refer to Procedure 019-061 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the Gen Set.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the natural gas supply.

  • Check that the quality of the natural gas supplied to the generator set meets or exceeds minimum requirements for the generator set (methane number and fuel contaminants limits).
  • Use the following procedure in the Operation and Maintenance Manual, QSK60G CM700 Generator Set, Bulletin 4021395, for fuel recommendations and specifications. Refer to Procedure 018-002 in Section V.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspection of cylinder 4 cylinder head.

Guided Step 7A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • Spark plug 'J' connector damaged.
  • Inspect the electrode for signs of oil contamination.
  • Spark plug porcelain damaged. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder 4 spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder 4 spark plug gap excessive?
YES NO

Repair

Replace the spark plug:

  • Replace the spark plug. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7C

Guided Step 7C - Check the cylinder head.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the cylinder head.

Inspect the cylinder 4 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder 4 cylinder head.

Cylinder 4 cylinder head gaskets leaking or loose components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head gasket. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose components on or immediately around cylinde 1 cylinder head. Reference the appropriate procedures in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396.
No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check that the valve lash is correct.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the valve lash.

  • Check to see if the cylinder 4 valve lash setting is correct. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 4 valve lash setting correct?
YES NO
No Repair

Repair

Repair as necessary:

  • Proceed to the next troubleshooting step.

Go to 8A

Go to 7E

Guided Step 7E - Check the valve train.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the valve train.

Inspect the cylinder 4 valve train for the following:

  • Inlet or exhaust valve wear/recession or damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Cam follower wear. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder 4 camshaft lobe wear. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Cylinder 4 valve train wear?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the cam follower. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the rocker lever assembly. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

Adjust the valve lash:

  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 9A

Go to 8A

Guided Step 8 - Inspection of cylinder 4 power cylinder.

Guided Step 8A - Cut open the oil filter(s) and inspect for debris.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the oil filters.

  • Remove the lubricating oil filter(s). Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter(s) and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filter(s)?
YES NO

Repair

Proceed to the next troubleshooting step

 No Repair

Go to 8B

Go to 8D

Guided Step 8B - Check the internal power cylinder.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the internal power cylinder.

NOTE: If available, these inspections can be performed using a borescope without component removal.

Inspect the internal power cylinder for the following:

  • Piston ring scuffing or breakage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 4 power cylinder damaged?
YES NO

Repair

Replace as necessary:

  • Replace the piston rings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Replace the liner. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-045 in Section 1.
  • Replace the cylinder head. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the connecting rod bearings.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the connecting rod bearings.

Inspect the cylinder 4 connecting rod bearings for excessive wear or damage. Use the following procedure to remove the connecting rod bearings in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder 4 connecting rod bearings damaged?
YES NO

Repair

Replace the connecting rod bearings:

  • Replace the connecting rod bearings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.
No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the piston cooling nozzle.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the piston cooling nozzle.

Cylinder 4 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle.

  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.
No Repair

Go to 9A

Go to 8E

Guided Step 8E - Inspect cylinder 4 and immediately adjacent main bearings.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect main bearings.

  • Inspect cylinder 4 and immediately adjacent main bearings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-006 in Section 2.

Cylinder 4 or immediately adjacent main bearings worn or damaged?
YES NO

Repair

Replace the main bearings as required (cylinder 4 or immediately adjacent cylinders):

  • Replace the main bearings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.
No Repair

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode and operate engine for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 564 is inactive.

Fault Code 564 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1213, 1274, 1281, 1286, 1291, 1296, 1583, and 2282 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specification?
STEP 3. | Check the kilowat load reference calibration. |
 | STEP 3A. Check the kilowatt load tranducer-sensed kilowatts against the generator set controller kilowatts. | Kilowatt load transducer sensed kilowatts match generator set controller kilowatts?
 | STEP 3B. Check the GenSet controller calibration. | GenSet controller voltage and ampere output calibration correct?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor supply voltage and reference resistance within specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor supply and reference voltage within specification?
STEP 6. | Check the quality of the natural gas supply to the GenSet. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply meets or exceeds minimum specification for GenSet?
STEP 7. | Inspect the number 5 cylinder head. |
 | STEP 7A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 7B. Check the spark plug gap. | Spark plug gap excessive?
 | STEP 7C. Check the cylinder head. | Leaking gaskets or loose components?
 | STEP 7D. Check the valve lash. | Valve lash correct?
 | STEP 7E. Check the valve train. | Worn or mis-set valve train components?
STEP 8. | Inspect cylinder 5 power cylinder. |
 | STEP 8A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 8B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 8C. Inspect the connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 8D. Inspect the piston cooling nozzle. | Piston cooling nozzle bent or missing?
 | STEP 8E. Check cylinder 5 and adjacent cylinder main bearings. | Main bearings damaged?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 565 inactive?
 | STEP 9B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1213, 1274, 1281, 1286, 1291, 1296, 1583, and 2282 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Reference troubleshooting symptom tree t048 (Engine Noise Excessive - Combustion Knocks) in Section TS.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Connect an exhaust gas analyzer.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode and operate at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Check the exhaust emissions.

  • Use an exhaust gas analyzer. With the sample probe inserted into the exhaust gas manifold test port, check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure for exhaust emission specfications in the Operation and Maintenance Manual, Generator Set QSK60G CM700, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specfication?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool. Reference the exhaust gas analyzer, adjust the 'open and closed-loop' fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.

  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 9A

Guided Step 3 - Check the kilowatt load reference signal.

Guided Step 3A - Check the kilowatt load transducer, reference signal - where fitted.

Conditions

NOTE: If the generator set is not fitted with a kilowatt load transducer, then proceed to Guided Step 3B.

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode with load available.

Action

Check the load.

  • Check the kilowatt load transducer-sensed kilowatts against the generator set controller displayed kilowatts.
  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatts match generator set controller kilowatts?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool to calibrate the kilowatt load sensor milliamp/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the calibration of the GenSet controller.

Conditions

NOTE: This guided step should ONLY be followed for generator sets not fitted with a kilowatt load transducer.

  • Connect all components.
  • Connect a power analyzer or digital multimeter.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode with load available.

Action

Check the GenSet controller.

  • Connect a power analyzer or digital multimeter to the alternator main output terminals. Check that the GenSet controller readings for output voltage (L1-L2, L2-L3, and L-3-L1) and amperes (L1, L2, and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

GenSet controller output voltage and ampere readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter. Recalibrate the GenSet controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode. Operate at maximum possible load with no knock present.

Action

Check the intake manifold temperature.

  • Use the generator set Human Machine Interface (HMI) to check the intake manifold temperature.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold temperature within specification?
YES NO
No Repair

Repair

Check the following:

  • Check the temperature of the high temperature (HT) coolant outlet from the engine. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 018-018 in Section V.
  • Check the temperature of the low temperature (LT) coolant outlet from the engine.Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 018-018 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the intake manifold temperature sensor.

  • Check the intake manifold temperature sensor resistances.

NOTE: The intake manifold temperature sensor may have failed 'in range' and the related fault codes will not be activated. Reference Fault Code 153 (Intake Manifold Temperature Sensor Shorted High) or Fault Code 154 (Intake Manifold Temperature Sensor Shorted Low) in Section TF.

  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
  • Use the following procedure for intake manifold temperature sensor specifications. Refer to Procedure 019-059 in Section 19.

Intake manifold temperature sensor resistances to specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode., Operate at maximum possible load with no knock present.

Action

Check the intake manifold pressure.

  • Use the generator set Human Machine Interface (HMI) to check the intake manifold pressure.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396 for the air intake system. Refer to Procedure 018-019 in Section V.

Intake manifold pressure within specification?
YES NO
No Repair

Repair

Check the following:

  • If fitted, check the operation of the compressor bypass valve (single turbocharger engines only).
  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the intake manifold pressure.

  • Check the intake manifold temperature sensor.

NOTE: The intake manifold pressure sensor may have failed 'in range' and the related fault codes will not be activated. Reference Fault Code 354 (Intake Manifold Pressure Sensor Shorted High) or Fault Code 355 (Intake Manifold Pressure Sensor Shorted Low) in Section TF.

  • Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.
  • Use a wiring diagram for intake manifold pressure sensor specifications.

Intake manifold pressure sensor resistance to specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor. Refer to Procedure 019-061 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the GenSet.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the natural gas supply.

  • Check that the quality of the natural gas supplied to the generator set meets or exceeds minimum requirements for the generator set (methane number and fuel contaminants limits).
  • Use the following procedure in the Operation and Maintenance Manual, QSK60G CM700 Generator Set, Bulletin 4021395, for fuel recommendations and specifications. Refer to Procedure 018-002 in Section V.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspection of cylinder 5 cylinder head.

Guided Step 7A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • Spark plug 'J' connector damaged.
  • Inspect the electrode for signs of oil contamination.
  • Spark plug porcelain damaged. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder 5 spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder 5 spark plug gap excessive?
YES NO

Repair

Replace the spark plug:

  • Replace the spark plug. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396, for the electrical system. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7C

Guided Step 7C - Check the cylinder head.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the cylinder head.

Inspect the cylinder 5 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder 5 cylinder head.

Cylinder 5 cylinder head gaskets leaking or loose components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head gasket. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose components on or immediately around cylinder 1 cylinder head. Reference the appropriate procedures in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396.
No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check that the valve lash is correct.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the valve lash.

  • Check to see if the cylinder 5 valve lash setting is correct. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 5 valve lash setting correct?
YES NO
No Repair

Repair

Repair as necessary:

  • Proceed to the next troubleshooting step.

Go to 8A

Go to 7E

Guided Step 7E - Check the valve train.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the valve train.

Inspect the cylinder 5 valve train for the following:

  • Inlet or exhaust valve wear/recession or damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Cam follower wear. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder 5 camshaft lobe wear. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Cylinder 5 valve train wear?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the cam follower. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the rocker lever assembly. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

Adjust the valve lash:

  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 9A

Go to 8A

Guided Step 8 - Inspection of cylinder 5 power cylinder.

Guided Step 8A - Cut open the oil filter(s) and inspect for debris.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the oil filters.

  • Remove the lubricating oil filter(s). Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter(s) and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filter(s)?
YES NO

Repair

Proceed to the next troubleshooting step

 No Repair

Go to 8B

Go to 8D

Guided Step 8B - Check the internal power cylinder.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the internal power cylinder.

NOTE: If available, these inspections can be performed using a borescope without component removal.

Inspect the internal power cylinder for the following:

  • Piston ring scuffing or breakage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 5 power cylinder damaged?
YES NO

Repair

Replace as necessary:

  • Replace the piston rings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Replace the liner. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-045 in Section 1.
  • Replace the cylinder head. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the connecting rod bearings.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the connecting rod bearings.

Inspect the cylinder 5 connecting rod bearings for excessive wear or damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder 5 connecting rod bearings damaged?
YES NO

Repair

Replace the connecting rod bearings:

  • Replace the connecting rod bearings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.
No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the piston cooling nozzle.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the piston cooling nozzle.

Cylinder 5 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle.

  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.
No Repair

Go to 9A

Go to 8E

Guided Step 8E - Inspect cylinder 5 and immediately adjacent main bearings.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect main bearings.

  • Inspect cylinder 5 and immediately adjacent main bearings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-006 in Section 2.

Cylinder 5 or immediately adjacent main bearings worn or damaged?
YES NO

Repair

Replace the main bearings as required (cylinder 5 or immediately adjacent cylinders):

  • Replace the main bearings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.
No Repair

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode and operate engine for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 565 is inactive.

Fault Code 565 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1213, 1274, 1281, 1286, 1291, 1296, 1583, and 2282 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specification?
STEP 3. | Check the kilowatt load reference calibration. |
 | STEP 3A. Check the kilowatt load tranducer-sensed kilowatts against the generator set controller kilowatts. | Kilowatt load transducer sensed kilowatts match generator set controller kilowatts?
 | STEP 3B. Check the GenSet controller calibration. | GenSet controller voltage and ampere output calibration correct?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor supply voltage and reference resistance within specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor supply and reference voltage within specification?
STEP 6. | Check the quality of the natural gas supply to the GenSet. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply meets or exceeds minimum specification for GenSet?
STEP 7. | Inspect the numberr 6 cylinder head. |
 | STEP 7A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 7B. Check the spark plug gap. | Spark plug gap excessive?
 | STEP 7C. Check the cylinder head. | Leaking gaskets or loose components?
 | STEP 7D. Check the valve lash. | Valve lash correct?
 | STEP 7E. Check the valve train. | Worn or mis-set valve train components?
STEP 8. | Inspect cylinder 6 power cylinder. |
 | STEP 8A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 8B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 8C. Inspect the connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 8D. Inspect the piston cooling nozzle. | Piston cooling nozzle bent or missing?
 | STEP 8E. Check cylinder 6 and adjacent cylinder main bearings. | Main bearings damaged?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 566 inactive?
 | STEP 9B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1213, 1274, 1281, 1286, 1291, 1296, 1583, and 2282 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Reference troubleshooting symptom tree t048 (Engine Noise Excessive - Combustion Knocks) in Section TS.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Connect an exhaust gas analyzer.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode and operate at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Check the exhaust emissions.

  • Use an exhaust gas analyzer. With the sample probe inserted into the exhaust gas manifold test port, check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure for exhaust emission specfications in the Operation and Maintenance Manual, Generator Set QSK60G CM700, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specfication?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool. Reference the exhaust gas analyzer, adjust the 'open and closed-loop' fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.

  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 9A

Guided Step 3 - Check the kilowatt load reference signal.

Guided Step 3A - Check the kilowatt load transducer, reference signal - where fitted.

Conditions

NOTE: If the generator set is not fitted with a kilowatt load transducer, then proceed to Guided Step 3B.

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode with load available.

Action

Check the load.

  • Check the kilowatt load transducer-sensed kilowatts against the generator set controller displayed kilowatts.
  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatts match generator set controller kilowatts?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool to calibrate the kilowatt load sensor milliamp/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the calibration of the GenSet controller.

Conditions

NOTE: This guided step should ONLY be followed for generator sets not fitted with a kilowatt load transducer.

  • Connect all components.
  • Connect a power analyzer or digital multimeter.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode with load available.

Action

Check the GenSet controller.

  • Connect a power analyzer or digital multimeter to the alternator main output terminals. Check that the GenSet controller readings for output voltage (L1-L2, L2-L3, and L-3-L1) and amperes (L1, L2, and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

GenSet controller output voltage and amperes readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter. Recalibrate the GenSet controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode. Operate at maximum possible load with no knock present.

Action

Check the intake manifold temperature.

  • Use the generator set Human Machine Interface (HMI) to check the intake manifold temperature.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold temperature within specification?
YES NO
No Repair

Repair

Check the following:

  • Check the temperature of the high temperature (HT) coolant outlet from the engine. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 018-018 in Section V.
  • Check the temperature of the low temperature (LT) coolant outlet from the engine.Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 018-018 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the intake manifold temperature sensor.

  • Check the intake manifold temperature sensor resistances.

NOTE: The intake manifold temperature sensor may have failed 'in range' and the related fault codes will not be activated. Reference Fault Code 153 (Intake Manifold Temperature Sensor Shorted High) or Fault Code 154 (Intake Manifold Temperature Sensor Shorted Low) in Section TF.

  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
  • Use the following procedure for intake manifold temperature sensor specifications. Refer to Procedure 019-059 in Section 19.

Intake manifold temperature sensor resistances to specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode., Operate at maximum possible load with no knock present.

Action

Check the intake manifold pressure.

  • Use the generator set Human Machine Interface (HMI) to check the intake manifold pressure.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396 for the air intake system. Refer to Procedure 018-019 in Section V.

Intake manifold pressure within specification?
YES NO
No Repair

Repair

Check the following:

  • If fitted, check the operation of the compressor bypass valve (single turbocharger engines only).
  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the intake manifold pressure.

  • Check the intake manifold temperature sensor.

NOTE: The intake manifold pressure sensor may have failed 'in range' and the related fault codes will not be activated. Reference Fault Code 354 (Intake Manifold Pressure Sensor Shorted High) or Fault Code 355 (Intake Manifold Pressure Sensor Shorted Low) in Section TF.

  • Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.
  • Use a wiring diagram for intake manifold pressure sensor specifications.

Intake manifold pressure sensor resistance to specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor. Refer to Procedure 019-061 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the GenSet.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the natural gas supply.

  • Check that the quality of the natural gas supplied to the generator set meets or exceeds minimum requirements for the generator set (methane number and fuel contaminants limits).
  • Use the following procedure in the Operation and Maintenance Manual, QSK60G CM700 Generator Set, Bulletin 4021395, for fuel recommendations and specifications. Refer to Procedure 018-002 in Section V.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspection of cylinder 6 cylinder head.

Guided Step 7A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • Spark plug 'J' connector damaged.
  • Inspect the electrode for signs of oil contamination.
  • Spark plug porcelain damaged. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder 6 spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder 6 spark plug gap excessive?
YES NO

Repair

Replace the spark plug:

  • Replace the spark plug. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396, for the electrical system. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7C

Guided Step 7C - Check the cylinder head.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the cylinder head.

Inspect the cylinder 6 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder 6 cylinder head.

Cylinder 6 cylinder head gaskets leaking or loose components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head gasket. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose components on or immediately around cylinder 1 cylinder head. Reference the appropriate procedures in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396.
No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check that the valve lash is correct.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the valve lash.

  • Check to see if the cylinder 6 valve lash setting is correct. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 6 valve lash setting correct?
YES NO
No Repair

Repair

Repair as necessary:

  • Proceed to the next troubleshooting step.

Go to 8A

Go to 7E

Guided Step 7E - Check the valve train.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the valve train.

Inspect the cylinder 6 valve train for the following:

  • Inlet or exhaust valve wear/recession or damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Cam follower wear. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder 6 camshaft lobe wear. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Cylinder 6 valve train wear?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the cam follower. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the rocker lever assembly. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

Adjust the valve lash:

  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 9A

Go to 8A

Guided Step 8 - Inspection of cylinder 6 power cylinder.

Guided Step 8A - Cut open the oil filter(s) and inspect for debris.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the oil filters.

  • Remove the lubricating oil filter(s). Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter(s) and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filter(s)?
YES NO

Repair

Proceed to the next troubleshooting step

 No Repair

Go to 8B

Go to 8D

Guided Step 8B - Check the internal power cylinder.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the internal power cylinder.

NOTE: If available, these inspections can be performed using a borescope without component removal.

Inspect the internal power cylinder for the following:

  • Piston ring scuffing or breakage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 6 power cylinder damaged?
YES NO

Repair

Replace as necessary:

  • Replace the piston rings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Replace the liner. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-045 in Section 1.
  • Replace the cylinder head. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the connecting rod bearings.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the connecting rod bearings.

Inspect the cylinder 6 connecting rod bearings for excessive wear or damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder 6 connecting rod bearings damaged?
YES NO

Repair

Replace the connecting rod bearings:

  • Replace the connecting rod bearings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.
No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the piston cooling nozzle.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the piston cooling nozzle.

Cylinder 6 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle.

  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.
No Repair

Go to 9A

Go to 8E

Guided Step 8E - Inspect cylinder 6 and immediately adjacent main bearings.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect main bearings.

  • Inspect cylinder 6 and immediately adjacent main bearings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-006 in Section 2.

Cylinder 6 or immediately adjacent main bearings worn or damaged?
YES NO

Repair

Replace the main bearings as required (cylinder 6 or immediately adjacent cylinders):

  • Replace the main bearings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.
No Repair

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode and operate engine for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 566 is inactive.

Fault Code 566 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1213, 1274, 1281, 1286, 1291, 1296, 1583, and 2282 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specification?
STEP 3. | Check the kilowatt load reference calibration. |
 | STEP 3A. Check the kilowatt load tranducer-sensed kilowatts against the generator set controller kilowatts. | Kilowatt load transducer sensed kilowatts match generator set controller kilowatts?
 | STEP 3B. Check the GenSet controller calibration. | GenSet controller voltage and ampere output calibration correct?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor supply voltage and reference resistance within specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor supply and reference voltage within specification?
STEP 6. | Check the quality of the natural gas supply to the GenSet. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply meets or exceeds minimum specification for GenSet?
STEP 7. | Inspect the number 7 cylinder head. |
 | STEP 7A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 7B. Check the spark plug gap. | Spark plug gap excessive?
 | STEP 7C. Check the cylinder head. | Leaking gaskets or loose components?
 | STEP 7D. Check the valve lash. | Valve lash correct?
 | STEP 7E. Check the valve train. | Worn or mis-set valve train components?
STEP 8. | Inspect cylinder 7 power cylinder. |
 | STEP 8A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 8B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 8C. Inspect the connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 8D. Inspect the piston cooling nozzle. | Piston cooling nozzle bent or missing?
 | STEP 8E. Check cylinder 7 and adjacent cylinder main bearings. | Main bearings damaged?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 567 inactive?
 | STEP 9B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1213, 1274, 1281, 1286, 1291, 1296, 1583, and 2282 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Reference troubleshooting symptom tree t048 (Engine Noise Excessive - Combustion Knocks) in Section TS.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Connect an exhaust gas analyzer.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode and operate at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Check the exhaust emissions.

  • Use an exhaust gas analyzer. With the sample probe inserted into the exhaust gas manifold test port, check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure for exhaust emission specfications in the Operation and Maintenance Manual, Generator Set QSK60G CM700, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specfication?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool. Reference the exhaust gas analyzer, adjust the 'open and closed-loop' fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.

  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 9A

Guided Step 3 - Check the kilowatt load reference signal.

Guided Step 3A - Check the kilowatt load transducer, reference signal - where fitted.

Conditions

NOTE: If the generator set is not fitted with a kilowatt load transducer, then proceed to Guided Step 3B.

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode with load available.

Action

Check the load.

  • Check the kilowatt load transducer-sensed kilowatts against the generator set controller displayed kilowatts.
  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatts match generator set controller kilowatts?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool to calibrate the kilowatt load sensor milliamp/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the calibration of the GenSet controller.

Conditions

NOTE: This guided step should ONLY be followed for generator sets not fitted with a kilowatt load transducer.

  • Connect all components.
  • Connect a power analyzer or digital multimeter.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode with load available.

Action

Check the GenSet controller.

  • Connect a power analyzer or digital multimeter to the alternator main output terminals. Check that the GenSet controller readings for output voltage (L1-L2, L2-L3, and L-3-L1) and amperes (L1, L2, and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

GenSet controller output voltage and amperes readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter. Recalibrate the GenSet controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode. Operate at maximum possible load with no knock present.

Action

Check the intake manifold temperature.

  • Use the generator set Human Machine Interface (HMI) to check the intake manifold temperature.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold temperature within specification?
YES NO
No Repair

Repair

Check the following:

  • Check the temperature of the high temperature (HT) coolant outlet from the engine. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 018-018 in Section V.
  • Check the temperature of the low temperature (LT) coolant outlet from the engine.Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 018-018 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the intake manifold temperature sensor.

  • Check the intake manifold temperature sensor resistances.

NOTE: The intake manifold temperature sensor may have failed 'in range' and the related fault codes will not be activated. Reference Fault Code 153 (Intake Manifold Temperature Sensor Shorted High) or Fault Code 154 (Intake Manifold Temperature Sensor Shorted Low) in Section TF.

  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
  • Use the following procedure for intake manifold temperature sensor specifications. Refer to Procedure 019-059 in Section 19.

Intake manifold temperature sensor resistance to specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode. Operate at maximum possible load with no knock present.

Action

Check the intake manifold pressure.

  • Use the generator set Human Machine Interface (HMI) to check the intake manifold pressure.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396 for the air intake system. Refer to Procedure 018-019 in Section V.

Intake manifold pressure within specification?
YES NO
No Repair

Repair

Check the following:

  • If fitted, check the operation of the compressor bypass valve (single turbocharger engines only).
  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the intake manifold pressure.

  • Check the intake manifold temperature sensor.

NOTE: The intake manifold pressure sensor may have failed 'in range' and the related fault codes will not be activated. Reference Fault Code 354 (Intake Manifold Pressure Sensor Shorted High) or Fault Code 355 (Intake Manifold Pressure Sensor Shorted Low) in Section TF.

  • Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.
  • Use a wiring diagram for intake manifold pressure sensor specifications.

Intake manifold pressure sensor resistances to specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor. Refer to Procedure 019-061 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the GenSet.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the natural gas supply.

  • Check that the quality of the natural gas supplied to the generator set meets or exceeds minimum requirements for the generator set (methane number and fuel contaminants limits).
  • Use the following procedure in the Operation and Maintenance Manual, QSK60G CM700 Generator Set, Bulletin 4021395, for fuel recommendations and specifications. Refer to Procedure 018-002 in Section V.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspection of cylinder 7 cylinder head.

Guided Step 7A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • Spark plug 'J' connector damaged.
  • Inspect the electrode for signs of oil contamination.
  • Spark plug porcelain damaged. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder 7 spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder 7 spark plug gap excessive?
YES NO

Repair

Replace the spark plug:

  • Replace the spark plug. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7C

Guided Step 7C - Check the cylinder head.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the cylinder head.

Inspect the cylinder 7 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder 7 cylinder head.

Cylinder 7 cylinder head gaskets leaking or loose components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head gasket. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose components on or immediately around cylinder 1 cylinder head. Reference the appropriate procedures in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396.
No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check that the valve lash is correct.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the valve lash.

  • Check to see if the cylinder 7 valve lash setting is correct. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 7 valve lash setting correct?
YES NO
No Repair

Repair

Repair as necessary:

  • Proceed to the next troubleshooting step.

Go to 8A

Go to 7E

Guided Step 7E - Check the valve train.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the valve train.

Inspect the cylinder 7 valve train for the following:

  • Inlet or exhaust valve wear/recession or damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Cam follower wear. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder 7 camshaft lobe wear. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Cylinder 7 valve train wear?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the cam follower. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the rocker lever assembly. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

Adjust the valve lash:

  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 9A

Go to 8A

Guided Step 8 - Inspection of cylinder 7 power cylinder.

Guided Step 8A - Cut open the oil filter(s) and inspect for debris.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the oil filters.

  • Remove the lubricating oil filter(s). Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396 . Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter(s) and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filter(s)?
YES NO

Repair

Proceed to the next troubleshooting step

 No Repair

Go to 8B

Go to 8D

Guided Step 8B - Check the internal power cylinder.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the internal power cylinder.

NOTE: If available, these inspections can be performed using a borescope without component removal.

Inspect the internal power cylinder for the following:

  • Piston ring scuffing or breakage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 7 power cylinder damaged?
YES NO

Repair

Replace as necessary:

  • Replace the piston rings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Replace the liner. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-045 in Section 1.
  • Replace the cylinder head. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the connecting rod bearings.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the connecting rod bearings.

Inspect the cylinder 7 connecting rod bearings for excessive wear or damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder 7 connecting rod bearings damaged?
YES NO

Repair

Replace the connecting rod bearings:

  • Replace the connecting rod bearings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.
No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the piston cooling nozzle.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the piston cooling nozzle.

Cylinder 7 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle.

  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.
No Repair

Go to 9A

Go to 8E

Guided Step 8E - Inspect cylinder 7 and immediately adjacent main bearings.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect main bearings.

  • Inspect cylinder 7 and immediately adjacent main bearings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-006 in Section 2.

Cylinder 7 or immediately adjacent main bearings worn or damaged?
YES NO

Repair

Replace the main bearings as required (cylinder 7 or immediately adjacent cylinders):

  • Replace the main bearings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.
No Repair

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode and operate engine for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 567 is inactive.

Fault Code 567 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1213, 1274, 1281, 1286, 1291, 1296, 1583, and 2282 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specification?
STEP 3. | Check the kilowatt load reference calibration. |
 | STEP 3A. Check the kilowatt load tranducer-sensed kilowatts against the generator set controller kilowatts. | Kilowatt load transducer-sensed kilowatts match generator set controller kilowatts?
 | STEP 3B. Check the GenSet controller calibration. | GenSet controller voltage and ampere output calibration correct?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor supply voltage and reference resistance within specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor supply and reference voltage within specification?
STEP 6. | Check the quality of the natural gas supply to the GenSet. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply meets or exceeds minimum specification for GenSet?
STEP 7. | Inspect the number 8 cylinder head. |
 | STEP 7A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 7B. Check the spark plug gap. | Spark plug gap excessive?
 | STEP 7C. Check the cylinder head. | Leaking gaskets or loose components?
 | STEP 7D. Check the valve lash. | Valve lash correct?
 | STEP 7E. Check the valve train. | Worn or mis-set valve train components?
STEP 8. | Inspect cylinder 8 power cylinder. |
 | STEP 8A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 8B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 8C. Inspect the connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 8D. Inspect the piston cooling nozzle. | Piston cooling nozzle bent or missing?
 | STEP 8E. Check cylinder 8 and adjacent cylinder main bearings. | Main bearings damaged?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 568 inactive?
 | STEP 9B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1213, 1274, 1281, 1286, 1291, 1296, 1583, and 2282 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Reference troubleshooting symptom tree t048 (Engine Noise Excessive - Combustion Knocks) in Section TS.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Connect an exhaust gas analyzer.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode and operate at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Check the exhaust emissions.

  • Use an exhaust gas analyzer. With the sample probe inserted into the exhaust gas manifold test port, check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure for exhaust emission specfications in the Operation and Maintenance Manual, Generator Set QSK60G CM700, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specfication?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool. Reference the exhaust gas analyzer, adjust the 'open and closed-loop' fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.

  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 9A

Guided Step 3 - Check the kilowatt load reference signal.

Guided Step 3A - Check the kilowatt load transducer, reference signal - where fitted.

Conditions

NOTE: If the generator set is not fitted with a kilowatt load transducer, then proceed to Guided Step 3B.

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode with load available.

Action

Check the load.

  • Check the kilowatt load transducer-sensed kilowatts against the generator set controller displayed kilowatts.
  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatts match generator set controller kilowatts?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool to calibrate the kilowatt load sensor milliamp/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the calibration of the GenSet controller.

Conditions

NOTE: This guided step should ONLY be followed for generator sets not fitted with a kilowatt load transducer.

  • Connect all components.
  • Connect a power analyzer or digital multimeter.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode with load available.

Action

Check the GenSet controller.

  • Connect a power analyzer or digital multimeter to the alternator main output terminals. Check that the GenSet controller readings for output voltage (L1-L2, L2-L3, and L-3-L1) and amperes (L1, L2, and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

GenSet controller output voltage and amperes readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter. Recalibrate the GenSet controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode. Operate at maximum possible load with no knock present.

Action

Check the intake manifold temperature.

  • Use the generator set Human Machine Interface (HMI) to check the intake manifold temperature.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold temperature within specification?
YES NO
No Repair

Repair

Check the following:

  • Check the temperature of the high temperature (HT) coolant outlet from the engine. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 018-018 in Section V.
  • Check the temperature of the low temperature (LT) coolant outlet from the engine.Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 018-018 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the intake manifold temperature sensor.

  • Check the intake manifold temperature sensor resistances.

NOTE: The intake manifold temperature sensor may have failed 'in range' and the related fault codes will not be activated. Reference Fault Code 153 (Intake Manifold Temperature Sensor Shorted High) or Fault Code 154 (Intake Manifold Temperature Sensor Shorted Low) in Section TF.

  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
  • Use the following procedure for intake manifold temperature sensor specifications. Refer to Procedure 019-059 in Section 19.

Intake manifold temperature sensor resistances to specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode., Operate at maximum possible load with no knock present.

Action

Check the intake manifold pressure.

  • Use the generator set Human Machine Interface (HMI) to check the intake manifold pressure.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396 for the air intake system. Refer to Procedure 018-019 in Section V.

Intake manifold pressure within specification?
YES NO
No Repair

Repair

Check the following:

  • If fitted, check the operation of the compressor bypass valve (single turbocharger engines only).
  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the intake manifold pressure.

  • Check the intake manifold temperature sensor.

NOTE: The intake manifold pressure sensor may have failed 'in range' and the related fault codes will not be activated. Reference Fault Code 354 (Intake Manifold Pressure Sensor Shorted High) or Fault Code 355 (Intake Manifold Pressure Sensor Shorted Low) in Section TF.

  • Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.
  • Use a wiring diagram for intake manifold pressure sensor specifications.

Intake manifold pressure sensor resistance to specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor. Refer to Procedure 019-061 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the GenSet.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the natural gas supply.

  • Check that the quality of the natural gas supplied to the generator set meets or exceeds minimum requirements for the generator set (methane number and fuel contaminants limits).
  • Use the following procedure in the Operation and Maintenance Manual, QSK60G CM700 Generator Set, Bulletin 4021395, for fuel recommendations and specifications. Refer to Procedure 018-002 in Section V.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspection of cylinder 8 cylinder head.

Guided Step 7A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • Spark plug 'J' connector damaged.
  • Inspect the electrode for signs of oil contamination.
  • Spark plug porcelain damaged. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder 8 spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder 8 spark plug gap excessive?
YES NO

Repair

Replace the spark plug:

  • Replace the spark plug. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7C

Guided Step 7C - Check the cylinder head.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the cylinder head.

Inspect the cylinder 8 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder 8 cylinder head.

Cylinder 8 cylinder head gaskets leaking or loose components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head gasket. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose components on or immediately around cylinder 1 cylinder head. Reference the appropriate procedures in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396.
No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check that the valve lash is correct.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the valve lash.

  • Check to see if the cylinder 8 valve lash setting is correct. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 8 valve lash setting correct?
YES NO
No Repair

Repair

Repair as necessary:

  • Proceed to the next troubleshooting step.

Go to 8A

Go to 7E

Guided Step 7E - Check the valve train.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the valve train.

Inspect the cylinder 8 valve train for the following:

  • Inlet or exhaust valve wear/recession or damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Cam follower wear. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder 8 camshaft lobe wear. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Cylinder 8 valve train wear?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the cam follower. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the rocker lever assembly. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

Adjust the valve lash:

  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 9A

Go to 8A

Guided Step 8 - Inspection of cylinder 8 power cylinder.

Guided Step 8A - Cut open the oil filter(s) and inspect for debris.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the oil filters.

  • Remove the lubricating oil filter(s). Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter(s) and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filter(s)?
YES NO

Repair

Proceed to the next troubleshooting step

 No Repair

Go to 8B

Go to 8D

Guided Step 8B - Check the internal power cylinder.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the internal power cylinder.

NOTE: If available, these inspections can be performed using a borescope without component removal.

Inspect the internal power cylinder for the following:

  • Piston ring scuffing or breakage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 8 power cylinder damaged?
YES NO

Repair

Replace as necessary:

  • Replace the piston rings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Replace the liner. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-045 in Section 1.
  • Replace the cylinder head. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the connecting rod bearings.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the connecting rod bearings.

Inspect the cylinder 8 connecting rod bearings for excessive wear or damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder 8 connecting rod bearings damaged?
YES NO

Repair

Replace the connecting rod bearings:

  • Replace the connecting rod bearings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.
No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the piston cooling nozzle.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the piston cooling nozzle.

Cylinder 8 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle.

  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.
No Repair

Go to 9A

Go to 8E

Guided Step 8E - Inspect cylinder 8 and immediately adjacent main bearings.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect main bearings.

  • Inspect cylinder 8 and immediately adjacent main bearings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-006 in Section 2.

Cylinder 8 or immediately adjacent main bearings worn or damaged?
YES NO

Repair

Replace the main bearings as required (cylinder 8 or immediately adjacent cylinders):

  • Replace the main bearings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.
No Repair

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode and operate engine for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 568 is inactive.

Fault Code 568 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1213, 1274, 1281, 1286, 1291, 1296, 1583, and 2282 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specification?
STEP 3. | Check the kilowat load reference calibration. |
 | STEP 3A. Check the kilowatt load tranducer sensed kilowatts against the generator set controller kilowatts. | Kilowatt load transducer sensed kilowat matches generator set controller kilowatts?
 | STEP 3B. Check the Genset controller calibration. | Genset controller voltage and ampere output calibration correct?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperture within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor supply voltages and reference resistances within specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor supply and reference voltages within specification?
STEP 6. | Check the quality of the natural gas supply to the Genset. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply meets or exceeds minimum specification for Genset?
STEP 7. | Inspect the number 9 cylinder head. |
 | STEP 7A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 7B. Check the spark plug gap. | Spark plug gap excessive?
 | STEP 7C. Check the cylinder head. | Leaking gaskets or loose components?
 | STEP 7D. Check the valve lash. | Valve lash correct?
 | STEP 7E. Check the valve train. | Worn or mis-set valve train components?
STEP 8. | Inspect cylinder 9 power cylinder. |
 | STEP 8A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 8B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 8C. Inspect the connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 8D. Inspect the piston cooling nozzle. | Piston cooling nozzle bent or missing?
 | STEP 8E. Check cylinder 9 and adjacent cylinders main bearings. | Main bearings damaged?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 569 inactive?
 | STEP 9B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1213, 1274, 1281, 1286, 1291, 1296, 1583, and 2282 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Reference troubleshooting symptom tree t048 (Engine Noise Excessive - Combustion Knocks) in Section TS.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Connect an exhaust gas analyzer.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode and running at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Check the exhaust emissions.

  • Use an exhaust gas analyzer. With the sample probe inserted into the exhaust gas manifold test port, check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure for exhaust emission specfications in the Operation and Maintenance Manual, Generator Set QSK60G CM700, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specfication?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool. Reference the exhaust gas analyzer, adjust the 'open and closed-loop' fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.

  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 9A

Guided Step 3 - Check the kilowatt load reference signal.

Guided Step 3A - Check the kilowatt load transducer, reference signal - where fitted.

Conditions

NOTE: If the generator set is not fitted with a kilowatt load transducer then proceed to Guided Step 3B.

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode with load available.

Action

Check the load.

  • Check the kilowatt load transducer-sensed kilowatts against the generator set controller displayed kilowatts.
  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatts matches generator set controller kilowatts?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool to calibrate the kilowatt load sensor milliamp/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the calibration of the GenSet controller.

Conditions

NOTE: This guided step should ONLY be followed for generator sets not fitted with a kilowatt load transducer.

  • Connect all components.
  • Connect a power analyzer or digital multimeter.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode with load available.

Action

Check the GenSet controller.

  • Connect a power analyzer or digital multimeter to the alternator main output terminals. Check that the GenSet controller readings for output voltage (L1-L2, L2-L3, and L-3-L1) and amperes (L1, L2, and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

GenSet controller output voltage and amperes readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter. Recalibrate the GenSet controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode. Operate at maximum possible load with no knock present.

Action

Check the intake manifold temperature.

  • Use the generator set Human Machine Interface (HMI) to check the intake manifold temperature.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396 for the air intake system. Refer to Procedure 018-019 in Section V.

Intake manifold temperature within specification?
YES NO
No Repair

Repair

Check the following:

  • Check the temperature of the high temperature (HT) coolant outlet from the engine for the air intake system. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396 Refer to Procedure 018-018 in Section V.
  • Check the temperature of the low temperature (LT) coolant outlet from the engine for the air intake system. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 018-018 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the intake manifold temperature sensor.

  • Check the intake manifold temperature sensor resistances.

NOTE: The intake manifold temperature sensor may have failed 'in range' and the related fault codes will not be activated. Reference Fault Code 153 (Intake Manifold Temperature Sensor Short High) or Fault Code 154 (Intake Manifold Temperature Sensor Shorted Low) in Section TF.

  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
  • Use the following procedure for intake manifold temperature sensor specifications. Refer to Procedure 019-059 in Section 19.

Intake manifold temperature sensor resistances to specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode., Operate at maximum possible load with no knock present.

Action

Check the intake manifold pressure.

  • Use the generator set Human Machine Interface (HMI) to check the intake manifold pressure.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold pressure within specification?
YES NO
No Repair

Repair

Check the following:

  • If fitted, check the operation of the compressor bypass valve (single turbocharger engines only).
  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the intake manifold pressure.

  • Check the intake manifold temperature sensor.

NOTE: The intake manifold pressure sensor may have failed 'in range' and the related fault codes will not be activated. Reference Fault Code 354 (Intake Manifold Pressure Sensor Shorted High) or Fault Code 355 (Intake Manifold Pressure Sensor Shorted Low) in Section TF.

  • Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.
  • Use the following procedure for intake manifold pressure sensor specifications. Refer to Procedure 019-061 in Section 19.

Intake manifold pressure sensor resistances to specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor. Refer to Procedure 019-061 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the GenSet.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the natural gas supply.

  • Check that the quality of the natural gas supplied to the generator set meets or exceeds minimum requirements for generator set (methane number and fuel contaminants limits).
  • Use the following procedure for fuel recommendations and specifications in the Operation and Maintenance Manual, QSK60G CM700 Generator Set, Bulletin 4021395. Refer to Procedure 018-002 in Section V.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspection of cylinder 9 cylinder head.

Guided Step 7A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tighened.
  • Spark plug 'J' connector damaged.
  • Inspect the electrode for signs of oil contamination.
  • Spark plug porcelain damaged. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder 9 spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Retighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder 9 spark plug gap excessive?
YES NO

Repair

Replace the spark plug:

  • Replace the spark plug. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7C

Guided Step 7C - Check the cylinder head.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the cylinder head.

Inspect the cylinder 9 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases. Use the following procedure to replace the cylinder head gasket in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396 . Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder 9 cylinder head.

Cylinder 9 cylinder head leaking gaskets or loose components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head gasket. Use the following procedure to replace the cylinder head gasket in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure to replace the cylinder head gasket in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose components on or immediately around cylinde 9 cylinder head. Reference the appropriate procedures in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396.
No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check that the valve lash is correct.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the valve lash.

  • Check to see if the cylinder 9 valve lash setting is correct. Use the following procedure to set valve lash in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 9 valve lash setting correct?
YES NO
No Repair

Repair

Repair as necessary:

  • Proceed to the next troubleshooting step.

Go to 8A

Go to 7E

Guided Step 7E - Check the valve train.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the valve train.

Inspect the cylinder 9 valve train for the following:

  • Inlet or exhaust valve wear/recession or damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Cam follower wear. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder 9 camshaft lobe wear. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Cylinder 9 valve train wear?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the cam follower. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the rocker lever assembly. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

Adjust the valve lash:

  • Use the following procedure to set valve lash in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 9A

Go to 8A

Guided Step 8 - Inspection of cylinder 9 power cylinder.

Guided Step 8A - Cut open the oil filter(s) and inspect for debris.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the oil filters.

  • Remove the lubricating oil filter(s). Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396 to remove the oil filters. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter(s) and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filter(s)?
YES NO

Repair

Proceed to the next troubleshooting step

 No Repair

Go to 8B

Go to 8D

Guided Step 8B - Check the internal power cylinder.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the internal power cylinder.

NOTE: If available, these inspections can be performed using a borescope without component removal.

Inspect the internal power cylinder for the following:

  • Piston ring scuffing or breakage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage.

Cylinder 9 power cylinder damaged?
YES NO

Repair

Replace as necessary:

  • Replace the piston rings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Replace the liner. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-045 in Section 1.
  • Replace the cylinder head. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the connecting rod bearings.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the connecting rod bearings.

Inspect the cylinder 9 connecting rod bearings for excessive wear or damage. Use the following procedure to remove the connecting rod bearings in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder 9 connecting rod bearings damaged?
YES NO

Repair

Replace the connecting rod bearings:

  • Replace the connecting rod bearings. Use the following procedure to remove the connecting rod bearings in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.
No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the piston cooling nozzle.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the piston cooling nozzle.

Cylinder 9 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle.

  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.
No Repair

Go to 9A

Go to 8E

Guided Step 8E - Inspect cylinder 9 and immediately adjacent main bearings.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect main bearings.

  • Inspect cylinder 9 and immediately adjacent main bearings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-006 in Section 2.

Cylinder 9 or immediately adjacent main bearings worn or damaged?
YES NO

Repair

Replace the main bearings as required (cylinder 9 or immediately adjacent cylinders):

  • Replace the main bearings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.
No Repair

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode and operate engine for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 569 is inactive.

Fault Code 569 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 - male Deutsch™ test lead, and Part Number 38248121 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 571 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check that the knock sensor wiring harness is connected to the knock sensor. | Knock sensor wiring harness connected?
 | STEP 2B. Inspect the wiring harness and connector pins. | Damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 3. | Check the knock sensor. |
 | STEP 3A. Check that the knock sensor is correctly tightened. | Knock sensor tightened to 20 N•m [177 in-lb]?
 | STEP 3B. Test the knock sensor. | Fault Code 572 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 571 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 571 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check that the knock sensor harness is connected to the knock sensor.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check that the knock sensor harness is connected to the knock sensor:

  • Check that the knock sensor wiring harness is connected to the knock sensor. Refer to Procedure 019-346 in Section 19.

Knock sensor harness connected?
YES NO
No Repair

Repair

Connect the knock sensor harness to the knock sensor.

  • Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-346 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM558 B connector.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM558 B connector.

Action

Check for an open circuit:

  • Measure the resistance from the knock cylinder number 1 signal pin in the knock sensor connector to the knock cylinder number 1 signal pin in the CM558 B connector.
  • Measure the resistance from the knock cylinder number 1 return pin in the knock sensor connector to the knock cylinder number 1 return pin in the CM558 B connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check for a short circuit pin-to-pin:

  • Measure the resistance from the knock cylinder number 1 signal pin in the knock sensor harness connector to all other pins in the connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the knock sensor.

Guided Step 3A - Check that the knock sensor is correctly tightened.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check that the knock sensor is correctly tightened:

  • Check that the knock sensor is tightened to the correct torque. Refer to Procedure 019-346 in Section 19.

Knock sensor tightened to 20 N•m [177 in-lb]?
YES NO
No Repair

Repair

Tighten the knock sensor.

  • Refer to Procedure 019-346 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Test the knock sensor.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode (only RUN the engine after relocating the cylinder 1 knock sensor to cylinder 2) and operate the engine longer than 1 minute.

Action

Test the knock sensor:

  • Move the knock sensor from cylinder head 1 to cylinder head 2. Install the knock sensor from cylinder head 2 to cylinder head 1. Refer to Procedure 019-346 in Section 19.
  • Place the RUN/STOP/AUTO switch in the RUN mode and operate the engine for longer than 1 minute. Use the following procedure in the Operations and Maintenance Manual, Generator Set QSK60G CM700, Bulletin 4021395. Refer to Procedure 101-014 in Section 1.

Fault Code 572 active?
YES NO

Repair

Replace the knock sensor.

  • Refer to Procedure 019-346 in Section 19.
No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the Place RUN mode and operate the engine longer than 1 minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 571 is inactive.

Fault Code 571 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to clear inactive fault codes.

All fault code cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigate prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 - male Deutsch™ test lead, and Part Number 38248121 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 572 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check that the knock sensor wiring harness is connected to the knock sensor. | Knock sensor wiring harness connected?
 | STEP 2B. Inspect the wiring harness and connector pins. | Damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 3. | Check the knock sensor. |
 | STEP 3A. Check that the knock sensor is correctly tightened. | Knock sensor tightened to 20 N•m [177 in-lb]?
 | STEP 3B. Test the knock sensor. | Fault Code 571 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 572 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 572 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check that the knock sensor harness is connected to the knock sensor.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check that the knock sensor harness is connected to the knock sensor:

  • Check that the knock sensor wiring harness is connected to the knock sensor. Refer to Procedure 019-346 in Section 19.

Knock sensor harness connected?
YES NO
No Repair

Repair

Connect the knock sensor harness to the knock sensor.

  • Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-346 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM558 B connector.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM558 B connector.

Action

Check for an open circuit:

  • Measure the resistance from the knock cylinder number 2 signal pin in the knock sensor connector to the knock cylinder number 2 signal pin in the CM558 B connector.
  • Measure the resistance from the knock cylinder number 2 return pin in the knock sensor connector to the knock cylinder number 2 return pin in the CM558 B connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check for a short circuit pin-to-pin:

  • Measure the resistance from the knock cylinder number 2 signal pin in the knock sensor harness connector to all other pins in the connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the knock sensor.

Guided Step 3A - Check that the knock sensor is correctly tightened.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check that the knock sensor is correctly tightened:

  • Check that the knock sensor is tightened to the correct torque. Refer to Procedure 019-346 in Section 19.

Knock sensor tightened to 20 N•m [177 in-lb]?
YES NO
No Repair

Repair

Tighten the knock sensor.

  • Refer to Procedure 019-346 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Test the knock sensor.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode (only RUN the engine after relocating the cylinder 1 knock sensor to cylinder 2 and operate the engine longer than 1 minute.

Action

Test the knock sensor:

  • Move the knock sensor from cylinder head 2 to cylinder head 1. Install the knock sensor from cylinder head 1 to cylinder head 2. Refer to Procedure 019-346 in Section 19.
  • Place the RUN/STOP/AUTO switch in the RUN mode and operate the engine for longer than 1 minute. Use the following procedure in the Operations and Maintenance Manual, Generator Set QSK60G CM700, Bulletin 4021395. Refer to Procedure 101-014 in Section 1.

Fault Code 571 active?
YES NO

Repair

Replace the knock sensor.

  • Refer to Procedure 019-346 in Section 19.
No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the Place RUN mode and operate the engine longer than 1 minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 572 is inactive.

Fault Code 572 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to clear inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigate prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 - male Deutsch™ test lead, and Part Number 38248121 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 573 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check that the knock sensor wiring harness is connected to the knock sensor. | Knock sensor wiring harness connected?
 | STEP 2B. Inspect the wiring harness and connector pins. | Damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 3. | Check the knock sensor. |
 | STEP 3A. Check that the knock sensor is correctly tightened. | Knock sensor tightened to 20 N•m [177 in-lb]?
 | STEP 3B. Test the knock sensor. | Fault Code 574 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 573 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 573 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check that the knock sensor harness is connected to the knock sensor.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check that the knock sensor harness is connected to the knock sensor:

  • Check that the knock sensor wiring harness is connected to the knock sensor. Refer to Procedure 019-346 in Section 19.

Knock sensor harness connected?
YES NO
No Repair

Repair

Connect the knock sensor harness to the knock sensor.

  • Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-346 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM558 B connector.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM558 B connector.

Action

Check for an open circuit:

  • Measure the resistance from the knock cylinder number 3 signal pin in the knock sensor connector to the knock cylinder number 3 signal pin in the CM558 B connector.
  • Measure the resistance from the knock cylinder number 3 return pin in the knock sensor connector to the knock cylinder number 3 return pin in the CM558 B connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check for a short circuit pin-to-pin:

  • Measure the resistance from the knock cylinder number 3 signal pin in the knock sensor harness connector to all other pins in the connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the knock sensor.

Guided Step 3A - Check that the knock sensor is correctly tightened.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check that the knock sensor is correctly tightened:

  • Check that the knock sensor is tightened to the correct torque. Refer to Procedure 019-346 in Section 19.

Knock sensor tightened to 20 N•m [177 in-lb]?
YES NO
No Repair

Repair

Tighten the knock sensor.

  • Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-346 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Test the knock sensor.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode (only RUN the engine after relocating the cylinder 3 knock sensor to cylinder 4) and operate the engine longer than 1 minute.

Action

Test the knock sensor:

  • Move the knock sensor from cylinder head 3 to cylinder head 4. Install the knock sensor from cylinder head 4 to cylinder head 3. Refer to Procedure 019-346 in Section 19.
  • Place the RUN/STOP/AUTO switch in the RUN mode and operate the engine for longer than 1 minute. Use the following procedure in the Operations and Maintenance Manual, Generator Set QSK60G CM700, Bulletin 4021395. Refer to Procedure 101-014 in Section 1.

Fault Code 574 active?
YES NO

Repair

Replace the knock sensor.

  • Refer to Procedure 019-346 in Section 19.
No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the Place RUN mode and operatre the engine longer than 1 minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 573 is inactive.

Fault Code 573 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to clear inactive fault codes.

All fault code cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigate prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 - male Deutsch™ test lead, and Part Number 38248121 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 574 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check that the knock sensor wiring harness is connected to the knock sensor. | Knock sensor wiring harness connected?
 | STEP 2B. Inspect the wiring harness and connector pins. | Damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 3. | Check the knock sensor. |
 | STEP 3A. Check that the knock sensor is correctly tightened. | Knock sensor tightened to 20 N•m [177 in-lb]?
 | STEP 3B. Test the knock sensor. | Is Fault Code 573 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Is Fault Code 574 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE electronic service tool to read the active fault codes.

Fault Code 574 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the knock sensor harness is connected to the knock sensor.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check that the knock sensor harness is connected to the knock sensor:

  • Check that knock sensor wiring harness is connected to the knock sensor. Refer to Procedure 019-346 in Section 19.

Knock sensor harness connected?
YES NO
No Repair

Repair

Connect the knock sensor harness to the knock sensor.

  • Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-346 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM558 B connector.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM558 B connector.

Action

Check for an open circuit:

  • Measure the resistance from the knock cylinder number 4 signal pin in the knock sensor connector to the knock cylinder number 4 signal pin in the CM558 B connector.
  • Measure the resistance from the knock cylinder number 4 return pin in the knock sensor connector to the knock cylinder number 4 return pin in the CM558 B connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check for a short circuit pin-to-pin:

  • Measure the resistance from the knock cylinder number 4 signal pin in the knock sensor harness connector to all other pins in the connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the knock sensor.

Guided Step 3A - Check that the knock sensor is correctly tightened.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check that the knock sensor is correctly tightened:

  • Check that the knock sensor is tightened to the correct torque. Refer to Procedure 019-346 in Section 19.

Knock sensor tightened to 20 N•m [177 in-lb]?
YES NO
No Repair

Repair

Tighten the knock sensor.

  • Refer to Procedure 019-346 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Test the knock sensor.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode (only RUN the engine after relocating the cylinder 4 knock sensor to cylinder 3) and operate the engine longer than 1 minute.

Action

Test the knock sensor:

  • Move the knock sensor from cylinder head 4 to cylinder head 3. Install the knock sensor from cylinder head 3 to cylinder head 4. Refer to Procedure 019-346 in Section 19.
  • Place the RUN/STOP/AUTO switch in the RUN mode and operate the engine for longer than 1 minute. Use the following procedure in the Operations and Maintenance Manual, Generator Set QSK60G CM700, Bulletin 4021395. Refer to Procedure 101-014 in Section 1.

Fault Code 573 active?
YES NO

Repair

Replace the knock sensor.

  • Refer to Procedure 019-346 in Section 19.
No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the Place RUN mode and operate the engine longer than 1 minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 574 is inactive.

Fault Code 574 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to clear inactive fault codes.

All fault code cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigate prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 - male Deutsch™ test lead, and Part Number 38248121 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 575 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check that the knock sensor wiring harness is connected to the knock sensor. | Knock sensor wiring harness connected?
 | STEP 2B. Inspect the wiring harness and connector pins. | Damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 3. | Check the knock sensor. |
 | STEP 3A. Check that the knock sensor is correctly tightened. | Knock sensor tightened to 20 N•m [177 in-lb]?
 | STEP 3B. Test the knock sensor. | Is Fault Code 576 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Is Fault Code 575 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 575 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the knock sensor harness is connected to the knock sensor.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check that the knock sensor harness is connected to the knock sensor:

  • Check that knock sensor wiring harness is connected to the knock sensor. Refer to Procedure 019-346 in Section 19.

Knock sensor harness connected?
YES NO
No Repair

Repair

Connect the knock sensor harness to the knock sensor.

  • Refer to Procedure 019-346 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM558 B connector.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM558 B connector.

Action

Check for an open circuit:

  • Measure the resistance from the knock cylinder number 5 signal pin in the knock sensor connector to the knock cylinder number 5 signal pin in the CM558 B connector.
  • Measure the resistance from the knock cylinder number 5 return pin in the knock sensor connector to the knock cylinder number 5 return pin in the CM558 B connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check for a short circuit pin-to-pin:

  • Measure the resistance from the knock cylinder number 5 signal pin in the knock sensor harness connector to all other pins in the connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the knock sensor.

Guided Step 3A - Check that the knock sensor is correctly tightened.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check that the knock sensor is correctly tightened:

  • Check that the knock sensor is tightened to the correct torque. Refer to Procedure 019-346 in Section 19.

Knock sensor tightened to 20 N•m [177 in-lb]?
YES NO
No Repair

Repair

Tighten the knock sensor.

  • Refer to Procedure 019-346 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Test the knock sensor.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode (only RUN the engine after relocating the cylinder 4 knock sensor to cylinder 3) and operate the engine longer than 1 minute.

Action

Test the knock sensor:

  • Move the knock sensor from cylinder head 5 to cylinder head 6. Install the knock sensor from cylinder head 6 to cylinder head 5. Refer to Procedure 019-346 in Section 19.
  • Place the RUN/STOP/AUTO switch in the RUN mode and operate the engine for longer than 1 minute. Use the following procedure in the Operations and Maintenance Manual, Generator Set QSK60G CM700, Bulletin 4021395. Refer to Procedure 101-014 in Section 1.

Fault Code 576 active?
YES NO

Repair

Replace the knock sensor.

  • Refer to Procedure 019-346 in Section 19.
No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the Place RUN mode and operate the engine longer than 1 minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 575 is inactive.

Fault Code 575 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to clear inactive fault codes.

All fault code cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigate prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 - male Deutsch™ test lead, and Part Number 38248121 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 576 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check that the knock sensor wiring harness is connected to the knock sensor. | Knock sensor wiring harness connected?
 | STEP 2B. Inspect the wiring harness and connector pins. | Damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 3. | Check the knock sensor. |
 | STEP 3A. Check that the knock sensor is correctly tightened. | Knock sensor tightened to 20 N•m [177 in-lb]?
 | STEP 3B. Test the knock sensor. | Is Fault Code 575 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Is Fault Code 576 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 576 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check that the knock sensor harness is connected to the knock sensor.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check that the knock sensor harness is connected to the knock sensor:

  • Check that the knock sensor wiring harness is connected to the knock sensor. Refer to Procedure 019-346 in Section 19.

Knock sensor harness connected?
YES NO
No Repair

Repair

Connect the knock sensor harness to the knock sensor.

  • Refer to Procedure 019-346 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM558 B connector.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM558 B connector.

Action

Check for an open circuit:

  • Measure the resistance from the knock cylinder number 6 signal pin in the knock sensor connector to the knock cylinder number 6 signal pin in the CM558 B connector.
  • Measure the resistance from the knock cylinder number 6 return pin in the knock sensor connector to the knock cylinder number 6 return pin in the CM558 B connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check for a short circuit pin-to-pin:

  • Measure the resistance from the knock cylinder number 6 signal pin in the knock sensor harness connector to all other pins in the connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the knock sensor.

Guided Step 3A - Check that the knock sensor is correctly tightened.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check that the knock sensor is correctly tightened:

  • Check that the knock sensor is tightened to the correct torque. Refer to Procedure 019-346 in Section 19.

Knock sensor tightened to 20 N•m [177 in-lb]?
YES NO
No Repair

Repair

Tighten the knock sensor.

  • Refer to Procedure 019-346 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Test the knock sensor.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode (only RUN the engine after relocating the cylinder 4 knock sensor to cylinder 3) and operate the engine longer than 1 minute.

Action

Test the knock sensor:

  • Move the knock sensor from cylinder head 6 to cylinder head 5. Install the knock sensor from cylinder head 5 to cylinder head 6. Refer to Procedure 019-346 in Section 19.
  • Place the RUN/STOP/AUTO switch in the RUN mode and operate the engine for longer than 1 minute. Use the following procedure in the Operations and Maintenance Manual, Generator Set QSK60G CM700, Bulletin 4021395. Refer to Procedure 101-014 in Section 1.

Fault Code 575 active?
YES NO

Repair

Replace the knock sensor.

  • Refer to Procedure 019-346 in Section 19.
No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the Place RUN mode and operate the engine longer than 1 minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 575 is inactive.

Fault Code 576 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to clear inactive fault codes.

All fault code cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigate prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead,Part Number 3824811 - male Deutsch™ test lead, and Part Number 38248121 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 577 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check that the knock sensor wiring harness is connected to the knock sensor. | Knock sensor wiring harness connected?
 | STEP 2B. Inspect the wiring harness and connector pins. | Damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 3. | Check the knock sensor. |
 | STEP 3A. Check that the knock sensor is correctly tightened. | Knock sensor tightened to 20 N•m [177 in-lb]?
 | STEP 3B. Test the knock sensor. | Is Fault Code 578 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Is Fault Code 577 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 577 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the knock sensor harness is connected to the knock sensor.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check that the knock sensor harness is connected to the knock sensor:

  • Check that knock sensor wiring harness is connected to the knock sensor. Refer to Procedure 019-346 in Section 19.

Knock sensor harness connected?
YES NO
No Repair

Repair

Connect the knock sensor harness to the knock sensor.

  • Refer to Procedure 019-346 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM558 B connector.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM558 B connector.

Action

Check for an open circuit:

  • Measure the resistance from the knock cylinder number 7 signal pin in the knock sensor connector to the knock cylinder number 7 signal pin in the CM558 B connector.
  • Measure the resistance from the knock cylinder number 7 return pin in the knock sensor connector to the knock cylinder number 7 return pin in the CM558 B connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check for a short circuit pin-to-pin:

  • Measure the resistance from the knock cylinder number 7 signal pin in the knock sensor harness connector to all other pins in the connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the knock sensor.

Guided Step 3A - Check that the knock sensor is correctly tightened.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check that the knock sensor is correctly tightened:

  • Check that the knock sensor is tightened to the correct torque. Refer to Procedure 019-346 in Section 19.

Knock sensor tightened to 20 N•m [177 in-lb]?
YES NO
No Repair

Repair

Tighten the knock sensor.

  • Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-346 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Test the knock sensor.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the Place RUN mode (only Place RUN the engine after relocating the cylinder 4 knock sensor to cylinder 3) and operate the engine longer than 1 minute.

Action

Test the knock sensor:

  • Move the knock sensor from cylinder head 7 to cylinder head 8. Install the knock sensor from cylinder head 8 to cylinder head 7. Refer to Procedure 019-346 in Section 19.
  • Place the RUN/STOP/AUTO switch in the RUN mode and operate the engine for longer than 1 minute. Use the following procedure in the Operations and Maintenance Manual, Generator Set QSK60G CM700, Bulletin 4021395. Refer to Procedure 101-014 in Section 1.

Fault Code 578 active?
YES NO

Repair

Replace the knock sensor.

  • Refer to Procedure 019-346 in Section 19.
No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the Place RUN mode and operate the engine longer than 1 minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 575 is inactive.

Fault Code 577 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to clear inactive fault codes.

All fault code cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigate prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 - male Deutsch™ test lead, and Part Number 38248121 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 578 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check that the knock sensor wiring harness is connected to the knock sensor. | Knock sensor wiring harness connected?
 | STEP 2B. Inspect the wiring harness and connector pins. | Damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 3. | Check the knock sensor. |
 | STEP 3A. Check that the knock sensor is correctly tightened. | Knock sensor tightened to 20 N•m [177 in-lb]?
 | STEP 3B. Test the knock sensor. | Is Fault Code 577 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Is Fault Code 578 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 578 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the knock sensor harness is connected to the knock sensor.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check that the knock sensor harness is connected to the knock sensor:

  • Check that knock sensor wiring harness is connected to the knock sensor. Refer to Procedure 019-346 in Section 19.

Knock sensor harness connected?
YES NO
No Repair

Repair

Connect the knock sensor harness to the knock sensor.

  • Refer to Procedure 019-346 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM558 B connector.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM558 B connector.

Action

Check for an open circuit:

  • Measure the resistance from the knock cylinder number 8 signal pin in the knock sensor connector to the knock cylinder number 8 signal pin in the CM558 B connector.
  • Measure the resistance from the knock cylinder number 8 return pin in the knock sensor connector to the knock cylinder number 8 return pin in the CM558 B connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check for a short circuit pin-to-pin:

  • Measure the resistance from the knock cylinder number 8 signal pin in the knock sensor harness connector to all other pins in the connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the knock sensor.

Guided Step 3A - Check that the knock sensor is correctly tightened.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check that the knock sensor is correctly tightened:

  • Check that the knock sensor is tightened to the correct torque. Refer to Procedure 019-346 in Section 19.

Knock sensor tightened to 20 N•m [177 in-lb]?
YES NO
No Repair

Repair

Tighten the knock sensor.

  • Refer to Procedure 019-346 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Test the knock sensor.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the Place RUN mode (only Place RUN the engine after relocating the cylinder 8 knock sensor to cylinder 7) and operate the engine longer than 1 minute.

Action

Test the knock sensor:

  • Move the knock sensor from cylinder head 8 to cylinder head 7. Install the knock sensor from cylinder head 7 to cylinder head 8. Refer to Procedure 019-346 in Section 19.
  • Place the RUN/STOP/AUTO switch in the RUN mode and operate the engine for longer than 1 minute. Use the following procedure in the Operations and Maintenance Manual, Generator Set QSK60G CM700, Bulletin 4021395. Refer to Procedure 101-014 in Section 1.

Fault Code 577 active?
YES NO

Repair

Replace the knock sensor.

  • Refer to Procedure 019-346 in Section 19.
No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode and operate the engine longer than 1 minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 578 is inactive.

Fault Code 578 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to clear inactive fault codes.

All fault code cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigate prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 - male Deutsch™ test lead, and Part Number 38248121 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 579 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check that the knock sensor wiring harness is connected to the knock sensor. | Knock sensor wiring harness connected?
 | STEP 2B. Inspect the wiring harness and connector pins. | Damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 3. | Check the knock sensor. |
 | STEP 3A. Check that the knock sensor is correctly tightened. | Knock sensor tightened to 20 N•m [177 in-lb]?
 | STEP 3B. Test the knock sensor. | Is Fault Code 1275 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Is Fault Code 579 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 579 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the knock sensor harness is connected to the knock sensor.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check that the knock sensor harness is connected to the knock sensor:

  • Check that knock sensor wiring harness is connected to the knock sensor. Refer to Procedure 019-346 in Section 19.

Knock sensor harness connected?
YES NO
No Repair

Repair

Connect the knock sensor harness to the knock sensor.

  • Refer to Procedure 019-346 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM558 B connector.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM558 B connector.

Action

Check for an open circuit:

  • Measure the resistance from the knock cylinder number 9 signal pin in the knock sensor connector to the knock cylinder number 9 signal pin in the CM558 B connector.
  • Measure the resistance from the knock cylinder number 9 return pin in the knock sensor connector to the knock cylinder number 9 return pin in the CM558 B connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check for a short circuit pin-to-pin:

  • Measure the resistance from the knock cylinder number 9 signal pin in the knock sensor harness connector to all other pins in the connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the knock sensor.

Guided Step 3A - Check that the knock sensor is correctly tightened.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check that the knock sensor is correctly tightened:

  • Check that the knock sensor is tightened to the correct torque. Refer to Procedure 019-346 in Section 19.

Knock sensor tightened to 20 N•m [177 in-lb]?
YES NO
No Repair

Repair

Tighten the knock sensor.

  • Refer to Procedure 019-346 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Test the knock sensor.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode (only RUN the engine after relocating the cylinder 9 knock sensor to cylinder 10) and operate the engine longer than 1 minute.

Action

Test the knock sensor:

  • Move the knock sensor from cylinder head 9 to cylinder head 10. Install the knock sensor from cylinder head 10 to cylinder head 9. Refer to Procedure 019-346 in Section 19.
  • Place the RUN/STOP/AUTO switch in the RUN mode and operate the engine for longer than 1 minute. Use the following procedure in the Operations and Maintenance Manual, Generator Set QSK60G CM700, Bulletin 4021395. Refer to Procedure 101-014 in Section 1.

Fault Code 1275 active?
YES NO

Repair

Replace the knock sensor.

  • Refer to Procedure 019-346 in Section 19.
No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the Place RUN mode and operate the engine longer than 1 minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 579 is inactive.

Fault Code 579 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to clear inactive fault codes.

All fault code cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Jun-2010


FAULT CODE 584 - Starter Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 584 active?
STEP 2. | Check the starter lockout relay circuit. |
 | STEP 2A. Inspect the starter lockout relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the starter lockout relay. | Less than 10k ohms?
 | STEP 2C. Check for an open circuit in the starter lockout relay return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 584 inactive?
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault code | Fault Code 584 inactive?
 | STEP 4B. Clear the inactive fault codes | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 584 inactive?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the starter lockout relay circuit.

Guided Step 2A - Inspect the starter lockout relay and connector pins.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the starter lockout relay from the harness.

Action

Inspect the starter relay and connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the starter lockout relay.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the starter lockout relay from the harness.

Action

Check the starter lockout relay resistance.

  • Measure the resistance between the starter lockout relay SIGNAL pin and the starter lockout relay RETURN pin.

Refer to the generator set wiring diagrams for starter lockout relay pin configuration.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

Repair

Replace the starter lockout relay.

Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the starter lockout relay return circuit.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the starter lockout relay from the harness.
  • Disconnect the harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the starter lockout relay RETURN pin at the starter lockout relay connector to ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit on the RETURN wire has been detected. Refer to the generator set wiring diagram for RETURN wire configuration.

If the return is wired to the ECM, repair or replace the harness.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the malfunctioned connection.

Clean, repair or replace the OEM harness.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect ECM and wiring harness connector pins.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness from the ECM.

Action

Inspect the harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the starter lockout relay from the OEM harness.
  • Disconnect the harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the starter lockout relay SIGNAL pin at the starter lockout relay connector and the starter lockout relay SIGNAL wire pin at the harness ECM connector plug C.

Refer to the generator set wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit in the starter lockout relay SIGNAL wire has been detected in the harness.

Refer to the generator set wiring diagram for connector pin identification.

Repair or replace the harness.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the starter lockout relay from the harness.
  • Disconnect the harness from the ECM.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the starter lockout relay SIGNAL wire pin in the ECM connector plug C and all other pins in the ECM connector plug C.

Refer to the generator set wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the output device driver SIGNAL wire has been detected in the harness.

Refer to the generator set wiring diagram for connector pin identification.

Repair or replace the harness.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Energize keyswicth circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 584 inactive?
YES NO

Repair

None.

The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine at rated speed for 1 minute no load.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 584 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked a second time.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Reset the engine - press the Reset button located on the generator control front panel.
  • Use INSITE™ electronic service tool to clear the inactive fault code.

Fault Code 584 cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 19-Mar-2012


FAULT CODE 585 - Starter Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 585 active?
STEP 2. | Check starter lockout relay circuit. |
 | STEP 2A. Inspect starter relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the starter lockout relay. | Greater than 6 ohms?
 | STEP 2C. Check for a pin-to-ground short circuit in the starter lockout relay. | Greater than 100k ohms?
 | STEP 2D. Check the starter lockout relay diagnostic supply voltage, supply line, and return circuit. | Greater than 3.75-VDC?
STEP 3. | Check the ECM and harness. |
 | STEP 3A. Inspect ECM and wiring harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 585 is inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 585 inactive?
 | STEP 4B. Clear the inactive fault codes. | All faults cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 585 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-061 in Section 19.

Guided Step 2 - Check starter lockout relay circuit.

Guided Step 2A - Inspect starter relay and connector pins.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the starter relay from the OEM harness.

Action

Inspect the starter relay and connector pins for the following:.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the relay or harness connections.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the starter lockout relay.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check the starter relay resistance.

  • Measure the resistance of the relay coil and check for low resistance between the starter lockout relay SIGNAL pin and the relay RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 6 ohms?
YES NO
No Repair

Repair

Replace the starter lockout relay.

Go to 2C

Go to 4A

Guided Step 2B-1 - Check for a pin-to-ground short circuit in the starter lockout relay.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Measure the resistance and check for a short circuit between the starter lockout relay SIGNAL pin and ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the starter lockout relay.

Refer to the OEM service manual.

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-ground short circuit in the starter lockout relay.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the starter lockout relay from the harness.

Action

Check for a pin-to-ground short circuit in the starter lockout relay.

  • Measure the resistance and check for a short circuit between the starter lockout relay SIGNAL pin and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the starter lockout relay.

Go to 2D

Go to 4A

Guided Step 2D - Check the starter lockout relay diagnostic supply voltage, supply line and return circuit.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check the starter lockout relay diagnostic supply voltage and return circuit.

  • Measure the voltage between the starter lockout relay SIGNAL pin and the starter lockout relay RETURN pin at the starter lockout relay connector of the harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Greater than 3.75-VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect ECM and wiring harness connector pins.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness from the ECM (CM700).

Action

Inspect the harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the harness.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the starter lockout relay from the harness.
  • Disconnect the harness from the ECM.

Action

Check for a short circuit to ground in the starter lockout relay harness.

  • Measure the resistance between the starter lockout relay SIGNAL pin in the harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground on the starter lockout relay SIGNAL wire has been detected in the harness.

Refer to the wiring diagram for starter lockout relay wiring configuration.

Repair or replace the harness.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness from the ECM.
  • Disconnect the starter lockout relay from the harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the starter lockout relay SIGNAL wire pin in the ECM connector plug C and all other pins in the ECM connector plug C.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the output device driver SIGNAL wire has been detected in the harness.

Refer to the wiring diagram for connector pin identification.

Repair or replace the harness.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 585 is inactive?
YES NO

Repair

None. The removal and installation of the connector correct the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 585 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked a second time.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Reset the engine - press the reset button located on the generator control front panel.
  • Use INSITE™ electronic service tool to clear inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting steps

Last Modified: 19-Mar-2012


FAULT CODE 595 - Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active/inactive fault codes. |
 | STEP 1A. Check for active Fault Code 595. | Fault Code 595 active?
 | STEP 1B. Check for active and inactive fault codes. | Fault Codes 155, 177, 222, 618, 686, 687, 691, 741, 742, 783, 1285, 1295, 1444, 1446, 1471, 1472, 1579, 1581, 1582, 1795, 1796, 1797, 1799, 2191, 2281, 2457, 2458, 2459, 2461, 2462, 2463, 2464, 2465, 2466, 2469, 2471, 2472, 2473, 2475, 2476, 2477, 2478, 2531, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2532, 3489, 3594, and/or 3595 active or inactive?
STEP 2. | Check for a damaged turbocharger speed sensor. |
 | STEP 2A. Inspect the engine harness to turbocharger speed sensor connector and pigtail harness. | Dirty or damage connector or pigtail harness?
 | STEP 2B. Check the turbocharger speed sensor resistance. | Resistance between 635 - 1065 ohms?
 | STEP 2C. Check for a short circuit to ground in the turbocharger speed sensor. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than10 ohms?
 | STEP 3C. Check for a short to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short in the engine harness. | Greater than 100k ohms?
STEP 4. | Connect all components and determine if fault code reoccurs. |
 | STEP 4A. Operate the engine at normal load to check for fault activation. | Fault Code 595 active during engine operation?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive | Fault Code 595 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active/inactive fault codes.

Guided Step 1A - Check for active Fault Code 595.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Run the engine at normal load conditions.

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 595 active?
YES NO

Repair

Follow the appropriate troubleshooting steps for the Active Fault Codes or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 1B

Go to 1B

Guided Step 1B - Check for active and inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Check for active and inactive fault codes.

Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 155, 177, 222, 618, 686, 687, 691, 741, 742, 783, 1285, 1295, 1444, 1446, 1471, 1472, 1579, 1581, 1582, 1795, 1796, 1797, 1799, 2191, 2281, 2457, 2458, 2459, 2461, 2462, 2463, 2464, 2465, 2466, 2469, 2471, 2472, 2473, 2475, 2476, 2477, 2478, 2531, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2532, 3489, 3594, and/or 3595 active or inactive?

YES NO

Repair

Follow the appropriate troubleshooting steps for the Active/Inactive Fault Code or contact a Cummins® Authorized Repair Location.

 No Repair

Go to 5A

2A

Guided Step 2 - Check for a damaged turbocharger speed sensor.

Guided Step 2A - Inspect the engine harness connector to the turbocharger speed sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the turbocharger speed sensor connector.

Action

Inspect the turbocharger speed sensor connector, the engine harness connector, and the turbocharger speed sensor pigtail harness for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damage connector or pigtail harness?
YES NO

Repair

Repair or replace the damaged connector or turbocharger speed sensor.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-209 in Section 19.
  • Replace the turbocharger speed sensor. Refer to Procedure 019-390 in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the turbocharger speed sensor resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the turbocharger speed sensor connector.

Action

Measure the turbocharger speed sensor resistance.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin to the turbocharger speed RETURN (-) pin at the sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 635 - 1065 ohms?
YES NO
No Repair

Repair

The turbocharger speed sensor has malfunctioned.

  • Replace the turbocharger speed sensor. Refer to Procedure 019-390 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to ground in the turbocharger speed sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the turbocharger speed sensor connector.

Action

Check for a short circuit to ground in the turbocharger speed sensor.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin on the sensor to the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

The turbocharger speed sensor is shorted to ground.

  • Replace the turbocharger speed sensor. Refer to Procedure 019-390 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700 module.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or connector?
YES NO

Repair

Clean the connector and pins.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the CM700.
  • Disconnect the engine harness connector to the turbocharger speed sensor.

Action

Use a multimeter to check for an open circuit in the engine harness:

  • Measure the resistance from the turbocharger speed SIGNAL (+) pin at the CM700 connector to the turbocharger speed SIGNAL (+) pin at the turbocharger speed sensor connector.
  • Measure the resistance from the turbocharger speed RETURN (-) pin at the CM700 connector to the turbocharger speed RETURN (-) pin at the turbocharger speed sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-209 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short to ground in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the engine harness connector to the turbocharger speed sensor connector.
  • Disconnect the engine harness connector from the CM700.

Action

Check for a short to ground in the engine harness.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the engine harness CM700 connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

There is a short to ground in the turbocharger speed sensor circuit. Inspect the engine harness for a short to ground.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a pin-to-pin short in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700 module.
  • Disconnect the engine harness from the turbocharger speed sensor.

Action

Use a multimeter to check for a pin-to-pin short circuit in the engine harness:

  • Measure the resistance from the turbocharger speed SIGNAL (+) pin at the CM700 connector to all other pins in the CM700 connector.
  • Measure the resistance from the turbocharger speed RETURN (-) pin at the CM700 connector to all other pins in the CM700 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Connect all components and determine if the fault code reoccurs.

Guided Step 4A - Operate the engine at rated speed to check for fault activation.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the engine harness connector to the turbocharger speed sensor.
  • Connect the engine harness connector to the CM700 module.
  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool.

Action

Operate the engine at normal/rated load.

  • Use INSITE™ electronic service tool to check if Fault Code 595 becomes active.

Does Fault Code 595 come active during normal engine operation?
YES NO

Repair

  • Replace the CM700 module. Refer to Procedure 019-031 in Section 19.

Repair

An intermittent fault condition exists.

  • The troubleshooting procedures performed may have corrected an intermittent connection problem when the engine harness connections were connected.
  • Make sure that the ECM grounds and engine/generator set chassis grounds are in good condition. Refer to Procedure 019-362 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

Use INSITE™ electronic service tool to verify that Fault Code 585 is inactive.

Fault Code 595 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 19-Mar-2012


FAULT CODE 641 - (Multiple Turbochargers) Exhaust Temperature Cylinder Left 1 High - Shutdown

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2442, 2443, or 2484 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in RUN mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Code 2442, 2443, or 2484 active?
YES NO
No Repair

Repair

Go to the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) troubleshooting symptom tree in Section TS.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in STOP mode.
  • Connect all components.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 19-Jan-2015


FAULT CODE 641 - (Single Turbocharger) Exhaust Temperature Cylinder Left 1 High - Shutdown

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2442, 2443, or 2484 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in RUN mode and running for greater than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2442, 2443, or 2484 active?
YES NO
No Repair

Repair

Go to the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) troubleshooting symptom tree in Section TS.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 19-Jan-2015


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2442, 2443, or 2484 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Codes 2442, 2443, or 2484 active?
YES NO
No Repair

Repair

Refer to the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) symptom trees in this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2442, 2443, or 2484 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2442, 2443, or 2484 active?
YES NO
No Repair

Repair

Refer to the Exhaust Temperature is High (Single Cylinder) and the Exhaust Temperature is High (Multiple Cylinders) symptom trees in this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


FAULT C ODE 671 - Multiple Turbochargers - Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 671 active?
STEP 2. | Check the exhaust gas temperature circuit. |
 | STEP 2A. Check the exhaust gas temperature sensor response. | Fault Code 671 inactive and Fault Code 672 active?
 | STEP 2B. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check the exhaust gas temperature circuit for a short circuit pin-to-ground. | Greater than 100k ohms?
 | STEP 2E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 671 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronicservice tool.

Action

Use INSITE™ electronic service tool to read the active fault codes

Fault Code 671 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault code information. Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature circuit.

Guided Step 2A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder 1 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 1 and 3.
  • Install the temperature sensor from cylinder 1 to cylinder 3.
  • Install the temperature sensor from cylinder 3 to cylinder 1.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 671 is inactive and that Fault Code 672 is active.

Fault Code 671 inactive and Fault Code 672 active?
YES NO

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 1 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 1 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the the circuit diagram or wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the circuit diagram or wiring diagram for harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harnessor the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 1 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

Repair the engine harness.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 1 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-ground:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the circuit diagram or wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harnessor the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 1 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust temperature sensor connector.

Perform these checks on all interconnecting harness connectors in the circuit.Use the following procedure for the resistance measurement techniques.

Refer to the circuit diagram or wiring diagram to the identify connectors and pins.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Placre run/stop/auto switch in the RUN mode and engine operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to verify that Fault Code 671 is inactive.

Fault Code 671 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

Connect INSITE™ electronic service tool.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to the appropriate troubleshooting chart.

Last Modified: 21-Dec-2010


FAULT CODE 671 - Exhaust Gas Temperature Cylinder 1 (A1) - Voltage Below Normal or Shorted to Low Source (Single Turbocharger)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™/ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault code. |
 | STEP 1A. Check for active fault codes. | Fault Code 671 active?
STEP 2. | Check the exhaust gas temperature circuit. |
 | STEP 2A. Check the exhaust gas temperature sensor response. | Fault Code 671 inactive and Fault Code 672 active?
 | STEP 2B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 2C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Engine harness and connector pins OK?
 | STEP 2D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2E. Check the exhaust gas temperature circuit for a short circuit from pin-to-ground. | More than 100k ohms?
 | STEP 2F. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 671 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 671 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature circuit.

Guided Step 2A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in the OFF mode.

Action

Check the cylinder 1 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 1 and 3.
  • Install the temperature sensor from cylinder 1 to cylinder 3.
  • Install the temperature sensor from cylinder 3 to cylinder 1.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 671 is inactive and Fault Code 672 is active.

Fault Code 671 inactive and Fault Code 672 active?
YES NO

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 1 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connectors from the cylinder 1 exhaust gas temperature sensor.

Action

Check the 5-VDC supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 1.
  • Reference the wiring diagram for the harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2C

Guided Step 2C - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 1 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the exhaust gas temperature circuit for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 1 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Measure the resistances from the exhaust temperature SUPPLY pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors in pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the exhaust gas temperature circuit for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 1 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-ground.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the CM850 module connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check the exhaust gas temperature circuit for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 1 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the engine harness CM850 module connector to the exhaust temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust temperature 5-VDC SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and engine running for more than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 671 is inactive.

Fault Code 671 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 02-Mar-2011


FAULT CODE 672 - Multiple Turbochargers - Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 672 active?
STEP 2. | Check the exhaust gas temperature circuit. |
 | STEP 2A. Check the exhaust gas temperature sensor response. | Fault Code 672 inactive and Fault Code 671 active?
 | STEP 2B. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check the exhaust gas temperature circuit for a short circuit pin-to-ground. | Greater than 100k ohms?
 | STEP 2E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 672 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronicservice tool.

Action

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 672 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault code information. Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature circuit.

Guided Step 2A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in STOP mode.

Action

Check Cylinder 3 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 1 and 3.
  • Install the temperature sensor from cylinder 1 to cylinder 3.
  • Install the temperature sensor from cylinder 3 to cylinder 1.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 672 is inactive and that Fault Code 671 is active.

Fault Code 672 inactive and Fault Code 671 active?
YES NO

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in Cylinder 3 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from Cylinder 3 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the the circuit diagram or wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the circuit diagram or wiring diagram for harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harnessor the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from Cylinder 3 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

Repair the engine harness.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 3 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-ground:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the circuit diagram or wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harnessor the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from Cylinder 3 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust temperature sensor connector.

Perform these checks on all interconnecting harness connectors in the circuit.Use the following procedure for the resistance measurement techniques.

Refer to the circuit diagram or wiring diagram to the identify connectors and pins.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Placre run/stop/auto switch in the RUN mode and engine operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to verify that Fault Code 672 is inactive.

Fault Code 672 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

Connect INSITE™ electronic service tool.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to the appropriate troubleshooting chart.

Last Modified: 25-Mar-2011


FAULT CODE 672 - Exhaust Gas Temperature Cylinder 3 (A2) - Voltage Below Normal or Shorted to Low Source (Single Turbocharger)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™/ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault code. |
 | STEP 1A. Check for active fault codes. | Fault Code 672 active?
STEP 2. | Check the exhaust gas temperature circuit. |
 | STEP 2A. Check the exhaust gas temperature sensor response. | Fault Code 672 inactive and Fault Code 671 active?
 | STEP 2B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 2C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Engine harness and connector pins OK?
 | STEP 2D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2E. Check the exhaust gas temperature circuit for a short circuit from pin-to-ground. | More than 100k ohms?
 | STEP 2F. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 672 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 672 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature circuit.

Guided Step 2A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Run/stop/auto switch in the OFF mode.

Action

Check the cylinder 3 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 3 and 1.
  • Install the temperature sensor from cylinder 3 to cylinder 1.
  • Install the temperature sensor from cylinder 1 to cylinder 3.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 672 is inactive and Fault Code 671 is active.

Fault Code 672 inactive and Fault Code 671 active?
YES NO

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 3 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connectors from the cylinder 2 exhaust gas temperature sensor.

Action

Check the 5-VDC supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 3.
  • Reference the wiring diagram for the harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2C

Guided Step 2C - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 3 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the exhaust gas temperature circuit for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 3 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Measure the resistances from the exhaust temperature SUPPLY pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors in pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the exhaust gas temperature circuit for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 3 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-ground.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the CM850 module connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check the exhaust gas temperature circuit for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 3 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the engine harness CM850 module connector to the exhaust temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust temperature 5-VDC SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Run/stop/auto switch in the RUN mode and engine running for more than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 672 is inactive.

Fault Code 672 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 22-Feb-2011


FAULT CODE 673 - Multiple Turbochargers - Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 673 active?
STEP 2. | Check the exhaust gas temperature circuit. |
 | STEP 2A. Check the exhaust gas temperature sensor response. | Fault Code 673 inactive and Fault Code 674 active?
 | STEP 2B. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check the exhaust gas temperature circuit for a short circuit pin-to-ground. | Greater than 100k ohms?
 | STEP 2E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 673 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronicservice tool.

Action

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 673 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault code information. Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature circuit.

Guided Step 2A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in STOP mode.

Action

Check Cylinder 5 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 5 and 7.
  • Install the temperature sensor from cylinder 5 to cylinder 7.
  • Install the temperature sensor from cylinder 7 to cylinder 5.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 673 is inactive and that Fault Code 674 is active.

Fault Code 673 inactive and Fault Code 674 active?
YES NO

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 5 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from Cylinder 5 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the the circuit diagram or wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the circuit diagram or wiring diagram for harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harnessor the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from Cylinder 5 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

Repair the engine harness.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 5 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-ground:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the circuit diagram or wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harnessor the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from Cylinder 5 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust temperature sensor connector.

Perform these checks on all interconnecting harness connectors in the circuit.Use the following procedure for the resistance measurement techniques.

Refer to the circuit diagram or wiring diagram to the identify connectors and pins.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Placre run/stop/auto switch in the RUN mode and engine operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to verify that Fault Code 673 is inactive.

Fault Code 673 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

Connect INSITE™ electronic service tool.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to the appropriate troubleshooting chart.

Last Modified: 25-Mar-2011


FAULT CODE 673 - Exhaust Gas Temperature Cylinder 5 (A3) - Voltage Below Normal or Shorted to Low Source (Single Turbocharger)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™/ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault code. |
 | STEP 1A. Check for active fault codes. | Fault Code 673 active?
STEP 2. | Check the exhaust gas temperature circuit. |
 | STEP 2A. Check the exhaust gas temperature sensor response. | Fault Code 673 inactive and Fault Code 674 active?
 | STEP 2B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 2C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Engine harness and connector pins OK?
 | STEP 2D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2E. Check the exhaust gas temperature circuit for a short circuit from pin-to-ground. | More than 100k ohms?
 | STEP 2F. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 673 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 673 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature circuit.

Guided Step 2A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Run/stop/auto switch in the OFF mode.

Action

Check the cylinder 5 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 5 and 7.
  • Install the temperature sensor from cylinder 5 to cylinder 7.
  • Install the temperature sensor from cylinder 7 to cylinder 5.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 673 is inactive and Fault Code 674 is active.

Fault Code 673 inactive and Fault Code 674 active?
YES NO

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 5 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connectors from the cylinder 5 exhaust gas temperature sensor.

Action

Check the 5-VDC supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 5.
  • Reference the wiring diagram for the harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2C

Guided Step 2C - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 5 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the exhaust gas temperature circuit for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 5 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Measure the resistances from the exhaust temperature SUPPLY pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors in pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the exhaust gas temperature circuit for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 5 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-ground.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the CM850 module connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check the exhaust gas temperature circuit for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 5 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the engine harness CM850 module connector to the exhaust temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust temperature 5-VDC SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Run/stop/auto switch in the RUN mode and engine running for more than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 673 is inactive.

Fault Code 673 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 22-Feb-2011


FAULT CODE 674 - Multiple Turbochargers - Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 674 active?
STEP 2. | Check the exhaust gas temperature circuit. |
 | STEP 2A. Check the exhaust gas temperature sensor response. | Fault Code 674 inactive and Fault Code 673 active?
 | STEP 2B. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check the exhaust gas temperature circuit for a short circuit pin-to-ground. | Greater than 100k ohms?
 | STEP 2E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 674 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronicservice tool.

Action

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 674 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault code information. Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature circuit.

Guided Step 2A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder 7 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 7 and 5.
  • Install the temperature sensor from cylinder 7 to cylinder 5.
  • Install the temperature sensor from cylinder 5 to cylinder 7.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 674 is inactive and that Fault Code 673 is active.

Fault Code 674 inactive and Fault Code 673active?
YES NO

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 7 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 7 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the the circuit diagram or wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the circuit diagram or wiring diagram for harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harnessor the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 7 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

Repair the engine harness.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 7 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-ground:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the circuit diagram or wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harnessor the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 7 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust temperature sensor connector.

Perform these checks on all interconnecting harness connectors in the circuit.Use the following procedure for the resistance measurement techniques.

Refer to the circuit diagram or wiring diagram to the identify connectors and pins.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Placre run/stop/auto switch in the RUN mode and engine operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to verify that Fault Code 674 is inactive.

Fault Code 674 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

Connect INSITE™ electronic service tool.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to the appropriate troubleshooting chart.

Last Modified: 25-Mar-2011


FAULT CODE 674 - Exhaust Gas Temperature Cylinder 7 (A4) - Voltage Below Normal or Shorted to Low Source (Single Turbocharger)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™/ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault code. |
 | STEP 1A. Check for active fault codes. | Fault Code 674 active?
STEP 2. | Check the exhaust gas temperature circuit. |
 | STEP 2A. Check the exhaust gas temperature sensor response. | Fault Code 674 inactive and Fault Code 673 active?
 | STEP 2B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 2C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Engine harness and connector pins OK?
 | STEP 2D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2E. Check the exhaust gas temperature circuit for a short circuit from pin-to-ground. | More than 100k ohms?
 | STEP 2F. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 674 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 674 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature circuit.

Guided Step 2A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Run/stop/auto switch in the OFF mode.

Action

Check the cylinder 7 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 7 and 5.
  • Install the temperature sensor from cylinder 7 to cylinder 5.
  • Install the temperature sensor from cylinder 5 to cylinder 7.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 674 is inactive and Fault Code 673 is active.

Fault Code 674 inactive and Fault Code 673 active?
YES NO

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 7 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connectors from the cylinder 7 exhaust gas temperature sensor.

Action

Check the 5-VDC supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 7.
  • Reference the wiring diagram for the harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2C

Guided Step 2C - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 7 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the exhaust gas temperature circuit for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 7 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Measure the resistances from the exhaust temperature SUPPLY pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors in pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the exhaust gas temperature circuit for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 7 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-ground.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the CM850 module connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check the exhaust gas temperature circuit for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 7 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the engine harness CM850 module connector to the exhaust temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust temperature 5-VDC SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Run/stop/auto switch in the RUN mode and engine running for more than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 674 is inactive.

Fault Code 674 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 22-Feb-2011


FAULT CODE 675 - Multiple Turbochargers - Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 675 active?
STEP 2. | Check the exhaust gas temperature circuit. |
 | STEP 2A. Check the exhaust gas temperature sensor response. | Fault Code 675 inactive and Fault Code 676 active?
 | STEP 2B. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check the exhaust gas temperature circuit for a short circuit pin-to-ground. | Greater than 100k ohms?
 | STEP 2E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 675 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronicservice tool.

Action

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 675 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault code information. Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature circuit.

Guided Step 2A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder 9 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 9 and 11.
  • Install the temperature sensor from cylinder 9 to cylinder 11.
  • Install the temperature sensor from cylinder 11 to cylinder 9.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 675 is inactive and that Fault Code 676 is active.

Fault Code 675 inactive and Fault Code 676 active?
YES NO

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 9 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 9 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the the circuit diagram or wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the circuit diagram or wiring diagram for harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harnessor the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 9 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

Repair the engine harness.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 9 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-ground:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the circuit diagram or wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harnessor the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 9 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust temperature sensor connector.

Perform these checks on all interconnecting harness connectors in the circuit.Use the following procedure for the resistance measurement techniques.

Refer to the circuit diagram or wiring diagram to the identify connectors and pins.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Placre run/stop/auto switch in the RUN mode and engine operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to verify that Fault Code 675 is inactive.

Fault Code 675 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

Connect INSITE™ electronic service tool.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to the appropriate troubleshooting chart.

Last Modified: 25-Mar-2011


FAULT CODE 675 - Exhaust Gas Temperature Cylinder 9 (A5) - Voltage Below Normal or Shorted to Low Source (Single Turbocharger)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™/ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault code. |
 | STEP 1A. Check for active fault codes. | Fault Code 675 active?
STEP 2. | Check the exhaust gas temperature circuit. |
 | STEP 2A. Check the exhaust gas temperature sensor response. | Fault Code 675 inactive and Fault Code 676 active?
 | STEP 2B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 2C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Engine harness and connector pins OK?
 | STEP 2D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2E. Check the exhaust gas temperature circuit for a short circuit from pin-to-ground. | More than 100k ohms?
 | STEP 2F. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 675 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 675 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature circuit.

Guided Step 2A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Run/stop/auto switch in the OFF mode.

Action

Check the cylinder 9 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 9 and 11.
  • Install the temperature sensor from cylinder 9 to cylinder 11.
  • Install the temperature sensor from cylinder 11 to cylinder 9 .
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 675 is inactive and Fault Code 676 is active.

Fault Code 675 inactive and Fault Code 676 active?
YES NO

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 9 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connectors from the cylinder 9 exhaust gas temperature sensor.

Action

Check the 5-VDC supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 9 .
  • Reference the wiring diagram for the harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2C

Guided Step 2C - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 9 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the exhaust gas temperature circuit for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 9 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Measure the resistances from the exhaust temperature SUPPLY pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors in pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the exhaust gas temperature circuit for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 9 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-ground.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the CM850 module connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check the exhaust gas temperature circuit for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 9 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the engine harness CM850 module connector to the exhaust temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust temperature 5-VDC SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Run/stop/auto switch in the RUN mode and engine running for more than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 675 is inactive.

Fault Code 675 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-Jan-2013


FAULT CODE 676 - Multiple Turbochargers - Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 676 active?
STEP 2. | Check the exhaust gas temperature circuit. |
 | STEP 2A. Check the exhaust gas temperature sensor response. | Fault Code 676 inactive and Fault Code 675 active?
 | STEP 2B. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check the exhaust gas temperature circuit for a short circuit pin-to-ground. | Greater than 100k ohms?
 | STEP 2E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 676 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronicservice tool.

Action

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 676 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault code information. Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature circuit.

Guided Step 2A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder 11 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 11 and 9.
  • Install the temperature sensor from cylinder 11 to cylinder 9.
  • Install the temperature sensor from cylinder 9 to cylinder 11.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 676 is inactive and that Fault Code 675 is active.

Fault Code 676 inactive and Fault Code 675 active?
YES NO

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 11 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 11 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the the circuit diagram or wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the circuit diagram or wiring diagram for harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harnessor the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 11 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

Repair the engine harness.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 11 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-ground:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the circuit diagram or wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harnessor the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 11 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust temperature sensor connector.

Perform these checks on all interconnecting harness connectors in the circuit.Use the following procedure for the resistance measurement techniques.

Refer to the circuit diagram or wiring diagram to the identify connectors and pins.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Placre run/stop/auto switch in the RUN mode and engine operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to verify that Fault Code 676 is inactive.

Fault Code 676 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

Connect INSITE™ electronic service tool.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to the appropriate troubleshooting chart.

Last Modified: 25-Mar-2011


FAULT CODE 676 - Exhaust Gas Temperature Cylinder 11 (A6) - Voltage Below Normal or Shorted to Low Source (Single Turbocharger)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™/ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault code. |
 | STEP 1A. Check for active fault codes. | Fault Code 676 active?
STEP 2. | Check the exhaust gas temperature circuit. |
 | STEP 2A. Check the exhaust gas temperature sensor response. | Fault Code 676 inactive and Fault Code 675 active?
 | STEP 2B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 2C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Engine harness and connector pins OK?
 | STEP 2D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2E. Check the exhaust gas temperature circuit for a short circuit from pin-to-ground. | More than 100k ohms?
 | STEP 2F. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 676 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 676 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature circuit.

Guided Step 2A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Run/stop/auto switch in the OFF mode.

Action

Check the cylinder 11 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 11 and 9.
  • Install the temperature sensor from cylinder 11 to cylinder 9.
  • Install the temperature sensor from cylinder 9 to cylinder 11.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 676 is inactive and Fault Code 675 is active.

Fault Code 676 inactive and Fault Code 675 active?
YES NO

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 11 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connectors from the cylinder 11 exhaust gas temperature sensor.

Action

Check the 5-VDC supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 11.
  • Reference the wiring diagram for the harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2C

Guided Step 2C - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 11 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the exhaust gas temperature circuit for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 11 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Measure the resistances from the exhaust temperature SUPPLY pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors in pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the exhaust gas temperature circuit for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 11 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-ground.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the CM850 module connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check the exhaust gas temperature circuit for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 11 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the engine harness CM850 module connector to the exhaust temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust temperature 5-VDC SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Run/stop/auto switch in the RUN mode and engine running for more than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 676 is inactive.

Fault Code 676 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 22-Feb-2011


FAULT CODE 677 - Multiple Turbochargers - Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 677 active?
STEP 2. | Check the exhaust gas temperature circuit. |
 | STEP 2A. Check the exhaust gas temperature sensor response. | Fault Code 677 inactive and Fault Code 678 active?
 | STEP 2B. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check the exhaust gas temperature circuit for a short circuit pin-to-ground. | Greater than 100k ohms?
 | STEP 2E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 677 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronicservice tool.

Action

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 677 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault code information. Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature circuit.

Guided Step 2A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder 13 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 13 and 15.
  • Install the temperature sensor from cylinder 13 to cylinder 15.
  • Install the temperature sensor from cylinder 15 to cylinder 13.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 677 is inactive and that Fault Code 678 is active.

Fault Code 677 inactive and Fault Code 678 active?
YES NO

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 13 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 13 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the the circuit diagram or wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the circuit diagram or wiring diagram for harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harnessor the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 13 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

Repair the engine harness.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 13 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-ground:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the circuit diagram or wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harnessor the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 13 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust temperature sensor connector.

Perform these checks on all interconnecting harness connectors in the circuit.Use the following procedure for the resistance measurement techniques.

Refer to the circuit diagram or wiring diagram to the identify connectors and pins.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Placre run/stop/auto switch in the RUN mode and engine operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to verify that Fault Code 677 is inactive.

Fault Code 677 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

Connect INSITE™ electronic service tool.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to the appropriate troubleshooting chart.

Last Modified: 25-Mar-2011


FAULT CODE 677 - Exhaust Gas Temperature Cylinder 13 (A7) - Voltage Below Normal or Shorted to Low Source (Single Turbocharger)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™/ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault code. |
 | STEP 1A. Check for active fault codes. | Fault Code 677 active?
STEP 2. | Check the exhaust gas temperature circuit. |
 | STEP 2A. Check the exhaust gas temperature sensor response. | Fault Code 677 inactive and Fault Code 678 active?
 | STEP 2B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 2C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Engine harness and connector pins OK?
 | STEP 2D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2E. Check the exhaust gas temperature circuit for a short circuit from pin-to-ground. | More than 100k ohms?
 | STEP 2F. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 677 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 677 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature circuit.

Guided Step 2A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in the OFF mode.

Action

Check the cylinder 13 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 13 and 15.
  • Install the temperature sensor from cylinder 13 to cylinder 15.
  • Install the temperature sensor from cylinder 15 to cylinder 13.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 677 is inactive and Fault Code 678 is active.

Fault Code 677 inactive and Fault Code 678 active?
YES NO

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 13 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connectors from the cylinder 13 exhaust gas temperature sensor.

Action

Check the 5-VDC supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 13.
  • Reference the wiring diagram for the harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2C

Guided Step 2C - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 13 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the exhaust gas temperature circuit for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 13 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Measure the resistances from the exhaust temperature SUPPLY pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors in pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the exhaust gas temperature circuit for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 13 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-ground.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the CM850 module connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check the exhaust gas temperature circuit for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 13 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the engine harness CM850 module connector to the exhaust temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust temperature 5-VDC SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Run/stop/auto switch in the RUN mode and engine running for more than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 677 is inactive.

Fault Code 677 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-Mar-2011


FAULT CODE 678 - Multiple Turbochargers - Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 678 active?
STEP 2. | Check the exhaust gas temperature circuit. |
 | STEP 2A. Check the exhaust gas temperature sensor response. | Fault Code 678 inactive and Fault Code 677 active?
 | STEP 2B. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check the exhaust gas temperature circuit for a short circuit pin-to-ground. | Greater than 100k ohms?
 | STEP 2E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 678 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronicservice tool.

Action

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 678 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault code information. Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature circuit.

Guided Step 2A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder 15 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 15 and 13.
  • Install the temperature sensor from cylinder 15 to cylinder 13.
  • Install the temperature sensor from cylinder 13 to cylinder 15 .
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 678 is inactive and that Fault Code 677 is active.

Fault Code 678 inactive and Fault Code 677 active?
YES NO

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 15 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 15 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the the circuit diagram or wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the circuit diagram or wiring diagram for harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harnessor the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 15 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

Repair the engine harness.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 15 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-ground:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the circuit diagram or wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harnessor the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 15 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust temperature sensor connector.

Perform these checks on all interconnecting harness connectors in the circuit.Use the following procedure for the resistance measurement techniques.

Refer to the circuit diagram or wiring diagram to the identify connectors and pins.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Placre run/stop/auto switch in the RUN mode and engine operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to verify that Fault Code 678 is inactive.

Fault Code 678 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

Connect INSITE™ electronic service tool.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to the appropriate troubleshooting chart.

Last Modified: 25-Mar-2011


FAULT CODE 678 - Exhaust Gas Temperature Cylinder 15 (A8) - Voltage Below Normal or Shorted to Low Source (Single Turbocharger)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™/ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault code. |
 | STEP 1A. Check for active fault codes. | Fault Code 678 active?
STEP 2. | Check the exhaust gas temperature circuit. |
 | STEP 2A. Check the exhaust gas temperature sensor response. | Fault Code 678 inactive and Fault Code 677 active?
 | STEP 2B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 2C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Engine harness and connector pins OK?
 | STEP 2D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2E. Check the exhaust gas temperature circuit for a short circuit from pin-to-ground. | More than 100k ohms?
 | STEP 2F. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 678 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 678 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature circuit.

Guided Step 2A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in the OFF mode.

Action

Check the cylinder 15 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 15 and 13.
  • Install the temperature sensor from cylinder 15 to cylinder 13.
  • Install the temperature sensor from cylinder 13 to cylinder 15.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 678 is inactive and Fault Code 677 is active.

Fault Code 678 inactive and Fault Code 677 active?
YES NO

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 15 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connectors from the cylinder 15 exhaust gas temperature sensor.

Action

Check the 5-VDC supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 15.
  • Reference the wiring diagram for the harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2C

Guided Step 2C - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 15 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the exhaust gas temperature circuit for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 15 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Measure the resistances from the exhaust temperature SUPPLY pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors in pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the exhaust gas temperature circuit for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 15 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-ground.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the CM850 module connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check the exhaust gas temperature circuit for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 15 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the engine harness CM850 module connector to the exhaust temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust temperature 5-VDC SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and engine running for more than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 678 is inactive.

Fault Code 678 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-Mar-2011


FAULT CODE 686 - Turbocharger 1 Speed - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for an intermittent fault condition. |
 | STEP 1A. Operate the engine at rated speed to check for fault activation. | Fault Code 686 active?
STEP 2. | Check for a damaged turbocharger speed sensor. |
 | STEP 2A. Inspect the engine harness to turbocharger speed sensor connector and pigtail harness. | Dirty or damaged connector or pigtail harness?
 | STEP 2B. Check the turbocharger speed sensor resistance. | Resistance between 635 to 1065 ohms?
 | STEP 2C. Check for a short circuit to ground in the turbocharger speed sensor. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins or connectors?
 | STEP 3B. Check for an open-circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short in the engine harness. | Greater than 100k ohms?
STEP 4. | Connect all components and determine if the fault code occurs again. |
 | STEP 4A. Operate the engine at idle and high idle to check for fault activation. | Fault Code 686 active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 686 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for an intermittent fault condition.

Guided Step 1A - Operate the engine at rated speed to check for fault activation.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine at normal load conditions.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 686 active?
YES NO
No Repair

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 5A

Guided Step 2 - Check for a damaged turbocharger speed sensor.

Guided Step 2A - Inspect the engine harness to turbocharger speed sensor connector and pigtail harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the turbocharger speed sensor.

Action

Inspect the turbocharger speed sensor connector, the engine harness connector, and the turbocharger speed sensor pigtail harness for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged connector or pigtail harness?
YES NO

Repair

Repair or replace the damaged connector or turbocharger speed sensor.

  • Repair or replace the damaged connector. Refer to Procedure 019-209 in Section 19.
  • Replace the turbocharger speed sensor. Refer to Procedure 019-390 in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Measure the turbocharger speed sensor resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the turbocharger speed sensor.

Action

Check the sensor resistance.

  • Use a multimeter to measure the resistance of the turbocharger speed sensor from the speed SIGNAL (+) pin to the speed RETURN (-) pin at the sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 635 to 1065 ohms?
YES NO
No Repair

Repair

The turbocharger speed sensor is damaged.

Replace the turbocharger speed sensor.

Refer to Procedure 019-390 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to ground in the turbocharger speed sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the turbocharger speed sensor.

Action

Check for a short circuit to ground.

  • Use a multimeter to measure the resistance of the turbocharger speed sensor from the speed SIGNAL (+) pin on the sensor to the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

The turbocharger speed sensor is shorted to ground.

Replace the turbocharger speed sensor.

Refer to Procedure 019-390 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-209 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open-circuit in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700.
  • Disconnect the engine harness from the turbocharger speed sensor

Action

Use a multimeter to check for an open circuit in the engine harness.

  • Measure the resistance from the turbocharger speed SIGNAL (+) pin at the CM700 connector to the turbocharger speed SIGNAL(+) pin at the turbocharger speed sensor connector.
  • Measure the resistance from the turbocharger speed RETURN (-) pin at the CM700 connector to the turbocharger speed RETURN (-) pin at the turbocharger speed sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the engine harness.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-209 in Section 19.
  • Repair the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short to ground in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700 module.
  • Disconnect the engine harness from the turbocharger speed sensor.

Action

Use a multimeter to check for a short circuit to ground in the engine harness.

  • Measure the resistance from the turbocharger speed SIGNAL (+) pin at the engine harness CM700 connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short to ground has been detected in the engine harness turbocharger speed sensor circuit. Inspect the engine harness for a short to ground.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a pin-to-pin short in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the engine harness from the CM700.
  • Disconnect the engine harness from the turbocharger speed sensor

Action

Check for a pin-to-pin short.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the CM700 connector to all other pins in the CM700 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short has been detected in the engine harness.

Repair or replace the engine wiring harness.

Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Connect all components and determine if the fault code occurs again.

Guided Step 4A - Operate the engine at rated speed to check for fault activation.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the engine harness connector to the turbocharger speed sensor.
  • Connect the engine harness to the CM700 module.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Place run/stop/auto switch in RUN mode.

Action

Operate the engine at rated speed.

  • Use INSITE™ electronic service tool to check if Fault Code 686 becomes active.

Fault Code 686 active?
YES NO

Repair

Replace the CM700 module.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

An intermittent fault condition exists. The troubleshooting procedures performed may have corrected an intermittent connection problem when the engine harness connections were connected.

Make sure that the ECM grounds and engine/generator set chassis grounds are in good condition.

Go to 5A

5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

Use INSITE™ electronic service tool to verify Fault Code 686 is inactive

Fault Code 686 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 19-Mar-2012


FAULT CODE 687 - Turbocharger 1 Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for an active fault code, | Fault Code 687 active?
 | STEP 1B. Check for active/inactive fault codes. | Fault Codes 1447, 1448, 1459, 1791 and/or 1792 active/inactive?
STEP 2. | Check for a damaged turbocharger speed sensor. |
 | STEP 2A. Inspect the engine harness to turbocharger speed sensor connector and pigtail harness. | Dirty or damage connect or or pigtail harness?
 | STEP 2B. Check the turbocharger speed sensor resistance. | Resistance between 635 - 1065 ohms?
 | STEP 2C. Check for a short circuit to ground in the turbocharger speed sensor. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins or connector?
 | STEP 3B. Check for an open-circuit in the engine harness. | Less than10 ohms?
 | STEP 3C. Check for a short-to-ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short in the engine harness. | Greater than 100k ohms?
STEP 4. | Connect all components and determine if fault code reoccurs. |
 | STEP 4A. Operate the engine at normal load to check for fault activation. | Does Fault Code 687 become active during normal engine operation?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive | Fault Code 687 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Run the engine at normal load conditions.

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 687 active?
YES NO

Repair

Follow the appropriate troubleshooting steps for the Active Fault Codes or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 1B

Go to 1B

Guided Step 1B - Check for other active/inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Run the engine at normal load conditions.

Use INSITE™ electronic service tool to read the active/inactive fault codes.

Fault Codes 1447, 1448, 1459, 1791 and/or 1792 active/inactive?
YES NO

Repair

Follow the appropriate troubleshooting steps for the Active Fault Code or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 5A

2A

Guided Step 2 - Check for a damaged turbocharger speed sensor.

Guided Step 2A - Inspect the engine harness to turbocharger speed sensor connector and pigtail harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the turbocharger speed sensor connector.

Action

Inspect the turbocharger speed sensor connector, the engine harness connector, and the turbocharger speed sensor pigtail harness for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged connector or pigtail harness?
YES NO

Repair

Repair or replace the damaged connector or turbocharger speed sensor.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-209 in Section 19.
  • Replace the turbocharger speed sensor. Refer to Procedure 019-390 in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the turbocharger speed sensor resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the turbocharger speed sensor connector.

Action

Measure the turbocharger speed sensor resistance.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin to the turbocharger speed RETURN (-) pin at the sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 635 - 1065 ohms?
YES NO
No Repair

Repair

The turbocharger speed sensor has malfunctioned.

  • Replace the turbocharger speed sensor. Refer to Procedure 019-390 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to ground in the turbocharger speed sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the turbocharger speed sensor connector.

Action

Check for a short circuit to ground in the turbocharger speed sensor.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin on the sensor to the engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

The turbocharger speed sensor is shorted-to-ground.

  • Replace the turbocharger speed sensor. Refer to Procedure 019-390 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700 module.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or connector?
YES NO

Repair

Clean the connector and pins.

Repair or replace the engine harness or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-209 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open-circuit in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the CM700 module.
  • Disconnect the engine harness connector to the turbocharger speed sensor.

Action

Use a multimeter to check for an open circuit in the engine harness:

  • Measure the resistance from the turbocharger speed SIGNAL (+) pin at the CM700 connector to the turbocharger speed SIGNAL (+) pin at the turbocharger speed sensor connector.
  • Measure the resistance from the turbocharger speed RETURN (-) pin at the CM700 connector to the turbocharger speed RETURN (-) pin at the turbocharger speed sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the engine harness.

  • Repair the engine wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-209 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short-to-ground in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the CM700 module.
  • Disconnect the engine harness connector to the turbocharger speed sensor connector.

Action

Check for a short-to-ground in the engine harness.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the engine harness CM700 connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short-to-ground has been detected in the engine harness. Inspect the engine harness for a short-to-ground.

Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a pin-to-pin short in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700 module.
  • Disconnect the engine harness from the turbocharger speed sensor.

Action

Use a multimeter to check for a pin-to-pin short circuit in the engine harness:

  • Measure the resistance from the turbocharger speed SIGNAL (+) pin at the CM700 connector to all other pins in the CM700 connector.
  • Measure the resistance from the turbocharger speed RETURN (-) pin at the CM700 connector to all other pins in the CM700 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Connect all components and determine if the fault code reoccurs.

Guided Step 4A - Operate the engine at normal load to check for fault activation.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the engine harness connector to the turbocharger speed sensor.
  • Connect the engine harness connector to the CM700 module.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Place run/stop/auto switch in RUN mode.

Action

Operate the engine at normal/rated load.

  • Use INSITE™ electronic service tool to check if Fault Code 595 becomes active.

Does Fault Code 687 become active during normal engine operation?
YES NO

Repair

Replace the CM700 module.

  • Replace the CM700 module. Refer to Procedure 019-031 in Section 19.

Repair

An intermittent fault condition exists.

  • The troubleshooting procedures performed may have corrected an intermittent connection problem when the engine harness connections were connected.
  • Make sure that the ECM grounds and engine/generator set chassis grounds are in good condition. Refer to Procedure 019-362 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

Use INSITE™ electronic service tool to verify that Fault Code 687 is inactive.

Fault Code 687 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 19-Mar-2012


FAULT CODE 689 - Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 689 active?
STEP 2. | Check the crankshaft engine speed sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged sensor or engine harness connector pins?
 | STEP 2B. Check the crankshaft engine speed sensor for damage. | Damaged crankshaft engine speed sensor?
 | STEP 2C. Check the crankshaft engine speed sensor resistance. | 750 to 1500 ohms?
 | STEP 2D. Check for a short circuit to ground in the crankshaft engine speed sensor. | Greater than 100K ohms?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins or connector?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short-to-ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 689 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault code.

Guided Step 1A - Check for an active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine at normal load conditions.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 686 active?
YES NO

Repair

Follow the appropriate troubleshooting steps for the Active Fault Codes or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check for the crankshaft engine speed sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the crankshaft engine speed sensor connector.

Action

Inspect the crankshaft engine speed sensor connector and the engine harness connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged sensor or engine harness connector pins?
YES NO

Repair

Repair or replace the damaged engine harness connector or crankshaft engine speed sensor.

  • Repair or replace the damaged connector. Refer to Procedure 019-206 in Section 19.
  • Replace the crankshaft engine speed sensor.Refer to Procedure 019-042 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the crankshaft engine speed sensor for damage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the crankshaft engine speed sensor from the engine harness.
  • Remove the crankshaft engine speed sensor.

Action

Inspect the crankshaft engine speed sensor for the following:

Measure the voltage between the crankshaft engine speed SUPPLY pin and the crankshaft engine speed RETURN pin at the sensor connector of the engine harness.

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by contacting the flywheel
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of the sensor

Damaged crankshaft engine speed sensor?
YES NO

Repair

The crankshaft engine speed sensor is damaged.

  • Replace the crankshaft engine speed sensor. Refer to Procedure 019-042 in Section 19.
No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the crankshaft engine speed sensor resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the crankshaft engine speed sensor connector.

Action

Use a multimeter to measure the resistance of the crankshaft engine speed sensor from the speed SIGNAL (+) pin to the speed RETURN (-) pin at the sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for or general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

750 to 1500 ohms?
YES NO
No Repair

Repair

The crankshaft engine speed sensor has malfunctioned.

  • Replace the crankshaft engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the crankshaft engine speed sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the crankshaft engine speed sensor connector.

Action

Use a multimeter to measure the resistance of the crankshaft engine speed sensor from the speed SIGNAL (+) pin on the sensor to the engine ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for or general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

The crankshaft engine speed sensor is damaged.

  • Replace the crankshaft engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700 module.

Action

Inspect the engine harnesses and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector pins
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagramto identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins or connector?
YES NO

Repair

Clean the connector and pins.

Repair the damaged pins.

Repair or replace the engine harness or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-206 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700 module.
  • Disconnect the engine harness from the crankshaft engine speed sensor.

Action

Use a multimeter to check for an open circuit in the engine harness:

  • Measure the resistance from the crankshaft engine speed SIGNAL (+) pin at the CM700 connector to the crankshaft engine speed SIGNAL (+) pin at the crankshaft engine speed sensor connector.
  • Measure the resistance from the crankshaft engine speed RETURN (-) pin at the CM700 connector to the turbocharger speed RETURN (-) pin at the crankshaft engine speed sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the engine harness.

  • Repair the engine wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-206 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short-to-ground in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700 module.
  • Disconnect the engine harness from the crankshaft engine speed sensor.

Action

Use a multimeter to check for a short-to-ground in the engine harness:

  • Measure the resistance from the crankshaft engine speed SIGNAL (+) pin at the CM700 connector to the engine ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for or general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short-to-ground has been detected in the engine harness.

  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700 module.
  • Disconnect the engine harness from the crankshaft engine speed sensor.

Action

Use a multimeter to check for a pin-to-pin short in the engine harness:

  • Measure the resistance from the crankshaft engine speed SIGNAL (+) pin at the CM700 connector to all other pins in the CM700 connector.
  • Measure the resistance from the crankshaft engine speed RETURN (-) pin at the CM700 connector to all other pins in the CM700 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short has been detected in the engine harness.

  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electronic service tool.
  • Operate engine for greater than 1 minute.

Action

Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 689 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-Jan-2011


FAULT CODE 691 - Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 691 inactive?
 | STEP 1B. Check for multiple active/inactive fault codes. | Fault Codes 135, 136, 137, 141, 144, 145, 212, 213, 231, 232, 2111, 2112, 2115, 2116, 2154, and/or 2155 active/inactive?
STEP 2. | Check the turbocharger compressor intake air temperature sensor. |
 | STEP 2A. Inspect the turbocharger compressor intake air temperature sensor and connector pins. | Dirty or damaged connector?
 | STEP 2B. Check the temperature sensor resistance. | 625 ohms to 36k ohms?
STEP 3. | Check the CM700 and engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins or connectors?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check the ECM response | Fault Code 692 active and Fault Code 691 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 691 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 inactive?
YES NO

Repair

Refer to Procedure 019-362 in Section 19.

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Go to 1B

Go to 1B

Guided Step 1B - Check for multiple active/inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple active/inactive fault codes.

  • Use INSITE™ electronic service tool to read the active and inactive fault codes.

Fault Codes 135, 136, 137, 141, 144, 145, 212, 213, 231, 232, 2111, 2112, 2115, 2116, 2154, and/or 2155 active/inactive?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

4A

Go to 2A

Guided Step 2 - Check the turbocharger compressor intake air temperature sensor.

Guided Step 2A - Inspect the turbocharger compressor intake air temperature sensor connector and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the turbocharger intake air temperature sensor.

Action

Inspect the turbocharger intake air temperature sensor connector, the engine harness connector and the connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged connector?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness or the turbocharger compressor intake air temperature sensor, whichever has the damaged connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510. Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-202 in Section 19.
  • Repair or replace the engine harness.

Refer to Procedure 019-043 in Section 19.

  • Replace the turbocharger intake air temperature sensor. Refer to Procedure 019-082 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the temperature sensor resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the turbocharger compressor intake air sensor connector.

Action

Use a multimeter to measure the resistance of the turbocharger compressor intake air temperature sensor from the sensor SIGNAL (+) pin to the sensor RETURN (-) pin at the sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

625 ohms to 36k ohms?
YES NO
No Repair

Repair

The turbocharger speed sensor has malfunctioned.

  • Replace the turbocharger intake air temperature sensor. Refer to Procedure 019-082 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the CM700 and engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700 module.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or connector?
YES NO

Repair

Clean the connector and pins.

Replace the damaged pins.

Repair or replace the engine harness or harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine wiring harness connector. Refer to Procedure 019-204 in Section 19.
  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700 module.
  • Disconnect the engine harness from the turbocharger compressor intake air temperature sensor.

Action

Use a multimeter to check for an open circuit in the engine harness:

  • Measure the resistance from the turbocharger compressor intake air temperature sensor SIGNAL (+) pin at the CM700 connector to the turbocharger compressor intake air temperature sensor SIGNAL (+) pin at the turbocharger compressor intake air temperature sensor connector.
  • Measure the resistance from the turbocharger compressor intake air temperature sensor RETURN (-) pin at the CM700 connector to the turbocharger compressor intake air temperature sensor RETURN (-) pin at the turbocharger compressor intake air temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for or general resistance measurement techniques. Refer to Procedure 019-360.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700 module.
  • Disconnect the engine harness from the turbocharger compressor intake air temperature sensor.

Action

Use a multimeter for a pin-to-pin short circuit in the engine harness:

  • Measure the resistance from the turbocharger compressor intake air temperature sensor SIGNAL (+) pin at the CM700 connector to all other pins in the CM700 connector.
  • Measure the resistance from the turbocharger compressor intake air temperature sensor RETURN (-) pin at the CM700 connector to all other pins in the CM700 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for or general resistance measurement techniques. Refer to Procedure 019-360.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check the ECM response.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700 module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response within 30 seconds.

  • Place a jumper wire between the turbocharger compressor intake air temperature sensor SIGNAL (+) pin and the turbocharger compressor intake air temperature sensor RETURN (-) pin at the CM700 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for or general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Fault Code 692 active and Fault Code 691 inactive?
YES NO
No Repair

Repair

A problem has been detected within the CM700 module.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electronic service tool.
  • Operate engine for greater than 1 minute.

Action

Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 691 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 19-Mar-2012


FAULT CODE 692 - Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 692 inactive?
 | STEP 1B. Check for multiple active/inactive fault codes. | Fault Codes 135, 136, 137, 141, 144, 145, 212, 213, 231, 232, 2111, 2112, 2115, 2116, 2154, and/or 2155 active/inactive?
STEP 2. | Check the turbocharger compressor intake air temperature sensor and circuit. |
 | STEP 2A. Inspect the turbocharger compressor intake air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the temperature sensor resistance. | 625 ohms to 36k ohms?
STEP 3. | Check the CM700 and engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short-to-ground in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check the ECM response. | Fault Code 691 active and Fault Code 692 inactive?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 692 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 inactive?
YES NO

Repair

Refer to Procedure 019-362 in Section 19.

No Repair

1B

Go to 1B

Guided Step 1B - Check for multiple active and inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple active and inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 135, 136, 137, 141, 144, 145, 212, 213, 231, 232, 2111, 2112, 2115, 2116, 2154, and/or 2155 active/inactive?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

4A

Go to 2A

Guided Step 2 - Check the turbocharger compressor intake air temperature sensor.

Guided Step 2A - Inspect the turbocharger compressor intake air temperature sensor and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the turbocharger intake air temperature sensor.

Action

Inspect the turbocharger intake air temperature sensor connector, the engine harness connectorand the connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harnessor the turbocharger compressor intakeair temperature sensor, whichever hasthe damaged connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace or repair the damaged connector. Refer to Procedure 019-202 in Section 19.
  • Repalce the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the turbocharger intake air temperature sensor. Refer to Procedure 019-082 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the temperature sensor resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the turbocharger compressor intake air sensor connector.

Action

Use a multimeter to check the temperature sensor resistance.

  • Measure the resistance of the turbocharger compressor intake air temperature sensor from the sensor SIGNAL (+) pin to the sensor RETURN (-) pin at the sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for or general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

625 ohms to 36k ohms?
YES NO
No Repair

Repair

The turbocharger compressor intake air temperature sensor has malfunctioned.

  • Replace the turbocharger compressor intake air temperature sensor. Refer to Procedure 019-082 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the CM700 and engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700 module.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged pins.

Repair or replace the engine harness or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine wiring harness connector. Refer to Procedure 019-204 in Section 19.
  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short-to-ground in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700 module.
  • Disconnect the engine harness from the turbocharger compressor intake air temperature sensor.

Action

Use a multimeter to check for a short-to-ground in the engine harness.

  • Measure the resistance from the turbocharger compressor intake air temperature sensor SIGNAL (+) pin at the CM700 connector to the engine ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for or general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short-to-ground has been detected in the engine harness.

  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700 module.
  • Disconnect the engine harness from the turbocharger compressor intake air temperature sensor.

Action

Use a multimeter to check for a pin-to-pin short in the engine harness.

  • Measure the resistance from the turbocharger compressor intake air temperature sensor SIGNAL (+) pin at the CM700 connector to all other pins in the CM700 connector.
  • Measure the resistance from the turbocharger compressor intake air temperature sensor RETURN (-) pin at the CM700 connector to all other pins in the CM700 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for or general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected in the engine harness.

  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check the ECM response.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700 module.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response within 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Multiple unrelated fault codes may become active at this time. These can be temporarily ignored.

Fault Code 691 active and Fault Code 692 inactive?
YES NO
No Repair

Repair

A problem has been detected within the CM700 module.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electronic service tool.
  • Operate engine for greater than 1 minute.

Action

Use INSITE™ electronic service tool to verify that Fault Code 692 is inactive.

Fault Code 692 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 19-Mar-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 697 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Code 697 active?
YES NO

Repair

Contact your Local Cummins Authorized Repair Location.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 698 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Code 698 active?
YES NO

Repair

Contact your Local Cummins Authorized Repair Location.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


FAULT CODE 721 - Multiple Turbochargers - Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 721 active?
STEP 2. | Check the exhaust gas temperature circuit. |
 | STEP 2A. Check the exhaust gas temperature sensor response. | Fault Code 721 inactive and Fault Code 722 active?
 | STEP 2B. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check the exhaust gas temperature circuit for a short circuit pin-to-ground. | Greater than 100k ohms?
 | STEP 2E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 721 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronicservice tool.

Action

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 721 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault code information. Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature circuit.

Guided Step 2A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder 2 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 2 and 4.
  • Install the temperature sensor from cylinder 2 to cylinder 4.
  • Install the temperature sensor from cylinder 4 to cylinder 2.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 721 is inactive and that Fault Code 722 is active.

Fault Code 721 inactive and Fault Code 722 active?
YES NO

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 2 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 2 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the the circuit diagram or wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the circuit diagram or wiring diagram for harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harnessor the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 2 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

Repair the engine harness.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 2 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-ground:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the circuit diagram or wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harnessor the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 2 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust temperature sensor connector.

Perform these checks on all interconnecting harness connectors in the circuit.Use the following procedure for the resistance measurement techniques.

Refer to the circuit diagram or wiring diagram to the identify connectors and pins.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Placre run/stop/auto switch in the RUN mode and engine operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to verify that Fault Code 721 is inactive.

Fault Code 721 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

Connect INSITE™ electronic service tool.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to the appropriate troubleshooting chart.

Last Modified: 25-Mar-2011


FAULT CODE 721 - Exhaust Gas Temperature Cylinder 2 (B1) - Voltage Below Normal or Shorted to Low Source (Single Turbocharger)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™/ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault code. |
 | STEP 1A. Check for active fault codes. | Fault Code 721 active?
STEP 2. | Check the exhaust gas temperature circuit. |
 | STEP 2A. Check the exhaust gas temperature sensor response. | Fault Code 721 inactive and Fault Code 722 active?
 | STEP 2B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 2C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Engine harness and connector pins OK?
 | STEP 2D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2E. Check the exhaust gas temperature circuit for a short circuit from pin-to-ground. | More than 100k ohms?
 | STEP 2F. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 721 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 721 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature circuit.

Guided Step 2A - Check the exhaust gas temperature sensor response.

Conditions

  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in the OFF mode.

Action

Check the cylinder 2 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 2 and 4.
  • Install the temperature sensor from cylinder 2 to cylilnder 4.
  • Install the temperature sensor from cylilnder 4 to cylinder 2.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 721 is inactive and Fault Code 722 is active.

Fault Code 721 inactive and Fault Code 722 active?
YES NO

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 2 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connectors from the cylinder 2 exhaust gas temperature sensor.

Action

Check the 5-VDC supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 2.
  • Reference the wiring diagram for the harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2C

Guided Step 2C - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 2 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the exhaust gas temperature circuit for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 2 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Measure the resistances from the exhaust temperature SUPPLY pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors in pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the exhaust gas temperature circuit for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 2 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-ground.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the CM850 module connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check the exhaust gas temperature circuit for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 2 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the engine harness CM850 module connector to the exhaust temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust temperature 5-VDC SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and engine running for more than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 721 is inactive.

Fault Code 721 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-Mar-2011


FAULT CODE 722 - Multiple Turbochargers - Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 722 active?
STEP 2. | Check the exhaust gas temperature circuit. |
 | STEP 2A. Check the exhaust gas temperature sensor response. | Fault Code 722 inactive and Fault Code 721 active?
 | STEP 2B. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check the exhaust gas temperature circuit for a short circuit pin-to-ground. | Greater than 100k ohms?
 | STEP 2E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 722 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronicservice tool.

Action

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 722 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault code information. Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature circuit.

Guided Step 2A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder 4 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 4 and 2.
  • Install the temperature sensor from cylinder 4 to cylinder 2.
  • Install the temperature sensor from cylinder 2 to cylinder 4.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 722 is inactive and that Fault Code 721 is active.

Fault Code 722 inactive and Fault Code 721 active?
YES NO

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 4 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 4 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the the circuit diagram or wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the circuit diagram or wiring diagram for harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harnessor the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Use INSITE™ electronic service tool to verify that Fault Code 721 is inactive.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 4 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

Repair the engine harness.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 4 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-ground:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the circuit diagram or wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harnessor the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 4 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust temperature sensor connector.

Perform these checks on all interconnecting harness connectors in the circuit.Use the following procedure for the resistance measurement techniques.

Refer to the circuit diagram or wiring diagram to the identify connectors and pins.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Placre run/stop/auto switch in the RUN mode and engine operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to verify that Fault Code 722 is inactive.

Fault Code 722 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

Connect INSITE™ electronic service tool.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to the appropriate troubleshooting chart.

Last Modified: 25-Mar-2011


FAULT CODE 722 - Exhaust Gas Temperature Cylinder 4 (B2) - Voltage Below Normal or Shorted to Low Source (Single Turbocharger)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™/ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault code. |
 | STEP 1A. Check for active fault codes. | Fault Code 722 active?
STEP 2. | Check the exhaust gas temperature circuit. |
 | STEP 2A. Check the exhaust gas temperature sensor response. | Fault Code 722 inactive and Fault Code 721 active?
 | STEP 2B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 2C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Engine harness and connector pins OK?
 | STEP 2D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2E. Check the exhaust gas temperature circuit for a short circuit from pin-to-ground. | More than 100k ohms?
 | STEP 2F. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 722 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 722 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature circuit.

Guided Step 2A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in the OFF mode.

Action

Check the cylinder 4 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 4 and 2.
  • Install the temperature sensor from cylinder 4 to cylinder 2.
  • Install the temperature sensor from cylinder 2 to cylinder 4.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 722 is inactive and Fault Code 721 is active.

Fault Code 722 inactive and Fault Code 721 active?
YES NO

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 4 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connectors from the cylinder 4 exhaust gas temperature sensor.

Action

Check the 5-VDC supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 4.
  • Reference the wiring diagram for the harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2C

Guided Step 2C - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 4 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the exhaust gas temperature circuit for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 4 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Measure the resistances from the exhaust temperature SUPPLY pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors in pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the exhaust gas temperature circuit for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 4 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-ground.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the CM850 module connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check the exhaust gas temperature circuit for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 4 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the engine harness CM850 module connector to the exhaust temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust temperature 5-VDC SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and engine running for more than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 722 is inactive.

Fault Code 722 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-Mar-2011


FAULT CODE 723 - Multiple Turbochargers - Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 723 active?
STEP 2. | Check the exhaust gas temperature circuit. |
 | STEP 2A. Check the exhaust gas temperature sensor response. | Fault Code 723 inactive and Fault Code 724 active?
 | STEP 2B. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check the exhaust gas temperature circuit for a short circuit pin-to-ground. | Greater than 100k ohms?
 | STEP 2E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 723 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronicservice tool.

Action

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 723 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault code information. Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature circuit.

Guided Step 2A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder 6 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 6 and 8.
  • Install the temperature sensor from cylinder 6 to cylinder 8.
  • Install the temperature sensor from cylinder 8 to cylinder 6.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 723 is inactive and that Fault Code 724 is active.

Fault Code 723 inactive and Fault Code 724 active?
YES NO

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 6 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 6 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the the circuit diagram or wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the circuit diagram or wiring diagram for harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harnessor the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 6 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

Repair the engine harness.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 6 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-ground:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the circuit diagram or wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harnessor the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 6 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust temperature sensor connector.

Perform these checks on all interconnecting harness connectors in the circuit.Use the following procedure for the resistance measurement techniques.

Refer to the circuit diagram or wiring diagram to the identify connectors and pins.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Placre run/stop/auto switch in the RUN mode and engine operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to verify that Fault Code 723 is inactive.

Fault Code 723 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

Connect INSITE™ electronic service tool.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to the appropriate troubleshooting chart.

Last Modified: 25-Mar-2011


FAULT CODE 723 - Exhaust Gas Temperature Cylinder 6 (B3) - Voltage Below Normal or Shorted to Low Source (Single Turbocharger)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™/ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault code. |
 | STEP 1A. Check for active fault codes. | Fault Code 723 active?
STEP 2. | Check the exhaust gas temperature circuit. |
 | STEP 2A. Check the exhaust gas temperature sensor response. | Fault Code 723 inactive and Fault Code 724 active?
 | STEP 2B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 2C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Engine harness and connector pins OK?
 | STEP 2D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2E. Check the exhaust gas temperature circuit for a short circuit from pin-to-ground. | More than 100k ohms?
 | STEP 2F. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 723 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 723 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature circuit.

Guided Step 2A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in the OFF mode.

Action

Check the cylinder 6 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 6 and 8.
  • Install the temperature sensor from cylinder 6 to cylinder 8.
  • Install the temperature sensor from cylinder 8 to cylinder 6.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 723 is inactive and Fault Code 724 is active.

Fault Code 723 inactive and Fault Code 724 active?
YES NO

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 6 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connectors from the cylinder 6 exhaust gas temperature sensor.

Action

Check the 5-VDC supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 6.
  • Reference the wiring diagram for the harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2C

Guided Step 2C - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 6 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the exhaust gas temperature circuit for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 6 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Measure the resistances from the exhaust temperature SUPPLY pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors in pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the exhaust gas temperature circuit for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 6 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-ground.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the CM850 module connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check the exhaust gas temperature circuit for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 6 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the engine harness CM850 module connector to the exhaust temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust temperature 5-VDC SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and engine running for more than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 723 is inactive.

Fault Code 723 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-Mar-2011


FAULT CODE 724 - Multiple Turbochargers - Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 724 active?
STEP 2. | Check the exhaust gas temperature circuit. |
 | STEP 2A. Check the exhaust gas temperature sensor response. | Fault Code 724 inactive and Fault Code 723 active?
 | STEP 2B. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check the exhaust gas temperature circuit for a short circuit pin-to-ground. | Greater than 100k ohms?
 | STEP 2E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 724 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronicservice tool.

Action

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 724 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault code information. Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature circuit.

Guided Step 2A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder 8 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 8 and 6.
  • Install the temperature sensor from cylinder 8 to cylinder 6.
  • Install the temperature sensor from cylinder 6 to cylinder 8.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 724 is inactive and that Fault Code 723 is active.

Fault Code 724 inactive and Fault Code 723 active?
YES NO

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 8 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 8 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the the circuit diagram or wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the circuit diagram or wiring diagram for harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harnessor the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 8 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

Repair the engine harness.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 8 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-ground:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the circuit diagram or wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harnessor the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 8 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust temperature sensor connector.

Perform these checks on all interconnecting harness connectors in the circuit.Use the following procedure for the resistance measurement techniques.

Refer to the circuit diagram or wiring diagram to the identify connectors and pins.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Placre run/stop/auto switch in the RUN mode and engine operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to verify that Fault Code 724 is inactive.

Fault Code 724 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

Connect INSITE™ electronic service tool.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to the appropriate troubleshooting chart.

Last Modified: 25-Mar-2011


FAULT CODE 724 - Exhaust Gas Temperature Cylinder 8 (B4) - Voltage Below Normal or Shorted to Low Source (Single Turbocharger)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™/ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault code. |
 | STEP 1A. Check for active fault codes. | Fault Code 724 active?
STEP 2. | Check the exhaust gas temperature circuit. |
 | STEP 2A. Check the exhaust gas temperature sensor response. | Fault Code 724 inactive and Fault Code 723 active?
 | STEP 2B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 2C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Engine harness and connector pins OK?
 | STEP 2D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2E. Check the exhaust gas temperature circuit for a short circuit from pin-to-ground. | More than 100k ohms?
 | STEP 2F. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 724 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 724 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature circuit.

Guided Step 2A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in the OFF mode.

Action

Check the cylinder 8 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 8 and 6.
  • Install the temperature sensor from cylinder 8 to cylinder 6.
  • Install the temperature sensor from cylinder 6 to cylinder 8.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 724 is inactive and Fault Code 723 is active.

Fault Code 724 inactive and Fault Code 723 active?
YES NO

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 8 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connectors from the cylinder 8 exhaust gas temperature sensor.

Action

Check the 5-VDC supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 8.
  • Reference the wiring diagram for the harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2C

Guided Step 2C - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 8 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the exhaust gas temperature circuit for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 8 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Measure the resistances from the exhaust temperature SUPPLY pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors in pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the exhaust gas temperature circuit for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 8 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-ground.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the CM850 module connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check the exhaust gas temperature circuit for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 8 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the engine harness CM850 module connector to the exhaust temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust temperature 5-VDC SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and engine running for more than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 724 is inactive.

Fault Code 724 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-Mar-2011


FAULT CODE 725 - Multiple Turbochargers - Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 725 active?
STEP 2. | Check the exhaust gas temperature circuit. |
 | STEP 2A. Check the exhaust gas temperature sensor response. | Fault Code 725 inactive and Fault Code 726 active?
 | STEP 2B. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check the exhaust gas temperature circuit for a short circuit pin-to-ground. | Greater than 100k ohms?
 | STEP 2E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 725 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronicservice tool.

Action

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 725 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault code information. Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature circuit.

Guided Step 2A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder 10 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 10 and 12.
  • Install the temperature sensor from cylinder 10 to cylinder 12.
  • Install the temperature sensor from cylinder 12 to cylinder 10.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 725 is inactive and that Fault Code 726 is active.

Fault Code 725 inactive and Fault Code 726 active?
YES NO

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 10 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 10 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the the circuit diagram or wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the circuit diagram or wiring diagram for harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harnessor the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 10 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

Repair the engine harness.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 10 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-ground:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the circuit diagram or wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harnessor the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 10 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust temperature sensor connector.

Perform these checks on all interconnecting harness connectors in the circuit.Use the following procedure for the resistance measurement techniques.

Refer to the circuit diagram or wiring diagram to the identify connectors and pins.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Placre run/stop/auto switch in the RUN mode and engine operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to verify that Fault Code 725 is inactive.

Fault Code 725 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

Connect INSITE™ electronic service tool.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to the appropriate troubleshooting chart.

Last Modified: 25-Mar-2011


FAULT CODE 725 - Exhaust Gas Temperature Cylinder 10 (B5) - Voltage Below Normal or Shorted to Low Source (Single Turbocharger)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™/ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault code. |
 | STEP 1A. Check for active fault codes. | Fault Code 725 active?
STEP 2. | Check the exhaust gas temperature circuit. |
 | STEP 2A. Check the exhaust gas temperature sensor response. | Fault Code 725 inactive and Fault Code 726 active?
 | STEP 2B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 2C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Engine harness and connector pins OK?
 | STEP 2D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2E. Check the exhaust gas temperature circuit for a short circuit from pin-to-ground. | More than 100k ohms?
 | STEP 2F. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 725 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 725 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature circuit.

Guided Step 2A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in the OFF mode.

Action

Check the cylinder 10 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 10 and 12.
  • Install the temperature sensor from cylinder 10 to cylinder 12.
  • Install the temperature sensor from cylinder 12 to cylinder 10 .
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 725 is inactive and Fault Code 726 is active.

Fault Code 725 inactive and Fault Code 726 active?
YES NO

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 10 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connectors from the cylinder 10 exhaust gas temperature sensor.

Action

Check the 5-VDC supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 10 .
  • Reference the wiring diagram for the harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2C

Guided Step 2C - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 10 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the exhaust gas temperature circuit for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 10 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Measure the resistances from the exhaust temperature SUPPLY pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors in pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the exhaust gas temperature circuit for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 10 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-ground.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the CM850 module connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check the exhaust gas temperature circuit for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 10 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the engine harness CM850 module connector to the exhaust temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust temperature 5-VDC SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and engine running for more than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 725 is inactive.

Fault Code 725 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-Mar-2011


FAULT CODE 726 - Multiple Turbochargers - Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 726 active?
STEP 2. | Check the exhaust gas temperature circuit. |
 | STEP 2A. Check the exhaust gas temperature sensor response. | Fault Code 726 inactive and Fault Code 725 active?
 | STEP 2B. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check the exhaust gas temperature circuit for a short circuit pin-to-ground. | Greater than 100k ohms?
 | STEP 2E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 726 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronicservice tool.

Action

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 726 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault code information. Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature circuit.

Guided Step 2A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in STOP mode.

Action

Check Cylinder 12 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 12 and 10.
  • Install the temperature sensor from Cylinder 12 to Cylinder 10.
  • Install the temperature sensor from Cylinder 10 to Cylinder 12.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 726 is inactive and that Fault Code 725 is active.

Fault Code 726 inactive and Fault Code 725 active?
YES NO

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in Cylinder 12 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from Cylinder 12 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the the circuit diagram or wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the circuit diagram or wiring diagram for harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harnessor the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from Cylinder 12 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

Repair the engine harness.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from Cylinder 12 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-ground:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the circuit diagram or wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harnessor the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from Cylinder 12 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust temperature sensor connector.

Perform these checks on all interconnecting harness connectors in the circuit.Use the following procedure for the resistance measurement techniques.

Refer to the circuit diagram or wiring diagram to the identify connectors and pins.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and engine operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to verify that Fault Code 726 is inactive.

Fault Code 726 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

Connect INSITE™ electronic service tool.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to the appropriate troubleshooting chart.

Last Modified: 25-Mar-2011


FAULT CODE 726 - Exhaust Gas Temperature Cylinder 12 (B6) - Voltage Below Normal or Shorted to Low Source (Single Turbocharger)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™/ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault code. |
 | STEP 1A. Check for active fault codes. | Fault Code 726 active?
STEP 2. | Check the exhaust gas temperature circuit. |
 | STEP 2A. Check the exhaust gas temperature sensor response. | Fault Code 726 inactive and Fault Code 725 active?
 | STEP 2B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 2C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Engine harness and connector pins OK?
 | STEP 2D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2E. Check the exhaust gas temperature circuit for a short circuit from pin-to-ground. | More than 100k ohms?
 | STEP 2F. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 726 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 726 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature circuit.

Guided Step 2A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in the OFF mode.

Action

Check the cylinder 12 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 12 and 10.
  • Install the temperature sensor from cylinder 12 to cylinder 10.
  • Install the temperature sensor from cylinder 10 to cylinder 12.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 726 is inactive and Fault Code 725 is active.

Fault Code 726 inactive and Fault Code 725 active?
YES NO

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 12 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connectors from the cylinder 12 exhaust gas temperature sensor.

Action

Check the 5-VDC supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 12.
  • Reference the wiring diagram for the harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2C

Guided Step 2C - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 12 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the exhaust gas temperature circuit for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 12 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Measure the resistances from the exhaust temperature SUPPLY pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors in pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the exhaust gas temperature circuit for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 12 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-ground.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the CM850 module connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check the exhaust gas temperature circuit for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 12 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the engine harness CM850 module connector to the exhaust temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust temperature 5-VDC SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and engine running for more than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 726 is inactive.

Fault Code 726 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 01-Mar-2011


FAULT CODE 727 - Multiple Turbochargers - Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 727 active?
STEP 2. | Check the exhaust gas temperature circuit. |
 | STEP 2A. Check the exhaust gas temperature sensor response. | Fault Code 727 inactive and Fault Code 728 active?
 | STEP 2B. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check the exhaust gas temperature circuit for a short circuit pin-to-ground. | Greater than 100k ohms?
 | STEP 2E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 727 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronicservice tool.

Action

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 727 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault code information. Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature circuit.

Guided Step 2A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder 14 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 14 and 16.
  • Install the temperature sensor from cylinder 14 to cylinder 16.
  • Install the temperature sensor from cylinder 16 to cylinder 14.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 727 is inactive and that Fault Code 728 is active.

Fault Code 727 inactive and Fault Code 728 active?
YES NO

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 14 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 14 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the the circuit diagram or wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the circuit diagram or wiring diagram for harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harnessor the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 14 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

Repair the engine harness.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 14 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-ground:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the circuit diagram or wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harnessor the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 14 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust temperature sensor connector.

Perform these checks on all interconnecting harness connectors in the circuit.Use the following procedure for the resistance measurement techniques.

Refer to the circuit diagram or wiring diagram to the identify connectors and pins.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Placre run/stop/auto switch in the RUN mode and engine operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to verify that Fault Code 727 is inactive.

Fault Code 727 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

Connect INSITE™ electronic service tool.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to the appropriate troubleshooting chart.

Last Modified: 25-Mar-2011


FAULT CODE 727 - Exhaust Gas Temperature Cylinder 14 (B7) - Voltage Below Normal or Shorted to Low Source (Single Turbocharger)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™/ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault code. |
 | STEP 1A. Check for active fault codes. | Fault Code 727 active?
STEP 2. | Check the exhaust gas temperature circuit. |
 | STEP 2A. Check the exhaust gas temperature sensor response. | Fault Code 727 inactive and Fault Code 728 active?
 | STEP 2B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 2C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Engine harness and connector pins OK?
 | STEP 2D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2E. Check the exhaust gas temperature circuit for a short circuit from pin-to-ground. | More than 100k ohms?
 | STEP 2F. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 727 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 727 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature circuit.

Guided Step 2A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in the OFF mode.

Action

Check the cylinder 14 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 14 and 16.
  • Install the temperature sensor from cylinder 14 to cylinder 16.
  • Install the temperature sensor from cylinder 16 to cylinder 14.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 727 is inactive and Fault Code 728 is active.

Fault Code 727 inactive and Fault Code 728 active?
YES NO

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 14 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connectors from the cylinder 14 exhaust gas temperature sensor.

Action

Check the 5-VDC supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 14.
  • Reference the wiring diagram for the harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2C

Guided Step 2C - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 14 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the exhaust gas temperature circuit for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 14 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Measure the resistances from the exhaust temperature SUPPLY pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors in pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the exhaust gas temperature circuit for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 14 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-ground.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the CM850 module connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check the exhaust gas temperature circuit for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 14 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the engine harness CM850 module connector to the exhaust temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust temperature 5-VDC SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and engine running for more than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 727 is inactive.

Fault Code 727 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 02-Mar-2011


FAULT CODE 728 - Multiple Turbochargers - Exhaust Gas Temperature Sensor Circuit Cylinder 16 – Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 728 active?
STEP 2. | Check the exhaust gas temperature circuit. |
 | STEP 2A. Check the exhaust gas temperature sensor response. | Fault Code 728 inactive and Fault Code 727 active?
 | STEP 2B. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 2D. Check the exhaust gas temperature circuit for a short circuit pin-to-ground. | Greater than 100k ohms?
 | STEP 2E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 728 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronicservice tool.

Action

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 728 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault code information. Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature circuit.

Guided Step 2A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder 16 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 16 and 14.
  • Install the temperature sensor from cylinder 16 to cylinder 14.
  • Install the temperature sensor from cylinder 14 to cylinder 16.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 728 is inactive and that Fault Code 727 is active.

Fault Code 728 inactive and Fault Code 727 active?
YES NO

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 16 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 16 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the the circuit diagram or wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the circuit diagram or wiring diagram for harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harnessor the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 16 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

Repair the engine harness.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 16 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-ground:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the circuit diagram or wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harnessor the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 16 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust temperature sensor connector.

Perform these checks on all interconnecting harness connectors in the circuit.Use the following procedure for the resistance measurement techniques.

Refer to the circuit diagram or wiring diagram to the identify connectors and pins.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Placre run/stop/auto switch in the RUN mode and engine operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to verify that Fault Code 728 is inactive.

Fault Code 728 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

Connect INSITE™ electronic service tool.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to the appropriate troubleshooting chart.

Last Modified: 25-Mar-2011


FAULT CODE 728 - Exhaust Gas Temperature Cylinder 16 (B8) - Voltage Below Normal or Shorted to Low Source (Single Turbocharger)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™/ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault code. |
 | STEP 1A. Check for active fault codes. | Fault Code 728 active?
STEP 2. | Check the exhaust gas temperature circuit. |
 | STEP 2A. Check the exhaust gas temperature sensor response. | Fault Code 728 inactive and Fault Code 727 active?
 | STEP 2B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 2C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Engine harness and connector pins OK?
 | STEP 2D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2E. Check the exhaust gas temperature circuit for a short circuit from pin-to-ground. | More than 100k ohms?
 | STEP 2F. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 728 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 728 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust gas temperature circuit.

Guided Step 2A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place run/stop/auto switch in the OFF mode.

Action

Check the cylinder 16 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 16 and 14.
  • Install the temperature sensor from cylinder 16 to cylinder 14.
  • Install the temperature sensor from cylinder 14 to cylinder 16.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 728 is inactive and Fault Code 727 is active.

Fault Code 728 inactive and Fault Code 727 active?
YES NO

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 16 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connectors from the cylinder 16 exhaust gas temperature sensor.

Action

Check the 5-VDC supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 16.
  • Reference the wiring diagram for the harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2C

Guided Step 2C - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 16 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the exhaust gas temperature circuit for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 16 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Measure the resistances from the exhaust temperature SUPPLY pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors in pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check the exhaust gas temperature circuit for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 16 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-ground.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the CM850 module connector to engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check the exhaust gas temperature circuit for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 16 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistances from the exhaust temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the engine harness CM850 module connector to the exhaust temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistances from the exhaust temperature 5-VDC SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and engine running for more than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 728 is inactive.

Fault Code 728 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 02-Mar-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 453 or 454 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Run mode and running for longer than 1 minute.

Action

Check the Electronic Control Module (ECM).

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 453 or 454 active?
YES NO
No Repair

Repair

t02-1001 (Engine Performance Troubleshooting Tree) in Section TT.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault code.

Conditions

  • Run/Stop/Auto switch in the Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault code.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


FAULT CODE 781 - SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 781 active?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and associated connector pins. | Dirty or damaged pins?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 781 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 781 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and associated connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Inspect the engine harness and associated connector pins.

  • Refer to Procedure 019-417 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the engine harness.

  • Refer to Procedure 019-417 in Section 19.

Repair or replace the ECM.

  • Refer to Procedure 019-031 in Section 19.
No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Clear the inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in STOP mode.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Clear the inactive fault codes.

  • Clear inactive fault codes by pressing the "Reset" button on the control panel and cycling the engine keyswitch . Use INSITE™ electronic service tool to verify inactive fault codes are cleared.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Go to 3B

Appropriate troubleshooting steps.

Guided Step 3B - Verify the fault code is inactive.

Conditions

  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in STOP mode.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 781 is inactive.

Fault Code 781 inactive?
YES NO

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Repair complete

Go to 1A

Last Modified: 01-Aug-2010


FAULT CODE 783 - Intake Manifold 1 Temperature - Abnormal Rate of Change

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active Fault Code 783. | Fault Code 783 active?
 | STEP 1B. Check the ECM for any other active fault codes. | Other fault codes active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Check the exhaust emissions are correct per engine rating/specification. | Exhaust emissions to specification?
STEP 3. | Check the intake manifold 1 temperature sensor. |
 | STEP 3A. Inspect the intake manifold 1 temperature sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Verify intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe. | Thermocouple reading agree with intake manifold 1 temperature sensor reading in INSITE™ electronic service tool?
STEP 4. | Inspect the coil-on-plug assemblies. |
 | STEP 4A. Inspect the coil-on-plug assembly harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Inspect the coil-on-plug assemblies for cracks or other damage. | Coil-on-plug assembly cracked or damaged?
 | STEP 4C. Check the coil-on-plug primary winding resistance is to specification. | Primary winding resistance below 1 ohm?
 | STEP 4D. Check the coil-on-plug secondary winding resistance. | Secondary winding resistance between 5k ohms and 12k ohms?
STEP 5. | Inspect the spark plugs. |
 | STEP 5A. Inspect the spark plugs. | Damage found?
 | STEP 5B. Check the spark plug gap is to specification. | Spark plug gap to specification?
STEP 6. | Inspect the air intake filters for excessive restriction. |
 | STEP 6A. Inspect the engine air intake filters for excessive restriction. | Restriction present?
 | STEP 6B. Inspect the engine room or engine container air inlet filters, if fitted, for excessive restriction. | Restriction present?
STEP 7. | Inspect the throttle and throttle mounting flange. |
 | STEP 7A. Inspect the throttle driver and engine harness electrical connectors. | Dirty or damaged pins?
 | STEP 7B. Check the throttle for free movement throughout the full range of movement. | Throttle drives through full range with no throttle position feedback errors reported in INSITE™ electronic service tool?
 | STEP 7C. Inspect the throttle plate alignment. | Throttle plate misaligned?
 | STEP 7D. Inspect the throttle mounting flange for leaks or cracks. | Leak or crack found?
STEP 8. | Check the fuel control valve actuator. |
 | STEP 8A. Inspect the fuel control valve actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 8B. Check the fuel control valve actuator commanded position signal percent duty cycle. | Percent duty cycle 10 to 91 percent?
 | STEP 8C. Check the fuel control valve actuator commanded position signal percent duty cycle output from the ECM. | Percent duty cycle 10 to 91 percent?
 | STEP 8D. Check the fuel control valve actuator position feedback signal voltage. | Feedback signal voltage 0 to 5 VDC?
 | STEP 8E. Check the fuel control valve actuator position feedback signal voltage input to the ECM. | Feedback signal voltage 0 to 5 VDC?
STEP 9. | Check the engine compression. |
 | STEP 9A. Check individual cylinder compression pressures. | Gross leakage detected?
STEP 10. | Check the quality of the natural gas supply to the engine. |
 | STEP 10A. Check the quality of the natural gas supply. | Natural gas supply meets or exceeds minimum specification for engine application?
STEP 11. | Clear the fault codes. |
 | STEP 11A. Clear the inactive fault codes. | All fault codes cleared?
 | STEP 11B. Verify fault code is inactive. | Fault Code 783 inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault code 783.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 783.

  • Use INSITE™ electronic service tool to read the left bank CM558 module fault codes.

Fault Code 783 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check the ECM for any other active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for any other active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Other fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree in Section TS.

Go to 2A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Check the exhaust emissions are correct per engine rating/specification.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Close generator circuit breaker.
  • Apply rated load.

Note: Make sure all recommended pre-start checks as detailed in the Shop Talk section of Fault Code Overview 59-fc783 have been performed prior to starting the engine.

Action

Verify exhaust emissions are adjusted to specification.

  • Use the air/fuel adjustment wizard to verify the engine is operating to published emissions specification with INSITE™ electronic service tool.

Exhaust emissions to specification?
YES NO
No Repair

Repair

Correct the exhaust emissions. Use INSITE™ electronic service tool.

Go to 3A

Go to 11A

Guided Step 3 - Check the intake manifold 1 temperature sensor.

Guided Step 3A - Inspect the intake manifold 1 temperature sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the intake manifold 1 temperature sensor and the engine harness connectors and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the engine harness or the intake manifold 1 temperature sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold 1 air temperature sensor. Refer to Procedure 019-059 in Section 19.
No Repair

Go to 11A

Go to 2B

Guided Step 3B - Verify the intake manifold 1 temperature sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Verify the intake manifold 1 temperature sensor accuracy with a 3A thermocouple or similar temperature probe as follows:

  • Connect a temperature probe of known quality and accuracy to the engine near the intake manifold 1 temperature sensor. The probe must extend into the air flow and must not touch the intake manifold, except at the probe threads.
  • Compare the intake manifold 1 temperature sensor reading on the INSITE™ electronic service tool monitor screen to the reading from the temperature probe.

NOTE: If a temperature measuring device is not available, answer Yes to this step.

Does the thermocouple reading agree with the intake manifold temperature sensor reading in INSITE™ electronic service tool?
YES NO
No Repair

Repair

Replace the intake manifold 1 temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 3A

Go to 11A

Guided Step 4 - Inspect the coil-on-plug assemblies.

Guided Step 4A - Inspect the coil-on-plug assembly harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the-coil-on plug assembly connectors, the engine harness connectors, and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the engine harness or coil-on-plug assembly, whichever has the dirty or damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the coil-on-plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.
No Repair

Go to 11A

Go to 4B

Guided Step 4B - Inspect the coil-on-plug assemblies for cracks or other damage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the coil-on-plug assemblies for cracks or other damage.

  • Inspect the coil-on-plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Coil-on-plug assembly cracked or damaged?
YES NO

Repair

Replace the coil-on-plug assembly.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.
No Repair

Go to 11A

Go to 4C

Guided Step 4C - Check the coil-on-plug primary winding resistance is to specification.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the coil-on-plug primary winding resistance is to specification.

  • Use a multimeter to measure the resistance of the primary winding.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Use the following procedure for general multimeter resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Primary resistance below 1 ohm?
YES NO
No Repair

Repair

Replace the coil-on-plug assembly.

  • Use the following procedure in the QSK60G Generator Cm700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 4D

Go to 11A

Guided Step 4D - Check the coil-on-plug secondary winding resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the coil-on-plug secondary winding resistance is to specification.

  • Use a multimeter to measure the resistance of the primary winding.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Use the following procedure for general multimeter resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Secondary winding resistance between 5k ohms and 12k ohms?
YES NO
No Repair

Repair

Replace the coil-on-plug assembly.

  • Use the following procedure in the QSK60G Generator Cm700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 5A

Go to 11A

Guided Step 5 - Inspect the spark plugs.

Guided Step 5A - Inspect the spark plugs.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plugs for cracks, contamination, signs of high temperature tracking down the porcelain, or other damage.

  • Inspect the spark plugs.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Damage found?
YES NO

Repair

Replace the spark plugs, as necessary.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 11A

Go to 5B

Guided Step 5B - Check the spark plug gap is to specification.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap is to specification.

  • Measure the spark plug electrode gap.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap to specification?
YES NO
No Repair

Repair

Replace the spark plugs, as necessary.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Go to 6A

Go to 11A

Guided Step 6 - Inspect the air intake filters for excessive restriction.

Guided Step 6A - Inspect the engine air intake filters for excessive restriction.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for engine air intake filter restriction or damage that can cause excessive restriction.

  • Use the following procedure in the QSK60G Generator CM700 Operation and Maintenance Manual, Bulletin 4021395, or QSK60 G CM700 K103 Operation and Maintenance Manual, Bulletin 4325991. Refer to Procedure 010-086 in Section 3.

Restriction present?
YES NO

Repair

Replace the air cleaner elements.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 010-014 in Section 10.
No Repair

Go to 11A

Go to 6B

Guided Step 6B - Inspect the engine room or engine container air inlet filters, if fitted, for excessive restriction.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for engine room or engine container air inlet filter restriction or damage that can cause excessive restriction.

  • See equipment manufacturer service information for air filter restriction guidelines.

Restriction present?
YES NO

Repair

Replace the air cleaner elements.

  • See equipment manufacturer service information for air filter replacement procedures.
 No Repair

Go to 11A

Go to 7A

Guided Step 7 - Inspect the throttle and throttle mounting flange.

Guided Step 7A - Inspect the throttle driver and engine harness electrical connections.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the throttle driver connectors, engine harness connectors, and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the engine harness or the throttle driver assembly, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 005-052 in Section 5.
No Repair

Go to 11A

Go to 7B

Guided Step 7B - Check the throttle for free movement throughout the full range of movement.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the throttle plate for free movement throughout the full range of movement.

  • Use INSITE™ electronic service tool to check the throttle plate for free movement throughout the full range of movement.

Throttle drives through full range with no throttle position feedback errors reported in INSITE™ electronic service tool?
YES NO
No Repair

Repair

Repair or replace the throttle assembly.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 005-052 in Section 5.

Go to 7C

Go to 11A

Guided Step 7C - Inspect the throttle plate alignment.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the throttle plate alignment.

  • Check the throttle plate alignment within the air/fuel intake plenum. The throttle body must be centered within the plenum.

Throttle plate misaligned?
YES NO

Repair

Realign the throttle plate or replace the throttle assembly.

  • Loosen the throttle plate mounting bolts. Align the throttle plate on the throttle shaft so the throttle plate is centered within the air/fuel intake plenum.
  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 005-052 in Section 5.
No Repair

Go to 11A

Go to 7D

Guided Step 7D - Inspect the throttle mounting flange for leaks or cracks.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.

Action

Check the throttle mounting flange for leaks or cracks.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 010-024 in Section 10.

Leak or crack found?
YES NO

Repair

Repair or replace the throttle body assembly.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 005-052 in Section 5.
No Repair

Go to 11A

Go to 8A

Guided Step 8 - Check the fuel control valve actuator.

Guided Step 8A - Inspect the fuel control valve actuator and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the fuel control valve connectors, engine harness connectors, and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the engine harness or the fuel control valve assembly, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel control valve assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 006-049 in Section 6.
No Repair

Go to 11A

Go to 8B

Guided Step 8B - Check the fuel control valve actuator commanded position signal percent duty cycle.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded position signal percent duty cycle.

  • Use Actuator Test in INSITE™ electronic service tool to drive the fuel control valve to a number of positions between 0 and 100 percent.
  • Connect breakout harnesses, Part Numbers 2892245 and 3824892, to the fuel control valve actuator connector. Use a multimeter to measure the commanded position percent duty cycle by connecting the multimeter probes between the fuel control valve actuator position SIGNAL (+) and RETURN (-) pins at the fuel control valve actuator connector. The signal percent duty cycle must be between 10 and 91 percent based on fuel control valve actuator position.
  • Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

See the specification table provided in the Shop Talk section of this fault code overview for commanded position percent duty cycle specifications.

Percent duty cycle 10 to 91 percent?
YES | NO
No Repair | No Repair

Go to 8D

Go to 8C

Guided Step 8C - Check the fuel control valve actuator commanded position signal percent duty cycle output from the ECM.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded position signal percent duty cycle output from the ECM.

  • Use Actuator Test in INSITE™ electronic service tool to drive the fuel control valve to a number of positions between 0 and 100 percent.
  • Open the back shell of the left bank SSM558 module connector B to expose the connector pins. Use a multimeter to measure the commanded position percent duty cycle output. Connect the multimeter probes between the fuel control valve actuator position SIGNAL (+) and RETURN (-) pins at the ECM connector. The signal percent duty cycle must be between 10 and 91 percent based on fuel control valve actuator position.
  • Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

See the specification table provided in the Shop Talk section of this fault code overview for commanded position percent duty cycle.

Percent duty cycle 10 to 91 percent?
YES NO

Repair

Repair or replace the engine wiring harness.

  • Refer to Procedure 019-043 in Section 19.

Repair

Replace the left bank SSM558 module.

  • Refer to Procedure 019-031 in Section 19.

Go to 11A

Go to 8C

Guided Step 8D - Check the fuel control valve actuator commanded position feedback signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator feedback signal voltage.

  • Use Actuator Test in INSITE™ electronic service tool to drive the fuel control valve to a number of positions between 0 and 100 percent.
  • Connect breakout harnesses, Part Numbers 2892245 and 3824892, to the fuel control valve actuator connector. Use a multimeter to measure the voltage. Connect the multimeter probes between the fuel control valve actuator position SIGNAL (+) and RETURN (-) pins at the fuel control valve actuator connector. The position feedback voltage must be between 0 and 5 VDC based on fuel control actuator position.
  • Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

See the specification table provided in the Shop Talk section of this fault code overview for commanded position percent duty cycle specifications.

Feedback signal voltage 0 to 5 VDC?
YES NO
No Repair

Repair

Replace the fuel control valve assembly.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 006-049 in Section 6.

Go to 8E

Go to 11A

Guided Step 8E - Check the fuel control valve actuator position feedback signal voltage input to the ECM.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator position feedback signal voltage input at the ECM.

  • Use Actuator Test in INSITE™ electronic service tool to drive the fuel control valve to a number of positions between 0 and 100 percent.
  • Open the back shell of the left bank SSM558 module connector B to expose the connector pins. Use a multimeter to measure the input. Connect the multimeter probes between the fuel control valve actuator position SIGNAL (+) and RETURN (-) pins at the fuel control valve actuator connector. The position feedback voltage must be between 0 and 5 VDC based on fuel control valve actuator position.
  • Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

See the specification table provided in the Shop Talk section of this fault code overview for commanded position percent duty cycle specifications.

Feedback signal voltage 0 to 5 VDC?
YES NO
No Repair

Repair

Repair or replace the engine wiring harness.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 006-049 in Section 6.

Go to 9A

Go to 11A

Guided Step 9 - Check the engine compression.

Guided Step 9A - Check individual cylinder compression pressures.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check individual cylinder compression for gross leakage.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 014-012 in Section 14.

Gross leakage detected?
YES NO

Repair

Repair or replace the following components, as necessary, on the cylinders where gross leakage has been detected.

Use the following procedures in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396:

  • Refer to Procedure 002-021 in Section 2 for the cylinder head gasket.
  • Refer to Procedure 002-004 in Section 2 for the cylinder head.
  • Refer to Procedure 001-047 in Section 1 for the piston rings.
  • Refer to Procedure 001-028 or Refer to Procedure 001-045 in Section 1 for the cylinder liner.
No Repair

Go to 11A

Go to 10A

Guided Step 10 - Check the quality of the natural gas supply to the engine.

Guided Step 10A - Check the quality of the natural gas supply.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the quality of the natural gas supply to the engine for the following:

  • Fuel quality - check the quality of the natural gas supplied to the engine meets or exceeds the minimum requirements for the engine application (methane number and fuel contaminants limits). Use the following procedure in the QSK60G Generator CM700 Operation and Maintenance Manual, Bulletin 4021395, or the Generator Drive QSK60 G CM700 K103 Operation and Maintenance Manual, Bulletin 4325991. Refer to Procedure 018-002 in Section V.

Natural gas supply meets or exceeds minimum specification for engine application?
YES NO
No Repair

Repair

Use the following procedure in the QSK60G Generator CM700 Operation and Maintenance Manual, Bulletin 4021395, or the Generator Drive QSK60 G CM700 K103 Operation and Maintenance Manual, Bulletin 4325991. Refer to Procedure 018-033 in Section V.

Go to 11A

Go to 11A

Guided Step 11 - Clear the fault codes.

Guided Step 11A - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
  • Depending on the generator set controller, the inactive fault codes may need to be cleared in the control panel. Cycle the engine ECM keyswitch.
  • Use INSITE™ electronic service tool to verify the inactive fault codes are cleared.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Go to 11B

Go to the appropriate fault code troubleshooting tree..

Guided Step 11B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode. Operate the engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 783 is inactive.

Fault Code 783 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if the steps have been completed and check again.

Repair complete

Go to 1A

Last Modified: 10-Nov-2014


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2517 or 2518 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2517 or 2518 active?
YES NO
No Repair

Repair

Check the turbocharger. Refer to Procedure 010-033 (Turbocharger) in the Service Manual QSK45 and QSK60, Bulletin 4021530.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


FAULT CODE 1243 - Engine Derate - Condition Exists

Associated Procedures

Cautions and Warnings

WARNING

Troubleshooting presents the risk of equipment damage, personal injury, or death. Troubleshooting must be performed by trained, experienced technicians.
CAUTION

To avoid the possibility of damaging a new ECM, all other fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 1243 and 3458 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Verify the fault code is inactive. | Fault code inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1243 and 3458 active?
YES NO

Repair

Follow the troubleshooting steps for Fault Code 3458 or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.
  • Reference the troubleshooting tree Engine Noise Excessive - Combustion Knocks in Section TS.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place Run/Stop/Auto switch in RUN mode.
  • Operate the engine for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 1243 is inactive.

Fault code inactive?
YES NO

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 19-Jul-2010


FAULT CODE 1274 - Engine Cylinder Number 10 Knock - Data Valid But AboveNormal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1213, 1274, 1281, 1286, 1291, 1296, 1583, and 2282 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specifications?
STEP 3. | Check the kilowatt load reference calibration. |
 | STEP 3A. Check the kilowatt load transducer-sensed kilowatts calibration against the generator set controller kilowatts calibration. | Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
 | STEP 3B. Check the generator set controller calibration. | Generator set controller voltage and ampere output calibration correct?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor resistances within specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor supply voltages and reference resistances within specification?
STEP 6. | Check the quality of the natural gas supply to the generator set. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply quality within specification for generator set?
STEP 7. | Inspect cylinder number 10 cylinder head. |
 | STEP 7A. Check the cylinder number 10 spark plug. | Cylinder number 10 spark plug contaminated or damaged?
 | STEP 7B. Check cylinder number 10 spark plug gap. | Cylinder number 10 spark plug gap excessive?
 | STEP 7C. Check the cylinder number 10 cylinder head. | Cylinder number 10 leaking gaskets or loose components?
 | STEP 7D. Check the cylinder number 10 valve lash. | Cylinder number 10 valve lash setting correct?
 | STEP 7E. Check the cylinder number 10 valve train. | Cylinder number 10 valve train wear?
STEP 8. | Inspect cylinder number 10 power cylinder. |
 | STEP 8A. Inspect the lubricating oil filters and check filter medium for debris. | Cylinder number 10 has debris present in oil filter?
 | STEP 8B. Inspect the cylinder number 10 internal power cylinder. | Cylinder number 10 damage to power cylinder components?
 | STEP 8C. Inspect the cylinder number 10 connecting rod bearings. | Cylinder number 10 damage to connecting rod bearings?
 | STEP 8D. Inspect the cylinder number 10 piston cooling nozzle. | Cylinder number 10 piston cooling nozzle bent or missing?
 | STEP 8E. Check cylinder number 10 and adjacent cylinders main bearings. | Main bearings damaged?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Is Fault Code 1274 inactive?
 | STEP 9B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1213, 1274, 1281, 1286, 1291, 1296, 1583, and 2282 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Reference troubleshooting tree t048 in Section TS.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Connect an exhaust gas analyzer.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode.
  • Operate engine at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Check exhaust emissions.

  • Use an exhaust gas analyzer. Insert the sample probe inserted into the exhaust gas manifold test port and check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure for exhaust emission specifications in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-020 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specifications?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool and reference the exhaust gas analyzer, adjust the open and closed loop fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.

  • Use the following procedure for exhaust emission specifications in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-020 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 9A

Guided Step 3 - Check the kilowatt load reference calibration.

Guided Step 3A - Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller kilowatt calibration.

Conditions

NOTE: If the generator set is not fitted with a kilowatt load transducer, proceed to Guided Step 3B.

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode with load available.

Action

Check the kilowatt load transducer-sensed kilowatts againist the generator set controller kilowatts.

  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool and calibrate the kilowatt load sensor milliampere/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the generator set controller calibration.

Conditions

NOTE: This guided step should only be followed for generator sets not fitted with a kilowatt load transducer.

  • Connect all components.
  • Connect a power analyzer or digital multimeter.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode with load available.

Action

Check the generator set controller calibration.

  • Connect a power analyzer or digital multimeter to the alternator main output terminals. Check that the generator set controller readings for output voltage (L1- L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller voltage and ampere output calibration correct?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter to calibrate the generator set controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode.
  • Operate engine at maximum possible load with no knock present with load available.

Action

Check the intake manifold temperature.

Use the generator set Human Machine Interface (HMI) to check the intake manifold temperature. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold temperature within specification?
YES NO
No Repair

Repair

Check the following:

  • Check the temperature of the high temperature (HT) coolant outlet from the engine. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-018 in Section V.
  • Check the temperature of the low temperature (LT) coolant outlet from the engine. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 018-018 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTORUN/STOP/AUTO

Action

Check the intake manifold temperature sensor resistances.

NOTE: The intake manifold temperature sensor may have malfunctioned in range. The related fault codes will not be activated.

  • Reference Fault Code 153 (Intake Manifold Temperature Sensor Shorted High) in Section TF.
  • Reference Fault Code 154 (Intake Manifold Temperature Sensor Shorted Low) in Section TF.
  • Use the following procedure for connector pin information. Refer to Procedure 019-360 in Section 19.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Intake manifold temperature sensor resistances within specification?
YES NO
No Repair

Repair

Replace the intake temperature sensor.

  • Refer to Procedure 019-059 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold pressure.

  • Use the generator set HMI to check the intake manifold pressure. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold pressure within specification?
YES NO
No Repair

Repair

If fitted, check the operation of the compressor bypass valve (single turbochargers engines only).

  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check the intake manifold pressure sensor.

NOTE: The intake manifold pressure sensor may have malfunctioned in range and the related fault codes will not be activated. Reference Fault Codes 354 (Intake Manifold Pressure Sensor Shorted High) or Fault Code 355 (Intake Manifold Pressure Sensor Shorted Low) in Section TF.

  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use the following procedure for connector pin location. Refer to Procedure 019-359 in Section 19.

Intake manifold pressure sensor within specification?
YES NO
No Repair

Repair

Replace the intake manifold pressure sensor.

  • Refer to Procedure 019-061 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the generator set.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check the quality of the natural gas supply.

  • Check the quality of the natural gas supplied to the generator set meets or exceeds minimum requirement for generator set (methane number and fuel contaminants limits).
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-016 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Natural gas supply quality within specification for generator set?
YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspect cylinder number 10 cylinder head.

Guided Step 7A - Check the cylinder number 10 spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug J connector damaged.
  • Inspect the electrode for signs of oil contamination.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder number 10 spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten or replace the spark plug.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the cylinder number 10 spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Remove the spark plug and measure the spark plug electrode gap.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
  • Contact a Cummins® Authorized Repair Location.

Cylinder number 10 spark plug gap excessive?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7C

Guided Step 7C - Check the cylinder number 10 cylinder head.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Inspect cylinder 10 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder number 10 cylinder head.

Cylinder number 10 cylinder head leaking gaskets or loose components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head gasket. Use the following procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose components on or immediately around cylinder number 10 cylinder head. Refer to the appropriate procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396.
No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check the cylinder number 10 valve lash setting is correct.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check cylinder 10 valve lash setting is correct.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder number 10 valve lash setting correct?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7E

Guided Step 7E - Check the cylinder number 10 valve train.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Inspect the cylinder 10 valve train for the following:

  • Inlet or exhaust valve wear/recession or damage. Use the following procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Camshaft follower wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder number 10 camshaft lobe wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 4.

Cylinder number 10 valve train wear?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head. Use the following procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the camshaft follower assembly. Refer to Procedure 004-001 in Section 4.
  • Replace the rocker lever assembly. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft. Refer to Procedure 001-008 in Section 4.

Repair

Adjust the valve lash. Set the valve lash setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 9A

Go to 8A

Guided Step 8 - Inspect the cylinder number 10 power cylinder.

Guided Step 8A - Inspect the oil filters for debris.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubrication oil filter. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter and inspect for debris in the filter medium.
  • Contact a Cummins® Authorized Repair Location.

Cylinder number 10 has debris present in the oil filters?
YES | NO
No Repair | No Repair

Go to 8B

Go to 8D

Guided Step 8B - Check the cylinder number 10 internal power cylinder.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check the internal power cylinder.

NOTE: If available, use a borescope to perform the inspections.

  • Piston ring scuffing or breakage. Use the following procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage.Use the following procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage.

Cylinder number 10 power cylinder damaged?
YES NO

Repair

Replace the piston rings. Use the following procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.

Replace the liner. Use the following procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-045 in Section 1.

Replace the cylinder head. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the cylinder number 10 connecting rod bearings.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP.

Action

Inspect the connecting rod bearings.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder number 10 connecting rod bearings damaged?
YES NO

Repair

Replace the connecting rod bearings:

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.
No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the piston cooling nozzle.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Inspect the piston cooling nozzle.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder number 10 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

No Repair

Go to 9A

Go to 8E

Guided Step 8E - Inspect cylinder number 10 and adjacent cylinder main bearings.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Inspect cylinder number 10 and adjacent cylinder main bearings.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

Main bearings damaged?
YES NO

Repair

Replace the main bearings. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

No Repair

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode.
  • Operate the engine for greater than 1 minute.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to verify Fault Code 1274 is inactive.

Fault Code 1274 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 9B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 02-Aug-2010


FAULT CODE 1275 - Engine Cylinder Number 10 Knock - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 - male Deutsch™ test lead, and Part Number 3824812 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1275 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check the connection from the knock sensor wiring harness to the knock sensor. | Knock sensor wiring harness connected?
 | STEP 2B. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 3. | Check the knock sensor. |
 | STEP 3A. Check the knock sensor is tightened to specification. | Knock sensor tightened to specification?
 | STEP 3B. Test the knock sensor. | Fault Code 579 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1275 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1275 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

 No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the connection from the knock sensor wiring harness to the knock sensor.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check that the knock sensor harness is connected to the knock sensor.

  • Refer to Procedure 019-346 in Section 19.

Knock sensor wiring harness connected?
YES NO
No Repair

Repair

Connect the knock sensor harness to the knock sensor.

  • Refer to Procedure 019-346 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM558 B connector.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the following procedure for general inspection techniques. 019-361 in Section 19.

Refer to the wiring diagram to identify connectors and pins.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair or replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Refer to Procedure 019-204 in Section 19.
  • Repair the wiring harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM558 B connector.

Action

Check for an open circuit:

  • Measure the resistance from knock cylinder number 10 SIGNAL pin in the knock sensor connector to the knock cylinder number 10 SIGNAL pin in the CM558 B Connector.
  • Measure the resistance from knock cylinder number 10 RETURN pin in the knock sensor connector to the knock cylinder number 10 RETURN pin in the CM558 B Connector.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure to identify connectors and pins. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check for a short circuit from pin to pin:

  • Measure the resistance from knock cylinder number 10 SIGNAL pin in the knock sensor harness connector to all other pins in the connector.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for resistance measurement. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Refer to Procedure 019-204 in Section 19.
  • Repair the wiring harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the knock sensor.

Guided Step 3A - Check the knock sensor is tightened to specification.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check the knock sensor is tightened to specification.

  • Check that the knock sensor is tightened to the correct torque value. Refer to Procedure 019-346 in Section 19.

Knock sensor tightened to specification?
YES NO
No Repair

Repair

Tighten the knock sensor. Refer to Procedure 019-346 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Test the knock sensor.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Test the knock sensor.

  • Move the knock sensor from cylinder head number 10 to cylinder head number 9. Install the knock sensor from cylinder head number 9 to cylinder head number 10. Refer to Procedure 019-346 in Section 19.
  • Place the RUN/STOP/AUTO switch in RUN mode and operate the engine for greater than 1 minute. Use the following procedure for starting the engine in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 101-014 in Section 1.

Fault Code 579 active?
YES NO

Repair

Replace the knock sensor. Refer to Procedure 019-346 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode.
  • Operate the engine for greater than 1 minute.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to verify Fault Code 1275 is inactive.

Fault Code 1275 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 01-Aug-2010


FAULT CODE 1277 - Engine Cylinder Number 11 Knock – Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 male Deutsch™ test lead, and Part Number 3824812 female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1277 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check the connection from the knock sensor wiring harness to the knock sensor. | Knock sensor wiring harness connected?
 | STEP 2B. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 3. | Check the knock sensor. |
 | STEP 3A. Check the knock sensor is tightened to specification. | Knock sensor tightened to specification?
 | STEP 3B. Test the knock sensor. | Is Fault Code 1282 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1277 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1277 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the connection from the knock sensor wiring harness to the knock sensor.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check that the knock sensor harness is connected to the knock sensor.

  • Refer to Procedure 019-346 in Section 19.

Knock sensor wiring harness connected?
YES NO
No Repair

Repair

Connect the knock sensor harness to the knock sensor.

  • Refer to Procedure 019-346 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM558 B connector.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the following procedure for general inspection techniques. 019-361 in Section 19.

Refer to the wiring diagram to identify connectors and pins.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair or replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Refer to Procedure 019-204 in Section 19.
  • Repair the wiring harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM558 B connector.

Action

Check for an open circuit:

  • Measure the resistance from knock cylinder number 11 SIGNAL pin in the knock sensor connector to the knock cylinder number 11 SIGNAL pin in the CM558 B Connector.
  • Measure the resistance from knock cylinder number 11 RETURN pin in the knock sensor connector to the knock cylinder number 11 RETURN pin in the CM558 B Connector.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure to identify connectors and pins. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check for a short circuit from pin to pin:

  • Measure the resistance from knock cylinder number 11 SIGNAL pin in the knock sensor harness connector to all other pins in the connector.
  • Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness.Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 1

Go to 3A

Go to 4A

Guided Step 3 - Check the knock sensor.

Guided Step 3A - Check the knock sensor is tightened to specification.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check the knock sensor is tightened to specification.

  • Check that the knock sensor is tightened to the correct torque value. Refer to Procedure 019-346 in Section 19.

Knock sensor tightened to specification?
YES NO
No Repair

Repair

Tighten the knock sensor. Refer to Procedure 019-346 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Test the knock sensor.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode.
  • Operate the engine for greater than 1 minute (only after relocating the cylinder 11 knock sensor to cylinder 12).

Action

Test the knock sensor.

  • Move the knock sensor from cylinder head number 11 to cylinder head number 12. Install the knock sensor from cylinder head number 12 to cylinder head number 11. Refer to Procedure 019-346 in Section 19.
  • Place the RUN/STOP/AUTO switch in RUN mode and operate the engine for greater than 1 minute. Use the following procedure for starting the engine in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 101-014 in Section 1.

Fault Code 1282 active?
YES NO

Repair

Replace the knock sensor. Refer to Procedure 019-346 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode.
  • Operate the engine for greater than 1 minute.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to verify Fault Code 1277 is inactive.

Fault Code 1277 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 01-Aug-2010


FAULT CODE 1281 - Engine Cylinder Number 12 Knock – Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1213, 1274, 1281, 1286, 1291, 1296, 1583, and 2282 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specifications?
STEP 3. | Check the kilowatt load reference calibration. |
 | STEP 3A. Check the kilowatt load transducer sensed kilowatt calibration against the generator set controller kilowatt calibration. | Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
 | STEP 3B. Check the generator set controller calibration. | Generator set controller output voltage and ampere output calibration correct?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor resistances to specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor supply voltages and reference resistances within specification?
STEP 6. | Check the quality of the natural gas supply to the generator set. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply quality within specification?
STEP 7. | Inspect cylinder number 12 cylinder head. |
 | STEP 7A. Check the cylinder number 12 spark plug. | Cylinder number 12 spark plug contaminated or damaged?
 | STEP 7B. Check the cylinder number 12 spark plug gap. | Cylinder number 12 spark plug gap excessive?
 | STEP 7C. Check the cylinder number 12 cylinder head | Cylinder number 12 leaking gaskets or loose components?
 | STEP 7D. Check the cylinder number 12 valve lash. | Cylinder number 12 valve lash setting correct?
 | STEP 7E. Check the cylinder number 12 valve train. | Cylinder number 12 worn or mis-set valve train components?
STEP 8. | Inspect cylinder number 12 power cylinder. |
 | STEP 8A. Inspect the lubricating oil filters and check filter medium for debris. | Cylinder number 12 debris present in oil filter?
 | STEP 8B. Inspect the cylinder number 12 internal power cylinder. | Cylinder number 12 damage to power cylinder components?
 | STEP 8C. Inspect the cylinder number 12 connecting rod bearings. | Cylinder number 12 damage to connecting rod bearings?
 | STEP 8D. Inspect the cylinder number 12 piston cooling nozzle. | Cylinder number 12 piston cooling nozzle bent or missing?
 | STEP 8E. Check cylinder number 12 and adjacent cylinder main bearings. | Main bearings damaged?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Is Fault Code 1281 inactive?
 | STEP 9B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1213, 1274, 1281, 1286, 1291, 1296, 1583, and 2282 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Reference troubleshooting tree t048 in Section TS.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Connect an exhaust gas analyzer.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode. Operate engine at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Check exhaust emissions.

  • Use an exhaust gas analyzer, with the sample probe inserted into the exhaust gas manifold test port, check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-020 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specifications?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool and reference the exhaust gas analyzer, adjust the open and closed loop fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-020 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 9A

Guided Step 3 - Check the kilowatt load reference calibration.

Guided Step 3A - Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller kilowatt calibration.

Conditions

NOTE: If the generator set is not fitted with a kilowatt load transducer, proceed to Guided Step 3B.

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in Run mode with load available.

Action

Check the kilowatt load transducer-sensed kilowatt calibration againist the generator set controller kilowatt calibration.

  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatts calibration?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool and calibrate the kilowatt load sensor milliampere/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the generator set controller calibration.

Conditions

NOTE: This guided step should only be followed for generator sets not fitted with a kilowatt load transducer.

  • Connect all components.
  • Connect a power analyzer or digital multimeter.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode with load available.

Action

Check the generator controller calibration.

  • Connect a power analyzer or digital multimeter to the alternator main output terminals. Check that the generator set controller readings for output voltage (L1- L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller output voltage and ampere output calibration correct?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter to calibrate the generator set controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode.
  • Operate at mximum possible load with no knock present.with load available.

Action

Check the intake manifold temperature.

Use the generator set Human Machine Interface (HMI) to check the intake manifold temperature. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold temperature within specification?
YES NO
No Repair

Repair

Check the following:

  • Check the temperature of the high temperature (HT) coolant outlet from the engine. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-018 in Section V.
  • Check the temperature of the low temperature (LT) coolant outlet from the engine. Refer to Procedure 018-018 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in RUN mode with load available.

Action

Check the intake manifold temperature sensor resistances.

NOTE: The intake manifold temperature sensor may have malfunctioned in range the related fault codes will not be activated.

  • Reference Fault Code 153 (Intake Manifold Temperature Sensor Shorted High) in Section TF.
  • Reference Fault Code 154 (Intake Manifold Temperature Sensor Shorted Low) in Section TF.
  • Use the following procedure for connector pin information. Refer to Procedure 019-360 in Section 19.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Intake manifold temperature sensor resistances within specification?
YES NO
No Repair

Repair

Replace the intake temperature sensor.

  • Refer to Procedure 019-059 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold pressure.

  • Use the HMI to check the intake manifold pressure. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold pressure within specification?
YES NO
No Repair

Repair

If fitted, check the operation of the compressor bypass valve (single turbochargers engines only).

  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check the intake manifold pressure sensor.

NOTE: The intake manifold pressure sensor may have malfunctioned in range and the related fault codes will not be activated. Reference Fault Codes 354 (Intake Manifold Pressure Sensor Shorted High) or Fault Code 355 (Intake Manifold Pressure Sensor Shorted Low) in Section TF.

  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use the following procedure for connector pin location. Refer to Procedure 019-359 in Section 19.

Intake manifold pressure sensor within specification?
YES NO
No Repair

Repair

Replace the intake manifold pressure sensor.

  • Refer to Procedure 019-061 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the generator set.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check the quality of the natural gas supply.

  • Check the quality of the natural gas supplied to the generator set meets or exceeds minimum requirement for generator set (methane number and fuel contaminants limits).
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-016 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspect cylinder number 12 cylinder head.

Guided Step 7A - Check the cylinder number 12 spark plug.

Conditions

  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug J connector damaged.
  • Inspect the electrode for signs of oil contamination.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder number 12 spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug.
  • Replace the spark plug.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the cylinder number 12 spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Remove the spark plug and measure the spark plug electrode gap.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
  • Contact a Cummins® Authorized Repair Location.

Cylinder number 12 spark plug gap excessive?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7C

Guided Step 7C - Check the cylinder number 12 cylinder head.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Inspect cylinder 12 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • The following procedure is found in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder number 12 cylinder head.

Cylinder number 12 cylinder head leaking gaskets or loose components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head gasket. Use the following procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose components on or immediately around cylinder number 12 cylinder head. Refer to the appropriate procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396.
No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check the cyclinder number 12 valve lash is correct.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check cylinder 12 valve lash is correct.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder number 12 valve lash setting correct?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7E

Guided Step 7E - Check the cylinder number 12 valve train.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Inspect the cylinder 12 valve train for the following:

  • Inlet or exhaust valve wear/recession or damage. Use the following procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Camshaft follower wear. Use the following procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder number 12 camshaft lobe wear. Use the following procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Cylinder number 12 valve train wear?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head. Use the following procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the camshaft follower assembly. Use the following procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the rocker lever assembly. Use the following procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft. Refer to Procedure 001-008 in Section 4.

Repair

Adjust the valve lash. Set the valve lash setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 9A

Go to 8A

Guided Step 8 - Inspect the cylinder number 12 power cylinder.

Guided Step 8A - Inspect the oil filters for debris.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubrication oil filter. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter and inspect for debris in the filter medium.
  • Contact a Cummins® Authorized Repair Location.

Cylinder number 12 debris present in the oil filters?
YES | NO
No Repair | No Repair

Go to 8B

Go to 8D

Guided Step 8B - Check the internal power cylinder.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check the internal power cylinder.

NOTE: If available, use a borescope to perform the inspections.

  • Piston ring scuffing or breakage. Use the following procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage.

Cylinder number 12 power cylinder damaged?
YES NO

Repair

Replace the piston rings. Use the following procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.

Replace the cylinder liner. Use the following procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-045 in Section 1.

Replace the cylinder head. Use the following procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the cylinder 13 connecting rod bearings.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP.

Action

Inspect the connecting rod bearings.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder number 12 connecting rod bearings damaged?
YES NO

Repair

Replace the connecting rod bearings:

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.
No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the piston cooling nozzle.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Inspect the piston cooling nozzle.

Cylinder number 12 piston cooling nozzle bent or broken?
YES NO

Repair

  • Replace the piston cooling nozzle. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.
No Repair

Go to 9A

Go to 8E

Guided Step 8E - Inspect cylinder number 12 and adjacent cylinder main bearings.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Inspect cylinder 12 and adjacent cylinder main bearings.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

Main bearings damaged?
YES NO

Repair

Replace the main bearings. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

No Repair

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode.
  • Operate the engine for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 1281 is inactive.

Fault Code 1281 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 9B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 02-Aug-2010


FAULT CODE 1282 - Engine Cylinder Number 12 Knock - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 male Deutsch™ test lead, and Part Number 3824812 female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1282 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check the connection from the knock sensor wiring harness to the knock sensor. | Knock sensor harness connected?
 | STEP 2B. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 3. | Check the knock sensor. |
 | STEP 3A. Check the knock sensor is tightened to specification. | Knock sensor tightened to specification?
 | STEP 3B. Test the knock sensor. | Fault Code 1277 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1282 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1282 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

 No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the connection from the knock sensor wiring harness to the knock sensor

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check that the knock sensor harness is connected to the knock sensor:

  • Refer to Procedure 019-346 in Section 19.

Knock sensor wiring harness connected?
YES NO
No Repair

Repair

Connect the knock sensor harness to the knock sensor.

  • Refer to Procedure 019-346 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM558 B connector.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.

Install the appropriate connector seal if it is damaged or missing.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM558 B connector.

Action

Check for an open circuit.

  • Measure the resistance from the knock cylinder number 12 SIGNAL pin in the knock sensor connector to the knock cylinder number 12 SIGNAL pin in the CM558 B.
  • Measure the resistance from the knock cylinder number 12 RETURN pin in the knock sensor connector to the knock cylinder number 12 RETURN pin in the CM558 B.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

Repair the wiring harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance from knock cylinder number 12 SIGNAL pin in the knock sensor harness connector to all other pins in the connector.
  • Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Refer to Procedure 019-204 in Section 19.
  • Repair the wiring harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the knock sensor.

Guided Step 3A - Check the knock sensor is tightened to specification.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check the knock sensor is tightened to specification.

  • Check that the knock sensor is tightened to the correct torque value. Refer to Procedure 019-346 in Section 19.

Knock sensor tightened to specification?
YES NO
No Repair

Repair

Tighten the knock sensor. Refer to Procedure 019-346 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Test the knock sensor.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode. (Operate the engine only after locating the cylinder number 12 knock sensor to cylinder 11)
  • Operate engine for greater than 1 minute.

Action

Test the knock sensor.

  • Move the knock sensor from cylinder head number 12 to cylinder head number 11. Install the knock sensor from cylinder head number 11 to cylinder head number 12. Refer to Procedure 019-346 in Section 19.
  • Place the RUN/STOP/AUTO switch in the RUN mode and operate the engine for greater than 1 minute. Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 101-014 in Section 1.

Fault Code 1277 active?
YES NO

Repair

Replace the knock sensor. Refer to Procedure 019-346 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode.
  • Operate the the engine for greater than 1 minute.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify Fault Code 1282 is inactive.

Fault Code 1282 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 01-Aug-2010


FAULT CODE 1285 - Engine Cylinder Number 13 Knock - Data Valid But AboveNormal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 146, 151, 155, 488, 1285, 1295, 1579, 1581, 1582, 2281, 2282, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2531, and 2532 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specification?
STEP 3. | Check the kilowatt load reference signal |
 | STEP 3A. Check the kilowatt load transducer reference signal - where fitted. | Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
 | STEP 3B. Check the calibration of the generator set controller. | Generator set controller output voltage and ampere readings match the measured readings?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor resistances to specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor within specification?
STEP 6. | Check the quality of the natural gas supply to the generator set. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply quality within specification?
STEP 7. | Inspect cylinder number 13 cylinder head. |
 | STEP 7A. Check the cylinder number 13 spark plug. | Cylinder number 13 spark plug contaminated or damaged?
 | STEP 7B. Check the cylinder number 13 spark plug gap. | Cylinder number 13 spark plug gap excessive?
 | STEP 7C. Inspect the cylinder number 13 cylinder head. | Cylinder number 13 cylinder head gasket leaking or loose components?
 | STEP 7D. Check that the cylinder number 13 valve lash setting is correct. | Cylinder number 13 valve lash setting correct?
 | STEP 7E. Check the cylinder number 13 valve train. | Cylinder number 13 valve train wear?
STEP 8. | Inspect cylinder number 13 power cylinder. |
 | STEP 8A. Inspect the oil filters for debris. | Debris present in oil filters?
 | STEP 8B. Inspect the cylinder number 13 internal power cylinder. | Cylinder number 13 power cylinder damaged?
 | STEP 8C. Inspect the cylinder number 13 connecting rod bearings. | Cylinder number 13 connecting rod bearings worn or damaged?
 | STEP 8D. Inspect the cylinder number 13 piston cooling nozzle. | Cylinder number 13 piston cooling nozzle bent or broken?
 | STEP 8E. Check cylinder number 13 and the adjacent cylinder main bearings. | Cylinder number 13 or immediatey adjacent main bearings worn or damaged?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 1285 inactive?
 | STEP 9B. Clear the fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 146, 151, 155, 488, 1285, 1295, 1579, 1581, 1582, 2281, 2282, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2531, and 2532 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Use symptom tree t048 (Engine Noise Excessive - Combustion Knocks) in Section TS in this manual.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electronic service tool.
  • Connect an exhaust gas analyzer.
  • Operate the engine at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Check exhaust emissions.

  • Use an exhaust gas analyzer. Insert the sample probe into the exhaust gas manifold test port. Check the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-020 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specification?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool and, referencing the exhaust gas analyzer, adjust the open and closed loop fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.

  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 9A

Guided Step 3 - Check the kilowatt load reference signal calibration.

Guided Step 3A - Check the kilowatt load transducer-sensed kilowatt calibration againist the generator set controller kilowatt calibration.

Conditions

NOTE: If the generator set is not fitted with a kilowatt load transducer then proceed to Guided Step 3B.

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.
  • Connect INSITE™ electronic service tool.

Action

Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller displayed kilowatts calibration.

  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool and calibrate the kilowatt load sensor milliampere/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the calibration of the generator set controller.

Conditions

NOTE: This guided step should only be followed if the generator set not fitted with a kilowatt load transducer.

  • Connect all components.
  • Connect a power analyzer or digital multimeter.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.

Action

Connect a power analyzer or digital multimeter to the alternator main output terminals.

  • Check that the generator set controller readings for output voltage (L1- L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller output voltage and ampere readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter to calibrate the generator set controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold temperature.

  • Use the generator set human machine interface (HMI), check the intake manifold temperature.
  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold temperature within specification?

YES NO
No Repair

Repair

Check the following:

  • Check the temperature of the high temperature (HT) coolant outlet from the engine.
  • Check the temperature of the low temperature (LT) coolant outlet from the engine.
  • Use the following procedure found in QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-018 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the intake manifold temperature sensor resistances.

NOTE: The intake manifold temperature sensor may have malfunctioned in-range. The related fault codes will not be activated.

  • Reference Fault Code 153 or Fault Code 154 in Section TF.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
  • Use the following wiring diagram for specification information 4022031.

Intake manifold temperature sensor resistances to specification?

YES NO
No Repair

Repair

Replace the intake manifold temperature sensor.

  • Refer to Procedure 019-059 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold pressure.

  • Use the generator set human machine interface (HMI) to check the intake manifold temperature.
  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold pressure within specification?
YES NO
No Repair

Repair

If fitted, check the operation of the compressor bypass valve (single turbocharger engines only).

  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the intake manifold pressure sensor.

NOTE: The intake manifold temperature sensor may have malfunctioned in-range and the related fault codes will not be activated.

  • Reference Fault Code 354 or Fault Code 355 in Section TF.
  • Use the following procedure for multimeter usage. Refer to Procedure 019-369 in Section 19.

Intake manifold pressure sensor within specification?

YES NO
No Repair

Repair

Replace the intake manifold pressure sensor.

  • Refer to Procedure 019-061 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the generator set.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the quality of the natural gas supply.

  • Check the quality of the natural gas supplied to the generator set meets or exceeds minimum requirements for generator set (methane number and fuel contaminants limits).
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Natural gas supply quality within specification?

YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspect cylinder number 13 cylinder head.

Guided Step 7A - Check the cylinder number 13 spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect cylinder number 13 spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug J connector damaged
  • Electrode has signs of oil contamination
  • Spark plug porcelain damaged.
  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder number 13 spark plug contaminated or damaged?

YES NO

Repair

Repair as necessary:

  • Tighten the spark plug.
  • Replace the spark plug
  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the cylinder number 13 spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Remove the spark plug and measure the spark plug electrode gap.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
  • Contact a Cummins® Authorized Repair Location.

Cylinder number 13 spark plug gap excessive?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7C

Guided Step 7C - Inspect the cylinder number 13 cylinder head.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the cylinder number 13 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Loose engine components on or immediately around cylinder number 13 cylinder head.
  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.

Cylinder number 13 cylinder head gasket leaking or loose components?

YES NO

Repair

Replace the cylinder head gasket.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 13.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 7.
  • Tighten any loose components on or immediately around cylinder number 13 cylinder head. Reference the appropriate procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396.
No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check the cylinder number 13 valve lash setting is correct.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder number 13 valve lash is correct.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder number 13 valve lash setting correct?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7E

Guided Step 7E - Check the cylinder number 13 valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the cylinder number 13 valve train for the following:

  • Intake or exhaust valve wear/recession or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Camshaft follower wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder 13 camshaft lobewear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Cylinder number 13 valve train wear?
YES NO

Repair

Repair as necessary

  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft follower assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the camshaft. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.

Repair

Adjust the valve lash.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 9A

Go to 8A

Guided Step 8 - Inspect cylinder number 13 power cylinder.

Guided Step 8A - Inspect the oil filters for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubrication oil filters. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filters and inspect for debris in the filter media.
  • Contact a Cummins® Authorized Repair Location.

Debris present in the oil filters?
YES | NO
No Repair | No Repair

Go to 8B

Go to 8D

Guided Step 8B - Check the cylinder number 13 internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the internal power cylinder for the following:

NOTE: If available these inspections can be performed with a borescope without removing the component.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage.

Cylinder number 1 power cylinder damaged?
YES NO

Repair

Replace the piston rings.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.

Replace the liner.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-045 in Section 1.

Replace the cylinder head.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the cylinder number 13 connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP.

Action

Inspect cylinder number 13 connecting rod bearings for excessive wear or other damage.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder number 1 connecting rod bearings worn or damaged?
YES NO

Repair

Replace the connecting rod bearings.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.
No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the cylinder number 13 piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the cylinder number 13 piston cooling nozzle.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder number 13 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.
No Repair

Go to 9A

Go to 8E

Guided Step 8E - Check cylinder number 13 and the adjacent cylinder main bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect cylinder 13 and adjacent main bearings.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

Cylinder number 13 or immediatey adjacent main bearings worn or damaged?
YES NO

Repair

Replace the main bearings .

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.
No Repair

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electronic service tool.
  • Operate the engine for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 1285 is inactive.

Fault Code 1285 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair location if all steps have been completed and checked again.

Go to 9B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps.

Last Modified: 17-Dec-2010


FAULT CODE 1286 - Engine Cylinder Number 13 Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1213, 1274, 1281, 1286, 1291, 1296, 1583 and 2282 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specifications?
STEP 3. | Check the kilowatt load reference calibration. |
 | STEP 3A. Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller kilowatt calibration. | Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
 | STEP 3B. Check the generator set controller calibration. | Generator set controller output voltage and ampere output calibration correct?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor resistance within specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor within specification?
STEP 6. | Check the quality of the natural gas supply to the generator set. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply quality within specification?
STEP 7. | Inspect cylinder number 13 cylinder head. |
 | STEP 7A. Check the cylinder number 13 spark plug. | Cylinder number 13 spark plug contaminated or damaged?
 | STEP 7B. Check the cylinder number 13 spark plug gap. | Cylinder number 13 spark plug gap excessive?
 | STEP 7C. Check the cylinder number 13 cylinder head. | Cylinder number 13 cylinder head leaking gaskets or loose components?
 | STEP 7D. Check the cylinder number 13 valve lash. | Cylinder number 13 valve lash setting correct?
 | STEP 7E. Check the cylinder number 13 valve train. | Cylinder number 13 valve train wear?
STEP 8. | Inspect the cylinder number 13 power cylinder. |
 | STEP 8A. Inspect the oil filter for debris. | Debris present in the oils filters?
 | STEP 8B. Check the cylinder number 13 internal power cylinder. | Cylinder number 13 power cylinder damaged?
 | STEP 8C. Inspect the cylinder number 13 connecting rod bearings. | Cylinder number 13 connecting rod bearings damaged?
 | STEP 8D. Inspect the cylinder number 13 piston cooling nozzle. | Cylinder number 13 piston cooling nozzle bent or broken?
 | STEP 8E. Check cylinder number 13 and adjacent cylinder main bearings. | Main bearings damaged?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 1286 inactive?
 | STEP 9B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1213, 1274, 1281, 1286, 1291, 1296, 1583 and 2282 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Reference t048 (Engine Noise Excessive - Combustion Knocks) in Section TS.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Connect the INSITE™ electric service tool.
  • Connect an exhaust gas analyzer.
  • Turn keyswitch ON
  • Place RUN/STOP/AUTO switch in RUN mode.
  • Operate engine at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Check exhaust emissions.

  • Use an exhaust gas analyzer. Insert the sample probe into the exhaust gas manifold test port, check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure for exhaust emission specifications. QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-020 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specifications?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool and referencing to the exhaust gas analyzer, adjust the open and closed loop fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine. Use the following procedure for exhaust emission specifications. QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-020 in Section V.

  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 9A

Guided Step 3 - Check the kilowatt load reference calibration.

Guided Step 3A - Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller kilowatt calibration.

Conditions

NOTE: If the Generator Set is not fitted with a kilowatt load transducer, proceed to Guided Step 3B.

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode with load available.

Action

Check the kilowatt load transducer-sensed kilowatts calibration against the generator set controller displayed kilowatts calibration.

  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool to calibrate the kilowatt load sensor milliampere/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the calibration of the Generator set controller.

Conditions

NOTE: This guided step should only be followed for generator set is not fitted with a kilowatt load transducer.

  • Connect all components.
  • Connect a power analyzer or digital multimeter
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode with load available.

Action

Connect a power analyzer or digital multimeter to the alternator main output terminals.

  • Check that the generator set controller readings for output voltage (L1- L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller output voltage and ampere output calibration correct?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter, to calibrate the generator set controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode.
  • Operate engine at maximum possible load with no knock present.

Action

Check the intake manifold temperature.

  • Use the generator set Human Machine Interface (HMI) to check the intake manifold temperature. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold temperature within specification?
YES NO
No Repair

Repair

Check the following:

  • Check the temperature of the high temperature (HT) coolant outlet from the engine.
  • Check the temperature of the low temperature (LT) coolant outlet from the engine.
  • Use the following procedure found in QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-018 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check the intake manifold temperature sensor resistances.

NOTE: The intake manifold temperature sensor may have malfunctioned in range. The related fault codes will not be activated.

  • Reference Fault Code 153 in Section TF.
  • Reference Fault Code 154 in Section TF.
  • Use the following procedure for connector pin information. Refer to Procedure 019-360 in Section 19.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Intake manifold temperature sensor resistance within specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor.

  • Refer to Procedure 019-059 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold pressure.

  • Use the generator set HMI to check the intake manifold pressure. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold pressure within specification?
YES NO
No Repair

Repair

Check the operation of the compressor bypass valve (single turbocharger engines only).

  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check the intake manifold pressure sensor.

NOTE: The intake manifold pressure sensor may have malfunctioned in range and the related fault codes will not be activated.

  • Reference Fault Code 354 or Fault Code 355 in Section TF.
  • Reer to the circuit diagram or wiring diagram for connector pin identification.
  • Use the following procedure for information on multimeter usage. Refer to Procedure 019-359 in Section 19.

Intake manifold pressure sensor within specification?
YES NO
No Repair

Repair

Replace the intake manifold pressure sensor.

  • Refer to Procedure 019-061 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the generator set.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check the quality of the natural gas supply.

  • Check the quality of the natural gas supplied to the generator set meets or exceeds minimum requirement for generator set (methane number and fuel contaminants limits).
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspect cylinder number 13 cylinder head.

Guided Step 7A - Check the cylinder number 13 spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug J connector damaged.
  • Inspect the electrode for signs of oil contamination.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder number 13 spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug.
  • Replace the spark plug.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the cylinder number 13 spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Remove the spark plug and measure the spark plug electrode gap.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
  • Contact a local Cummins® Authorized Repair Location.

Cylinder number 13 spark plug gap excessive?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7C

Guided Step 7C - Check the cylinder number 13 cylinder head.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Inspect cylinder 13 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder number 13 cylinder head.

Cylinder number 13 cylinder head leaking gaskets or loose components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose components on or immediately around cylinder number 13 cylinder head. Reference the appropriate procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396.
No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check the cylinder number 13 valve lash is correct.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check cylinder 13 valve lash is correct.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder number 13 valve lash setting correct?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7E

Guided Step 7E - Check the cylinder number 13 valve train.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Inspect the cylinder 13 valve train for the following:

  • Inlet or exhaust valve wear/recession or damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Camshaft follower wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder number 13 camshaft lobe wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Cylinder number 13 valve train wear?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the camshaft follower assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

Adjust the valve lash.

Set the valve lash setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 9A

Go to 8A

Guided Step 8 - Inspect the cylinder number 13 power cylinder.

Guided Step 8A - Inspect the oil filter for debris.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter and inspect for debris in the filter medium.
  • Contact a Cummins® Authorized Repair Location.

Debris present in the oil filters?
YES | NO
No Repair | No Repair

Go to 8B

Go to 8D

Guided Step 8B - Check the cylinder number 13 internal power cylinder.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Inspect the internal power cylinder.

NOTE: If available, use a borescope to perform the inspections.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Check for cylinder head flame face damage.

Cylinder number 13 power cylinder damaged?
YES NO

Repair

Replace the piston rings. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.

Replace the cylinder liner. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-045 in Section 1.

Replace the cylinder head.Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the cylinder number 13 connecting rod bearings.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP.

Action

Inspect the connecting rod bearings.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396 001-005 in Section 1.

Cylinder number 13 connecting rod bearings damaged?
YES NO

Repair

Replace the connecting rod bearings:

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.
No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the cylinder number 13 piston cooling nozzle.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Inspect the piston cooling nozzle.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder number 13 piston cooling nozzle bent or broken?
YES NO

Repair

  • Replace the piston cooling nozzle. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.
No Repair

Go to 9A

Go to 8E

Guided Step 8E - Inspect cylinder number 13 and adjacent cylinder main bearings.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Inspect cylinder 13 and adjacent cylinder main bearings.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

Main bearings damaged?
YES NO

Repair

Replace the main bearings. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

No Repair

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode.
  • Operate the engine for greater than 1 minute.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to verify Fault Code 1286 is inactive.

Fault Code 1286 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 9B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 01-Aug-2010


FAULT CODE 1287 - Engine Cylinder Number 13 Knock - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 male Deutsch™ test lead, and Part Number 3824812 female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1287 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check the connection from the knock sensor wiring harness to the knock sensor. | Knock sensor wiring harness connected?
 | STEP 2B. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 3. | Check the knock sensor. |
 | STEP 3A. Check the knock sensor is tightened correctly. | Knock sensor tightened to specification?
 | STEP 3B. Test the knock sensor. | Fault Code 1292 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1287 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1287 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the connection from the knock sensor wiring harness to the knock sensor.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check that the knock sensor harness is connected to the knock sensor:

  • Check that knock sensor wiring harness is connected to the knock sensor. Refer to Procedure 019-346 in Section 19.

Knock sensor wiring harness connected?
YES NO
No Repair

Repair

Connect the knock sensor harness to the knock sensor.

  • Refer to Procedure 019-346 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM558 B connector.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins. Repair or replace the engine harness or the harness connector.

Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.

Install the appropriate connector seal if it is damaged or missing.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM558 B.

Action

Check for an open circuit.

  • Measure the resistance from the knock cylinder number 13 SIGNAL pin in the knock sensor connector to the knock cylinder number 13 SIGNAL pin in the CM558 B.
  • Measure the resistance from the knock cylinder number 13 RETURN pin in the knock sensor connector to the knock cylinder number 13 RETURN pin in the CM558 B.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Repair the wiring harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check for a short circuit from pin to pin:

  • Measure the resistance from knock cylinder number 13 signal pin in the knock sensor harness connector to all other pins in the connector.
  • Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

Repair the wiring harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the knock sensor.

Guided Step 3A - Check the knock sensor is tightened correctly.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check the knock sensor is tightened correctly.

  • Check that the knock sensor is tightened to the correct torque value. Refer to Procedure 019-346 in Section 19.

Knock sensor tightened to specification?
YES NO
No Repair

Repair

Tighten the knock sensor. Refer to Procedure 019-346 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Test the knock sensor.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode.
  • Operate the engine for greater than 1 minute.

Action

Test the knock sensor.

  • Move the knock sensor from cylinder head number 13 to cylinder head number 14. Install the knock sensor from cylinder head number 14 to cylinder head number 13. Refer to Procedure 019-346 in Section 19.
  • Place the RUN/STOP/AUTO switch in the RUN mode and operate the engine for greater than 1 minute. Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 101-014 in Section 1.

Fault Code 1292 active?
YES NO

Repair

Replace the knock sensor. Refer to Procedure 019-346 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode.
  • Operate the engine greater than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 1287 is inactive.

Fault Code 1287 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 01-Aug-2010


FAULT CODE 1291 - Engine Cylinder Number 14 Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1213, 1274, 1281, 1286, 1291, 1296, 1583, and 2282 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specifications?
STEP 3. | Check the kilowatt load reference calibration. |
 | STEP 3A. Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller kilowatt calibration. | Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
 | STEP 3B. Check the generator set controller calibration. | Generator set controller output voltage and ampere readings match the measured readings?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor resistances within specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor within specification?
STEP 6. | Check the quality of the natural gas supply to the generator set. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply quality within specification?
STEP 7. | Inspect cylinder number 14 cylinder head. |
 | STEP 7A. Check the cylinder number 14 spark plug. | Cylinder number 14 spark plug contaminated or damaged?
 | STEP 7B. Check the cylinder number 14 spark plug gap. | Cylinder number 14 spark plug gap excessive?
 | STEP 7C. Check the cylinder number 14 cylinder head. | Cylinder number 14 cylinder head leaking gaskets or loose components?
 | STEP 7D. Check the cylinder number 14 valve lash is correct. | Cylinder number 14 valve lash setting correct?
 | STEP 7E. Check the cylinder number 14 valve train. | Cylinder number 14 valve train wear?
STEP 8. | Inspect the cylinder number 14 power cylinder. |
 | STEP 8A. Inspect the lubricating oil filters and inspect for debris. | Debris present in the oil filters?
 | STEP 8B. Check the cylinder number 14 internal power cylinder. | Cylinder number 14 power cylinder damaged?
 | STEP 8C. Inspect the cylinder number 14 connecting rod bearings. | Cylinder number 14 connecting rod bearings damaged?
 | STEP 8D. Inspect the cylinder number 14 piston cooling nozzle. | Cylinder number 14 piston cooling nozzle bent or broken?
 | STEP 8E. Check cylinder number 14 and adjacent cylinder main bearings. | Cylinder number 14 or adjacent main bearings worn or damaged?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 1291 active?
 | STEP 9B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1213, 1274, 1281, 1286, 1291, 1296, 1583, and 2282 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Reference t048 (Engine Noise Excessive - Combustion Knocks) in Section TS.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Connect INSITE™ electric service tool.
  • Connect an exhaust gas analyzer.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode.
  • Operate the engine at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Check exhaust emissions.

  • Use an exhaust gas analyzer. Insert the sample probe into the exhaust gas manifold test port, check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-020 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specifications?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool and referencing to the exhaust gas analyzer, adjust the open and closed loop fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.

  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 9A

Guided Step 3 - Check the kilowatt load reference signal calibration.

Guided Step 3A - Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller kilowatt calibration.

Conditions

NOTE: If the generator set is not fitted with a kilowatt load transducer, proceed to Guided Step 3B.

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode with load available.

Action

Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller displayed kilowatt calibration.

  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool and calibrate the kilowatt load sensor milliampere/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the generator set controller calibration.

Conditions

NOTE: This guided step should only be followed if the generator set is not fitted with a kilowatt load transducer.

  • Connect all components.
  • Connect a power analyzer or digital multimeter
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode with load available.

Action

Connect a power analyzer or digital multimeter to the alternator main output terminals.

  • Check that the generator set controller readings for output voltage (L1- L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller output voltage and ampere readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter to calibrate the generator set controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold temperature.

  • Use the generator set human machine interface (HMI) to check the intake manifold temperature. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold temperature within specification?
YES NO
No Repair

Repair

Check the following:

  • Check the temperature of the high temperature (HT) coolant outlet from the engine.
  • Check the temperature of the low temperature (LT) coolant outlet from the engine.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 018-018 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check the intake manifold temperature sensor resistances.

  • NOTE: The intake manifold temperature sensor may have malfunctioned in-range and the related fault codes will not be activated. Reference Fault Code 153 (Intake Manifold Temperature Sensor Shorted High) or fc154 (Intake Manifold Temperature Sensor Shorted Low) in Section TF.
  • Refer to circuit diagram or wiring diagram for connector pin identification. Refer to Procedure 019-360 in Section 19.

Intake manifold temperature sensor supply voltages and reference resistances within specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor.

  • Refer to Procedure 019-059 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold pressure.

  • Use the generator set human machine interface (HMI) to check the intake manifold pressure. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold pressure within specification?
YES NO
No Repair

Repair

If fitted, check the operation of the compressor bypass valve (single turbochargers engines only).

  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check the intake manifold pressure sensor.

NOTE: The intake manifold pressure sensor may have malfunctioned in-range and the related fault codes will not be activated.

  • Reference Fault Code 354 (IntakeManifold Pressure SensorShorted High) or Fault Code 355 (IntakeManifold Pressure SensorShorted Low) in Section TF.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Refer to Procedure 019-359 in Section 19.

Intake manifold pressure sensor within specification?
YES NO
No Repair

Repair

Replace the intake manifold pressure sensor.

  • Refer to Procedure 019-061 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the generator set.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check the quality of the natural gas supply.

  • Check that the quality of the natural gas supplied to the generator set meets or exceeds minimum requirement for generator set (methane number and fuel contaminants limits).
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspect cylinder number 14 cylinder head.

Guided Step 7A - Check the cylinder number 14 spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug J connector damaged.
  • Inspect the electrode for signs of oil contamination.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder number 14 spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten or replace the spark plug.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the cylinder number 14 spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Remove the spark plug and measure the spark plug electrode gap.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
  • Contact a Cummins® Authorized Repair Location.

Cylinder number 14 spark plug gap excessive?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7C

Guided Step 7C - Check the cylinder number 14 cylinder head.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Inspect cylinder 14 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder number 14 cylinder head.

Cylinder number 14 cylinder head leaking gaskets or loose components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose components on or immediately around cylinder number 14 cylinder head. Reference the appropriate procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396.
No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check the cylinder number 14 valve lash is correct.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check cylinder 14 valve lash is correct.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder number 14 valve lash setting correct?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7E

Guided Step 7E - Check the cylinder number 14 valve train.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Inspect the cylinder 14 valve train for the following:

  • Inlet or exhaust valve wear/recession or damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Camshaft follower wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder number 14 camshaft lobe wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Cylinder number 14 valve train wear?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the camshaft follower assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

Adjust the valve lash. Reset the valve lash setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 9A

Go to 8A

Guided Step 8 - Inspect the cylinder number 14 power cylinder.

Guided Step 8A - Inspect the oil filters for debris.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter and inspect for debris in the filter medium.
  • Contact a Cummins® Authorized Repair Location.

Debris present in the oil filters?
YES | NO
No Repair | No Repair

Go to 8B

Go to 8D

Guided Step 8B - Check the cylinder number 14 internal power cylinder.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check the internal power cylinder.

NOTE: If available, use a borescope to perform the inspections.

Use the following procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage.

Cylinder number 14 power cylinder damaged?
YES NO

Repair

Replace the piston rings. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.

Replace the cylinder liner. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-045 in Section 1.

Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the cylinder number 14 connecting rod bearings.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP.

Action

Inspect the connecting rod bearings for excessive wear or other damage.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396 Refer to Procedure 001-005 in Section 1.

Cylinder number 14 connecting rod bearings damaged?
YES NO

Repair

Replace the connecting rod bearings:

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.
No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the cylinder number 14 piston cooling nozzle.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Inspect the piston cooling nozzle.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder number 14 piston cooling nozzle bent or broken?
YES NO

Repair

  • Replace the piston cooling nozzle. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.
No Repair

Go to 9A

Go to 8E

Guided Step 8E - Inspect cylinder number 14 and adjacent cylinder main bearings.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Inspect cylinder 14 and adjacent cylinder main bearings.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1. This procedure is found in the QSK60G CM700Troubleshooting and RepairManual 4021396.

Cylinder number 14 or immediately adjacent main bearings worn or damaged?
YES NO

Repair

Replace the main bearings. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

No Repair

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode.
  • Operate the engine for greater than 1 minute.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to verify Fault Code 1291 is inactive.

Fault Code 1291 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 9B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 01-Aug-2010


FAULT CODE 1292 - Engine Cylinder Number 14 Knock - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 male Deutsch™ test lead, and Part Number 3824812 female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1292 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check the connection from the knock sensor wiring harness to the knock sensor. | Knock sensor harness connected?
 | STEP 2B. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 3. | Check the knock sensor. |
 | STEP 3A. Check that the knock sensor is tightened correctly. | Knock sensor tightened to specification?
 | STEP 3B. Test the knock sensor. | Fault Code 1287 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1292 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1292 active?
YES NO

Repair

Follow the troubleshooting steps or contact a Cummins® Authorized Repair Location

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the connection from the knock sensor wiring harness to the knock sensor

Conditions

  • Connect all components
  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check that the knock sensor harness is connected to the knock sensor:

  • Check that knock sensor wiring harness is connected to the knock sensor. Refer to Procedure 019-346 in Section 19.

Knock sensor harness connected?
YES NO
No Repair

Repair

Connect the knock sensor harness to the knock sensor.

  • Refer to Procedure 019-346 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM558 B connector.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins. Repair or replace the engine harness or the harness connector.

Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.

Install the appropriate connector seal if it is damaged or missing.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM558 B.

Action

Check for an open circuit.

  • Measure the resistance from the knock cylinder number 14 SIGNAL pin in the knock sensor connector to the knock cylinder number 14 SIGNAL pin in the CM558 B.
  • Measure the resistance from the knock cylinder number 14 RETURN pin in the knock sensor connector to the knock cylinder number 14 RETURN pin in the CM558 B.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

Repair the wiring harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check for a short circuit from pin to pin:

  • Measure the resistance from knock cylinder number 14 SIGNAL pin in the knock sensor harness connector to all other pins in the connector.
  • Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

Repair the wiring harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the knock sensor.

Guided Step 3A - Check that the knock sensor is tightened correctly.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check that the knock sensor is tightened correctly.

  • Check that the knock sensor is tightened to the correct torque value. Refer to Procedure 019-346 in Section 19.

Knock sensor tightened to specification?
YES NO
No Repair

Repair

Tighten the knock sensor. Refer to Procedure 019-346 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Test the knock sensor.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode. (Operate the engine only after relocating the cylinder 14 knock sensor to cylinder 13)
  • Operate engine for greater than 1 minute.

Action

Test the knock sensor.

  • Move the knock sensor from cylinder head number 14 to cylinder head number 13. Install the knock sensor from cylinder head number 13 to cylinder head number 14. Refer to Procedure 019-346 in Section 19.
  • Place the RUN/STOP/AUTO switch in the RUN mode and operate the engine for greater than 1 minute. Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 101-014 in Section 1.

Fault Code 1287 active?
YES NO

Repair

Replace the knock sensor. Refer to Procedure 019-346 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode.
  • Operate the engine greater than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 1292 is inactive.

Fault Code 1292 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 01-Aug-2010


FAULT CODE 1295 - Engine Cylinder Number 15 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 146, 151, 155, 488, 1285, 1295, 1579, 1581, 1582, 2281, 2282, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2531, and 2532 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specification?
STEP 3. | Check the kilowatt load reference signal calibration. |
 | STEP 3A. Check the kilowatt load transducer reference signal - where fitted. | Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
 | STEP 3B. Check the calibration of the generator set controller. | Generator set controller output voltage and ampere readings match measured readings?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor resistances within specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor within specification?
STEP 6. | Check the quality of the natural gas supply to the generator set. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply quality within specification?
STEP 7. | Inspect cylinder number 15 cylinder head. |
 | STEP 7A. Check the cylinder number 15 spark plug. | Cylinder number 15 spark plug contaminated or damaged?
 | STEP 7B. Check the cylinder number 15 spark plug gap. | Cylinder number 15 spark plug gap excessive?
 | STEP 7C. Check the cylinder number 15 cylinder head. | Cylinder number 15 cylinder head gasket leaking or loose components?
 | STEP 7D. Check the cylinder number 15 valve lash setting is correct. | Cylinder number 15 valve lash setting correct?
 | STEP 7E. Check the cylinder number 15 valve train. | Cylinder number 15 valve train wear?
STEP 8. | Inspect the cylinder number 15 power cylinder. |
 | STEP 8A. Inspect the oil filters for debris. | Debris present in the oil filters?
 | STEP 8B. Check the cylinder number 15 internal power cylinder. | Cylinder number 15 power cylinder damaged?
 | STEP 8C. Inspect the cylinder number 15 connecting rod bearings. | Cylinder number 15 connecting rod bearings worn or damaged?
 | STEP 8D. Inspect the cylinder number 15 piston cooling nozzle. | Cylinder number 15 piston cooling nozzle bent or broken?
 | STEP 8E. Check cylinder number 15 and adjacent cylinder main bearings. | Cylinder number 15 or immediately adjacent main bearings worn or damaged?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 1295 inactive?
 | STEP 9B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 146, 151, 155, 488, 1285, 1295, 1579, 1581, 1582, 2281, 2282, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2531, and 2532 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Use symptom tree t048 (Engine Noise Excessive - Combustion Knocks) in Section TS in this manual.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect the INSITE™ electric service tool.
  • Connect an exhaust gas analyzer.
  • Operate the engine at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Check exhaust emissions.

  • Use an exhaust gas analyzer, with the sample probe inserted into the exhaust gas manifold test port, check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specifications?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool and referencing to the exhaust gas analyzer, adjust the open and closed loop fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.

  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 9A

Guided Step 3 - Check the kilowatt load reference signal calibration.

Guided Step 3A - Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller kilowatt calibration.

Conditions

NOTE: If the generator set is not fitted with a kilowatt load transducer, proceed to Guided Step 3B.

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.
  • Connect INSITE™ electronic service tool.

Action

Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller displayed kilowatt calibration.

  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool to calibrate the kilowatt load sensor milliampere/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the calibration of the generator set controller.

Conditions

NOTE: This guided step should only be followed if the generator set is not fitted with a kilowatt load transducer.

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.
  • Connect a power analyzer or digital multimeter

Action

Connect a power analyzer or digital multimeter to the alternator main output terminals.

  • Check that the generator set controller readings for output voltage (L1- L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller output voltage and ampere readings match measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter. Calibrate the generator set controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold temperature.

  • Use the generator set human machine interface (HMI) to check the intake manifold temperature. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold temperature within specification?
YES NO
No Repair

Repair

Check the following:

  • Check the temperature of the high temperature (HT) coolant outlet from the engine.
  • Check the temperature of the low temperature (LT) coolant outlet from the engine.
  • Use the following procedure found in QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-018 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the intake manifold temperature sensor resistances.

NOTE: The intake manifold temperature sensor may have malfunctioned in-range and the related fault codes will not be activated. Reference Fault Code 153 and Fault Code 154 in Section TF.

  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use the following procedure for connector pin information. Refer to Procedure 019-360 in Section 19.

Intake manifold temperature sensor resistances within specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor.

  • Refer to Procedure 019-059 in Section 19.

Go to 4A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold pressure.

  • Use the generator set human machine interface (HMI) to check the intake manifold pressure. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold pressure within specification?
YES NO
No Repair

Repair

If fitted, check the operation of the compressor bypass valve (single turbocharger engines only).

  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the intake manifold pressure sensor.

NOTE: The intake manifold pressure sensor may have malfunctioned in-range and the related fault codes will not be activated.

  • Reference Fault Code 354 or Fault Code 355 in Section TF in this manual.
  • Use the following procedure for multimeter usage. Refer to Procedure 019-359 in Section 19.

Intake manifold pressure sensor within specification?
YES NO
No Repair

Repair

Replace the intake manifold pressure sensor.

  • Refer to Procedure 019-061 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the generator set.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the quality of the natural gas supply.

  • Check the quality of the natural gas supplied to the generator set meets or exceeds minimum requirements for generator set (methane number and fuel contaminants limits).
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspect cylinder number 15 cylinder head.

Guided Step 7A - Check cylinder number 15 the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug J connector damaged.
  • Inspect the electrode for signs of oil contamination.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder number 15 spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug.
  • Replace the spark plug.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the cylinder number 15 spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Remove the spark plug and measure the spark plug electrode gap.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
  • Contact a Cummins® Authorized Repair Location.

Cylinder number 15 spark plug gap excessive?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7C

Guided Step 7C - Check the cylinder number 15 cylinder head.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect cylinder number 15 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • The following procedure is found in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder number 15 cylinder head.

Cylinder number 15 cylinder head gasket leaking or loose components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose components on or immediately around cylinder number 15 cylinder head. Reference the appropriate procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396.
No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check the cylinder number 15 valve lash setting is correct.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder 15 valve lash setting is correct.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder number 15 valve lash setting correct?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7E

Guided Step 7E - Check the cylinder number 15 valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the cylinder number 15 valve train for the following:

  • Inlet or exhaust valve wear/recession or damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Camshaft follower wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder number 15 camshaft lobe wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Cylinder number 15 valve train wear?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft follower assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the camshaft. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

Adjust the valve lash. Reset the valve lash setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 9A

Go to 8A

Guided Step 8 - Inspect the cylinder number 15 power cylinder.

Guided Step 8A - Inspect the oil filters for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter and inspect for debris in the filter medium.
  • Contact a Cummins® Authorized Repair Location.

Debris present in the oil filters?
YES | NO
No Repair | No Repair

Go to 8B

Go to 8D

Guided Step 8B - Check the cylinder number 15 internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the internal power cylinder for the following:

NOTE: If available, use a borescope to perform the inspections.

  • Piston ring scuffing or breakage. Use the following procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder head flame face damage.

Cylinder number 15 power cylinder damaged?
YES NO

Repair

Replace the piston rings. Use the following procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.

Replace the cylinder liner. Refer to Procedure 001-045 in Section 1.

Replace the cylinder head. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the cylinder number 15 connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the connecting rod bearings for wear or damage.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396 Refer to Procedure 001-005 in Section 1.
  • Contact a Cummins® Authorized Repair Location

Cylinder number 15 connecting rod bearings worn or damaged?
YES NO

Repair

Replace the connecting rod bearings:

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.
No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the cylinder number 15 piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the piston cooling nozzle.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder number 15 piston cooling nozzle bent or broken?
YES NO

Repair

  • Replace the piston cooling nozzle. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.
No Repair

Go to 9A

Go to 8E

Guided Step 8E - Inspect cylinder number 15 and adjacent cylinder main bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect cylinder number 15 and adjacent cylinder main bearings.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

Cylinder number 15 or immediately adjacent main bearings worn or damaged?
YES NO

Repair

Replace the main bearings as required (cylinder 15 or immediately adjacent cylinders). Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

No Repair

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electronic service tool.
  • Operate the engine for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 1295 is inactive.

Fault Code 1295 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 9B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 17-Dec-2010


FAULT CODE 1296 - Engine Cylinder Number 15 Knock - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1214, 1274, 1281, 1286, 1291, 1296, 1583, and 2282 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specifications?
STEP 3. | Check the kilowatt load reference signal calibration. |
 | STEP 3A. Check the kilowatt load transducer-sensed kilowatts calibration against the generator set controller kilowatts calibration. | Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
 | STEP 3B. Check the calibration of the generator set controller calibration. | Generator set controller output voltage and ampere readings match the measured readings?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor resistances within specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor within specification?
STEP 6. | Check the quality of the natural gas supply to the generator set. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply quality within specification?
STEP 7. | Inspect cylinder number 15 cylinder head. |
 | STEP 7A. Check the cylinder number 15 spark plug. | Cylinder number 15 spark plug contaminated or damaged?
 | STEP 7B. Check the cylinder number 15 spark plug gap. | Cylinder number 15 spark plug gap excessive?
 | STEP 7C. Check the cylinder number 15 cylinder head. | Cylinder number 15 cylinder head leaking gaskets or loose components?
 | STEP 7D. Check the valve lash is correct. | Cylinder number 15 valve lash setting correct?
 | STEP 7E. Check the cylinder number 15 valve train. | Cylinder number 15 valve train wear?
STEP 8. | Inspect the cylinder number 15 power cylinder. |
 | STEP 8A. Cut open the oil filters and inspect for debris. | Debris present in the oils filters?
 | STEP 8B. Check the internal power cylinder. | Cylinder number 15 power cylinder damaged?
 | STEP 8C. Inspect the connecting rod bearings. | Cylinder number 15 connecting rod bearings damaged?
 | STEP 8D. Inspect the piston cooling nozzle. | Cylinder number 15 piston cooling nozzle bent or broken?
 | STEP 8E. Check cylinder number 15 and adjacent cylinder main bearings. | Cylinder number 15 or immediately adjacent main bearings worn or damaged?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 1296 active?
 | STEP 9B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1214, 1274, 1281, 1286, 1291, 1296, 1583, and 2282 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Reference t048 (Engine Noise Excessive - Combustion Knocks) in Section TS.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Connect INSITE™ electric service tool.
  • Connect an exhaust gas analyzer.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode. Operate the engine at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Check exhaust emissions.

  • Use an exhaust gas analyzer. Insert the sample probe into the exhaust gas manifold test port, check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-020 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specifications?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool and referencing the exhaust gas analyzer, adjust the open and closed loop fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.

  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 3A

Guided Step 3 - Check the kilowatt load reference calibration.

Guided Step 3A - Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller kilowatt calibration.

Conditions

NOTE: If the generator set is not fitted with a kilowatt load transducer, proceed to Guided Step 3B.

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode with load available.

Action

Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller displayed kilowatt calibration.

  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
YES NO
No Repair

Repair

Connect INSITE™ electronic service tool. Calibrate the kilowatt load sensor milliampere/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the calibration of the generator set controller calibration.

Conditions

NOTE: This guided step should only be followed if the generator set is not fitted with a kilowatt load transducer.

  • Connect all components.
  • Connect a power analyzer or digital multimeter.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode with load available.

Action

Connect a power analyzer or digital multimeter to the alternator main output terminals.

  • Check that the generator set controller readings for output voltage (L1- L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller output voltage and ampere output calibration correct?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter. Calibrate the generator set controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode. Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold temperature.

  • Use the generator set human machine interface (HMI) to check the intake manifold temperature. This procedure is found in the following QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold temperature within specification?
YES NO
No Repair

Repair

Check the following:

  • Check the temperature of the high temperature (HT) coolant outlet from the engine.
  • Check the temperature of the low temperature (LT) coolant outlet from the engine.
  • Use the following procedure found in QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check the intake manifold temperature sensor resistances.

  • Check the intake manifold temperature sensor resistances. NOTE: The intake manifold temperature sensor may have malfunctioned in-range and the related fault codes will not be activated.
  • Reference Fault Code 153 (Intake Manifold Temperature Sensor Shorted High) or Fault Code 154 (Intake Manifold Temperature Sensor Shorted Low) in Section TF.
  • Refer to Procedure 019-360 in Section 19.

Intake manifold temperature sensor supply voltages and reference resistances within specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor.

  • . Refer to Procedure 019-059 in Section 19.

Go to 4A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure sensor.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode. Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold pressure.

  • Use the generator set HMI to check the intake manifold pressure. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold pressure within specification?
YES NO
No Repair

Repair

Check the operation of the compressor bypass valve (single turbocharger engines only).

  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check the intake manifold pressure sensor.

NOTE: The intake manifold pressure sensor may have malfunctioned in range and the related fault codes will not be activated.

  • Reference Fault Code 354 (Intake Manifold Pressure Sensor Shorted High) or Fault Code 355 (Intake Manifold Pressure Sensor Shorted Low) in Section TF.
  • Refer to Procedure 019-359 in Section 19.

Intake manifold pressure sensor within specification?
YES NO
No Repair

Repair

Replace the intake manifold pressure sensor.

  • Refer to Procedure 019-061 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the generator set.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check the quality of the natural gas supply.

  • Check that the quality of the natural gas supplied to the generator set meets or exceeds minimum requirement for generator set (methane number and fuel contaminants limits).
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspect cylinder number 15 cylinder head.

Guided Step 7A - Check the cylinder number 15 spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug J connector damaged.
  • Inspect the electrode for signs of oil contamination.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder number 15 spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug.
  • Replace the spark plug.
  • Use the following procedure in theQSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the cylinder number 15 spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Remove the spark plug and measure the spark plug electrode gap.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
  • Contact a Cummins® Authorized Repair Location.

Cylinder number 15 spark plug gap excessive?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7C

Guided Step 7C - Check the cylinder number 15 cylinder head.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Inspect cylinder number 15 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around Cylinder 15 cylinder head.

Cylinder number 15 cylinder head leaking gaskets or loose components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose components on or immediately around Cylinder 15 cylinder head. Refer to the appropriate procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396.
No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check the cylinder number 15 valve lash is correct.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check cylinder number 15 valve lash is correct.

  • Use the following procedure in theQSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder number 15 valve lash setting correct?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7E

Guided Step 7E - Check the cylinder number 15 valve train.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Inspect the cylinder number 15 valve train for the following:

  • Inlet or exhaust valve wear/recession or damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Camshaft follower wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder 15 camshaft lobe wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Cylinder number 15 valve train wear?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the cam follower assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

Adjust the valve lash. Reset the valve lash setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 9A

Go to 8A

Guided Step 8 - Inspect the cylinder number 15 power cylinder.

Guided Step 8A - Inspect the oil filters for debris.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Cut open the oil filters and inspect for debris.

  • Remove the lubrication oil filter. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter and inspect for debris in the filter medium.
  • Contact a Cummins® Authorized Repair Location.

Debris present in the oil filters?
YES | NO
No Repair | No Repair

Go to 8B

Go to 8D

Guided Step 8B - Check the cylinder number 15 internal power cylinder.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check the cylinder number 15 internal power cylinder.

NOTE: If available, these inspections can be performed using a Borescope without component removal.

Inspect the internal power cylinder for the following:

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage.

Cylinder number 15 power cylinder damaged?
YES NO

Repair

Replace the piston rings. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.

Replace the liner. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.

Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the cylinder number 15 connecting rod bearings.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP.

Action

Inspect the cylinder number 15 connecting rod bearings.

  • Check that the generator set controller readings for output voltage (L1- L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Cylinder number 15 connecting rod bearings damaged?
YES NO

Repair

Replace the connecting rod bearings:

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-007 in Section 1.
No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the cylinder number 15 piston cooling nozzle.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Inspect the cylinder number 15 piston cooling nozzle.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder number 15 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.
No Repair

Go to 9A

Go to 8E

Guided Step 8E - Inspect cylinder number 15 and adjacent cylinder main bearings.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Inspect cylinder number 15 and adjacent cylinder main bearings.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

Cylinder number 15 or immediately adjacent main bearings worn or damaged?
YES NO

Repair

Replace the main bearings. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

No Repair

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode.
  • Operate the engine for greater than 1 minute.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to verify Fault Code 1296 is inactive.

Fault Code 1296 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 9B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 02-Aug-2010


FAULT CODE 1297 - Engine Cylinder Number 15 Knock - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 male Deutsch™ test lead, and Part Number 3824812 female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1297 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Check theconnection from the knock sensor wiring harnessd to the knock sensor. | Knock sensor wiring harness connected?
 | STEP 2B. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 3. | Check the knock sensor. |
 | STEP 3A. Check that the knock sensor is tightened correctly. | Knock sensor tightened to specification?
 | STEP 3B. Test the knock sensor. | Fault Code 1584 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1297 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1297 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Check the connection from the knock sensor wiring harness to the knock sensor

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTOswitch in STOP mode.

Action

Check that the knock sensor wiring harness is connected to the knock sensor.

  • Refer to Procedure 019-346 in Section 19.

Knock sensor wiring harness connected?
YES NO
No Repair

Repair

Connect the knock sensor harness to the knock sensor.

  • Refer to Procedure 019-346 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTOswitch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM558B connector.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins. Repair or replace the engine harness or the harness connector.

Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.

Install the appropriate connector seal if it is damaged or missing.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTOswitch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM558 B connector.

Action

Check for an open circuit.

  • Measure the resistance from the knock cylinder number 15 SIGNAL pin in the knock sensor connector to the knock cylinder number 15 SIGNAL pin in the CM558 B.
  • Measure the resistance from the knock cylinder number 15 RETURN pin in the knock sensor connector to the knock cylinder number 15 RETURN pin in the CM558 B.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

Repair the wiring harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTOswitch in the STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check for a short circuit from pin to pin:

  • Measure the resistance from knock cylinder number 15 SIGNAL pin in the knock sensor harness connector to all other pins in the connector.
  • Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Repair the wiring harness.

  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the knock sensor.

Guided Step 3A - Check the knock sensor is tightened correctly.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTOswitch in STOP mode.
  • Disconnect the knock sensor harness from the knock sensor.

Action

Check that the knock sensor is tightened correctly.

  • Check that the knock sensor is tightened to the correct torque value. Refer to Procedure 019-346 in Section 19.

Knock sensor tightened to specification?
YES NO
No Repair

Repair

Tighten the knock sensor. Refer to Procedure 019-346 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Test the knock sensor.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTOswitch in RUN mode. (Operate the engine only after relocating the cylinder 15 knock sensor to cylinder 16)
  • Operate the engine for greater than 1 minute.

Action

Test the knock sensor.

  • Move the knock sensor from cylinder head number 15 to cylinder head number 16. Install the knock sensor from cylinder head number 16 to cylinder head number 15. Refer to Procedure 019-346 in Section 19.
  • Place the RUN/STOP/AUTO switch in the RUN mode and operate the engine for greater than 1 minute. Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 101-014 in Section 1.

Fault Code 1584 active?
YES NO

Repair

Replace the knock sensor. Refer to Procedure 019-346 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTOswitch in RUN mode.
  • Operate the engine for greater than 1 minute.

Action

Clear the inactive fault codes.

  • Use INSITE ™ electronic service tool to verify Fault Code 1297 is inactive.

Fault Code 1297 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTOswitch in STOP mode.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 01-Aug-2010


FAULT CODE 1362 - Engine Oil Filter Restriction High - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active or inactive fault codes. |
 | STEP 1A. Check for Fault Code 1362. | Active or inactive counts of Fault Code 1362?
 | STEP 1B. Check for multiple fault codes. | Active or inactive counts of Fault Codes 143, 415, 556, 1367, 1368, 1377, and 1378?
STEP 2. | Lubricating oil filters |
 | STEP 2A. Replace the lubricating oil filters. | Oil filters contaminated?
STEP 3. | Lubricating oil pressure sensors. |
 | STEP 3A. Check the pre- and post-filter lubricating oil pressure sensors. | Pressure sensor malfunctioning?
STEP 4. | Lubricating oil filter head |
 | STEP 4A. Check the lubricating oil filter head. | Lubricating oil filter head malfunctioning?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 1362 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active or inactive fault codes.

Guided Step 1A - Check for Fault Code 1362.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1362?
YES | NO
No Repair | No Repair

Go to 1B

Go to 5A

Guided Step 1B - Check for multiple fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the active and inactive fault codes.

Active or inactive counts of Fault Codes 143, 415, 556, 1367, 1368, 1377, and 1378?
YES NO

Repair

Troubleshoot any of the above fault codes. See relevant fault code tree in Section TF of this manual.

 No Repair

Go to 5A

Go to 2A

Guided Step 2 - Lubricating oil filters

Guided Step 2A - Replace the lubricating oil filters.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Remove, inspect, and replace the lubricating oil filters.

  • Use the following procedure in the QSK60G CM700 Generator Set, Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 007-002 in Section 8.
  • Cut open the lubricating oil filters and identify any debris or oil contamination. Check the lubricating oil condition as per Cummins® Engine Oil and Oil Analysis Recommendations, Bulletin Number 3810340.
  • Contact a Cummins® Authorized Repair Location.

Oil filters contaminated?
YES NO

Repair

NOTE: Replace the engine lubricating oil if the oil shows signs of contamination or the oil analysis results recommend that the lubricating oil should be replaced.

  • Use the following procedure in the QSK60G CM700 Generator Set, Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 007-002 in Section 8.
No Repair

Go to 5A

Go to 3A

Guided Step 3 - Lubiricating oil pressure sensors

Guided Step 3A - Check the pre and post-filter lubricating oil pressure sensors.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the operation and range of pre and post-filter lubricating oil pressure sensors.

  • Use the following procedure for pre-filter oil pressure sensor. Refer to Procedure 019-126 in Section 19.
  • Use the following procedure for post-filter oil pressure sensor. Refer to Procedure 019-447 in Section 19.

Pressure sensor malfunctioning?
YES NO

Repair

Replace pressure sensor.

  • Use the following procedure for pre-filter oil pressure sensor. Refer to Procedure 019-126 in Section 19.
  • Use the following procedure for post-filter oil pressure sensor. Refer to Procedure 019-447 in Section 19.
No Repair

Go to 5A

Go to 4A

Guided Step 4 - Lubricating oil filter head

Guided Step 4A - Check the lubricating oil filter head.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the lubricating oil filter head assembly.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-015 in Section 7.

Lubricating oil filter head malfunctioning?
YES NO

Repair

Repair or replace as required.

 No Repair

Go to 5A

5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.
  • Operate the engine for greater than 1 minute.

Action

Use INSITE™ electronic service tool to verify Fault Code 1362 is inactive.

Fault Code 1362 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 05-Jan-2011


FAULT CODE 1434 - Operator Interface Mode Transition to Emergency Stop (Due to Remote E-Stop) - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Troubleshoot the fault code. |
 | STEP 1A. Refer to the appropriate troubleshooting procedure. | Fault Code 1434 cleared?

Guided Step 1 - Troubleshoot the fault code.

Guided Step 1A - Refer to the appropriate troubleshooting procedure.

Conditions

  • Interview the operator to determine the reason for the remote emergency stop switch being activated.
  • Connect INSITE™ electronic service tool.
  • Reset either the local or remote emergency stop switch.
  • Reset the engine - press the Reset switch located on the generator control front panel.

Action

Take any actions based on the operator's comments and then reset the remote emergency stop switch.

  • Use INSITE™ electronic service tool to clear the fault code.

Fault Code 1434 cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 07-Jan-2011


Fault Code 1457 - Generator Synchronizing to Electric Bus Failed - Condition Exists

Associated Procedures

Cautions and Warnings

WARNING

To reduce the possibility of personal injury or equipment damage, this procedure must only be performed by suitably qualified service technicians.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes |
 | STEP 1A. Check for any active fault codes. | Fault Codes 121, 234, 175, 176, 177, 512, 513, 689, 1446, 1447, 1448, 1452, 1457, 1458, 1546, 1737, 1738, 1739, 1741, 1742, 1743, 1744, 1745, 1746, 1747, 1748, 1749, 1751, 1752, 1793, 1821, 2455, 2456, 2519, 2643, 2644, 2752, 2796, 2812, 2863, 3499, 3511, 3512, 3514, 3515, 3521, 3522, 3594 and 3595 active?
STEP 2. | Check the spark plugs |
 | STEP 2A. Check the spark plug gaps. | Spark plug electrode gap to specification?
STEP 3. | Check the throttle assemblies. |
 | STEP 3A. Check the throttle assemblies commanded position signal and position feedback signal for excessive deviation. | Throttle assemblies commanded position signal and position feedback signal exceeds 30 percent?
 | STEP 3B. Check the throttle shafts for free movement. | Throttle shafts move freely?
STEP 4. | Check the exhaust emissions. |
 | STEP 4A. Check the exhaust emissions are set to specification. | Exhaust emissions to specification?
STEP 5. | Check the speed bias sensor. |
 | STEP 5A. Check the speed bias sensor adjustment. | Speed bias sensor adjustment correct?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify the fault code is inactive. | Fault Code 1457 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • Connect INSITE™ electronic service tool.

Action

Verify that there are no active fault codes.

  • Use INSITE™ electronic service tool to read for any active fault codes.

Fault Codes 121, 234, 175, 176, 177, 512, 513, 689, 1446, 1447, 1448, 1452, 1457, 1458, 1546, 1737, 1738, 1739, 1741, 1742, 1743, 1744, 1745, 1746, 1747, 1748, 1749, 1751, 1752, 1793, 1821, 2455, 2456, 2519, 2643, 2644, 2752, 2796, 2812, 2863, 3499, 3511, 3512, 3514, 3515, 3521, 3522, 3594 and 3595 active?

YES NO

Repair

Follow the appropriate fault code troubleshooting steps or contact a Cummins® Authorized Repair Location.

Repair

Note: Use the following procedure if any fault codes are 'Inactive'. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plugs.

Guided Step 2A - Check the spark plug gaps.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plugs and measure the spark plug electrode gap on all spark plugs. Use the following procedure in the QSK45G and QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug electrode gap to specification?
YES NO
No Repair

Repair

Repair as necessary:

  • Adjust the spark plug electrode gaps.
  • Replace the spark plugs. Use the following procedure in the QSK45G and QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Go to 3A

Go to 6A

Guided Step 3 - Check the throttle assemblies.

Guided Step 3A - Check the throttle assemblies commanded position signal and position feedback signal for excessive deviation.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check the throttle assemblies for commanded signal position signal and feedback position signal for excessive deviation (greater than 30 percent deviation).

  • Use INSITE™ electronic service tool to electronically test the throttle plates for free movement. Use the "Actuator Diagnostics Tests" within the "ECM Diagnostics Tests" feature to perform this test.
  • Contact a Cummins® Authorized Repair Location.

Throttle assemblies commanded position signal and position feedback signal exceeds 30 percent?
YES NO

Repair

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 4A

Guided Step 3B - Check the throttle shafts for free movement.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the throttle assembly.

Action

Mechanically check the throttle shafts for free movement. Carry out the following procedures:

  • Remove the throttle assemblies. Use the following procedure in the QSK45G and QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 005-052 in Section 5.
  • Mechanically rotate the shaft from the fully closed to fully open position
  • Check for smooth movement through the full range
  • Check for any tight spots during the rotation of the shaft
  • Check the throttle shaft bearings for excessive free-play
  • Repeat for second throttle assembly.
  • Contact a Cummins® Authorized Repair Location.

Throttle shafts move freely?

YES NO
No Repair

Repair

Repair as necessary:

  • Replace the throttle assemblies. Use the following procedure in the QSK45G and QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 005-052 in Section 5.
  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust emissions.

Guided Step 4A - Check the exhaust emissions are set to specification.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Connect an exhaust gas analyzer
  • Energize keyswitch circuit
  • Place run/stop/auto switch in the RUN mode and engine running at the highest possible load with no knock - must be at a minimum 70 percent load.

Action

Check the exhaust emissions are to specification:

  • Use an exhaust gas analyzer, with the sample probe inserted into the exhaust gas manifold test port, to check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395, for exhaust emission specifications. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specification?
YES NO
No Repair

Repair

Adjust the exhaust emissions to specification.

  • Use INSITE™ electronic service tool and referencing to the exhaust gas analyzer to adjust the "open and closed-loop" fueling offsets so that the Nox and O2 emissions meet the fuel rating specification for the engine.
  • Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 6A

Guided Step 5 - Check the speed bias sensor.

Guided Step 5A - Check the speed bias sensor adjustment.

Conditions

  • Connect all components
  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode.

Action

Check the speed bias sensor adjustment:

  • Check that the speed bias sensor air gap setting is correctly adjusted. Refer to Procedure 019-042 in Section 19.

Speed bias sensor adjustment correct?

YES NO
No Repair

Repair

Adjust the speed bias sensor air gap to specification

  • Refer to Procedure 019-042 in Section 19.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.

Action

Verify that the fault code is inactive:

  • Use INSITE™ electronic service tool to verify that the Fault Code 1457 is inactive.

Fault Code 1457 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-Oct-2011


FAULT CODE 1474 - Software Version Mismatch Between Master Controller and Extended I/O Board - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for software compatibility |
 | STEP 1A. Check for software compatibility | Fault Code 1474 active?
 | STEP 1B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for software compatibility

Guided Step 1A - Check for software compatibility

Conditions

  • Connect INSITE™ electronic service tool.
  • Place run/stop/auto switch on the PSC front panel in STOP mode.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to load compatible software into the ECM.

Is Fault Code 1474 active?
YES | NO
No Repair | No Repair

Repair complete.

Repair complete.

Guided Step 1B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch on the PSC front panel in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Appropriate troubleshooting chart.

Last Modified: 07-Jan-2011


FAULT CODE 1521 - Exhaust Gas Temperature Sensor Cylinder 3 (A2) - Voltage Above Normal or Shorted to High Source (Multiple Turbochargers)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™/ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1521 active?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 3. |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 3. | Inspect the CENSE™ module and engine harness. |
 | STEP 3A. Check the ECM response. | Fault Code 1521 inactive and Fault Code 672 active?
 | STEP 3B. Check the CENSE™ harness and connector pins. | CENSE™ module harness and connector pins OK?
 | STEP 3C. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1521 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1521 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas temperature circuit cylinder 3.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the exhaust gas temperature sensor connector from the exhaust gas temperature sensor.

Action

Inspect the engine harness and the exhaust gas temperature sensor circuit cylinder 3 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 3 or in the engine harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 3 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 3 SIGNAL pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 3 RETURN pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors in pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the exhaust gas temperature sensor connector cylinder 3.

  • Repair the engine harness or the exhaust gas temperature sensor connector cylinder 3.
  • Replace the engine harness or exhaust gas temperature sensor connector cylinder 3.
  • Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the CENSE™ module and engine harness.

Guided Step 3A - Check the ECM response.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connector from the exhaust gas temperature sensor cylinder 3.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1521 inactive and Fault Code 672 active?
YES NO
No Repair

Repair

Replace the CENSE™ module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the CENSE™ harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CENSE™ module.

Action

Inspect the CENSE™ module harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

CENSE™ module harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or CENSE™ module connector.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CENSE™ module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 3 SIGNAL pin in the engine harness CENSE™ module connector to all other pins in the engine harness CENSE™ module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 3 RETURN pin in the engine harness CENSE™ module connector to all other pins in the engine harness CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and engine running for greater than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1521 is inactive.

Fault Code 1521 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-Mar-2011


FAULT CODE 1521 - (Single Turbocharger) Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1521 active?
STEP 2. | Check the exhaust temperature sensor circuit cylinder 3 (A2). |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 3. | Inspect the CM850 module and engine harness. |
 | STEP 3A. Check the CM850 response. | Fault Code 1521 inactive, Fault Code 671 active?
 | STEP 3B. Inspect the CM850 module harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the 5-VDC supply to the exhaust temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 3D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1521 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1521 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 3 (A2).

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 3 (A2) exhaust temperature sensor.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector on cylinder 3 (A2).

Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 3 (A2) exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 3 (A2) SIGNAL pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 3 (A2) SUPPLY pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 3 (A2) RETURN pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness exhaust gas temperature sensor connector cylinder 3 (A2).

  • Repair the engine harness or exhaust gas temperature sensor connector cylinder 3 (A2).
  • Replace the engine harness or exhaust gas temperature sensor connector cylinder 3 (A2). Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the CM850 module and engine harness.

Guided Step 3A - Check the ECM response.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the OFF mode
  • Disconnect the engine harness connector from the exhaust gas temperature sensor cylinder 3 (A2)
  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1521 inactive, Fault Code 671 active?
YES NO
No Repair

Repair

Replace the CM850 module.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the CM850 harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from the CM850 module.

Action

Inspect the CM850 module harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or CM850 module connector.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connectors from cylinder 3 (A2) exhaust temperature sensor.

Action

Check the 5-VDC supply to the exhaust temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 3 (A2).
  • Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Go to next troubleshooting step.

Go to 4A

Go to 3D

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 3 (A2) SUPPLY pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 3 (A2) SIGNAL pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 3 (A2) RETURN pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the CM850 module.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the engine harness.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and engine operating for longer than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify the Fault Code 1521 is inactive.

Fault Code 1521 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes

Repair complete.

Appropriate troubleshooting steps

Last Modified: 08-May-2012


FAULT CODE 1522 - Exhaust Gas Temperature Sensor Cylinder 5 (A3) - Voltage Above Normal or Shorted to High Source (Multiple Turbochargers)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™/ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1522 active?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 1. |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 3. | Inspect the CENSE™ module and engine harness. |
 | STEP 3A. Check the ECM response. | Fault Code 1522 inactive and Fault Code 673 active?
 | STEP 3B. Check the CENSE™ harness and connector pins. | CENSE™ module harness and connector pins OK?
 | STEP 3C. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1522 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1522 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas temperature circuit cylinder 1.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the exhaust gas temperature sensor connector cylinder 1 from the exhaust gas temperature sensor.

Action

Inspect the engine harness and the exhaust gas temperature sensor circuit cylinder 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 1 or in the engine harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 1 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 1 SIGNAL pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 1 RETURN pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors in pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the exhaust gas temperature sensor connector cylinder 1.

  • Repair the engine harness or the exhaust gas temperature sensor connector cylinder 1.
  • Replace the engine harness or exhaust gas temperature sensor connector cylinder 1.
  • Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the CENSE™ module and engine harness.

Guided Step 3A - Check the ECM response.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connector from the exhaust gas temperature sensor cylinder 1.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1522 inactive and Fault Code 673 active?
YES NO
No Repair

Repair

Replace the CENSE™ module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the CENSE™ harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CENSE™ module.

Action

Inspect the CENSE™ module harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

CENSE™ module harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or CENSE™ module connector.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CENSE™ module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 1 SIGNAL pin in the engine harness CENSE™ module connector to all other pins in the engine harness CENSE™ module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 1 RETURN pin in the engine harness CENSE™ module connector to all other pins in the engine harness CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and engine running for greater than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1618 is inactive.

Fault Code 1618 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-Mar-2011


FAULT CODE 1522 - (Single Turbocharger) Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1522 active?
STEP 2. | Check the exhaust temperature sensor circuit cylinder 5 (A3). |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 3. | Inspect the CM850 module and engine harness. |
 | STEP 3A. Check the CM850 response. | Fault Code 1522 inactive, Fault Code 671 active?
 | STEP 3B. Inspect the CM850 module harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the 5-VDC supply to the exhaust temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 3D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1522 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1522 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 5 (A3).

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 5 (A3) exhaust temperature sensor.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector on cylinder 5 (A3).

Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 5 (A3) exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 5 (A3) SIGNAL pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 5 (A3) SUPPLY pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 5 (A3) RETURN pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness exhaust gas temperature sensor connector cylinder 5 (A3).

  • Repair the engine harness or exhaust gas temperature sensor connector cylinder 5 (A3).
  • Replace the engine harness or exhaust gas temperature sensor connector cylinder 5 (A3). Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the CM850 module and engine harness.

Guided Step 3A - Check the ECM response.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the OFF mode
  • Disconnect the engine harness connector from the exhaust gas temperature sensor cylinder 5 (A3)
  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1522 inactive, Fault Code 671 active?
YES NO
No Repair

Repair

Replace the CM850 module.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the CM850 harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from the CM850 module.

Action

Inspect the CM850 module harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or CM850 module connector.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connectors from cylinder 5 (A3) exhaust temperature sensor.

Action

Check the 5-VDC supply to the exhaust temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 5 (A3).
  • Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Go to next troubleshooting step.

Go to 4A

Go to 3D

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 5 (A3) SUPPLY pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 5 (A3) SIGNAL pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 5 (A3) RETURN pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the CM850 module.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the engine harness.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and engine operating for longer than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify the Fault Code 1522 is inactive.

Fault Code 1522 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes

Repair complete.

Appropriate troubleshooting steps

Last Modified: 08-May-2012


FAULT CODE 1523 - Exhaust Gas Temperature Sensor Cylinder 7 (A4) - Voltage Above Normal or Shorted to High Source (Multiple Turbochargers)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™/ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1523 active?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 7. |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 3. | Inspect the CENSE™ module and engine harness. |
 | STEP 3A. Check the ECM response. | Fault Code 1523 inactive and Fault Code 674 active?
 | STEP 3B. Check the CENSE™ harness and connector pins. | CENSE™ module harness and connector pins OK?
 | STEP 3C. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1523 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1523 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas temperature circuit cylinder 7.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the exhaust gas temperature sensor connector cylinder 7 from the exhaust gas temperature sensor.

Action

Inspect the engine harness and the exhaust gas temperature sensor circuit cylinder 7 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 7 or in the engine harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 7 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 7 SIGNAL pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 7 RETURN pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors in pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the exhaust gas temperature sensor connector cylinder 7.

  • Repair the engine harness or the exhaust gas temperature sensor connector cylinder 7.
  • Replace the engine harness or exhaust gas temperature sensor connector cylinder 7.
  • Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the CENSE™ module and engine harness.

Guided Step 3A - Check the ECM response.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connector from the exhaust gas temperature sensor cylinder 7.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1523 inactive and Fault Code 674 active?
YES NO
No Repair

Repair

Replace the CENSE™ module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the CENSE™ harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CENSE™ module.

Action

Inspect the CENSE™ module harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

CENSE™ module harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or CENSE™ module connector.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CENSE™ module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 7 SIGNAL pin in the engine harness CENSE™ module connector to all other pins in the engine harness CENSE™ module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 7 RETURN pin in the engine harness CENSE™ module connector to all other pins in the engine harness CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and engine running for greater than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1523 is inactive.

Fault Code 1523 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-Mar-2011


FAULT CODE 1523 - (Single Turbocharger) Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1523 active?
STEP 2. | Check the exhaust temperature sensor circuit cylinder 7 (A4). |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 3. | Inspect the CM850 module and engine harness. |
 | STEP 3A. Check the CM850 response. | Fault Code 1523 inactive, Fault Code 671 active?
 | STEP 3B. Inspect the CM850 module harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the 5-VDC supply to the exhaust temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 3D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1523 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1523 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 7 (A4).

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 7 (A4) exhaust temperature sensor.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector on cylinder 7 (A4).

Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 7 (A4) exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 7 (A4) SIGNAL pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 7 (A4) SUPPLY pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 7 (A4) RETURN pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness exhaust gas temperature sensor connector cylinder 7 (A4).

  • Repair the engine harness or exhaust gas temperature sensor connector cylinder 7 (A4).
  • Replace the engine harness or exhaust gas temperature sensor connector cylinder 7 (A4). Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the CM850 module and engine harness.

Guided Step 3A - Check the ECM response.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the OFF mode
  • Disconnect the engine harness connector from the exhaust gas temperature sensor cylinder 7 (A4)
  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1523 inactive, Fault Code 671 active?
YES NO
No Repair

Repair

Replace the CM850 module.

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the CM850 harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from the CM850 module.

Action

Inspect the CM850 module harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or CM850 module connector.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connectors from cylinder 7 (A4) exhaust temperature sensor.

Action

Check the 5-VDC supply to the exhaust temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 7 (A4).
  • Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Go to next troubleshooting step.

Go to 4A

Go to 3D

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 7 (A4) SUPPLY pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 7 (A4) SIGNAL pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 7 (A4) RETURN pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the CM850 module.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the engine harness.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and engine operating for longer than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify the Fault Code 1523 is inactive.

Fault Code 1523 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes

Repair complete.

Appropriate troubleshooting steps

Last Modified: 08-May-2012


FAULT CODE 1524 - Exhaust Gas Temperature Sensor Cylinder 9 (A5) - Voltage Above Normal or Shorted to High Source (Multiple Turbochargers)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™/ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1524 active?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 9. |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 3. | Inspect the CENSE™ module and engine harness. |
 | STEP 3A. Check the ECM response. | Fault Code 1524 inactive and Fault Code 675 active?
 | STEP 3B. Check the CENSE™ harness and connector pins. | CENSE™ module harness and connector pins OK?
 | STEP 3C. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1524 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1524 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas temperature circuit cylinder 9.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the exhaust gas temperature sensor connector cylinder 9 from the exhaust gas temperature sensor.

Action

Inspect the engine harness and the exhaust gas temperature sensor circuit cylinder 9 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 9 or in the engine harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 9 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 9 SIGNAL pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 9 RETURN pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors in pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the exhaust gas temperature sensor connector cylinder 9.

  • Repair the engine harness or the exhaust gas temperature sensor connector cylinder 9.
  • Replace the engine harness or exhaust gas temperature sensor connector cylinder 9.
  • Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the CENSE™ module and engine harness.

Guided Step 3A - Check the ECM response.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connector from the exhaust gas temperature sensor cylinder 9.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1524 inactive and Fault Code 675 active?
YES NO
No Repair

Repair

Replace the CENSE™ module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the CENSE™ harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CENSE™ module.

Action

Inspect the CENSE™ module harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

CENSE™ module harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or CENSE™ module connector.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CENSE™ module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 9 SIGNAL pin in the engine harness CENSE™ module connector to all other pins in the engine harness CENSE™ module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 9 RETURN pin in the engine harness CENSE™ module connector to all other pins in the engine harness CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and engine running for greater than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1524 is inactive.

Fault Code 1524 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-Mar-2011


FAULT CODE 1524 - (Single Turbocharger) Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1524 active?
STEP 2. | Check the exhaust temperature sensor circuit cylinder 9 (A5). |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 3. | Inspect the CM850 module and engine harness. |
 | STEP 3A. Check the CM850 response. | Fault Code 1524 inactive, Fault Code 671 active?
 | STEP 3B. Inspect the CM850 module harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the 5-VDC supply to the exhaust temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 3D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1524 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1524 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 9 (A5).

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 9 (A5) exhaust temperature sensor.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector on cylinder 9 (A5).

Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 9 (A5) exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 9 (A5) SIGNAL pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 9 (A5) SUPPLY pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 9 (A5) RETURN pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness exhaust gas temperature sensor connector cylinder 9 (A5).

  • Repair the engine harness or exhaust gas temperature sensor connector cylinder 9 (A5).
  • Replace the engine harness or exhaust gas temperature sensor connector cylinder 9 (A5). Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the CM850 module and engine harness.

Guided Step 3A - Check the ECM response.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the OFF mode
  • Disconnect the engine harness connector from the exhaust gas temperature sensor cylinder 9 (A5)
  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1524 inactive, Fault Code 671 active?
YES NO
No Repair

Repair

Replace the CM850 module.

Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the CM850 harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from the CM850 module.

Action

Inspect the CM850 module harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or CM850 module connector.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connectors from cylinder 9 (A5) exhaust temperature sensor.

Action

Check the 5-VDC supply to the exhaust temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 9 (A5).
  • Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Go to next troubleshooting step.

Go to 4A

Go to 3D

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 9 (A5) SUPPLY pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 9 (A5) SIGNAL pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 9 (A5) RETURN pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the CM850 module.

  • Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the engine harness.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and engine operating for longer than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify the Fault Code 1524 is inactive.

Fault Code 1524 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes

Repair complete.

Appropriate troubleshooting steps

Last Modified: 08-May-2012


FAULT CODE 1525 - Exhaust Gas Temperature Sensor Cylinder 11 (A6) - Voltage Above Normal or Shorted to High Source (Multiple Turbochargers)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™/ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1525 active?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 11. |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 3. | Inspect the CENSE™ module and engine harness. |
 | STEP 3A. Check the ECM response. | Fault Code 1525 inactive and Fault Code 676 active?
 | STEP 3B. Check the CENSE™ harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1525 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1525 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas temperature circuit cylinder 11.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the exhaust gas temperature sensor connector cylinder 11 from the exhaust gas temperature sensor.

Action

Inspect the engine harness and the exhaust gas temperature sensor circuit cylinder 11 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 11 or in the engine harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from the cylinder 11 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 11 SIGNAL pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 11 RETURN pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors in pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the exhaust gas temperature sensor connector cylinder 11.

  • Repair the engine harness or the exhaust gas temperature sensor connector cylinder 11.
  • Replace the engine harness or exhaust gas temperature sensor connector cylinder 11.
  • Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the CENSE™ module and engine harness.

Guided Step 3A - Check the ECM response.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connector from the exhaust gas temperature sensor cylinder 11.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1525 inactive and Fault Code 676 active?
YES NO
No Repair

Repair

Replace the CENSE™ module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the CENSE™ harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CENSE™ module.

Action

Inspect the CENSE™ module harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or CENSE™ module connector.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CENSE™ module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 11 SIGNAL pin in the engine harness CENSE™ module connector to all other pins in the engine harness CENSE™ module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 11 RETURN pin in the engine harness CENSE™ module connector to all other pins in the engine harness CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and opeate engine running for more than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1525 is inactive.

Fault Code 1525 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 18-Mar-2011


FAULT CODE 1525 - (Single Turbocharger) Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1525 active?
STEP 2. | Check the exhaust temperature sensor circuit cylinder 11 (A6). |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 3. | Inspect the CM850 module and engine harness. |
 | STEP 3A. Check the CM850 response. | Fault Code 1525 inactive, Fault Code 671 active?
 | STEP 3B. Inspect the CM850 module harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the 5-VDC supply to the exhaust temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 3D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1525 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1525 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 11 (A6).

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 11 (A6) exhaust temperature sensor.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector on cylinder 11 (A6).

Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 11 (A6) exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 11 (A6) SIGNAL pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 11 (A6) SUPPLY pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 11 (A6) RETURN pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness exhaust gas temperature sensor connector cylinder 11 (A6).

  • Repair the engine harness or exhaust gas temperature sensor connector cylinder 11 (A6).
  • Replace the engine harness or exhaust gas temperature sensor connector cylinder 11 (A6). Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the CM850 module and engine harness.

Guided Step 3A - Check the ECM response.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the OFF mode
  • Disconnect the engine harness connector from the exhaust gas temperature sensor cylinder 11 (A6)
  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1525 inactive, Fault Code 671 active?
YES NO
No Repair

Repair

Replace the CM850 module.

  • Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the CM850 harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from the CM850 module.

Action

Inspect the CM850 module harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or CM850 module connector.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connectors from cylinder 11 (A6) exhaust temperature sensor.

Action

Check the 5-VDC supply to the exhaust temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 11 (A6).
  • Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Go to next troubleshooting step.

Go to 4A

Go to 3D

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 11 (A6) SUPPLY pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 11 (A6) SIGNAL pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 11 (A6) RETURN pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the CM850 module.

  • Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the engine harness.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and engine operating for longer than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify the Fault Code 1525 is inactive.

Fault Code 1525 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes

Repair complete.

Appropriate troubleshooting steps

Last Modified: 08-May-2012


FAULT CODE 1526 - Exhaust Gas Temperature Sensor Cylinder 13 (A7) - Voltage Above Normal or Shorted to High Source (Multiple Turbochargers)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™/ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1526 active?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 13 . |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 3. | Inspect the CENSE™ module and engine harness. |
 | STEP 3A. Check the ECM response. | Fault Code 1526 inactive and Fault Code 677 active?
 | STEP 3B. Check the CENSE™ harness and connector pins. | CENSE™ module harness and connector pins OK?
 | STEP 3C. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1526 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1526 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas temperature circuit cylinder 13 .

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the exhaust gas temperature sensor connector cylinder 13 from the exhaust gas temperature sensor.

Action

Inspect the engine harness and the exhaust gas temperature sensor circuit cylinder 13 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 13 or in the engine harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 13 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 13 SIGNAL pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 13 RETURN pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors in pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the exhaust gas temperature sensor connector cylinder 13 .

  • Repair the engine harness or the exhaust gas temperature sensor connector cylinder 13 .
  • Replace the engine harness or exhaust gas temperature sensor connector cylinder 13 .
  • Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the CENSE™ module and engine harness.

Guided Step 3A - Check the ECM response.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connector from the exhaust gas temperature sensor cylinder 13 .
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1526 inactive and Fault Code 677 active?
YES NO
No Repair

Repair

Replace the CENSE™ module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the CENSE™ harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CENSE™ module.

Action

Inspect the CENSE™ module harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

CENSE™ module harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or CENSE™ module connector.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CENSE™ module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 13 SIGNAL pin in the engine harness CENSE™ module connector to all other pins in the engine harness CENSE™ module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 13 RETURN pin in the engine harness CENSE™ module connector to all other pins in the engine harness CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and engine running for greater than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1526 is inactive.

Fault Code 1526 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-Mar-2011


FAULT CODE 1526 - (Single Turbocharger) Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1526 active?
STEP 2. | Check the exhaust temperature sensor circuit cylinder 13 (A7). |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 3. | Inspect the CM850 module and engine harness. |
 | STEP 3A. Check the CM850 response. | Fault Code 1526 inactive, Fault Code 671 active?
 | STEP 3B. Inspect the CM850 module harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the 5-VDC supply to the exhaust temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 3D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1526 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1526 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 13 (A7).

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 13 (A7) exhaust temperature sensor.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector on cylinder 13 (A7).

Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 13 (A7) exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 13 (A7) SIGNAL pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 13 (A7) SUPPLY pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 13 (A7) RETURN pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness exhaust gas temperature sensor connector cylinder 13 (A7).

  • Repair the engine harness or exhaust gas temperature sensor connector cylinder 13 (A7).
  • Replace the engine harness or exhaust gas temperature sensor connector cylinder 13 (A7). Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the CM850 module and engine harness.

Guided Step 3A - Check the ECM response.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the OFF mode
  • Disconnect the engine harness connector from the exhaust gas temperature sensor cylinder 13 (A7)
  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1526 inactive, Fault Code 671 active?
YES NO
No Repair

Repair

Replace the CM850 module.

  • Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the CM850 harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from the CM850 module.

Action

Inspect the CM850 module harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or CM850 module connector.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connectors from cylinder 13 (A7) exhaust temperature sensor.

Action

Check the 5-VDC supply to the exhaust temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 13 (A7).
  • Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Go to next troubleshooting step.

Go to 4A

Go to 3D

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 13 (A7) SUPPLY pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 13 (A7) SIGNAL pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 13 (A7) RETURN pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the CM850 module.

  • Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the engine harness.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and engine operating for longer than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify the Fault Code 1526 is inactive.

Fault Code 1526 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes

Repair complete.

Appropriate troubleshooting steps

Last Modified: 08-May-2012


FAULT CODE 1527 - Exhaust Gas Temperature Sensor Cylinder 15 (A8) - Voltage Above Normal or Shorted to High Source (Multiple Turbochargers)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™/ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1527 active?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 15 . |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 3. | Inspect the CENSE™ module and engine harness. |
 | STEP 3A. Check the ECM response. | Fault Code 1527 inactive and Fault Code 678 active?
 | STEP 3B. Check the CENSE™ harness and connector pins. | CENSE™ module harness and connector pins OK?
 | STEP 3C. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1527 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1527 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas temperature circuit cylinder 15 .

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the exhaust gas temperature sensor connector cylinder 15 from the exhaust gas temperature sensor.

Action

Inspect the engine harness and the exhaust gas temperature sensor circuit cylinder 15 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 15 or in the engine harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 15 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 15 SIGNAL pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 15 RETURN pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors in pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the exhaust gas temperature sensor connector cylinder 15 .

  • Repair the engine harness or the exhaust gas temperature sensor connector cylinder 15 .
  • Replace the engine harness or exhaust gas temperature sensor connector cylinder 15 .
  • Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the CENSE™ module and engine harness.

Guided Step 3A - Check the ECM response.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connector from the exhaust gas temperature sensor cylinder 15 .
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1527 inactive and Fault Code 678 active?
YES NO
No Repair

Repair

Replace the CENSE™ module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the CENSE™ harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CENSE™ module.

Action

Inspect the CENSE™ module harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

CENSE™ module harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or CENSE™ module connector.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CENSE™ module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 15 SIGNAL pin in the engine harness CENSE™ module connector to all other pins in the engine harness CENSE™ module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 15 RETURN pin in the engine harness CENSE™ module connector to all other pins in the engine harness CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and engine running for greater than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1527 is inactive.

Fault Code 1527 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-Mar-2011


FAULT CODE 1527 - (Single Turbocharger) Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1527 active?
STEP 2. | Check the exhaust temperature sensor circuit cylinder 15 (A8). |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 3. | Inspect the CM850 module and engine harness. |
 | STEP 3A. Check the CM850 response. | Fault Code 1527 inactive, Fault Code 671 active?
 | STEP 3B. Inspect the CM850 module harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the 5-VDC supply to the exhaust temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 3D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1527 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1527 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 15 (A8).

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 15 (A8) exhaust temperature sensor.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector on cylinder 15 (A8).

Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 15 (A8) exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 15 (A8) SIGNAL pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 15 (A8) SUPPLY pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 15 (A8) RETURN pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness exhaust gas temperature sensor connector cylinder 15 (A8).

  • Repair the engine harness or exhaust gas temperature sensor connector cylinder 15 (A8).
  • Replace the engine harness or exhaust gas temperature sensor connector cylinder 15 (A8). Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the CM850 module and engine harness.

Guided Step 3A - Check the ECM response.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the OFF mode
  • Disconnect the engine harness connector from the exhaust gas temperature sensor cylinder 15 (A8)
  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1527 inactive, Fault Code 671 active?
YES NO
No Repair

Repair

Replace the CM850 module.

  • Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the CM850 harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from the CM850 module.

Action

Inspect the CM850 module harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or CM850 module connector.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connectors from cylinder 15 (A8) exhaust temperature sensor.

Action

Check the 5-VDC supply to the exhaust temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 15 (A8).
  • Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Go to next troubleshooting step.

Go to 4A

Go to 3D

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 15 (A8) SUPPLY pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 15 (A8) SIGNAL pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 15 (A8) RETURN pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the CM850 module.

  • Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the engine harness.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and engine operating for longer than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify the Fault Code 1527 is inactive.

Fault Code 1527 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes

Repair complete.

Appropriate troubleshooting steps

Last Modified: 08-May-2012


FAULT CODE 1529 - Exhaust Gas Temperature Sensor Cylinder 2 (B1) - Voltage Above Normal or Shorted to High Source (Multiple Turbochargers)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™/ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1529 active?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 2. |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 3. | Inspect the CENSE™ module and engine harness. |
 | STEP 3A. Check the ECM response. | Fault Code 1529 inactive and Fault Code 721 active?
 | STEP 3B. Check the CENSE™ harness and connector pins. | CENSE™ module harness and connector pins OK?
 | STEP 3C. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1529 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1529 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas temperature circuit cylinder 2.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the exhaust gas temperature sensor connector cylinder 2 from the exhaust gas temperature sensor.

Action

Inspect the engine harness and the exhaust gas temperature sensor circuit cylinder 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 2 or in the engine harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 2 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 2 SIGNAL pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 2 RETURN pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors in pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the exhaust gas temperature sensor connector cylinder 2.

  • Repair the engine harness or the exhaust gas temperature sensor connector cylinder 2.
  • Replace the engine harness or exhaust gas temperature sensor connector cylinder 2.
  • Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the CENSE™ module and engine harness.

Guided Step 3A - Check the ECM response.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connector from the exhaust gas temperature sensor cylinder 2.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1529 inactive and Fault Code 721 active?
YES NO
No Repair

Repair

Replace the CENSE™ module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the CENSE™ harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CENSE™ module.

Action

Inspect the CENSE™ module harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

CENSE™ module harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or CENSE™ module connector.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CENSE™ module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 2 SIGNAL pin in the engine harness CENSE™ module connector to all other pins in the engine harness CENSE™ module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 2 RETURN pin in the engine harness CENSE™ module connector to all other pins in the engine harness CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and engine running for greater than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1529 is inactive.

Fault Code 1529 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-Mar-2011


FAULT CODE 1529 - (Single Turbocharger) Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1529 active?
STEP 2. | Check the exhaust temperature sensor circuit cylinder 2 (B1). |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 3. | Inspect the CM850 module and engine harness. |
 | STEP 3A. Check the CM850 response. | Fault Code 1529 inactive, Fault Code 671 active?
 | STEP 3B. Inspect the CM850 module harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the 5-VDC supply to the exhaust temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 3D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1529 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1529 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 2 (B1).

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 2 (B1) exhaust temperature sensor.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector on cylinder 2 (B1).

Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 2 (B1) exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 2 (B1) SIGNAL pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 2 (B1) SUPPLY pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 2 (B1) RETURN pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness exhaust gas temperature sensor connector cylinder 2 (B1).

  • Repair the engine harness or exhaust gas temperature sensor connector cylinder 2 (B1).
  • Replace the engine harness or exhaust gas temperature sensor connector cylinder 2 (B1). Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the CM850 module and engine harness.

Guided Step 3A - Check the ECM response.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the OFF mode
  • Disconnect the engine harness connector from the exhaust gas temperature sensor cylinder 2 (B1)
  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1529 inactive, Fault Code 671 active?
YES NO
No Repair

Repair

Replace the CM850 module.

  • Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the CM850 harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from the CM850 module.

Action

Inspect the CM850 module harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or CM850 module connector.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connectors from cylinder 2 (B1) exhaust temperature sensor.

Action

Check the 5-VDC supply to the exhaust temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 2 (B1).
  • Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Go to next troubleshooting step.

Go to 4A

Go to 3D

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 2 (B1) SUPPLY pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 2 (B1) SIGNAL pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 2 (B1) RETURN pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the CM850 module.

  • Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the engine harness.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and engine operating for longer than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify the Fault Code 1529 is inactive.

Fault Code 1529 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes

Repair complete.

Appropriate troubleshooting steps

Last Modified: 08-May-2012


FAULT CODE 1531 - Exhaust Gas Temperature Sensor Cylinder 6 (B3) - Voltage Above Normal or Shorted to High Source (Multiple Turbochargers)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™/ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1531 active?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 6. |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 3. | Inspect the CENSE™ module and engine harness. |
 | STEP 3A. Check the ECM response. | Fault Code 1531 inactive and Fault Code 723 active?
 | STEP 3B. Check the CENSE™ harness and connector pins. | CENSE™ module harness and connector pins OK?
 | STEP 3C. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1531 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1531 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas temperature circuit cylinder 6.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the exhaust gas temperature sensor connector cylinder 6 from the exhaust gas temperature sensor.

Action

Inspect the engine harness and the exhaust gas temperature sensor circuit cylinder 6 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 6 or in the engine harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 6 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 6 SIGNAL pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 6 RETURN pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors in pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the exhaust gas temperature sensor connector cylinder 6.

  • Repair the engine harness or the exhaust gas temperature sensor connector cylinder 6.
  • Replace the engine harness or exhaust gas temperature sensor connector cylinder 6.
  • Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the CENSE™ module and engine harness.

Guided Step 3A - Check the ECM response.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connector from the exhaust gas temperature sensor cylinder 6.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1531 inactive and Fault Code 723 active?
YES NO
No Repair

Repair

Replace the CENSE™ module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the CENSE™ harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CENSE™ module.

Action

Inspect the CENSE™ module harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

CENSE™ module harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or CENSE™ module connector.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CENSE™ module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 6 SIGNAL pin in the engine harness CENSE™ module connector to all other pins in the engine harness CENSE™ module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 6 RETURN pin in the engine harness CENSE™ module connector to all other pins in the engine harness CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and engine running for greater than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1531 is inactive.

Fault Code 1531 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-Mar-2011


FAULT CODE 1531 - (Single Turbocharger) Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1531 active?
STEP 2. | Check the exhaust temperature sensor circuit cylinder 6 (B3). |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 3. | Inspect the CM850 module and engine harness. |
 | STEP 3A. Check the CM850 response. | Fault Code 1531 inactive, Fault Code 671 active?
 | STEP 3B. Inspect the CM850 module harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the 5-VDC supply to the exhaust temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 3D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1531 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1531 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 6 (B3).

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 6 (B3) exhaust temperature sensor.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector on cylinder 6 (B3).

Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 6 (B3) exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 6 (B3) SIGNAL pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 6 (B3) SUPPLY pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 6 (B3) RETURN pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness exhaust gas temperature sensor connector cylinder 6 (B3).

  • Repair the engine harness or exhaust gas temperature sensor connector cylinder 6 (B3).
  • Replace the engine harness or exhaust gas temperature sensor connector cylinder 6 (B3). Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the CM850 module and engine harness.

Guided Step 3A - Check the ECM response.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the OFF mode
  • Disconnect the engine harness connector from the exhaust gas temperature sensor cylinder 6 (B3)
  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1531 inactive, Fault Code 671 active?
YES NO
No Repair

Repair

Replace the CM850 module.

  • Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the CM850 harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from the CM850 module.

Action

Inspect the CM850 module harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or CM850 module connector.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connectors from cylinder 6 (B3) exhaust temperature sensor.

Action

Check the 5-VDC supply to the exhaust temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 6 (B3).
  • Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Go to next troubleshooting step.

Go to 4A

Go to 3D

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 6 (B3) SUPPLY pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 6 (B3) SIGNAL pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 6 (B3) RETURN pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the CM850 module.

  • Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the engine harness.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and engine operating for longer than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify the Fault Code 1531 is inactive.

Fault Code 1531 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes

Repair complete.

Appropriate troubleshooting steps

Last Modified: 08-May-2012


FAULT CODE 1532 - Exhaust Gas Temperature Sensor Cylinder 8 (B4) - Voltage Above Normal or Shorted to High Source (Multiple Turbochargers)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™/ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1532 active?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 8. |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 3. | Inspect the CENSE™ module and engine harness. |
 | STEP 3A. Check the ECM response. | Fault Code 1532 inactive and Fault Code 724 active?
 | STEP 3B. Check the CENSE™ harness and connector pins. | CENSE™ module harness and connector pins OK?
 | STEP 3C. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1532 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1532 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas temperature circuit cylinder 8.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the exhaust gas temperature sensor connector cylinder 8 from the exhaust gas temperature sensor.

Action

Inspect the engine harness and the exhaust gas temperature sensor circuit cylinder 8 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 8 or in the engine harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 8 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 8 SIGNAL pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 8 RETURN pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors in pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the exhaust gas temperature sensor connector cylinder 8.

  • Repair the engine harness or the exhaust gas temperature sensor connector cylinder 8.
  • Replace the engine harness or exhaust gas temperature sensor connector cylinder 8.
  • Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the CENSE™ module and engine harness.

Guided Step 3A - Check the ECM response.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connector from the exhaust gas temperature sensor cylinder 8.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1532 inactive and Fault Code 724 active?
YES NO
No Repair

Repair

Replace the CENSE™ module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the CENSE™ harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CENSE™ module.

Action

Inspect the CENSE™ module harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

CENSE™ module harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or CENSE™ module connector.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CENSE™ module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 8 SIGNAL pin in the engine harness CENSE™ module connector to all other pins in the engine harness CENSE™ module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 8 RETURN pin in the engine harness CENSE™ module connector to all other pins in the engine harness CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and engine running for greater than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1532 is inactive.

Fault Code 1532 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 03-Mar-2011


FAULT CODE 1532 - (Single Turbocharger) Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1532 active?
STEP 2. | Check the exhaust temperature sensor circuit cylinder 8 (B4). |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 3. | Inspect the CM850 module and engine harness. |
 | STEP 3A. Check the CM850 response. | Fault Code 1532 inactive, Fault Code 671 active?
 | STEP 3B. Inspect the CM850 module harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the 5-VDC supply to the exhaust temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 3D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1532 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1532 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 8 (B4).

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 8 (B4) exhaust temperature sensor.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector on cylinder 8 (B4).

Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 8 (B4) exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 8 (B4) SIGNAL pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 8 (B4) SUPPLY pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 8 (B4) RETURN pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness exhaust gas temperature sensor connector cylinder 8 (B4).

  • Repair the engine harness or exhaust gas temperature sensor connector cylinder 8 (B4).
  • Replace the engine harness or exhaust gas temperature sensor connector cylinder 8 (B4). Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the CM850 module and engine harness.

Guided Step 3A - Check the ECM response.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the OFF mode
  • Disconnect the engine harness connector from the exhaust gas temperature sensor cylinder 8 (B4)
  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1532 inactive, Fault Code 671 active?
YES NO
No Repair

Repair

Replace the CM850 module.

  • Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the CM850 harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from the CM850 module.

Action

Inspect the CM850 module harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or CM850 module connector.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connectors from cylinder 8 (B4) exhaust temperature sensor.

Action

Check the 5-VDC supply to the exhaust temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 8 (B4).
  • Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Go to next troubleshooting step.

Go to 4A

Go to 3D

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 8 (B4) SUPPLY pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 8 (B4) SIGNAL pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 8 (B4) RETURN pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the CM850 module.

  • Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the engine harness.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and engine operating for longer than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify the Fault Code 1532 is inactive.

Fault Code 1532 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes

Repair complete.

Appropriate troubleshooting steps

Last Modified: 08-May-2012


FAULT CODE 1533 - Exhaust Gas Temperature Sensor Cylinder 10 (B5) - Voltage Above Normal or Shorted to High Source (Multiple Turbochargers)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™/ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1533 active?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 10. |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 3. | Inspect the CENSE™ module and engine harness. |
 | STEP 3A. Check the ECM response. | Fault Code 1533 inactive and Fault Code 725 active?
 | STEP 3B. Check the CENSE™ harness and connector pins. | CENSE™ module harness and connector pins OK?
 | STEP 3C. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1533 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1533 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas temperature circuit cylinder 10.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the exhaust gas temperature sensor connector cylinder 10 from the exhaust gas temperature sensor.

Action

Inspect the engine harness and the exhaust gas temperature sensor circuit cylinder 10 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 10 or in the engine harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 10 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 10 SIGNAL pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 10 RETURN pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors in pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the exhaust gas temperature sensor connector cylinder 10.

  • Repair the engine harness or the exhaust gas temperature sensor connector cylinder 10.
  • Replace the engine harness or exhaust gas temperature sensor connector cylinder 10.
  • Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the CENSE™ module and engine harness.

Guided Step 3A - Check the ECM response.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connector from the exhaust gas temperature sensor cylinder 10.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1533 inactive and Fault Code 725 active?
YES NO
No Repair

Repair

Replace the CENSE™ module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the CENSE™ harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CENSE™ module.

Action

Inspect the CENSE™ module harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

CENSE™ module harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or CENSE™ module connector.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CENSE™ module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 10 SIGNAL pin in the engine harness CENSE™ module connector to all other pins in the engine harness CENSE™ module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 10 RETURN pin in the engine harness CENSE™ module connector to all other pins in the engine harness CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and engine running for greater than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1533 is inactive.

Fault Code 1533 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Mar-2011


FAULT CODE 1533 - (Single Turbocharger) Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1533 active?
STEP 2. | Check the exhaust temperature sensor circuit cylinder 10 (B5). |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 3. | Inspect the CM850 module and engine harness. |
 | STEP 3A. Check the CM850 response. | Fault Code 1533 inactive, Fault Code 671 active?
 | STEP 3B. Inspect the CM850 module harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the 5-VDC supply to the exhaust temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 3D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1533 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1533 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 10 (B5).

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 10 (B5) exhaust temperature sensor.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector on cylinder 10 (B5).

Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 10 (B5) exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 10 (B5) SIGNAL pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 10 (B5) SUPPLY pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 10 (B5) RETURN pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness exhaust gas temperature sensor connector cylinder 10 (B5).

  • Repair the engine harness or exhaust gas temperature sensor connector cylinder 10 (B5).
  • Replace the engine harness or exhaust gas temperature sensor connector cylinder 10 (B5). Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the CM850 module and engine harness.

Guided Step 3A - Check the ECM response.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the OFF mode
  • Disconnect the engine harness connector from the exhaust gas temperature sensor cylinder 10 (B5)
  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1533 inactive, Fault Code 671 active?
YES NO
No Repair

Repair

Replace the CM850 module.

  • Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the CM850 harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from the CM850 module.

Action

Inspect the CM850 module harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or CM850 module connector.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connectors from cylinder 10 (B5) exhaust temperature sensor.

Action

Check the 5-VDC supply to the exhaust temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 10 (B5).
  • Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Go to next troubleshooting step.

Go to 4A

Go to 3D

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 10 (B5) SUPPLY pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 10 (B5) SIGNAL pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 10 (B5) RETURN pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the CM850 module.

  • Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the engine harness.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and engine operating for longer than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify the Fault Code 1533 is inactive.

Fault Code 1533 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes

Repair complete.

Appropriate troubleshooting steps

Last Modified: 08-May-2012


FAULT CODE 1534 - Exhaust Gas Temperature Sensor Cylinder 12 (B6) - Voltage Above Normal or Shorted to High Source (Multiple Turbochargers)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™/ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1534 active?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 12. |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 3. | Inspect the CENSE™ module and engine harness. |
 | STEP 3A. Check the ECM response. | Fault Code 1534 inactive and Fault Code 726 active?
 | STEP 3B. Check the CENSE™ harness and connector pins. | CENSE™ module harness and connector pins OK?
 | STEP 3C. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1534 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1534 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas temperature circuit cylinder 12.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the exhaust gas temperature sensor connector cylinder 12 from the exhaust gas temperature sensor.

Action

Inspect the engine harness and the exhaust gas temperature sensor circuit cylinder 12 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 12 or in the engine harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 12 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 12 SIGNAL pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 12 RETURN pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors in pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the exhaust gas temperature sensor connector cylinder 12.

  • Repair the engine harness or the exhaust gas temperature sensor connector cylinder 12.
  • Replace the engine harness or exhaust gas temperature sensor connector cylinder 12.
  • Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the CENSE™ module and engine harness.

Guided Step 3A - Check the ECM response.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connector from the exhaust gas temperature sensor cylinder 12.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1534 inactive and Fault Code 726 active?
YES NO
No Repair

Repair

Replace the CENSE™ module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the CENSE™ harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CENSE™ module.

Action

Inspect the CENSE™ module harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

CENSE™ module harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or CENSE™ module connector.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CENSE™ module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 12 SIGNAL pin in the engine harness CENSE™ module connector to all other pins in the engine harness CENSE™ module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 12 RETURN pin in the engine harness CENSE™ module connector to all other pins in the engine harness CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and engine running for greater than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1534 is inactive.

Fault Code 1534 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Mar-2011


FAULT CODE 1534 - (Single Turbocharger) Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1534 active?
STEP 2. | Check the exhaust temperature sensor circuit cylinder 12 (B6). |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 3. | Inspect the CM850 module and engine harness. |
 | STEP 3A. Check the CM850 response. | Fault Code 1534 inactive, Fault Code 671 active?
 | STEP 3B. Inspect the CM850 module harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the 5-VDC supply to the exhaust temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 3D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1534 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1534 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 12 (B6).

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 12 (B6) exhaust temperature sensor.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector on cylinder 12 (B6).

Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 12 (B6) exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 12 (B6) SIGNAL pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 12 (B6) SUPPLY pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 12 (B6) RETURN pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness exhaust gas temperature sensor connector cylinder 12 (B6).

  • Repair the engine harness or exhaust gas temperature sensor connector cylinder 12 (B6).
  • Replace the engine harness or exhaust gas temperature sensor connector cylinder 12 (B6). Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the CM850 module and engine harness.

Guided Step 3A - Check the ECM response.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the OFF mode
  • Disconnect the engine harness connector from the exhaust gas temperature sensor cylinder 12 (B6)
  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1534 inactive, Fault Code 671 active?
YES NO
No Repair

Repair

Replace the CM850 module.

  • Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the CM850 harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from the CM850 module.

Action

Inspect the CM850 module harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or CM850 module connector.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connectors from cylinder 12 (B6) exhaust temperature sensor.

Action

Check the 5-VDC supply to the exhaust temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 12 (B6).
  • Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Go to next troubleshooting step.

Go to 4A

Go to 3D

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 12 (B6) SUPPLY pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 12 (B6) SIGNAL pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 12 (B6) RETURN pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the CM850 module.

  • Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the engine harness.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and engine operating for longer than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify the Fault Code 1534 is inactive.

Fault Code 1534 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes

Repair complete.

Appropriate troubleshooting steps

Last Modified: 08-May-2012


FAULT CODE 1535 - Exhaust Gas Temperature Sensor Cylinder 14 (B7) - Voltage Above Normal or Shorted to High Source (Multiple Turbochargers)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™/ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1535 active?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 14. |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 3. | Inspect the CENSE™ module and engine harness. |
 | STEP 3A. Check the ECM response. | Fault Code 1535 inactive and Fault Code 727 active?
 | STEP 3B. Check the CENSE™ harness and connector pins. | CENSE™ module harness and connector pins OK?
 | STEP 3C. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1535 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1535 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas temperature circuit cylinder 14.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the exhaust gas temperature sensor connector cylinder 14 from the exhaust gas temperature sensor.

Action

Inspect the engine harness and the exhaust gas temperature sensor circuit cylinder 14 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 14 or in the engine harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 14 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 14 SIGNAL pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 14 RETURN pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors in pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the exhaust gas temperature sensor connector cylinder 14.

  • Repair the engine harness or the exhaust gas temperature sensor connector cylinder 14.
  • Replace the engine harness or exhaust gas temperature sensor connector cylinder 14.
  • Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the CENSE™ module and engine harness.

Guided Step 3A - Check the ECM response.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connector from the exhaust gas temperature sensor cylinder 14.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1535 inactive and Fault Code 727 active?
YES NO
No Repair

Repair

Replace the CENSE™ module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the CENSE™ harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CENSE™ module.

Action

Inspect the CENSE™ module harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

CENSE™ module harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or CENSE™ module connector.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CENSE™ module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 14 SIGNAL pin in the engine harness CENSE™ module connector to all other pins in the engine harness CENSE™ module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 14 RETURN pin in the engine harness CENSE™ module connector to all other pins in the engine harness CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and engine running for greater than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1535 is inactive.

Fault Code 1535 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Mar-2011


FAULT CODE 1535 - (Single Turbocharger) Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7)4 (B7) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1535 active?
STEP 2. | Check the exhaust temperature sensor circuit cylinder 14 (B7). |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 3. | Inspect the CM850 module and engine harness. |
 | STEP 3A. Check the CM850 response. | Fault Code 1535 inactive, Fault Code 671 active?
 | STEP 3B. Inspect the CM850 module harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the 5-VDC supply to the exhaust temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 3D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1535 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1535 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 14 (B7).

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 14 (B7) exhaust temperature sensor.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector on cylinder 14 (B7).

Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 14 (B7) exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 14 (B7) SIGNAL pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 14 (B7) SUPPLY pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 14 (B7) RETURN pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness exhaust gas temperature sensor connector cylinder 14 (B7).

  • Repair the engine harness or exhaust gas temperature sensor connector cylinder 14 (B7).
  • Replace the engine harness or exhaust gas temperature sensor connector cylinder 14 (B7). Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the CM850 module and engine harness.

Guided Step 3A - Check the ECM response.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the OFF mode
  • Disconnect the engine harness connector from the exhaust gas temperature sensor cylinder 14 (B7)
  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1535 inactive, Fault Code 671 active?
YES NO
No Repair

Repair

Replace the CM850 module.

  • Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the CM850 harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from the CM850 module.

Action

Inspect the CM850 module harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or CM850 module connector.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connectors from cylinder 14 (B7) exhaust temperature sensor.

Action

Check the 5-VDC supply to the exhaust temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 14 (B7).
  • Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Go to next troubleshooting step.

Go to 4A

Go to 3D

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 14 (B7) SUPPLY pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 14 (B7) SIGNAL pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 14 (B7) RETURN pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the CM850 module.

  • Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the engine harness.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and engine operating for longer than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify the Fault Code 1535 is inactive.

Fault Code 1535 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes

Repair complete.

Appropriate troubleshooting steps

Last Modified: 08-May-2012


FAULT CODE 1536 - Exhaust Gas Temperature Sensor Cylinder 16 (B8) - Voltage Above Normal or Shorted to High Source (Multiple Turbochargers)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™/ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1536 active?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 16. |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 3. | Inspect the CENSE™ module and engine harness. |
 | STEP 3A. Check the ECM response. | Fault Code 1536 inactive and Fault Code 728 active?
 | STEP 3B. Check the CENSE™ harness and connector pins. | CENSE™ module harness and connector pins OK?
 | STEP 3C. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1536 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1536 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas temperature circuit cylinder 16.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the exhaust gas temperature sensor connector cylinder 16 from the exhaust gas temperature sensor.

Action

Inspect the engine harness and the exhaust gas temperature sensor circuit cylinder 16 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 16 or in the engine harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 16 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 16 SIGNAL pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 16 RETURN pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors in pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the exhaust gas temperature sensor connector cylinder 16.

  • Repair the engine harness or the exhaust gas temperature sensor connector cylinder 16.
  • Replace the engine harness or exhaust gas temperature sensor connector cylinder 16.
  • Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the CENSE™ module and engine harness.

Guided Step 3A - Check the ECM response.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connector from the exhaust gas temperature sensor cylinder 16.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1536 inactive and Fault Code 728 active?
YES NO
No Repair

Repair

Replace the CENSE™ module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the CENSE™ harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CENSE™ module.

Action

Inspect the CENSE™ module harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

CENSE™ module harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or CENSE™ module connector.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CENSE™ module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 16 SIGNAL pin in the engine harness CENSE™ module connector to all other pins in the engine harness CENSE™ module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 16 RETURN pin in the engine harness CENSE™ module connector to all other pins in the engine harness CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and engine running for greater than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1536 is inactive.

Fault Code 1536 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Mar-2011


FAULT CODE 1536 - (Single Turbocharger) Exhaust Gas Temperature Sensor Circuit Cylinder 16 (B8) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1536 active?
STEP 2. | Check the exhaust temperature sensor circuit cylinder 16 (B8). |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 3. | Inspect the CM850 module and engine harness. |
 | STEP 3A. Check the CM850 response. | Fault Code 1536 inactive, Fault Code 671 active?
 | STEP 3B. Inspect the CM850 module harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the 5-VDC supply to the exhaust temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 3D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1536 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1536 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 16 (B8).

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 16 (B8) exhaust temperature sensor.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector on cylinder 16 (B8).

Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 16 (B8) exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 16 (B8) SIGNAL pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 16 (B8) SUPPLY pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 16 (B8) RETURN pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness exhaust gas temperature sensor connector cylinder 16 (B8).

  • Repair the engine harness or exhaust gas temperature sensor connector cylinder 16 (B8).
  • Replace the engine harness or exhaust gas temperature sensor connector cylinder 16 (B8). Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the CM850 module and engine harness.

Guided Step 3A - Check the ECM response.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the OFF mode
  • Disconnect the engine harness connector from the exhaust gas temperature sensor cylinder 16 (B8)
  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1536 inactive, Fault Code 671 active?
YES NO
No Repair

Repair

Replace the CM850 module.

  • Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the CM850 harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from the CM850 module.

Action

Inspect the CM850 module harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or CM850 module connector.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connectors from cylinder 16 (B8) exhaust temperature sensor.

Action

Check the 5-VDC supply to the exhaust temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 16 (B8).
  • Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Go to next troubleshooting step.

Go to 4A

Go to 3D

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 16 (B8) SUPPLY pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 16 (B8) SIGNAL pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 16 (B8) RETURN pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the CM850 module.

  • Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the engine harness.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and engine operating for longer than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify the Fault Code 1536 is inactive.

Fault Code 1536 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes

Repair complete.

Appropriate troubleshooting steps

Last Modified: 08-May-2012


FAULT CODE 1546 - Engine Crankshaft Speed/Position Lost - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for an active fault code. |
 | STEP 1A. Check for an active fault code. | Fault Code 1546 active?
STEP 2. | Check the crankshaft engine speed sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged sensor or engine harness connector pins?
 | STEP 2B. Inspect the crankshaft engine speed sensor for damage. | Damaged crankshaft engine speed sensor?
 | STEP 2C. Check the crankshaft engine speed sensor resistance. | 750 to 1500 ohms?
 | STEP 2D. Check for short circuit to ground in the crankshaft engine speed sensor. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins or connector?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1546 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for an active fault code.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine at normal load conditions.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1546 active?
YES NO

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked.

Repair

Use INSITE™ electronic service tool to clear the inactive fault codes.

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the crankshaft engine speed sensor.

Guided Step 2A - Inspect the sensor and the engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the crankshaft engine speed sensor connector.

Action

Inspect the crankshaft engine speed sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged sensor or engine harness connector pins?
YES NO

Repair

Repair or replace the damaged engine harness connector or crankshaft engine speed sensor.

  • Repair or replace the damage connector. Refer to Procedure 019-206 in Section 19.
  • Replace the crankshaft engine speed sensor. Refer to Procedure 019-042 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the crankshaft engine speed sensor for damage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the crankshaft engine speed sensor connector.
  • Remove the crankshaft engine speed sensor.

Action

Inspect the crankshaft engine speed sensor for the following:

  • Metal debris on end of sensor
  • Damage to end of sensor caused by contacting the flywheel.
  • Oil leakage or insulation problems such as swelling.
  • Damaged electrical potting in sensing end of sensor.

Damaged crankshaft engine speed sensor?
YES NO

Repair

The crankshaft engine speed sensor is damaged.

  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.
No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the crankshaft engine speed sensor resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the crankshaft engine speed sensor connector.

Action

Check the resistance of the sensor.

  • Use a multimeter to measure the resistance of the crankshaft engine speed sesnor from the speed SIGNAL (+) pin to the speed RETURN (-) pin at the sensor connector.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

750 to 1500 ohms?
YES NO
No Repair

Repair

The crankshaft engine speed sensor has malfunctioned.

  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for short circuit to ground in the crankshaft engine speed sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the crankshaft engine speed sensor connector.

Action

Check the sensor for a short to ground.

  • Use a multimeter to measure the resistance of the crankshaft engine speed sensor from the speed SIGNAL (+) pin on the sensor to the engine ground.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

The crankshaft engine speed sensor is damaged.

  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700 module.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or connectors?
YES NO

Repair

Clean the connector and pins.

Replace the damaged pins.

Repair or replace the engine harnessor harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-206 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700 module.
  • Disconnect the engine harness from the crankshaft engine speed sensor.

Action

Use a multimeter to check for an open circuit in the engine harness.

  • Measure the resistance from the crankshaft engine speed SIGNAL (+) pin at the CM700 connector to the crankshaft engine speed SIGNAL (+) pin at the crankshaft engine speed sensor connector.
  • Measure the resistance from the crankshaft engine speed RETURN (-) pin at the CM700 connector to the crankshaft speed RETURN (-) pin at the crankshaft engine speed sensor connector.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-206 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short to ground in the engine harness.

Conditions

  • Keyswitch circuit de-energized.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700 module.
  • Disconnect the engine harness from the crankshaft engine speed sensor.

Action

Use a multimeter to check for a short circuit to ground in the engine harness.

  • Measure the resistance from the crankshaft engine speed SIGNAL (+) pin at the CM700 connector to the engine ground.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit to ground has been detected in the engine harness.

  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short in the engine harness.

Conditions

  • Keyswitch circuit de-energized.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700 module.
  • Disconnect the engine harness from the crankshaft engine speed sensor.

Action

Use a multimeter to check for a pin-to-pin short in the engine harness:

  • Measure the resistance from the crankshaft engine speed SIGNAL (+) pin at the CM700 connector to all other pins in the CM700 connector.
  • Measure the resistance from the crankshaft engine speed RETURN (-) pin at the CM700 connector to all other pins in the CM700 connector.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short has been detected in the engine harness.

  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate engine for longer than 1 minute.

Action

Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 1546 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 07-Jan-2011


FAULT CODE 1579 - Engine Cylinder Number 12 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 146, 151, 155, 488, 1285, 1295, 1579, 1581, 1582, 2281, 2282, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2531 and 2532 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specifications?
STEP 3. | Check the kilowatt load reference signal calibration. |
 | STEP 3A. Check the kilowatt load transducer reference signal - where fitted. | Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
 | STEP 3B. Check the calibration of the generator set controller. | Generator set controller output voltage and ampere readings match the measured readings?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor resistances within specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor within specification?
STEP 6. | Check the quality of the natural gas supply to the generator set. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply quality within specification?
STEP 7. | Inspect cylinder number 12 cylinder head. |
 | STEP 7A. Check the cylinder number 12 spark plug. | Cylinder number 12 spark plug contaminated or damaged?
 | STEP 7B. Check the cylinder number 12 spark plug gap. | Cylinder number 12 spark plug gap excessive?
 | STEP 7C. Check the cylinder number 12 cylinder head. | Cylinder number 12 cylinder head gasket leaking or loose components?
 | STEP 7D. Check that the cylinder number 12 valve lash setting is correct. | Cylinder number 12 valve lash setting correct?
 | STEP 7E. Check the cylinder number 12 valve train. | Cylinder number 12 valve train wear?
STEP 8. | Inspect the cylinder number 12 power cylinder. |
 | STEP 8A. Inspect the oil filters for debris. | Debris present in the oil filters?
 | STEP 8B. Check the cylinder number 12 internal power cylinder. | Cylinder number 12 power cylinder damaged?
 | STEP 8C. Inspect the cylinder number 12 connecting rod bearings. | Cylinder number 12 connecting rod bearings worn or damaged?
 | STEP 8D. Inspect the cylinder number 12 piston cooling nozzle. | Cylinder number 12 piston cooling nozzle bent or broken?
 | STEP 8E. Check cylinder number1and adjacent cylinder main bearings. | Cylinder number 12 or immediately adjacent main bearings worn or damaged?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 2522 inactive?
 | STEP 9B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 146, 151, 155, 488, 1285, 1295, 1579, 1581, 1582, 2281, 2282, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2531, and 2532 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Use symptom tree t048 in Section TS in this manual.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electric service tool.
  • Connect an exhaust gas analyzer.
  • Operate the engine at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Check exhaust emissions.

  • Use an exhaust gas analyzer. Insert the sample probe into the exhaust gas manifold test port, check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specifications?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool and referencing to the exhaust gas analyzer, adjust the open and closed loop fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.

  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 9A

Guided Step 3 - Check the kilowatt load reference signal calibration.

Guided Step 3A - Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller kilowatt calibration.

Conditions

NOTE: If the generator set is not fitted with a kilowatt load transducer, proceed to Guided Step 3B.

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.
  • Connect INSITE™ electronic service tool.

Action

Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller displayed kilowatt calibration.

  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
YES NO
No Repair

Repair

INSITE™ electronic service tool, calibrate the kilowatt load sensor milliampere/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the calibration of the generator set controller.

Conditions

NOTE: This guided step should only be followed if the generator set is not fitted with a kilowatt load transducer.

  • Connect all components.
  • Connect a power analyzer or digital multimeter
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.

Action

Connect a power analyzer or digital multimeter to the alternator main output terminals.

  • Check that the generator set controller readings for output voltage (L1- L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller output voltage and ampere readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter to calibrate the generator set controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold temperature.

  • Use the generator set human machine interface (HMI) to check the intake manifold temperature. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold temperature within specification?
YES NO
No Repair

Repair

Check the following:

  • Check the temperature of the high temperature (HT) coolant outlet from the engine.
  • Check the temperature of the low temperature (LT) coolant outlet from the engine.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 018-018 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the intake manifold temperature sensor resistances.

  • NOTE: The intake manifold temperature sensor may have malfunctioned in range and the related fault codes will not be activated. Reference Fault Code 153 or Fault Code 154 in Section TF.
  • Refer to circuit diagram or wiring diagram for connector pin identification. Refer to Procedure 019-360 in Section 19.

Intake manifold temperature sensor resistances within specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor.

  • Refer to Procedure 019-059 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold pressure.

  • Use the generator set human machine interface (HMI) to check the intake manifold pressure. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold pressure within specification?
YES NO
No Repair

Repair

If fitted, check the operation of the compressor bypass valve (single turbocharger engines only).

  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the intake manifold pressure sensor.

NOTE: The intake manifold pressure sensor may have malfunctioned in-range and the related fault codes will not be activated.

  • Reference Fault Code 354 or Fault Code 355 in Section TF.
  • Refer to Procedure 019-359 in Section 19.

Intake manifold pressure sensor within specification?
YES NO
No Repair

Repair

Replace the intake manifold pressure sensor.

  • Refer to Procedure 019-061 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the generator set.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the quality of the natural gas supply.

  • Check the quality of the natural gas supplied to the generator set meets or exceeds minimum requirement for generator set (methane number and fuel contaminants limits).
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspect cylinder number 12 cylinder head.

Guided Step 7A - Check the cylinder number 12 spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug J connector damaged
  • Electrode has signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder number 12 spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug.
  • Replace the spark plug.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the cylinder number 12 spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Remove the spark plug and measure the spark plug electrode gap.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
  • Contact a Cummins® Authorized Repair Location.

Cylinder number 12 spark plug gap excessive?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7C

Guided Step 7C - Check the cylinder number 12 cylinder head.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect cylinder number 12 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder number 12 cylinder head.

Cylinder number 12 cylinder head gasket leaking or loose components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose components on or immediately around cylinder number 12 cylinder head. Reference the appropriate procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396.
No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check that the cylinder number 12 valve lash setting is correct.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder number 12 valve lash is correct.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder number 12 valve lash setting correct?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7E

Guided Step 7E - Check the cylinder number 12 valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the cylinder number 12 valve train for the following:

  • Intake or exhaust valve wear/recession or damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Camshaft follower wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder number 12 camshaft lobe wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Cylinder number 12 valve train wear?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft follower assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the camshaft. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

Adjust the valve lash. Reset the valve lash setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 9A

Go to 8A

Guided Step 8 - Inspect the cylinder number 12 power cylinder.

Guided Step 8A - Inspect the oil filters for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubrication oil filters. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filters and inspect for debris in the filter media.
  • Contact a Cummins® Authorized Repair Location.

Debris present in the oil filters?
YES | NO
No Repair | No Repair

Go to 8B

Go to 8D

Guided Step 8B - Check the cylinder number 12 internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the cylinder number 12 internal power cylinder.

Inspect the internal power cylinder for the following:

NOTE: If available, use a borescope to perform the inspections.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage.

Cylinder number 12 power cylinder damaged?
YES NO

Repair

Replace the piston rings. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.

Replace the liner. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-045 in Section 1.

Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the cylinder number 12 connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP.

Action

Inspect the cylinder number 12 connecting rod bearings for excessive wear or other damage.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder number 12 connecting rod bearings worn or damaged?
YES NO

Repair

Replace the connecting rods bearings:

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.
No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the cylinder number 12 piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the piston cooling nozzle.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder number 12 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.
No Repair

Go to 9A

Go to 8E

Guided Step 8E - Inspect cylinder number 12 and adjacent cylinder main bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect cylinder number 12 and adjacent cylinder main bearings.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

Cylinder number 12 or immediately adjacent main bearings worn or damaged?
YES NO

Repair

Replace the main bearings as required (cylinder 12 or immediately adjacent cylinders). Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

No Repair

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electronic service tool.
  • Operate the engine for longer than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2522 is inactive.

Fault Code 2522 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Authorized Cummins® Repair Location if all steps have been completed and checked again.

Go to 9B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 07-Jan-2011


FAULT CODE 1581 - Engine Cylinder Number 14 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 146, 151, 155, 488, 1285, 1295, 1579, 1581, 1582, 2281, 2282, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2531 and 2532 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specifications?
STEP 3. | Check the kilowatt load reference signal calibration. |
 | STEP 3A. Check the kilowatt load transducer reference signal - where fitted. | Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
 | STEP 3B. Check the calibration of the generator set controller. | Generator set controller output voltage and ampere readings match the measured readings?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor resistances within specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor within specification?
STEP 6. | Check the quality of the natural gas supply to the generator set. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply quality within specification?
STEP 7. | Inspect cylinder number 14 cylinder head. |
 | STEP 7A. Check the cylinder number 14 spark plug. | Cylinder number 14 spark plug contaminated or damaged?
 | STEP 7B. Check the cylinder number 14 spark plug gap. | Cylinder number 14 spark plug gap excessive?
 | STEP 7C. Check the cylinder number 14 cylinder head. | Cylinder number 14 cylinder head gasket leaking or loose components?
 | STEP 7D. Check that the cylinder number 14 valve lash setting is correct. | Cylinder number 14 valve lash setting correct?
 | STEP 7E. Check the cylinder number 14 valve train. | Cylinder number 14 valve train wear?
STEP 8. | Inspect the cylinder number 14 power cylinder. |
 | STEP 8A. Inspect the oil filters for debris. | Debris present in the oil filters?
 | STEP 8B. Check the cylinder number 14 internal power cylinder. | Cylinder number 14 power cylinder damaged?
 | STEP 8C. Inspect the cylinder number 14 connecting rod bearings. | Cylinder number 14 connecting rod bearings worn or damaged?
 | STEP 8D. Inspect the cylinder number 14 piston cooling nozzle. | Cylinder number 14 piston cooling nozzle bent or broken?
 | STEP 8E. Check cylinder number1and adjacent cylinder main bearings. | Cylinder number 14 or immediately adjacent main bearings worn or damaged?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 2522 inactive?
 | STEP 9B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 146, 151, 155, 488, 1285, 1295, 1579, 1581, 1582, 2281, 2282, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2531, and 2532 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Use symptom tree t048 in Section TS in this manual.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electric service tool.
  • Connect an exhaust gas analyzer.
  • Operate the engine at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Check exhaust emissions.

  • Use an exhaust gas analyzer. Insert the sample probe into the exhaust gas manifold test port, check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specifications?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool and referencing to the exhaust gas analyzer, adjust the open and closed loop fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.

  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 9A

Guided Step 3 - Check the kilowatt load reference signal calibration.

Guided Step 3A - Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller kilowatt calibration.

Conditions

NOTE: If the generator set is not fitted with a kilowatt load transducer, proceed to Guided Step 3B.

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.
  • Connect INSITE™ electronic service tool.

Action

Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller displayed kilowatt calibration.

  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
YES NO
No Repair

Repair

INSITE™ electronic service tool, calibrate the kilowatt load sensor milliampere/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the calibration of the generator set controller.

Conditions

NOTE: This guided step should only be followed if the generator set is not fitted with a kilowatt load transducer.

  • Connect all components.
  • Connect a power analyzer or digital multimeter
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.

Action

Connect a power analyzer or digital multimeter to the alternator main output terminals.

  • Check that the generator set controller readings for output voltage (L1- L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller output voltage and ampere readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter to calibrate the generator set controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold temperature.

  • Use the generator set human machine interface (HMI) to check the intake manifold temperature. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold temperature within specification?
YES NO
No Repair

Repair

Check the following:

  • Check the temperature of the high temperature (HT) coolant outlet from the engine.
  • Check the temperature of the low temperature (LT) coolant outlet from the engine.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 018-018 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the intake manifold temperature sensor resistances.

  • NOTE: The intake manifold temperature sensor may have malfunctioned in range and the related fault codes will not be activated. Reference Fault Code 153 or Fault Code 154 in Section TF.
  • Refer to circuit diagram or wiring diagram for connector pin identification. Refer to Procedure 019-360 in Section 19.

Intake manifold temperature sensor resistances within specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor.

  • Refer to Procedure 019-059 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold pressure.

  • Use the generator set human machine interface (HMI) to check the intake manifold pressure. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold pressure within specification?
YES NO
No Repair

Repair

If fitted, check the operation of the compressor bypass valve (single turbocharger engines only).

  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the intake manifold pressure sensor.

NOTE: The intake manifold pressure sensor may have malfunctioned in-range and the related fault codes will not be activated.

  • Reference Fault Code 354 or Fault Code 355 in Section TF.
  • Refer to Procedure 019-359 in Section 19.

Intake manifold pressure sensor within specification?
YES NO
No Repair

Repair

Replace the intake manifold pressure sensor.

  • Refer to Procedure 019-061 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the generator set.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the quality of the natural gas supply.

  • Check the quality of the natural gas supplied to the generator set meets or exceeds minimum requirement for generator set (methane number and fuel contaminants limits).
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspect cylinder number 14 cylinder head.

Guided Step 7A - Check the cylinder number 14 spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug J connector damaged
  • Electrode has signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder number 14 spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug.
  • Replace the spark plug.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the cylinder number 14 spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Remove the spark plug and measure the spark plug electrode gap.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
  • Contact a Cummins® Authorized Repair Location.

Cylinder number 14 spark plug gap excessive?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7C

Guided Step 7C - Check the cylinder number 14 cylinder head.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect cylinder number 14 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder number 14 cylinder head.

Cylinder number 14 cylinder head gasket leaking or loose components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose components on or immediately around cylinder number 14 cylinder head. Reference the appropriate procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396.
No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check that the cylinder number 14 valve lash setting is correct.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder number 14 valve lash is correct.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder number 14 valve lash setting correct?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7E

Guided Step 7E - Check the cylinder number 14 valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the cylinder number 14 valve train for the following:

  • Intake or exhaust valve wear/recession or damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Camshaft follower wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder number 14 camshaft lobe wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Cylinder number 14 valve train wear?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft follower assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the camshaft. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

Adjust the valve lash. Reset the valve lash setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 9A

Go to 8A

Guided Step 8 - Inspect the cylinder number 14 power cylinder.

Guided Step 8A - Inspect the oil filters for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubrication oil filters. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filters and inspect for debris in the filter media.
  • Contact a Cummins® Authorized Repair Location.

Debris present in the oil filters?
YES | NO
No Repair | No Repair

Go to 8B

Go to 8D

Guided Step 8B - Check the cylinder number 14 internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the cylinder number 14 internal power cylinder.

Inspect the internal power cylinder for the following:

NOTE: If available, use a borescope to perform the inspections.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage.

Cylinder number 14 power cylinder damaged?
YES NO

Repair

Replace the piston rings. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.

Replace the liner. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-045 in Section 1.

Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the cylinder number 14 connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP.

Action

Inspect the cylinder number 14 connecting rod bearings for excessive wear or other damage.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder number 14 connecting rod bearings worn or damaged?
YES NO

Repair

Replace the connecting rods bearings:

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.
No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the cylinder number 14 piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the piston cooling nozzle.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder number 14 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.
No Repair

Go to 9A

Go to 8E

Guided Step 8E - Inspect cylinder number 14 and adjacent cylinder main bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect cylinder number 14 and adjacent cylinder main bearings.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

Cylinder number 14 or immediately adjacent main bearings worn or damaged?
YES NO

Repair

Replace the main bearings as required (cylinder 14 or immediately adjacent cylinders). Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

No Repair

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electronic service tool.
  • Operate the engine for longer than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2522 is inactive.

Fault Code 2522 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Authorized Cummins® Repair Location if all steps have been completed and checked again.

Go to 9B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 07-Jan-2011


FAULT CODE 1582 - Engine Cylinder Number 16 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 146, 151, 155, 488, 1285, 1295, 1579, 1581, 1582, 2281, 2282, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2531 and 2532 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specifications?
STEP 3. | Check the kilowatt load reference signal calibration. |
 | STEP 3A. Check the kilowatt load transducer reference signal - where fitted. | Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
 | STEP 3B. Check the calibration of the generator set controller. | Generator set controller output voltage and ampere readings match the measured readings?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor resistances within specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor within specification?
STEP 6. | Check the quality of the natural gas supply to the generator set. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply quality within specification?
STEP 7. | Inspect cylinder number 16 cylinder head. |
 | STEP 7A. Check the cylinder number 16 spark plug. | Cylinder number 16 spark plug contaminated or damaged?
 | STEP 7B. Check the cylinder number 16 spark plug gap. | Cylinder number 16 spark plug gap excessive?
 | STEP 7C. Check the cylinder number 16 cylinder head. | Cylinder number 16 cylinder head gasket leaking or loose components?
 | STEP 7D. Check that the cylinder number 16 valve lash setting is correct. | Cylinder number 16 valve lash setting correct?
 | STEP 7E. Check the cylinder number 16 valve train. | Cylinder number 16 valve train wear?
STEP 8. | Inspect the cylinder number 16 power cylinder. |
 | STEP 8A. Inspect the oil filters for debris. | Debris present in the oil filters?
 | STEP 8B. Check the cylinder number 16 internal power cylinder. | Cylinder number 16 power cylinder damaged?
 | STEP 8C. Inspect the cylinder number 16 connecting rod bearings. | Cylinder number 16 connecting rod bearings worn or damaged?
 | STEP 8D. Inspect the cylinder number 16 piston cooling nozzle. | Cylinder number 16 piston cooling nozzle bent or broken?
 | STEP 8E. Check cylinder number1and adjacent cylinder main bearings. | Cylinder number 16 or immediately adjacent main bearings worn or damaged?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 2522 inactive?
 | STEP 9B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 146, 151, 155, 488, 1285, 1295, 1579, 1581, 1582, 2281, 2282, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2531, and 2532 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Use symptom tree t048 in Section TS in this manual.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electric service tool.
  • Connect an exhaust gas analyzer.
  • Operate the engine at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Check exhaust emissions.

  • Use an exhaust gas analyzer. Insert the sample probe into the exhaust gas manifold test port, check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specifications?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool and referencing to the exhaust gas analyzer, adjust the open and closed loop fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.

  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 9A

Guided Step 3 - Check the kilowatt load reference signal calibration.

Guided Step 3A - Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller kilowatt calibration.

Conditions

NOTE: If the generator set is not fitted with a kilowatt load transducer, proceed to Guided Step 3B.

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.
  • Connect INSITE™ electronic service tool.

Action

Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller displayed kilowatt calibration.

  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
YES NO
No Repair

Repair

INSITE™ electronic service tool, calibrate the kilowatt load sensor milliampere/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the calibration of the generator set controller.

Conditions

NOTE: This guided step should only be followed if the generator set is not fitted with a kilowatt load transducer.

  • Connect all components.
  • Connect a power analyzer or digital multimeter
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.

Action

Connect a power analyzer or digital multimeter to the alternator main output terminals.

  • Check that the generator set controller readings for output voltage (L1- L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller output voltage and ampere readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter to calibrate the generator set controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold temperature.

  • Use the generator set human machine interface (HMI) to check the intake manifold temperature. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold temperature within specification?
YES NO
No Repair

Repair

Check the following:

  • Check the temperature of the high temperature (HT) coolant outlet from the engine.
  • Check the temperature of the low temperature (LT) coolant outlet from the engine.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 018-018 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the intake manifold temperature sensor resistances.

  • NOTE: The intake manifold temperature sensor may have malfunctioned in range and the related fault codes will not be activated. Reference Fault Code 153 or Fault Code 154 in Section TF.
  • Refer to circuit diagram or wiring diagram for connector pin identification. Refer to Procedure 019-360 in Section 19.

Intake manifold temperature sensor resistances within specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor.

  • Refer to Procedure 019-059 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold pressure.

  • Use the generator set human machine interface (HMI) to check the intake manifold pressure. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold pressure within specification?
YES NO
No Repair

Repair

If fitted, check the operation of the compressor bypass valve (single turbocharger engines only).

  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the intake manifold pressure sensor.

NOTE: The intake manifold pressure sensor may have malfunctioned in-range and the related fault codes will not be activated.

  • Reference Fault Code 354 or Fault Code 355 in Section TF.
  • Refer to Procedure 019-359 in Section 19.

Intake manifold pressure sensor within specification?
YES NO
No Repair

Repair

Replace the intake manifold pressure sensor.

  • Refer to Procedure 019-061 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the generator set.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the quality of the natural gas supply.

  • Check the quality of the natural gas supplied to the generator set meets or exceeds minimum requirement for generator set (methane number and fuel contaminants limits).
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspect cylinder number 16 cylinder head.

Guided Step 7A - Check the cylinder number 16 spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug J connector damaged
  • Electrode has signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder number 16 spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug.
  • Replace the spark plug.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the cylinder number 16 spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Remove the spark plug and measure the spark plug electrode gap.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
  • Contact a Cummins® Authorized Repair Location.

Cylinder number 16 spark plug gap excessive?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7C

Guided Step 7C - Check the cylinder number 16 cylinder head.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect cylinder number 16 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder number 16 cylinder head.

Cylinder number 16 cylinder head gasket leaking or loose components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose components on or immediately around cylinder number 16 cylinder head. Reference the appropriate procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396.
No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check that the cylinder number 16 valve lash setting is correct.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder number 16 valve lash is correct.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder number 16 valve lash setting correct?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7E

Guided Step 7E - Check the cylinder number 16 valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the cylinder number 16 valve train for the following:

  • Intake or exhaust valve wear/recession or damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Camshaft follower wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder number 16 camshaft lobe wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Cylinder number 16 valve train wear?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft follower assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the camshaft. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

Adjust the valve lash. Reset the valve lash setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 9A

Go to 8A

Guided Step 8 - Inspect the cylinder number 16 power cylinder.

Guided Step 8A - Inspect the oil filters for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubrication oil filters. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filters and inspect for debris in the filter media.
  • Contact a Cummins® Authorized Repair Location.

Debris present in the oil filters?
YES | NO
No Repair | No Repair

Go to 8B

Go to 8D

Guided Step 8B - Check the cylinder number 16 internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the cylinder number 16 internal power cylinder.

Inspect the internal power cylinder for the following:

NOTE: If available, use a borescope to perform the inspections.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage.

Cylinder number 16 power cylinder damaged?
YES NO

Repair

Replace the piston rings. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.

Replace the liner. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-045 in Section 1.

Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the cylinder number 16 connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP.

Action

Inspect the cylinder number 16 connecting rod bearings for excessive wear or other damage.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder number 16 connecting rod bearings worn or damaged?
YES NO

Repair

Replace the connecting rods bearings:

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.
No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the cylinder number 16 piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the piston cooling nozzle.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder number 16 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.
No Repair

Go to 9A

Go to 8E

Guided Step 8E - Inspect cylinder number 16 and adjacent cylinder main bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect cylinder number 16 and adjacent cylinder main bearings.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

Cylinder number 16 or immediately adjacent main bearings worn or damaged?
YES NO

Repair

Replace the main bearings as required (cylinder 16 or immediately adjacent cylinders). Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

No Repair

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electronic service tool.
  • Operate the engine for longer than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2522 is inactive.

Fault Code 2522 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Authorized Cummins® Repair Location if all steps have been completed and checked again.

Go to 9B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 07-Jan-2011


FAULT CODE 1583 - Engine Cylinder Number 16 Knock - Data Valid but Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1213, 1274, 1281, 1286, 1291, 1296, 1583, and 2282 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specification?
STEP 3. | Check the kilowatt load reference signal. |
 | STEP 3A. Check the kilowatt load transducer sensed killowatts against the generator set controller killowatts. | Kilowatt load transducer-sensed kilowatts match generator set controller kilowatts?
 | STEP 3B. Check the generator set controller calibration. | Generator set controller output voltage and ampere output calibration correct?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor supply voltages and reference resistances within specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor supply and reference voltages within specification?
STEP 6. | Check the quality of the natural gas supply to the generator set. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply meets or exceeds minimum specification for generator set?
STEP 7. | Inspection of cylinder 16 cylinder head. |
 | STEP 7A. Check spark plug. | Spark plug contaminated or damaged?
 | STEP 7B. Check spark plug gap. | Spark plug gap excessive?
 | STEP 7C. Inspect the cylinder head. | Leaking gaskets or loose components?
 | STEP 7D. Check the valve lash. | Valve lash correct?
 | STEP 7E. Inspect the valve train. | Worn or mis-set valve train components?
STEP 8. | Inspect cylinder 16 power cylinder. |
 | STEP 8A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 8B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 8C. Inspect connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 8D. Inspect piston cooling nozzle. | Piston cooling nozzle bent or missing?
 | STEP 8E. Inspect cylinder 16 and adjacent cylinders main bearings. | Main bearings damaged?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 1583 inactive?
 | STEP 9B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1213, 1274, 1281, 1286, 1291, 1296, 1583, and 2282 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.
  • Go to the Engine Noise Excessive - Combustion Knocks troubleshooting symptom tree.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and operate at the highest load possible with no knock - must be at a minimum 70 percent load.
  • Connect an exhaust gas analyzer.
  • Connect INSITE™ electronic service tool.

Action

Measure the exhaust emissions.

  • Use an exhaust gas analyzer, with the sample probe inserted into the exhaust gas manifold test port, to check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure for exhaust emission specifications in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specification?
YES NO
No Repair

Repair

  • Use INSITE™ electronic service tool and reference the exhaust gas analyzer. Adjust the open and closed loop fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.
  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 9A

Guided Step 3 - Check the kilowatt load reference signal.

Guided Step 3A - Check the kilowatt load transducer sensed killowatts against the generator set controller killowatts.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode with load available.
  • Connect INSITE™ electronic service tool.

Action

Check the kilowatt load transducer reference signal.

  • Check the kilowatt load transducer sensed kilowatts against the generator set controller displayed kilowatts.
  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer sensed kilowatts match generator set controller kilowatts?
YES NO
No Repair

Repair

  • Use INSITE™ electronic service tool to calibrate the kilowatt load sensor milliamp / load reference signal.
  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the calibration of the generator set controller.

Conditions

NOTE: This guided step should only be followed for generator sets without a kilowatt load transducer installed.

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode with load available.
  • Connect a power analyzer or digital multimeter.

Action

Check the calibration of the generator set controller.

  • Connect a power analyzer or digital multimeter to the alternator main output terminals.
  • Check that the generator set controller readings for output voltage (L1- L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller output voltage and ampere readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter to calibrate the generator set controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode, operating at maximum possible load with no knock present.

Action

Check the intake manifold temperature.

  • Use the generator set Human Machine Interface (HMI) to check the intake manifold temperature. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold temperature within specification?
YES NO
No Repair

Repair

Check the following:

  • Check the temperature of the High Temperature (HT) coolant outlet from the engine. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-018 in Section V.
  • Check the temperature of the Low Temperature (LT) coolant outlet from the engine. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-018 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check the intake manifold temperature sensor.

  • Check the intake manifold temperature sensor resistances.
  • NOTE: The intake manifold temperature sensor may have malfunctioned in-range and the related fault codes will not be activated. Go to Fault Code 153 or Fault Code 154.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
  • Go to the appropriate specifications in Section V.

Intake manifold temperature sensor resistances to specification?
YES NO
No Repair

Repair

  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure sensor.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode, operating at maximum possible load with no knock present.

Action

Check the intake manifold pressure.

  • Use the generator set Human Machine Interface (HMI) to check the intake manifold pressure. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold pressure within specification?
YES NO
No Repair

Repair

Check the following:

  • If installed, check the operation of the compressor bypass valve (single turbochargers engines only).
  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check the intake manifold pressure sensor.

NOTE: The intake manifold pressure sensor may have malfunctioned in-range and the related fault codes will not be activated. Go to Fault Code 354 or Fault Code 355 in Section TF.

  • Refer to Procedure 019-359 in Section 19.
  • Use the appropriate specifications information in Section V.

Intake manifold pressure sensor to specification?
YES NO
No Repair

Repair

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the generator set.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check the quality of the natural gas supply.

  • Check that the quality of the natural gas supplied to the generator set meets or exceeds minimum requirement for the generator set (methane number and fuel contaminants limits). Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspection of cylinder 16 cylinder head.

Guided Step 7A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check the spark plug.

Inspect the spark plug for the following:

  • Spark plug is installed correctly
  • Spark plug”J” connector is damaged.
  • Inspect the electrode for signs of oil contamination.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder 16 spark plug contaminated or damaged?
YES NO

Repair

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.
  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check the spark plug gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder 16 spark plug gap excessive?
YES NO

Repair

  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7C

Guided Step 7C - Inspect the cylinder head.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Inspect the cylinder head.

Inspect the cylinder 16 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder 16 cylinder head.

Cylinder 16 cylinder head leaking gaskets or loose components?
YES NO

Repair

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose components on or immediately around cylinder 16 cylinder head. Use the appropriate procedures in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396.
No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check the valve lash.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check the valve lash.

  • Check that the cylinder 16 valve lash setting is correct. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 16 valve lash setting correct?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7E

Guided Step 7E - Inspect the valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Inspect cylinder 16 valve train for the following:

  • Inlet or exhaust valve wear/recession or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Cam follower wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 3.
  • Cylinder 16 camshaft lobe wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Cylinder 16 valve train wear?
YES NO

Repair

Replace the damaged components.

  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the cam follower assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 3.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

Adjust the valve lash. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 9A

Go to 8A

Guided Step 8 - Inspect cylinder 16 power cylinder.

Guided Step 8A - Cut open the oil filters and inspect for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Inspect the oil filters for debris..

  • Remove the lubricating oil filter. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Repair

Proceed to the next troubleshooting step.

 No Repair

Go to 8B

Go to 8D

Guided Step 8B - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Inspect the internal power cylinder for the following:

NOTE: If available, the inspection can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 16 power cylinder damaged?
YES NO

Repair

Replace the damaged components.

  • Replace the piston rings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Replace the cylinder liner. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Inspect the connecting rod bearings.

  • Inspect cylinder 16 connecting rod bearings for excessive wear or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder 16 connecting rod bearings damaged?
YES NO

Repair

Replace the connecting rod bearings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Inspect the piston cooling nozzle.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder 16 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

No Repair

Go to 9A

Go to 8E

Guided Step 8E - Inspect cylinder 16 and immediately adjacent main bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Inspect cylinder 16 and immediately adjacent main bearings.

  • Inspect cylinder 16 and immediately adjacent main bearings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

Cylinder 16 or immediately adjacent main bearings worn or damaged?
YES NO

Repair

Replace the main bearings as required (cylinder 16 or immediately adjacent cylinders).

  • Replace the main bearings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.
No Repair

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and operate engine for longer than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 1583 is inactive.

Fault code 1583 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 9B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes

Repair Complete

Appropriate troubleshooting chart

Last Modified: 04-Jan-2011


FAULT CODE 1584 - Engine Cylinder Number 16 Knock - Voltage below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead; Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead; Part Number 3824811 - male Deutsch™ test lead and Part Number 3824812 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1584 active?
STEP 2. | Check the wiring harness |
 | STEP 2A. Check that the knock sensor wiring harness is connected to the knock sensor. | Knock sensor wiring harness connected?
 | STEP 2B. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 3. | Check the knock sensor. |
 | STEP 3A. Check that the knock sensor is correctly tightened. | Knock sensor tightened to 20 N•m [177 in-lb]?
 | STEP 3B. Test the knock sensor. | Fault Code 1297 active?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1584 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1584 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.
  • Go to the Engine Noise Excessive Combustion Knocks troubleshooting symptom tree.

Go to 2A

Go to 4A

Guided Step 2 - Check the wiring harness

Guided Step 2A - Check that the knock sensor harness is connected to the knock sensor.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check that the knock sensor harness is connected to the knock sensor.

  • Check that the knock sensor wiring harness is connected to the knock sensor. Refer to Procedure 019-346 in Section 19.

Knock sensor harness connected?
YES NO
No Repair

Repair

  • Connect the knock sensor harness to the knock sensor. Refer to Procedure 019-346 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the wiring harness and connector pins.

Conditions

  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM558 connector B.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Disconnect the knock sensor harness from the knock sensor.
  • Disconnect the CM558 connector B.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check for an open circuit.

  • Measure the resistance from knock cylinder number 16 SIGNAL pin in the knock sensor connector to the knock cylinder number 16 SIGNAL pin in the CM558 connector B.
  • Measure the resistance from knock cylinder number 16 RETURN pin in the knock sensor connector to the knock cylinder number 16 RETURN pin in the CM558 connector B.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit from pin to pin.

Conditions

  • Disconnect the knock sensor harness from the knock sensor.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from knock cylinder number 16 SIGNAL pin in the knock sensor harness connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the knock sensor.

Guided Step 3A - Check that the knock sensor is correctly tightened.

Conditions

  • Disconnect the knock sensor harness from the knock sensor.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check that the knock sensor is correctly tightened.

  • Check that the knock sensor is tightened to the correct torque value. Refer to Procedure 019-346 in Section 19.

Knock sensor tightened to 20 N•m [177 in-lb]?
YES NO
No Repair

Repair

  • Tighten the knock sensor. Refer to Procedure 019-346 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Test the knock sensor.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode (only RUN the engine after relocating the cylinder 16 knock sensor to cylinder 15) and engine operating for longer than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Test the knock sensor.

  • Move the knock sensor from cylinder head 16 to cylinder head 15. Install the knock sensor from cylinder head 15 to cylinder head 16. Refer to Procedure 019-346 in Section 19.
  • Place the run/stop/auto switch in the RUN mode and operate the engine for greater than 1 minute. Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 101-014 in Section 1.

Is Fault Code 1297 active?
YES NO

Repair

Replace the knock sensor. Refer to Procedure 019-346 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and engine operating longer than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 1584 is inactive.

Fault Code 1584 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate troubleshooting chart

Last Modified: 04-Jan-2011


FAULT CODE 1618 - Exhaust Gas Temperature Sensor Cylinder 1 (A1) - Voltage Above Normal or Shorted to High Source (Multiple Turbochargers)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™/ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1618 active?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 1. |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 3. | Inspect the CENSE™ module and engine harness. |
 | STEP 3A. Check the ECM response. | Fault Code 1618 inactive and Fault Code 671 active?
 | STEP 3B. Check the CENSE™ harness and connector pins. | CENSE™ module harness and connector pins OK?
 | STEP 3C. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1618 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1618 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas temperature circuit cylinder 1.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the exhaust gas temperature sensor connector cylinder 1 from the exhaust gas temperature sensor.

Action

Inspect the engine harness and the exhaust gas temperature sensor circuit cylinder 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 1 or in the engine harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 1 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 1 SIGNAL pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 1 RETURN pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors in pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the exhaust gas temperature sensor connector cylinder 1.

  • Repair the engine harness or the exhaust gas temperature sensor connector cylinder 1.
  • Replace the engine harness or exhaust gas temperature sensor connector cylinder 1.
  • Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the CENSE™ module and engine harness.

Guided Step 3A - Check the ECM response.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connector from the exhaust gas temperature sensor cylinder 1.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1618 inactive and Fault Code 671 active?
YES NO
No Repair

Repair

Replace the CENSE™ module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the CENSE™ harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CENSE™ module.

Action

Inspect the CENSE™ module harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

CENSE™ module harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or CENSE™ module connector.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CENSE™ module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 1 SIGNAL pin in the engine harness CENSE™ module connector to all other pins in the engine harness CENSE™ module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 1 RETURN pin in the engine harness CENSE™ module connector to all other pins in the engine harness CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and engine running for greater than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1618 is inactive.

Fault Code 1618 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 07-Mar-2011


FAULT CODE 1618 - (Single Turbocharger) Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1618 active?
STEP 2. | Check the exhaust temperature sensor circuit cylinder 1. |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 3. | Inspect the CM850 module and engine harness. |
 | STEP 3A. Check the CM850 response. | Fault Code 1618 inactive, Fault Code 671 active?
 | STEP 3B. Inspect the CM850 module harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the 5-VDC supply to the exhaust temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 3D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1618 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1618 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 1.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 1 exhaust temperature sensor.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector on cylinder 1.

Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 1 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 1 SIGNAL pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 1 SUPPLY pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 1 RETURN pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness exhaust gas temperature sensor connector cylinder 1.

  • Repair the engine harness or exhaust gas temperature sensor connector cylinder 1.
  • Replace the engine harness or exhaust gas temperature sensor connector cylinder 1. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the CM850 module and engine harness.

Guided Step 3A - Check the ECM response.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the OFF mode
  • Disconnect the engine harness connector from the exhaust gas temperature sensor cylinder 1
  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1618 inactive, Fault Code 671 active?
YES NO
No Repair

Repair

Replace the CM850 module.

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the CM850 harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from the CM850 module.

Action

Inspect the CM850 module harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or CM850 module connector.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connectors from cylinder 1 exhaust temperature sensor.

Action

Check the 5-VDC supply to the exhaust temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 1.
  • Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Go to next troubleshooting step.

Go to 4A

Go to 3D

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 1 SUPPLY pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 1 SIGNAL pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 1 RETURN pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the CM850 module.

  • Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the engine harness.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and engine operating for longer than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify the Fault Code 1618 is inactive.

Fault Code 1618 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes

Repair complete.

Appropriate troubleshooting steps

Last Modified: 30-Dec-2010


FAULT CODE 1619 - Exhaust Gas Temperature Sensor Cylinder 4 (B2) - Voltage Above Normal or Shorted to High Source (Multiple Turbochargers)

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3824811 - male Deutsch™/ test lead, Part Number 3824812 - female Deutsch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1619 active?
STEP 2. | Check the exhaust gas temperature sensor circuit cylinder 4. |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 3. | Inspect the CENSE™ module and engine harness. |
 | STEP 3A. Check the ECM response. | Fault Code 1619 inactive and Fault Code 722 active?
 | STEP 3B. Check the CENSE™ harness and connector pins. | CENSE™ module harness and connector pins OK?
 | STEP 3C. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1619 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault code.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1619 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas temperature circuit cylinder 4.

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the exhaust gas temperature sensor connector cylinder 4 from the exhaust gas temperature sensor.

Action

Inspect the engine harness and the exhaust gas temperature sensor circuit cylinder 4 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

A damaged connection has been detected in the exhaust gas temperature sensor circuit cylinder 4 or in the engine harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 4 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 4 SIGNAL pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 4 RETURN pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors in pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the exhaust gas temperature sensor connector cylinder 4.

  • Repair the engine harness or the exhaust gas temperature sensor connector cylinder 4.
  • Replace the engine harness or exhaust gas temperature sensor connector cylinder 4.
  • Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the CENSE™ module and engine harness.

Guided Step 3A - Check the ECM response.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connector from the exhaust gas temperature sensor cylinder 4.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1619 inactive and Fault Code 722 active?
YES NO
No Repair

Repair

Replace the CENSE™ module. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the CENSE™ harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CENSE™ module.

Action

Inspect the CENSE™ module harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Reference the wiring diagram for the harness termination and location.

CENSE™ module harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, and moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or CENSE™ module connector.
  • Replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CENSE™ module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 4 SIGNAL pin in the engine harness CENSE™ module connector to all other pins in the engine harness CENSE™ module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 4 RETURN pin in the engine harness CENSE™ module connector to all other pins in the engine harness CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify the connectors and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and engine running for greater than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that Fault Code 1619 is inactive.

Fault Code 1619 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-Mar-2011


FAULT CODE 1619 - (Single Turbocharger) Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1619 active?
STEP 2. | Check the exhaust temperature sensor circuit cylinder 4 (B2). |
 | STEP 2A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 3. | Inspect the CM850 module and engine harness. |
 | STEP 3A. Check the CM850 response. | Fault Code 1619 inactive, Fault Code 671 active?
 | STEP 3B. Inspect the CM850 module harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the 5-VDC supply to the exhaust temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 3D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1619 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1619 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the exhaust gas temperature sensor circuit cylinder 4 (B2).

Guided Step 2A - Inspect the exhaust gas temperature sensor circuit harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 4 (B2) exhaust temperature sensor.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector on cylinder 4 (B2).

Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 2B

Go to 4A

Guided Step 2B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 4 (B2) exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 4 (B2) SIGNAL pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 4 (B2) SUPPLY pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 4 (B2) RETURN pin in the exhaust gas temperature sensor connector to all other pins in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness exhaust gas temperature sensor connector cylinder 4 (B2).

  • Repair the engine harness or exhaust gas temperature sensor connector cylinder 4 (B2).
  • Replace the engine harness or exhaust gas temperature sensor connector cylinder 4 (B2). Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Inspect the CM850 module and engine harness.

Guided Step 3A - Check the ECM response.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the OFF mode
  • Disconnect the engine harness connector from the exhaust gas temperature sensor cylinder 4 (B2)
  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1619 inactive, Fault Code 671 active?
YES NO
No Repair

Repair

Replace the CM850 module.

  • Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check the CM850 harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from the CM850 module.

Action

Inspect the CM850 module harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness or CM850 module connector.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connectors from cylinder 4 (B2) exhaust temperature sensor.

Action

Check the 5-VDC supply to the exhaust temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 4 (B2).
  • Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Go to next troubleshooting step.

Go to 4A

Go to 3D

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 4 (B2) SUPPLY pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 4 (B2) SIGNAL pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Measure the resistance of the harness from the exhaust gas temperature sensor cylinder 4 (B2) RETURN pin in the engine harness CM850 module connector to all other pins in the engine harness CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the CM850 module.

  • Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the engine harness.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and engine operating for longer than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify the Fault Code 1619 is inactive.

Fault Code 1619 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes

Repair complete.

Appropriate troubleshooting steps

Last Modified: 09-May-2012


FAULT CODE 1737 - Engine Throttle Control Actuator - Bad Intelligent Device or Component

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes and high counts of inactive fault codes. | Active fault codes and/or high counts of inactive fault codes?
STEP 2. | Check the digital throttle assembly. |
 | STEP 2A. Check the reponse of the digital throttle assembly. | Digital throttle assembly response OK?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 1737 inactive?
 | STEP 3B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes or high counts of inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes or high counts of inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes and/or high counts of inactive fault codes?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the digital throttle assembly.

Guided Step 2A - Check the response of the digital throttle assembly.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the response of the digital throttle assembly.

  • Use INSITE™ electronic service tool to perform the Actuator Diagnostic Test. Contact your nearest Cummins® Authorized Repair Location.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Digital throttle assembly response OK?
YES NO
No Repair

Repair

Replace the digital throttle assembly. Use the following procedure in the Generator Set CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 005-012 in Section 5.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and running for longer than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 1737 is inactive.

Fault Code 1737 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Dec-2010


FAULT CODE 1738 - Engine Throttle Control Actuator – Root Cause Not Known

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes and high counts of inactive fault codes. | Active fault codes or high counts of inactive fault codes?
STEP 2. | Check the engine performance. |
 | STEP 2A. Check the engine for performance related symptoms. | Engine performance related symptoms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 1738 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes or high counts of inactive fault codes.

Guided Step 1A - Check for active fault codes or high counts of inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes and/or high counts of inactive fault codes.

  • Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Active fault codes and/or high counts of inactive fault codes?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the engine performance.

Guided Step 2A - Check the engine for performance related symptoms.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode. Generator set operating on load for more than 1 minute.

Action

Check the engine for performance related symptoms.

  • Check the engine for performance related symptoms. Use the Engine Performance Troubleshooting Tree in Section TT of the Generator Set CM700 Troubleshooting and Repair Manual, Bulletin 4021396.

Engine performance related symptoms present?
YES NO

Repair

  • Replace the digital throttle assembly. Use the following procedure in the Generator Set CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 005-052 in Section 5.
No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 1738 is inactive.

Fault Code 1738 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair Complete

Appropriate troubleshooting chart

Last Modified: 27-Mar-2020


FAULT CODE 1739 - Engine Throttle Control Actuator - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes and/or high counts of inactive fault codes. | Active fault codes and/or high counts of inactive fault codes?
STEP 2. | Check the digital throttle assembly. |
 | STEP 2A. Check the response of the digital throttle assembly. | Digital throttle assembly response OK?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 1739 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes and/or high counts of inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes and/or high counts of inactive fault codes.

  • Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Active fault codes and/or high counts of inactive fault codes?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 2A

Guided Step 2 - Check the digital throttle assembly.

Guided Step 2A - Check the response of the digital throttle assembly.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the response of the digital throttle assembly.

  • Use INSITE™ electronic service tool to perform the Actuator Diagnostic Test. Contact a Cummins® Authorized Repair Location.

Digital throttle assembly response OK?
YES NO
No Repair

Repair

Replace the digital throttle assembly. Use the following procedure in the Generator Set CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 005-002 in Section 5.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 1739 is inactive.

Fault code 1739 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes

Repair Complete

Appropriate troubleshooting chart

Last Modified: 31-Dec-2010


FAULT CODE 1741 - Engine Throttle Control Actuator Temperature - Data Valid but Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes and/or high counts of inactive fault codes. | Active fault codes and/or high counts of inactive fault codes?
STEP 2. | Check the digital throttle assembly. |
 | STEP 2A. Check the response of the digital throttle assembly. | Digital throttle assembly response OK?
STEP 3. | Check the digital throttle assembly. |
 | STEP 3A. Check the engine room ventilation fans. | Engine room ventilation fans operating correctly?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1741 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes and/or high counts of inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes and/or high counts of inactive fault codes.

  • Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Active fault codes and/or high counts of inactive fault codes?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 4A

Go to 2A

Guided Step 2 - Check the digital throttle assembly.

Guided Step 2A - Check the response of the digital throttle assembly.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the response of the digital throttle assembly.

  • Use INSITE™ electronic service tool to perform the Actuator Diagnostic Test. Contact a Cummins® Authorized Repair Location.

Digital throttle assembly response OK?
YES NO
No Repair

Repair

Replace the digital throttle assembly. Use the following procedure in the Generator Set CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 005-002 in Section 5.

Go to 4A

Go to 3A

Guided Step 3 - Check the engine room ventilation fans.

Guided Step 3A - Check the operation of the engine room ventilation fans.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and operate generator set for greater than 5 minutes.

Action

Check the operation of the engine room ventilation fans.

  • Ventilation fans are operating when the generator set is operating.
  • Ventilation fans "run-on" for specified period following normal shutdown.

Engine room ventilation fans operating correctly?
YES NO
No Repair

Repair

Repair or replace the engine room ventilation fans, fan supply, or fan control. Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 1741 is inactive.

Fault code 1741 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes

Repair Complete

Appropriate troubleshooting chart

Last Modified: 31-Dec-2010


FAULT CODE 1742 - Engine Throttle Control Actuator Temperature - Data Valid but Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes and/or high counts of inactive fault codes. | Active fault codes and/or high counts of inactive fault codes?
STEP 2. | Check the digital throttle assembly. |
 | STEP 2A. Check the response of the digital throttle assembly. | Digital throttle assembly response OK?
STEP 3. | Check the digital throttle assembly. |
 | STEP 3A. Check the engine room ventilation fans. | Engine room ventilation fans operating correctly?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1741 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes and/or high counts of inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes and/or high counts of inactive fault codes.

  • Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Active fault codes and/or high counts of inactive fault codes?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 4A

Go to 2A

Guided Step 2 - Check the digital throttle assembly.

Guided Step 2A - Check the response of the digital throttle assembly.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the response of the digital throttle assembly.

  • Use INSITE™ electronic service tool to perform the Actuator Diagnostic Test. Contact a Cummins® Authorized Repair Location.

Digital throttle assembly response OK?
YES NO
No Repair

Repair

Replace the digital throttle assembly. Use the following procedure in the Generator Set CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 005-002 in Section 5.

Go to 4A

Go to 3A

Guided Step 3 - Check the engine room ventilation fans.

Guided Step 3A - Check the operation of the engine room ventilation fans.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate generator set for greater than 5 minutes.

Action

Check the operation of the engine room ventilation fans.

  • Ventilation fans are operating when the generator set is operating.
  • Ventilation fans "run-on" for specified period following normal shutdown.

Engine room ventilation fans operating correctly?
YES NO
No Repair

Repair

Repair or replace the engine room ventilation fans, fan supply, or fan control. Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 1742 is inactive.

Fault code 1742 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair Complete

Appropriate troubleshooting chart

Last Modified: 31-Dec-2010


FAULT CODE 1761 - Engine Electronic Fuel Control Valve 1 Position – Data Erratic, Intermittent or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 455, 511, 2311, and/or 2867 active?
STEP 2. | Check the fuel control valve for free movement. |
 | STEP 2A. Check the fuel control valve for movement and compare the commanded position signal and feedback position signal for excessive deviation. | Fuel control valve has free movement and commanded position signal and feedback position signal exceeds the 30 percent deviation limit?
STEP 3. | Check the fuel control valve actuator. |
 | STEP 3A. Inspect the actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the fuel control valve actuator commanded signal percent duty cycle. | Percent duty cycle is 10 to 91 percent?
 | STEP 3C. Check the fuel control valve actuator feedback signal voltage. | 0 to 5-VDC?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4C. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check for a CM558 response. |
 | STEP 5A. Check for an appropriate CM558 response. | Fault Code 1761 inactive?
STEP 6. | Clear the fault code. |
 | STEP 6A. Verify that fault code is inactive. | Fault Code 1761 inactive?
 | STEP 6B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 455, 511, 2311, and/or 2867 active?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the fuel control valve for free movement.

Guided Step 2A - Check the fuel control valve for free movement and compare the commanded position signal and feedback position signal for excessive deviation.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve (FCV) for free movement and compare the commanded signal position signal and feedback position signal for excessive deviation (greater than 30 percent deviation).

  • Use INSITE™ electronic service tool to electronically test the FCV for free movement. Drive the FCV to a number of positions through its range and compare the commanded position and position feedback data. Use the Actuator Diagnostics Tests within the ECM Diagnostics Tests feature to perform this test.
  • Contact a Cummins® Authorized Repair Location.

Fuel control valve has free movement and commanded position signal and feedback position signal exceeds the 30 perccent deviation limit?

YES | NO
No Repair | No Repair

Go to 3A

Go to 5A

Guided Step 3 - Check the fuel control valve actuator.

Guided Step 3A - Inspect the actuator and engine harness connector pins.

Conditions

  • Disconnect the engine harness connector from the fuel control valve actuator.
  • De-energize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the actuator and the engine harness connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness, the harness connector, or the fuel control valve actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Repair the harness connector. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel control valve. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 006-049 in Section 6.
No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check the fuel control valve actuator commanded signal percent duty cycle.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a number of positions between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter probes between the FCV actuator position SIGNAL (+) and RETURN (-) pins at the FCV actuator connector. The signal percent duty cycle must be between 10 and 91 percent, based on the FCV actuator position.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Refer to the specification table provided in the Shop Talk section of this document for commanded position percent duty cycle specifications.

Percent duty cycle 10 to 91 percent?
YES NO
No Repair

Repair

Check the power supply connections and the fuses. See the engine wiring diagram for the appropriate circuit.

Go to 4A

Go to 3C

Guided Step 3C - Check the fuel control valve actuator feedback signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator feedback signal voltage.

  • Use INSITE™ electronic service tool, to monitor the fuel control valve feedback position voltage.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Refer to the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

Feedback voltage 0 to 5-VDC?
YES NO
No Repair

Repair

A fault has been detected with the fuel control valve actuator.

  • Replace the fuel control valve. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 006-049 in Section 6.

Go to 4A

Go to 6A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harnesses and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness from the fuel control valve actuator and the CM558 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness from the fuel control valve actuator.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator. Refer to the wiring diagram to identify shared sensors.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel control valve actuator commanded position SIGNAL (+) pin to all other pins in the engine harness.
  • Measure the resistance from the fuel control valve actuator position FEEDBACK pin to all other pins in the engine harness.
  • Measure the resistance from the fuel control valve actuator RETURN (–) pin to all other pins in the engine harness.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolater the generator set 24 volt power supply.
  • Disconnect the engine harness from the fuel control valve actuator.

Action

Check for an open circuit.

  • Measure the resistance from the fuel control valve actuator commanded position SIGNAL (+) pin in the engine harness CM558 connector to the fuel control valve actuator commanded position SIGNAL (+) pin in the fuel control valve actuator connector.
  • Measure the resistance from the fuel control valve actuator RETURN (–) pin in the engine harness CM558 connector to the fuel control valve actuator RETURN (–) pin in the fuel control valve actuator connector.
  • Measure the resistance from the fuel control valve actuator position FEEDBACK pin in the engine harness CM558 connector to the fuel control valve actuator position FEEDBACK pin in the fuel control valve actuator connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check for a CM558 module response.

Guided Step 5A - Check for the appropriate CM558 module response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Check for the appropriate CM558 response after thirty seconds.
  • Use INSITE™ electronic service tool to verify the fault codes.
  • Contact a Cummins® Authorized Repair Location

Fault Code 1761 inactive?
YES NO
No Repair

Repair

Replace the CM558 module. Refer to Procedure 019-031 in Section 19. Contact a Cummins® Authorized Repair Location.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 1761 is inactive.

Fault Code 1761 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 31-Dec-2010


FAULT CODE 1791 - Electrical Load, Engine Failure to Meet Load and/or Speed Demand - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple active fault codes. | Fault Codes 144, 145, 146, 153, 154, 155, 156, 157, 158, 177, 263, 265, 354, 355, 453, 454, 488, 512, 513, 691, 692, 751, 783, 1737, 1738, 1739, 1741,1743, 1744, 1745, 1746, 1747, 1748,1749, 1751, 1752, 1759, 1761, 1765,1766, 1767, 1768, 1783, 1793, 1821,1827, 1828, 1838, 1839, 1841, 1984, 2157, 2191, 2311, 2313, 2427, 2428, 2455, 2456, 2457, 2517, 2518, 2569, 2643, 2644, 2752, 2812, 2866, 2867, 2876, 2877, 3384, 3391, 3475, 3476, 3499, 3511, 3512, 3514, 3521, 3522, 3594, and/or 3595 active?
STEP 2. | Check the air intake system. |
 | STEP 2A. Check the air intake system for restriction. | Air intake system restricted?
 | STEP 2B. Check aftercooler for restriction. | Aftercooler blocked?
STEP 3. | Check the exhaust emissions. |
 | STEP 3A. Measure the exhaust emissions. | Exhaust emissions to specification?
STEP 4. | Check the air inlet temperature. |
 | STEP 4A. Check the air inlet temperature. | Air inlet temperature high?
STEP 5. | Check the kilowatt load reference signal. |
 | STEP 5A. If fitted, check the kilowatt load transducer-sensed kilowatts against the generator set controller kilowatts. | Kilowatt load transducer sensed kilowatt matches generator set controller kilowatts?
 | STEP 5B. Check the generator set controller calibration. | Generator set controller voltage and ampere output calibration correct?
STEP 6. | Check the turbocharger(s). |
 | STEP 6A. Inspect the turbocharger(s). | Turbocharger(s) worn or damaged?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 1791 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes or high counts of inactive fault codes.

Guided Step 1A - Check for active fault codes or high counts of inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for multiple active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 144, 145, 146, 153, 154, 155, 156, 157, 158, 177, 263, 265, 354, 355, 453, 454, 488, 512, 513, 691, 692, 751, 783, 1737, 1738, 1739, 1741, 1743, 1744, 1745, 1746, 1747, 1748,1749, 1751, 1752, 1759, 1761, 1765, 1766, 1767, 1768, 1783, 1793, 1821,1827, 1828, 1838, 1839, 1841, 1984, 2157, 2191, 2311, 2313,2427, 2428, 2455, 2456, 2457, 2517, 2518, 2569, 2643, 2644, 2752, 2812, 2866, 2867, 2876, 2877, 3384, 3391, 3475, 3476, 3499, 3511, 3512, 3514, 3521, 3522, 3594, and/or 3595 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the air intake system.

Guided Step 2A - Check the air intake system for restriction.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the air intake system for restriction:

  • Air filters excessive restriction. Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 010-086 in Section 10.
  • Air filters element damage. Use the following procedure in the QSK60G CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 010-014 in Section 10.
  • Air intake restriction. Use the following procedure in the QSK60G CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 010-031 in Section 10.

Air intake system restricted?
YES NO

Repair

A restriction has been detected in the air intake system.

  • Replace the air filter elements. Use the following procedure in the QSK60G CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 010-014 in Section 10.
  • Repair or replace the air intake piping as appropriate. Contact a Cummins® Authorized Repair Location.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check aftercooler for restriction.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the aftercooler core on the charge-air inlet for signs of blockage (dust build-up, core element damage/collapse, oil carry-over, etc.).

  • Remove the aftercooler assembly from the engine. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 010-001 in Section 10.
  • Remove the aftercooler inlet cover. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 010-008 in Section 10.

Aftercooler blocked?
YES NO

Repair

Clean aftercooler core.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 010-008 in Section 10.

Replace aftercooler assembly.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 010-001 in Section 10.
No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the exhaust emissions

Guided Step 3A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Connect an exhaust gas analyzer.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine at the highest load possible with no knock; should be at a minimum of 70 percent load.

Action

Measure the exhaust emissions.

  • Use an exhaust gas analyzer, with the sample probe inserted into the exhaust gas manifold test port, to check that the exhaust emissions are to the Fuel Rating specification for the engine.
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395, for the exhaust emission specifications. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specification?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool and reference the exhaust gas analyzer to adjust the “open and closed-loop” fueling offsets so that the NOx and the O2 emissions meet the Fuel Rating specification for the engine.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 7A

Guided Step 4 - Check the air inlet temperature.

Guided Step 4A - Check the air inlet temperature.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the air inlet temperature.

  • Check the temperature of the air entering the engine against the specification limit for the engine. Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395, for the exhaust emission specifications. Refer to Procedure 018-019 in Section V.

Air inlet temperature high?
YES NO

Repair

The temperature of the air entering the engine is too high. Inspect the following balance-of-plant systems and repair or replace as necessary.

  • Engine room ventilation fans operation.
  • Motorized engine room louvres operation.
  • Engine room air intake grilles for blockages and other obstructions.
  • Contact a Cummins® Authorized Repair Location.
 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Check the kilowatt load transducer, if installed.

Guided Step 5A - Check the kilowatt load transducer-reference signal.

Conditions

Note: If the generator set is not fitted with a kilowatt load transducer, proceed to Step 5B.

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.

Action

Check the kilowatt load transducer-sensed kilowatts against the generator set controller displayed kilowatts.

  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatt matches generator set controller kilowatts?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool to calibrate the kilowatt load sensor milliampere/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 6A

Go to 7A

Guided Step 5B - Check the calibration of the generator set controller.

Conditions

Note: This guided step should only be followed for generator sets not installed with a kilowatt load transducer.

  • Connect all components.
  • Connect a power analyzer or digital multimeter.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.

Action

Check the calibration of the generator set controller.

  • Connect a power analyzer or digital multimeter to the alternator main output terminals. Check that the genset controller readings for output voltage (L1- L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller voltage and ampere output calibration correct?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter to calibrate the generator set controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 6A

Go to 7A

Guided Step 6 - Check the turbocharger(s).

Guided Step 6A - Inspect the turbocharger(s).

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the turbocharger(s).

Inspect the turbocharger(s) for the following:

  • Excessive axial clearance. Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 010-038 in Section 3.
  • Excessive radial clearance. Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 010-047 in Section 3.
  • Turbocharger turbine or compressor damage.
  • Contact a Cummins® Authorized Repair Location.

Turbocharger(s) worn or damaged?
YES NO
No Repair

Repair

A fault code has been detected with the turbocharger(s).

  • Replace the turbocharger(s) as necessary. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 010-033 in Section 10.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 1791 is inactive.

Fault Code 1791 inactive?
YES NO

Repair

Use INSITE™ electronic service tool and an exhaust gas analyzer to check the exhaust emissions against the specification for the engine and fine-tune as required. Contact a Cummins® Authorized Repair Location.

  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395, for fuel recommendations and specifications. Refer to Procedure 018-002 in Section V.

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes

Repair Complete

Appropriate troubleshooting chart

Last Modified: 25-Jun-2012


FAULT CODE 1792 - Engine Low Idle / Rated Speed with Generator Breakers Closed

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the Generator Set with PowerCommand™ Supervisor and Generator Set with PCC300. |
 | STEP 1A. Read the PowerCommand™ Supervisor and PCC3300 fault codes. | Active fault code a PowerCommand™ Supervisor?
 | STEP 1B. Check the ECM for active fault codes. | Fault Code 1792 active?
STEP 2. | Check the idle / rated command circuit. |
 | STEP 2A. Check for idle idle command input. | Idle command ON?
 | STEP 2B. Measure the resistance of the K10-2 contact. | Less than 10 ohms?
 | STEP 2C. Measure the voltage drop across the K10 coil. | Between 5VDC and 24VDC?
 | STEP 2D. Check for short circuit to ground between the K10-2 contact and CM700A-14. | More than 100k ohms?
 | STEP 2E. Check for short circuit to ground between K10-2 coil and PLC6-7. | More than 100k ohms?
STEP 3. | Check the ultility parallel status circuit. |
 | STEP 3A. Measure the voltage at C44. | Between 5VDC and 24VDC?
 | STEP 3B. Measure the resistance of K12-3 contact. | Less than 10 ohms?
 | STEP 3C. Measure the voltage drop across K12 coil. | Between 5VDC and 24VDC?
 | STEP 3D. Check for a short circuit to ground between K12 and CM700. | More than 100k ohms?
 | STEP 3E. Check for a short circuit to B+ between the C44 and K12 coil. | More than 100k ohms?
 | STEP 3F. Measure the voltage at C46. | Between 5VDC and 24VDC?
 | STEP 3G. Measure the resistance of K15-2 contact. | Less than 10 ohms?
 | STEP 3H. Measure the voltage drop across the K15 coil. | Between 5VDC and 24VDC?
 | STEP 3I. Check for short circuit to ground between K15 and K12. | More than 100k ohms?
 | STEP 3J. Check for short circuit to B+ between C46 and K15 coil. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Clear the inactive fault codes. | All fault codes cleared?
 | STEP 4B. Verify the fault code is inactive. | Fault Code 1792 inactive?
STEP 5. | Check the fault codes. |
 | STEP 5A. Check the ECM for active fault codes. | Fault Code 1792 active?
STEP 6. | Check the idle / rated command circuit. |
 | STEP 6A. Check for idle command input. | Idle command present?
STEP 7. | Check the utility parallel status circuit. |
 | STEP 7A. Check the generator set circuit breaker position. | Open?
 | STEP 7B. Check for PCC3300 TB10-1 short circuit to ground. | More than 100k ohms?
STEP 8. | Clear the fault codes. |
 | STEP 8A. Clear the inactive fault codes. | All fault codes cleared?
 | STEP 8B. Verify the fault code is inactive. | Fault Code 1792 inactive?

Guided Step 1 - Check Generator Set with PowerCommand™ Supervisor and Generator Set with PCC3300.

Guided Step 1A - Read the PowerCommand™ Supervisor and PCC3300 fault codes.

Conditions

  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code.

Verify whether fault code PowerCommand™ Supervisor or PCC3300 is active?

Is active fault code a PowerCommand™ Supervisor?
YES NO
No Repair

Repair

This is a PCC3300 fault code. Begin troubleshooting at Guided Step 5A.

Go to 1B

Go to 5A

Guided Step 1B - Check the ECM for active fault codes.

Conditions

  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1792 active?
YES NO
No Repair

Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 5A

Guided Step 2 - Check the idle / rated command circuit.

Guided Step 2A - Check for idle command input.

Conditions

  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in RUN mode.

Action

Via generator set Human Machine Interface; check the state of idle command (ON or OFF).

Idle commanded ON?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2B

Guided Step 2B - Measure the resistance of K10-2 contact.

Conditions

  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in RUN mode.

Action

Measure the resistance of K10-2 contact.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2D

Guided Step 2C - Measure the voltage drop across the K10 coil.

Conditions

  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in RUN mode.

Action

Measure the voltage drop across the K10 coil.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 5VDC and 24VDC?
YES NO
No Repair

Repair

Replace or replace K10 relay.

Go to 2E

Go to 4A

Guided Step 2D - Check for short circuit to ground between the K10-2 contact and CM700A-14.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Check for a short circuit to ground between K10-2 contact and CM700A-14 via resistance measurement.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Replace or replace the wire or connections between the K10-2 contact and CM700A-14.

Go to 4A

Go to 4A

Guided Step 2E - Check for a short circuit to ground between the K10-2 coil and PLC6-7.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Check for a short-circuit to ground between K10-2 and PLC6-7 via resistance measurement.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO

Repair

Repair or replace K10 relay.

Repair

Repair or replace the wire or connections between K10-2 coil and PLC6-7.

Go to 4A

Go to 4A

Guided Step 3 - Check the utlility parallel status circuit.

Guided Step 3A - Measure the voltage at C44.

Conditions

  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in RUN mode.

Action

Measure the voltage at C44.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 5VDC and 24VDC?
YES | NO
No Repair | No Repair

Go to 3F

Go to 3B

Guided Step 3B - Measure the resistance of K12-3 contact.

Conditions

  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in RUN mode.

Action

Measure the resistance of K12-3 contact.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3D

Guided Step 3C - Measure the voltage drop across the K12 coil.

Conditions

  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in RUN mode.

Action

Measure the voltage drop across the K12 coil.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 5VDC and 24VDC?
YES NO
No Repair

Repair

Repair or replace the K12 relay.

Go to 3E

Go to 4A

Guided Step 3D - Check for a short-circuit to ground between K12-3 contact and CM700.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Check for a short circuit to ground between K12-3 contact and CM700 via resistance measurement.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the wire or connections between K12-3 and CM700C-36.

Go to 4A

Go to 4A

Guided Step 3E - Check for a short-circuit to B+ between C44 and K12-3 coil.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Check for a short-circuit to ground between C43 and K12-3 coil via resistance measurement.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO

Repair

Repair or replace the K12 relay.

Repair

Repair or replace the wire or connections between K12-3 and C44.

Go to 4A

Go to 4A

Guided Step 3F - Measure the voltage at C46.

Conditions

  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in RUN mode.

Action

Measure the voltage at C46.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 5VDC and 24VDC?
YES NO

Repair

Via generator set Human Machine Interface, remove the idle command and or remove the generator set from utility parallel mode of operation.

No Repair

Go to 4A

Go to 3G

Guided Step 3G - Measure the resistance of K15-2 contact.

Conditions

  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in RUN mode.

Action

Measure the resistance of K15-2 contact.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES | NO
No Repair | No Repair

Go to 3H

Go to 3I

Guided Step 3H - Measure the voltage drop across the K15 coil.

Conditions

  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in RUN mode.

Action

Measure the voltage drop across the K15 coil.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 5VDC and 24VDC?
YES NO
No Repair

Repair

Repair or replace the K15 relay.

Go to 3J

Go to 4A

Guided Step 3I - Check for a short-circuit to ground between K15 contact and K12.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Check for a short circuit to ground between K15 contact and K12 via resistance measurement.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the wire or connections between K12-3 and K15-2.

Go to 4A

Go to 4A

Guided Step 3J - Check for a short-circuit to B+ between C46 and K15 coil.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Check for a short-circuit to ground between C43 and K12-3 coil via resistance measurement.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO

Repair

Repair or replace the K15 relay.

Repair

Repair or replace the wire or connections between K15-2 and C46.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Clear the inactive fault codes.

  • Clear inactive fault codes by pressing the "Reset" button on the control panel and cycling the engine keyswitch. Use INSITE™ electronic service tool to verify inactive fault codes are cleared.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Go to 4B

Appropriate troubleshooting steps

Guided Step 4B - Verify the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Place Run/Stop/Auto switch in RUN mode and operate for greater than 1 minute.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Verify fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 1792 is inactive.

Fault Code 1792 inactive?

YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Guided Step 5 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1792 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 6 - Check the idle / rated command circuit.

Guided Step 6A - Check for idle command input.

Conditions

  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Via the Generator Set Human Machine Interface, navigate to"Adjust" screen and check the state of Rated/Idle Switch.

Idle command present?
YES NO

Repair

Remove the idle command by enabling rated command.

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 7A

Go to 8A

Guided Step 7 - Check the Utility Parallel Status circuit.

Guided Step 7A - Check Generator Set Circuit Breaker position.

Conditions

  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in the RUN mode.

Action

Visually confirm the position of the generator set circuit breaker (open or closed).

Open?
YES NO
No Repair

Repair

Unload the generator set and open the generator set circuit breaker.

Go to 7B

Go to 8A

Guided Step 7B - Check for PCC3300 TB10-1 short-circuit to ground.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Check for PCC3300 TB10-1 short-circuit to ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the wire.

Go to 8A

Go to 8A

Guided Step 8 - Clear the fault codes.

Guided Step 8A - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Clear the inactive fault codes.

  • Clear inactive fault codes by pressing the "Reset" button on the control panel and cycling the engine keyswitch. Use INSITE™ electronic service tool to verify inactive fault codes are cleared.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Go to 4B

Appropriate troubleshooting steps

Guided Step 8B - Verify the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Place Run/Stop/Auto switch in RUN mode and operate for greater than 1 minute.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Verify fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 1792 is inactive.

Fault Code 1792 inactive?

YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-May-2012


FAULT CODE 1793 - Engine Crankshaft Speed / Position Mismatch between ECMs – Mechanical System not Responding or Out of Adjustment

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple active fault codes. | Fault Codes 121, 234, 689, 1546, 1821, and/or 1837 active?
STEP 2. | Check the crankshaft engine speed sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged crankshaft engine speed sensor or engine harness connector pins?
 | STEP 2B. Inspect the crankshaft engine speed sensor for damage. | Damaged crankshaft engine speed sensor?
 | STEP 2C. Check the crankshaft engine speed sensor resistance. | Resistance 750 – 1500 ohms?
 | STEP 2D. Check for a short circuit to ground in the crankshaft engine speed sensor. | Greater than 100k ohms?
STEP 3. | Check the camshaft engine speed/position sensor. |
 | STEP 3A. Inspect the sensor and engine harness connector pins. | Dirty or damaged sensor or engine harness connector pins?
 | STEP 3B. Inspect the sensor for damage. | Damaged camshaft engine speed/position sensor?
 | STEP 3C. Check the resistance of the sensor. | Less than 2k ohms?
 | STEP 3D. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit between coils. | Greater than 100k ohms?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit-to-ground in the engine harness. | Greater than 100k ohms?
 | STEP 4D. Check for a short circuit from pin-to-pin in the engine harness. | Greater than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 1793 inactive?
 | STEP 5B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for mulitple active fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in the RUN mode.

Action

Run the engine at normal load conditions.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault codes 121, 234, 689, 1546, 1821, and/or 1837 active?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 5A

Go to 2A

Guided Step 2 - Check the crankshaft engine speed sensor.

Guided Step 2A - Inspect the sensor and the engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in OFF mode.
  • Disconnect the engine harness connector from the crankshaft engine speed sensor connector.

Action

Inspect the crankshaft engine speed sensor connector and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged sensor or engine harness connector pins?
YES NO

Repair

  • Repair or replace the damaged connector. Refer to Procedure 019-206 in Section 19.
  • Replace the crankshaft engine speed sensor. Refer to Procedure 019-042 in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the crankshaft engine speed sensor for damage.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in OFF mode.
  • Disconnect the engine harness from the crankshaft engine speed sensor connector.
  • Remove the crankshaft engine speed sensor.

Action

Inspect the crankshaft engine speed sensor for the following:

  • Metal debris on end of sensor.
  • Damage to the end of the sensor caused by contacting the flywheel.
  • Oil leakage or insulation problems such as swelling.
  • Damaged electrical potting in sensing end of the sensor.

Damaged crankshaft engine speed sensor?
YES NO

Repair

Replace the crankshaft engine speed sensor. Refer to Procedure 019-042 in Section 19.

No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check the crankshaft engine speed sensor resistance.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in OFF mode.
  • Disconnect the engine harness from the crankshaft engine speed sensor connector.

Action

Use a multimeter to measure the resistance of the crankshaft engine speed sensor from the speed SIGNAL(+) pin to the speed RETURN (-) pin at the sensor connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance 750 – 1500 ohms?
YES NO
No Repair

Repair

The crankshaft engine speed sensor has malfunctioned.

  • Replace the crankshaft engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 2D

Go to 5A

Guided Step 2D - Check for a short circuit to ground in the crankshaft engine speed sensor.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in OFF mode.
  • Disconnect the engine harness connector from the crankshaft engine speed sensor connector.

Action

Use a multimeter to measure the resistance of the crankshaft engine speed sensor from the speed SIGNAL(+) pin on the sensor to the engine ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

The crankshaft engine speed sensor is damaged.

  • Replace the engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check for the camshaft engine speed/position sensor

Guided Step 3A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in OFF mode.
  • Disconnect the engine harness connector from the camshaft engine speed/position sensor connector.

Action

Inspect the camshaft engine speed/position sensor connector and the engine harness connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged sensor or engine harness connector pins?
YES NO

Repair

Repair or replace the damaged engine harness connector or camshaft engine speed/position sensor.

  • Flush the dirt, debris, or moisture, from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged engine harness or connector. Refer to Procedure 019-043 in Section 19.
  • Replace the camshaft engine speed/position sensor. Refer to Procedure 019-038 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the camshaft engine speed/position sensor for damage.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in OFF mode.
  • Disconnect the engine harness connector from the camshaft engine speed/position sensor connector.
  • Remove the camshaft engine speed/position sensor.

Action

Inspect the camshaft engine speed/position sensor for the following:

  • Metal debris on the end of the sensor.
  • Damage to the end of the sensor caused by contacting the flywheel.
  • Oil leakage or insulation problems such as swelling.
  • Damaged electrical potting in sensing end of the sensor.
  • Refer to Procedure 019-038 in Section 19.

Damaged camshaft engine speed/position sensor?
YES NO

Repair

The camshaft engine speed/position sensor is damaged.

  • Replace the camshaft engine speed/position sensor. Refer to Procedure 019-038 in Section 19.
No Repair

Go to 5A

Go to 3C

Guided Step 3C - Check the camshaft engine speed/position sensor resistance.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in OFF mode.
  • Disconnect the engine harness from the camshaft engine speed/position sensor.

Action

Check the resistance of the sensor.

  • Use a multimeter to measure the resistance of the camshaft engine speed/position sensor from the speed/position SIGNAL(+) pin to the speed/position.
  • Use a multimeter to measure the resistance of the camshaft engine speed/position sensor backup SIGNAL (+) pin to the speed/position sensor backup RETURN (-) at the sensor connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2k ohms?
YES NO
No Repair

Repair

The camshaft engine speed/position sensor has malfunctioned.

  • Replace the camshaft engine speed/position sensor. Refer to Procedure 019-038 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit to ground in the camshaft engine speed/position sensor.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in OFF mode.
  • Disconnect the engine harness connector from the camshaft engine speed/position sensor.

Action

Check for a short circuit to ground.

  • Use a multimeter to measure the resistance of the camshaft engine speed/position sensor from the speed/position SIGNAL(+) pin on the sensor to the engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

The camshaft engine speed/position sensor is damaged.

  • Replace the engine harness. Refer to Procedure 019-038 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check the camshaft engine speed/position sensor for a short between coils.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in OFF mode.
  • Disconnect the engine harness connector from the camshaft engine speed/position sensor.

Action

Check the sensor for a short circuit between coils.

  • Use a multimeter to measure the resistance of the camshaft engine speed/position sensor from the speed/position SIGNAL(+) pin of one coil to all other pins in the sensor connector.
  • Use a multimeter to measure the resistance of the camshaft engine speed/position sensor RETURN (-) pin to all other pins at the sensor connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

The camshaft engine speed/position sensor is damaged.

  • Replace the engine harness. Refer to Procedure 019-038 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine harness.

Guided Step 4A - Inspect the engine harness and ECM connector pins.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in OFF mode.
  • Disconnect the engine harness from the CM700 module.
  • Disconnect the harness from both CM558 modules.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or connector?
YES NO

Repair

Clean the connector and pins.

Replace the damaged pins.

Repair or replace the engine harness or harness connector.

  • Flush the dirt, debris, or moisture, from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-206 in Section 19.
  • Replace the camshaft engine speed/position sensor. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open-circuit in the engine harness.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in OFF mode.
  • Disconnect the engine harness from the CM700 and both CM558 control modules.
  • Disconnect the engine harness from the crankshaft engine speed sensor.
  • Disconnect the engine harness from the engine camshaft speed/position sensor.

Action

Use a multimeter to check for an open circuit in the engine harness:

  • Measure the resistance from the crankshaft engine speed SIGNAL (+) pin at the CM700 connector to the crankshaft engine speed SIGNAL (+) pin at the crankshaft engine speed sensor connector.
  • Measure the resistance from the crankshaft engine speed RETURN (-) pin at the CM700 connector to the crankshaft engine speed RETURN (-) pin at the crankshaft engine speed sensor connector.
  • Measure the resistance from the camshaft engine speed/position SIGNAL (+) pin at the CM558 left-bank connector to the camshaft engine/position speed SIGNAL (+) pin at the camshaft engine speed/position sensor connector.
  • Measure the resistance from the camshaft engine speed/position RETURN (-) pin at the CM558 left-bank connector to the camshaft engine speed/position RETURN (-) pin at the camshaft engine speed/position sensor connector.
  • Measure the resistance from the camshaft engine speed/position backup SIGNAL (+) pin at the CM558 right-bank connector to the camshaft engine/position speed backup SIGNAL (+) pin at the camshaft engine speed/position sensor connector.
  • Measure the resistance from the camshaft engine speed/position backup RETURN (-) pin at the CM558 right-bank connector to the camshaft engine speed/position backup RETURN(-) pin at the camshaft engine speed/position sensor connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the engine harness.

  • Repair the engine wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-206 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short-to-ground in the engine harness.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in OFF mode.
  • Disconnect the engine harness from the CM700 module.
  • Disconnect the engine harness from the crankshaft engine speed sensor.
  • Disconnect the engine harness both CM558 modules.
  • Disconnect the engine harness from the camshaft engine speed/position sensor.

Action

Use a multimeter to check for a short circuit-to-ground in the engine harness:

  • Use a multimeter to measure the resistance of the camshaft engine speed/position sensor from the speed/position SIGNAL(+) pin to the speed/position.
  • Measure the resistance from the crankshaft engine speed SIGNAL (+) pin at the CM700 connector to the engine block ground.
  • Measure the resistance from the camshaft engine speed/position SIGNAL (+) pin at the left-bank CM558 module to the engine block ground.
  • Measure the resistance from the camshaft engine speed/position backup SIGNAL (+) pin at the right-bank CM558 module to engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short to ground has been detected in the engine harness. Inspect the engine harness for a short to ground.

  • Replace the camshaft engine speed/position sensor. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a pin-to-pin short in the engine harness.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in OFF mode.
  • Disconnect the engine harness from the CM700 module.
  • Disconnect the engine harness from the crankshaft engine speed sensor.
  • Disconnect the engine harness both CM558 modules.
  • Disconnect the engine harness from the camshaft engine speed/position sensor.

Action

Use a multimeter to check for a short circuit-to-ground in the engine harness:

  • Measure the resistance from the crankshaft engine speed SIGNAL (+) pin at the CM700 connector to all other pins in the CM700 connector.
  • Measure the resistance from the crankshaft engine speed RETURN (-) pin at the CM700 connector to all other pins in the CM700 connector.
  • Measure the resistance from the camshaft engine speed/position SIGNAL (+) pin at the left-bank CM558 connector to all other pins in the left-bank CM558 connector.
  • Measure the resistance from the camshaft engine speed/position RETURN (-) pin at the left-bank CM558 connector to all other connector.
  • Measure the resistance from the camshaft engine speed/position backup SIGNAL (+) pin at the right-bank CM558 connector to all other pins in the right-bank CM558 connector.
  • Measure the resistance from the camshaft engine speed/position backup RETURN (-) pin at the right-bank CM558 connector to all other pins in the right-bank CM558 connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short has been detected in the engine harness.

  • Replace or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Place Run/Stop/Auto switch in RUN mode and operate the engine longer than 1 minute.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 1793 is inactive.

Fault Code 1793 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 07-Oct-2010


FAULT CODE 1794 - Unexpected Thermal Event - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine room/container and Generator Set for any thermal damage. |
 | STEP 1A. Check the engine room/container and the Generator Set for any thermal damage. | Any engine room/container or Generator Set thermal damage located?
STEP 2. | Check for active fault codes. |
 | STEP 2A. Check for active fault codes. | Active fault codes present?
STEP 3. | Clear the local Generator Room/Container fire detection/alarm system. |
 | STEP 3A. Verify the fire alarm detection system is acknowledged. | Generator room/container fire detection/alarm system acknowledged?
 | STEP 3B. Reset the fire detection/alarm system. | Generator room/container fire detection/alarm system reset?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1794 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the engine room/container and Generator Set for any thermal damage.

Guided Step 1A - Check the engine room/container and Generator Set for any thermal damage.

Conditions

  • Keyswitch circuit energized
  • Place Run/Stop/Auto switch in the OFF mode.

Action

When authorized as safe to proceed, check the engine room/container and Generator Set for any thermal damage. If the thermal event was local to the Generator Set, check for the following:

  • Engine fuel system leakage
  • Engine intake system/charge air leakage
  • Engine exhaust system leakage
  • Engine heaters for possible short circuit
  • Batteries and battery charger for possible short circuit or overload
  • Engine lubricating oil leakage onto hot surfaces
  • Engine coolant leakage onto hot surfaces
  • Alternator - possible winding short circuits and contaminants on windings
  • Alternator heaters possible short circuit or contact with contaminants
  • Switch gear possible short circuit
  • All wiring for possible short circuits
  • Ventilation fan motors for possible short circuits
  • Generator Set panels (AC panel, DC panel, or Generator Inteface Box) for possible short circuits
  • Local oil make-up tank system oil leakage onto hot surfaces
  • Contact a local Cummins® Authorized Repair Location.

Any engine room/container or Generator Set thermal damage located?
YES NO

Repair

Rectify any engine room/container or Generator Set source of the thermal event and repair all resulting in damage. Use the appropriate repair procedures.

  • Contact a local Cummins® Authorized Repair Location.
 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check for active fault codes.

Guided Step 2A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Use INSITE™ electronic service tool to read the active fault codes.

Active fault codes present?
YES NO

Repair

Follow the appropriate troubleshooting steps for the Active Fault Codes or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.
No Repair

Go to 4A

Go to 3A

Guided Step 3 - Clear the local Generator Room/Container fire detection/alarm system.

Guided Step 3A - Verify the fire detection/alarm system is acknowledged.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Verify that the engine room/ container fire alarm detection system is acknowledged.

  • Acknowledge the fire alarm via the system panel. Reference the fire detection system manual.
  • Contact your local Cummins® Authorized Repair Location.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Generator room/container fire detection/alarm system acknowledged?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Reset the fire detection system.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Reset the engine room/container fire detection system.

  • Reset the fire detection system via the system panel. Reference the fire detection system manual.
  • Contact your local Cummins® Authorized Repair Location.

Generator room/container fire detection/alarm system reset?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4A

Go to 1A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in RUN mode and operate engine for longer than 1 minute.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 1794 is inactive.

Fault Code 1794 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in STOP mode.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 07-Oct-2010


FAULT CODE 1795 - Engine Turbocharger Compressor Bypass Actuator Position Sensor - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new CM558, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1795 active?
 | STEP 1B. Check for multiple active fault codes. | Fault Codes 441, 442, 477, and/or 478 active?
STEP 2. | Check the turbocharger compressor bypass actuator. |
 | STEP 2A. Inspect the turbocharger compressor bypass actuator connector and engine harness connector pins. | Dirty or damaged connector pins?
 | STEP 2B. Check the actuator position feedback signal voltage. | 0 to 5-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins or connector?
 | STEP 3B. Check for a short circuit from pin-to-pin in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 1795 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 1795 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for the fault code.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place the run/stop/auto switch in the OFF mode.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1795 active?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 1B

Go to 1B

Guided Step 1B - Check for multiple active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place the run/stop/auto switch in the OFF mode.

Action

Check for multiple active/inactive fault code.

  • Use INSITE™ electronic service tool to read the active and inactive fault codes.

Fault Codes 441, 442, 477, and/or 478 active?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 5A

Go to 2A

Guided Step 2 - Check the turbocharger compressor bypass actuator.

Guided Step 2A - Inspect the turbocharger compressor bypass actuator connector and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness connector from the turbocharger compressor bypass actuator.

Action

Inspect the actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged connector?
YES NO

Repair

A damaged connection has been detected in the turbocharger compressor actuator connector or harness connector.

Repair or replace the engine harness or the turbocharger compressor bypass actuator, whichever has the damaged connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Replace the appropriate connector seal if is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the turbocharger compressor bypass control valve. Contact a Cummins® Authorized Repair Location to perform this repair.
 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the actuator position feedback signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the turbocharger compressor bypass actuator position feedback signal voltage.

  • Use the actuator test function within INSITE™ electronic service tool to drive the turbocharger compressor bypass valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the position feedback signal voltage by connecting the multimeter test probes between the turbocharger compressor bypass actuator position feedback SIGNAL pin and the RETURN (–) pin at the actuator connector. The voltage signal must be between 0 and 5-VDC, based on the actuator position.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Refer to the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

0 to 5-VDC?
YES NO
No Repair

Repair

Replace the turbocharger compressor bypass valve. Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the engine harness from the CM558 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the circuit diagram or the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged connector pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged pins.

Repair or replace the engine harness or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine wiring harness connector. Refer to Procedure 019-204 in Section 19.
  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the engine harness from the CM558 module.
  • Disconnect the engine harness from the turbocharger compressor intake air temperature sensor.

Action

Use a multimeter to check for a short circuit to ground in the engine harness:

  • Measure the resistance from the turbocharger compressor bypass actuator position feedback pin at the CM558 connector to all other pins in the CM558 connector.
  • Measure the resistance from the turbocharger compressor bypass actuator RETURN (-) pin at the CM558 connector to all other pins in the CM558 connector.

Use the circuit diagram or the wiring diagram to identify connectors and pins.

  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the engine harness from the CM558 module.
  • Disconnect the engine harness from the turbocharger compressor intake air temperature sensor.

Action

Use a multimeter to check for an open circuit to ground in the engine harness:

  • Measure the resistance from the turbocharger compressor bypass actuator position feedback pin at the CM558 connector to the turbocharger compressor bypass actuator position feedback pin at the turbocharger compressor intake air temperature sensor connector.
  • Measure the resistance from the turbocharger compressor bypass actuator RETURN (-) pin at the CM558 connector to the turbocharger compressor intake air temperature sensor connector.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the engine harness.

  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the engine harness from the turbocharger compressor bypass actuator.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Check for the appropriate CM558 response within 30 seconds
  • Use INSITE™ electronic service tool verify the fault codes.

Fault Code 1795 inactive?
YES NO
No Repair

Repair

A problem has been detected within the CM558 module.

Replace the CM558 module.

  • Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for longer than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 1795 is inactive.

Fault Code 1795 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 09-May-2012


FAULT CODE 1796 - Engine Turbocharger Compressor Bypass Actuator Position Sensor - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new CM558, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for an active fault code. |
 | STEP 1A. Check for an active fault code. | Fault Code 1796 active?
 | STEP 1B. Check for multiple active fault codes. | Fault Codes 441, 442, 477, or 478 active?
STEP 2. | Check the turbocharger compressor bypass actuator. |
 | STEP 2A. Inspect the turbocharger compressor bypass actuator connector and engine harness connector pins. | Dirty or damaged connector pins?
 | STEP 2B. Check the actuator position feedback voltage. | 0 to 5-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit from pin-to-ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit in the engine harness. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 1796 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 1796 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 1796 active?
YES NO

Repair

Follow the appropriate troubleshooting steps of the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 1B

Go to 1B

Guided Step 1B - Check for multiple active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.

Action

Check for multiple active/inactive fault codes.

  • Use INSITE™ electronic service tool to read the active and inactive fault codes.

Fault Codes 441, 442, 477, or 478 are active?
YES NO

Repair

Follow the appropriate troubleshooting steps of the active fault codes or contact a Cummins® Authorized Repair Location.

 No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check the turbocharger compressor bypass actuator.

Guided Step 2A - Inspect the turbocharger compressor bypass actuator connector and the engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness from the turbocharger compressor bypass actuator.

Action

Inspect the turbocharger compressor bypass actuator connector, the engine harness connector, and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged connector?
YES NO

Repair

A damaged connection has been detected in the turbocharger compressor actuator connector or harness connector.

Repair or replace the engine harness or the turbocharger compressor bypass actuator, whichever has the damaged connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the turbocharger compressor bypass valve. Contact a Cummins® Authorized Repair Location to perform this repair.
 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the actuator position feedback signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check the turbocharger compressor bypass actuator position feedback signal voltage.

  • Use the actuator test function within INSITE™ electronic service tool to drive the turbocharger compressor bypass valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the turbocharger compressor bypass actuator position feedback signal voltage by connecting the multimeter test probes between the position feedback SIGNAL pin and the RETURN (–) pin on the actuator connector. The voltage signal must be between 0 and 5-VDC based on the actuator position.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Refer to the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

0 to 5-VDC?
YES NO
No Repair

Repair

Replace the turbocharger compressor bypass control valve.

Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode
  • Disconnect the engine harness from the CM558.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform all these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or connector?
YES NO

Repair

Clean the connector and pins.

Replace the damaged pins.

Repair or replace the engine harness or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode
  • Disconnect the engine harness from the CM558 module.
  • Disconnect the engine harness from the turbocharger compressor bypass actuator

Action

Use a multimeter to check for a short circuit to ground in the engine harness:

  • Measure the resistance from the turbocharger compressor bypass actuator Position FEEDBACK pin at the CM558 connector to all other pins in the CM558 connector.
  • Measure the resistance from the turbocharger compressor bypass actuator RETURN (-) pin at the CM558 connector to all other pins in the CM558 connector.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short has been detected in the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit from pin to ground in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness from the CM558 module.
  • Disconnect the engine harness from the turbocharger compressor bypass actuator.

Action

Use a multimeter to check for a short circuit to ground in the engine harness:

  • Measure the resistance from the turbocharger compressor bypass actuator position FEEDBACK pin at the CM558 connector to the engine block ground.
  • Measure the resistance from the turbocharger compressor bypass actuator RETURN (-) pin at the CM558 connector to the engine block ground.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short has been detected in the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness from the CM558 module.
  • Disconnect the engine harness from the turbocharger compressor bypass actuator.

Action

Use a multimeter to check for an open circuit in the engine harness:

  • Measure the resistance from the turbocharger compressor bypass actuator position FEEDBACK pin at the CM558 connector to the turbocharger compressor bypass actuator position FEEDBACK pin at the turbocharger compressor bypass actuator connector.
  • Measure the resistance from the turbocharger compressor bypass actuator RETURN (-) pin at the CM558 connector to the turbocharger compressor bypass actuator RETURN (-) pin at the turbocharger compressor bypass actuator connector.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the engine harness from the turbocharger compressor bypass actuator connector.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Check for the appropriate circuit response within 30 seconds
  • Use INSITE™ electronic service tool to verify the fault codes.

Fault Code 1796 inactive?
YES NO
No Repair

Repair

A problem has been detected within the CM558 module.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for longer than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 1796 is inactive.

Fault Code 1796 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 09-May-2012


FAULT CODE 1797 - Engine Turbocharger Compressor Bypass Actuator Control Command Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new CM558, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code1797 active?
 | STEP 1B. Check for multiple active fault codes. | Fault Codes 441, 442, 477, and/or 478 active?
STEP 2. | Check the turbocharger compressor bypass actuator. |
 | STEP 2A. Inspect the turbocharger compressor bypass actuator connector and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the actuator commanded signal percentage of duty cycle. | Percentage of duty cycle 10 to 91 percent?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for an open-circuit in the engine harness. | Less than 10 ohms?
STEP 4. | Check the CM558 module. |
 | STEP 4A. Check the actuator commanded signal percentage of duty cycle at the CM558 module. | Percentage of duty cycle 10 to 91 percent?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 1797 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit
  • Place run/stop/auto switch in the OFF mode

Action

Check for an active code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 1797 active?
YES NO

Repair

Follow the appropriate troubleshooting steps of the ative fault codes or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 1B

Go to 1B

Guided Step 1B - Check for multiple active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit
  • Place run/stop/auto switch in the OFF mode

Action

Check for multiple active/inactive fault codes.

  • Use INSITE™ electronic service tool to read the active and inactive fault codes.

Fault Codes 441, 442, 477, and/or 478 active?
YES NO

Repair

Follow the appropriate troubleshooting steps of the ative fault codes or contact a Cummins® Authorized Repair Location.

 No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check the turbocharger compressor bypass actuator.

Guided Step 2A - Inspect the turbocharger compressor bypass actuator connector and the engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Disconnect the engine harness from the turbocharger compressor bypass actuator.

Action

Inspect the turbocharger compressor bypass actuator connector, the engine harness connector, and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the turbocharger compressor actuator connector or harness connector.

Repair or replace the engine harness or the turbocharger compressor bypass actuator, whichever has the damaged connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the turbocharger compressor bypass control valve. Contact a Cummins® Authorized Repair Location to perform this repair.
 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the actuator commanded signal percentage duty cycle .

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percentage duty cycle.

  • Use the actuator test function within INSITE™ electronic service tool to drive the turbocharger compressor bypass valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percentage duty cycle by connecting the multimeter test probes between the turbocharger compressor bypass actuator position signal (+) and RETURN (–) pins at the actuator connector. The signal percentage of duty cycle must be between 10 and 91 percent, based on the actuator position.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Refer to the specification table provided in the Shop Talk section of this document for percentage of duty cycle specifications.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

Percentage of duty cycle 10 to 91 percent?
YES | NO
No Repair | No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the engine harness from the CM558.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform all these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins ?
YES NO

Repair

Clean the connector and pins.

Replace the damaged pins.

Replace the engine harness or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness connector. Refer to Procedure 019-204 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the engine harness from the CM558 module.
  • Disconnect the engine harness from the turbocharger compressor intake air temperature sensor.

Action

Use a multimeter to check for a short circuit to ground in the engine harness:

  • Measure the resistance from the turbocharger compressor bypass actuator SIGNAL (+) pin at the CM558 connector to all other pins in the CM558 connector.
  • Measure the resistance from the turbocharger compressor bypass actuator RETURN (-) pin at the CM558 connector to all other pins in the CM558 connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short has been detected in the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the engine harness from the CM558 module.
  • Disconnect the engine harness from the turbocharger compressor intake air temperature sensor.

Action

Use a multimeter to check for an open circuit in the engine harness:

  • Measure the resistance from the turbocharger compressor bypass actuator SIGNAL (+) pin at the CM558 connector to the turbocharger compressor intake air temperature sensor SIGNAL (+) pin at the turbocharger compressor intake air temperature sensor connector.
  • Measure the resistance from the turbocharger compressor bypass actuator RETURN (-) pin at the CM558 connector to the turbocharger compressor intake air temperature sensor RETURN (-) pin at the turbocharger compressor intake air temperature sensor connector.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM558 module.

Guided Step 4A - Check the actuator commanded signal percentage duty cycle at the CM558 module.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percentage duty cycle at the CM558 connector.

  • Use the actuator test function within INSITE™ electronic service tool to drive the turbocharger compressor bypass valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percentage of duty cycle by connecting the multimeter test probes between the turbocharger compressor bypass actuator position SIGNAL (+) and RETURN (–) pins at the CM558 connector. The signal percentage of duty cycle must be between 10 and 91 percent.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Refer to the specification table provided in the Shop Talk section of this document for percentage duty cycle specifications.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Percentage duty cycle 10 to 91 percent?
YES NO
No Repair

Repair

A problem has been detected within the CM558 module.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for longer than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 1797 is inactive.

Fault Code 1797 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 09-May-2012


FAULT CODE 1798 - Engine Turbocharger Compressor Bypass Actuator Control Command Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new CM558, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1798 active?
 | STEP 1B. Check for multiple active fault codes. | Fault Codes 441, 442, 477, and/or 478 active?
STEP 2. | Check the turbocharger compressor bypass actuator. |
 | STEP 2A. Inspect the turbocharger compressor bypass actuator connector and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the actuator commanded signal percent duty cycle. | Precentage of duty cycle 10 to 91 percent?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit from pin-to-ground in the engine harness. | Greater than 100k ohms?
STEP 4. | Check for a CM558 module. |
 | STEP 4A. Check the actuator commanded signal percent duty cycle at the CM558 connector. | Percentage of duty cycle 10 to 91 percent?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 1798 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check for an active code.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1798 active?
YES NO

Repair

Follow the appropriate troubleshooting steps of the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 1B

Go to 1B

Guided Step 1B - Check for multiple active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 441, 442, 477, and/or 478 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the turbocharger compressor bypass valve.

Guided Step 2A - Inspect the actuator and the harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the engine harness connector from the turbocharger compressor bypass valve.

Action

Inspect the actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins

Repair or replace the engine harness or replace the turbocharger compressor bypass valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Replace the appropriate connector seal if is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the turbocharger compressor bypass control valve. Contact a Cummins® Authorized Repair Location to perform this repair.
 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the actuator commanded signal percent duty cycle.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the main engine harness from the turbocharger compressor bypass valve.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle.

  • Use the actuator test function within INSITE™ electronic service tool to drive the turbocharger compressor bypass valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percentage of duty cycle by connecting the multimeter test probes between the turbocharger compressor bypass actuator position SIGNAL (+) and RETURN (–) pins at the actuator connector. The signal percentage of duty cycle must be between 10 and 91 percent, based on the actuator position.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Refer to the specification table provided in the Shop Talk section of this document for percentage of duty cycle specifications.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

Percentage of duty cycle 10 to 91 percent?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the engine harness from the turbocharger compressor bypass valve and the CM558.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform all these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or connector?
YES NO

Repair

Clean the connector and pins.

Replace the damaged pins.

Repair or replace the engine harness or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the engine harness from the CM558 module.
  • Disconnect the engine harness from the turbocharger compressor bypass actuator.

Action

Use a multimeter to check for a short circuit-to-ground in the engine harness:

  • Measure the resistance from the turbocharger compressor bypass actuator SIGNAL (+) pin at the CM558 connector to all other pins in the CM558 connector.
  • Measure the resistance from the turbocharger compressor bypass actuator RETURN (-) pin at the CM558 connector to all other pins in the CM558 connector.
  • Use the following procedure for general resistance measurent Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

a pin-to-pin short has been detected in the engine harness.

  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit from pin-to-ground in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the engine harness from the CM558 module.
  • Disconnect the engine harness from the turbocharger compressor bypass actuator.

Action

Use a multimeter to check for a short circuit to engine block ground in the engine harness:

  • Measure the resistance from the turbocharger compressor bypass actuator SIGNAL (+) pin at the CM558 connector to the engine block ground.
  • Refer to the circuit diagram or the appropriate wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techiques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM558 module.

Guided Step 4A - Check the actuator commanded signal percent duty cycle at the CM558 module.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded position signal percent duty cycle at the CM558 connector.

  • Use the actuator test function within INSITE™ electronic service tool to drive the turbocharger compressor bypass valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the turbocharger compressor bypass actuator position SIGNAL (+) and RETURN (–) pins at the CM558 connector. The signal percentage of duty cycle must be between 10 and 91 percent, based on the actuator position.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Refer to the specification table provided in the Shop Talk section of this document for percentage of duty cycle specifications.

  • Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

Percentage of duty cycle 10 to 91 percent?
YES NO
No Repair

Repair

A problem has been detected within the CM558 module.

  • Replace the CM558 module. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for longer than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 1798 is inactive.

Fault Code 1798 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if the steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 08-Nov-2010


FAULT CODE 1799 - Engine Turbocharger Compressor Bypass Actuator Control Command - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 – male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 – female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 2892245 - diagnostic breakout cable kit, and Part Number 3824892 - breakout cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple active fault codes. | Fault Code 1795, 1796, 1797, and/or 1798 active?
STEP 2. | Check the turbocharger compressor bypass actuator. |
 | STEP 2A. Check the turbocharger compressor bypass valve for free movement. | Commanded position signal and feedback signal within 30 percent?
 | STEP 2B. Inspect the turbocharger compressor bypass actuator connector and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the actuator commanded signal percent duty cycle. | Percent duty cycle 10 to 94 percent?
 | STEP 2D. Check the actuator feedback signal voltage. | 0 to 5-VDC?
STEP 3. | Check the CM558 module. |
 | STEP 3A. Check the actuator commanded signal percent duty cycle at the CM558 connector. | Percent duty cycle 10 to 94 percent?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1799 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for multiple active/inactive fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 1795, 1796, 1797, and/or 1798 active?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

 No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the turbocharger compressor bypass actuator.

Guided Step 2A - Check the turbocharger compressor bypass valve for free movement.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the turbocharger compressor bypass valve for free movement.

  • Use the Actuator Diagnostic Tests feature located within the ECM Diagnostic Test options within INSITE™ electronic service tool. Test the valve for free movement throughout its full range (0 to 100 percent).
  • Compare the commanded position signal and feedback position signal values.
  • Contact your local Cummins®Authorized Repair Location.

Commanded position signal and feedback signal within 30 percent?
YES NO
No Repair

Repair

A problem has been detected with the turbocharger compressor bypass valve or its control and feedback circuit.

Proceed to the next troubleshooting step.

Go to 4A

Go to 2B

Guided Step 2B - Inspect the turbocharger compressor bypass actuator connector and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the turbocharger compressor bypass actuator.

Action

Inspect the turbocharger compressor bypass actuator connector, the engine harness connector, and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the turbocharger compressor actuator connector or harness connector

Repair or replace the engine harness or the turbocharger compressor bypass actuator, whichever has the damaged connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the turbocharger compressor bypass valve. Contact Cummins® Authorized Repair Location.
 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the actuator commanded signal percent duty cycle.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle.

  • Use the actuator test function within INSITE™ electronic service tool to drive the turbocharger compressor bypass valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the breakout harnesses Part Number 2892245 and Part Number 3824892, and connecting the multimeter test probes between the turbocharger compressor bypass actuator position SIGNAL (+) and RETURN (–) pins at the breakout harness test connectors. The signal percent duty cycle must be between 10 and 94 percent based on the actuator position.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Refer to the specification table provided in the Shop Talk section of this document for percent duty cycle specifications.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

Use the following procedure for compressor bypass valve inspection techniques. Refer to Procedure 010-136 in Section 10 of the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396.

Percent duty cycle 10 to 94 percent?
YES NO
No Repair

Repair

Proceed to the next troubleshooting step.

Go to 4A

Go to 3A

Guided Step 2D - Check the actuator position feedback signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the turbocharger compressor bypass actuator signal voltage.

  • Use the actuator test function within INSITE™ electronic service tool to drive the turbocharger compressor bypass valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the signal feedback voltage by connecting the breakout harnesses, Part Number 2892245 and Part Number 3824892, and connecting the multimeter test probes between the turbocharger compressor bypass actuator position SIGNAL (+) and RETURN (–) pins. The feedback signal must be between 0 to 5-VDC.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Refer to the specification table provided in the Shop Talk section of this document for position feedback voltage specifications

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

Use the following procedure for compressor bypass valve inspection techniques. Refer to Procedure 010-136 in Section 10 of the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396.

0 to 5-VDC?
YES NO
No Repair

Repair

A problem has been detected in the turbocharger compressor bypass control valve.

  • Replace the turbocharger compressor bypass valve.
  • Refer to Procedure 010-136 in Section 10 of the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396.

Go to 3A

Go to 4A

Guided Step 3 - Check the CM558 module.

Guided Step 3A - Check the actuator commanded signal percent duty cycle at the CM558 module.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded position signal percent duty cycle at the CM558 connector.

  • Use the actuator test function within INSITE™ electronic service tool to drive the turbocharger compressor bypass valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the turbocharger compressor bypass actuator position SIGNAL(+) and RETURN (–) pins at the right bank CM558 connector B. The signal percent duty cycle must be between 10 and 94 percent, based on the actuator position.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Refer to the specification table provided in the Shop Talk section of this document for percentage of duty cycle specifications.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

Use the following procedure for compressor bypass valve inspection techniques. Refer to Procedure 010-136 in Section 10 of the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396.

Percentage of duty cycle 10 to 94 percent?
YES NO
No Repair

Repair

A problem has been detected within the CM558 module.

  • Replace the CM558 module. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for more than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 1799 is inactive.

Fault Code 1799 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 11-Jan-2012


FAULT CODE 1811 - Engine Fuel Shutoff Valve Leak Test Control Circuit – Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1839 active?
STEP 2. | Check the Valve Proving System Module. |
 | STEP 2A. Inspect the Valve Proving System Module and Gas Valve harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the Valve Proving System Module supply voltage. | Supply voltage 18VDC - 27.6-VDC?
STEP 3. | Check the Valve Proving System Module harness. |
 | STEP 3A. Check the engine harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault Code 1811 inactive and Fault Code 1812 active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 1811 inactive?
 | STEP 5B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1839 active?
YES NO

Repair

Troubleshoot the Fault Code using the appropriate troubleshooting chart.

  • Reference Fault Code 1839 (Gas Supply Pressure Sensor - Voltage Above Normal or Shorted to High Source) in Section TF.
 No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check the Valve Proving System Module

Guided Step 2A - Inspect the Valve Proving System (VPS) Module and GasValve harness connector pins.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the harness from the Valve Proving System (VPS) module.

Action

Inspect the VPS module and the harness for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the damaged pins.

Repair or replace the gas valve harness or replace the VPS module, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture form the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector.
  • Replace the gas valve harness.
  • Replace the VPS module. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 005-230 in Section 5.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the Valve Proving System (VPS) Module supply voltage.

Conditions

  • Keyswitch circuit energized.
  • Disconnect the harness from the Valve Proving System (VPS) Module.
  • Connect INSITE™ electronic service tool.
  • Place Run/Stop/Auto switch in RUN mode, operate engine and perform a normal shutdown.

Action

Immediately following the engine shutdown, check the VPS Module supply voltage:

  • Use a multimeter to connect the multimeter test leads to the VPS supply and return pins in the gas valve harness connector and check the VPS Module supply voltage. Contact a Cummins® Authorized Repair Location.

Supply voltage 18VDC – 27.6-VDC?
YES NO
No Repair

Repair

Check the 24VDC power supply connections and the fuses in the harness. Refer to the appropriate engine wiring diagram for the appropriate circuit.

Go to 4A

Go to 3A

Guided Step 3 - Check the Valve Proving System (VPS) Module harness.

Guided Step 3A - Inspect the Valve Proving System (VPS) Module and Gas Valve harness connector pins.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in StOP mode.
  • Disconnect the harness from th Valve Proving System (VPS) module and the CM700 module.

Action

Inspect the engine harness and the connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the damaged pins.

Repair or replace the appropriate harness section or replace the VPS module, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the gas valve harness,the extension harness, or the Generator Interface Box (GIB) harness as appropriate. Contact a Cummins® Authorized Repair Location.
  • Replace the VPS module. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 005-230 in Section 5.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in STOP mode.
  • Isolate the Generator Set 24VDC Power Supply.
  • Disconnect the harness from the Valve Proving System (VPS) module and the CM700 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance from the VPS Module SUPPLY pin in the CM700 connector to all other pins in the Generator Interface Box harness.
  • Measure the resistance from the VPS Module RETURN pin in the CM700 connector to all other pins in the Generator Interface Box harness.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness or harness connector.

  • Repair the appropriate wiring harness. Contact a Cummins® Authorized Repair Location.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24VDC power supply.
  • Disconnect the harness from the Valve Proving System (VPS) module and the CM700 module.

Action

Check for an open circuit.

  • Measure the resistance from the VPS SUPPLY pin in the VPS Module connector to the VPS Module SUPPLY pin in the CM700 module connector.
  • Measure the resistance from the VPS RETURN pin in the VPS Module connector to the VPS Module RETURN pin in the CM700 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness or the harness connector.

  • Repair the appropriate wiring harness. Contact a Cummins® Authorized Repair Location. Repair the engine harness.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM700 response.

Guided Step 4A - Check for the appropriate CM700 response.

Conditions

  • Keyswitch circuit de-energised.
  • Disconnect the harness from the Valve Proving System (VPS) module.
  • Connect INSITE™ electronic service tool.
  • Place RUN/STOP/AUTO switch in the RUN mode, engine running, and perform a normal engine shutdown.

Action

Check for the appropriate CM700 response:

  • Fault Code 1811 will become inactive and Fault Code 1812 will become active.
  • Use INSITE™ electronic service tool to verify the fault codes.

Fault Code 1811 inactive, Fault Code 1812 active?
YES NO
No Repair

Repair

Replace the CM700 module.

  • Refer to Procedure 019-031 in Section 19.
  • Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 3B

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Place Run/Stop/Auto switch in RUN mode and for longer than 1 minute.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 1811 is inactive.

Fault Code 1811 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 09-May-2012


FAULT CODE 1812 - Engine Fuel Shutoff Valve Leak Test Control Circuit –Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1841 active?
STEP 2. | Check the Valve Proving System Module. |
 | STEP 2A. Inspect the Valve Proving System Module and Gas Valve harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the Valve Proving System Module supply voltage. | Supply voltage 18VDC - 27.6-VDC?
STEP 3. | Check the Valve Proving System Module harness. |
 | STEP 3A. Check the engine harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1812 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1841 active?
YES NO

Repair

Troubleshoot the Fault Code using the appropriate troubleshooting chart.

  • Reference Fault Code 1839 (Gas Supply Pressure Sensor - Voltage Above Normal or Shorted to High Source) in Section TF.
 No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the Valve Proving System Module

Guided Step 2A - Inspect the Valve Proving System (VPS) Module and Gas Valve harness connector pins.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the harness from the Valve Proving System (VPS) module.

Action

Inspect the VPS module and the harness for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the damaged pins.

Repair or replace the gas valve harness or replace the VPS module, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture form the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector.
  • Replace the gas valve harness. Contact a Cummins® Authorized Repair Location.
  • Replace the VPS module. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 005-230 in Section 5.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the Valve Proving System (VPS) Module supply voltage.

Conditions

  • Keyswitch circuit energized.
  • Disconnect the harness from the Valve Proving System (VPS) Module.
  • Connect INSITE™ electronic service tool.
  • Place Run/Stop/Auto switch in RUN mode, engine running, and perform a normal shutdown.

Action

Immediately following the engine shutdown, check the VPS Module supply voltage:

  • Use a multimeter to connect the multimeter test leads to the VPS supply and return pins in the gas valve harness connector and check the VPS Module supply voltage. Contact a Cummins® Authorized Repair Location.

Supply voltage 18VDC – 27.6-VDC?
YES NO
No Repair

Repair

Check the 24VDC power supply connections and the fuses in the harness. Refer to the appropriate engine wiring diagram for the appropriate circuit.

Go to 4A

Go to 3A

Guided Step 3 - Check the Valve Proving System (VPS) Module harness.

Guided Step 3A - Inspect the Valve Proving System (VPS) Module and Gas Valve harness connector pins.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the harness from th Valve Proving System (VPS) module and the CM700 module.

Action

Inspect the engine harness and the connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the damaged pins.

Repair or replace the appropriate harness section or replace the VPS module, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the gas valve harness, the extension harness or the Generator Interface Box (GIB) harness as appropriate. Contact a Cummins® Authorized Repair Location.
  • Replace the VPS module. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 005-230 in Section 5.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in STOP mode.
  • Isolate the Generator Set 24VDC Power Supply.
  • Disconnect the harness from the Valve Proving System (VPS) module and the CM700 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance from the VPS Module SUPPLY pin in the CM700 connector to all other pins in the Generator Interface Box harness.
  • Measure the resistance from the VPS Module RETRUN pin in the CM700 connector to all other pins in the Generator Interface Box harness.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness or harness connector.

  • Repair the appropriate wiring harness. Contact a Cummins® Authorized Repair Location.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Isolate the generator set 24VDC power supply.
  • Disconnect the harness from the Valve Proving System (VPS) module and the CM700 module.

Action

Check for an open circuit.

  • Measure the resistance from the VPS SUPPLY pin in the VPS Module connector to the VPS Module SUPPLY pin in the CM700 module connector.
  • Measure the resistance from the VPS RETURN pin in the VPS Module connector to the VPS Module RETURN pin in the CM700 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness or the harness connector.

  • Repair the appropriate wiring harness. Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in RUN mode and operate engine for longer than 1 minute.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 1812 is inactive.

Fault Code 1812 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Use INSITE™ electronic service tool, clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 13-Oct-2010


FAULT CODE 1813 - Engine Fuel Shutoff Valve Leak Test – Data Valid But Below Normal Operating Range – Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1841 active?
STEP 2. | Check the Fuel Double Solenoid Shutoff Valve (DSSV). |
 | STEP 2A. Check the upstream and downstream shutoff valves. | Dirty or damaged shutoff valves?
STEP 3. | Check the Valve Proving System (VPS) Module. |
 | STEP 3A. Check the Valve Proving System (VPS) Module seals. | Damaged VPS seals?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1813 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1841 active?
YES NO

Repair

Troubleshoot the Fault Code using the appropriate troubleshooting chart.

  • Reference Fault Code 1839 (Gas Supply Pressure Sensor - Voltage Above Normal or Shorted to High Source) in Section TF.
 No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the Fuel Double Solenoid Shutoff Valve (DSSV).

Guided Step 2A - Check the upstream and downstream shutoff valves.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the harness from the fuel double solenoid shutoff valve.

Action

Check the upstream and downstream shutoff valves:

  • Remove the fuel double solenoid shutoff valve (DSSV) from the main fuel supply line. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G Generator Set CM700, Bulletin 4021396. Refer to Procedure 005-044 in Section 5.
  • Check the condition of the upstream and downstream shutoff valves. Contact a Cummins® Authorized Repair Location.

Check the upstream and downstream gas valves for the following:

  • Damaged valves and valve seats
  • Moisture in or on the valves
  • Dirt or debris in or on the valves.

Dirty or damaged shutoff valves?
YES NO

Repair

Repair or replace the fuel double solenoid shutoff valve.

  • Flush the dirt, debris, or moisture from the upstream or downstream gas valves. Contact a Cummins® Authorized Repair Location.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector.
  • Replace the gas valve harness. Contact a Cummins® Authorized Repair Location.
  • Replace the fuel double solenoid shutoff valve (DSSV). Use the following procedure in the Troubleshooting and Repair Manual, QSK60G Generator Set CM700, Bulletin 4021396. Refer to Procedure 005-044 in Section 5.
No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the Valve Proving System (VPS) Module

Guided Step 3A - Check the Valve Proving System (VPS) Module seals.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the harness from the valve proving system (VPS) module.

Action

Remove the Valve Proving System (VPS) Module and inspect the module seals:

  • Remove the Valve Proving System Module (VPS) by removing the 4 screws (1). Use the following procedure in the Troubleshooting and Repair Manual, QSK60G Generator Set CM700, Bulletin 4021396. Refer to Procedure 005-230 in Section 5.

Inspect the Valve Proving System (VPS) Module seals for the following:

  • Damaged seals
  • Dirt or debris on the seals
  • Dirt or debris on the integral VPS filters.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G Generator Set CM700, Bulletin 4021396. Refer to Procedure 005-230 in Section 5.

Damaged VPS seals?
YES NO

Repair

Repair or replace the Valve Proving System (VPS) Module:

  • Flush the dirt or debris from the seals
  • Replace the damaged seals
  • Replace the VPS Module integral filters.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 005-230 in Section 5.
No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Place Run/Stop/Auto switch in RUN mode and operate engine for longer than 1 minute.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 1813 is inactive.

Fault Code 1813 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Use INSITE™ electronic service tool, clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 13-Oct-2010


FAULT CODE 1814 - Engine Fuel Shutoff Valve Leak Test – Data Valid But Below Normal Operating Range – Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1814 active?
STEP 2. | Check the Fuel Double Solenoid Shutoff Valve (DSSV). |
 | STEP 2A. Check the upstream and downstream shutoff valves. | Dirty or damaged shutoff valves?
STEP 3. | Check the Valve Proving System (VPS) Module. |
 | STEP 3A. Check the Valve Proving System (VPS) Module seals. | Damaged VPS seals?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1814 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1841 active?
YES NO

Repair

Troubleshoot the fault code using the appropriate troubleshooting chart.

  • Reference Fault Code 1839 (Gas Supply Pressure Sensor - Voltage Above Normal or Shorted to High Source) in Section TF.
 No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the Fuel Double Solenoid Shutoff Valve (DSSV).

Guided Step 2A - Check the upstream and downstream shutoff valves.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the harness from the fuel double solenoid shutoff valve.

Action

Check the upstream and downstream shutoff valves:

  • Remove the fuel double solenoid shutoff valve (DSSV) from the main fuel supply line. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G Generator Set CM700, Bulletin 4021396. Refer to Procedure 005-044 in Section 5.
  • Check the condition of the upstream and downstream shutoff valves. Contact a Cummins® Authorized Repair Location.

Check the upstream and downstream gas valves for the following:

  • Damaged valves and valve seats
  • Moisture in or on the valves
  • Dirt or debris in or on the valves.

Dirty or damaged shutoff valves?
YES NO

Repair

Repair or replace the fuel double solenoid shutoff valve.

  • Flush the dirt, debris, or moisture from the upstream or downstream gas valves. Contact a Cummins® Authorized Repair Location.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector.
  • Replace the gas valve harness. Contact a Cummins® Authorized Repair Location.
  • Replace the fuel double solenoid shutoff valve (DSSV). Use the following procedure in the Troubleshooting and Repair Manual, QSK60G Generator Set CM700, Bulletin 4021396. Refer to Procedure 005-044 in Section 5.
No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the Valve Proving System (VPS) Module

Guided Step 3A - Check the Valve Proving System (VPS) Module seals.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the harness from the valve proving system (VPS) module.

Action

Remove the Valve Proving System (VPS) Module and inspect the module seals:

  • Remove the Valve Proving System Module (VPS) by removing the 4 screws (1). Use the following procedure in the Troubleshooting and Repair Manual, QSK60G Generator Set CM700, Bulletin 4021396. Refer to Procedure 005-230 in Section 5.

Inspect the Valve Proving System (VPS) Module seals for the following:

  • Damaged seals
  • Dirt or debris on the seals
  • Dirt or debris on the integral VPS filters.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G Generator Set CM700, Bulletin 4021396. Refer to Procedure 005-230 in Section 5.

Damaged VPS seals?
YES NO

Repair

Repair or replace the Valve Proving System (VPS) Module:

  • Flush the dirt or debris from the seals
  • Replace the damaged seals
  • Replace the VPS Module integral filters.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 005-230 in Section 5.
No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in RUN mode and operate engine for longer than 1 minute.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 1814 is inactive.

Fault Code 1814 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Use INSITE™ electronic service tool, clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 13-Oct-2010


FAULT CODE 1821 - Engine Crankshaft Speed / Position Very Low EngineSpeed Detected When Engine is Supposed to be Running - Root Cause Not Known

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple active fault codes. | Fault codes 121, 234, 689, 1546, 1793 and/or 1837 active?
STEP 2. | Check the crankshaft engine speed sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged crankshaft engine speed sensor or engine harness connector pins?
 | STEP 2B. Inspect the crankshaft engine speed sensor for damage. | Damaged crankshaft engine speed sensor?
 | STEP 2C. Check the crankshaft engine speed sensor resistance. | Resistance 750 – 1500 ohms?
 | STEP 2D. Check for a short circuit to ground in the crankshaft engine speed sensor. | Greater than 100k ohms?
STEP 3. | Check the camshaft engine speed/position sensor. |
 | STEP 3A. Inspect the sensor and engine harness connector pins. | Dirty or damaged sensor or engine harness connector pins?
 | STEP 3B. Inspect the sensor for damage. | Damaged camshaft engine speed/position sensor?
 | STEP 3C. Check the resistance of the sensor. | Less than 2k ohms?
 | STEP 3D. Check for a short circuit to engine block ground. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit between coils. | Greater than 100k ohms?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 4D. Check for a short circuit from pin-to-pin in the engine harness. | Greater than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 1821 inactive?
 | STEP 5B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronicservice tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in the RUN mode.

Action

Operate the engine at normal load conditions.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 121, 234, 689, 1546, 1793 and/or 1837 active?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-360 in Section 19.

No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check for the crankshaft engine speed sensor

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in OFF mode.
  • Disconnect the engine harness connector from the crankshaft engine speed sensor connector.

Action

Inspect the crankshaft engine speed sensor connector and the engine harness connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged sensor or engine harness connector pins?
YES NO

Repair

Repair or replace the damaged engine harness connector or crankshaft engine speed sensor.

  • Repair or replace the damaged connector. Refer to Procedure 019-206 in Section 19.
  • Replace the crankshaft engine speed sensor. Refer to Procedure 019-042 in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the crankshaft engine speed sensor for damage.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in OFF mode.
  • Disconnect the engine harness from the crankshaft engine speed sensor connector.
  • Remove the crankshaft engine speed sensor.

Action

Inspect the crankshaft engine speed sensor for the following:

  • Metal debris on end of sensor
  • Damage to the end of the sensor caused by contacting the flywheel
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damaged crankshaft engine speed sensor?
YES NO

Repair

The crankshaft engine speed sensor is damaged.

  • Refer to Procedure 019-042 in Section 19.
No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check the crankshaft engine speed sensor resistance.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in OFF mode.
  • Disconnect the engine harness connector from the crankshaft engine speed sensor connector.

Action

Measure the resistance.

  • Use a multimeter to measure the resistance of the crankshaft engine speed sensor from the speed SIGNAL(+) pin to the speed RETURN (-) pin at the sensor connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance 750 – 1500 ohms?
YES NO
No Repair

Repair

The crankshaft engine speed sensor has malfunctioned.

  • Replace the crankshaft engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the crankshaft engine speed sensor.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in OFF mode.
  • Disconnect the engine harness connector from the crankshaft engine speed sensor connector.

Action

Measure the resistance.

  • Use a multimeter to measure the resistance of the crankshaft engine speed sensor from the speed SIGNAL(+) pin on the sensor to the engine ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

The crankshaft engine speed sensor is damaged.

  • Replace the crankshaft engine speed sensor. Refer to Procedure 019-042 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check for the camshaft engine speed/position sensor

Guided Step 3A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in OFF mode.
  • Disconnect the engine harness from the control module.

Action

Inspect the camshaft engine speed/position sensor connector and the engine harness connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following proceure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged camshaft speed/position sensor or engine harness connector pins?
YES NO

Repair

Repair or replace the damaged engine harness connector or camshaft engine speed/position sensor.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged engine harness or connector. Refer to Procedure 019-043 in Section19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section19.
  • Replace the camshaft engine speed/position sensor. Refer to Procedure 019-038 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the camshaft engine speed/position sensor for damage.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in OFF mode.
  • Disconnect the engine harness connector from the camshaft engine speed/position sensor connector.
  • Remove the camshaft engine speed/position sensor.

Action

Inspect the camshaft engine speed/position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by contacting the flywheel
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of the sensor
  • Refer to Procedure 019-038 in Section 19.

Damaged camshaft engine speed/position sensor?
YES NO

Repair

The camshaft engine speed/position sensor is damaged.

  • Replace the camshaft engine speed/position sensor. Refer to Procedure 019-038 in Section 19.
No Repair

Go to 5A

Go to 3C

Guided Step 3C - Check the camshaft engine speed/position sensor resistance.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in OFF mode.
  • Disconnect the engine harness connector from the camshaft engine speed/position sensor.

Action

Check the resistance of the sensor.

  • Use a multimeter to measure the resistance of the camshaft engine speed/position sensor from the speed/position SIGNAL(+) pin to the speed/position RETURN (-) pin at the sensor connector.
  • Use a multimeter to measure the resistance of the camshaft engine speed/position sensor backup SIGNAL (+) pin to the speed/position sensor backup RETURN (-) at the sensor connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2k ohms?
YES NO
No Repair

Repair

The camshaft engine speed/position sensor has malfunctioned.

  • Replace the camshaft engine speed/position sensor. Refer to Procedure 019-038 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a short circuit to ground in the camshaft engine speed/position sensor.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in OFF mode.
  • Disconnect the engine harness connector from the camshaft engine speed/position sensor.

Action

Check for a short circuit to ground.

  • Use a multimeter to measure the resistance of the camshaft engine speed/position sensor from the speed/position SIGNAL(+) pin on the sensor to the engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

The camshaft engine speed/position sensor is damaged.

  • Replace the camshaft engine speed/position sensor. Refer to Procedure 019-038 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check the camshaft engine speed/position sensor for a short between coils.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in OFF mode.
  • Disconnect the engine harness connector from the camshaft engine speed/position sensor.

Action

Check the sensor for short circuit between coils.

  • Use a multimeter to measure the resistance of the camshaft engine speed/position sensor from the speed/position SIGNAL(+) pin of one coil to all other pins in the sensor connector.
  • Use a multimeter to measure the resistance of the camshaft engine speed/position sensor RETURN (-) pin to all other pins at the sensor connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

The camshaft engine speed/position sensor has malfunctioned.

  • Replace the camshaft engine speed/position sensor. Refer to Procedure 019-038 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the engine harness

Guided Step 4A - Inspect the engine harness and ECM connector pins.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in OFF mode.
  • Disconnect the engine harness from the CM700 module.
  • Disconnect the harness from both CM558 modules.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following proceure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or connector?
YES NO

Repair

Clean the connector and pins.

  • Replace the damaged pins.
  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine wiring harness. Refer to Procedure 019-204 in Section 19 or Refer to Procedure 019-206 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section19.
No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open-circuit in the engine harness.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in OFF mode.
  • Disconnect the engine harness from the CM700 and both CM558 control modules.
  • Disconnect the engine harness from the crankshaft engine speed sensor.
  • Disconnect the engine harness from the engine camshaft speed/position sensor.

Action

Use a multimeter to check for an open circuit in the engine harness:

  • Measure the resistance from the crankshaft engine speed SIGNAL (+) pin at the CM700 connector to the crankshaft engine speed SIGNAL (+) pin at the crankshaft engine speed sensor connector.
  • Measure the resistance from the crankshaft engine speed RETURN (-) pin at the CM700 connector to the crankshaft engine speed RETURN (-) pin at the crankshaft engine speed sensor connector.
  • Measure the resistance from the camshaft engine speed/position SIGNAL (+) pin at the CM558 left-bank connector to the camshaft engine/position speed SIGNAL (+) pin at the camshaft engine speed/position sensor connector.
  • Measure the resistance from the camshaft engine speed/position RETURN (-) pin at the CM558 left-bank connector to the camshaft engine speed/position RETURN (-) pin at the camshaft engine speed/position sensor connector.
  • Measure the resistance from the camshaft engine speed/position backup SIGNAL (+) pin at the CM558 right-bank connector to the camshaft engine/position speed backup SIGNAL (+) pin at the camshaft engine speed/position sensor connector.
  • Measure the resistance from the camshaft engine speed/position backup RETURN (-) pin at the CM558 right-bank connector to the camshaft engine speed/position backup RETURN (-) pin at the camshaft engine speed/position sensor connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the engine harness.

  • Repair the engine wiring harness. Refer to Procedure 019-204 in Section 19 or Refer to Procedure 019-206 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short to ground in the engine harness.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in OFF mode.
  • Disconnect the engine harness from the CM700 module.
  • Disconnect the engine harness from the crankshaft engine speed sensor.
  • Disconnect the engine harness from both CM558 modules.
  • Disconnect the engine harness from the camshaft engine speed/position sensor.

Action

Use a multimeter to check for a short circuit to ground in the engine harness:

  • Measure the resistance from the crankshaft engine speed SIGNAL (+) pin at the CM700 connector to the engine block ground.
  • Measure the resistance from the camshaft engine speed/positionSIGNAL (+) pin at the left-bank CM558 module to the engine block ground.
  • Measure the resistance from camshaft engine speed/position backup SIGNAL (+) pin at the right-bank CM558 module to engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short to ground has been detected in the engine harness. Inspect the engine harness for a short-to-ground.

  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 5A

Guided Step 4D - Check for a pin-to-pin short in the engine harness.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in OFF mode.
  • Disconnect the engine harness from the CM700 module.
  • Disconnect the engine harness from the crankshaft engine speed sensor.
  • Disconnect the engine harness from both CM558 modules.
  • Disconnect the engine harness from the camshaft engine speed/position sensor.

Action

Use a multimeter to check for a short circuit to ground in the engine harness:

  • Measure the resistance from the crankshaft engine speed SIGNAL (+) pin at the CM700 connector to all other pins in the CM700 connector.
  • Measure the resistance from the crankshaft engine speed RETURN (-) pin at the CM700 connector to all other pins in the CM700 connector.
  • Measure the resistance from the camshaft engine speed/position SIGNAL (+) pin at the left-bank CM558 connector to all other pins in the left-bank CM558 connector.
  • Measure the resistance from the camshaft engine speed/position RETURN (-) pin at the left-bank CM558 connector to all other pins in the right-bank CM558 connector.
  • Measure the resistance from the camshaft engine speed/position backup SIGNAL (+) pin at the right-bank CM558 connector to all other pins in the right-bank CM558 connector.
  • Measure the resistance from the camshaft engine speed/position backup RETURN (-) pin at the right-bank CM558 connector to all other pins in the right-bank CM558 connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short has been detected in the engine harness.

  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in RUN mode and operate engine for longer than 1 minute.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 1821 is inactive.

Fault Code 1821 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 12-Oct-2010


FAULT CODE 1822 - Engine Aftercooler Coolant Level (LT) – Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1822 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Verify the fault code is inactive. | Fault Code 1822 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault code 1822 active?
YES NO

Repair

Reference troubleshooting trees t021-240 (Coolant Pressure Low - High Temperature Circuit) and t021-250 (Coolant Pressure Low - Low Temperature Circuit) in section TS in the Troubleshooting and Repair Manual, QSK60G CM700 Generator, Bulletin 4021396.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Place Run/Stop/Auto switch in RUN mode and operatre engine for longer than 1 minute.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 1822 is inactive.

Fault Code 1822 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 13-Oct-2010


FAULT CODE 1823 - Engine Aftercooler Coolant Level (LT) – Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1823 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Verify the fault code is inactive. | Fault Code 1823 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault code 1823 active?
YES NO

Repair

Reference troubleshooting trees t021-240 (Coolant Pressure Low - High Temperature Circuit) and t021-250 (Coolant Pressure Low - Low Temperature Circuit) in section TS in the Troubleshooting and Repair Manual, QSK60G CM700 Generator, Bulletin 4021396.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Place Run/Stop/Auto switch in RUN mode and operatre engine for longer than 1 minute.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 1823 is inactive.

Fault Code 1823 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 13-Oct-2010


FAULT CODE 1824 - Engine Oil Temperature Sensor 1 Circuit - Too Cold for High Idle - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 212, 213, 2789, 2793, 2869, 2871, or 2872 active?
STEP 2. | Check the engine goes to rated speed. |
 | STEP 2A. Check the engine goes to rated speed. | Engine has speed increased to rated speed?
STEP 3. | Check the oil cooling system. |
 | STEP 3A. Check the oil cooling system temperature. | Oil cooling system operating temperature to specification?
STEP 4. | Check the engine oil temperature sensor 1. |
 | STEP 4A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the resistance of the sensor. | 625 ohms to 36k ohms?
 | STEP 4C. Check for a short circuit to engine block ground. | More than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 1824 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check for active fault codes.

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 212, 213, 2789, 2793, 2869, 2871, or 2872 active?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.
No Repair

5A

Go to 2A

Guided Step 2 - Check the engine goes to rated speed

Guided Step 2A - Check the engine goes to rated speed.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and operate engine for more than 1 minute.

Action

Continue to run the engine at low idle (900 rpm).

  • Operate the engine and observe for oil temperature rise. The engine should go to rated speed within 30 minutes. Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance , Bulletin 4021395. Refer to Procedure 101-015 in Section 1.

Engine has speed increased to rated speed?
YES | NO
No Repair | No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the oil cooling system

Guided Step 3A - Check the oil temperature.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and operate engine for more than 1 minute.

Action

Verify that the engine oil temperature system operating temperature is to specification.

  • Via the Generator Set Human Machine Interface, check that the engine oil operating temperature is to specification. Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance , Bulletin 4021395. Refer to Procedure 018-017 in Section V.

Engine oil temperature to specification?
YES NO
No Repair

Repair

Proceed to the next troubleshooting procedure.

Go to 5A

Go to 4A

Guided Step 4 - Check the engine oil temperature sensor 1

Guided Step 4A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the oil temperature sensor and the CM700 module (connectors A and C).
  • Disconnect any other sensors that share the same signal or return circuits.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Wiring harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4B

Go to 5A

Guided Step 4B - Check the resistance of the oil temperature sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the engine harness from the oil temperature sensor.
  • Disconnect any other sensors that share the same signal or return circuits.

Action

Check the resistance of the engine oil temperature sensor:

  • Measure the resistance between the engine oil temperature SIGNAL pin and the engine oil temperature RETURN pin.
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance , Bulletin 4021395. Refer to Procedure 018-017 in Section V.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

625 ohms to 36k ohms?
YES NO
No Repair

Repair

Repair the engine oil temperature sensor.

Replace the oil temperature sensor. Refer to Procedure 019-067 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the engine harness from the oil temperature sensor.
  • Disconnect any other sensors that share the same signal or return circuits.

Action

Check for a short circuit to ground:

  • Measure the resistance from each of the pins of the engine oil temperature sensor connector to the engine block ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair the engine oil temperature sensor.

Replace the oil temperature sensor. Refer to Procedure 019-067 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and operate engine for greater than 1 minute.

Action

Verify inactive fault code.

  • Use INSITE™ electronic service tool to verify Fault Code 1824 is inactive.
  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 1824 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 04-May-2012


FAULT CODE 1826 - Incompatible Software version Determined in Secondary Control Module - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for Software Compatibility |
 | STEP 1A. Check for software compatibility. | Fault Code 1826 active?
 | STEP 1B. Clear the inactive fault codes | All fault codes cleared?

Guided Step 1 - Check for Software Compatibility

Guided Step 1A - Check for Software Compatibility.

Conditions

  • Connect INSITE™ electronic service tool.
  • Place Run/Stop/Auto switch on PCS front panel in STOP mode.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the software version of each CM558 Module.

Fault Code 1826 active?
YES NO

Repair

Use the electronic service tool to load compatible software into the CM558 modules.

 No Repair

Repair complete

Repair complete

Guided Step 1B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch on PCS front panel in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 13-Oct-2010


FAULT CODE 1827 - Engine Gas Control Valve Intake Pressure - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1827 active?
STEP 2. | Check the fuel pressure sensor and circuit. |
 | STEP 2A. Check the fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1828 active and Fault Code 1827 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Supply voltage 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1827 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1827 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1827 active?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for general inspection technques. Refer to Procedure 019-362 in Section 19.
No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check the fuel inlet pressure sensor and circuit

Guided Step 2A - Check the fuel inlet pressure sensor and connector pins.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in the OFF mode.
  • Disconnect the fuel inlet pressure sensor from the engine harness.

Action

Inspect the engine harness and fuel inlet pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, the harness connector or the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel inlet pressure sensor. Refer to Procedure 019-188 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Connect INSITE™ electronic service tool.
  • Place Run/Stop/Auto switch in the STOP mode.
  • Disconnect the fuel inlet pressure sensor from the engine harness.
  • Keyswitch circuit engergized.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1828 active and Fault Code1827 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Place Run/Stop/Auto switch in the STOP mode.
  • Disconnect the fuel inlet pressure sensor from the engine harness and install the pressure sensor breakout harness between the sensor and sensor harness connector.
  • Keyswitch circuit energized.

Action

Check the supply voltage and return circuit.

  • Measure the supply voltage between the fuel inlet pressure sensor SUPPLY pin and the fuel inlet pressure sensor RETURN pin at the fuel inlet pressure sensor breakout harness test connectors.

Supply voltage 4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Place Run/Stop/Auto switch in the STOP mode.
  • Keyswitch circuit de-energized.
  • Connect the fuel inlet pressure sensor to the engine harness.
  • Keyswitch circuit energized.
  • Connect INSITE™ electronicservice tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1827 active?
YES NO

Repair

A damaged sensor has been detected.

  • Replace the fuel inlet pressure sensor. Refer to Procedure 019-188 in Section 19.
No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in the STOP mode.
  • Isolate the generator set 24 VDC power supply.
  • Disconnect the engine harness fom the CM558 left-bank module.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harnesses and connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Wiring harness and ECM connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in the STOP mode.
  • Isolate the generator set 24VDC power supply.
  • Disconnect the fuel inlet pressure sensor from the engine harness.
  • Disconnect the engine harness from the left-bank CM558 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel inlet pressure sensor SIGNAL pin in the CM558 connector to all other pins in the engine harness.
  • Measure the resistance from the fuel inlet pressure sensor SUPPLY pin in the CM558 connector to all other pins in the engine harness.
  • Perform these checks on all interconnecting harnesses and connectors in the circuit.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

An pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in the RUN mode and operate engine for greater than 1 minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 1827 is inactive.

Fault code 1827 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Appropriate troubleshooting chart

Last Modified: 09-May-2012


FAULT CODE 1828 - Engine Gas Control Valve Intake Pressure - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1828 active?
STEP 2. | Check the fuel inlet pressure sensor and circuit. |
 | STEP 2A. Check the fuel inlet pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | Supply voltage 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | Signal voltage 0.50 to 4.50-VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 1828 inactive?
 | STEP 4B. Check the CM558 SIGNAL pin resistance. | Less than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 1828 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1828 active?
YES NO

Repair

Reference Fault Code 27 (Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source).

  • Use the following procedure for general inspection technques. Refer to Procedure 019-362 in Section 19.
No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check the fuel inlet pressure sensor.

Guided Step 2A - Check the fuel inlet pressure sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in the OFF mode.
  • Disconnect the fuel inlet pressure sensor from the engine harness.

Action

Inspect the engine harness and fuel inlet pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the engine harness, the harness connector or the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel inlet pressure sensor. Refer to Procedure 019-188 in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltagr.

Conditions

  • Connect INSITE™ electronic service tool.
  • Place Run/Stop/Auto switch in the STOP mode.
  • Disconnect the fuel pressure sensor from the engine harness and install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Keyswitch circuit energized.

Action

Check for the fuel inlet pressure supply voltage.

  • Measure the supply voltage with a mulitmeter between the breakout harness SUPPLY and RETURN test connectors.

Fuel Inlet Pressure Sensor Supply Voltage 4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Place Run/Stop/Auto switch in the STOP mode.
  • Disconnect the fuel pressure sensor from the engine harness and install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Keyswitch circuit energized.

Action

Check the fuel inlet pressure sensor signal circuit.

  • Measure the signal voltage with a multimeter between the breakout harness SIGNAL and RETURN test connectors.

Signal voltage 0.50 to 4.50-VDC?
YES NO
No Repair

Repair

A damaged sensor has been detected.

  • Replace the fuel inlet pressure sensor. Refer to Procedure 019-188 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine wiring harness.

Guided Step 3A - Inspect the engine wiring harness and connector pins.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in the STOP mode.
  • Isolate the generator set 24VDC power supply.
  • Disconnect the engine harness from the CM558 left-bank module.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harnesses and connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Wiring harness and ECM connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in the STOP mode.
  • Isolate the generator set 24VDC power supply.
  • Disconnect the fuel inlet pressure sensor from the engine harness.
  • Disconnect the engine harness from the left-bank CM558 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel inlet pressure sensor SIGNAL pin in the CM558 connector to all other pins in the engine harness.
  • Measure the resistance from the fuel inlet pressure sensor SUPPLY pin in the CM558 connector to all other pins in the engine harness.
  • Perform these checks on all interconnecting harnesses and connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL or SUPPLY circuit has been detected in the engine harness.

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in the STOP mode.
  • Isolate the generator set 24VDC power supply.
  • Disconnect the fuel inlet pressure sensor from the engine harness.
  • Disconnect the engine harness from the left-bank CM558 module.

Action

Check for an open circuit in the engine harness:

  • Measure the resistance from the fuel inlet pressure sensor SIGNAL pin in the CM558 connector to the fuel inlet pressure sensor SIGNAL pin in the engine harness fuel inlet pressure sensor connector.
  • Measure the resistance from the fuel inlet pressure sensor SUPPLY pin in the CM558 connector to the fuel inlet pressure sensor SUPPLY pin in the engine harness fuel inlet pressure sensor connector.
  • Measure the resistance from the fuel inlet pressure sensor RETURN pin in the CM558 connector to the fuel inlet pressure sensor RETURN pin in the engine harness fuel inlet pressure sensor connector.
  • Perform these checks on all interconnecting harnesses and connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit on the SIGNAL, SUPPLY, or RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM558 response

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in the STOP mode.
  • Disconnect the fuel inletpressure sensor connector.
  • Connect INSITE™ elctronic service tool.

Action

Check for the appropriate CM558 response:

  • Place a jumper wire between the fuel inlet pressure sensor SUPPLY pin and the fuel inlet pressure sensor SIGNAL pin of the sensor connector.
  • Check for the appropriate CM558 response after 30seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Fault Code 546 or Fault Code 1827 will become active upon installing the jumper wire.

Fault Code 1828 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM558 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in the STOP mode.
  • Disconnect the engine harness from the left-bank CM558 module.

Action

Check the CM558 SIGNAL pin resistance:

  • Measure the resistance from the fuel inlet pressure sensor SIGNAL pin on the CM558 to the CM558 fuel inlet pressure sensor RETURN pin.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 100k ohms?
YES NO
No Repair

Repair

Replace the left-bank CM558 module.

  • Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 4B

Guided Step 5 - Clear the fault codes

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in the RUN mode and operate engine for greater than 1 minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 1827 is inactive.

Fault code 1828 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Appropriate troubleshooting chart

Last Modified: 09-May-2012


FAULT CODE 1834 - Engine Coolant Circulating Pump Control (HT) - Breaker Tripped

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the Generator Set with PowerCommand™ Supervisor and Generator Set with PCC3300 |
 | STEP 1A. Read the PowerCommand™ Supervisor and PCC3300 fault code. | Is the fault code a PowerCommand™ Supervisor?
STEP 2. | Check the HT Control Valve trip sensing circuit. |
 | STEP 2A. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit between ECM and circuit breaker. | Less than 10 ohms?
 | STEP 2C. Check for an open circuit between circuit breaker and VDC Source. | Less than 10 ohms?
STEP 3. | Check the HT Control Valve supply circuit. |
 | STEP 3A. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground between circuit breaker and contactor A. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to ground between circuit breaker and contactor B. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground between contactor A and HT Control Valve. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit to ground between contactor B and HT Control Valve. | Greater than 100k ohms?
STEP 4. | Check for high resistance across contactors. |
 | STEP 4A. Check for high resistance across contactor A. | Less than 10 ohms?
 | STEP 4B. Check for high resistance across contactor B. | Less than 10 ohms?
STEP 5. | Check circuit breaker trip switch resistance. |
 | STEP 5A. Check for high resistance across circuit breaker trip switch with main switch closed. | Less than 10 ohms?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Clear the inactive fault codes. | All fault codes cleared?
 | STEP 6B. Verify the fault code is inactive. | Fault Code 1834 inactive?
STEP 7. | Check the fault codes. |
 | STEP 7A. Check the ECM for active fault codes. | Fault Code 1834 active?
STEP 8. | Check the HT Control Valve trip sensing circuit. |
 | STEP 8A. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 8B. Check for an open circuit between CM700 and MCB9 trip circuit. | Less than 10 ohms?
 | STEP 8C. Check for an open circuit between MCB9 trip circuit and MCB8 trip circuit. | Less than 10 ohms?
STEP 9. | Check the HT Control Valve supply circuit. |
 | STEP 9A. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 9B. Check for a short circuit to ground between MCB9 and contactor A. | Greater than 100k ohms?
 | STEP 9C. Check for a short circuit to ground between MCB9 and contactor B. | Greater than 100k ohms?
 | STEP 9D. Check for a short circuit to ground between contactor A and HT Control Valve. | Greater than 100k ohms?
 | STEP 9E. Check for a short circuit to ground between contactor B and HT Control Valve. | Greater than 100k ohms?
STEP 10. | Check for high resistance across contactors. |
 | STEP 10A. Check for high resistance across contactor A. | Less than 10 ohms?
 | STEP 10B. Check for high resistance across contactor B. | Less than 10 ohms?
STEP 11. | Check circuit breaker trip switch resistance. |
 | STEP 11A. Check for high resistance across MCB8 trip switch with main switch closed. | Less than 10 ohms?
 | STEP 11B. Check for high resistance across MCB9 trip switch with main switch closed. | Less than 10 ohms?
STEP 12. | Clear the fault codes. |
 | STEP 12A. Clear the inactive fault codes. | All fault codes cleared?
 | STEP 12B. Verify the fault code is inactive. | Fault Code 1834 inactive?

Guided Step 1 - Check the Generator Set with PowerCommand™ Supervisor and Generator Set with PCC3300.

Guided Step 1A - Read the PowerCommand™ Supervisor and PCC3300 fault codes.

Conditions

  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code.

  • Verify whether fault code PowerCommand™ Supervisor or PCC3300 is active?

Is active fault code a PowerCommand™ Supervisor?
YES NO
No Repair

Repair

This is a PCC3300 fault code. Begin troubleshooting at Guided Step 7A.

Go to 2A

Go to 7A

Guided Step 2 - Check the HT Control Valve trip sensing circuit.

Guided Step 2A - Inspect the wiring harness and connector pins.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the harness at the MCB6 trip out and CM700.

Action

Inspect the circuit breaker trip circuit and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the harness or the MCB, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the contact pins. Use electronic contact cleaner, Part Number 3824510.
 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check for an open circuit between ECM and circuit breaker.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in STOP mode.
  • Disconnect the harness at the MCB6 trip out and CM700.

Action

Check for an open circuit.

  • Measure the harness' electrical resistance from the MCB6 trip circuit out to the CM700.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

Go to 2C

Go to 6A

Guided Step 2C - Check for an open circuit between circuit breaker and VDC source.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the harness at the MCB6 trip in and VDC source.

Action

Check for an open circuit.

  • Measure the MCB6 trip supply harness' electrical resistance between VDC source and MCB6 trip in.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

Go to 6A

Go to 3A

Guided Step 3 - Check the HT Control Valve supply

Guided Step 3A - Inspect the wiring harness and connector pins.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the harness at the VAC isolator, MCB6 main, KM6A contactor, KM6B contactor and HT Control Valve.

Action

Inspect the harnesses and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the harness, MCB,KM, HT Control Valve, or whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the contact pins. Use electronic contact cleaner, Part Number 3824510.
 No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check for a short circuit to ground between circuit breaker and contactor A.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the harness at the MCB6 main out and KM6A contactor in.

Action

Check for a short circuit to ground.

  • Measure the harness' electrical resistance from the MCB6 main circuit outlet to electrical ground.
  • Measure the harness' electrical resistance from the KM6A contactor circuit inlet to electrical ground.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit to ground between circuit breaker and contactor B.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the harness at the MCB6 main out and KM6B contactor in.

Action

Check for a short circuit to ground.

  • Measure the harness' electrical resistance from the MCB6 main circuit outlet to electrical ground.
  • Measure the harness' electrical resistance from the KM6B contactor circuit inlet to electrical ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

Go to 3D

Go to 6A

Guided Step 3D - Check for a short circuit to ground between contactor A and HT Control Valve.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the harness at the KM6A contactor out to HT Control Valve.

Action

Check for a short circuit to ground.

  • Measure the harness' electrical resistance from the KM6A contactor out to electrical ground.
  • Measure the harness' electrical resistance from the HT Control Valve to electrical ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

Go to 3E

Go to 6A

Guided Step 3E - Check for a short circuit to ground between contactor B and HT Control Valve.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the harness at the KM6A contactor out to HT Control Valve.

Action

Check for a short circuit to ground.

  • Measure the harness' electrical resistance from the KM6B contactor out to electrical ground.
  • Measure the harness' electrical resistance from the HT Control Valve to electrical ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

Go to 4A

Go to 6A

Guided Step 4 - Check for high resistance across contactors.

Guided Step 4A - Check for high resistance across contactor A.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the harness at the KM6A contactor and driver in and out.

Action

Supply KM6A driver in with +24VDC. Check resistance across KM6A contactor.

  • Measure KM6A contactor's electrical resistance from contactor in to out.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Replace the KM6A.

Go to 4B

Go to 6A

Guided Step 4B - Check for high resistance across contactor B.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the harness at the KM6B contactor and driver in and out.

Action

Supply KM6B driver in with +24VDC. Check resistance across KM6B contactor.

  • Measure KM6B contactor's electrical resistance from contactor in to out.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Replace the KM6B.

Go to 5A

Go to 6A

Guided Step 5 - Check circuit breaker trip switch resistance.

Guided Step 5A - Check for high resistance across circuit breaker trip switch with main switch closed.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the harness at MCB6 trip switch in and out and MCB6 main switch in and out.

Action

Close MCB6 main switch. Check resistance of MCB6 trip circuit.

  • Measure electrical resistance of MCB6 trip circuit in and out.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Replace the MCB6.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Clear the inactive fault codes.

  • Clear the inactive fault codes by pressing the "Reset" button on the control panel and cycling the engine keyswitch. Use INSITE™ electronic service tool to verify inactive fault codes are cleared.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Go to 6B

Appropriate troubleshooting steps

Guided Step 6B - Verify the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Place Run/Stop/Auto switch in Run mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.
  • Connect all components

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 1834 is inactive.

Fault Code 1834 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Guided Step 7 - Check the fault codes.

Guided Step 7A - Check the ECM for active fault codes.

Conditions

  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1834 active?
YES | NO
No Repair | No Repair

Go to 8A

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 8 - Check the HT Control Valve trip sensing circuit.

Guided Step 8A - Inspect the wiring harness and connector pins.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the harness at the MCB6 trip out and CM700.

Action

Inspect the circuit breaker trip circuit and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the harness or the MCB, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the contact pins. Use electronic contact cleaner, Part Number 3824510.
 No Repair

Go to 12A

Go to 8B

Guided Step 8B - Check for an open circuit between CM700 and MCB9 trip circuit.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the harness at the MCB9 trip out and CM700.

Action

Check for an open circuit.

  • Measure the harness' electrical resistance from the MCB9 trip circuit out to the CM700.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

Go to 8C

Go to 12A

Guided Step 8C - Check for an open circuit between MCB9 trip circuit and MCB8 trip circuit.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the harness at the MCB9 trip out and MCB8 trip in.

Action

Check for an open circuit.

  • Measure the harnesses' electrical resistance from the MCB9 trip circuit out to MCB8 trip circuit in.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

Go to 8D

Go to 12A

Guided Step 8D - Check for an open circuit between MCB8 trip circuit and Battery regulator out return.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the harness at the MCB8 trip out and Battery Regulator Out return.

Action

Check for an open circuit.

  • Measure the MCB6 trip supply harness' electrical resistance between VDC source and MCB6 trip in.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

Go to 12A

Go to 9A

Guided Step 9 - Check the HT Control Valve supply

Guided Step 9A - Inspect the wiring harness and connector pins.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the harness at the VAC isolators, MCB8 and MCB9 mains, KM6A contactor, KM6B contactor and HT Control Valve.

Action

Inspect the harnesses and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the harness, MCB,KM, HT Control Valve of which ever has the damaged pins.

  • Flush the dirt, debris, or moisture from the contact pins. Use electronic contact cleaner, Part Number 3824510.
 No Repair

Go to 12A

Go to 9B

Guided Step 9B - Check for a short circuit to ground between MCB9 and contactor A.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the harness at the MCB9 main out and KM6A contactor in.

Action

Check for a short circuit to ground.

  • Measure the harness' electrical resistance from the MCB9 main circuit outlet to electrical ground.
  • Measure the harness' electrical resistance from the KM6A contactor circuit inlet to electrical ground.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

Go to 9C

Go to 12A

Guided Step 9C - Check for a short circuit to ground between MCB9 and contactor B.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the harness at the MCB9 main out and KM6B contactor in.

Action

Check for a short circuit to ground.

  • Measure the harness' electrical resistance from the MCB9 main circuit outlet to electrical ground.
  • Measure the harness' electrical resistance from the KM6B contactor circuit inlet to electrical ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

Go to 9D

Go to 12A

Guided Step 9D - Check for a short circuit to ground between contactor A and HT Control Valve.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the harness at the KM6A contactor out to HT Control Valve.

Action

Check for a short circuit to ground.

  • Measure the harnesses' electrical resistance from the KM6A contactor out to electrical ground.
  • Measure the harnesses' electrical resistance from the HT Control Valve to electrical ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

Go to 9E

Go to 12A

Guided Step 9E - Check for a short circuit to ground between contactor B and HT Control Valve.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the harness at the KM6A contactor out to HT Control Valve.

Action

Check for a short circuit to ground.

  • Measure the harness' electrical resistance from the KM6B contactor out to electrical ground.
  • Measure the harness' electrical resistance from the HT Control Valve to electrical ground.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

Go to 10A

Go to 12A

Guided Step 10 - Check for high resistance across contactors.

Guided Step 10A - Check for high resistance across contactor A.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the harness at the KM6A contactor and driver in and out.

Action

Supply KM6A driver in with +24VDC. Check resistance across KM6A contactor.

  • Measure KM6A contactor's electrical resistance from contactor in to out.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Replace the KM6A.

Go to 10B

Go to 12A

Guided Step 10B - Check for high resistance across contactor B.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the harness at the KM6B contactor and driver in and out.

Action

Supply KM6B driver in with +24VDC. Check resistance across KM6B contactor.

  • Measure KM6B contactor's electrical resistance from contactor in to out.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Replace the KM6B.

Go to 11A

Go to 12A

Guided Step 11 - Check circuit breaker trip switch resistance.

Guided Step 11A - Check for high resistance across MCB8 trip switch with MCB8 main switch closed.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the harness at the MCB8 trip switch in and out and MCB8 main switch in and out.

Action

Close MCB8 main switch. Check resistance of MCB8 trip circuit.

  • Measure electrical resistance of MCB6 trip circuit in and out.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Replace the MCB8.

Go to 11B

Go to 12A

Guided Step 11B - Check for high resistance across MCB9 trip switch with MCB9 main switch closed.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the harness at the MCB9 trip switch in and out and MCB9 main switch in and out.

Action

Close MCB9 main switch. Check resistance of MCB8 trip circuit.

  • Measure electrical resistance of MCB9 trip circuit in and out.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Replace the MCB8.

Go to 12A

Go to 12A

Guided Step 12 - Clear the fault codes.

Guided Step 12A - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Clear the inactive fault codes.

  • Clear the inactive fault codes by pressing the "Reset" button on the control panel and cycling the engine keyswitch. Use INSITE™ electronic service tool to verify inactive fault codes are cleared.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Go to 6B

Appropriate troubleshooting steps

Guided Step 12B - Verify the fault code is inactive.

Conditions

  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in RUN mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 1834 is inactive.

Fault Code 1834 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-May-2012


FAULT CODE 1837 - Camshaft Engine Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1837 active?
STEP 2. | Check the camshaft engine speed/position sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged sensor or engine harness connector pins?
 | STEP 2B. Check the camshaft speed/position sensor for damage. | Damaged camshaft engine speed/position sensor?
 | STEP 2C. Check the camshaft engine speed/position sensor resistance. | Less than 2k ohms?
 | STEP 2D. Check for a short circuit to ground in the camshaft engine speed/position sensor. | Greater than 100k ohms?
 | STEP 2E. Check the camshaft engine speed/position sensor for a short circuit between coils. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit from pin-to-pin in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1837 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.

Action

Operate the engine at normal load conditions.

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1837 active?
YES NO

Repair

Follow the appropriate troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the camshaft engine speed/position sensor.

Guided Step 2A - Inspect the sensor and the engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode
  • Disconnect the engine harness connector from the camshaft engine speed/position sensor connector.

Action

Inspect the engine harness and camshaft engine speed/position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged sensor or engine harness connector pins?
YES NO

Repair

Repair or replace the damaged engine harness connector or camshaft engine speed/position sensor.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness or connector. Refer to Procedure 019-043 in Section 19.
  • Replace the camshaft engine speed sensor. Refer to Procedure 019-038 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the camshaft engine speed/position sensor for damage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness connector from the camshaft engine speed/position sensor.
  • Remove the camshaft engine speed/position sensor.

Action

Inspect the camshaft engine speed/position sensor for the following:

  • Metal debris on the end of the sensor.
  • Damage to the end of the sensor caused by contacting the flywheel.
  • Oil leakage or insulation problems such as swelling.
  • Damaged electrical potting in sensing end of the sensor. Refer to Procedure 019-038 in Section 19.

Damaged camshaft engine speed/position sensor?
YES NO

Repair

  • Replace the camshaft engine speed/position sensor. Refer to Procedure 019-038 in Section 19.
No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the camshaft engine speed/position sensor resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode
  • Disconnect the engine harness connector from the camshaft engine speed/position sensor.

Action

Use a multimeter to check the resistance of the sensor.

  • Measure the resistance from the camshaft engine speed/position sensor SIGNAL positive (+) pin to the engine speed/position sensor RETURN negative (-) pin in the engine speed/position sensor connector.
  • Measure the resistance from the camshaft engine speed/position sensor backup SIGNAL positive (+) pin to the engine speed/position sensor backup RETURN negative (-) pin in the engine speed/position sensor connector.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 2k ohms?
YES NO
No Repair

Repair

The camshaft engine speed/position sensor has malfunctioned.

  • Replace the camshaft engine speed/position sensor. Refer to Procedure 019-038 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the camshaft engine speed/position sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness connector from the camshaft engine speed/position sensor

Action

Use a multimeter to check for a short circuit to ground.

  • Measure the resistance of the camshaft engine speed/position sensor from the speed/position SIGNAL (+) pin on the sensor to the engine block ground.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurment techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

The camshaft engine speed/position sensor is damaged.

  • Replace the camshaft engine speed/position sensor. Refer to Procedure 019-038 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check the camshaft engine speed/position sensor for a short circuit between coils.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode
  • Disconnect the engine harness from the camshaft engine speed/position sensor.

Action

Use a multimeter to check the sensor for a short circuit between coils.

  • Measure the resistance of the camshaft engine speed/position sensor from the speed/position SIGNAL (+) pin of one coil to all other pins in the sensor connector.
  • Measure the resistance of the camshaft engine speed/position sensor RETURN (-) pin to all other pins at the sensor connector.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

The camshaft engine speed/position sensor has malfunctioned.

  • Replace the camshaft engine speed/position sensor. Refer to Procedure 019-038 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode
  • Disconnect the harness from both CM558 modules.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or connectors?
YES NO

Repair

Clean the connector and pins.

Replace the damaged pins.

Repair or replace the engine harness or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-206 in Section 19.
  • Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness from both CM558 control modules.
  • Connect the engine harness from the camshaft engine speed/position sensor.

Action

Use a multimeter to check for an open circuit in the engine harness:

  • Measure the resistance from the camshaft engine speed/position SIGNAL (+) pin at the CM558 left-bank connector to the camshaft engine/position speed SIGNAL (+) pin at the camshaft engine speed/position sensor connector.
  • Measure the resistance from the camshaft engine speed/position RETURN (-) pin at the CM558 left-bank connector to the camshaft engine speed/position RETURN (-) pin at the camshaft engine speed/position sensor connector.
  • Measure the resistance from the camshaft engine speed/position backup SIGNAL (+) pin at the CM558 right-bank connector to the camshaft engine/position speed backup SIGNAL (+) pin at the camshaft engine speed/position sensor connector.
  • Measure the resistance from the camshaft engine speed/position backup RETURN (-) pin at the CM558 right-bank connector to the camshaft engine speed/position backup RETURN (-) pin at the camshaft engine speed/position sensor connector.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-206 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short to ground in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness from both CM558 control modules.
  • Disconnect the engine harness from the camshaft engine speed/position sensor.

Action

Use a multimeter to check for a short circuit to ground in the engine harness:

  • Measure the resistance from the camshaft engine speed/position sensor SIGNAL (+) pin at the left-bank CM558 module to the engine block ground.
  • Measure the resistance from the camshaft engine speed/position backup SIGNAL (+) pin at the right-bank CM558 control module to the engine block ground.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short to ground has been detected in the engine harness. Inspect the engine harness for a short to ground.

  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the engine harness from both CM558 control modules.
  • Disconnect the engine harness from the camshaft engine speed/position sensor.

Action

Use a multimeter to check for a short circuit to ground in the engine harness:

  • Measure the resistance from the camshaft engine speed/position SIGNAL (+) pin at the left-bank CM558 connector to all other pins in the left-bank CM558 connector.
  • Measure the resistance from the camshaft engine speed/position RETURN (-) pin at the left-bank CM558 connector to all other pins in the right-bank CM558 connector.
  • Measure the resistance from the camshaft engine speed/position backup SIGNAL (+) pin at the right-bank CM558 connector to all other pins in the right-bank CM558 connector.
  • Measure the resistance from the camshaft engine speed/position backup RETURN (-) pin at the right-bank CM558 connector to all other pins in the right-bank CM558 connector.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short has been detected in the engine harness.

  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for longer than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 1837 is inactive.

Fault Code 1837 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Nov-2010


FAULT CODE 1838 - Generator Electrical Overload (kW) Signal (Partial Overload) - Data Valid But High - Serious

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the Generator Set with PowerCommand® Supervisor and Generator Set with PCC3300. |
 | STEP 1A. Read the PowerCommand® Supervisor and PCC3300 fault codes. | Is active fault code a PowerCommand® Supervisor?
STEP 2. | Check the kilowatt accuracy. |
 | STEP 2A. Verify the kilowatt load demanded by the parallel controller is not above the generator set limits. | Kilowatt load command below set limits?
STEP 3. | Check the ECM value. |
 | STEP 3A. Verify that the fault simulation feature for the kW overload is not enabled. | Fault simulation disabled?
STEP 4. | Check the current transformers. |
 | STEP 4A. Inspect the current transformers and current transformer connections. | Current transformer connections correct?
 | STEP 4B. Check the AC harness. | Dirty or damaged pins?
 | STEP 4C. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 4D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 5. | Check the PT/CT board. |
 | STEP 5A. Check the PT/CT board 3 ohm resistors. | 3 ohm resistors good?
 | STEP 5B. Inspect the PT/CT board and the generator control harness connector pins. | Dirty of damaged pins?
STEP 6. | Check the generator control harness. |
 | STEP 6A. Inspect the generator control harness and the ECM connector pins. | Dirty of damaged pins?
 | STEP 6B. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 6C. Check for an open circuit. | Less than 10 ohms?
 | STEP 6D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Clear the inactive fault codes. | All fault codes cleared?
 | STEP 7B. Verify the fault code is inactive. | Fault Code 1838 inactive?
STEP 8. | Check the fault codes. |
 | STEP 8A. Check the ECM for active fault codes. | Fault Code 1838 active?
STEP 9. | Check the kilowatt accuracy. |
 | STEP 9A. Verify the kilowatt load demanded by the parallel controller is not above the generator set limits. | Kilowatt load command below set limits?
STEP 10. | Check the ECM value. |
 | STEP 10A. Verify that the fault simulation feature for the kW overload is not enabled. | Fault simulation disabled?
STEP 11. | Check the current transformers. |
 | STEP 11A. Inspect the current transformers and current transformer connections. | Current transformer connections correct?
 | STEP 11B. Check the AC harness. | Dirty or damaged pins?
 | STEP 11C. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 11D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 12. | Check the generator control harness. |
 | STEP 12A. Inspect the generator control harness and the ECM connector pins. | Dirty of damaged pins?
 | STEP 12B. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 12C. Check for an open circuit. | Less than 10 ohms?
 | STEP 12D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 13. | Clear the fault codes. |
 | STEP 13A. Clear the inactive fault codes. | All fault codes cleared?
 | STEP 13B. Verify the fault code is inactive. | Fault Code 1838 inactive?

Guided Step 1 - Check the Generator Set with PowerCommand® Supervisor and Generator Set with PCC3300.

Guided Step 1A - Read the PowerCommand® Supervisor and PCC3300 fault codes.

Conditions

  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code.

Verify whether fault code PowerCommand® Supervisor or PCC3300 is active.

Is active fault code a PowerCommand® Supervisor?
YES NO
No Repair

Repair

This is a PCC3300 fault code. Begin troubleshooting at Guided Step 8A.

Go to 1A

Go to 8A

Guided Step 2 - Check the kilowatt accuracy.

Guided Step 2A - Verify the kilowatt load demanded by the parallel controller is not above generator set limits.

Conditions

  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Verify kilowatt load demand is not above generator set limits.

  • Use INSITE™ electronic service tool to verify the kilowatt load demanded by the parallel controller is not above generator set limits.

Kilowatt load command not above set limits?

YES NO
No Repair

Repair

  • Refer to customer/facility/installation documentation.

Go to 3A

Go to 7A

Guided Step 3 - Check the ECM value.

Guided Step 3A - Verify that the fault simulation feature for the kilowatt overload is not enabled.

Conditions

  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Verify that the fault simulation feature is not enabled.

  • Use INSITE™ electronic service tool to verify that the fault simulation feature for the kilowatt overload is not enabled.

Fault simulation disabled?
YES NO
No Repair

Repair

  • kW overload is enabled. Refer to customer/facility/installation documentation.

Go to 4A

Go to 7A

Guided Step 4 - Check the current transformers.

Guided Step 4A - Inspect the current transformers and current transformer connections.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the AC harness connectors from the current transformers.

Action

Inspect the current transformers and the current transformer connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the AC harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.
No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the AC harness.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the AC harness from the PT/CT Board.

Action

Inspect the AC harness connector and the PT/CT board connector 09 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the engine harness, or replace the AC harness and/or PT/CT board, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the AC harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.
  • Replace the PT/CT Board. Refer to Procedure 019-318 in Section 19.
No Repair

Go to 7A

Go to 4C

Guided Step 4C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the AC harness from the PT/CT Board.
  • Disconnect the AC harness connectors from the current transformers.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each current transformer pin on the AC harness PT/CT board connector to engine block ground.
  • Repeat previous step for all other current transformer pins.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the AC harness from the PT/CT Board.
  • Disconnect the AC harness connectors from the current transformers.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the current transformer pins on the AC harness connector to all other pins on the AC harness connector.
  • Repeat previous step for all other current transformer pins.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the PT/CT board.

Guided Step 5A - Check the PT/CT board 3 ohm resistors.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the AC harness from the PT/CT Board.

Action

Verify the 3-ohm resistors from PT/CT board connector 08.

  • Measure the resistance between CT21 pin on connector 08 and CT21 COM pin on connector 08.
  • Measure the resistance between CT22 pin on connector 08 and CT22 COM pin on connector 08.
  • Measure the resistance between CT23 pin on connector 08 and CT23 COM pin on connector 08.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Are the 3 ohm resistors good?
YES NO
No Repair

Repair

Replace the PT/CT board.

  • Replace the PT/CT Board. Refer to Procedure 019-318 in Section 19.

Go to 5B

Go to 7A

Guided Step 5B - Inspect the PT/CT board and the generator control harness connector pins.

Conditions

  • Keyswitch circuit de-engergized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the PT/CT board from the generator control harness.

Action

Inspect the generator control harness and the CM700 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the generator control, CM700 and/or control harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the generator set parallel board. Refer to Procedure 019-322 in Section 19.
No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check the generator control harness.

Guided Step 6A - Inspect the generator control harness and the ECM connector pins.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the generator control harness from the CM700.

Action

Inspect the generator control harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the generator control, PT/CT board and/or control harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the generator set or parallel board. See wiring diagram for appropriate board. Refer to Procedure 019-318 in Section 19.
No Repair

Go to 7A

Go to 6B

Guided Step 6B - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the generator control harness from the CM700.
  • Disconnect the generator control harness from the generator control.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each pin on the generator control harness ECM connector to engine block ground.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the generator control, PT/CT board and/or control harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the PT/CT board. See wiring diagram for appropriate board. Refer to Procedure 019-318 in Section 19.

Go to 6C

Go to 7A

Guided Step 6C - Check for an open circuit in the generator control harness.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the generator control harness from the CM700.
  • Disconnect the generator control harness from the generator control.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from each of the pins on the generator control harness PT/CT board connector to the aligned generator control harness ECM connector pin.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 6D

Go to 7A

Guided Step 6D - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the generator control harness from the CM700.
  • Disconnect the generator control harness from the generator control.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of each pin on the generator control harness ECM connector to all other pins on the generator control harness ECM connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Clear the inactive fault codes.

  • Clear inactive fault codes by pressing the “Reset” button on the control panel and cycling the engine keyswitch.
  • Use INSITE™ electronic service tool to verify inactive fault codes are cleared.

All fault codes cleared?
YES NO
No Repair

Repair

  • Troubleshoot any remaining active fault codes.

Go to 7B

Appropriate troubleshooting steps

Guided Step 7B - Verify the fault code is inactive.

Conditions

  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in RUN mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 1838 is inactive.

Fault Code 1838 inactive?
YES NO
No Repair

Repair

  • Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Guided Step 8 - Check the fault codes.

Guided Step 8A - Check the ECM for active fault codes.

Conditions

  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1838 active?
YES | NO
No Repair | No Repair

Go to 9A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 9 - Check the kilowatt accuracy.

Guided Step 9A - Verify the kilowatt load demanded by the parallel controller is not above generator set limits.

Conditions

  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Verify kilowatt load demand is not above generator set limits.

  • Use INSITE™ electronic service tool to verify the kilowatt load demanded by the parallel controller is not above generator set limits.

Kilowatt load command not above set limits?

YES NO
No Repair

Repair

  • Refer to customer/facility/installation documentation.

Go to 10A

Go to 13A

Guided Step 10 - Check the ECM value.

Guided Step 10A - Verify that the fault simulation feature for the kilowatt overload is not enabled.

Conditions

  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Verify that the fault simulation feature is not enabled.

  • Use INSITE™ electronic service tool to verify that the fault simulation feature for the kilowatt overload is not enabled.

Fault simulation disabled?
YES NO
No Repair

Repair

  • kW overload simulation is enabled. Reference the customer/facility/installation documentation to disable fault simulation.

Go to 11A

Go to 13A

Guided Step 11 - Check the current transformers.

Guided Step 11A - Inspect the current transformers and current transformer connections.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the AC harness connectors from the current transformers.

Action

Inspect the current transformers and the current transformer connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the AC harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.
No Repair

Go to 13A

Go to 11B

Guided Step 11B - Check the AC harness.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the AC harness from the PT/CT Board.

Action

Inspect the AC harness connector and the PT/CT board connector 09 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the engine harness, or replace the AC harness and/or PT/CT board, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the AC harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.
  • Replace the PT/CT Board. Refer to Procedure 019-318 in Section 19.
No Repair

Go to 13A

Go to 11C

Guided Step 11C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the AC harness from the PT/CT Board.
  • Disconnect the AC harness connectors from the current transformers.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each current transformer pin on the AC harness generator control connector toengine block ground.
  • Repeat previous step for all other current transformer pins.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 11D

Go to 13A

Guided Step 11D - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the AC harness from the PT/CT Board.
  • Disconnect the AC harness connectors from the current transformers.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the current transformer pins on the AC harness connector to all other pins on the AC harness connector.
  • Repeat previous step for all other current transformer pins.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 12A

Go to 13A

Guided Step 12 - Check the generator control harness.

Guided Step 12A - Inspect the generator control harness and the CM700 connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the generator control harness from the CM700.

Action

Inspect the generator control harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the generator control, PT/CT board, and/or control harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the generator set control board. Refer to Procedure 019-322 in Section 19.
No Repair

Go to 13A

Go to 12B

Guided Step 12B - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the generator control harness from the CM700.
  • Disconnect the generator control harness from the generator control.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each pin on the generator control harness ECM connector to engine block ground.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the generator control, PT/CT board, and/or control harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 6C

Go to 13A

Guided Step 12C - Check for an open circuit in the generator control harness.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the generator control harness from the CM700.
  • Disconnect the generator control harness from the generator control.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from each of the pins on the generator control harness generator control connector to the aligned CM700 connector pin.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 12D

Go to 13A

Guided Step 12D - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-engergized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Disconnect the generator control harness from the CM700.
  • Disconnect the generator control harness from the generator control.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from each of the pins on the generator control harness generator control connector to all other CM700 connector pins.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 13A

Go to 13A

Guided Step 13 - Clear the fault codes.

Guided Step 13A - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Clear the inactive fault codes.

  • Clear inactive fault codes by pressing the “Reset” button on the control panel and cycling the engine keyswitch.
  • Use INSITE™ electronic service tool to verify inactive fault codes are cleared.

All fault codes cleared?
YES NO
No Repair

Repair

  • Troubleshoot any remaining active fault codes.

Go to 13B

Appropriate troubleshooting steps

Guided Step 13B - Verify the fault code is inactive.

Conditions

  • Keyswitch circuit engergized.
  • Place Run/Stop/Auto switch in RUN mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 1838 is inactive.

Fault Code 1838 inactive?
YES NO
No Repair

Repair

  • Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-May-2012


FAULT CODE 1839 - Gas Supply (Regulated) Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1839 active?
STEP 2. | Check the fuel supply pressure sensor and circuit. |
 | STEP 2A. Check the fuel supply pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1841 active and Fault Code 1839 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Supply voltage 4.75 and 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1839 active?
STEP 3. | Check the ECM and Generator Interface Box harness. |
 | STEP 3A. Inspect the ECM and Generator Interface Box harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 1839 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1839 active?
YES NO

Repair

Follow the appropriate troubleshooting steps for the Active Fault Codes or contact a Cummins® Authorized Repair Location.

  • Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.
No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the fuel supply pressure sensor and circuit

Guided Step 2A - Check the fuel supply pressure sensor and connector pins.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/auto switch in the OFF mode.
  • Disconnect the harness from the fuel supply pressure sensor.

Action

Inspect the gas valve harness and fuelsupply pressure sensor connector pinsfor the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the gas valve harness, the harness connector or the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the gas valve wiring harness. Contact your local Cummins® Authorized Repair Location.
  • Replace the fuel supply pressure sensor. Contact a Cummins® Authorized Repair Location.
 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Connect INSITE™ electronic service tool.
  • Place Run/Stop/Auto switch in the STOP mode.
  • Disconnect the harness from the fuel supply pressure sensor.
  • Keyswitch circuit energized.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1841 active and Fault Code 1839 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Place Run/Stop/Auto switch in the STOP mode.
  • Disconnect the harness from the fuel supply pressure sensor and install the pressure sensor breakout harness between the sensor and sensor harness connector.
  • Keyswitch circuit energized.

Action

Check the supply voltage and return circuit.

  • Measure the supply voltage between the fuel supply pressure sensor SUPPLY pin and the fuel supply pressures ensor RETURN pin at the fuel supply pressure sensor breakout harness test connectors.

Supply voltage 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Place Run/Stop/Auto switch in the STOP mode.
  • Keyswtich circuit de-energized.
  • Connect the harness to the fuel pressure sensor.
  • Keyswitch circuit energized.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1839 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the fuel supply pressure sensor. Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 4A

Go to 4B

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect the ECM and harness connector pins.

Conditions

  • Keyswitch circuit de-engergized.
  • Place Run/Stop/Auto switch in the STOP mode.
  • Isolate the generator set 24VDC power supply.
  • Disconnect the harness from the CM700 connectors A and C.

Action

Inspect the Generator Interface Box (GIB) harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harnesses and connectors in the circuit. Refer to the wiring diagram to identify connectorsand pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Wiring harness and ECM connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the appropriate harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the Generator Interface Box (GIB) wiring harness. Contact a Cummins® Authorized Repair Location.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 4A

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in the STOP mode.
  • Isolate the generator set 24VDC power supply.
  • Disconnect the harness and gas valve from the fuel supply pressure sensor.
  • Disconnect the harness from the CM700 module connectors A and C.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance from the Fuel Supply Pressure Sensor SIGNAL pin in the CM700 connector to all other pins in the engine harness.
  • Measure the resistance from the Fuel Supply Pressure Sensor SUPPLY pin in the CM700 connector to all other pins in the engine harness.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the appropriate harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the Generator Interface Box (GIB) wiring harness. Contact a Cummins® Authorized Repair Location.
  • Replace the extension harness. Contact a Cummins® Authorized Repair Location.
  • Replace the harness and gas valve. Contact a Cummins® Authorized Repair Location.

Go to 3C

Go to 4B

Guided Step 4 - Clear the fault codes

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in the RUN mode and operate engine for greater than 1 minute.

Action

Check for inactive fault codes.

Use INSITE™ electronic service tool to verify Fault Code 1839 is inactive.

Fault code 1839 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Appropriate troubleshooting chart

Last Modified: 09-May-2012


FAULT CODE 1841 - Gas Supply (Regulated) Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1841 active?
STEP 2. | Check the fuel supply pressure sensor. |
 | STEP 2A. Check the fuel supply pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | Supply voltage 4.75 and 5.25-VDC?
 | STEP 2C. Check the sensor supply signal voltage. | Supply voltage 0.50 and 4.50-VDC?
STEP 3. | Check the Generator Interface Box / CM700 module wiring harness. |
 | STEP 3A. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault Code 1841 inactive?
 | STEP 4B. Check the CM700 signal pin resistance. | Less than 100k ohms?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 1841 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1841 active?
YES NO

Repair

Reference the Sensor Supply 1 Circuit - Voltage Below Normal, or Shorted to Low Source troubleshooting steps.

  • Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.
No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check the fuel supply pressure sensor

Guided Step 2A - Check the fuel supply pressure sensor and harness connector pins.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/auto switch in the OFF mode.
  • Disconnect the harness from the fuel supply pressure sensor.

Action

Inspect the harness and fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the gas valve harness, the harness connector or the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical/electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the appropriate wiring harness. Contact your local Cummins® Authorized Repair Location.
  • Replace the fuel supply pressure sensor. Contact a Cummins® Authorized Repair Location.
 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Connect INSITE™ electronic service tool.
  • Place Run/Stop/Auto switch in the STOP mode.
  • Disconnect the harness from the fuel supply pressure sensor and install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Keyswitch circuit energized.

Action

Check for the fuel supply pressure sensor supply voltage.

  • Measure the supply voltage by measuring between the breakout harness supply and return test connectors with a multimeter.

Fuel Supply Pressure Sensor Supply Voltage 4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Place Run/Stop/Auto switch in the STOP mode.
  • Disconnect the harness from the fuel supply pressure sensor and install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Keyswitch circuit energized.

Action

Check for the fuel supply pressure sensor signal voltage.

  • Measure the supply voltage by measuring between the breakout harness supply and return test connectors with a multimeter.

Signal voltage 0.50 to 4.50-VDC?
YES NO
No Repair

Repair

  • Replace the fuel supply pressure sensor. Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 5A

Guided Step 3 - Check the Generator Interface Box / CM700 module wiring harness

Guided Step 3A - Inspect the Generator Interface Box / CM700 Module wiring harness and connector pins.

Conditions

  • Keyswitch circuit de-engergized.
  • Place Run/Stop/Auto switch in the STOP mode.
  • Isolate the generator set 24VDC power supply.
  • Disconnect the harness from the CM700 module.

Action

Inspect the harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harnesses and connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Wiring harness and ECM connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the appropriate harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical/electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the Generator Interface Box (GIB) wiring harness. Contact a Cummins® Authorized Repair Location.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in the STOP mode.
  • Isolate the generator set 24VDC power supply.
  • Disconnect the harness from the fuel supply pressure sensor.
  • Disconnect the harness from the CM700 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance from the fuel supply pressure sensor SIGNAL pin in the CM700 connector to all other pins in the engine harness.
  • Measure the resistance from the fuel supply pressure sensor SUPPLY pin in the CM700 connector to all other pins in the engine harness.
  • Measure the resistance from the fuel supply pressure sensor RETURN pin in the CM700 connector to all other pins in the harness.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL, SUPPLY, or RETURN circuit has been detected in the harness.

Repair or replace the appropriate harness or the harness connector.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the appropriate wiring harness. Contact a Cummins® Authorized Repair Location.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in the STOP mode.
  • Isolate the generator set 24VDC power supply.
  • Disconnect the harness from the fuel supply pressure sensor.
  • Disconnect the harness from the CM700 module.

Action

Check for an open circuit in the engine harness:

  • Measure the resistance from the fuel supply pressure sensor SIGNAL pin in the CM700 connector to the fuel supply pressure sensor SIGNAL pin inthe gas valve harness fuel supply pressure sensor connector.
  • Measure the resistance from the fuel supply pressure sensor SUPPLY pin in the CM700 connector to the fuel supply pressure sensor SUPPLY pin in the gas valve harness fuel supply pressure sensor connector.
  • Measure the resistance from the fuel supply pressure sensor RETURN pin in the CM700 connector to the fuel supply pressure sensor RETURN pin in the gas valve harness fuel supply pressure sensor connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit on the SIGNAL, SUPPLY, or RETURN circuit has been detected in the harness.

Repair or replace the appropriate harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the appropriate wiring harness. Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM700 response

Guided Step 4A - Check for the appropriate CM700 response.

Conditions

  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in the STOP mode.
  • Disconnect the fuel supply pressure sensor connector.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM700 response:

  • Place a jumper wire between the fuel supply pressure sensor SUPPLY pin and the fuel supply pressure sensor SIGNAL pin of the sensor connector.
  • Check for the appropriate CM700 response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1839 will become active upon installing the jumper wire.

Fault Code 1841 inactive?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL, SUPPLY, or RETURN circuit has been detected in the harness.

Repair or replace the appropriate harness or the harness connector.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the appropriate wiring harness. Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 4B

Guided Step 4B - Check the CM700 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized.
  • Place Run/Stop/Auto switch in the STOP mode.
  • Disconnect the harness from the CM700 module.

Action

Check the CM700 signal pin resistance:

  • Measure the resistance from the fuel inlet pressure sensor SIGNAL pin on the CM700 to the CM700 fuel inlet pressure sensor RETURN pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Replace the left-bank CM700 module.

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in the RUN mode and operate engine for greater than 1 minute.

Action

Check for inactive fault codes.

Use INSITE™ electronic service tool to verify Fault Code 1841 is inactive.

Fault code 1841 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Appropriate troubleshooting chart

Last Modified: 09-May-2012


FAULT CODE 59-t05-1843 - Crankcase Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164752 - pressure sensor breakout cable, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the multiple fault codes |
 | STEP 1A. Read the fault codes. | Fault Code 187 or 227 active?
STEP 2. | Check the crankcase pressure sensor and circuit |
 | STEP 2A. Check the crankcase blowby pressure sensor. | Dirty or damaged pins?
 | STEP 2B. Check the sensor SUPPLY voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor SIGNAL voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the engine harness |
 | STEP 3A. Inspect engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100K ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM700 response. |
 | STEP 4A.. Check for the appropriate CM700 response. | Fault Code 1843 inactive?
 | STEP 4B. Check the CM700 SIGNAL pin resistance. | Less than 100K ohms?
STEP 5. | Clear the fault code |
 | STEP 5A. Verify that Fault Code 1843 is inactive. | Fault Code 1843 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the multiple fault codes

Guided Step 1A - Read the fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for J1939 data link Fault Codes 187 and 227.

Fault Codes 187 or 227 active?
YES | NO
No Repair | No Repair

Refer to Sensor Supply Fault Code 187 or 227

Go to 2A

Guided Step 2 - Check the crankcase blowby pressure sensor and circuit.

Guided Step 2A - Check the crankcase blowby pressure sensor.

Conditions

  • De-energize keyswitch circuit.
  • Pace run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the crankcase blowby pressure sensor.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the engine harness or replace the crankcase blowby pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture fromthe connector pins. Use electrcial/electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the crankcase blowby pressure sensor. Refer to Procedure 019-011 in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the crankcase blowby pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's SUPPLY and RETURN connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor SIGNAL voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the crankcase blowby pressure sensor SIGNAL voltage.

  • Measure the SIGNAL voltage by installing the breakout cable's SUPPLY and RETURN connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

Repair

Replace the crankcase blowbypressure sensor. Refer to Procedure 019-011 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the crankcase blowby pressure sensor and the CM558.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical/electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19..
  • Refer to Procedure 019-208 in Section 19..
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • De-energized keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the crankcase blowby pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the crankcase blowby pressure sensor.

Action

Check for a short from pin to pin.

  • Measure the resistance from the crankcase blowby pressure SUPPLY pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the crankcase blowby pressure RETURN pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from thecrankcase blowby pressure SIGNAL pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks in or on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

For general inspection techniques, refer to Component Connector and Pin Inspection, Refer to Procedure 019-361 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the crankcase blowby pressure sensor.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the crankcase blowby pressure RETURN pin on the engine harness connector to the crankcase blowby pressure RETURN pin on the engine harness senso rconnector.
  • Perform these checks in or on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 10 ohms?
YES NO
No Repair

Repair

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 4 - Check for a CM700 response.

Guided Step 4A - Check for an appropriate CM700 response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the crankcase blowby pressure sensor connector.
  • Connect INSITE™ electronic service tool.

Action

Check for an appropriate CM700 response.

  • Use INSITE™ electronic service tool to verify that fault codes.

Note: Fault Code 1844 will become active upon disconnecting the sensor.

Fault Code 1843 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM700 SIGNAL pin resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main harness connector from the CM700 module.

Action

Check the CM700 SIGNAL pin resistance.

  • Measure the resistance from the crankcase blowby pressure SIGNAL pin on the CM700 to the CM700 sensor SUPPLY RETURN pin.

More than 100k ohms?
YES | NO
No Repair | No Repair

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code

Guided Step 5A - Verify that Fault Code 1843 is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 1843 is inactive.

Fault Code 1843 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-Oct-2010


FAULT CODE 59-t05-1844 - Crankcase Pressure Sensor Circuit - Shorted Low

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164752 - pressure sensor breakout cable, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the multiple fault codes |
 | STEP 1A. Read the fault codes. | Fault Code 187 or 227 active?
STEP 2. | Check the crankcase blowby pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor SUPPLY voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor SIGNAL voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the wiring harness |
 | STEP 3A. Inspect wiring harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | More than 100K ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM700 response. |
 | STEP 4A.. Check for the appropriate CM700 response. | Fault Code 1844 inactive?
 | STEP 4B. Check the CM700 SIGNAL pin resistance. | Less than 100K ohms?
STEP 5. | Clear the fault code |
 | STEP 5A. Verify that Fault Code 1844 is inactive. | Fault Code 1844 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the multiple fault codes

Guided Step 1A - Read the fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for J1939 data link Fault Codes 187 and 227.

Fault Codes 187 or 227 active?
YES | NO
No Repair | No Repair

Refer to Sensor Supply Fault Code 187 or 227

Go to 2A

Guided Step 2 - Check the crankcase blowby pressure sensor.

Guided Step 2A - Check the crankcase blowby pressure sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the crankcase blowby pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the engine harness or replace the crankcase blowby pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical/electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the crankcase blowby pressure sensor. Refer to Procedure 019-011 in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the crankcase blowby pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's SUPPLY and RETURN connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor SIGNAL voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the crankcase blowby pressure sensor SIGNAL voltage.

  • Measure the SIGNAL voltage by installing the breakout cable's SIGNAL and RETURN connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

Repair

Replace the crankcase blowby pressure sensor. Refer to Procedure 019-011 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the crankcase blowby pressure sensor and the CM700 module.

Action

Inspect the engine harness and extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical/electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal, if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the crankcase blowby pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared SUPPLY or RETURN with the crankcase blowby pressure sensor.

Action

Check for a short from pin to pin.

  • Measure the resistance from the crankcase blowby pressure SUPPLY pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the crankcase blowby pressure RETURN pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the crankcase blowby pressure sensor SIGNAL pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks in or on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the crankcase blowby pressure sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the crankcase blowby pressure sensor RETURN pin on the engine harness connector to the crankcase blowby pressure RETURN pin on the engine harness sensor connector.
  • Measure the resistance from the crankcase blowby pressure sensor SIGNAL pin on the engine harnessconnector to the crankcase blowby pressure sensor SIGNAL pin on theengine harness sensor connector.
  • Measure the resistance from the crankcase blowby pressure sensor SUPPLY pin on the engine harnessconnector to the crankcase blowby pressure sensor SUPPLY pin on theengine harness sensor connector.
  • Perform these checks in or on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM700 response.

Guided Step 4A - Check for an appropriate CM700 response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the crankcase blowby pressure sensor connector.
  • Connect INSITE™ electronic service tool.

Action

Check for an appropriate CM700 response.

  • Place a jumper wire between the crankcase blowby pressure sensor SUPPLY pin and the crankcase blowby pressure sensor SIGNAL pin of the sensor connector.
  • Check for the appropriate CM700 response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Note: Fault Code 1843 will become active upon installing the jumper.

Fault Code 1844 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM700 SIGNAL pin resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the main harness connector from the CM700 module.

Action

Check the CM700 SIGNAL pin resistance.

  • Measure the resistance from the crankcase blowby pressure SIGNAL pin on the CM700 to the CM700 sensor SUPPLY RETURN pin.

More than 100k ohms?
YES NO
No Repair

Repair

Contact the a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code

Guided Step 5A - Verify that the Fault Code 1844 is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for longer than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 1844 is inactive.

Fault Code 1844 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 27-Oct-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes active?
STEP 2. | Check the engine coolant temperature sensor (low temperature). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for a short circuit to the engine block ground. | More than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault Code 2111 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 2111 inactive?
 | STEP 5B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the engine specific wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the engine coolant temperature sensor (low temperature).

Other fault codes active?
YES | NO
No Repair | No Repair

Refer to appropriate fault code

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor (low temperature).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the engine coolant temperature sensor (low temperature).

Action

Inspect the harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or replace the engine coolant temperature sensor (low temperature), whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-202 (Metripack Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the engine coolant temperature sensor (low temperature). Refer to Procedure 019-019 (Engine Coolant Temperature Sensor) in Section 19.
No Repair

5A

Go to 2B

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the engine coolant temperature sensor (low temperature).

Action

Check the resistance of the engine coolant temperature sensor (low temperature).

  • Measure the resistance between the engine coolant temperature sensor (low temperature) pin and the engine coolant temperature sensor (low temperature) pin.

600 ohms to 36k ohms?
YES NO
No Repair

Repair

  • Replace the engine coolant temperature sensor (low temperature). Refer to Procedure 019-019 (Engine Coolant Temperature Sensor) in Section 19.

Go to 3A

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the engine coolant temperature sensor (low temperature).

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the engine coolant temperature sensor (low temperature) connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair

  • Replace the engine coolant temperature sensor (low temperature). Refer to Procedure 019-019 (Engine Coolant Temperature Sensor) in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the engine coolant temperature sensor (low temperature) and the CM700.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Flush the dirt, debris, or moisture from the connector pins.

Repair or replace the engine harness or the extension harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the CM700
  • Disconnect the engine harness from the engine coolant temperature sensor (low temperature).

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the engine coolant temperature sensor (low temperature) pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant temperature sensor (low temperature) pin in the engine harness connector to all other pins in the engine harness connector.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the engine coolant temperature sensor (low temperature)
  • Disconnect the engine harness from the CM700.

Action

Check for a short circuit to ground in the signal and return wires

  • Measure the resistance from the engine coolant temperature sensor (low temperature) pin on the engine harness connector to the engine block ground.
  • Measure the resistance from the engine coolant temperature sensor (low temperature) pin on the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the engine coolant temperature sensor (low temperature)
  • Disconnect the engine harness from the CM700.

Action

Check for an open circuit.

  • Measure the resistance from the signal pin on the engine coolant temperature sensor (low temperature) connector to the sensor signal pin on the CM700.
  • Measure the resistance from the return pin on the engine coolant temperature sensor (low temperature) connector to the return signal pin on the CM700.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM700 response.

Guided Step 4A - Check for the appropriate CM700 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch is Stop mode
  • Disconnect the engine harness from the engine coolant temperature sensor (low temperature)
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate CM700 response.

  • Place a jumper wire between the engine coolant temperature sensor (low temperature) pin and the engine coolant temperature sensor (low temperature) pin of the sensor connector.
  • Check for the appropriate CM700 response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Fault Code 2112 will become active upon installing the jumper.

Fault Code 2111 inactive?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Repair complete

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™electronic service tool to verify Fault Code 2111 is inactive.

Fault Code 2111 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Other fault codes are active?
STEP 2. | Check the engine coolant temperature sensor (low temperature). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the resistance of the sensor. | 600 ohms to 36k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | More than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for a short circuit to the engine block ground. | More than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault Code 2112 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 2112 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical ground/return with the engine coolant temperature sensor (low temperature).

Other fault codes are active?
YES | NO
No Repair | No Repair

Refer to appropriate fault code

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor (low temperature).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the engine coolant temperature sensor (low temperature).

Action

Inspect the harness and the sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or replace the engine coolant temperature sensor (low temperature), whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is missing or damaged.
  • Repair the engine harness. Refer to Procedure 019-202 (Metripack Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the engine coolant temperature sensor (low temperature). Refer to Procedure 019-019 (Engine Coolant Temperature Sensor) in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the engine coolant temperature sensor (low temperature).

Action

Check the resistance of the engine coolant temperature sensor (low temperature).

  • Measure the resistance between the engine coolant temperature sensor signal (low temperature) pin and the engine coolant temperature sensor return (low temperature) pin.

600 ohms to 36k ohms?
YES NO
No Repair

Repair

  • Replace the engine coolant temperature sensor (low temperature). Refer to Procedure 019-019 (Engine Coolant Temperature Sensor) in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the engine coolant temperature sensor (low temperature).

Action

Check for a short circuit to ground.

  • Measure the resistance from each of the pins of the engine coolant temperature sensor (low temperature) connector to the engine block ground.

More than 100k ohms?
YES NO
No Repair

Repair

  • Replace the engine coolant temperature sensor (low temperature). Refer to Procedure 019-019 (Engine Coolant Temperature Sensor) in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the engine coolant temperature sensor (low temperature) and the CM700.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair or replace the engine harness or the extension harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the CM700
  • Disconnect the engine harness from the engine coolant temperature sensor (low temperature).

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the engine coolant temperature return (low temperature) pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant temperature signal (low temperature) pin in the engine harness connector to all other pins in the engine harness connector.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit to the engine block ground.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the engine coolant temperature sensor (low temperature)
  • Disconnect the engine harness from the CM700.

Action

Check for a short circuit to ground in the signal and return wires

  • Measure the resistance from the engine coolant temperature signal (low temperature) pin on the engine harness connector to the engine block ground.
  • Measure the resistance from the engine coolant temperature return (low temperature) pin on the engine harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the engine coolant temperature sensor (low temperature)
  • Disconnect the engine harness from the CM700.

Action

Check for an open circuit.

  • Measure the resistance from the signal pin on the engine coolant temperature sensor (low temperature) connector to the sensor signal pin on the CM700.
  • Measure the resistance from the return pin on the engine coolant temperature sensor (low temperature) connector to the return pin on the CM700.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM700 response.

Guided Step 4A - Check for the appropriate CM700 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the engine coolant temperature sensor (low temperature)
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM700 response.

  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Fault Code 2111 will become active upon disconnecting the sensor.

Fault Code 2112 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2112 is inactive.

Fault Code 2112 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear any inactive fault codes.

  • Use INSITE™ electronic service tool to clear any inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2111 or 2112 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2111 or 2112 active?
YES NO
No Repair

Repair

t02-1001 (Engine Performance Troubleshooting Tree) in Section TT in this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2111 or 2112 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2111 or 2112 active?
YES NO
No Repair

Repair

t02-1001 (Engine Performance Troubleshooting Tree) in Section TT in this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164752 - pressure sensor breakout cablePart Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 386 active?
STEP 2. | Check the engine coolant pressure sensor (low temperature). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault Code 2115 is inactive?
 | STEP 4B. Check the CM700 signal pin resistance. | Less than 100k ohm.
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 2115 is inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the engine coolant pressure sensor (low temperature).

Fault Code 386 active?
YES | NO
No Repair | No Repair

Refer to Sensor Supply Fault Code 386

Go to 2A

Guided Step 2 - Check the engine coolant pressure sensor (low temperature).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the engine coolant pressure sensor (low temperature).

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or replace the engine coolant pressure sensor (low temperature), whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 (Danfoss (Circular DIN Series) Connector) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the engine coolant pressure sensor (low temperature). Refer to Procedure 019-016 (Coolant Pressure Sensor) in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the engine coolant pressure sensor (low temperature) supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the engine coolant pressure sensor (low temperature) breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the engine coolant pressure sensor (low temperature) signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

Repair

Replace the engine coolant pressure sensor (low temperature). Refer to Procedure 019-016 (Coolant Pressure Sensor) in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the engine coolant pressure sensor (low temperature) and the CM700.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the engine coolant pressure sensor (low temperature)
  • Disconnect the engine harness from all sensors that have a shared supply or return with the engine coolant pressure sensor (low temperature).

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the engine coolant pressure supply (low temperature) pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant pressure return (low temperature) pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant pressure signal (low temperature) pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the engine coolant pressure sensor (low temperature).

Action

Check for an open circuit in the harness.

  • Measure the resistance from the engine coolant pressure return (low temperature) pin on the engine harness connector to the engine coolant pressure return (low temperature) pin on the engine harness sensor connector.
  • Measure the resistance from the engine coolant pressure signal (low temperature) pin on the engine harness connector to the engine coolant pressure signal (low temperature) pin on the engine harness sensor connector.
  • Measure the resistance from the engine coolant pressure supply (low temperature) pin on the engine harness connector to the engine coolant pressure supply (low temperature) pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM700 response.

Guided Step 4A - Check for an appropriate CM700 response.

Conditions

  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine coolant pressure sensor (low temperature) connector.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM700 response.

  • Use INSITE™ electronic service tool to verify the fault codes.

NOTE: Fault Code 2116 will become active upon disconnecting the sensor.

Fault Code 2115 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM700 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the 50-pin A Deutsch™ connector from the CM700.
  • Disconnect the 50-pin B Deutsch™ connector from the CM700.
  • Disconnect the 50-pin C Deutsch™ connector from the CM700.

Action

Check the CM700 signal pin resistance.

  • Measure the resistance from the engine coolant pressure signal (low temperature) pin on the CM700 to the CM700 sensor supply circuit number 1 pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2115 is inactive.

Fault Code 2115 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3164752 - pressure sensor breakout cablePart Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 352 active?
STEP 2. | Check the engine coolant pressure sensor (low temperature). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault Code 2116 is inactive?
 | STEP 4B. Check the CM700 signal pin resistance. | Less than 100k ohm.
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 2116 is inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the engine coolant pressure sensor (low temperature).

Fault Code 352 active?
YES | NO
No Repair | No Repair

Refer to Sensor Supply Fault Code 352

Go to 2A

Guided Step 2 - Check the engine coolant pressure sensor (low temperature).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the engine coolant pressure sensor (low temperature).

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or replace the engine coolant pressure sensor (low temperature), whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 (Danfoss (Circular DIN Series) Connector) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the engine coolant pressure sensor (low temperature). Refer to Procedure 019-016 (Coolant Pressure Sensor) in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the engine coolant pressure sensor (low temperature) supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the engine coolant pressure sensor (low temperature) breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the engine coolant pressure sensor (low temperature) signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

Repair

Replace the engine coolant pressure sensor (low temperature). Refer to Procedure 019-016 (Coolant Pressure Sensor) in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the engine coolant pressure sensor (low temperature) and the CM700.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the engine coolant pressure sensor (low temperature).
  • Disconnect the engine harness from all sensors that have a shared supply or return with the engine coolant pressure sensor (low temperature).

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the engine coolant pressure sensor supply (low temperature) pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant pressure sensor return (low temperature) pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant pressure sensor signal (low temperature) pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the engine coolant pressure sensor return (low temperature).

Action

Check for an open circuit in the harness.

  • Measure the resistance from the engine coolant pressure sensor return (low temperature) pin on the engine harness connector to the engine coolant pressure sensor return (low temperature) pin on the engine harness sensor connector.
  • Measure the resistance from the engine coolant pressure sensor signal (low temperature) pin on the engine harness connector to the engine coolant pressure sensor signal (low temperature) pin on the engine harness sensor connector.
  • Measure the resistance from the engine coolant pressure sensor supply (low temperature) pin on the engine harness connector to the engine coolant pressure sensor supply (low temperature) pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM700 response.

Guided Step 4A - Check for an appropriate CM700 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine coolant pressure sensor return (low temperature) connector
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM700 response.

  • Place a jumper wire between the engine coolant pressure sensor return (low temperature) supply pin and the engine coolant pressure sensor return (low temperature) signal pin of the sensor connector.
  • Check for the appropriate CM700 response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Fault Code 2115 will become active upon installing the jumper.

Fault code 2116 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM700 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the 50-pin A Deutsch™ connector from the CM700.
  • Disconnect the 50-pin B Deutsch™ connector from the CM700.
  • Disconnect the 50-pin C Deutsch™ connector from the CM700.

Action

Check the CM700 signal pin resistance.

  • Measure the resistance from the engine coolant pressure signal (low temperature) pin on the CM700 to the CM700 sensor supply circuit number 1 return pin.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2116 is inactive.

Fault Code 2116 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2115 or 2116 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2115 or 2116 active?
YES NO
No Repair

Repair

Refer to the Engine Performance Troubleshooting Tree in Section TT in this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3824776 - pressure sensor breakout cablePart Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine oil pressure sensor (post-filter). |
 | STEP 1A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 1C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the wiring harnesses and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check for a CM700 module response. |
 | STEP 3A. Check for the appropriate CM700 module response. | Fault Code 2154 is inactive?
 | STEP 3B. Check the CM700 module signal pin resistance. | Less than 100k ohm.
STEP 4. | Clear the fault code. |
 | STEP 4A. Verify that fault code is inactive. | Fault Code 2154 is inactive?
 | STEP 4B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine oil pressure sensor (post-filter).

Guided Step 1A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the engine oil pressure sensor (post-filter).

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or the engine oil pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 (Danfoss&trade; (Circular DIN Series)) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the Engine Oil Pressure Sensor. Refer to Procedure 019-066 (Engine Oil Pressure Sensor) in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 1B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect INSITE™ electronic service tool.

Action

Check the engine oil pressure sensor circuit (post-filter) supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 1C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the harness connector
  • Connect INSITE™ electronic service tool.

Action

Check the engine oil pressure sensor circuit (post-filter) signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

Repair

  • Replace the Engine Oil Pressure Sensor. Refer to Procedure 019-066 (Engine Oil Pressure Sensor) in Section 19.

Go to 3A

Go to 5A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the engine oil pressure sensor circuit (post-filter) and the CM700.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19. Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the engine oil pressure sensor circuit (post-filter)
  • Disconnect the engine harness from all sensors that have a shared supply or return with the engine oil pressure sensor circuit (post-filter).

Action

Inspect the engine harness and connector pins for the following:

  • Measure the resistance from the engine oil pressure sensor circuit (post-filter) supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine oil pressure sensor circuit (post-filter) return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine oil pressure sensor circuit (post-filter) signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Refer to Procedure 019-360 (Resistance Measurements Using a Multimeter) in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19. Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 5A

Guided Step 2C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the engine oil pressure sensor circuit (post-filter).

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the engine oil pressure sensor circuit (post-filter) return pin on the engine harness connector to the engine oil pressure sensor circuit (post-filter) return pin on the engine harness sensor connector.
  • Measure the resistance from the engine oil pressure sensor circuit (post-filter) signal pin on the engine harness connector to the engine oil pressure sensor circuit (post-filter) signal pin on the engine harness sensor connector.
  • Measure the resistance from the engine oil pressure sensor circuit (post-filter) supply pin on the engine harness connector to the engine oil pressure sensor circuit (post-filter) supply pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Refer to Procedure 019-360 (Resistance Measurements Using a Multimeter) in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19. Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 5A

Guided Step 3 - Check for a CM700 module response.

Guided Step 3A - Check for an appropriate CM700 module response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine oil pressure sensor circuit (post-filter) connector
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM700 module response.

  • Use INSITE™ electronic service tool, verify the fault codes.

NOTE: Fault Code 2155 will become active upon disconnecting the sensor.

Fault Code 2154 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 3B - Check the CM700 module signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main harness connectors from the CM700.

Action

Check the CM700 module signal pin resistance.

  • Measure the resistance from the oil pressure signal pin on the CM700 module to CM700 module sensor supply circuit return pin.
  • Refer to Procedure 019-360 (Resistance Measurements Using a Multimeter) in Section 19.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2154 is inactive.

Fault Code 2154 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 4B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement:Part Number 3824776 - pressure sensor breakout cablePart Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test leadPart Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine oil pressure sensor (post-filter). |
 | STEP 1A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 1B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 1C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the wiring harnesses and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check for a CENSE™ module response. |
 | STEP 3A. Check for the appropriate CENSE™ module response. | Fault Code 2155 is inactive?
 | STEP 3B. Check the CENSE™ module signal pin resistance. | Less than 100k ohm.
STEP 4. | Clear the fault code. |
 | STEP 4A. Verify that fault code is inactive. | Fault Code 2155 is inactive?
 | STEP 4B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the engine oil pressure sensor (post-filter).

Guided Step 1A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness connector from the engine oil pressure sensor (post-filter).

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or replace the oil pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 (Danfoss&trade; (Circular DIN Series)) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the engine oil pressure Sensor. Refer to Procedure 019-066 (Engine Oil Pressure Sensor) in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 1B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect INSITE™ electronic service tool.

Action

Check the engine oil pressure sensor (post-filter) supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 1C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Install the pressure sensor breakout cable between the sensor and the harness connector
  • Connect INSITE™ electronic service tool.

Action

Check the engine oil pressure sensor (post-filter) signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

Repair

  • Replace the engine oil pressure sensor. Refer to Procedure 019-066 (Engine Oil Pressure Sensor) in Section 19.

Go to 3A

Go to 5A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the engine oil pressure sensor (post-filter) and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19. Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the engine oil pressure sensor (post-filter)
  • Disconnect the engine harness from all sensors that have a shared supply or return with the oil pressure sensor (post-filter).

Action

Inspect the engine harness and connector pins for the following:

  • Measure the resistance from the engine oil pressure sensor (post-filter) supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine oil pressure sensor (post-filter) return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine oil pressure sensor (post-filter) signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Refer to Procedure 019-360 (Resistance Measurements Using a Multimeter) in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19. Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 5A

Guided Step 2C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the engine oil pressure sensor (post-filter).

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the engine oil pressure sensor (post-filter) return pin on the engine harness connector to the engine oil pressure sensor (post-filter) return pin on the engine harness sensor connector.
  • Measure the resistance from the engine oil pressure sensor (post-filter) signal pin on the engine harness connector to the engine oil pressure sensor (post-filter) signal pin on the engine harness sensor connector.
  • Measure the resistance from the engine oil pressure sensor (post-filter) supply pin on the engine harness connector to the engine oil pressure sensor (post-filter) supply pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Refer to Procedure 019-360 (Resistance Measurements Using a Multimeter) in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19. Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 5A

Guided Step 3 - Check for a CENSE™ module response.

Guided Step 3A - Check for an appropriate CENSE™ module response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine oil pressure sensor (post-filter) connector
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CENSE™ module response.

  • Use INSITE™ electronic service tool to verify the fault codes.

NOTE: Fault Code 2154 will become active upon disconnecting the sensor.

Fault Code 2155 is inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 3B - Check the CENSE™ module signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main harness connectors from the CENSE™ module.

Action

Check the CENSE™ module signal pin resistance.

  • Measure the resistance from the oil pressure signal pin on the CENSE™ module to the CENSE™ module sensor supply circuit return pin.
  • Refer to Procedure 019-360 (Resistance Measurements Using a Multimeter) in Section 19.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2155 is inactive.

Fault Code 2155 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 4B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


FAULT CODE 2191 - Intake Manifold Absolute Pressure Sensor Disagrees with the Compressor Outlet Pressure Sensor - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the engine control module (ECM) for active Fault Code 2191. | Fault Code 2191 active?
 | STEP 1B. Check ECM for multiple active fault codes. | Fault Codes 153, 154, 155, 354, 355, 488, 2113, 2114, 2517, and /or 2518?
STEP 2. | Inspect the air filters for excessive restriction. |
 | STEP 2A. Check the engine air filter restriction. | Engine air filter restricted?
 | STEP 2B. Check the engine room or container air inlet filter restriction, if installed. | Engine room or container air inlet filter restricted?
STEP 3. | Check the exhaust emissions. |
 | STEP 3A. Measure the exhaust emissions. | Exhaust emissions to specification?
STEP 4. | Inspect the turbocharger(s). |
 | STEP 4A. Inspect the turbocharger (s) for damage or excessive wear. | Turbocharger(s) damaged or out of specification?
STEP 5. | Check the exhaust restriction. |
 | STEP 5A. Measure the exhaust back pressure. | Exhaust back pressure exceeds specification?
STEP 6. | Check the aftercooler. |
 | STEP 6A. Check the aftercooler core for restriction or damage. | Aftercooler core restricted or damaged?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Disable the fault code. | Fault Code 2191 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active Fault Code 2191.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the ECM for active Fault Code 2191.

  • Use INSITE™ electronic service tool to read for active Fault Code 2191.

Fault Code 2191 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check the ECM for multiple active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for multiple active/inactive fault codes.

  • Use INSITE™ electronic service tool to read for multiple active fault codes 153, 154, 155, 354, 355, 488, 2113, 2114, 2517, and/or 2518.

Fault Codes 153, 154, 155, 354, 355, 488, 2113, 2114, 2517, and /or 2518?
YES NO

Repair

Troubleshoot the active fault code(s).

 No Repair

Refer to the appropriate fault code troubleshooting procedure within Section TF.

Go to 2A

Guided Step 2 - Inspect the air filters for excessive restriction.

Guided Step 2A - Check the engine air filter restriction.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the engine air filter restriction or damage that may cause excessive restriction.

Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395 or the Generator Drive QSK60 G CM700 V103 Operation and Maintenance Manual, Bulletin Number 4325991.

  • Refer to Procedure 010-086 in Section 3.

Engine air filter restricted?
YES NO

Repair

Replace the air cleaner elements.

  • Use the following procedure in the Operation and Maintenance Manual QSV81 and QSV91 CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021313. Refer to Procedure 010-014 in Section 6.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the engine room or container air inlet filter restriction, if installed.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

NOTE: Only perform Guided Step 2B if engine room or container air inlet filters are fitted. If they are not fitted proceed to Guided Step 3A

Action

Check the engine room or container air inlet filter restriction or damage that may cause excessive restriction.

Refer to the original equipment manufacturer (OEM) service manuals for engine room or container air filter restriction specifications and inspection procedures.

Engine room or container air inlet filter restricted?
YES NO

Repair

Replace the engine room or container air cleaner elements.

  • Refer to the OEM service manuals for engine room or container air filter element replacement procedures.
 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the exhaust emissions.

Guided Step 3A - Measure the exhaust emissions.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode, generator circuit breaker closed and rated load applied.

Action

Check that the exhaust emissions are to specification.

  • Use an emissions analyser to verify that the engine exhaust emissions are not running too lean.

Exhaust emissions to specification?
YES NO
No Repair

Repair

Correct the exhaust emissions.

  • Use INSITE™ electronic service tool to tune the exhaust emissions.

Go to 4A

Go to 7A

Guided Step 4 - Inspect the turbocharger(s)

Guided Step 4A - Inspect the turbocharger (s) for damage or excessive wear.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Check the turbocharger radial bearing clearance, axial bearing clearance and impeller for damage or out-of-specification condition.

  • Check the turbocharger axial clearance. Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021313. Refer to Procedure 010-038 in Section 8.
  • Check the turbocharger radial clearance. Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021313. Refer to Procedure 010-047 in Section 8.

Turbocharger(s) damaged or out of specification?
YES NO

Repair

Replace the turbocharger(s).

  • Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 010-033 in Section 10.
No Repair

Go to 7A

Go to 5A

Guided Step 5 - Check the exhaust restriction.

Guided Step 5A - Check the exhaust back pressure.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode, generator circuit breaker closed and rated load applied.

Action

Check that the exhaust back pressure specification is not exceeded.

  • Measure the exhaust back pressure. Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 011-009 in Section 11.

Exhaust back pressure exceeds specification?
YES NO

Repair

Inspect the exhaust system and associated components and remove restriction.

  • Refer to the OEM service manual.

Replace the exhaust system components causing the restriction.

  • Refer to the OEM service manual.
 No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check the aftercooler.

Guided Step 6A - Check the aftercooler for restriction.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that the aftercooler core is not restricted or damaged.

  • Inspect the aftercooler core. Use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 010-001 in Section 10.

Aftercooler core restricted or damaged?
YES NO
No Repair

Repair

Clean or replace the aftercooler core.

  • Clean or replace the aftercooler core. use the following procedure in the QSV81 and QSV91 CM700 Generator Set Troubleshooting and Repair Manual, Bulletin 4021314. Refer to Procedure 010-001 in Section 10.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate engine for greater than 1 minute.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify Fault Code 2191 is inactive.

Fault Code 2191 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jul-2013


FAULT CODE 2217 - Engine Control Module Calibration Program Memory (RAM) Corruption - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple active fault codes. | Fault Codes 343, 346, 441, 442, 1826, 2294, and/or 2863 active?
STEP 2. | Calibrate the ECM. |
 | STEP 2A. Calibrate the ECM. | Calibrations download successful?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 2217 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple active fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check the ECM for multiple active fault codes.

  • Use INSITE™ electronic service tool to check for multiple active fault codes.

Fault Codes 343, 346, 441, 442, 1826, 2294, and/or 2863 active?
YES NO

Repair

Troubleshoot the fault code using the appropriate troubleshooting guide.

Repair

Refer to Procedure 019-362 in Section 19.

Go to appropriate fault code troubleshooting tree.

Go to 3A

Guided Step 2 - Calibrate the ECM

Guided Step 2A - Calibrate the ECM.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Calibrate the ECM.

  • Use INSITE™ electronic service tool to calibrate the ECMs. Refer to Procedure 019-032 in Section 19.
  • Repeat for each engine ECM, as appropriate.

Calibrations download successful?
YES NO
No Repair

Repair

Replace the right or left bank CM700 or CM558 as appropriate.

Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 63 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and operate engine at no load for greater than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Code 2217 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-May-2012


FAULT CODE 2281 - Engine Cylinder Number 11 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 146, 151, 155, 488, 1285, 1295, 1579, 1581, 1582, 2281, 2282, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2531 and 2532 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specifications?
STEP 3. | Check the kilowatt load reference signal calibration. |
 | STEP 3A. Check the kilowatt load transducer reference signal - where fitted. | Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
 | STEP 3B. Check the calibration of the generator set controller. | Generator set controller output voltage and ampere readings match the measured readings?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor resistances within specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor within specification?
STEP 6. | Check the quality of the natural gas supply to the generator set. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply quality within specification?
STEP 7. | Inspect cylinder number 11 cylinder head. |
 | STEP 7A. Check the cylinder number 11 spark plug. | Cylinder number 11 spark plug contaminated or damaged?
 | STEP 7B. Check the cylinder number 11 spark plug gap. | Cylinder number 11 spark plug gap excessive?
 | STEP 7C. Check the cylinder number 11 cylinder head. | Cylinder number 11 cylinder head gasket leaking or loose components?
 | STEP 7D. Check that the cylinder number 11 valve lash setting is correct. | Cylinder number 11 valve lash setting correct?
 | STEP 7E. Check the cylinder number 11 valve train. | Cylinder number 11 valve train wear?
STEP 8. | Inspect the cylinder number 11 power cylinder. |
 | STEP 8A. Inspect the oil filters for debris. | Debris present in the oil filters?
 | STEP 8B. Check the cylinder number 11 internal power cylinder. | Cylinder number 11 power cylinder damaged?
 | STEP 8C. Inspect the cylinder number 11 connecting rod bearings. | Cylinder number 11 connecting rod bearings worn or damaged?
 | STEP 8D. Inspect the cylinder number 11 piston cooling nozzle. | Cylinder number 11 piston cooling nozzle bent or broken?
 | STEP 8E. Check cylinder number1and adjacent cylinder main bearings. | Cylinder number 11 or immediately adjacent main bearings worn or damaged?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 2522 inactive?
 | STEP 9B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 146, 151, 155, 488, 1285, 1295, 1579, 1581, 1582, 2281, 2282, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2531, and 2532 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Use symptom tree t048 in Section TS in this manual.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electric service tool.
  • Connect an exhaust gas analyzer.
  • Operate the engine at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Check exhaust emissions.

  • Use an exhaust gas analyzer. Insert the sample probe into the exhaust gas manifold test port, check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specifications?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool and referencing to the exhaust gas analyzer, adjust the open and closed loop fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.

  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 9A

Guided Step 3 - Check the kilowatt load reference signal calibration.

Guided Step 3A - Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller kilowatt calibration.

Conditions

NOTE: If the generator set is not fitted with a kilowatt load transducer, proceed to Guided Step 3B.

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.
  • Connect INSITE™ electronic service tool.

Action

Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller displayed kilowatt calibration.

  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
YES NO
No Repair

Repair

INSITE™ electronic service tool, calibrate the kilowatt load sensor milliampere/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the calibration of the generator set controller.

Conditions

NOTE: This guided step should only be followed if the generator set is not fitted with a kilowatt load transducer.

  • Connect all components.
  • Connect a power analyzer or digital multimeter
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.

Action

Connect a power analyzer or digital multimeter to the alternator main output terminals.

  • Check that the generator set controller readings for output voltage (L1- L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller output voltage and ampere readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter to calibrate the generator set controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold temperature.

  • Use the generator set human machine interface (HMI) to check the intake manifold temperature. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold temperature within specification?
YES NO
No Repair

Repair

Check the following:

  • Check the temperature of the high temperature (HT) coolant outlet from the engine.
  • Check the temperature of the low temperature (LT) coolant outlet from the engine.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 018-018 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the intake manifold temperature sensor resistances.

  • NOTE: The intake manifold temperature sensor may have malfunctioned in range and the related fault codes will not be activated. Reference Fault Code 153 or Fault Code 154 in Section TF.
  • Refer to circuit diagram or wiring diagram for connector pin identification. Refer to Procedure 019-360 in Section 19.

Intake manifold temperature sensor resistances within specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor.

  • Refer to Procedure 019-059 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold pressure.

  • Use the generator set human machine interface (HMI) to check the intake manifold pressure. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold pressure within specification?
YES NO
No Repair

Repair

If fitted, check the operation of the compressor bypass valve (single turbocharger engines only).

  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the intake manifold pressure sensor.

NOTE: The intake manifold pressure sensor may have malfunctioned in-range and the related fault codes will not be activated.

  • Reference Fault Code 354 or Fault Code 355 in Section TF.
  • Refer to Procedure 019-359 in Section 19.

Intake manifold pressure sensor within specification?
YES NO
No Repair

Repair

Replace the intake manifold pressure sensor.

  • Refer to Procedure 019-061 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the generator set.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the quality of the natural gas supply.

  • Check the quality of the natural gas supplied to the generator set meets or exceeds minimum requirement for generator set (methane number and fuel contaminants limits).
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspect cylinder number 11 cylinder head.

Guided Step 7A - Check the cylinder number 11 spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug J connector damaged
  • Electrode has signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder number 11 spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug.
  • Replace the spark plug.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the cylinder number 11 spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Remove the spark plug and measure the spark plug electrode gap.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
  • Contact a Cummins® Authorized Repair Location.

Cylinder number 11 spark plug gap excessive?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7C

Guided Step 7C - Check the cylinder number 11 cylinder head.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect cylinder number 11 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder number 11 cylinder head.

Cylinder number 11 cylinder head gasket leaking or loose components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose components on or immediately around cylinder number 11 cylinder head. Reference the appropriate procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396.
No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check that the cylinder number 11 valve lash setting is correct.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder number 11 valve lash is correct.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder number 11 valve lash setting correct?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7E

Guided Step 7E - Check the cylinder number 11 valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the cylinder number 11 valve train for the following:

  • Intake or exhaust valve wear/recession or damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Camshaft follower wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder number 11 camshaft lobe wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Cylinder number 11 valve train wear?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft follower assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the camshaft. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

Adjust the valve lash. Reset the valve lash setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 9A

Go to 8A

Guided Step 8 - Inspect the cylinder number 11 power cylinder.

Guided Step 8A - Inspect the oil filters for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubrication oil filters. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filters and inspect for debris in the filter media.
  • Contact a Cummins® Authorized Repair Location.

Debris present in the oil filters?
YES | NO
No Repair | No Repair

Go to 8B

Go to 8D

Guided Step 8B - Check the cylinder number 11 internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the cylinder number 11 internal power cylinder.

Inspect the internal power cylinder for the following:

NOTE: If available, use a borescope to perform the inspections.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage.

Cylinder number 11 power cylinder damaged?
YES NO

Repair

Replace the piston rings. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.

Replace the liner. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-045 in Section 1.

Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the cylinder number 11 connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP.

Action

Inspect the cylinder number 11 connecting rod bearings for excessive wear or other damage.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder number 11 connecting rod bearings worn or damaged?
YES NO

Repair

Replace the connecting rods bearings:

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.
No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the cylinder number 11 piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the piston cooling nozzle.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder number 11 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.
No Repair

Go to 9A

Go to 8E

Guided Step 8E - Inspect cylinder number 11 and adjacent cylinder main bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect cylinder number 11 and adjacent cylinder main bearings.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

Cylinder number 11 or immediately adjacent main bearings worn or damaged?
YES NO

Repair

Replace the main bearings as required (cylinder 11 or immediately adjacent cylinders). Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

No Repair

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electronic service tool.
  • Operate the engine for longer than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2522 is inactive.

Fault Code 2522 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Authorized Cummins® Repair Location if all steps have been completed and checked again.

Go to 9B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 03-Jan-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1213, 1274, 1281, 1286, 1291, 1296, 1583, and 2282 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specification?
STEP 3. | Check the kilowatt load reference calibration. |
 | STEP 3A. Check the kilowatt load tranducer-sensed kilowatts against the generator set controller kilowatts. | Kilowatt load transducer-sensed kilowatts match generator set controller kilowatts?
 | STEP 3B. Check the Gen Set controller calibration. | Gen Set controller voltage and ampere output calibration correct?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor supply voltage and reference resistance within specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor supply and reference voltage within specification?
STEP 6. | Check the quality of the natural gas supply to the Gen Set. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply meets or exceeds minimum specification for Gen Set?
STEP 7. | Inspect the number 11 cylinder head. |
 | STEP 7A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 7B. Check the spark plug gap. | Spark plug gap excessive?
 | STEP 7C. Check the cylinder head. | Leaking gaskets or loose components?
 | STEP 7D. Check the valve lash. | Valve lash correct?
 | STEP 7E. Check the valve train. | Worn or mis-set valve train components?
STEP 8. | Inspect cylinder 11 power cylinder. |
 | STEP 8A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 8B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 8C. Inspect the connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 8D. Inspect the piston cooling nozzle. | Piston cooling nozzle bent or missing?
 | STEP 8E. Check cylinder 11 and adjacent cylinder main bearings. | Main bearings damaged?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 2282 inactive?
 | STEP 9B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 146, 151, 155, 488, 561, 562, 563, 564, 565, 566, 567, 568, 569, 1213, 1274, 1281, 1286, 1291, 1296, 1583, and 2282 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Reference troubleshooting symptom tree t048 (Engine Noise Excessive - Combustion Knocks) in Section TS.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Connect an exhaust gas analyzer.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode and operate at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Check the exhaust emissions.

  • Use an exhaust gas analyzer. With the sample probe inserted into the exhaust gas manifold test port, check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure for exhaust emission specfications in the Operation and Maintenance Manual, Generator Set QSK60G CM700, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specfication?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool. Reference the exhaust gas analyzer, adjust the 'open and closed-loop' fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.

  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 9A

Guided Step 3 - Check the kilowatt load reference signal.

Guided Step 3A - Check the kilowatt load transducer, reference signal - where fitted.

Conditions

NOTE: If the generator set is not fitted with a kilowatt load transducer, then proceed to Guided Step 3B.

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode with load available.

Action

Check the load.

  • Check the kilowatt load transducer-sensed kilowatts against the generator set controller displayed kilowatts.
  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatts match generator set controller kilowatts?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool to calibrate the kilowatt load sensor milliamp/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the calibration of the Gen Set controller.

Conditions

NOTE: This guided step should ONLY be followed for generator sets not fitted with a kilowatt load transducer.

  • Connect all components.
  • Connect a power analyzer or digital multimeter.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode with load available.

Action

Check the GenSet controller.

  • Connect a power analyzer or digital multimeter to the alternator main output terminals. Check that the Gen Set controller readings for output voltage (L1-L2, L2-L3, and L-3-L1) and amperes (L1, L2, and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Gen Set controller output voltage and ampere readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter. Recalibrate the Gen Set controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode. Operate at maximum possible load with no knock present.

Action

Check the intake manifold temperature.

  • Use the generator set Human Machine Interface (HMI) to check the intake manifold temperature.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold temperature within specification?
YES NO
No Repair

Repair

Check the following:

  • Check the temperature of the high temperature (HT) coolant outlet from the engine. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 018-018 in Section V.
  • Check the temperature of the low temperature (LT) coolant outlet from the engine.Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 018-018 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the intake manifold temperature sensor.

  • Check the intake manifold temperature sensor resistances.

NOTE: The intake manifold temperature sensor may have failed 'in range' and the related fault codes will not be activated. Reference Fault Code 153 (Intake Manifold Temperature Sensor Shorted High) or Fault Code 154 (Intake Manifold Temperature Sensor Shorted Low) in Section TF.

  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
  • Use the following procedure for intake manifold temperature sensor specifications. Refer to Procedure 019-059 in Section 19.

Intake manifold temperature sensor resistance to specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode., Operate at maximum possible load with no knock present.

Action

Check the intake manifold pressure.

  • Use the generator set Human Machine Interface (HMI) to check the intake manifold pressure.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396 for the air intake system. Refer to Procedure 018-019 in Section V.

Intake manifold pressure within specification?
YES NO
No Repair

Repair

Check the following:

  • If fitted, check the operation of the compressor bypass valve (single turbocharger engines only).
  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the intake manifold pressure.

  • Check the intake manifold temperature sensor.

NOTE: The intake manifold pressure sensor may have failed 'in range' and the related fault codes will not be activated. Reference Fault Code 354 (Intake Manifold Pressure Sensor Shorted High) or Fault Code 355 (Intake Manifold Pressure Sensor Shorted Low) in Section TF.

  • Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.
  • Use a wiring diagram for intake manifold pressure sensor specifications.

Intake manifold pressure sensor resistance to specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor. Refer to Procedure 019-061 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the Gen Set.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the natural gas supply.

  • Check that the quality of the natural gas supplied to the generator set meets or exceeds minimum requirements for the generator set (methane number and fuel contaminants limits).
  • Use the following procedure in the Operation and Maintenance Manual, QSK60G CM700 Generator Set, Bulletin 4021395, for fuel recommendations and specifications. Refer to Procedure 018-002 in Section V.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspection of cylinder 11 cylinder head.

Guided Step 7A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • Spark plug 'J' connector damaged.
  • Inspect the electrode for signs of oil contamination.
  • Spark plug porcelain damaged. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder 11 spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder 11 spark plug gap excessive?
YES NO

Repair

Replace the spark plug:

  • Replace the spark plug. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7C

Guided Step 7C - Check the cylinder head.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the cylinder head.

Inspect the cylinder 11 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder 11 cylinder head.

Cylinder 11 cylinder head gaskets leaking or loose components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head gasket. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose components on or immediately around cylinder 1 cylinder head. Reference the appropriate procedures in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396.
No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check that the valve lash is correct.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the valve lash.

  • Check to see if the cylinder 11 valve lash setting is correct. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 11 valve lash setting correct?
YES NO
No Repair

Repair

Repair as necessary:

  • Proceed to the next troubleshooting step.

Go to 8A

Go to 7E

Guided Step 7E - Check the valve train.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the valve train.

Inspect the cylinder 11 valve train for the following:

  • Inlet or exhaust valve wear/recession or damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Cam follower wear. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder 11 camshaft lobe wear. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Cylinder 11 valve train wear?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the cam follower. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the rocker lever assembly. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

Adjust the valve lash:

  • Use the following procedure to set valve lash in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 9A

Go to 8A

Guided Step 8 - Inspection of cylinder 11 power cylinder.

Guided Step 8A - Cut open the oil filter(s) and inspect for debris.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the oil filters.

  • Remove the lubricating oil filter(s). Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter(s) and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filter(s)?
YES NO

Repair

Proceed to the next troubleshooting step

 No Repair

Go to 8B

Go to 8D

Guided Step 8B - Check the internal power cylinder.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the internal power cylinder.

NOTE: If available, these inspections can be performed using a borescope without component removal.

Inspect the internal power cylinder for the following:

  • Piston ring scuffing or breakage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 11 power cylinder damaged?
YES NO

Repair

Replace as necessary:

  • Replace the piston rings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Replace the liner. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-045 in Section 1.
  • Replace the cylinder head. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the connecting rod bearings.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the connecting rod bearings.

Inspect the cylinder 11 connecting rod bearings for excessive wear or damage. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder 11 connecting rod bearings damaged?
YES NO

Repair

Replace the connecting rod bearings:

  • Replace the connecting rod bearings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.
No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the piston cooling nozzle.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the piston cooling nozzle.

Cylinder 11 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle.

  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.
No Repair

Go to 9A

Go to 8E

Guided Step 8E - Inspect cylinder 11 and immediately adjacent main bearings.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect main bearings.

  • Inspect cylinder 11 and immediately adjacent main bearings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-006 in Section 2.

Cylinder 11 or immediately adjacent main bearings worn or damaged?
YES NO

Repair

Replace the main bearings as required (cylinder 11 or immediately adjacent cylinders):

  • Replace the main bearings. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.
No Repair

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in RUN mode and operate engine for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2282 is inactive.

Fault Code 2282 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


FAULT CODE 2311 - Engine Electronic Fuel Control Valve 1 Circuit - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2311 active or high inactive counts?
STEP 2. | Check the fuel control valve actuator. |
 | STEP 2A. Inspect the actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fuel control valve actuator commanded signal percent duty cycle. | Percent duty cycle 10 to 91 percent?
 | STEP 2C. Check the fuel control valve feedback signal voltage. | 0 to 5-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check the engine harness for a short-to-ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness malfunction. | Fault Codes 2311 and/or 2864, 2866, and 2867 active?
STEP 4. | Check the ECM. |
 | STEP 4A. Check the fuel control valve commanded position percent Pulse Width Modulation duty cycle signal at the CM558 connector. | Percent duty cycle 10 to 91 percent?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 2311 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2311 active or high inactive counts?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 5A

Guided Step 2 - Check the fuel control valve actuator.

Guided Step 2A - Inspect the actuator and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/autoswitch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the fuel control valve actuator.

Action

Inspect the actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness,the harness connector, or the fuel control valve actuator, whichever has the damaged pins.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel control valve. Use the following procedure found in the QSK60G Generator CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 006-049 in Section 6.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the fuel control valve actuator commanded signal percent duty cycle.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a number of positions between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the fuel control valve actuator position SIGNAL (+) and RETURN (-) pins at the fuel control valve actuator connector. The signal percent duty cycle must be between 10 and 91 percent, based on the fuel control valve actuator position.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

Percent duty cycle 10 to 91 percent?
YES NO
No Repair

Repair

Check the power supply connections and the fuses. Use the engine wiring diagram for the appropriate circuit.

Go to 2C

Go to 3A

Guided Step 2C - Check the fuel control valve feedback signal voltage

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve feedback signal voltage

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the signal feedback voltage by connecting the multimeter test probes between the fuel control valve actuator position feedback and RETURN (-) pins. The feedback signal must be between 0 to 5-VDC.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

0 to 5-VDC?
YES NO
No Repair

Repair

Replace the fuel control valve. Use the following procedure for information on the fuel control valve actuator in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 006-049 in Section 6.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the CM558 Module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged connector. Refer to Procedure 019-204 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Connect the engine harness to the fuel control valve actuator
  • Disconnect the engine harness from all sensors that have a shared SUPPLY or RETURN with the fuel control valve actuator. Refer to the wiring diagram to identify shared sensors.
  • Disconnect the engine harness from the CM700 module.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the fuel control valve actuator SIGNAL pin at the fuel control valve connector and the fuel control valve actuator SIGNAL pin at the CM700 module connector of the engine harness.
  • Measure the resistance between the fuel control valve actuator RETURN pin at the fuel control valve connector and the fuel control valve actuator RETURN pin at the CM700 module connector of the engine harness.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the damaged connector. Refer to Procedure 019-204 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check the engine harness for a short-to-ground.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the CM558 module
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator. Refer to the wiring diagram to identify shared sensors.

Action

Check the engine harness and fuel control valve actuator resistance.

  • Measure the resistance from the fuel control valve actuator SIGNAL pin in the engine harness CM558 connector to the engine block ground.
  • Measure the resistance from the fuel control valve actuator feedback pin in the engine harness CM558 connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the appropriate wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the damaged connector. Refer to Procedure 019-204 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an intermittent engine harness malfunction.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or malfunction:

  • Manipulate the engine harness starting at the ECM engine harness connector and working to the fuel control valve actuator.
  • Perform these checks on all interconnecting harness connectors in the circuit.

If a short or open circuit is induced while the engine is operating, a Warning or Shutdown Alarm and corresponding fault code will be activated.

Fault Codes 2311 and/or 2864, 2866, and 2867 active?
YES NO

Repair

An intermittent connection has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the damaged connector. Refer to Procedure 019-204 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.

Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Repair

Replace the fuel pump actuator.

Refer to Procedure 019-117 in Section 19.

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM.

Guided Step 4A - Check the fuel control valve commanded position percent Pulse Width Modulation duty cycle signal at the CM558 connector.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle at the left-bank CM558 connector B.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a number of positions between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the fuel control valve actuator position SIGNAL (+) and RETURN (-) pins at the CM558 connector. The signal percent duty cycle must be between 10 and 91 percent, based on the fuel control valve actuator position.

Use the appropriate wiring diagram to identify the SIGNAL and RETURN pins.

Refer to the specification table provided in the Shop Talk section of this document for commanded position percent duty cycle specifications.

Percent duty cycle 10 to 91 percent?
YES NO
No Repair

Repair

A fault has been detected with the CM558 module.

  • Replace the left-bank CM558 Module. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode. Engine operating for greater than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2311 is inactive.

Fault Code 2311 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit
  • Place run/stop/autos witch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-May-2012


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 227 active?
STEP 2. | Check the fuel outlet pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 2427 inactive?
 | STEP 4B. Check the CM558 signal pin resistance. | Less than 100k ohms.
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 2427 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the fuel outlet pressure sensor.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Refer to the Sensor Supply Fault Code 227.

Go to 2A

Guided Step 2 - Check the fuel outlet pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the fuel outlet pressure sensor.

Action

Inspect the sensor and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or replace the fuel outlet pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 (Danfoss&trade; (Circular DIN Series)) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the fuel outlet pressure sensor. Refer to Procedure 019-188 (Fuel Pressure Sensor) in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect INSITE™ electronic service tool.

Action

Check the fuel outlet pressure sensor supply voltage.

  • Measure the supply voltage by the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect INSITE™ electronic service tool.

Action

Check the Fuel Outlet Pressure Sensor signal voltage.

  • Measure the signal voltage by the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

Repair

  • Replace the fuel outlet pressure sensor. Refer to Procedure 019-188 (Fuel Pressure Sensor) in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the fuel outlet pressure sensor and the CM558.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19. Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the fuel outlet pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel outlet pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel outlet pressure supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Refer to Procedure 019-360 (Resistance Measurements Using a Multimeter) in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19. Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the fuel outlet pressure sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the fuel outlet pressure return pin on the engine harness connector to fuel outlet pressure return pin on the engine harness connector.
  • Measure the resistance from the fuel outlet pressure signal pin on the engine harness connector to fuel outlet pressure signal pin on the engine harness connector.
  • Measure the resistance from the fuel outlet pressure supply pin on the engine harness connector to fuel outlet pressure supply pin on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Refer to Procedure 019-360 (Resistance Measurements Using a Multimeter) in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19. Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the Fuel Delivery Pressure Sensor connector
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Use INSITE™ electronic service tool to verify the fault codes.

NOTE: Fault Code 2428 will become active upon disconnecting the sensor.

Fault Code 2427 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM558 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the main harness connectors from the CM558.

Action

Check the CM558 signal pin resistance.

  • Measure the resistance from the fuel delivery pressure signal pin on the CM558 to the CM558 sensor supply circuit number two pin.
  • Refer to Procedure 019-360 (Resistance Measurements Using a Multimeter) in Section 19.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2427 is inactive.

Fault Code 2427 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 352 active?
STEP 2. | Check the fuel outlet pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 2428 inactive?
 | STEP 4B. Check the CM558 signal pin resistance. | Less than 100k ohms.
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 2428 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the fuel outlet pressure sensor.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Refer to the Sensor Supply Fault Code 227.

Go to 2A

Guided Step 2 - Check the fuel outlet pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness connector from the fuel outlet pressure sensor.

Action

Inspect the sensor and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or replace the fuel outlet pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 (Danfoss&trade; (Circular DIN Series)) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
  • Replace the fuel outlet pressure sensor. Refer to Procedure 019-188 (Fuel Pressure Sensor) in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect INSITE™ electronic service tool.

Action

Check the Fuel Outlet Pressure Sensor supply voltage.

  • Measure the supply voltage by the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector
  • Connect INSITE™ electronic service tool.

Action

Check the fuel outlet pressure sensor signal voltage.

  • Measure the signal voltage by the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

Repair

  • Replace the fuel outlet pressure sensor. Refer to Procedure 019-188 (Fuel Pressure Sensor) in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the fuel outlet pressure sensor and the CM558.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19. Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the fuel outlet pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel outlet pressure sensor.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the fuel outlet pressure supply pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Refer to Procedure 019-360 (Resistance Measurements Using a Multimeter) in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19. Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the fuel outlet pressure sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the fuel outlet pressure return pin on the engine harness connector to fuel outlet pressure return pin on the engine harness connector.
  • Measure the resistance from the fuel outlet pressure signal pin on the engine harness connector to fuel outlet pressure signal pin on the engine harness connector.
  • Measure the resistance from the fuel outlet pressure supply pin on the engine harness connector to fuel outlet pressure supply pin on the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Refer to Procedure 019-360 (Resistance Measurements Using a Multimeter) in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19. Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the Fuel Delivery Pressure Sensor connector
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Place a jumper wire between the fuel delivery pressure sensor supply pin and the fuel supply pressure sensor signal pin of the sensor connector.
  • Check for the appropriate CM558 response after 30 seconds.
  • Use INSITE™ Electronic Service Tool to read the fault codes.

NOTE: Fault Code 2427 will become active upon adding the jumper.

Fault Code 2428 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM558 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the main harness connectors from the CM558.

Action

Check the CM558 signal pin resistance.

  • Measure the resistance from the fuel delivery pressure signal pin on the CM558 to the CM558 sensor supply circuit number one pin.
  • Refer to Procedure 019-360 (Resistance Measurements Using a Multimeter) in Section 19.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2428 is inactive.

Fault Code 2428 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 441, 442, 477, or 478 are active?
STEP 2. | Check the kilowatt load transducer. |
 | STEP 2A. Inspect the kilowatt load transducer for loose connections. | Loose connections?
 | STEP 2B. Check the kilowatt load transducer output. | More than 20 mA?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the harnesses, terminal blocks, and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
STEP 4. | Check for a CM700 response. |
 | STEP 4A. Check for an appropriate CM700 response | Fault Code 2453 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 2453 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Keyswitch circuit energized
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 441, 442, 477, or 478 are active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the kilowatt load transducer.

Guided Step 2A - Inspect the kilowatt load transducer for loose connections.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode.

Action

Inspect the terminal connections on the kilowatt load transducer.

Tighten any loose connections.

Loose connections?
YES NO

Repair

Tighten connections.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the kilowatt load transducer output.

Conditions

  • Keyswitch circuit de-energized.

Action

Check the kilowatt load transducer output current.

Connect an ammeter in series with the positive (+) wire running between the transducer and the generator control panel (GCP) terminal block.

More than 20 mA?
YES NO
No Repair

Repair

Repair or replace the kilowatt load transducer. Refer to Procedure 019-425 (Kilowatt Load Transducer) in Section 19.

Go to 5A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the harnesses, terminal blocks, and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the CM700.

Action

Inspect the engine harness and connector pins for the following:.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins and terminals.

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19. Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the kilowatt load transducer.

Action

Check for a short circuit form pin to pin.

  • Measure the resistance from the kilowatt load return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the kilowatt load signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors, pins, and terminal locations.
  • Refer to Procedure 019-360 (Resistance Measurements Using a Multimeter) in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19. Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM700 response.

Guided Step 4A - Check for an appropriate CM700 response

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the Kilowatt Load Transducer
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM700 response.

Use INSITE™ electronic service tool to verify the fault codes.

NOTE: Fault Code 2454 will become active upon disconnecting the transducer.

Fault Code 2453 inactive?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2453 is inactive.

Fault Code 2453 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 441, 442, 477, or 478 are active?
STEP 2. | Check the Kilowatt Load Transducer. |
 | STEP 2A. Inspect the Kilowatt Load Transducer for loose connections. | Loose connections?
 | STEP 2B. Check the kilowatt load transducer output. | Less than 4 mA?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the harnesses, terminal blocks, and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | More than 10 ohms?
STEP 4. | Check for a CM700 response. |
 | STEP 4A. Check for an appropriate CM700 response | Fault Code 2454 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 2454 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Keyswitch circuit energized
  • Connect INSITE™ electronic service tool
  • Run/Stop/Auto switch in the Run mode and engine running for more than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 441, 442, 477, or 478 are active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the kilowatt load transducer.

Guided Step 2A - Inspect the kilowatt load transducer for loose connections.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode.

Action

Inspect the terminal connections on the kilowatt load transducer.

Tighten any loose connections.

Loose connections?
YES NO

Repair

Tighten connections.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the kilowatt load transducer output.

Conditions

  • Keyswitch circuit de-energized.

Action

Check the kilowatt load transducer output current.

Connect an ammeter in series with the positive (+) wire running between the transducer and the generator control panel (GCP) terminal block.

More than 4 mA?
YES NO
No Repair

Repair

Repair or replace the kilowatt load transducer. Refer to Procedure 019-425 (Kilowatt Load Transducer) in Section 19.

Go to 5A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the harnesses, terminal blocks, and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the CM700.

Action

Inspect the engine harness and connector pins for the following:.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins and terminals.

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19. Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Repair

Repair the wire.

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the kilowatt load transducer.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance from the kilowatt load return pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the kilowatt load signal pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors, pins, and terminal locations.
  • Refer to Procedure 019-360 (Resistance Measurements Using a Multimeter) in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19. Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine harness from the extension harness (if present)
  • Disconnect the engine harness from the kilowatt load transducer connector.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the kilowatt load transducer return pin on the engine harness connector to the kilowatt load transducer return pin on the engine harness sensor connector.
  • Measure the resistance from the kilowatt load transducer position signal pin on the engine harness connector to the kilowatt load transducer signal pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Refer to Procedure 019-360 (Resistance Measurements Using a Multimeter) in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19. Refer to Procedure 019-208 (Deutsch HDP20 and HD30 Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM700 response.

Guided Step 4A - Check for an appropriate CM700 response

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in the Stop mode
  • Disconnect the kilowatt load transducer
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM700 response.

Use INSITE™ electronic service tool to verify the fault codes.

NOTE: Fault Code 2453 will become active upon disconnecting the transducer.

Fault Code 2454 inactive?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2454 is inactive.

Fault Code 2454 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


FAULT CODE 2455 - External Governor Speed or Frequency Bias - Current Below Normal or Open Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new CM700, all other active fault codes must be investigated prior to replacing the CM700.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - male Deutsch™/AMP™/Metri-Pack™ test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2455 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the wiring harness and connector pins. | Dirty or damaged connector pins?
 | STEP 2B. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check the speed bias signal. |
 | STEP 3A. Inspect the speed bias signal terminations. | Dirty or damaged pins or connector?
 | STEP 3B. Check the speed bias signal at the CM700 control module. | Frequency between 2.5 and 3.5 kHz?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 2455 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electric service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the AUTO mode.

Action

Operate the engine at normal speed and parallel with the utility and/or with other generator sets in the system.

  • Use INSITE™ electric service tool to read the active fault code.

Fault Code 2455 active?
YES NO

Repair

Follow the appropriate troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the wiring harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the CM700 connector C.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged connector pins?
YES NO

Repair

Repair or replace the damaged connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the CM700 connector C.

Action

Check for a short circuit from pin to pin.

  • Use a multimeter to measure the resistance from the speed bias SIGNAL (+) pin on the CM700 module harness connector to all other pins in the CM700 module harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Repair the damaged terminations.

 No Repair

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the PowerCommand™ Supervisor 3100 P4 (white) connector.

Action

Check for an open circuit in the speed bias circuit.

  • Use a multimeter to measure the resistance from the speed bias SIGNAL (+) pin on the CM700 module connector to the speed bias SIGNAL (+) pin at the PowerCommand™ Supervisor 3100 P4 connector.
  • Use a multimeter to measure the resistance from the speed bias RETURN (-) pin on the CM700 module connector to the speed bias RETURN (-) pin at the PowerCommand™ Supervisor 3100 P4 connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the appropriate wiring harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Repair or replace the appropriate generator set wiring harness. Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 4A

Guided Step 3 - Check the speed bias signal.

Guided Step 3A - Inspect the speed bias signal terminations.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the PowerCommand™ Supervisor 3100 P4 (white) connector.
  • Disconnect the harness at all harness interconnection points.

Action

Inspect the speed bias terminations on the PowerCommand™ Supervisor 3100 P4 (white) connector and all generator set harness interconnection points:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or connector?
YES NO

Repair

Clean the connector and pins. Replace the damaged pins. Repair or replace the engine harness or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the appropriate generator set wiring harness. Contact a Cummins® Authorized Repair Location.
 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the speed bias signal at the CM700 module.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the AUTO mode.
  • Open the backshell on the CM700 control module connector C.

Action

Run the generator set parallel with the utility and/or other generator sets in the system and check the speed bias signal frequency.

  • Use a high speed multimeter to measure the speed bias signal frequency between the speed bias SIGNAL (+) pin and the speed bias RETURN (–) pin at the CM700 module C connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Frequency between 2.5 and 3.5 kHz?
YES NO

Repair

Follow the appropriate troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for longer than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2455 is inactive.

Fault Code 2455 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Facility if the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 01-Dec-2010


FAULT CODE 2456 - External Governor Speed or Frequency Bias - Current Above Normal or Grounded Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new CM700, all other active fault codes must be investigated prior to replacing the CM700.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - male Deutsch™/AMP™/Metri-Pack™ test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2456 active?
STEP 2. | Check the wiring harness. |
 | STEP 2A. Inspect the wiring harness and connector pins. | Dirty or damaged connector pins?
 | STEP 2B. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to engine block ground. | Greater than 100k ohms?
STEP 3. | Check the speed bias signal. |
 | STEP 3A. Inspect the speed bias signal terminations. | Dirty or damaged pins or connectors?
 | STEP 3B. Check the speed bias signal at the CM700 control module. | Between 2.5 and 3.5 kHz?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 2456 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in AUTO mode.

Action

Operate the engine at normal speed parallel with utility and/or with other generator sets in the system.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2456 active?
YES NO

Repair

Follow the appropriate troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 4A

Guided Step 2 - Check the wiring harness.

Guided Step 2A - Inspect the wiring harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the CM700 connector C.

Action

Inspect the wiring harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged connector pins?
YES NO

Repair

Repair or replace the damaged harness connector pins.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged engine harness or connector. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Disconnect the CM700 connector C.

Action

Check for a short circuit from pin to pin.

  • Use a multimeter to measure the resistance from the speed bias SIGNAL (+) pin on the CM700 module harness connector to all other pins in the CM700 module harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Sectioin 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engne harness.

  • Repair the damaged engine harness or connector. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to engine block ground.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the CM700 connector C.

Action

Check for a short circuit to engine blockground.

  • Use a multimeter to measure the resistance from the speed bias SIGNAL (+) pin on the CM700 control module harness connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the appropriate wiring harness.

  • Repair the engine harness or connector. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043.
  • Repair or replace the appropriate generator set wiring harness. Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 4A

Guided Step 3 - Check the speed bias signal.

Guided Step 3A - Inspect the speed bias signal terminations.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the PowerCommand™ Supervisor 3100 P4 (white) connector.
  • Disconnect the harness at all harness interconnection points.

Action

Inspect the speed bias terminations on the PowerCommand™ Supervisor 3100 P4 (white) connector and all generator set harness interconnection points:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connectorseals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or connectors?
YES NO

Repair

Clean the connector and pins. Replace the damaged pins. Repair or replace the engine harness or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the appropriate generator set wiring harness. Contact a Cummins® Authorized Repair Location.
 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the speed bias signal at the CM700 module.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in AUTO mode.
  • Open the backshell on CM700 module connector C.

Action

Operate the generator set parallel with the utility and/or other generator sets in the system and check the speed bias signal frequency.

  • Use a high speed multimeter to measure the speed bias signal frequency between the speed bias SIGNAL (+) pin and the speed bias RETURN (–) pin at the CM700 module C connector.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 2.5 and 3.5 kHz?
YES NO
No Repair

Repair

A fault code has been detected with the speed bias signal.

  • Replace the PowerCommand™ Supervisor 3100 Engine Interface Circuit Board (A31).
  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect the electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate engine for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2465 is inactive.

Fault Code 2456 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact the nearest Cummins® Authorized Repair Facility if the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 21-Dec-2010


FAULT CODE 2457 (Multiple Turbochargers) - Engine Misfire for Multiple Cylinders - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 426, 427, 2458, 2459, 2461, 2462, 2463, 2464, 2465, 2466, 2469, 2471, 2472, 2473, 2475, 2476, 2477, 2478, 2766 and/or 2767 active?
STEP 2. | Check the spark plugs. |
 | STEP 2A. Check spark plugs. | Spark plugs contaminated or damaged?
 | STEP 2B. Check spark plug gap. | Spark plug gap excessive?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coils. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature harness. |
 | STEP 4A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 4C. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check the J1939 data link circuit. |
 | STEP 5A. Check the J1939 data link circuit. | J1939 data link circuit OK?
STEP 6. | Check the exhaust emissions. |
 | STEP 6A. Measure the exhaust emissions. | Exhaust emissions to specification?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify that the fault code is inactive. | Fault Code 2457 inactive?
 | STEP 7B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 426, 427, 2458, 2459, 2461, 2462, 2463, 2464, 2465, 2466, 2469, 2471, 2472, 2473, 2475, 2476, 2477, 2478, 2766 and/or 2767 active?

YES NO
No Repair

Repair

No Repair.

  • Refer to Procedure 019-362 in Section 19.
  • Go to the Engine Noise Excessive - Combustion Knocks in Section TS.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plugs.

Guided Step 2A - Check the spark plugs.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plugs for all cylinders showing low exhaust temperature for the following:

  • Spark plug correctly tightened
  • Spark plug ”J" connector damaged
  • Inspect the electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plugs contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug electrode gap for all cylinders showing low exhaust gas temperature.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap excessive?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for all cylinders showing low exhaust temperatures.

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coils Primary and Secondary resistances. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

Replace the ignition coil on any cylinder where the coil is not to specification.

Replace the ignition coil extension tube o-ring as found necessary.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for a short circuit for pin-to-pin.

  • Measure the resistance from the ignition signal pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check from an open circuit.

  • Measure the resistance from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector for any cylinder showing a low exhaust temperature.
  • Measure the resistance from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector for any cylinder showing a low exhaust temperature.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Repeat these checks on all cylinders showing a low exhaust temperature.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature harness.

Guided Step 4A - Check the ignition harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from the exhaust temperature sensors and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4B

Go to 7A

Guided Step 4B - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from the exhaust temperature sensors and the CENSE™ module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature signal pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from the exhaust temperature sensors and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature signal pin in the engine harness CENSE™ module connector to the exhaust temperature signal pin in the exhaust temperature sensor connector for any cylinder showing a low exhaust temperature.
  • Measure the resistance from the exhaust temperature return pin in the engine harness CENSE™ module connector to the exhaust temperature return pin in the exhaust temperature sensor connector for any cylinder showing a low exhaust temperature.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Repeat these checks on all cylinders showing a low exhaust temperature.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the J1939 data link circuit.

Guided Step 5A - Check the J1939 data link circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from the CENSE™ module and the CM700 module.

Action

Check the J1939 data link circuit.

  • Check the J1939 data link circuit. Refer to Procedure 019-165 in Section 19.
  • Use the circuit diagram or wiring diagram to identify connector and pins.

J1939 datalink circuit OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 6A

Go to 7A

Guided Step 6 - Check the exhaust emissions.

Guided Step 6A - Measure the exhaust emissions.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Connect an exhaust gas analyzer
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and running at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Measure the exhaust emissions.

  • Use an exhaust gas analyzer, with the sample probe inserted into the exhaust gas manifold test port, check that the exhaust emissions are to the Fuel Rating specification for the engine.
  • Use the following procedure for exhaust emission specifications in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-020 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specification?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool and referencing to the exhaust gas analyzer to adjust the open and closed loop fuelling offsets so that the Nox and O2 emissions meet the Fuel Rating specification for the engine.

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and running for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2457 is inactive.

Fault Code 2457 inactive?
YES NO
No Repair

Repair

If all troubleshooting steps have been completed and Fault Code 2547 is still active, then repair or replace the CENSE™ module:

  • Use INSITE™ electronic service tool to reload the CENSE™ module software
  • Replace the CENSE™ module
  • Recheck Step 7A - verify the fault code is inactive. Refer to Procedure 019-031 in Section 19.
  • Contact a Cummins® Authorized Repair Location.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 02-Jul-2010


FAULT CODE 2457 (Single Turbocharger) - Engine Misfire for Multiple Cylinders - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 426, 427, 2458, 2459, 2461, 2462, 2463, 2464, 2465, 2466, 2469, 2471, 2472, 2473, 2475, 2476, 2477, 2478, 2766 and/or 2767 active?
STEP 2. | Check the spark plugs. |
 | STEP 2A. Check spark plugs. | Spark plugs contaminated or damaged?
 | STEP 2B. Check spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coils. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature harness. |
 | STEP 4A. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the 5-VDC output from the CM850 to the exhaust temperature sensors. | 4.75 to 5.25-VDC?
 | STEP 4C. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 4D. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check the Proprietary data link circuit. |
 | STEP 5A. Check the Proprietary data link circuit. | Proprietary data link circuit OK?
STEP 6. | Check the exhaust emissions. |
 | STEP 6A. Measure the exhaust emissions. | Exhaust emissions to specification?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify that the fault code is inactive. | Fault Code 2457 is inactive?
 | STEP 7B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 426, 427, 2458, 2459, 2461, 2462, 2463, 2464, 2465, 2466, 2469, 2471, 2472, 2473, 2475, 2476, 2477, 2478, 2766 and/or 2767 active?

YES NO
No Repair

Repair

No Repair.

  • Refer to Procedure 019-362 in Section 19.
  • Go to the Engine Noise Excessive - Combustion Knocks in Section TS.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plugs.

Guided Step 2A - Check the spark plugs.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode.

Action

Inspect the spark plugs for all cylinders showing low exhaust temperature for the following:

  • Spark plug correctly tightened
  • Spark plug ”J" connector damaged
  • Inspect the electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plugs contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode.

Action

Check the spark plug electrode gap for all cylinders showing low exhaust gas temperature.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the OFF
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for all cylinders showing low exhaust temperatures.

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coils Primary and Secondary resistances. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

Replace the ignition coil on any cylinder where the coil is not to specification.

Replace the ignition coil extension tube o-ring, if necessary.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for a short circuit for pin-to-pin.

  • Measure the resistance from the ignition signal pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector for any cylinder showing a low exhaust temperature.
  • Measure the resistance from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector for any cylinder showing a low exhaust temperature.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Repeat these checks on all cylinders showing a low exhaust temperature.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature harness.

Guided Step 4A - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from the exhaust temperature sensors and the CM850 modules.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4B

Go to 7A

Guided Step 4B - Check the 5-VDC output from the CM850 to the exhaust temperature sensors.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the OFF mode
  • Disconnect the engine harness connectors from the CM850 connector 60-pin connector C23.

Action

Check the 5 volt supply to the exhaust temperature sensor.

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt supply output pin and the exhaust temperature return output pin of each CM850 module.

Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

Replace the CM850 module

  • Refer to Procedure 019-031 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from the exhaust temperature sensors and the CM850 modules.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature 5 volt supply pin in the left-bank CM850 module connector to all other pins in the left-bank CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Repeat this procedure for the right-bank CM850 harness.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from the exhaust temperature sensors and the CM850 modules.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature signal pin in the engine harness CM850 module connector to the exhaust temperature signal pin in the exhaust temperature sensor connector for any cylinder showing a low exhaust temperature.
  • Measure the resistance from the exhaust temperature return pin in the engine harness CM850 module connector to the exhaust temperature return pin in the exhaust temperature sensor connector for any cylinder showing a low exhaust temperature.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Repeat these checks on all cylinders showing a low exhaust temperature.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the Proprietary data link circuit.

Guided Step 5A - Check the Proprietary data link circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from the CM850 module and the CM700 module.

Action

Check the Proprietary data link circuit.

  • Check the Proprietary data link circuit. Refer to Procedure 019-417 in Section 19.
  • Use the circuit diagram or wiring diagram to identify connector and pins.

Proprietary data link circuit OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 6A

Go to 7A

Guided Step 6 - Check the exhaust emissions.

Guided Step 6A - Measure the exhaust emissions.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Connect an exhaust gas analyzer
  • Energize keyswitch circuit
  • Place run/stop/auto switch in the RUN mode and operate at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Measure the exhaust emissions.

  • Use an exhaust gas analyzer, with the sample probe inserted into the exhaust gas manifold test port, check that the exhaust emissions are to the Fuel Rating specification for the engine.
  • Use the following procedure for exhaust emission specifications in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-020 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specification?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool and reference the exhaust gas analyzer to adjust the open and closed loop fueling offsets so that the Nox and O2 emissions meet the Fuel Rating specification for the engine.

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in the RUN mode and operate for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2457 is inactive.

Fault Code 2457 inactive?
YES NO
No Repair

Repair

If all troubleshooting steps have been completed and Fault Code 2547 is still active, then repair or replace the CM850 module:

  • Use INSITE™ electronic service tool to reload the CENSE™ module software
  • Replace the CENSE™ module
  • Recheck Step 7A to verify the fault code is inactive. Replace the ECM. Refer to Procedure 019-031 in Section 19.
  • Contact a Cummins® Authorized Repair Location.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 09-May-2012


FAULT CODE 2458 (Multiple Turbochargers) - Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 2. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plugs contaminated or damaged?
 | STEP 2B. Check spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coils. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2458 inactive, Fault Code 2459 active?
 | STEP 4B. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 4D. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 2 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify that fault code is inactive. | Fault Code 2458 is inactive?
 | STEP 6B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

No Repair.

  • Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 2.

Guided Step 2A - Check the spark plug.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug.

  • Spark plug correctly tightened
  • Spark plug ”J" connector damaged
  • Inspect the electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plugs contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the Spark Plug Gap.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap excessive?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the Ignition System.

Guided Step 3A - Check the ignition coil on cylinder 2.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following.

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coils primary and secondary resistances. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the ignition signal pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Keyswitch circuit energized
  • Connect INSITE™ electronic service tool
  • Isolate the generator set 24-VDC power supply
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check cylinder 2 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 2 and 4.
  • Install the temperature sensor from cylinder 2 to cylinder 4.
  • Install the temperature sensor from cylinder 4 to cylinder 2.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2458 is inactive and that Fault Code 2459 is active.

Fault Code 2458 inactive and Fault Code 2459 active?
YES NO

Repair

Replace the exhaust temperature sensor.

  • Replace the exhaust temperature sensor that was originally installed in cylinder 2 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 2 exhaust temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 2 exhaust temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistances from the exhaust temperature signal pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurements techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 2 exhaust temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature signal pin in the engine harness CENSE™ module connector to the exhaust temperature signal pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature return pin in the engine harness CENSE™ module connector to the exhaust temperature return pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 2 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check overhead set.

  • Check that the cylinder 2 overhead setting is correct. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 19.

Cylinder 2 overhead setting correct?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and operate for greater than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2458 is inactive.

Fault Code 2458 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 02-Jul-2010


FAULT CODE 2458 (Single Turbocharger) - Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 2. |
 | STEP 2A. Check spark plug for contamination or damage. | Spark plug contaminated or damaged?
 | STEP 2B. Check spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2458 inactive, Fault Code 2459 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust temperature sensors. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 2 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify that the fault code is inactive. | Fault Code 2458 is inactive?
 | STEP 6B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

No Repair.

  • Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 2.

Guided Step 2A - Check the spark plug.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug ”J" connector damaged
  • Inspect the electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the Spark Plug Gap.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the Ignition System.

Guided Step 3A - Check the ignition coil on cylinder 2.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coils Primary and Secondary resistances. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring, if necessary.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature harness.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Keyswitch circuit energized
  • Connect INSITE™ electronic service tool
  • Isolate the generator set 24-VDC power supply
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check cylinder 2 exhaust gas temperature sensor response.

  • Remove the exhaust gas temperature sensors from cylinders 2 and 4.
  • Install the temperature sensor from cylinder 2 to cylinder 4.
  • Install the temperature sensor from cylinder 4 to cylinder 2.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2458 is inactive and that Fault Code 2459 is active.

Fault Code 2458 inactive and Fault Code 2459 active?
YES NO
No Repair

Repair

  • Replace the exhaust temperature sensor that was originally installed in cylinder 2 location. Refer to Procedure 019-013 in Section 19.

Go to 6A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Disconnect the engine harness connectors from cylinder 2 exhaust temperature sensor.

Action

Check the 5 VDC supply to the exhaust temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt supply pin and the exhaust temperature return pin of the exhaust temperature sensor harness cylinder 2.
  • Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 2 exhaust temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 2 exhaust temperature sensor and the CM850 module.

Action

Check for a short circuit for pin-to-pin.

  • Measure the resistance from the exhaust temperature signal pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 6A

Guided Step 4E - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 2 exhaust temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature signal pin in the engine harness CM850 module connector to the exhaust temperature signal pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature return pin in the engine harness CM850 module connector to the exhaust temperature return pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust temperature 5 volt supply pin in the engine harness CM850 module connector to the exhaust temperature 5 volt supply pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 2 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check overhead set.

  • Check that cylinder 2 overhead setting is correct. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 19.

Cylinder 2 overhead setting correct?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and running for greater than one minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2458 is inactive.

Fault Code 2458 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 02-Jul-2010


FAULT CODE 2459 (Multiple Turbochargers) - Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 4. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coils. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2459 inactive, Fault Code 2458 active?
 | STEP 4B. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 4D. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 4 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify that fault code is inactive. | Fault Code 2459 inactive?
 | STEP 6B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

No Repair.

  • Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 4.

Guided Step 2A - Check the spark plug.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug.

  • Spark plug correctly tightened
  • Spark plug ”J" connector damaged
  • Inspect the electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap excessive?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 4.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following.

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coils primary and secondary resistances. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the ignition signal pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Keyswitch circuit energized
  • Connect INSITE™ electronic service tool
  • Isolate the generator set 24-VDC power supply
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check cylinder 4 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 4 and 2.
  • Install the temperature sensor from cylinder 4 to cylinder 2.
  • Install the temperature sensor from cylinder 2 to cylinder 4.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2459 is inactive and that Fault Code 2458 is active.

Fault Code 2459 inactive and Fault Code 2458 active?
YES NO

Repair

Replace the exhaust temperature sensor.

  • Replace the exhaust temperature sensor that was originally installed in cylinder 4 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 4 exhaust temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 4 exhaust temperature sensor and the CENSE™ module.

Action

Check for a short circuit for pin-to-pin.

  • Measure the resistance from the exhaust temperature signal pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 4 exhaust temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature signal pin in the engine harness CENSE™ module connector to the exhaust temperature signal pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature return pin in the engine harness CENSE™ module connector to the exhaust temperature return pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 4 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check overhead set.

  • Check that the cylinder 4 overhead setting is correct. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 19.

Cylinder 4 overhead setting correct?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and operate for greater than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2459 is inactive.

Fault Code 2459 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 02-Jul-2010


FAULT CODE 2459 (Single Turbocharger) - Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 4. |
 | STEP 2A. Check spark plug for contamination or damage. | Spark plug contaminated or damaged?
 | STEP 2B. Check spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2459 inactive, Fault Code 2458 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust temperature sensors. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 4 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify that the fault code is inactive. | Fault Code 2459 inactive?
 | STEP 6B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

No Repair.

  • Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 4.

Guided Step 2A - Check the spark plug.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug ”J" connector damaged
  • Inspect the electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 4.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coils Primary and Secondary resistances. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring, if necessary.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature harness.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Keyswitch circuit energized
  • Connect INSITE™ electronic service tool
  • Isolate the generator set 24-VDC power supply
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check cylinder 4 exhaust gas temperature sensor response.

  • Remove the exhaust gas temperature sensors from cylinders 4 and 2.
  • Install the temperature sensor from cylinder 4 to cylinder 2.
  • Install the temperature sensor from cylinder 2 to cylinder 4.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2459 is inactive and that Fault Code 2458 is active.

Fault Code 2459 inactive and Fault Code 2458 active?
YES NO
No Repair

Repair

  • Replace the exhaust temperature sensor that was originally installed in cylinder 4 location. Refer to Procedure 019-013 in Section 19.

Go to 6A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Disconnect the engine harness connectors from cylinder 4 exhaust temperature sensor.

Action

Check the 5 VDC supply to the exhaust temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt supply pin and the exhaust temperature return pin of the exhaust temperature sensor harness cylinder 4.
  • Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 4 exhaust temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 4 exhaust temperature sensor and the CM850 module.

Action

Check for a short circuit for pin-to-pin.

  • Measure the resistance from the exhaust temperature signal pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 6A

Guided Step 4E - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 4 exhaust temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature signal pin in the engine harness CM850 module connector to the exhaust temperature signal pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature return pin in the engine harness CM850 module connector to the exhaust temperature return pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature 5 volt supply pin in the engine harness CM850 module connector to the exhaust temperature 5 volt supply pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 4 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check overhead set.

  • Check that cylinder 4 overhead setting is correct. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 19.

Cylinder 4 overhead setting correct?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and running for greater than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2459 is inactive.

Fault Code 2459 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 02-Jul-2010


FAULT CODE 2461 (Multiple Turbochargers) Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 6. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coils. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2461 inactive, Fault Code 2462 active?
 | STEP 4B. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 4D. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 6 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify that fault code is inactive. | Fault Code 2461 inactive?
 | STEP 6B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

No Repair.

  • Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 6.

Guided Step 2A - Check the spark plug.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug.

  • Spark plug correctly tightened
  • Spark plug ”J" connector damaged
  • Inspect the electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap excessive?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 6.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following.

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coils primary and secondary resistances. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the ignition signal pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Keyswitch circuit energized
  • Connect INSITE™ electronic service tool
  • Isolate the generator set 24-VDC power supply
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check cylinder 6 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 6 and 8.
  • Install the temperature sensor from cylinder 6 to cylinder 8.
  • Install the temperature sensor from cylinder 8 to cylinder 6.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2461 is inactive and that Fault Code 2462 is active.

Fault Code 2461 inactive and Fault Code 2462 active?
YES NO

Repair

Replace the exhaust temperature sensor.

  • Replace the exhaust temperature sensor that was originally installed in cylinder 6 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 6 exhaust temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 6 exhaust temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature signal pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 6 exhaust temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature signal pin in the engine harness CENSE™ module connector to the exhaust temperature signal pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature return pin in the engine harness CENSE™ module connector to the exhaust temperature return pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 6 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check overhead set.

  • Check that cylinder 6 overhead setting is correct. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 19.

Cylinder 6 overhead setting correct?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and running for greater than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2461 is inactive.

Fault Code 2461 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 02-Jul-2010


FAULT CODE 2461 (Single Turbocharger) Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 6. |
 | STEP 2A. Check spark plug for contamination or damage. | Spark plug contaminated or damaged?
 | STEP 2B. Check spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2461 inactive, Fault Code 2462 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust temperature sensors. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 6 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify that fault code is inactive. | Fault Code 2461 inactive?
 | STEP 6B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

No Repair.

  • Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 6.

Guided Step 2A - Check the spark plug.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug ”J" connector damaged
  • Inspect the electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 6.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coils Primary and Secondary resistances. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring, if necessary.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature harness.

Guided Step 4A -

Conditions

  • Keyswitch circuit energized
  • Connect INSITE™ electronic service tool
  • Isolate the generator set 24-VDC power supply
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check cylinder 6 exhaust gas temperature sensor response.

  • Remove the exhaust gas temperature sensors from cylinders 6 and 8.
  • Install the temperature sensor from cylinder 6 to cylinder 8.
  • Install the temperature sensor from cylinder 8 to cylinder 6.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2461 is inactive and that Fault Code 2462 is active.

Fault Code 2461 inactive and Fault Code 2462 active?
YES NO
No Repair

Repair

  • Replace the exhaust temperature sensor that was originally installed in cylinder 6 location. Refer to Procedure 019-013 in Section 19.

Go to 6A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Disconnect the engine harness connectors from cylinder 6 exhaust temperature sensor.

Action

Check the 5-VDC supply to the exhaust temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt supply pin and the exhaust temperature return pin of the exhaust temperature sensor harness cylinder 6.
  • Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 6 exhaust temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 6 exhaust temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature signal pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 6A

Guided Step 4E - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 6 exhaust temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature signal pin in the engine harness CM850 module connector to the exhaust temperature signal pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature return pin in the engine harness CM850 module connector to the exhaust temperature return pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature 5 volt supply pin in the engine harness CM850 module connector to the exhaust temperature 5 volt supply pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 6 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check overhead set.

  • Check that cylinder 6 overhead setting is correct. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 19.

Cylinder 6 overhead setting correct?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and running for greater than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2461 is inactive.

Fault Code 2461 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 02-Jul-2010


FAULT CODE 2462 (Multiple Turbochargers) - Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 8. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coils. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2462 inactive, Fault Code 2461 active?
 | STEP 4B. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 4D. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 8 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify that fault code is inactive. | Fault Code 2462 inactive?
 | STEP 6B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

No Repair.

  • Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 8.

Guided Step 2A - Check the spark plug.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug.

  • Spark plug correctly tightened
  • Spark plug ”J" connector damaged
  • Inspect the electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the Spark Plug Gap.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap excessive?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the Ignition System.

Guided Step 3A - Check the ignition coil on cylinder 8.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following.

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coils primary and secondary resistances. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the ignition signal pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Keyswitch circuit energized
  • Connect INSITE™ electronic service tool
  • Isolate the generator set 24-VDC power supply
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check cylinder 8 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 8 and 6.
  • Install the temperature sensor from cylinder 8 to cylinder 6.
  • Install the temperature sensor from cylinder 6 to cylinder 8.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2462 is inactive and that Fault Code 2461 is active.

Fault Code 2462 inactive and Fault Code 2461 active?
YES NO

Repair

Replace the exhaust temperature sensor.

  • Replace the exhaust temperature sensor that was originally installed in cylinder 8 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 8 exhaust temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 8 exhaust temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature signal pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 8 exhaust temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature signal pin in the engine harness CENSE™ module connector to the exhaust temperature signal pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature return pin in the engine harness CENSE™ module connector to the exhaust temperature return pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 8 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check overhead set.

  • Check that cylinder 8 overhead setting is correct. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 19.

Cylinder 8 overhead setting correct?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and running for greater than one minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2462 is inactive.

Fault Code 2462 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 02-Jul-2010


FAULT CODE 2462 (Single Turbocharger) - Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 8. |
 | STEP 2A. Check spark plug for contamination or damage. | Spark plug contaminated or damaged?
 | STEP 2B. Check spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2462 inactive, Fault Code 2461 active?
 | STEP 4B. Check the 5 VDC supply to the exhaust temperature sensors. | 4.75 to 5.25 VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 8 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify that the fault code is inactive. | Fault Code 2462 inactive?
 | STEP 6B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

No Repair.

  • Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 8.

Guided Step 2A - Check the spark plug.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug ”J" connector damaged
  • Inspect the electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 8.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coils Primary and Secondary resistances. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring, if necessary.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature harness.

Guided Step 4A -

Conditions

  • Keyswitch circuit energized
  • Connect INSITE™ electronic service tool
  • Isolate the generator set 24-VDC power supply
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check cylinder 8 exhaust gas temperature sensor response.

  • Remove the exhaust gas temperature sensors from cylinders 8 and 6.
  • Install the temperature sensor from cylinder 8 to cylinder 6.
  • Install the temperature sensor from cylinder 6 to cylinder 8.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2462 is inactive and that Fault Code 2459 is active.

Fault Code 2462 inactive and Fault Code 2461 active?
YES NO
No Repair

Repair

  • Replace the exhaust temperature sensor that was originally installed in cylinder 8 location. Refer to Procedure 019-013 in Section 19.

Go to 6A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Disconnect the engine harness connectors from cylinder 8 exhaust temperature sensor.

Action

Check the 5-VDC supply to the exhaust temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt supply pin and the exhaust temperature return pin of the exhaust temperature sensor harness cylinder 8.
  • Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 8 exhaust temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 8 exhaust temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature signal pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 6A

Guided Step 4E - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 8 exhaust temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature signal pin in the engine harness CM850 module connector to the exhaust temperature signal pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature return pin in the engine harness CM850 module connector to the exhaust temperature return pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature 5 VDC supply pin in the engine harness CM850 module connector to the exhaust temperature 5 VDC supply pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 8 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check overhead set.

  • Check that cylinder 8 overhead setting is correct. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 19.

Cylinder 8 overhead setting correct?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and running for greater than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2462 is inactive.

Fault Code 2462 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 02-Jul-2010


FAULT CODE 2463 (Multiple Turbochargers) - Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Below Normal Operating Range - Moderately Severe

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 10. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 10. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2463 inactive, Fault Code 2464 active?
 | STEP 4B. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 4D. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 10 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify that the fault code is inactive. | Fault Code 2463 inactive?
 | STEP 6B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

No Repair.

  • Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 10.

Guided Step 2A - Check the spark plug on cylinder 10.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug.

  • Spark plug correctly tightened
  • Spark plug ”J" connector damaged
  • Inspect the electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 10.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following.

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring, if necessary.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the ignition signal pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Keyswitch circuit energized
  • Connect INSITE™ electronic service tool
  • Isolate the generator set 24-VDC power supply
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check cylinder 10 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 10 and 12.
  • Install the temperature sensor from cylinder 10 to cylinder 12.
  • Install the temperature sensor from cylinder 12 to cylinder 10.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2463 is inactive and that Fault Code 2464 is active.

Fault Code 2463 inactive and Fault Code 2464 active?
YES NO

Repair

Replace the exhaust temperature sensor.

  • Replace the exhaust temperature sensor that was originally installed in cylinder 10 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 10 exhaust temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 10 exhaust temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature signal pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 10 exhaust temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature signal pin in the engine harness CENSE™ module connector to the exhaust temperature signal pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature return pin in the engine harness CENSE™ module connector to the exhaust temperature return pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 10 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check overhead set.

  • Check that cylinder 10 overhead setting is correct. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 19.

Cylinder 10 overhead setting correct?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and operate engine for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2463 is inactive.

Fault Code 2463 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 02-Jul-2010


FAULT CODE 2463 (Single Turbocharger) - Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Below Normal Operating Range - Moderately Severe

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 10. |
 | STEP 2A. Check spark plug for contamination or damage. | Spark plug contaminated or damaged?
 | STEP 2B. Check spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 10. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2463 inactive, Fault Code 2464 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust temperature sensors. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 10 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify that the fault code is inactive. | Fault Code 2463 inactive?
 | STEP 6B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

No Repair.

  • Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 10.

Guided Step 2A - Check the spark plug.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug ”J" connector damaged
  • Inspect the electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 10.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring, if necessary.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature harness.

Guided Step 4A -

Conditions

  • Keyswitch circuit energized
  • Connect INSITE™ electronic service tool
  • Isolate the generator set 24-VDC power supply
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check cylinder 10 exhaust gas temperature sensor response.

  • Remove the exhaust gas temperature sensors from cylinders 10 and 12.
  • Install the temperature sensor from cylinder 10 to cylinder 12.
  • Install the temperature sensor from cylinder 12 to cylinder 10.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in Section 19.
  • Start the engine and run the engine to run on-load for greater than 1 minute.
  • Use INSITE™ electronic service tool to check that Fault Code 2463 is inactive and that Fault Code 2459 is active.

Fault Code 2463 Inactive and Fault Code 2464 active?
YES NO
No Repair

Repair

  • Replace the exhaust temperature sensor that was originally installed in cylinder 10 location. Refer to Procedure 019-013 in Section 19.

Go to 6A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Disconnect the engine harness connectors from cylinder 10 exhaust temperature sensor.

Action

Check the 5 volt supply to the exhaust temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt supply pin and the exhaust temperature return pin of the exhaust temperature sensor harness cylinder 10.
  • Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 10 exhaust temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 10 exhaust temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature signal pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 6A

Guided Step 4E - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 10 exhaust temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature signal pin in the engine harness CM850 module connector to the exhaust temperature signal pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature return pin in the engine harness CM850 module connector to the exhaust temperature return pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature 5 volt supply pin in the engine harness CM850 module connector to the exhaust temperature 5 volt supply pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 10 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check overhead set.

  • Check that cylinder 10 overhead setting is correct. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 19.

Cylinder 10 overhead setting correct?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and operate engine for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2463 is inactive.

Fault Code 2463 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 02-Jul-2010


FAULT CODE 2464 (Multiple Turbochargers) - Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Below Normal Operating Range - Moderately Severe

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 12 |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 12. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2464 inactive, Fault Code 2463 active?
 | STEP 4B. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 4D. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 12 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify that the fault code is inactive. | Fault Code 2464 inactive?
 | STEP 6B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

No Repair.

  • Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 12.

Guided Step 2A - Check the spark plug.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug.

  • Spark plug correctly tightened
  • Spark plug ”J" connector damaged
  • Inspect the electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 12.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring, if necessary.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for a short circuit for pin-to-pin.

  • Measure the resistance from the ignition signal pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Keyswitch circuit energized
  • Connect INSITE™ electronic service tool
  • Isolate the generator set 24-VDC power supply
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check cylinder 12 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 12 and 10.
  • Install the temperature sensor from cylinder 12 to cylinder 10.
  • Install the temperature sensor from cylinder 10 to cylinder 12.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2464 is inactive and that Fault Code 2463 is active.

Fault Code 2464 inactive and Fault Code 2463 active?
YES NO

Repair

Replace the exhaust temperature sensor.

  • Replace the exhaust temperature sensor that was originally installed in cylinder 12 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 12 exhaust temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 12 exhaust temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature signal pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 12 exhaust temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature signal pin in the engine harness CENSE™ module connector to the exhaust temperature signal pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature return pin in the engine harness CENSE™ module connector to the exhaust temperature return pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 12 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check overhead set.

  • Check that cylinder 12 overhead setting is correct. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 19.

Cylinder 12 overhead setting correct?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and operate engine for greater than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2464 is inactive.

Fault Code 2464 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 02-Jul-2010


FAULT CODE 2464 (Single Turbocharger) - Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Below Normal Operating Range - Moderately Severe

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 12. |
 | STEP 2A. Check spark plug for contamination or damage. | Spark plug contaminated or damaged?
 | STEP 2B. Check spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 12. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2464 inactive, Fault Code 2463 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust temperature sensors. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 12 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify that the fault code is inactive. | Fault Code 2464 inactive?
 | STEP 6B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

No Repair.

  • Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 12.

Guided Step 2A - Check the spark plug.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug ”J" connector damaged
  • Inspect the electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 12.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring, if necessary.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature harness.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Keyswitch circuit energized
  • Connect INSITE™ electronic service tool
  • Isolate the generator set 24-VDC power supply
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check cylinder 12 exhaust gas temperature sensor response.

  • Remove the exhaust gas temperature sensors from cylinders 12 and 10.
  • Install the temperature sensor from cylinder 12 to cylinder 10.
  • Install the temperature sensor from cylinder 10 to cylinder 12.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2464 is inactive and that Fault Code 2463 is active.

Fault Code 2464 Inactive and Fault Code 2463 Active?
YES NO
No Repair

Repair

  • Replace the exhaust temperature sensor that was originally installed in cylinder 12 location. Refer to Procedure 019-013 in Section 19.

Go to 6A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Disconnect the engine harness connectors from cylinder 12 exhaust temperature sensor.

Action

Check the 5 VDC supply to the exhaust temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt supply pin and the exhaust temperature return pin of the exhaust temperature sensor harness cylinder 12.
  • Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 12 exhaust temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 12 exhaust temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature signal pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 6A

Guided Step 4E - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 12 exhaust temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature signal pin in the engine harness CM850 module connector to the exhaust temperature signal pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature return pin in the engine harness CM850 module connector to the exhaust temperature return pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature 5 volt supply pin in the engine harness CM850 module connector to the exhaust temperature 5 volt supply pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 12 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check overhead set.

  • Check that cylinder 12 overhead setting is correct. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 19.

Cylinder 12 overhead setting correct?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and running for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2464 is inactive.

Fault Code 2464 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 02-Jul-2010


FAULT CODE 2465 (Multiple Turbochargers) - Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Below Normal Operating Range - Moderately Severe

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 14. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 14. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2465 inactive, Fault Code 2466 active?
 | STEP 4B. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 4D. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 14 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify that the fault code is inactive. | Fault Code 2465 inactive?
 | STEP 6B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

No Repair.

  • Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 14.

Guided Step 2A - Check the spark plug.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug.

  • Spark plug correctly tightened
  • Spark plug ”J" connector damaged
  • Inspect the electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 14.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following.

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coils primary and secondary resistances. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring, if necessary.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the ignition signal pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Keyswitch circuit energized
  • Connect INSITE™ electronic service tool
  • Isolate the generator set 24-VDC power supply
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check cylinder 14 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 14 and 16.
  • Install the temperature sensor from cylinder 14 to cylinder 16.
  • Install the temperature sensor from cylinder 16 to cylinder 14.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2465 is inactive and that Fault Code 2466 is active.

Fault Code 2465 inactive and Fault Code 2466 active?
YES NO

Repair

Replace the exhaust temperature sensor.

  • Replace the exhaust temperature sensor that was originally installed in cylinder 14 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 14 exhaust temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 14 exhaust temperature sensor and the CENSE™ module.

Action

Check for a short circuit for pin-to-pin.

  • Measure the resistance from the exhaust temperature signal pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 14 exhaust temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature signal pin in the engine harness CENSE™ module connector to the exhaust temperature signal pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature return pin in the engine harness CENSE™ module connector to the exhaust temperature return pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 14 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check overhead set.

  • Check that cylinder 14 overhead setting is correct. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 19.

Cylinder 14 overhead setting correct?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and operate engine for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2465 is inactive.

Fault Code 2465 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 02-Jul-2010


FAULT CODE 2465 (Single Turbocharger) - Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Below Normal Operating Range - Moderately Severe

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 14. |
 | STEP 2A. Check spark plug for contamination or damage. | Spark plug contaminated or damaged?
 | STEP 2B. Check spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 14. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2465 inactive, Fault Code 2466 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust temperature sensors. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 14 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify that the fault code is inactive. | Fault Code 2465 inactive?
 | STEP 6B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

No Repair.

  • Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 14.

Guided Step 2A - Check the spark plug.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug ”J" connector damaged
  • Inspect the electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 14.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring, if necessary.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature harness.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Keyswitch circuit energized
  • Connect INSITE™ electronic service tool
  • Isolate the generator set 24-VDC power supply
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check cylinder 16 exhaust gas temperature sensor response.

  • Remove the exhaust gas temperature sensors from cylinders 14 and 16.
  • Install the temperature sensor from cylinder 14 to cylinder 16.
  • Install the temperature sensor from cylinder 16 to cylinder 14.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2465 is inactive and that Fault Code 2466 is active.

Fault Code 2465 Inactive and Fault Code 2466 Active?
YES NO
No Repair

Repair

  • Replace the exhaust temperature sensor that was originally installed in cylinder 14 location. Refer to Procedure 019-013 in Section 19.

Go to 6A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Disconnect the engine harness connectors from cylinder 14 exhaust temperature sensor.

Action

Check the 5 VDC supply to the exhaust temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt supply pin and the exhaust temperature return pin of the exhaust temperature sensor harness cylinder 14.
  • Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 14 exhaust temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 14 exhaust temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature signal pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 6A

Guided Step 4E - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 14 exhaust temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature signal pin in the engine harness CM850 module connector to the exhaust temperature signal pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature return pin in the engine harness CM850 module connector to the exhaust temperature return pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature 5 volt supply pin in the engine harness CM850 module connector to the exhaust temperature 5 volt supply pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 14 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check overhead set.

  • Check that cylinder 14 overhead setting is correct. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 19.

Cylinder 14 overhead setting correct?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and operate engine for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2465 is inactive.

Fault Code 2465 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 02-Jul-2010


FAULT CODE 2465 (Single Turbocharger) - Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Below Normal Operating Range - Moderately Severe

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 16. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 16. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2466 inactive, Fault Code 2465 active?
 | STEP 4B. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 4D. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 16 overhead set. |
 | STEP 5A. Check the overhead set. | Cylinder 16 overhead setting correct?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify that the fault code is inactive. | Fault Code 2466 inactive?
 | STEP 6B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

No Repair.

  • Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 16.

Guided Step 2A - Check the spark plug.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug.

  • Spark plug correctly tightened
  • Spark plug ”J" connector damaged
  • Inspect the electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 16.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following.

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring, if necessary.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the ignition signal pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Keyswitch circuit energized
  • Connect INSITE™ electronic service tool
  • Isolate the generator set 24-VDC power supply
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check cylinder 16 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 16 and 14.
  • Install the temperature sensor from cylinder 16 to cylinder 14.
  • Install the temperature sensor from cylinder 14 to cylinder 16.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2466 is inactive and that Fault Code 2465 is active.

Fault Code 2466 inactive and Fault Code 2465 active?
YES NO

Repair

Replace the exhaust temperature sensor.

  • Replace the exhaust temperature sensor that was originally installed in cylinder 16 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 16 exhaust temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 16 exhaust temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature signal pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 16 exhaust temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature signal pin in the engine harness CENSE™ module connector to the exhaust temperature signal pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature return pin in the engine harness CENSE™ module connector to the exhaust temperature return pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 16 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check overhead set.

  • Check that cylinder 16 overhead setting is correct. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 19.

Cylinder 16 overhead setting correct?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and operate engine for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2466 is inactive.

Fault Code 2466 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 02-Jul-2010


FAULT CODE 2466 (Single Turbocharger) - Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Below Normal Operating Range - Moderately Severe

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 16. |
 | STEP 2A. Check spark plug for contamination or damage. | Spark plug contaminated or damaged?
 | STEP 2B. Check spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 16. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2466 inactive, Fault Code 2465 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust temperature sensors. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 16 overhead set. |
 | STEP 5A. Check the overhead set. | Cylinder 16 overhead setting correct?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify that the fault code is inactive. | Fault Code 2466 inactive?
 | STEP 6B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

No Repair.

  • Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 16.

Guided Step 2A - Check the spark plug.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug ”J" connector damaged
  • Inspect the electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 16.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

Replace the ignition coil extension tube o-ring as found necessary.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coils and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature harness.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Keyswitch circuit energized
  • Connect INSITE™ electronic service tool
  • Isolate the generator set 24-VDC power supply
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check cylinder 16 exhaust gas temperature sensor response.

  • Remove the exhaust gas temperature sensors from cylinders 16 and 14.
  • Install the temperature sensor from cylinder 16 to cylinder 14.
  • Install the temperature sensor from cylinder 14 to cylinder 16.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2466 is inactive and that Fault Code 2465 is active.

Fault Code 2466 Inactive and Fault Code 2465 Active?
YES NO
No Repair

Repair

  • Replace the exhaust temperature sensor that was originally installed in cylinder 16 location. Refer to Procedure 019-013 in Section 19.

Go to 6A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Disconnect the engine harness connectors from cylinder 16 exhaust temperature sensor.

Action

Check the 5 VDC supply to the exhaust temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust temperature 5 volt supply pin and the exhaust temperature return pin of the exhaust temperature sensor harness cylinder 16.
  • Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 16 exhaust temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 16 exhaust temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature signal pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 6A

Guided Step 4E - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 16 exhaust temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature signal pin in the engine harness CM850 module connector to the exhaust temperature signal pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature return pin in the engine harness CM850 module connector to the exhaust temperature return pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature 5 volt supply pin in the engine harness CM850 module connector to the exhaust temperature 5 volt supply pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 16 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check overhead set.

  • Check that cylinder 16 overhead setting is correct. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 19.

Cylinder 16 overhead setting correct?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and operate engine for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2466 is inactive.

Fault Code 2466 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 02-Jul-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 1. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for a open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2469 inactive, Fault Code 2471 active?
 | STEP 4B. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 4D. Check the exhaust gas temperature circuit for a open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 1 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify the fault code is inactive. | Fault Code 2469 inactive?
 | STEP 6B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch is the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or Contact a Cummins® Authorized Repair Location.

Repair

  • Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 1.

Guided Step 2A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • Spark plug 'J' connector damaged.
  • Oil contamination of the electrode.
  • Spark plug porcelain damaged.

Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.
  • Use the following procedure for inspection of spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 1.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13, to check the ignition coil resistance.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13, to check the ignition coil resistance.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Ignition harness and connector pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place RUN/STOP/AUTO switch in the OFF mode.

Action

Check cylinder 1 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 1 and 3.
  • Install the temperature sensor from cylinder 1 to cylinder 3.
  • Install the temperature sensor from cylinder 3 to cylinder 1.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and operate the engine to run on-load for longer than 1 minute.

  • Use INSITE electronic service tool to check for Fault Code inactive and that Fault Code 2471 is active.

Fault Code 2469 inactive and Fault Code 2471 active?
YES NO

Repair

Replace the exhaust temperature sensor:

  • Replace the exhaust temperature sensor that was originally installed in cylinder 1 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 1 exhaust temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Engine harness and connector pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 1 exhaust temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature signal pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 1 exhaust temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature signal pin in the engine harness CENSE™ module connector to the exhaust temperature signal pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust temperature return pin in the engine harness CENSE™ module connector to the exhaust temperature return pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 1 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check cylinder 1.

  • Check that the cylinder 1 overhead setting is correct. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 1 overhead setting correct?
YES NO
No Repair

Repair

Adjust the overhead setting on cylinder 1. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify the fault code inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode and operate engine for longer than 1 minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to verify Fault Code 2469 is inactive.

Fault Code 2469 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 1. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2469 inactive, Fault Code 2471 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | More than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 1 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify the fault code is inactive. | Fault Code 2469 inactive?
 | STEP 6B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 1.

Guided Step 2A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • Spark plug 'J' connector damaged.
  • Oil contamination of the electrode.
  • Spark plug porcelain damaged.

Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.
  • Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 1.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396, to check the ignition coil resistance. Refer to Procedure 013-024 in Section 13,

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396, to check the ignition coil resistance. Refer to Procedure 013-024 in Section 13,

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Ignition harness and connector pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place RUN/STOP/AUTO switch in the OFF mode.

Action

Check cylinder 1 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 1 and 3.
  • Install the temperature sensor from cylinder 1 to cylinder 3.
  • Install the temperature sensor from cylinder 3 to cylinder 1.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and operate the engine to run on-load for longer than 1 minute.

  • Use INSITE™ electronic service tool to check for Fault Code 2469 inactive and that Fault Code 2471 is active.

Fault Code 2469 inactive and Fault Code 2471 active?
YES NO

Repair

Replace the exhaust temperature sensor:

  • Replace the exhaust temperature sensor that was originally installed in cylinder 1 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Disconnect the engine harness connectors from cylinder 1 exhaust temperature sensor.

Action

Check the 5-VDC supply to the exhaust temperature sensor.

  • Using a multimeter, measure the voltage between the exhaust temperature 5 volt supply pin and the exhaust temperature return pin of the exhaust temperature sensor harness cylinder 1.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 1 exhaust temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 1 exhaust temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature signal pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4E - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 1 exhaust temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature signal pin in the engine harness CM850 module connector to the exhaust temperature signal pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature return pin in the engine harness CM850 module connector to the exhaust temperature return pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature 5-VDC supply pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC supply pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 1 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check cylinder 1.

  • Check that the cylinder 1 overhead setting is correct. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 1 overhead setting correct?
YES NO
No Repair

Repair

Adjust the overhead setting on cylinder 1. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify the fault code inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode and operate engine for longer than 1 minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to verify Fault Code 2469 is inactive.

Fault Code 2469 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 3. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2469 inactive, Fault Code 2471 active?
 | STEP 4B. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 4D. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 3 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify the fault code is inactive. | Fault Code 2471 inactive?
 | STEP 6B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch ins the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or Contact a Cummins® Authorized Repair Location.

Repair

  • Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 3.

Guided Step 2A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • Spark plug 'J' connector damaged.
  • Oil contamination of the electrode.
  • Spark plug porcelain damaged.

Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.
  • Use the following procedure for inspection of spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 3.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396 to check the ignition coil resistance. Refer to Procedure 013-024 in Section 13,

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396 to check the ignition coil resistance. Refer to Procedure 013-024 in Section 13,

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place RUN/STOP/AUTO switch in the OFF mode.

Action

Check cylinder 3 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 3 and 1.
  • Install the temperature sensor from cylinder 3 to cylinder 1.
  • Install the temperature sensor from cylinder 1 to cylinder 3.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and operate the engine to run on-load for longer than 1 minute.

  • Use INSITE™ electronic service tool to check for Fault Code 2469 inactive and that Fault Code 2471 is active.

Fault Code 2471 inactive and Fault Code 2469 active?
YES NO

Repair

Replace the exhaust temperature sensor:

  • Replace the exhaust temperature sensor that was originally installed in cylinder 3 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 1 exhaust temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 1 exhaust temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature signal pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 3 exhaust temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature signal pin in the engine harness CENSE™ module connector to the exhaust temperature signal pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature return pin in the engine harness CENSE™ module connector to the exhaust temperature return pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 3 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check cylinder 1.

  • Check that the cylinder 3 overhead setting is correct. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 3 overhead setting correct?
YES NO
No Repair

Repair

Adjust the overhead setting on cylinder 3. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify the fault code inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode and operate engine for longer than 1 minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to verify Fault Code 2471 is inactive.

Fault Code 2471 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 3. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2471 inactive, Fault Code 2469 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | More than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 3 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify the fault code is inactive. | Fault Code 2471 inactive?
 | STEP 6B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 3.

Guided Step 2A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • Spark plug 'J' connector damaged.
  • Oil contamination of the electrode.
  • Spark plug porcelain damaged.

Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.
  • Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 3.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396 to check the ignition coil resistance. Refer to Procedure 013-024 in Section 13,

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396, to check the ignition coil resistance. Refer to Procedure 013-024 in Section 13,

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place RUN/STOP/AUTO switch in the OFF mode.

Action

Check cylinder 3 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 1 and 3.
  • Install the temperature sensor from cylinder 3 to cylinder 1.
  • Install the temperature sensor from cylinder 1 to cylinder 3.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and operate the engine to run on-load for longer than 1 minute.

  • Use INSITE™ electronic service tool to check for Fault Code 2471 is inactive and that Fault Code 2469 is active.

Fault Code 2471 inactive and Fault Code 2471 active?
YES NO

Repair

Replace the exhaust temperature sensor:

  • Replace the exhaust temperature sensor that was originally installed in cylinder 3 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Disconnect the engine harness connectors from cylinder 3 exhaust temperature sensor.

Action

Check the 5-VDC supply to the exhaust temperature sensor.

  • Using a multimeter, measure the voltage between the exhaust temperature 5 volt supply pin and the exhaust temperature return pin of the exhaust temperature sensor harness cylinder 3.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 6A

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 3 exhaust temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 3 exhaust temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature signal pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4E - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 3 exhaust temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature signal pin in the engine harness CM850 module connector to the exhaust temperature signal pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature return pin in the engine harness CM850 module connector to the exhaust temperature return pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature 5-VDC supply pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC supply pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 3 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check cylinder 3.

  • Check that the cylinder 3 overhead setting is correct. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 3 overhead setting correct?
YES NO
No Repair

Repair

Adjust the overhead setting on cylinder 3. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify the fault code inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode and operate engine for longer than 1 minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to verify Fault Code 2471 is inactive.

Fault Code 2471 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 5. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2472 inactive, Fault Code 2473 active?
 | STEP 4B. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 4D. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 5 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify the fault code is inactive. | Fault Code 2472 inactive?
 | STEP 6B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 5.

Guided Step 2A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • Spark plug 'J' connector damaged.
  • Oil contamination of the electrode.
  • Spark plug porcelain damaged.

Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.
  • Use the following procedure for inspection of spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 5.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396 to check the ignition coil resistance. Refer to Procedure 013-024 in Section 13,

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396 to check the ignition coil resistance. Refer to Procedure 013-024 in Section 13,

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place RUN/STOP/AUTO switch in the OFF mode.

Action

Check cylinder 5 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 5 and 7.
  • Install the temperature sensor from cylinder 5 to cylinder 7.
  • Install the temperature sensor from cylinder 7 to cylinder 5.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and operate the engine to run on-load for longer than 1 minute.

  • Use INSITE™ electronic service tool to check for Fault Code 2472 inactive and that Fault Code 2473 is active.

Fault Code 2472 inactive and Fault Code 2473 active?
YES NO

Repair

Replace the exhaust temperature sensor:

  • Replace the exhaust temperature sensor that was originally installed in cylinder 5 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 5 exhaust temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 5 exhaust temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature signal pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 5 exhaust temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature signal pin in the engine harness CENSE™ module connector to the exhaust temperature signal pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature return pin in the engine harness CENSE™ module connector to the exhaust temperature return pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 5 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check cylinder 1.

  • Check that the cylinder 5 overhead setting is correct. Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 5 overhead setting correct?
YES NO
No Repair

Repair

Adjust the overhead setting on cylinder 5. Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify the fault code inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode and operate engine for longer than 1 minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to verify Fault Code 2472 is inactive.

Fault Code 2472 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 5. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2472 inactive, Fault Code 2473 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | More than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 5 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify the fault code is inactive. | Fault Code 2472 inactive?
 | STEP 6B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 5.

Guided Step 2A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • Spark plug 'J' connector damaged.
  • Oil contamination of the electrode.
  • Spark plug porcelain damaged.

Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.
  • Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 5.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396, to check the ignition coil resistance. Refer to Procedure 013-024 in Section 13,

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396 to check the ignition coil resistance. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Ignition harness and connector pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place RUN/STOP/AUTO switch in the OFF mode.

Action

Check cylinder 5 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 5 and 7.
  • Install the temperature sensor from cylinder 5 to cylinder 7.
  • Install the temperature sensor from cylinder 7 to cylinder 5.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and operate the engine to run on-load for longer than 1 minute.

  • Use INSITE™ electronic service tool to check for Fault Code 2472 inactive and that Fault Code 2473 is active.

Fault Code 2472 inactive and Fault Code 2473 active?
YES NO

Repair

Replace the exhaust temperature sensor:

  • Replace the exhaust temperature sensor that was originally installed in cylinder 5 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Turn keyswitch ON.
  • RUN/STOP/AUTO switch in the OFF mode.
  • Disconnect the engine harness connectors from cylinder 5 exhaust temperature sensor.

Action

Check the 5-VDC supply to the exhaust temperature sensor.

  • Using a multimeter, measure the voltage between the exhaust temperature 5 volt supply pin and the exhaust temperature return pin of the exhaust temperature sensor harness cylinder 5.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 5 exhaust temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 5 exhaust temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature signal pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4E - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 5 exhaust temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature signal pin in the engine harness CM850 module connector to the exhaust temperature signal pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature return pin in the engine harness CM850 module connector to the exhaust temperature return pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature 5-VDC supply pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC supply pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 5 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check cylinder 5.

  • Check that the cylinder 5 overhead setting is correct. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396Refer to Procedure 003-006 in Section 3.

Cylinder 5 overhead setting correct?
YES NO
No Repair

Repair

Adjust the overhead setting on cylinder 5. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396Refer to Procedure 003-006 in Section 3.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify the fault code inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode and operate engine for longer than 1 minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to verify Fault Code 2472 is inactive.

Fault Code 2472 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 7. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2473 inactive, Fault Code 2472 active?
 | STEP 4B. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 4D. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 7 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify the fault code is inactive. | Fault Code 2473 inactive?
 | STEP 6B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 7.

Guided Step 2A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • Spark plug 'J' connector damaged.
  • Oil contamination of the electrode.
  • Spark plug porcelain damaged.

Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.
  • Use the following procedure for inspection of spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 7.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396 to check the ignition coil resistance. Refer to Procedure 013-024 in Section 13,

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396 to check the ignition coil resistance. Refer to Procedure 013-024 in Section 13,

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place RUN/STOP/AUTO switch in the OFF mode.

Action

Check cylinder 7 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 7 and 5.
  • Install the temperature sensor from cylinder 7 to cylinder 5.
  • Install the temperature sensor from cylinder 5 to cylinder 7.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and operate the engine to run on-load for longer than 1 minute.

  • Use INSITE™ electronic service tool to check for Fault Code 2469 inactive and that Fault Code 2471 is active.

Fault Code 2469 inactive and Fault Code 2471 active?
YES NO

Repair

Replace the exhaust temperature sensor:

  • Replace the exhaust temperature sensor that was originally installed in cylinder 7 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 7 exhaust temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 7 exhaust temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature signal pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 7 exhaust temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature signal pin in the engine harness CENSE™ module connector to the exhaust temperature signal pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature return pin in the engine harness CENSE™ module connector to the exhaust temperature return pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 7 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check cylinder 7.

  • Check that the cylinder 7 overhead setting is correct. Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 7 overhead setting correct?
YES NO
No Repair

Repair

Adjust the overhead setting on cylinder7. Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify the fault code inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode and operate engine for longer than 1 minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to verify Fault Code 2473 is inactive.

Fault Code 2473 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 7. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2473 inactive, Fault Code 2472 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | More than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 7 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify the fault code is inactive. | Fault Code 2473 inactive?
 | STEP 6B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 7.

Guided Step 2A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • Spark plug 'J' connector damaged.
  • Oil contamination of the electrode.
  • Spark plug porcelain damaged.

Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.
  • Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 7.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396 to check the ignition coil resistance. Refer to Procedure 013-024 in Section 13,

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396 to check the ignition coil resistance. Refer to Procedure 013-024 in Section 13,

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Ignition harness and connector pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24-VDC power supply.
  • Place RUN/STOP/AUTO switch in the OFF mode.

Action

Check cylinder 7 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 7 and 5.
  • Install the temperature sensor from cylinder 7 to cylinder 5.
  • Install the temperature sensor from cylinder 5 to cylinder 7.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and operate the engine to run on-load for longer than 1 minute.

  • Use INSITE™ electronic service tool to check for Fault Code 2472 inactive and that Fault Code 2473 is active.

Fault Code 2473 inactive and Fault Code 2473 active?
YES NO

Repair

Replace the exhaust temperature sensor:

  • Replace the exhaust temperature sensor that was originally installed in cylinder 7 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Disconnect the engine harness connectors from cylinder 7 exhaust temperature sensor.

Action

Check the 5-VDC supply to the exhaust temperature sensor.

  • Using a multimeter, measure the voltage between the exhaust temperature 5 volt supply pin and the exhaust temperature return pin of the exhaust temperature sensor harness cylinder 7.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 7 exhaust temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 7 exhaust temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature signal pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4E - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 7 exhaust temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature signal pin in the engine harness CM850 module connector to the exhaust temperature signal pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust temperature return pin in the engine harness CM850 module connector to the exhaust temperature return pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature 5-VDC supply pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC supply pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 7 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check cylinder 1.

  • Check that the cylinder 7 overhead setting is correct. Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396.Refer to Procedure 003-006 in Section 3.

Cylinder 7 overhead setting correct?
YES NO
No Repair

Repair

Adjust the overhead setting on cylinder 7. Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396.Refer to Procedure 003-006 in Section 3.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify the fault code inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode and operate engine for longer than 1 minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to verify Fault Code 2473 is inactive.

Fault Code 2473 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 9. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for a open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2475 inactive, Fault Code 2476 active?
 | STEP 4B. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 4D. Check the exhaust gas temperature circuit for a open circuit. | Less than 10 ohms?
STEP 5. | Check Cylinder 9 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify the fault code is inactive. | Fault Code 2475 inactive?
 | STEP 6B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or Contact a Cummins® Authorized Repair Location.

Repair

  • Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 9.

Guided Step 2A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • Spark plug 'J' connector damaged.
  • Oil contamination of the electrode.
  • Spark plug porcelain damaged.

Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.
  • Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 9.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13, to check the ignition coil resistance.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13, to check the ignition coil resistance.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Ignition harness and connector pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24 volt power supply.
  • Place RUN/STOP/AUTO switch in the OFF mode.

Action

Check cylinder 1 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 9 and 11.
  • Install the temperature sensor from cylinder 9 to cylinder 11.
  • Install the temperature sensor from cylinder 11 to cylinder 9.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and operate the engine to run on-load for longer than 1 minute.

  • Use INSITE™ electronic service tool to check for Fault Code 2475 inactive and that Fault Code 2476 is active.

Fault Code 2475 inactive and Fault Code 2476 active?
YES NO

Repair

Replace the exhaust temperature sensor:

  • Replace the exhaust temperature sensor that was originally installed in cylinder 9 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 9 exhaust temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Engine harness and connector pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 9 exhaust temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature signal pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 9 exhaust temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature signal pin in the engine harness CENSE™ module connector to the exhaust temperature signal pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature return pin in the engine harness CENSE™ module connector to the exhaust temperature return pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 9 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check cylinder 1.

  • Check that the cylinder 9 overhead setting is correct. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 9 overhead setting correct?
YES NO
No Repair

Repair

Adjust the overhead setting on cylinder 9. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify the fault code inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode and operate engine for longer than 1 minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to verify Fault Code 2475 is inactive.

Fault Code 2475 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 9. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2475 inactive, Fault Code 2476 active?
 | STEP 4B. Check the 5 volt supply to the exhaust temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | More than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 9 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify the fault code is inactive. | Fault Code 2475 inactive?
 | STEP 6B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 9.

Guided Step 2A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • Spark plug 'J' connector damaged.
  • Oil contamination of the electrode.
  • Spark plug porcelain damaged.

Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.
  • Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 9.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396 to check the ignition coil resistance. Refer to Procedure 013-024 in Section 13,

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396 to check the ignition coil resistance. Refer to Procedure 013-024 in Section 13,

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Ignition harness and connector pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24 volt power supply.
  • Place RUN/STOP/AUTO switch in the OFF mode.

Action

Check cylinder 9 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 9 and 11.
  • Install the temperature sensor from cylinder 9 to cylinder 11.
  • Install the temperature sensor from cylinder 11 to cylinder 9.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and operate the engine to run on-load for longer than 1 minute.

  • Use INSITE™ electronic service tool to check for Fault Code 2475 inactive and that Fault Code 2476 is active.

Fault Code 2475 inactive and Fault Code 2476 active?
YES NO

Repair

Replace the exhaust temperature sensor:

  • Replace the exhaust temperature sensor that was originally installed in cylinder 9 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the 5 volt supply to the exhaust temperature sensor.

Conditions

  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Disconnect the engine harness connectors from cylinder 9 exhaust temperature sensor.

Action

Check the 5 volt supply to the exhaust temperature sensor.

  • Use a multimeter. Measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 9.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 9 exhaust temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 9 exhaust temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4E - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 9 exhaust temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature RETURN pin in the engine harness CM850 module connector to the exhaust temperature RETURN pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature 5 volt SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5 volt SUPPLY pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 15 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check cylinder 15.

  • Check that the cylinder 15 overhead setting is correct. Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396.Refer to Procedure 003-006 in Section 3.

Cylinder 9 overhead setting correct?
YES NO
No Repair

Repair

Adjust the overhead setting on cylinder 15. Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396.Refer to Procedure 003-006 in Section 3.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify the fault code inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode and operate engine for longer than 1 minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to verify Fault Code 2475 is inactive.

Fault Code 2475 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 11. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for a open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2476 inactive, Fault Code 2475 active?
 | STEP 4B. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 4D. Check the exhaust gas temperature circuit for a open circuit. | Less than 10 ohms?
STEP 5. | Check Cylinder 11 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify the fault code is inactive. | Fault Code 2476 inactive?
 | STEP 6B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or Contact a Cummins® Authorized Repair Location.

Repair

  • Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 11.

Guided Step 2A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • Spark plug 'J' connector damaged.
  • Oil contamination of the electrode.
  • Spark plug porcelain damaged.

Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.
  • Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 11.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13, to check the ignition coil resistance.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13, to check the ignition coil resistance.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Ignition harness and connector pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24 volt power supply.
  • Place RUN/STOP/AUTO switch in the OFF mode.

Action

Check cylinder 11 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 11 and 9.
  • Install the temperature sensor from cylinder 11 to cylinder 9.
  • Install the temperature sensor from cylinder 9 to cylinder 11.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and operate the engine to run on-load for longer than 1 minute.

  • Use INSITE™ electronic service tool to check for Fault Code 2476 inactive and that Fault Code 2475 is active.

Fault Code 2476 inactive and Fault Code 2475 active?
YES NO

Repair

Replace the exhaust temperature sensor:

  • Replace the exhaust temperature sensor that was originally installed in cylinder 11 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 11 exhaust temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Engine harness and connector pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from Cylinder 11 exhaust temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 11 exhaust temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust temperature RETURN pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 11 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check cylinder 11.

  • Check that the cylinder 11 overhead setting is correct. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 11 overhead setting correct?
YES NO
No Repair

Repair

Adjust the overhead setting on cylinder 11. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify the fault code inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode and operate engine for longer than 1 minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to verify Fault Code 2476 is inactive.

Fault Code 2476 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 11. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2476 inactive, Fault Code 2475 active?
 | STEP 4B. Check the 5 volt supply to the exhaust temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | More than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 11 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify the fault code is inactive. | Fault Code 2476 inactive?
 | STEP 6B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 11.

Guided Step 2A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • Spark plug 'J' connector damaged.
  • Oil contamination of the electrode.
  • Spark plug porcelain damaged.

Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.
  • Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 11.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396 to check the ignition coil resistance. Refer to Procedure 013-024 in Section 13,

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396 to check the ignition coil resistance. Refer to Procedure 013-024 in Section 13,

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Ignition harness and connector pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24 volt power supply.
  • Place RUN/STOP/AUTO switch in the OFF mode.

Action

Check cylinder 11 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 11 and 9.
  • Install the temperature sensor from cylinder 11 to cylinder 9.
  • Install the temperature sensor from cylinder 9 to cylinder 11.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and operate the engine to run on-load for longer than 1 minute.

  • Use INSITE™ electronic service tool to check for Fault Code 2476 inactive and that Fault Code 2475 is active.

Fault Code 2476 inactive and Fault Code 2475 active?
YES NO

Repair

Replace the exhaust temperature sensor:

  • Replace the exhaust temperature sensor that was originally installed in cylinder 11 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the 5 volt supply to the exhaust temperature sensor.

Conditions

  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Disconnect the engine harness connectors from cylinder 11 exhaust temperature sensor.

Action

Check the 5 volt supply to the exhaust temperature sensor.

  • Using a multimeter, measure the voltage between the exhaust temperature 5 volt supply pin and the exhaust temperature return pin of the exhaust temperature sensor harness cylinder 11.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 11 exhaust temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 11 exhaust temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4E - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 11 exhaust temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the engine harness CM850 module connector to the exhaust temperature RETURN pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature 5 volt SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5 volt SUPPLY pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 11 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check cylinder 11.

  • Check that the cylinder 11 overhead setting is correct. Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396.Refer to Procedure 003-006 in Section 3.

Cylinder 11 overhead setting correct?
YES NO
No Repair

Repair

Adjust the overhead setting on cylinder 11. Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396.Refer to Procedure 003-006 in Section 3.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify the fault code inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode and operate engine for longer than 1 minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to verify Fault Code 2476 is inactive.

Fault Code 2476 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


FAULT CODE 2477 (Multiple Turbochargers) - Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 13. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for a open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2477 inactive, Fault Code 2478 active?
 | STEP 4B. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 4D. Check the exhaust gas temperature circuit for a open circuit. | Less than 10 ohms?
STEP 5. | Check Cylinder 13 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify the fault code is inactive. | Fault Code 2477 inactive?
 | STEP 6B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or Contact a Cummins® Authorized Repair Location.

Repair

  • Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 13.

Guided Step 2A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • Spark plug 'J' connector damaged.
  • Oil contamination of the electrode.
  • Spark plug porcelain damaged.

Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.
  • Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 13.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13, to check the ignition coil resistance.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396, to check the ignition coil resistance. Refer to Procedure 013-024 in Section 13,

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Ignition harness and connector pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24 volt power supply.
  • Place RUN/STOP/AUTO switch in the OFF mode.

Action

Check cylinder 13 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 13 and 15.
  • Install the temperature sensor from cylinder 13 to cylinder 15.
  • Install the temperature sensor from cylinder 15 to cylinder 13.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and operate the engine to run on-load for longer than 1 minute.

  • Use INSITE™ electronic service tool to check for Fault Code 2477 is inactive and that Fault Code 2478 is active.

Fault Code 2477 inactive and Fault Code 2478 active?
YES NO

Repair

Replace the exhaust temperature sensor:

  • Replace the exhaust temperature sensor that was originally installed in cylinder 13 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 13 exhaust temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Engine harness and connector pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 13 exhaust temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 13 exhaust temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust temperature RETURN pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 13 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check cylinder 13.

  • Check that the cylinder 13 overhead setting is correct. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 13 overhead setting correct?
YES NO
No Repair

Repair

Adjust the overhead setting on cylinder 13. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify the fault code inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode and operate engine for longer than 1 minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to verify Fault Code 2477 is inactive.

Fault Code 2477 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 22-Jun-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 13. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2477 inactive, Fault Code 2478 active?
 | STEP 4B. Check the 5 volt supply to the exhaust temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | More than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 13 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify the fault code is inactive. | Fault Code 2477 inactive?
 | STEP 6B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 13.

Guided Step 2A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • Spark plug 'J' connector damaged.
  • Oil contamination of the electrode.
  • Spark plug porcelain damaged.

Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.
  • Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 13.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396 to check the ignition coil resistance. Refer to Procedure 013-024 in Section 13,

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396 to check the ignition coil resistance. Refer to Procedure 013-024 in Section 13,

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Ignition harness and connector pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24 volt power supply.
  • Place RUN/STOP/AUTO switch in the OFF mode.

Action

Check cylinder 13 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 13 and 15.
  • Install the temperature sensor from cylinder 13 to cylinder 15.
  • Install the temperature sensor from cylinder 15 to cylinder 13.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and operate the engine to run on-load for longer than 1 minute.

  • Use INSITE™ electronic service tool to check for Fault Code 2477 inactive and that Fault Code 2478 is active.

Fault Code 2477 inactive and Fault Code 2478 active?
YES NO

Repair

Replace the exhaust temperature sensor:

  • Replace the exhaust temperature sensor that was originally installed in cylinder 13 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the 5 volt supply to the exhaust temperature sensor.

Conditions

  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Disconnect the engine harness connectors from cylinder 13 exhaust temperature sensor.

Action

Check the 5 volt supply to the exhaust temperature sensor.

  • Using a multimeter, measure the voltage between the exhaust temperature 5 volt SUPPLY pin and the exhaust temperature RETURN pin of the exhaust temperature sensor harness cylinder 13.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 13 exhaust temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 13 exhaust temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4E - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 13 exhaust temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the engine harness CM850 module connector to the exhaust temperature RETURN pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature 5 volt SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5 volt SUPPLY pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 13 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check cylinder 13.

  • Check that the cylinder 13 overhead setting is correct. Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396.Refer to Procedure 003-006 in Section 3.

Cylinder 13 overhead setting correct?
YES NO
No Repair

Repair

Adjust the overhead setting on cylinder 13. Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396.Refer to Procedure 003-006 in Section 3.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify the fault code inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode and operate engine for longer than 1 minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to verify Fault Code 2477 is inactive.

Fault Code 2477 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 15. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for a open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2478 inactive, Fault Code 2477 active?
 | STEP 4B. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 4D. Check the exhaust gas temperature circuit for a open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 15 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify the fault code is inactive. | Fault Code 2478 inactive?
 | STEP 6B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or Contact a Cummins® Authorized Repair Location.

Repair

  • Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 15.

Guided Step 2A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • Spark plug 'J' connector damaged.
  • Oil contamination of the electrode.
  • Spark plug porcelain damaged.

Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.
  • Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 15.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13, to check the ignition coil resistance.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13, to check the ignition coil resistance.

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Ignition harness and connector pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24 volt power supply.
  • Place RUN/STOP/AUTO switch in the OFF mode.

Action

Check cylinder 15 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 15 and 13.
  • Install the temperature sensor from cylinder 15 to cylinder 13.
  • Install the temperature sensor from cylinder 13 to cylinder 15.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and operate the engine to run on-load for longer than 1 minute.

  • Use INSITE™ electronic service tool to check for Fault Code 2478 inactive and that Fault Code 2477 is active.

Fault Code 2478 inactive and Fault Code 2477 active?
YES NO

Repair

Replace the exhaust temperature sensor:

  • Replace the exhaust temperature sensor that was originally installed in cylinder 15 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 15 exhaust temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Engine harness and connector pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 15 exhaust temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 15 exhaust temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust temperature RETURN pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 15 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check cylinder 15.

  • Check that the cylinder 15 overhead setting is correct. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 15 overhead setting correct?
YES NO
No Repair

Repair

Adjust the overhead setting on cylinder 15. Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify the fault code inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode and operate engine for longer than 1 minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to verify Fault Code 2478 is inactive.

Fault Code 2478 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2457 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 15. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust temperature circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2478 inactive, Fault Code 2477 active?
 | STEP 4B. Check the 5 volt supply to the exhaust temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit pin-to-pin. | More than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 15 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify the fault code is inactive. | Fault Code 2478 inactive?
 | STEP 6B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2457 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 6A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 15.

Guided Step 2A - Check the spark plug.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • Spark plug 'J' connector damaged.
  • Oil contamination of the electrode.
  • Spark plug porcelain damaged.

Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.
  • Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 15.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396 to check the ignition coil resistance. Refer to Procedure 013-024 in Section 13,

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.
  • Use the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396 to check the ignition coil resistance. Refer to Procedure 013-024 in Section 13,

Go to 3B

Go to 6A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Ignition harness and connector pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Isolate the generator set 24 volt power supply.
  • Place RUN/STOP/AUTO switch in the OFF mode.

Action

Check cylinder 15 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 15 and 13.
  • Install the temperature sensor from cylinder 15 to cylinder 13.
  • Install the temperature sensor from cylinder 13 to cylinder 15.
  • Connect the exhaust temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and operate the engine to run on-load for longer than 1 minute.

  • Use INSITE™ electronic service tool to check for Fault Code 2478 inactive and that Fault Code 2477 is active.

Fault Code 2478 inactive and Fault Code 2477 active?
YES NO

Repair

Replace the exhaust temperature sensor:

  • Replace the exhaust temperature sensor that was originally installed in cylinder 15 location. Refer to Procedure 019-013 in Section 19.
No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust temperature sensor.

Conditions

  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Disconnect the engine harness connectors from cylinder 15 exhaust temperature sensor.

Action

Check the 5 volt supply to the exhaust temperature sensor.

  • Using a multimeter, measure the voltage between the exhaust temperature 5 volt supply pin and the exhaust temperature return pin of the exhaust temperature sensor harness cylinder 15.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 15 exhaust temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use a wiring diagram for connector pin identification or the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Reference the wiring diagram for harness termination and location.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for a short circuit pin-to-pin.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 15 exhaust temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 6A

Guided Step 4E - Check for a open circuit.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 15 exhaust temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust temperature RETURN pin in the engine harness CM850 module connector to the exhaust temperature RETURN pin in the exhaust temperature sensor connector.
  • Measure the resistance from the exhaust temperature 5 volt SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5 volt SUPPLY pin in the exhaust temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check cylinder 15 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Check cylinder 15

  • Check that the cylinder 15 overhead setting is correct. Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396.Refer to Procedure 003-006 in Section 3.

Cylinder 15 overhead setting correct?
YES NO
No Repair

Repair

Adjust the overhead setting on cylinder 15. Use the following procedure for inspection of the spark plug in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396.Refer to Procedure 003-006 in Section 3.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Verify the fault code inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the RUN mode and operate engine for longer than 1 minute.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to verify Fault Code 2478 is inactive.

Fault Code 2478 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 1A

Guided Step 6B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Place RUN/STOP/AUTO switch in the STOP mode.

Action

Clear inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Other fault codes active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Other fault codes active?
YES NO
No Repair

Repair

Refer to the Engine Performance Troubleshooting Tree in Section TT of this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2482 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2482 active?
YES NO
No Repair

Repair

Refer to the Engine Performance Troubleshooting Tree in Section TT of this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


FAULT CODE 2484 - Multiple Turbochargers Exhaust Gas Temperature Cylinder 1 (A1) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2469 and/or 2766 active?
STEP 2. | Check the spark plug on cylinder 1. |
 | STEP 2A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 1. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Ignition harness and connector pins OK?
 | STEP 3C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2484 inactive and Fault Code 2485 active?
 | STEP 4B. Check the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 1 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check cylinder 1 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2484 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the active fault codes.

  • Read the fault codes.

Fault Code 2469 and/or 2766 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 1.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug ‘J’ connector damaged
  • Electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Repair as necessary:

  • Replace the spark plug.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 1.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube
  • Check the ignition coil primary and secondary resistances.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 1 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensor connector from cylinder 1
  • Install the temperature sensor from cylinder 1 to cylinder 3.
  • Install the temperature sensor from cylinder 3 to cylinder 1.
  • Reconnect the exhaust temperature sensors.

Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2484 is inactive and that Fault Code 2485 is active.

Fault Code 2484 inactive and Fault Code 2485 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in cylinder 1 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 1 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 1 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 1 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 1 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 1 overhead set is correct.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder 1 power cylinder.

Guided Step 6A - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (If available, these inspections can be performed using a borescope without component removal):

  • Damage to the cylinder head intake or exhaust valves
  • Damage to the cylinder head intake or exhaust valve seats.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair or replace the cylinder head.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2484 is inactive.

Fault Code 2484 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit..
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Dec-2010


FAULT CODE 2484 - Single Turbocharger Exhaust Gas Temperature Cylinder 1 (A1) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2469 and/or 2766 active?
STEP 2. | Check the spark plug on cylinder 1. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 1. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2484 inactive and Fault Code 2485 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | Voltage between 4.75 and 5.25-VDC?
 | STEP 4C. Check the engine harness and connector pins. | Dirty or damaged pin?
 | STEP 4D. Check the exhaust gas temperature sensor circuit for a short circuit pin-to-pin. | More than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check the cylinder 1 overhead set. |
 | STEP 5A. Complete visual inspection of the cylinder 1 overhead set. | Overhead set OK?
STEP 6. | Inspect the cylinder 1 power cylinder. |
 | STEP 6A. Visually inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2484 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and running for more than one minute.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2469 and/or 2766 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 1.

Guided Step 2A - Check the spark plug on cylinder 1.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the spark plug for the following:

  • Plug correctly tightened.
  • 'J' connector damaged.
  • Oil contamination on electrode.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Retighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 1.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil and ignition coil extension tube o-ring. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the appropriate wiring diagram for connector pin identification.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check the ignition harness for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks to all interconnecting harness connectors in the circuit.
  • Refer to the appropriate wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check the ignition harness for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature sensor circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool
  • Isolate the generator set 24-VDC power supply
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder 1 exhaust gas temperature sensor response.

  • Remove the exhaust gas temperature sensors from cylinders 1 and 3.
  • Install the temperature sensor from cylinder 1 to 3.
  • Install the temperature sensor from cylinder 3 to 1.
  • Reconnect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool, check that Fault Code 2484 is inactive and that Fault Code 2485 is active.

Fault Code 2484 inactive and Fault Code 2485 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in the cylinder 1 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connectors from cylinder 1 exhaust gas temperature sensor.

Action

Check the 5-VDC supply to the exhaust gas temperature sensor.

  • Measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 1.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 1 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair or replace the engine harness or harness connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check the exhaust gas temperature sensor circuit for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from cylinder 1 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connectors. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check the exhaust gas temperature sensor circuit for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 1 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CM850 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5-VDC SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust gas temperature sensor connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or harness connectors. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the cylinder 1 overhead set.

Guided Step 5A - Check the cylinder 1 overhead set.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 1 overhead setting is correct.

  • Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Complete visual inspection of the cylinder 1 power cylinder.

Guided Step 6A - Visually inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (if available, these inspections can be performed using a Borescope without component removal):

  • Cylinder Head - Intake or exhaust valve/valve seat damage. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair the cylinder head as necessary. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2484 is inactive.

Fault Code 2484 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Using INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 18-Mar-2011


FAULT CODE 2485 - Multiple Turbochargers Exhaust Gas Temperature Cylinder 3 (A2) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2469 and/or 2766 active?
STEP 2. | Check the spark plug on cylinder 3. |
 | STEP 2A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 3. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Ignition harness and connector pins OK?
 | STEP 3C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2485 inactive and Fault Code 2484 active?
 | STEP 4B. Check the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 3 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check cylinder 3 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2485 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the active fault codes.

  • Read the fault codes.

Fault Code 2469 and/or 2766 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 3.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug ‘J’ connector damaged
  • Electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Repair as necessary:

  • Replace the spark plug.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 3.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube
  • Check the ignition coil primary and secondary resistances.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 3 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensor connector from cylinder 3
  • Install the temperature sensor from cylinder 3 to cylinder 1.
  • Install the temperature sensor from cylinder 1 to cylinder 3.
  • Reconnect the exhaust temperature sensors.

Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2485 is inactive and that Fault Code 2484 is active.

Fault Code 2485 inactive and Fault Code 2484 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in cylinder 3 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 3 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 3 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 3 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 3 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 3 overhead set is correct.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder 3 power cylinder.

Guided Step 6A - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (If available, these inspections can be performed using a borescope without component removal):

  • Damage to the cylinder head intake or exhaust valves
  • Damage to the cylinder head intake or exhaust valve seats.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair or replace the cylinder head.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2485 is inactive.

Fault Code 2485 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-Jan-2011


FAULT CODE 2485 – Single Turbocharger Exhaust Gas Temperature Cylinder 3 (A2) – Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2471 and/or 2766 active?
STEP 2. | Check the spark plug on cylinder 3. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 3. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2485 inactive and Fault Code 2484 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | Voltage between 4.75 and 5.25-VDC?
 | STEP 4C. Check the engine harness and connector pins. | Dirty or damaged pin?
 | STEP 4D. Check the exhaust gas temperature sensor circuit for a short circuit pin-to-pin. | More than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check the cylinder 3 overhead set. |
 | STEP 5A. Complete visual inspection of the cylinder 3 overhead set. | Overhead set OK?
STEP 6. | Inspect the cylinder 3 power cylinder. |
 | STEP 6A. Visually inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2485 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and running for more than one minute.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2471 and/or 2766 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 3.

Guided Step 2A - Check the spark plug on cylinder 3.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the spark plug for the following:

  • Plug correctly tightened.
  • 'J' connector damaged.
  • Oil contamination on electrode.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Retighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 3.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil and ignition coil extension tube o-ring. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the appropriate wiring diagram for connector pin identification.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check the ignition harness for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks to all interconnecting harness connectors in the circuit.
  • Refer to the appropriate wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check the ignition harness for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature sensor circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool
  • Isolate the generator set 24-VDC power supply
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder 3 exhaust gas temperature sensor response.

  • Remove the exhaust gas temperature sensors from cylinders 1 and 3.
  • Install the temperature sensor from cylinder 3 to 1.
  • Install the temperature sensor from cylinder 1 to 3.
  • Reconnect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool, check that Fault Code 2485 is inactive and that Fault Code 2484 is active.

Fault Code 2485 inactive and Fault Code 2484 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in the cylinder 3 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connectors from cylinder 3 exhaust gas temperature sensor.

Action

Check the 5-VDC supply to the exhaust gas temperature sensor.

  • Measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 3.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 3 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair or replace the engine harness or harness connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check the exhaust gas temperature sensor circuit for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from cylinder 3 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connectors. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check the exhaust gas temperature sensor circuit for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 3 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CM850 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5-VDC SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust gas temperature sensor connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or harness connectors. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the cylinder 3 overhead set.

Guided Step 5A - Check the cylinder 3 overhead set.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 3 overhead setting is correct.

  • Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Complete visual inspection of the cylinder 3 power cylinder.

Guided Step 6A - Visually inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (if available, these inspections can be performed using a Borescope without component removal):

  • Cylinder Head - Intake or exhaust valve/valve seat damage. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair the cylinder head as necessary. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2484 is inactive.

Fault Code 2485 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Using INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 24-Mar-2011


FAULT CODE 2486 - Multiple Turbochargers Exhaust Gas Temperature Cylinder 5 (A3) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2472 and/or 2766 active?
STEP 2. | Check the spark plug on cylinder 5. |
 | STEP 2A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 5. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Ignition harness and connector pins OK?
 | STEP 3C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2486 inactive and Fault Code 2487 active?
 | STEP 4B. Check the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 5 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check cylinder 5 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2486 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the active fault codes.

  • Read the fault codes.

Fault Code 2469 and/or 2766 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 5.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug ‘J’ connector damaged
  • Electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Repair as necessary:

  • Replace the spark plug.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 5.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube
  • Check the ignition coil primary and secondary resistances.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 5 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensor connector from cylinder 5
  • Install the temperature sensor from cylinder 5 to cylinder 7.
  • Install the temperature sensor from cylinder 7 to cylinder 5.
  • Reconnect the exhaust temperature sensors.

Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2486 is inactive and that Fault Code 2487 is active.

Fault Code 2486 inactive and Fault Code 2487 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in cylinder 5 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 5 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 5 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 5 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 5 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 5 overhead set is correct.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder 5 power cylinder.

Guided Step 6A - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (If available, these inspections can be performed using a borescope without component removal):

  • Damage to the cylinder head intake or exhaust valves
  • Damage to the cylinder head intake or exhaust valve seats.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair or replace the cylinder head.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2486 is inactive.

Fault Code 2486 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-Jan-2011


FAULT CODE 2486 – Single Turbocharger Exhaust Gas Temperature Cylinder 5 (A3) – Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2472 and/or 2766 active?
STEP 2. | Check the spark plug on cylinder 5. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 5. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2486 inactive and Fault Code 2487 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | Voltage between 4.75 and 5.25-VDC?
 | STEP 4C. Check the engine harness and connector pins. | Dirty or damaged pin?
 | STEP 4D. Check the exhaust gas temperature sensor circuit for a short circuit pin-to-pin. | More than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check the cylinder 5 overhead set. |
 | STEP 5A. Complete visual inspection of the cylinder 5 overhead set. | Overhead set OK?
STEP 6. | Inspect the cylinder 5 power cylinder. |
 | STEP 6A. Visually inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2486 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and running for more than one minute.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2472 and/or 2766 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 5.

Guided Step 2A - Check the spark plug on cylinder 5.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the spark plug for the following:

  • Plug correctly tightened.
  • 'J' connector damaged.
  • Oil contamination on electrode.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Retighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 5.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil and ignition coil extension tube o-ring. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the appropriate wiring diagram for connector pin identification.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check the ignition harness for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks to all interconnecting harness connectors in the circuit.
  • Refer to the appropriate wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check the ignition harness for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature sensor circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool
  • Isolate the generator set 24-VDC power supply
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder 5 exhaust gas temperature sensor response.

  • Remove the exhaust gas temperature sensors from cylinders 5 and 7.
  • Install the temperature sensor from cylinder 5 to 7.
  • Install the temperature sensor from cylinder 7 to 5.
  • Reconnect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool, check that Fault Code 2486 is inactive and that Fault Code 2487 is active.

Fault Code 2486 inactive and Fault Code 2487 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in the cylinder 5 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connectors from cylinder 5 exhaust gas temperature sensor.

Action

Check the 5-VDC supply to the exhaust gas temperature sensor.

  • Measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 5.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 5 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair or replace the engine harness or harness connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check the exhaust gas temperature sensor circuit for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from cylinder 5 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connectors. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check the exhaust gas temperature sensor circuit for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 5 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CM850 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5-VDC SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust gas temperature sensor connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or harness connectors. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the cylinder 5 overhead set.

Guided Step 5A - Check the cylinder 5 overhead set.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 5 overhead setting is correct.

  • Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Complete visual inspection of the cylinder 5 power cylinder.

Guided Step 6A - Visually inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (if available, these inspections can be performed using a Borescope without component removal):

  • Cylinder Head - Intake or exhaust valve/valve seat damage. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair the cylinder head as necessary. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2486 is inactive.

Fault Code 2486 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Using INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 24-Mar-2011


FAULT CODE 2487 - Multiple Turbochargers Exhaust Gas Temperature Cylinder 7 (A4) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2473 and/or 2766 active?
STEP 2. | Check the spark plug on cylinder 7. |
 | STEP 2A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 7. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Ignition harness and connector pins OK?
 | STEP 3C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2487 inactive and Fault Code 2486 active?
 | STEP 4B. Check the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 7 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check cylinder 7 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2487 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the active fault codes.

  • Read the fault codes.

Fault Code 2475 and/or 2766 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 7.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug ‘J’ connector damaged
  • Electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Repair as necessary:

  • Replace the spark plug.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 7.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube
  • Check the ignition coil primary and secondary resistances.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 7 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensor connector from cylinder 7
  • Install the temperature sensor from cylinder 7 to cylinder 5.
  • Install the temperature sensor from cylinder 5 to cylinder 7.
  • Reconnect the exhaust temperature sensors.

Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2487 is inactive and that Fault Code 2486 is active.

Fault Code 2487 inactive and Fault Code 2486 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in cylinder 7 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 7 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 7 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 7 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 7 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 7 overhead set is correct.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder 7 power cylinder.

Guided Step 6A - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (If available, these inspections can be performed using a borescope without component removal):

  • Damage to the cylinder head intake or exhaust valves
  • Damage to the cylinder head intake or exhaust valve seats.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair or replace the cylinder head.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2487 is inactive.

Fault Code 2487 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-Jan-2011


FAULT CODE 2487 – Single Turbocharger Exhaust Gas Temperature Cylinder 7 (A4) – Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2473 and/or 2766 active?
STEP 2. | Check the spark plug on cylinder 7. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 7. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2487 inactive and Fault Code 2486 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | Voltage between 4.75 and 5.25-VDC?
 | STEP 4C. Check the engine harness and connector pins. | Dirty or damaged pin?
 | STEP 4D. Check the exhaust gas temperature sensor circuit for a short circuit pin-to-pin. | More than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check the cylinder 7 overhead set. |
 | STEP 5A. Complete visual inspection of the cylinder 7 overhead set. | Overhead set OK?
STEP 6. | Inspect the cylinder 7 power cylinder. |
 | STEP 6A. Visually inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2487 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and running for more than one minute.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2473 and/or 2766 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 7.

Guided Step 2A - Check the spark plug on cylinder 7.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the spark plug for the following:

  • Plug correctly tightened.
  • 'J' connector damaged.
  • Oil contamination on electrode.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Retighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 7.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil and ignition coil extension tube o-ring. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the appropriate wiring diagram for connector pin identification.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check the ignition harness for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks to all interconnecting harness connectors in the circuit.
  • Refer to the appropriate wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check the ignition harness for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature sensor circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool
  • Isolate the generator set 24-VDC power supply
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder 7 exhaust gas temperature sensor response.

  • Remove the exhaust gas temperature sensors from cylinders 7 and 5.
  • Install the temperature sensor from cylinder 7 to 5.
  • Install the temperature sensor from cylinder 5 to 7.
  • Reconnect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool, check that Fault Code 2487 is inactive and that Fault Code 2486 is active.

Fault Code 2487 inactive and Fault Code 2486 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in the cylinder 7 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connectors from cylinder 7 exhaust gas temperature sensor.

Action

Check the 5-VDC supply to the exhaust gas temperature sensor.

  • Measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 7.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 7 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair or replace the engine harness or harness connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check the exhaust gas temperature sensor circuit for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from cylinder 7 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connectors. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check the exhaust gas temperature sensor circuit for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 7 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CM850 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5-VDC SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust gas temperature sensor connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or harness connectors. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the cylinder 7 overhead set.

Guided Step 5A - Check the cylinder 7 overhead set.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 7 overhead setting is correct.

  • Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Complete visual inspection of the cylinder 7 power cylinder.

Guided Step 6A - Visually inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (if available, these inspections can be performed using a Borescope without component removal):

  • Cylinder Head - Intake or exhaust valve/valve seat damage. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair the cylinder head as necessary. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2487 is inactive.

Fault Code 2487 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Using INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 24-Mar-2011


FAULT CODE 2488 - Multiple Turbochargers Exhaust Gas Temperature Cylinder 9 (A5) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2475 and/or 2766 active?
STEP 2. | Check the spark plug on cylinder 9. |
 | STEP 2A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 9. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Ignition harness and connector pins OK?
 | STEP 3C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2488 inactive and Fault Code 2489 active?
 | STEP 4B. Check the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 9 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check cylinder 9 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2488 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the active fault codes.

  • Read the fault codes.

Fault Code 2475 and/or 2766 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 9.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug ‘J’ connector damaged
  • Electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Repair as necessary:

  • Replace the spark plug.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 9.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube
  • Check the ignition coil primary and secondary resistances.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 9 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensor connector from cylinder 9
  • Install the temperature sensor from cylinder 9 to cylinder 11.
  • Install the temperature sensor from cylinder 11 to cylinder 9.
  • Reconnect the exhaust temperature sensors.

Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2488 is inactive and that Fault Code 2489 is active.

Fault Code 2488 inactive and Fault Code 2489 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in cylinder 9 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 9 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 9 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 9 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 9 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 9 overhead set is correct.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder 9 power cylinder.

Guided Step 6A - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (If available, these inspections can be performed using a borescope without component removal):

  • Damage to the cylinder head intake or exhaust valves
  • Damage to the cylinder head intake or exhaust valve seats.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair or replace the cylinder head.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2488 is inactive.

Fault Code 2488 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-Jan-2011


FAULT CODE 2488 – Single Turbocharger Exhaust Gas Temperature Cylinder 9 (A5) – Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2475 and/or 2766 active?
STEP 2. | Check the spark plug on cylinder 9. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 9. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2488 inactive and Fault Code 2489 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | Voltage between 4.75 and 5.25-VDC?
 | STEP 4C. Check the engine harness and connector pins. | Dirty or damaged pin?
 | STEP 4D. Check the exhaust gas temperature sensor circuit for a short circuit pin-to-pin. | More than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check the cylinder 9 overhead set. |
 | STEP 5A. Complete visual inspection of the cylinder 9 overhead set. | Overhead set OK?
STEP 6. | Inspect the cylinder 9 power cylinder. |
 | STEP 6A. Visually inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2488 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and running for more than one minute.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2475 and/or 2766 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 9.

Guided Step 2A - Check the spark plug on cylinder 9.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the spark plug for the following:

  • Plug correctly tightened.
  • 'J' connector damaged.
  • Oil contamination on electrode.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Retighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 9.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil and ignition coil extension tube o-ring. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the appropriate wiring diagram for connector pin identification.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check the ignition harness for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks to all interconnecting harness connectors in the circuit.
  • Refer to the appropriate wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check the ignition harness for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature sensor circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool
  • Isolate the generator set 24-VDC power supply
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder 9 exhaust gas temperature sensor response.

  • Remove the exhaust gas temperature sensors from cylinders 9 and 11.
  • Install the temperature sensor from cylinder 9 to 11.
  • Install the temperature sensor from cylinder 11 to 9.
  • Reconnect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool, check that Fault Code 2488 is inactive and that Fault Code 2489 is active.

Fault Code 2488 inactive and Fault Code 2489 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in the cylinder 9 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connectors from cylinder 9 exhaust gas temperature sensor.

Action

Check the 5-VDC supply to the exhaust gas temperature sensor.

  • Measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 9.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 9 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair or replace the engine harness or harness connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check the exhaust gas temperature sensor circuit for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from cylinder 9 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connectors. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check the exhaust gas temperature sensor circuit for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 9 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CM850 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5-VDC SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust gas temperature sensor connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or harness connectors. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the cylinder 9 overhead set.

Guided Step 5A - Check the cylinder 9 overhead set.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 9 overhead setting is correct.

  • Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Complete visual inspection of the cylinder 9 power cylinder.

Guided Step 6A - Visually inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (if available, these inspections can be performed using a Borescope without component removal):

  • Cylinder Head - Intake or exhaust valve/valve seat damage. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair the cylinder head as necessary. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2488 is inactive.

Fault Code 2488 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Using INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 24-Mar-2011


FAULT CODE 2489 - Multiple Turbochargers Exhaust Gas Temperature Cylinder 11 (A6) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2476 and/or 2766 active?
STEP 2. | Check the spark plug on cylinder 11. |
 | STEP 2A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 11. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Ignition harness and connector pins OK?
 | STEP 3C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2489 inactive and Fault Code 2488 active?
 | STEP 4B. Check the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 11 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check cylinder 11 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2489 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the active fault codes.

  • Read the fault codes.

Fault Code 2476 and/or 2766 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 11.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug ‘J’ connector damaged
  • Electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Repair as necessary:

  • Replace the spark plug.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 11.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube
  • Check the ignition coil primary and secondary resistances.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 11 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensor connector from cylinder 11
  • Install the temperature sensor from cylinder 11 to cylinder 9.
  • Install the temperature sensor from cylinder 9 to cylinder 11.
  • Reconnect the exhaust temperature sensors.

Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2489 is inactive and that Fault Code 2488 is active.

Fault Code 2489 inactive and Fault Code 2488 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in cylinder 11 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 11 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 11 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 11 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 11 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 11 overhead set is correct.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder 11 power cylinder.

Guided Step 6A - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (If available, these inspections can be performed using a borescope without component removal):

  • Damage to the cylinder head intake or exhaust valves
  • Damage to the cylinder head intake or exhaust valve seats.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair or replace the cylinder head.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2489 is inactive.

Fault Code 2489 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-Jan-2011


FAULT CODE 2484 - Single Turbocharger Exhaust Gas Temperature Cylinder 1 (A1) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2476 and/or 2766 active?
STEP 2. | Check the spark plug on cylinder 11. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 11. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2489 inactive and Fault Code 2488 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | Voltage between 4.75 and 5.25-VDC?
 | STEP 4C. Check the engine harness and connector pins. | Dirty or damaged pin?
 | STEP 4D. Check the exhaust gas temperature sensor circuit for a short circuit pin-to-pin. | More than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check the cylinder 11 overhead set. |
 | STEP 5A. Complete visual inspection of the cylinder 11 overhead set. | Overhead set OK?
STEP 6. | Inspect the cylinder 11 power cylinder. |
 | STEP 6A. Visually inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2489 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and running for more than one minute.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2476 and/or 2766 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 11.

Guided Step 2A - Check the spark plug on cylinder 11.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the spark plug for the following:

  • Plug correctly tightened.
  • 'J' connector damaged.
  • Oil contamination on electrode.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Retighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 11.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil and ignition coil extension tube o-ring. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the appropriate wiring diagram for connector pin identification.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check the ignition harness for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks to all interconnecting harness connectors in the circuit.
  • Refer to the appropriate wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check the ignition harness for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature sensor circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool
  • Isolate the generator set 24-VDC power supply
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder 11 exhaust gas temperature sensor response.

  • Remove the exhaust gas temperature sensors from cylinders 11 and 9.
  • Install the temperature sensor from cylinder 11 to 9.
  • Install the temperature sensor from cylinder 9 to 11.
  • Reconnect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool, check that Fault Code 2489 is inactive and that Fault Code 2488 is active.

Fault Code 2489 inactive and Fault Code 2488 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in the cylinder 11 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connectors from cylinder 11 exhaust gas temperature sensor.

Action

Check the 5-VDC supply to the exhaust gas temperature sensor.

  • Measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 11.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 11 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair or replace the engine harness or harness connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check the exhaust gas temperature sensor circuit for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from cylinder 11 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connectors. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check the exhaust gas temperature sensor circuit for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 11 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CM850 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5-VDC SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust gas temperature sensor connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or harness connectors. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the cylinder 11 overhead set.

Guided Step 5A - Check the cylinder 11 overhead set.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 11 overhead setting is correct.

  • Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Complete visual inspection of the cylinder 11 power cylinder.

Guided Step 6A - Visually inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (if available, these inspections can be performed using a Borescope without component removal):

  • Cylinder Head - Intake or exhaust valve/valve seat damage. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair the cylinder head as necessary. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2489 is inactive.

Fault Code 2489 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Using INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 24-Mar-2011


FAULT CODE 2491 - Multiple Turbochargers Exhaust Gas Temperature Cylinder 13 (A7) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2477 and/or 2766 active?
STEP 2. | Check the spark plug on cylinder 13. |
 | STEP 2A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 13. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Ignition harness and connector pins OK?
 | STEP 3C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2491 inactive and Fault Code 2492 active?
 | STEP 4B. Check the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 13 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check cylinder 13 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2491 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the active fault codes.

  • Read the fault codes.

Fault Code 2477 and/or 2766 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 13.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug ‘J’ connector damaged
  • Electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Repair as necessary:

  • Replace the spark plug.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 13.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube
  • Check the ignition coil primary and secondary resistances.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 13 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensor connector from cylinder 13
  • Install the temperature sensor from cylinder 13 to cylinder 15.
  • Install the temperature sensor from cylinder 15 to cylinder 13.
  • Reconnect the exhaust temperature sensors.

Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2491 is inactive and that Fault Code 2492 is active.

Fault Code 2491 inactive and Fault Code 2492 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in cylinder 13 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 13 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 13 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 13 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 13 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 13 overhead set is correct.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder 13 power cylinder.

Guided Step 6A - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (If available, these inspections can be performed using a borescope without component removal):

  • Damage to the cylinder head intake or exhaust valves
  • Damage to the cylinder head intake or exhaust valve seats.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair or replace the cylinder head.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2491 is inactive.

Fault Code 2491 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-Jan-2011


FAULT CODE 2491 – Single Turbocharger Exhaust Gas Temperature Cylinder 13 (A7) – Deviation

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2477 and/or 2766 active?
STEP 2. | Check the spark plug on cylinder 13. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 13. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2491 inactive and Fault Code 2492 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | Voltage between 4.75 and 5.25-VDC?
 | STEP 4C. Check the engine harness and connector pins. | Dirty or damaged pin?
 | STEP 4D. Check the exhaust gas temperature sensor circuit for a short circuit pin-to-pin. | More than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check the cylinder 13 overhead set. |
 | STEP 5A. Complete visual inspection of the cylinder 13 overhead set. | Overhead set OK?
STEP 6. | Inspect the cylinder 13 power cylinder. |
 | STEP 6A. Visually inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2491 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and running for more than one minute.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2477 and/or 2766 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 13.

Guided Step 2A - Check the spark plug on cylinder 13.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the spark plug for the following:

  • Plug correctly tightened.
  • 'J' connector damaged.
  • Oil contamination on electrode.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Retighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 13.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil and ignition coil extension tube o-ring. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the appropriate wiring diagram for connector pin identification.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check the ignition harness for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks to all interconnecting harness connectors in the circuit.
  • Refer to the appropriate wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check the ignition harness for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature sensor circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool
  • Isolate the generator set 24-VDC power supply
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder 13 exhaust gas temperature sensor response.

  • Remove the exhaust gas temperature sensors from cylinders 13 and 15.
  • Install the temperature sensor from cylinder 13 to 15.
  • Install the temperature sensor from cylinder 15 to 13.
  • Reconnect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool, check that Fault Code 2491 is inactive and that Fault Code 2492 is active.

Fault Code 2491 inactive and Fault Code 2492 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in the cylinder 13 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connectors from cylinder 13 exhaust gas temperature sensor.

Action

Check the 5-VDC supply to the exhaust gas temperature sensor.

  • Measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 13.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 13 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair or replace the engine harness or harness connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check the exhaust gas temperature sensor circuit for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from cylinder 13 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connectors. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check the exhaust gas temperature sensor circuit for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 13 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CM850 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5-VDC SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust gas temperature sensor connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or harness connectors. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the cylinder 13 overhead set.

Guided Step 5A - Check the cylinder 13 overhead set.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 13 overhead setting is correct.

  • Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Complete visual inspection of the cylinder 13 power cylinder.

Guided Step 6A - Visually inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (if available, these inspections can be performed using a Borescope without component removal):

  • Cylinder Head - Intake or exhaust valve/valve seat damage. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair the cylinder head as necessary. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2491 is inactive.

Fault Code 2491 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Using INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 24-Mar-2011


FAULT CODE 2492 - Multiple Turbochargers Exhaust Gas Temperature Cylinder 15 (A8) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2478 and/or 2766 active?
STEP 2. | Check the spark plug on cylinder 15. |
 | STEP 2A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 15. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Ignition harness and connector pins OK?
 | STEP 3C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2492 inactive and Fault Code 2491 active?
 | STEP 4B. Check the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 15 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check cylinder 15 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2492 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the active fault codes.

  • Read the fault codes.

Fault Code 2478 and/or 2766 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 15.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug ‘J’ connector damaged
  • Electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Repair as necessary:

  • Replace the spark plug.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 15.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube
  • Check the ignition coil primary and secondary resistances.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 15 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensor connector from cylinder 15
  • Install the temperature sensor from cylinder 15 to cylinder 13.
  • Install the temperature sensor from cylinder 13 to cylinder 15.
  • Reconnect the exhaust temperature sensors.

Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2492 is inactive and that Fault Code 2491 is active.

Fault Code 2492 inactive and Fault Code 2491 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in cylinder 15 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 15 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 15 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 15 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 15 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 15 overhead set is correct.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder 15 power cylinder.

Guided Step 6A - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (If available, these inspections can be performed using a borescope without component removal):

  • Damage to the cylinder head intake or exhaust valves
  • Damage to the cylinder head intake or exhaust valve seats.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair or replace the cylinder head.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2492 is inactive.

Fault Code 2492 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-Jan-2011


FAULT CODE 2492 – Single Turbocharger Exhaust Gas Temperature Cylinder 15 (A8) – Deviation

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2478 and/or 2766 active?
STEP 2. | Check the spark plug on cylinder 15. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 15. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2492 inactive and Fault Code 2491 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | Voltage between 4.75 and 5.25-VDC?
 | STEP 4C. Check the engine harness and connector pins. | Dirty or damaged pin?
 | STEP 4D. Check the exhaust gas temperature sensor circuit for a short circuit pin-to-pin. | More than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check the cylinder 15 overhead set. |
 | STEP 5A. Complete visual inspection of the cylinder 15 overhead set. | Overhead set OK?
STEP 6. | Inspect the cylinder 15 power cylinder. |
 | STEP 6A. Visually inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2492 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and running for more than one minute.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2478 and/or 2766 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 15.

Guided Step 2A - Check the spark plug on cylinder 15.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the spark plug for the following:

  • Plug correctly tightened.
  • 'J' connector damaged.
  • Oil contamination on electrode.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Retighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 15.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil and ignition coil extension tube o-ring. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the appropriate wiring diagram for connector pin identification.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check the ignition harness for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks to all interconnecting harness connectors in the circuit.
  • Refer to the appropriate wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check the ignition harness for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature sensor circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool
  • Isolate the generator set 24-VDC power supply
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder 15 exhaust gas temperature sensor response.

  • Remove the exhaust gas temperature sensors from cylinders 15 and 13.
  • Install the temperature sensor from cylinder 15 to 13.
  • Install the temperature sensor from cylinder 13 to 15.
  • Reconnect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool, check that Fault Code 2492 is inactive and that Fault Code 2491 is active.

Fault Code 2492 inactive and Fault Code 2491 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in the cylinder 15 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connectors from cylinder 15 exhaust gas temperature sensor.

Action

Check the 5-VDC supply to the exhaust gas temperature sensor.

  • Measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 15.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 15 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair or replace the engine harness or harness connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check the exhaust gas temperature sensor circuit for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from cylinder 15 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connectors. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check the exhaust gas temperature sensor circuit for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 15 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CM850 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5-VDC SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust gas temperature sensor connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or harness connectors. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the cylinder 15 overhead set.

Guided Step 5A - Check the cylinder 15 overhead set.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 15 overhead setting is correct.

  • Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Complete visual inspection of the cylinder 15 power cylinder.

Guided Step 6A - Visually inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (if available, these inspections can be performed using a Borescope without component removal):

  • Cylinder Head - Intake or exhaust valve/valve seat damage. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair the cylinder head as necessary. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2492 is inactive.

Fault Code 2492 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Using INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 24-Mar-2011


FAULT CODE 2494 - Multiple Turbochargers Exhaust Gas Temperature Cylinder 2 (B1) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2458 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 2. |
 | STEP 2A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 2. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Ignition harness and connector pins OK?
 | STEP 3C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2494 inactive and Fault Code 2495 active?
 | STEP 4B. Check the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 2 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check cylinder 2 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2494 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the active fault codes.

  • Read the fault codes.

Fault Code 2458 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 2.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug ‘J’ connector damaged
  • Electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Repair as necessary:

  • Replace the spark plug.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 2.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube
  • Check the ignition coil primary and secondary resistances.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 2 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensor connector from cylinder 2
  • Install the temperature sensor from cylinder 2 to cylinder 4.
  • Install the temperature sensor from cylinder 4 to cylinder 2.
  • Reconnect the exhaust temperature sensors.

Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2494 is inactive and that Fault Code 2495 is active.

Fault Code 2494 inactive and Fault Code 2495 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in cylinder 2 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 2 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 2 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 2 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 2 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 2 overhead set is correct.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder 2 power cylinder.

Guided Step 6A - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (If available, these inspections can be performed using a borescope without component removal):

  • Damage to the cylinder head intake or exhaust valves
  • Damage to the cylinder head intake or exhaust valve seats.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair or replace the cylinder head.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2494 is inactive.

Fault Code 2494 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-Jan-2011


FAULT CODE 2494 – Single Turbocharger Exhaust Gas Temperature Cylinder 2 (B1) – Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2458 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 2. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 2. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2494 inactive and Fault Code 2495 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | Voltage between 4.75 and 5.25-VDC?
 | STEP 4C. Check the engine harness and connector pins. | Dirty or damaged pin?
 | STEP 4D. Check the exhaust gas temperature sensor circuit for a short circuit pin-to-pin. | More than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check the cylinder 2 overhead set. |
 | STEP 5A. Complete visual inspection of the cylinder 2 overhead set. | Overhead set OK?
STEP 6. | Inspect the cylinder 2 power cylinder. |
 | STEP 6A. Visually inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2494 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and running for more than one minute.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2458 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 2.

Guided Step 2A - Check the spark plug on cylinder 2.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the spark plug for the following:

  • Plug correctly tightened.
  • 'J' connector damaged.
  • Oil contamination on electrode.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Retighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 2.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil and ignition coil extension tube o-ring. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the appropriate wiring diagram for connector pin identification.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check the ignition harness for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks to all interconnecting harness connectors in the circuit.
  • Refer to the appropriate wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check the ignition harness for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature sensor circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool
  • Isolate the generator set 24-VDC power supply
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder 2 exhaust gas temperature sensor response.

  • Remove the exhaust gas temperature sensors from cylinders 2 and 4.
  • Install the temperature sensor from cylinder 2 to 4.
  • Install the temperature sensor from cylinder 4 to 2.
  • Reconnect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool, check that Fault Code 2494 is inactive and that Fault Code 2495 is active.

Fault Code 2494 inactive and Fault Code 2495 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in the cylinder 2 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connectors from cylinder 2 exhaust gas temperature sensor.

Action

Check the 5-VDC supply to the exhaust gas temperature sensor.

  • Measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 2.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 2 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair or replace the engine harness or harness connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check the exhaust gas temperature sensor circuit for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from cylinder 2 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connectors. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check the exhaust gas temperature sensor circuit for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 2 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CM850 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5-VDC SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust gas temperature sensor connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or harness connectors. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the cylinder 2 overhead set.

Guided Step 5A - Check the cylinder 2 overhead set.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 2 overhead setting is correct.

  • Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Complete visual inspection of the cylinder 2 power cylinder.

Guided Step 6A - Visually inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (if available, these inspections can be performed using a Borescope without component removal):

  • Cylinder Head - Intake or exhaust valve/valve seat damage. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair the cylinder head as necessary. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2494 is inactive.

Fault Code 2494 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Using INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 24-Mar-2011


FAULT CODE 2495 - Multiple Turbochargers Exhaust Gas Temperature Cylinder 4 (B2) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2459 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 4. |
 | STEP 2A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 4. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Ignition harness and connector pins OK?
 | STEP 3C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2495 inactive and Fault Code 2494 active?
 | STEP 4B. Check the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 4 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check cylinder 4 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2495 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the active fault codes.

  • Read the fault codes.

Fault Code 2459 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 4.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug ‘J’ connector damaged
  • Electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Repair as necessary:

  • Replace the spark plug.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 4.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube
  • Check the ignition coil primary and secondary resistances.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 4 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensor connector from cylinder 4
  • Install the temperature sensor from cylinder 4 to cylinder 2.
  • Install the temperature sensor from cylinder 2 to cylinder 4.
  • Reconnect the exhaust temperature sensors.

Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2495 is inactive and that Fault Code 2494 is active.

Fault Code 2495 inactive and Fault Code 2494 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in cylinder 4 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 4 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 4 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 4 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 4 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 4 overhead set is correct.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder 4 power cylinder.

Guided Step 6A - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (If available, these inspections can be performed using a borescope without component removal):

  • Damage to the cylinder head intake or exhaust valves
  • Damage to the cylinder head intake or exhaust valve seats.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair or replace the cylinder head.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2495 is inactive.

Fault Code 2495 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-Jan-2011


FAULT CODE 2495 – Single Turbocharger Exhaust Gas Temperature Cylinder 4 (B2) – Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2459 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 4. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 4. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2495 inactive and Fault Code 2494 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | Voltage between 4.75 and 5.25-VDC?
 | STEP 4C. Check the engine harness and connector pins. | Dirty or damaged pin?
 | STEP 4D. Check the exhaust gas temperature sensor circuit for a short circuit pin-to-pin. | More than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check the cylinder 4 overhead set. |
 | STEP 5A. Complete visual inspection of the cylinder 4 overhead set. | Overhead set OK?
STEP 6. | Inspect the cylinder 4 power cylinder. |
 | STEP 6A. Visually inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2495 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and running for more than one minute.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2459 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 4.

Guided Step 2A - Check the spark plug on cylinder 4.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the spark plug for the following:

  • Plug correctly tightened.
  • 'J' connector damaged.
  • Oil contamination on electrode.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Retighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 4.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil and ignition coil extension tube o-ring. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the appropriate wiring diagram for connector pin identification.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check the ignition harness for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks to all interconnecting harness connectors in the circuit.
  • Refer to the appropriate wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check the ignition harness for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature sensor circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool
  • Isolate the generator set 24-VDC power supply
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder 4 exhaust gas temperature sensor response.

  • Remove the exhaust gas temperature sensors from cylinders 4 and 2.
  • Install the temperature sensor from cylinder 4 to 2.
  • Install the temperature sensor from cylinder 2 to 4.
  • Reconnect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool, check that Fault Code 2495 is inactive and that Fault Code 2494 is active.

Fault Code 2495 inactive and Fault Code 2494 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in the cylinder 4 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connectors from cylinder 4 exhaust gas temperature sensor.

Action

Check the 5-VDC supply to the exhaust gas temperature sensor.

  • Measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 4.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 4 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair or replace the engine harness or harness connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check the exhaust gas temperature sensor circuit for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from cylinder 4 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connectors. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check the exhaust gas temperature sensor circuit for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 4 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CM850 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5-VDC SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust gas temperature sensor connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or harness connectors. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the cylinder 4 overhead set.

Guided Step 5A - Check the cylinder 4 overhead set.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 4 overhead setting is correct.

  • Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Complete visual inspection of the cylinder 4 power cylinder.

Guided Step 6A - Visually inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (if available, these inspections can be performed using a Borescope without component removal):

  • Cylinder Head - Intake or exhaust valve/valve seat damage. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair the cylinder head as necessary. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2495 is inactive.

Fault Code 2495 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Using INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 24-Mar-2011


FAULT CODE 2496 - Multiple Turbochargers Exhaust Gas Temperature Cylinder 6 (B3) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2461 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 6. |
 | STEP 2A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 6. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Ignition harness and connector pins OK?
 | STEP 3C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2496 inactive and Fault Code 2497 active?
 | STEP 4B. Check the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 6 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check cylinder 6 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2496 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the active fault codes.

  • Read the fault codes.

Fault Code 2461 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 6.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug ‘J’ connector damaged
  • Electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Repair as necessary:

  • Replace the spark plug.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 6.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube
  • Check the ignition coil primary and secondary resistances.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 6 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensor connector from cylinder 6
  • Install the temperature sensor from cylinder 6 to cylinder 8.
  • Install the temperature sensor from cylinder 8 to cylinder 6.
  • Reconnect the exhaust temperature sensors.

Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2496 is inactive and that Fault Code 2497 is active.

Fault Code 2496 inactive and Fault Code 2497 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in cylinder 6 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 6 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 6 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 6 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 6 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 6 overhead set is correct.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder 6 power cylinder.

Guided Step 6A - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (If available, these inspections can be performed using a borescope without component removal):

  • Damage to the cylinder head intake or exhaust valves
  • Damage to the cylinder head intake or exhaust valve seats.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair or replace the cylinder head.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2496 is inactive.

Fault Code 2496 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-Jan-2011


FAULT CODE 2496 – Single Turbocharger Exhaust Gas Temperature Cylinder 6 (B3) – Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2461 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 6. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 6. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2496 inactive and Fault Code 2497 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | Voltage between 4.75 and 5.25-VDC?
 | STEP 4C. Check the engine harness and connector pins. | Dirty or damaged pin?
 | STEP 4D. Check the exhaust gas temperature sensor circuit for a short circuit pin-to-pin. | More than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check the cylinder 6 overhead set. |
 | STEP 5A. Complete visual inspection of the cylinder 6 overhead set. | Overhead set OK?
STEP 6. | Inspect the cylinder 6 power cylinder. |
 | STEP 6A. Visually inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2496 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and running for more than one minute.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2461 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 6.

Guided Step 2A - Check the spark plug on cylinder 6.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the spark plug for the following:

  • Plug correctly tightened.
  • 'J' connector damaged.
  • Oil contamination on electrode.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Retighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 6.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil and ignition coil extension tube o-ring. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the appropriate wiring diagram for connector pin identification.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check the ignition harness for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks to all interconnecting harness connectors in the circuit.
  • Refer to the appropriate wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check the ignition harness for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature sensor circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool
  • Isolate the generator set 24-VDC power supply
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder 6 exhaust gas temperature sensor response.

  • Remove the exhaust gas temperature sensors from cylinders 6 and 8.
  • Install the temperature sensor from cylinder 6 to 8.
  • Install the temperature sensor from cylinder 8 to 6.
  • Reconnect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool, check that Fault Code 2496 is inactive and that Fault Code 2497 is active.

Fault Code 2496 inactive and Fault Code 2497 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in the cylinder 6 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connectors from cylinder 6 exhaust gas temperature sensor.

Action

Check the 5-VDC supply to the exhaust gas temperature sensor.

  • Measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 6.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 6 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair or replace the engine harness or harness connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check the exhaust gas temperature sensor circuit for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from cylinder 6 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connectors. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check the exhaust gas temperature sensor circuit for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 6 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CM850 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5-VDC SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust gas temperature sensor connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or harness connectors. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the cylinder 6 overhead set.

Guided Step 5A - Check the cylinder 6 overhead set.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 6 overhead setting is correct.

  • Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Complete visual inspection of the cylinder 6 power cylinder.

Guided Step 6A - Visually inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (if available, these inspections can be performed using a Borescope without component removal):

  • Cylinder Head - Intake or exhaust valve/valve seat damage. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair the cylinder head as necessary. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2496 is inactive.

Fault Code 2496 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Using INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 24-Mar-2011


FAULT CODE 2497 - Multiple Turbochargers Exhaust Gas Temperature Cylinder 8 (B4) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2462 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 8. |
 | STEP 2A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 8. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Ignition harness and connector pins OK?
 | STEP 3C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2497 inactive and Fault Code 2496 active?
 | STEP 4B. Check the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 8 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check cylinder 8 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2497 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the active fault codes.

  • Read the fault codes.

Fault Code 2462 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 8.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug ‘J’ connector damaged
  • Electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Repair as necessary:

  • Replace the spark plug.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 8.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube
  • Check the ignition coil primary and secondary resistances.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 8 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensor connector from cylinder 8
  • Install the temperature sensor from cylinder 8 to cylinder 6.
  • Install the temperature sensor from cylinder 6 to cylinder 8.
  • Reconnect the exhaust temperature sensors.

Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2497 is inactive and that Fault Code 2496 is active.

Fault Code 2497 inactive and Fault Code 2496 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in cylinder 8 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 8 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 8 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 8 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 8 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 8 overhead set is correct.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder 8 power cylinder.

Guided Step 6A - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (If available, these inspections can be performed using a borescope without component removal):

  • Damage to the cylinder head intake or exhaust valves
  • Damage to the cylinder head intake or exhaust valve seats.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair or replace the cylinder head.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2497 is inactive.

Fault Code 2497 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-Jan-2011


FAULT CODE 2497 – Single TurbochargerExhaust Gas Temperature Cylinder 8 (B4) – Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2462 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 8. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 8. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2497 inactive and Fault Code 2496 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | Voltage between 4.75 and 5.25-VDC?
 | STEP 4C. Check the engine harness and connector pins. | Dirty or damaged pin?
 | STEP 4D. Check the exhaust gas temperature sensor circuit for a short circuit pin-to-pin. | More than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check the cylinder 8 overhead set. |
 | STEP 5A. Complete visual inspection of the cylinder 8 overhead set. | Overhead set OK?
STEP 6. | Inspect the cylinder 8 power cylinder. |
 | STEP 6A. Visually inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2497 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and running for more than one minute.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2462 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 8.

Guided Step 2A - Check the spark plug on cylinder 8.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the spark plug for the following:

  • Plug correctly tightened.
  • 'J' connector damaged.
  • Oil contamination on electrode.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Retighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 8.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil and ignition coil extension tube o-ring. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the appropriate wiring diagram for connector pin identification.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check the ignition harness for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks to all interconnecting harness connectors in the circuit.
  • Refer to the appropriate wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check the ignition harness for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature sensor circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool
  • Isolate the generator set 24-VDC power supply
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder 8 exhaust gas temperature sensor response.

  • Remove the exhaust gas temperature sensors from cylinders 8 and 6.
  • Install the temperature sensor from cylinder 8 to 6.
  • Install the temperature sensor from cylinder 6 to 8.
  • Reconnect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool, check that Fault Code 2497 is inactive and that Fault Code 2496 is active.

Fault Code 2497 inactive and Fault Code 2496 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in the cylinder 8 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connectors from cylinder 8 exhaust gas temperature sensor.

Action

Check the 5-VDC supply to the exhaust gas temperature sensor.

  • Measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 8.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 8 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair or replace the engine harness or harness connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check the exhaust gas temperature sensor circuit for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from cylinder 8 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connectors. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check the exhaust gas temperature sensor circuit for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 8 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CM850 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5-VDC SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust gas temperature sensor connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or harness connectors. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the cylinder 8 overhead set.

Guided Step 5A - Check the cylinder 8 overhead set.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 8 overhead setting is correct.

  • Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Complete visual inspection of the cylinder 8 power cylinder.

Guided Step 6A - Visually inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (if available, these inspections can be performed using a Borescope without component removal):

  • Cylinder Head - Intake or exhaust valve/valve seat damage. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair the cylinder head as necessary. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2497 is inactive.

Fault Code 2497 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Using INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 24-Mar-2011


FAULT CODE 2498 - Multiple Turbochargers Exhaust Gas Temperature Cylinder 10 (B5) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2463 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 10. |
 | STEP 2A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 10. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Ignition harness and connector pins OK?
 | STEP 3C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2498 inactive and Fault Code 2499 active?
 | STEP 4B. Check the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 10 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check cylinder 10 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2498 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the active fault codes.

  • Read the fault codes.

Fault Code 2463 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 10.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug ‘J’ connector damaged
  • Electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Repair as necessary:

  • Replace the spark plug.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 10.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube
  • Check the ignition coil primary and secondary resistances.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 10 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensor connector from cylinder 10
  • Install the temperature sensor from cylinder 10 to cylinder 12.
  • Install the temperature sensor from cylinder 12 to cylinder 10.
  • Reconnect the exhaust temperature sensors.

Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2498 is inactive and that Fault Code 2499 is active.

Fault Code 2498 inactive and Fault Code 2499 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in cylinder 10 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 10 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 10 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 10 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 10 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 10 overhead set is correct.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder 10 power cylinder.

Guided Step 6A - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (If available, these inspections can be performed using a borescope without component removal):

  • Damage to the cylinder head intake or exhaust valves
  • Damage to the cylinder head intake or exhaust valve seats.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair or replace the cylinder head.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2498 is inactive.

Fault Code 2498 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-Jan-2011


FAULT CODE 2498 – Single TurbochargerExhaust Gas Temperature Cylinder 10 (B5) – Deviation

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2463 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 10. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 10. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2498 inactive and Fault Code 2499 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | Voltage between 4.75 and 5.25-VDC?
 | STEP 4C. Check the engine harness and connector pins. | Dirty or damaged pin?
 | STEP 4D. Check the exhaust gas temperature sensor circuit for a short circuit pin-to-pin. | More than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check the cylinder 10 overhead set. |
 | STEP 5A. Complete visual inspection of the cylinder 10 overhead set. | Overhead set OK?
STEP 6. | Inspect the cylinder 10 power cylinder. |
 | STEP 6A. Visually inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2498 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and running for more than one minute.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2463 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 10.

Guided Step 2A - Check the spark plug on cylinder 10.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the spark plug for the following:

  • Plug correctly tightened.
  • 'J' connector damaged.
  • Oil contamination on electrode.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Retighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 10.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil and ignition coil extension tube o-ring. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the appropriate wiring diagram for connector pin identification.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check the ignition harness for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks to all interconnecting harness connectors in the circuit.
  • Refer to the appropriate wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check the ignition harness for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature sensor circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool
  • Isolate the generator set 24-VDC power supply
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder 10 exhaust gas temperature sensor response.

  • Remove the exhaust gas temperature sensors from cylinders 10 and 12.
  • Install the temperature sensor from cylinder 10 to 12.
  • Install the temperature sensor from cylinder 12 to 10.
  • Reconnect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool, check that Fault Code 2498 is inactive and that Fault Code 2499 is active.

Fault Code 2498 inactive and Fault Code 2499 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in the cylinder 10 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connectors from cylinder 10 exhaust gas temperature sensor.

Action

Check the 5-VDC supply to the exhaust gas temperature sensor.

  • Measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 10.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 10 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair or replace the engine harness or harness connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check the exhaust gas temperature sensor circuit for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from cylinder 10 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connectors. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check the exhaust gas temperature sensor circuit for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 10 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CM850 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5-VDC SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust gas temperature sensor connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or harness connectors. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the cylinder 10 overhead set.

Guided Step 5A - Check the cylinder 10 overhead set.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 10 overhead setting is correct.

  • Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Complete visual inspection of the cylinder 10 power cylinder.

Guided Step 6A - Visually inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (if available, these inspections can be performed using a Borescope without component removal):

  • Cylinder Head - Intake or exhaust valve/valve seat damage. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair the cylinder head as necessary. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2498 is inactive.

Fault Code 2498 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Using INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 24-Mar-2011


FAULT CODE 2499 - Multiple Turbochargers Exhaust Gas Temperature Cylinder 12 (B6) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2464 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 12. |
 | STEP 2A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 12. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Ignition harness and connector pins OK?
 | STEP 3C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2499 inactive and Fault Code 2498 active?
 | STEP 4B. Check the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 12 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check cylinder 12 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2499 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the active fault codes.

  • Read the fault codes.

Fault Code 2464 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 12.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug ‘J’ connector damaged
  • Electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Repair as necessary:

  • Replace the spark plug.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 12.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube
  • Check the ignition coil primary and secondary resistances.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 12 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensor connector from cylinder 12
  • Install the temperature sensor from cylinder 12 to cylinder 10.
  • Install the temperature sensor from cylinder 10 to cylinder 12.
  • Reconnect the exhaust temperature sensors.

Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2499 is inactive and that Fault Code 2498 is active.

Fault Code 2499 inactive and Fault Code 2498 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in cylinder 12 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 12 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 12 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 12 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 12 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 12 overhead set is correct.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder 12 power cylinder.

Guided Step 6A - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (If available, these inspections can be performed using a borescope without component removal):

  • Damage to the cylinder head intake or exhaust valves
  • Damage to the cylinder head intake or exhaust valve seats.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair or replace the cylinder head.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2499 is inactive.

Fault Code 2499 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-Jan-2011


FAULT CODE 2499 – Single Turbocharger Exhaust Gas Temperature Cylinder 12 (B6) – Deviation

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2464 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 12. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 12. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2499 inactive and Fault Code 2498 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | Voltage between 4.75 and 5.25-VDC?
 | STEP 4C. Check the engine harness and connector pins. | Dirty or damaged pin?
 | STEP 4D. Check the exhaust gas temperature sensor circuit for a short circuit pin-to-pin. | More than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check the cylinder 12 overhead set. |
 | STEP 5A. Complete visual inspection of the cylinder 12 overhead set. | Overhead set OK?
STEP 6. | Inspect the cylinder 12 power cylinder. |
 | STEP 6A. Visually inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2499 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and running for more than one minute.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2464 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 12.

Guided Step 2A - Check the spark plug on cylinder 12.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the spark plug for the following:

  • Plug correctly tightened.
  • 'J' connector damaged.
  • Oil contamination on electrode.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Retighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 12.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil and ignition coil extension tube o-ring. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the appropriate wiring diagram for connector pin identification.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check the ignition harness for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks to all interconnecting harness connectors in the circuit.
  • Refer to the appropriate wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check the ignition harness for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature sensor circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool
  • Isolate the generator set 24-VDC power supply
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder 12 exhaust gas temperature sensor response.

  • Remove the exhaust gas temperature sensors from cylinders 12 and 10.
  • Install the temperature sensor from cylinder 12 to 10.
  • Install the temperature sensor from cylinder 10 to 12.
  • Reconnect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool, check that Fault Code 2499 is inactive and that Fault Code 2498 is active.

Fault Code 2499 inactive and Fault Code 2498 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in the cylinder 12 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connectors from cylinder 12 exhaust gas temperature sensor.

Action

Check the 5-VDC supply to the exhaust gas temperature sensor.

  • Measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 12.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 12 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair or replace the engine harness or harness connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check the exhaust gas temperature sensor circuit for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from cylinder 12 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connectors. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check the exhaust gas temperature sensor circuit for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 12 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CM850 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5-VDC SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust gas temperature sensor connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or harness connectors. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the cylinder 12 overhead set.

Guided Step 5A - Check the cylinder 12 overhead set.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 12 overhead setting is correct.

  • Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Complete visual inspection of the cylinder 12 power cylinder.

Guided Step 6A - Visually inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (if available, these inspections can be performed using a Borescope without component removal):

  • Cylinder Head - Intake or exhaust valve/valve seat damage. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair the cylinder head as necessary. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2499 is inactive.

Fault Code 2499 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Using INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 24-Mar-2011


FAULT CODE 2511 - Multiple Turbochargers Exhaust Gas Temperature Cylinder 14 (B7) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2465 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 14. |
 | STEP 2A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 14. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Ignition harness and connector pins OK?
 | STEP 3C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2511 inactive and Fault Code 2512 active?
 | STEP 4B. Check the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 14 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check cylinder 14 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2511 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the active fault codes.

  • Read the fault codes.

Fault Code 2465 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 14.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug ‘J’ connector damaged
  • Electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Repair as necessary:

  • Replace the spark plug.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 14.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube
  • Check the ignition coil primary and secondary resistances.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 14 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensor connector from cylinder 14
  • Install the temperature sensor from cylinder 14 to cylinder 16.
  • Install the temperature sensor from cylinder 16 to cylinder 14.
  • Reconnect the exhaust temperature sensors.

Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2511 is inactive and that Fault Code 2512 is active.

Fault Code 2511 inactive and Fault Code 2512 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in cylinder 14 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 14 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 14 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 14 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 14 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 14 overhead set is correct.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder 14 power cylinder.

Guided Step 6A - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (If available, these inspections can be performed using a borescope without component removal):

  • Damage to the cylinder head intake or exhaust valves
  • Damage to the cylinder head intake or exhaust valve seats.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair or replace the cylinder head.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2511 is inactive.

Fault Code 2511 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-Jan-2011


FAULT CODE 2511 – Single TurbochargerExhaust Gas Temperature Cylinder 14 (B7) – Deviation

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2465 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 14. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 14. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2511 inactive and Fault Code 2512 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | Voltage between 4.75 and 5.25-VDC?
 | STEP 4C. Check the engine harness and connector pins. | Dirty or damaged pin?
 | STEP 4D. Check the exhaust gas temperature sensor circuit for a short circuit pin-to-pin. | More than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check the cylinder 14 overhead set. |
 | STEP 5A. Complete visual inspection of the cylinder 14 overhead set. | Overhead set OK?
STEP 6. | Inspect the cylinder 14 power cylinder. |
 | STEP 6A. Visually inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2511 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and running for more than one minute.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2465 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 14.

Guided Step 2A - Check the spark plug on cylinder 14.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the spark plug for the following:

  • Plug correctly tightened.
  • 'J' connector damaged.
  • Oil contamination on electrode.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Retighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 14.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil and ignition coil extension tube o-ring. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the appropriate wiring diagram for connector pin identification.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check the ignition harness for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks to all interconnecting harness connectors in the circuit.
  • Refer to the appropriate wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check the ignition harness for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature sensor circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool
  • Isolate the generator set 24-VDC power supply
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder 14 exhaust gas temperature sensor response.

  • Remove the exhaust gas temperature sensors from cylinders 14 and 16.
  • Install the temperature sensor from cylinder 14 to 16.
  • Install the temperature sensor from cylinder 16 to 14.
  • Reconnect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool, check that Fault Code 2511 is inactive and that Fault Code 2512 is active.

Fault Code 2511 inactive and Fault Code 2512 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in the cylinder 14 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connectors from cylinder 14 exhaust gas temperature sensor.

Action

Check the 5-VDC supply to the exhaust gas temperature sensor.

  • Measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 14.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 14 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair or replace the engine harness or harness connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check the exhaust gas temperature sensor circuit for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from cylinder 14 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connectors. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check the exhaust gas temperature sensor circuit for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 14 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CM850 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5-VDC SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust gas temperature sensor connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or harness connectors. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the cylinder 14 overhead set.

Guided Step 5A - Check the cylinder 14 overhead set.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 14 overhead setting is correct.

  • Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Complete visual inspection of the cylinder 14 power cylinder.

Guided Step 6A - Visually inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (if available, these inspections can be performed using a Borescope without component removal):

  • Cylinder Head - Intake or exhaust valve/valve seat damage. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair the cylinder head as necessary. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2511 is inactive.

Fault Code 2511 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Using INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 24-Mar-2011


FAULT CODE 2512 - Multiple Turbochargers Exhaust Gas Temperature Cylinder 16 (B8) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2466 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 16. |
 | STEP 2A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 16. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Ignition harness and connector pins OK?
 | STEP 3C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2512 inactive and Fault Code 2511 active?
 | STEP 4B. Check the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 16 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check cylinder 16 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2512 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the active fault codes.

  • Read the fault codes.

Fault Code 2466 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 16.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug ‘J’ connector damaged
  • Electrode for signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Repair as necessary:

  • Replace the spark plug.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 16.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube
  • Check the ignition coil primary and secondary resistances.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil.
  • Replace the ignition coil extension tube o-ring.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the ignition harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition supply pin in the ignition harness connector to the ignition supply input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition return pin in the ignition harness connector to the ignition supply return pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 16 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensor connector from cylinder 16
  • Install the temperature sensor from cylinder 16 to cylinder 14.
  • Install the temperature sensor from cylinder 14 to cylinder 16.
  • Reconnect the exhaust temperature sensors.

Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2512 is inactive and that Fault Code 2511 is active.

Fault Code 2512 inactive and Fault Code 2511 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in cylinder 16 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 16 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 16 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connectors from cylinder 16 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 16 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 16 overhead set is correct.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder 16 power cylinder.

Guided Step 6A - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (If available, these inspections can be performed using a borescope without component removal):

  • Damage to the cylinder head intake or exhaust valves
  • Damage to the cylinder head intake or exhaust valve seats.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair or replace the cylinder head.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2512 is inactive.

Fault Code 2512 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 17-Jan-2011


FAULT CODE 2512 – Single Turbocharger Exhaust Gas Temperature Cylinder 16 (B8) – Deviation

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2466 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 16. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 16. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2512 inactive and Fault Code 2511 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | Voltage between 4.75 and 5.25-VDC?
 | STEP 4C. Check the engine harness and connector pins. | Dirty or damaged pin?
 | STEP 4D. Check the exhaust gas temperature sensor circuit for a short circuit pin-to-pin. | More than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check the cylinder 16 overhead set. |
 | STEP 5A. Complete visual inspection of the cylinder 16 overhead set. | Overhead set OK?
STEP 6. | Inspect the cylinder 16 power cylinder. |
 | STEP 6A. Visually inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2512 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and running for more than one minute.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 2466 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 16.

Guided Step 2A - Check the spark plug on cylinder 16.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the spark plug for the following:

  • Plug correctly tightened.
  • 'J' connector damaged.
  • Oil contamination on electrode.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Retighten the spark plug to the specified torque.
  • Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 16.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil and ignition coil extension tube o-ring. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the appropriate wiring diagram for connector pin identification.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the ignition harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check the ignition harness for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks to all interconnecting harness connectors in the circuit.
  • Refer to the appropriate wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check the ignition harness for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY INPUT pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition SUPPLY RETURN pin in the ignition coil connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature sensor circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool
  • Isolate the generator set 24-VDC power supply
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder 16 exhaust gas temperature sensor response.

  • Remove the exhaust gas temperature sensors from cylinders 16 and 14
  • Install the temperature sensor from cylinder 16 to 14.
  • Install the temperature sensor from cylinder 14 to 16
  • Reconnect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool, check that Fault Code 2512 is inactive and that Fault Code 2511 is active.

Fault Code 2512 inactive and Fault Code 2511 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in the cylinder 16 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connectors from cylinder 16 exhaust gas temperature sensor.

Action

Check the 5-VDC supply to the exhaust gas temperature sensor.

  • Measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 16

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in OFF mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 16 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair or replace the engine harness or harness connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check the exhaust gas temperature sensor circuit for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connector from cylinder 16 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connectors. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check the exhaust gas temperature sensor circuit for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness connectors from cylinder 16 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CM850 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5-VDC SUPPLY pin in the engine harness CM850 module connector to the exhaust temperature 5-VDC SUPPLY pin in the exhaust gas temperature sensor connector.

Perform these check on all interconnecting harness connectors in the circuit.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or harness connectors. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check the cylinder 16 overhead set.

Guided Step 5A - Check the cylinder 16 overhead set.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 16 overhead setting is correct.

  • Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Complete visual inspection of the cylinder 16 power cylinder.

Guided Step 6A - Visually inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (if available, these inspections can be performed using a Borescope without component removal):

  • Cylinder Head - Intake or exhaust valve/valve seat damage. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair the cylinder head as necessary. Use the following procedure in the QSK60G Generator CM700 Service Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2512 is inactive.

Fault Code 2512 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Using INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 24-Mar-2011


FAULT CODE 2517 - Engine Turbocharger 1 Boost Pressure Sensor - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164752 - pressure sensor breakout cable, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Check for multiple fault codes. | Fault Codes 227, 263, 1827, and 2427 active?
STEP 2. | Check the compressor outlet pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 2517 inactive?
 | STEP 4B. Check the CM558 signal pin resistance. | Less than 100k ohm?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 2517 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Keyswitch circuit energized.
  • Run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the compressor outlet pressure sensor.

Fault Codes 227, 263, 1827, and 2427 active?
YES | NO
No Repair | No Repair

Troubleshoot the fault code using the appropriate troubleshooting chart.

Go to 2A

Guided Step 2 - Check the compressor outlet pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized.
  • Run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the compressor outlet pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or replace the compressor outlet pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the compressor outlet pressure sensor. Refer to Procedure 019-061 in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized.
  • Run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the compressor outlet pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized.
  • Run/stop/auto switch in STOP mode.
  • Install the compressor outlet pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the compressor outlet pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

Repair

  • Replace the compressor outlet pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized.
  • Run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the compressor outlet pressure sensor and the CM558.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform all these checks on all interconnecting harness connectors in the circuit. Use the circuit art or the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness with damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized.
  • Run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the compressor outlet pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the compressor outlet pressure sensor.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the compressor outlet pressure SUPPLY pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the compressor outlet pressure RETURN pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the compressor outlet pressure SIGNAL pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized.
  • Run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the compressor outlet pressure sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the compressor outlet pressure RETURN pin on the engine harness connector to the compressor outlet pressure RETURN pin on the engine harness sensor connector.
  • Measure the resistance from the compressor outlet pressure SIGNAL pin on the engine harness connector to the compressor outlet pressure SIGNAL pin on the engine harness sensor connector.
  • Measure the resistance from the compressor outlet pressure SUPPLY pin on the engine harness connector to the compressor outlet pressure SUPPLY pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized.
  • Run/stop/auto switch in STOP mode.
  • Disconnect the compressor outlet pressure sensor connector.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Place a jumper wire between the fuel delivery pressure sensor SUPPLY pin and the fuel SUPPLY pressure sensor SIGNAL pin of the sensor connector.
  • Check for the appropriate CM558 response after 30 seconds.
  • Use INSITE™ electronic service tool to verify the fault codes.

NOTE: Fault Code 2518 will become active upon disconnecting the sensor.

Fault Code 2517 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM558 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized.
  • Run/stop/auto switch in STOP mode.
  • Disconnect the main harness connectors from the CM558.

Action

Check the CM558 signal pin resistance.

  • Measure the resistance from the compressor outlet pressure SIGNAL pin on the CM558 to the CM558 sensor supply circuit number two RETURN pin.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/stop/auto switch in RUN mode and running for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2517 is inactive.

Fault Code 2517 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized.
  • Run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 15-Sep-2010


FAULT CODE 2518 - Engine Turbocharger 1 Boost Pressure Sensor - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164752 - pressure sensor breakout cable, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Check for multiple fault codes. | Fault Codes 187, 265, 1828, and 2428 active?
STEP 2. | Check the compressor outlet pressure sensor. |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the sensor signal voltage. | 0.46 to 4.56-VDC?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 2518 inactive?
 | STEP 4B. Check the CM558 signal pin resistance. | Less than 100k ohm?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 2518 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Keyswitch circuit energized.
  • Run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes
  • Use the specific engine wiring diagram to verify that no fault codes are active for any sensor sharing a common electrical supply with the compressor outlet pressure sensor.

Fault Code 187, 265, 1828, and 2428 active?
YES | NO
No Repair | No Repair

Troubleshoot the fault code using the appropriate troubleshooting chart.

Go to 2A

Guided Step 2 - Check the compressor outlet pressure sensor.

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • Keyswitch circuit de-energized.
  • Run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the compressor outlet pressure sensor.

Action

Inspect the sensor and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness or replace the compressor outlet pressure sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19..
  • Replace the compressor outlet pressure sensor. Refer to Procedure 019-061 in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the sensor supply voltage.

Conditions

  • Keyswitch circuit energized.
  • Run/stop/auto switch in STOP mode.
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the compressor outlet pressure sensor supply voltage.

  • Measure the supply voltage by installing the breakout cable's supply and return connectors into the multimeter.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor signal voltage.

Conditions

  • Keyswitch circuit energized.
  • Run/stop/auto switch in STOP mode.
  • Install the compressor outlet pressure sensor breakout cable between the sensor and the sensor harness connector.
  • Connect INSITE™ electronic service tool.

Action

Check the compressor outlet pressure sensor signal voltage.

  • Measure the signal voltage by installing the breakout cable's signal and return connectors into the multimeter.

0.46 to 4.56-VDC?
YES NO
No Repair

Repair

  • Replace the compressor outlet pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized.
  • Run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the compressor outlet pressure sensor and the CM558.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform all these checks on all interconnecting harness connectors in the circuit. Use the circuit art or the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness with damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized.
  • Run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the compressor outlet pressure sensor.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the compressor outlet pressure sensor.

Action

Inspect the engine harness and the extension harness connector pins for the following:

  • Measure the resistance from the compressor outlet pressure SUPPLY pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the compressor outlet pressure RETURN pin on the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the compressor outlet pressure SIGNAL pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized.
  • Run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the extension harness (if present).
  • Disconnect the engine harness from the compressor outlet pressure sensor.

Action

Check for an open circuit in the harness.

  • Measure the resistance from the compressor outlet pressure RETURN pin on the engine harness connector to the compressor outlet pressure RETURN pin on the engine harness sensor connector.
  • Measure the resistance from the compressor outlet pressure SIGNAL pin on the engine harness connector to the compressor outlet pressure SIGNAL pin on the engine harness sensor connector.
  • Measure the resistance from the compressor outlet pressure SUPPLY pin on the engine harness connector to the compressor outlet pressure SUPPLY pin on the engine harness sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized.
  • Run/stop/auto switch in STOP mode.
  • Disconnect the compressor outlet pressure sensor connector.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Place a jumper wire between the fuel delivery pressure sensor SUPPLY pin and the fuel supply pressure sensor SIGNAL pin of the sensor connector.
  • Check for the appropriate CM558 response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

NOTE: Fault Code 2517 will become active upon adding the jumper.

Fault Code 2518 inactive?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM558 signal pin resistance.

Conditions

  • Keyswitch circuit de-energized.
  • Run/stop/auto switch in STOP mode.
  • Disconnect the main harness connectors from the CM558.

Action

Check the CM558 signal pin resistance.

  • Measure the resistance from the compressor outlet pressure SIGNAL pin on the CM558 to the CM558 sensor supply circuit number two RETURN pin.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 100k ohms?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/stop/auto switch in RUN mode and operate for longer than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2518 is inactive.

Fault Code 2518 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized.
  • Run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 15-Sep-2010


Throttle Position Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Throttle Body Assembly | Refer to Procedure 005-052 in Section 5. | QSK60G Generator CM700 | 4021396

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Codes 175, 176, 512, or 513 active?
STEP 2. | Check the throttle driver and throttle actuator. |
 | STEP 2A. Inspect the throttle driver and engine wiring harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the throttle driver position signal voltage. | 24 VDC?
STEP 3. | Check the engine wiring harness. |
 | STEP 3A. Inspect the engine wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin to pin. | More than 100k ohms?
 | STEP 3C. Check for open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM558 response. |
 | STEP 4A. Check for an appropriate CM558 response. | Fault Code 2519 is inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that fault code is inactive. | Fault Code 2519 is inactive?
 | STEP 5B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the recommended Cummins® electronic service tool or equivalent
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than one minute.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 175, 176, 512, or 513 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Check the throttle driver and throttle actuator.

Guided Step 2A - Inspect the throttle driver and engine wiring harness connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine wiring harness connectors from the throttle driver and throttle actuator.

Action

Inspect the actuator and the engine wiring harness connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine wiring harness or replace the throttle driver, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the throttle actuator assembly. Refer to Procedure 005-052 in the Associated Procedures Table.
 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the throttle driver position signal voltage.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main engine wiring harness from the throttle driver power connections
  • Connect the electronic service tool.

Action

Check the throttle driver supply voltage.

  • Use a multimeter to measure the signal voltage.

24 VDC?
YES NO
No Repair

Repair

Check the power supply connections and fuses in the power supply wires to the CM558. Refer to the circuit diagram or wiring diagram for the appropriate circuit.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine wiring harness.

Guided Step 3A - Inspect the engine wiring harnesses and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine wiring harness from the throttle driver and the CM558.

Action

Inspect the engine wiring harness and connector pins for the following:

  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins

Perform all these checks on all interconnecting wiring harness connectors in the circuit. Use the circuit art or the wiring diagram to identify connectors and pins.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin to pin.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the engine wiring harness from the extension harness (if present)
  • Disconnect the engine wiring harness from the throttle driver.

Action

Inspect the engine wiring harness and connector pins for the following:

  • Measure the resistance from the throttle driver supply pin on the engine wiring harness connector to all other pins in the engine wiring harness connector.
  • Measure the resistance from the throttle driver return pin on the engine wiring harness connector to all other pins in the engine wiring harness connector.
  • Measure the resistance from the throttle driver position feedback pin on the engine wiring harness connector to all other pins in the engine wiring harness connector.
  • Perform these checks on all interconnecting wiring harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode.
  • Disconnect the engine wiring harness from the extension harness (if present)
  • Disconnect the engine wiring harness from the throttle driver.

Action

Check for an open circuit in the return wire.

  • Measure the resistance from the throttle driver supply pin on the engine wiring harness connector to the Throttle Driver supply pin on the engine wiring harness sensor connector.
  • Measure the resistance from the throttle driver return pin on the engine wiring harness connector to the Throttle Driver return pin on the engine wiring harness sensor connector.
  • Measure the resistance from the throttle driver position feedback pin on the engine wiring harness connector to the throttle driver position feedback pin on the engine wiring harness sensor connector.
  • Perform these checks on all interconnecting wiring harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM558 response.

Guided Step 4A - Check for an appropriate CM558 response.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than one minute
  • Connect the electronic service tool.

Action

Check for the appropriate CM558 response.

  • Use INSITE™ electronic service tool to verify the fault codes.

Fault Code 2519 is inactive?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Facility.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than one minute.

Action

Verify that fault code is inactive.

  • Use the electronic service tool to verify that Fault Code 2519 is inactive.

Fault Code 2519 is inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.
  • Press reset button on generator set controller.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 10-Mar-2021


Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the left bank CM558. | Fault Code 2521 is active?
 | STEP 1B. Check the right bank CM558. | Fault Code 2521 active?
STEP 2. | Check the left bank CM558 bank identification circuit. |
 | STEP 2A. Inspect the harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Verify a short circuit between bank identification pin 1 and Left Bank CM558 Switch Return. | Less than 10 ohms?
 | STEP 2C. Verify an open circuit on bank identification pin 2. | Greater than 100k ohms?
STEP 3. | Check the right bank CM558 bank identification circuit. |
 | STEP 3A. Inspect the harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Verify a short circuit between bank identification pin 2 and Right Bank CM558 Switch Return. | Less than 10 ohms?
 | STEP 3C. Verify an open circuit on bank identification pin 1. | Greater than 100k ohms?
STEP 4. | Clear the fault code. |
 | STEP 4A. Verify that the fault code is inactive. | Fault Code 2521 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the left bank CM558.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Check for bank identification error fault codes.

  • Use INSITE™ electronic service tool read to the fault codes.

Fault Code 2521 is active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check the right bank CM558.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect INSITE™ electronic service tool.

Action

Check for bank identification error fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2521 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4A

Guided Step 2 - Check the left bank CM558 bank identification circuit.

Guided Step 2A - Inspect the harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main harness connector from the left bank CM558.

Action

Inspect the harness connector and pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Verify a short circuit between bank identification pin 1 and Left Bank CM558 Switch Return.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main harness connector from the left bank CM558.

Action

Harness connector - pin to pin continuity check.

  • Measure the resistance between bank identification pin 1 and Left Bank CM558 Switch Return.
  • Refer to the wiring diagram for connector pin identification.
  • Refer to Procedure 019-360 (Resistance Measurements Using a Multimeter) in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

  • Add a short circuit between bank identification pin 1 and Left Bank CM558 Switch Return.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Verify an open circuit on bank identification pin 2.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main harness connector from the left bank CM558.

Action

Harness connector - pin to pin continuity check:

  • Measure the resistance between bank identification pin 2 and Left Bank CM558 Switch Return.
  • Refer to the wiring diagram for connector pin identification.
  • Refer to Procedure 019-360 (Resistance Measurements Using a Multimeter) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

  • Restore an open circuit between bank identification pin 2 and Left Bank CM558 Switch Return.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the right bank CM558 bank identification circuit.

Guided Step 3A - Inspect the harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main harness connector from the right bank CM558.

Action

Inspect the harness connector and pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform all these checks on all interconnecting harness connectors in the circuit. Use the circuit art or the wiring diagram to identify connectors and pins.

Refer to Procedure For general inspection techniques, 019-361 (Component Connector and Pin Inspection) in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins.

Repair or replace the engine harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Verify a short circuit between bank identification pin 2 and Right Bank CM558 Switch Return.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main harness connector from the right bank CM558.

Action

Harness connector - pin to pin continuity check:

  • Measure the resistance between bank identification pin 2 and Right Bank CM558 switch return.
  • Refer to the wiring diagram for connector pin identification.
  • Refer to Procedure 019-360 (Resistance Measurements Using a Multimeter) in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Add a short circuit between bank identification pin 2 and Right Bank CM558 Switch Return.

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Verify an open circuit on bank identification pin 1.

Conditions

  • Keyswitch circuit de-energized
  • Run/Stop/Auto switch in Stop mode
  • Disconnect the main harness connector from the right bank CM558.

Action

Harness connector - pin to pin continuity check:

  • Measure the resistance between bank identification pin 1 and Right Bank CM558 switch return.
  • Refer to the wiring diagram for connector pin identification.
  • Refer to Procedure 019-360 (Resistance Measurements Using a Multimeter) in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Restore an open circuit between bank identification pin 1 and Right Bank CM558 switch return.

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 (Deutsch DRC Connector Series) in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 (Engine Wiring Harness) in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 2521 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 30-Jun-2010


FAULT CODE 2522 - Engine Cylinder Number 1 Knock – Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 146, 151, 155, 488, 1285, 1295, 1579, 1581, 1582, 2281, 2282, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2531 and 2532 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specifications?
STEP 3. | Check the kilowatt load reference signal calibration. |
 | STEP 3A. Check the kilowatt load transducer reference signal - where fitted. | Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
 | STEP 3B. Check the calibration of the generator set controller. | Generator set controller output voltage and ampere readings match the measured readings?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor resistances within specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor within specification?
STEP 6. | Check the quality of the natural gas supply to the generator set. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply quality within specification?
STEP 7. | Inspect cylinder number 1 cylinder head. |
 | STEP 7A. Check the cylinder number 1 spark plug. | Cylinder number 1 spark plug contaminated or damaged?
 | STEP 7B. Check the cylinder number 1 spark plug gap. | Cylinder number 1 spark plug gap excessive?
 | STEP 7C. Check the cylinder number 1 cylinder head. | Cylinder number 1 cylinder head gasket leaking or loose components?
 | STEP 7D. Check that the cylinder number 1 valve lash setting is correct. | Cylinder number 1 valve lash setting correct?
 | STEP 7E. Check the cylinder number 1 valve train. | Cylinder number 1 valve train wear?
STEP 8. | Inspect the cylinder number 1 power cylinder. |
 | STEP 8A. Inspect the oil filters for debris. | Debris present in the oil filters?
 | STEP 8B. Check the cylinder number 1 internal power cylinder. | Cylinder number 1 power cylinder damaged?
 | STEP 8C. Inspect the cylinder number 1 connecting rod bearings. | Cylinder number 1 connecting rod bearings worn or damaged?
 | STEP 8D. Inspect the cylinder number 1 piston cooling nozzle. | Cylinder number 1 piston cooling nozzle bent or broken?
 | STEP 8E. Check cylinder number1and adjacent cylinder main bearings. | Cylinder number 1 or immediately adjacent main bearings worn or damaged?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 2522 inactive?
 | STEP 9B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 146, 151, 155, 488, 1285, 1295, 1579, 1581, 1582, 2281, 2282, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2531, and 2532 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Use symptom tree t048 in Section TS in this manual.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electric service tool.
  • Connect an exhaust gas analyzer.
  • Operate the engine at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Check exhaust emissions.

  • Use an exhaust gas analyzer. Insert the sample probe into the exhaust gas manifold test port, check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specifications?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool and referencing to the exhaust gas analyzer, adjust the open and closed loop fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.

  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 9A

Guided Step 3 - Check the kilowatt load reference signal calibration.

Guided Step 3A - Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller kilowatt calibration.

Conditions

NOTE: If the generator set is not fitted with a kilowatt load transducer, proceed to Guided Step 3B.

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.
  • Connect INSITE™ electronic service tool.

Action

Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller displayed kilowatt calibration.

  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
YES NO
No Repair

Repair

INSITE™ electronic service tool, calibrate the kilowatt load sensor milliampere/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the calibration of the generator set controller.

Conditions

NOTE: This guided step should only be followed if the generator set is not fitted with a kilowatt load transducer.

  • Connect all components.
  • Connect a power analyzer or digital multimeter
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.

Action

Connect a power analyzer or digital multimeter to the alternator main output terminals.

  • Check that the generator set controller readings for output voltage (L1- L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller output voltage and ampere readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter to calibrate the generator set controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold temperature.

  • Use the generator set human machine interface (HMI) to check the intake manifold temperature. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold temperature within specification?
YES NO
No Repair

Repair

Check the following:

  • Check the temperature of the high temperature (HT) coolant outlet from the engine.
  • Check the temperature of the low temperature (LT) coolant outlet from the engine.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 018-018 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the intake manifold temperature sensor resistances.

  • NOTE: The intake manifold temperature sensor may have malfunctioned in range and the related fault codes will not be activated. Reference Fault Code 153 or Fault Code 154 in Section TF.
  • Refer to circuit diagram or wiring diagram for connector pin identification. Refer to Procedure 019-360 in Section 19.

Intake manifold temperature sensor resistances within specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor.

  • Refer to Procedure 019-059 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold pressure.

  • Use the generator set human machine interface (HMI) to check the intake manifold pressure. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold pressure within specification?
YES NO
No Repair

Repair

If fitted, check the operation of the compressor bypass valve (single turbocharger engines only).

  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the intake manifold pressure sensor.

NOTE: The intake manifold pressure sensor may have malfunctioned in-range and the related fault codes will not be activated.

  • Reference Fault Code 354 or Fault Code 355 in Section TF.
  • Refer to Procedure 019-359 in Section 19.

Intake manifold pressure sensor within specification?
YES NO
No Repair

Repair

Replace the intake manifold pressure sensor.

  • Refer to Procedure 019-061 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the generator set.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the quality of the natural gas supply.

  • Check the quality of the natural gas supplied to the generator set meets or exceeds minimum requirement for generator set (methane number and fuel contaminants limits).
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspect cylinder number 1 cylinder head.

Guided Step 7A - Check the cylinder number 1 spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug J connector damaged
  • Electrode has signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder number 1 spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug.
  • Replace the spark plug.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the cylinder number 1 spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Remove the spark plug and measure the spark plug electrode gap.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
  • Contact a Cummins® Authorized Repair Location.

Cylinder number 1 spark plug gap excessive?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7C

Guided Step 7C - Check the cylinder number 1 cylinder head.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect cylinder number 1 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder number 1 cylinder head.

Cylinder number 1 cylinder head gasket leaking or loose components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose components on or immediately around cylinder number 1 cylinder head. Reference the appropriate procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396.
No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check that the cylinder number 1 valve lash setting is correct.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder number 1 valve lash is correct.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder number 1 valve lash setting correct?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7E

Guided Step 7E - Check the cylinder number 1 valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the cylinder number 1 valve train for the following:

  • Intake or exhaust valve wear/recession or damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Camshaft follower wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder number 1 camshaft lobe wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Cylinder number 1 valve train wear?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft follower assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the camshaft. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

Adjust the valve lash. Reset the valve lash setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 9A

Go to 8A

Guided Step 8 - Inspect the cylinder number 1 power cylinder.

Guided Step 8A - Inspect the oil filters for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubrication oil filters. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filters and inspect for debris in the filter media.
  • Contact a Cummins® Authorized Repair Location.

Debris present in the oil filters?
YES | NO
No Repair | No Repair

Go to 8B

Go to 8D

Guided Step 8B - Check the cylinder number 1 internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the cylinder number 1 internal power cylinder.

Inspect the internal power cylinder for the following:

NOTE: If available, use a borescope to perform the inspections.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage.

Cylinder number 1 power cylinder damaged?
YES NO

Repair

Replace the piston rings. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.

Replace the liner. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-045 in Section 1.

Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the cylinder number 1 connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP.

Action

Inspect the cylinder number 1 connecting rod bearings for excessive wear or other damage.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder number 1 connecting rod bearings worn or damaged?
YES NO

Repair

Replace the connecting rods bearings:

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.
No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the cylinder number 1 piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the piston cooling nozzle.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder number 1 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.
No Repair

Go to 9A

Go to 8E

Guided Step 8E - Inspect cylinder number 1 and adjacent cylinder main bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect cylinder number 1 and adjacent cylinder main bearings.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

Cylinder number 1 or immediately adjacent main bearings worn or damaged?
YES NO

Repair

Replace the main bearings as required (cylinder 1 or immediately adjacent cylinders). Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

No Repair

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electronic service tool.
  • Operate the engine for longer than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2522 is inactive.

Fault Code 2522 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Authorized Cummins® Repair Location if all steps have been completed and checked again.

Go to 9B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 17-Dec-2010


FAULT CODE 2523 - Engine Cylinder Number 2 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 146, 151, 155, 488, 1285, 1295, 1579, 1581, 1582, 2281, 2282, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2531 and 2532 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specifications?
STEP 3. | Check the kilowatt load reference signal calibration. |
 | STEP 3A. Check the kilowatt load transducer reference signal - where fitted. | Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
 | STEP 3B. Check the calibration of the generator set controller. | Generator set controller output voltage and ampere readings match the measured readings?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor resistances within specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor within specification?
STEP 6. | Check the quality of the natural gas supply to the generator set. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply quality within specification?
STEP 7. | Inspect cylinder number 2 cylinder head. |
 | STEP 7A. Check the cylinder number 2 spark plug. | Cylinder number 2 spark plug contaminated or damaged?
 | STEP 7B. Check the cylinder number 2 spark plug gap. | Cylinder number 2 spark plug gap excessive?
 | STEP 7C. Check the cylinder number 2 cylinder head. | Cylinder number 2 cylinder head gasket leaking or loose components?
 | STEP 7D. Check that the cylinder number 2 valve lash setting is correct. | Cylinder number 2 valve lash setting correct?
 | STEP 7E. Check the cylinder number 2 valve train. | Cylinder number 2 valve train wear?
STEP 8. | Inspect the cylinder number 2 power cylinder. |
 | STEP 8A. Inspect the oil filters for debris. | Debris present in the oil filters?
 | STEP 8B. Check the cylinder number 2 internal power cylinder. | Cylinder number 2 power cylinder damaged?
 | STEP 8C. Inspect the cylinder number 2 connecting rod bearings. | Cylinder number 2 connecting rod bearings worn or damaged?
 | STEP 8D. Inspect the cylinder number 2 piston cooling nozzle. | Cylinder number 2 piston cooling nozzle bent or broken?
 | STEP 8E. Check cylinder number1and adjacent cylinder main bearings. | Cylinder number 2 or immediately adjacent main bearings worn or damaged?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 2522 inactive?
 | STEP 9B. Clear the inactive fault codes. | All fault codes cleared?
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 2442 or 2443 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 146, 151, 155, 488, 1285, 1295, 1579, 1581, 1582, 2281, 2282, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2531, and 2532 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Use symptom tree t048 in Section TS in this manual.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electric service tool.
  • Connect an exhaust gas analyzer.
  • Operate the engine at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Check exhaust emissions.

  • Use an exhaust gas analyzer. Insert the sample probe into the exhaust gas manifold test port, check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specifications?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool and referencing to the exhaust gas analyzer, adjust the open and closed loop fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.

  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 9A

Guided Step 3 - Check the kilowatt load reference signal calibration.

Guided Step 3A - Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller kilowatt calibration.

Conditions

NOTE: If the generator set is not fitted with a kilowatt load transducer, proceed to Guided Step 3B.

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.
  • Connect INSITE™ electronic service tool.

Action

Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller displayed kilowatt calibration.

  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
YES NO
No Repair

Repair

INSITE™ electronic service tool, calibrate the kilowatt load sensor milliampere/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the calibration of the generator set controller.

Conditions

NOTE: This guided step should only be followed if the generator set is not fitted with a kilowatt load transducer.

  • Connect all components.
  • Connect a power analyzer or digital multimeter
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.

Action

Connect a power analyzer or digital multimeter to the alternator main output terminals.

  • Check that the generator set controller readings for output voltage (L1- L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller output voltage and ampere readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter to calibrate the generator set controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold temperature.

  • Use the generator set human machine interface (HMI) to check the intake manifold temperature. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold temperature within specification?
YES NO
No Repair

Repair

Check the following:

  • Check the temperature of the high temperature (HT) coolant outlet from the engine.
  • Check the temperature of the low temperature (LT) coolant outlet from the engine.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 018-018 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the intake manifold temperature sensor resistances.

  • NOTE: The intake manifold temperature sensor may have malfunctioned in range and the related fault codes will not be activated. Reference Fault Code 153 or Fault Code 154 in Section TF.
  • Refer to circuit diagram or wiring diagram for connector pin identification. Refer to Procedure 019-360 in Section 19.

Intake manifold temperature sensor resistances within specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor.

  • Refer to Procedure 019-059 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold pressure.

  • Use the generator set human machine interface (HMI) to check the intake manifold pressure. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold pressure within specification?
YES NO
No Repair

Repair

If fitted, check the operation of the compressor bypass valve (single turbocharger engines only).

  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the intake manifold pressure sensor.

NOTE: The intake manifold pressure sensor may have malfunctioned in-range and the related fault codes will not be activated.

  • Reference Fault Code 354 or Fault Code 355 in Section TF.
  • Refer to Procedure 019-359 in Section 19.

Intake manifold pressure sensor within specification?
YES NO
No Repair

Repair

Replace the intake manifold pressure sensor.

  • Refer to Procedure 019-061 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the generator set.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the quality of the natural gas supply.

  • Check the quality of the natural gas supplied to the generator set meets or exceeds minimum requirement for generator set (methane number and fuel contaminants limits).
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspect cylinder number 2 cylinder head.

Guided Step 7A - Check the cylinder number 2 spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug J connector damaged
  • Electrode has signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder number 2 spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug.
  • Replace the spark plug.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the cylinder number 2 spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Remove the spark plug and measure the spark plug electrode gap.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
  • Contact a Cummins® Authorized Repair Location.

Cylinder number 2 spark plug gap excessive?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7C

Guided Step 7C - Check the cylinder number 2 cylinder head.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect cylinder number 2 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder number 2 cylinder head.

Cylinder number 2 cylinder head gasket leaking or loose components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose components on or immediately around cylinder number 2 cylinder head. Reference the appropriate procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396.
No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check that the cylinder number 2 valve lash setting is correct.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder number 2 valve lash is correct.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder number 2 valve lash setting correct?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7E

Guided Step 7E - Check the cylinder number 2 valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the cylinder number 2 valve train for the following:

  • Intake or exhaust valve wear/recession or damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Camshaft follower wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • cylinder number 2 camshaft lobe wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Cylinder number 2 valve train wear?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft follower assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the camshaft. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

Adjust the valve lash. Reset the valve lash setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 9A

Go to 8A

Guided Step 8 - Inspect the cylinder number 2 power cylinder.

Guided Step 8A - Inspect the oil filters for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubrication oil filters. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filters and inspect for debris in the filter media.
  • Contact a Cummins® Authorized Repair Location.

Debris present in the oil filters?
YES | NO
No Repair | No Repair

Go to 8B

Go to 8D

Guided Step 8B - Check the cylinder number 2 internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the cylinder number 2 internal power cylinder.

Inspect the internal power cylinder for the following:

NOTE: If available, use a borescope to perform the inspections.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage.

Cylinder number 2 power cylinder damaged?
YES NO

Repair

Replace the piston rings. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.

Replace the liner. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-045 in Section 1.

Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the cylinder number 2 connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP.

Action

Inspect the cylinder number 2 connecting rod bearings for excessive wear or other damage.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder number 2 connecting rod bearings worn or damaged?
YES NO

Repair

Replace the connecting rods bearings:

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.
No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the cylinder number 2 piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the piston cooling nozzle.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder number 2 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.
No Repair

Go to 9A

Go to 8E

Guided Step 8E - Inspect cylinder number 2 and adjacent cylinder main bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect cylinder number 2 and adjacent cylinder main bearings.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

Cylinder number 2 or immediately adjacent main bearings worn or damaged?
YES NO

Repair

Replace the main bearings as required (cylinder 2 or immediately adjacent cylinders). Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

No Repair

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electronic service tool.
  • Operate the engine for longer than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2522 is inactive.

Fault Code 2522 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Authorized Cummins® Repair Location if all steps have been completed and checked again.

Go to 9B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 03-Jan-2011


FAULT CODE 2524 - Engine Cylinder Number 3 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 146, 151, 155, 488, 1285, 1295, 1579, 1581, 1582, 2281, 2282, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2531 and 2532 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specifications?
STEP 3. | Check the kilowatt load reference signal calibration. |
 | STEP 3A. Check the kilowatt load transducer reference signal - where fitted. | Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
 | STEP 3B. Check the calibration of the generator set controller. | Generator set controller output voltage and ampere readings match the measured readings?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor resistances within specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor within specification?
STEP 6. | Check the quality of the natural gas supply to the generator set. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply quality within specification?
STEP 7. | Inspect cylinder number 3 cylinder head. |
 | STEP 7A. Check the cylinder number 3 spark plug. | Cylinder number 3 spark plug contaminated or damaged?
 | STEP 7B. Check the cylinder number 3 spark plug gap. | Cylinder number 3 spark plug gap excessive?
 | STEP 7C. Check the cylinder number 3 cylinder head. | Cylinder number 3 cylinder head gasket leaking or loose components?
 | STEP 7D. Check that the cylinder number 3 valve lash setting is correct. | Cylinder number 3 valve lash setting correct?
 | STEP 7E. Check the cylinder number 3 valve train. | Cylinder number 3 valve train wear?
STEP 8. | Inspect the cylinder number 3 power cylinder. |
 | STEP 8A. Inspect the oil filters for debris. | Debris present in the oil filters?
 | STEP 8B. Check the cylinder number 3 internal power cylinder. | Cylinder number 3 power cylinder damaged?
 | STEP 8C. Inspect the cylinder number 3 connecting rod bearings. | Cylinder number 3 connecting rod bearings worn or damaged?
 | STEP 8D. Inspect the cylinder number 3 piston cooling nozzle. | Cylinder number 3 piston cooling nozzle bent or broken?
 | STEP 8E. Check cylinder number1and adjacent cylinder main bearings. | Cylinder number 3 or immediately adjacent main bearings worn or damaged?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 2522 inactive?
 | STEP 9B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 146, 151, 155, 488, 1285, 1295, 1579, 1581, 1582, 2281, 2282, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2531, and 2532 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Use symptom tree t048 in Section TS in this manual.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electric service tool.
  • Connect an exhaust gas analyzer.
  • Operate the engine at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Check exhaust emissions.

  • Use an exhaust gas analyzer. Insert the sample probe into the exhaust gas manifold test port, check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specifications?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool and referencing to the exhaust gas analyzer, adjust the open and closed loop fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.

  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 9A

Guided Step 3 - Check the kilowatt load reference signal calibration.

Guided Step 3A - Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller kilowatt calibration.

Conditions

NOTE: If the generator set is not fitted with a kilowatt load transducer, proceed to Guided Step 3B.

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.
  • Connect INSITE™ electronic service tool.

Action

Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller displayed kilowatt calibration.

  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
YES NO
No Repair

Repair

INSITE™ electronic service tool, calibrate the kilowatt load sensor milliampere/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the calibration of the generator set controller.

Conditions

NOTE: This guided step should only be followed if the generator set is not fitted with a kilowatt load transducer.

  • Connect all components.
  • Connect a power analyzer or digital multimeter
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.

Action

Connect a power analyzer or digital multimeter to the alternator main output terminals.

  • Check that the generator set controller readings for output voltage (L1- L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller output voltage and ampere readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter to calibrate the generator set controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold temperature.

  • Use the generator set human machine interface (HMI) to check the intake manifold temperature. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold temperature within specification?
YES NO
No Repair

Repair

Check the following:

  • Check the temperature of the high temperature (HT) coolant outlet from the engine.
  • Check the temperature of the low temperature (LT) coolant outlet from the engine.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 018-018 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the intake manifold temperature sensor resistances.

  • NOTE: The intake manifold temperature sensor may have malfunctioned in range and the related fault codes will not be activated. Reference Fault Code 153 or Fault Code 154 in Section TF.
  • Refer to circuit diagram or wiring diagram for connector pin identification. Refer to Procedure 019-360 in Section 19.

Intake manifold temperature sensor resistances within specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor.

  • Refer to Procedure 019-059 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold pressure.

  • Use the generator set human machine interface (HMI) to check the intake manifold pressure. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold pressure within specification?
YES NO
No Repair

Repair

If fitted, check the operation of the compressor bypass valve (single turbocharger engines only).

  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the intake manifold pressure sensor.

NOTE: The intake manifold pressure sensor may have malfunctioned in-range and the related fault codes will not be activated.

  • Reference Fault Code 354 or Fault Code 355 in Section TF.
  • Refer to Procedure 019-359 in Section 19.

Intake manifold pressure sensor within specification?
YES NO
No Repair

Repair

Replace the intake manifold pressure sensor.

  • Refer to Procedure 019-061 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the generator set.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the quality of the natural gas supply.

  • Check the quality of the natural gas supplied to the generator set meets or exceeds minimum requirement for generator set (methane number and fuel contaminants limits).
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspect cylinder number 3 cylinder head.

Guided Step 7A - Check the cylinder number 3 spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug J connector damaged
  • Electrode has signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder number 3 spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug.
  • Replace the spark plug.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the cylinder number 3 spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Remove the spark plug and measure the spark plug electrode gap.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
  • Contact a Cummins® Authorized Repair Location.

Cylinder number 3 spark plug gap excessive?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7C

Guided Step 7C - Check the cylinder number 3 cylinder head.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect cylinder number 3 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder number 3 cylinder head.

Cylinder number 3 cylinder head gasket leaking or loose components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose components on or immediately around cylinder number 3 cylinder head. Reference the appropriate procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396.
No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check that the cylinder number 3 valve lash setting is correct.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder number 3 valve lash is correct.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder number 3 valve lash setting correct?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7E

Guided Step 7E - Check the cylinder number 3 valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the cylinder number 3 valve train for the following:

  • Intake or exhaust valve wear/recession or damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Camshaft follower wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder number 3 camshaft lobe wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Cylinder number 3 valve train wear?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft follower assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the camshaft. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

Adjust the valve lash. Reset the valve lash setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 9A

Go to 8A

Guided Step 8 - Inspect the cylinder number 3 power cylinder.

Guided Step 8A - Inspect the oil filters for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubrication oil filters. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filters and inspect for debris in the filter media.
  • Contact a Cummins® Authorized Repair Location.

Debris present in the oil filters?
YES | NO
No Repair | No Repair

Go to 8B

Go to 8D

Guided Step 8B - Check the cylinder number 3 internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the cylinder number 3 internal power cylinder.

Inspect the internal power cylinder for the following:

NOTE: If available, use a borescope to perform the inspections.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage.

Cylinder number 3 power cylinder damaged?
YES NO

Repair

Replace the piston rings. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.

Replace the liner. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-045 in Section 1.

Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the cylinder number 3 connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP.

Action

Inspect the cylinder number 3 connecting rod bearings for excessive wear or other damage.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder number 3 connecting rod bearings worn or damaged?
YES NO

Repair

Replace the connecting rods bearings:

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.
No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the cylinder number 3 piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the piston cooling nozzle.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder number 3 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.
No Repair

Go to 9A

Go to 8E

Guided Step 8E - Inspect cylinder number 3 and adjacent cylinder main bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect cylinder number 3 and adjacent cylinder main bearings.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

Cylinder number 3 or immediately adjacent main bearings worn or damaged?
YES NO

Repair

Replace the main bearings as required (cylinder 3 or immediately adjacent cylinders). Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

No Repair

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electronic service tool.
  • Operate the engine for longer than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2522 is inactive.

Fault Code 2522 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Authorized Cummins® Repair Location if all steps have been completed and checked again.

Go to 9B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 03-Jan-2011


FAULT CODE 2525 - Engine Cylinder Number 4 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 146, 151, 155, 488, 1285, 1295, 1579, 1581, 1582, 2281, 2282, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2531 and 2532 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specifications?
STEP 3. | Check the kilowatt load reference signal calibration. |
 | STEP 3A. Check the kilowatt load transducer reference signal - where fitted. | Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
 | STEP 3B. Check the calibration of the generator set controller. | Generator set controller output voltage and ampere readings match the measured readings?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor resistances within specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor within specification?
STEP 6. | Check the quality of the natural gas supply to the generator set. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply quality within specification?
STEP 7. | Inspect cylinder number 4 cylinder head. |
 | STEP 7A. Check the cylinder number 4 spark plug. | Cylinder number 4 spark plug contaminated or damaged?
 | STEP 7B. Check the cylinder number 4 spark plug gap. | Cylinder number 4 spark plug gap excessive?
 | STEP 7C. Check the cylinder number 4 cylinder head. | Cylinder number 4 cylinder head gasket leaking or loose components?
 | STEP 7D. Check that the cylinder number 4 valve lash setting is correct. | Cylinder number 4 valve lash setting correct?
 | STEP 7E. Check the cylinder number 4 valve train. | Cylinder number 4 valve train wear?
STEP 8. | Inspect the cylinder number 4 power cylinder. |
 | STEP 8A. Inspect the oil filters for debris. | Debris present in the oil filters?
 | STEP 8B. Check the cylinder number 4 internal power cylinder. | Cylinder number 4 power cylinder damaged?
 | STEP 8C. Inspect the cylinder number 4 connecting rod bearings. | Cylinder number 4 connecting rod bearings worn or damaged?
 | STEP 8D. Inspect the cylinder number 4 piston cooling nozzle. | Cylinder number 4 piston cooling nozzle bent or broken?
 | STEP 8E. Check cylinder number1and adjacent cylinder main bearings. | Cylinder number 4 or immediately adjacent main bearings worn or damaged?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 2522 inactive?
 | STEP 9B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 146, 151, 155, 488, 1285, 1295, 1579, 1581, 1582, 2281, 2282, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2531, and 2532 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Use symptom tree t048 in Section TS in this manual.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electric service tool.
  • Connect an exhaust gas analyzer.
  • Operate the engine at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Check exhaust emissions.

  • Use an exhaust gas analyzer. Insert the sample probe into the exhaust gas manifold test port, check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specifications?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool and referencing to the exhaust gas analyzer, adjust the open and closed loop fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.

  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 9A

Guided Step 3 - Check the kilowatt load reference signal calibration.

Guided Step 3A - Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller kilowatt calibration.

Conditions

NOTE: If the generator set is not fitted with a kilowatt load transducer, proceed to Guided Step 3B.

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.
  • Connect INSITE™ electronic service tool.

Action

Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller displayed kilowatt calibration.

  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
YES NO
No Repair

Repair

INSITE™ electronic service tool, calibrate the kilowatt load sensor milliampere/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the calibration of the generator set controller.

Conditions

NOTE: This guided step should only be followed if the generator set is not fitted with a kilowatt load transducer.

  • Connect all components.
  • Connect a power analyzer or digital multimeter
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.

Action

Connect a power analyzer or digital multimeter to the alternator main output terminals.

  • Check that the generator set controller readings for output voltage (L1- L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller output voltage and ampere readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter to calibrate the generator set controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold temperature.

  • Use the generator set human machine interface (HMI) to check the intake manifold temperature. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold temperature within specification?
YES NO
No Repair

Repair

Check the following:

  • Check the temperature of the high temperature (HT) coolant outlet from the engine.
  • Check the temperature of the low temperature (LT) coolant outlet from the engine.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 018-018 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the intake manifold temperature sensor resistances.

  • NOTE: The intake manifold temperature sensor may have malfunctioned in range and the related fault codes will not be activated. Reference Fault Code 153 or Fault Code 154 in Section TF.
  • Refer to circuit diagram or wiring diagram for connector pin identification. Refer to Procedure 019-360 in Section 19.

Intake manifold temperature sensor resistances within specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor.

  • Refer to Procedure 019-059 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold pressure.

  • Use the generator set human machine interface (HMI) to check the intake manifold pressure. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold pressure within specification?
YES NO
No Repair

Repair

If fitted, check the operation of the compressor bypass valve (single turbocharger engines only).

  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the intake manifold pressure sensor.

NOTE: The intake manifold pressure sensor may have malfunctioned in-range and the related fault codes will not be activated.

  • Reference Fault Code 354 or Fault Code 355 in Section TF.
  • Refer to Procedure 019-359 in Section 19.

Intake manifold pressure sensor within specification?
YES NO
No Repair

Repair

Replace the intake manifold pressure sensor.

  • Refer to Procedure 019-061 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the generator set.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the quality of the natural gas supply.

  • Check the quality of the natural gas supplied to the generator set meets or exceeds minimum requirement for generator set (methane number and fuel contaminants limits).
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspect cylinder number 4 cylinder head.

Guided Step 7A - Check the cylinder number 4 spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug J connector damaged
  • Electrode has signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder number 4 spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug.
  • Replace the spark plug.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the cylinder number 4 spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Remove the spark plug and measure the spark plug electrode gap.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
  • Contact a Cummins® Authorized Repair Location.

Cylinder number 4 spark plug gap excessive?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7C

Guided Step 7C - Check the cylinder number 4 cylinder head.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect cylinder number 4 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder number 4 cylinder head.

Cylinder number 4 cylinder head gasket leaking or loose components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose components on or immediately around cylinder number 4 cylinder head. Reference the appropriate procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396.
No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check that the cylinder number 4 valve lash setting is correct.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder number 4 valve lash is correct.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder number 4 valve lash setting correct?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7E

Guided Step 7E - Check the cylinder number 4 valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the cylinder number 4 valve train for the following:

  • Intake or exhaust valve wear/recession or damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Camshaft follower wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder number 4 camshaft lobe wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Cylinder number 4 valve train wear?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft follower assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the camshaft. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

Adjust the valve lash. Reset the valve lash setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 9A

Go to 8A

Guided Step 8 - Inspect the cylinder number 4 power cylinder.

Guided Step 8A - Inspect the oil filters for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubrication oil filters. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filters and inspect for debris in the filter media.
  • Contact a Cummins® Authorized Repair Location.

Debris present in the oil filters?
YES | NO
No Repair | No Repair

Go to 8B

Go to 8D

Guided Step 8B - Check the cylinder number 4 internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the cylinder number 4 internal power cylinder.

Inspect the internal power cylinder for the following:

NOTE: If available, use a borescope to perform the inspections.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage.

Cylinder number 4 power cylinder damaged?
YES NO

Repair

Replace the piston rings. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.

Replace the liner. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-045 in Section 1.

Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the cylinder number 4 connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP.

Action

Inspect the cylinder number 4 connecting rod bearings for excessive wear or other damage.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder number 4 connecting rod bearings worn or damaged?
YES NO

Repair

Replace the connecting rods bearings:

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.
No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the cylinder number 4 piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the piston cooling nozzle.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder number 4 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.
No Repair

Go to 9A

Go to 8E

Guided Step 8E - Inspect cylinder number 4 and adjacent cylinder main bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect cylinder number 4 and adjacent cylinder main bearings.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

Cylinder number 4 or immediately adjacent main bearings worn or damaged?
YES NO

Repair

Replace the main bearings as required (cylinder 4 or immediately adjacent cylinders). Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

No Repair

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electronic service tool.
  • Operate the engine for longer than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2522 is inactive.

Fault Code 2522 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Authorized Cummins® Repair Location if all steps have been completed and checked again.

Go to 9B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 03-Jan-2011


FAULT CODE 2526 - Engine Cylinder Number 5 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 146, 151, 155, 488, 1285, 1295, 1579, 1581, 1582, 2281, 2282, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2531 and 2532 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specifications?
STEP 3. | Check the kilowatt load reference signal calibration. |
 | STEP 3A. Check the kilowatt load transducer reference signal - where fitted. | Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
 | STEP 3B. Check the calibration of the generator set controller. | Generator set controller output voltage and ampere readings match the measured readings?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor resistances within specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor within specification?
STEP 6. | Check the quality of the natural gas supply to the generator set. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply quality within specification?
STEP 7. | Inspect cylinder number 5 cylinder head. |
 | STEP 7A. Check the cylinder number 5 spark plug. | Cylinder number 5 spark plug contaminated or damaged?
 | STEP 7B. Check the cylinder number 5 spark plug gap. | Cylinder number 5 spark plug gap excessive?
 | STEP 7C. Check the cylinder number 5 cylinder head. | Cylinder number 5 cylinder head gasket leaking or loose components?
 | STEP 7D. Check that the cylinder number 5 valve lash setting is correct. | Cylinder number 5 valve lash setting correct?
 | STEP 7E. Check the cylinder number 5 valve train. | Cylinder number 5 valve train wear?
STEP 8. | Inspect the cylinder number 5 power cylinder. |
 | STEP 8A. Inspect the oil filters for debris. | Debris present in the oil filters?
 | STEP 8B. Check the cylinder number 5 internal power cylinder. | Cylinder number 5 power cylinder damaged?
 | STEP 8C. Inspect the cylinder number 5 connecting rod bearings. | Cylinder number 5 connecting rod bearings worn or damaged?
 | STEP 8D. Inspect the cylinder number 5 piston cooling nozzle. | Cylinder number 5 piston cooling nozzle bent or broken?
 | STEP 8E. Check cylinder number1and adjacent cylinder main bearings. | Cylinder number 5 or immediately adjacent main bearings worn or damaged?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 2522 inactive?
 | STEP 9B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 146, 151, 155, 488, 1285, 1295, 1579, 1581, 1582, 2281, 2282, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2531, and 2532 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Use symptom tree t048 in Section TS in this manual.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electric service tool.
  • Connect an exhaust gas analyzer.
  • Operate the engine at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Check exhaust emissions.

  • Use an exhaust gas analyzer. Insert the sample probe into the exhaust gas manifold test port, check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specifications?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool and referencing to the exhaust gas analyzer, adjust the open and closed loop fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.

  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 9A

Guided Step 3 - Check the kilowatt load reference signal calibration.

Guided Step 3A - Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller kilowatt calibration.

Conditions

NOTE: If the generator set is not fitted with a kilowatt load transducer, proceed to Guided Step 3B.

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.
  • Connect INSITE™ electronic service tool.

Action

Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller displayed kilowatt calibration.

  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
YES NO
No Repair

Repair

INSITE™ electronic service tool, calibrate the kilowatt load sensor milliampere/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the calibration of the generator set controller.

Conditions

NOTE: This guided step should only be followed if the generator set is not fitted with a kilowatt load transducer.

  • Connect all components.
  • Connect a power analyzer or digital multimeter
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.

Action

Connect a power analyzer or digital multimeter to the alternator main output terminals.

  • Check that the generator set controller readings for output voltage (L1- L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller output voltage and ampere readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter to calibrate the generator set controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold temperature.

  • Use the generator set human machine interface (HMI) to check the intake manifold temperature. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold temperature within specification?
YES NO
No Repair

Repair

Check the following:

  • Check the temperature of the high temperature (HT) coolant outlet from the engine.
  • Check the temperature of the low temperature (LT) coolant outlet from the engine.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 018-018 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the intake manifold temperature sensor resistances.

  • NOTE: The intake manifold temperature sensor may have malfunctioned in range and the related fault codes will not be activated. Reference Fault Code 153 or Fault Code 154 in Section TF.
  • Refer to circuit diagram or wiring diagram for connector pin identification. Refer to Procedure 019-360 in Section 19.

Intake manifold temperature sensor resistances within specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor.

  • Refer to Procedure 019-059 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold pressure.

  • Use the generator set human machine interface (HMI) to check the intake manifold pressure. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold pressure within specification?
YES NO
No Repair

Repair

If fitted, check the operation of the compressor bypass valve (single turbocharger engines only).

  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the intake manifold pressure sensor.

NOTE: The intake manifold pressure sensor may have malfunctioned in-range and the related fault codes will not be activated.

  • Reference Fault Code 354 or Fault Code 355 in Section TF.
  • Refer to Procedure 019-359 in Section 19.

Intake manifold pressure sensor within specification?
YES NO
No Repair

Repair

Replace the intake manifold pressure sensor.

  • Refer to Procedure 019-061 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the generator set.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the quality of the natural gas supply.

  • Check the quality of the natural gas supplied to the generator set meets or exceeds minimum requirement for generator set (methane number and fuel contaminants limits).
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspect cylinder number 5 cylinder head.

Guided Step 7A - Check the cylinder number 5 spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug J connector damaged
  • Electrode has signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder number 5 spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug.
  • Replace the spark plug.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the cylinder number 5 spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Remove the spark plug and measure the spark plug electrode gap.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
  • Contact a Cummins® Authorized Repair Location.

Cylinder number 5 spark plug gap excessive?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7C

Guided Step 7C - Check the cylinder number 5 cylinder head.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect cylinder number 5 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder number 5 cylinder head.

Cylinder number 5 cylinder head gasket leaking or loose components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose components on or immediately around cylinder number 5 cylinder head. Reference the appropriate procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396.
No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check that the cylinder number 5 valve lash setting is correct.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder number 5 valve lash is correct.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder number 5 valve lash setting correct?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7E

Guided Step 7E - Check the cylinder number 5 valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the cylinder number 5 valve train for the following:

  • Intake or exhaust valve wear/recession or damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Camshaft follower wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder number 5 camshaft lobe wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Cylinder number 5 valve train wear?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft follower assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the camshaft. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

Adjust the valve lash. Reset the valve lash setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 9A

Go to 8A

Guided Step 8 - Inspect the cylinder number 5 power cylinder.

Guided Step 8A - Inspect the oil filters for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubrication oil filters. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filters and inspect for debris in the filter media.
  • Contact a Cummins® Authorized Repair Location.

Debris present in the oil filters?
YES | NO
No Repair | No Repair

Go to 8B

Go to 8D

Guided Step 8B - Check the cylinder number 5 internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the cylinder number 5 internal power cylinder.

Inspect the internal power cylinder for the following:

NOTE: If available, use a borescope to perform the inspections.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage.

Cylinder number 5 power cylinder damaged?
YES NO

Repair

Replace the piston rings. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.

Replace the liner. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-045 in Section 1.

Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the cylinder number 5 connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP.

Action

Inspect the cylinder number 5 connecting rod bearings for excessive wear or other damage.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder number 5 connecting rod bearings worn or damaged?
YES NO

Repair

Replace the connecting rods bearings:

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.
No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the cylinder number 5 piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the piston cooling nozzle.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder number 5 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.
No Repair

Go to 9A

Go to 8E

Guided Step 8E - Inspect cylinder number 5 and adjacent cylinder main bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect cylinder number 5 and adjacent cylinder main bearings.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

Cylinder number 5 or immediately adjacent main bearings worn or damaged?
YES NO

Repair

Replace the main bearings as required (cylinder 5 or immediately adjacent cylinders). Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

No Repair

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electronic service tool.
  • Operate the engine for longer than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2522 is inactive.

Fault Code 2522 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Authorized Cummins® Repair Location if all steps have been completed and checked again.

Go to 9B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 03-Jan-2011


FAULT CODE 2527 - Engine Cylinder Number 6 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 146, 151, 155, 488, 1285, 1295, 1579, 1581, 1582, 2281, 2282, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2531 and 2532 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specifications?
STEP 3. | Check the kilowatt load reference signal calibration. |
 | STEP 3A. Check the kilowatt load transducer reference signal - where fitted. | Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
 | STEP 3B. Check the calibration of the generator set controller. | Generator set controller output voltage and ampere readings match the measured readings?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor resistances within specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor within specification?
STEP 6. | Check the quality of the natural gas supply to the generator set. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply quality within specification?
STEP 7. | Inspect cylinder number 6 cylinder head. |
 | STEP 7A. Check the cylinder number 6 spark plug. | Cylinder number 6 spark plug contaminated or damaged?
 | STEP 7B. Check the cylinder number 6 spark plug gap. | Cylinder number 6 spark plug gap excessive?
 | STEP 7C. Check the cylinder number 6 cylinder head. | Cylinder number 6 cylinder head gasket leaking or loose components?
 | STEP 7D. Check that the cylinder number 6 valve lash setting is correct. | Cylinder number 6 valve lash setting correct?
 | STEP 7E. Check the cylinder number 6 valve train. | Cylinder number 6 valve train wear?
STEP 8. | Inspect the cylinder number 6 power cylinder. |
 | STEP 8A. Inspect the oil filters for debris. | Debris present in the oil filters?
 | STEP 8B. Check the cylinder number 6 internal power cylinder. | Cylinder number 6 power cylinder damaged?
 | STEP 8C. Inspect the cylinder number 6 connecting rod bearings. | Cylinder number 6 connecting rod bearings worn or damaged?
 | STEP 8D. Inspect the cylinder number 6 piston cooling nozzle. | Cylinder number 6 piston cooling nozzle bent or broken?
 | STEP 8E. Check cylinder number1and adjacent cylinder main bearings. | Cylinder number 6 or immediately adjacent main bearings worn or damaged?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 2522 inactive?
 | STEP 9B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 146, 151, 155, 488, 1285, 1295, 1579, 1581, 1582, 2281, 2282, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2531, and 2532 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Use symptom tree t048 in Section TS in this manual.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electric service tool.
  • Connect an exhaust gas analyzer.
  • Operate the engine at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Check exhaust emissions.

  • Use an exhaust gas analyzer. Insert the sample probe into the exhaust gas manifold test port, check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specifications?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool and referencing to the exhaust gas analyzer, adjust the open and closed loop fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.

  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 9A

Guided Step 3 - Check the kilowatt load reference signal calibration.

Guided Step 3A - Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller kilowatt calibration.

Conditions

NOTE: If the generator set is not fitted with a kilowatt load transducer, proceed to Guided Step 3B.

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.
  • Connect INSITE™ electronic service tool.

Action

Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller displayed kilowatt calibration.

  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
YES NO
No Repair

Repair

INSITE™ electronic service tool, calibrate the kilowatt load sensor milliampere/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the calibration of the generator set controller.

Conditions

NOTE: This guided step should only be followed if the generator set is not fitted with a kilowatt load transducer.

  • Connect all components.
  • Connect a power analyzer or digital multimeter
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.

Action

Connect a power analyzer or digital multimeter to the alternator main output terminals.

  • Check that the generator set controller readings for output voltage (L1- L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller output voltage and ampere readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter to calibrate the generator set controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold temperature.

  • Use the generator set human machine interface (HMI) to check the intake manifold temperature. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold temperature within specification?
YES NO
No Repair

Repair

Check the following:

  • Check the temperature of the high temperature (HT) coolant outlet from the engine.
  • Check the temperature of the low temperature (LT) coolant outlet from the engine.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 018-018 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the intake manifold temperature sensor resistances.

  • NOTE: The intake manifold temperature sensor may have malfunctioned in range and the related fault codes will not be activated. Reference Fault Code 153 or Fault Code 154 in Section TF.
  • Refer to circuit diagram or wiring diagram for connector pin identification. Refer to Procedure 019-360 in Section 19.

Intake manifold temperature sensor resistances within specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor.

  • Refer to Procedure 019-059 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold pressure.

  • Use the generator set human machine interface (HMI) to check the intake manifold pressure. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold pressure within specification?
YES NO
No Repair

Repair

If fitted, check the operation of the compressor bypass valve (single turbocharger engines only).

  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the intake manifold pressure sensor.

NOTE: The intake manifold pressure sensor may have malfunctioned in-range and the related fault codes will not be activated.

  • Reference Fault Code 354 or Fault Code 355 in Section TF.
  • Refer to Procedure 019-359 in Section 19.

Intake manifold pressure sensor within specification?
YES NO
No Repair

Repair

Replace the intake manifold pressure sensor.

  • Refer to Procedure 019-061 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the generator set.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the quality of the natural gas supply.

  • Check the quality of the natural gas supplied to the generator set meets or exceeds minimum requirement for generator set (methane number and fuel contaminants limits).
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspect cylinder number 6 cylinder head.

Guided Step 7A - Check the cylinder number 6 spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug J connector damaged
  • Electrode has signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder number 6 spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug.
  • Replace the spark plug.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the cylinder number 6 spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Remove the spark plug and measure the spark plug electrode gap.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
  • Contact a Cummins® Authorized Repair Location.

Cylinder number 6 spark plug gap excessive?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7C

Guided Step 7C - Check the cylinder number 6 cylinder head.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect cylinder number 6 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder number 6 cylinder head.

Cylinder number 6 cylinder head gasket leaking or loose components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose components on or immediately around cylinder number 6 cylinder head. Reference the appropriate procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396.
No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check that the cylinder number 6 valve lash setting is correct.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder number 6 valve lash is correct.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder number 6 valve lash setting correct?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7E

Guided Step 7E - Check the cylinder number 6 valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the cylinder number 6 valve train for the following:

  • Intake or exhaust valve wear/recession or damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Camshaft follower wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder number 6 camshaft lobe wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Cylinder number 6 valve train wear?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft follower assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the camshaft. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

Adjust the valve lash. Reset the valve lash setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 9A

Go to 8A

Guided Step 8 - Inspect the cylinder number 6 power cylinder.

Guided Step 8A - Inspect the oil filters for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubrication oil filters. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filters and inspect for debris in the filter media.
  • Contact a Cummins® Authorized Repair Location.

Debris present in the oil filters?
YES | NO
No Repair | No Repair

Go to 8B

Go to 8D

Guided Step 8B - Check the cylinder number 6 internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the cylinder number 6 internal power cylinder.

Inspect the internal power cylinder for the following:

NOTE: If available, use a borescope to perform the inspections.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage.

Cylinder number 6 power cylinder damaged?
YES NO

Repair

Replace the piston rings. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.

Replace the liner. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-045 in Section 1.

Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the cylinder number 6 connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP.

Action

Inspect the cylinder number 6 connecting rod bearings for excessive wear or other damage.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder number 6 connecting rod bearings worn or damaged?
YES NO

Repair

Replace the connecting rods bearings:

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.
No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the cylinder number 6 piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the piston cooling nozzle.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder number 6 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.
No Repair

Go to 9A

Go to 8E

Guided Step 8E - Inspect cylinder number 6 and adjacent cylinder main bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect cylinder number 6 and adjacent cylinder main bearings.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

Cylinder number 6 or immediately adjacent main bearings worn or damaged?
YES NO

Repair

Replace the main bearings as required (cylinder 6 or immediately adjacent cylinders). Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

No Repair

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electronic service tool.
  • Operate the engine for longer than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2522 is inactive.

Fault Code 2522 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Authorized Cummins® Repair Location if all steps have been completed and checked again.

Go to 9B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 03-Jan-2011


FAULT CODE 2528 - Engine Cylinder Number 7 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 146, 151, 155, 488, 1285, 1295, 1579, 1581, 1582, 2281, 2282, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2531 and 2532 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specifications?
STEP 3. | Check the kilowatt load reference signal calibration. |
 | STEP 3A. Check the kilowatt load transducer reference signal - where fitted. | Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
 | STEP 3B. Check the calibration of the generator set controller. | Generator set controller output voltage and ampere readings match the measured readings?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor resistances within specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor within specification?
STEP 6. | Check the quality of the natural gas supply to the generator set. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply quality within specification?
STEP 7. | Inspect cylinder number 7 cylinder head. |
 | STEP 7A. Check the cylinder number 7 spark plug. | Cylinder number 7 spark plug contaminated or damaged?
 | STEP 7B. Check the cylinder number 7 spark plug gap. | Cylinder number 7 spark plug gap excessive?
 | STEP 7C. Check the cylinder number 7 cylinder head. | Cylinder number 7 cylinder head gasket leaking or loose components?
 | STEP 7D. Check that the cylinder number 7 valve lash setting is correct. | Cylinder number 7 valve lash setting correct?
 | STEP 7E. Check the cylinder number 7 valve train. | Cylinder number 7 valve train wear?
STEP 8. | Inspect the cylinder number 7 power cylinder. |
 | STEP 8A. Inspect the oil filters for debris. | Debris present in the oil filters?
 | STEP 8B. Check the cylinder number 7 internal power cylinder. | Cylinder number 7 power cylinder damaged?
 | STEP 8C. Inspect the cylinder number 7 connecting rod bearings. | Cylinder number 7 connecting rod bearings worn or damaged?
 | STEP 8D. Inspect the cylinder number 7 piston cooling nozzle. | Cylinder number 7 piston cooling nozzle bent or broken?
 | STEP 8E. Check cylinder number1and adjacent cylinder main bearings. | Cylinder number 7 or immediately adjacent main bearings worn or damaged?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 2522 inactive?
 | STEP 9B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 146, 151, 155, 488, 1285, 1295, 1579, 1581, 1582, 2281, 2282, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2531, and 2532 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Use symptom tree t048 in Section TS in this manual.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electric service tool.
  • Connect an exhaust gas analyzer.
  • Operate the engine at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Check exhaust emissions.

  • Use an exhaust gas analyzer. Insert the sample probe into the exhaust gas manifold test port, check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specifications?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool and referencing to the exhaust gas analyzer, adjust the open and closed loop fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.

  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 9A

Guided Step 3 - Check the kilowatt load reference signal calibration.

Guided Step 3A - Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller kilowatt calibration.

Conditions

NOTE: If the generator set is not fitted with a kilowatt load transducer, proceed to Guided Step 3B.

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.
  • Connect INSITE™ electronic service tool.

Action

Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller displayed kilowatt calibration.

  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
YES NO
No Repair

Repair

INSITE™ electronic service tool, calibrate the kilowatt load sensor milliampere/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the calibration of the generator set controller.

Conditions

NOTE: This guided step should only be followed if the generator set is not fitted with a kilowatt load transducer.

  • Connect all components.
  • Connect a power analyzer or digital multimeter
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.

Action

Connect a power analyzer or digital multimeter to the alternator main output terminals.

  • Check that the generator set controller readings for output voltage (L1- L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller output voltage and ampere readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter to calibrate the generator set controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold temperature.

  • Use the generator set human machine interface (HMI) to check the intake manifold temperature. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold temperature within specification?
YES NO
No Repair

Repair

Check the following:

  • Check the temperature of the high temperature (HT) coolant outlet from the engine.
  • Check the temperature of the low temperature (LT) coolant outlet from the engine.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 018-018 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the intake manifold temperature sensor resistances.

  • NOTE: The intake manifold temperature sensor may have malfunctioned in range and the related fault codes will not be activated. Reference Fault Code 153 or Fault Code 154 in Section TF.
  • Refer to circuit diagram or wiring diagram for connector pin identification. Refer to Procedure 019-360 in Section 19.

Intake manifold temperature sensor resistances within specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor.

  • Refer to Procedure 019-059 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold pressure.

  • Use the generator set human machine interface (HMI) to check the intake manifold pressure. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold pressure within specification?
YES NO
No Repair

Repair

If fitted, check the operation of the compressor bypass valve (single turbocharger engines only).

  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the intake manifold pressure sensor.

NOTE: The intake manifold pressure sensor may have malfunctioned in-range and the related fault codes will not be activated.

  • Reference Fault Code 354 or Fault Code 355 in Section TF.
  • Refer to Procedure 019-359 in Section 19.

Intake manifold pressure sensor within specification?
YES NO
No Repair

Repair

Replace the intake manifold pressure sensor.

  • Refer to Procedure 019-061 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the generator set.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the quality of the natural gas supply.

  • Check the quality of the natural gas supplied to the generator set meets or exceeds minimum requirement for generator set (methane number and fuel contaminants limits).
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspect cylinder number 7 cylinder head.

Guided Step 7A - Check the cylinder number 7 spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug J connector damaged
  • Electrode has signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder number 7 spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug.
  • Replace the spark plug.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the cylinder number 7 spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Remove the spark plug and measure the spark plug electrode gap.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
  • Contact a Cummins® Authorized Repair Location.

Cylinder number 7 spark plug gap excessive?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7C

Guided Step 7C - Check the cylinder number 7 cylinder head.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect cylinder number 7 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder number 7 cylinder head.

Cylinder number 7 cylinder head gasket leaking or loose components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose components on or immediately around cylinder number 7 cylinder head. Reference the appropriate procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396.
No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check that the cylinder number 7 valve lash setting is correct.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder number 7 valve lash is correct.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder number 7 valve lash setting correct?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7E

Guided Step 7E - Check the cylinder number 7 valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the cylinder number 7 valve train for the following:

  • Intake or exhaust valve wear/recession or damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Camshaft follower wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder number 7 camshaft lobe wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Cylinder number 7 valve train wear?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft follower assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the camshaft. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

Adjust the valve lash. Reset the valve lash setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 9A

Go to 8A

Guided Step 8 - Inspect the cylinder number 7 power cylinder.

Guided Step 8A - Inspect the oil filters for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubrication oil filters. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filters and inspect for debris in the filter media.
  • Contact a Cummins® Authorized Repair Location.

Debris present in the oil filters?
YES | NO
No Repair | No Repair

Go to 8B

Go to 8D

Guided Step 8B - Check the cylinder number 7 internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the cylinder number 7 internal power cylinder.

Inspect the internal power cylinder for the following:

NOTE: If available, use a borescope to perform the inspections.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage.

Cylinder number 7 power cylinder damaged?
YES NO

Repair

Replace the piston rings. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.

Replace the liner. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-045 in Section 1.

Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the cylinder number 7 connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP.

Action

Inspect the cylinder number 7 connecting rod bearings for excessive wear or other damage.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder number 7 connecting rod bearings worn or damaged?
YES NO

Repair

Replace the connecting rods bearings:

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.
No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the cylinder number 7 piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the piston cooling nozzle.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder number 7 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.
No Repair

Go to 9A

Go to 8E

Guided Step 8E - Inspect cylinder number 7 and adjacent cylinder main bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect cylinder number 7 and adjacent cylinder main bearings.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

Cylinder number 7 or immediately adjacent main bearings worn or damaged?
YES NO

Repair

Replace the main bearings as required (cylinder 7 or immediately adjacent cylinders). Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

No Repair

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electronic service tool.
  • Operate the engine for longer than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2522 is inactive.

Fault Code 2522 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Authorized Cummins® Repair Location if all steps have been completed and checked again.

Go to 9B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 03-Jan-2011


FAULT CODE 2529 - Engine Cylinder Number 8 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 146, 151, 155, 488, 1285, 1295, 1579, 1581, 1582, 2281, 2282, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2531 and 2532 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specifications?
STEP 3. | Check the kilowatt load reference signal calibration. |
 | STEP 3A. Check the kilowatt load transducer reference signal - where fitted. | Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
 | STEP 3B. Check the calibration of the generator set controller. | Generator set controller output voltage and ampere readings match the measured readings?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor resistances within specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor within specification?
STEP 6. | Check the quality of the natural gas supply to the generator set. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply quality within specification?
STEP 7. | Inspect cylinder number 8 cylinder head. |
 | STEP 7A. Check the cylinder number 8 spark plug. | Cylinder number 8 spark plug contaminated or damaged?
 | STEP 7B. Check the cylinder number 8 spark plug gap. | Cylinder number 8 spark plug gap excessive?
 | STEP 7C. Check the cylinder number 8 cylinder head. | Cylinder number 8 cylinder head gasket leaking or loose components?
 | STEP 7D. Check that the cylinder number 8 valve lash setting is correct. | Cylinder number 8 valve lash setting correct?
 | STEP 7E. Check the cylinder number 8 valve train. | Cylinder number 8 valve train wear?
STEP 8. | Inspect the cylinder number 8 power cylinder. |
 | STEP 8A. Inspect the oil filters for debris. | Debris present in the oil filters?
 | STEP 8B. Check the cylinder number 8 internal power cylinder. | Cylinder number 8 power cylinder damaged?
 | STEP 8C. Inspect the cylinder number 8 connecting rod bearings. | Cylinder number 8 connecting rod bearings worn or damaged?
 | STEP 8D. Inspect the cylinder number 8 piston cooling nozzle. | Cylinder number 8 piston cooling nozzle bent or broken?
 | STEP 8E. Check cylinder number1and adjacent cylinder main bearings. | Cylinder number 8 or immediately adjacent main bearings worn or damaged?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 2522 inactive?
 | STEP 9B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 146, 151, 155, 488, 1285, 1295, 1579, 1581, 1582, 2281, 2282, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2531, and 2532 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Use symptom tree t048 in Section TS in this manual.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electric service tool.
  • Connect an exhaust gas analyzer.
  • Operate the engine at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Check exhaust emissions.

  • Use an exhaust gas analyzer. Insert the sample probe into the exhaust gas manifold test port, check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specifications?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool and referencing to the exhaust gas analyzer, adjust the open and closed loop fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.

  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 9A

Guided Step 3 - Check the kilowatt load reference signal calibration.

Guided Step 3A - Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller kilowatt calibration.

Conditions

NOTE: If the generator set is not fitted with a kilowatt load transducer, proceed to Guided Step 3B.

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.
  • Connect INSITE™ electronic service tool.

Action

Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller displayed kilowatt calibration.

  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
YES NO
No Repair

Repair

INSITE™ electronic service tool, calibrate the kilowatt load sensor milliampere/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the calibration of the generator set controller.

Conditions

NOTE: This guided step should only be followed if the generator set is not fitted with a kilowatt load transducer.

  • Connect all components.
  • Connect a power analyzer or digital multimeter
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.

Action

Connect a power analyzer or digital multimeter to the alternator main output terminals.

  • Check that the generator set controller readings for output voltage (L1- L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller output voltage and ampere readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter to calibrate the generator set controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold temperature.

  • Use the generator set human machine interface (HMI) to check the intake manifold temperature. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold temperature within specification?
YES NO
No Repair

Repair

Check the following:

  • Check the temperature of the high temperature (HT) coolant outlet from the engine.
  • Check the temperature of the low temperature (LT) coolant outlet from the engine.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 018-018 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the intake manifold temperature sensor resistances.

  • NOTE: The intake manifold temperature sensor may have malfunctioned in range and the related fault codes will not be activated. Reference Fault Code 153 or Fault Code 154 in Section TF.
  • Refer to circuit diagram or wiring diagram for connector pin identification. Refer to Procedure 019-360 in Section 19.

Intake manifold temperature sensor resistances within specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor.

  • Refer to Procedure 019-059 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold pressure.

  • Use the generator set human machine interface (HMI) to check the intake manifold pressure. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold pressure within specification?
YES NO
No Repair

Repair

If fitted, check the operation of the compressor bypass valve (single turbocharger engines only).

  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the intake manifold pressure sensor.

NOTE: The intake manifold pressure sensor may have malfunctioned in-range and the related fault codes will not be activated.

  • Reference Fault Code 354 or Fault Code 355 in Section TF.
  • Refer to Procedure 019-359 in Section 19.

Intake manifold pressure sensor within specification?
YES NO
No Repair

Repair

Replace the intake manifold pressure sensor.

  • Refer to Procedure 019-061 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the generator set.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the quality of the natural gas supply.

  • Check the quality of the natural gas supplied to the generator set meets or exceeds minimum requirement for generator set (methane number and fuel contaminants limits).
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspect cylinder number 8 cylinder head.

Guided Step 7A - Check the cylinder number 8 spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug J connector damaged
  • Electrode has signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder number 8 spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug.
  • Replace the spark plug.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the cylinder number 8 spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Remove the spark plug and measure the spark plug electrode gap.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
  • Contact a Cummins® Authorized Repair Location.

Cylinder number 8 spark plug gap excessive?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7C

Guided Step 7C - Check the cylinder number 8 cylinder head.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect cylinder number 8 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder number 8 cylinder head.

Cylinder number 8 cylinder head gasket leaking or loose components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose components on or immediately around cylinder number 8 cylinder head. Reference the appropriate procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396.
No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check that the cylinder number 8 valve lash setting is correct.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder number 8 valve lash is correct.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder number 8 valve lash setting correct?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7E

Guided Step 7E - Check the cylinder number 8 valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the cylinder number 8 valve train for the following:

  • Intake or exhaust valve wear/recession or damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Camshaft follower wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder number 8 camshaft lobe wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Cylinder number 8 valve train wear?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft follower assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the camshaft. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

Adjust the valve lash. Reset the valve lash setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 9A

Go to 8A

Guided Step 8 - Inspect the cylinder number 8 power cylinder.

Guided Step 8A - Inspect the oil filters for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubrication oil filters. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filters and inspect for debris in the filter media.
  • Contact a Cummins® Authorized Repair Location.

Debris present in the oil filters?
YES | NO
No Repair | No Repair

Go to 8B

Go to 8D

Guided Step 8B - Check the cylinder number 8 internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the cylinder number 8 internal power cylinder.

Inspect the internal power cylinder for the following:

NOTE: If available, use a borescope to perform the inspections.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage.

Cylinder number 8 power cylinder damaged?
YES NO

Repair

Replace the piston rings. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.

Replace the liner. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-045 in Section 1.

Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the cylinder number 8 connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP.

Action

Inspect the cylinder number 8 connecting rod bearings for excessive wear or other damage.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder number 8 connecting rod bearings worn or damaged?
YES NO

Repair

Replace the connecting rods bearings:

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.
No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the cylinder number 8 piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the piston cooling nozzle.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder number 8 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.
No Repair

Go to 9A

Go to 8E

Guided Step 8E - Inspect cylinder number 8 and adjacent cylinder main bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect cylinder number 8 and adjacent cylinder main bearings.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

Cylinder number 8 or immediately adjacent main bearings worn or damaged?
YES NO

Repair

Replace the main bearings as required (cylinder 8 or immediately adjacent cylinders). Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

No Repair

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electronic service tool.
  • Operate the engine for longer than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2522 is inactive.

Fault Code 2522 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Authorized Cummins® Repair Location if all steps have been completed and checked again.

Go to 9B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 03-Jan-2011


FAULT CODE 2531 - Engine Cylinder Number 9 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 146, 151, 155, 488, 1285, 1295, 1579, 1581, 1582, 2281, 2282, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2531 and 2532 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specifications?
STEP 3. | Check the kilowatt load reference signal calibration. |
 | STEP 3A. Check the kilowatt load transducer reference signal - where fitted. | Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
 | STEP 3B. Check the calibration of the generator set controller. | Generator set controller output voltage and ampere readings match the measured readings?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor resistances within specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor within specification?
STEP 6. | Check the quality of the natural gas supply to the generator set. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply quality within specification?
STEP 7. | Inspect cylinder number 9 cylinder head. |
 | STEP 7A. Check the cylinder number 9 spark plug. | Cylinder number 9 spark plug contaminated or damaged?
 | STEP 7B. Check the cylinder number 9 spark plug gap. | Cylinder number 9 spark plug gap excessive?
 | STEP 7C. Check the cylinder number 9 cylinder head. | Cylinder number 9 cylinder head gasket leaking or loose components?
 | STEP 7D. Check that the cylinder number 9 valve lash setting is correct. | Cylinder number 9 valve lash setting correct?
 | STEP 7E. Check the cylinder number 9 valve train. | Cylinder number 9 valve train wear?
STEP 8. | Inspect the cylinder number 9 power cylinder. |
 | STEP 8A. Inspect the oil filters for debris. | Debris present in the oil filters?
 | STEP 8B. Check the cylinder number 9 internal power cylinder. | Cylinder number 9 power cylinder damaged?
 | STEP 8C. Inspect the cylinder number 9 connecting rod bearings. | Cylinder number 9 connecting rod bearings worn or damaged?
 | STEP 8D. Inspect the cylinder number 9 piston cooling nozzle. | Cylinder number 9 piston cooling nozzle bent or broken?
 | STEP 8E. Check cylinder number1and adjacent cylinder main bearings. | Cylinder number 9 or immediately adjacent main bearings worn or damaged?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 2522 inactive?
 | STEP 9B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 146, 151, 155, 488, 1285, 1295, 1579, 1581, 1582, 2281, 2282, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2531, and 2532 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Use symptom tree t048 in Section TS in this manual.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electric service tool.
  • Connect an exhaust gas analyzer.
  • Operate the engine at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Check exhaust emissions.

  • Use an exhaust gas analyzer. Insert the sample probe into the exhaust gas manifold test port, check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specifications?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool and referencing to the exhaust gas analyzer, adjust the open and closed loop fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.

  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 9A

Guided Step 3 - Check the kilowatt load reference signal calibration.

Guided Step 3A - Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller kilowatt calibration.

Conditions

NOTE: If the generator set is not fitted with a kilowatt load transducer, proceed to Guided Step 3B.

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.
  • Connect INSITE™ electronic service tool.

Action

Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller displayed kilowatt calibration.

  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
YES NO
No Repair

Repair

INSITE™ electronic service tool, calibrate the kilowatt load sensor milliampere/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the calibration of the generator set controller.

Conditions

NOTE: This guided step should only be followed if the generator set is not fitted with a kilowatt load transducer.

  • Connect all components.
  • Connect a power analyzer or digital multimeter
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.

Action

Connect a power analyzer or digital multimeter to the alternator main output terminals.

  • Check that the generator set controller readings for output voltage (L1- L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller output voltage and ampere readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter to calibrate the generator set controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold temperature.

  • Use the generator set human machine interface (HMI) to check the intake manifold temperature. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold temperature within specification?
YES NO
No Repair

Repair

Check the following:

  • Check the temperature of the high temperature (HT) coolant outlet from the engine.
  • Check the temperature of the low temperature (LT) coolant outlet from the engine.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 018-018 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the intake manifold temperature sensor resistances.

  • NOTE: The intake manifold temperature sensor may have malfunctioned in range and the related fault codes will not be activated. Reference Fault Code 153 or Fault Code 154 in Section TF.
  • Refer to circuit diagram or wiring diagram for connector pin identification. Refer to Procedure 019-360 in Section 19.

Intake manifold temperature sensor resistances within specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor.

  • Refer to Procedure 019-059 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold pressure.

  • Use the generator set human machine interface (HMI) to check the intake manifold pressure. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold pressure within specification?
YES NO
No Repair

Repair

If fitted, check the operation of the compressor bypass valve (single turbocharger engines only).

  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the intake manifold pressure sensor.

NOTE: The intake manifold pressure sensor may have malfunctioned in-range and the related fault codes will not be activated.

  • Reference Fault Code 354 or Fault Code 355 in Section TF.
  • Refer to Procedure 019-359 in Section 19.

Intake manifold pressure sensor within specification?
YES NO
No Repair

Repair

Replace the intake manifold pressure sensor.

  • Refer to Procedure 019-061 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the generator set.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the quality of the natural gas supply.

  • Check the quality of the natural gas supplied to the generator set meets or exceeds minimum requirement for generator set (methane number and fuel contaminants limits).
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspect cylinder number 9 cylinder head.

Guided Step 7A - Check the cylinder number 9 spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug J connector damaged
  • Electrode has signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder number 9 spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug.
  • Replace the spark plug.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the cylinder number 9 spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Remove the spark plug and measure the spark plug electrode gap.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
  • Contact a Cummins® Authorized Repair Location.

Cylinder number 9 spark plug gap excessive?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7C

Guided Step 7C - Check the cylinder number 9 cylinder head.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect cylinder number 9 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder number 9 cylinder head.

Cylinder number 9 cylinder head gasket leaking or loose components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose components on or immediately around cylinder number 9 cylinder head. Reference the appropriate procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396.
No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check that the cylinder number 9 valve lash setting is correct.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder number 9 valve lash is correct.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder number 9 valve lash setting correct?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7E

Guided Step 7E - Check the cylinder number 9 valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the cylinder number 9 valve train for the following:

  • Intake or exhaust valve wear/recession or damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Camshaft follower wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder number 9 camshaft lobe wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Cylinder number 9 valve train wear?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft follower assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the camshaft. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

Adjust the valve lash. Reset the valve lash setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 9A

Go to 8A

Guided Step 8 - Inspect the cylinder number 9 power cylinder.

Guided Step 8A - Inspect the oil filters for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubrication oil filters. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filters and inspect for debris in the filter media.
  • Contact a Cummins® Authorized Repair Location.

Debris present in the oil filters?
YES | NO
No Repair | No Repair

Go to 8B

Go to 8D

Guided Step 8B - Check the cylinder number 9 internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the cylinder number 9 internal power cylinder.

Inspect the internal power cylinder for the following:

NOTE: If available, use a borescope to perform the inspections.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage.

Cylinder number 9 power cylinder damaged?
YES NO

Repair

Replace the piston rings. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.

Replace the liner. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-045 in Section 1.

Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the cylinder number 9 connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP.

Action

Inspect the cylinder number 9 connecting rod bearings for excessive wear or other damage.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder number 9 connecting rod bearings worn or damaged?
YES NO

Repair

Replace the connecting rods bearings:

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.
No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the cylinder number 9 piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the piston cooling nozzle.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder number 9 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.
No Repair

Go to 9A

Go to 8E

Guided Step 8E - Inspect cylinder number 9 and adjacent cylinder main bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect cylinder number 9 and adjacent cylinder main bearings.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

Cylinder number 9 or immediately adjacent main bearings worn or damaged?
YES NO

Repair

Replace the main bearings as required (cylinder 9 or immediately adjacent cylinders). Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

No Repair

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electronic service tool.
  • Operate the engine for longer than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2522 is inactive.

Fault Code 2522 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Authorized Cummins® Repair Location if all steps have been completed and checked again.

Go to 9B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 03-Jan-2011


FAULT CODE 2532 - Engine Cylinder Number 10 Knock - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 146, 151, 155, 488, 1285, 1295, 1579, 1581, 1582, 2281, 2282, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2531 and 2532 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specifications?
STEP 3. | Check the kilowatt load reference signal calibration. |
 | STEP 3A. Check the kilowatt load transducer reference signal - where fitted. | Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
 | STEP 3B. Check the calibration of the generator set controller. | Generator set controller output voltage and ampere readings match the measured readings?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor resistances within specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor within specification?
STEP 6. | Check the quality of the natural gas supply to the generator set. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply quality within specification?
STEP 7. | Inspect cylinder number 10 cylinder head. |
 | STEP 7A. Check the cylinder number 10 spark plug. | Cylinder number 10 spark plug contaminated or damaged?
 | STEP 7B. Check the cylinder number 10 spark plug gap. | Cylinder number 10 spark plug gap excessive?
 | STEP 7C. Check the cylinder number 10 cylinder head. | Cylinder number 10 cylinder head gasket leaking or loose components?
 | STEP 7D. Check that the cylinder number 10 valve lash setting is correct. | Cylinder number 10 valve lash setting correct?
 | STEP 7E. Check the cylinder number 10 valve train. | Cylinder number 10 valve train wear?
STEP 8. | Inspect the cylinder number 10 power cylinder. |
 | STEP 8A. Inspect the oil filters for debris. | Debris present in the oil filters?
 | STEP 8B. Check the cylinder number 10 internal power cylinder. | Cylinder number 10 power cylinder damaged?
 | STEP 8C. Inspect the cylinder number 10 connecting rod bearings. | Cylinder number 10 connecting rod bearings worn or damaged?
 | STEP 8D. Inspect the cylinder number 10 piston cooling nozzle. | Cylinder number 10 piston cooling nozzle bent or broken?
 | STEP 8E. Check cylinder number1and adjacent cylinder main bearings. | Cylinder number 10 or immediately adjacent main bearings worn or damaged?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 2522 inactive?
 | STEP 9B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 146, 151, 155, 488, 1285, 1295, 1579, 1581, 1582, 2281, 2282, 2522, 2523, 2524, 2525, 2526, 2527, 2528, 2529, 2531, and 2532 active?

YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Use symptom tree t048 in Section TS in this manual.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electric service tool.
  • Connect an exhaust gas analyzer.
  • Operate the engine at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Check exhaust emissions.

  • Use an exhaust gas analyzer. Insert the sample probe into the exhaust gas manifold test port, check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specifications?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool and referencing to the exhaust gas analyzer, adjust the open and closed loop fueling offsets so that the NOx and O2 emissions meet the fuel rating specification for the engine.

  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 9A

Guided Step 3 - Check the kilowatt load reference signal calibration.

Guided Step 3A - Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller kilowatt calibration.

Conditions

NOTE: If the generator set is not fitted with a kilowatt load transducer, proceed to Guided Step 3B.

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.
  • Connect INSITE™ electronic service tool.

Action

Check the kilowatt load transducer-sensed kilowatt calibration against the generator set controller displayed kilowatt calibration.

  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer-sensed kilowatt calibration matches generator set controller kilowatt calibration?
YES NO
No Repair

Repair

INSITE™ electronic service tool, calibrate the kilowatt load sensor milliampere/load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the calibration of the generator set controller.

Conditions

NOTE: This guided step should only be followed if the generator set is not fitted with a kilowatt load transducer.

  • Connect all components.
  • Connect a power analyzer or digital multimeter
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode with load available.

Action

Connect a power analyzer or digital multimeter to the alternator main output terminals.

  • Check that the generator set controller readings for output voltage (L1- L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller output voltage and ampere readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter to calibrate the generator set controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold temperature.

  • Use the generator set human machine interface (HMI) to check the intake manifold temperature. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold temperature within specification?
YES NO
No Repair

Repair

Check the following:

  • Check the temperature of the high temperature (HT) coolant outlet from the engine.
  • Check the temperature of the low temperature (LT) coolant outlet from the engine.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 018-018 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the intake manifold temperature sensor resistances.

  • NOTE: The intake manifold temperature sensor may have malfunctioned in range and the related fault codes will not be activated. Reference Fault Code 153 or Fault Code 154 in Section TF.
  • Refer to circuit diagram or wiring diagram for connector pin identification. Refer to Procedure 019-360 in Section 19.

Intake manifold temperature sensor resistances within specification?
YES NO
No Repair

Repair

Replace the intake manifold temperature sensor.

  • Refer to Procedure 019-059 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate the engine at maximum possible load with no knock present.

Action

Check the intake manifold pressure.

  • Use the generator set human machine interface (HMI) to check the intake manifold pressure. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold pressure within specification?
YES NO
No Repair

Repair

If fitted, check the operation of the compressor bypass valve (single turbocharger engines only).

  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the intake manifold pressure sensor.

NOTE: The intake manifold pressure sensor may have malfunctioned in-range and the related fault codes will not be activated.

  • Reference Fault Code 354 or Fault Code 355 in Section TF.
  • Refer to Procedure 019-359 in Section 19.

Intake manifold pressure sensor within specification?
YES NO
No Repair

Repair

Replace the intake manifold pressure sensor.

  • Refer to Procedure 019-061 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the generator set.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the quality of the natural gas supply.

  • Check the quality of the natural gas supplied to the generator set meets or exceeds minimum requirement for generator set (methane number and fuel contaminants limits).
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspect cylinder number 10 cylinder head.

Guided Step 7A - Check the cylinder number 10 spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug J connector damaged
  • Electrode has signs of oil contamination
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Cylinder number 10 spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug.
  • Replace the spark plug.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the cylinder number 10 spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Remove the spark plug and measure the spark plug electrode gap.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
  • Contact a Cummins® Authorized Repair Location.

Cylinder number 10 spark plug gap excessive?
YES NO

Repair

Replace the spark plug.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7C

Guided Step 7C - Check the cylinder number 10 cylinder head.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect cylinder number 10 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder number 10 cylinder head.

Cylinder number 10 cylinder head gasket leaking or loose components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose components on or immediately around cylinder number 10 cylinder head. Reference the appropriate procedures in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396.
No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check that the cylinder number 10 valve lash setting is correct.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check cylinder number 10 valve lash is correct.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder number 10 valve lash setting correct?
YES | NO
No Repair | No Repair

Go to 8A

Go to 7E

Guided Step 7E - Check the cylinder number 10 valve train.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the cylinder number 10 valve train for the following:

  • Intake or exhaust valve wear/recession or damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Camshaft follower wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder number 10 camshaft lobe wear. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Cylinder number 10 valve train wear?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft follower assembly. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the camshaft. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

Adjust the valve lash. Reset the valve lash setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 9A

Go to 8A

Guided Step 8 - Inspect the cylinder number 10 power cylinder.

Guided Step 8A - Inspect the oil filters for debris.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubrication oil filters. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filters and inspect for debris in the filter media.
  • Contact a Cummins® Authorized Repair Location.

Debris present in the oil filters?
YES | NO
No Repair | No Repair

Go to 8B

Go to 8D

Guided Step 8B - Check the cylinder number 10 internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the cylinder number 10 internal power cylinder.

Inspect the internal power cylinder for the following:

NOTE: If available, use a borescope to perform the inspections.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage.

Cylinder number 10 power cylinder damaged?
YES NO

Repair

Replace the piston rings. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.

Replace the liner. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-045 in Section 1.

Replace the cylinder head. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the cylinder number 10 connecting rod bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP.

Action

Inspect the cylinder number 10 connecting rod bearings for excessive wear or other damage.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder number 10 connecting rod bearings worn or damaged?
YES NO

Repair

Replace the connecting rods bearings:

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.
No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the cylinder number 10 piston cooling nozzle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the piston cooling nozzle.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder number 10 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.
No Repair

Go to 9A

Go to 8E

Guided Step 8E - Inspect cylinder number 10 and adjacent cylinder main bearings.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect cylinder number 10 and adjacent cylinder main bearings.

  • Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

Cylinder number 10 or immediately adjacent main bearings worn or damaged?
YES NO

Repair

Replace the main bearings as required (cylinder 10 or immediately adjacent cylinders). Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-006 in Section 1.

No Repair

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Connect INSITE™ electronic service tool.
  • Operate the engine for longer than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2522 is inactive.

Fault Code 2522 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Authorized Cummins® Repair Location if all steps have been completed and checked again.

Go to 9B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 03-Jan-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2544 active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect the electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for greater than one minute.

Action

Check the ECM.

  • Use the electronic service tool to read the active fault codes.

Fault Code 2544 active?
YES NO

Repair

Allow the ECM to cool and then restart the engine. If the fault reoccurs, contact a local authorized service location.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


FAULT CODE 2553 - Engine Oil Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active Fault Code 2553. | Fault Code 2553 active?
 | STEP 1B. Check for multiple active/inactive fault codes. | Fault Codes 137, 143, 219, 415, 481, 555, 556, 1362, 1785, 1787, 1788, 1825 and/or 3491 active/inactive?
STEP 2. | Check the engine oil day tank. |
 | STEP 2A. Check the oil level within the engine oil day tank. | Engine oil day tank oil level low?
 | STEP 2B. Check for oil flow between the engine oil day tank and the Murphy® oil level switch. | Oil flow from engine oil day tank to the Murphy® oil level switch?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 2553 inactive?
 | STEP 3B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active Fault Code 2553.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2553.

  • Use INSITE™ electronic service tool to verify Fault Code 2553 is active.

Fault Code 2553 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 1B

Guided Step 1B - Check for multiple active/inactive fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for multiple active/inactive fault codes.

  • Use INSITE™ electronic service tool to read the multiple active/inactive fault codes.

Fault Codes 137, 143, 219, 415, 481, 555, 556, 1362, 1785, 1787, 1788, 1825, and/or 3491 active/inactive?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active/inactive fault codes or contact a Cummins® Authorized Repair Location.

 No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the engine oil day tank.

Guided Step 2A - Check the oil level within the engine oil day tank.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Check the oil level within the engine oil day tank.

  • Visually check the oil level in the engine oil day tank.

Engine oil day tank oil level low?
YES NO

Repair

  • Use the following procedure for lubricating oil recommendations and specifications in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-003 in Section V.
  • Contact a Cummins® Authorized Repair Location.
 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for oil flow between the engine oil day tank and the Murphy® oil level switch.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Check for oil flow between the engine oil day tank and the Murphy® oil level switch.

  • Temporarily disconnect the oil supply pipe from the engine oil day tank to the Murphy® oil level switch from the connection at the Murphy® oil level switch
  • Use a suitable container to catch the oil to check that there is a good flow of oil from the engine oil day tank.
  • Contact a Cummins® Authorized Repair Location.

Oil flow from engine oil day tank to the Murphy® oil level switch?
YES NO
No Repair

Repair

Poor or no oil flow has been detected between the engine oil day tank and the Murphy® oil level switch. Check for the following conditions:

  • Engine oil day tank to Murphy® oil level switch oil supply pipe - isolation valve fully open.
  • Engine oil day tank - no blockages at oil outlet, i.e. foreign matter, etc.
  • Engine oil day tank to Murphy® oil level switch oil supply pipe - no restrictions caused by routing or securing of flexible pipe work.
  • Engine oil day tank to Murphy® oil level switch oil supply pipe - no restrictions caused by internal blockages.
  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2553 is inactive.

Fault Code 2553 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 10-Feb-2011


FAULT CODE 2568 - Gas Supply Pressure (Regulated) - Data Valid But Above Normal Operational Range - Most Severe Level

Associated Procedures

Cautions and Warnings

WARNING

In most countries, inspection, repair, and adjustment of Natural Gas supply systems and components can only be undertaken by qualified and certified personnel. In many regions, accreditation to a nationally recognized trade organization is also required. It is necessary to comply with all local and national codes and legislation when performing these maintenance procedures.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3162898 - pressure sensor breakout cable, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for the fault codes. |
 | STEP 1A. Check for multiple active fault codes. | Fault Codes 1839 or 1841 active?
 | STEP 1B. Check for an active fault code. | Fault Code 2568 active?
STEP 2. | Check the fuel supply pressure. |
 | STEP 2A. Check the fuel supply pressure at the inlet to the fuel control valve. | Fuel supply pressure 130 - 150 mBar [1.885 - 2.176 psi]?
STEP 3. | Check the fuel supply pressure sensor. |
 | STEP 3A. Check the fuel supply pressure sensor and harness connector. | Dirty or damaged pins?
 | STEP 3B. Verify the engine fuel supply pressure sensor reading. | Fuel pressure within 5 percent?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 2568 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 1839 or 1841 active?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 4A

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2568 active?
YES NO

Repair

Proceed to the next troubleshooting step or contact a Cummins® Authorized Repair Location.

 No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel supply pressure.

Guided Step 2A - Check the fuel supply pressure at the inlet to the fuel control valve.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode. Engine operating at no load for greater than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Check the fuel supply pressure at the inlet to the fuel control valve.

  • Use INSITE™ electronic service tool to verify the fuel inlet pressure at the fuel control valve.

Fuel supply pressure 130 - 150 mBar [1.885 - 2.176 psi]?
YES NO
No Repair

Repair

High pressure has been detected at the intake to the fuel control valve.

  • Adjust the fuel supply pressure to between 150 - 180 mBar [2.176 -2.611 psi] at the outlet of the fuel supply pressure regulator.
  • Repair or replace the malfunctioning fuel supply pressure regulator. Use the following procedures for information on the fuel control valve in the QSK60G Generator Set CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 005-042 in Section 5.

Go to 4A

Go to 3A

Guided Step 3 - Check the fuel supply pressure sensor.

Guided Step 3A - Check the fuel supply pressure sensor and harness connector.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness from the fuel supply pressure sensor.

Action

Inspect the gas valve/fuel supply pressure sensor harness and fuel supply pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the gas valve harness, the harness connector, or the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pin. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the gas valve wiring harness. Contact a Cummins® Authorized Repair Location.
  • Replace the fuel supply pressure sensor. Contact a Cummins® Authorized Repair Location.
 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Verify the engine fuel supply pressure sensor reading.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode. Engine operating at no load for greater than 1 minute
  • Connect INSITE™ electronic service tool
  • Connect a mechanical manometer/pressure gauge to the gas pressure test point immediately after the fuel supply gas pressure regulator.

Note: The mechanical manometer/pressure gauge used for this test must be approved for use with natural gas systems.

Action

Verify the engine fuel supply pressure reading.

  • Use INSITE™ electronic service tool to monitor the fuel supply pressure sensor value.
  • Compare the electronic reading with the fuel supply pressure displayed on the mechanical manometer/pressure gauge.

Fuel pressure within 5 percent?
YES NO
No Repair

Repair

Replace the fuel supply pressure sensor.

  • Replace the fuel supply pressure sensor. Refer to Procedure 019-188 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2568 is inactive.

Fault code 2568 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes

Repair complete

Appropriate troubleshooting chart

Last Modified: 10-Feb-2011


FAULT CODE 2569 - Gas Supply Pressure (Regulated) - Data Valid But Below Normal Operational Range - Most Severe Level

Associated Procedures

Cautions and Warnings

WARNING

In most countries, inspection, repair, and adjustment of Natural Gas supply systems and components can only be undertaken by qualified and certified personnel. In many regions, accreditation to a nationally recognized trade organization is also required. It is necessary to comply with all local and national codes and legislation when performing these maintenance procedures.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3162898 - pressure sensor breakout cable, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for the fault codes. |
 | STEP 1A. Check for multiple active fault codes. | Fault Codes 1839 or 1841 active?
 | STEP 1B. Check for an active fault code. | Fault Code 2569 active?
STEP 2. | Check the fuel supply pressure. |
 | STEP 2A. Check the fuel supply pressure at the inlet to the fuel control valve. | Fuel supply pressure 130 - 150 mBar [1.885 - 2.176 psi]?
STEP 3. | Check the fuel supply pressure sensor. |
 | STEP 3A. Check the fuel supply pressure sensor and harness connector. | Dirty or damaged pins?
 | STEP 3B. Verify the engine fuel supply pressure sensor reading. | Fuel pressure within 5 percent?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 2569 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 1839 or 1841 active?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 4A

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2569 active?
YES NO

Repair

Proceed to the next troubleshooting step or contact a Cummins® Authorized Repair Location.

 No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel supply pressure.

Guided Step 2A - Check the fuel supply pressure at the inlet to the fuel control valve.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode. Engine operating at no load for greater than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Check the fuel supply pressure at the inlet to the fuel control valve.

  • Use INSITE™ electronic service tool to verify the fuel inlet pressure at the fuel control valve.

Fuel supply pressure 130 - 150 mBar [1.885 - 2.176 psi]?
YES NO
No Repair

Repair

High pressure has been detected at the intake to the fuel control valve.

  • Adjust the fuel supply pressure to between 150 - 180 mBar [2.176 -2.611 psi] at the outlet of the fuel supply pressure regulator.
  • Repair or replace the malfunctioning fuel supply pressure regulator. Use the following procedures for information on the fuel control valve in the QSK60G Generator Set CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 005-042 in Section 5.

Go to 4A

Go to 3A

Guided Step 3 - Check the fuel supply pressure sensor.

Guided Step 3A - Check the fuel supply pressure sensor and harness connector.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness from the fuel supply pressure sensor.

Action

Inspect the gas valve/fuel supply pressure sensor harness and fuel supply pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged pins. Repair or replace the gas valve harness, the harness connector or the sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pin. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the gas valve wiring harness. Contact a Cummins® Authorized Repair Location.
  • Replace the fuel supply pressure sensor. Contact a Cummins® Authorized Repair Location.
 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Verify the engine fuel supply pressure sensor reading.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode. Engine operating at no load for greater than 1 minute
  • Connect INSITE™ electronic service tool
  • Connect a mechanical manometer/pressure gauge to the gas pressure test point immediately after the fuel supply gas pressure regulator.

Note: The mechanical manometer/pressure gauge used for this test must be approved for use with natural gas systems.

Action

Verify the engine fuel supply pressure reading.

  • Use INSITE™ electronic service tool to monitor the fuel supply pressure sensor value.
  • Compare the electronic reading with the fuel supply pressure displayed on the mechanical manometer/pressure gauge.

Fuel pressure within 5 percent?
YES NO
No Repair

Repair

  • Replace the fuel supply pressure sensor. Refer to Procedure 019-188 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2569 is inactive.

Fault code 2569 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes

Repair complete

Appropriate troubleshooting chart

Last Modified: 10-Feb-2011


FAULT CODE 2752 - Multiple Turbocharger Integrated Throttle. Engine Throttle Control Actuator - Current above Normal or Grounded Circuit - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 441, 442, 477, and/or 478 active?
STEP 2. | Check the throttle assembly. |
 | STEP 2A. Inspect the throttle assembly connector and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the throttle driver supply voltage. | 18 - 27.6-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit from pin-to-ground. | Greater than 100k ohms?
STEP 4. | Check the throttle driver. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 2752 is inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 2752 is inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 441, 442, 477, and/or 478 active?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 5A

Go to 2A

Guided Step 2 - Check the throttle assembly.

Guided Step 2A - Inspect the throttle assembly connector and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connector from the throttle assembly.

Action

Inspect the throttle driver connector and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector. Repair or replace the throttle assembly.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the throttle assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 005-052 in Section 5.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the throttle driver supply voltage.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness from the throttle assembly.

Action

Check the throttle driver supply voltage.

  • Use a multimeter to measure the throttle driver supply voltage.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general multimeter operating instruction. Refer to Procedure 019-359 in Section 19.

18 - 27.6-VDC?
YES NO
No Repair

Repair

Check the power supply connections and the fuses in the harness. Reference the wiring diagram to identify the appropriate circuit.

Go to 3A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the throttle assembly, CM558 left and right bank modules, and the CM700 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the throttle assembly.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the throttle driver SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the throttle driver RETURN pin in the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the throttle assembly, CM558 left and right bank modules, and the CM700 module.

Action

Check for a short circuit from pin-to-ground:

  • Measure the resistance from the throttle driver SIGNAL pin in the engine harness connector to the engine block ground.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the throttle driver.

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness from the throttle assembly
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Remove the throttle assembly harness connector. Fault Code 2752 should become inactive.
  • Use INSITE™ electronic service tool to verify the fault codes.
  • Contact a Cummins® Authorized Repair Location.

Fault Code 2752 is inactive?
YES NO
No Repair

Repair

Replace the CM558 module.

  • Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2752 is inactive.

Fault Code 2752 is inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes

Repair complete

Appropriate troubleshooting chart

Last Modified: 09-May-2012


FAULT CODE 2752 - Multiple Turbochargers Two-Piece Throttle. Engine Throttle Control Actuator - Current Above Normal or Grounded Circuit - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 175, 441, 442, 477, and/or 478 active?
STEP 2. | Check the throttle assembly. |
 | STEP 2A. Inspect the throttle assembly connector and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the throttle driver supply voltage. | 18 - 27.6-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit from pin-to-ground. | Greater than 100k ohms?
STEP 4. | Check the throttle driver. |
 | STEP 4A. Check the throttle driver commanded position signal current. | Greater than 20 mA?
 | STEP 4B. Check for the appropriate CM558 response. | Fault Code 2752 is inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 2752 is inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 175, 441, 442, 477, and/or 478 active?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

 No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the throttle assembly.

Guided Step 2A - Inspect the throttle assembly connector and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connector from the throttle assembly.

Action

Inspect the throttle driver connector and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector. Repair or replace the throttle assembly.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the throttle assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 005-052 in Section 5.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the throttle driver supply voltage.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness from the throttle assembly.

Action

Check the throttle driver supply voltage.

  • Use a multimeter to measure the throttle driver supply voltage.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general multimeter operating instruction. Refer to Procedure 019-359 in Section 19.

18 - 27.6-VDC?
YES NO
No Repair

Repair

Check the power supply connections and the fuses in the harness. Reference the wiring diagram to identify the appropriate circuit.

Go to 3A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the throttle actuator, CM558 left bank module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the throttle actuator assembly.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the throttle actuator control driver SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the throttle actuator control driver RETURN pin in the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the throttle actuator assembly, CM558 left bank module.

Action

Check for a short circuit from pin-to-ground:

  • Measure the resistance from the throttle actuator control driver SIGNAL pin in the engine harness connector to the engine block ground.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the throttle driver.

Guided Step 4A - Check the throttle driver commanded position signal current.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness from the throttle actuator assembly
  • Connect INSITE™ electronic service tool.

Action

Check the throttle driver commanded position signal at the throttle actuator.

  • Connect an ammeter in series with the commanded position SIGNAL wire.
  • Use a jumper wire to connect the return connection.
  • Contact a Cummins® Authorized Repair Location.

Greater than 20 mA?
YES NO
No Repair

Repair

Replace the throttle driver module.

  • Replace the throttle driver module. Refer to Procedure 019-429 in Section 19.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 5A

Guided Step 4B - Check for the appropriate CM558 response.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness from the throttle assembly
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Remove the throttle assembly harness connector. Fault Code 2752 should become inactive.
  • Use INSITE™ electronic service tool to verify the fault codes.
  • Fault Code 176 will become active upon disconnecting the throttle driver connection.
  • Contact a Cummins® Authorized Repair Location.

Fault Code 2752 is inactive?
YES NO
No Repair

Repair

Replace the CM558 module.

  • Refer to Procedure 019-031 in Section 19.
  • Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2752 is inactive.

Fault Code 2752 is inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes

Repair complete

Appropriate troubleshooting chart

Last Modified: 09-May-2012


FAULT CODE 2752 - Single Turbocharger Integrated Throttle. Engine Throttle Control Actuator - Current Above Normal or Grounded Circuit - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 441, 442, 477, and/or 478 active?
STEP 2. | Check the throttle assembly. |
 | STEP 2A. Inspect the throttle assembly connector and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the throttle driver supply voltage. | 18 - 27.6-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit from pin-to-ground. | Greater than 100k ohms?
STEP 4. | Check the throttle driver. |
 | STEP 4A. Check for the appropriate CM558 response. | Fault Code 2752 inactive?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 2752 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 441, 442, 477, and/or 478 active?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 5A

Go to 2A

Guided Step 2 - Check the throttle assembly.

Guided Step 2A - Inspect the throttle assembly connector and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness connector from the throttle assembly.

Action

Inspect the throttle driver connector and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector. Repair or replace the throttle assembly.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the throttle assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 005-052 in Section 5.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the throttle driver supply voltage.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness from the throttle assembly.

Action

Check the throttle driver supply voltage.

  • Use a multimeter to measure the throttle driver supply voltage.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general multimeter operating instruction. Refer to Procedure 019-359 in Section 19.

18 - 27.6-VDC?
YES NO
No Repair

Repair

Check the power supply connections and the fuses in the harness. Reference the wiring diagram to identify the appropriate circuit.

Go to 3A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the throttle assembly, CM558 left and right bank modules, and the CM700 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the throttle assembly.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the throttle driver SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the throttle driver RETURN pin in the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit from pin-to-ground.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Isolate the generator set 24-VDC power supply
  • Disconnect the engine harness from the throttle assembly, CM558 left and right bank modules, and the CM700 module.

Action

Check for a short circuit from pin-to-ground:

  • Measure the resistance from the throttle driver SIGNAL pin in the engine harness connector to the engine block ground.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the throttle driver.

Guided Step 4A - Check for the appropriate CM558 response.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness from the throttle assembly
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM558 response.

  • Remove the throttle assembly harness connector. Fault Code 2752 should become inactive.
  • Use INSITE™ electronic service tool to verify the fault codes.
  • Contact a Cummins® Authorized Repair Location.

Fault Code 2752 is inactive?
YES NO
No Repair

Repair

Replace the CM558 module.

  • Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2752 is inactive.

Fault Code 2752 is inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 5B

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes

Repair complete

Appropriate troubleshooting chart

Last Modified: 09-May-2012


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Other fault codes active?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Run mode and running for longer than 1 minute.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Other fault codes active?
YES NO
No Repair

Repair

Refer to the Cylinder Power Low (Multiple Cylinders) troubleshooting tree in this manual.

Appropriate troubleshooting chart

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Run/Stop/Auto switch in Stop mode
  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


FAULT CODE 2768 - Engine Network Primary/Secondary Communication - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 477, 478, or 2769 active?
STEP 2. | Check the engine harness. |
 | STEP 2A. Check the resistance or the proprietary data link circuit. | Proprietary data link circuit resistance is 60 ohms?
 | STEP 2B. Inspect the engine harness connectors and electronic control module connectors. | Dirty or damaged pins?
 | STEP 2C. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 2768 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Enerigize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 477, 478, or 2769 active?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-417 in Section 19.

Go to 4A

Go to 2A

Guided Step 2 - Clear the engine harness.

Guided Step 2A - Check the resistance of the proprietary data link circuit.

Conditions

  • De-enerigize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the Gen Set 24 volt power supply.
  • Disconnect the engine wiring harness connectors from all electronic control modules (ECMs).

Action

Measure the resistance of the proprietary data link circuit:

  • Measure the resistance from the proprietary data link SIGNAL pin to the proprietary data link RETURN pin of one of the ECM connectors. Refer to Procedure 019-417 in Section 19.

Proprietary data link circuit resistance is 60 ohms?
YES NO
No Repair

Repair

Repair the engine wiring harness proprietary data link circuit:

  • Locate and check the resistance of the engine harness 120 ohm termination resistor. Reference wiring diagrams 4021359 and 4022031 for resistor location.
  • If termination resistor does not measure 120 ohms resistance, replace the resistor.
  • Measure the resistance of the second 120 ohm termination resistor located in the Generator Interface Box. Reference the Cummins Power Generation® Generator Interface wiring diagrams for resistor location.
  • If the second termination resistor does not measure 120 ohms, replace the resistor.
  • Contact a Cummins® Authorized Repair Location.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the engine harness connectors and electronic control module connectors.

Conditions

  • De-enerigize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the Gen Set 24 volt power supply.
  • Disconnect the engine wiring harness connectors from all electronic control modules (ECMs).

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Sectino 19.

Dirty or damaged connector pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness.
  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • De-enerigize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the Gen Set 24 volt power supply.
  • Disconnect the engine wiring harness connectors from all electronic control modules (ECMs).

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance from the proprietary data link SIGNAL pin in the CM700 connector to all other pins in the engine harness.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to Procedure 019-417 in Section 19.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness.
  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for an open circuit.

Conditions

  • De-enerigize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the Gen Set 24 volt power supply.
  • Disconnect the engine wiring harness connectors from all electronic control modules (ECMs).

Action

Check for an open circuit:

  • Measure the resistance from the proprietary data link SIGNAL pin in the CM700 connector A harness to the proprietary data link SIGNAL pin in the CM558 left-bank connector A harness connector (C29).
  • Measure the resistance from the proprietary data link RETURN pin in the CM700 connector A harness to the proprietary data link RETURN pin in the CM558 left-bank connector A harness connector (C29).
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to Procedure 019-417 in Section 19.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness.
  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Enerigize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and operate engine for longer than 1 minute.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 2768 is inactive.

Fault Code 2768 inactive?
YES NO
No Repair

Repair

Replace the CM558 module:

  • Replace the CM558 that has generated Fault Code 2768. Use INSITE™ electronic service tool to verify which bank CM558 module generated the fault code.
  • Refer to Procedure 019-031 in Section 19.
  • Repeat Guided Step 3A following replacement of the CM558 module.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Enerigize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting chart

Last Modified: 09-May-2012


FAULT CODE 2769 - Engine Network Primary Message - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 477, 478, or 2768 active?
STEP 2. | Check the engine harness. |
 | STEP 2A. Check the resistance or the proprietary data link circuit. | Proprietary data link circuit resistance is 60 ohms?
 | STEP 2B. Inspect the engine harness connectors and electronic control module connectors. | Dirty or damaged pins?
 | STEP 2C. Check for a short circuit from pin-to-pin. | More than 100k ohms?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 2769 inactive?
 | STEP 3B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 477, 478, or 2769 active?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-417 in Section 19.

Go to 4A

Go to 2A

Guided Step 2 - Clear the engine harness.

Guided Step 2A - Check the resistance of the proprietary data link circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine wiring harness connectors from all electronic control modules (ECMs).

Action

Measure the resistance of the proprietary data link circuit:

  • Measure the resistance from the proprietary data link SIGNAL pin to the proprietary data link RETURN pin of one of the ECM connectors. Refer to Procedure 019-417 in Section 19.

Proprietary data link circuit resistance is 60 ohms?
YES NO
No Repair

Repair

Repair the engine wiring harness proprietary data link circuit:

  • Locate and check the resistance of the engine harness 120 ohm termination resistor. Reference wiring diagrams 4021359 and 4022031 for resistor location.
  • If termination resistor does not measure 120 ohms resistance, replace the resistor.
  • Measure the resistance of the second 120 ohm termination resistor located in the Generator Interface Box. Reference the Cummins Power Generation® Generator Interface wiring diagrams for resistor location.
  • If the second termination resistor does not measure 120 ohms, replace the resistor.
  • Contact a Cummins® Authorized Repair Location.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the engine harness connectors and electronic control module connectors.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the OFF mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine wiring harness connectors from all electronic control modules (ECMs).

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged connector pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness.
  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine wiring harness connectors from all electronic control modules (ECMs).

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance from the proprietary data link SIGNAL pin in the CM700 connector to all other pins in the engine harness.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to Procedure 019-417 in Section 19.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness.
  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine wiring harness connectors from all electronic control modules (ECMs).

Action

Check for an open circuit:

  • Measure the resistance from the proprietary data link SIGNAL pin in the CM700 connector A harness to the proprietary data link SIGNAL pin in the CM558 left-bank connector A harness connector (C29).
  • Measure the resistance from the proprietary data link RETURN pin in the CM700 connector A harness to the proprietary data link RETURN pin in the CM558 left-bank connector A harness connector (C29).
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to Procedure 019-417 in Section 19.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness.
  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode and operate engine for longer than 1 minute.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 2769 is inactive.

Fault Code 2769 inactive?
YES NO
No Repair

Repair

Replace the CM558 module:

  • Replace the CM558 that has generated Fault Code 2769. Use INSITE™ electronic service tool to verify which bank CM558 module generated the fault code.
  • Refer to Procedure 019-031 in Section 19.
  • Repeat Guided Step 3A following replacement of the CM558 module.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES | NO
No Repair | No Repair

Repair complete

Appropriate troubleshooting chart

Last Modified: 09-May-2012


FAULT CODE 2789 (Multi-Turbochargers) - Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 114, 145, or 1824 active?
STEP 2. | Check the on-engine high temperature (HT) cooling system. |
 | STEP 2A. Check the operation of the high temperature (HT) system thermostats. | High Temperature (HT) cooling circuit thermostats operate to specification?
STEP 3. | Check the high temperature (HT) system radiator fans. |
 | STEP 3A. Check the High Temperature (HT) radiator cooling fans control logic. | High Temperature (HT) radiator fans operating correctly?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify that the fault code is inactive. | Fault Code 2789 inactive?
 | STEP 4B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 144, 145, or 1824 active?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

No Repair.

  • Refer to Procedure 019-362 in Section 19.

Go to 4A

Go to 2A

Guided Step 2 - Check the on-engine high temperature (HT) cooling system.

Guided Step 2A - Check the operation of the high temperature (HT) system thermostats.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check the high temperature (HT) cooling system thermostats or electronic control valves for correct operation.

  • Check the on-engine high temperature (HT) cooling system thermostats. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 008-013 in Section 8.

High Temperature (HT) cooling circuit thermostats operate to specification?
YES NO
No Repair

Repair

Replace the high temperature cooling system thermostats.

  • Replace the on-engine high temperature (HT) cooling system thermostats. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 008-013 in Section 8.

Go to 3A

Go to 4A

Guided Step 3 - Check the high temperature (HT) cooling system radiator fans.

Guided Step 3A - Check the high temperature (HT) cooling system radiator fans control logic.

Conditions

  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the mode
  • Operate engine for more than 1 minute.

Action

Check the high temperature (HT) cooling system radiator fans for correct operation.

  • If fitted, check the operation of the high temperature cooling system radiator fans. Check for - Control logic versus ambient air temperature (number of fans running/ fan speed in low ambient temperatures).
  • Contact a Cummins® Authorized Repair Location.

High Temperature (HT) radiator fans operating correctly?
YES NO
No Repair

Repair

Repair the high temperature cooling system radiator fans.

  • Adjust the high temperature cooling system radiator fans control logic to provide improved radiator fan control / temperature regulation for the ambient conditions.
  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and operate engine for greater than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2789 is inactive.

Fault Code 2789 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 02-Jul-2010


FAULT CODE 2789 (Single Turbocharger) - Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 144, 145, 1824, 2869, 2871 or 2872 active?
STEP 2. | Check of the high temperature system temperature control module. |
 | STEP 2A. Is the high temperature control module powered up? | High temperature control module powered up?
 | STEP 2B. Check the high temperature control module for system alarms. | High temperature control module displaying system alarms?
STEP 3. | Check the voltage power supply. |
 | STEP 3A. Check the 24 volt power supply to the high temperature system control module. | Between 20 - 29-VDC?
 | STEP 3B. Check the voltage in-line fuse. | Less than 10 ohms?
 | STEP 3C. Check the voltage supply harness and connector pins. | Dirty or damaged pins?
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3E. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the temperature input signal. |
 | STEP 4A. Check the 4 - 20mA input from the CM700 module to the high temperature control module. | Input between 4 - 20mA?
 | STEP 4B. Check the CM700 to high temperature control module interconnect harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4D. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check the voltage output from the high temperature system temperature controller. |
 | STEP 5A. Check the voltage output at the temperature control module voltage. | Between 20 - 29-VDC?
 | STEP 5B. Check the voltage output at the temperature control module voltage CLOSE output terminals. | Between 20 - 29-VDC?
 | STEP 5C. Check the high temperature control module to CLOSE relay interconnect harness and connector pins. | Dirty or damaged pins?
 | STEP 5D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 5E. Check for an open circuit. | Less than 10 ohms?
STEP 6. | Check the voltage supply to the high temperature system temperature control valve. |
 | STEP 6A. Check the voltage input to the high temperature control valve CLOSE terminals. | Voltage input 120/240-VAC?
 | STEP 6B. Manually check that the high temperature system temperature control valve is closed. | High temperature control valve closed?
 | STEP 6C. Check the voltage output from the high temperature CLOSE relay. | Voltage output 120/240-VAC?
 | STEP 6D. Check the voltage interconnect harness and connector pins. | Dirty or damaged pins?
 | STEP 6E. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 6F. Check for an open circuit. | Less than 10 ohms?
STEP 7. | Check the high temperature system radiator fans. |
 | STEP 7A. Check the high temperature radiator cooling fans control logic. | High temperature radiator fans operating correctly?
STEP 8. | Clear the fault codes. |
 | STEP 8A. Verify that fault code is inactive. | Fault code 2789 is inactive?
 | STEP 8B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 144, 145, 1824, 2869, 2871 or 2872 active?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

No Repair.

  • Refer to Procedure 019-362 in Section 19.

Go to 5A

Go to 2A

Guided Step 2 - Check the high temperature system temperature control module

Guided Step 2A - Check the high temperature system temperature control module is powered up.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • 24 volt switched and unswitched power supplies energized.

Action

Check the high temperature system temperature control module is powered up.

  • Check that the high temperature system temperature control module display panel is illuminated.

High temperature control module powered up?
YES | NO
No Repair | No Repair

Go to 2B

Go to 3A

Guided Step 2B - Check the high temperature system temperature control module for system alarms.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • 24 volt switched and unswitched power supplies energized.

Action

Check the high temperature system temperature control module for system alarms.

  • Use the high temperature system temperature control module display to check for system alarms.

High temperature control module displaying system alarms?
YES NO

Repair

Troubleshoot and repair the high temperature control system faults.

  • Troubleshoot and repair the high temperature system control system faults, as indicated by the alarms displayed on the high temperature control module display.
  • Contact a Cummins® Authorized Repair Location.
 No Repair

Go to 8A

Go to 3A

Guided Step 3 - Check the voltage power supply

Guided Step 3A - Check the 24 volt power supply to the high temperature system temperature control module.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF
  • 24 volt switched and unswitched power supplies energized.

Action

Check the 24 volt power supply to the high temperature system temperature control module:

  • Check for 24-VDC at the high temperature control module 24-VDC (+), 24-VDC (-), 1A OP1 and 1A OP2 terminals.
  • Use the circuit diagram or wiring diagram for temperature control module termination and pin identification.
  • Contact a Cummins® Authorized Repair Location.

Between 20 - 29-VDC?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the voltage supply fuse.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF
  • 24 volt switched and unswitched power supplies energized.

Action

Check the 24 volt supply in-line fuse.

  • Use a multimeter to check the condition of the inline fuse.

Use the circuit diagram or wiring diagram for fuse designation and rating.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Replace the fuse. Refer to Procedure 019-198 in Section 19.

Go to 3C

Go to 8A

Guided Step 3C - Check the voltage supply harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24 volt power supply
  • Disconnect the interconnect harness connectors from the voltage power supply and high temperature control module.

Action

Inspect the interconnect harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the voltage harness. Contact a Cummins® Authorized Repair Location.

Go to 3D

Go to 8A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24 volt power supply
  • Disconnect the interconnect harness connectors from the voltage isolator switch and high temperature control module voltage input terminals.

Action

Check for a short circuit for pin-to-pin.

  • Measure the resistance from the voltage isolator switch 24 volt supply pin in the CM700 connector to all other pins in the voltage harness.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurements techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the voltage harness. Contact a Cummins® Authorized Repair Location.

Go to 3E

Go to 8A

Guided Step 3E - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24 volt power supply
  • Disconnect the interconnect harness connectors from the voltage isolator switch and high temperature control module voltage input terminals

Action

Check for an open circuit.

  • Measure the resistance from the voltage isolator supply pin in the voltage harness connector to the voltage supply input pin in the high temperature controller voltage connector.
  • Measure the resistance from the voltage isolator return pin in the voltage harness connector to the voltage return input pin in the high temperature controller voltage connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurements techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the voltage harness. Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 8A

Guided Step 4 - Check the temperature input signal.

Guided Step 4A - Check the 4-20mA input from the CM700 module to the high temperature system temperature control module.

Conditions

  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and engine running for more than 1 minute.

Action

Check the high temperature 4-20mA signal from the CM700 module to the high temperature control module.

  • Connect an ammeter in series with 4-20mA positive wire running between the CM700 and the high temperature control module.
  • Use the circuit diagram or wiring diagrams for termination and pin identification.
  • Contact a Cummins® Authorized Repair Location.

Input signal between 4 and 20mA?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM700 to high temperature system temperature control module interconnect harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24 volt power supply
  • Disconnect the interconnect harness connectors from the CM700 and high temperature control module

Action

Inspect the interconnect harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the interconnect harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the CM700 to high temperature controller interconnect wiring harness. Contact a Cummins® Authorized Repair Location.

Go to 4C

Go to 8A

Guided Step 4C - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24 volt power supply
  • Disconnect the interconnect harness connectors from the CM700 and high temperature control module.

Action

Check for a short circuit for pin-to-pin.

  • Measure the resistance from the CM700 high temperature input signal pin in the CM700 connector B to all other pins in the CM700 connector B.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurements techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the interconnect harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the CM700 to high temperature controller interconnect wiring harness. Contact a Cummins® Authorized Repair Location.

Go to 4D

Go to 8A

Guided Step 4D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24 volt power supply
  • Disconnect the interconnect harness connectors from the CM700 and high temperature control module.

Action

Check for an open circuit.

  • Measure the resistance from the high temperature input signal pin in the CM700 Connector B harness connector to the high temperature input signal pin in the high temperature control module connector.
  • Measure the resistance from the high temperature input return pin in the CM700 Connector B harness connector to the high temperature input return pin in the high temperature control module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurements techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the interconnect harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the CM700 to high temperature controller interconnect wiring harness. Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 8A

Guided Step 5 - Check the voltage output from the high temperature system temperature control module.

Guided Step 5A - Check the voltage output at the high temperature system temperature control module.

Conditions

  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and engine operating for more than 1 minute.

Action

Check the 24-VDC output at the high temperature system temperature control module CLOSE terminals.

  • Use a multimeter to check for 24-VDC output at the high temperature system temperature control module CLOSE terminals. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Contact a Cummins® Authorized Repair Location.

Between 20 - 29-VDC?
YES NO
No Repair

Repair

Replace the high temperature system temperature control module.

  • Replace the high temperature system temperature control module.
  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 8A

Guided Step 5B - Check the voltage input at the high temperature system temperature control CLOSE relay.

Conditions

  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and engine operating for more than 1 minute.

Action

Check the 24-VDC input at the high temperature system temperature control COLSE relay input terminals.

  • Use a multimeter to check for 24-VDC input at the high temperature system temperature control CLOSE relay terminals.
  • Use the circuit diagram or wiring diagram for relay termination and pin identification.
  • Contact a Cummins® Authorized Repair Location.

Between 20 - 29-VDC?
YES | NO
No Repair | No Repair

Go to 6A

Go to 5C

Guided Step 5C - Check the high temperature system temperature control module to CLOSE relay interconnect harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24 volt power supply
  • Disconnect the interconnect harness connectors from the high temperature control module and the CLOSE relay.

Action

Inspect the interconnect harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the interconnect harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the interconnect harness. Contact a Cummins® Authorized Repair Location.

Go to 5D

Go to 8A

Guided Step 5D - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24 volt power supply
  • Disconnect the interconnect harness connectors from the high temperature control module and the CLOSE relay.

Action

Check for a short circuit for pin-to-pin.

  • Measure the resistance from the high temperature module output signal pin in the high temperature module 24-VDC output connector to all other pins in the connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurements techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the interconnect harness. Contact a Cummins® Authorized Repair Location.

Go to 5E

Go to 8A

Guided Step 5E - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24 volt power supply
  • Disconnect the interconnect harness connectors from the high temperature control module and the CLOSE relay.

Action

Check for an open circuit.

  • Measure the resistance from the high temperature module 24-VDC output signal pin in the voltage control harness connector to the high temperature input signal pin on the high temperature control CLOSE relay connector.
  • Measure the resistance from the high temperature module 24-VDC output return pin in the voltage control harness connector to the high temperature input return pin on the high temperature control CLOSE relay connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurements techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the interconnect harness or the harness connector.

  • Repair or replace the interconnect harness. Contact a Cummins® Authorized Repair Location.

Go to 6A

Go to 8A

Guided Step 6 - Check the voltage supply to the high temperature system temperature control valve.

Guided Step 6A - Check the voltage input to the high temperature control valve CLOSE input terminals.

Conditions

  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and operating for more than 1 minute.

Action

Check the 120/240-VAC input at the high temperature system temperature control CLOSE valve input terminals.

  • Use a multimeter to check for 120/240-VAC input at the high temperature system temperature control CLOSE valve input terminals. Use the circuit diagram or wiring diagram for termination and pin identification.
  • Contact a Cummins® Authorized Repair Location.

Voltage output 120/240-VAC?
YES NO
No Repair

Repair

Replace the high temperature system temperature control module.

  • Contact a Cummins® Authorized Repair Location.

Go to 6B

Go to 8A

Guided Step 6B - Check the high temperature system temperature control valve is closed.

Conditions

  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and engine running for more than 1 minute.

Action

Manually check the high temperature system temperature control valve (1) is closed.

  • Use the valves manual OPEN/CLOSE turn-wheel to check that the high temperature system temperature control valve is CLOSED.
  • Contact a Cummins® Authorized Repair Location.

High temperature control valve closed?
YES NO
No Repair

Repair

Replace the high temperature system temperature control valve.

  • Replace the high temperature system temperature control valve.
  • Contact a Cummins® Authorized Repair Location.

Go to 6C

Go to 8A

Guided Step 6C - Check the voltage output at the high temperature system temperature control CLOSE relay.

Conditions

  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and engine running for more than 1 minute.

Action

Check the 120/240 VAC output at the high temperature system temperature control CLOSE relay output terminals.

  • Use a multimeter to check for 120/240VAC output at the high temperature system temperature control CLOSE relay output terminals.
  • Use the circuit diagram or wiring diagram for relay termination and pin identification.
  • Contact a Cummins® Authorized Repair Location.

Voltage output 120/240-VAC?
YES NO
No Repair

Repair

Replace the high temperature system : CLOSE relay.

  • Replace the high temperature system temperature control CLOSE relay.
  • Contact a Cummins® Authorized Repair Location.

Go to 6D

Go to 8A

Guided Step 6D - Check the voltage harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the Generator Set 24-VDC Power Supply
  • Disconnect the voltage harness connectors from the high temperature control valve, the “CLSOE” relay and the MCB.

Action

Inspect the voltage harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the voltage interconnect harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the voltage interconnect harness.
  • Contact a Cummins® Authorized Repair Location.

Go to 6E

Go to 8A

Guided Step 6E - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set voltage power supply
  • Disconnect the voltage harness connectors from the high temperature control module and the CLOSE relay and the MCB.

Action

Check for a short circuit for pin-to-pin.

  • Measure the resistance from the voltage input connection to the high temperature control valve to all other pins in the VAC harness.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurements techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the voltage harness or the harness connector.

  • Repair or replace the voltage interconnect harness
  • Contact a Cummins® Authorized Repair Location.

Go to 6F

Go to 8A

Guided Step 6F - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set voltage power supply
  • Disconnect the voltage harness connectors from the high temperature control module and the CLOSE relay and the MCB.

Action

Check for an open circuit.

  • Measure the resistance from the voltage input signal pin in the high temperature voltage harness connector to the voltage signal output pin in the CLOSE relay voltage harness connector.
  • Measure the resistance from the voltage common pin in the high temperature voltage harness connector to the voltage common pin in the MCB voltage harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurements techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the interconnect harness or the harness connector.

  • Repair or replace the interconnect harness.
  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 8A

Guided Step 7 - Check the high temperature cooling system radiator fans.

Guided Step 7A - Check the high temperature cooling system radiator fans control logic.

Conditions

  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and running for greater than 1 minute.

Action

Check the high temperature (HT) cooling system radiator fans for correct operation.

  • If installed, check the operation of the high temperature cooling system radiator fans. Check for - control logic versus ambient air temperature (number of fans running / fan speed in low ambient temperatures).
  • Contact a Cummins® Authorized Repair Location.

High Temperature (HT) radiator fans operating correctly?
YES NO
No Repair

Repair

Repair the high temperature cooling system radiator fans.

  • Adjust the high temperature cooling system radiator fans control logic to provide improved radiator fan control / temperature regulation for the ambient conditions.

Contact a Cummins® Authorized Repair Location.

Go to 8A

Go to 8A

Guided Step 8 - Clear the fault codes.

Guided Step 8A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and running for greater than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2789 is inactive.

Fault Code 2789 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 8B

Go to 1A

Guided Step 8B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 02-Jul-2010


Fault Code 2793 (Multiple Turbochargers) - Engine Coolant Temperature – Data Valid but BelowNormal Operating Range – Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 114, 145, 1824 or 2789 active?
STEP 2. | Check the on-engine high temperature (HT) cooling system. |
 | STEP 2A. Check the operation of the high temperature (HT) system thermostats. | High Temperature (HT) cooling circuit thermostats operate to specification?
STEP 3. | Check the high temperature (HT) system radiator fans. |
 | STEP 3A. Check the High Temperature (HT) radiator cooling fans control logic. | High Temperature (HT) radiator fans operating correctly?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify that the fault code is inactive. | Fault Code 2793 inactive?
 | STEP 4B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 144, 145, 1824 or 2789 active?
YES NO
No Repair

Repair

No Repair.

  • Refer to Procedure 019-362 in Section 19.

Go to 4A

Go to 2A

Guided Step 2 - Check the on-engine high temperature (HT) cooling system.

Guided Step 2A - Check the operation of the high temperature (HT) system thermostats.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode.

Action

Check the high temperature (HT) cooling system thermostats or electronic control valves for correct operation.

  • Check the on-engine high temperature (HT) cooling system thermostats. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 008-013 in Section 8.

High Temperature (HT) cooling circuit thermostats operate to specification?
YES NO
No Repair

Repair

Replace the high temperature cooling system thermostats.

  • Replace the on-engine high temperature (HT) cooling system thermostats. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual 4021396. Refer to Procedure 008-013 in Section 8.

Go to 3A

Go to 4A

Guided Step 3 - Check the high temperature (HT) cooling system radiator fans.

Guided Step 3A - Check the high temperature (HT) cooling system radiator fans control logic.

Conditions

  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the mode
  • Operate engine for more than 1 minute.

Action

Check the high temperature (HT) cooling system radiator fans for correct operation.

  • If fitted, check the operation of the high temperature cooling system radiator fans. Check for - Control logic versus ambient air temperature (number of fans running/ fan speed in low ambient temperatures).
  • Contact a Cummins® Authorized Repair Location.

High Temperature (HT) radiator fans operating correctly?
YES NO
No Repair

Repair

Repair the high temperature cooling system radiator fans.

  • Adjust the high temperature cooling system radiator fans control logic to provide improved radiator fan control / temperature regulation for the ambient conditions.
  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify that the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and operate engine for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2793 is inactive.

Fault Code 2793 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 09-Jul-2010


Fault Code 2793 (Single Turbocharger) - Engine Coolant Temperature - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 144, 145, 1824, 2789, 2869, 2871 or 2872 active?
STEP 2. | Check of the high temperature system temperature control module. |
 | STEP 2A. Is the high temperature control module powered up? | High temperature control module powered up?
 | STEP 2B. Check the high temperature control module for system alarms. | High temperature control module displaying system alarms?
STEP 3. | Check the voltage power supply. |
 | STEP 3A. Check the 24 volt power supply to the high temperature system control module. | Between 20 - 29-VDC?
 | STEP 3B. Check the voltage in-line fuse. | Less than 10 ohms?
 | STEP 3C. Check the voltage supply harness and connector pins. | Dirty or damaged pins?
 | STEP 3D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3E. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the temperature input signal. |
 | STEP 4A. Check the 4 - 20mA input from the CM700 module to the high temperature control module. | Input between 4 - 20mA?
 | STEP 4B. Check the CM700 to high temperature control module interconnect harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4D. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check the voltage output from the high temperature system temperature controller. |
 | STEP 5A. Check the voltage output at the temperature control module voltage CLOSE output terminals. | Between 20 - 29-VDC?
 | STEP 5B. Check the voltage input at the temperature control module voltage CLOSE input terminals. | Between 20 - 29-VDC?
 | STEP 5C. Check the high temperature control module to CLOSE relay interconnect harness and connector pins. | Dirty or damaged pins?
 | STEP 5D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 5E. Check for an open circuit. | Less than 10 ohms?
STEP 6. | Check the voltage supply to the high temperature system temperature control valve. |
 | STEP 6A. Check the voltage input to the high temperature control valve CLOSE terminals. | Voltage input 120/240-VAC?
 | STEP 6B. Manually check that the high temperature system temperature control valve is closed. | High temperature control valve closed?
 | STEP 6C. Check the voltage output from the high temperature CLOSE relay. | Voltage output 120/240-VAC?
 | STEP 6D. Check the voltage interconnect harness and connector pins. | Dirty or damaged pins?
 | STEP 6E. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 6F. Check for an open circuit. | Less than 10 ohms?
STEP 7. | Check the high temperature system radiator fans. |
 | STEP 7A. Check the high temperature radiator cooling fans control logic. | High temperature radiator fans operating correctly?
STEP 8. | Clear the fault codes. |
 | STEP 8A. Verify that fault code is inactive. | Fault code 2793 is inactive?
 | STEP 8B. Clear inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 144, 145, 1824, 2789, 2869, 2871 or 2872 active?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

No Repair.

  • Refer to Procedure 019-362 in Section 19.

Go to 5A

Go to 2A

Guided Step 2 - Check the high temperature system temperature control module

Guided Step 2A - Check the high temperature system temperature control module is powered up.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • 24 volt switched and unswitched power supplies energized.

Action

Check the high temperature system temperature control module is powered up.

  • Check that the high temperature system temperature control module display panel is illuminated.

High temperature control module powered up?
YES | NO
No Repair | No Repair

Go to 2B

Go to 3A

Guided Step 2B - Check the high temperature system temperature control module for system alarms.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • 24 volt switched and unswitched power supplies energized.

Action

Check the high temperature system temperature control module for system alarms.

  • Use the high temperature system temperature control module display to check for system alarms.

High temperature control module displaying system alarms?
YES NO

Repair

Troubleshoot and repair the high temperature control system faults.

  • Troubleshoot and repair the high temperature system control system faults, as indicated by the alarms displayed on the high temperature control module display.
  • Contact a Cummins® Authorized Repair Location.
 No Repair

Go to 8A

Go to 3A

Guided Step 3 - Check the voltage power supply

Guided Step 3A - Check the 24 volt power supply to the high temperature system temperature control module.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF
  • 24 volt switched and unswitched power supplies energized.

Action

Check the 24 volt power supply to the high temperature system temperature control module:

  • Check for 24-VDC at the high temperature control module 24-VDC (+), 24-VDC (-), 1A OP1 and 1A OP2 terminals.
  • Use the circuit diagram or wiring diagram for temperature control module termination and pin identification.
  • Contact a Cummins® Authorized Repair Location.

Between 20 - 29-VDC?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the voltage supply fuse.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF
  • 24 volt switched and unswitched power supplies energized.

Action

Check the 24 volt supply in-line fuse.

  • Use a multimeter to check the condition of the inline fuse.

Use the circuit diagram or wiring diagram for fuse designation and rating.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Replace the fuse. Refer to Procedure 019-198 in Section 19.

Go to 3C

Go to 8A

Guided Step 3C - Check the voltage supply harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24 volt power supply
  • Disconnect the interconnect harness connectors from the voltage power supply and high temperature control module.

Action

Inspect the interconnect harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the voltage harness. Contact a Cummins® Authorized Repair Location.

Go to 3D

Go to 8A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24 volt power supply
  • Disconnect the interconnect harness connectors from the voltage isolator switch and high temperature control module voltage input terminals.

Action

Check for a short circuit for pin-to-pin.

  • Measure the resistance from the voltage isolator switch 24 volt supply pin in the CM700 connector to all other pins in the voltage harness.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurements techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the voltage harness. Contact a Cummins® Authorized Repair Location.

Go to 3E

Go to 8A

Guided Step 3E - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24 volt power supply
  • Disconnect the interconnect harness connectors from the voltage isolator switch and high temperature control module voltage input terminals

Action

Check for an open circuit.

  • Measure the resistance from the voltage isolator supply pin in the voltage harness connector to the voltage supply input pin in the high temperature controller voltage connector.
  • Measure the resistance from the voltage isolator return pin in the voltage harness connector to the voltage return input pin in the high temperature controller voltage connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurements techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the voltage harness. Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 8A

Guided Step 4 - Check the temperature input signal.

Guided Step 4A - Check the 4-20mA input from the CM700 module to the high temperature system temperature control module.

Conditions

  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and engine running for more than 1 minute.

Action

Check the high temperature 4-20mA signal from the CM700 module to the high temperature control module.

  • Connect an ammeter in series with 4-20mA positive wire running between the CM700 and the high temperature control module.
  • Use the circuit diagram or wiring diagrams for termination and pin identification.
  • Contact a Cummins® Authorized Repair Location.

Input signal between 4 and 20mA?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the CM700 to high temperature system temperature control module interconnect harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24 volt power supply
  • Disconnect the interconnect harness connectors from the CM700 and high temperature control module

Action

Inspect the interconnect harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the interconnect harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the CM700 to high temperature controller interconnect wiring harness. Contact a Cummins® Authorized Repair Location.

Go to 4C

Go to 8A

Guided Step 4C - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24 volt power supply
  • Disconnect the interconnect harness connectors from the CM700 and high temperature control module.

Action

Check for a short circuit for pin-to-pin.

  • Measure the resistance from the CM700 high temperature input signal pin in the CM700 connector B to all other pins in the CM700 connector B.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurements techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the interconnect harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the CM700 to high temperature controller interconnect wiring harness. Contact a Cummins® Authorized Repair Location.

Go to 4D

Go to 8A

Guided Step 4D - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode
  • Isolate the generator set 24 volt power supply
  • Disconnect the interconnect harness connectors from the CM700 and high temperature control module.

Action

Check for an open circuit.

  • Measure the resistance from the high temperature input signal pin in the CM700 Connector B harness connector to the high temperature input signal pin in the high temperature control module connector.
  • Measure the resistance from the high temperature input return pin in the CM700 Connector B harness connector to the high temperature input return pin in the high temperature control module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurements techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the CM700 to high temperature controller interconnect wiring harness. Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 8A

Guided Step 5 - Check the voltage output from the high temperature system temperature control module.

Guided Step 5A - Check the voltage output at the high temperature system temperature control module.

Conditions

  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and engine operating for more than 1 minute.

Action

Check the 24-VDC output at the high temperature system temperature control module CLOSE terminals.

  • Use a multimeter to check for 24-VDC output at the high temperature system temperature control module CLOSE terminals. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Contact a Cummins® Authorized Repair Location.

Between 20 - 29-VDC?
YES NO
No Repair

Repair

Replace the high temperature system temperature control module.

  • Replace the high temperature system temperature control module.
  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 8A

Guided Step 5B - Check the voltage input at the high temperature system temperature control CLOSE relay.

Conditions

  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and engine operating for more than 1 minute.

Action

Check the 24-VDC input at the high temperature system temperature control CLOSE relay input terminals.

  • Use a multimeter to check for 24-VDC input at the high temperature system temperature control CLOSE relay terminals.
  • Use the circuit diagram or wiring diagram for relay termination and pin identification.
  • Contact a Cummins® Authorized Repair Location.

Between 20 - 29-VDC?
YES | NO
No Repair | No Repair

Go to 6A

Go to 5C

Guided Step 5C - Check the high temperature system temperature control module to CLOSE relay interconnect harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24 volt power supply
  • Disconnect the interconnect harness connectors from the high temperature control module and the CLOSE relay.

Action

Inspect the interconnect harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the interconnect harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the interconnect harness. Contact a Cummins® Authorized Repair Location.

Go to 5D

Go to 8A

Guided Step 5D - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24 volt power supply
  • Disconnect the interconnect harness connectors from the high temperature control module and the CLOSE relay.

Action

Check for a short circuit for pin-to-pin.

  • Measure the resistance from the high temperature module output signal pin in the high temperature module 24-VDC output connector to all other pins in the connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurements techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair or replace the interconnect harness. Contact a Cummins® Authorized Repair Location.

Go to 5E

Go to 8A

Guided Step 5E - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set 24 volt power supply
  • Disconnect the interconnect harness connectors from the high temperature control module and the CLOSE relay.

Action

Check for an open circuit.

  • Measure the resistance from the high temperature module 24-VDC output signal pin in the voltage control harness connector to the high temperature input signal pin on the high temperature control CLOSE relay connector.
  • Measure the resistance from the high temperature module 24-VDC output return pin in the voltage control harness connector to the high temperature input return pin on the high temperature control CLOSE relay connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurements techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the interconnect harness or the harness connector.

  • Repair or replace the interconnect harness. Contact a Cummins® Authorized Repair Location.

Go to 6A

Go to 8A

Guided Step 6 - Check the voltage supply to the high temperature system temperature control valve.

Guided Step 6A - Check the voltage input to the high temperature control valve CLOSE input terminals.

Conditions

  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and operating for more than 1 minute.

Action

Check the 120/240-VAC input at the high temperature system temperature control CLOSE valve input terminals.

  • Use a multimeter to check for 120/240-VAC input at the high temperature system temperature control CLOSE valve input terminals. Use the circuit diagram or wiring diagram for termination and pin identification.
  • Contact a Cummins® Authorized Repair Location.

Voltage output 120/240-VAC?
YES NO
No Repair

Repair

Replace the high temperature system temperature control module.

  • Contact a Cummins® Authorized Repair Location.

Go to 6B

Go to 8A

Guided Step 6B - Check the high temperature system temperature control valve is closed.

Conditions

  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and engine running for more than 1 minute.

Action

Manually check the high temperature system temperature control valve (1) is closed.

  • Use the valves manuaL OPEN/CLOSE turn-wheel to check that the high temperature system temperature control valve is CLOSED.
  • Contact a Cummins® Authorized Repair Location.

High temperature control valve closed?
YES NO
No Repair

Repair

Replace the high temperature system temperature control valve.

  • Replace the high temperature system temperature control valve.
  • Contact a Cummins® Authorized Repair Location.

Go to 6C

Go to 8A

Guided Step 6C - Check the voltage output at the high temperature system temperature control CLOSE relay.

Conditions

  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and engine running for more than 1 minute.

Action

Check the 120/240 VAC output at the high temperature system temperature control CLOSE relay output terminals.

  • Use a multimeter to check for 120/240VAC output at the high temperature system temperature control CLOSE relay output terminals.
  • Use the circuit diagram or wiring diagram for relay termination and pin identification.
  • Contact a Cummins® Authorized Repair Location.

Voltage output 120/240-VAC?
YES NO
No Repair

Repair

Replace the high temperature system CLOSE relay.

  • Replace the high temperature system temperature control CLOSE relay.
  • Contact a Cummins® Authorized Repair Location.

Go to 6D

Go to 8A

Guided Step 6D - Check the voltage harness and connector pins.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the Generator Set 24-VDC Power Supply
  • Disconnect the voltage harness connectors from the high temperature control valve, the CLOSE relay and the MCB.

Action

Inspect the voltage harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector, pins, and harness termination location.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the voltage interconnect harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the voltage interconnect harness.
  • Contact a Cummins® Authorized Repair Location.

Go to 6E

Go to 8A

Guided Step 6E - Check for a short circuit from pin-to-pin.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set voltage power supply
  • Disconnect the voltage harness connectors from the high temperature control module and the CLOSE relay and the MCB.

Action

Check for a short circuit for pin-to-pin.

  • Measure the resistance from the voltage input connection to the high temperature control valve to all other pins in the VAC harness.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurements techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the voltage harness or the harness connector.

  • Repair or replace the voltage interconnect harness
  • Contact a Cummins® Authorized Repair Location.

Go to 6F

Go to 8A

Guided Step 6F - Check for an open circuit.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the OFF mode
  • Isolate the generator set voltage power supply
  • Disconnect the voltage harness connectors from the high temperature control module and the CLOSE relay and the MCB.

Action

Check for an open circuit.

  • Measure the resistance from the voltage input signal pin in the high temperature voltage harness connector to the voltage signal output pin in the CLOSE relay voltage harness connector.
  • Measure the resistance from the voltage common pin in the high temperature voltage harness connector to the voltage common pin in the MCB voltage harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram to identify connector and pins.
  • Use the following procedure for resistance measurements techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the interconnect harness or the harness connector.

  • Repair or replace the interconnect harness.
  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 8A

Guided Step 7 - Check the high temperature cooling system radiator fans.

Guided Step 7A - Check the high temperature cooling system radiator fans control logic.

Conditions

  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and running for greater than 1 minute.

Action

Check the high temperature (HT) cooling system radiator fans for correct operation.

  • If installed, check the operation of the high temperature cooling system radiator fans. Check for - control logic versus ambient air temperature (number of fans running / fan speed in low ambient temperatures).
  • Contact a Cummins® Authorized Repair Location.

High Temperature (HT) radiator fans operating correctly?
YES NO
No Repair

Repair

Repair the high temperature cooling system radiator fans.

  • Adjust the high temperature cooling system radiator fans control logic to provide improved radiator fan control / temperature regulation for the ambient conditions.

Contact a Cummins® Authorized Repair Location.

Go to 8A

Go to 8A

Guided Step 8 - Clear the fault codes.

Guided Step 8A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and running for greater than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2793 is inactive.

Fault Code 2793 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 8B

Go to 1A

Guided Step 8B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 09-Jul-2010


FAULT CODE 2796 - Generator Electrical Load Signal - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the GenSet with PowerCommand™ Supervisor and GenSet with PCC3300. |
 | STEP 1A. Read the PowerCommand™ Supervisor and PCC3300 fault codes. | Is active fault code a PowerCommand™ Supervisor?
 | STEP 1B. Check the ECM for active fault codes. | Fault Code 2796 active?
STEP 2. | Check the kilowatt accuracy. |
 | STEP 2A. Verify the kilowatt load demanded by the parallel controller is not above the generator set limits. | Kilowatt load command below set limits?
STEP 3. | Check the ECM value. |
 | STEP 3A. Verify that the fault simulation feature for the kW overload is not enabled. | Fault simulation disabled?
STEP 4. | Check the current transformers. |
 | STEP 4A. Inspect the current transformers and current transformer connections. | Current transformer connections correct?
 | STEP 4B. Check the AC harness. | Dirty or damaged pins?
 | STEP 4C. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 4D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 5. | Check the PT/CT board. |
 | STEP 5A. Check the PT/CT board 3 ohm resistors. | Are 3 ohm resistors good?
 | STEP 5B. Inspect the PT/CT board and the generator control harness connector pins. | Dirty of damaged pins?
STEP 6. | Check the generator control harness. |
 | STEP 6A. Inspect the generator control harness and the ECM connector pins. | Dirty of damaged pins?
 | STEP 6B. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 6C. Check for an open circuit. | Less than 10 ohms?
 | STEP 6D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Clear the inactive fault codes. | All fault codes cleared?
 | STEP 7B. Verify the fault code is inactive. | Fault Code 2796 inactive?
STEP 8. | Check the fault codes. |
 | STEP 8A. Check the ECM for active fault codes. | Fault Code 2796 active?
STEP 9. | Check the kilowatt accuracy. |
 | STEP 9A. Verify the kilowatt load demanded by the parallel controller is not above the generator set limits. | Kilowatt load command below set limits?
STEP 10. | Check the ECM value. |
 | STEP 10A. Verify that the fault simulation feature for the kW overload is not enabled. | Fault simulation disabled?
STEP 11. | Check the current transformers. |
 | STEP 11A. Inspect the current transformers and current transformer connections. | Current transformer connections correct?
 | STEP 11B. Check the AC harness. | Dirty or damaged pins?
 | STEP 11C. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 11D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 12. | Check the generator control harness. |
 | STEP 12A. Inspect the generator control harness and the ECM connector pins. | Dirty of damaged pins?
 | STEP 12B. Check for a short circuit to engine block ground. | More than 100k ohms?
 | STEP 12C. Check for an open circuit. | Less than 10 ohms?
 | STEP 12D. Check for a short circuit from pin-to-pin. | More than 100k ohms?
STEP 13. | Clear the fault codes. |
 | STEP 13A. Clear the inactive fault codes. | All fault codes cleared?
 | STEP 13B. Verify the fault code is inactive. | Fault Code 2796 inactive?

Guided Step 1 - Check the GenSet with PowerCommand™ Supervisor and GenSet with PCC3300.

Guided Step 1A - Read the PowerCommand™ Supervisor and PCC3300 fault codes.

Conditions

  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code.

Verify whether fault code PowerCommand™ Supervisor or PCC3300 are active.

Is active fault code a PowerCommand™ Supervisor?
YES NO
No Repair

Repair

This is a PCC3300 fault code. Begin troubleshooting at Guided Step 8A.

Go to 1A

Go to 8A

Guided Step 2 - Check the kilowatt accuracy.

Guided Step 2A - Verify the kilowatt load demanded by the parallel controller is not above generator set limits.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Verify kilowatt load demand is not above generator set limits.

  • Use INSITE™ electronic service tool to verify the kilowatt load demanded by the parallel controller is not above generator set limits.

Kilowatt load command not above set limits?

YES NO
No Repair

Repair

  • Refer to customer/facility/installation documentation.

Go to 3A

Go to 7A

Guided Step 3 - Check the ECM value.

Guided Step 3A - Verify that the fault simulation feature for the kilowatt overload is not enabled.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Verify that the fault simulation feature is not enabled.

  • Use INSITE™ electronic service tool to verify that the fault simulation feature for the kilowatt overload is not enabled.

Fault simulation disabled?
YES NO
No Repair

Repair

  • kW overload is enabled. Refer to customer/facility/installation documentation.

Go to 4A

Go to 7A

Guided Step 4 - Check the current transformers.

Guided Step 4A - Inspect the current transformers and current transformer connections.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the AC harness connectors from the current transformers.

Action

Inspect the current transformers and the current transformer connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the AC harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.
No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the AC harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position
  • Disconnect the AC harness from the PT/CT Board.

Action

Inspect the AC harness connector and the PT/CT board connector 09 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the engine harness, or replace the AC harness and/or PT/CT board, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the AC harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.
  • Replace the PT/CT Board. Refer to Procedure 019-318 in Section 19.
No Repair

Go to 7A

Go to 4C

Guided Step 4C - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position
  • Disconnect the AC harness from the PT/CT Board.
  • Disconnect the AC harness connectors from the current transformers.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each current transformer pin on the AC harness PT/CT board connector to engine block ground.
  • Repeat previous step for all other current transformer pins.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 4D

Go to 7A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the PT/CT Board.
  • Disconnect the AC harness connectors from the current transformers.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the current transformer pins on the AC harness connector to all other pins on the AC harness connector.
  • Repeat previous step for all other current transformer pins.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 4A

Go to 7A

Guided Step 5 - Check the PT/CT board.

Guided Step 5A - Check the PT/CT board 3 ohm resistors.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the PT/CT Board.

Action

Verify the 3-ohm resistors from PT/CT board connector 08.

  • Measure the resistance between CT21 pin on connector 08 and CT21 COM pin on connector 08.
  • Measure the resistance between CT22 pin on connector 08 and CT22 COM pin on connector 08.
  • Measure the resistance between CT23 pin on connector 08 and CT23 COM pin on connector 08.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Are the 3 ohm resistors good?
YES NO
No Repair

Repair

Replace the PT/CT board.

  • Replace the PT/CT Board. Refer to Procedure 019-318 in Section 19.

Go to 5B

Go to 7A

Guided Step 5B - Inspect the PT/CT board and the generator control harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the PT/CT board from the generator control harness.

Action

Inspect the generator control harness and the CM700 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the generator control, CM700 and/or control harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the generator set parallel board. Refer to Procedure 019-322 in Section 19.
No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check the generator control harness.

Guided Step 6A - Inspect the generator control harness and the ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the CM700.

Action

Inspect the generator control harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the generator control, PT/CT board and/or control harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the genset or parallel board. See wiring diagram for appropriate board. Refer to Procedure 019-318 in Section 19.
No Repair

Go to 7A

Go to 6B

Guided Step 6B - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the CM700.
  • Disconnect the generator control harness from the generator control.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each pin on the generator control harness ECM connector to engine block ground.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the generator control, PT/CT board and/or control harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the PT/CT board. See wiring diagram for appropriate board. Refer to Procedure 019-318 in Section 19.

Go to 6C

Go to 7A

Guided Step 6C - Check for an open circuit in the generator control harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the CM700.
  • Disconnect the generator control harness from the generator control.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from each of the pins on the generator control harness PT/CT board connector to the aligned generator control harness ECM connector pin.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 6D

Go to 7A

Guided Step 6D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the CM700.
  • Disconnect the generator control harness from the generator control.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of each pin on the generator control harness ECM connector to all other pins on the generator control harness ECM connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Clear the inactive fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Clear the inactive fault codes.

  • Clear inactive fault codes by pressing the “Reset” button on the control panel and cycling the engine keyswitch.
  • Use INSITE™ electronic service tool to verify inactive fault codes are cleared.

All fault codes cleared?
YES NO
No Repair

Repair

  • Troubleshoot any remaining active fault codes.

Go to 7B

Appropriate troubleshooting steps

Guided Step 7B - Verify the fault code is inactive.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate for greater than 1 minute.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2796 is inactive.

Fault Code 2796 inactive?
YES NO
No Repair

Repair

  • Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Guided Step 8 - Check the fault codes.

Guided Step 8A - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2796 active?
YES | NO
No Repair | No Repair

Go to 9A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 9 - Check the kilowatt accuracy.

Guided Step 9A - Verify the kilowatt load demanded by the parallel controller is not above generator set limits.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Verify kilowatt load demand is not above generator set limits.

  • Use INSITE™ electronic service tool to verify the kilowatt load demanded by the parallel controller is not above generator set limits.

Kilowatt load command not above set limits?

YES NO
No Repair

Repair

  • Refer to customer/facility/installation documentation.

Go to 10A

Go to 13A

Guided Step 10 - Check the ECM value.

Guided Step 10A - Verify that the fault simulation feature for the kilowatt overload is not enabled.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Verify that the fault simulation feature is not enabled.

  • Use INSITE™ electronic service tool to verify that the fault simulation feature for the kilowatt overload is not enabled.

Fault simulation disabled?
YES NO
No Repair

Repair

  • kW overload is enabled. Refer to customer/facility/installation documentation.

Go to 11A

Go to 13A

Guided Step 11 - Check the current transformers.

Guided Step 11A - Inspect the current transformers and current transformer connections.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the AC harness connectors from the current transformers.

Action

Inspect the current transformers and the current transformer connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the AC harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.
No Repair

Go to 13A

Go to 11B

Guided Step 11B - Check the AC harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position
  • Disconnect the AC harness from the PT/CT Board.

Action

Inspect the AC harness connector and the PT/CT board connector 09 pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the engine harness, or replace the AC harness and/or PT/CT board, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the AC harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.
  • Replace the PT/CT Board. Refer to Procedure 019-318 in Section 19.
No Repair

Go to 13A

Go to 11C

Guided Step 11C - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position
  • Disconnect the AC harness from the PT/CT Board.
  • Disconnect the AC harness connectors from the current transformers.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each current transformer pin on the AC harness PT/CT board connector to engine block ground.
  • Repeat previous step for all other current transformer pins.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 11D

Go to 13A

Guided Step 11D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the AC harness from the PT/CT Board.
  • Disconnect the AC harness connectors from the current transformers.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the current transformer pins on the AC harness connector to all other pins on the AC harness connector.
  • Repeat previous step for all other current transformer pins.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the AC harness.

  • Repair the AC harness. Refer to Procedure 019-203 in Section 19. Refer to Procedure 019-197 in Section 19.
  • Replace the AC harness. Refer to Procedure 019-315 in Section 19.

Go to 12A

Go to 13A

Guided Step 12 - Check the generator control harness.

Guided Step 12A - Inspect the generator control harness and the ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the CM700.

Action

Inspect the generator control harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the generator control, PT/CT board and/or control harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the genset or parallel board. See wiring diagram for appropriate board. Refer to Procedure 019-318 in Section 19.
No Repair

Go to 13A

Go to 12B

Guided Step 12B - Check for a short circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the CM700.
  • Disconnect the generator control harness from the generator control.

Action

Check for a short circuit to engine block ground.

  • Measure the resistance of each pin on the generator control harness ECM connector to engine block ground.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the generator control, PT/CT board, and/or control harness, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.
  • Replace the PT/CT board. See wiring diagram for appropriate board. Refer to Procedure 019-318 in Section 19.

Go to 6C

Go to 13A

Guided Step 12C - Check for an open circuit in the generator control harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the CM700.
  • Disconnect the generator control harness from the generator control.

Action

Check for an open circuit in the generator control harness.

  • Measure the resistance from each of the pins on the generator control harness PT/CT board connector to the aligned generator control harness ECM connector pin.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the generator control harness.

  • Repair the generator control harness. Refer to Procedure 019-213 in Section 19.
  • Replace the generator control harness. Refer to Procedure 019-183 in Section 19.

Go to 12D

Go to 13A

Guided Step 12D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the generator control harness from the CM700.
  • Disconnect the generator control harness from the generator control.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance of each pin on the generator control harness ECM connector to all other pins on the generator control harness ECM connector.
  • Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 13A

Go to 13A

Guided Step 13 - Clear the fault codes.

Guided Step 13A - Clear the inactive fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Clear the inactive fault codes.

  • Clear inactive fault codes by pressing the “Reset” button on the control panel and cycling the engine keyswitch.
  • Use INSITE™ electronic service tool to verify inactive fault codes are cleared.

All fault codes cleared?
YES NO
No Repair

Repair

  • Troubleshoot any remaining active fault codes.

Go to 13B

Appropriate troubleshooting steps

Guided Step 13B - Verify the fault code is inactive.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate for greater than 1 minute.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2796 is inactive.

Fault Code 2796 inactive?
YES NO
No Repair

Repair

  • Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-May-2012


FAULT CODE 2799 - Engine Turbocharger 1 Boost Pressure - Abnormal Rate of Change

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2799 active?
STEP 2. | Inspect intake air filters for excessive restriction. |
 | STEP 2A. Check air filter restriction. | Restriction present?
STEP 3. | Inspect air/fuel mixer for damage. |
 | STEP 3A. Inspect air/fuel mixer for damage. | Damage found?
STEP 4. | Inspect turbocharger for damage. |
 | STEP 4A. Inspect turbocharger for damage. | Damage or out of specification found?
STEP 5. | Inspect charge-air system for damage. |
 | STEP 5A. Inspect charge-air system for visible damage. | Damage found?
 | STEP 5B. Inspect charge-air system for leaks. | Leak found?
STEP 6. | Inspect throttle and throttle mounting flange. |
 | STEP 6A. Inspect the throttle driver and engine harness electrical connections. | Dirty or damaged pins?
 | STEP 6B. Inspect the throttle for damage. | Damage or misalignment found?
 | STEP 6C. Inspect the throttle mounting flange for leaking or cracks. | Leak or crack found?
STEP 7. | Clear the fault code. |
 | STEP 7A. Clear the inactive fault codes. | All fault codes cleared?
 | STEP 7B. Verify that the fault code is inactive. | Fault Code 2799 is inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service. tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2799 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Inspect the intake air filters for excessive restriction.

Guided Step 2A - Check air filter restriction.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for air filter restriction or damage that can cause excessive restriction.

  • Use the Operation and Maintenance Manual Generator Set QSK60G CM700, Bulletin 4021395. Refer to Procedure 010-086 in Section 10.

Restriction present?
YES NO

Repair

  • Inspect and/or replace the air cleaner elements.
  • Use the Operation and Maintenance Manual Generator Set QSK60G CM700, Bulletin 4021395. Refer to Procedure 010-014 in Section 10.
No Repair

Go to 7A

Go to 3A

Guided Step 3 - Inspect air/fuel mixer for damage.

Guided Step 3A - Inspect air/fuel mixer for damage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for air/fuel mixer damage.

  • Use the Troubleshooting and Repair Manual QSK60G Generator CM700, Bulletin 4021396. Refer to Procedure 005-003 in Section 5.

Damage found?
YES NO

Repair

Replace the air/fuel mixer.

  • Use the Troubleshooting and Repair Manual QSK60G Generator CM700, Bulletin 4021396. Refer to Procedure 005-003 in Section 5.
No Repair

Go to 7A

Go to 4A

Guided Step 4 - Inspect the turbocharger for damage.

Guided Step 4A - Inspect the turbocharger for damage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for air/fuel mixer damage.

  • Use the Operation and Maintenance Manual Generator Set QSK60G CM700, Bulletin 4021395. Refer to Procedure 010-038 in Section 10.
  • Use the Operation and Maintenance Manual Generator Set QSK60G CM700, Bulletin 4021395. Refer to Procedure 010-047 in Section 10.

Damaged or out of specification found?
YES NO

Repair

Replace the turbocharger.

  • Use the Troubleshooting and Repair Manual QSK60G Generator CM700, Bulletin 4021396. Refer to Procedure 010-033 in Section 10.
No Repair

Go to 7A

Go to 5A

Guided Step 5 - Inspect charge-air system for damage.

Guided Step 5A - Inspect charge-air system for visible damage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the charge-air ducting, compressor bypass circuit, and aftercooler for damage.

  • Use the Troubleshooting and Repair Manual QSK60G Generator CM700, Bulletin 4021396. Refer to Procedure 010-024 in Section 10.
  • Use the Troubleshooting and Repair Manual QSK60G Generator CM700, Bulletin 4021396. Refer to Procedure 010-001 in Section 10.

Damage found?
YES NO

Repair

Repair or replace the damaged component.

  • Use the Troubleshooting and Repair Manual QSK60G Generator CM700, Bulletin 4021396. Refer to Procedure 010-024 in Section 10.
  • Use the Operation and Maintenance Manual Generator Set QSK60G CM700, Bulletin 4021395. Refer to Procedure 010-136 in Section 12.
  • Use the Troubleshooting and Repair Manual QSK60G Generator CM700, Bulletin 4021396. Refer to Procedure 010-001 in Section 10.
No Repair

Go to 7A

Go to 5B

Guided Step 5B - Inspect the charge-air system for leaks.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.

Action

Check the charge-air ducting, compressor bypass circuit and aftercooler for leaks.

  • Use the Troubleshooting and Repair Manual QSK60G Generator CM700, Bulletin 4021396. Refer to Procedure 010-024 in Section 10.
  • Use the Troubleshooting and Repair Manual QSK60G Generator CM700, Bulletin 4021396. Refer to Procedure 010-001 in Section 10.

Leaks found?
YES NO

Repair

Repair or replace the damaged component.

  • Use the Troubleshooting and Repair Manual QSK60G Generator CM700, Bulletin 4021396. Refer to Procedure 010-024 in Section 10.
  • Use the Operation and Maintenance Manual Generator Set QSK60G CM700, Bulletin 4021395. Refer to Procedure 010-136 in Section 12.
  • Use the Troubleshooting and Repair Manual QSK60G Generator CM700, Bulletin 4021396. Refer to Procedure 010-001 in Section 10.
No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspect the throttle and throttle mounting flange.

Guided Step 6A - Inspect the throttle driver and engine harness electrical connections.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the throttle driver connectors and the engine harness connectors and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair or replace the engine harness or the throttle driver assembly, whichever has the dirty or damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Use the Troubleshooting and Repair Manual QSK60G Generator CM700, Bulletin 4021396. Refer to Procedure 005-052 in Section 5.

Go to 7A

Go to 6B

Guided Step 6B - Inspect throttle for damage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect throttle for damage.

Check the throttle for damage, valve misalignment, and freedom of valve rotational movement.

Damage or misalignment found?
YES NO

Repair

Repair or replace the throttle body assembly.

  • Use the Troubleshooting and Repair Manual QSK60G Generator CM700, Bulletin 4021396. Refer to Procedure 005-052 in Section 5.
No Repair

Go to 7A

Go to 6C

Guided Step 6C - Inspect throttle mounting flange for leaking or cracks.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.

Action

Check the throttle mounting flange for leaking or cracks.

  • Use the Troubleshooting and Repair Manual QSK60G Generator CM700, Bulletin 4021396. Refer to Procedure 010-024 in Section 10.

Leaks or crack found?
YES NO

Repair

Repair or replace the throttle body assembly

  • Use the Troubleshooting and Repair Manual QSK60G Generator CM700, Bulletin 4021396. Refer to Procedure 010-024 in Section 10.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault code.

Guided Step 7A - Clear the inactive fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Clear the inactive fault codes.

  • Clear inactive fault codes by pressing the "Reset" button on the control panel and cycling the engine keyswitch.
  • Use INSITE™ electronic service tool to verify inactive fault codes are cleared.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Go to 7B

Appropriate troubleshooting steps

Guided Step 7B - Verify the fault code is inactive.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2799 is inactive.

Fault Code 2799 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 30-Jan-2013


FAULT CODE 2811 - Engine Turbocharger 1 Boost Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2811 active?
STEP 2. | Inspect intake air filters for excessive restriction. |
 | STEP 2A. Check air filter restriction. | Restriction present?
STEP 3. | Inspect air/fuel mixer for damage. |
 | STEP 3A. Inspect air/fuel mixer for damage. | Damage found?
STEP 4. | Inspect turbocharger for damage. |
 | STEP 4A. Inspect turbocharger for damage. | Damage or out of specification found?
STEP 5. | Inspect charge-air system for damage. |
 | STEP 5A. Inspect charge-air system for visible damage. | Damage found?
 | STEP 5B. Inspect charge-air system for leaks. | Leak found?
STEP 6. | Inspect throttle and throttle mounting flange. |
 | STEP 6A. Inspect the throttle driver and engine harness electrical connections. | Dirty or damaged pins?
 | STEP 6B. Inspect the throttle for damage. | Damage or misalignment found?
 | STEP 6C. Inspect the throttle mounting flange for leaking or cracks. | Leak or crack found?
STEP 7. | Clear the fault code. |
 | STEP 7A. Clear the inactive fault codes. | All fault codes cleared?
 | STEP 7B. Verify that the fault code is inactive. | Fault Code 2811 inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service. tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2811 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Inspect the intake air filters for excessive restriction.

Guided Step 2A - Check air filter restriction.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for air filter restriction or damage that can cause excessive restriction.

  • Use the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 010-086 in Section 10.

Restriction present?
YES NO

Repair

  • Inspect and/or replace the air cleaner elements.
  • Use the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 010-014 in Section 10.
No Repair

Go to 7A

Go to 3A

Guided Step 3 - Inspect air/fuel mixer for damage.

Guided Step 3A - Inspect air/fuel mixer for damage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for air/fuel mixer damage.

  • Use the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 005-003 in Section 5.

Damage found?
YES NO

Repair

Replace the air/fuel mixer.

  • Use the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 005-003 in Section 5.
No Repair

Go to 7A

Go to 4A

Guided Step 4 - Inspect the turbocharger for damage.

Guided Step 4A - Inspect the turbocharger for damage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for air/fuel mixer damage.

  • Use the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 010-038 in Section 10.
  • Use the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 010-047 in Section 10.

Damaged or out of specification found?
YES NO

Repair

Replace the turbocharger.

  • Use the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 010-033 in Section 10.
No Repair

Go to 7A

Go to 5A

Guided Step 5 - Inspect charge-air system for damage.

Guided Step 5A - Inspect charge-air system for visible damage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the charge-air ducting, compressor bypass circuit, and aftercooler for damage.

  • Use the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 010-024 in Section 10.
  • Use the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 010-001 in Section 10.

Damage found?
YES NO

Repair

Repair or replace the damaged component.

  • Use the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 010-024 in Section 10.
  • Use the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 010-136 in Section 12.
  • Use the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 010-001 in Section 10.
No Repair

Go to 7A

Go to 5B

Guided Step 5B - Inspect the charge-air system for leaks.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.

Action

Check the charge-air ducting, compressor bypass circuit, and aftercooler for leaks.

  • Use the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 010-024 in Section 10.
  • Use the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 010-001 in Section 10.

Leaks found?
YES NO

Repair

Repair or replace the damaged component.

  • Use the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 010-024 in Section 10.
  • Use the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 010-136 in Section 12.
  • Use the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 010-001 in Section 10.
No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspect the throttle and throttle mounting flange.

Guided Step 6A - Inspect the throttle driver and engine harness electrical connections.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the throttle driver connectors and the engine harness connectors and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Repair or replace the engine harness or the throttle driver assembly, whichever has the dirty or damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Use the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 005-052 in Section 5.

Go to 7A

Go to 6B

Guided Step 6B - Inspect throttle for damage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect throttle for damage.

Check the throttle for damage, valve misalignment, and freedom of valve rotational movement.

Damage or misalignment found?
YES NO

Repair

Repair or replace the throttle body assembly.

  • Use the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 005-052 in Section 5.
No Repair

Go to 7A

Go to 6C

Guided Step 6C - Inspect throttle mounting flange for leaking or cracks.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.

Action

Check the throttle mounting flange for leaking or cracks.

  • Use the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 010-024 in Section 10.

Leaks or crack found?
YES NO

Repair

Repair or replace the throttle body assembly

  • Use the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 010-024 in Section 10.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault code.

Guided Step 7A - Clear the inactive fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Clear the inactive fault codes.

  • Clear inactive fault codes by pressing the "Reset" button on the control panel and cycling the engine keyswitch.
  • Use INSITE™ electronic service tool to verify inactive fault codes are cleared.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Go to 7B

Appropriate troubleshooting steps

Guided Step 7B - Verify the fault code is inactive.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2811 is inactive.

Fault Code 2811 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 30-Jan-2013


FAULT CODE 2812 - Engine Throttle Control Actuator - Data Erratic, Intermittent or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

There may be other generator set fault codes activated as a result of Fault Code 2812 being triggered. To avoid the possibility of damaging a new digital throttle assembly, all other active fault codes must be investigated and rectified before replacing the digital throttle assembly.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes or high counts of inactive fault codes. |
 | STEP 1A. Check for active fault codes or high counts of inactive fault codes. | Active fault codes and /or high counts of inactive fault codes present?
STEP 2. | Check the digital throttle assembly. |
 | STEP 2A. Check the response of the digital throttle assembly. | Digital throttle assembly response OK?
STEP 3. | Check the proprietary data link. |
 | STEP 3A. Check the proprietary data link circuit. | Proprietary data link circuit OK?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 2812 inactive?
 | STEP 4B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes or high counts of inactive fault codes.

Guided Step 1A - Check for active fault codes or high counts of inactive fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes or high counts of inactive fault codes.

  • Use INSITE™ electronic service tool to read the active and inactive fault codes.

Active fault codes and /or high counts of inactive fault codes present?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 4A

Go to 2A

Guided Step 2 - Check the digital throttle assembly.

Guided Step 2A - Check the response of the digital throttle assembly.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check the response of the digital throttle assembly.

  • Use INSITE™ electronic service tool to perform the Actuator Diagnostic Test.

Contact a Cummins® Authorized Repair Location.

Digital throttle assembly response OK?
YES NO
No Repair

Repair

Replace the digital throttle assembly.

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 005-052 in Section 5.

Go to 3A

Go to 4A

Guided Step 3 - Check the proprietary data link.

Guided Step 3A - Check the proprietary data link circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness from the throttle actuator, CM700, and CM558 left-bank connector A.

Action

Check the proprietary data link circuit

  • Loose connector
  • Refer to Procedure 019-417 in Section 19.

Proprietary data link circuit OK?
YES NO
No Repair

Repair

A problem has been detected in the proprietary data link circuit in the engine harness.

Repair or replace the engine harness.

  • Locate and check the resistance of the engine harness 120 ohm termination resistor. Reference the Engine Wiring Diagrams 4021359 or 4022031.
  • If the termination resistor does not measure 120 ohms resistance, replace the resistor.
  • Measure the resistance of the second 120 ohm termination resistor located in the generator interface box. Reference the Cummins Power Generation™, Generator Interface Panel wiring diagrams for resistor location.
  • If the second termination resistor does not measure 120 ohms, replace the resistor. Contact a Cummins® Authorized Repair Location.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify Fault Code 2812 is inactive.

Fault Code 2812 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting charta

Last Modified: 16-Feb-2011


FAULT CODE 2814 - Engine Electronic Fuel Control Valve 1 Circuit - Root Cause Not Known

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Fault Code 2184 active or high inactive counts?
STEP 2. | Check the fuel control valve (FCV) actuator. |
 | STEP 2A. Inspect the actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the actuator commanded position percent pulse-width modulated (PMW) duty cycle signal. | Percent duty cycle 10 to 94 percent?
 | STEP 2C. Check the actuator commanded position feedback signal. | 0 to 5-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harnesses and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less then 10 ohms?
 | STEP 3C. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3D. Check for an intermittent engine harness malfunction. | Fault Code 2184 and/or 2311, 2864, 2866 and 2867 active?
STEP 4. | Check the ECM. |
 | STEP 4A. Check the fuel control valve commanded position percent PWM duty cycle signal at the CM558 connector. | Percent duty cycle 10 to 94 percent?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 2184 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2184 active or high inactive counts?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 5A

Guided Step 2 - Clear the fuel control valve actuator.

Guided Step 2A - Inspect the actuator and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the fuel control valve actuator.

Action

Inspect the actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness, the harness connector, or the fuel control valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel control valve. Refer to Procedure 006-049 in Section 6 of the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin Number 4021396.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the fuel control valve actuator commanded signal percent duty cycle.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a number of positions between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the fuel control valve actuator position SIGNAL (+) and RETURN (–) pins at the fuel control valve actuator connector. The signal percent duty cycle must be between 10 and 94 percent based on the fuel control valve actuator position.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Refer to the specification table provided in the Shop Talk section of this document for commanded position percent duty cycle specifications.

Percent duty cycle 10 to 94 percent?
YES NO
No Repair

Repair

Check the power supply connections and the fuses. Refer to the engine wiring diagram for the appropriate circuit.

Go to 2C

Go to 3A

Guided Step 2C - Check the fuel control valve feedback signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve feedback signal voltage.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the signal feedback voltage by connecting the multimeter test probes between the fuel control valve actuator position feedback and RETURN (–) pins. The feedback signal must be between 0 to 5-VDC.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-059 in Section 19.

0 to 5-VDC?
YES NO
No Repair

Repair

Replace the fuel control valve.

  • Replace the fuel control valve. Refer to Procedure 006-049 in Section 6 of the QSK60G Generator CM700 Troubleshooting and Repair Manual, Service Bulletin 4021396.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harnesses and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the CM558 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Wiring harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Connect the engine harness to the fuel control valve actuator.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve. Refer to the wiring diagram to identify shared sensors.
  • Disconnect the engine harness from the left-bank CM558 module.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the fuel control valve actuator SIGNAL pin at the fuel control valve connector and the fuel control valve actuator SIGNAL pin at the CM558 module connector of the engine harness.
  • Measure the resistance between the fuel control valve actuator RETURN pin at the fuel control valve connector and the fuel control valve actuator RETURN pin at the CM558 module connector of the engine harness.

Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check the engine harness for a short-to-ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the CM558 module.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator. Refer to the wiring diagram to identify shared sensors

Action

Check the engine harness and fuel control valve actuator resistance.

  • Measure the resistance from the fuel control valve actuator SIGNAL pin in the engine harness CM558 connector to the engine block ground.
  • Measure the resistance from the fuel control valve actuator feedback pin in the engine harness CM558 connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the appropriate wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an intermittent engine harness malfunction.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode at rated speed, no load.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or malfunction.

  • Manipulate the engine harness starting at the ECM engine harness connector and working to the fuel control valve actuator connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

If a short or open circuit is induced while the engine is operating, a warning or shutdown alarm and corresponding fault code will be activated.

Fault Code 2184 and/or 2311, 2864, 2866 and 2867 become active?
YES NO

Repair

An intermittent connection has been detected in the engine harness.

Repair or replace the engine harness.

  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM.

Guided Step 4A - Check the fuel control valve commanded position percent PWM duty cycle signal at the CM558 connector.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle at the left bank CM558 connector B.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a number of positions between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the fuel control valve actuator position SIGNAL (+) and RETURN (–) pins at the CM558 connector. The signal percent duty cycle must be between 10 and 94 percent based on the fuel control valve actuator position.

Use the appropriate wiring diagram to identify the SIGNAL and RETURN pins.

Refer to the specification table provided in the Shop Talk section of this document for commanded position percent duty cycle specifications.

Percent duty cycle 10 to 94 percent?
YES NO
No Repair

Repair

A fault code has been detected with the CM558 module.

  • Replace the left bank CM558 module. Refer to Procedure 019-031 in Section 19.
  • Contact a local Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for more than 1 minute.

Action

  • Use INSITE™ electronic service tool to verify that Fault Code 2184 is inactive.

Fault Code 2184 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Appropriate troubleshooting chart.

Last Modified: 09-May-2012


FAULT CODE 2837 (Multiple Turbochargers) - Exhaust Gas Temperature Cylinder 1 (A1) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2469 and/or 2766 active?
STEP 2. | Check the spark plug on cylinder 1. |
 | STEP 2A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 1. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2837 inactive and Fault Code 2838 active?
 | STEP 4B. Check the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the exhaust gas temperature circuit for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 1 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check cylinder 1 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Cylinder 1 power cylinder damaged?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2837 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2469 and/or 2766 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 1.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • "J" connector damaged.
  • Oil contamination on electrode.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary.

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 1.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube
  • Check the ignition coil primary and secondary resistances.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil or the ignition coil extension tube o-ring. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify harness terminations, connectors, and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the ignition harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and ignition module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 1 exhaust gas temperature sensor response:

  • Remove the exhaust gastemperature sensor connectorfrom cylinder 1
  • Install the temperature sensor from cylinder 1 to cylinder 3.
  • Install the temperature sensor from cylinder 3 to cylinder 1.
  • Reconnect the exhaust temperature sensors.

Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2837 is inactive and that Fault Code 2838 is active.

Fault Code 2837 inactive and Fault Code 2838 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in cylinder 1 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 1 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 1 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 1 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 1 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 1 overhead set is correct.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 1 overhead setting correct?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder 1 power cylinder.

Guided Step 6A - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (If available, these inspections can be performed using a borescope without component removal):

  • Damage to the cylinder head intake or exhaust valves
  • Damage to the cylinder head intake or exhaust valve seats.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 1 power cylinder damaged?
YES NO

Repair

Repair or replace the cylinder head.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2837 is inactive.

Fault Code 2837 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Dec-2010


FAULT CODE 2837 (Single Turbocharger) - Exhaust Gas Temperature Cylinder 1 (A1) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2469 and/or 2766 active?
STEP 2. | Check the spark plug on cylinder 1. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2837 inactive, Fault Code 2838 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 1 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Inspect cylinder 1 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2837 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

N/A

Fault Code 2469 and/or 2766 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 1.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug 'J' connector damaged
  • Electrode has signs of oil contamination
  • Spark plug procelain damaged. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug.

  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system

Guided Step 3A - Check the ignition coil on cylinder 1.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.
  • Pushed back or expanded pins

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors inthe circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

  • Repair or replace the ignition harness or the harness connector.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harnessconnector to the ignition SUPPLY input pin in the ignition coilconnector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram toidentify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • De-engergize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 1 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 1 and 3.
  • Install the temperature sensor from cylinder 1 to cylinder 3.
  • Install the temperature sensor from cylinder 3 to cylinder 1.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 13.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check Fault Code 2837 is inactive and Fault Code 2838 is active.

Fault Code 2837 inactive and Fault Code 2838 active?
YES NO
No Repair

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 1 location. Refer to Procedure 019-013 in Section 13.

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from cylinder 1 exhaust gas temperature sensor.

Action

Check the 5 volt supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 1.
  • Refer to the wiring diagram for harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 1 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Replace the ignition harness.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 1 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 1 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust gas temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CM850 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5 volt SUPPLY pin in the engine harness CM850 module connector to the exhaust gas temperature 5 volt.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram toidentify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 1 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-engergize keyswitch circuit.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Check that the cylinder 1 overhead setting is correct.

  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspection of cylinder 1 power cylinder.

Guided Step 6A - Check the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Inspect the internal power cylinder for the following. If available, these inspections can be performed using a borescope without component removal.

  • Cylinder head – intake or exhaust valve / valve seat for any damage.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Refer to Procedure 003-006 in Section 3.

  • Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energized keyswitch circuit.
  • Place run/stop/auto switch in Run mode and running for more than 1 minute.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 2837 is inactive.

Fault Code 2837 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Engergize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 14-Dec-2010


FAULT CODE 2838 (Multiple Turbochargers) - Exhaust Gas Temperature Cylinder 3 (A2) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2471 and/or 2766 active?
STEP 2. | Check the spark plug on cylinder 3. |
 | STEP 2A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 3. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2838 inactive and Fault Code 2837 active?
 | STEP 4B. Check the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the exhaust gas temperature circuit for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 3 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check cylinder 3 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Cylinder 3 power cylinder damaged?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2838 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2469 and/or 2766 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 3.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • "J" connector damaged.
  • Oil contamination on electrode.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary.

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 3.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube
  • Check the ignition coil primary and secondary resistances.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil or the ignition coil extension tube o-ring. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify harness terminations, connectors, and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the ignition harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and ignition module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 3 exhaust gas temperature sensor response:

  • Remove the exhaust gastemperature sensor connectorfrom cylinder 3
  • Install the temperature sensor from cylinder 3 to cylinder 1.
  • Install the temperature sensor from cylinder 1 to cylinder 3.
  • Reconnect the exhaust temperature sensors.

Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2838 is inactive and that Fault Code 2837 is active.

Fault Code 2838 inactive and Fault Code 2837 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in cylinder 3 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 3 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 3 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 3 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 3 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 3 overhead set is correct.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

cylinder 3 overhead setting correct?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder 3 power cylinder.

Guided Step 6A - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (If available, these inspections can be performed using a borescope without component removal):

  • Damage to the cylinder head intake or exhaust valves
  • Damage to the cylinder head intake or exhaust valve seats.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 3 power cylinder damaged?
YES NO

Repair

Repair or replace the cylinder head.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2838 is inactive.

Fault Code 2838 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 19-Jan-2011


FAULT CODE 2838 (Single Turbocharger) - Exhaust Gas Temperature Cylinder 3 (A2) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2471 and/or 2766 active?
STEP 2. | Check the spark plug on cylinder 3. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2837 inactive, Fault Code 2838 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 3 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Inspect cylinder 3 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2837 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

N/A

Fault Code 2471 and/or 2766 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 3.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug 'J' connector damaged
  • Electrode has signs of oil contamination
  • Spark plug procelain damaged. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug.

  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system

Guided Step 3A - Check the ignition coil on cylinder 3.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.
  • Pushed back or expanded pins

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors inthe circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

  • Repair or replace the ignition harness or the harness connector.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harnessconnector to the ignition SUPPLY input pin in the ignition coilconnector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram toidentify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • De-engergize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 3 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 1 and 3.
  • Install the temperature sensor from cylinder 1 to cylinder 3.
  • Install the temperature sensor from cylinder 3 to cylinder 1.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 13.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check Fault Code 2837 is inactive and Fault Code 2838 is active.

Fault Code 2837 inactive and Fault Code 2838 active?
YES NO
No Repair

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 3 location. Refer to Procedure 019-013 in Section 13.

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from cylinder 3 exhaust gas temperature sensor.

Action

Check the 5 volt supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 3.
  • Refer to the wiring diagram for harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 3 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Replace the ignition harness.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 3 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 3 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust gas temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CM850 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5 volt SUPPLY pin in the engine harness CM850 module connector to the exhaust gas temperature 5 volt.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram toidentify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 3 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-engergize keyswitch circuit.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Check that the cylinder 3 overhead setting is correct.

  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspection of cylinder 3 power cylinder.

Guided Step 6A - Check the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Inspect the internal power cylinder for the following. If available, these inspections can be performed using a borescope without component removal.

  • Cylinder head – intake or exhaust valve / valve seat for any damage.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Refer to Procedure 003-006 in Section 3.

  • Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energized keyswitch circuit.
  • Place run/stop/auto switch in Run mode and running for more than 1 minute.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 2838 is inactive.

Fault Code 2838 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Engergize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Dec-2010


FAULT CODE 2839 (Multiple Turbochargers) - Exhaust Gas Temperature Cylinder 5 (A3) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2472 and/or 2766 active?
STEP 2. | Check the spark plug on cylinder 5. |
 | STEP 2A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 5. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2839 inactive and Fault Code 2841 active?
 | STEP 4B. Check the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the exhaust gas temperature circuit for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 5 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check cylinder 5 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Cylinder 5 power cylinder damaged?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2839 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2472 and/or 2766 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 5.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • "J" connector damaged.
  • Oil contamination on electrode.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary.

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 5.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube
  • Check the ignition coil primary and secondary resistances.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil or the ignition coil extension tube o-ring. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify harness terminations, connectors, and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the ignition harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and ignition module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 5 exhaust gas temperature sensor response:

  • Remove the exhaust gastemperature sensor connectorfrom cylinder 5
  • Install the temperature sensor from cylinder 5 to cylinder 7.
  • Install the temperature sensor from cylinder 7 to cylinder 5.
  • Reconnect the exhaust temperature sensors.

Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2839 is inactive and that Fault Code 2841 is active.

Fault Code 2839 inactive and Fault Code 2841 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in cylinder 5 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 5 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 5 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 5 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 5 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 5 overhead set is correct.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 5 overhead setting correct?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder 5 power cylinder.

Guided Step 6A - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (If available, these inspections can be performed using a borescope without component removal):

  • Damage to the cylinder head intake or exhaust valves
  • Damage to the cylinder head intake or exhaust valve seats.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 5 power cylinder damaged?
YES NO

Repair

Repair or replace the cylinder head.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2839 is inactive.

Fault Code 2839 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 19-Jan-2011


FAULT CODE 2839 (Single Turbocharger) - Exhaust Gas Temperature Cylinder 5 (A3) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2472 and/or 2766 active?
STEP 2. | Check the spark plug on cylinder 5. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 5. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2839 inactive, Fault Code 2841 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 5 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Inspect cylinder 5 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2839 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

N/A

Fault Code 2472 and/or 2766 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 5.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug 'J' connector damaged
  • Electrode has signs of oil contamination
  • Spark plug procelain damaged. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug.

  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system

Guided Step 3A - Check the ignition coil on cylinder 5.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.
  • Pushed back or expanded pins

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors inthe circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

  • Repair or replace the ignition harness or the harness connector.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harnessconnector to the ignition SUPPLY input pin in the ignition coilconnector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram toidentify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • De-engergize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 5 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 5 and 7.
  • Install the temperature sensor from cylinder 5 to cylinder 7.
  • Install the temperature sensor from cylinder 7 to cylinder 5.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 13.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check Fault Code 2837 is inactive and Fault Code 2838 is active.

Fault Code 2839 inactive and Fault Code 2841 active?
YES NO
No Repair

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 5 location. Refer to Procedure 019-013 in Section 13.

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from cylinder 5 exhaust gas temperature sensor.

Action

Check the 5 volt supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 5.
  • Refer to the wiring diagram for harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 5 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Replace the ignition harness.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 5 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 5 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust gas temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CM850 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5 volt SUPPLY pin in the engine harness CM850 module connector to the exhaust gas temperature 5 volt.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram toidentify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 5 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-engergize keyswitch circuit.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Check that the cylinder 5 overhead setting is correct.

  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspection of cylinder 5 power cylinder.

Guided Step 6A - Check the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Inspect the internal power cylinder for the following. If available, these inspections can be performed using a borescope without component removal.

  • Cylinder head – intake or exhaust valve / valve seat for any damage.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Refer to Procedure 003-006 in Section 3.

  • Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energized keyswitch circuit.
  • Place run/stop/auto switch in Run mode and running for more than 1 minute.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 2839 is inactive.

Fault Code 2839 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Engergize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Dec-2010


FAULT CODE 2841 (Multiple Turbochargers) - Exhaust Gas Temperature Cylinder 7 (A4) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2473 and/or 2766 active?
STEP 2. | Check the spark plug on cylinder 7. |
 | STEP 2A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 7. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2841 inactive and Fault Code 2839 active?
 | STEP 4B. Check the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the exhaust gas temperature circuit for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 7 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check cylinder 7 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Cylinder 7 power cylinder damaged?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2841 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2473 and/or 2766 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 7.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • "J" connector damaged.
  • Oil contamination on electrode.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary.

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 7.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube
  • Check the ignition coil primary and secondary resistances.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil or the ignition coil extension tube o-ring. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify harness terminations, connectors, and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the ignition harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and ignition module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 7 exhaust gas temperature sensor response:

  • Remove the exhaust gastemperature sensor connectorfrom cylinder 7.
  • Install the temperature sensor from cylinder 7 to cylinder 5.
  • Install the temperature sensor from cylinder 5 to cylinder 7.
  • Reconnect the exhaust temperature sensors.

Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2841 is inactive and that Fault Code 2839 is active.

Fault Code 2841 inactive and Fault Code 2839 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in cylinder 7 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 7 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 7 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 7 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 7 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 7 overhead set is correct.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 7 overhead setting correct?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder 7 power cylinder.

Guided Step 6A - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (If available, these inspections can be performed using a borescope without component removal):

  • Damage to the cylinder head intake or exhaust valves
  • Damage to the cylinder head intake or exhaust valve seats.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 7 power cylinder damaged?
YES NO

Repair

Repair or replace the cylinder head.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2841 is inactive.

Fault Code 2841 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 19-Jan-2011


FAULT CODE 2841 (Single Turbocharger) - Exhaust Gas Temperature Cylinder 7 (A4) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2473 and/or 2766 active?
STEP 2. | Check the spark plug on cylinder 7. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 7. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2841 inactive, Fault Code 2839 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 7 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Inspect cylinder 7 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2841 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

N/A

Fault Code 2473 and/or 2766 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 7.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug 'J' connector damaged
  • Electrode has signs of oil contamination
  • Spark plug procelain damaged. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug.

  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system

Guided Step 3A - Check the ignition coil on cylinder 7.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.
  • Pushed back or expanded pins

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors inthe circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

  • Repair or replace the ignition harness or the harness connector.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harnessconnector to the ignition SUPPLY input pin in the ignition coilconnector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram toidentify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • De-engergize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 7 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 7 and 5.
  • Install the temperature sensor from cylinder 7 to cylinder 5.
  • Install the temperature sensor from cylinder 5 to cylinder 7.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 13.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check Fault Code 2837 is inactive and Fault Code 2838 is active.

Fault Code 2841 inactive and Fault Code 2839 active?
YES NO
No Repair

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 7 location. Refer to Procedure 019-013 in Section 13.

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from cylinder 5 exhaust gas temperature sensor.

Action

Check the 5 volt supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 7.
  • Refer to the wiring diagram for harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 7 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Replace the ignition harness.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 7 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 7 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust gas temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CM850 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5 volt SUPPLY pin in the engine harness CM850 module connector to the exhaust gas temperature 5 volt.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram toidentify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 7 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-engergize keyswitch circuit.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Check that the cylinder 7 overhead setting is correct.

  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspection of cylinder 7 power cylinder.

Guided Step 6A - Check the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place Run/Stop/Auto switch in the STOP mode.

Action

Inspect the internal power cylinder for the following. If available, these inspections can be performed using a borescope without component removal.

  • Cylinder head – intake or exhaust valve / valve seat for any damage.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Refer to Procedure 003-006 in Section 3.

  • Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energized keyswitch circuit.
  • Place run/stop/auto switch in Run mode and running for more than 1 minute.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 2841 is inactive.

Fault Code 2841 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Engergize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Dec-2010


FAULT CODE 2842 (Multiple Turbochargers) - Exhaust Gas Temperature Cylinder 9 (A5) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2475 and/or 2766 active?
STEP 2. | Check the spark plug on cylinder 9. |
 | STEP 2A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 9. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2842 inactive and Fault Code 2843 active?
 | STEP 4B. Check the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the exhaust gas temperature circuit for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 9 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check cylinder 9 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Cylinder 9 power cylinder damaged?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2842 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2475 and/or 2766 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 9.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • "J" connector damaged.
  • Oil contamination on electrode.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary.

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 9.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube
  • Check the ignition coil primary and secondary resistances.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil or the ignition coil extension tube o-ring. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify harness terminations, connectors, and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the ignition harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and ignition module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 9 exhaust gas temperature sensor response:

  • Remove the exhaust gastemperature sensor connectorfrom cylinder 9
  • Install the temperature sensor from cylinder 9 to cylinder 11.
  • Install the temperature sensor from cylinder 11 to cylinder 9.
  • Reconnect the exhaust temperature sensors.

Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2842 is inactive and that Fault Code 2843 is active.

Fault Code 2842 inactive and Fault Code 2843 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in cylinder 9 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 9 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 9 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 9 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 9 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 9 overhead set is correct.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 9 overhead setting correct?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder 9 power cylinder.

Guided Step 6A - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (If available, these inspections can be performed using a borescope without component removal):

  • Damage to the cylinder head intake or exhaust valves
  • Damage to the cylinder head intake or exhaust valve seats.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 9 power cylinder damaged?
YES NO

Repair

Repair or replace the cylinder head.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2842 is inactive.

Fault Code 2842 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 19-Jan-2011


FAULT CODE 2842 (Single Turbocharger) - Exhaust Gas Temperature Cylinder 9 (A5) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2475 and/or 2766 active?
STEP 2. | Check the spark plug on cylinder 9. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 9. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2842 inactive, Fault Code 2843 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 9 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Inspect cylinder 9 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2842 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

N/A

Fault Code 2475 and/or 2766 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 9.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug 'J' connector damaged
  • Electrode has signs of oil contamination
  • Spark plug procelain damaged. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug.

  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system

Guided Step 3A - Check the ignition coil on cylinder 9.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.
  • Pushed back or expanded pins

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors inthe circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

  • Repair or replace the ignition harness or the harness connector.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harnessconnector to the ignition SUPPLY input pin in the ignition coilconnector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram toidentify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • De-engergize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 9 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 9 and 11.
  • Install the temperature sensor from cylinder 9 to cylinder 11.
  • Install the temperature sensor from cylinder 11 to cylinder 9.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 13.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check Fault Code 2837 is inactive and Fault Code 2838 is active.

Fault Code 2842 inactive and Fault Code 2843 active?
YES NO
No Repair

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 9 location. Refer to Procedure 019-013 in Section 13.

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from cylinder 5 exhaust gas temperature sensor.

Action

Check the 5 volt supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 9.
  • Refer to the wiring diagram for harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 7 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Replace the ignition harness.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 9 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 9 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust gas temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CM850 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5 volt SUPPLY pin in the engine harness CM850 module connector to the exhaust gas temperature 5 volt.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram toidentify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 9 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check that the cylinder 9 overhead setting is correct.

  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspection of cylinder 9 power cylinder.

Guided Step 6A - Check the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Inspect the internal power cylinder for the following. If available, these inspections can be performed using a borescope without component removal.

  • Cylinder head – intake or exhaust valve / valve seat for any damage.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Refer to Procedure 003-006 in Section 3.

  • Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energized keyswitch circuit.
  • Place run/stop/auto switch in Run mode and running for more than 1 minute.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 2842 is inactive.

Fault Code 2842 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Engergize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Dec-2010


FAULT CODE 2843 (Multiple Turbochargers) - Exhaust Gas Temperature Cylinder 11 (A6) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2476 and/or 2766 active?
STEP 2. | Check the spark plug on cylinder 11. |
 | STEP 2A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 11. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2843 inactive and Fault Code 2842 active?
 | STEP 4B. Check the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the exhaust gas temperature circuit for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 11 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check cylinder 11 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Cylinder 11 power cylinder damaged?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2843 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2476 and/or 2766 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 11.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • "J" connector damaged.
  • Oil contamination on electrode.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary.

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 11.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube
  • Check the ignition coil primary and secondary resistances.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil or the ignition coil extension tube o-ring. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify harness terminations, connectors, and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the ignition harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and ignition module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 11 exhaust gas temperature sensor response:

  • Remove the exhaust gastemperature sensor connectorfrom cylinder 11
  • Install the temperature sensor from cylinder 11 to cylinder 9.
  • Install the temperature sensor from cylinder 9 to cylinder 11.
  • Reconnect the exhaust temperature sensors.

Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2843 is inactive and that Fault Code 2842 is active.

Fault Code 2843 inactive and Fault Code 2842 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in cylinder 11 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 11 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 11 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 11 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 11 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 11 overhead set is correct.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 11 overhead setting correct?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder 11 power cylinder.

Guided Step 6A - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (If available, these inspections can be performed using a borescope without component removal):

  • Damage to the cylinder head intake or exhaust valves
  • Damage to the cylinder head intake or exhaust valve seats.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 11 power cylinder damaged?
YES NO

Repair

Repair or replace the cylinder head.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2843 is inactive.

Fault Code 2843 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 19-Jan-2011


FAULT CODE 2843 (Single Turbocharger) - Exhaust Gas Temperature Cylinder 11 (A6) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2476 and/or 2766 active?
STEP 2. | Check the spark plug on cylinder 11. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 11. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2843 inactive, Fault Code 2842 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 11 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Inspect cylinder 11 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2843 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

N/A

Fault Code 2476 and/or 2766 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 11.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug 'J' connector damaged
  • Electrode has signs of oil contamination
  • Spark plug procelain damaged. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug.

  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system

Guided Step 3A - Check the ignition coil on cylinder 11.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.
  • Pushed back or expanded pins

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors inthe circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

  • Repair or replace the ignition harness or the harness connector.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harnessconnector to the ignition SUPPLY input pin in the ignition coilconnector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram toidentify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • De-engergize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 11 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 11 and 9.
  • Install the temperature sensor from cylinder 11 to cylinder 9.
  • Install the temperature sensor from cylinder 9 to cylinder 11.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 13.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check Fault Code 2843 is inactive and Fault Code 2842 is active.

Fault Code 2843 inactive and Fault Code 2842 active?
YES NO
No Repair

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 11 location. Refer to Procedure 019-013 in Section 13.

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from cylinder 11 exhaust gas temperature sensor.

Action

Check the 5 volt supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 9.
  • Refer to the wiring diagram for harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 11 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Replace the ignition harness.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 11 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 11 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust gas temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CM850 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5 volt SUPPLY pin in the engine harness CM850 module connector to the exhaust gas temperature 5 volt.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram toidentify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 11 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check that the cylinder 11 overhead setting is correct.

  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspection of cylinder 11 power cylinder.

Guided Step 6A - Check the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Inspect the internal power cylinder for the following. If available, these inspections can be performed using a borescope without component removal.

  • Cylinder head – intake or exhaust valve / valve seat for any damage.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Refer to Procedure 003-006 in Section 3.

  • Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energized keyswitch circuit.
  • Place run/stop/auto switch in Run mode and running for more than 1 minute.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 2843 is inactive.

Fault Code 2843 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Engergize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Dec-2010


FAULT CODE 2844 (Multiple Turbochargers) - Exhaust Gas Temperature Cylinder 13 (A7) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2477 and/or 2766 active?
STEP 2. | Check the spark plug on cylinder 13. |
 | STEP 2A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 13. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2844 inactive and Fault Code 2845 active?
 | STEP 4B. Check the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the exhaust gas temperature circuit for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 13 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check cylinder 13 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Cylinder 13 power cylinder damaged?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2844 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2477 and/or 2766 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 13.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • "J" connector damaged.
  • Oil contamination on electrode.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary.

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 13.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube
  • Check the ignition coil primary and secondary resistances.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil or the ignition coil extension tube o-ring. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify harness terminations, connectors, and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the ignition harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and ignition module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 13 exhaust gas temperature sensor response:

  • Remove the exhaust gastemperature sensor connectorfrom cylinder 13.
  • Install the temperature sensor from cylinder 13 to cylinder 15.
  • Install the temperature sensor from cylinder 15 to cylinder 13.
  • Reconnect the exhaust temperature sensors.

Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2844 is inactive and that Fault Code 2845 is active.

Fault Code 2844 inactive and Fault Code 2845 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in cylinder 13 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 13 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 13 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 13 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 13 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 13 overhead set is correct.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 13 overhead setting correct?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder 13 power cylinder.

Guided Step 6A - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (If available, these inspections can be performed using a borescope without component removal):

  • Damage to the cylinder head intake or exhaust valves
  • Damage to the cylinder head intake or exhaust valve seats.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 13 power cylinder damaged?
YES NO

Repair

Repair or replace the cylinder head.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2844 is inactive.

Fault Code 2844 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 19-Jan-2011


FAULT CODE 2844 (Single Turbocharger) - Exhaust Gas Temperature Cylinder 13 (A7) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2477 and/or 2766 active?
STEP 2. | Check the spark plug on cylinder 13. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 13. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2844 inactive, Fault Code 2845 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 13 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Inspect cylinder 13 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2844 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

N/A

Fault Code 2477 and/or 2766 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 13.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug 'J' connector damaged
  • Electrode has signs of oil contamination
  • Spark plug procelain damaged. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug.

  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system

Guided Step 3A - Check the ignition coil on cylinder 13.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.
  • Pushed back or expanded pins

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors inthe circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

  • Repair or replace the ignition harness or the harness connector.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harnessconnector to the ignition SUPPLY input pin in the ignition coilconnector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram toidentify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • De-engergize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 13 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 13 and 15.
  • Install the temperature sensor from cylinder 13 to cylinder 15.
  • Install the temperature sensor from cylinder 15 to cylinder 13.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 13.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check Fault Code 2843 is inactive and Fault Code 2842 is active.

Fault Code 2844 inactive and Fault Code 2845 active?
YES NO
No Repair

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 13 location. Refer to Procedure 019-013 in Section 13.

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from cylinder 13 exhaust gas temperature sensor.

Action

Check the 5 volt supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 13.
  • Refer to the wiring diagram for harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 13 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Replace the ignition harness.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 13 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 13 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust gas temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CM850 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5 volt SUPPLY pin in the engine harness CM850 module connector to the exhaust gas temperature 5 volt.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram toidentify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 13 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check that the cylinder 13 overhead setting is correct.

  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspection of cylinder 13 power cylinder.

Guided Step 6A - Check the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Inspect the internal power cylinder for the following. If available, these inspections can be performed using a borescope without component removal.

  • Cylinder head – intake or exhaust valve / valve seat for any damage.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Refer to Procedure 003-006 in Section 3.

  • Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energized keyswitch circuit.
  • Place run/stop/auto switch in Run mode and running for more than 1 minute.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 2844 is inactive.

Fault Code 2844 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Engergize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Dec-2010


FAULT CODE 2845 (Multiple Turbochargers) - Exhaust Gas Temperature Cylinder 15 (A8) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2478 and/or 2766 active?
STEP 2. | Check the spark plug on cylinder 15. |
 | STEP 2A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 15. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2845 inactive and Fault Code 2844 active?
 | STEP 4B. Check the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the exhaust gas temperature circuit for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 15 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check cylinder 15 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Cylinder 15 power cylinder damaged?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2845 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2478 and/or 2766 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 15.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • "J" connector damaged.
  • Oil contamination on electrode.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary.

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 15.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube
  • Check the ignition coil primary and secondary resistances.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil or the ignition coil extension tube o-ring. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify harness terminations, connectors, and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the ignition harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and ignition module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 15 exhaust gas temperature sensor response:

  • Remove the exhaust gastemperature sensor connectorfrom cylinder 15.
  • Install the temperature sensor from cylinder 15 to cylinder 13.
  • Install the temperature sensor from cylinder 13 to cylinder 15.
  • Reconnect the exhaust temperature sensors.

Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2845 is inactive and that Fault Code 2844 is active.

Fault Code 2845 inactive and Fault Code 2844 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in cylinder 15 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 15 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 15 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 15 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 15 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 15 overhead set is correct.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 15 overhead setting correct?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder 15 power cylinder.

Guided Step 6A - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (If available, these inspections can be performed using a borescope without component removal):

  • Damage to the cylinder head intake or exhaust valves
  • Damage to the cylinder head intake or exhaust valve seats.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 15 power cylinder damaged?
YES NO

Repair

Repair or replace the cylinder head.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2845 is inactive.

Fault Code 2845 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 19-Jan-2011


FAULT CODE 2845 (Single Turbocharger) - Exhaust Gas Temperature Cylinder 15 (A8) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2478 and/or 2766 active?
STEP 2. | Check the spark plug on cylinder 15. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 15. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2845 inactive, Fault Code 2844 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 15 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Inspect cylinder 15 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2845 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

N/A

Fault Code 2478 and/or 2766 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 15.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug 'J' connector damaged
  • Electrode has signs of oil contamination
  • Spark plug procelain damaged. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug.

  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system

Guided Step 3A - Check the ignition coil on cylinder 15.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.
  • Pushed back or expanded pins

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors inthe circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

  • Repair or replace the ignition harness or the harness connector.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harnessconnector to the ignition SUPPLY input pin in the ignition coilconnector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram toidentify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • De-engergize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 15 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 15 and 13.
  • Install the temperature sensor from cylinder 15 to cylinder 13.
  • Install the temperature sensor from cylinder 13 to cylinder 15.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 13.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check Fault Code 2845 is inactive and Fault Code 2844 is active.

Fault Code 2845 inactive and Fault Code 2844 active?
YES NO
No Repair

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 15 location. Refer to Procedure 019-013 in Section 13.

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from cylinder 15 exhaust gas temperature sensor.

Action

Check the 5 volt supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 15.
  • Refer to the wiring diagram for harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 15 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Replace the ignition harness.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 15 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 15 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust gas temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CM850 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5 volt SUPPLY pin in the engine harness CM850 module connector to the exhaust gas temperature 5 volt.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram toidentify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 15 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check that the cylinder 13 overhead setting is correct.

  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspection of cylinder 15 power cylinder.

Guided Step 6A - Check the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Inspect the internal power cylinder for the following. If available, these inspections can be performed using a borescope without component removal.

  • Cylinder head – intake or exhaust valve / valve seat for any damage.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Refer to Procedure 003-006 in Section 3.

  • Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energized keyswitch circuit.
  • Place run/stop/auto switch in Run mode and running for more than 1 minute.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 2845 is inactive.

Fault Code 2845 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Engergize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Dec-2010


FAULT CODE 2847 (Multiple Turbochargers) - Exhaust Gas Temperature Cylinder 2 (B1) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2458 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 2. |
 | STEP 2A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 2. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2847 inactive and Fault Code 2848 active?
 | STEP 4B. Check the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the exhaust gas temperature circuit for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 2 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check cylinder 2 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Cylinder 2 power cylinder damaged?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2847 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2458 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 2.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • "J" connector damaged.
  • Oil contamination on electrode.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary.

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 2.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube
  • Check the ignition coil primary and secondary resistances.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil or the ignition coil extension tube o-ring. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify harness terminations, connectors, and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the ignition harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and ignition module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 2 exhaust gas temperature sensor response:

  • Remove the exhaust gastemperature sensor connectorfrom cylinder 2.
  • Install the temperature sensor from cylinder 2 to cylinder 4.
  • Install the temperature sensor from cylinder 4 to cylinder 2.
  • Reconnect the exhaust temperature sensors.

Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2847 is inactive and that Fault Code 2848 is active.

Fault Code 2847 inactive and Fault Code 2848 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in cylinder 2 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 2 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 2 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 2 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 2 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 2 overhead set is correct.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 2 overhead setting correct?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder 2 power cylinder.

Guided Step 6A - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (If available, these inspections can be performed using a borescope without component removal):

  • Damage to the cylinder head intake or exhaust valves
  • Damage to the cylinder head intake or exhaust valve seats.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 2 power cylinder damaged?
YES NO

Repair

Repair or replace the cylinder head.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2847 is inactive.

Fault Code 2847 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 19-Jan-2011


FAULT CODE 2847 (Single Turbocharger) - Exhaust Gas Temperature Cylinder 2 (B1) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2458 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 2. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 2. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2847 inactive, Fault Code 2848 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 2 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Inspect cylinder 2 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2847 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

N/A

Fault Code 2458 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 2.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug 'J' connector damaged
  • Electrode has signs of oil contamination
  • Spark plug procelain damaged. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug.

  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system

Guided Step 3A - Check the ignition coil on cylinder 2.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.
  • Pushed back or expanded pins

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors inthe circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

  • Repair or replace the ignition harness or the harness connector.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harnessconnector to the ignition SUPPLY input pin in the ignition coilconnector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram toidentify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • De-engergize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 2 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 2 and 4.
  • Install the temperature sensor from cylinder 2 to cylinder 4.
  • Install the temperature sensor from cylinder 4 to cylinder 2.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 13.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check Fault Code 2847 is inactive and Fault Code 2848 is active.

Fault Code 2847 inactive and Fault Code 2448 active?
YES NO
No Repair

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 2 location. Refer to Procedure 019-013 in Section 13.

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from cylinder 2 exhaust gas temperature sensor.

Action

Check the 5 volt supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 2.
  • Refer to the wiring diagram for harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 2 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Replace the ignition harness.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 2 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 2 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust gas temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CM850 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5 volt SUPPLY pin in the engine harness CM850 module connector to the exhaust gas temperature 5 volt.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram toidentify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 2 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check that the cylinder 2 overhead setting is correct.

  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspection of cylinder 2 power cylinder.

Guided Step 6A - Check the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Inspect the internal power cylinder for the following. If available, these inspections can be performed using a borescope without component removal.

  • Cylinder head – intake or exhaust valve / valve seat for any damage.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Refer to Procedure 003-006 in Section 3.

  • Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energized keyswitch circuit.
  • Place run/stop/auto switch in Run mode and running for more than 1 minute.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 2847 is inactive.

Fault Code 2847 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Engergize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Dec-2010


FAULT CODE 2848 (Multiple Turbochargers) - Exhaust Gas Temperature Cylinder 4 (B2) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2459 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 4. |
 | STEP 2A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 4. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2848 inactive and Fault Code 2847 active?
 | STEP 4B. Check the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the exhaust gas temperature circuit for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 4 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check cylinder 4 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Cylinder 4 power cylinder damaged?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2848 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2459 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 4.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • "J" connector damaged.
  • Oil contamination on electrode.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary.

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 4.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube
  • Check the ignition coil primary and secondary resistances.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil or the ignition coil extension tube o-ring. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify harness terminations, connectors, and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the ignition harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and ignition module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 4 exhaust gas temperature sensor response:

  • Remove the exhaust gastemperature sensor connectorfrom cylinder 4.
  • Install the temperature sensor from cylinder 4 to cylinder 2.
  • Install the temperature sensor from cylinder 2 to cylinder 4.
  • Reconnect the exhaust temperature sensors.

Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2848 is inactive and that Fault Code 2847 is active.

Fault Code 2848 inactive and Fault Code 2847 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in cylinder 4 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 4 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 4 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 4 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 4 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 4 overhead set is correct.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 4 overhead setting correct?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder 4 power cylinder.

Guided Step 6A - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (If available, these inspections can be performed using a borescope without component removal):

  • Damage to the cylinder head intake or exhaust valves
  • Damage to the cylinder head intake or exhaust valve seats.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 4 power cylinder damaged?
YES NO

Repair

Repair or replace the cylinder head.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2848 is inactive.

Fault Code 2848 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 19-Jan-2011


FAULT CODE 2848 (Single Turbocharger) - Exhaust Gas Temperature Cylinder 4 (B2) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2459 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 4. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 4. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2848 inactive, Fault Code 2847 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 4 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Inspect cylinder 4 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2848 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

N/A

Fault Code 2459 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 4.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug 'J' connector damaged
  • Electrode has signs of oil contamination
  • Spark plug procelain damaged. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug.

  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system

Guided Step 3A - Check the ignition coil on cylinder 4.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.
  • Pushed back or expanded pins

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors inthe circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

  • Repair or replace the ignition harness or the harness connector.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harnessconnector to the ignition SUPPLY input pin in the ignition coilconnector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram toidentify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • De-engergize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 4 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 4 and 2.
  • Install the temperature sensor from cylinder 4 to cylinder 2.
  • Install the temperature sensor from cylinder 2 to cylinder 4.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 13.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check Fault Code 2848 is inactive and Fault Code 2847 is active.

Fault Code 2848 inactive and Fault Code 2447 active?
YES NO
No Repair

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 4 location. Refer to Procedure 019-013 in Section 13.

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from cylinder 4 exhaust gas temperature sensor.

Action

Check the 5 volt supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 4.
  • Refer to the wiring diagram for harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 4 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Replace the ignition harness.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 4 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 4 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust gas temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CM850 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5 volt SUPPLY pin in the engine harness CM850 module connector to the exhaust gas temperature 5 volt.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram toidentify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 4 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check that the cylinder 4 overhead setting is correct.

  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspection of cylinder 4 power cylinder.

Guided Step 6A - Check the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Inspect the internal power cylinder for the following. If available, these inspections can be performed using a borescope without component removal.

  • Cylinder head – intake or exhaust valve / valve seat for any damage.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Refer to Procedure 003-006 in Section 3.

  • Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energized keyswitch circuit.
  • Place run/stop/auto switch in Run mode and running for more than 1 minute.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 2848 is inactive.

Fault Code 2848 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Engergize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Dec-2010


FAULT CODE 2849 (Multiple Turbochargers) - Exhaust Gas Temperature Cylinder 6 (B3) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2461 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 6. |
 | STEP 2A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 6. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2849 inactive and Fault Code 2851 active?
 | STEP 4B. Check the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the exhaust gas temperature circuit for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 6 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check cylinder 6 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Cylinder 6 power cylinder damaged?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2849 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2461 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 6.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • "J" connector damaged.
  • Oil contamination on electrode.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary.

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 6.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube
  • Check the ignition coil primary and secondary resistances.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil or the ignition coil extension tube o-ring. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify harness terminations, connectors, and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the ignition harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and ignition module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 6 exhaust gas temperature sensor response:

  • Remove the exhaust gastemperature sensor connectorfrom cylinder 6.
  • Install the temperature sensor from cylinder 6 to cylinder 8.
  • Install the temperature sensor from cylinder 8 to cylinder 6.
  • Reconnect the exhaust temperature sensors.

Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2849 is inactive and that Fault Code 2851 is active.

Fault Code 2849 inactive and Fault Code 2851 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in cylinder 6 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 6 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 6 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 6 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 6 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 6 overhead set is correct.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 6 overhead setting correct?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder 6 power cylinder.

Guided Step 6A - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (If available, these inspections can be performed using a borescope without component removal):

  • Damage to the cylinder head intake or exhaust valves
  • Damage to the cylinder head intake or exhaust valve seats.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 6 power cylinder damaged?
YES NO

Repair

Repair or replace the cylinder head.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2849 is inactive.

Fault Code 2849 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 19-Jan-2011


FAULT CODE 2849 (Single Turbocharger) - Exhaust Gas Temperature Cylinder 6 (B3) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2461 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 6. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 6. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2849 inactive, Fault Code 2851 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 6 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Inspect cylinder 6 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2849 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

N/A

Fault Code 2461 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 6.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug 'J' connector damaged
  • Electrode has signs of oil contamination
  • Spark plug procelain damaged. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug.

  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system

Guided Step 3A - Check the ignition coil on cylinder 6.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.
  • Pushed back or expanded pins

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors inthe circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

  • Repair or replace the ignition harness or the harness connector.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harnessconnector to the ignition SUPPLY input pin in the ignition coilconnector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram toidentify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • De-engergize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 6 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 6 and 8.
  • Install the temperature sensor from cylinder 6 to cylinder 8.
  • Install the temperature sensor from cylinder 8 to cylinder 6.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 13.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check Fault Code 2848 is inactive and Fault Code 2847 is active.

Fault Code 2849 inactive and Fault Code 2851 active?
YES NO
No Repair

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 6 location. Refer to Procedure 019-013 in Section 13.

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from cylinder 6 exhaust gas temperature sensor.

Action

Check the 5 volt supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 6.
  • Refer to the wiring diagram for harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 6 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Replace the ignition harness.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 6 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 6 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust gas temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CM850 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5 volt SUPPLY pin in the engine harness CM850 module connector to the exhaust gas temperature 5 volt.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram toidentify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 6 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check that the cylinder 4 overhead setting is correct.

  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspection of cylinder 6 power cylinder.

Guided Step 6A - Check the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Inspect the internal power cylinder for the following. If available, these inspections can be performed using a borescope without component removal.

  • Cylinder head – intake or exhaust valve / valve seat for any damage.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Refer to Procedure 003-006 in Section 3.

  • Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energized keyswitch circuit.
  • Place run/stop/auto switch in Run mode and running for more than 1 minute.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 2849 is inactive.

Fault Code 2849 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Engergize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Dec-2010


FAULT CODE 2851 (Multiple Turbochargers) - Exhaust Gas Temperature Cylinder 8 (B4) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2462 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 8. |
 | STEP 2A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 8. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2851 inactive and Fault Code 2849 active?
 | STEP 4B. Check the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the exhaust gas temperature circuit for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 8 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check cylinder 8 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Cylinder 8 power cylinder damaged?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2851 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2462 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 8.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • "J" connector damaged.
  • Oil contamination on electrode.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary.

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 8.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube
  • Check the ignition coil primary and secondary resistances.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil or the ignition coil extension tube o-ring. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify harness terminations, connectors, and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the ignition harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and ignition module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 8 exhaust gas temperature sensor response:

  • Remove the exhaust gastemperature sensor connectorfrom cylinder 8.
  • Install the temperature sensor from cylinder 8 to cylinder 6.
  • Install the temperature sensor from cylinder 6 to cylinder 8.
  • Reconnect the exhaust temperature sensors.

Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2851 is inactive and that Fault Code 2849 is active.

Fault Code 2851 inactive and Fault Code 2849 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in cylinder 8 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 8 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 8 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 8 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 8 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 8 overhead set is correct.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 8 overhead setting correct?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder 8 power cylinder.

Guided Step 6A - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (If available, these inspections can be performed using a borescope without component removal):

  • Damage to the cylinder head intake or exhaust valves
  • Damage to the cylinder head intake or exhaust valve seats.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 8 power cylinder damaged?
YES NO

Repair

Repair or replace the cylinder head.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2851 is inactive.

Fault Code 2851 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 19-Jan-2011


FAULT CODE 2851 (Single Turbocharger) - Exhaust Gas Temperature Cylinder 8 (B4) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2462 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 8. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 8. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2851 inactive, Fault Code 2849 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 8 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Inspect cylinder 8 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2851 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

N/A

Fault Code 2462 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 8.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug 'J' connector damaged
  • Electrode has signs of oil contamination
  • Spark plug procelain damaged. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug.

  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system

Guided Step 3A - Check the ignition coil on cylinder 8.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.
  • Pushed back or expanded pins

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

  • Repair or replace the ignition harness or the harness connector.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harnessconnector to the ignition SUPPLY input pin in the ignition coilconnector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram toidentify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • De-engergize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 8 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 8 and 6.
  • Install the temperature sensor from cylinder 8 to cylinder 6.
  • Install the temperature sensor from cylinder 6 to cylinder 8.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 13.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check Fault Code 2848 is inactive and Fault Code 2847 is active.

Fault Code 2851 inactive and Fault Code 2849 active?
YES NO
No Repair

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 8 location. Refer to Procedure 019-013 in Section 13.

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from cylinder 8 exhaust gas temperature sensor.

Action

Check the 5 volt supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 8.
  • Refer to the wiring diagram for harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 8 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Replace the ignition harness.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 8 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 8 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust gas temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CM850 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5 volt SUPPLY pin in the engine harness CM850 module connector to the exhaust gas temperature 5 volt.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram toidentify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 8 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check that the cylinder 8 overhead setting is correct.

  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspection of cylinder 8 power cylinder.

Guided Step 6A - Check the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Inspect the internal power cylinder for the following. If available, these inspections can be performed using a borescope without component removal.

  • Cylinder head – intake or exhaust valve / valve seat for any damage.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Refer to Procedure 003-006 in Section 3.

  • Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energized keyswitch circuit.
  • Place run/stop/auto switch in Run mode and running for more than 1 minute.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 2851 is inactive.

Fault Code 2851 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Engergize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Dec-2010


FAULT CODE 2852 (Multiple Turbochargers) - Exhaust Gas Temperature Cylinder 10 (B5) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2463 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 10. |
 | STEP 2A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 10. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2852 inactive and Fault Code 2853 active?
 | STEP 4B. Check the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the exhaust gas temperature circuit for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 10 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check cylinder 10 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Cylinder 10 power cylinder damaged?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2852 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2463 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 10.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • "J" connector damaged.
  • Oil contamination on electrode.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary.

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 10.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube
  • Check the ignition coil primary and secondary resistances.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil or the ignition coil extension tube o-ring. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify harness terminations, connectors, and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the ignition harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and ignition module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 10 exhaust gas temperature sensor response:

  • Remove the exhaust gastemperature sensor connectorfrom cylinder 10.
  • Install the temperature sensor from cylinder 10 to cylinder 12.
  • Install the temperature sensor from cylinder 12 to cylinder 10.
  • Reconnect the exhaust temperature sensors.

Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2852 is inactive and that Fault Code 2853 is active.

Fault Code 2852 inactive and Fault Code 2853 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in cylinder 10 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 10 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 10 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 10 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 10 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 10 overhead set is correct.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 10 overhead setting correct?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder 10 power cylinder.

Guided Step 6A - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (If available, these inspections can be performed using a borescope without component removal):

  • Damage to the cylinder head intake or exhaust valves
  • Damage to the cylinder head intake or exhaust valve seats.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 10 power cylinder damaged?
YES NO

Repair

Repair or replace the cylinder head.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2852 is inactive.

Fault Code 2852 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 19-Jan-2011


FAULT CODE 2852 (Single Turbocharger) - Exhaust Gas Temperature Cylinder 10 (B5) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2463 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 10. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 10. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2852 inactive, Fault Code 2853 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 10 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Inspect cylinder 10 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2852 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

N/A

Fault Code 2463 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 10.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug 'J' connector damaged
  • Electrode has signs of oil contamination
  • Spark plug procelain damaged. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug.

  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system

Guided Step 3A - Check the ignition coil on cylinder 10.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.
  • Pushed back or expanded pins

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

  • Repair or replace the ignition harness or the harness connector.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harnessconnector to the ignition SUPPLY input pin in the ignition coilconnector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram toidentify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • De-engergize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 10 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 10 and 12.
  • Install the temperature sensor from cylinder 10 to cylinder 12.
  • Install the temperature sensor from cylinder 12 to cylinder 10.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 13.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check Fault Code 2852 is inactive and Fault Code 2853 is active.

Fault Code 2852 inactive and Fault Code 2853 active?
YES NO
No Repair

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 10 location. Refer to Procedure 019-013 in Section 13.

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from cylinder 10 exhaust gas temperature sensor.

Action

Check the 5 volt supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 10.
  • Refer to the wiring diagram for harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 10 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Replace the ignition harness.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 10 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 10 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust gas temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CM850 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5 volt SUPPLY pin in the engine harness CM850 module connector to the exhaust gas temperature 5 volt.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram toidentify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 10 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check that the cylinder 10 overhead setting is correct.

  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspection of cylinder 10 power cylinder.

Guided Step 6A - Check the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Inspect the internal power cylinder for the following. If available, these inspections can be performed using a borescope without component removal.

  • Cylinder head – intake or exhaust valve / valve seat for any damage.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Refer to Procedure 003-006 in Section 3.

  • Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energized keyswitch circuit.
  • Place run/stop/auto switch in Run mode and running for more than 1 minute.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 2852 is inactive.

Fault Code 2852 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Engergize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 15-Dec-2010


FAULT CODE 2853 (Multiple Turbochargers) - Exhaust Gas Temperature Cylinder 12 (B6) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2464 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 12. |
 | STEP 2A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 12. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2853 inactive and Fault Code 2852 active?
 | STEP 4B. Check the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the exhaust gas temperature circuit for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 12 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check cylinder 12 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Cylinder 12 power cylinder damaged?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2853 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2464 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 12.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • "J" connector damaged.
  • Oil contamination on electrode.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary.

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 12.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube
  • Check the ignition coil primary and secondary resistances.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil or the ignition coil extension tube o-ring. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify harness terminations, connectors, and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the ignition harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and ignition module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 12 exhaust gas temperature sensor response:

  • Remove the exhaust gastemperature sensor connectorfrom cylinder 12.
  • Install the temperature sensor from cylinder 12 to cylinder 10.
  • Install the temperature sensor from cylinder 10 to cylinder 12.
  • Reconnect the exhaust temperature sensors.

Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2853 is inactive and that Fault Code 2852 is active.

Fault Code 2853 inactive and Fault Code 2852 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in cylinder 12 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 12 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 12 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 12 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 12 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 12 overhead set is correct.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 12 overhead setting correct?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder 12 power cylinder.

Guided Step 6A - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (If available, these inspections can be performed using a borescope without component removal):

  • Damage to the cylinder head intake or exhaust valves
  • Damage to the cylinder head intake or exhaust valve seats.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 12 power cylinder damaged?
YES NO

Repair

Repair or replace the cylinder head.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2853 is inactive.

Fault Code 2853 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 19-Jan-2011


FAULT CODE 2853 (Single Turbocharger) - Exhaust Gas Temperature Cylinder 12 (B6) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2464 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 12. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 12. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2853 inactive, Fault Code 2852 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 12 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Inspect cylinder 12 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2853 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

N/A

Fault Code 2464 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 12.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug 'J' connector damaged
  • Electrode has signs of oil contamination
  • Spark plug procelain damaged. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug.

  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system

Guided Step 3A - Check the ignition coil on cylinder 12.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.
  • Pushed back or expanded pins

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

  • Repair or replace the ignition harness or the harness connector.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harnessconnector to the ignition SUPPLY input pin in the ignition coilconnector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram toidentify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • De-engergize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 12 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 12 and 10.
  • Install the temperature sensor from cylinder 12 to cylinder 10.
  • Install the temperature sensor from cylinder 10 to cylinder 12.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 13.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check Fault Code 2853 is inactive and Fault Code 2852 is active.

Fault Code 2853 inactive and Fault Code 2852 active?
YES NO
No Repair

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 12 location. Refer to Procedure 019-013 in Section 13.

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from cylinder 12 exhaust gas temperature sensor.

Action

Check the 5 volt supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 12.
  • Refer to the wiring diagram for harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 12 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Replace the ignition harness.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 12 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 12 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust gas temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CM850 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5 volt SUPPLY pin in the engine harness CM850 module connector to the exhaust gas temperature 5 volt.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram toidentify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 12 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check that the cylinder 12 overhead setting is correct.

  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspection of cylinder 12 power cylinder.

Guided Step 6A - Check the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Inspect the internal power cylinder for the following. If available, these inspections can be performed using a borescope without component removal.

  • Cylinder head – intake or exhaust valve / valve seat for any damage.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Refer to Procedure 003-006 in Section 3.

  • Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energized keyswitch circuit.
  • Place run/stop/auto switch in Run mode and running for more than 1 minute.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 2853 is inactive.

Fault Code 2853 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Engergize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 15-Dec-2010


FAULT CODE 2854 (Multiple Turbochargers) - Exhaust Gas Temperature Cylinder 14 (B7) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2465 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 14. |
 | STEP 2A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 14. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2854 inactive and Fault Code 2855 active?
 | STEP 4B. Check the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the exhaust gas temperature circuit for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 14 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check cylinder 14 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Cylinder 14 power cylinder damaged?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2854 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2465 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 14.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • "J" connector damaged.
  • Oil contamination on electrode.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary.

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 14.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube
  • Check the ignition coil primary and secondary resistances.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil or the ignition coil extension tube o-ring. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify harness terminations, connectors, and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the ignition harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and ignition module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 14 exhaust gas temperature sensor response:

  • Remove the exhaust gastemperature sensor connectorfrom cylinder 14.
  • Install the temperature sensor from cylinder 14 to cylinder 16.
  • Install the temperature sensor from cylinder 16 to cylinder 14.
  • Reconnect the exhaust temperature sensors.

Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2854 is inactive and that Fault Code 2855 is active.

Fault Code 2854 inactive and Fault Code 2855 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in cylinder 14 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 14 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 14 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 14 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 14 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 14 overhead set is correct.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 14 overhead setting correct?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder 14 power cylinder.

Guided Step 6A - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (If available, these inspections can be performed using a borescope without component removal):

  • Damage to the cylinder head intake or exhaust valves
  • Damage to the cylinder head intake or exhaust valve seats.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 14 power cylinder damaged?
YES NO

Repair

Repair or replace the cylinder head.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2854 is inactive.

Fault Code 2854 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 19-Jan-2011


FAULT CODE 2854 (Single Turbocharger) - Exhaust Gas Temperature Cylinder 14 (B7) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2465 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 14. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 14. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2854 inactive, Fault Code 2855 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 14 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Inspect cylinder 14 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2854 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

N/A

Fault Code 2465 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 14.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug 'J' connector damaged
  • Electrode has signs of oil contamination
  • Spark plug procelain damaged. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug.

  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system

Guided Step 3A - Check the ignition coil on cylinder 14.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.
  • Pushed back or expanded pins

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

  • Repair or replace the ignition harness or the harness connector.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harnessconnector to the ignition SUPPLY input pin in the ignition coilconnector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram toidentify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • De-engergize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 14 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 14 and 16.
  • Install the temperature sensor from cylinder 14 to cylinder 16.
  • Install the temperature sensor from cylinder 16 to cylinder 14.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 13.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check Fault Code 2854 is inactive and Fault Code 2855 is active.

Fault Code 2854 inactive and Fault Code 2855 active?
YES NO
No Repair

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 14 location. Refer to Procedure 019-013 in Section 13.

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from cylinder 14 exhaust gas temperature sensor.

Action

Check the 5 volt supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 14.
  • Refer to the wiring diagram for harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 14 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Replace the ignition harness.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 14 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 14 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust gas temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CM850 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5 volt SUPPLY pin in the engine harness CM850 module connector to the exhaust gas temperature 5 volt.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram toidentify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 14 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check that the cylinder 14 overhead setting is correct.

  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspection of cylinder 14 power cylinder.

Guided Step 6A - Check the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Inspect the internal power cylinder for the following. If available, these inspections can be performed using a borescope without component removal.

  • Cylinder head – intake or exhaust valve / valve seat for any damage.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Refer to Procedure 003-006 in Section 3.

  • Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energized keyswitch circuit.
  • Place run/stop/auto switch in Run mode and running for more than 1 minute.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 2854 is inactive.

Fault Code 2854 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Engergize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 15-Dec-2010


FAULT CODE 2855 (Multiple Turbochargers) - Exhaust Gas Temperature Cylinder 16 (B8) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2466 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 16. |
 | STEP 2A. Check the spark plug. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 16. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust gas temperature sensor response. | Fault Code 2855 inactive and Fault Code 2854 active?
 | STEP 4B. Check the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 4C. Check the exhaust gas temperature circuit for a short circuit from pin to pin. | Greater than 100k ohms?
 | STEP 4D. Check the exhaust gas temperature circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 16 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Check cylinder 16 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Cylinder 16 power cylinder damaged?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2855 inactive?
 | STEP 7B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2466 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 16.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the spark plug for the following:

  • Spark plug correctly tightened.
  • "J" connector damaged.
  • Oil contamination on electrode.
  • Spark plug porcelain damaged.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary.

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system.

Guided Step 3A - Check the ignition coil on cylinder 16.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube
  • Check the ignition coil primary and secondary resistances.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil or the ignition coil extension tube o-ring. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify harness terminations, connectors, and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Repair the damaged pins.

Repair or replace the ignition harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and ignition module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or harness connector. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and ignition module.

Action

Check for an open circuit.

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harness connector to the ignition SUPPLY input pin in the ignition coil connector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust temperature circuit.

Guided Step 4A - Check the exhaust temperature sensor response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 16 exhaust gas temperature sensor response:

  • Remove the exhaust gastemperature sensor connectorfrom cylinder 16.
  • Install the temperature sensor from cylinder 16 to cylinder 14.
  • Install the temperature sensor from cylinder 14 to cylinder 16.
  • Reconnect the exhaust temperature sensors.

Refer to Procedure 019-013 in Section 19.

Start the engine and run the engine to run on-load for greater than 1 minute.

  • Use INSITE™ electronic service tool to check that Fault Code 2855 is inactive and that Fault Code 2854 is active.

Fault Code 2855 inactive and Fault Code 2854 active?
YES NO

Repair

Replace the exhaust gas temperature sensor that was originally installed in cylinder 16 location. Refer to Procedure 019-013 in Section 19.

No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 16 exhaust gas temperature sensor and the CENSE™ module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram to identify connectors and pins.

Engine harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4C

Go to 7A

Guided Step 4C - Check for a short circuit from pin to pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 16 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for a short circuit from pin to pin.

  • Measure the resistance of the harness from the exhaust gas temperature SIGNAL pin in the CENSE™ module connector to all other pins in the CENSE™ module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 16 exhaust gas temperature sensor and the CENSE™ module.

Action

Check for an open circuit.

  • Measure the resistance from the exhaust gas temperature SIGNAL pin in the engine harness CENSE™ module connector to the exhaust gas temperature SIGNAL pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature RETURN pin in the engine harness CENSE™ module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the wiring diagram to identify connectors and pins.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 16 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check that cylinder 16 overhead set is correct.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Cylinder 16 overhead setting correct?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check cylinder 16 power cylinder.

Guided Step 6A - Inspect the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Visually inspect the internal power cylinder for the following (If available, these inspections can be performed using a borescope without component removal):

  • Damage to the cylinder head intake or exhaust valves
  • Damage to the cylinder head intake or exhaust valve seats.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 16 power cylinder damaged?
YES NO

Repair

Repair or replace the cylinder head.

Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Use the following procedure in the QSK60G CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operating for greater than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2855 is inactive.

Fault Code 2855 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 19-Jan-2011


FAULT CODE 2855 (Single Turbocharger) - Exhaust Gas Temperature Cylinder 16 (B8) - Deviation Error

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2466 and/or 2767 active?
STEP 2. | Check the spark plug on cylinder 16. |
 | STEP 2A. Check the spark plug for damage or contamination. | Spark plug contaminated or damaged?
 | STEP 2B. Check the spark plug gap. | Spark plug gap incorrect?
STEP 3. | Check the ignition system. |
 | STEP 3A. Check the ignition coil on cylinder 16. | Ignition coil OK?
 | STEP 3B. Check the ignition harness and connector pins. | Dirty or damaged pins?
 | STEP 3C. Check the ignition harness for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check the ignition harness for an open circuit. | Less than 10 ohms?
STEP 4. | Check the exhaust gas temperature sensor circuit. |
 | STEP 4A. Check the exhaust temperature sensor response. | Fault Code 2855 inactive, Fault Code 2854 active?
 | STEP 4B. Check the 5-VDC supply to the exhaust gas temperature sensor. | 4.75 to 5.25-VDC?
 | STEP 4C. Inspect the exhaust gas temperature sensor circuit harness and connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the exhaust gas temperature circuit for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 4E. Check the exhaust gas temperature sensor circuit for an open circuit. | Less than 10 ohms?
STEP 5. | Check cylinder 16 overhead set. |
 | STEP 5A. Check the overhead set. | Overhead set OK?
STEP 6. | Inspect cylinder 16 power cylinder. |
 | STEP 6A. Inspect the internal power cylinder. | Damage to power cylinder components?
STEP 7. | Clear the fault codes. |
 | STEP 7A. Verify the fault code is inactive. | Fault Code 2855 inactive?
 | STEP 7B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

N/A

Fault Code 2466 and/or 2767 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 7A

Go to 2A

Guided Step 2 - Check the spark plug on cylinder 16.

Guided Step 2A - Check the spark plug.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the spark plug for the following:

  • Spark plug correctly tightened
  • Spark plug 'J' connector damaged
  • Electrode has signs of oil contamination
  • Spark plug procelain damaged. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug contaminated or damaged?
YES NO

Repair

Repair as necessary:

  • Tighten the spark plug to the specified torque.
  • Replace the spark plug. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the spark plug gap.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the spark plug electrode gap.

  • Remove the spark plug and measure the spark plug electrode gap. See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap incorrect?
YES NO

Repair

Replace the spark plug.

  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the ignition system

Guided Step 3A - Check the ignition coil on cylinder 16.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.

Action

Check the ignition coil for the following:

  • Check the condition of the o-ring located in the ignition coil extension tube.
  • Check the ignition coil primary and secondary resistances.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.
  • Pushed back or expanded pins

Ignition coil OK?
YES NO
No Repair

Repair

Replace the ignition coil.

  • Replace the ignition coil extension tube o-ring.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 013-024 in Section 13.

Go to 3B

Go to 7A

Guided Step 3B - Check the ignition harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Inspect the ignition harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.
  • Refer to the wiring diagram for harness termination and location.

Ignition harness and connector pins OK?
YES NO
No Repair

Repair

Replace the damaged pins.

  • Repair or replace the ignition harness or the harness connector.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 7A

Guided Step 3C - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistance of the harness from the ignition supply pin in the ignition module connector to all other pins in the ignition module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 7A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the ignition harness connectors from the ignition coil and the ignition module.

Action

Check for an open circuit:

  • Measure the resistance of the harness from the ignition SUPPLY pin in the ignition harnessconnector to the ignition SUPPLY input pin in the ignition coilconnector.
  • Measure the resistance of the harness from the ignition RETURN pin in the ignition harness connector to the ignition supply RETURN pin in the ignition coil connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram toidentify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the ignition harness or the harness connector.

  • Repair the ignition harness.
  • Replace the ignition harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas temperature circuit.

Guided Step 4A - Check the exhaust gas temperature sensor response.

Conditions

  • De-engergize keyswitch circuit.
  • Isolate the generator set 24 volt power supply.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check cylinder 16 exhaust gas temperature sensor response:

  • Remove the exhaust gas temperature sensors from cylinders 16 and 14.
  • Install the temperature sensor from cylinder 16 to cylinder 14.
  • Install the temperature sensor from cylinder 14 to cylinder 16.
  • Connect the exhaust gas temperature sensors. Refer to Procedure 019-013 in Section 13.

Start the engine and run the engine to run on-load for more than 1 minute.

  • Use INSITE™ electronic service tool to check Fault Code 2855 is inactive and Fault Code 2854 is active.

Fault Code 2855 inactive and Fault Code 2854 active?
YES NO
No Repair

Repair

Replace the exhaust gas temperature sensor:

  • Replace the exhaust gas temperature sensor that was originally installed in cylinder 16 location. Refer to Procedure 019-013 in Section 13.

Go to 7A

Go to 4B

Guided Step 4B - Check the 5-VDC supply to the exhaust gas temperature sensor.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from cylinder 16 exhaust gas temperature sensor.

Action

Check the 5 volt supply to the exhaust gas temperature sensor:

  • Use a multimeter to measure the voltage between the exhaust gas temperature 5 volt SUPPLY pin and the exhaust gas temperature RETURN pin of the exhaust gas temperature sensor harness cylinder 16.
  • Refer to the wiring diagram for harness termination and location.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4C

Guided Step 4C - Check the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 16 exhaust gas temperature sensor and the CM850 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use a wiring diagram for connector pin identification and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins.

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing. Replace the ignition harness.
  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4D

Go to 7A

Guided Step 4D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 16 exhaust gas temperature sensor and the CM850 module.

Action

Check for a short circuit from pin-to-pin:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the CM850 module connector to all other pins in the CM850 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4E

Go to 7A

Guided Step 4E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24 volt power supply.
  • Disconnect the engine harness connectors from cylinder 16 exhaust gas temperature sensor and the CM850 module.

Action

Check for an open circuit:

  • Measure the resistances from the exhaust gas temperature SIGNAL pin in the engine harness CM850 module connector to the exhaust gas temperature SIGNAL pin in the exhaust temperature sensor connector.
  • Measure the resistances from the exhaust gas temperature RETURN pin in the engine harness CM850 module connector to the exhaust gas temperature RETURN pin in the exhaust gas temperature sensor connector.
  • Measure the resistance from the exhaust gas temperature 5 volt SUPPLY pin in the engine harness CM850 module connector to the exhaust gas temperature 5 volt.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Refer to the wiring diagram toidentify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Repair the engine harness.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 7A

Guided Step 5 - Check cylinder 16 overhead set.

Guided Step 5A - Check the overhead set.

Conditions

  • De-engergize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check that the cylinder 16 overhead setting is correct.

  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Overhead set OK?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6A

Guided Step 6 - Inspection of cylinder 16 power cylinder.

Guided Step 6A - Check the internal power cylinder.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Inspect the internal power cylinder for the following. If available, these inspections can be performed using a borescope without component removal.

  • Cylinder head – intake or exhaust valve / valve seat for any damage.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Repair as necessary:

  • Replace the cylinder head.
  • See the following procedure in the Troubleshooting and Repair Manual, QSK60G CM700, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Repair

Adjust the overhead setting. Refer to Procedure 003-006 in Section 3.

  • Refer to Procedure 003-006 in Section 3.

Go to 7A

Go to 7A

Guided Step 7 - Clear the fault codes.

Guided Step 7A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energized keyswitch circuit.
  • Place run/stop/auto switch in Run mode and running for more than 1 minute.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 2855 is inactive.

Fault Code 2855 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 7B

Go to 1A

Guided Step 7B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Engergize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?

YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 16-Dec-2010


FAULT CODE 2857 - Turbocharger Number 1 Speed High - Data Valid But Above Normal Operational Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for intermittent fault condition. |
 | STEP 1A. Operate the engine at rated speed to check for fault activation. | Fault Code 2857 active?
STEP 2. | Check for a damaged turbocharger speed sensor. |
 | STEP 2A. Inspect the engine harness connector to the turbocharger speed sensor. | Is the connector or pigtail harness damaged?
 | STEP 2B. Measure the turbocharger speed sensor resistance. | Between 450 and 800 ohms?
 | STEP 2C. Check for a short circuit to ground in the turbocharger speed sensor. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the turbocharger speed sensor circuit continuity. | Resistance within 10 ohms of the sensor resistance?
 | STEP 3C. Check for a short to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short in the engine harness. | Greater than 100k ohms?
STEP 4. | Connect all components and determine if the fault code reoccurs. |
 | STEP 4A. Operate the engine at idle and high idle to check for fault activation. | Does Fault Code 2857 come active during engine operation?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault Code 2857 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for intermittent fault condition.

Guided Step 1A - Operate the engine at rated speed to check for fault activation.

Conditions

  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operating for greater than 1 minute.

Action

Operate the engine at rated speed to check for fault activation.

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2857 active?
YES NO
No Repair

Repair

An intermittent fault condition exists. The problem can be with the turbocharger speed sensor circuit.

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check for a damaged turbocharger speed sensor.

Guided Step 2A - Inspect the engine harness connector to the turbocharger speed sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the turbocharger speed sensor.

Action

Inspect the turbocharger speed sensor connector, the engine harness connector, and the turbocharger speed sensor pigtail harness for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Is the connector or pigtail harness damaged?
YES NO

Repair

A damaged connection has been detected in the turbocharger speed sensor or engine harness connector.

Repair or replace the damaged connector or turbocharger speed sensor, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-390 in Section 19.
  • Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Measure the turbocharger speed sensor resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the turbocharger speed sensor.

Action

Measure the turbocharger speed sensor resistance.

Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin to the turbocharger speed RETURN (-) pin at the sensor.

  • Refer to the circuit diagram on the wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 450 and 800 ohms?
YES NO
No Repair

Repair

The turbocharger speed sensor has malfunctioned.

  • Replace the turbocharger speed sensor. Refer to Procedure 019-390 in Section 19.

Go to 2C

Go to 5A

Guided Step 2C - Check for a short circuit to ground in the turbocharger speed sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the turbocharger speed sensor.

Action

Check for a short circuit to ground in the turbocharger speed sensor.

Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin on the sensor to the engine block ground.

  • Refer to the circuit diagram on the wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

The turbocharger speed sensor is shorted to ground.

  • Replace the turbocharger speed sensor. Refer to Procedure 019-390 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the engine harness connector to the turbocharger speed sensor.
  • Disconnect the engine harness from the CM700.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Use the following procedure for general inspection techniques. 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected CM700 engine connector or engine harness connector.

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins, use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged harness, connector or pins, if possible.
  • Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the turbocharger speed sensor circuit continuity.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the engine harness connector to the turbocharger speed sensor.
  • Disconnect the engine harness from the CM700.

Action

Check the turbocharger speed sensor circuit continuity.

Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the engine harness ECM connector to the turbocharger speed RETURN (-) pin at the engine harness CM700 connector.

Note: The resistance of the turbocharger speed sensor circuit must not be more than 10 ohms greater than the resistance of the turbocharger speed sensor. The turbocharger speed sensor resistance value was read in Step 2B.

  • Refer to the circuit diagram on the wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance within 10 ohms of sensor resistance?
YES NO
No Repair

Repair

There is high resistance or an open circuit in the engine harness or turbocharger speed sensor connector. Otherwise, there is a low resistance (short) across the sensor input pins.

  • Repair or replace the engine harness or connector(s).
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short to ground in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the engine harness connector to the turbocharger speed sensor.
  • Disconnect the engine harness from the CM700.

Action

Check for a short to ground in the engine harness.

Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the engine harness CM700 connector to engine block ground.

  • Refer to the circuit diagram on the wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

There is a short to ground in the turbocharger speed sensor circuit. Inspect the engine harness for a short to ground.

  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for a pin-to-pin short in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the engine harness connector to the turbocharger speed sensor.
  • Disconnect the engine harness from the CM700.

Action

Check for a pin-to-pin short in the engine harness.

Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness CM700 connector to all other pins in the connector except the turbocharger speed RETURN (-) pin.

  • Refer to the circuit diagram on the wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

There is a short between pins of the engine harness.

  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Connect all components and determine if the fault code reoccurs.

Guided Step 4A - Operate the engine at idle or high idle to check for fault activation.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the engine harness connector to the turbocharger speed sensor.
  • Connect the engine harness to the CM700
  • Energize keyswitch circuit
  • Connect INSITE™ electronic service tool.

Action

Operate the engine at idle.

  • Keyswitch circuit energized, Place run/stop/auto switch in RUN mode and running for greater than 1 minute.

Does Fault Code 2857 come active during engine operation?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

  • An intermittent fault condition exists. The problem can exist in the turbocharger speed sensor circuit.
  • Be certain that the ECM and chassis grounds are in good condition.

Go to 5A

Refer to Procedure 019-362 in Section 19.

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the engine harness connector to the turbocharger speed sensor.
  • Connect the engine harness to the CM700.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Keyswitch circuit energized,
  • Place run/stop/auto switch in RUN mode and operate for greater than 1 minute.

Fault Code 2857 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location is all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-May-2012


FAULT CODE 2859 - Alternator Heater Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2859 active?
STEP 2. | Check the alternator heater control circuit. |
 | STEP 2A. Inspect the alternator heater control relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the alternator heater control relay. | Resistance between 24 and 50 ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the CM700 and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a short to ground in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2859 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2859 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the alternator heater control circuit.

Guided Step 2A - Inspect the alternator heater control relay and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the alternator heater control relay.

Action

Inspect the engine harness and alternator heater control relay for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the turbocharger speed sensor or engine harness connector.

Repair or replace the engine harness or harness connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the alternator heater control relay.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the alternator heater control relay.

Action

Measure the turbocharger speed sensor resistance.

Use a multimeter to measure the resistance from the alternator heater control relay terminal and ground.

  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 24 and 50 ohms?
YES NO
No Repair

Repair

Replace the alternator control relay. Contact a Cummins® Authorized Repair Location to schedule this repair.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the engine harness connector to the alternator heater control relay.
  • Disconnect the engine harness from the CM700.

Action

Inspect the engine harness and CM700 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the CM700 engine connector or engine harness connector.

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged harness, connector or pins, if possible.
  • Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch off
  • Disconnect the engine harness connector to the CM700
  • Disconnect the alternator control relay from the engine harness.

Action

Check the circuit continuity.

  • Measure the resistance between the alternator heater SIGNAL pin at the alternator heater relay and the SIGNAL pin at the engine harness CM700 connector.

Use the circuit diagram on the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short to ground in the engine harness.

Conditions

  • Turn keyswitch off.
  • Disconnect the engine harness from the CM700 connector.
  • Disconnect the alternator control relay from the engine harness.

Action

Check for a short circuit.

  • Measure the resistance between the alternator control relay SIGNAL pin at the engine harness CM700 connector and all other pins in the engine harness CM700 connector.

Use the circuit diagram on the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Keyswitch circuit energize.
  • Connect INSITE™ electronic service tool.
  • Place run/stop/auto switch in RUN mode and engine operating for greater than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2859 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energize.
  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-May-2012


FAULT CODE 2861 - Alternator Heater Control Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2861 active?
STEP 2. | Check the alternator heater control circuit. |
 | STEP 2A. Inspect the alternator heater control relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-ground short circuit in the alternator heater control relay. | Resistance between 24 and 50 ohms?
STEP 3. | Check the CM700 and engine harness. |
 | STEP 3A. Inspect the CM700 and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Disable the fault code. | Fault Code 2861 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2861 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the alternator heater control circuit.

Guided Step 2A - Inspect the alternator heater control relay and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the alternator heater control relay.

Action

Inspect the engine harness and alternator heater control relay for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the turbocharger speed sensor or engine harness connector.

Repair or replace the engine harness or harness connector, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a pin-to-ground short circuit in the alternator heater control relay.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the alternator heater control relay.

Action

Check for a pin-to-ground short circuit.

Measure the resistance from the alternator heater control relay and engine block.

  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 24 and 50 ohms?
YES NO
No Repair

Repair

Replace the alternator control relay. Contact a Cummins® Authorized Repair Location to schedule this repair.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect the engine harness connector to the alternator heater control relay.
  • Disconnect the engine harness from the CM700.

Action

Inspect the engine harness and CM700 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the CM700 engine connector or engine harness connector.

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged harness, connector or pins, if possible.
  • Refer to Procedure 019-043 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the engine harness connector from the alternator heater control relay.

Action

Check for a short circuit to ground.

  • Measure the resistance between the alternator heater control relay pin and ground.

Use the circuit diagram on the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

  • Repair or replace the engine harness.
  • Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.
  • Disconnect the engine harness connector from the alternator heater control relay.

Action

Check for a short circuit.

  • Measure the resistance between the alternator control relay SIGNAL pin at the engine harness CM700 connector and all other pins in the engine harness CM700 connector.

Refer to the circuit diagram on the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energize.
  • Place run/stop/auto switch in RUN mode and engine running for greater than 1 minute.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify that the fault code is inactive.

Fault Code 2861 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Keyswitch circuit energize.
  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-May-2012


FAULT CODE 2863 - Engine ECM to Gen Set Controller Communications - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2863 active?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and connector pins. | Dirty or damaged pins?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 2863 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2863 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode

Action

Inspect the engine harness and connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Use the following procedure for data link circuit. Refer to Procedure 019-417 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the engine harness or ECM.

  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Use the following procedure for the data link circuit. Refer to Procedure 019-417 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

NOTE: Press the “RESET” button on the panel. This will clear all the inactive fault codes as well as key cycle the engine.

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool

Action

Verify fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2863 is inactive.

Fault Code 2863 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-May-2012


FAULT CODE 2864 - Engine Fuel Shutoff Valve Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple active fault codes. | Fault Codes 441 and 442 or 477 and 478 active?
STEP 2. | Check the fuel shutoff valve. |
 | STEP 2A. Inspect the valve and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fuel shutoff valve supply voltage. | Supply voltage 18 - 27.6-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check for a CM700 response. |
 | STEP 4A. Check for the appropriate CM700 response. | Fault Code 2864 inactive?
STEP 5. | Clear the fault code. |
 | STEP 5A. Verify that the fault code is inactive. | Fault Code 2864 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 441 and 442 or 477 and 478 active?
YES NO

Repair

Use the appropriate troubleshooting chart to troubleshoot the fault code.

 No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check the fuel shutoff valve.

Guided Step 2A - Inspect the fuel shutoff valve and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the fuel shutoff valve.

Action

Inspect the fuel shutoff valve and the harness for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Reference the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the damaged pins.

Repair or replace the fuel shutoff valve harness or replace the fuel shutoff valve, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Contact a Cummins® Authorized Repair Location.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel shutoff valve. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 005-044 in Section 5.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the fuel shutoff valve supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and crank engine.
  • Disconnect the main engine harness from the fuel shutoff valve.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel shutoff valve supply voltage.

  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
  • Connect the multimeter test leads to the fuel shutoff valve SUPPLY and RETURN pins in the gas valve harness connector and check the supply voltage. Contact a Cummins® Authorized Repair Location.

Supply voltage 18 - 27.6-VDC?
YES NO
No Repair

Repair

Check the 24-VDC power supply, power supply connections, and the fuses in the harness. Use the circuit diagram or the wiring diagram to identify connectors and pins.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the fuel shutoff valve and the CM700 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector.
  • Replace the fuel shutoff valve harness, or the appropriate extension harness. Contact a Cummins® Authorized Repair Location.
 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the harness from the fuel control valve and the CM700 module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel shutoff valve SUPPLY pin in the CM700 connector to all other pins in the connector.
  • Measure the resistance from the fuel shutoff valve RETURN pin in the CM700 connector to all other pins in the connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness or the harness connector.

  • Repair the appropriate wiring harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness or appropriate wiring harness extension. Refer to Procedure 019-043 in Section 19.
  • Contact a Cummins® Authorized Repair Location.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the harness from the fuel shutoff valve and the CM700 module.

Action

Check for an open circuit in the SUPPLY and RETURN wires.

  • Measure the resistance from the fuel shutoff valve SUPPLY pin in the fuel shutoff valve connector to the fuel shutoff valve SUPPLY pin in the CM700 module connector.
  • Measure the resistance from the fuel shutoff valve RETURN pin in the fuel shutoff valve connector to the fuel shutoff valve RETURN pin in the CM700 module connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or the wiring diagram to identify connectors and pins.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness extension.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness or appropriate wiring harness extension. Refer to Procedure 019-043 in Section 19.
  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 5A

Guided Step 4 - Check for a CM700 response.

Guided Step 4A - Check for the appropriate CM700 response.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and crank engine.
  • Disconnect the engine harness connector from the fuel shutoff valve.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate CM700 response.

  • Install a jumper wire to the fuel shutoff valve relays and then crank the engine.
  • Use the circuit diagram or wiring diagram for connector pin and relay identification.
  • Use INSITE™ electronic service tool to verify the fault codes.

Fault Code 2864 inactive?
YES NO
No Repair

Repair

  • Replace the CM700 module. Refer to Procedure 019-031 in Section 19.
  • Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault code.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for more than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2864 is inactive.

Fault Code 2864 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 09-May-2012


FAULT CODE 2866 - Engine Electronic Fuel Control Valve 1 Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2866 active or high inactive counts?
STEP 2. | Check the fuel control valve actuator. |
 | STEP 2A. Inspect the actuator and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fuel control valve actuator commanded signal percent duty cycle. | Percent duty cycle 10 - 91 percent?
 | STEP 2C. Check the fuel control valve feedback signal voltage. | 0 to 5-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness for a short from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
 | STEP 3D. Check for an intermittent engine harness malfunction. | Fault Codes 2866 and/or 2311, 2864, and 2867 become active?
STEP 4. | Check the ECM. |
 | STEP 4A. Check the fuel control valve commanded position percent pulse width modulator duty cycle signal at the CM558 connector. | Percent duty cycle 10 - 91 percent?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 2866 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2866 active or high inactive counts?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 5A

Guided Step 2 - Check the fuel control valve actuator.

Guided Step 2A - Inspect the actuator and harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the fuel control valve actuator.

Action

Inspect the actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Repair

Repair or replace the engine harness, the harness connector, or the fuel control valve actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Repair the wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel control valve. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 006-049 in Section 6.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the fuel control valve actuator commanded signal percent duty cycle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a number of positions between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the fuel control valve actuator position SIGNAL (+) and RETURN (-) pins at the fuel control valve actuator connector. The signal percent duty cycle must be between10 and 91 percent, based on the fuel control valve actuator position.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Percent duty cycle 10 - 91 percent?
YES NO
No Repair

Repair

Check the power supply connections and the fuses. Use the engine wiring diagram to identify the appropriate circuit.

Go to 2C

Go to 3A

Guided Step 2C - Check the fuel control valve feedback signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve feedback signal voltage:

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the signal feedback voltage by connecting the multimeter test probes between the fuel control valve actuator position FEEDBACK and RETURN (-) pins. The feedback signal must be between 0 to 5-VDC.

Use the circuit diagram or wiring diagram for connector pin identification.

Reference the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

0 to 5-VDC?
YES NO
No Repair

Repair

Replace the fuel control valve.

  • Replace the fuel control valve. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 006-049 in Section 6.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CM558 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins. Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the engine harness resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the CM558 module.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator.
  • Use the wiring diagram to identify shared sensors.

Action

Check the engine harness and fuel control valve actuator resistance.

  • Measure the resistance from the fuel control valve actuator SIGNAL pin in the engine harness CM558 connector to all other pins in the connector.
  • Measure the resistance from the fuel control valve actuator RETURN pin in the engine harness CM558 connector to all other pins in the connector.
  • Measure the resistance from the fuel control valve actuator POSITION pin in the engine harness CM558 connector to all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Connect the engine harness to the fuel control valve actuator.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator. Use the wiring diagram to identify shared sensors.
  • Disconnect the engine harness from the CM700 module.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the fuel control valve actuator SIGNAL pin at the fuel control valve connector and the fuel control valve actuator SIGNAL pin at the CM700 module connector of the engine harness.
  • Measure the resistance between the fuel control valve actuator RETURN pin at the fuel control valve connector and the fuel control valve actuator RETURN pin at the CM700 module connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an intermittent engine harness malfunction.

Conditions

  • Energize keyswitch circuit .
  • Place run/stop/auto switch in RUN mode at rated speed with no load.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or malfunction:

  • Manipulate the engine harness, starting at the ECM engine harness connector and working to the fuel control valve actuator connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

If a short or open circuit is induced while the engine is operating, a Warning or Shutdown Alarm and corresponding fault code will be activated.

Fault Codes 2866 and/or 2311, 2864, and 2867 become active?
YES NO

Repair

An intermittent connection has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM.

Guided Step 4A - Check the fuel control valve commanded position position pulse width modulator duty cycle signal at the CM558 connector.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle at the left-bank CM558.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a number of positions between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the fuel control valve actuator position SIGNAL (+) and RETURN (-) pins at the CM558 connector. The signal percent duty cycle must be between 10 and 91 percent, based on the fuel control valve actuator position.

Use the appropriate wiring diagram to identify the SIGNAL and RETURN pins.

Reference the specification table provided in the Shop Talk section of this document for commanded position percent duty cycle specifications.

Percent duty cycle 10 - 91 percent?
YES NO
No Repair

Repair

A malfunction has been detected with the CM558 module.

  • Replace the Left-Bank CM558 module. Refer to Procedure 019-031 in Section 19.
  • Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for more than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify the Fault Code 2866 is inactive.

Fault Code 2866 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-May-2012


FAULT CODE 2867 - Engine Electronic Fuel Control Valve 1 Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2867 active or high inactive counts?
STEP 2. | Check the fuel control valve actuator. |
 | STEP 2A. Inspect the actuator and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fuel control valve actuator commanded signal percent duty cycle. | Percent duty cycle 10 - 91 percent?
 | STEP 2C. Check the fuel control valve feedback signal voltage. | 0 to 5-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the engine harness for a short to ground. | Greater than 100k ohms?
 | STEP 3C. Check the engine harness for a short from pin-to-pin. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit. | Less than 10 ohms?
 | STEP 3E. Check for an intermittent engine harness malfunction. | Fault Codes 2867 and/or 2311, 2864, and 2866 active?
STEP 4. | Check the ECM. |
 | STEP 4A. Check the fuel control valve commanded position percent pulse width modulator duty cycle signal at the CM558 connector. | Percent duty cycle 10 - 91 percent?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 2867 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2867 active or high inactive counts?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 5A

Guided Step 2 - Check the fuel control valve actuator.

Guided Step 2A - Inspect the actuator and harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the fuel control valve actuator.

Action

Inspect the actuator and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?

YES NO

Repair

Repair or replace the engine harness, the harness connector, or the fuel control valve actuator, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Repair the engine harness. Refer to Procedure 019-208 in Section 19.
  • Repair the wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel control valve. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 006-049 in Section 6.
No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the fuel control valve actuator commanded signal percent duty cycle.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a number of positions between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the fuel control valve actuator position SIGNAL (+) and RETURN (-) pins at the fuel control valve actuator connector. The signal percent duty cycle must be between10 and 91 percent, based on the fuel control valve actuator position.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Percent duty cycle 10 - 91 percent?
YES NO
No Repair

Repair

Check the power supply connections and the fuses. Use the engine wiring diagram to identify the appropriate circuit.

Go to 2C

Go to 3A

Guided Step 2C - Check the fuel control valve feedback signal voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve feedback signal voltage:

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the signal feedback voltage by connecting the multimeter test probes between the fuel control valve actuator position FEEDBACK and RETURN (-) pins. The feedback signal must be between 0 to 5-VDC.

Use the circuit diagram or wiring diagram for connector pin identification.

Reference the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

0 to 5-VDC?
YES NO
No Repair

Repair

Replace the fuel control valve.

  • Replace the fuel control valve. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 006-049 in Section 6.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness connector from the CM558 module.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins. Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the engine harness for a short to ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the CM558 module.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator.
  • Use the wiring diagram to identify shared sensors.

Action

Check the engine harness and fuel control valve actuator resistance.

  • Measure the resistance from the fuel control valve actuator SIGNAL pin in the engine harness CM558 connector to the engine block ground.
  • Measure the resistance from the fuel control valve actuator RETURN pin in the engine harness CM558 connector to the engine block ground.
  • Measure the resistance from the fuel control valve actuator POSITION pin in the engine harness CM558 connector to the engine block ground.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check the engine harness resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine harness from the CM558 module.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator.
  • Use the wiring diagram to identify shared sensors.

Action

Check the engine harness and fuel control valve actuator resistance.

  • Measure the resistance from the fuel control valve actuator SIGNAL pin in the engine harness CM558 connector to all other pins in the connector.
  • Measure the resistance from the fuel control valve actuator RETURN pin in the engine harness CM558 connector to all other pins in the connector.
  • Measure the resistance from the fuel control valve actuator POSITION pin in the engine harness CM558 connector to all other pins in the connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Connect the engine harness to the fuel control valve actuator.
  • Disconnect the engine harness from all sensors that have a shared supply or return with the fuel control valve actuator. Use the wiring diagram to identify shared sensors.
  • Disconnect the engine harness from the CM700 module.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the fuel control valve actuator SIGNAL pin at the fuel control valve connector and the fuel control valve actuator SIGNAL pin at the CM700 module connector of the engine harness.
  • Measure the resistance between the fuel control valve actuator RETURN pin at the fuel control valve connector and the fuel control valve actuator RETURN pin at the CM700 module connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 5A

Guided Step 3E - Check for an intermittent engine harness malfunction.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode at rated speed with no load.
  • Connect INSITE™ electronic service tool.

Action

Check for an intermittent engine harness connection or malfunction:

  • Manipulate the engine harness, starting at the ECM engine harness connector and working to the fuel control valve actuator connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

If a short or open circuit is induced while the engine is operating, a Warning or Shutdown Alarm and corresponding fault code will be activated.

Fault Codes 2867 and/or 2311, 2864, and 2866 active?
YES NO

Repair

An intermittent connection has been detected in the engine harness.

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM.

Guided Step 4A - Check the fuel control valve commanded position position pulse width modulator duty cycle signal at the CM558 connector.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle at the left-bank CM558.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a number of positions between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the fuel control valve actuator position SIGNAL (+) and RETURN (-) pins at the CM558 connector. The signal percent duty cycle must be between 10 and 91 percent, based on the fuel control valve actuator position.

Use the appropriate wiring diagram to identify the SIGNAL and RETURN pins.

Reference the specification table provided in the Shop Talk section of this document for commanded position percent duty cycle specifications.

Percent duty cycle 10 - 91 percent?
YES NO
No Repair

Repair

A malfunction has been detected with the CM558 module.

  • Replace the Left-Bank CM558 module. Refer to Procedure 019-031 in Section 19.
  • Contact a Cummins® Authorized Repair Location.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for more than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify the Fault Code 2876 is inactive.

Fault Code 2867 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-May-2012


FAULT CODE 2868 - Engine Block/Coolant Pre-heater Control Circuit - Engine Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2868 active?
STEP 2. | Check the engine control. |
 | STEP 2A. Check the coolant level. | Coolant level low?
STEP 3. | Check the engine coolant temperature sensor and sensor circuit. |
 | STEP 3A. Inspect the sensor and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the resistance of the engine coolant temperature sensor. | 600 ohms to 36k ohm?
 | STEP 3C. Check for short-circuit to engine block ground. | Greater than 100k ohms?
 | STEP 3D. Check for short-circuit from pin to pin. | Greater than 100k ohms?
 | STEP 3E. Check the sensor supply voltage. | 4.75 to 5.25-VDC?
STEP 4. |  |
 | STEP 4A. Inspect the harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check thermostat performance. | Within specifications?
STEP 5. | Check the control contactor. |
 | STEP 5A. Inspect the harness and connections. | Dirty, damaged or loose connections?
 | STEP 5B. Check the coil supply voltage. | 23 to 26-VDC?
 | STEP 5C. Check connector performance. | Within specifications?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Verify that fault code is inactive. | Fault Code 2868 inactive?
 | STEP 6B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2868 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the engine coolant level.

Guided Step 2A - Check the coolant level.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check the level of the coolant.

  • Refer to Procedure 008-066 in Section 3. Use the Operation and Maintenance Manual, Generator Set QSK60G CM700, Bulletin 4021395.

Coolant level low?
YES NO

Repair

Add coolant to the appropriate level.

  • Refer to Procedure 008-066 in Section 3. Use the Operation and Maintenance Manual, Generator Set QSK60G CM700, Bulletin 4021395.
No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the engine coolant temperature sensor and sensor circuit.

Guided Step 3A - Inspect the sensor and harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine coolant temperature sensor.

Action

Inspect the engine harness connector and sensor pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the engine coolant temperature sensor.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in Section 19.
No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check the resistance of the engine coolant temperature sensor.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine coolant temperature sensor.

Action

Check the resistance of the engine coolant temperature sensor.

  • Measure the resistance between the engine coolant temperature sensor signal and return pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

600 ohms to 36k ohms?
YES NO
No Repair

Repair

  • Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for short-circuit to engine block ground.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine coolant temperature sensor.

Action

Check for short-circuit to ground.

  • Measure the resistance from each pin of the coolant temperature sensor to the engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

  • Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine coolant temperature sensor.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the engine coolant temperature sensor return pin in the engine harness connector to all other pins in the engine harness connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100 ohms?
YES NO
No Repair

Repair

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 6A

Guided Step 3E - Check the sensor supply voltage.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode

Action

Check the engine coolant temperature sensor supply voltage.

  • Measure the supply voltage at the engine coolant temperature sensor connector supply pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general voltage measurement techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check the coolant heater thermostat.

Guided Step 4A - Inspect the harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the engine coolant temperature sensor.

Action

Inspect the thermostat connector and pins for:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the connector or heater.

  • Replace the connector. Refer to Procedure 019-206 in Section 19.
  • Replace the coolant heater. Refer to Procedure 008-011 in Section 8. Use the Troubleshooting and Repair Manual, Generator Set QSK60G CM700, Bulletin 4021396.
No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check thermostat performance.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check thermostat performance.

  • Use INSITE™ electronic service tool to read the coolant temperature.
  • With the engine coolant temperature below 127°C [260°F], measure the resistance of the thermostat.
  • After measurement, enable the engine coolant heater. If engine coolant temperature exceeds 127°C [260°F], measure the resistance of the thermostat again.
  • Coolant Temperature less than 127°C [260°F], resistance less than 10 ohms
  • Coolant Temperature greater than 127°C [260°F], resistance greater than 10 ohms

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Within specifications?
YES NO
No Repair

Repair

Repair or replace the thermostat or heater.

  • Replace the thermostat.
  • Refer to Procedure 008-013 in Section 8. Use the Troubleshooting and Repair Manual, Generator Set QSK60G CM700, Bulletin 4021396
  • Replace the heater. Refer to Procedure 008-011 in Section 8. Use the Troubleshooting and Repair Manual, Generator Set QSK60G CM700, Bulletin 4021396.

Go to 5A

Go to 6A

Guided Step 5 - Check the control connector.

Guided Step 5A - Inspect the harness and connections.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect contactor KM1 harness and connections for:

  • Loose connections
  • Moisture in or on the connections
  • Dirt or debris in or on the connections
  • Wire insulation damage.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty, damaged or loose connections?
YES NO

Repair

Repair the harness or connections as needed by:

  • securing connection terminations
  • replacing wire segments with damage.

Replace KM1 contactor.

  • Isolate the voltage supply from the Generator Interface Box.
  • Create and attach identification tags to all contactor assembly electrical connections for reference during the installation of a new contactor assembly.
  • Disconnect all electrical connections to the contactor assembly.
  • Pry down on the mounting rail lock tab to free contactor assembly from the mounting rail.
  • Remove contactor assembly.
  • Install a new contactor assembly. Verify the new contactor assembly is securely mounted to mounting rail.
  • Connect all the electrical connections to new contactor assembly. Use the circuit diagram or wiring diagram for connection identification.
  • Remove the identification tags attached on all contactor assembly electrical connections.
  • Restore voltage supply to Generator Interface Box.
 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check the coil supply voltage.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check contactor KM1 coil supply voltage.

  • Use INSITE™ electronic service tool to enable the engine coolant heater.
  • Measure the voltage at the contactor coil inlet and outlet.

Use a circuit diagrams for coil connection identification and the following procedure for general voltage measurement techniques. Refer to Procedure 019-359 in Section 19.

23 to 26-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check the contactor performance.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check contactor KM1 performance.

  • Measure the resistance across all lines of the contactor switch when not energized.
  • Use INSITE™ electronic service tool to enable the engine coolant heater.
  • Measure the resistance across all lines when energized. Do not measure coil resistance.
  • Contactor coil energized, resistance is less than 10 ohms.
  • Contactor coil not energized, resistance is greater than 100k ohms.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Within specifications?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Replace KM1 contactor.

  • Isolate the voltage supply from the Generator Interface Box.
  • Create and attach identification tags to all contactor assembly electrical connections for reference during the installation of a new contactor assembly.
  • Disconnect all electrical connections to the contactor assembly.
  • Pry down on the mounting rail lock tab to free contactor assembly from the mounting rail.
  • Remove contactor assembly.
  • Install a new contactor assembly. Verify the new contactor assembly is securely mounted to mounting rail.
  • Connect all the electrical connections to new contactor assembly. Use the circuit diagram or wiring diagram for connection identification.
  • Remove the identification tags attached on all contactor assembly electrical connections.
  • Restore voltage supply to Generator Interface Box.

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Clear the inactive fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Clear the inactive fault codes.

  • Clear the inactive fault codes by pressing the "Reset" button on the control panel and cycling the engine keyswitch.
  • Use INSITE™ electronic service tool to verify the inactive fault codes are cleared.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Go to 6B

Appropriate troubleshooting steps

Guided Step 6B - Verify that fault code is inactive.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode and running for greater than 1 minute.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2868 is inactive.

Fault Code 2868 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-May-2012


FAULT CODE 2869 - High Temperature Cooling Circuit Current Driver - Current Above Normal or Grounded Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2869 active?
STEP 2. | Check the high temperature cooling control driver circuit. |
 | STEP 2A. Inspect the temperature controller and engine harness connector pins. | Dirty or damaged pins?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100 ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify that fault code is inactive. | Fault Code 2869 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2869 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the high temperature cooling control driver circuit.

Guided Step 2A - Inspect the temperature controller and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the temperature controller.

Action

Inspect the temperature controller and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the engine harness or the temperature controller, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the temperature controller.

Action

Inspect the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the engine harness and connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness.
  • Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from the CM700.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the HT temperature control circuit pin on the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit. Refer to the wiring diagram to identify connectors and pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100 ohms?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

  • Repair the engine harness.
  • Refer to Procedure 019-204 in Section 19
  • Refer to Procedure 019-208 in Section 19.
  • Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify that fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2869 is inactive.

Fault Code 2869 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect all components.
  • Connect INSITE™ electronic service tool

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 09-May-2012


FAULT CODE 2871 - High Temperature Cooling Circuit Current Driver - Current Below Normal or Open Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2871 active?
STEP 2. | Verify the signal circuit. |
 | STEP 2A. Verify the signal current between ECM and temperature controller. | 4 to 20 mA?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Clear the inactive fault code. | All fault codes cleared?
 | STEP 4B. Verify that the fault code is inactive. | Fault Code 2871 inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault code.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2871 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19..

Guided Step 2 - Verify the signal current.

Guided Step 2A - Verify the signal current between ECM and temperature controller.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Verify the circuit.

  • Measure the electrical current between the high temperature temperature controller supply and the high temperature temperature controller.

Use the following procedure for general current measurement techniques. Refer to Procedure 019-359 in Section 19.

Vary the high temperature temperature controller target temperature about the observed coolant temperature to modulate signal current.

4 to 20 mA?
YES NO

Repair

Replace the ECM.

  • Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harnesses and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness at the temperature controller and the CM700.

Action

Inspect the temperature controller and the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in temperature controller or engine harness connector.

Repair or replace the engine harness or the temperature controller, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness at the temperature controller connector and CM700 connector.

Action

Inspect the temperature controller and the engine harness connector pins for the following:

  • Measure the resistance from the high temperature temperature control circuit pin on the engine harness to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.
  • Use the circuit art or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness at the temperature controller connector and the CM700 connector.

Action

Check for an open circuit.

  • Measure the high temperature temperature controller supply resistance between the CM700 harness connector pin and the temperature controller harness connector pin.
  • Measure the high temperature temperature controller return resistance between the CM700 harness connector pin and the temperature controller harness connector pin.
  • Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

Repair

Replace the ECM.

  • Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Clear the inactive fault code.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Clear the inactive fault codes.

  • Clear inactive fault codes by pressing the "Reset" button on the control panel and cycling the engine keyswitch.
  • Use INSITE™ electronic service tool to verify the inactive fault codes are cleared.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Go to 4B

Appropriate troubleshooting chart

Guided Step 4B - Verify that the fault code is inactive.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 352 is inactive.

Fault Code 2871 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-May-2012


FAULT CODE 2872 - High Temperature (HT) Cooling Circuit Current Driver Breaker Tripped - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2872 active?
STEP 2. | Check the aftercooler cooling control circuit. |
 | STEP 2A. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit between ECM and circuit breaker. | Less than 10 ohms?
 | STEP 2C. Check for an open circuit between circuit breaker and VDC Source. | Less than 10 ohms?
STEP 3. | Check the high temperature control valve supply circuit. |
 | STEP 3A. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground between circuit breaker and contactor A. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to ground between circuit breaker and contactor B. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground between contactor A and high temperature control valve. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit to ground between contactor B and high temperature control valve. | Greater than 100k ohms?
STEP 4. | Check for high resistance across contactors. |
 | STEP 4A. Check for high resistance across contactor A. | Less than 10 ohms?
 | STEP 4B. Check for high resistance across contactor B. | Less than 10 ohms?
STEP 5. | Check circuit breaker trip switch resistance. |
 | STEP 5A. Check for high resistance across circuit breaker trip switch with main switch closed. | Less than 10 ohms?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Clear the inactive fault codes. | All fault codes cleared?
 | STEP 6B. Verify the fault code is inactive. | Fault Code 2872 inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2872 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the high temperature control valve trip sensing circuit.

Guided Step 2A - Inspect the wiring harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the MCB6 trip out and CM700.

Action

Inspect the circuit breaker trip circuit and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Repair or replace the engine harness, or the MCB, whichever has the damaged pins.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-043 in Section 19.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check for an open circuit between ECM and circuit breaker.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the MCB6 trip out and CM700.

Action

Check for an open circuit.

  • Measure the harnesses' electrical resistance from the MCB6 trip circuit out to the CM700.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

  • Repair or replace the engine harness.
  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 6A

Guided Step 2C - Check for an open circuit between circuit breaker and VDC source.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the MCB6 trip in and VDC source.

Action

Check for an open circuit.

  • Measure the MCB6 trip supply harnesses' electrical resistance between VDC source and MCB6 trip in.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

  • Repair or replace the engine harness.
  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-043 in Section 19.

Go to 6A

Go to 3A

Guided Step 3 - Check the high temperature control valve supply circuit.

Guided Step 3A - Inspect the wiring harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the VAC isolator, MCB6 main, KM6A contactor, KM6B contactor and high temperature control valve.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Repair or replace the engine harness, or the MCB, KM, high temperature control valve, whichever has the damaged pins.
  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check for a short circuit to ground between circuit breaker and contactor A.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the harness at the MCB6 main out connector and KM6A contactor in connector.

Action

Check for a short circuit from pin-to-pin.

  • Measure the harnesses' electrical resistance from the MCB6 main circuit outlet to electrical ground.
  • Measure the harnesses' electrical resistance from the KM6A contactor circuit inlet to electrical ground.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit to ground between circuit breaker and contactor B.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the harness at the MCB6 main out connector and KM6B contactor in connector.

Action

Check for a short circuit to ground.

  • Measure the harnesses' electrical resistance from the MCB6 main circuit outlet to electrical ground.
  • Measure the harnesses' electrical resistance from the KM6B contactor circuit inlet to electrical ground.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a short circuit to ground between contactor A and high temperature control valve.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the harness at the KM6A contactor out to high temperature control valve.

Action

Check for a short circuit to ground.

  • Measure the harnesses' electrical resistance from the KM6A contactor out to electrical ground.
  • Measure the harnesses' electrical resistance from the high temperature control valve to electrical ground.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 6A

Guided Step 3E - Check for a short circuit to ground between contactor B and high temperature control valve.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the harness at the KM6B contactor out connector to high temperature control valve.

Action

Check for a short circuit to ground.

  • Measure the harnesses' electrical resistance from the KM6B contactor out to electrical ground.
  • Measure the harnesses' electrical resistance from the high temperature control valve to electrical ground.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check for high resistance across contactors.

Guided Step 4A - Check for high resistance across contactor A.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the harness at the KM6A contactor and driver in connector and out connector.

Action

Supply KM6A driver in with +24VDC. Check resistance across KM6A contactor.

  • Measure KM6A contactor's electrical resistance from contactor in connector to the out connector.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Replace KM6A.

  • Isolate the voltage supply from the generator interface box.
  • Create and attach identification tags to all contactor assembly electrical connections for reference during the installation of a new contactor assembly.
  • Disconnect all electrical connections to the contactor assembly.
  • Pry down on the mounting rail lock tab to free contactor assembly from the mounting rail.
  • Remove contactor assembly.
  • Install a new contactor assembly. Verify the new contactor assembly is securely mounted to mounting rail.
  • Connect all the electrical connections to new contactor assembly. Use the circuit diagram or wiring diagram for connection identification.
  • Remove the identification tags attached on all contactor assembly electrical connections
  • Restore voltage supply to generator interface box.

Go to 4B

Go to 6A

Guided Step 4B - Check for high resistance across contactor B.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the harness at the KM6B contactor and driver in connector and out connector.

Action

Supply KM6B driver in with +24VDC. Check resistance across KM6B contactor.

  • Measure KM6B contactor's electrical resistance from contactor in connector to the out connector.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Replace KM6B.

  • Isolate the voltage supply from the generator interface box.
  • Create and attach identification tags to all contactor assembly electrical connections for reference during the installation of a new contactor assembly.
  • Disconnect all electrical connections to the contactor assembly.
  • Pry down on the mounting rail lock tab to free contactor assembly from the mounting rail.
  • Remove contactor assembly.
  • Install a new contactor assembly. Verify the new contactor assembly is securely mounted to mounting rail.
  • Connect all the electrical connections to new contactor assembly. Use the circuit diagram or wiring diagram for connection identification.
  • Remove the identification tags attached on all contactor assembly electrical connections
  • Restore voltage supply to generator interface box.

Go to 5A

Go to 6A

Guided Step 5 - Check circuit breaker trip switch resistance.

Guided Step 5A - Check for high resistance across circuit breaker trip switch with main switch closed.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the harness at the KM6A contactor and driver in connector and out connector.

Action

Close MCB6 main switch. Check resistance of MCB6 trip circuit.

  • Measure electrical resistance of MCB6 trip circuit in connector and out connector.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Clear the inactive fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Verify that fault code is inactive.

  • Clear the inactive fault codes by pressing the "Reset" button on the control panel and cycling the engine keyswitch.
  • Use INSITE™ electronic service tool to verify that the inactive fault codes are cleared.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Go to 6B

Appropriate troubleshooting steps

Guided Step 6B - Verify the fault codes are inactive.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 2872 is inactive.

Fault Code 2872 inactive?
YES NO
No Repair

Repair

  • Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-May-2012


FAULT CODE 2873 - Aftercooler Cooling Circuit Current Driver - Current Above Normal or Grounded Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2873 active?
STEP 2. | Verify the signal current. |
 | STEP 2A. Verify the signal current between ECM and temperature controller. | 4 to 20-mA?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Clear the inactive fault codes. | All fault codes cleared?
 | STEP 4B. Verify that fault code is inactive. | Fault Code 2873 inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2873 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Verify the signal current.

Guided Step 2A - Verify the signal current between ECM and temperature controller.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Verify the current.

  • Measure the electrical current between the low temperature temperature controller supply and the low temperature temperature controller.

Use the following procedure for general current measurement techniques. Refer to Procedure 019-359 in Section 19.

Vary the low temperature temperature controller target temperature about the observed coolant temperature to modulate signal current.

4 to 20-mA?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from the temperature controller and the CM700.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Repair or replace the engine harness, or the temperature controller, whichever has the damaged pins.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness.Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the harness at the temperature controller and CM700.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the low temperature temperature control circuit pin on the engine harness to all other pins in the engine harness connector.
  • Perform these check on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-204 Refer to Procedure and 019-208 in Section 19.
  • Replace the wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Clear the inactive fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Clear the inactive fault codes.

  • Clear inactive fault codes by pressing the "Reset" button on the control panel and cycling the engine keyswitch.
  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

  • Troubleshoot any remaining active fault codes.

Go to 4B

Appropriate troubleshooting chart

Guided Step 4B - Verify that fault code is inactive.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in Run mode and running for greater than one minute.
  • Connect INSITE™ electronic service tool.
  • Connect all components

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2873 is inactive.

Fault Code 2873 inactive?
YES NO
No Repair

Repair

  • Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-May-2012


FAULT CODE 2874 - Aftercooler Cooling Circuit Current Driver - Current Below Normal or Grounded Circuit

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2874 active?
STEP 2. | Verify the signal current. |
 | STEP 2A. Verify the signal current between the ECM and temperature controller. | 4 to 20-mA?
STEP 3. | Check the wiring harness. |
 | STEP 3A. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Clear the inactive fault codes. | All fault codes cleared?
 | STEP 4B. Verify that fault code is inactive. | Fault Code 2874 inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2874 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Verify the signal current.

Guided Step 2A - Verify the signal current between the ECM and temperature controller.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Verify the current.

  • Measure the electrical current between the low temperature temperature controller supply and the low temperature temperature controller.

Use the following procedure for general current measurement techniques. Refer to Procedure 019-359 in Section 19.

Vary the low temperature temperature controller target temperature about the observed coolant temperature to modulate signal current.

4 to 20-mA?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the wiring harness.

Guided Step 3A - Inspect the wiring harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connectors from the temperature controller and the CM700.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Repair or replace the engine harness, or the temperature controller, whichever has the damaged pins.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit.
  • Run/STOP switch in STOP position.
  • Disconnect the harness at the temperature controller and CM700.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the low temperature temperature control circuit pin on the engine harness to all other pins in the engine harness connector.
  • Perform these check on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the temperature controller and CM700.

Action

Check for an open circuit.

  • Measure the low temperature temperature controller supply resistance between the CM700 harness connector pin and the temperature controller harness connector pin.
  • Measure the low temperature temperature controller Return resistance between the CM700 harness connector pin and the temperature controller harness connector pin.
  • Perform these check on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Clear the inactive fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Clear the inactive fault codes.

  • Clear inactive fault codes by pressing the "Reset" button on the control panel and cycling the engine keyswitch.
  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

  • Troubleshoot any remaining active fault codes.

Go to 4B

Appropriate troubleshooting chart

Guided Step 4B - Verify that fault code is inactive.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.
  • Connect all components

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2874 is inactive.

Fault Code 2874 inactive?
YES NO
No Repair

Repair

  • Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-May-2012


FAULT CODE 2875 - Aftercooler Cooling (LT) Circuit Current Driver Breaker Tripped - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2875 active?
STEP 2. | Check the low temperature control valve trip sensing circuit. |
 | STEP 2A. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit between ECM and circuit breaker. | Less than 10 ohms?
 | STEP 2C. Check for an open circuit between circuit breaker and VDC Source. | Less than 10 ohms?
STEP 3. | Check the low temperature control valve supply circuit. |
 | STEP 3A. Inspect the wiring harness and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground between circuit breaker and contactor A. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to ground between circuit breaker and contactor B. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground between contactor A and low temperature control valve. | Greater than 100k ohms?
 | STEP 3E. Check for a short circuit to ground between contactor B and low temperature control valve. | Greater than 100k ohms?
STEP 4. | Check for high resistance across contactors. |
 | STEP 4A. Check for high resistance across contactor A. | Less than 10 ohms?
 | STEP 4B. Check for high resistance across contactor B. | Less than 10 ohms?
STEP 5. | Check circuit breaker trip switch resistance. |
 | STEP 5A. Check for high resistance across circuit breaker trip switch with main switch closed. | Less than 10 ohms?
STEP 6. | Clear the fault codes. |
 | STEP 6A. Clear the inactive fault codes. | All fault codes cleared?
 | STEP 6B. Verify the fault code is inactive. | Fault Code 2875 inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check the ECM for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2875 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the low temperature control valve trip sensing circuit.

Guided Step 2A - Inspect the wiring harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the MCB7 trip out and CM700.

Action

Inspect the circuit breaker trip circuit and the harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Repair or replace the engine harness, or the MCB, whichever has the damaged pins.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-043 in Section 19.
No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check for an open circuit between ECM and circuit breaker.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the MCB7 trip out and CM700.

Action

Check for an open circuit.

  • Measure the harnesses' electrical resistance from the MCB7 trip circuit out to the CM700.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

  • Repair or replace the engine harness.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-043 in Section 19.

Go to 2C

Go to 6A

Guided Step 2C - Check for an open circuit between circuit breaker and VDC source.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the MCB7 trip in and VDC source.

Action

Check for an open circuit.

  • Measure the MCB7 trip supply harnesses' electrical resistance between VDC source and MCB7 trip in.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

  • Repair or replace the engine harness.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-043 in Section 19.

Go to 6A

Go to 3A

Guided Step 3 - Check the low temperature control valve supply circuit.

Guided Step 3A - Inspect the wiring harness and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the harness at the VAC isolator, MCB7 main, KM7A contactor, KM7B contactor and low temperature control valve.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair the damaged pins.

  • Repair or replace the engine harness, or the MCB, KM, low temperature control valve, whichever has the damaged pins.
  • Flush the dirt, debris, or moisture from the connector pins, use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check for a short circuit to ground between circuit breaker and contactor A.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the harness at the MCB7 main out connector and KM7A contactor in connector.

Action

Check for a short circuit from pin to pin.

  • Measure the harnesses' electrical resistance from the MCB7 main circuit outlet to electrical ground.
  • Measure the harnesses' electrical resistance from the KM7A contactor circuit inlet to electrical ground.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 6A

Guided Step 3C - Check for a short circuit to ground between circuit breaker and contactor B.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the harness at the MCB7 main out connector and KM7B contactor in connector.

Action

Check for a short circuit to ground.

  • Measure the harnesses' electrical resistance from the MCB7 main circuit outlet to electrical ground.
  • Measure the harnesses' electrical resistance from the KM7B contactor circuit inlet to electrical ground.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 6A

Guided Step 3D - Check for a short circuit to ground between contactor A and low temperature control valve.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the harness at the KM7A contactor out to low temperature control valve.

Action

Check for a short circuit to ground.

  • Measure the harnesses' electrical resistance from the KM7A contactor out to electrical ground.
  • Measure the harnesses' electrical resistance from the low temperature control valve to electrical ground.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 6A

Guided Step 3E - Check for a short circuit to ground between contactor B and low temperature control valve.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the harness at the KM7B contactor out connector to low temperature control valve.

Action

Check for a short circuit to ground.

  • Measure the harnesses' electrical resistance from the KM7B contactor out to electrical ground.
  • Measure the harnesses' electrical resistance from the low temperature control valve to electrical ground.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-204 and Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 6A

Guided Step 4 - Check for high resistance across contactors.

Guided Step 4A - Check for high resistance across contactor A.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the harness at the KM7A contactor and driver in connector and out connector.

Action

Supply KM7A driver in with +24-VDC. Check resistance across KM7A contactor.

  • Measure KM7A contactor's electrical resistance from contactor in connector to the out connector.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Replace KM7A.

  • Isolate the voltage supply from the generator interface box.
  • Create and attach identification tags to all contactor assembly electrical connections for reference during the installation of a new contactor assembly.
  • Disconnect all electrical connections to the contactor assembly.
  • Pry down on the mounting rail lock tab to free contactor assembly from the mounting rail.
  • Remove contactor assembly.
  • Install a new contactor assembly. Verify the new contactor assembly is securely mounted to mounting rail.
  • Connect all the electrical connections to new contactor assembly. Use the circuit diagram or wiring diagram for connection identification.
  • Remove the identification tags attached on all contactor assembly electrical connections
  • Restore voltage supply to generator interface box.

Go to 4B

Go to 6A

Guided Step 4B - Check for high resistance across contactor B.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the harness at the KM7B contactor and driver in connector and out connector.

Action

Supply KM7B driver in with +24-VDC. Check resistance across KM7B contactor.

  • Measure KM7B contactor's electrical resistance from contactor in connector to the out connector.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Replace KM7B.

  • Isolate the voltage supply from the generator interface box.
  • Create and attach identification tags to all contactor assembly electrical connections for reference during the installation of a new contactor assembly.
  • Disconnect all electrical connections to the contactor assembly.
  • Pry down on the mounting rail lock tab to free contactor assembly from the mounting rail.
  • Remove contactor assembly.
  • Install a new contactor assembly. Verify the new contactor assembly is securely mounted to mounting rail.
  • Connect all the electrical connections to new contactor assembly. Use the circuit diagram or wiring diagram for connection identification.
  • Remove the identification tags attached on all contactor assembly electrical connections
  • Restore voltage supply to generator interface box.

Go to 5A

Go to 6A

Guided Step 5 - Check circuit breaker trip switch resistance.

Guided Step 5A - Check for high resistance across circuit breaker trip switch with main switch closed.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP position.
  • Disconnect the harness at the KM7A contactor and driver in connector and out connector.

Action

Close MCB7 main switch. Check resistance of MCB7 trip circuit.

  • Measure electrical resistance of MCB7 trip circuit in connector and out connector.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Go to 6A

Go to 6A

Guided Step 6 - Clear the fault codes.

Guided Step 6A - Clear the inactive fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Verify that fault code is inactive.

  • Clear the inactive fault codes by pressing the "Reset" button on the control panel and cycling the engine keyswitch.
  • Use INSITE™ electronic service tool to verify that the inactive fault codes are cleared.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Go to 6B

Appropriate troubleshooting steps

Guided Step 6B - Verify the fault codes are inactive.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in Run mode and operate the engine for greater than 1 minute.
  • Connect INSITE™ electronic service tool.
  • Connect all components.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 2875 is inactive.

Fault Code 2875 inactive?
YES NO
No Repair

Repair

  • Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-May-2012


FAULT CODE 2876 - Turbocharger 1 Compressor Inlet Temperature - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2876 active?
 | STEP 1B. Check for multiple active/inactive fault codes. | Fault Codes 135, 136, 137, 141, 144,145, 212, 213, 231, 232, 2111, 2112, 2115, 2116, 2154, 2155, and/or 2877 active/inactive?
STEP 2. | Check the turbocharger compressor intake air temperature sensor. |
 | STEP 2A. Inspect the turbocharger compressor intake air temperature sensor connector and connector pins. | Dirty or damaged pins ?
 | STEP 2B. Check the temperature sensor resistance. | Resistance 625 ohms to 36k ohms?
STEP 3. | Check the CM700 and engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open-circuit in the engine harness. | Less than10 ohms?
 | STEP 3C. Check for a pin-to-pin short in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check the supply voltage at the ECM. | 4.75 to 5.25-VDC?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Is Fault Code 2876 inactive?
 | STEP 4B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronics ervice tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2876 active?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 1B

Go to 1B

Guided Step 1B - Check for multiple active/inactive active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Check for multiple active/inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 135, 136, 137, 141, 144,145, 212, 213, 231, 232, 2111, 2112,2115, 2116, 2154, 2155, and/or 2877 active/inactive?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

Refer to Procedure 019-362 in Section 19.

Go to 4A

Go to 2A

Guided Step 2 - Check the turbocharger compressor intake air temperature sensor.

Guided Step 2A - Inspect the turbocharger compressor intake air temperature sensor connector and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the turbocharger intake air temperature sensor.

Action

Inspect the turbocharger intake air temperature sensor connector, the engine harness connector and the connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness or the turbocharger compressor intake air temperature sensor, whichever has the damaged connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-202 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the turbocharger intake air temperature sensor. Refer to Procedure 019-082 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the temperature sensor resistance.

Conditions

  • De-energized keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the turbocharger compressor intake air sensor connector.

Action

Use a multimeter, measure the resistance of the turbocharger compressor intake air temperature sensor from the sensor SIGNAL (+) pin to the sensor RETURN (-) pin at the sensor.

  • Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance 625 ohms to 36k ohms?
YES NO
No Repair

Repair

The turbocharger speed sensor has malfunctioned.

  • Replace the turbocharger intake air temperature sensor. Refer to Procedure 019-082 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the CM700 and engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700 module.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform all these checks on all interconnecting harness connectors in the circuit. Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Replace the damaged pins.

Repair or replace the engine harness or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness .

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700 module.
  • Disconnect the engine harness from the turbocharger compressor intake air temperature sensor.

Action

Use a multimeter to check for an open circuit in the engine harness:

  • Measure the resistance from the turbocharger compressor intake air temperature sensor SIGNAL(+) pin at the CM700 connector to the turbocharger compressor intake air temperature sensor SIGNAL (+) pin at the turbocharger compressor intake air temperature sensor connector.
  • Measure the resistance from the turbocharger compressor intake air temperature sensor RETURN(-) pin at the CM700 connector to the turbocharger compressor intake air temperature sensor RETURN (-) pin at the turbocharger compressor intake air temperature sensor connector
  • Use the circuit diagram or wiring diagram for connector pin identification.
  • Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the engine harness.

  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700 module.
  • Disconnect the engine harness from the turbocharger compressor intake air temperature sensor.

Action

Use a multimeter, check for a short circuit pin-to-pin in the engine harness:

  • Measure the resistance from the turbocharger compressor intake air temperature sensor SIGNAL(+) pin at the CM700 connector to all other pins in the CM700 connector.
  • Measure the resistance from the turbocharger compressor intake air temperature sensor RETURN(-) pin at the CM700 connector to all other pins in the CM700 connector.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short has been detected in the engine harness.

  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700 module.
  • Disconnect the engine harness from the turbocharger compressor intake air temperature sensor.

Action

Use a multimeter to check for a short circuit-to-ground in the engine harness:

  • Measure the resistance from the turbocharger compressor intake air temperature sensor SIGNAL(+) pin at the CM700 connector to the engine block ground.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short has been detected in the engine harness.

  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check the supply voltage at the ECM.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode
  • Disconnect the engine harness from the CM700 module.

Action

Use a multimeter to check the turbocharger compressor inlet temperature supply voltage at the ECM.

  • Measure the voltage between the turbocharger compressor intake air temperature sensor SIGNAL (+) pin at the CM700 connector B on the ECM to the engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general voltage measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • A fault has been detected within the CM700 module. Replace the CM700 module. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute.
  • Use INSITE™ electronic service tool to verify that Fault Code 2876 is inactive.

Action

Clear the inactive fault codes.

  • Clear inactive fault codes by pressing the "Reset" button on the control panel and cycling the engine keyswitch.
  • Use INSITE™ electronic service tool to verify inactive fault codes are cleared.

Fault code 2876 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 09-May-2012


FAULT CODE 2877 - Turbocharger 1 Compressor Inlet Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2877 active?
 | STEP 1B. Check for multiple active/inactive active fault codes. | Fault codes 135, 136, 137, 141, 144, 145, 212, 213, 231, 232, 2111, 2112, 2115, 2116, 2154, and/or 2155 active/inactive?
STEP 2. | Check the turbocharger compressor intake air temperature sensor. |
 | STEP 2A. Inspect the turbocharger compressor intake air temperature sensor connector and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the temperature sensor resistance. | Resistance 625 ohms to 36k ohms?
STEP 3. | Check the CM700 and engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check the supply voltage at the ECM. | 4.75 to 5.25-VDC?
STEP 4. | Clear the fault code. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 2877 is inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 2877 active?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 1B

Go to 1B

Guided Step 1B - Check for multiple active/inactive active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active/inactive fault codes.

  • Use INSITE™ electronic service tool to read the active and inactive fault codes.

Fault Codes 135, 136, 137, 141, 144, 145, 212, 213, 231, 232, 2111, 2112, 2115, 2116, 2154, and/or 2155 active/inactive?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 4A

Go to 2A

Guided Step 2 - Check the turbocharger compressor intake air temperature sensor.

Guided Step 2A - Inspect the turbocharger compressor intake air temperature sensor connector and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the turbocharger intake air temperature sensor.

Action

Inspect the turbocharger intake air temperature sensor connector, the engine harness connector, and the connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Repair or replace the engine harness or the turbocharger compressor intake air temperature sensor, whichever has the damaged connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the damaged connector. Refer to Procedure 019-202 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the turbocharger intake air temperature sensor. Refer to Procedure 019-082 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the temperature sensor resistance.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness connector from the turbocharger compressor intake air sensor connector.

Action

Check the temperature sensor resistance.

  • Use a multimeter to measure the resistance of the turbocharger compressor intake air temperature sensor from the sensor SIGNAL (+) pin to the sensor RETURN (-) pin at the sensor.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance 625 ohms to 36k ohms?
YES NO
No Repair

Repair

The turbocharger speed sensor has malfunctioned.

  • Replace the turbocharger intake air temperature sensor. Refer to Procedure 019-082 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the CM700 and engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700 module.

Action

Inspect the compressor inlet air temperature sensor connector and pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the circuit art or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the engine harness or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine wiring harness connector. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700 module.
  • Disconnect the engine harness from the turbocharger compressor intake air temperature sensor.

Action

Use a multimeter to check for an open circuit in the engine harness:

  • Measure the resistance from the turbocharger compressor intake air temperature sensor SIGNAL (+) pin at the CM700 connector to the turbocharger compressor intake air temperature sensor SIGNAL (+) pin at the turbocharger compressor intake air temperature sensor connector.
  • Measure the resistance from the turbocharger compressor intake air temperature sensor RETURN (-) pin at the CM700 connector to the turbocharger compressor intake air temperature sensor RETURN (-) pin at the turbocharger compressor intake air temperature sensor connector.
  • Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700 module.
  • Disconnect the engine harness from the turbocharger compressor intake air temperature sensor.

Action

Use a multimeter to check for a short circuit pin-to-pin in the engine harness:

  • Measure the resistance from the turbocharger compressor intake air temperature sensor SIGNAL (+) pin at the CM700 connector to all other pins in the CM700 connector.
  • Measure the resistance from the turbocharger compressor intake air temperature sensor RETURN (-) pin at the CM700 connector to all other pins in the CM700 connector.
  • Use the circuit diagram or wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short has been detected in the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the CM700 module.
  • Disconnect the engine harness from the turbocharger compressor intake air temperature sensor.

Action

Use a multimeter to check for a short circuit to ground in the engine harness:

  • Measure the resistance from the turbocharger compressor intake air temperature sensor SIGNAL (+) pin at the CM700 connector to the engine block ground.
  • Use the circuit diagram or wiring diagram for connector pin identification.
  • Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short has been detected in the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check the supply voltage at the ECM.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the wiring harness from the CM700 module.

Action

Use a multimeter to check the turbocharger compressor inlet temperature supply voltage at the ECM.

  • Measure the voltage between the turbocharger compressor intake air temperature sensor SIGNAL (+) pin at the CM700 connector B on the ECM to the engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault code.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate the engine for greater than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 2877 is inactive.

Fault Code 2877 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes

Repair complete

Appropriate troubleshooting chart.

Last Modified: 09-May-2012


FAULT CODE 2994 - Engine Control Module Internal Failure - Special Instructions

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 2994 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 2994. | Less than three counts?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check the ECM.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to verify that the Fault Code 2994 is inactive.

Fault Code 2994 inactive?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 1B

Repair complete

Guided Step 1B - Check the inactive counts of Fault Code 2994.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check the inactive counts of Fault Code 2994.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 2994.

Less than three counts?
YES NO
No Repair

Repair

Contact a Cummins® Authorized Repair Location.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 18-Mar-2011


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3111 and/or 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
STEP 2. | Inspect cylinder 1 cylinder head. |
 | STEP 2A. Inspect the cylinder head. | Leaking gaskets or loose components?
 | STEP 2B. Check the valve lash. | Valve lash correct?
 | STEP 2C. Inspect the valve train. | Worn or improperly installed valve train components?
STEP 3. | Inspect cylinder 1 power cylinder. |
 | STEP 3A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 3B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 3C. Inspect connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 3D. Inspect piston cooling nozzle. | Piston cooling nozzle bent or missing?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 3111 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3111 and/or 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Go to 2A

Go to 4A

Guided Step 2 - Inspect cylinder 1 cylinder head.

Guided Step 2A - Inspect the cylinder head.

Conditions

  • Keyswitch circuit de-energised.
  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the cylinder head.

Inspect the cylinder 1 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder 1 cylinder head.

Leaking gaskets or loose components?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose engine components on or immediately around cylinder 1 cylinder head.
 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the valve lash.

Conditions

  • Keyswitch circuit de-energised.
  • Run/Stop/Auto switch in Stop mode.

Action

Check the valve lash.

  • Check that cylinder 1 valve lash setting is correct. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Valve lash correct?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

Go to 4A

Go to 2C

Guided Step 2C - Inspect the valve train.

Conditions

  • Keyswitch circuit de-energised.
  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the valve train.

Inspect the cylinder 1 valve train for the following:

  • Correct valve lash setting. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.
  • Inlet or exhaust valve wear or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Cam follower wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder 1 camshaft lobe wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Worn or improperly installed valve train components?
YES NO

Repair

  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the cam follower assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

  • Adjust the valve lash setting. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 4A

Go to 3A

Guided Step 3 - Inspect cylinder 1 power cylinder.

Guided Step 3A - Cut open the oil filters and inspect for debris.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Repair

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 3D

Guided Step 3B - Inspect the internal power cylinder.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the internal power cylinder for the following:

NOTE: If available, the inspection can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 1 power cylinder damaged?
YES NO

Repair

Replace the damaged components.

  • Replace the piston rings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Replace the cylinder liner. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the connecting rod bearings.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the connecting rod bearings.

  • Inspect cylinder 1 connecting rod bearings for excessive wear or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder 1 connecting rod bearings damaged?
YES NO

Repair

Replace the connecting rod bearings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the piston cooling nozzle.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the piston cooling nozzle.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder 1 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 3111 is inactive.

Fault code 3111 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the RUN mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes

Repair Complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3112 and/or 3111, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
STEP 2. | Inspect cylinder 2 cylinder head. |
 | STEP 2A. Inspect the cylinder head. | Leaking gaskets or loose components?
 | STEP 2B. Check the valve lash. | Valve lash correct?
 | STEP 2C. Inspect the valve train. | Worn or improperly installed valve train components?
STEP 3. | Inspect cylinder 2 power cylinder. |
 | STEP 3A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 3B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 3C. Inspect connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 3D. Inspect piston cooling nozzle. | Piston cooling nozzle bent or missing?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 3112 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3112 and/or 3111, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Go to 2A

Go to 4A

Guided Step 2 - Inspect cylinder 2 cylinder head.

Guided Step 2A - Inspect the cylinder head.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the cylinder head.

Inspect the cylinder 2 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder 2 cylinder head.

Leaking gaskets or loose components?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose engine components on or immediately around cylinder 2 cylinder head.
 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the valve lash.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Check the valve lash.

  • Check that cylinder 2 valve lash setting is correct. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Valve lash correct?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

Go to 4A

Go to 2C

Guided Step 2C - Inspect the valve train.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the valve train.

Inspect the cylinder 2 valve train for the following:

  • Correct valve lash setting. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.
  • Inlet or exhaust valve wear or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Cam follower wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder 2 camshaft lobe wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Worn or improperly installed valve train components?
YES NO

Repair

  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the cam follower assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

  • Adjust the valve lash setting. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 4A

Go to 3A

Guided Step 3 - Inspect cylinder 2 power cylinder.

Guided Step 3A - Cut open the oil filters and inspect for debris.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Repair

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 3D

Guided Step 3B - Inspect the internal power cylinder.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the internal power cylinder for the following:

NOTE: If available, the inspection can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 2 power cylinder damaged?
YES NO

Repair

Replace the damaged components.

  • Replace the piston rings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Replace the cylinder liner. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the connecting rod bearings.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the connecting rod bearings.

  • Inspect cylinder 2 connecting rod bearings for excessive wear or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder 2 connecting rod bearings damaged?
YES NO

Repair

Replace the connecting rod bearings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the piston cooling nozzle.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the piston cooling nozzle.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder 2 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 3112 is inactive.

Fault code 3112 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the RUN mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes

Repair Complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3113 and/or 3111, 3112, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
STEP 2. | Inspect cylinder 3 cylinder head. |
 | STEP 2A. Inspect the cylinder head. | Leaking gaskets or loose components?
 | STEP 2B. Check the valve lash. | Valve lash correct?
 | STEP 2C. Inspect the valve train. | Worn or improperly installed valve train components?
STEP 3. | Inspect cylinder 3 power cylinder. |
 | STEP 3A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 3B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 3C. Inspect connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 3D. Inspect piston cooling nozzle. | Piston cooling nozzle bent or missing?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 3113 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3113 and/or 3111, 3112, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Go to 2A

Go to 4A

Guided Step 2 - Inspect cylinder 3 cylinder head.

Guided Step 2A - Inspect the cylinder head.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the cylinder head.

Inspect the cylinder 3 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder 3 cylinder head.

Leaking gaskets or loose components?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose engine components on or immediately around cylinder 3 cylinder head.
 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the valve lash.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Check the valve lash.

  • Check that cylinder 3 valve lash setting is correct. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Valve lash correct?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

Go to 4A

Go to 2C

Guided Step 2C - Inspect the valve train.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the valve train.

Inspect the cylinder 3 valve train for the following:

  • Correct valve lash setting. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.
  • Inlet or exhaust valve wear or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Cam follower wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder 3 camshaft lobe wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Worn or improperly installed valve train components?
YES NO

Repair

  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the cam follower assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

  • Adjust the valve lash setting. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 4A

Go to 3A

Guided Step 3 - Inspect cylinder 3 power cylinder.

Guided Step 3A - Cut open the oil filters and inspect for debris.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Repair

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 3D

Guided Step 3B - Inspect the internal power cylinder.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the internal power cylinder for the following:

NOTE: If available, the inspection can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 3 power cylinder damaged?
YES NO

Repair

Replace the damaged components.

  • Replace the piston rings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Replace the cylinder liner. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the connecting rod bearings.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the connecting rod bearings.

  • Inspect cylinder 3 connecting rod bearings for excessive wear or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder 3 connecting rod bearings damaged?
YES NO

Repair

Replace the connecting rod bearings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the piston cooling nozzle.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the piston cooling nozzle.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder 3 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 3113 is inactive.

Fault code 3113 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the RUN mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes

Repair Complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3114 and/or 3111, 3112, 3113, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
STEP 2. | Inspect cylinder 4 cylinder head. |
 | STEP 2A. Inspect the cylinder head. | Leaking gaskets or loose components?
 | STEP 2B. Check the valve lash. | Valve lash correct?
 | STEP 2C. Inspect the valve train. | Worn or improperly installed valve train components?
STEP 3. | Inspect cylinder 4 power cylinder. |
 | STEP 3A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 3B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 3C. Inspect connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 3D. Inspect piston cooling nozzle. | Piston cooling nozzle bent or missing?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 3114 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3114 and/or 3111, 3112, 3113, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Go to 2A

Go to 4A

Guided Step 2 - Inspect cylinder 4 cylinder head.

Guided Step 2A - Inspect the cylinder head.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the cylinder head.

Inspect the cylinder 4 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder 4 cylinder head.

Leaking gaskets or loose components?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose engine components on or immediately around cylinder 4 cylinder head.
 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the valve lash.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Check the valve lash.

  • Check that cylinder 4 valve lash setting is correct. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Valve lash correct?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

Go to 4A

Go to 2C

Guided Step 2C - Inspect the valve train.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the valve train.

Inspect the cylinder 4 valve train for the following:

  • Correct valve lash setting. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.
  • Inlet or exhaust valve wear or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Cam follower wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder 4 camshaft lobe wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Worn or improperly installed valve train components?
YES NO

Repair

  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the cam follower assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

  • Adjust the valve lash setting. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 4A

Go to 3A

Guided Step 3 - Inspect cylinder 4 power cylinder.

Guided Step 3A - Cut open the oil filters and inspect for debris.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Repair

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 3D

Guided Step 3B - Inspect the internal power cylinder.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the internal power cylinder for the following:

NOTE: If available, the inspection can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 4 power cylinder damaged?
YES NO

Repair

Replace the damaged components.

  • Replace the piston rings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Replace the cylinder liner. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the connecting rod bearings.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the connecting rod bearings.

  • Inspect cylinder 4 connecting rod bearings for excessive wear or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder 4 connecting rod bearings damaged?
YES NO

Repair

Replace the connecting rod bearings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the piston cooling nozzle.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the piston cooling nozzle.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder 4 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 3114 is inactive.

Fault code 3114 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the RUN mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes

Repair Complete

Appropriate troubleshooting chart

Last Modified: 30-Jun-2010


FAULT CODE 3115 - Engine Cylinder Number 5 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3115 and/or 3111, 3112, 3113, 3114, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
STEP 2. | Inspect cylinder 5 cylinder head. |
 | STEP 2A. Inspect the cylinder head. | Leaking gaskets or loose components?
 | STEP 2B. Check the valve lash. | Valve lash correct?
 | STEP 2C. Inspect the valve train. | Worn or improperly installed valve train components?
STEP 3. | Inspect cylinder 5 power cylinder. |
 | STEP 3A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 3B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 3C. Inspect connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 3D. Inspect piston cooling nozzle. | Piston cooling nozzle bent or missing?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 3115 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3115 and/or 3111, 3112, 3113, 3114, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Go to 2A

Go to 4A

Guided Step 2 - Inspect cylinder 5 cylinder head.

Guided Step 2A - Inspect the cylinder head.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the cylinder head.

Inspect the cylinder 5 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder 5 cylinder head.

Leaking gaskets or loose components?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose engine components on or immediately around cylinder 5 cylinder head.
 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the valve lash.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Check the valve lash.

  • Check that cylinder 5 valve lash setting is correct. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Valve lash correct?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

Go to 4A

Go to 2C

Guided Step 2C - Inspect the valve train.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the valve train.

Inspect the cylinder 5 valve train for the following:

  • Correct valve lash setting. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.
  • Inlet or exhaust valve wear or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Cam follower wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder 5 camshaft lobe wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Worn or improperly installed valve train components?
YES NO

Repair

  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the cam follower assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

  • Adjust the valve lash setting. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 4A

Go to 3A

Guided Step 3 - Inspect cylinder 5 power cylinder.

Guided Step 3A - Cut open the oil filters and inspect for debris.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Repair

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 3D

Guided Step 3B - Inspect the internal power cylinder.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the internal power cylinder for the following:

NOTE: If available, the inspection can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 5 power cylinder damaged?
YES NO

Repair

Replace the damaged components.

  • Replace the piston rings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Replace the cylinder liner. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the connecting rod bearings.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the connecting rod bearings.

  • Inspect cylinder 5 connecting rod bearings for excessive wear or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder 5 connecting rod bearings damaged?
YES NO

Repair

Replace the connecting rod bearings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the piston cooling nozzle.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the piston cooling nozzle.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder 5 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 3115 is inactive.

Fault code 3115 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the RUN mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes

Repair Complete

Appropriate troubleshooting chart

Last Modified: 02-Jul-2010


FAULT CODE 3116 - Engine Cylinder Number 6 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3116 and/or 3111, 3112, 3113, 3114, 3115, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
STEP 2. | Inspect cylinder 6 cylinder head. |
 | STEP 2A. Inspect the cylinder head. | Leaking gaskets or loose components?
 | STEP 2B. Check the valve lash. | Valve lash correct?
 | STEP 2C. Inspect the valve train. | Worn or improperly installed valve train components?
STEP 3. | Inspect cylinder 6 power cylinder. |
 | STEP 3A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 3B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 3C. Inspect connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 3D. Inspect piston cooling nozzle. | Piston cooling nozzle bent or missing?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 3116 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3116 and/or 3111, 3112, 3113, 3114, 3115, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Go to 2A

Go to 4A

Guided Step 2 - Inspect cylinder 6 cylinder head.

Guided Step 2A - Inspect the cylinder head.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the cylinder head.

Inspect the cylinder 6 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder 6 cylinder head.

Leaking gaskets or loose components?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose engine components on or immediately around cylinder 6 cylinder head.
 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the valve lash.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Check the valve lash.

  • Check that cylinder 6 valve lash setting is correct. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Valve lash correct?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

Go to 4A

Go to 2C

Guided Step 2C - Inspect the valve train.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the valve train.

Inspect the cylinder 6 valve train for the following:

  • Correct valve lash setting. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.
  • Inlet or exhaust valve wear or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Cam follower wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder 6 camshaft lobe wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Worn or improperly installed valve train components?
YES NO

Repair

  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the cam follower assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

  • Adjust the valve lash setting. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 4A

Go to 3A

Guided Step 3 - Inspect cylinder 6 power cylinder.

Guided Step 3A - Cut open the oil filters and inspect for debris.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Repair

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 3D

Guided Step 3B - Inspect the internal power cylinder.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the internal power cylinder for the following:

NOTE: If available, the inspection can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 6 power cylinder damaged?
YES NO

Repair

Replace the damaged components.

  • Replace the piston rings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Replace the cylinder liner. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the connecting rod bearings.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the connecting rod bearings.

  • Inspect cylinder 6 connecting rod bearings for excessive wear or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder 6 connecting rod bearings damaged?
YES NO

Repair

Replace the connecting rod bearings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the piston cooling nozzle.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the piston cooling nozzle.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder 6 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 3116 is inactive.

Fault code 3116 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the RUN mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes

Repair Complete

Appropriate troubleshooting chart

Last Modified: 02-Jul-2010


FAULT CODE 3117 - Engine Cylinder Number 7 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3117 and/or 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
STEP 2. | Inspect cylinder 7 cylinder head. |
 | STEP 2A. Inspect the cylinder head. | Leaking gaskets or loose components?
 | STEP 2B. Check the valve lash. | Valve lash correct?
 | STEP 2C. Inspect the valve train. | Worn or improperly installed valve train components?
STEP 3. | Inspect cylinder 7 power cylinder. |
 | STEP 3A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 3B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 3C. Inspect connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 3D. Inspect piston cooling nozzle. | Piston cooling nozzle bent or missing?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 3117 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3117 and/or 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Go to 2A

Go to 4A

Guided Step 2 - Inspect cylinder 7 cylinder head.

Guided Step 2A - Inspect the cylinder head.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the cylinder head.

Inspect the cylinder 7 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder 7 cylinder head.

Leaking gaskets or loose components?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose engine components on or immediately around cylinder 7 cylinder head.
 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the valve lash.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Check the valve lash.

  • Check that cylinder 7 valve lash setting is correct. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Valve lash correct?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

Go to 4A

Go to 2C

Guided Step 2C - Inspect the valve train.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the valve train.

Inspect the cylinder 7 valve train for the following:

  • Correct valve lash setting. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.
  • Inlet or exhaust valve wear or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Cam follower wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder 7 camshaft lobe wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Worn or improperly installed valve train components?
YES NO

Repair

  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the cam follower assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

  • Adjust the valve lash setting. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 4A

Go to 3A

Guided Step 3 - Inspect cylinder 7 power cylinder.

Guided Step 3A - Cut open the oil filters and inspect for debris.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Repair

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 3D

Guided Step 3B - Inspect the internal power cylinder.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the internal power cylinder for the following:

NOTE: If available, the inspection can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 7 power cylinder damaged?
YES NO

Repair

Replace the damaged components.

  • Replace the piston rings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Replace the cylinder liner. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the connecting rod bearings.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the connecting rod bearings.

  • Inspect cylinder 7 connecting rod bearings for excessive wear or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder 7 connecting rod bearings damaged?
YES NO

Repair

Replace the connecting rod bearings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the piston cooling nozzle.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the piston cooling nozzle.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder 7 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 3117 is inactive.

Fault code 3117 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the RUN mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes

Repair Complete

Appropriate troubleshooting chart

Last Modified: 02-Jul-2010


FAULT CODE 3118 - Engine Cylinder Number 8 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3118 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
STEP 2. | Inspect cylinder 8 cylinder head. |
 | STEP 2A. Inspect the cylinder head. | Leaking gaskets or loose components?
 | STEP 2B. Check the valve lash. | Valve lash correct?
 | STEP 2C. Inspect the valve train. | Worn or improperly installed valve train components?
STEP 3. | Inspect cylinder 8 power cylinder. |
 | STEP 3A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 3B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 3C. Inspect connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 3D. Inspect piston cooling nozzle. | Piston cooling nozzle bent or missing?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 3118 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3118 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Go to 2A

Go to 4A

Guided Step 2 - Inspect cylinder 8 cylinder head.

Guided Step 2A - Inspect the cylinder head.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the cylinder head.

Inspect the cylinder 8 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder 8 cylinder head.

Leaking gaskets or loose components?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose engine components on or immediately around cylinder 8 cylinder head.
 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the valve lash.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Check the valve lash.

  • Check that cylinder 8 valve lash setting is correct. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Valve lash correct?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

Go to 4A

Go to 2C

Guided Step 2C - Inspect the valve train.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the valve train.

Inspect the cylinder 8 valve train for the following:

  • Correct valve lash setting. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.
  • Inlet or exhaust valve wear or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Cam follower wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder 8 camshaft lobe wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Worn or improperly installed valve train components?
YES NO

Repair

  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the cam follower assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

  • Adjust the valve lash setting. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 4A

Go to 3A

Guided Step 3 - Inspect cylinder 8 power cylinder.

Guided Step 3A - Cut open the oil filters and inspect for debris.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Repair

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 3D

Guided Step 3B - Inspect the internal power cylinder.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the internal power cylinder for the following:

NOTE: If available, the inspection can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 8 power cylinder damaged?
YES NO

Repair

Replace the damaged components.

  • Replace the piston rings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Replace the cylinder liner. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the connecting rod bearings.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the connecting rod bearings.

  • Inspect cylinder 8 connecting rod bearings for excessive wear or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder 8 connecting rod bearings damaged?
YES NO

Repair

Replace the connecting rod bearings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the piston cooling nozzle.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the piston cooling nozzle.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder 8 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 3118 is inactive.

Fault code 3118 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the RUN mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes

Repair Complete

Appropriate troubleshooting chart

Last Modified: 02-Jul-2010


FAULT CODE 3119 - Engine Cylinder Number 9 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3119 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
STEP 2. | Inspect cylinder 9 cylinder head. |
 | STEP 2A. Inspect the cylinder head. | Leaking gaskets or loose components?
 | STEP 2B. Check the valve lash. | Valve lash correct?
 | STEP 2C. Inspect the valve train. | Worn or improperly installed valve train components?
STEP 3. | Inspect cylinder 9 power cylinder. |
 | STEP 3A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 3B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 3C. Inspect connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 3D. Inspect piston cooling nozzle. | Piston cooling nozzle bent or missing?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 3119 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3119 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Go to 2A

Go to 4A

Guided Step 2 - Inspect cylinder 9 cylinder head.

Guided Step 2A - Inspect the cylinder head.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the cylinder head.

Inspect the cylinder 9 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder 9 cylinder head.

Leaking gaskets or loose components?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose engine components on or immediately around cylinder 9 cylinder head.
 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the valve lash.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Check the valve lash.

  • Check that cylinder 9 valve lash setting is correct. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Valve lash correct?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

Go to 4A

Go to 2C

Guided Step 2C - Inspect the valve train.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the valve train.

Inspect the cylinder 9 valve train for the following:

  • Correct valve lash setting. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.
  • Inlet or exhaust valve wear or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Cam follower wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder 9 camshaft lobe wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Worn or improperly installed valve train components?
YES NO

Repair

  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the cam follower assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

  • Adjust the valve lash setting. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 4A

Go to 3A

Guided Step 3 - Inspect cylinder 9 power cylinder.

Guided Step 3A - Cut open the oil filters and inspect for debris.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Repair

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 3D

Guided Step 3B - Inspect the internal power cylinder.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the internal power cylinder for the following:

NOTE: If available, the inspection can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 9 power cylinder damaged?
YES NO

Repair

Replace the damaged components.

  • Replace the piston rings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Replace the cylinder liner. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the connecting rod bearings.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the connecting rod bearings.

  • Inspect cylinder 9 connecting rod bearings for excessive wear or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder 9 connecting rod bearings damaged?
YES NO

Repair

Replace the connecting rod bearings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the piston cooling nozzle.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the piston cooling nozzle.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder 9 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 3119 is inactive.

Fault code 3119 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the RUN mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes

Repair Complete

Appropriate troubleshooting chart

Last Modified: 02-Jul-2010


FAULT CODE 3121 - Engine Cylinder Number 10 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3121 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3122, 3123, 3124, 3125, 3126, 3127 active?
STEP 2. | Inspect cylinder 10 cylinder head. |
 | STEP 2A. Inspect the cylinder head. | Leaking gaskets or loose components?
 | STEP 2B. Check the valve lash. | Valve lash correct?
 | STEP 2C. Inspect the valve train. | Worn or improperly installed valve train components?
STEP 3. | Inspect cylinder 10 power cylinder. |
 | STEP 3A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 3B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 3C. Inspect connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 3D. Inspect piston cooling nozzle. | Piston cooling nozzle bent or missing?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 3121 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3121 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3122, 3123, 3124, 3125, 3126, 3127 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Go to 2A

Go to 4A

Guided Step 2 - Inspect cylinder 10 cylinder head.

Guided Step 2A - Inspect the cylinder head.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the cylinder head.

Inspect the cylinder 10 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder 10 cylinder head.

Leaking gaskets or loose components?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose engine components on or immediately around cylinder 10 cylinder head.
 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the valve lash.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Check the valve lash.

  • Check that cylinder 10 valve lash setting is correct. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Valve lash correct?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

Go to 4A

Go to 2C

Guided Step 2C - Inspect the valve train.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the valve train.

Inspect the cylinder 10 valve train for the following:

  • Correct valve lash setting. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.
  • Inlet or exhaust valve wear or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Cam follower wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder 10 camshaft lobe wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Worn or improperly installed valve train components?
YES NO

Repair

  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the cam follower assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

  • Adjust the valve lash setting. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 4A

Go to 3A

Guided Step 3 - Inspect cylinder 10 power cylinder.

Guided Step 3A - Cut open the oil filters and inspect for debris.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Repair

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 3D

Guided Step 3B - Inspect the internal power cylinder.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the internal power cylinder for the following:

NOTE: If available, the inspection can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 10 power cylinder damaged?
YES NO

Repair

Replace the damaged components.

  • Replace the piston rings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Replace the cylinder liner. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the connecting rod bearings.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the connecting rod bearings.

  • Inspect cylinder 10 connecting rod bearings for excessive wear or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder 10 connecting rod bearings damaged?
YES NO

Repair

Replace the connecting rod bearings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the piston cooling nozzle.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the piston cooling nozzle.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder 10 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 3121 is inactive.

Fault code 3121 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the RUN mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes

Repair Complete

Appropriate troubleshooting chart

Last Modified: 02-Jul-2010


FAULT CODE 3122 - Engine Cylinder Number 11 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3122 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3123, 3124, 3125, 3126, 3127 active?
STEP 2. | Inspect cylinder 11 cylinder head. |
 | STEP 2A. Inspect the cylinder head. | Leaking gaskets or loose components?
 | STEP 2B. Check the valve lash. | Valve lash correct?
 | STEP 2C. Inspect the valve train. | Worn or improperly installed valve train components?
STEP 3. | Inspect cylinder 11 power cylinder. |
 | STEP 3A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 3B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 3C. Inspect connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 3D. Inspect piston cooling nozzle. | Piston cooling nozzle bent or missing?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 3122 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3122 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3123, 3124, 3125, 3126, 3127 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Go to 2A

Go to 4A

Guided Step 2 - Inspect cylinder 11 cylinder head.

Guided Step 2A - Inspect the cylinder head.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the cylinder head.

Inspect the cylinder 11 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder 11 cylinder head.

Leaking gaskets or loose components?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose engine components on or immediately around cylinder 11 cylinder head.
 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the valve lash.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Check the valve lash.

  • Check that cylinder 11 valve lash setting is correct. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Valve lash correct?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

Go to 4A

Go to 2C

Guided Step 2C - Inspect the valve train.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the valve train.

Inspect the cylinder 11 valve train for the following:

  • Correct valve lash setting. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.
  • Inlet or exhaust valve wear or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Cam follower wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder 11 camshaft lobe wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Worn or improperly installed valve train components?
YES NO

Repair

  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the cam follower assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

  • Adjust the valve lash setting. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 4A

Go to 3A

Guided Step 3 - Inspect cylinder 11 power cylinder.

Guided Step 3A - Cut open the oil filters and inspect for debris.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Repair

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 3D

Guided Step 3B - Inspect the internal power cylinder.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the internal power cylinder for the following:

NOTE: If available, the inspection can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 11 power cylinder damaged?
YES NO

Repair

Replace the damaged components.

  • Replace the piston rings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Replace the cylinder liner. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the connecting rod bearings.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the connecting rod bearings.

  • Inspect cylinder 11 connecting rod bearings for excessive wear or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder 11 connecting rod bearings damaged?
YES NO

Repair

Replace the connecting rod bearings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the piston cooling nozzle.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the piston cooling nozzle.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder 11 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 3122 is inactive.

Fault code 3122 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the RUN mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes

Repair Complete

Appropriate troubleshooting chart

Last Modified: 02-Jul-2010


FAULT CODE 3123 - Engine Cylinder Number 12 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3123 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3124, 3125, 3126, 3127 active?
STEP 2. | Inspect cylinder 12 cylinder head. |
 | STEP 2A. Inspect the cylinder head. | Leaking gaskets or loose components?
 | STEP 2B. Check the valve lash. | Valve lash correct?
 | STEP 2C. Inspect the valve train. | Worn or improperly installed valve train components?
STEP 3. | Inspect cylinder 12 power cylinder. |
 | STEP 3A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 3B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 3C. Inspect connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 3D. Inspect piston cooling nozzle. | Piston cooling nozzle bent or missing?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 3123 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3123 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3124, 3125, 3126, 3127 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Go to 2A

Go to 4A

Guided Step 2 - Inspect cylinder 12 cylinder head.

Guided Step 2A - Inspect the cylinder head.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the cylinder head.

Inspect the cylinder 12 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder 12 cylinder head.

Leaking gaskets or loose components?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose engine components on or immediately around cylinder 12 cylinder head.
 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the valve lash.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Check the valve lash.

  • Check that cylinder 12 valve lash setting is correct. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Valve lash correct?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

Go to 4A

Go to 2C

Guided Step 2C - Inspect the valve train.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the valve train.

Inspect the cylinder 12 valve train for the following:

  • Correct valve lash setting. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.
  • Inlet or exhaust valve wear or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Cam follower wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder 12 camshaft lobe wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Worn or improperly installed valve train components?
YES NO

Repair

  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the cam follower assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

  • Adjust the valve lash setting. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 4A

Go to 3A

Guided Step 3 - Inspect cylinder 12 power cylinder.

Guided Step 3A - Cut open the oil filters and inspect for debris.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Repair

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 3D

Guided Step 3B - Inspect the internal power cylinder.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the internal power cylinder for the following:

NOTE: If available, the inspection can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 12 power cylinder damaged?
YES NO

Repair

Replace the damaged components.

  • Replace the piston rings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Replace the cylinder liner. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the connecting rod bearings.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the connecting rod bearings.

  • Inspect cylinder 12 connecting rod bearings for excessive wear or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder 12 connecting rod bearings damaged?
YES NO

Repair

Replace the connecting rod bearings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the piston cooling nozzle.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the piston cooling nozzle.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder 12 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 3123 is inactive.

Fault code 3123 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the RUN mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes

Repair Complete

Appropriate troubleshooting chart

Last Modified: 02-Jul-2010


FAULT CODE 3124 - Engine Cylinder Number 13 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3124 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 31212, 3122, 3123, 3125, 3126, 3127 active?
STEP 2. | Inspect cylinder 13 cylinder head. |
 | STEP 2A. Inspect the cylinder head. | Leaking gaskets or loose components?
 | STEP 2B. Check the valve lash. | Valve lash correct?
 | STEP 2C. Inspect the valve train. | Worn or improperly installed valve train components?
STEP 3. | Inspect cylinder 13 power cylinder. |
 | STEP 3A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 3B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 3C. Inspect connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 3D. Inspect piston cooling nozzle. | Piston cooling nozzle bent or missing?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 3124 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3124 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 31212, 3122, 3123, 3125, 3126, 3127 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Go to 2A

Go to 4A

Guided Step 2 - Inspect cylinder 13 cylinder head.

Guided Step 2A - Inspect the cylinder head.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the cylinder head.

Inspect the cylinder 13 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder 13 cylinder head.

Leaking gaskets or loose components?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose engine components on or immediately around cylinder 13 cylinder head.
 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the valve lash.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Check the valve lash.

  • Check that cylinder 13 valve lash setting is correct. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Valve lash correct?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

Go to 4A

Go to 2C

Guided Step 2C - Inspect the valve train.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the valve train.

Inspect the cylinder 13 valve train for the following:

  • Correct valve lash setting. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.
  • Inlet or exhaust valve wear or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Cam follower wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder 13 camshaft lobe wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Worn or improperly installed valve train components?
YES NO

Repair

  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the cam follower assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

  • Adjust the valve lash setting. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 4A

Go to 3A

Guided Step 3 - Inspect cylinder 13 power cylinder.

Guided Step 3A - Cut open the oil filters and inspect for debris.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Repair

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 3D

Guided Step 3B - Inspect the internal power cylinder.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the internal power cylinder for the following:

NOTE: If available, the inspection can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 13 power cylinder damaged?
YES NO

Repair

Replace the damaged components.

  • Replace the piston rings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Replace the cylinder liner. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the connecting rod bearings.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the connecting rod bearings.

  • Inspect cylinder 13 connecting rod bearings for excessive wear or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder 13 connecting rod bearings damaged?
YES NO

Repair

Replace the connecting rod bearings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the piston cooling nozzle.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the piston cooling nozzle.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder 13 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 3124 is inactive.

Fault code 3124 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the RUN mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes

Repair Complete

Appropriate troubleshooting chart

Last Modified: 02-Jul-2010


FAULT CODE 3125 - Engine Cylinder Number 14 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3125 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3126, 3127 active?
STEP 2. | Inspect cylinder 14 cylinder head. |
 | STEP 2A. Inspect the cylinder head. | Leaking gaskets or loose components?
 | STEP 2B. Check the valve lash. | Valve lash correct?
 | STEP 2C. Inspect the valve train. | Worn or improperly installed valve train components?
STEP 3. | Inspect cylinder 14 power cylinder. |
 | STEP 3A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 3B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 3C. Inspect connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 3D. Inspect piston cooling nozzle. | Piston cooling nozzle bent or missing?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Fault Code 3125 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3125 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3126, 3127 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Go to 2A

Go to 4A

Guided Step 2 - Inspect cylinder 14 cylinder head.

Guided Step 2A - Inspect the cylinder head.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the cylinder head.

Inspect the cylinder 14 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder 14 cylinder head.

Leaking gaskets or loose components?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose engine components on or immediately around cylinder 14 cylinder head.
 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the valve lash.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Check the valve lash.

  • Check that cylinder 14 valve lash setting is correct. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Valve lash correct?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

Go to 4A

Go to 2C

Guided Step 2C - Inspect the valve train.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the valve train.

Inspect the cylinder 14 valve train for the following:

  • Correct valve lash setting. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.
  • Inlet or exhaust valve wear or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Cam follower wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder 14 camshaft lobe wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Worn or improperly installed valve train components?
YES NO

Repair

  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the cam follower assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

  • Adjust the valve lash setting. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 4A

Go to 3A

Guided Step 3 - Inspect cylinder 14 power cylinder.

Guided Step 3A - Cut open the oil filters and inspect for debris.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Repair

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 3D

Guided Step 3B - Inspect the internal power cylinder.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the internal power cylinder for the following:

NOTE: If available, the inspection can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder 14 power cylinder damaged?
YES NO

Repair

Replace the damaged components.

  • Replace the piston rings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Replace the cylinder liner. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the connecting rod bearings.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the connecting rod bearings.

  • Inspect cylinder 14 connecting rod bearings for excessive wear or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder 14 connecting rod bearings damaged?
YES NO

Repair

Replace the connecting rod bearings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the piston cooling nozzle.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the piston cooling nozzle.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder 14 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 3125 is inactive.

Fault code 3125 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the RUN mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes

Repair Complete

Appropriate troubleshooting chart

Last Modified: 02-Jul-2010


FAULT CODE 3126 - Engine Cylinder Number 15 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3126 and/or 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
STEP 2. | Inspect cylinder number 15 cylinder head. |
 | STEP 2A. Inspect the cylinder head. | Leaking gaskets or loose components?
 | STEP 2B. Check the valve lash. | Valve lash correct?
 | STEP 2C. Inspect the valve train. | Worn or improperly installed valve train components?
STEP 3. | Inspect cylinder number 15 power cylinder. |
 | STEP 3A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 3B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 3C. Inspect connecting rod bearings. | Cylinder number 15 connecting rod bearings damage?
 | STEP 3D. Inspect piston cooling nozzle. | Cylinder number 15 piston cooling nozzle bent or broken?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Is Fault Code 3126 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in STOP mode.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3126 and/or 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126, 3127 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Go to 2A

Go to 4A

Guided Step 2 - Inspect cylinder number 15 cylinder head.

Guided Step 2A - Inspect the cylinder head.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in STOP mode.

Action

Inspect the cylinder head.

Inspect the cylinder number 15 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder number 15 cylinder head.

Leaking gaskets or loose components?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose engine components on or immediately around cylinder number 15 cylinder head.
 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the valve lash.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in STOP mode.

Action

Check the valve lash.

  • Check that cylinder number 15 valve lash setting is correct. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Valve lash correct?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

Go to 4A

Go to 2C

Guided Step 2C - Inspect the valve train.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in STOP mode.

Action

Inspect the valve train.

Inspect the cylinder number 15 valve train for the following:

  • Correct valve lash setting. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.
  • Intake or exhaust valve wear or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Cam follower wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder number 15 camshaft lobe wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Worn or improperly installed valve train components?
YES NO

Repair

  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the cam follower assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

  • Adjust the valve lash setting. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 4A

Go to 3A

Guided Step 3 - Inspect cylinder number 15 power cylinder.

Guided Step 3A - Cut open the oil filters and inspect for debris.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the lubricating oil filters for debris.

  • Remove the lubricating oil filter. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Repair

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 3D

Guided Step 3B - Inspect the internal power cylinder.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the internal power cylinder for the following:

NOTE: If available, the inspection can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Damage to power cylinder components?
YES NO

Repair

Replace the damaged components.

  • Replace the piston rings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Replace the cylinder liner. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the connecting rod bearings.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the connecting rod bearings.

  • Inspect cylinder number 15 connecting rod bearings for excessive wear or other damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder number 15 connecting rod bearings damaged?
YES NO

Repair

Replace the connecting rod bearings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the piston cooling nozzle.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the piston cooling nozzle.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder number 15 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 3126 is inactive.

Fault Code 3126 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the RUN mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes

Repair Complete

Appropriate troubleshooting chart

Last Modified: 02-Jul-2010


FAULT CODE 3127 - Engine Cylinder Number 16 Knock Sensor - Excessive Mechanical Vibration - Special Instructions

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3127 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126 active?
STEP 2. | Inspect cylinder number 16 cylinder head. |
 | STEP 2A. Inspect the cylinder head. | Leaking gaskets or loose components?
 | STEP 2B. Check the valve lash. | Valve lash correct?
 | STEP 2C. Inspect the valve train. | Worn or improperly installed valve train components?
STEP 3. | Inspect cylinder number 16 power cylinder. |
 | STEP 3A. Cut open the lubricating oil filters and check filter medium for debris. | Debris present in oil filter?
 | STEP 3B. Inspect the internal power cylinder. | Damage to power cylinder components?
 | STEP 3C. Inspect connecting rod bearings. | Damage to connecting rod bearings?
 | STEP 3D. Inspect piston cooling nozzle. | Piston cooling nozzle bent or missing?
STEP 4. | Clear the fault codes. |
 | STEP 4A. Verify the fault code is inactive. | Is Fault Code 3127 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3127 and/or 3111, 3112, 3113, 3114, 3115, 3116, 3117, 3118, 3119, 3121, 3122, 3123, 3124, 3125, 3126 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Go to 2A

Go to 4A

Guided Step 2 - Inspect cylinder number 16 cylinder head.

Guided Step 2A - Inspect the cylinder head.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the cylinder head.

Inspect the cylinder number 16 cylinder head for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases.
  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around cylinder number 16 cylinder head.

Leaking gaskets or loose components?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose engine components on or immediately around cylinder number 16 cylinder head.
 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the valve lash.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Check the valve lash.

  • Check that cylinder number 16 valve lash setting is correct. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Valve lash correct?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

Go to 4A

Go to 2C

Guided Step 2C - Inspect the valve train.

Conditions

  • Keyswitch circuit de-energized.
  • Run/Stop/Auto switch in Stop mode.

Action

Inspect the valve train.

Inspect the cylinder number 16 valve train for the following:

  • Correct valve lash setting. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.
  • Intake or exhaust valve wear or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Cam follower wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Cylinder number 16 camshaft lobe wear. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Worn or improperly installed valve train components?
YES NO

Repair

  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
  • Replace the cam follower assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 004-001 in Section 4.
  • Replace the rocker lever assembly. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-008 in Section 1.

Repair

  • Adjust the valve lash setting. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 4A

Go to 3A

Guided Step 3 - Inspect cylinder number 16 power cylinder.

Guided Step 3A - Cut open the oil filters and inspect for debris.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the oil filters for debris.

  • Remove the lubricating oil filter. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter and inspect for debris in the filter medium. Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Repair

Proceed to the next troubleshooting step.

 No Repair

Go to 3B

Go to 3D

Guided Step 3B - Inspect the internal power cylinder.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the internal power cylinder for the following:

Note: If available, the inspection can be performed using a borescope without component removal.

  • Piston ring scuffing or breakage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.

Cylinder number 16 power cylinder damaged?
YES NO

Repair

Replace the damaged components.

  • Replace the piston rings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Replace the cylinder liner. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Replace the cylinder head. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-004 in Section 2.
No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the connecting rod bearings.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the connecting rod bearings.

  • Inspect cylinder number 16 connecting rod bearings for excessive wear or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Cylinder number 16 connecting rod bearings damaged?
YES NO

Repair

Replace the connecting rod bearings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

No Repair

Go to 4A

Go to 3D

Guided Step 3D - Inspect the piston cooling nozzle.

Conditions

  • Keyswitch circuit de-energized.
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the piston cooling nozzle.

Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Cylinder number 16 piston cooling nozzle bent or broken?
YES NO

Repair

Replace the piston cooling nozzle. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 3127 is inactive.

Fault Code 3127 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Keyswitch circuit energized.
  • RUN/STOP/AUTO switch in the RUN mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes

Repair Complete

Appropriate troubleshooting chart

Last Modified: 02-Jul-2010


FAULT CODE 3458 - Knock Sensor Based Engine Derate - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 3458 and 1243 active?
STEP 2. | Check the exhaust emissions. |
 | STEP 2A. Measure the exhaust emissions. | Exhaust emissions to specification?
STEP 3. | Check the kilowatt load reference signal. |
 | STEP 3A. Check the kilowatt load transducer reference signal - if installed. | Kilowatt load transducer sensed kilowatt matches generator set controller kilowatts?
 | STEP 3B. Check the calibration of the generator set controller. | Generator set controller output voltage and ampere readings match the measured readings?
STEP 4. | Check the intake manifold temperature. |
 | STEP 4A. Check the intake manifold temperature. | Intake manifold temperature within specification?
 | STEP 4B. Check the intake manifold temperature sensor. | Intake manifold temperature sensor resistances to specification?
STEP 5. | Check the intake manifold pressure. |
 | STEP 5A. Check the intake manifold pressure sensor. | Intake manifold pressure within specification?
 | STEP 5B. Check the intake manifold pressure sensor. | Intake manifold pressure sensor to specification?
STEP 6. | Check the quality of the natural gas supply to the generator set. |
 | STEP 6A. Check the quality of the natural gas supply. | Natural gas supply quality within specification?
STEP 7. | Inspect all the cylinder heads. |
 | STEP 7A. Check the spark plugs. | Spark plug contaminated or damaged?
 | STEP 7B. Check the spark plug gap. | Spark plug gap excessive?
 | STEP 7C. Check the cylinder head. | Cylinder heads: leaking gaskets or loose components?
 | STEP 7D. Check the valve lash. | Valve lash settings correct?
 | STEP 7E. Check the valve train. | Valve train worn?
STEP 8. | Inspect all the power cylinders. |
 | STEP 8A. Cut open the lubricating oil filters and inspect for debris. | Debris present in oil filter?
 | STEP 8B. Check the power cylinders. | Power cylinder damaged?
 | STEP 8C. Inspect the connecting rod bearings. | Connecting rod bearings damaged?
 | STEP 8D. Inspect the piston cooling nozzles. | Piston cooling nozzle bent or damaged?
 | STEP 8E. Check the main bearings. | Main bearings worn or damaged?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 3458 inactive?
 | STEP 9B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 3458 and 1243 active?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

No Repair.

  • Refer to Procedure 019-362 in Section 19.
  • Reference 4021353-t048 (Engine Noise Excessive - Combustion Knocks) in Section TS.

Go to 2A

Go to 7A

Guided Step 2 - Check the exhaust emissions.

Guided Step 2A - Measure the exhaust emissions.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Connect an exhaust gas analyzer
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and running at the highest load possible with no knock - should be at a minimum 70 percent load.

Action

Measure the exhaust emissions.

  • Use an exhaust gas analyzer, with the sample probe inserted into the exhaust gas manifold test port to check that the exhaust emissions are to the fuel rating specification for the engine.
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395, for exhaust emission specifications. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Exhaust emissions to specification?
YES NO
No Repair

Repair

  • Use INSITE™ electronic service tool and referencing to the exhaust gas analyzer to adjust the open and closed loop fueling offsets so that the Nox and O2 emissions meet the fuel rating specification for the engine.
  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 9A

Guided Step 3 - Check the kilowatt load reference signal.

Guided Step 3A - Check the kilowatt load transducer reference signal - if installed.

Conditions

Note: If the generator set is not installed with a kilowatt load transducer, proceed to Step 3B.

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode with load available

Action

Check the kilowatt load transducer reference signal.

  • Check the kilowatt load transducer sensed kilowatts against the generator set controller displayed kilowatts.
  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer sensed kilowatt matches generator set controller kilowatts?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool to calibrate the kilowatt load sensor milliamp / load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 3B - Check the calibration of the generator set controller.

Conditions

Note: This guided step should only be followed for generator sets without a kilowatt load transducer installed.

  • Connect all components
  • Connect a power analyzer or digital multimeter
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode with load available.

Action

Check the calibration of the generator set controller.

  • Connect a power analyzer or digital multimeter to the alternator main output terminals.
  • Check that the generator set controller readings for output voltage (L1- L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller output voltage and ampere readings match the measured readings?
YES NO
No Repair

Repair

  • Use a power analyzer or digital multimeter to calibrate the generator set controller (output voltage and output amperes).
  • Contact a Cummins® Authorized Repair Location.

Go to 4A

Go to 9A

Guided Step 4 - Check the intake manifold temperature.

Guided Step 4A - Check the intake manifold temperature.

Conditions

  • Connect all components
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode, operating at maximum possible load with no knock present.

Action

Check the intake manifold temperature.

  • Use the generator set Human Machine Interface (HMI) to check the intake manifold temperature. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold temperature within specification?
YES NO
No Repair

Repair

Check the following:

  • Check the temperature of the High Temperature (HT) and Low Temperature (LT) coolant outlets from the engine. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-018 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Go to 4B

Go to 9A

Guided Step 4B - Check the intake manifold temperature sensor.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the intake manifold temperature sensor.

  • Check the intake manifold temperature sensor resistances.
  • Note: The intake manifold temperature sensor may have malfunctioned in range and the related fault codes will not be activated. Reference to Fault Code 153 (Intake Manifold Temperature Sensor Shorted High) or Fault Code 154 (Intake Manifold Temperature Sensor Shorted Low) in Section TF.
  • Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.
  • Reference 4021359 or 4022031 (Specifications) in Section V.

Intake manifold temperature sensor resistances to specification?
YES NO
No Repair

Repair

  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the intake manifold pressure.

Guided Step 5A - Check the intake manifold pressure sensor.

Conditions

  • Connect all components
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode, operating at maximum possible load with no knock present.

Action

Check the intake manifold pressure sensor.

  • Use the generator set Human Machine Interface (HMI) to check the intake manifold temperature. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 018-019 in Section V.

Intake manifold pressure within specification?
YES NO
No Repair

Repair

Check the following:

  • If installed, check the operation of the Compressor Bypass Valve (single turbochargers engines only).
  • Contact a Cummins® Authorized Repair Location.

Go to 5B

Go to 9A

Guided Step 5B - Check the intake manifold pressure sensor

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the intake manifold pressure sensor.

Note: The intake manifold pressure sensor may have malfunctioned in range and the related fault codes will not be activated. Reference Fault Code 354 (Intake Manifold Pressure Sensor Shorted High) or Fault Code 355 (Intake Manifold Pressure Sensor Shorted Low) in Section TF.

  • Use the following procedure for multimeter usage techniques. Refer to Procedure 019-359 in Section 19.
  • Reference 4021359 or 4022031 (Specifications) in Section V.

Intake manifold pressure sensor to specification?
YES NO
No Repair

Repair

Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the quality of the natural gas supply to the generator set.

Guided Step 6A - Check the quality of the natural gas supply.

Conditions

  • Connect all components
  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the quality of the natural gas supply.

  • Check the quality of the natural gas supplied to the generator set meets or exceeds minimum requirement for generator set (methane number and fuel contaminants limits). Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Natural gas supply quality within specification?
YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 7A

Go to 9A

Guided Step 7 - Inspect all cylinder heads.

Guided Step 7A - Check the spark plugs.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plugs.

Inspect all the spark plugs for the following:

  • Spark plug correctly tightened.
  • Spark plug “J” connector damaged.
  • Inspect the electrode for signs of oil contamination.
  • Spark plug porcelain damaged. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plugs contaminated or damaged?
YES NO

Repair

  • Tighten the spark plugs to the specified torque.
  • Replace the spark plugs. Refer to Procedure 013-016 in Section 13.
No Repair

Go to 9A

Go to 7B

Guided Step 7B - Check the spark plug gap.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the spark plug gap on all cylinders.

  • Remove the spark plugs and measure the spark plug electrode gap. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 013-016 in Section 13.

Spark plug gap excessive?
YES NO

Repair

Replace the spark plugs. Refer to Procedure 013-016 in Section 13.

No Repair

Go to 9A

Go to 7C

Guided Step 7C - Check all the cylinder heads.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check all the cylinder heads.

Inspect all cylinder heads for the following:

  • Cylinder head-to-block mating face for signs of cylinder head gasket leakage.
  • Cylinder head-to-exhaust manifold gasket leaking exhaust gases. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Loose engine components on or immediately around the cylinder heads.

Cylinder heads: leaking gaskets or loose components?
YES NO

Repair

Repair as necessary.

  • Replace the cylinder head gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 002-021 in Section 2.
  • Replace the exhaust manifold gasket. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 011-007 in Section 11.
  • Tighten any loose components on or immediately around the cylinder head. Reference to the appropriate procedures in the QSK60G CM700 Troubleshooting and Repair Manual 4021396.
No Repair

Go to 9A

Go to 7D

Guided Step 7D - Check the valve lash.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the valve lash.

  • Check that valve lash setting is correct on all cylinders. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Valve lash settings correct?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

Go to 8A

Go to 7E

Guided Step 7E - Check the valve train.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the valve train.

Use the following procedures in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396 to inspect the valve train on all cylinders for the following:

  • Inlet or exhaust valve wear/recession or damage. Refer to Procedure 002-004 in Section 2.
  • Rocker lever assembly excessive wear. Refer to Procedure 003-009 in Section 3.
  • Camshaft follower wear. Refer to Procedure 004-001 in Section 4.
  • Camshaft lobe wear. Refer to Procedure 001-008 in Section 1.

Valve train worn?
YES NO

Repair

Use the following procedures in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396 to repair as necessary.

  • Replace the cylinder head. Refer to Procedure 002-004 in Section 2.
  • Replace the camshaft follower. Refer to Procedure 004-001 in Section 4.
  • Replace the rocker lever assembly. Refer to Procedure 003-009 in Section 3.
  • Replace the camshaft. Refer to Procedure 001-008 in Section 1.

Repair

Adjust the valve lash. Use the following procedures in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 003-006 in Section 3.

Go to 9A

Go to 8A

Guided Step 8 - Inspect all power cylinders.

Guided Step 8A - Cut open the oil filters and inspect for debris.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Cut open the oil filters and inspect for debris.

  • Remove the lubricating oil filter. Use the following procedures in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 007-013 in Section 7.
  • Cut open the oil filter and inspect for debris in the filter medium.
  • Contact a Cummins® Authorized Repair Location.

Debris present in oil filters?
YES NO

Repair

Proceed to the next troubleshooting step.

 No Repair

Go to 8B

Go to 8D

Guided Step 8B - Check the power cylinders.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the power cylinders.

Inspect the internal power cylinders for the following (Note: If available, these inspections can be performed using a borescope without component removal):

  • Piston ring scuffing or breakage. Use the following procedures in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-047 in Section 1.
  • Cylinder liner bore damage. Use the following procedures in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-028 in Section 1.
  • Cylinder head flame face damage.

Power cylinder damaged?
YES NO

Repair

Use the following procedures in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396 to repair as necessary.

  • Replace the piston rings. Refer to Procedure 001-047 in Section 1.
  • Replace the liner. Refer to Procedure 001-045 in Section 1.
  • Replace the cylinder head. Refer to Procedure 002-004 in Section 2.
No Repair

Go to 9A

Go to 8C

Guided Step 8C - Inspect the connecting rod bearings.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the connecting rod bearings.

  • Inspect all cylinder connecting rod bearings for excessive wear or damage. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

Connecting rod bearings damaged?
YES NO

Repair

Replace the connecting rod bearings. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-005 in Section 1.

No Repair

Go to 9A

Go to 8D

Guided Step 8D - Inspect the piston cooling nozzles.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the piston cooling nozzles.

Inspect the piston cooling nozzles on all cylinder locations for the following:

  • Bent cooling nozzles
  • Broken cooling nozzles.

Piston cooling nozzles bent or broken?
YES NO

Repair

Replace the piston cooling nozzle. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

No Repair

Go to 9A

Go to 8E

Guided Step 8E - Inspect the main bearings.

Conditions

  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Inspect the main bearings.

  • Inspect main bearings on all cylinder locations. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.

Main bearings worn or damaged?
YES NO

Repair

  • Replace the main bearings as required. Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396. Refer to Procedure 001-046 in Section 1.
No Repair

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify that fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and running for greater than 1 minute.

Action

Verify that fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 2793 is inactive.

Fault Code 3458 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 9B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 02-Jul-2010


FAULT CODE 3489 - Engine Turbocharger Compressor Bypass Actuator Control Command - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP®/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple active fault codes. | Fault Codes 1795, 1796, 1797, and/or 1798 active?
STEP 2. | Check the turbocharger compressor bypass actuator. |
 | STEP 2A. Check the turbocharger compressor bypass valve for free-movement. | Commanded position signal and feedback signal within 30 percent?
 | STEP 2B. Inspect the turbocharger compressor bypass actuator connector and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2C. Check the actuator commanded signal percent duty cycle. | Percent duty cycle 10 - 91 percent?
 | STEP 2D. Check the actuator position feedback signal voltage. | 0 to 5-VDC?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit from pin-to-ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit in the engine harness. | Less than 10 ohms?
STEP 4. | Check the CM558 module. |
 | STEP 4A. Check the actuator commanded signal percent duty cycle at the CM558 module. | Percent duty cycle 10 - 91 percent?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 1799 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple active fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for multiple active/inactive fault codes.

  • Use INSITE™ electronic service tool to read the active and inactive fault codes.

Fault Codes 1795, 1796, 1797, and/or 1798 active?
YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

 No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check the turbocharger compressor bypass actuator.

Guided Step 2A - Check the turbocharger compressor bypass valve for free-movement.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check the turbocharger compressor bypass valve for free movement.

  • Use the Actuator Diagnostic Tests feature located within the ECM Diagnostic Test options within INSITE™ electronic service tool to test the valve for free movement throughout its full range (0 - 100 percent).
  • Compare the Commanded Position Signal and Feedback Position Signal values.
  • Contact a Cummins® Authorized Repair Location.

Commanded position signal and feedback signal within 30 percent?
YES NO
No Repair

Repair

A problem has been detected with the turbocharger compressor bypass valve or its control and feedback circuit.

Proceed to the next troubleshooting step.

Go to 5A

Go to 2B

Guided Step 2B - Inspect the sensor and the engine harness connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness from the turbocharger compressor bypass actuator.

Action

Inspect the turbocharger compressor bypass actuator connector, the engine harness connector and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the turbocharger compressor actuator connector or harness connector.

Repair or replace the engine harness or the turbocharger compressor bypass actuator, whichever has the damaged connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
  • Replace the turbocharger compressor bypass valve. Contact a Cummins® Authorized Repair Location.
 No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check the actuator commanded signal percent duty cycle.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle.

  • Use the actuator test function within INSITE™ electronic service tool to drive the turbocharger compressor bypass valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the turbocharger compressor bypass actuator commanded position SIGNAL (+) and RETURN (-) pins at the actuator connector. The signal percent duty cycle must be between 10 and 91 percent, based on the actuator position.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the specification table provided in the Shop Talk section of this document for percent duty cycle specifications.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

Percent duty cycle 10 - 91 percent?
YES NO
No Repair

Repair

Proceed to the next troubleshooting step

Go to 5A

Go to 3A

Guided Step 2D - Check the actuator position feedback signal voltage.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check the turbocharger compressor bypass actuator feedback signal voltage.

  • Use the actuator test function within INSITE™ electronic service tool to drive the turbocharger compressor bypass valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the signal feedback voltage by connecting the multimeter test probes between the turbocharger compressor bypass actuator position feedback and RETURN (-) pins. The feedback signal must be between 0 to 5-VDC.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

Section 19.0 to 5-VDC?
YES NO
No Repair

Repair

A problem has been detected in the turbocharger compressor bypass control valve.

  • Replace the turbocharger compressor bypass valve. Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness from the CM558 module.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit. Use the wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.
No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin in the engine harness.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness from the CM558 module
  • Disconnect the engine harness from the turbocharger compressor bypass actuator.

Action

Use a multimeter to check for a short circuit pin-to-pin in the engine harness:

  • Measure the resistance from the turbocharger compressor bypass actuator SIGNAL (+) pin at the CM558 connector to all other pins in the CM558 connector.
  • Measure the resistance from the turbocharger compressor bypass actuator RETURN (-) pin at the CM558 connector to all other pins in the CM558 connector.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit from pin-to-ground in the engine harness.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness from the CM558 module
  • Disconnect the engine harness from the turbocharger compressor bypass actuator.

Action

Use a multimeter to check for a short circuit to engine block ground in the engine harness:

  • Measure the resistance from the turbocharger compressor bypass actuator SIGNAL (+) pin at the CM558 connector to engine block ground.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An short circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness from the CM558 module
  • Disconnect the engine harness from the turbocharger compressor intake air temperature sensor.

Action

Use a multimeter to check for an open circuit in the engine harness:

  • Measure the resistance from the turbocharger compressor bypass actuator SIGNAL (+) pin at the CM558 connector to the turbocharger compressor intake air temperature sensor SIGNAL (+) pin at the turbocharger compressor intake air temperature sensor connector.
  • Measure the resistance from the turbocharger compressor bypass actuator RETURN (-) pin at the CM558 connector to the turbocharger compressor intake air temperature sensor RETURN (-) pin at the turbocharger compressor intake air temperature sensor connector.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Check the CM558 module.

Guided Step 4A - Check the actuator commanded signal percent duty cycle at the CM558 module.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded position signal percent duty cycle at the CM558 connector.

  • Use the actuator test function within INSITE™ electronic service tool to drive the turbocharger compressor bypass valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the turbocharger compressor bypass actuator position SIGNAL (+) and RETURN (-) pins at the CM558 connector. The signal percent duty cycle must be between 10 and 91 percent, based on the actuator position.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the specification table provided in the Shop Talk section of this document for percent duty cycle specifications.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

Percent duty cycle 10 - 91 percent?
YES NO
No Repair

Repair

A problem has been detected within the CM558 module.

  • Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and operate engine for longer than 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 1799 is inactive.

Fault Code 1799 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 18-Mar-2011


FAULT CODE 3491 - Engine Oil Filter Restriction High - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing an ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 3491 - Engine Oil Filter Restriction High. | Active or inactive counts of Fault Code 3491?
 | STEP 1B. Check for multiple fault codes. | Active or inactive counts of Fault Codes 143, 415, 556, 1362, 1367, 1368, 1377, and 1378?
STEP 2. | Check the lubricating oil filters. |
 | STEP 2A. Replace the lubricating oil filters. | Oil filters contaminated?
STEP 3. | Check the lubricating oil pressure sensors. |
 | STEP 3A. Check the pre and post-filter oil pressure sensors. | Pressure sensor found malfunctioning?
STEP 4. | Check the lubricating oil filter head. |
 | STEP 4A. Check the lubricating oil filter head. | Lubricating oil filter head malfunctioning?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 3491 inactive?
 | STEP 4B. Clear any inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active or inactive fault codes.

Guided Step 1A - Check for Fault Code 3491 - Engine Oil Filter Restriction High.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the active and inactive fault codes.

Active or inactive counts of Fault Code 3491?
YES NO

Repair

Proceed to next troubleshooting step.

 No Repair

Go to 1B

Go to 5A

Guided Step 1B - Check for multiple fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the active and inactive fault codes.

Active or inactive counts of Fault Codes 143, 415, 556, 1362, 1367, 1368, 1377, and 1378?
YES NO

Repair

Troubleshoot any the above fault codes.

  • See the relevant fault code troubleshooting procedure in Section TF.
 No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check the lubricating oil filters.

Guided Step 2A - Inspect the sensor and the engine harness connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Remove, inspect, and replace the lubricating oil filters.

  • Loose connector
  • Remove and replace the lubricating oil filters. Use the following procedure in the Operation and Maintenance Manual Generator Set QSK60G CM700, Bulletin 4021395. Refer to Procedure 007-002 in Section 7.

Cut open the lubricating oil filters and inspect for debris or oil contamination.

Check the lubricating oil condition as per Cummins® Engine Oil and Oil Analysis Recommendations, Bulletin 3810340, or Contact a Cummins® Authorized Repair Location.

Oil filters contaminated?
YES NO

Repair

Replace the engine lubricating oil if the oil shows signs of contamination or the oil analysis results recommend that the lubricating oil should be replaced.

  • Replace the engine lubricating oil. Use the following procedure in the Operation and Maintenance Manual Generator Set QSK60G CM700, Bulletin 4021395. Refer to Procedure 007-002 in Section 7.
No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the lubricating oil pressure sensors.

Guided Step 3A - Check the pre and post-filter oil pressure sensors.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Check the operation and range of the pre and post-filter lubricating oil pressure sensors.

  • Refer to Procedure 019-126 in Section 19.
  • Refer to Procedure 019-447 in Section 19.

Pressure sensor found malfunctioning?
YES NO

Repair

Replace the appropriate pressure sensor.

Replace the malfunctioning pressure sensor .

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Refer to Procedure 019-126 in Section 19.
  • Refer to Procedure 019-447 in Section 19.
No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the lubricating oil filter head.

Guided Step 4A - Check the lubricating oil filter head.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the lubricating oil filter head assembly.

  • Use the following procedure for information on the lubricating filter head in the Troubleshooting and Repair Manual QSK60G Generator CM700, Bulletin 4021396. Refer to Procedure 007-015 in Section 07.

Lubricating oil filter head malfunctioning?
YES NO

Repair

Repair or replace the lubricating oil filter head.

  • Use the following procedure for information on the lubricating filter head in the Troubleshooting and Repair Manual QSK60G Generator CM700, Bulletin 4021396. Refer to Procedure 007-015 in Section 07.
No Repair

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and operate engine for longer than 1 minute.

Action

Clear the fault codes.

  • Use INSITE™ electronic service tool to verify that Fault Code 3491 is inactive.

Fault Code 3491inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 21-Mar-2011


FAULT CODE 3515 - Engine Throttle Control Actuator CAN Commanded Shutdown - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK45G and QSK60G | 4021353

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing an ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault code 426, 427, or 781 active or more than one inactive count within the last 25 engine hours?
STEP 2. | Check the throttle control actuator. |
 | STEP 2A. Inspect the throttle control actuator connector and engine wiring harness connector pins. | Dirty or damaged pins?
STEP 3. | Check the engine wiring harness. |
 | STEP 3A. Inspect the engine wiring harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit from pin-to-pin in the engine wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit from pin-to-ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an open circuit in the engine wiring harness. | Less than 10 ohms?
STEP 4. | Check the DC1 generator set wiring harness. |
 | STEP 4A. Inspect the harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for a short circuit from pin-to-pin in the DC1 generator set wiring harness. | Greater than 100k ohms?
 | STEP 4C. Check for a short circuit from pin-to-ground in the DC1 generator set wiring harness. | Greater than 100k ohms?
 | STEP 4D. Check for open circuit in the generator set wiring harness. | Less than 10 ohms?
STEP 5. | Check the DC2 generator set wiring harness. |
 | STEP 5A. Inspect the harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for a short circuit from pin-to-pin in the DC2 generator set wiring harness. | Greater than 100k ohms?
 | STEP 5C. Check for a short circuit from pin-to-ground in the DC2 generator set wiring harness. | Greater than 100k ohms?
 | STEP 5D. Check for open circuit in the generator set wiring harness. | Less than 10 ohms?
 | STEP . |
STEP 6. | Check the run enable relay. |
 | STEP 6A. Verify the relay fitted is correct. | 4 Pole 24V 10A DC relay?
 | STEP 6B. Inspect the wiring to the run enable relay base and pins and contactors. | Dirty or damaged pins/fixings/contactors?
 | STEP 6C. Verify correct coil resistance. | Coil resistance 298 to 402 ohms?
 | STEP 6D. Verify the relay is energized. | Relay energized light illuminated?
 | STEP 6E. Check contactor movement inside the relay casing. | Free contactor movement?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple active/inactive fault codes.

  • Use INSITE™ electronic service tool to read the active and inactive fault codes.

Fault code 426, 427, or 781 active or more than one inactive count within the last 25 engine hours?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the throttle control actuator.

Guided Step 2A - Inspect the sensor and the engine harness connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the throttle control actuator.

Action

Inspect the throttle control actuator connector, the engine harness connector and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the throttle control actuator connector or harness connector.

Repair or replace the engine harness or the throttle control actuator, whichever has the damaged connector pins.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-219 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the throttle control actuator. Contact a Cummins® Authorized Repair Location.
 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the engine harness or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit from pin-to-pin in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the throttle control actuator.

Action

Use a multimeter to check for a short circuit pin-to-pin in the engine harness:

  • Measure the resistance from the throttle control actuator SIGNAL (+) pin at the ECM connector to all other pins in the ECM connector.
  • Measure the resistance from the throttle control actuator RETURN (-) pin at the ECM connector to all other pins in the ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin-to-ground in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the throttle control actuator.

Action

Use a multimeter to check for a short circuit to engine block ground in the engine harness:

  • Measure the resistance from the throttle control actuator SIGNAL (+) pin at the ECM connector to engine block ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

An short circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an open circuit in the engine harness.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the throttle control actuator.

Action

Use a multimeter to check for an open circuit in the engine harness:

  • Measure the resistance from the throttle control actuator SIGNAL (+) pin at the ECM connector to the throttle control actuator SIGNAL (+) pin at the throttle control actuator connector.
  • Measure the resistance from the throttle control actuator RETURN (-) pin at the ECM connector to the throttle control actuator RETURN (-) pin at the throttle control connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check DC1 generator set wiring harness.

Guided Step 4A - Inspect the DC1 generator set wiring harness and ECM connector pins.

Conditions

  • Verify the AC and DC isolators are switched to the OFF position.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect DC1 generator set wiring harness from PCC3300 Generator Control Panel.
  • Disconnect DC1 connector at the engine wiring harness connection.

Action

Inspect the DC1 generator set wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Refer to circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins in the DC1 to engine wiring harness connector or DC1 to PCC3300 Genset Control connector.

Repair or replace the DC1 generator set wiring harness or harness connectors.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the DC1 generator set wiring harness. Refer to original equipment manufacturer (OEM) service information.
  • Replace the DC1 generator set wiring harness. Refer to OEM service information.
 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for a short circuit from pin-to-pin in the DC1 generator set wiring harness.

Conditions

  • Verify the AC and DC isolators are switched to the OFF position.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect DC1 generator set wiring harness from PCC3300 Generator Control Panel.
  • Disconnect DC1 connector at the engine wiring harness connection.

Action

Use a multimeter to check for a short circuit pin-to-pin in the DC1 generator set wiring harness:

  • Measure the resistance from the throttle control actuator CANBUS SIGNAL (+) pin at the DC1 connector to all other pins in the DC1 connector.
  • Measure the resistance from the throttle control actuator CANBUS RETURN (-) pin at the DC1 connector to all other pins in the DC1 connector.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short has been detected in the DC1 generator set wiring harness.

Repair or replace the DC1 generator set wiring harness. Refer to OEM service information.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit from pin-to-ground in the DC1 generator set wiring harness.

Conditions

  • Verify the AC and DC isolators are switched to the OFF position.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect DC1 generator set wiring harness from PCC3300 Generator Control Panel.
  • Disconnect DC1 connector at the engine wiring harness connection.

Action

Use a multimeter to check for a short circuit to engine block ground in the DC1 generator set wiring harness:

  • Measure the resistance from the throttle control actuator SIGNAL (+) pin at the DC1 connector to generator set ground.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short has been detected in the DC1 generator set wiring harness.

Repair or replace the DC1 generator set wiring harness. Refer to OEM service information.

Go to 4D

Go to 5A

Guided Step 4D - Check for open circuit in the generator set wiring harness.

Conditions

  • Verify the AC and DC isolators are switched to the OFF position.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect DC1 generator set wiring harness from PCC3300 Generator Control Panel.
  • Disconnect DC1 connector at the engine wiring harness connection.

Action

Use a multimeter to check for an open circuit in the generator set wiring harness:

  • Measure the resistance from the throttle control actuator CANBUS SIGNAL (+) pin at the DC1 connector (at engine wiring harness connector end) to the throttle control actuator CANBUS SIGNAL (+) pin DC1 generator set wiring harness connector (at generator set panel connection end).
  • Measure the resistance from the throttle control actuator CANBUS RETURN (-) pin at the DC1 connector (at engine wiring harness connector end) to the throttle control actuator CANBUS SIGNAL (-) pin DC1 generator set wiring harness connector (at generator set panel connection end).

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the engine harness.

Repair or replace the DC1 generator set wiring harness. Refer to OEM service information.

Go to 5A

Go to 5A
Go to
Go to

Guided Step 5 - Check DC2 generator set wiring harness.

Guided Step 5A - Inspect the DC2 generator set wiring harness and ECM connector pins.

Conditions

  • Verify the AC and DC isolators are switched to the OFF position.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect DC2 generator set wiring harness from PCC3300 Generator Control Panel.
  • Disconnect DC2 connector at the engine wiring harness connection.

Action

Inspect the DC2 generator set wiring harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Refer to circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins.

Repair or replace the DC2 generator set wiring harness or harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the DC2 generator set wiring harness. Refer to OEM service information.
  • Replace the DC2 generator set wiring harness. Refer to OEM service information.
 No Repair

Go to 6A

Go to 5A

Guided Step 5B - Check for a short circuit from pin-to-pin in the DC2 generator set wiring harness.

Conditions

  • Verify the AC and DC isolators are switched to the OFF position.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect DC2 generator set wiring harness from PCC3300 Generator Control Panel.
  • Disconnect DC2 connector at the engine wiring harness connection.

Action

Use a multimeter to check for a short circuit pin-to-pin in the DC2 generator set wiring harness:

  • Measure the resistance from the throttle control actuator 24 VDC (+) pin at the DC2 connector to all other pins in the DC2 connector.
  • Measure the resistance from the throttle control actuator 24 VDC (-) pin at the DC2 connector to all other pins in the DC2 connector.
  • Measure the resistance from the throttle control actuator run enable Signal pin at the DC2 connector to all other pins in the DC2 connector.
  • Measure the resistance from the throttle control actuator run enable Return pin at the DC2 connector to all other pins in the DC2 connector.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short has been detected in the DC2 generator set wiring harness

Repair or replace the DC2 generator set wiring harness. Refer to OEM service information.

Go to 5C

Go to 6A
Go to
Go to

Guided Step 5C - Check for a short circuit from pin-to-ground in the DC2 generator set wiring harness.

Conditions

  • Verify the AC and DC isolators are switched to the OFF position.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect DC2 generator set wiring harness from PCC3300 Generator Control Panel.
  • Disconnect DC2 connector at the engine wiring harness connection.

Action

Use a multimeter to check for a short circuit to engine block ground in the DC2 generator set wiring harness:

  • Measure the resistance from the throttle control actuator 24 VDC (+) pin at the DC2 connector to generator set ground.
  • Measure the resistance from the throttle control actuator 24 VDC (-) pin at the DC2 connector to generator set ground.
  • Measure the resistance from the throttle control actuator run enable Signal pin at the DC2 connector to generator set ground.
  • Measure the resistance from the throttle control actuator run enable Return pin at the DC2 connector to generator set ground.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the DC2 generator set wiring harness.

Repair or replace the DC2 generator set wiring harness. Refer to OEM service manual.

Go to 5D

Go to 6A

Guided Step 5D - Check for open circuit in the generator set wiring harness.

Conditions

  • Verify the AC and DC isolators are switched to the OFF position.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Disconnect DC2 generator set wiring harness from PCC3300 Generator Control Panel.
  • Disconnect DC2 connector at the engine wiring harness connection.

Action

Use a multimeter to check for an open circuit in the DC2 generator set wiring harness:

  • Measure the resistance from the throttle control actuator 24 VDC (+) pin at the DC2 connector to the engine wiring harness 24 VDC (+) pin at the DC2 generator set wiring harness connector at the PCC3300 generator set controller.
  • Measure the resistance from the throttle control actuator throttle control actuator 24 VDC (-) pin at the DC2 connector to the engine wiring harness 24 VDC (-) pin at the DC2 generator set wiring harness connector at the PCC3300 genset controller.
  • Measure the resistance from the throttle control actuator run enable Signal pin at the DC2 connector to the engine wiring harness run enable Signal pin at the DC2 generator set wiring harness connector at the PCC3300 genset controller.
  • Measure the resistance from the throttle control actuator run enable Return pin at the DC2 connector to the engine wiring harness run enable Return pin at the DC2 generator set wiring harness connector at the PCC3300 genset controller.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the DC2 generator set wiring harness.

Repair or replace the DC2 generator set wiring harness. Refer to OEM service information.

Go to 6A

Go to 6A

Guided Step 6 - Check the run enable relay.

Guided Step 6A - Verify the relay fitted is the correct rating for the run enable relay application.

Conditions

  • Verify the AC and DC isolators are switched to the OFF position.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP.

Action

Visually inspect the casing of the run enable relay location in the PCC3300 Generator Control Panel.

Verify the fitted relay is of the correct specification.

4 Pole 24V 10A DC relay?
YES NO
No Repair

Repair

Replace with the run enable relay (0307-3168).

Go to 6B

Go to 7A

Guided Step 6B - Inspect the wiring to the run enable relay base, pins and contactors.

Conditions

  • Verify the AC and DC isolators are switched to the OFF position.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP.
  • Disconnect run enable relay from the Generator Control Panel.

Action

Inspect the run enable relay pins and DC2 connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector or relay pins
  • Connector or relay shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Refer to circuit diagram or wiring diagram for connector pin identification.

Run enable relay and connector pin diagrams can be found in the following procedure. See the accompanying fault code overview, 59-fc3515.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the run enable relay.

Repair or replace the wiring to the relay base.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Replace the wiring to the run enable. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the throttle control actuator. Contact a Cummins® Authorized Repair Location.

 No Repair

Go to 7A

Go to 6C
Go to
Go to

Guided Step 6C - Verify correct coil resistance.

Conditions

  • Verify the AC and DC isolators are switched to the OFF position.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP.
  • Disconnect run enable relay from the Generator Control Panel.

Action

Remove the run enable relay from the PCC3300 Generator Control Panel to test. Using a multimeter, check the resistance across pins 13 (negative) and 14 (positive).

Coil resistance 298 to 402 ohms?
YES NO
No Repair

Repair

Replace the run enable relay (0307-3168).

Go to 6D

Go to 7A

Guided Step 6D - Verify the relay is energized.

Conditions

  • Verify the AC and DC isolators are switched to the OFF position.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP.
  • Disconnect run enable relay from the Generator Control Panel.

Action

Remove the run enable relay from the PCC3300 Generator Control Panel and test it by applying 24V across pins 13 (negative) and 14 (positive). If the green light illuminates on the relay itself, the relay is energized and should function correctly.

Relay energized light illuminated?

YES NO
No Repair

Repair

Replace the run enable relay (0307-3168).

Go to 6E

Go to 7A

Guided Step 6E - Check contactor movement inside the relay casing.

Conditions

  • Verify the AC and DC isolators are switched to the OFF position.
  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP.
  • Disconnect run enable relay from the Generator Control Panel.

Action

Remove the run enable relay from the PCC3300 Generator Control Panel to test. Apply 24V across pins 13 (negative) and 14 (positive). Check throttle actuator contactor movement across pins 12 and 8 inside the relay casing.

Free contactor movement?
YES NO
No Repair

Repair

Replace the run enable relay (0307-3168).

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool the recommended Cummins® electronic service tool or equivalent to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete

Escalate or call for assistance
Go to
Go to

Last Modified: 09-Feb-2021


FAULT CODE 3584 - Engine Derate - Special Instructions

Associated Procedures

Cautions and Warnings

WARNING

To reduce the possibility of personal injury or equipment damage, this procedure must only be performed by suitably qualified service technicians.
CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3584 active?
STEP 2. | Check the PowerCommand® Generator Control Panel. |
 | STEP 2A. Check if the Generator Set PowerCommand® generator control panel has requested the generator set circuit breaker to open. | The Generator Set PowerCommand® generator control has an Active Generator Set circuit breaker inhibit?
 | STEP 2B. Check if the Generator Set PowerCommand® generator control panel has requested the utility paralleling circuit breaker to open. | The Generator Set PowerCommand® generator control has an active utility paralleling circuit breaker inhibit?
STEP 3. | Check the generator set circuit breaker |
 | STEP 3A. Check the status generator set circuit breaker. | Generator set circuit breaker tripped?
 | STEP 3B. Check the status of the generator set circuit breaker protection devices. | Generator set circuit breaker utility protection devices tripped?
STEP 4. | Check the utility paralleling circuit breaker |
 | STEP 4A. Check the status utility paralleling circuit breaker. | Utility paralleling circuit breaker tripped?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Verify the fault code is inactive. | Fault Code 3584 inactive?
 | STEP 5B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • Run/Stop/Auto switch in Stop mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3584 active?
YES NO

Repair

Follow the troubleshooting steps below or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise - Combustion Knocks symptom tree in this manual.

Go to 2A

Go to 5A

Guided Step 2 - Check the PowerCommand® Generator Control Panel

Guided Step 2A - Check if the Generator Set PowerCommand® generator control panel has requested the generator set circuit breaker to open.

Conditions

  • Connect all components
  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check if the Generator Set PowerCommand® generator control panel has requested the generator set circuit breaker to open.

For PowerCommand® Supervisor 3100 Generator Control check for:

  • Circuit breaker Inhibit command being activated via an external control. Check LED DS9 (1) on the Customer Interface Board, A34 (2) if the LED is illuminated, the circuit breaker inhibit command has been requested. Alternatively, check for the Generator Set Breaker Close INHIBIT notification on the Human machine Interface (HMI) located in the Generator Control Panel (GCP).
  • Contact a Cummins® Authorized Repair Location.

For PowerCommand® Control 3300 Generator Control check for:

  • Via the control panel Human Machine Interface (HMI), check the status of the generator CB Inh/#28 (Advance Controller Status Screen 5 of 6) the status will state ACTIVE if a generator set circuit breaker Inhibit has been requested.
  • Contact a Cummins® Authorized Repair Location.

The Generator Set PowerCommand® generator control has an active generator set circuit breaker inhibit?
YES NO

Repair

Investigate the cause of the generator set circuit breaker being commanded to open.

  • Contact site operators and check reason for generator set circuit breaker inhibit being activated.
  • Contact a Cummins® Authorized Repair Location.
 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check if the Generator Set PowerCommand® generator control panel has requested the utility paralleling circuit breaker to open.

Conditions

  • Connect all components
  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check if the Generator Set PowerCommand® generator control panel has requested the utility paralleling circuit breaker to open.

NOTE: This step only applies to generator sets fitted with PowerCommand® Control 3300 Generator Control.

  • Via the control panel Human Machine Interface (HMI), check the status of the Util CB Inh/#25 (Advance Controller Status Screen 5 of 6) the status will state ACTIVE if a utility paralleling circuit breaker inhibit has been requested.
  • Contact a Cummins® Authorized Repair Location.

The Generator Set PowerCommand® generator control has an active utility paralleling circuit breaker inhibit?
YES NO

Repair

Investigate the cause of the generator set circuit breaker being commanded to open.

  • Contact site operators and check reason for generator set circuit breaker inhibit being activated.
  • Contact a Cummins® Authorized Repair Location.
 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the generator set circuit breaker.

Guided Step 3A - Check the status generator set circuit breaker.

Conditions

  • Connect all components
  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the status generator set circuit breaker.

  • Generator set circuit breaker tripped.
  • Contact a Cummins® Authorized Repair Location.

Generator set circuit breaker tripped?
YES NO

Repair

Investigate and rectify the cause of the generator set circuit breaker tripping.

  • Attempt to reset the generator set circuit breaker
  • Check for instantaneous short circuit
  • Check for long-time short circuit
  • Contact a Cummins® Authorized Repair Location.
 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the status of the generator set circuit breaker protection devices.

Conditions

  • Connect all components
  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the status of the generator set circuit breaker utility protection devices.

Check the following:

  • Generator set circuit breaker utility protection relay tripped
  • Vector shift or ROCOF relay tripped
  • Contact a Cummins® Authorized Repair Location.

Generator set circuit breaker utility protection devices tripped?
YES NO

Repair

Investigate the cause of the Generator Set utility protection devices tripping.

  • Contact a Cummins® Authorized Repair Location.
 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the utility paralleling circuit breaker.

Guided Step 4A - Check the status utility paralleling circuit breaker.

Conditions

  • Connect all components
  • Keyswitch circuit de-energized
  • RUN/STOP/AUTO switch in the STOP mode.

Action

Check the status utility paralleling circuit breaker.

  • Utility paralleling circuit breaker tripped.
  • Contact a Cummins® Authorized Repair Location.

Utility paralleling circuit breaker tripped?
YES NO

Repair

Investigate and rectify the cause of the utility paralleling circuit breaker tripping.

  • Attempt to RESET the Utility Paralleling circuit breaker
  • Check for instantaneous short circuit
  • Check for long-time short circuit
  • Contact a Cummins® Authorized Repair Location.
 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode and engine running for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify that Fault Code 3126 is inactive.

Fault Code 3584 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 5B

Go to 1A

Guided Step 5B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Keyswitch circuit energized
  • RUN/STOP/AUTO switch in the RUN mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes

Repair Complete

Appropriate troubleshooting chart

Last Modified: 20-Aug-2010


FAULT CODE 3594 - Engine Emissions Closed Loop Fueling (Limit) - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple active fault codes. | Fault Codes 144, 145, 146, 151, 154, 155, 213, 227, 238, 239, 352, 354, 355, 386, 453, 454, 455, 482, 488, 511, 546, 547, 751, 1761, 2191, 2427, 2428, 2453, 2454, 2568, 2569, 2789, 2793, 2799, 2866, and/or 2867 active?
STEP 2. | Check the coolant temperature sensor (high temperature coolant circuit). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the sensor. | 625 ohms to 36k ohms?
 | STEP 2C. Check for a short circuit. | Greater than 100k ohms?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check the intake manifold temperature and pressure sensors. |
 | STEP 3A. Inspect the intake manifold temperature sensor, pressure sensor, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the resistance intake manifold temperature sensor. | 625 ohms to 36k ohms?
 | STEP 3C. Check the intake manifold pressure sensor supply voltage. | 4.75 to 5.25-VDC?
 | STEP 3D. Check the intake manifold pressure sensor signal voltage. | 0.5 to 4.5-VDC?
 | STEP 3E. Check for a short circuit. | Greater than 100k ohms?
 | STEP 3F. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the fuel inlet and fuel outlet pressure sensors. |
 | STEP 4A. Inspect the fuel inlet and fuel outlet pressure sensors and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the fuel inlet and fuel outlet pressure sensors supply voltage. | 4.75 to 5.25-VDC?
 | STEP 4C. Check the fuel inlet pressure sensor signal voltage. | 1.7 to 4.5-VDC?
 | STEP 4D. Check the fuel outlet pressure sensor signal voltage. | 0.5 to 4.5-VDC?
 | STEP 4E. Check for a short circuit. | Greater than 100k ohms?
 | STEP 4F. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check the gas mass flow sensor. |
 | STEP 5A. Inspect the gas mass flow sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check the gas mass flow sensor supply voltage. | 8 to 15-VDC?
 | STEP 5C. Check the gas mass flow sensor signal voltage. | 0.46 to 4.50-VDC?
 | STEP 5D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 5E. Check for an open circuit. | Less than 10 ohms?
STEP 6. | Check the fuel control valve. |
 | STEP 6A. Check the fuel control valve for free movement. | Commanded position signal and feedback signal within 30 percent?
 | STEP 6B. Inspect the fuel control valve and engine harness connector pins. | Dirty or damaged pins?
 | STEP 6C. Check the actuator commanded signal percent duty cycle signal. | Percent duty cycle 10 - 91 percent?
 | STEP 6D. Check the fuel control valve feedback signal voltage. | 0 to 5-VDC?
 | STEP 6E. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 6F. Check for an open circuit. | Less than 10 ohms?
STEP 7. | Check the kilowatt load reference signal, if installed. |
 | STEP 7A. Check the kilowatt load transducer referance signal. | Kilowatt load transducer-sensed kilowatt matches generator set controller kilowatts?
 | STEP 7B. Check the calibration of the generator set controller. | Generator set controller voltage and ampere output calibration correct?
STEP 8. | Check the quality of the natural gas supply to the generator set. |
 | STEP 8A. Check the quality of the natural gas supply. | Natural gas supply quality within specification?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 3594 inactive?
 | STEP 9B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for multiple active fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check for multiple active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 144, 145, 146, 151, 154, 155, 213, 227, 238, 239, 352, 354, 355, 386, 453, 454, 455, 482, 488, 511, 546, 547, 751, 1761, 2191, 2427, 2428, 2453, 2454, 2568, 2569, 2789, 2793, 2799, 2866, and/or 2867 active?

YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

No Repair.

  • Refer to Procedure 019-362 in Section 19.
  • Reference 4021353-t048 (Engine Noise Excessive - Combustion Knocks) in Section TS.

Go to 9A

Go to 2A

Guided Step 2 - Check the coolant temperature sensor (high temperature circuit).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • De-energize 24-VDC power supply
  • Disconnect the engine harness from the engine coolant temperature sensor (high temperature)
  • Disconnect the CM700 connector A.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

Replace the damaged pins. Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine coolant temperature sensor (high temperature). Refer to Procedure 019-019 in Section 19.

Go to 2B

Go to 9A

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness from the coolant temperature sensor (high temperature).

Action

Check the resistance of the engine coolant temperature sensor (high temperature).

  • Measure the resistance between the engine coolant temperature sensor (high temperature) SIGNAL pin and the engine coolant temperature sensor (high temperature) RETURN pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

625 ohms to 36k ohms?
YES NO
No Repair

Repair

  • Replace the engine coolant temperature sensor (high temperature). Refer to Procedure 019-019 in Section 19.

Go to 2C

Go to 9A

Guided Step 2C - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • De-energize 24-VDC power supply
  • Disconnect the engine harness from the engine coolant temperature sensor (high temperature)
  • Disconnect the harness from the CM700 connector A.

Action

Check for a short circuit to engine ground.

Measure the resistance from each of the pins of the engine coolant temperature sensor (high temperature) connector to the engine block ground.

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the engine coolant temperature sensor (high temperature) RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant temperature sensor (high temperature) SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 9A

Guided Step 2D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • De-energize 24-VDC power supply
  • Disconnect the engine harness from the engine coolant temperature sensor (high temperature)
  • Disconnect the harness from the CM700 connector A.

Action

Check for an open circuit.

  • Measure the resistance from the engine coolant temperature sensor (high temperature) SIGNAL pin in the engine coolant temperature sensor (high temperature) connector to the engine coolant temperature sensor (high temperature) SIGNAL pin in the CM700 connector A.
  • Measure the resistance from the engine coolant temperature sensor (high temperature) RETURN pin in the engine coolant temperature sensor (high temperature) connector to the engine coolant temperature sensor (high temperature) RETURN pin in the CM700 connector A.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 9A

Guided Step 3 - Check the intake manifold temperature and pressure sensors.

Guided Step 3A - Inspect the intake manifold temperature sensor, pressure sensor, and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • De-energize 24-VDC power supply
  • Disconnect the intake manifold temperature sensor connector
  • Disconnect the intake manifold pressure sensor
  • Disconnect the left bank CM558 connector A.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins. Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.
No Repair

Go to 9A

Go to 3B

Guided Step 3B - Check the resistance of the intake manifold temperature sensor.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check the resistance of the engine coolant temperature sensor (high temperature).

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin and the intake manifold temperature sensor RETURN pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

625 ohms to 36k ohms?
YES NO
No Repair

Repair

  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 3C

Go to 9A

Guided Step 3C - Check the intake manifold temperature sensor supply voltage.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the intake manifold pressure sensor supply voltage.

  • Measure the supply voltage by connecting a multimeter to the breakout cable's SUPPLY and RETURN test connectors.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Proceed to troubleshooting step 3E.

Go to 3D

Go to 3E

Guided Step 3D - Check the intake manifold temperature sensor signal voltage.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the intake manifold pressure sensor signal voltage.

  • Measure the SIGNAL voltage by connecting a multimeter to the breakout cable's SIGNAL and RETURN test connectors.

0.46 to 4.50-VDC?
YES NO
No Repair

Repair

  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 3E

Go to 9A

Guided Step 3E - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • De-energize 24-VDC power supply
  • Disconnect the engine harness from the intake manifold pressure sensor
  • Disconnect the engine harness from the intake manifold temperature sensor
  • Disconnect the engine harness from the left bank CM558 connector A.

Action

Check for a short circuit to engine ground.

Measure the resistance from the SUPPLY pin of the intake manifold temperature sensor connector to the engine block ground.

  • Measure the resistance from the SIGNAL pin of the intake manifold temperature sensor connector to the engine block ground.

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the intake temperature sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant temperature sensor (high temperature) SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 9A

Guided Step 3F - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • De-energize 24-VDC power supply
  • Disconnect the engine harness from the intake manifold pressure sensor
  • Disconnect the engine harness from the intake manifold temperature sensor
  • Disconnect the engine harness from the left bank CM558 connector A.

Action

Check the intake manifold temperature and pressure sensor circuits for an open circuit

  • Measure the resistance from the intake manifold temperature sensor SIGNAL pin in the intake manifold temperature sensor connector to the intake manifold temperature sensor SIGNAL pin in the left bank CM558 connector A.
  • Measure the resistance from the intake manifold temperature sensor RETURN pin in the intake manifold temperature sensor connector to the intake manifold temperature sensor RETURN pin in the left bank CM558 connector A.
  • Measure the resistance from the intake manifold pressure sensor SUPPLY pin in the intake manifold temperature sensor connector to the intake manifold pressure sensor SUPPLY pin in the left bank CM558 connector A.
  • Measure the resistance from the intake manifold pressure sensor RETURN pin in the intake manifold temperature sensor connector to the intake manifold pressure sensor RETURN pin in the left bank CM558 connector A.
  • Measure the resistance from the intake manifold pressure sensor SIGNAL pin in the intake manifold temperature sensor connector to the intake manifold pressure sensor SIGNAL pin in the left bank CM558 connector A.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 9A

Guided Step 4 - Check the fuel inlet and fuel outlet pressure sensors

Guided Step 4A - Inspect the fuel inlet and fuel outlet pressure sensors and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • De-energize 24-VDC power supply
  • Disconnect the fuel inlet pressure sensor harness connector
  • Disconnect the fuel outlet pressure sensor connector
  • Disconnect the left bank CM558 connector B.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins. Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel inlet and outlet pressure sensors. Refer to Procedure 019-188 in Section 19.
No Repair

Go to 9A

Go to 4B

Guided Step 4B - Check the fuel inlet and fuel outlet pressure sensors supply voltage.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the fuel inlet pressure sensor supply voltage.

  • Measure the SUPPLY voltage by connecting a multimeter to the breakout cable's SUPPLY and RETURN test connectors.

Check the fuel outlet pressure sensor SUPPLY voltage.

  • Measure the SUPPLY voltage by connecting a multimeter to the breakout cable's supply and RETURN test connectors.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

  • Proceed to troubleshooting step 4E.

Go to 4C

Go to 4E

Guided Step 4C - Check the fuel inlet pressure sensor signal voltage.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the fuel inlet pressure sensor signal voltage.

  • Measure the signal voltage by connecting a multimeter to the breakout cable's SIGNAL and RETURN test connectors.

1.7 to 4.50-VDC?
YES NO
No Repair

Repair

  • Replace the fuel inlet pressure sensor. Refer to Procedure 019-188 in Section 19.

Go to 4D

Go to 9A

Guided Step 4D - Check the fuel outlet pressure sensor signal voltage.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the fuel outlet pressure sensor signal voltage.

  • Measure the SIGNAL voltage by connecting a multimeter to the breakout cable's SIGNAL and RETURN test connectors.

0.5 to 4.50-VDC?
YES NO
No Repair

Repair

  • Replace the fuel inlet pressure sensor. Refer to Procedure 019-188 in Section 19.

Go to 4E

Go to 9A

Guided Step 4E - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • De-energize 24-VDC power supply
  • Disconnect the engine harness from the fuel outlet sensor
  • Disconnect the engine harness from the left bank CM558 connector B.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel inlet pressure sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel inlet pressure sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel inlet pressure sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4F

Go to 9A

Guided Step 4F - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • De-energize 24-VDC power supply
  • Disconnect the engine harness from the fuel inlet pressure sensor
  • Disconnect the engine harness from the fuel outlet pressure sensor
  • Disconnect the engine harness from the left bank CM558 connector B.

Action

Check the fuel inlet and fuel outlet pressure sensor circuits for an open circuit.

  • Measure the resistance from the fuel inlet pressure sensor SUPPLY pin in the fuel inlet pressure sensor connector to the fuel inlet pressure sensor SUPPLY pin in the left bank CM558 connector B.
  • Measure the resistance from the fuel inlet pressure sensor RETURN pin in the fuel inlet pressure sensor connector to the fuel inlet pressure sensor RETURN pin in the left bank CM558 connector B.
  • Measure the resistance from the fuel inlet pressure SIGNAL return pin in the fuel inlet pressure sensor connector to the fuel inlet pressure sensor SIGNAL pin in the left bank CM558 connector B.
  • Measure the resistance from the fuel outlet pressure sensor SUPPLY pin in the fuel outlet pressure sensor connector to the fuel outlet pressure sensor SUPPLY pin in the left bank CM558 connector B.
  • Measure the resistance from the fuel outlet pressure sensor RETURN pin in the fuel outlet pressure sensor connector to the fuel outlet pressure sensor RETURN pin in the left bank CM558 connector B.
  • Measure the resistance from the fuel outlet pressure SIGNAL pin in the fuel outlet pressure sensor connector to the fuel outlet pressure sensor SIGNAL pin in the left bank CM558 connector B.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the gas mass flow sensor.

Guided Step 5A - Inspect the gas mass flow sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • De-energize 24-VDC power supply
  • Disconnect the engine harness from the gas mass flow sensor
  • Disconnect the left bank CM558 connector B.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins. Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel inlet and outlet pressure sensors. Refer to Procedure 019-188 in Section 19.
No Repair

Go to 9A

Go to 5B

Guided Step 5B - Check the gas mass flow sensor supply voltage.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the main engine harness from the gas mass flow sensor.

Action

Check the gas mass flow sensor supply voltage.

  • Measure the supply voltage by connecting a multimeter to the gas mass flow sensor SUPPLY and RETURN connector pins in the main engine harness.

8.0 to 15.0-VDC?
YES NO
No Repair

Repair

Proceed to troubleshooting Step 5D.

Go to 5C

Go to 5D

Guided Step 5C - Check the gas mass flow sensor signal voltage.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Disconnect the main engine harness from the left bank CM558 connector B.

Action

Check the gas mass flow sensor signal voltage.

  • Measure the signal voltage by connecting a multimeter to the gas mass flow sensor SIGNAL and RETURN pins in the left bank CM558 connector B.

0.46 to 4.50-VDC?
YES NO
No Repair

Repair

Replace the gas mass flow sensor. Refer to Procedure 019-101 in Section 19.

Go to

Go to 9A

Guided Step 5D - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • De-energize 24-VDC power supply
  • Disconnect the engine harness from the gas mass flow sensor
  • Disconnect the engine harness from the left bank CM558 connector B.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the gas mass flow sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the gas mass flow sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the gas mass flow sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 5E

Go to 9A

Guided Step 5E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • De-energize 24-VDC power supply
  • Disconnect the engine harness from the gas mass flow sensor
  • Disconnect the engine harness from the left bank CM558 connector B.

Action

Check the gas mass flow sensor circuits for an open circuit.

  • Measure the resistance from the gas mass flow sensor SIGNAL pin in the gas mass flow sensor connector to the gas mass flow sensor SIGNAL pin in the left bank CM558 connector B.
  • Measure the resistance from the gas mass flow sensor SUPPLY pin in the gas mass flow sensor connector to the gas mass flow sensor SUPPLY pin in the left bank CM558 connector B.
  • Measure the resistance from the gas mass flow sensor RETURN pin in the gas mass flow sensor connector to the gas mass flow sensor RETURN pin in the left bank CM558 connector B.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the fuel control valve.

Guided Step 6A - Check the fuel control valve for free movement.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve for free movement.

  • Use INSITE™ electronic service tool to perform the Actuator Diagnostic Test within the ECM Diagnostic Tests option and compare the actuator commanded position and position feedback signals.
  • Contact a Cummins® Authorized Repair Location.

Commanded position signal and feedback signal within 30 percent?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

7A or 7B as appropriate

Go to 6B

Guided Step 6B - Inspect the fuel control valve and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • De-energize 24-VDC power supply
  • Disconnect the engine harness from the fuel control valve
  • Disconnect the left bank CM558 connector B.

Action

Inspect the fuel control valve and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins. Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the inlet and outlet pressure sensors. Refer to Procedure 019-188 in Section 19.
No Repair

Go to 9A

Go to 6C

Guided Step 6C - Check the actuator commanded signal percent duty cycle.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the Commanded Signal percent duty cycle by connecting the multimeter test probes between the fuel control valve actuator position SIGNAL positive (+) and RETURN negative (-) pins at the fuel control valve actuator connector. The signal percent duty cycle must be between 10 and 91 percent, based on the fuel control valve actuator position.

Percent duty cycle 10 - 91 percent?
YES NO
No Repair

Repair

  • Check the power supply connections and the fuses. Use the circuit diagram or engine wiring diagram for the appropriate circuit.

Go to 6D

Go to 6E

Guided Step 6D - Check the fuel control valve feedback signal voltage.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve feedback signal voltage.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the signal feedback voltage by connecting the multimeter test probes between the fuel control valve actuator position feedback and RETURN negative (-) pins. The feedback signal must be between 0 to 5-VDC.

Use the circuit diagram on the appropriate wiring diagram for connector pin identification.

Reference to the specification table provided in the Shop Talk section of this document for Position Feedback voltage specifications.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

0 to 5-VDC?
YES NO
No Repair

Repair

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396, to replace the fuel control valve. Refer to Procedure 006-049 in Section 6.

Go to 6E

Go to 9A

Guided Step 6E - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • De-energize 24-VDC power supply
  • Disconnect the engine harness from the fuel control valve
  • Disconnect all sensors that have a shared supply or return with the fuel control valve
  • Disconnect the engine harness from the left bank CM558 connector B.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel control valve commanded position actuator SIGNAL positive (+) pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel control valve commanded position actuator RETURN negative (-) pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel control valve position feedback pin in the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Use the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 6F

Go to 9A

Guided Step 6F - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • De-energize 24-VDC power supply
  • Disconnect the engine harness from the fuel control valve
  • Disconnect the harness from the left bank CM558 connector B.

Action

Check the fuel control valve for an open circuit.

  • Measure the resistance from the fuel control valve position actuator SIGNAL positive (+) pin in the fuel control valve connector to the fuel control valve position actuator SIGNAL positive (+) pin in the left bank CM558 connector B.
  • Measure the resistance from the fuel control valve position actuator RETURN negative (-) pin in the fuel control valve connector to the fuel control valve position actuator RETURN negative (-) pin in the left bank CM558 connector B.
  • Measure the resistance from the fuel control valve position feedback pin in the fuel control valve connector to the fuel control valve position feedback pin in the left bank CM558 connector B.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 7A

Go to 9A

Guided Step 7 - Check the kilowatt load transducer, if installed.

Guided Step 7A - Check the kilowatt load transducer reference signal.

Conditions

If the generator set is not fitted with a Kilowatt Load Transducer, proceed to Guided Step 7B.

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode with load available
  • Connect INSITE™ electronic service tool.

Action

Check the kilowatt load transducer reference signal.

  • Check the kilowatt load transducer sensed kilowatts against the generator set controller displayed kilowatts.
  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer sensed kilowatt matches generator set controller kilowatts?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool to calibrate the kilowatt load sensor milliampere / load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 8A

Go to 9A

Guided Step 7B - Check the calibration of the generator set controller.

Conditions

This guided step should only be followed for generator sets not fitted with a Kilowatt Load Transducer.

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode with load available
  • Connect a power analyzer or digital multimeter.

Action

Check the calibration of the generator set controller.

  • Connect a power analyzer or digital multimeter to the alternator main output terminals.Check that the generator set controller readings for output voltage (L1-L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller output voltage and amperes readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter to calibrate the generator set controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 8A

Go to 9A

Guided Step 8 - Check the quality of the natural gas supply to the generator set.

Guided Step 8A - Check the quality of the natural Gas supply

Conditions

  • Connect all components
  • De-energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode.

Action

Check the kilowatt load transducer reference signal.

  • Check the quality of the natural gas supplied to the generator set meets or exceeds minimum requirement for generator set (methane number and fuel contaminants limits).
  • For fuel recommendations and specification information, use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Natural Gas supply quality within specification?
YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in RUN mode and operate engine for greater than 1 minute
  • Connect INSITE™ electronic service tool.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 3594 is inactive.

Fault Code 3594 inactive?
YES NO

Repair

  • Use INSITE™ electronic service tool and an exhaust gas analyzer to check the exhaust emissions against the specification for the engine and fine-tune as required.
  • Contact a Cummins® Authorized Repair Location.
  • For fuel recommendations and specification information, use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 9B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Energize keyswitch circuit
  • Place run/stop/auto switch in STOP mode
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 21-Mar-2011


FAULT CODE 3595 - Engine Emissions Closed Loop Fueling (Limit) - Root Cause Not Known

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 144, 145, 146, 151, 154, 155, 213, 227, 238, 239, 352, 354, 355, 386, 453, 454, 455, 482, 488, 511, 546, 547, 751, 1761, 2191, 2427, 2428, 2453, 2454, 2568, 2569, 2789, 2793, 2799, 2866, 2867, and/or 3494 active?
STEP 2. | Check the coolant temperature sensor (high temperature coolant circuit). |
 | STEP 2A. Inspect the sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the sensor. | Resistance between 625 ohms and 36k ohms?
 | STEP 2C. Check for a short circuit. | Greater than 100k ohms?
 | STEP 2D. Check for an open circuit. | Less than 10 ohms?
STEP 3. | Check the intake manifold temperature and pressure sensors. |
 | STEP 3A. Inspect the intake manifold temperature sensor, pressure sensor, and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the resistance intake manifold temperature sensor. | Resistance between 625 ohms and 36k ohms?
 | STEP 3C. Check the intake manifold pressure sensor supply voltage. | Voltage between 4.75 and 5.25-VDC?
 | STEP 3D. Check the intake manifold pressure sensor signal voltage. | Voltage between 0.5 and 4.5-VDC?
 | STEP 3E. Check for a short circuit. | Greater than 100k ohms?
 | STEP 3F. Check for an open circuit. | Less than 10 ohms?
STEP 4. | Check the fuel inlet and fuel outlet pressure sensors. |
 | STEP 4A. Inspect the fuel inlet and fuel outlet pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the fuel inlet and fuel outlet pressure sensors supply voltage. | Voltage between 4.75 and 5.25-VDC?
 | STEP 4C. Check the fuel inlet pressure sensor signal voltage. | Voltage between 1.7 and 4.5-VDC?
 | STEP 4D. Check the fuel outlet pressure sensor signal voltage. | Voltage between 0.5 and 4.5-VDC?
 | STEP 4E. Check for a short circuit. | Greater than 100k ohms?
 | STEP 4F. Check for an open circuit. | Less than 10 ohms?
STEP 5. | Check the gas mass flow sensor. |
 | STEP 5A. Inspect the sensor and harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check the sensor supply voltage. | Voltage between 8 and 15-VDC?
 | STEP 5C. Check the sensor signal voltage. | Voltage between 0.46 and 4.56-VDC?
 | STEP 5D. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 5E. Check for an open circuit. | Less than 10 ohms?
STEP 6. | Check the fuel control valve actuator. |
 | STEP 6A. Check the fuel control valve for free movement. | Commanded position signal and feedback signal within 30 percent?
 | STEP 6B. Inspect the actuator and engine harness connector pins. | Dirty or damaged pins?
 | STEP 6C. Check the actuator commanded signal percent duty cycle signal. | Percent duty cycle 10 - 91 percent?
 | STEP 6D. Check the actuator commanded position feedback signal. | Voltage between 0 and 5-VDC?
 | STEP 6E. Check for a short circuit from pin-to-pin. | Greater than 100k ohms?
 | STEP 6F. Check for an open circuit. | Less than 10 ohms?
STEP 7. | Check the kilowatt load reference signal. |
 | STEP 7A. If fitted, check the kilowatt load transducer sensed kilowatts against the generator set controller kilowatts. | Kilowatt load transducer sensed kilowatt matches generator set controller kilowatts?
 | STEP 7B. Check the generator set controller calibration. | Generator set controller voltage and ampere output calibration correct?
STEP 8. | Check the quality of the natural gas supply to the generator set. |
 | STEP 8A. Check the quality of the natural gas supply. | Natural gas supply meets or exceeds minimum specification for generator set?
STEP 9. | Clear the fault codes. |
 | STEP 9A. Verify the fault code is inactive. | Fault Code 3595 inactive?
 | STEP 9B. Clear the inactive fault code. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for multiple active fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode.

Action

Check for multiple active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 144, 145, 146, 151, 154, 155, 213, 227, 238, 239, 352, 354, 355, 386, 453, 454, 455, 482, 488, 511, 546, 547, 751, 1761, 2191, 2427, 2428, 2453, 2454, 2568, 2569, 2789, 2793, 2799, 2866, 2867 and/or 3494 active?

YES NO

Repair

Follow the appropriate troubleshooting steps for the active fault codes or contact a Cummins® Authorized Repair Location.

Repair

  • Refer to Procedure 019-362 in Section 19.
  • Reference the Engine Noise Excessive - Combustion Knocks troubleshooting symptom tree in Section TS.

Go to 9A

Go to 2A

Guided Step 2 - Check the coolant temperature sensor (high temperature circuit).

Guided Step 2A - Inspect the sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • De-energize 24-VDC power supply
  • Disconnect the engine harness from the engine coolant temperature sensor (high temperature)
  • Disconnect the CM700 connector A.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins. Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the engine coolant temperature sensor (high temperature). Refer to Procedure 019-019 in Section 19.
No Repair

Go to 2B

Go to 9A

Guided Step 2B - Check the resistance of the sensor.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • Disconnect the engine harness from the coolant temperature sensor (high temperature).

Action

Check the resistance of the engine coolant temperature sensor (high temperature).

  • Measure the resistance between the engine coolant temperature sensor (high temperature) SIGNAL pin and the engine coolant temperature sensor (high temperature) RETURN pin.

Voltage between 625 ohms and 36k ohms?
YES NO
No Repair

Repair

  • Replace the engine coolant temperature sensor (high temperature). Refer to Procedure 019-019 in Section 19.

Go to 2C

Go to 9A

Guided Step 2C - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • De-energize 24-VDC power supply
  • Disconnect the engine harness from the engine coolant temperature sensor (high temperature)
  • Disconnect the harness from the CM700 connector A.

Action

Check for a short circuit.

Check for a short circuit to engine ground.

  • Measure the resistance from each of the pins of the engine coolant temperature sensor (high temperature) connector to the engine block ground.

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the engine coolant temperature sensor (high temperature) RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant temperature sensor (high temperature) SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 2D

Go to 9A

Guided Step 2D - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • De-energize 24-VDC power supply
  • Disconnect the engine harness from the engine coolant temperature sensor (high temperature)
  • Disconnect the harness from the CM700 connector A.

Action

Check for an open circuit.

  • Measure the resistance from the engine coolant temperature sensor (high temperature) SIGNAL pin in the engine coolant temperature sensor (high temperature) connector to the engine coolant temperature sensor (high temperature) SIGNAL pin in the CM700 connector A.
  • Measure the resistance from the engine coolant temperature sensor (high temperature) RETURN pin in the engine coolant temperature sensor (high temperature) connector to the engine coolant temperature sensor (high temperature) RETURN pin in the CM700 connector A.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3A

Go to 9A

Guided Step 3 - Check the intake manifold temperature and pressure sensors.

Guided Step 3A - Inspect the intake manifold temperature sensor, pressure sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • De-energize 24-VDC power supply
  • Disconnect the intake manifold temperature sensor connector
  • Disconnect the intake manifold pressure sensor
  • Disconnect the left bank CM558 connector A.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins. Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.
  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.
No Repair

Go to 9A

Go to 3B

Guided Step 3B - Check the resistance of the intake manifold temperature sensor.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • Disconnect the engine harness from the intake manifold temperature sensor.

Action

Check the resistance of the engine coolant temperature sensor (high temperature).

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin and the intake manifold temperature sensor RETURN pin.

Resistance between 625 ohms and 36k ohms?
YES NO
No Repair

Repair

  • Replace the intake manifold temperature sensor. Refer to Procedure 019-059 in Section 19.

Go to 3C

Go to 9A

Guided Step 3C - Check the intake manifold temperature sensor supply voltage.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the intake manifold pressure sensor supply voltage.

  • Measure the supply voltage by connecting a multimeter to the breakout cable's SUPPLY and RETURN test connectors.

Voltage between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Check the intake manifold temperature sensor signal voltage.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector

Action

Check the intake manifold pressure sensor signal voltage.

  • Measure the signal voltage by connecting a multimeter to the breakout cable's SIGNAL and RETURN test connectors.

Voltage between 0.46 and 4.50-VDC?
YES NO
No Repair

Repair

  • Replace the intake manifold pressure sensor. Refer to Procedure 019-061 in Section 19.

Go to 3E

Go to 9A

Guided Step 3E - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • De-energize 24-VDC power supply
  • Disconnect the engine harness from the intake manifold pressure sensor
  • Disconnect the harness from the intake manifold temperature sensor
  • Disconnect the engine harness from the left bank CM558 connector A.

Action

Check for a short circuit.

Check for a short circuit to engine ground.

  • Measure the resistance from the SUPPLY pin of the intake manifold temperature sensor connector to the engine block ground.
  • Measure the resistance from the SIGNAL pin of the intake manifold temperature sensor connector to the engine block ground.

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the intake temperature sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the engine coolant temperature sensor (high temperature) SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the intake manifold pressure sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 3F

Go to 9A

Guided Step 3F - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • De-energize 24-VDC power supply
  • Disconnect the engine harness from the intake manifold pressure sensor
  • Disconnect the engine harness from the intake manifold temperature sensor
  • Disconnect the engine harness from the left bank CM558 connector A.

Action

Check the intake manifold temperature and pressure sensor circuits for an open circuit

  • Measure the resistance from the intake manifold temperature sensor SIGNAL pin in the intake manifold temperature sensor connector to the intake manifold temperature sensor SIGNAL pin in the left bank CM558 connector A.
  • Measure the resistance from the intake manifold temperature sensor RETURN pin in the intake manifold temperature sensor connector to the intake manifold temperature sensor RETURN pin in the left bank CM558 connector A.
  • Measure the resistance from the intake manifold pressure sensor SUPPLY pin in the intake manifold temperature sensor connector to the intake manifold pressure sensor SUPPLY pin in the left bank CM558 connector A.
  • Measure the resistance from the intake manifold pressure sensor RETURN pin in the intake manifold temperature sensor connector to the intake manifold pressure sensor RETURN pin in the left bank CM558 connector A.
  • Measure the resistance from the intake manifold pressure sensor SIGNAL pin in the intake manifold temperature sensor connector to the intake manifold pressure sensor SIGNAL pin in the left bank CM558 connector A.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 9A

Guided Step 4 - Check the fuel inlet and fuel outlet pressure sensors

Guided Step 4A - Inspect the fuel inlet and fuel outlet pressure sensors and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • De-energize 24-VDC power supply
  • Disconnect the fuel inlet pressure sensor harness connector
  • Disconnect the fuel outlet pressure sensor connector
  • Disconnect the left bank CM558 connector B.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins. Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel inlet and outlet pressure sensors. Refer to Procedure 019-188 in Section 19.
No Repair

Go to 9A

Go to 4B

Guided Step 4B - Check the fuel inlet and fuel outlet pressure sensors supply voltage.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the fuel inlet pressure sensor supply voltage.

  • Measure the supply voltage by connecting a multimeter to the breakout cable's SUPPLY and RETURN test connectors.

Check the fuel outlet pressure sensor supply voltage.

  • Measure the SUPPLY voltage by connecting a multimeter to the breakout cable's supply and RETURN test connectors.

Voltage between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4E

Guided Step 4C - Check the fuel inlet pressure sensor signal voltage.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the fuel inlet pressure sensor signal voltage.

  • Measure the signal voltage by connecting a multimeter to the breakout cable's SIGNAL and RETURN test connectors.

Voltage between 1.7 and 4.50-VDC?
YES NO
No Repair

Repair

  • Replace the fuel inlet pressure sensor. Refer to Procedure 019-188 in Section 19.

Go to 4D

Go to 9A

Guided Step 4D - Check the fuel outlet pressure sensor signal voltage.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • Install the pressure sensor breakout cable between the sensor and the sensor harness connector.

Action

Check the fuel outlet pressure sensor signal voltage.

  • Measure the signal voltage by connecting a multimeter to the breakout cable's SIGNAL and RETURN test connectors.

Voltage between 0.5 and 4.50-VDC?
YES NO
No Repair

Repair

  • Replace the fuel inlet pressure sensor. Refer to Procedure 019-188 in Section 19.

Go to 4E

Go to 9A

Guided Step 4E - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • De-energize 24-VDC power supply
  • Disconnect the engine harness from the fuel outlet sensor
  • Disconnect the engine harness from the left bank CM558 connector B.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel inlet pressure sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel inlet pressure sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel inlet pressure sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel outlet pressure sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4F

Go to 9A

Guided Step 4F - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • De-energize 24-VDC power supply
  • Disconnect the engine harness from the fuel inlet pressure sensor
  • Disconnect the engine harness from the fuel outlet pressure sensor
  • Disconnect the engine harness from the left bank CM558 connector B.

Action

Check the fuel inlet and fuel outlet pressure sensor circuits for an open circuit.

  • Measure the resistance from the fuel inlet pressure sensor SUPPLY pin in the fuel inlet pressure sensor connector to the fuel inlet pressure sensor SUPPLY pin in the left bank CM558 connector B.
  • Measure the resistance from the fuel inlet pressure sensor RETURN pin in the fuel inlet pressure sensor connector to the fuel inlet pressure sensor RETURN pin in the left bank CM558 connector B.
  • Measure the resistance from the fuel inlet pressure SIGNAL return pin in the fuel inlet pressure sensor connector to the fuel inlet pressure sensor SIGNAL pin in the left bank CM558 connector B.
  • Measure the resistance from the fuel outlet pressure sensor SUPPLY pin in the fuel outlet pressure sensor connector to the fuel outlet pressure sensor SUPPLY pin in the left bank CM558 connector B.
  • Measure the resistance from the fuel outlet pressure sensor RETURN pin in the fuel outlet pressure sensor connector to the fuel outlet pressure sensor RETURN pin in the left bank CM558 connector B.
  • Measure the resistance from the fuel outlet pressure SIGNAL pin in the fuel outlet pressure sensor connector to the fuel outlet pressure sensor SIGNAL pin in the left bank CM558 connector B.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 5A

Go to 9A

Guided Step 5 - Check the gas mass flow sensor.

Guided Step 5A - Inspect the gas mass flow sensor and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • De-energize 24-VDC power supply
  • Disconnect the engine harness from the gas mass flow sensor
  • Disconnect the left bank CM558 connector B.

Action

Inspect the sensor and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins. Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the fuel inlet and outlet pressure sensors. Refer to Procedure 019-188 in Section 19.
No Repair

Go to 9A

Go to 5B

Guided Step 5B - Check the gas mass flow sensor supply voltage.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • Disconnect the main engine harness from the gas mass flow sensor.

Action

Check the gas mass flow sensor supply voltage.

  • Measure the supply voltage by connecting a multimeter to the gas mass flow sensor SUPPLY and RETURN connector pins in the main engine harness.

Voltage between 8.0 and 15.0-VDC?
YES | NO
No Repair | No Repair

Go to 5C

Go to 5D

Guided Step 5C - Check the gas mass flow sensor signal voltage.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • Disconnect the main engine harness from the left bank CM558 connector B.

Action

Check the gas mass flow sensor signal voltage.

  • Measure the signal voltage by connecting a multimeter to the gas mass flow sensor SIGNAL and RETURN pins in the left bank CM558 connector B.

Voltage between 0.46 and 4.50-VDC?
YES NO
No Repair

Repair

Replace the gas mass flow sensor. Refer to Procedure 019-101 in Section 19.

Go to

Go to 9A

Guided Step 5D - Check for a short circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • De-energize 24-VDC power supply
  • Disconnect the engine harness from the gas mass flow sensor
  • Disconnect the engine harness from the left bank CM558 connector B.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the gas mass flow sensor SUPPLY pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the gas mass flow sensor RETURN pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the gas mass flow sensor SIGNAL pin in the engine harness connector to all other pins in the engine harness connector.

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.

Go to 5E

Go to 9A

Guided Step 5E - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • De-energize 24-VDC power supply
  • Disconnect the engine harness from the gas mass flow sensor
  • Disconnect the engine harness from the left bank CM558 connector B.

Action

Check the gas mass flow sensor circuits for an open circuit.

  • Measure the resistance from the gas mass flow sensor SIGNAL pin in the gas mass flow sensor connector to the gas mass flow sensor SIGNAL pin in the left bank CM558 connector B.
  • Measure the resistance from the gas mass flow sensor SUPPLY pin in the gas mass flow sensor connector to the gas mass flow sensor SUPPLY pin in the left bank CM558 connector B.
  • Measure the resistance from the gas mass flow sensor RETURN pin in the gas mass flow sensor connector to the gas mass flow sensor RETURN pin in the left bank CM558 connector B.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 6A

Go to 9A

Guided Step 6 - Check the fuel control valve.

Guided Step 6A - Check the fuel control valve for free movement.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode.

Action

Check the fuel control valve for free movement.

  • Use INSITE™ electronic service tool to perform the Actuator Diagnostic Test within the ECM Diagnostic Tests option and compare the actuator commanded position and position feedback signals.
  • Contact a Cummins® Authorized Repair Location.

Commanded position signal and feedback signal within 30 percent?
YES NO
No Repair

Repair

Proceed to next troubleshooting step.

7A or 7B as appropriate.

Go to 6B

Guided Step 6B - Inspect the fuel control valve and engine harness connector pins.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • De-energize 24-VDC power supply
  • Disconnect the engine harness from the fuel control valve
  • Disconnect the left bank CM558 connector B.

Action

Inspect the fuel control valve and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Replace the damaged pins. Repair or replace the engine harness or the harness connector.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-202 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Replace the inlet and outlet pressure sensors. Refer to Procedure 019-188 in Section 19.
No Repair

Go to 9A

Go to 9A

Guided Step 6C - Check the actuator commanded signal precent duty cycle.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check the actuator commanded signal percent duty cycle.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the commanded signal percent duty cycle by connecting the multimeter test probes between the fuel control valve actuator position SIGNAL positive and RETURN negative pins at the fuel control valve actuator connector. The signal percent duty cycle must be between 10 and 91 percent, based on the fuel control valve actuator position.

Percent duty cycle 10 - 91 percent?
YES NO
No Repair

Repair

  • Check the power supply connections and the fuses. Refer to the circuit diagram or engine wiring diagram for the appropriate circuit.

Go to 6D

Go to 6E

Guided Step 6D - Check the fuel control valve feedback signal voltage.

Conditions

  • Energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • Connect INSITE™ electronic service tool.

Action

Check the fuel control valve feedback signal voltage.

  • Use the actuator test function within INSITE™ electronic service tool to drive the fuel control valve to a position between 0 and 100 percent.
  • Use a multimeter to measure the signal feedback voltage by connecting the multimeter test probes between the fuel control valve actuator position FEEDBACK and RETURN negative pins. The feedback signal must be between 0 to 5-VDC.

Refer to the circuit diagram on the appropriate wiring diagram for connector pin identification.

Reference to the specification table provided in the Shop Talk section of this document for position feedback voltage specifications.

Use the following procedure for general multimeter techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 0 and 5-VDC?
YES NO
No Repair

Repair

  • Use the following procedure in the QSK60G Generator CM700 Troubleshooting and Repair Manual, Bulletin 4021396, to replace the fuel control valve. Refer to Procedure 006-049 in Section 6.

Go to 6E

Go to 9A

Guided Step 6E - Check for a short circuit from pin-to-pin.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • De-energize 24-VDC power supply
  • Disconnect the engine harness from the fuel control valve
  • Disconnect all sensors that have a shared supply or return with the fuel control valve
  • Disconnect the engine harness from the left bank CM558 connector B.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from the fuel control valve commanded position actuator SIGNAL positive (+) pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel control valve commanded position actuator RETURN negative (-) pin in the engine harness connector to all other pins in the engine harness connector.
  • Measure the resistance from the fuel control valve position FEEDBACK pin in the engine harness connector to all other pins in the engine harness connector.
  • Perform these checks on all interconnecting harness connectors in the circuit.

Refer to the circuit diagram or wiring diagram to identify connectors and pins.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 6F

Go to 9A

Guided Step 6F - Check for an open circuit.

Conditions

  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode
  • De-energize 24-VDC power supply
  • Disconnect the engine harness from the fuel control valve
  • Disconnect the harness from the left bank CM558 connector B.

Action

Check the fuel control valve for an open circuit.

  • Measure the resistance from the fuel control valve position actuator SIGNAL positive (+) pin in the fuel control valve connector to the fuel control valve position actuator SIGNAL positive (+) pin in the left bank CM558 connector B.
  • Measure the resistance from the fuel control valve position actuator RETURN negative (-) pin in the fuel control valve connector to the fuel control valve position actuator RETURN negative (-) pin in the left bank CM558 connector B.
  • Measure the resistance from the fuel control valve position FEEDBACK pin in the fuel control valve connector to the fuel control valve position FEEDBACK pin in the left bank CM558 connector B.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the harness.

  • Repair the engine harness. Refer to Procedure 019-204 in Section 19.
  • Refer to Procedure 019-208 in Section 19.
  • Replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 7A

Go to 9A

Guided Step 7 - Check the kilowatt load transducer (if fitted)

Guided Step 7A - Check the kilowatt load transducer reference signal.

Conditions

If the Generator Set is not fitted with a Kilowatt Load Transducer, proceed to Guided Step 7B.

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in the RUN mode with load available.

Action

Check the kilowatt load transducer reference signal.

  • Check the kilowatt load transducer-sensed kilowatts against the generator set controller displayed kilowatts.
  • Contact a Cummins® Authorized Repair Location.

Kilowatt load transducer sensed kilowatt matches generator set controller kilowatts?
YES NO
No Repair

Repair

Use INSITE™ electronic service tool to calibrate the kilowatt load sensor milliampere / load reference signal.

  • Contact a Cummins® Authorized Repair Location.

Go to 8A

Go to 9A

Guided Step 7B - Check the calibration of the generator set controller.

Conditions

This guided step should only be followed for Generator Sets not fitted with a Kilowatt Load Transducer.

  • Connect all components
  • Connect a power analyzer or digital multimeter
  • Energize keyswitch circuit
  • Place run/stop/auto switch in the RUN mode with load available.

Action

Check the calibration of the generator set controller.

  • Connect a power analyzer or digital multimeter to the alternator main output terminals.Check that the generator set controller readings for output voltage (L1-L2, L2-L3 and L3-L1) and amperes (L1, L2 and L3) match those measured at the alternator output terminals.
  • Contact a Cummins® Authorized Repair Location.

Generator set controller output voltage and amperes readings match the measured readings?
YES NO
No Repair

Repair

Use a power analyzer or digital multimeter to calibrate the generator set controller (output voltage and output amperes).

  • Contact a Cummins® Authorized Repair Location.

Go to 8A

Go to 9A

Guided Step 8 - Check the quality of the Natural Gas supply to the generator set.

Guided Step 8A - Check the quality of the Natural Gas supply

Conditions

  • Connect all components
  • De-energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode.

Action

Check the kilowatt load transducer reference signal.

  • Check the quality of the Natural Gas supplied to the generator set meets or exceeds minimum requirement for Generator Set (methane number and fuel contaminants limits).
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.
  • Contact a Cummins® Authorized Repair Location.

Natural Gas supply quality within specification?
YES NO
No Repair

Repair

  • Contact a Cummins® Authorized Repair Location.

Go to 9A

Go to 9A

Guided Step 9 - Clear the fault codes.

Guided Step 9A - Verify the fault code is inactive.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in the RUN mode and running for greater than 1 minute.

Action

Verify that the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 3595 is inactive.

Fault Code 3595 inactive?
YES NO

Repair

  • Use INSITE™ electronic service tool and an exhaust gas analyzer to check the exhaust emissions against the specification for the engine and fine-tune as required.
  • Contact a Cummins® Authorized Repair Location.
  • Use the following procedure in the QSK60G CM700 Generator Set Operation and Maintenance Manual, Bulletin 4021395. Refer to Procedure 018-002 in Section V.

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 9B

Go to 1A

Guided Step 9B - Clear the inactive fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Energize keyswitch circuit
  • Place run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting chart.

Last Modified: 24-Mar-2011


FAULT CODE 3869 - Low Voltage Ride Through - Bad Intelligent Device or Component

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Fault Code 3869 active or high inactive counts?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Verify the fault code is inactive. | Fault Code 3869 inactive?
 | STEP 2B. Clear the inactive fault codes. | Fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3869 active or high inactive counts?
YES NO

Repair

Follow the appropriate troubleshooting steps within the Cummins® PowerCommand™ Controller (PCC) 3300 Service Manual, Bulletin Number 0900-0670.

Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for more than 1 minute.

Action

  • Use INSITE™ electronic service tool to verify that Fault Code 3869 is inactive.

Fault Code 3869 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete.

Appropriate troubleshooting chart.

Last Modified: 09-Feb-2012


FAULT CODE 3871 - Low Voltage Ride Through - Abnormal Update Rate

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3871 and/or 426, 427, 781 and 3872 active or high inactive counts??
STEP 2. | Check the data link circuit. |
 | STEP 2A. Check the J1939 data link. | J1939 data link circuit OK?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 3871 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3871 and/or 426, 427, 781 and 3872 active or high inactive counts?
YES NO

Repair

Proceed to next troubleshooting step.

Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the data link circuit.

Guided Step 2A - Check the J1939 data link.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect engine wiring harness connectors from all ECMs.

Action

Check the J1939 data link circuit.

  • Check the SAE J1939 data link circuit. Refer to Procedure 019-165 in Section 19.

J1939 data link circuit OK?
YES NO
No Repair

Repair

Repair or replace the engine harness of the harness connector.

  • Locate and check the resistance of the engine harness 120 ohm termination resistor. Refer to Cummins Power Generation® Generator Set wiring diagrams for resistor location.
  • If termination resistor does not measure 120 ohms resistance, replace the resistor.
  • Measure the resistance of the second 120 ohm termination resistor located in the Generator Interface Box. Refer to Cummins Power Generation® Generator Interface Panel wiring diagrams for resistor location.
  • If the second termination resistor does not measure 120 ohms, replace the resistor.
  • Contact your local Cummins® Authorized Repair Location
  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510
  • Install the appropriate connector seal if it is damaged or missing
  • Repair the wiring harness. Refer to Procedure 019-204. Refer to Procedure 019-208 in Section 19
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19
  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode and operate engine for more than 1 minute.

Action

  • Use INSITE™ electronic service tool to verify Fault Code 3871 is inactive.

Fault Code 3871 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location of all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart.

Last Modified: 09-Feb-2012


FAULT CODE 3872 - Low Voltage Ride Through - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

WARNING

To reduce the possibility of personal injury or equipment damage, this procedure must only be performed by suitably qualified service technicians

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3872 and/or 426, 427, 781, 3871, 3873, 3874 or 3875 active or high inactive counts?
STEP 2. | Check the data link circuit. |
 | STEP 2A. Check the J1939 data link. | J1939 data link circuit OK?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 3872 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3872 and/or 426, 427, 781, 3871, 3873, 3874 or 3875 active or high inactive counts?
YES NO
No Repair

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the data link circuit.

Guided Step 2A - Check the J1939 data link.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the generator set 24-VDC power supply.
  • Disconnect the engine wiring harness connectors from all electronic control modules (ECMs).

Action

Check the J1939 data link circuit:

  • Check the SAE J1939 data link circuit. Refer to Procedure 019-165 in Section 19.

J1939 data link circuit OK?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Locate and check the resistance of the engine harness 120 ohm termination resistor. Reference the Cummins Power Generation® Generator Set wiring diagrams for resistor location.
  • If termination resistor does not measure 120 ohms resistance, replace the resistor.
  • Measure the resistance of the second 120 ohm termination resistor located in the Generator Interface Box. Refer to Cummins Power Generation® Generator Interface Panel wiring diagrams for resistor location.
  • If the second termination resistor does not measure 120 ohms, replace the resistor.
  • Contact a Cummins® Authorized Repair Location.
  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate engine for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 3872 is inactive.

Fault Code 3872 inactive?
YES NO

Repair

Follow the appropriate troubleshooting steps within the Cummins® PowerCommand™ Controller (PCC) 3300 Service Manual Bulletin Number 0900-0670.

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 06-Feb-2012


FAULT CODE 3873 - Low Voltage Ride Through - Abnormal Frequency, Pulse Width, or Period

Associated Procedures

Cautions and Warnings

WARNING

To reduce the possibility of personal injury or equipment damage, this procedure must only be performed by suitably qualified service technicians

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3873 and/or 426, 427, 781, 3871, 3872, 3874 or 3875 active or high inactive counts?
STEP 2. | Check the data link circuit. |
 | STEP 2A. Check the J1939 data link. | J1939 data link circuit OK?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 3873 inactive?
 | STEP 3A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3873 and/or 426, 427, 781, 3871, 3872, 3874 or 3875 active or high inactive counts?
YES NO
No Repair

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Check the data link circuit.

Guided Step 2A - Check the J1939 data link.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the Generator Set 24-VDC power supply.
  • Disconnect the engine wiring harness connectors from all electronic control modules (ECMs).

Action

Check the J1939 data link circuit:

  • Check the SAE J1939 data link circuit. Refer to Procedure 019-165 in Section 19.

J1939 data link circuit OK?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Locate and check the resistance of the engine harness 120 ohm termination resistor Refer to Cummins Power Generation® Generator Set wiring diagrams for resistor location.
  • If termination resistor does not measure 120 ohms resistance, replace the resistor.
  • Measure the resistance of the second 120 ohm termination resistor located in the Generator Interface Box. Refer to Cummins Power Generation® Generator Interface Panel wiring diagrams for resistor location.
  • If the second termination resistor does not measure 120 ohms, replace the resistor.
  • Contact a Cummins® Authorized Repair Location.
  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate engine for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 3873 is inactive.

Fault Code 3873 inactive?
YES NO

Repair

Follow the appropriate troubleshooting steps within the Cummins® PowerCommand™ Controller (PCC) 3300 Service Manual Bulletin Number 0900-0670.

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 13-Feb-2012


FAULT CODE 3874 - Low Voltage Ride Through - Root Cause Not Known

Associated Procedures

Cautions and Warnings

WARNING

To reduce the possibility of personal injury or equipment damage, this procedure must only be performed by suitably qualified service technicians

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3874 and/or 426, 427, 781, 3871, 3872, 3873 or 3875 active or high inactive counts?
STEP 2. | Check the data link circuit. |
 | STEP 2A. Check the J1939 data link. | J1939 data link circuit OK?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 3874 inactive?
 | STEP 3A. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3874 and/or 426, 427, 781, 3871, 3872, 3873 or 3875 active or high inactive counts?
YES NO
No Repair

Repair

  • Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 2A

Guided Step 2 - Check the data link circuit.

Guided Step 2A - Check the J1939 data link.

Conditions

  • De-energize keyswitch circuit.
  • Place run/stop/auto switch in OFF mode.
  • Isolate the Generator Set 24-VDC power supply.
  • Disconnect the engine wiring harness connectors from all electronic control modules (ECMs).

Action

Check the J1939 data link circuit:

  • Check the SAE J1939 data link circuit. Refer to Procedure 019-165 in Section 19.

J1939 data link circuit OK?
YES NO
No Repair

Repair

Repair or replace the engine harness or the harness connector.

  • Locate and check the resistance of the engine harness 120 ohm termination resistor Refer to Cummins Power Generation® Generator Set wiring diagrams for resistor location.
  • If termination resistor does not measure 120 ohms resistance, replace the resistor.
  • Measure the resistance of the second 120 ohm termination resistor located in the Generator Interface Box. Refer to Cummins Power Generation® Generator Interface Panel wiring diagrams for resistor location.
  • If the second termination resistor does not measure 120 ohms, replace the resistor.
  • Contact a Cummins® Authorized Repair Location.
  • Flush the dirt, debris or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.
  • Repair the wiring harness. Refer to Procedure 019-204 in Section 19. Refer to Procedure 019-208 in Section 19.
  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Contact a Cummins® Authorized Repair Location.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in RUN mode.
  • Operate engine for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 3874 is inactive.

Fault Code 3874 inactive?
YES NO

Repair

Follow the appropriate troubleshooting steps within the Cummins® PowerCommand™ Controller (PCC) 3300 Service Manual Bulletin Number 0900-0670.

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Repair complete

Appropriate troubleshooting chart

Last Modified: 06-Feb-2012


FAULT CODE 3875 - Low Voltage Ride Through - Condition Exists

Associated Procedures

Cautions and Warnings

WARNING

To reduce the possibility of personal injury or equipment damage, this procedure must only be performed by suitably qualified service technicians

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3875 active or high inactive counts?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Verify the fault code is inactive. | Fault Code 3875 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3875 active or high inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the RUN mode.
  • Operate engine for greater than 1 minute.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to verify Fault Code 3875 is inactive.

Fault Code 3875 inactive?
YES NO

Repair

Follow the appropriate troubleshooting steps within the Cummins® PowerCommand™ Controller (PCC) 3300 Service Manual Bulletin Number 0900-0670.

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Energize keyswitch circuit.
  • Place run/stop/auto switch in the STOP mode.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes

No Repair

Appropriate troubleshooting chart

Last Modified: 01-Feb-2012


FAULT CODE 4687 - Engine Controlled Shutdown Request - Special Instructions

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the ECM for active fault codes. | Fault Code 2863, 1781, or 1782 active?
 | STEP 1B. Check the ECM for active fault codes. | Fault Code 4687 active?
STEP 2. | Check the engine harness. |
 | STEP 2A. Inspect the engine harness and connector pins. | Dirty or damaged pins?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2863, 1781, or 1782 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check the ECM for active fault codes.

Conditions

  • Energize keyswitch circuit.
  • Place run/stop/auto switch in STOP mode.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4687 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the engine harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Place run/stop/auto switch in STOP mode.

Action

Inspect the engine harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Use the following procedure for the data link circuit. Refer to Procedure 019-417 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Repair or replace the engine harness or ECM.

  • Replace the engine wiring harness. Refer to Procedure 019-043 in Section 19.
  • Use the following procedure for the data link circuit. Refer to Procedure 019-417 in Section 19.
  • Replace the ECM. Refer to Procedure 019-031 in Section 19.
No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Sep-2016


INDEX
59-fc121.htm

59-t05-121.htm

59-fc135.htm

59-t05-135.htm

59-fc136.htm

59-t05-136.htm

59-fc137.htm

59-t05-137.htm

59-fc141.htm

59-t05-141.htm

59-fc142.htm

59-t05-142.htm

59-fc143.htm

59-t05-143.htm

59-fc144.htm

59-t05-144.htm

59-fc145.htm

59-t05-145.htm

59-fc146.htm

59-t05-146.htm

59-fc151.htm

59-t05-151.htm

59-fc153.htm

59-t05-153.htm

59-fc154.htm

59-t05-154.htm

59-fc155.htm

59-t05-155.htm

59-fc175.htm

59-t05-175.htm

59-fc176.htm

59-t05-176.htm

59-fc177.htm

59-fc177mtit.htm

59-t05-177mtit.htm

59-fc177mttt.htm

59-t05-177mttt.htm

59-fc177stit.htm

59-t05-177stit.htm

59-fc187.htm

59-t05-187.htm

59-fc197.htm

59-t05-197.htm

59-fc212.htm

59-t05-212.htm

59-fc213.htm

59-t05-213.htm

59-fc214.htm

59-t05-214.htm

59-fc227.htm

59-t05-227.htm

59-fc228.htm

59-t05-228.htm

59-fc231.htm

59-t05-231.htm

59-fc232.htm

59-t05-232.htm

59-fc233.htm

59-t05-233.htm

59-fc234.htm

59-t05-234.htm

59-fc235.htm

59-t05-235.htm

59-fc238.htm

59-t05-238.htm

59-fc239.htm

59-t05-239.htm

59-fc253.htm

59-t05-253.htm

59-fc254.htm

59-t05-254.htm

59-fc263.htm

59-t05-263.htm

59-fc265.htm

59-t05-265.htm

59-fc277.htm

59-t05-277.htm

59-fc343.htm

59-t05-343.htm

59-fc346.htm

59-t05-346.htm

59-fc352.htm

59-t05-352.htm

59-fc354.htm

59-t05-354.htm

59-fc355.htm

59-t05-355.htm

59-fc359.htm

59-t05-359.htm

59-fc386.htm

59-t05-386.htm

59-fc412.htm

59-t05-412.htm

59-fc414.htm

59-t05-414.htm

59-fc415.htm

59-t05-415.htm

59-fc421.htm

59-t05-421.htm

59-fc426.htm

59-t05-426.htm

59-fc427.htm

59-t05-427.htm

59-fc441.htm

59-t05-441.htm

59-fc442.htm

59-t05-442.htm

59-fc453.htm

59-t05-453.htm

59-fc454.htm

59-t05-454.htm

59-fc458.htm

59-t05-458.htm

59-fc459.htm

59-t05-459.htm

59-fc461.htm

59-t05-461.htm

59-fc462.htm

59-t05-462.htm

59-fc477.htm

59-t05-477.htm

59-fc478.htm

59-t05-478.htm

59-fc488.htm

59-t05-488.htm

59-fc512.htm

59-t05-512.htm

59-fc513.htm

59-t05-513.htm

59-fc556.htm

59-t05-556.htm

59-fc561.htm

59-t05-561.htm

59-fc562.htm

59-t05-562.htm

59-fc563.htm

59-t05-563.htm

59-fc564.htm

59-t05-564.htm

59-fc565.htm

59-t05-565.htm

59-fc566.htm

59-t05-566.htm

59-fc567.htm

59-t05-567.htm

59-fc568.htm

59-t05-568.htm

59-fc569.htm

59-t05-569.htm

59-fc571.htm

59-t05-571.htm

59-fc572.htm

59-t05-572.htm

59-fc573.htm

59-t05-573.htm

59-fc574.htm

59-t05-574.htm

59-fc575.htm

59-t05-575.htm

59-fc576.htm

59-t05-576.htm

59-fc577.htm

59-t05-577.htm

59-fc578.htm

59-t05-578.htm

59-fc584.htm

59-t05-584.htm

59-fc585.htm

59-t05-585.htm

59-fc579.htm

59-t05-579.htm

59-fc595.htm

59-t05-595.htm

59-fc641.htm

59-fc641-mt.htm

59-t05-641-mt.htm

59-fc641-st.htm

59-t05-641-st.htm

59-fc642.htm

59-fc642-mt.htm

59-t05-642-mt.htm

59-fc642-st.htm

59-t05-642-st.htm

59-fc643.htm

59-fc643-mt.htm

59-t05-643-mt.htm

59-fc643-st.htm

59-t05-643-st.htm

59-fc644.htm

59-fc644-mt.htm

59-t05-644-mt.htm

59-fc644-st.htm

59-t05-644-st.htm

59-fc645.htm

59-fc645-mt.htm

59-t05-645-mt.htm

59-fc645-st.htm

59-t05-645-st.htm

59-fc646.htm

59-fc646-mt.htm

59-t05-646-mt.htm

59-fc646-st.htm

59-t05-646-st.htm

59-fc647.htm

59-fc647-mt.htm

59-t05-647-mt.htm

59-fc647-st.htm

59-t05-647-st.htm

59-fc648.htm

59-fc648-mt.htm

59-t05-648-mt.htm

59-fc648-st.htm

59-t05-648-st.htm

59-fc652.htm

59-fc652-mt.htm

59-t05-652-mt.htm

59-fc652-st.htm

59-t05-652-st.htm

59-fc653.htm

59-fc653-mt.htm

59-t05-653-mt.htm

59-fc653-st.htm

59-t05-653-st.htm

59-fc654.htm

59-fc654-mt.htm

59-t05-654-mt.htm

59-fc654-st.htm

59-t05-654-st.htm

59-fc655.htm

59-fc655-mt.htm

59-t05-655-mt.htm

59-fc655-st.htm

59-t05-655-st.htm

59-fc656.htm

59-fc656-mt.htm

59-t05-656-mt.htm

59-fc656-st.htm

59-t05-656-st.htm

59-fc657.htm

59-fc657-mt.htm

59-t05-657-mt.htm

59-fc657-st.htm

59-t05-657-st.htm

59-fc658.htm

59-fc658-mt.htm

59-t05-658-mt.htm

59-fc658-st.htm

59-t05-658-st.htm

59-fc671.htm

59-fc671mt.htm

59-t05-671mt.htm

59-fc671st.htm

59-t05-671st.htm

59-fc672.htm

59-fc672mt.htm

59-t05-672mt.htm

59-fc672st.htm

59-t05-672st.htm

59-fc673.htm

59-fc673mt.htm

59-t05-673mt.htm

59-fc673st.htm

59-t05-673st.htm

59-fc674.htm

59-fc674mt.htm

59-t05-674mt.htm

59-fc674st.htm

59-t05-674st.htm

59-fc675.htm

59-fc675mt.htm

59-t05-675mt.htm

59-fc675st.htm

59-t05-675st.htm

59-fc676.htm

59-fc676mt.htm

59-t05-676mt.htm

59-fc676st.htm

59-t05-676st.htm

59-fc677.htm

59-fc677mt.htm

59-t05-677mt.htm

59-fc677st.htm

59-t05-677st.htm

59-fc678.htm

59-fc678mt.htm

59-t05-678mt.htm

59-fc678st.htm

59-t05-678st.htm

59-fc686.htm

59-t05-686.htm

59-fc687.htm

59-t05-687.htm

59-fc689.htm

59-t05-689.htm

59-fc691.htm

59-t05-691.htm

59-fc692.htm

59-t05-692.htm

59-fc697.htm

59-t05-697.htm

59-fc698.htm

59-t05-698.htm

59-fc721.htm

59-fc721mt.htm

59-t05-721mt.htm

59-fc721st.htm

59-t05-721st.htm

59-fc722.htm

59-fc722mt.htm

59-t05-722mt.htm

59-fc722st.htm

59-t05-722st.htm

59-fc723.htm

59-fc723mt.htm

59-t05-723mt.htm

59-fc723st.htm

59-t05-723st.htm

59-fc724.htm

59-fc724mt.htm

59-t05-724mt.htm

59-fc724st.htm

59-t05-724st.htm

59-fc725.htm

59-fc725mt.htm

59-t05-725mt.htm

59-fc725st.htm

59-t05-725st.htm

59-fc726.htm

59-fc726mt.htm

59-t05-726mt.htm

59-fc726st.htm

59-t05-726st.htm

59-fc727.htm

59-fc727mt.htm

59-t05-727mt.htm

59-fc727st.htm

59-t05-727st.htm

59-fc728.htm

59-fc728mt.htm

59-t05-728mt.htm

59-fc728st.htm

59-t05-728st.htm

59-fc751.htm

59-t05-751.htm

59-fc781.htm

59-t05-781.htm

59-fc783.htm

59-t05-783.htm

59-fc1213.htm

59-t05-1213.htm

59-fc1243.htm

59-t05-1243.htm

59-fc1274.htm

59-t05-1274.htm

59-fc1275.htm

59-t05-1275.htm

59-fc1277.htm

59-t05-1277.htm

59-fc1281.htm

59-t05-1281.htm

59-fc1282.htm

59-t05-1282.htm

59-fc1285.htm

59-t05-1285.htm

59-fc1286.htm

59-t05-1286.htm

59-fc1287.htm

59-t05-1287.htm

59-fc1291.htm

59-t05-1291.htm

59-fc1292.htm

59-t05-1292.htm

59-fc1295.htm

59-t05-1295.htm

59-fc1296.htm

59-t05-1296.htm

59-fc1297.htm

59-t05-1297.htm

59-fc1362.htm

59-t05-1362.htm

59-fc1434.htm

59-t05-1434.htm

59-fc1457.htm

59-t05-1457.htm

59-fc1474.htm

59-t05-1474.htm

59-fc1521.htm

59-fc1521mt.htm

59-t05-1521mt.htm

59-fc1521st.htm

59-t05-1521st.htm

59-fc1522.htm

59-fc1522mt.htm

59-t05-1522mt.htm

59-fc1522st.htm

59-t05-1522st.htm

59-fc1523.htm

59-fc1523mt.htm

59-t05-1523mt.htm

59-fc1523st.htm

59-t05-1523st.htm

59-fc1524.htm

59-fc1524mt.htm

59-t05-1524mt.htm

59-fc1524st.htm

59-t05-1524st.htm

59-fc1525.htm

59-fc1525mt.htm

59-t05-1525mt.htm

59-fc1525st.htm

59-t05-1525st.htm

59-fc1526.htm

59-fc1526mt.htm

59-t05-1526mt.htm

59-fc1526st.htm

59-t05-1526st.htm

59-fc1527.htm

59-fc1527mt.htm

59-t05-1527mt.htm

59-fc1527st.htm

59-t05-1527st.htm

59-fc1529.htm

59-fc1529mt.htm

59-t05-1529mt.htm

59-fc1529st.htm

59-t05-1529st.htm

59-fc1531.htm

59-fc1531mt.htm

59-t05-1531mt.htm

59-fc1531st.htm

59-t05-1531st.htm

59-fc1532.htm

59-fc1532mt.htm

59-t05-1532mt.htm

59-fc1532st.htm

59-t05-1532st.htm

59-fc1533.htm

59-fc1533mt.htm

59-t05-1533mt.htm

59-fc1533st.htm

59-t05-1533st.htm

59-fc1534.htm

59-fc1534mt.htm

59-t05-1534mt.htm

59-fc1534st.htm

59-t05-1534st.htm

59-fc1535.htm

59-fc1535mt.htm

59-t05-1535mt.htm

59-fc1535st.htm

59-t05-1535st.htm

59-fc1536.htm

59-fc1536mt.htm

59-t05-1536mt.htm

59-fc1536st.htm

59-t05-1536st.htm

59-fc1546.htm

59-t05-1546.htm

59-fc1579.htm

59-t05-1579.htm

59-fc1581.htm

59-t05-1581.htm

59-fc1582.htm

59-t05-1582.htm

59-fc1583.htm

59-t05-1583.htm

59-fc1584.htm

59-t05-1584.htm

59-fc1618.htm

59-fc1618mt.htm

59-t05-1618mt.htm

59-fc1618st.htm

59-t05-1618st.htm

59-fc1619.htm

59-fc1619mt.htm

59-t05-1619mt.htm

59-fc1619st.htm

59-t05-1619st.htm

59-fc1737.htm

59-t05-1737.htm

59-fc1738.htm

59-t05-1738.htm

59-fc1739.htm

59-t05-1739.htm

59-fc1741.htm

59-t05-1741.htm

59-fc1742.htm

59-t05-1742.htm

59-fc1761.htm

59-t05-1761.htm

59-fc1791.htm

59-t05-1791.htm

59-fc1792.htm

59-t05-1792.htm

59-fc1793.htm

59-t05-1793.htm

59-fc1794.htm

59-t05-1794.htm

59-fc1795.htm

59-t05-1795.htm

59-fc1796.htm

59-t05-1796.htm

59-fc1797.htm

59-t05-1797.htm

59-fc1798.htm

59-t05-1798.htm

59-fc1799.htm

59-t05-1799.htm

59-fc1811.htm

59-t05-1811.htm

59-fc1812.htm

59-t05-1812.htm

59-fc1813.htm

59-t05-1813.htm

59-fc1814.htm

59-t05-1814.htm

59-fc1821.htm

59-t05-1821.htm

59-fc1822.htm

59-t05-1822.htm

59-fc1823.htm

59-t05-1823.htm

59-fc1824.htm

59-t05-1824.htm

59-fc1826.htm

59-t05-1826.htm

59-fc1827.htm

59-t05-1827.htm

59-fc1828.htm

59-t05-1828.htm

59-fc1834.htm

59-t05-1834.htm

59-fc1837.htm

59-t05-1837.htm

59-fc1838.htm

59-t05-1838.htm

59-fc1839.htm

59-t05-1839.htm

59-fc1841.htm

59-t05-1841.htm

59-fc1843.htm

59-t05-1843.htm

59-fc1844.htm

59-t05-1844.htm

59-fc2111.htm

59-t05-2111.htm

59-fc2112.htm

59-t05-2112.htm

59-fc2113.htm

59-t05-2113.htm

59-fc2114.htm

59-t05-2114.htm

59-fc2115.htm

59-t05-2115.htm

59-fc2116.htm

59-t05-2116.htm

59-fc2117.htm

59-t05-2117.htm

59-fc2121.htm

59-fc2121-mt.htm

59-t05-2121-mt.htm

59-fc2121-st.htm

59-t05-2121-st.htm

59-fc2122.htm

59-fc2122-mt.htm

59-t05-2122-mt.htm

59-fc2122-st.htm

59-t05-2122-st.htm

59-fc2123.htm

59-fc2123-mt.htm

59-t05-2123-mt.htm

59-fc2123-st.htm

59-t05-2123-st.htm

59-fc2124.htm

59-fc2124-mt.htm

59-t05-2124-mt.htm

59-fc2124-st.htm

59-t05-2124-st.htm

59-fc2125.htm

59-fc2125-mt.htm

59-t05-2125-mt.htm

59-fc2125-st.htm

59-t05-2125-st.htm

59-fc2126.htm

59-fc2126-mt.htm

59-t05-2126-mt.htm

59-fc2126-st.htm

59-t05-2126-st.htm

59-fc2127.htm

59-fc2127-mt.htm

59-t05-2127-mt.htm

59-fc2127-st.htm

59-t05-2127-st.htm

59-fc2128.htm

59-fc2128-mt.htm

59-t05-2128-mt.htm

59-fc2128-st.htm

59-t05-2128-st.htm

59-fc2131.htm

59-fc2131-mt.htm

59-t05-2131-mt.htm

59-fc2131-st.htm

59-t05-2131-st.htm

59-fc2132.htm

59-fc2132-mt.htm

59-t05-2132-mt.htm

59-fc2132-st.htm

59-t05-2132-st.htm

59-fc2133.htm

59-fc2133-mt.htm

59-t05-2133-mt.htm

59-fc2133-st.htm

59-t05-2133-st.htm

59-fc2134.htm

59-fc2134-mt.htm

59-t05-2134-mt.htm

59-fc2134-st.htm

59-t05-2134-st.htm

59-fc2135.htm

59-fc2135-mt.htm

59-t05-2135-mt.htm

59-fc2135-st.htm

59-t05-2135-st.htm

59-fc2136.htm

59-fc2136-mt.htm

59-t05-2136-mt.htm

59-fc2136-st.htm

59-t05-2136-st.htm

59-fc2137.htm

59-fc2137-mt.htm

59-t05-2137-mt.htm

59-fc2137-st.htm

59-t05-2137-st.htm

59-fc2138.htm

59-fc2138-mt.htm

59-t05-2138-mt.htm

59-fc2138-st.htm

59-t05-2138-st.htm

59-fc2144.htm

59-fc2144-mt.htm

59-t05-2144-mt.htm

59-fc2144-st.htm

59-t05-2144-st.htm

59-fc2154.htm

59-t05-2154.htm

59-fc2155.htm

59-t05-2155.htm

59-fc2191.htm

59-t05-2191.htm

59-fc2217.htm

59-t05-2217.htm

59-fc2281.htm

59-t05-2281.htm

59-fc2282.htm

59-t05-2282.htm

59-fc2191.htm

59-t05-2191.htm

59-fc2311.htm

59-t05-2311.htm

59-fc2427.htm

59-t05-2427.htm

59-fc2428.htm

59-t05-2428.htm

59-fc2453.htm

59-t05-2453.htm

59-fc2454.htm

59-t05-2454.htm

59-fc2455.htm

59-t05-2455.htm

59-fc2456.htm

59-t05-2456.htm

59-fc2457.htm

59-fc2457mt.htm

59-t05-2457mt.htm

59-fc2457st.htm

59-t05-2457st.htm

59-fc2458.htm

59-fc2458mt.htm

59-t05-2458mt.htm

59-fc2458st.htm

59-t05-2458st.htm

59-fc2459.htm

59-fc2459mt.htm

59-t05-2459mt.htm

59-fc2459st.htm

59-t05-2459st.htm

59-fc2461.htm

59-fc2461mt.htm

59-t05-2461mt.htm

59-fc2461st.htm

59-t05-2461st.htm

59-fc2462.htm

59-fc2462mt.htm

59-t05-2462mt.htm

59-fc2462st.htm

59-t05-2462st.htm

59-fc2463.htm

59-fc2463mt.htm

59-t05-2463mt.htm

59-fc2463st.htm

59-t05-2463st.htm

59-fc2464.htm

59-fc2464mt.htm

59-t05-2464mt.htm

59-fc2464st.htm

59-t05-2464st.htm

59-fc2465.htm

59-fc2465mt.htm

59-t05-2465mt.htm

59-fc2465st.htm

59-t05-2465st.htm

59-fc2466.htm

59-fc2466mt.htm

59-t05-2466mt.htm

59-fc2466st.htm

59-t05-2466st.htm

59-fc2469.htm

59-fc2469mt.htm

59-t05-2469mt.htm

59-fc2469st.htm

59-t05-2469st.htm

59-fc2471.htm

59-fc2471mt.htm

59-t05-2471mt.htm

59-fc2471st.htm

59-t05-2471st.htm

59-fc2472.htm

59-fc2472mt.htm

59-t05-2472mt.htm

59-fc2472st.htm

59-t05-2472st.htm

59-fc2473.htm

59-fc2473mt.htm

59-t05-2473mt.htm

59-fc2473st.htm

59-t05-2473st.htm

59-fc2475.htm

59-fc2475mt.htm

59-t05-2475mt.htm

59-fc2475st.htm

59-t05-2475st.htm

59-fc2476.htm

59-fc2476mt.htm

59-t05-2476mt.htm

59-fc2476st.htm

59-t05-2476st.htm

59-fc2477.htm

59-fc2477mt.htm

59-t05-2477mt.htm

59-fc2477st.htm

59-t05-2477st.htm

59-fc2478.htm

59-fc2478mt.htm

59-t05-2478mt.htm

59-fc2478st.htm

59-t05-2478st.htm

59-fc2482.htm

59-t05-2482.htm

59-fc2483.htm

59-t05-2483.htm

59-fc2484.htm

59-fc2484-mt.htm

59-t05-2484-mt.htm

59-fc2484-st.htm

59-t05-2484-st.htm

59-fc2485.htm

59-fc2485-mt.htm

59-t05-2485-mt.htm

59-fc2485-st.htm

59-t05-2485-st.htm

59-fc2486.htm

59-fc2486-mt.htm

59-t05-2486-mt.htm

59-fc2486-st.htm

59-t05-2486-st.htm

59-fc2487.htm

59-fc2487-mt.htm

59-t05-2487-mt.htm

59-fc2487-st.htm

59-t05-2487-st.htm

59-fc2488.htm

59-fc2488-mt.htm

59-t05-2488-mt.htm

59-fc2488-st.htm

59-t05-2488-st.htm

59-fc2489.htm

59-fc2489-mt.htm

59-t05-2489-mt.htm

59-fc2489-st.htm

59-t05-2489-st.htm

59-fc2491.htm

59-fc2491-mt.htm

59-t05-2491-mt.htm

59-fc2491-st.htm

59-t05-2491-st.htm

59-fc2492.htm

59-fc2492-mt.htm

59-t05-2492-mt.htm

59-fc2492-st.htm

59-t05-2492-st.htm

59-fc2494.htm

59-fc2494-mt.htm

59-t05-2494-mt.htm

59-fc2494-st.htm

59-t05-2494-st.htm

59-fc2495.htm

59-fc2495-mt.htm

59-t05-2495-mt.htm

59-fc2495-st.htm

59-t05-2495-st.htm

59-fc2496.htm

59-fc2496-mt.htm

59-t05-2496-mt.htm

59-fc2496-st.htm

59-t05-2496-st.htm

59-fc2497.htm

59-fc2497-mt.htm

59-t05-2497-mt.htm

59-fc2497-st.htm

59-t05-2497-st.htm

59-fc2498.htm

59-fc2498-mt.htm

59-t05-2498-mt.htm

59-fc2498-st.htm

59-t05-2498-st.htm

59-fc2499.htm

59-fc2499-mt.htm

59-t05-2499-mt.htm

59-fc2499-st.htm

59-t05-2499-st.htm

59-fc2511.htm

59-fc2511-mt.htm

59-t05-2511-mt.htm

59-fc2511-st.htm

59-t05-2511-st.htm

59-fc2512.htm

59-fc2512-mt.htm

59-t05-2512-mt.htm

59-fc2512-st.htm

59-t05-2512-st.htm

59-fc2517.htm

59-t05-2517.htm

59-fc2518.htm

59-t05-2518.htm

59-fc2519.htm

59-t05-2519.htm

59-fc2521.htm

59-t05-2521.htm

59-fc2522.htm

59-t05-2522.htm

59-fc2523.htm

59-t05-2523.htm

59-fc2524.htm

59-t05-2524.htm

59-fc2525.htm

59-t05-2525.htm

59-fc2526.htm

59-t05-2526.htm

59-fc2527.htm

59-t05-2527.htm

59-fc2528.htm

59-t05-2528.htm

59-fc2529.htm

59-t05-2529.htm

59-fc2531.htm

59-t05-2531.htm

59-fc2532.htm

59-t05-2532.htm

59-fc2544.htm

59-t05-2544.htm

59-fc2553.htm

59-t05-2553.htm

59-fc2568.htm

59-t05-2568.htm

59-fc2569.htm

59-t05-2569.htm

59-fc2752.htm

59-fc2752mtit.htm

59-t05-2752mtit.htm

59-fc2752mttt.htm

59-t05-2752mttt.htm

59-fc2752stit.htm

59-t05-2752stit.htm

59-fc2766.htm

59-t05-2766.htm

59-fc2767.htm

59-t05-2767.htm

59-fc2768.htm

59-t05-2768.htm

59-fc2769.htm

59-t05-2769.htm

59-fc2789.htm

59-fc2789mt.htm

59-t05-2789mt.htm

59-fc2789st.htm

59-t05-2789st.htm

59-fc2793.htm

59-fc2793mt.htm

59-t05-2793mt.htm

59-fc2793st.htm

59-t05-2793st.htm

59-fc2796.htm

59-t05-2796.htm

59-fc2799.htm

59-t05-2799.htm

59-fc2811.htm

59-t05-2811.htm

59-fc2812.htm

59-t05-2812.htm

59-fc2814.htm

59-t05-2814.htm

59-fc2837.htm

59-fc2837mt.htm

59-t05-2837mt.htm

59-fc2837st.htm

59-t05-2837st.htm

59-fc2838.htm

59-fc2838mt.htm

59-t05-2838mt.htm

59-fc2838st.htm

59-t05-2838st.htm

59-fc2839.htm

59-fc2839mt.htm

59-t05-2839mt.htm

59-fc2839st.htm

59-t05-2839st.htm

59-fc2841.htm

59-fc2841mt.htm

59-t05-2841mt.htm

59-fc2841st.htm

59-t05-2841st.htm

59-fc2842.htm

59-fc2842mt.htm

59-t05-2842mt.htm

59-fc2842st.htm

59-t05-2842st.htm

59-fc2843.htm

59-fc2843mt.htm

59-t05-2843mt.htm

59-fc2843st.htm

59-t05-2843st.htm

59-fc2844.htm

59-fc2844mt.htm

59-t05-2844mt.htm

59-fc2844st.htm

59-t05-2844st.htm

59-fc2845.htm

59-fc2845mt.htm

59-t05-2845mt.htm

59-fc2845st.htm

59-t05-2845st.htm

59-fc2847.htm

59-fc2847mt.htm

59-t05-2847mt.htm

59-fc2847st.htm

59-t05-2847st.htm

59-fc2848.htm

59-fc2848mt.htm

59-t05-2848mt.htm

59-fc2848st.htm

59-t05-2848st.htm

59-fc2849.htm

59-fc2849mt.htm

59-t05-2849mt.htm

59-fc2849st.htm

59-t05-2849st.htm

59-fc2851.htm

59-fc2851mt.htm

59-t05-2851mt.htm

59-fc2851st.htm

59-t05-2851st.htm

59-fc2852.htm

59-fc2852mt.htm

59-t05-2852mt.htm

59-fc2852st.htm

59-t05-2852st.htm

59-fc2853.htm

59-fc2853mt.htm

59-t05-2853mt.htm

59-fc2853st.htm

59-t05-2853st.htm

59-fc2854.htm

59-fc2854mt.htm

59-t05-2854mt.htm

59-fc2854st.htm

59-t05-2854st.htm

59-fc2855.htm

59-fc2855mt.htm

59-t05-2855mt.htm

59-fc2855st.htm

59-t05-2855st.htm

59-fc2857.htm

59-t05-2857.htm

59-fc2859.htm

59-t05-2859.htm

59-fc2861.htm

59-t05-2861.htm

59-fc2863.htm

59-t05-2863.htm

59-fc2864.htm

59-t05-2864.htm

59-fc2866.htm

59-t05-2866.htm

59-fc2867.htm

59-t05-2867.htm

59-fc2868.htm

59-t05-2868.htm

59-fc2869.htm

59-t05-2869.htm

59-fc2871.htm

59-t05-2871.htm

59-fc2872.htm

59-t05-2872.htm

59-fc2873.htm

59-t05-2873.htm

59-fc2874.htm

59-t05-2874.htm

59-fc2875.htm

59-t05-2875.htm

59-fc2876.htm

59-t05-2876.htm

59-fc2877.htm

59-t05-2877.htm

59-fc2994.htm

59-t05-2994.htm

59-fc3111.htm

59-t05-3111.htm

59-fc3112.htm

59-t05-3112.htm

59-fc3113.htm

59-t05-3113.htm

59-fc3114.htm

59-t05-3114.htm

59-fc3115.htm

59-t05-3115.htm

59-fc3116.htm

59-t05-3116.htm

59-fc3117.htm

59-t05-3117.htm

59-fc3118.htm

59-t05-3118.htm

59-fc3119.htm

59-t05-3119.htm

59-fc3121.htm

59-t05-3121.htm

59-fc3122.htm

59-t05-3122.htm

59-fc3123.htm

59-t05-3123.htm

59-fc3124.htm

59-t05-3124.htm

59-fc3125.htm

59-t05-3125.htm

59-fc3126.htm

59-t05-3126.htm

59-fc3127.htm

59-t05-3127.htm

59-fc3458.htm

59-t05-3458.htm

59-fc3489.htm

59-t05-3489.htm

59-fc3491.htm

59-t05-3491.htm

59-fc3515.htm

59-t05-3515.htm

59-fc3584.htm

59-t05-3584.htm

59-fc3594.htm

59-t05-3594.htm

59-fc3595.htm

59-t05-3595.htm

59-fc3869.htm

59-t05-3869.htm

59-fc3871.htm

59-t05-3871.htm

59-fc3872.htm

59-t05-3872.htm

59-fc3873.htm

59-t05-3873.htm

59-fc3874.htm

59-t05-3874.htm

59-fc3875.htm

59-t05-3875.htm

59-fc4687.htm

59-t05-4687.htm